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Chapter 1 Introduction

This guide is the absolute Toon Boom Animate kick
start kit covering all the basics of the software that you
need to get started on your own animation projects.

Discover Animate in 12 lessons! Use the sample
material provided or if you prefer, use your own. The
sample material will help you follow the different
exercises contained in this guide.

To install the sample material
provided, simply follow

the installation

instructions on the
installation disc, at the end
of this chapter or download
them from our website at

toonboom.com.

The keyboard shortcuts used in this guide are based on
the Adobe®Flash® shortcut set.

If you are using Animate Pro, you have access

to additional exclusive features that are not available in
Animate. The Animate Pro Getting Started Guide adds
chapters and lessons covering these extra features.




Your Training Outline

Are you ready? Let's take a first glance at the training
outline covered in this guide.

Chapter 2 Creating Your Own Animation

Get to know the basics of Animate while you create a
butterfly from some simple shapes and animate it.

Chapter 3 Gathering Content

Learn how to import external content such as multilayer
PSD and QuickTime movies to build a scene out of it.

Chapter 4 Designing a Character

Learn to use the basic drawing tools available in Animate
as well as many helpful features for the design tasks.
Starting from the rough design through to the Ink and
Paint process.

Chapter 5 Painting Your Character

Get to know the different painting tools, the Tools
Properties and the Palette concept in Animate while
painting a character.

Chapter 6 Using Symbols to Animate a
Skateboard

Learn the concept of Symbols in Animate, and how to use
them while creating a simple skateboarding animation.

Chapter 7 Creating a Simple Hand-Drawn
Animation

Learn the different tools and features available to you in
Animate that let you easily create paperless animation.

Chapter 8 Building a Cut-out Puppet

Learn the different steps and tasks involved in creating a
cut-out puppet, from breaking it down to rigging it.
Chapter 9 Animating Your Puppet

Learn how to use the different animation tools available in
Animate while animating a cut-out puppet.

Chapter 10 Creating a Multiplane and
Animating the Camera

Learn how to use Animate's different views and tools to

create multiplane effects and give the illusion of depth and
3D space to your project.

The aspect ratio is the relation between the width and height of any scene, frame or film format. The TV ratio

is 4:3 and the widescreen is 16:9.

8 Toon Boom Animate Getting Started Guide




Chapter 11 Sound and Lip-Sync

Get to know the different sound and lip-sync tools while
creating a quick lip-sync animation. Learn how you can
share your animation by exporting it in a QuickTime movie
format.

Chapter 12 Morphing a Flag

Get to know the Morphing tools and features while you
create an animation of a flag.

Chapter 13 Creating Effects (Animate
Only)

Learn how to enhance the quality of your projects using
the effect layers in the Timeline view.

* Note that this chapter is ONLY valid for Animate. In
Animate Pro, the effects are not created using the Timeline
view, but using the Network view, exclusive in Animate
Pro. Refer to Chapter 5 of the Animate Pro Getting Started
Guide to learn how to add effects using Animate Pro.

The Ease-in is a gradual acceleration in the action.

Introduction - Your Training Outline 9



Interface Highlights

It's important that you familiarise yourself with the
interface before you start to navigate through

Toon Boom Animate. As you work through this guide and
learn to use the software, you can refer to the following
section whenever you need to identify a specific view or
toolbar.

Note: The numbers in this list correspond to the numbers
in the interface diagram on the following page.
1. Top Menu
Contains most of the commands available in the
software in the Top menu.
2. Playback Toolbar
This is used to play your animation, loop it,
change the playback range and temporarily
modify the frame rate.
3. Workspace Toolbar
This is used to customize and load different
workspaces.
4. Colour View
This is used to select, create and modify colours.
You can also create specific palettes and palette
styles for your characters.

Library
This is used to store and reuse Symbols and
templates. Anything you create in Animate, you
can store in the Library.

Tool Properties View
Contains the options related to the currently
selected tool. When you work with a tool, you will
often use the Tool Properties view to either alter a
selection or change the tool's behaviour.

Timeline View
This is mainly used to add layers, change the
timing, create effects* and order your elements.
You can also change the scene length, create
Symbols and templates, enter Symbols and add
keyframes.

Tools Toolbar
Contains most of the drawing and animation
tools you will use when working in Animate.

Camera View
This is the centre of your operations. This is where
you draw, paint, animate, position your elements,
and view the animation playback and results of
any effects you add.

* Available ONLY in Animate. For Animate Pro, see the Animate Pro Getting Started Guide.

10 Toon Boom Animate Getting Started Guide
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In Animation, the Ease or velocity, is the acceleration or deceleration of a motion. This can be a motion created

by a function curve or a series of animated drawings. Other common terms used are slow-in and slow-out.

Introduction - Interface Highlights 11



Timeline View Legend

The Timeline view is the main view used to adjust the
timing of your drawings, connect effects* and order layers.

Refer to the following legend to learn about the Timeline.

Note: The numbers in this legend correspond to the
numbers in the Timeline View on the following page.

1. Layers used in the Timeline view:

o 6Drawing . & Camera
. J Peg J ')_:kEffect
o Pk T d5ound

2. =N
When position keyframes are added on a Drawing
layer, they are displayed as black squares. When
interpolation is created between these keyframes,
an arrow is displayed.

A

An exposed drawing is represented by a grey block.
Exposing the drawing for several frames extends the
grey block. Exposing a second drawing displays a
new grey block.

An exposed Symbol is represented by a small film
frame. Exposing a Symbol for several frames
extends the film frame. Exposing a second Symbol's
frame displays a new film frame.

L]

When a Morphing sequence is created, it is
represented by a series of arrows. The key drawings
are still represented as grey blocks, but the
morphed in-betweens are shown as a series of grey
arrows.

When a Peg layer contains keyframes, they are
represented by black squares. A Peg layeris a
motion path which you can attach drawing layers to.
When an interpolation is created, a straight line is
displayed between the keyframes.

* Available ONLY in Animate. For Animate Pro, see the Animate Pro Getting Started Guide.

12 Toon Boom Animate Getting Started Guide
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Buttons

In this guide, you will find tools that you will use frequently.

Most tools have a button. Recognizing these allows you
access the tools faster. You can find the most common
ones on the next page.
e Edit: The Edit tools are used to copy, cut, paste,
delete a selection and cancel actions.
e File: The File tools are used to import images,
open, close and save scenes.
e Animation: The Animation tools are used to
position and animate your elements on your stage.
* Morphing: The Morphing tools are used to set
morphing hint points in your morphing sequences.
e Selection: The Selection tools are used to select
drawing strokes and modify them.
e Drawing: The Drawing tools are used to draw and
design your characters and backgrounds.
e Drawing Mode: The Drawing Mode tools are used
to change a drawing tool behaviour.
e Onion Skin: The Onion Skin tool is used to view
previous and next images.
e Light: The Light tool is used to see your other
columns in the Drawing view.

14 Toon Boom Animate Getting Started Guide

Paint: The Paint tools are used to paint your
drawings.

Gap Closing: The Gap Closing tools are used to
close gaps while painting.

Gradient: The Gradient tools are used to edit your
gradient zones.

View: The View tools are used to navigate in the
Camera and Drawing views.

Drawing Markers: The Drawing Markers tools are
used to identify drawings in the Xsheet view.
Layers: The Layers tools are used to add different
types of layers in the Timeline view.

Flatten: The Flatten tools are used to flatten
drawing strokes.

Playback: The Playback tools are used to play back
your animation.

Sound: The Sound tools are used to edit and play
back the sound.

Ease: The Ease tool is used to adjust your
animation'’s velocity.

Layout: The Layout tool lets your organize your
workspace.
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Sample material setup guide

Templates and sample files will be required for some of the
lessons in the Getting Started Guide. You must first install
them, then follow steps to use them in your project.

Step-by-step installation

1. Go to the following web page:
toonboom.com/products/animate/eLearning/*

2. Inthe Tutorials section download the Sample
Material package.

3. Once the package is downloaded, double-click on it
to launch it.

4. Follow the installer's instructions.

WinZip Self-Extractor - ToonBoomAnimate_SampleMaterial[1]....

{;_:1 Click on Setup to install Animate Sample Material.

O e P

16 Toon Boom Animate Getting Started Guide

To use the templates

1.
2.
3.

To use the templates:

Launch Toon Boom Animate.
Create a new blank project.
In the Library view, click on one of the following
folders to view the sample material content:

» Templates

» Templates > Undone_example_Sample_

material

» Templates > Completed_examples
Select a template from the right-hand side of the
Library view.
Click and drag that template to the left-hand side of
the Timeline view and drop it where the layers are
ordered. You can also drop it directly in the Camera
view.

The template now appears in both the Timeline

and Camera views and is ready to be animated!

* For Animate Pro go to:
toonboom.com/products/animatepro/eLearning/



Files in the Library view

Here are the types of files you will find in the templates
folder:

° Undone_example_Sample_material
Prepared scenes to be completed during
lessons in the Getting Started Guide.

e  Completed_examples
The resulting scene files for completed
lessons in the Getting Started Guide.

e Templates
Various elements that can be used to
completed some of the lessons in the
Getting Started Guide.

Extra sample material
You will need to browse and import some extra files from
the following location*:

*  Mac: /Applications/Toon Boom Animate 2/
Templates/Samples

e Windows XP: C:\Documents and Settings\All
Users\Documents\Toon Boom Animation\Toon
Boom Animate 2\Templates\Samples

. Windows Vista and 7: C:\Users\Public\
Documents\Toon Boom Animation\Toon Boom
Animate 2\Templates\Samples

Files for chapters 3,5 and 11:
e  background_tv.psd
. SuperHero_Soundtracks (3 sound clips)
. Textures (16 examples)

* For Animate Pro, browse for Toon Boom
Animate Pro 2 rather than Toon Boom Animate 2.

Introduction - Sample material setup guide 17



toonboom.com/animatepro/

Need More Animation Power ?

Toon Boom Animate Pro is the professional

version of Animate. Building upon Animate’s
capabilities, Animate Pro delivers additional exciting
and powerful features that will make your creative
process easier and smoother.

Scan and vectorize drawings following traditional methods
Create rich-looking effects and advanced puppet rigging
Sketch and design with textured brush styles

Access advanced traditional animation features

Output simultaneously to different resolutions and formats




Chapter 2 Creating Your Own Animation

Creating a basic animation from start to finish in
Toon Boom Animate is child’s play. In a few easy
steps you can have a colourful butterfly fluttering its
way across your screen!

This chapter contains the following topics where you
will learn how to create new projects, select colours,
use drawing tools, animate drawings and layers, and
finally export your project.
The topics are:
e Creating a New Project
e Choosing a Colour

* Getting Ready to
Draw p

e Drawinga ' p
Butterfly - gt

¢ Animating the L%
Butterfly

* Animating the Butterfly

Layer Pl S ﬁ

e Exporting Your Project fr.

19



Creating a New Project

To start any animation, you need to create a new project
from the Welcome Screen. You can also create new
projects from the main interface’s File menu.
To create a new scene:
1. Inthe Welcome Screen, click on the Choose button
to select the directory where to save the project.
2. Inthe Project Name field, type the name of the new
project.
3. Inthe Resolution list, select a resolution for the
project.
4. Click on the Create Button.
If you need to reopen a project, you can open it using the
Welcome Screen and clicking on the Open Scene
command.
You can also open itin File > Open or by clicking on the
Open {7 button in the File toolbar.

ANlMAT

ANIMATION UNLIMITED

New Scene

Recent Scenes
Project Directory: [2./Users/shabana/Documerts

Project Name: |

Resoltion Width Height FPS  Aspect Ratio
fim133 2048 1536 24 133

fim166 2048 1234 24 166 @
HOTY 1920 080 M 178
low W T M 13
NTSC 0 B0 M 13
PAL 75 %/ 133

& - @

Create

Open Scene..

Tutorials

[T] Do not show this window at startup

To create a custom resolution for your scene, refer to the Animate User Guide.

20 Toon Boom Animate Getting Started Guide




Choosing a Colour

The first thing you will do is to select a colour for your
butterfly.

Toon Boom Animate has a colour palette which

consists of a group of colour swatches. The important
point to remember is that when a zone is painted with one
of these colour swatches, that zone is linked to the swatch.
This means that if you modify the swatch'’s colour, the zone
is updated at the same time!

Brush Pencil Fill

ST 1T

Default Line
Colour 2
Colour 3
Colour 4
colour &

colour B

The Colour view can keep track of the colour you were
using the last time you were using either the Brush tool,
Pencil line tool (Pencil, Polyline, Line, Rectangle or Ellipse)
or Paint tool.

» If you would prefer the Colour view to always
use the selected swatch, click on the Link =

button. Once the colours linked, the Link
button will look like this . .

» Inthe Colour List, select the colour you want
to use to draw the butterfly’s wings.

Double-click on a swatch to access the Colour Picker window and modify the swatch’s colour. You can also

clickinthe H, S, V, or R, G, B radio buttons to modify the picker display.

Creating Your Own Animation - Choosing a Colour 21



Getting Ready to Draw

[Toots o )
R BLE&T & 8o w ) ﬁlﬂ oS
k/ Line
@. Rectangle
@ Elipse
(&) Polyine

To design the butterfly, use the following tools found in the
Tools toolbar:

e (L Rectangle Tool

Use this tool to draw a rectangle.
e (R Contour Editor Tool

Use this tool to reshape lines.
e (% Select Tool

Use this tool to reposition, scale, skew, rotate
or delete drawing objects.

o Paint Tool

Use this tool to paint the drawings.

| Tool Properties |

kk Salect

Manipulstors

BE=

Cptions.

@ @D @
S@e€
Operations.

e e

@D e©®
P |

O s ] X [ |4 CHE
a

Or oo fs | ¥4 o |

Pencil selection

@ |2 4

Each tool has a set of properties that can be found in the
Tool Properties view. This way, each time you select a tool,
you have quick access to the main actions performed with
this tool.

If you need a drawing tool for a very short period of time, hold down its shortcut key without the [Alt] key

® while you use the tool. Once done, release the hot key.

22 Toon Boom Animate Getting Started Guide



& Top Camera | BI%

—
Q@ge g = - Drawing Transform ToolFr 54

Most of the drawing, animation, design and scene setup
occur in the Camera view. By default, when you draw in the
Camera view, the lines are anti-aliased using the project
resolution. To view the lines as plain vector, disable the
antialiasing property in the Preferences panel.

To start drawing in the Camera view, select the cell
where you want to draw by clicking on itin the
Timeline view.

W to B G 4

+43 Drawing (== ‘ } ’

In the Tools toolbar, select the Rectangle L tool.

s @ @ +@B)

[] Draw Square
- Pencil 1 [v] & 2 A
In the Tool Properties view, enable the following
options:
» (@ Automatically Fill Inside Region
» (& Auto-Flatten

Set the tool size to 0 (zero) so you do not have any
border around the shape.

Disabling the antialiasing preference. In Windows, Edit > Preferences > OpenGL > Real-Time Antialiasing. For

Mac, Animate > Preferences > OpenGL > Real-Time Antialiasing. In both cases uncheck the Enable box.
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Drawing a Butterfly

In the Camera view, you will draw a butterfly using the
Rectangle and Contour Editor tools. This will help you to
learn how to design characters out of shapes instead of
just drawing their contours with the Brush tool.

o

1. Inthe Camera view, draw two rectangles to form the
basic shape of the first wing.
A warning message opens to indicate that you
are not displaying the invisible lines.
2. Click on the OK button to ignore the message.
» If youwant to see the invisible line, select
View > Show > Show Strokes or use the
default keyboard shortcut[D].

In the Tools toolbar, select the Contour Editor (&

tool.

Select an area of the drawing and move the
rectangles’ contours to form a butterfly wing in the
up position.

You can modify a shape by doing one of the following:

e Directly moving the point
e  Pulling the stroke between two points
e  Rotating and pulling on a point’s Bezier handle

With the Contour Editor tool, move one of the two Bezier handles by holding down the [Alt] key and nudging

selected points using the arrow keys. You can add a point by using the [Ctrl] key and clicking.
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In the Tools toolbar, click on the Select (k) tool and

select the wing in the Camera view.

Rotate and resize the wing. You can do this using the
Tool Properties view or by moving the anchor points
on the selection bounding box.

Using the Ellipse (&) tool and different colours, draw

a series of circles and ellipses on the wing.
Select the butterfly wing and select Edit > Group >
Group to group the wing as one element.

9. If you have finished drawing, disable the
Auto-Flatten (Z& mode in the Tool Properties view.

10. Next, draw the butterfly’s body and duplicate the
first wing by copying and pasting it.

11. Assemble the butterfly using the Select (K tool.
Bring the wings in front of or behind the body using
Drawing > Arrange > Bring to Front or Send to
Back.

You can group a selection by using the default keyboard shortcut [Ctrl]+[G] (Windows), []+[G] (Mac) or Edit >

Group > Group. This shortcut is valid only when working in the Camera or Drawing view.
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Animating the Butterfly

To animate your butterfly:
1. Inthe Tools toobar, select the
Select (R tool.

2. Inthe Camera view, select the
2. entire butterfly drawing.

3. Select Edit > Copy Drawing
Object.

In the Timeline view, select the third cell of the
butterfly layer.

o 4k

+43 Drawing &= w

5. Paste the butterfly drawing into Camera view using
Edit > Paste Drawing Object.

6. To see the previous drawing, enable the Onion Skin
= button in the butterfly layer.

A&
D@J

0w o & G
+ 45 Drawing

Scale Y-axis I

Rotate (:)
Scale X, Y ‘)A/
axis By =P ° &
Skew Y-axis
Scale X-axis 1 re I

Next, create a second drawing with the wings in the down
position and the trick will be done!
7. Inthe Timeline view, select cell #3.

8. Inthe Camera view, using the Select & tool, select
the wings and flip them vertically moving the
bounding box’s anchor points.

You can use Drawing > Transform > Flip Vertical or
the keyboard shortcut [5].

If you want to extend the exposure of one of your drawing, in the Timeline view, select your drawing and then

press the [+] key once to increase the drawing'’s exposure by one cell.
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9. Adjust the wings using the Select & tool.

In the Timeline view, make sure the second butterfly
drawing is selected and then press the [+] key once
to increase the drawing’s exposure by one cell. You

now have a flapping butterfly wing.
0%t & & b S

+43 Drawing ma= w

10. In the Timeline view, select the four butterfly cells.
Right-click and select Create Cycle.

L vdto B G

+ 45 Drawing
11. In the Create Cycle dialog box, set the Number of
Cycles field to 15 to fill the 60 frames length.

Create Cycle
MNumber of Cyclas: |15 =]
[ 0K l ’ Cancel ]

Gt b b i | 1
M +oawrg [ AT T A T A T T A A T B Y

Drawing #1

Drawing #1

1-2 3-4 5-6 7-8 9-10

Drawing #1 Drawing #2 Drawing #2 Drawing #1

You can easily modify the colour or design of the butterfly,
if you like. The looped drawings are linked to the original
ones, so you can modify any of the butterflies with the
wings in the up position on the layer and all of them will
update. You can also do the same for the butterflies with
the wings in the down position.

You can use the [+] and [-] keyboard shortcuts to increase or decrease a selected cell’s exposure.
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Animating the Butterfly Layer

[Tools

B BLETLEGORE

It's easy to animate a layer, press two buttons, position
your drawing and you‘re done!
1. Inthe Tools toolbar, enable the Animate <& mode.

The default keyboard shortcut is [Shift]+[A].
2. Inthe Tools toolbar, select the Transform {1 tool.

The default keyboard shortcut is [Alt]+[Q].
3. Inthe Timeline view, go to the first frame.

—

Q% to B & r'4
+43 Drawing Ha =

S
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4. Inthe Camera view, select the butterfly and move it
to the left or right of your screen depending on how
you designed the butterfly.

» When you move the butterfly using the
Transform tool a keyframe is automatically
created in the Timeline view.

5. Use the bounding box's corner anchor points to
scale it down.

The butterfly should be small enough for it to be able to fly
across the screen over 60 frames.

To animate a layer, use the Transform tool and enable the Animate mode. If you want to reposition a layer

without animating it, disable the Animate mode.
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o By default, the interpolation is automatically calculated
In the Timeline view, go to the last frame. between the keyframes. There is no need to do anything.

""""""""""""'@ e NTSSSIINITL

In the Camera view, move the butterfly to the other

side. You can press [Shift]+[F11] (Windows) or \gg)_ 5w et e st s 5 s s s

[38]+[F11] (Mac) to view the path.
8. Inthe Playback toolbar, press the Play (») button to

see your animation.
9. Inthe Playback toolbar, press the Loop () button

/?@ | to play your animation repeatedly.

You can move between the Timeline frames using the [,] and [.] keys.
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Exporting Your Project

E Export to Flash Mowvie (Suf)
Output

s/anouk/Documents/S cene-01.swi

Export Range
@ al

Options
Frame rate [fpz]

Jpeg quality

Disabled Effects

[7] Tanes [ Highlights
[ Shadows [] Glaws

[7] Transparencies  [] Blendings

2 =s

Browse...

() Frames 1 o to [157

15 2
a0 2

[ Pratect from impart  [] Compress Mavie

[ Radial Blurs [] Directional Blurs
[7] Calowr-Overrides  [] Colaur-Scales

[ 0K

Now that your animation is complete you can export it.
Toon Boom Animate allows you to export to different
formats. In this case, we will export the project as an SWF
format.

To export the project as a SWF file:
1. Inthe top menu, select File > Export > SWF.
2. Inthe Export dialog box, click on the Choose button
to name and select where you will store your movie.
3. Click on the OK button to start the export process.

There you go! You have just completed your first project
using Toon Boom Animate.

You can export your projects as image sequences, QuickTime movies, Flash movies (SWF) and Flash videos

® (FLV).
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Chapter 3 Gathering Content

Toon Boom Animate allows you to draw directly in the
software, and import external content.

You can import QuickTime videos, pictures, multi-
layered PSD files, as well as Al, SWF and PDF files.
For this lesson, you can either use your own content or
the files from the sample material package*.

e  Templates/limpa.tpl

e Mac: /Applications/Toon Boom Animate 2/

Templates/Samples/ background_tv.psd and
fireworks.mov

e Windows XP: C:\Documents and Settings\All
Users\Documents\Toon Boom Animation\
Toon Boom Animate 2\Templates\Samples\
background_tv.psd and fireworks.mov
e Windows Vista and 7: C:\Users\Public\
Documents\Toon Boom Animation\Toon
Boom Animate 2\Templates\Samples\
background_tv.psd and fireworks.mov
The topics are:
e Setting Up the Living Room
® Importing a QuickTime Movie
e GetLimpa to Celebrate

* For Animate Pro, browse for Toon Boom Animate Pro 2 rather than Toon Boom Animate 2.
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Setting Up the Living Room

For some of your projects, you will probably want to paint
your backgrounds in a bitmap editing software such as
Adobe® Photoshop® . With Animate, you can import
multi- layered PSD backgrounds and keep the layers
separated!

To start building the scene, we will import a living room
background. This background has three layers; a wall, a
television and a chair. We will import the file so that each
one of these PSD layers will be inserted in a separate
timeline layer.

To do this, you must group your layers in Adobe®
Photoshop®.

1
1] =

| Layers x | v
Opacity:

Lock: [ &+ @ Fill:

[® v @ char

|§ E Chair

®(v@

|§ Tw

[® v (3 Backgrourd

|§ E Background
N\

= &~ 0 o(a)a 5 .

1. In Adobe® Photoshop®, group your layers. Each
PSD layer you want on a separate timeline layer
must be in a different group.

» If you want some of your PSD layers to be
integrated in the same timeline layer, insert
them in the same group.

If you name your groups, their name will be preserved
once your import the file in Animate.

) To import a photo puppet in Adobe® Photoshop® put all the hands in one group, the heads in another one and

so on, so that when you import it in Animate each body part has its own layer containing all of its own pieces.
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In Animate, select Files > Import > Images.

3. Inthe Import Drawings dialog box, browse for the
PSD file to import.

4. Inthe Layer section, enable the Create Layer(s) and

the Create Single Layer Named options.

Disable the Vectorize the Imported Items option.

6. Click on the OK button.

o

7. Inthe Image to Load field of the Multilayer Image
Import Settings dialog box, select the All Layer
Images option.

Some ofthe items you are importing contain multiple layers

Please indicate how you wish these items to be imported:
Irmages to Load. All Lawer Images M

Transparency Type: Premultiplied with \White M

8. Select the Transparency Type if applicable.
9. Pressthe OK button.

V] 443 prawing &=

Z ﬁl‘ﬂchair &= {

M +91v [1& =] f

v \+ﬂ Background &= [

Your background appears in the Timeline view and the
new layersare named as your PSD groups. The only thing
left to do is to extend their exposure.

10. In the Timeline view, select the last cell of each
layers and press [F5] to extend their exposure.

6 o & & 4b
3 Chair : &
ATy a=
Hgackgound [ | & =

A To vectorize the images you import, learn more about the Alignmentc and Transparency options, refer to the

Animate User Guide to learn more.
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Importing a QuickTime Movie

If you have a live-action clip you want to integrate into your
project, you can do it with Animate! Using Animate

you can import QuickTime movies. This way, you can
integrate your videos with your animation and push the
envelop even further!

If your clip is not a QuickTime movie you need to convert it
to * .mov format first. You can do this using an editing
software.

In this example, we import a Happy New Year fireworks
clip that we will position inside the television.

To import a QuickTime movie:
1. Inthe top menu, select Files > Import > Movie.
2. Inthe Import QuickTime Movie dialog box, browse
for the movie to import.

3. Click on the Open button.
Note: Your movie will be transformed into an
image sequence and a sound layer will be added
to contain the sound if there is any.

= Import Movie

Converting Movie to Images...

T —

Once the import process is completed, you will
be asked where and how you want to insert your
movie's images.

When you import a QuickTime movie in Animate it is converted to an image sequence. The sound is

extracted from it and placed in a sound layer. This way, you can modify your clip’s timing.
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4. Inthe Import Images dialog box, enable the Create
Layer(s) and the Create Single Layer Named
options.

5. Name your new layer with a relevant name.
6. Disable the Vectorize the Imported Iltems option.
7. Enable the Create Symbol for Imported Items

option if you want your movie to be a Symbol.
8. Click on the OK button to import your image
sequence.

9. Inthe Timeline view, drag and drop the fireworks
layer below the TV one.

[/ +49char e
v a7y [1&=
Z 43 firewarks []&=
lv|  +49 Background L=

10. In the Tools toolbar, select
the Transform {3 tool and

disable the Animate <&

: mode.

11. In the Timeline view, select
your QuickTime Movie
layer.

1 12.In the Camera view, resize

your clip to the tv screen
size.

» Hold the [Shift] key
down to maintain
aspect ratio of the
movie.

You can extend the scene length by selecting Scene > Scene Length or by dragging the Timeline view's red

length bracket.
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Get Limpa to Celebrate

Now that the living room is
ready for the celebration and
the television is switched on,
you can locate the Limpa
character's template in the
Library and import him in the
scene!

Limpa was previously designed
and stored in the sample library
as a template.

A template is a small scene or container that you can
import into any of your projects and its content will be
copied in your scene.

1.

2.
3.

In the Library, select the Templates folder and then
select the Limpa.tpl template.

Drag the selected template to your Timeline view.
Use the Transform {1 tool to position Limpa on the

stage.

4. Inthe Playback toolbar, press the Play (#) button to

play back your animation.

=ld

| Library | K

Drawing Substitution

limpa_colour |4

Limpa.tpl

@ symbols
(&)l &nimate Librany

F.tpl

| Tirneline | K

4, )

w6 tonaf

ﬁlimpa_colour& [1&=
+43 Chair [la=s
+49 1y [&=
+43 firewarks [1& =
+ 45 Background [ =

Any drawing or animation your create in Animate can be stored as a template in the Library. Refer to the

Animate User Guide to learn more about creating templates.
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toonboom.com/storyboardpro/

The power of digital storyboarding

Toon Boom Storyboard Pro is a system for visual storytelling,

perfectly suited to traditional and paperless methods. Truly \
completing the production pipeline, Storyboard Pro helps you
take an idea and translate it into a visual story that will become
a complete production, whether animated or live-action. i B

Work like you always have, but faster and smarter while maximizing the
benefits of working digitally

Create instant animatics as you work, in the same time it takes to storyboard
Play back your storyboard in sync with audio
Enjoy interactive review and faster approval process

Y




Chapter 4 Designing a Character

With Animate’s advanced tools, you no longer need
to draw on paper, scan and clean your drawings.
You can do all that in the software. Although, if
you love to draw on paper, Animate allows

you to import your artwork in your project.
Using Animate you get the best of both

worlds.

This chapter contains the following topics
where you will learn how to use the
Brush tool, add new layers and
clean up the drawings.
The topics are:
¢ Drawing Using the Brush Tool
e Other Useful Drawing Tools
e Adding a New Layer
e Tracing Over Your Character
e Adding Thick and Thin Lines
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Drawing Using the Brush Tool

The Brush & tool supports pressure sensitivity and

several brush tips.

<+*’ ballerinaE )

To keep your work organized, rename the default layer

with your new character’s name.

1. Inthe Timeline view, double-click on the layer name
and type the new name in the field.

2. Press[Return]to validate the name.

3. Select the cell where you want to draw.
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Alpha[133 |
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To get a feeling similar to drawing on paper with blue
pencils, you can modify a colour swatch'’s colour and
transparency.

4. Double-click on the colour swatch if you want to
modify the tint.

5. To modify the colour’s transparency, slide the Alpha
cursor to the right or left.

The Contour Optimization smooths the contour of your
line once the line has been traced.

Rename a layer by clicking on its name in the Timeline view or in the Layer’s editor.
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There are several parameters which you can adjust in the
Brush Properties:
e ! Minimum Size

e () Maximum Size
e .~ Smoothness
e ¢ Contour Optimization

- @ H Brush Tips

You are now ready to throw all kinds of ideas onto your
canvas, which in this case is the Camera view.

6. Inthe Camera view, sketch your character.
7. If you want to draw some shading on your character,
enable the Draw Behind @ option in the Brush Tool

Properties.

The Smoothness option smooths the initial movement of your line. Increasing the value results in a line with

less control points. The Contour Optimization smooths the contour of your line once the line has been traced.
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Other Useful Drawing Tools

S— O
3,0 0UQ)tlueed

There are several other useful drawing tools you can use to
perfect your work such as:

* (R Select Tool
The Select tool allows to reposition, scale,
skew, rotate and delete a selection.

e (& Cutter Tool
The Cutter tool allows to select a portion of a
drawing to reposition it or delete it.

* ( Eraser Tool
The Eraser tool allows to erase any section of
aline or drawing.

* @ Rotate View Tool

The Rotate tool allows to turn the workspace
the same as an animation table.

To use the Rotate View & tool, hold down the [Ctrl]+[Alt]
keys on Windows and [3]+[Alt] on Mac OS.

The default keyboard shortcut to reset the Camera view
rotation is [Shift]+[X]. Or press the Reset View @ button

in the Camera view's bottom toolbar.

Refer to the Animate User Guide to learn more about these drawing tools and their properties. Take a

look at the other exciting and innovative tools available to help you produce some world class animation.
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Adding a New Layer

W % )G Ll
ballerina clean| &=
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Now that your sketch is completed, you will learn how to
trace over it to get a clean drawing.

1. Inthe Timeline view, click on the
Add Drawing Layer # button to add a new layer

for your clean drawing.
2. Rename the layer as clean or any other appropriate

name.

It is now time to clean your character!

You can add an unlimited number of layers in the Timeline view.

Designing a Character - Adding a New Layer 43



Tracing Over Your Character

- P Py

\.k', \‘k,@ kﬁ @ R @,
There are many ways to clean up your character’s sketch.
Here we will demonstrate how to use the Pencil & tool

and the Polyline (<) tool to do it, although you could also
use the Brush & tool for this task.

1. Inthe Timeline view, in your clean layer, select the
cell just above your sketch drawing.

- %

o by

+ 4 balerina_clean [ | & =
+43 ballerina [@ =

Drawing in the clean layer cell does not affect your sketch.
To make sure that you don’t modify your original drawing,
you can lock it by clicking on the Lock @ button of this
layer.
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You may find it confusing if all of the Colour swatches are
named sequentially, such as Colour 1, Colour 2, and so on.
To avoid this confusion you can rename your swatches by
double-clicking on their name and then pressing the
[Return] key to validate the name.

Pressing [Return], when you have a series of colour
swatches, selects the next colour swatch.

To remove colour swatches from the Colour view, click on the Remove Colour button in the Colour view

toolbar.
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Using the Polyline (5 tool to clean your drawing allows To fine-tune the lines you created with the Polyline (&

you to shape your lines easier than if you were tracing tool, use the Contour Editor (%2 tool.
them by hand using the Brush & tool or the Pencil . . .
em by hand using the Brush (g tool or the Pencil @ 3. Click on the line to see the points appear.
tool. 4. Then, click on a point to select it and move its Bezier
2. Click to set a point along your drawing and then pull handles to reshape the line.
away from it V\{h'le holdm.g down the left mouse Use the Pencil &) tool to draw the lines you don‘t want to
button. You will see the line shape as you move the :

handles. do with the Polyline (<) tool.

To move only one of the two Bezier handles using the Polyline or Contour Editor tool, hold down the [Alt] key.
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Adding Thick and Thin Lines

Since you drew your lines as a central vector type, using
the Polyline tool and the Pencil tool, your drawing does
not contain thick and thin lines. There are different
techniques you can use to add these lines.

Cptions.
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@=7 |« A

P Freview
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The first method is to use the Brush & tool to draw some

of the lines and change the tip to an oblique shape or use
a pen tablet which provides you with pressure sensitivity
and allows you to draw lines of variable thickness.

Drawing with the Brush tool does not allow you to reshape
your lines as easily as with the Polyline or Pencil tool. The
Brush tool creates contour vector lines (also known as fills)
where the vector points are situated on the line's contour,
Pencil lines are central vector lines in which the points
follow the centre of the line.

Central vector lines do not support thick and thin lines, but
have the same thickness throughout. Contour lines
support thick and thin lines, but take longer to reshape.

You can convert contour lines to central lines and central lines to contour lines. You can make an invisible line

® by setting the size of the Pencil tool, Ellipse tool, Rectangle tool, Line tool or Polyline tool to 0 (zero).
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The second technique is to convert the central lines to
contour lines and to add some thick and thin lines by using
the Contour Editor (&) tool.

1. Inthe Tools toolbar, select the Select (k) tool.

2. Inthe Camera view, select the lines to convert to
contour lines.

3. Inthe Tool Properties view, click on the Convert
Pencil Lines to Brush Lines (¢ button.

4. Inthe Tools toolbar, select the Contour Editor (&

tool.
5. Inthe Camera view, push the points and contours to
add the desired thickness.

No matter which tools you use to draw with you must
finally flatten the lines so that your character outline is a
single shape instead of being built out of many strokes.
This makes it easier and lighter to manipulate.

1. Inthe Tools toolbar, select the Select (K tool.

2. Inthe Camera view, select the lines to flatten.
3. Inthe Tool Properties view, click on the Flatten (&

tool.

There you go! You now know how to design and clean a
complete character in Toon Boom Animate.

If you plan to use this character as a cut-out puppet in a later step, you can decide not to flatten your lines for

® an easier breakdown process. Refer to the Creating a Cut-out Puppet chapter for more information.
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Chapter 5 Painting Your Character

One of the greatest benefits of using Animate are its
colour palettes. With Animate, you can create a group
of colours specifically for your character which will stay
with it throughout your project. You can change the
colours at any time.

You can use the character you drew previously or a
character model from the sample material package*:
e Templates/Joe_unpainted.tpl
e Mac: /Applications/Toon Boom Animate 2/
Templates/Samples/ Textures
e Windows XP: C:\Documents and Settings\All
Users\Documents\Toon Boom Animation\Toon
Boom Animate 2\Templates\Samples\Textures
¢ Windows Vista and 7: C:\Users\Public\
Documents\Toon Boom Animation\Toon Boom
Animate 2\Templates\Samples\Textures

The topics are:
e Creating a Colour Palette
® Painting the Character
e Closing Gaps
e Creating Gradient Colours
e Painting With Bitmap Textures
e Editing Gradients and Textures
e Creating a Palette Style

* For Animate Pro, browse for Toon Boom Animate Pro 2 rather than Toon Boom Animate 2.
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Creating a Colour Palette
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You don't need to use the default palette to paint all of
your drawings and animations. You can create a small
group of colours specifically for your character! This helps
to keep your work organized by keeping your character’s
colours together. These groups of colours are known as
colour palettes.

To access the Palette List, in the Colour view, click
on the Show Palette List View 5= button.

¢ o s «@ a@ ()

I * Dc=foultLine
| Calour 3
| ] Calour 4
— colour 5

In the Colour toolbar, click on the New Palette =
button.

o Q&
Default
@ Joe

In the Palette Browser dialog box, name your
palette with a relevant name.

Click on the OK button to validate the palette’s
creation.

Refer to the Creating Your Own Animation chapter to review the Colour view basics.
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If you are not using the default palette, remove it from the
Palette List.

Note: The default palette itself will not be deleted and it
can always be brought back later.

&t o O 7o
@ Joe

sB @@ =&

5. Inthe Colour view, select the default palette.
6. Inthe Colour view toolbar, click on the Remove
Palette '— button.

4%3 5 7. Inthe Colour view, click on the Add Colour =
N

button to add new colour swatches.

8. Double-click on a colour swatch to open the Colour
Picker window and modify the colour.

9. Click on the colour swatch’s name to rename it.

You are now ready to add colour swatches to your new
palette.

* |ing
skin
hair
shirt
tie
pants
shoes
mauth

H0E L L

collar

Remember that when you paint a zone with a specific colour swatch, the zone is linked to this colour swatch.

When you modify the swatch, the zone will be updated along with it.
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Painting the Character
+ = & 0«0 80 &

N— *hair )
C—S
@ 1. Inthe Tools toolbar, select the Paint (& tool.

2. Inthe Colour view, select the colour swatch
corresponding to the zone your want to paint.

3. Inthe Camera view, paint the zone.
4. Repeat this process until the drawing is entirely

L painted.

With the Paint tool you can only paint closed zones. If a zone is open, you will need to close it either with the

® Brush tool or the Close Gap tool.
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Tool Properties | 3%

\ Paint

Options

O & @ @ &
W paint

() Paint Unpainted

(&) Repaint
() Unpaint

There are many Paint ({#) tool options available. You can

set these options in the Tool Properties view:
e Paint
Paints everything it touches
e Paint Unpainted
Paints only unpainted zones
® Repaint
Paints only already painted zones
e Unpaint
Unpaints everything it touches

To quickly paint a series of drawings, it is advantageous to set the Paint tool’s painting option to Paint

#® Unpainted.
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Closing Gaps
~— \{® Paint

Options

@ @‘ k‘ & @ & &

() Mo Close Gap

() Close small Gap

. . . . Close Medium Ga|

If your drawing has a gap in a line, the Paint (& tool O P
i . . () Close Large Gap
cannot paint the unclosed zone. First you need to close it. :

You can do this using the automatic Close Gap mode or You can also use the automatic close gap available in the
the Close Gap tool. You could also use the Brush, Contour Paint’s Tool Properties. You can choose the size of the gap
Editor or Pencil tools. that you want the system to automatically ignore while

painting. Gap closing only occurs when you paint using the

Paint tool.
2 @ To use the automatic Close Gap mode:
” 1. Inthe Tools toolbar, select the Paint (&) tool.
2. Inthe Tool Properties view, select one of the gap

To use the Close Gap tool: closing options from the drop-down list.
1. Inthe Tools toolbar, select the Close Gap () tool. 3. Inthe Camera view, paint your drawing.

2. Press[D]to display the invisible strokes.
3. Inthe Camera view, trace a stroke near to the gap.

You can set the automated gap closing to Close Small Gap. Selecting Close Large Gap could result in not

¥ painting all of the small areas in your drawings.
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Creating Gradient Colours

Animate adds life to your drawings by letting you paint
with both gradient and solid colours.

Creating a gradient colour is so easy to do. You can even
modify one of your existing colour swatches. As a bonus
you can see the result on your painted character as you
adjust the gradient!

Colour Picker =

I N [ s o
I
EEEEEE
H® 10 RO 170

sOhm GO s
v(Oler BO

Alpha 255 I
() Solid radiem

Gradient

—
a= (16

In the Colour view, double-click on the colour

swatch to transform it into a gradient.

In the Colour Picker window, enable the Gradient

option.
Choose a Linear or Radial gradient.

Click on the gradient arrows and adjust their

position and colour.

Refer to the Animate User Guide to learn more about editing gradient swatches.
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Painting With Bitmap Textures
&+ &

—
=1 har

0«0 80 =&

&

1. Inthe Colour view, click on the Add Texture

button.
2. Browse for a PSD or TGA picture.
In the Tools toolbar, select the Paint () tool.

w

4. Inthe Colour view, click on the Paint Colour ¥

button.
In the Colour view, select your new texture swatch.
6. Inthe Camera view, paint the desired zone.

o

After painting with solid and gradient colours, you can also
paint with bitmap textures.

You can use any photo or textured image in your computer and paint your animation with it. It only needs to

be in PSD or TGA format.
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Editing Gradients and Textures

1. Inthe Tools toolbar, select the Edit Gradient/Texture
& tool.

2. Inthe Camera view, click on the gradient or texture
zone to modify.

3. Using the tool’s anchor points, modify the gradient
or texture’s size, angle and position.

Squash and Stretch

Rotate

If you like the gradient position you made with the Edit
Gradient/Texture (@l tool, you can store it so that next

time you paint with a gradient or a texture it will be
positioned the same.

Position

1. Inthe Tools toolbar, select the Select (k) tool and

select the desired gradient zone.
2. Inthe Select (K tool’s Tool Properties view, click on

the Store Gradient Colour (g button.

3. To use the stored gradient, in the Brush or Paint Tool
Properties view enable the Use Stored Gradient

After you paint a zone with a gradient or texture colour, Colour §g option.

you can reposition and adjust it. B

You can copy and paste a gradient/texture position using the Edit Gradient/Texture tool. This can be very

handy when you have a hand-drawn animation painted with gradient colours.
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Creating a Palette Style

A palette style is created by cloning your original palette.
This links the colour swatches to the same zones as the
original palette. This has the advantage of letting you
change the colours in your cloned palette, and then by
replacing the original palette with the clone the character’s
colours will update automatically without you having to
repaint!

| Colour | K

oo &
@ _loe

(@ ssercons) |

(0ARaoeon
I[N

1. To access the Palette List, in the Colour view, click
on the Show Palette List View == button.

2. Inthe Colour view, click on the Menu "BF button

and select Palettes > Clone.

Day Palette Style Night Palette Style 3. Inthe Clone Palette dialog box, name the palette
appropriately. We recommend keeping the suffix
-clone as part of the palette’s name. For example,
Joe-clone.

4. Inthe Colour View, select the new cloned palette.

You can create palette styles for your character such as a
Day palette or a Night palette.

You can use the Tint Panel to modify all of your palette’s colours at once. You do not have to modify them

individually.
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The Tint Panel window allows you to offset or blend a

—— X, colour in all your selected swatches.
Joe-copy [v] () Offset ) )
: ® Blend . 1. Inthe Colour view, click on the Menu "E® button
= !En O Moer and select Palettes > Tint Panel.
e Amourt o 2. Inthe Tint Panel window, select the palette to
B shin J modify, in this case, your clone palette.
o TS H J 17 3. Inthe Colour list, select the swatches you want to
— pants s j 0 modlfy
B shoes o 3 ) 4. Choose between Offset or Blend mode.
i . 1 = 5. Ifyou are using the Blend mode, increase the
. J e blencfiing amount. .
. ] — 6. Mf)dlfy the offset or blend tint.
- 7. Click on the Apply button to apply the changes to
1B your palette or click on the Reset button to reset the
[] Preview changes.
e =]

To modify the cloned palette colours, edit them one ata
time in the Colour Picker window or you can offset all of
the colours at once using the Tint Panel window.

If you want to use your painted character as a colour model, you can store it in your library as a template.

Refer to the Animate User Guide to learn more about creating templates.

Painting Your Character - Creating a Palette Style 59



Would you share some connections?
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We do.

The Toon Boom Job Connection online
pages gather a huge selection of job
opportunities from the major professional
cartoon animation studios all over the world.

Find your next job or post your resume.
Whichever you do you'll make some

new connections.

All you have to do is register.
Try it now, it's free.

oo BRI



Chapter 6 Using Symbols to Animate a Skateboard

With Symbols, Toon Boom extends Animate'’s
spectacular animation capabilities even further. For
example, by using Symbols, you can build animated
props and manipulate them as a unified object.
This chapter contains the following topics where you
will learn how to create, combine, extend, edit, cycle
and animate Symbols.
The topics are:

e Creating the Skateboard

¢ Animating the Smoke Cycle

e Creating Symbols

e Adding Smoke to the Wheels

¢ Building the Skateboard

* Importing the Skateboard

¢ Animating the Skateboard
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Creating the Skateboard

1. Inthe Timeline view, add a new layer and rename it 3. Inthe Timeline view, add a new layer and rename it
as Skateboard. as Wheel.
Mm% o & & b
O e 0. 6 G ¢
&6 .6 % G D-gdb J ooy [Ta=
@ S B Skateboard &=l |
2. Using the tools you learned about in the previous 4. Inthe Camera view, draw a wheel to match the scale
lessons, draw the board without the wheels. The of your board. There is no need to draw it in any
wheels will be drawn on a separate layer. particular location as you will reposition it later.

> VU®

To add a new layer in your Timeline view, click on the Add Drawing Layer button in the Timeline layer toolbar.
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Animating the Smoke Cycle

You will create a three drawing animation cycle. The
animation cycle will be done later after you have imported
the smoke symbol back into your scene. For now, just
create the three main drawings.

1.

2.

Ve

In the Timeline view, add a new layer and rename it

Smoke.
v &~ 8B & Hp
CHBsmoke_ D &=~
+45 whesl Cla=| |
~+43 skatehoard &=l |

In the Camera view, draw the first smoke drawing.

3. Using the Onion Skin feature, draw the second and

third drawings.

L vdto B G

-

+43 smoke
+ 49 whesl
~+43 skateboard

__
0o~

&=

i)
1

4. To change the number of drawings visible in the
Onion Skin display, push or pull on the Onion Skin

blue arrows.
J—
to & & ey
+43 smoke Cl& =~
L ST R Ma = |

Refer to the Animate User Guide to learn how to add effects on your animations. For example, you could

add a transparency and a blur on your smoke animation.
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Creating Symbols

Animate has a library where you can store your

drawings and animation for reuse in your scene or sharing

in your projects.

To reuse drawings or animation in another scene, you need

to create a template out of them.

A good example of reuse is shown in the skateboard you
are building, it has four wheels. However, you only need to
draw one wheel and then reuse it three more times to

create the three missing wheels. To do this, you must

create a Symbol out of the wheel and then reimport it into

your scene.
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Creating a Symbol is easy. You only need to select the
drawings or layers you want to transform and drag them to
your Library view.

You can either select:

e Asingle drawing

e Several drawings in a row on a single layer
e Several drawings in a row on many layers
e Asingle layer

e Several layers

To build your skateboard:
In the Timeline view, select the skateboard drawing
and drag it to the Library view inside the Symbols
folder.
Select the wheel drawing and drag it to the Library
view inside the Symbols folder.
Select the three smoke drawings and drag them to
the Library view inside the Symbols folder. Or use
the default keyboard shortcut [F8].

All your skateboard elements should now be in the Library
as Symbols.

: Refer to the Animate User Guide to learn more about creating Symbols and templates.



By right-clicking in Windows (or [Ctrl] + click in Mac OS) on the Symbols folder, you can add a new folder and

rename it to organize your Symbols.
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Adding Smoke to the Wheels

To add the smoke to each wheel and cycle it, you will enter
the Wheel Symbol and add the smoke animation. This way
all the wheels will receive the smoke cycle simultaneously.

1. Inthe Library, double-click on the Wheel Symbol.
You should now be inside the Wheel Symbol where
you can edit it.

£ Top - aaWheel | Carnera | pAE S
@ L = L Transfdl

Before importing the Smoke Symbol, you will need to
extend the symbol length.

2. Inthe Timeline view, pull on the scene length red
bracket and extend it to frame 3.

—
dl»{! }b
&=

W e+~ B &
+43 wheel

You will now import the Smoke Symbol:

3. Inthe Library, select the Smoke Symbol.
4. Drag and drop the Smoke Symbol into the
Timeline’s left section to create a new layer.

O 866 +]1
+43 whesl Cla =]~
~+43 smoke Cl&=| [

You should now see the three smoke frames in your
Timeline.

Extend or reduce a symbol’s length by sliding the Timeline’s red bracket to the left or right. Moving it

towards the left reduces the symbol'’s length, while moving it towards the right extends the symbol’s length.
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5. Inthe Tools toolbar, disable the Animate mode and
select the Transform tool.

6. Inthe Camera view, position the Smoke layer. If the
smoke needs to be resized, use the Transform tool’s
corner anchor points to resize it. The whole
animation will be scaled together.

[Tools O

@®

As you can see, the wheel’s exposure is only one frame
long. You must extend it to three frames.

7. Inthe Timeline, select the wheel’s last cell and press
the [F5] key to extend the wheel’s exposure.

RS b
+ 43 whesl [la=
+43 5ok &=
e [ Wheel-1.tvg

= | Library | Mk

Freview

[ Symbols Wheel
(&)l &nimate Librany

(@ Templates

nan®
Skateboard
®

Whael Smoke

Your Wheel Symbol now contains your Smoke Symbol.

In the Library, click on the Wheel Symbol to preview it and
press the Play (®/ button to view the animation.

You must save your project in order to save the Symbols stored in your Library.
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Building the Skateboard

Now you need to add the completed wheels inside the
Skateboard Symbol. This will enable you to manage your
skateboard as a single object instead of many.
1. Inthe Library, double-click on the skateboard
Symbol.

You will see the name of the Symbol at the top of the
Camera view. You should now be inside the Skateboard
Symbol.

@rTop - g Skateboard | Camera | YK
O o © 100% - Select Fr 1.00:0.

Before importing the Wheel Symbols, you will need to
extend the Skateboard Symbol’s length.

2. Inthe Timeline view, pull on the scene length red
bracket and extend it to frame 3.

7\

Wt 86 HPM
+43 whesl [la=

3. From the library, import four Wheel Symbols. Place
two of the wheel layers above and two more below
the Skateboard layer. Remember to rename your
layers correctly.

+49 yhesl1 &=
+49 ywheslz [la=s
~+43 skatehoard [1a=
+49 ywheai3 [la=s
+49 yheai e

You can enter a selected symbol by using the default keyboard shortcut [Ctrl]+[E] on Windows

or [$]+[E] on Mac OS.
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4. Inthe Tools toolbar, disable the Animate & mode

and select the Transform &3 tool.

[Toots — 0|

5. Inthe Camera view, position the wheels. If the wheel
is the wrong size, use the Transform tool’s corner
anchor points to scale it.

To modify the Wheel Symbol, double-click on a wheel.
Once inside the Wheel Symbol, modify whatever you want
to and the four wheels on your skateboard will be
automatically updated to include the modification.

The skateboard’s exposure is only one frame long. Change
it to three frames long to match the wheel’s exposure.

6. Inthe Timeline view, select the board’s third cell and
press the [F5] key to extend the skateboard’s

exposure.
W%+ 8 G a4,
+49 whesl1 [la=
+43 ywheslz [la=s
+45 ckateboard [1&=
+43 yhel3 [la=s
+43 yheal Clas

You now have a complete skateboard which you can
manage as a single object. Get ready to add it to your
scene and do some tricks!

When editing a symbol, go back to the scene’s root, click on the word "Top"” at the top of your Camera view.
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Importing the Skateboard
Your completed Skateboard Symbol is ready to animate, Before importing the Skateboard Symbol, you will need to
but first, you must clear the content of the Timeline. extend the scene length.

To import the Skateboard Symbol:

In the Timeline view, pull on the scene length red
bracket and extend it to frame 60.

To clear the Timeline:
1. Inthe Camera view top area, click on the Top %=
button to go back to the scene’s root.
In the Timeline view, select all of your layers.
3. Inthe Timeline view toolbar, click on the Delete
Layers (=’ button.

N

N

+ 49 g C]a
Ty Dalete Lovers 11 -

~+43 skatehnard &

(00| (00| (0w

[N
Il
I

4. Inthe Confirm Delete dialog box, click on the OK

button. 4.

You are now ready to import your skateboard from the
library, but before dropping it into your Timeline, you will
perform an extra operation called: Paste Special. The
Paste Special command allows to expose the symbol’s full
length and then create a cycle from it in a several different
ways.

1.

® 6 Eq G o 3.

N
> \J

In the Library, select the Skateboard Symbol.

Start dragging the Skateboard Symbol toward your
Timeline view.

R P e e “

+45 ckatehoard N [ \& = J
3]

Press and Hold down the [Alt] (Windows) or [Ctrl]
(Mac) key before releasing the Symbol.

Drop the symbol in your Timeline's left side while
holding down the [Alt] (Windows) or [Ctrl] (Mac) key.

Once you store a drawing or a layer as a Symbol in your Library, you can delete it from your Timeline. Your

work will still be available as a Symbol in the Library view.
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Paste Special

If you forgot to use the Paste Special command when you
y 9 P y

Basic | Advanced

imported, do the following:
1. Inthe Timeline view, select the symbol’s frame.

Drawings

(@) Only create drawings when they do not exist
() Always create drawings

[v/] Extend Exposure

k- hste all Frames of the symbaol (full mowvie)

Cycle
Mumber of Cycles: @
Cycle Type Normal (foreard)

&
[

2. Inthe top menu, select Edit > Copy.
3. Inthe Timeline, right-click in Windows or
[Ctrl] + click in Mac OS and select Paste Special.

~
0% - G ( ;9 )
+49 skateboard I:‘ &=/ %ﬁ LLU_LL

[ Ok H Cancel ]

6. Inthe Paste Special dialog box, enable the Paste
All Frames of the Symbol (full movie).

N

8. Click on the OK button.

Set the Number of Cycles field to 20.

The default keyboard shortcut for the Paste Special command is [Ctrl]+[Shift]+[B] (Windows)

or [Shift]+[3£]+[B] (Mac OS X).
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Animating the Skateboard

S

To complete your project, animate the Skateboard
Symbol’s position.

1. Inthe Tools toolbar, enable the Animate <& mode
and select the Transform &3 tool.

2. Inthe Timeline view, go to the first frame.

3. Inthe Camera view, select the Skateboard and
position it to the left side of the screen.

In the Timeline view, go to the last frame.

In the Camera view, select the Skateboard and
position it to the right side of the screen.

6. Inthe Playback toolbar, click on the Play (#®/ button

o~

to view your completed animation!

To learn more about animating with Symbols, read the Animating a Cut-out Puppet chapter in the

Animate User Guide.
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Chapter 7 Creating a Simple Hand-Drawn Animation

In Toon Boom Animate, you can take advantage of useful tools and features to animate paperlessly.
Animate lets you create traditional looking animation without paper, pencils or scans.

This chapter will focus on the Xsheet view and its
functionality, but everything can be also achieved in the

Timeline view if you prefer.

The topics are:

e Sketching your Rough Keyposes
e Marking Keyposes in the Xsheet
e Completing the Animation (r

e Setting the Exposure and Van'
Testing the Animation

¢ Cleaning Up the Animation -
e Painting the Animation A’\



Sketching your Rough Keyposes

The first step in hand-drawn animation is to draw a rough
sketch. This step lets you create and test your animation.
You can concentrate on the flow of movement without
being concerned about the character’s details. You can
focus on the details during the clean up process later on.

To easily draw your animation, first switch to the
Hand-Drawn Animation workspace.

1.

In the Workspace toolbar,

Drefault b )
select the Hand-Drawn [Dafalt e
Animation workspace from  dsrid el ition] 1
Cormnpositing

the drop-down menu.

To ensure that your scene is kept well organized, enable
the Use Current Frame As Drawing Name option. This uses
the current frame number to name each new drawing.

Press [Ctrl]+[U] (Windows) or [$8]+][,] (Mac OS X) to
open the Preferences panel.

In the Exposure Sheet tab, enable the Use Current
Frame as Drawing Name option.

B Refer to the Discovering the Interface Chapter in the Animate User Guide to learn more about Preferences.
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In the Tools toolbar, select the Brush & tool.

To sketch the second keypose of your animation, you will

In the Colour view, select a colour swatch. This is the use the Onion Skin feature. The Onion Skin lets you see
colour you are going to use for your sketch. the previous and next drawings in washed-out colours.
Sketching with a light colour helps during cleanup. This mimics the effect of working with a stack of paper on
In the Xsheet view, select the first cell in the Drawing an animation disc and light table.
column.
i 8. Inthe Tools toolbar, enable the Onion Skin %
1 ( fﬁmﬂg )
2 feature.
3 9. Inthe Xsheet view, select cell number 4, this will be
A
. . the location of the second keypose.
In the Camera view, sketch your first keypose. o . :
y yp 10. In the Timeline view, click and drag the blue arrows
S to decide the number of previous and next drawings
i that will appear in the Camera view.
: The first keypose in the >
walk cycle animation is the @@ 4o B G K ~
character with legs and B Dravine Oa®]~ ]

arms spread apart.
11. In the Camera view, sketch the second keypose.

You can customize the Onion Skin display options such as the render style and washed out values in the

Preferences panel under the Drawing tab: Edit > Preferences (Windows) or Animate > Preferences (Mac).

Creating a Simple Hand-Drawn Animation - Sketching your Rough Keyposes 75



The second keypose is the highest point of the walk cycle.
The leg that was pointing forward on the first one should
now be straight beneath the character.

Keypose 1 Keypose2  Keypose3 Keypose 4
Cell1 Cell 4 Cell 7 Cell 10

Using this picture as a guide, complete the four keyposes
of the simple walk cycle animation.
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Marking Keyposes in the Xsheet

eCHEQLLETFEFIBEE@ O &
Crrawin
("
1. Inthe Xsheet view, select the cell containing the first
keypose.
2. Inthe Xsheet Tools toolbar, click on the Mark as Key
Drawing (@ button. A Key K marker will appear in

the cell.
3. Repeat these steps for each keypose.

You can do the same for breakdown drawings using the
Mark as Breakdown Drawing () button. This places a

Breakdown B marker in the selected cell.
The Mark As In-between Drawing (£ option will not add a

marker in the Xsheet view.

Once you have sketched your keyposes, you should mark Another great way to keep organized is by renaming your
them in the Xsheet view so you can keep your animation Xsheet columns.

organized. Doing this helps you to rapidly determine 1. Inthe Xsheet view, double-click on the Drawing
which poses are keyframes, breakdowns or in-betweens. column’s header.

2. Inthe Layer Properties dialog box, enter a relevant
name for the column in the name field.

The Mark as In-between Drawing option will not add a marker in your Xsheet view. It is used to switch from a

key or breakdown to an in-between drawing by removing the current marker.
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Completing the Animation

click (Mac) on any cell between two keyposes, and
select Drawing > Create Empty Drawing.

This will add a new empty drawing in your layer
ready for your next pose to be drawn in.

2. Add new drawings and sketch

Dirawing

your poses with the help of 1 1K
the Onion Skin feature. g +

. . B

Continue until you complete |} i K

the walk cycle animation. 5 5

B E B

The completed animation should be |7 7 K
composed of a total of twelve : +E

It is now time to complete the rough animation. Do this by different drawings. 10 1w K
adding two in-between drawings between each keyframe. Your Xsheet should look like this. 112 +

You can use the default shortcuts [F] and [G] to quickly flip through the different poses to get a feel of the

motion as you sketch your animation.
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Setting the Exposure and Testing
the Animation Before testing the animation, set the exposure and reduce

the scene length. The correct timing for this simple walk
cycle example is a double exposure.
1. Inthe Top menu, select Scene > Scene Length.
2. Inthe Set Scene Length dialog box, extend the
scene to 24 frames.

3. Inthe Xsheet view, ;——
select your twelve 3 A
drawings, right-click 4 4
and select Exposure > o 3
Set Exposure to > Set |7 7
Exposure to 2. : :
4. Usethe[F]and[G] 0 10
keyboard shortcuts to no_
) 12 2 12
flip through your 13 q
drawings.
|Playhack
&p \D \1!)_ \15 @:-/ Frame |1 @l St 1 @l Sop B0 o FRS 24 &
Testing your animation is a crucial step. You will finally see .
the mgt)i/on in the Camera view and dzcide ifitis goo)él or 1. Inthe Playback toolbar, click on the Loop & button
not. to enable the looping feature.

2. To start the playback, click on the Play (») button in
the Playback toolbar.

Refer to the Animate User Guide to learn more about the Playback toolbar features.
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Cleaning Up the Animation
In the rough sketch layer, start by cleaning up the key
poses first and then do the in-between drawings.

Remember, you can use the Onion Skin feature to verify
the accuracy of the line between the different poses.

5 p— o Ay S
@» Ep 6o uD. & @
Baby_‘walk_Clean\ Baby_‘walk_Rough

1 \ ) 1K
2 / |
3 N— 7 2
1. In the Xsheet view, click on the Add Column {{J+
button.

2. Inthe Add Columns dialog box, name your column
Baby Walk_Clean.
3. Inthe Tools toolbars, click on the Brush (& button.

When you are satisfied with your animation, you can begin
the clean up process.

If you are animating in the Drawing view you will need to enable the Light Table feature to see your other

layers. Simply press [Shift]+[L], the default keyboard shortcut.
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4. Inthe Tools Properties view, click on the
Auto Flatten (& button and modify the minimum

and maximum brush sizes.

—

5. Inthe Colour view, click on the desired colour
swatch. Choose a darker colour that will contrast
with your rough sketch.

6. Inthe Camera view, carefully trace the poses.

The Auto Flatten option flattens your brush lines as you
draw them. It also simplifies the process of perfecting your

lines with the Contour Editor tool.

Refer to the Character Design chapter to learn more on how to perfect your brush line using the Contour

® Editor as well as other useful tips on cleaning up your drawings.
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Painting the Animation

1. Inthe top part of the Colour view, click on the New
Palette =+ button.

Name your palette in the Palette Browser window.
Rename the default colour swatch and call it Line.
In the Tools toolbar, select the Paint tool.

o hwbd

In the Tools Properties view, select the Repaint ({#

mode and click on the
Apply to Multiple Drawings (@) button.

Options

o [eo @;T.'i @

The Repaint mode @& will make sure that only the lines
will be repainted, all the empty zones will remain.

e . The Apply to Multiple Drawings (i) option lets you repaint
It is time to create a palette for your character and repaint ) PRl P ) 9 @ op ¥ P
the outlines using the colours contained in this palette. the lines on all your drawings at once.

Refer to the Painting your Character chapter to learn more about colour palettes features and helpful

painting tips.
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Use the Onion Skin feature to check that no part of the Now you can add and customize the different colours that

animation is left outside the selection. will be painted in your animation. Be creative! You can
6. Inthe Camera view, make a selection around your work with one colour at a time or create them all at once.
animation. Remember, you can modify them anytime you want

without repainting your drawings.

oo 1 ¢
@ Baby

& <@ ¢cm 8@ & &
# Line

pyiama_a
Skin
pyiama_b

0]

Button

1. Inthe bottom part of the Colour view, click on the
Add Colour = button.

2. Inthe Colour view, double-click on the new colour
swatch.

3. Inthe Colour Picker dialog box, pick the desired
colour and rename your colour swatch.

4. Repeat these steps for each colour. In this exercise,
you will need a total of five colours, including the
line.

Refer to the Painting your Character chapter to learn more about the Colour Picker dialog box and Palettes.
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As soon as your palette is completed you can start to fill
the zones.

In the Tool Properties view, select the Paint
Unpainted (& mode and click on the Apply to

Multiple Drawings (&, button.

The Paint Unpainted mode will only allow the empty zone
to be painted, preventing lines from being accidentally
repainted.

The Apply to Multiple Drawings feature is useful when you
want to paint the central body zone on all of your drawings
at once. It can also be used on the head zone.

In the Tools toolbar,
enable the Onion Skin
feature.

In the Colour view, select
the colour of the pyjamas.
Click inside the central
zone you want to paint.
Enable the Apply to
Multiple Drawings feature
again and repeat these
steps for the head.
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To paint the final details, disable the Onion Skin feature so
you can see one drawing at a time. Use the Paint tool in
Paint Unpainted mode to speed up the painting process.

|

In the Colour view, click on the colour swatch.

2. Inthe Camera view, click on the zone corresponding
to the selected colour.

3. Flip through the drawings by pressing [F] and [G],
the default keyboard shortcuts.

4. Repeat these steps for each colour until every zone

is painted!

=N
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Chapter 8 Building a Cut-out Puppet

In Toon Boom Animate you will find all the tools you
ever wished for to build and animate cut-out puppets
with. A wide variety of breakdown and rigging
techniques are available since Animate mixes the most
common and popular concepts.

The topics are:
e Getting Ready for the Breakdown
e Breaking Down the Main Parts
e Fixing Articulations and Gaps
e Breaking Down the Other Views
e Ordering the Puppet’s Layers
e Setting the Pivots
e Creating Hierarchies
e Ordering Layer Hierarchy
e Adding a Master Peg
e Storing the Puppet in the Library
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Getting Ready for the Breakdown Breaking dowr.1 a puppet, consists of cutting the body into
parts and placing them on different layers so that the

character becomes articulated.

To build your puppet, you will first need the character’s
picture. It's even better if your have a complete
turnaround.

You can use the sample template provided in your library:
e Templates > limpa_colour.tpl

I This tutorial shows you how to build a basic puppet. To get more information on how to build a cut-out
puppet for a production, refer to the Animate User Guide.
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The breakdown task will be easier if your turnaround views
are placed in separate cells on the same layer and centred
in the Camera view. If your puppets are placed one beside
the other, your final puppets will not align and will need to
be repositioned.

Start by analyzing your character. What are the main parts?
If you look at this sample character, Limpa, you can identify
five main pieces:

e Body

o LeftArm
e Right Arm
o LeftLeg

e RightLeg

Later on, you will break those sections in smaller pieces
such as right hand, left foot, right eye, mouth, head, etc.

Before starting any breaking down, try to decide what will
be separated from what. For example, to keep this puppet
simple, we will keep the hat attached to the head, but you

could decide to separate it from the head to be able to
animate itindependently.

Body

Right Arm

Right Leg Left Leg

b It is wise to analyze your character before starting to cut it apart. You should be careful what you separate

from each part. For example, do you want to separate the mouth

e head or not.
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Breaking Down the Main Parts
J— Ol

B CETELBOLRO e dd

Belect

" Reposition All Drawings

To breakdown your character, use the Select X tool and
the Cutter @ tool.

You do not need to create new layers when you break
down your character. They will be created as you go.

Start by creating the main pieces of your character. In this
case, the body, arms and legs.

Use the Cutter and Select tools to extract the parts, such
as the arms, from the body and send them to separate
layers. It does not matter if there are bits from other parts
or gaps. You will fill and fix those later.

Only do the front or three-quarter view for now. You will
break down the other views later on.

Note: You could also decide to add layers manually and
redraw over the model if this technique does not suit your
needs.

In the Tools toolbar, select the Cutter @ tool.

In the Tool Properties view, select the Lasso
Selection é2 option.

In the Camera view, trace a selection around the first
part to separate it. In this case, we will do the right
arm.
»  You can hold down the [Shift] key if you want
to create a second area.
» If yousimply click on a line, it will be entirely
selected until it meets an intersection.

B There are several breakdown techniques. In this lesson, we show you the most commonly used. Refer to the

Animate User Guide to get more tips about breaking down your puppet.
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o

Create Drawing from Drawing Selection E]

Layer Marne lp_r_arm [v]

@Cut Artwork From Source

In the top menu, select Edit > Create Drawing from
Drawing Selection. The default keyboard shortcut
is [F9] (Windows) or [8]+[F9] (Mac OS X).

In the dialog box, type the new layer name.

Disable the Cut Artwork from Source option. When
you create layers out of your colour model, you do
not want to cut out the artwork.

Press the OK button to validate.

Repeat the process for each main piece: body, legs,
arms, head, etc.

0w o & & qb
Hla__leg |:| L= J
+4 0 leg []& = J
+48 1 |_am []& = J
+45 ¢ am []& = J
+45 |0 _body []& = J

Once your main pieces are separated, you can start to
break them down.

9.

10.

11.
12.

13.
14.

In the Camera view, select the hand from the new
arm layer. Do not select it from the model.

In the top menu, select Edit > Create Drawing from
Drawing Selection.

In the dialog box, type the new layer name.

Enable the Cut Artwork from Source option. You
want to cut the hand away from the arm.

Click on the OK button.

Repeat the process for each part in the character to
be broken down.

All of the parts should now be in separate layers.

If you forget to send something into your new layer, you can add it afterward. If you select it and use the

Create Drawing from Drawing Selection option, you can choose the existing layer in the drop-down menu.
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Fixing Articulations and Gaps

The body artwork
continues underneath
the arm drawing.

Now that all your parts are in their respective layers, it is
time to fix the rough cuts you did earlier and draw nice
articulations. To do so, you will use tools such as:

° \.ﬁ Eraser tool

e ® Paint tool

When you fix the joints, make sure they overlap properly.
Remember that the puppet will be animated and each part
* @ Brush tool will move and rotate, so make sure not to leave a gap in

o X selecttool the part underneath.

e (% Contour Editor tool

You could fix the gaps and remove the extra lines while breaking down the parts, but since you will have to fix

the articulations afterward you are better off doing everything together.
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Top part

l

Overlapping Zon

Bottom part

l

The easiest articulation to make is the classic joint. The
classic joint consists in removing a portion of the outline on
the overlapping part. For example, the outline around the
elbow can be erased on the forearm piece. The arm placed
beneath the forearm will keep its entire outline.

When you assemble those two pieces together, the joint is
seamless and it looks like a single drawing!

There are other ways to build articulations that are even
more efficient. This one is the simplest and is often quite
sufficient.

When you
assemble the two
parts, the joint is
seamless.
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Breaking Down the Other Views

When you have finished fixing your drawings and joints on
your three-quarter view, you can start breaking down the
other views such as side and back views.

Since you already broke down a view, the layers already
exist and are named. You won't need to do it twice!

The breakdown principle is the same, except that your
layers already exist.

In the Timeline view, select the cell containing your
view to breakdown.

+ 49 Ip__hand e =

-+ 49 Ip_r_hand : as 7
445 lp_r_am : as [T

+ 45 Ip_r_thish Oas| |
+43 g Oes| |
449 Ip_colour : as _g

In the Tools toolbar, select the Cutter @ tool or
Select (% tool.

In the Camera view, trace a selection around the first
part to separate it.

A In the Timeline view, disable the checkbox if you want to hide certain layers while working. You can also

enable the Lock option to avoid selecting or modifying layers.
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This time, you will add your selection to an existing layer,
instead of creating a new layer.

4.

5.

In the top menu, select Edit > Create Drawing from
Drawing Selection.
In the dialog box, select the desired layer from the
Layer Name drop-down menu.
» Disable or enable the Cut Artwork from
Source option depending on what you are
doing.

-

Create Drawing from Drawing Selection

Layer Mame Ip_clean [v]

Ip_clean

[] Cut Artweark. Fram Source Ip_colour
Ip_deszign
Ip_r_arm
Ip_r_forearm
Ip_r_hand

Ip_rough

Click on the OK button.

Once the view is all broken down, fix the
articulations and gaps.

Repeat the process for each view.

Refer to the Animate User Guide to find out more about the Create Drawing from Drawing Selection feature.
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Once your timeline is completed it should look similar to

this example.

MR K]

+4 1| _eve
+8 0 eyve
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+4 |n_head
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Ordering the Puppet’s Layers

It is possible at this point your character’s pieces may show
up in the wrong order. There are two ways to fix this.

DisEIayed in Front

+4 0 hea
+91n |_tiHa
+Bip_r_titha
+49|p |_hahd
C +49p r hard
:Fﬂlp |_farearm
+45 a0 forearm
+4 0 | leg
+4 0 leg
+48 1 |_am
+45 ¢ am
+45 |0 _body
+45 |0 _colour

To reorder your layers drag them to a higher or lower level
in the Timeline view. The top layer is displayed in front of
the others and the bottom one is displayed behind.

7
[

Displayed
Behind

(W 000 { (0| 00W | 000 | (W | 000 { (W] 00W | (0| (0N 000 | (M| 00N | (N (0O

KRR EEEEEE]

1. Inthe Timeline view, drag the layer to reorder it and
drop it in-between the other layers.
Note: If you drop it on a layer, it will create a parent
hierarchy, so make sure to drop it in-between layers.

If you select a layer and reposition it, its child layers will follow. There is no need to select all the layers.
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Setting the Pivots

Do the following steps for each layer in the Timeline view.

To set the pivots for the Body parts:
1. Inthe Tools toolbar, select the Pivot & tool.

2. Inthe Timeline view, select the cell you want to set
the pivot for.

3. Inthe Camera view, click where you want the pivot
to be. You can also drag the pivot marker to the
desired location.

4. Inthe Timeline view, select the cell where you want
to set the new pivot.

5. Inthe Camera view move the pivot to the desired
position.

If you want your puppet’s pieces to rotate properly, you
need to set the pivot points. Even the eyes and mouth
require you to set their pivots.

B For more information about pivots, refer to the Animate User Guide.
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Creating Hierarchies

Animate lets you extend your rigging techniques beyond
normal boundaries and set new standards. You can create
hierarchies without encapsulating your layers inside each
other by creating a linked structure between your layers.

D Refer to the Animate User Guide to learn more about complete production rigging.
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To create a hierarchy:
Simply drag the child piece (hand) and drop it ON
the parent piece (forearm). Then, you can drag the
parent (forearm) piece on another parent piece

4k

(arm).
W% - B G
Z +45 |0 _body L=
v  +9n head []&=
V] =+ ¢ leg []&=
M Y+ tibia [1&=
V] = 90 | leg []&=
V] L 8| b []&=

_7f+ﬂ|p |_arm R =
T L4489 forearr/ <4 4 s
N b B g [ =
V] S+ ¢ am []&=
Z LS+ foeam [ & =
v L ¥ prhand []& =

You should create a hierarchy of your arms and legs and
keep the arms and legs separate from the body. This gives
you more animation freedom.




Ordering Layer Hierarchy

If you created a hierarchy of your arms, legs or other body
parts, it is possible that you will want a child part, such as
the hand, to appear in front of its parent. If you move the
hand layer above the arm layer, you will break the
hierarchy.

S+ am [1&

LS Sy foream [ &

L A ¥prhand [ &
Therefore, to reorder a layer rigged in a hierarchy, nudge it
forward or backward.

(00] (00| (0w

Animate allows you to move your elements in the three
dimensions:

e Up and Down (Y)
e Leftand Right (X)
e Forward and Backward (2)

The same way you can create multiplane backgrounds
(depth), you can do a micro nudge on the part to be
reordered. This makes possible for a reordered part to
appear in front of the other elements even if its layer is
behind the other ones in the Timeline view. The Forward-
Backward position can also be animated over time.

To move elements along the Z-axis, use the default keyboard shortcut [Alt] + Up Arrow to move the layer
% backward and [Alt] + Down Arrow to move the element forward.

Normal Ordering Forward - Backward Ordering

S+ am [1&
LS Sy foream [ &
L A prhand [ ®

(00] (00| (0w

1. Inthe Tools toolbar, select the Transform 1 tool.

Make sure to disable the Animate & mode.

2. Inthe Camera view, select the element to reorder.

3. To move the element forward, user the default
keyboard shortcut [Alt] + [Down Arrow] and to move
the element backward, use the default keyboard
shortcut [Alt] + [Up Arrow].
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Adding a Master Peg

To control all your puppet’s pieces together, you will need
to add a peg layer at the top of your hierarchy. A peg layer
is a trajectory on which you can attach your character. This
way you can scale and reposition your complete character
for the entire scene or over time.

1. Inthe Timeline view, click on the Add Peg (%

button. Name the new peg Master.
2. Inthe Timeline view, select all of the layers you want
to attach to your new peg.
@ % - a(&

3 +s
4 49 Ip_hezd
=443 1p_r_hand
=43 ip_r_forearm
+ 49 pram
+491pr kg
~+ 49 Ip_r_tibia
U] 43 lobody
L | +49 11 foream
L1 +480klem
L |+ hend
L |+l
L A9 |p |_tibia
N ——

3. Dragyour selection right on the peg layer to parent
all your character’s pieces to the peg.
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Storing the Puppet in the Library

To store your character in the library you first need to
create a position keyframe on all your layers and finally
store it as a template in a sharing library.

1. Inthe Timeline view, select the first frame of every
layer.

2. Inthe top menu, select Insert > Keyframe or use
the default keyboard shortcut [Ctrl] + [F6]
(WIndows) or [8]+[F6] (Mac).

3. Inthe Library view, select the Animate Library folder,
right-click (Windows) or [Ctrl]+click (Mac OS) and
select Right To Modify.

4. Inthe Timeline view, select all of your layers and
drag them into the Animate Library.

You now have a complete cut-out puppet!

A To find out more about sharing templates via the library, refer to the Animate User Guide.
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Chapter 9 Animating Your Puppet

It is time to show off your animation skills!

Toon Boom Animate was created for you to animate. It

contains a series of animation tools beyond your

expectations.

This lesson will cover the basics of cut-out
animation, but there are an infinite number of
possibilities. Take a look at the Animate User
Guide to discover more about animation.

You can use the character you drew
previously or use a character model from the
sample material package:
¢  Undone_example_Sample_material >
Chapter09_Sample_material.tpl

The topics are:

e Getting Ready to Animate

® Repositioning the Character

® Animating Using the Transform Tool

* Motion and Stop-Motion

e Swapping Images

¢ Inverse Kinematics Tool

e Easing

\

.__ﬁ\ '
N

AN
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Getting Ready to Animate
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To start this lesson, import your character into a new

scene.

1. Create a new Animate project.
2. From the library, drag your character template into
the Timeline view's left side.

P S e R |
Onion Skin 1
Onion Skin 2

Before starting your animation, you may want to enable
the Onion Skin feature to see your previous and next

frames as a reference.
» Inthe Tools toolbar, enable the Onion Skin

-y .
== option.

»  Youcan also enable individual layer's onion
=

skin by clicking on their Onion Skin = icon in

the Timeline view.

To use a character you previously built in another project and transformed into a symbol, drag the symbol

into the Animate Library or into any other templates folder and transform it into a template.
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Repositioning the Character

Now that you have your puppet on your stage, you probably need
to resize and reposition it to fit your scene. When you need to

scale down or move your character it's a good idea to hook ~
(attach) the whole puppet to a trajectory.

In Animate, there is a type of layer you can %, .
add to your timeline allowing you to Al &
create a motion path or to .(’j. By
reposition drawings. This o, &_}‘b

trajectory layer is called a Peg. : s

Any drawing or layer you hook ’ R ’;‘%\

to a peg will follow the 07
defined motion path, e

rotation, scaling and skewing i
information.

Attaching your puppet to a peg will 8
allow you to scale it and reposition it

without having to do it on all of your different

parts and pieces. Only one layer will contain

the position information, this makes your

animation easier to modify and control.
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If you do not have a top peg layer to control your
character, you can add one at any time. A peg layeris a

trajectory on which you can attach your character. This way

you can scale and reposition your character for the entire
scene or over time.

1.

In the Timeline view, click on the Add Peg (%

button. The new peg should be called Master.

In the Timeline view, select all of the layers you want
to attach to your new peg.

Drag your selection right on the peg layer to parent
all your character’s pieces to the peg.

o,

Next, you need to position your character on the stage by
moving and scaling it to the correct size. You will not scale
each layer individually. You either want to do it on the top
symbol or top peg layer.
4. Inthe Timeline view, select the top peg layer (master
peg).
5. Inthe Tools toolbar, select the Transform ¥ tool
and disable the Animate < mode.

6. Inthe Camera view, position the character.

You can change the Onion Skin display’s look in the Preferences panel. In Edit > Preferences (Windows) or

Animate > Preferences in (Mac OS X) go to the Drawing tab and change the Onion Skin Render Style option.
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Animating Using the Transform Tool

From now on, the Transform {3 tool will become your

most useful tool. You will use it to do most of your
animation. With the Transform tool, you can select, move,
scale, rotate, skew, squash and stretch.

&% G b &‘
[ 4 bl_MASTER e

1. Inthe Timeline view, go to the frame where you
want to animate your first pose. At this point, it is
generally the first frame.

2. Inthe Tools toolbar, select the Transform &} tool

and enable the Animate <& mode.

3. Inthe Camera view, select the part you want to
animate and using the Transform tool’s anchor
points, move it to its new position.

The pose you are doing is automatically retained. There is
no need to set a keyframe before moving your parts. As
soon as you move an element in your Camera view, a
keyframe is set on the current frame in the Timeline view.

Remember, animation keyframes and drawings are not the
same thing. If you swap a drawing, you do not need to
insert a keyframe in your timeline.

To avoid selecting some layers, click on the Lock button in the Timeline view. In the Preferences panel, you

can go to the Camera view tab and enable the Show Locked Drawings as Outlines to see through them.
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Once your first pose is ready, move on to your next key
pose.
4. Inthe Timeline view, move to the frame where you
want your second pose.

If you need to, you can temporarily move the Transform
tool’s pivot to provide a better rotation or scale centre.
Simply drag it to where you need it. Next time you select
your element, it will be back to its original place.

You can also select your current selection’s parent layer by
using the default keyboard shortcut [B]. If you press on it
repeatedly, you will go up the entire parent chain until the
master peg or highest layer in the tree.

AR d . A

[ bl_MASTER &=lo- ()

We recommend that you collapse your master peg and
add a keyframe after your pose is set. This will lock all of
the parts in place. You only need to do this once.

5. Inthe Timeline view, select the pose and press [F6].

When you select a series of elements using the [Shift] key, the pivot used by the Transform tool will be in the

first selected element.
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Motion and Stop-Motion

W% - B G b
[ 4 bl masTER ORI —3

By default, your keyframes will be created as Motion
Keyframes. This means that Animate automatically
generates the animation between your poses.

Because you may not necessarily want that, you can set
your keyframe creation mode to create Stop-Motion
Keyframes. Later on, you will be able to convert the
desired keyframes to Motion Keyframes.

» Inthe top menu, select Animation > Stop-
Motion Keyframe.

To switch between Motion and Stop-Motion
Keyframes:
1. Inthe Timeline view, select the keyframes to

convert.
2. Right-click (Windows) or [Ctrl] + click (Mac OS X)
and select Set Stop-Motion Keyframe —or Set

% Motion Keyframe (/).
3. Pressthe (») button to see your animation.

To flip between the keyframes of the selected layer, use the [PgUp] and [PgDown] keyboard shortcuts.
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Swapping Images

Cut-out animation is not only about moving pieces around,
it's also about switching some drawings around. For
example, the ballerina Giselle wants to point her toes.

Instead of rotating the foot, you can swap the regular foot
drawing for another one that you drew when you built
your character. You could also create an empty drawing on
your foot layer and draw a new foot while animating.

1.

To swap a drawing:
In the Camera view, with the Transform &1 tool,

select the part you want to swap.

In the Library view, go to the Drawing Substitution
section.

Move the substitution slider to the right or left to
scroll through the symbol’s frames or drawings. You
can also use the keyboard shortcuts[[ ]Jand [ ]].

To quickly swap drawings and frames around, use the [[] and the [] ] keyboard shortcuts.
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Inverse Kinematics Tool

For the IK to work on your character, there are some
preconditions:

* Your character must have hierarchy chains, for
instance, the hand is attached to the forearm and
the forearm is attached to the arm.

® Your character is not required to be entirely done
with hierarchy chains. You can have mixed
technique and it will still work well. IK works with
characters rigged with symbols, drawing layers and
pegs.

The IK will work at its best when you lock a part on the
spot, such as a foot on the floor, and then select the entire
body or another extremity and move it.

To lock a piece in place, you will use the IK Nail &) option.

The Inverse Kinematics (2 tool (IK) allows you to pull on

your character’s extremities, such as the hands and feet,
and get the rest of the body to follow!

While using the IK tool, you can hold down the [Ctrl] key to select any part.
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Selection: Drawing
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In the Tools toolbar, select the Inverse Kinematics
2 tool.

. Inthe Camera view, hold down [Ctrl] (Windows) or
[38] (Mac OS X) and click on the part you want to lock

down.

In the IK Tool Properties, click on the IK Nail &

button.

In the Camera view, press the [B] key until the body

is completely selected.

Click on the pieces’ bone to reposition the

character.

Using the IK tool and the Transform tool, fine-tune

the character’s pose.

»  Using the IK tool, holding down the [Alt] key,

you can rotate the selected part without
moving the rest of the body.

The Inverse Kinematics tool has a lot of options. Refer to the Animate User Guide for more information about

them.
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Easing

If you used Motion Keyframes in your animation, you will
certainly want to add some ease in and ease out to smooth
out your movements and avoid having a robotic animation.

There are two ways to set an ease on your animation:
directly on the function curve or using the Set Ease For
Multiple Parameters script.

N LD bl thighp aes
Pasition: Patk
Pasition: Welc

Scale: x

1. Inthe Timeline view, expand the layer
corresponding to the part you want to set the ease

on by clicking on the Show Functions 4 button. If

Fast

the layer is a parent, make sure to expand its
children by clicking on the Expand Hierarchy [*

arrow.

2. Double-click on the function corresponding to the
movement you want to ease, such as Angle, for the
rotation of the thigh. This opens the Function Editor.

You can display function curves in the Function view by clicking on the function layers in the Timeline view.
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In the Function Editor, you can see all of the keyframes
corresponding to the thigh rotation animation.
3. Inthe function curve, locate the keyframe
corresponding to the animation you want to ease.
4. Select the keyframe and pull on the Bezier handle.
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» The more you pull on it, the stronger the ease
will be.

This technique is good when you have to do a simple ease.
However, when you have a series of layers you want to set
to the same ease it can be tedious and repetitive. Instead,
you will use the Set Ease for Multiple Parameters function.

In the Timeline view, collapse the parent peg layer
containing all of the layers you want to ease.

‘E‘!!!!)é\'—’!!!!!!!!!!!'l

L+l back har [ ®

L@ X bl_r_arm-P &

LY 430 top [[&
Right-click (Windows) or [Ctrl]+click (Mac) and select
Set Ease for Multiple Parameters.

(0] (00| (o

o [ Fiters
Mation
Rotation
Seale
Skew
Morphing
g 28 ) 43 L) Cther
36 functions selected
a
Lsft Time Ratio |75.34 ¢ Right Time Ratio [55.71 B
Left Value Ratio | 14.79 ¢ Right Value Ratio [7.75 +
[AppN/PrEmnus] [ Aply ] [ Apply/Next ] [ Close: ]

Pull on the Bezier handle and adjust the keyframe's
velocity.

Click on the Apply button and then on the Close
button.

To display a toolbar, select Window > Toolbars and the desired toolbar.
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Chapter 10 Creating a Multiplane and Animating the Camera

One of the most exciting features in

Toon Boom Animate is the Multiplane, also called

Z-depth. In the Multiplane you can create
backgrounds in several layers, spread them on
the Z-axis, add depth, and then move the
camera through this environment to create an
impressive perspective illusion.

You can create your own background, use a
layered PSD file or use a project from the
sample material package:

¢  Undone_example_Sample_material >
Chapter10_Sample_material.tpl

The topics are:
e Building a Multiplane
e Setting the Multiplane Space
* Animating the Camera

117



Building a Multiplane

To construct a multiplane, you must imagine what a real
environment is like. Take a look at this picture and imagine
the camera moving across the space. You will notice that
objects in the picture will move at different speeds
depending on where they are in relation to the camera
lens.

In this picture the moon is almost stationary and the tower
in front of it is moving very slowly, but the tower closest to

the foreground is moving faster and the plant in the
foreground is flying by really quickly.
Building a multiplane requires an understanding of your
background and which object should be placed in the
different layers. You want to separate all the main
elements, but not every small object.
For example, in this background, the main objects to be
separated are:

e Fern

* Fronttower

® Second tower

e Moon

e Stars

e Sky
However, some objects are not separated, such as the
plants and the front tower or the roof and the second
tower.
Also, each layer must be a complete drawing because
even if the bottom of the tower is hidden behind the plant
and the ladder, later on in the scene, the hidden portions
may show up.

If you move a camera over a drawing, all the objects in the drawing move at the same speed. If you move the

camera across the room, you will see all the objects are moving at different speeds, producing a depth effect.
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B Build your backgrounds in Toon Boom Animate so that they are vector drawings. You can zoom as much
as you want on vector drawings, but zooming a lot on bitmap images will result in pixelation.
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Setting the Multiplane Space

QB i - Shy-1 Ratats
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By default, all of your layers are set at the same distance.
They are all located at “0". You can see it better in the
Perspective view.
1. To open the Perspective view, select
Windows > Perspective.
2. Inthe Tools toolbar, select the Rotate View & tool.
The default keyboard shortcut is [Ctrl]+[Alt] for
Windows or [$8]+[Alt] for Mac.

3. Inthe Perspective view, rotate the stage to view the
3D space.

) Use the default keyboard shortcut [Ctrl]+[Alt] in Windows or [$8]+[Alt] in Mac OS to rotate the Perspective

A
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To set your multiplane space, you will use the Top view.

In the Top view, you can see the camera cone and all the
layers set at the same distance.

. To display the Top view, select

Windows > Top.

. To display the Advanced Animation toolbar, select

Windows > Toolbars >Advanced Animation.
In the Advanced Animation toolbar, select the

Maintain Size &3 tool. This tool scales your layer as
you move forward or backward in the Top view.

In the Top view's left side, select the layer you want
to move.

In the Top view's right side, move the selected layer
up to push it backward, or down to bring it forward.
It is possible that you will not see the selected layer,
but you can still move it.

The Maintain Size tool will scale your layer as you move it forward or backward and maintain the original look

which you set in the Camera view. The depth effect will be visible once you move the camera.
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Animating the Camera

. . a,
Since you will animate the camera over time, you will need You can animate the camera using the Translate €7 tool,
to extend your layers’ exposure. The camera is a static
element, to animate it you will need to add a trajectory

Rotate (&) tool and Scale & tool available in the

layer called a Peg Advanced Animation toolbar.
1. Inthe Timeline view, select the last frame of each
layer.

To animate the Camera:
1. Inthe Tools toolbar, enable the Animate & mode.

2. Inthe Advanced Animation toolbar, select the
Translate %_" tool.

BEEREEE

2. Press[F5]to extend the exposure until the end. 3. In The Tihmeline vie\fv, goto tge first .fr.amg -
3. Inthe Timeline toolbar, click on the Add Layers = 4. S.e ect the Camera s Peg and reposition it in the Top
view and Camera view.
button and in the drop-down list, select Camera. 5. In the Timeline view, go to the last frame.
In the Timeline view, select the Camera layer. 6. Select the Camera’s Peg and position it closer to the
5. Inthe Timeline toolbar, click on the

background in the Top view and Camera view.
Add Peg % button.

¥ T Moon Y
+43 stars [1&=
+49 oy [ =

+ 7 camera-p &=
L & camera &=

You can animate the camera in the Camera view by using the Translate tool available in the Advanced

Animation toolbar.
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Have you seen our tricks?

Whether you're a novice or an v
expert, all users will benefit from

our free articles available in the .
elLearning section of our website.

Visit our website and learn about
subjects such as:

Rigging

How to Make a Camera or Object Shake
Sunrise Sunset

Lens Flare FX Template

Storyboarding Without a Pencil

Importing a Final Draft Script in Storyboard
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Chapter 11 Sound and Lip-Sync

Adding lip-sync to a project can really enhance its
quality and storytelling. But animating a lip-sync can
often be tricky. In Toon Boom Animate there are many
useful features available to help you complete this task
quickly and efficiently.

You can lip-sync the traditional way or let the system
automatically create the basic detection.

You can use your own lip-sync ready cut-out character
and sound file or use the ones provided to you in the
sample material package.

The topics are:
e Importing a Sound
¢ Decoding your Sound
* Assigning the Mouth Shapes
e Swapping Mouths
¢ Playing Back and Exporting

The following sample material is located in the Animate
Library of your operating system*:

e  Undone_example_Sample_material >
Chapter11_Sample_material.tpl

° Mac
/Applications/Toon Boom Animate 2/
Templates/Samples/ SuperHero_Soundtracks

e  Windows XP
C:\Documents and Settings\All Users\
Documents\Toon Boom Animation\Toon Boom
Animate 2\Templates\Samples\SuperHero_
Soundtracks

e  Windows Vistaand 7
C:\Users\Public\Documents\Toon Boom
Animation\Toon Boom Animate 2\Templates\
Samples\SuperHero_Soundtracks

* For Animate Pro, browse for Toon Boom Animate Pro 2 rather than Toon Boom Animate 2. 125



Importing a Sound

p—

The first step in lip-synching an animation is importing the
dialogue into your scene. The dialogue is a sound file
which only contains your character’s voice. It is important
to only have the sound of the voice in this file as it will be
the only sound which the lip-sync process will detect. In
this example, the dialogue we will use is
cartoon_monster-01.wav.

1.
2.

Select File > Import > Sound.
In the Select Sound File browser, select your sound
file* and click on the OK button.

J | animation hero, way

J'| cartoon monster 01.wav

|4 save the world UL.wav

The sound layer will appear in the Timeline view and be
displayed as a waveform. You can play your sound in the
Timeline view and Sound Editor.

In the Timeline view, double-click on the sound layer
to open the Sound Editor.
In the Sound Editor, press on the Play (#) button to

listen to your sound.

D Ll |4 | - |8 | - |12I Ll |1BI Ll |2DI Ll |24I Ll |28I

1

_—
-

£ ] 1l | [ >

Start Frame 1 \!1 GI k. @\!’ \?I @ Stop Frame 1

* Refer to the previous page for the complete sample material paths.
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Decoding your Sound

Sound Element

0 4 a 12

Auto Lip-Sync Detection

Delete Soun r\(f: =/ (K:_}; (Ri.y W
<] E EK-T CF:J W EK*/

G

Start Frame 1 Qﬂ \:ﬂ \.\!F \Fl \_D Stop Frame 51

A great way to determine the timing of the mouth
animation is to use the Auto Lip-Sync Detection feature. It
automatically detects each phoneme and assigns a mouth
shape toit.
1. Inthe Sound Editor, right-click (Windows) or
[Ctrl]+Click (Mac OS X) in the Sound Element space
and select Auto Lip-Sync Detection.

2. Presson the Play (® button to view the result in the

preview space.
An X mouth shape appears when no sound has been
detected for a frame.

o)

%‘—_:—

You can also detect your sound or fine tune the automated
detection using the Sound Scrubbing feature. This feature
lets you scroll through the character’s voice waveform in
the Timeline view and listen to the sound one frame at a
time.

1. In the Playback toolbar, click on the
Sound Scrubbing s button.

L

2. Inthe Timeline view, click and drag the red marker
to scroll through the scene and scrub the sound.

Read the Swapping Mouths topic to learn how to assign
your mouth shapes as you decode your sound manually.

Refer to the Animate User Guide to learn more about the Auto Lip-Sync Detection and Sound Scrubbing

features.
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Assigning the Mouth Shapes

A/ B/ cC
| e
D/ cE F

The automatic
detection supports
seven sound mouth

shapes and one
silent mouth shape.

Now it is time to assign the detected mouth shape to your

actual character mouth shapes layer.

1. Inthe Timeline view's
right side, right-click __
(Windows) or [Ctrl]+Click esination Layer | mauihs shapes|v])
(Mac OS X) on the sound Symbals in Layer: | Don't use any s
layer and select epene

Lip-Sync > Map Lip- A \

Source Layer : cartoon_monster-01

Sync. B | B
2. Inthe Mapping Lip-Sync el
dialog box, choose the
layer that contains your o
character’s mouths in the E|E
Destination Layer el
drop-down menu.
3. Inthe Mapping fields, e

enter the name of each of % \[x ),
your layer’s mouth shapes

drawing. In this example, the actual drawing
names, match the mouth shapes convention, so

there is no need to change it.
4. Press on the OK button.

The lip-sync timing is now all set in the Timeline view, in
the mouth_shapes layer.
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Swapping Mouths

You can use the drawing swap feature to time your lip-sync
from the start, or use it to quickly complete the

Auto Lip-Sync Detection and Map Lip-Sync results.

1. Inthe Timeline view, click on the Expand 4¢ button

to display the Data view.

R a—
} cartoon_rnonsker_1 ——— i ———
+ 4 head Oa s 1
49 mouths_shapes D U = ( Q"i’
+ 43 bady Oa =

2. Inthe Timeline view, select the cell containing the
mouth shape you want to swap.

3. Inthe Data view space, place your cursor on top of
the drawing name until it changes to the swapping
pointer, and choose the mouth shape you want to
expose.

You can also use the Drawing Substitution panel to swap
drawings.

Drrawing Substitution

#

mouths_z| n}

1. Inthe Timeline view, select the cell containing the
mouth shape you want to swap.

2. Inthe Library view, in the Drawing Substitution
space, click and drag the slider to choose the
desired mouth shape. This automatically swaps the
current drawing for the one displayed in the preview
window. You can also use the default keyboard
shortcuts[[]or[]].

Refer to the Animate User Guide to learn more about swapping drawings.
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Playing Back and Exporting Super o e

File Edt Wiew Window Help

O LY

ookl T

To export a QuickTime movie:

Now it is time to playback the result and export the 1. Select File > Export > Movie.
finished animation to a QuickTime movie file. 2. Inthe Export to QuickTime movie dialog box, click
on the Browse button to name the movie and select
1. Inthe Playback toolbar, click on the where you want to save the file.
Enable Sound @) button. This will let you hear the 3. Select either a specific frame range or the entire

animation to export.
4. You can also set the Video and Sound options as
required.
and view your animation in the Camera view. 5. Click on the OK button to export your animation to
a QuickTime format.

sound of your scene during playback.
2. Inthe Playback toolbar, click on the Play #®/ button

Refer to the Animate User Guide to learn more about export options and parameters.
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Chapter 12 Morphing a Flag

Toon Boom Animate has more than one tool to help
you animate efficiently. When doing hand-drawn
animation, you will spend most of your time creating
in-between drawings.

For a simple animation such as a flag, splashing water,
smoke or even hair, you can use the Morphing feature
to let the system automatically create
the drawings

between your keys!

You can create

your own

drawings or use a

project from the

sample material package.

The topics are:
e Preparing Your Morphing Keys
¢ Creating the Morphing

Sequences
e Adjusting the
Ease
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Preparing Your Morphing Keys

The Morphing feature can be used to create computer
generated drawings between simple shapes. Your
drawings can have outlines or not. It is up to you!

Your key drawings have to follow these basic rules:

Drawings must be painted with the same colour
swatches.

Drawings must have the same number of zones.
If a colour zone does not exist in one of the two key
drawings, it will progressively appear or vanish.

Drawings must be flattened.

A contour line (fill) must be morphed with a
contour line, and a centre line (pencil) must be
morphed with a pencil line.

You can have several colours in a morphing key.
You cannot morph colour tints.

To create your first morphing sequence, try using simple
shapes without an outline. Once you master the feature,
you can experiment as much as you want.

A When you animate effects such as smoke, think of using the Morphing feature to create your in-betweens. It

has the advantage of being reusable and you can change the timing to create longer or shorter animations.
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To morph the flag, first draw three keyposes and set their
approximate timing. Note, once your morphing sequence
is done you can always increase or decrease your timing.
We added a flagpole layer. You can do the same.
1. Inthe Timeline view, add a drawing layer and name
it "Flag”.

2. Inthe Tools toolbar, select the Brush & tool. ST
. . -1 T T T T T T T )
3. Inthe Colour view, select a solid colour. 3 o o e e @ Padial
4. Inthe Camera view, draw your first flag. Once your are done creating your key drawings, you can
5. Inthe Tools toolbar, select the Paint @& tool and transform your solid colour into a gradient to make the flag
paint your flag using the same colour. even more interesting. You can then add several gradient
6. Inthe Tools toolbar, select the Select (% tool. arrows to simulate highlights and shadows.
In the Camera view, select your entire flag From the Tools toolbar, use the Edit Gradient/Texture
8. Inthe Tools Properties view, click on the Flatten (& tool to reposition your gradient zones the way you want.
button. . ) '
9. Repeat the same steps for the two other flag 10. Copy your first key drawing and paste it at frame 30.
drawings. Create your drawings on frames 10 and
20.

If you set two different gradient positions on your key drawings with the Edit Gradient/Texture tool the

position will be interpolated during the morphing sequence.
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Creating the Morphing Sequences

W v o B G Hp
+49 pole []& = ™N
= Das(‘g il TN

You are now ready to create your first morphing sequence!
1. Inthe Timeline view, select your first key drawing.
2. Right-click (Windows) or [Ctrl] + click (Mac OS) and
select Morphing > Create Morphing.
3. Repeat the process for each key drawing.
You now have three morphing sequence.
4. Inthe Playback toolbar, press the Play (#®/ button to

see the result.

As you probably noticed, there are in-between drawings,
but they are not necessarily going the way you want. Your
flag probably looks like a piece of cardboard bending
instead of smoothly flapping in the wind. Also, it is most
likely that you will have strange corners and points.

All that is because the system is always looking for the
closest similar line, corner or curve to morph the drawing.

To fix random
results like this
one, you will place
morphing hints
along the flag's
contours.

To fix a morphing sequence, you need to control its
behaviour with Morphing Hint points. Hint points associate
areas from the key drawings together so that the system
knows how to control the drawings.

You can control different aspects of your animation. Here,
we will focus on controlling the contour using Contour Hint
points.

When fixing a morphing sequence, you will add points all
across the screen. This is done progressively. To fix the
flag, will take you three passes:

e Blocking the corners
¢ Animating the wind waves
e Fixing the remaining details

The Hint points tell the system how to animate your drawings. It is almost like telling your assistant animator

what to do.
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When you add points on the corners and tips, you will see
that most of the shape problems are resolved. Fixing one
big problem will often fix all the small ones.

No

In the Tools toolbar, select the Morphing @ tool.

In the Timeline view, select the first key drawing.
In the Tool Properties, select the Contour Hint &%

option.

In the Camera view, click in the screen to add a new
Contour hint.

Select the hint point and drag it toward the flag’s
contour until it snaps.

Position the hint on a corner to lock it in place.
Repeat these steps for all of the corners.

Press [F4] to switch to the other key drawing.

9. Select the existing hint points and snap them to the

corresponding corners.

0

= 3
e

3
i

i .10

10. In the first and second key drawings, associate the

wind waves so that it will slide to the right instead of
up and down.

After fixing the corners and waves, there should only be a
few details left to fix.
11. Set your hint points on the other morphing

sequence in the same way you did for the first one.

A A morphing sequence is composed of two drawings. If you have more than one morphing sequence, you will

need to set hint points for each sequence. If a drawing is used in two sequence, it will have two sets of hints.
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This hint point associates these
two waves together. It makes the

This hint point associates these
two corners together and locks
the flag’s corner on the spot

instead of having it wrap around. \*<

wave slide from left to right
- instead of going up and down as
Il E it was originally doing.

P

[N

First set your hint points in the corners and intersections. Use the many types of hint points to control

different aspects of your morphing sequence. Refer to the Animate User Guide to find out more.
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Adjusting the Ease
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1. Inthe Tools toolbar, select the Morphing i tool.

_ 2. Inthe Timeline view, select the first key drawing.
Once your morphing sequence is completed, you can 3. Inthe Tool Properties view, set the Ease In and Ease
adjust the ease so that your animation does not look too Out values by clicking on the Increase and Decrease
mechanical.

arrows.

You are now ready to explore the Morphing capabilities!

If you are morphing a drawing with holes, such as a donut, you need to enable the Flatten option in the

Morphing tool’s Tool Properties view.
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Chapter 13 Creating Effects (Animate Only)

In Toon Boom Animate, there are many effects you can
easily use to improve the quality of a project.

In this chapter you will use two of these effectsin a
production-like context to enhance your scene.
You can practice these effects on material you create
from scratch or you can also use the sample material:
e Undone_example_Sample_material >
Chapter13_Sample_material.tpl

The topics are:

e Painting a Starry Sky

e Making your Stars Glow

e Fading your Stars

¢ Lighting Up the Lampposts

e Making it Shine in the Night

¢ Keeping Your Distance

® Preparing to Hit the Switch

e Hitting the Switch

® Shooting Star

e Putting On a Mask

e Editing the Mask

This chapter does NOT apply to Animate Pro. Refer to the Animate Pro Getting Started Guide to learn how to

create effects in Animate Pro, using the exclusive Network view.
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Painting a Starry Sky

To build a starry night effect, we first need a layer of stars. 6

In Animate, select a star-shaped brush, pick a star-like
colour, and draw stars on a new drawing layer!
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In the Timeline view, click on the Add Layers (+,

button to add a Drawing layer on top of your
background.

Name the new layer Stars and click on its first cell.
In the Tools toolbar, select the Brush & tool.

In the Tool Properties view, select a star shaped tip
and customize the minimum and maximum size
values so that you have a range of star sizes when
you draw with your pen tablet.

Options

EISrArA=

[v] & @ A
~ 2 +
A =

In the Colour view, pick a star-like colour.
In the Camera view, draw your stars.

i Brush 1

: Refer to the Animate User Guide to learn more about the Tools Properties.



Making your Stars GIOW To make your stars glow:
1. Inthe Timeline view, right-click (Windows) or

[Ctrl]+Click (Mac OS X) on the Stars layer and select
Duplicate Selected Elements.

Rename the new layer Stars_Matte.

3. Click onthe Add Layers (+) button and select

Effect > Glow.
4. Click and drag the

N

W v e B G
Star_Matte layer on aEr &=
the Glow effect Bt G —
|ayer. ‘ L + 49 stars_Mante e =
+45 &g =
Now that you have stars in your project, it is time to make 5. Inthe Timeline view, double-click on the Glow layer
them shine! to display the Layer Properties dialog box.
. . ) lur Type adial
As you customize your effects, you can preview the final Colour éﬁ:p :Sd ! - ,r'[\:]
result in the Camera view. Red 255 -
1. Inthe Camera view bottom toolbar, click on the Green =5 w8
Render @ mode button. Blue 25 w82
. . . Alpha 255 a (T
2. To update the preview, click on the Update Preview i

D button.

6. Set the Blur Radius value.
7. Pick a colour and alpha value. Double-click on the
colour swatch to display the Colour Picker.

I You can enable the Auto Render preview option by clicking and holding the Update preview button in the

Camera view bottom toolbar and selecting Auto Render.
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Fading your Stars

Now that your sky is glowing with stars, you might want to
soften them a bit. Try adding a Transparency effect on your
Star layer.

1. Inthe Timeline view, click on the Add Layers (+)

button and select Effect > Transparency.
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2.

In the Timeline view, click and drag the Stars layer
on the Transparency effect layer to connect it.

W% e &G
,Erv =+ Transparency \

v] L + 49 stars J

S5 Glow

L =+ 49 stars_Mane

+43 g
In the Timeline view, double-click on the
Transparency layer to modify the transparency value
of your layer.

Enable/Disable . =

Marne: Transparency

@parency )

D

Display the result in the Camera view using the

Render @ mode.




Lighting Up the Lampposts

Lighting up the lampposts is as easy as making the stars
shine. But first, you have to create a lamp layer from the
background layer.

»

In the Timeline view, select the Bg layer’s first cell.
In the Tools toolbar, select the Select (% tool.

In the Camera view, make sure that you are in Open

GL @8 mode and select the light bulb zones of the

two lampposts. Press [Shift]+Click as you select the
zones to create a multi-selection.

Press the default keyboard shortcut [F9] (Windows)
or [#8]+[F9] (Mac OS X) to Create Drawing from
Drawing Selection.

Name your new layer 1ight_matte.

In the Timeline view toolbar, use the Add Layers i
button to create a new glow effect layer.

In the Timeline view, connect the light_matte layer
under the glow layer and customize the effect.

. Verify the result in the Camera view, using the

Render @ mode.

B You can make a multi-selection using the [Shift] key while clicking on your objects in the Camera and Drawing

view using the Select tool.
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Making it Shine in the Night

Adding a halo around the lampposts and a highlight on
the statue is an easy and effective way to enhance the
glow effect and integrate all of the elements in the scene.

In the Timeline view toolbar, use the Add Layers &+

button to create a new drawing layer.

Name this new layer Lamp_Highlight matte.
In the Timeline view, select the first cell of the new
layer.

In the Tools toolbar, select the Ellipse (&) tool.

In the Tool Properties view, enable the Auto Fill (&

mode.

In the Colour view, select any colour.

In the Camera view, trace a large ellipse around the
lamp area. This shape will become your halo.

In the Timeline view, click on the Add Layers =

button and select Effect > Highlight.

B Refer to the Animate User Guide to learn more about the different effects available in

Toon Boom Animate.
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The Highlight layer, unlike the Glow effect, will only affect
particular layers. This means you need to connect the mask
as well as the layer it will affect. In this case, it will be the

Bg layer.
[ <" Highlight
L Sl Mask
‘ 45 Lamp_Highlight_matte

T~ +498g

1. Inthe Timeline view, click and drag the Lamp_
Highlight_matte layer on to the Mask of the
Highlight effect layer and click and drag the bg layer
onto the Highlight.

2. Aswith the Glow effects, in the Timeline view,
double-click on the Highlight layer to customize it.

3. Inthe Camera view, verify the result using the

Render ## mode.

The statue highlight effect will follow similar steps.
1. Inthe Timeline view toolbar, use the Add Layers =

B EkRDBE
(0N ] 00 [ (0| (00

button to create a new drawing layer.

Name this new layer Statue_Highlight matte.

3. Inthe Timeline view, select the first cell of the new
layer.

N

the highlight zones.

the Add Layers = button

In the Tools toolbar, select the
Brush & tool.

In the Camera view, paint

In the Timeline view, click on

and select Effect >
Highlight.

In the Timeline view,
click and drag the
Statue_Highlight_matte
layer on to the Mask of the
Highlight effect layer and
click and drag the Statue layer
onto the Highlight.

In the Timeline view, double-
click on the Highlight layer to
customize it.

In the Camera view, verify the result
using the Render % mode.

A When painting a highlight zone, you do not need to worry about other layers as the highlight effect will only

affect the layer you decide to connect into it.
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Keeping Your Distance
1. Inthe Timeline view toolbar, click on the Add Layers

&+ button and select Effect > Blur.

2. Inthe Timeline view, click and drag the Ol layer onto
the Blur effect layer.
@ % o &G
4+ Blur
L 4480
3. Inthe Timeline view, double click on the Blur layer to
customize the Radius value of the effect.

Layer Properties |:|
[] EnableiDisable . =
Mame:  Blur
Truck Factor_[v]
Lkadius 19.3 )J’ @
Cuuality High [v]
A good way to increase a depth illusion is by having an 4. Inthe Camera view, verify the result using the
overlay which is out-of-focus. In this example we will be Render @ mode.

hiding behind a broken structure.
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Preparing to Hit the Switch

All these effects can be animated over time. For this
example, we will progressively light up the lampposts
making their glow, halo and the statue's highlight
gradually appear. Now, let us prepare this nice effect.

= 41t Transparency = 4+t Highlight

L S 5y Glow_2 LS (2] Mask

5 449 Light_Matte L 57 4% Transparency_2

5 = 43 Lamp_Highlight_rmatte

1. Inthe Timeline view, use the Add Layers = button

to add three Transparency effect layers.

2. Inthe Timeline view, connect the lamppost’'s Glow
layer into one of the Transparency layers.

3. Connect the matte shape layers of the two Highlight
effects into the two remaining Transparency layers.

With these Transparency layers you will create a fade in
effect, making the scene go from lights out to lights on.
Now we need to extend the scene so that we can animate
the effects.
1. Inthe Timeline view, make a multi-selection of all of
your layers' last cell of the scene using [Shift]+Click.
2. Press[F5]to extend the exposure.

40 =) [ 7

\{

Refer to the Animate User Guide to learn more about keyframes and functions.
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Hitting the Switch

Now is the time to create a function and enter the
keyframes that will animate the Transparency effects and
gradually light up your scene.

In the Timeline view, click on the Expand 4t button

to display the Data view.

@ G (4p)——
" 45" Transparency =

L =% Glow 2 a =

L =+ 49 Light_Matte l:l =48

In the Timeline view, click on the Transparency layer
Expand <4 button to display the Transparency'’s

function.
@t 0BG I
x—).‘? Transparency as
= - Transparency + dr
L S 45 alow 2 as
L + 49 Light_Matte D =M1

Make sure that your timeline marker is on the first
cell, click on the Add Keyframe + button and enter

the first Transparency value. This keyframe should
be set to 100 so that the lights are out.

$d- %6 & N
" =<7 Transparency as -

- Transparency — - 10 g
LS fiichwe @ =] b ?

You can create a hold at the start and end of your scene by adding two more keyframes on your timeline. One

of equal value to the first one of your scene and another one of equal value of the one at the end.
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4. Move the timeline marker to the last frame of your
scene and press the Add Keyframe + button and

enter the last transparency value. This value should
be set to 0 (zero) to light up the scene completely.

= [ '
-

4§
S
)

5. Repeat Step 1 to Step 4 for the other two
Transparency layers.

Follow these simple steps to preview your animated effect.

1. Inthe Playback toolbar, click on the
Render and Playi®) button.
Your frames will be calculated and the Play view
will pop up.
2. Inthe Play view, press on the Play (®/ button and

enjoy your scene!

D Refer to the Animate User Guide to learn more about the Play view and previewing your scene as well as

exporting your scene.
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Shooting Star

P L |
S
| NN
Yy

Now, to make things more interesting, let’s add a shooting
star flying across the heavens. Use the collapsed layer
Shooting_Star which we have provided.

» Inthe Timeline view, enable the
Shooting_Star layer and drag it between the
bg and the statue layers.

L 49 Statue_Highlight_Matte
|\ 49 Shaating_Star

S = Highlight A

L 4498

LS () mask

To animate the shooting star:
1. In the Tools toolbar, click on the Animate & button

and then click on the Transform I Tool button.

2. Inthe Timeline view, click on the first cell of the
Shooting_Star layer.

3. Inthe Camera view, click and drag the shooting star
to its first position on the extreme left, outside of
the camera frame.

4. Inthe Timeline view, click on the last cell of the
Shooting_Star layer.

5. Inthe Camera view, click and drag the shooting star
across the screen, ending at it's final position.

ol

The system will automatically create the motion between

the two keyframe positions.
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The shooting star now moves at a constant speed along To add a velocity effect.

the straight line from point A to point B. To add a curve 1. Inthe Timeline view, click on the Expand 4k button
and a velocity effect, follow these steps.

to display the Data view.
2. Inthe Timeline view, click on the Expand Arrow |-

and Expand 4 buttons of the Shooting_Star layer
to display its functions.

@. J Shooting_Star

" — 49 Shooting_Star

| > < Offset: Yelocity )

Sealar v

To add a curve to the animation:
In the Timeline view, select the Shooting_Star layer.
2. Select View > Show > Control to display the
trajectory. P
3. Inthe Camera view, position your cursor over the T — ( 9
trajectory and press [P] to add a control point.
4. Inthe Camera view, click and drag the new control
point to create a curve.

4. In the Velocity Editor dialog box, click on the last
keyframe and drag the handle toward the centre to

create a velocity curve.

3. Inthe Timeline view, double-click on the Offset
Velocity function of the shooting star layer.
The Velocity Editor dialog box opens.
a 1 2 _ 3‘ A

—_

5. Inthe Coordinate and Control Point view, adjust the
Tension and Continuity values to adjust your
trajectory’s curve.

By default, the preferences are set to Motion Keyframes, this means that the system will automatically create

the motion between the two keyframes of the shooting star.
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Putting On a Mask

1. Inthe Timeline view, enable the Lamp_Mask layer
and drag it on top of the Shooting_Star layer.

L 574+ Transparency
L 49 Statue_Highlight_Matte
A5 Lamp_Mask

|\ 49 Shaating_Star ‘k
= 4+ Highlight
L 4498

2. Inthe Timeline view toolbar, click on the Add Layers
=+ button and select Mask.

3. Inthe Timeline view, drag the Lamp_Mask layer
onto the Mask’s matte layer to connectit to it.

S5 Mask

LS (2] mask > S >
@ ~+ 49 Lamp_Mazk

4. Inthe Timeline view, connect your Shooting_Star
layer under the Mask top layer.

-

Now the shooting star is all set, only one thing is left to do.
Since the lampposts are part of the bg layer, the star

cannot pass behind them. For this reason, we will add a S Mask
. L. . L "
mask layer and drawing that will hide the shooting star S G vask
hen'i inf fihe | .. he illusi L 4 Lamp Mazk
when it passes in front of the lampposts, giving the illusion @I\ prpv——

of passing behind. For this lesson, a matte drawing of the

| ) . The shooting star will now cross the screen behind the two
ampposts is provided for you.

lampposts!

Refer to the Animate User Guide to learn more about Trajectories, Control Points and the Velocity Editor.
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Editing the Mask

1. Inthe Timeline view, select the Mask Effect layer.

S5 Mask D)

| L G Mkt
L ~+ 49 Lamp_Mazk
L [~ =449 shooting_star
2. Select View > Show > Control.
This will automatically render your drawing visible
in the Camera view. It will be displayed on top of
all other layers, making the editing easy to do.

EE|[E<

Once a matte drawing layer is connected to a mask effect 3. Inthe Tools toolbar, select the drawing tools you
the drawing will become invisible in the Camera view, as it need.

will automatically be applied as a mask. If you need to edit 4. Inthe Camera view, edit your matte drawing.
your matte drawing after you create your connections in 5. Select View > Show > Control to hide the matte
the Timeline view, you can easily make your drawing visible drawing and return to the normal display of your
without breaking the connections. scene.

Refer to the Animate User Guide to learn more about Mask and Effects.

Creating Effects (Animate Only) - Editing the Mask 153



It's cartoon animation showtime!

We have the best customers
in the world. You can
check for yourself.

Our web showcase screens
the best of their cartoon
production and much more,
from professionnal tips

and tricks to case studies.

Get some popcorn, get
comfortable and press
that fullscreen button.

FEATURED ARTIST

NOW SHOWING

I Trdk of Trick

. Decong
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Chapter 1 Introduction

The Toon Boom Animate Pro Starting Guide guide builds on the
content included in the Toon Boom Animate Starting Guide. This
guide contains supplementary information about

Toon Boom Animate Pro’s specific features. Together, they form the
absolute kick start guide, covering all the basics of this software that
you need to get started on your own projects with
Animate Pro.

Before starting these lessons, it is highly recommended that
you complete the lessons in the Toon Boom Animate Getting
Starting Guide first.

Discover the basics of Animate Pro’s key features through
three new lessons. Use the sample material provided or if
you prefer, use your own. The sample material will help you
follow the different exercises contained in this guide.

To install the sample material provided, simply follow the
installation instructions at the end of this chapter:
e Sample material setup guide
or download them from our website at:
¢  toonboom.com/products/animatepro/elLearning/

The keyboard shortcuts used in this guide are based on the
Adobe®Flash® shortcut set.

Get ready to Animate Pro!


http://www.toonboom.com/products/animatepro/eLearning/

Your Training Outline

Getready! Let's take a first glance at this Starting Guide's training
outline.

Chapter 2 From Sketching Table to Animate Pro

Learn the different ways to add and use textures in your project,
an easy way to enhance its look and quality.

Chapter 3 Going 3D

Unleash Animate’s power by creating a full 3D decor. Rotate your
layers on all axis and get your camera to pivot on a 360 degree
trajectory.

Chapter 4 Building a Cut-out Puppet Using the
Network View

Learn how you can easily take your cut-out puppet and rig it inside
the Network view.

Chapter 5 Compositing

Learn how to use the Network view to enhance the quality of your
projects by compositing effects from the effect modules contained
in the Module Library view.

Refer to Toon Boom Animate Getting Started Guide to obtain the complete Training Outline.

4 - Toon Boom Animate Pro Getting Started Guide



What's Extra in Animate Pro?

Animate Pro is the professional version of Toon Boom Animate. In Animate Pro you will find many exciting and powerful
new tools as well as all the features from Animate, making your life even easier and allowing you to create with style!

These are an highlight of the top features you will find in Animate Pro :

e Advanced Compositing
Using the Network and Module Library views, you
can create complex effects and advanced puppet
rigging.

¢ Line Texture
Using the Brush tool, you can sketch and design
with textured brush styles. You can even create
your own pencil-bank by creating a set of bitmap
textures in a third-party software.

¢ Advanced Traditional Animation Features
Using features such as Multiple Drawing Layers
and Annotation Columns, you can complete your
hand-drawn animations with ease while feeling at
home with tools you are familiar with.

Full 3D Rotation

You can enable the 3D rotation on your elements
and camera to pivot them on all 3 axis, creating a
3D set where you can animate your characters and
amazing camera moves.

More Effects

You can find many more effects in the Module
Library, such as the Refract, Glue and Sparkle.
Multiple Renders

Because of its Network view and node system,
Animate Pro allows you to render out different
resolution, formats and portions of your scenes
simultaneously.

Refer to Toon Boom Animate Getting Started Guide to learn more about Interface Highlights.

Introduction - What's Extra in Animate Pro? - 5



Network View Legend

The Network view is the main view used to composite the
scene'’s components, special effects and rig cut-out
characters.

Refer to the following legend to learn about the Network
view.

Note: The numbers in this legend correspond to the
numbers in the Network view on the following page.

1. Network Main View:
This is where you drag in, organize and connect the
different modules in your scene.

2. Main Modules:

. _ Drawing Layer
. _ Effect

o %I Display

o _ Write

. @,

o [2r Composte | Composite

6 - Toon Boom Animate Pro Getting Started Guide

Refer to Toon Boom Animate User Guide to learn more about the Network view.

3. Module In and Out Ports:

In port

Out port

The input and output ports are used to connect
modules. Simply click and drag one port to another
portand a connection is created.

Navigator:

This is a smaller version of your Network view. Use
this to zoom in, zoom out and pan to navigate
through your network.

Note that because they are created using the
Timeline view, effects previously created using
Animate will be displayed as orange group modules
when in Animate Pro. This way it is easy to quickly
identify them.

—
||:| b Glow Stas ™ |




"B @rTop @ / X @\_/ Network |;\-y;

Q- Display

Introduction - Network View Legend - 7



Sample material setup guide

Templates and sample files will be required for some of the
lessons in the Getting Started Guide. You must first install
them, then follow steps to use them in your project.

Step-by-step installation

1. Go to the following web page:
toonboom.com/products/animatepro/elLearning/

2. Inthe Tutorials section download the Sample
Material package.

3. Once the package is downloaded, double-click on it
to launch it.

4. Follow the installer’s instructions.

To use the templates

1.
2.
3.

To use the templates:

Launch Toon Boom Animate Pro.
Create a new blank project.
In the Library view, click on one of the following
folders to view the sample material content:

» Templates

» Templates > Undone_example_Sample_

material

» Templates > Completed_examples
Select a template from the right-hand side of the
Library view.
Click and drag that template to the left-hand side of
the Timeline view and drop it where the layers are
ordered. You can also drop it directly in the Camera
view.

The template now appears in both the Timeline

and Camera views and is ready to be animated!

8 - Toon Boom Animate Pro Getting Started Guide
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Files in the Library view
Here are the types of files you will find in the templates
folder:

e Undone_example_Sample_material
Prepared scenes to be completed during
lessons in the Getting Started Guide.

e  Completed_examples
The resulting scene files for completed
lessons in the Getting Started Guide.

e Templates
Various elements that can be used to
completed some of the lessons in the
Getting Started Guide.

Extra sample material
You will need to browse and import some extra files from
the following location:

e Mac: /Applications/Toon Boom Animate Pro 2/
Templates/Samples

e Windows XP: C:\Documents and Settings\All
Users\Documents\Toon Boom Animation\Toon
Boom Animate Pro 2\Templates\Samples

. Windows Vista and 7: C:\Users\Public\
Documents\Toon Boom Animation\Toon Boom
Animate Pro 2\Templates\Samples

Files for Animate chapters 3,5 and 11:
e background_tv.psd
. SuperHero_Soundtracks (3 sound clips)
° Textures (16 examples)

Files for Animate Pro chapter 2:
e Multi-layerd_Monster.psd
*  monster_drawing.png

Introduction - Sample material setup guide - 9



toonboom.com/pencilcheckpro/

Capture the motion

Developed for the most prestigious and demanding studios,
Pencil Check Pro provides an extensive feature set designed
around a user friendly interface. Pencil Check Pro is the
classic animators’ best friend, sitting next to the animation
table for fast and accurate line tests.

Create and preview the line test movie with synchronized sound, in real-time

Fill the exposure sheet using industry standard tools and the audio waveform display
Annotate and draw directly in the exposure sheet column using the pen tool
Animate camera motion with pencil drawing composited on top of a background

-
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Chapter 2 From Sketching Table
to Animate Pro

Are you a pencil and paper lover? Animate Pro lets you
scan and import your sketches, draw directly in the
application using textured lines, bring in your colourful
illustrations and keep your bitmap colours as well as fully
vectorizing your cleaned up drawings.

You can play around with textures, vector and bitmap graphics to
get the high quality look you are wishing for.

To go through this lesson, you can use the bitmap images provided s
in the sample material package or scan your own sketches. You will P
also find a full page illustration to scan included in this chapter. é;r

In the provided sample material, you can find the
monster_drawing.png and the Multi-layered_Monster.psd in the
following folder:

° Mac: /Applications/Toon Boom Animate Pro 2/
Templates/Samples

e Windows XP: C:\Documents and Settings\All Users\
Documents\Toon Boom Animation\Toon Boom
Animate Pro 2\Templates\Samples

. Windows Vista and 7: C:\Users\Public\Documents\
Toon Boom Animation\Toon Boom Animate Pro 2\
Templates\Samples

The Topics are:
e Monster Scanning
® Scanning Process
e Pencils and Crayons in Animate Pro
e Colours as Textures



Monster Scanning

One of the first techniques you can use to get your
drawings into Animate Pro is to scan them using a TWAIN
device. You can adjust the import settings to match the
style you are looking for.
Follow these main steps to get your sketches into
Animate Pro:
e Make sure a TWAIN device is installed on your
computer and working correctly.
* In Animate Pro, create a new project or open the
scene where you want to import your artwork.
e Scan your drawings.
e Set the vectorization parameters.
¢ Import your images.
You can scan the monster drawing included on the
following page and follow the next steps in this lesson.
(We have also included a digital version of this image in the
sample material package). Or you can scan one of your

own designs, try to find a drawing with a few rough lines
where you see the pencil texture.

Once a TWAIN scanner is installed on your computer, Animate Pro will detect it automatically and add it to the

TWAIN Source list.

12 - Toon Boom Animate Pro Getting Started Guide






Scanning Process

To scan your drawings, make sure your scanner is
connected and you are ready to go!

Scan Drawings

Scanner

To scan your drawings:
1. Inthe Top Menu, select File > Import > From
Scanner.

- CanoScan LIDE 60 [v] ’ Scan... ] ’Show Scanner Album...]

Scanneditages: 1

The Scan Drawings dialog box opens. Layer
2. Inthe Scanner section, select your scanner from the 3p-(3) Create Layerfs)
“St Mame: |myMonster
3. Click on the Scan button to begin the scanning O Addto Bdsting Layer: Drawing [v]

process using the scanner’s interface. LBt Vectorize Acquired ftems

Create Symbol for Acquired tems

® 00

File Format: TVG

Vectorization

Name
Black and White
Colour

> Grey

Q

Refer to the Toon Boom Animate User Guide to learn how to create your own vectorization parameter presets.
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4. Once the scan is completed, the Scanner Album
opens to let you organize the scanned images.

5. Inthe Scan Drawings window, enable the Create
Layer(s) option and name your new layer in the
Name field.

6. Make sure the Vectorize Imported Items option is
enabled. You can also disable the Create Symbol for
the Imported Items option if you do not want the

new layer to be encapsulated in a Symbol. £, {
7. To keep the pencil line's texture, select the Grey (

default vectorization parameters. i
8. Click on the OK button and let the system import -

and vectorize your images. This is the greyscale vectorization result in Animate Pro.

In the Scan Drawings interface, you can click on the Show Scanner Album button to return to the Scanner

Album window.

From Sketching Table to Animate Pro - Scanning Process - 15



Pencils and Crayons in Animate Pro
W “\ 9%

You do not necessarily need a scanner in Animate Pro to
play with texture. In fact, you can create your own set of
textured pens and draw with them directly in the
application.

These pens can be used to either correct imported
sketches or to draw artwork from scratch, straight in the
Camera view.

Animate Pro supplies you with a series of default texture

brushes or you can create your own in a third-party
software and then import them in the Tool Properties view.

The only requirement is that the image used as your
texture must be in either PSD or TGA file format.

1.
2.

@"._ Brush

Cptions.

e @<

Texturs 3

L

L

Brush 3

Brush 4

Brush §

Brush &

Texturs

Texturs 2

(1

Texture 3

L3

(

Texturs 4

e
* Texturs
——————
L A

To use a textured brush:
In the Tools toolbar, select the Brush & tool.
In the Tool Properties View, display the Brush
drop-down list and select one of the default

textured brushes.

In the Camera view, start drawing.

When you import a bitmap image as a pen texture, the colour in the image is not used. The Brush tool will use the

colour selected in the Colour view.
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'W‘wh » If you have a texture such as this and you
‘g_ s would like to use it to draw in

nh . Animate Pro, you can simply import it

. into your brush list and use it as a default

4‘? ey v, texture.

o N
Hal

e
@0 |+ £
@ ¢ @Mk

a*

a*

To import a texture in your brush list:
In the Tools toolbar, select the Brush & tool.
2. Inthe Tool Properties view, click on the Add Pen ¢
button.
3. Check the Enable Texture option.
4. Click on the Texture button to browse and select the
desired bitmap image. The image has to be a PSD
or a TGA file format.
In the Camera view, start drawing.
6. Inthe Tool Properties view, adjust the opacity,
hardness and texture size parameters.

=N

o

In the Sample material, you can use the monster structure
template provided to trace your own character over or you
can sketch your own.

In the Eraser Tool Properties view, you can enable the Use Blur Parameters option to create a feather when

erasing a textured line instead of having a straight cut.

From Sketching Table to Animate Pro - Pencils and Crayons in Animate Pro - 17



Colours as Textures

If you created illustrations and drawing pieces in a third-
party software such as Adobe® Photoshop®, you have two
options available when you import these images in
Animate Pro. You can either import them as bitmap images
or vectorize them using the Colour as Texture option.

If your image is to be used as a background or an overlay,
there is no need to vectorize them. Although, if you are
planning on building a photo puppet or using

Animate Pro’s drawing tools to modify the imported
artwork, vectorizing your images using the Colour as
Texture parameters will be quite useful.

Note: your image will remain a bitmap, but it will be
contained in a vector frame. This way, you can modify the
contours using the Contour Editor tool or draw over with
the Brush tool or even erase areas.

In the Sample Material package, you can find a complete
image of the same monster character as well as a multi-
layered PSD file containing its body divided into five main
pieces. You can use those to try out the colour
vectorization.

Once the pieces are imported, you can move on to the
next lesson to learn how you can connect them.

When creating bitmap pieces for a puppet in a third-party software, it is a good idea to create a feathered edge on

the articulations. This way, when you animate the puppet, the joints look much neater.

18 - Toon Boom Animate Pro Getting Started Guide



1. Inthe top menu, select File > Import > Images. Files
2. Inthe Import Drawings dialog box, click on the
. ! . es/Samples/Muttidayverd_Manster psd
Browse button and select the images to import. ®_’ - Ak £

3. Enable the Create Layer(s) and the Create Layer(s)

Based on Filename options to make a new layer with Layer
the same name as your file. 3 (&) Create Layerfs)
4. Make sure the Vectorize Imported Items and the () Create Single Layer Named:
Create Symbol for Imported Items options are
enabled. (#) Create Layer(s) Based on Filenames
5. Inthe Vectorization area, select the Colour option. ) Addto Bdsting Layer: Drawing
6. Click Oh the O_K bUttOI:]' . &*} Vectorize Imported kems
7. If yourimage is a multi-layer PSD file, the Multilayer A
Image Import Settings dialog box opens. Create Symbol for Imported fems
Multilayer Image Import Settings Vectarization
Some of the items you are importing contain multiple layers.
Please indicate how you wish these items to be imported: Name
Images to Load: All Layer Images £2 Black and White
Transparency Type: Straight v @-’ ‘Calour
Crey

8. Select the All Layer Images option and set the ¢t c

Transparency type to match the source file. [
9. Click on the OK button and let the system import @ > ok | ’ Cancel
and vectorize your images.

The Transparency type of the imported image is related to how the alpha channel in the source file was

® pre-multiplied with the background. Refer to the Toon Boom Animate User Guide to learn more about this.

From Sketching Table to Animate Pro - Colours as Textures - 19



toonboom.com/storyboardpro/

The power of dlgltal storyboarding

Toon Boom Storyboard Pro is a system for visual storytelling,
perfectly suited to traditional and paperless methods. Truly
completing the production pipeline, Storyboard Pro helps you
take an idea and translate it into a visual story that will become

a complete production, whether animated or live-action. 'y
Work like you always have, but faster and smarter while maximizing the >-5
benefits of working digitally N,
Create instant animatics as you work, in the same time it takes to storyboard <

Play back your storyboard in sync with audio
Enjoy interactive review and faster approval process

o &
o




Chapter 3 Going 3D

Toon Boom'’s technology has always been recognized for
its Multiplane feature. Now you can take this attribute one
step further by going 3D!

Learn how to build sets by rotating and repositioning
planes in three dimensional space. Apply textures,
patterns and gradients and see them mapped in
perspective onto your drawing objects. Discover how to
use a camera to explore the 3D area, including the use of
fully rotational pivots, as well as how to give the illusion of
3D by panning a multi-plane’s layers.

You can practice this chapter on material you create from
scratch or you can also use the sample material.

e  Undone_example_Sample_material >
Chapter3PRO_Sample_Material.tpl

The topics are:
e  Setting Up Your Workspace
e Building the Structure
e  Filming Your Set

e  Adding an Outdoor
Decor

21



Setting Up Your Workspace

In the Timeline view, take a moment to examine the layers

and to get an idea of what kind of movements you might
need to make to separate them.

You might be concerned that thinking in a 3D mindset will
be complicated. Never fear! In this lesson, we will take

you step by step on how to construct in and move through

this new frontier. It will occur to you that the floor, ceiling, left and right walls

When you open the sample scene and look at it in the need to rotate outwards at a 90 degree angle from the
Perspective view, it will look like the picture above, with all Back_Wall.
the layers flattened on the same x, y, z planes.

When you position elements in the 3D space, it is important to remember that your drawings are still 2D images. If

¥ you rotate the camera around them, they will still look like flat layers.
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The Side view allows you to see your scene’s elements
from the side and move them on the Y-axis and Z-axis.

To perform these operations, you will need the following

views:

>

Layer Properties View
Perspective View

Top View

Side View

In the top menu, select
Window > the desired window.

In the Layers Properties view, you will be able to set the

position co

ordinates and enable the 3D movements.

Layer Properties

-

FE

e

bl ]

vt [l

|

Enzble/Diszble
Mame: | Flood
Transformation

Enzble 30

Drawing

Adwvanced

0@

The Top view allows you to see your scene’s elements from
the top and move them on the X-axis and Z-axis.

- - N

Paosition

(O30 Path
() Asis
.:\r) Az

{2} Asis

(3)5=parat=

1225

O T
91
1

.

Animate Pro allows you to build very complex 3D sets. You could build an entire fortress or a spaceship as

® long as you plan out your different walls and pieces and reuse them in your different scenes.
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Building the Structure

At this point, you should have all the layers necessary to
build your 3D set. In this case, we have three walls, a
ceiling and a floor. Later on, we will also include an
outdoor background to see through the window.

By default, the 3D motions are disabled on your drawing
layers, this prevents you from accidentally rotating them

when you need your drawings to stay perfectly flat and
aligned with the camera. So, when you want to rotate

layers in the 3D space, you need to enable the 3D motions.

To enable the 3D motions:

Layer Properties | %R

[ Enzble/Diszble D@ &
Mame: | Flood

m| Drawing Acvanced

Eratle 31D

Paosition 3

Rotation
( (8) Quaternion (O)EBuler Angles

3 = .{' -

(30 Aais /A Sy

() Ao /A (A

(@) Aois /A Ay

Velocity NiA e

1. Inthe Timeline view, select the layer you want to

enable the 3D motion for.
2. Inthe Layer Properties view, check the Enable 3D

option.
You will notice a series of changes in the Layer Properties
view, mainly regarding the Rotation section. You now have
the Quaternion and the Euler Angles options.

If you are unsure of what the width and height of your drawings should be, you can always go back in the Drawing

view after the setup is done and correct your drawing to match the layout better.
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There is a substantial difference between the Quaternion
and Euler Angles options. They will not be covered in this
guide. Refer to the Animate User Guide to learn more
about those.

To give you a basic idea, you will mainly use the
Quaternion rotation when you want to create a smooth
trajectory over the three axes, such as a camera move, and
you will use the Euler Angles when you have a precise
position in mind for a stationary object such as a wall.

To build our room structure, we will use the Euler Angles
rotation.

To position the floor:

1. Inthe Timeline view, select the Floor layer.

2. Inthe Layer Properties view, check the Enable 3D
option.

3. Inthe Rotation section, enable the Euler Angles
option.

4. Inthe (x) Axis field, type -90 to give the backward
rotation to the floor.

5. In the Position section, enable the Separate option
to control the three axis separately.

6. Inthe (y) Axis field, type -12.25 to send the floor to
the ground.

Rotation
(x) Axis: -90

Position
(y) Axis: -12.25

Repeat the same process for the back wall, ceiling and side
walls.

Back Wall: Position (z) Axis = -4.55

Left Side Wall: Position (x) Axis = -12.3, (z) Axis = -1.55,
Rotation (y) Axis = -90

Right Side Wall: Position (x) Axis = 12.3, (z) Axis = -1.55,
Rotation (y) Axis = 90

Ceiling: Position (y) Axis = 12.25, Rotation (x) Axis = 90

When you build a 3D room, make the walls wider or higher than they need to be for your drawings to

® intersect in the corner and avoid having small gaps.

Going 3D - Building the Structure 25



Filming Your Set

Now is the really exciting part: adding a camera and
filming on a 3D trajectory!
To do so, you will need to add a Peg to your camera and

set the trajectory, the same as the camera rail used in
live-action shooting.

wn =

ok

To animate a 3D camera move:

-+ 49 window

~+ 49 Back_wall
=+ 43 Foor
~+45 csiling

4 49 Left_wall
~+ 49 Right_w=ll
T CameraP

L +a Camers

In the top menu, select Insert > Camera.

In the Timeline view, select the Camera layer.

In the Timeline toolbar, click on the Add Peg %
button to parent a peg layer to your camera.
Select the Camera Peg layer.

In the Layer Properties view, check the Enable 3D

option.

In the Rotation section, enable the Quaternion
option.

[advanced Animation s

+
@O
In the top menu, select Window > Toolbars >

Advanced Animation to display the Advanced
Animation toolbar.

To animate a camera motion, selecting the Quaternion rotation is your best choice if you want to have a very smooth

and well interpolated trajectory.
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8. Inthe Timeline view, go to the first frame.

9. Inthe Tools toolbar, enable the Animate & Mode.

10. In the Advanced Animation toolbar, select the
Rotate (=) tool or the Translate €% tool.

[ /

11. In the Camera, Top and Side views, set your
camera’s first position.

12. In the Timeline view, go to the last frame.

13.In the Camera, Top and Side views, set your
camera’s last position.

14. If you do not have interpolation between your
frames, select the camera’s first keyframe and use
the Set Motion Keyframe shortcut [Ctrl] + [K]
(Windows) or [#8] + [K] (Mac OS X).

The Advanced Animation toolbar is useful to set your camera since it allows you to control one movement

® type at a time. You can use the Rotate tool to set your angle, then the Translate tool to set your position.
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Adding an Outdoor Decor

Background  {Symbol)

e

--Symbols
: Animate Library
--Templates

o
v
\\.

To enhance the look of your scene, include what you ﬁ *ﬁe+d" - &6 "%I — L SRR
: ; 49 Foxr e
previously learned about the multiplane. ey | Oa=
When your camera is moving, having a multiplane +8sw [ Oa=
background outside the window will add that little + 43 fught wl / O&=
: ) + 49 Jindow EE
something special to your scene. Ol Sl
You will find in the Symbol library of your sample scene a +Bbagond s Oe=| BT
multiplane background that you can import in your S meer By &=
Timeline view's left side. L hil G a=

Encapsulating your multiplane background in a Symbol is a great idea for keeping your Timeline view clear and

organized. This way, you only get one layer instead of several ones added to your scene.
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1. Inthe Playback toolbar,
click on the Play @
button to playback your
scene.

2. Adjust your camera
move to get the look
you want.

You can start adding more
elements to your scene such
as props in the room or effects
on your layers.

Once you are comfortable
with the 3D scene setup, you
can start building houses,
buildings and beyond!

Refer to the Animate User Guide to learn more about adding props and other elements to your scene as well

as locking some layers to the camera.
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Experts Speak Up

House of Cool Inc.

atocus on the development of ariginal content.
Their business is built on transforming their
client's mostvalued ]

House of Coal Inc. s 3 pre-groduction studio with |

Cartoon Network Studios has adopted Toon
Boom Storyboard Pro for the pre-production of

B" Chowder, the Emmy-nominated animated

@

compeliing and marketable products.

o= television series aboul Chowder, an aspiring
young chet in training, who dreams of becoming

[View |

a great chef someday.
[ew] | [View]
Soul Productions || FWWAK! ANIMATION

Led by Laura J. Milliken, the accomplished | FWAKI ANIMATION was established in 2000 in

{ producer and entrepreneur, Blg Soul Productions Sidney, Australla and ks cumrendly based in Los
nn*r' Is celebrating its tenth anniversary, with a very Angeles, USA The Directors - Eddle Mort and Lill
1 Impressive irack record. Since its inception, the Chin = have over ten years' axperience working in

Toronto-based studio has been aleaderin the 20 animation industry on short fims and

series.
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Sean Petrilak

| | SeanPetrilakis an emerging artist with work
'-!I experience in several industry markets. Before

Sean received his BFA in Animation and
F A.{ | and warking with Electronic Ants.

| Mlustration from San Jose Stale, he was iraining

[View

A moment with: Mark Simon

Wark Simon worked in the entertainment indusiry
for over 20 years and has been a professional
artist for over 25 years. His background includes
Iive action and animation production, print, writing
and teaching.

[View

Check out Toon Boom’s Expert
Corner, a section dedicated to
customers using Toon Boom's
professional products, including
Storyboard Pro, Animate Pro and
Harmony.

In addition to Cartoon Network, you
can listen to interviews with Fwak!
Animation, House of Cool, Mark
Simon and Sean Petrilak. Hear it
from the pros and see how they
maximize the use of ¢
leading-edge tec



Chapter 4 Building a Cut-out Puppet Using the Network View

In Toon Boom Animate Pro you will find all the tools,
features and views you ever wished for to build cut-out
puppets and animate them. A wide variety of breakdown
and rigging techniques are available since

Animate Pro mixes the most common and popular
concepts.

Before starting this lesson, you should complete

Chapter 8: Building a Cut-out Puppet in the

Toon Boom Animate Getting Started Guide. You can
either do the rigging following the Animate method, using
the timeline, or the Animate Pro one, using the network.
To use the network, read the following topics:

® Ordering the Puppet’s Layers

e Setting the Pivots /

e Connecting to a Composite Module ‘
e Creating Hierarchies

e Ordering Layer Hierarchy
e Storing the Puppetin the Library

To follow these topics you can also use the bitmap
puppet monster you imported while completing

L

Chapter 2: From Sketching Table to Animate Pro. =
__._)t_ — e e
. e e




Ordering the Puppet’s Layers
DisEIayed in Front
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+41n | hahd
C +90p r_hand
:F*ﬂlp |_farearm
+45 a0 forearm
+4 0 | leg
+4 0 leg
+48 1 |_am
+45 ¢ am
+45 |0 _body
+45 |0 _colour

4
[

Displayed
Behind

[ R R R R R R R R RS |

To reorder your layers drag them to a higher or lower level
in the Timeline view. The top layer is displayed in front of
the others and the bottom one is displayed behind.

1. Inthe Timeline view, drag the layer to reorder it and
drop it inbetween the other layers.
Note: If you drop it on a layer, it will create a parent
hierarchy, so make sure to drop it inbetween layers.

It is possible at this point that your character’s pieces show
up in the wrong order. There are two ways to fix this.

If you select a layer and reposition it, its child layers will follow. There is no need to select all the layers.
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Setting the Pivots

Do the following steps for each layer in the Timeline view.

To set the pivots for the Body parts:

1. Inthe Tools toolbar, select the Pivot (& tool.

2. Inthe Timeline view, select the cell you want to set
the pivot for.

3. Inthe Camera view, click where you want the pivot
to be. You can also drag the pivot marker to the
desired location.

4. Inthe Timeline view, select the cell where you want
to set the new pivot.

5. Inthe Camera view move the pivot to the desired
position.

If you want your puppet's pieces to rotate properly, you
need to set the pivot points. Even the eyes and mouth
require you to set their pivot.

For more information about pivots, refer to the Toon Boom Animate User Guide.

Building a Cut-out Puppet Using the Network View - Setting the Pivots - 33



Connecting to a Composite Module

w
A,
R | e
=i \ sy
e Es—

A composite module takes all the different parts of your
puppet and combines them into one single image. This
way, you can create effects and complete your scene with
ease.

If you do not already have a Composite module in your
Network view, do the following:

1. Inthe Network view, use the default keyboard
shortcut [Ctrl]+[H] to add a Composite module.

2. Inthe Timeline view's left side, select all of your
layers, using the [Shift] key.

3. Right-click (Windows) or [Ctrl]+ click (Mac OS X) and
select Connect to Composite> select your
Composite module from the list.

All of the drawing modules are now connected to a
Composite. The next step is to add a Master Peg to gather
up all the pieces to be able to control your puppet.

To add a master peg:

1. Inthe Network view, add a Peg module using the
default keyboard shortcut [Ctrl]+[P] (Windows) or
[88]+[P] (Mac OS X).

2. Inthe Timeline view, make a multiple selection of all

your layers using the [Shift] key and drag the
selection on the Peg layer.

Refer to the Toon Boom Animate User Guide to learn more about module types and the Module Library.
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The basic rigging is almost done, these final few steps will
make sure you optimize your puppet.

a Display |

The Network view might appear chaotic and tangled. You
can use the Scripting toolbar to untangle your modules.

1.

2.

Select Windows > Toolbars > Scripting to display
the Scripting toolbar.

In the Network view, use the default keyboard
shortcut [Ctrl]+[A] (Windows) or [8]+[A] (Mac OS X)
to select all the modules.

In the Scripting toolbar, click on the Order Network
Down &) button.

You can use the default values and click OK to
untangle your layers.

=N

In the Network view, click on the Composite’s
Properties button.

In the editor, enable the Pass Through option and
click on the Close button. This allows your
character’s parts to move on the Z-axis and interact
with other characters and manipulate props with
ease.

If you do not already have one, add a Display
module in the Network view by dragging one from
the Module Library and connect the Composite’s
bottom port to the Display’s top port.

If you have a Write module in your network, select it
and delete it using the default keyboard shortcut
[Deletel.

It is important to delete the Write module when building a cut-out puppet. A Write module is used to render

portions of your network. If you have two characters in a scene, their render would overwrite the scene’s one.
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Creating Hierarchies To create a hierarchy:

1. Starting from your basic rigging, simply click and
drag the bottom port of the parent piece’s module
(arm) and drag the connection to the top port of the
child piece’s module (forearm).

2. Then, connect this piece (forearm) on to the other

child piece (hand).

Animate Pro lets you extend your rigging techniques
beyond normal boundaries and set new standards. You can
create hierarchies by creating a linked structure between
them.

Refer to the Toon Boom Animate User Guide to learn more about complete production rigging.
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This is how your Network should look after the hierarchy is
complete.

3~ Display
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Ordering Layer Hierarchy

Top Bottom

Z S+ am L=
V] L+ ¢ forearm L | L=
v L+ hand L=

Before

As you work on your puppet and after you create a
hierarchy for your arms, legs or other body parts, it is
possible that you will notice that some parts do not appear
in the correct order. If you move the forearm layer above
the arm layer using the Timeline view, you will break the
hierarchy. Luckily, reordering in the Network is as easy as a
click and drag and will not modify the hierarchy.

On a Composite module, the bottom element is
connected on the far right port and the top element is
connected on the far left port.

1. Inthe Network view, click and hold the Composite
port corresponding to the piece you want to
reorder.

After

2. Drag the selected connection to the new position
and release.

B Refer to the Toon Boom Animate User Guide to learn more about the Network view and its functionality.
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Storing the Puppet in the Library

To store your character in the Library, you first need to
create a position keyframe on all your layers and finally
group and store it as a template in a sharing library.

In the Timeline view, select the first frame of every
layer.
In the top menu, select Insert > Keyframe or use

. the default keyboard shortcut [Ctrl] + [F6] (Windows)

or [38] + [F6] (Mac).
In the Network view, select all your modules and use

the default keyboard shortcut [Ctrl]+[G] (Windows)

or [z]+[G] (Mac OS X) to group them into a Group
module.

. Click on the Group module’s right side black arrow

to enter the group.

From the Module Library, select a Multi-Port-Out
module and drag it into the Network view.

In the Network view, connect the Multi-Port-Out
module to the bottom of the Composite.

. Click on Top from the Network view'’s left part of the

status bar, to exit the Group module.
In the Library view, select the Animate Pro Library

folder, right-click (Windows) or [Ctrl]+click (Mac OS)

and select Right To Modify.
In the Network view, select your group and use the

. default keyboard shortcuts [Ctrl]+[C] and [Ctrl]+[V]

(Windows) or [#8]+[C] and [$8]+[V] (Mac OS X) to
copy and paste it into the Animate Pro Library.

You now have a complete cut-out puppet!

Refer to the Toon Boom Animate User Guide to learn more about Group modules and the Library.
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Chapter 5 Compositing

In Toon Boom Animate Pro, there are many effects you can use to improve the quality of a project.

In this chapter you will composite effects in a production-like context. Animate Pro allows you to composite your
scene using a node system. In this lesson, you will perform the same tasks as the Creating Effects chapter from the
Toon Boom Animate Getting Started Guide, but using the node network. In Animate Pro, you can not create effects
from the Timeline view.

You can practice these effects on material you create
from scratch or you can also use the sample material.

e Undone_example_Sample_material >
Chapter5PRO_Sample_Material.tpl
The topics are:
¢ Drawing Your Star Points
* Making Your Stars Twinkle
e Making your Stars Glow
e Fading your Stars
e Lighting Up the Lampposts
e Making it Shine in the Night
e Keeping Your Distance
® Preparing to Hit the Switch
e Hitting the Switch
e Shooting Star
e Putting On a Mask
e Editing the Mask
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To build a starry night effect, we first need a layer of stars.
In Animate Pro, select a round brush, pick a star colour,
and draw dots where you want your stars on a new
drawing layer!

If you are working with Animate Pro PLE, use the star
shaped brush and skip the next topic task.

Drawing Your Star Points

1. Inthe Timeline view, click on the Add Layers (+.
button to add a Drawing layer on top of your
background. Name it Stars and click on its first cell.
In the Tools toolbar, select the Brush & tool.

3. Inthe Tool Properties view, select a round shape and
customize the minimum and maximum size values so
that you have a varied range of star sizes when you
draw with your pen tablet.

N

Options

o st ¥ %@ A
o5 4 ~ 2 s Shape

) 2 s A2 s .lvl

4. Inthe Colour view, pick a star-like colour.
5. Inthe Camera view, draw as many dots as you want
stars.

If you want five-point stars or if you are working with Animate Pro PLE, you can select a star shaped brush

from the Brush tool Properties and skip the next topic task.
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Making Your Stars Twinkle

3. Inthe Network view, select the Sparkle module,
hold down the [Alt] key as you drag it in between the
Stars and Composite modules to connect it.

(NOTE:This feature is not available in Animate Pro PLE

version)

Now that you have drawn the positions of your stars, it's 4. Click on the Sparkle module’s Properties to open
time to make some magic and transform these points of the Layer Properties dialog box and modify the
light into stars. Start Angle, Scale, Factor and Number of Points

As you customize your effects, you can preview the final values to customize the look of your stars.

result in the Camera view. In the Camera view bottom

toolbar, click on the Render &% mode button. To update jaT ansle ?? f i T
the preview, click on the Update Preview () button. Caor i .-
Drensity 1] o .,f' -

1. Display both the Network view and Module Library. Nurber of Points 5 g -

2. Inthe Module Library, under the Plugins tab, select
and drag a Sparkle Effect into your Network view.

Refer to Toon Boom Animate User Guide to learn more about the different options of the Sparkles effect

module.
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Making your Stars Glow

3. Click on the Sparkle module’s bottom port and drag
it in the Glow module’s top port to connect it.

4. Connect the Glow module to the Composite.

Now that you have stars in your project, it is time to make
them shinel!

1. Display both the Network and Modules Library
views.
2. Inthe Module Library view, select a Glow module e
isplay
under the Filters tab and drag it into the Network
view.

A Refer to Toon Boom Animate User Guide to learn more about connecting the modules and the Network view.
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In the Network view, click on the Glow module’s
Properties button to display the Layer Properties
dialog box.

Blur Type Radial [V]
@us 4.5 D% W
Colour
25 o
E w0
55 w7
255 [

. Set the Blur Radius value.

Pick a colour and alpha value. Double-click on the
colour swatch to display the Colour Picker.
Display the result in the Camera view using the
Render #mode.

Adding new layers in the Timeline view can result in a messy Network. Use the Order Network Down button in

the Scripting toolbar to untangle the modules. Refer to Toon Boom Animate User Guide to learn more.
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Fading your Stars

Now that your sky is glowing with stars, you might want to
soften them a bit.Try adding a Transparency effect on your
Star layer.

RN

2. Inthe Module Library view, select a Transparency
module under the Filters tab and drag it into the
Network view.

Display both the Network and Module Library views.

3.

In the Network view, select Transparency module
and hold the [Alt] key as you drag it between the
Sparkle and Composite modules.

In the Network view, click on the Transparency
module’s Properties button to modify the
transparency value of your layer.

Enable/Disable . =

Marne: Transparency

(Transparency =] , W

Display the result in the Camera view using the
Render #mode.

Refer to Toon Boom Animate User Guide to learn more about the Transparency effect module.
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Lighting Up the Lampposts

Lighting up the lampposts is as easy as making the stars
shine. Only one step differs. You have to create a lamp
layer from the background layer.

»

In the Timeline view, select the Bg layer’s first cell.

In the Tools toolbar, select the Select (% tool.

In the Camera view, select the light bulb zones of
the two lampposts. Press [Shift]+Click as you select
the zones to create a multi-selection.

Press the default keyboard shortcut [F9] to Create
Drawing from Drawing Selection.

Name your new layer 1ight_matte.

Drag a Glow module effect from the Module Library
to the Network view.

In the Network view, connect the Glow module
under the light_matte module and customize the
effect.

. Verify the result in the Camera view, using the

Render # mode.

When the Network view gets overcrowded, you can select modules and gather them inside Group modules

using [Ctrl]+[G] (Windows) or [3]+[G] (Mac OS X). Refer to Toon Boom Animate User Guide to learn more.
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Making it Shine in the Night

Adding a halo around the lampposts and a highlight on
the statue is an easy and effective way to enhance the
glow effect and integrate all of the elements in the scene.

In the Timeline view toolbar, use the Add Layers =+
button to create a new drawing layer.

Name this new layer Lamp_Highlight matte.
In the Timeline view, select the first cell of the new
layer.

In the Tools toolbar, select the Ellipse (£ tool.

In the Tool Properties view, enable the Auto Fill &)
mode.

In the Colour view, select any colour.

In the Camera view, trace a large ellipse around the
lamp area, this shape will become your halo.
Display both the Network and Modules Library
views.

In the Module Library view, select a Highlight
module under the Filters tab and drag it into the
Network view.

Refer to Toon Boom Animate User Guide to learn more about the Highlight module.
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The Highlight module, unlike the Glow effect, will only
affect specific layers. This means you need to connect the
mask as well as the layer it will affect. In this case, it will be

the Bg layer.

1. In the Network view, connect the Highlight module
to the Composite module.

2. Connect the Lamp_Highlight_matte module into
the left port of the Highlight module.

3. Connect the Bg module into the right port of the
Highlight module.

4. Click on the Highlight module’s Properties button
and customize the effect.

5. Verify the result in the Camera view using the

Render & mode.

The statue highlight effect will follow
similar steps.
1.

o

In the Timeline view, create a

new layer &+ and nameit
Statue_Highlight matte.

In the Timeline view, select the
first cell of the new layer.

In the Camera view, paint the
highlight zones using the

Brush < tool.

In the Module

Library view, select a
Highlight module and
drag itinto the Network view.
In the Network view, connect
the Statue_Highlight
matte module into the left port
of the Highlight module and
connect the Statue module into the
right port .

Customize the highlight effect.
Verify the result in the Camera view
using the Render @ mode.
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A good way to increase an illusion of depth is by using an
overlay which is out-of-focus. In this example we will be
hiding behind a broken structure.

B Refer to Toon Boom Animate User Guide to learn more about the Blur-Radial effect module.
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Display both the Network view and Modules Library.

2. Inthe Module Library view, select a Blur-Radial
module under the Favourites tab and drag it into the
Network view.

3. Inthe Network view, select and hold the [Alt] key as

you drag the Blur-Radial module in between the Ol

and Composite modules to connect it.

4. Click on the Blur-Radial module’s Properties button
to customize the Radius value of the effect.

Radiuz

[v]

Cuality High

5. Inthe Camera view, verify the result using the
Render &% mode.




Preparing to Hit the Switch

2. Inthe Network view, connect the
lamppost’s Glow layer into one of the
Transparency layers.

3. Connect the matte shape layers of the
two Highlight effects into the two remaining
Transparency layers.

With these Transparency layers you will
create a fade in effect, making the scene go
from lights out, to lights on.

Now we need to extend the drawing

exposure.
All these effects can be animated over time. For this
example, we will progressively light up the lampposts 1. Inthe Timeline view, make a multi-selection which
making their glow, halo and the statue’s highlight includes the last cell of each layer using [Shift]+Click
gradually appear. and press [F5].
1. Inthe Module Library view, drag three Transparency |
effects to the Network view. k

Refer to the Toon Boom Animate User Guide to learn more about keyframes and functions.
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Hitting the Switch

Now is time to create a function and enter the keyframes
that will animate the Transparency effects and gradually
light up your scene.

1. Inthe Timeline view, click on the Expand 4t button
to display the Data view.

QB G (4——
5 =49 Stamue_Highlight_Mat= O& =9[4 Drawing- 1

L 57 45 Transparency_3 as

L 5" Highlight_1 as

+ 49 stare O& =49 Dr=wing 1

2. Inthe Timeline view, click on the Transparency layer
Expand = button to display the Transparency’s

function.
W% - G b
5 =44 Srane Highlight_Mate [O& = |(49 Drawing 1
L Transparenc\.r_l as
k— Transparency + 50 0
L 5" Highlight_1 as

3. Make sure that your timeline marker is on the first

cell, click on the Add Keyframe + button and enter
the first Transparency value. This keyframe should
be set to 100 so that the lights are out.

w - & G b
= 449 Statue_Highlight Matte ' [] i = || 49 Drawing- 1
L 57 — 5 Transparency_3 as
Transparency - IDD.DDDI dr
L 5" Highlight_1 as

Move the timeline marker to the last frame of your
scene and press the Add Keyframe F button and
enter the last transparency value. This value should
be set to 0 (zero) to light up the scene completely.

% - B G 4 L
= 4 49 Stawe_Highlight_Mame @ =||49 Drawing 1 J
L 57 =5 Transparency_3 =]
Transparency <= D.DDDI J
L =<7 Highiight_1 as

Repeat Step 1 to Step 4 for the other two
Transparency layers.
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Follow these simple steps to preview your animated
effect.

1. Inthe Playback toolbar, press on the Render and
Play (®/ button.

2. Your frames will be calculated and the Play view will
pop up.

3. Inthe Play view, press on the Play (®/ button and
enjoy your scene!

Refer to Toon Boom Animate User Guide to learn more about the Play view and previewing your scene as well

as exporting your scene.
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Shooting Star

. * - ‘
T n AN
S

,:t

To animate the shooting star:
1. In the Tools toolbar, click on the Animate & button
and then select the Transform -1 Tool.

2. Inthe Timeline view, click on the first cell of the
Shooting_Star layer.

3. Inthe Camera view, click and drag the shooting star
to its first position on the extreme left, outside of
the camera frame.

Now, to make things more interesting, let’s add a shooting
star flying across the heavens. Use the disabled module

Shooting_Star which we have provided. 4. Inthe Timeline view, click on the last cell of the
[A] : Shooting_Star layer.
_ > 5. Inthe Camera view, click and drag the shooting star

] across the screen, ending at it's final position.
1. Inthe Network view, select and enable the N

Shooting_Star module using the default keyboard
shortcut [A].

The system will automatically create the motion between
the two keyframe positions.

When animating the shooting star, make sure that the Peg Selection Mode €3 in the Transform tool

Properties view is disabled.
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The shooting star now moves at a constant speed along
the straight line from point A to point B. To add a curve
and a velocity effect, follow these steps.

1. Inthe Timeline view, select the Shooting_Star layer.

2. Select View > Show > Control to display the
trajectory.

3. Inthe Camera view, position your cursor over the
trajectory and press [P] to add a control point.

4. Inthe Camera view, click and drag the new control
point to create a curve.

5. Inthe Control Point toolbar, adjust the Tension and
Continuity values to set your trajectory’s curve.

1.

To add a velocity effect:

In the Timeline view, click on the Expand 4 button
to display the Data view.

In the Timeline view, click on the Expand Arrow [*
and Expand 4 buttons of the Shooting_Star layer
to display its functions.

hooting_Star [ = (2] Sheoting_St=r &=
t %«5 Shootng S| /(& =
Position: Path
: Position: Velocity
| Sczle: Scale x

In the Timeline view, double-click on the Position
Velocity function of the shooting star layer.
The Velocity Editor dialog box opens.

a 1 2 E

“Ax"k
W
|

In the Velocity Editor dialog box, click on the last
keyframe and drag the handle toward the centre to
create a velocity curve.

By default, the preferences are set to Motion Keyframes, this means that the system will automatically create

the motion between the two keyframes of the shooting star.
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Putting On a Mask

Now the shooting star is all set, only one thing is left to do.
Since the lampposts are part of the Bg layer, the star
cannot pass behind them. For this reason, we will add a
Cutter module and drawing that will hide the shooting star
when it passes in front of the lampposts, giving the illusion
of passing behind. For this lesson, a matte drawing of the
lampposts is provided for you.

1. Inthe Network view, enable the Lamp_Mask layer
using the default keyboard shortcut [A].

2. Inthe Module Library view, select a Cutter module
under the Filters tab and drag it into the Network
view.

3. Inthe Network view, connect the Lamp_Mask
module to the Cutter module right port, the
Shooting_Star group module in the left port and
connect the Cutter module into the Composite
module.

||:I | Shoo?ng_Star Pl

S

The shooting star will now cross the screen behind the two
lampposts!

Refer to the Toon Boom Animate User Guide to learn more about Trajectories, Control Points and the Velocity

Editor.
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Editing the Mask

m
2> Shooting Star ™ |

1. Inthe Network view, connect the Lamp_Mask
module directly into the Composite module without
changing the current connection via the Cutter
module.

This will automatically render your drawing visible in the

Camera view. It will be displayed on top of all other layers,
making the editing easy to do.

Once a matte drawing module is connected to a Cutter

effect the drawing will become invisible in the Camera 1. Inthe Tools toolbar, select the drawing tools you
view, as it will automatically be applied as a mask. If you need and edit the matte in the Camera view.

need to edit your matte drawing after you create your 2. When you are done, simply disconnect the Lamp_
connections in the Timeline view, you can easily make your Mask module from the Composite module, keeping
drawing visible without breaking the connections. it connected only via the Cutter module.

Refer to the Toon Boom Animate User Guide to learn more about Cutter and Effects.
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Have you seen our tricks?

Whether you're a novice or an ¥
expert, all users will benefit from

our free articles available in the v.
elLearning section of our website.

Visit our website and learn about
subjects such as:

Rigging

How to Make a Camera or Object Shake
Sunrise Sunset

Lens Flare FX Template

Storyboarding Without a Pencil

Importing a Final Draft Script in Storyboard
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master peg
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Adding storing in Library 39
Camera 26 colours
Symbols 28 textures 18
Advanced Compositing Composite Module
about 5 about 34
Advanced Traditional Animation Features adding
about 5 to Network View 34
Animating connecting
Animate Mode 27 modules
Set Motion Keyframe 27 example of 44
animation creating
previewing 53 layers
from background layer 47
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. about 37
Background 28. See also Multiplane how to 36
bodypaﬁs' Cutter module
setting pivots 33 adding 56
brush
textured
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brush list dialog boxes
import Import Drawings 19
texture 17 Multi-layer Image Import Settings 19
drawings
C scanning
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optimizing Quaternion 24, 25, 26
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Creating Hierarchies 34
Ordering Layer Hierarchy 36
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textured Rotate Tool 27
about 16
pivots S
Pivot Tool 33 .
rotation sample image
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setting 33 Sample Material
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pivots 33
setting pivots
body parts 33
Side View 23, 27
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scanning process 12
Symbols
Importing 28
Storing the Puppet in the Library 38
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texture image

example of 17
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textures
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Toolbar
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Tools

Rotate Tool 27
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