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Chapter 1: Introduction
Harmony is a complete animation software allowing you to do endless creative projects. It comes with a very
wide variety of tools and features.

In the Getting Started Guide, you will learn about themain features covering the basic concepts of Harmony,
which will quickly bring you up to speed. Refer to the complete Harmony User Guide available online at
docs.toonboom.com to learn about all the tools and options, as well as advanced techniques.

This guide is divided as follows:

• Interface on page 6

• How to Draw on page 10

• How to Animate on page 12

• How to Paint on page 18

• How to Morph Drawings on page 22

• How to Import Bitmap Images on page 26

• How to Build a Cut-out Character on page 30

• How to Use BoneDeform on page 38

• How to Animate a Cut-out Character on page 48

• How to Create Templates on page 54

• How to Setup a Scene on page 58

• How to Create a Multiplane on page 74

• How to Set-up Objects in the 3D Space on page 78

• How to AnimateObjects and the Camera on page 64

• How to Import Sound and Add Lip-Sync on page 82

• How to Add Effects to your Scene on page 88

• How to Export a Movie on page 98

http://docs.toonboom.com/
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Chapter 2: Interface
It’s important that you become familiar with the following elements of the user interface, this will help you to
start using Harmony. You can learnmore about the highlights described here, and how to use them in a
production context, throughout this guide.

When you start Harmony for the first time, the default workspace is displayed. It contains all of themain
elements you need to use.

1. Camera View

2. Tools Toolbar

3. Tool Properties View

4. Timeline View

5. Menus

6. Colour View

7. Library View

8. Playback Toolbar

Adding a View
To add a view:

1. Select the view youwant to add fromWindows > The desired view.
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You can also use theWindow drop-downmenu button included in each view already available in the
workspace. Click on the button and select a view from the list. You can only open one instance of the
same view. In other words, you cannot have two Camera views open at the same time.

You can open several instances of the same view except for the Timeline, Tool Properties, Colour and
Drawing views.

2. To dock a floating window in your workspace, drag the window’s tab onto one of the workspace’s views.
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Tool Properties View

The contextual Tool Properties view contains themost common options and operations related to the currently
selected tool. As soon as you select a tool from the Tools toolbar, the Tool Properties view will be updated.

For example, if you choose the Select tool in the Tools toolbar, the Tool Properties view will display the

options and operations related to the Select tool such as Snap to Contour, Apply to All Drawings, Flip
Horizontal and Flatten.

Interface Navigation
Harmony supports zoom in, zoom out, rotate, pan and reset view position for easy interface navigation.

• Zoom In: Zooms into the view. From the top menu, select View > Zoom In or press [2].

• Zoom Out: Zooms out of the view. From the top menu, select View > Zoom Out or press [1].

• To zoom in and zoom out, hold down [Spacebar] and your middlemouse button while moving themouse
up or down.

• To pan the view, hold down the keyboard shortcut [Spacebar] and drag your mouse in the direction you
want to pan the view.

• To Recentre the view: recentres the view on your mouse cursor or press [N].

• Reset View: Resets the view to its default position. From the top menu, select View > Reset View or
press [Shift] + [M].

• Reset Rotation: Resets the view’s rotation to its default position. From the top menu, select View >
Reset Rotationor press [Shift] + [X].

• Reset Pan: Resets the view’s pan to its default position. From the top menu, select View > Reset Pan or
press [Shift] + [N].

• Reset Zoom: Resets the view’s zoom to its default position. From the top menu, select View > Reset
Zoom.
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• Toggle Full Screen: Enlarges the selected view to full screen. The full screen process is done in three
stages. From the top menu, select View > Toggle Full Screen or press [Ctrl] + [F] (Windows/Linux) or [⌘ ]
+ [F] (MacOS X).

• First, the selected view enlarges to themaximumwidth or height, but keeps the tool views such as
Colour or Tool Properties view.

• Second, the view enlarges to full screen.

• Third, the view returns to its original size.

• Rotate 90 CW: Rotates the Camera view 90 degrees clockwise, like an animation table. From the top
menu, select View > Rotate View CW.

• Rotate 90 CCW: Rotates the Camera view 90 degrees counter-clockwise, like an animation table. From
the top menu, select View > Rotate View CCW.

If you're using a tablet or trackpad that supports touch, then you can also use standard two-finger
gestures for zoom, rotate, and pan of the canvas.
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Chapter 3: How to Draw
As soon as Harmony is started, you can start to draw straight away using the default drawing layer.

How to draw:

1. In the Tools toolbar, select the Brush tool or press [Alt] + [B].

2. In the Xsheet view, click in the first cell of the drawing layer.

3. In the Drawing view, start drawing.

4. To select a different colour, in the Colour view, select the a different colour swatch. Double-click on the
colour swatch to open the Colour Picker window andmodify the colour. Remember that anything already
painted with that colour swatch will update to the new colour.
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Chapter 4: How to Animate

Now that you know about the existing tools, you can start your animation.

The first step to complete is the rough animation, which is the skeleton of your animation. You would usually
start with themain action. For example, to animate a walk-cycle, you will start with the torso moves and the legs.
Head, arms and clothes will be added later, during the secondary animation.

For a satisfactory animation, complete themain action before adding all of the details. If you start animating all
of the details right away, you will lose a lot of time if you have to do corrections, and your animation will often
look too rigid.

To animate:

1. In the Preferences panel, you can set your preferences to Use Current Frame as Drawing Name.

2. In the Tools toolbar, select the Brush tool or press [Alt] + [B].

3. In the Colour view, select the colour you will use to draw. It is a good idea to choose a light colour for your
rough animation to help for the following task, the clean up process.

4. In the Timeline or Xsheet view, select the cell where the first drawing will appear.

5. In the Camera or Drawing view, draw the first key drawing.
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6. Make sure your first key drawing is still selected, and in theMark Drawing toolbar, click on theMark
SelectedDrawings as Key button.

‣ In the Xsheet view, you can also select Animation > Mark Drawing As > Key Drawing to identify your
drawing.

7. In the Tools toolbar, click on the Enable Onion Skin button.

8. In the Timeline view, click and drag the onion skin bluemarkers to extend the number of previous and
next visible drawings to fit your need.

9. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

10. In the Camera or Drawing view, draw your second key drawing.
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11. In the Xsheet view, identify the drawing as a key drawing.

12. In the Xsheet view, select a cell between your two key drawings.

13. From the Timeline View toolbar, click to create an empty drawing or press [Alt] + [Shift] + [R].

‣ In the Xsheet view, right-click and select Drawings > Create Empty Drawing or press [Alt] + [Shift] +
[R].

14. Draw your new drawing.
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15. If necessary, in the Xsheet view, identify the new drawing as a Key, Breakdown or In-between drawing.

16. In the Timeline or Xsheet view, select a new cell and repeat step 9 to step 15 for each new drawing.

17. In the Timeline view, disable the layers you do not want to show during playback.

18. In the Playback toolbar, click on the Loop button if you want the playback to loop.

19. In the Playback toolbar, click on the Play button to start the animation.

Cleaning Up
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When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It
consists of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless
animation step before the ink and paint step.

You will need to add a new drawing layer to draw your clean. This is the equivalent of adding a sheet of paper
and tracing the rough using the animation disk.

If you plan on tracing your animation in the Drawing view, you will need to enable the Light Table
feature in order to display all the layers of your project.

To trace your animation in a new layer:

1. In the Timeline View toolbar, click on theAddDrawing Layer button.

2. In the Timeline view, click the lock icon of the layer containing your rough animation to prevent selecting
the layer in the Camera view.

1.

2. In the Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of your
rough animation.

3. In the Tools toolbar, select the drawing tool of your choice. We recommend the Pencil tool.

4. In the Colour view, select the colour you will use to trace your animation. Pick a dark bold colour such as
black to make sure it contrasts well with the light colour of your rough animation.

5. In the Camera or Drawing view, start tracing the first key drawing.

6. If you have some other layers in the way, you can disable them temporarily from the Timeline view so that
only your rough animation and your clean up layer are displayed in the Camera view.
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7. In the Tools toolbar, click on the Enable Onion Skin button and extend theOnion Skin In the Timeline

view.

8. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

9. In the Camera view, trace your next drawing.

10. Repeat the previous steps for each drawing.

This method allows you to keep the roughs and the cleans intact. You only need to disable the rough
layer to prevent it from appearing in the scene.
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Chapter 5: How to Paint
Harmony has some very powerful colouring features when it comes to painting. To paint your drawings you will
use different colour swatches, unlike some paint programs where youmodify one swatch each time youwant to
paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You
can add as many swatches as you want. You can also rename them andmodify existing ones.

When youmodify the colour of an existing swatch it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted
zones. This way, you can change the look of your character at anytimewithout having to repaint it!

In colour animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. These are
referred to as master palettes.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.

Using a master colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.

• You cannot accidentally use a colour which is not in themaster palette.

• Standardization and colour consistency throughout the production
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• Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all of the colours needed to paint your elements, allowing complete control and
consistency in your painting process.

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, etc.

Learn how to paint your drawings by following these instructions.

To paint your drawings:

1. In the Tools toolbar, select the Paint tool or press [Alt] + [I].

2. In the Colour view, select a colour from the palette.

‣ Double-click on a colour swatch to open the Colour Picker window andmodify the colour.

3. In the Camera or Drawing view, start painting the colours on your drawing.
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Closing Gaps

When painting, you will notice that some of your drawing areas are not closed. To close the zone you can either
draw themissing line with the Brush or Pencil tool, but you can also close the gap with an invisible line. To do so,
you will use the Close Gap tool.

The Close Gap tool is used to close small gaps in a drawing. The Paint tool only paints closed areas. The Close
Gap tool will create a small, invisible stroke between the two closest points to close the colour zone. You do not
need to trace directly over the gap. You can draw it a few millimetres away and the Close Gap will automatically
choose the two closest points and close the gap.

To use the Close Gap tool:

1. In the Tools toolbar, select theClose Gap  tool. You can also select theClose Gap tool from the top

menu under Drawing> Tools > Close Gap or press [Alt] + [C].

‣ Enable theAuto-Flatten option in the Tool Properties view if you want the stroke you will draw to

be flattened in your drawing instead to be on top.

‣ You can display the invisible lines with the Show Strokes option under View > Show Strokes or press
[K].

‣ If you do not display the strokes, a Message dialog box will appear.

Enabling the Don’t Show This Message Again option prevents this Message dialog box from appearing.

2. In the Camera or Drawing view, trace an invisible line near to the gap to be closed. The gap will
automatically close.
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Chapter 6: How to Morph Drawings

Once you are familiar with the basic rules, you can start creating morphing sequences. You need to practice and
become at ease with theMorphing feature. To begin, start with simple elements, once you become confident
with themorphing process you canmove on to complex and advanced morphing techniques, such as head
rotation or full characters.

To create a basicmorphing:

1. In the Timeline view, click on the Add Drawing Layer button to add a new layer to your project.

2. Rename the new layer Morphing.

3. In the Timeline or Xsheet view, select the first cell in your layer.

4. In the Tools toolbar, select the Rectangle tool or press [Alt] + [7].

5. In the Tool Properties view, enable the Auto Fill option.

6. In the Colour view, click on the Set Paint Current Colour button.

7. In the Colour list, select a colour to fill your rectangle with.

8. In the Colour view, click on the Set Pencil Current Colour button.
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9. In the Colour list, select a colour to trace your rectangle's outline with.

10. In the Camera or Drawing view, draw a rectangle.

‣ Hold down the [Shift] key if you want to draw a square.

‣ Hold down the [Alt] key if you want to draw the rectangle from its centre.

11.In the Xsheet or Timeline view, select the last cell.

12. Repeat Step 5 to Step 10 using the Ellipse tool instead of the Rectangle tool or press [Alt] + [=].

‣ Draw an ellipse using the same outline colour as the rectangle ("Outline").

‣ Paint the ellipse with the same fill colour as the rectangle ("Fill").

13. In the Xsheet or Timeline view, select your first drawing's cell, the rectangle drawing.

14. In the Xsheet or Timeline view, right-click on the selection and selectMorphing > Create Morphing or
press [Alt] + [M].

‣ In the top menu, you can also select Animation > Morphing > Create Morphing.
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Arrows appear between the two key drawings to show they are computer generated.

15. Use the Playback toolbar to play themorphing sequence. To flip through the in-betweens toggle between
[,] and [.] or press [F4] to toggle between the two key drawings.
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Chapter 7: How to Import Bitmap
Images
Abitmap image is an image composed of pixels that is both size and resolution-dependant.

To import a bitmap image:

1. From the top menu select File > Import > Images. You can also click on the Import Images button in

the File toolbar.

‣ In the Xsheet view, you can right-click anywhere in the frame area and select Import > Drawings.

The Import Images dialog box opens.

2. In the Files section, click Browse to find and select one or several images on your computer.

3. In the Layer section, you have the option of creating a whole new layer for your image or adding the image
to an existing layer.

‣ To create a new layer, select Layer > Create Layer(s) > Create Single Layer Named and name your
layer accordingly.

OR

‣ To create a new layer using the file name, select Layer > Create Layer(s) > Create Layer(s) Based on
Filenames.

OR

‣ To add the image to an existing layer, select Layer > Add to Existing Layer and select the layer
already created in your Harmony file from the drop-downmenu. If only vector layers are available

in your scene (and therefore the drop-downmenu), you will either have to Vectorize Imported Items,
Create Symbols for imported Items or check both options to put your bitmap image on a vector layer.
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If you vectorize your image usring the Vectorize as Colour option, you can import it on a vector layer,
and use vector tools on it.

4. In this case, uncheck theVectorize Imported Items option.

The vectorization options are hidden and the Transparency section appears.

5. In Harmony, if you want your bitmap images to be encapsulated in a symbol, enable theCreate Symbol
for Imported Items option. If not, disable the option. If you chose to add your image to an existing
vector layer then the Create Symbol for Imported Items will automatically be checked and greyed out.

6. Next, in the Alignment section, youmust decide on the size and placement of your imagewithin the
camera frame. Depending on the Scene Settings (the height and width in pixels that you chose for your
project), an image that you import may get scaled to the point where all its individual pixels become
visible.

Be sure that you are in the Camera view’s Render Mode when judging an imported image, otherwise
it may appear blurry.when judging an imported image, otherwise it may appear blurry.

The following three options are available

• Alignment > Rules > Fit

• If your image orientation is portrait format, this selection will enlarge or shrink (but not distort) to your
image height to match the full height of the camera frame.

• If your image orientation is landscape format, this selection will enlarge or shrink (but not distort) your
imagewidthmatches that of the camera frame.

• Alignment > Rules > Pan

This selection achieves the opposite result of the Fit command.

• If your image orientation is portrait, its width will bemade to match the width of the camera frame. As
a result, part of the image’s height will extend beyond the height of the frame.

• This can be useful if you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning, or to actually perform a camera pan.

• Alignment > Rules > Project Resolution

This selection will scale the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the scene's resolution, for
example 1920 x 1080, and adjusts the scale factor in proportion. So in this example the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is 960 x 540 it will be displayed at 50% (960/1920)
of the size of the project resolution.

7. The last step is to decide on the image’s transparency from the Alpha drop-downmenu. For this, there
are four options available. These options deal with the way that the bitmap imagewill be antialiased,
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more specifically the way that the pixels along the edge are blended in the RGBA (red, green, blue, alpha
(transparent)) channels.

The options are:

‣ Premultiplied withWhite

Individual pixels at the edge of an image are blended with white.

‣ Premultiplied with Black

Pixels at the edge of an image are blended with black.

‣ Straight

Pixels at the edge of an image are blended with black, white and greys.

‣ Clamp Colour to Alpha

Select this option if you want to premultiply the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. If you have a pixel of value
R=247, G=188, B=29 and the alpha is 50% (the image is 50% transparent, then the actual RGB value
output would be half of the amounts listed above.

8. Click OK.
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Chapter 8: How to Build a Cut-out
Character

There aremany techniques you can use to break down a puppet. In this section, you will learn about one of the
most common and simplest method. For your first character break down, follow these instructions to get an
idea of the way Harmony works. Once you are used to the software and understand its basic functions and
commands, you will be able to create your own techniques to satisfy the needs of your production.

Drawing the Pieces
Themain break down technique shown here is to trace your model, completing the hidden lines and filling the
gaps.

To trace over your model:

1. In the Timeline view, add a new drawing layer for each body part to separate. You can press [Ctrl] + [R]
(Windows/Linux) or [⌘ ] + [R] (MacOS X).

2. In the Timeline view, select the layer's first cell in which you want to draw the part.

3. In the Tools toolbar, select the drawing tool needed.
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4. In the Colour view, select the desired colour swatch.

5. In the Camera or Drawing view, draw the new part.

If you are working in the Drawing view, click on the Light Table button located in the Drawing View
toolbar to display the other layers as washed out colours. You can also press [Shift] + [L].

6. In the Tool Properties view, you can set the Pencil tool width to 0 to create an invisible hairline if you want
to close a shapewithout drawing an actual stroke.
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7. In the Tools toolbar, select the Paint or Paint Unpainted tool to colour your drawing.

8. In the Colour view, select the corresponding colour.

9. In the Camera or Drawing view, paint your drawing.

10. Using the Select tool, select your drawing and flatten your lines by clicking on the Flatten button

located in the Tool Properties view.

11. If your lines are composed of several pencil strokes, youmight want to combine them into one single
smooth pencil line using theMerge Pencil Lines option. Using the Select tool, select the pencil lines to be
merged and in the Tool Properties view, click on theMerge Pencil Lines button.
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12.Repeat the entire process until the breakdown is completed.

Parenting Layers
Harmony lets you extend your rigging techniques beyond normal boundaries and sets new standards. You can
create hierarchies without encapsulating pieces inside each other by creating a linked structure between your
layers.

You should create a hierarchy on your arms and legs and keep the arms and legs separated from the body. This
gives youmore animation freedom. This way, when you need to scale or skew the torso, it will not affect the
entire body.
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To create a hierarchy in the Timeline view:

‣ Drag the child piece (hand) and drop itON the parent piece (forearm). Then, you can drag the parent
(forearm) piece onto another parent piece (arm).
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To create a hierarchy in the Network view:

‣ From the parent part, drag a new cable connection out of themodule's output port (bottom) and
connect it to the child part module's input port (top).

Here is an example of a rig with a simple hierarchy:

Master Peg

When you animate your character, you will probably need to resize and reposition it to fit your scene. When you
need to scale down or move your character, it is a good idea to hook (attach) the whole puppet to a trajectory.

Attaching your puppet to a peg will allow you to scale it and reposition it without having to do this to your
different parts and pieces. Only one layer will contain the position information, this makes your animation easier
to modify and control.



Chapter 8: How to Build a Cut-out Character

36

To add aMaster peg:

1. In the Timeline view, deselect any selected layers and click on the Add Peg button located in the

Timeline Layers toolbar.

2. Name the new peg Master plus the character's name.

3. In the Timeline view, select all of the layers you want to attach to your new peg.

4. Drag your selectionON the peg layer to parent all your character's pieces to the peg.
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Chapter 9: How to Use Bone Deform
This chapter is divided as follows:

• Rigging below

• Optimizing the Deformation Chain on page 40

• Display the Deformers' Controls on page 43

• Animation on page 44

Rigging
This topic explains how you can quickly use the Rigging tool to create a basic Bone and Articulation or Curve rig.
Before you can create a Basic Deformation rig, youmust set up the performance preferences which are necessary
to allow the system to process the deformation effect efficiently.

To create a basic deformation rig:

1. Youmust set up the Performance Preferences. See note above. After you have done this continue to step
2.

2. In the Preferences panel, under the Deformation tab, disable theCreate PosedDeformer in Create
Deformation Above/Under .

Disabling this preference will result in a simpler Network rigging structure.

But remember that this option must be re-enabled when rigging a multi pose (front, quarter, side and
back) character.

3. From the Deformation toolbar, select the Rigging tool.

4. In the Rigging Tool Properties, enable the Automatic Mode.

5. In the Network or Timeline view, select the element that you want to add a deformation to.

6. In the Camera view, you can start to create a Bone or Curve rig.

‣ To create a Bone rig:

‣ Place the cursor at the far end of your element, click once and release. For example, on the shoulder.
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‣ Click again at the location where you want your first bone to finish and your second bone to start. An
articulation will automatically be inserted between each bones you create.

‣ Repeat this until you are finished creating the Bone chain.

‣ To create a Curve rig:

‣ Click at the far end of your element, for example, the shoulder and drag your cursor to extend the
control handle and release, just as you would do when using the Polyline tool.

‣ Click again at the location where you want the curve to end and drag your cursor to extend the second
control handle.

‣ Repeat this process until you have finished building the Curve chain.

This will automatically create a Deformation Group connected to the top node of the selected element. This
group includes all the necessary deformationmodules as well as the Bones, Curves and Articulations you
created.
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Note that this Network structure is the result of a simple rigging which was a created with the Create
Posed Deformer in Create Deformation Above/Under preference disabled.

Optimizing the Deformation Chain
Once you have a deformation chain created, you can optimize its positioning to fit the element it will deform.
This task is done in the SetupMode . The SetupMode lets you set the resting position of the deformers to

make sure it is at the optimal position.

To setup a bone and articulation deformation chain:

1. In the Network view, select the Deformation Group youwant to setup.
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2. In the Deformation toolbar, click on the Show Selected Deformers and Hide All Others button to

display the deformer controls in the Camera view. This also hides all the deformer controls that were
displayed.

3. In the Deformation toolbar, enable the SetupMode .

The chain will turn from light green to red. If the chain is displayed in green, it means the SetupMode is
disabled. Click the button oncemore to enable it.

4. In the Tools toolbar, select the Transform tool.

5. In the Camera view, setup the deformation chain.

• Use the Pivot rotation handle to change the angle of the chain.
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• Use the Pivot centre control point to reposition the entire chain.

• Use the Articulation control point, the square at the bottom, to reposition the articulation. This will
elongate, shorten or change the direction of the first bone.

• Use the Articulation, top diamond-shaped, control point to change the size of the articulation. For quality
purposes it is recommended to have an articulation which fits the diameter of the part it controls.
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• In the Deformation toolbar, if desired, you can disable the Show Simplified Manipulators option to display
all themanipulators. You can choose to work with the simplified deformers, but if you needmore fine-
tune control you can also access the full deformers. You will notice two extra square control points
appearing in themiddle of the articulation circle. Drag these up and down to modify the steepness (bias)
of the articulation.

6. Repeat until all the articulations and bones of the chain are correctly aligned to the element it is linked to.

7. With the Deformation Group still selected, click on the Copy Resting Position to Current button. This

will make sure to set the current resting position as the current frame one.

8. In the Deformation toolbar, disable the SetupMode and test your modifications using the Transform

tool.

For optimal results, make sure the size of the articulation is about the same size as the drawing.

Display the Deformers' Controls
To be able to manipulate the deformer outside of the SetupMode, youmust enable the Deformation Controls.
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If you have just created the bone rig, the controls will still be showing. However, whenever you close
your project the deformers are turned off, so when you reopen the project you can show the ones
you need while you're animating.

You can also select all themodules from your Network view and select View > Show > Controls from the top
menu.

To display the selected deformation controls:

1. In the Network view, select the Deformation Group containing the deformation chain you want to display.

2. In the Camera View toolbar, click on the Show Control button. You can also select View > Show >

Control from the top menu or press [Shift] + [F11].

To display the selected deformation controls and hide all the others:

1. In the Network view, select the Deformation Group containing the deformation chain you want to display.

2. In the Deformation toolbar, click on the Show Selected Deformers and Hide All Others button.

The selected deformation controls will appear in the Camera view and all the others will be hidden.

To display all the deformer controls at the same time:

1. In the Top level of the Network view,select Edit > Select All from the top menu to select all themodules
or press [Ctrl] + [A] (Windows/Linux) or [⌘ ] + [A] (MacOS X).

2. In the Camera View toolbar, select Show Control or press [Shift] + [F11]. This will display all the

deformation controls in your scene.

To hide the deformer controls:

‣ In the Camera View toolbar, click on the Hide All Controls button. You can also select View > Hide

All Controls from the top menu or press [Shift] + [C].

Animation
The Bone deformer operates the same as a human limb does and is composed of a pivot, as a starting point, and
bones and articulations.

Tomanipulate a Bone andArticulation deformer:

1. In the Deformation toolbar, disable SetupMode . When SetupMode is disabled, the default colour of

the deformation control is light green.

If you leave Setup Mode on, you will modify the resting position of the deformer chain, instead of
animating it.
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If you had made changes to your rig in Setup mode, you can select the deform group and click on
Copy Resting Position to Current button. This resets the rig outside Setup mode to match what the
rig looks like in Setup mode.

2. In the Tools toolbar, if you want to create keyframes, enable the Animate mode.

3. In the Tools toolbar, select the Transform tool.

4. In the Top level of the Network view, press [Ctrl] + [A] (Windows/Linux) or [⌘ ] + [A] (MacOS X) to select
all themodules, you can also select Edit > Select All from the top menu.

5. In the Camera View toolbar, select Show Control or press [Shift] + [F11]. This will display all the

deformation controls in your scene.

6. In the Camera view:

‣ Click on the centre of the Deformation-Root pivot and drag it around to reposition the entire limb.

‣ Use the first bone or the pivot square handle to rotate the entire limb.

‣ Use the square control point located at the extremity of a bone to stretch or shorten its length.
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‣ Use a bone next to an articulation to rotate it. You can also hold down the [Alt] key, this will lock all the
controls and movement and only allow the rotation of the articulation.

‣ Click and drag the articulation’s diamond-shaped control point to modify its radius.
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Chapter 10: How to Animate a Cut-out
Character
This chapter is divided as follows:

• Animation below

• Navigating the Hierarchy on the facing page

• Easing on page 50

Animation
To create a simple cut-out animation:

1. In the Tools toolbar, select the Transform tool. You can also press [Shift] + [T].

2. In the Tools toolbar, enable the Animate mode so that everything youmovewill be keyframed

automatically.

3. In the top menu, select Animation > Stop-Motion Keyframe so that the interpolation is not created
automatically between your keyframes.

4. In the Timeline view, collapse your character.

5. In the Timeline view, go to the framewhere you want to set your first pose.

6. In the Camera view, select the parts to animate.
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7. Using the Transform tool, rotate, skew, scale or translate the selection to its new position.

A new keyframe appears in the Timeline view.

8. If you want to make sure that nothing will move on your new pose, in the Timeline view, select the frame
corresponding to the pose,right-click and select Add Keyframe. You can also press [F6].

9. In the Tools toolbar, enable theOnion Skin feature.

10.In the Timeline view, go to the framewhere you want to set your second keyframe.

11. In the Camera view, animate your character.

12. Repeat this process until all your poses are done.

Navigating the Hierarchy
If you created a layer hierarchy when you built your puppet, you can use the keyboard shortcuts to travel up and
down the parent-child chain. You can also travel between the children in a layer.

To select the parent or child layer:

1. In the Tools toolbar, select the Transform tool.

2. In the Transform Tool Properties view, make sure the Peg Selection mode is deselected.

3. In the Camera or Timeline view, select a layer attached to a hierarchy.
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4. Select Animation > Select Parent or press [B] to select the parent layer. Now select Animation > Select
Child or press [Shift]+[B] to select the child layer. The keyboard shortcuts are [B] and [Shift] + [B].

These keyboard shortcuts will ignore any effect module encountered in the Network or Timeline
view. Only drawing and peg modules will be considered. If you want to navigate the hierarchy
including the effect modules, you can create a custom keyboard shortcut in the Preferences dialog
box for the Select Parent Skipping Effects and Select Child Skipping Effects commands on the
General tab.

Easing
If you have several functions you would like to adjust the velocity for at the same time, such as the hand, forearm
and arm of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in one
frame.

To set eases on multiple parameters:

1. In the Timeline view, select a keyframe from one or more layers.
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Only the first keyframe selected on a given layer will be considered when using the Set Ease for
Multiple Parameter function. If many keyframes are selected on the same layer, the ease values will
be applied only to the first one and the rest will be ignored.

2. In the Timeline view,right-click (Windows) or [Ctrl]+Click (MacOS X) and select Set Ease ForMultiple
Parameters. In the Timeline View toolbar, you can click the Set Ease For Multiple Parameters   button.

If the button is not in the Timeline View menu, you can add it through the Toolbar Manager.

The Set Ease For Multiple Parameters dialog box opens.

3. In the graph interface, pull on the Bézier handle to adjust the velocity for all the selected functions.

4. If you want to apply these easing parameters to a certain type of function only, such as Rotation or Scale,
in the Filters section, deselect the function types you do not want to affect.

‣ Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 3D Path
functions

‣ Rotation: Applies the easing parameters to the selected Angle functions.

‣ Scale: Applies the easing parameters to the selected Scale functions.

‣ Skew: Applies the easing parameters to the selected Skew functions.

‣ Morphing: Applies the easing parameters to the selectedMorphing Velocity functions. Note that it
applied to theMorphing velocity function in the Layer Properties dialog, not to the basicMorphing
ease in the Tool Properties view.
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‣ Other: Applies the easing parameters to all the other selected functions, such as all functions created
to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are
calculated in percentage.

‣ In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the
length of time youwant the easing to last. The valuemust be between 0% and 100%.

‣ In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong youwant
the easing out. The valuemust be between 0% and 100%.

‣ If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click one of the following button:

‣ Apply: Applies the easing parameters to the selected keyframes.

‣ Apply/Previous: Applies the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

‣ Apply/Next: Applies the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

‣ Close: Closes the dialog box. If you did not apply themodifications, they will be cancelled.
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Chapter 11: How to Create Templates
You can create a template out of a layer or cells. You can store anything available in the Timeline view as a
template.

When creating a template from the Timeline view, it will lose the extra connections, effects and
groupings from the Network view.

Creating a template selecting a layer will incorporate the layer and all the drawings that were created
in it, even if they're not exposed in the Timeline view. Selecting cells will only save those specific
drawings in the template.

To create a template from the Timeline view:

1. In the Timeline view, select some cells or layers.

2. In the Library view, select the folder in which you want to store the template.

3. If the library folder is locked,right-click and select Right toModify.

4. Drag the selection to the Product NameMacMenu Library folder or to any other library folder.

5. In the Rename dialog box, rename the new template.

If you want to rename a template once it is created,right-click on it and select Rename.
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6. Click OK.

To import a template in the Timeline view:

1. In the Library view, select the template you want to import.

2. Drag the selected template to the Camera view or Timeline view's left side.

3. You can also drag a template to the Timeline view's right side into existing layers if the layer structure is
the same as the existing one.

Creating a Template from the Network View
The Timeline and theNetwork views have different ways to display the scene; each view displays different
information.

Amain character's template, is created from theNetwork view. This template contains all the connections,
effects, composites, modules, pegs, advanced groupings, function columns, scene lengths, drawings, timings,
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etc. The template is saved in the Library view andmust be imported back into the scene for use, either into the
Network view or into the left side of the Timeline view.

If you are creating a template from a character rig master template, you should collapse everything
inside a master peg and put a keyframe on the first frame before creating the template.

To create a template from the Network view:

1. In the Library view, select the folder in which you want to store the template.

2. If the library folder is locked, right-click and select Right toModify.

3. In the Network view, select themodules you want to create a template with and group them.

4. Select Edit > Group > Group Selected Layers or press [Ctrl] + [G] (Windows/Linux) or [⌘ ] + [G] (MacOS
X).

5. In the Network view, click on the group module's yellow button to rename it.

The Layer Properties dialog box opens.
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6. In the Network view, select your group module and copy and paste it inside the template folder in the
Library view or press [Ctrl] + [C] and [Ctrl] + [V] (Windows/Linux) or [⌘ ] + [C] and [⌘ ] + [V] (MacOS X).

7. In the Rename dialog box, rename the new template.

‣ To rename a template, right-click on it and select Rename.

8. Click OK.
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Chapter 12: How to Setup a Scene
This chapter is divided as follows:

• Positioning the Camera below

• Positioning Objects on page 60

• Repositioning the Pivot on page 61

Positioning the Camera

Refer to How to Animate Objects and the Camera on page 64 to learn how to animate the camera.

To set the camera frame, you need to add a Camera layer to your scene so you can edit the default camera
frame.

To add a Camera layer in the Timeline view, do one of the following:

‣ In the Timeline view, click the Add Layer button and select Camera.

‣ From the top menu, select Insert > Camera.

A new camera layer is added to your scene and appears in the Timeline view.

You cannot add a camera inside a symbol. If you try to do so, a warning message will pop-up and
inform you that this operation is not possible.

If you've added more than one camera to your scene, you can switch the active camera by going to
Scene > Camera and selecting the camera you want to use.

In Harmony, you can also use theNetwork andModule Library views to add a camera layer into your scene.

To add a Camera module in the Network view:

1. Display theNetwork view.

2. In theModule Library view, select a Cameramodule from the Favorites,Move or AllModules tab.
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3. Drag theCameramodule into theNetwork view.

You can reposition your camera frame directly in the Camera view, using the Translate and Rotate tools.

To reposition the camera frame directly in the Camera view:

1. Select Animation > Tools > Translate or press [Alt] + [2].

2. In the Camera view, click on the camera frame to select it. You can also select the camera layer from the
Timeline view.

The selected camera frame is highlighted in purple.

3. Drag the camera frame to a new position.

4. To tilt the camera frame, select Animation > Tools > Rotate or press [Alt] + [3].

5. In the Camera view, click on the camera frame to select it and rotate the camera frame until it reaches the
desired rotation angle.
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The Translate and Rotate tools can also be found in the Advanced Animation toolbar.

Positioning Objects

Refer to How to Animate Objects and the Camera on page 64 to learn how to animate objects.

To pan a layer using the Transform tool:

1. In the Tools toolbar, select the Transform tool or press [Shift] + [T].

2. In the Transform tool Tool Properties view, make sure the Peg SelectionMode is deselected.

3. In the Camera view, select a drawing layer and drag the selection to a new area. You can select multiple
layers to reposition them at once.

To rotate a layer using the Transform tool:

1. In the Tools toolbar, select the Transform tool or press [Shift] + [T].

2. In the Transform tool Tool Properties view, make sure the Peg SelectionMode is deselected.

3. In the Camera view, select a drawing layer and rotate the transform bonding box handle.
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To scale a layer using the Transform tool:

1. In the Tools toolbar, select the Transform tool or press [Shift] + [T].

2. In the Transform tool Tool Properties view, make sure the Peg SelectionMode is deselected.

3. In the Camera view, select a drawing layer and pull or push on the size, top, or corner control point. Hold
down [Shift] to lock the selection’s ratio.

To skew a layer using the Transform tool:

1. In the Tools toolbar, select the Transform tool or press [Shift] + [T].

2. In the Transform tool Tool Properties view, make sure the Peg SelectionMode is deselected.

3. In the Camera view, select a drawing layer and drag sideway or up and down the sides or top and bottom
segments, between the control points.

Repositioning the Pivot
Some transformations, such as the rotation, scale, skew and flip, aremade relative to the pivot point position.
You can reposition this pivot point anywhere using the advanced animation tools.

To permanently reposition the pivot point:

1. In the Advanced Animation toolbar, select the Rotate , Scale or Skew tool.

2. In the Camera view, [Ctrl] + click (Windows/Linux) or [⌘ ] + click (MacOS X) to select your element.

The pivot point appears in the Camera view.
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3. Drag the pivot point to a new position.

This is the new position of the pivot point for future transformations until you reposition it.

Using the advanced animation tools to permanently reposition your pivot overrides the existing pivot
point position until you change its position again.
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Chapter 13: How to Animate Objects
and the Camera
This topic is divided as follows:

• Animating a Layer below

• Animating the Camera on page 66

Animating a Layer

You can create a motion path directly on your layers.

Drawing layers can house drawings and symbols. Also, in that same layer you can create a motion path using
keyframes and all the artwork contained in the layer will follow.

You can control and define your trajectory using several different parameters. These parameters are:

• X, Y and Z positions

• Angle (rotation)

• Skew

• X and Y scales

Each parameter has its own function curve where you can add keyframes and control the easing.
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Do not worry about using graphs and function curves if you are not familiar with this concept. Harmony has a
series of easy-to-use tools for visually controlling your trajectories in theCamera view.

To animate a simple object such as an arrow in flight or a wheel spinning, you can use the integrated trajectory.
Also, each part of a cut-out puppet will be animated directly on the drawing layer.

Follow these steps to perform a basic layer animation.

To animate a layer:

1. In the Tools toolbar, select the Transform tool or press [Shift] + [T].

2. In the Transform Tool Properties view, make sure that the Peg SelectionMode is deselected.

3. In the Tools toolbar, click the AnimateMode button.

4. In the Timeline view, go to the first frame.

5. In the Camera view, select the element to animate and move it to its first position.

6. In the Timeline view, go to the frame onwhich you want to set the second position.

7. Play back your animation.
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Animating the Camera
The camera is treated the sameway as any other element. The same tools and selectionmodes are used to
offset or animate it. To animate the camera, you need to connect it to a peg element.

This means that you can animate the camera visually, with the function curve, or by typing values in the Xsheet
column.

To add a camera with a peg to your scene:

1. If you do not already have a camera layer, do one of the following:

‣ From the top menu, select Insert > Camera.

‣ From the Timeline view layers toolbar, click the Add Layers button and select Camera.

‣ In Harmony, select a Camera module from the Library view and drag it to theNetwork view.

A new camera layer is added to the scene and appears in the Timeline view.

2. From the Timeline View Layer toolbar, click the Add Peg button.

A Peg layer appears directly above the Camera layer. The Camera layer is automatically attached to it.

The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it is a
Peg layer, for example Camera-P.

If the new Peg layer did not appear directly above the camera, youmay have clicked elsewhere in the
scene, which deactivated the layer on which you want to add the Peg layer.

‣ Select the Camera layer and drag and drop it under the new Peg layer. Or delete themisplaced Peg
layer, select the Camera layer and click the Add Peg button again.

‣ In Harmony, you can select a Peg module from the Library view and drag it to theNetwork view. Then
you can connect the peg’s output port to the camera’s input port.
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You are now ready to animate your camera.

Make use of both the Top and Camera views while making camera moves. You can open this view is one of two
ways:

‣ From the top menu, selectWindows > Top.

‣ From any existing window already open in your project, click the Arrow button at the top-right

corner and select Top.

The Top view appears as a tab in that view.
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To animate the camera:

1. Make sure both the Animate button and the Transform Tool are activated.

2. In the Top, Side or Camera view, select the camera (the large V-shape on the right side) and move it to the
desired position.

3. In the Camera view, the camera is represented by a thin frame. You need to click directly on one of the
edge.
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4. In the Timeline view, click on a cell in the Camera Peg layer where you would like the camera move to
begin.

5. Right-click (Windows) or [Ctrl]+Click (MacOS X) and select Insert Keyframe.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as in this keyframe.

6. Click on another cell a bit further down your scene’s Timeline. This is where the camera movewill end.

7. Select the camera in the Top view andmove it to the desired position.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.
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8. Play back your animation.

You are now ready to animate your camera.

It is recommended to use both the Top and Camera views while making camera moves. You can open this view is
one of two ways:

• From the top menu, selectWindows > Top.

• From any existing window already open in your project, click the arrow  button in the top-right corner

and select Top.



Toon Boom Harmony 10.3 Getting Started Guide

71

To animate your camera:

1. Make sure that the Animate   button and Transform tool are activated.

2. In the Top, Side or Camera view, select the camera and move it to the desired position.

‣ In the Top and Sive view, the camera is the large V cone. You need to click directly on one of the edge.

‣ In the Camera view, the camera is represented by a thin frame. You need to click directly on one of the
edge.



Chapter 13: How to Animate Objects and the Camera

72

3. In the Timeline view, click on a cell in the Camera Peg layer where you want the camera move to begin.

4. Right-click and select Insert Keyframe.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as in this keyframe.

5. Click on another cell, further down your scene's Timeline, where you want the camera move to end.

6. Select the camera in the Top view andmove it to the desired position.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.

7. Play back  the camera move in the Camera view to watch the results.
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Chapter 14: How to Create a Multiplane

To construct a multiplane, youmust imagine what a real environment is like. Take a look at your background
picture and imagine a camera moving across the space. You will notice that objects in the picture would move at
different speeds depending onwhere they are in relation to the camera lens.

Building a multiplane requires an understanding of the scene's background as well as the positioning of the
elements on different layers.

For example, in this background, themain objects to be separated are:

1. Fern

2. Front tower

3. Second tower

4. Moon

5. Stars

6. Sky
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Although the bottom of the tower is hidden behind the plant and the ladder, each of your multiplane
layers should be a complete drawing. This is because hidden portions may show up during a camera
movement later on in the scene

Now is the time to distribute the layers composing your multiplane along the Z-axis, maintaining their distance.
You can position your layers on the Z-axis in the Side and Top view.

Positioning your element toward the camera will make your element bigger. Using theMaintain Size tool,

you will be able to drag your element toward the camera while keeping the same size aspect in the Camera view.
This tool is available in the Advanced Animation toolbar.

It is a good idea to keep a Camera view opened to see what your scene looks like while positioning
your element in the Top or Side view.

Positioning Elements in the Top and Side Views

To be able to distribute the layers along the Z-axis using the Top and Side views, disable the No Z
Dragging option by selecting Animation > No Z Dragging.

To position your element in the Top and Side views:

1. In the Advanced Animation toolbar, click theMaintain Size tool or press [Alt] + [6].

2. In the Side view, select one of the layers in the thumbnails section of the Top or Side view. You can also
select your layer from the Timeline view.

The selected layer will be highlighted in the camera cone.
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3. Click and drag the layer to the correct depth position in the camera cone. Your element aspect will remain
the same in the Camera view.

4. In the Tools toolbar, click the Transform tool, or select the Translate tool in the Advanced

Animation toolbar and select a layer from the thumbnails section of the Top or Side view. You can also
select your layer from the Timeline view.

‣ If you choose the Transform tool, make sure that the Peg SelectionMode option is disabled in

the Transform tool's Tool Properties view.

The selected layer will be highlighted in the camera cone.

5. In the TOP view, drag the element sideways to position horizontally. You can press and hold [Shift] while
dragging the element to make sure it only moves along the X-axis.

6. In the Side view, drag the selected element up or down to position it vertically. You can press and hold
[Shift] while dragging the element to make sure it only moves along the Y-axis.
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Chapter 15: How to Set-up Objects in
the 3D Space
Once you have your drawings and symbols assembled, it is time to position them. This section explains how this
is done using the simple room shown previously.

To position your layers, you require the following elements:

• Camera View

• Top View

• Side View

• Perspective View

• Library View

• Timeline View

• 3D Transformation Tools

• Layer Properties View or dialog box

To position layers in the 3D space:

1. In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.

2. In the Transformation tab, check the Enable 3D option.

3. In the Rotation section, enable the Euler Angle option.

4. Type 90 in the Rotation's (x) Axis field to flip the floor so that it is flat on the ground.
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5. To position the height of the floor, type values in the Position section of the Layer Properties, use the 3D
Translate tool or 3D Transform tool.

6. Repeat the process for the other pieces to import.

7. If you have parallel walls, once you have positioned one, select theWall layer in the Timeline view.

8. In the top menu, select Edit > Duplicate to duplicate the layer.

If the drawing is contained inside a symbol, the symbol will not be duplicated, only the layer
containing the symbol. This way you are still using the same drawing.

9. Once the layer is duplicated, use either the Layer Properties window to type the positioning values, or use
the 3D transformation tools.

10.When you are using the transformation tools, use the Camera, Top or Side view to position the elements
instead of the Perspective view to position your layers precisely.

11. If your walls are touching each others, you should have them intersect by extending one end of the wall
through the other wall. This prevents seeing a small gap in-between them.
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There you go, you now have a complete 3D room.
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Chapter 16: How to Import Sound and
Add Lip-Sync
If you decide to add sound to your movie, youmust first prepare this sound outside of Harmony. When this is
done youmust add a sound element in Harmony to the organize sound files in your animation. Sound will play in
themovie until it reaches the end of the file or a stop frame that you have created in the Sound Element Editor.

If you first create your project in Toon Boom Storyboard Pro, the sound will be cut up into the
different scenes for you automatically.

You can import WAV, AIFF or MP3 sound files using any of themethods listed below.

To import a sound file:

1. Select File > Import > Sound

‣ Right-click anywhere in the frame zone of the Xsheet view.

‣ From the Topmenu

‣ From the Xsheet View menu

‣ From the Timeline View menu

The Select Sound File dialog box opens.

2. From the Select Sound File dialog box find and select your sound file from your computer.

Your sound file appears as a layer in both the Timeline and Xsheet view.
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Lip-Sync
Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth so that it matches the sound at the precise frame.

To solve this problemHarmony provides a lip-sync feature which analyzes the contents of a sound element and
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is
used to represent silence).

Themouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

The letters used to represent the shapes do NOT correspond to an actual sound.
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Here is an approximation of which sound eachmouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to themouth chart positions as you draw the shape of your character's mouth.

Automatic Lip-Sync Detection
To generate a sound detection for your lip-sync using the Layer Properties view:

1. In the Timeline or Xsheet view, select your sound layer.
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2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

Harmony can automatically map drawings in an element to themouth chart you have generated for a sound. This
can save timewhen you are lip-synching a voice track.

In the Lip-SyncMapping dialog box, you can identify each lip drawing of a character. Harmony then automatically
labels all of the cells in the character's element with the appropriate name.

To automatically map lip-sync drawings to a mouth layer:

1. To open the Lip-SyncMapping dialog box, do one of the following:

‣ In the Timeline view,right-click on any cell in the sound sample layer and select Lip-Sync > Map Lip-
Sync.

‣ From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

‣ In the Timeline view, select your sound layer and in the Layer Properties view, clickMap.

The Lip-SyncMapping dialog box opens.
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2. From theDestination Layer drop-down list, select the layer that contains themouth positions for the
character's voice track.

3. If the selected layer contains symbols, you canmap the lip-sync using drawings located directly on the
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to
use the drawings or select the desired symbol from the drop-downmenu.

4. In theMapping section, type the drawing name or Symbol frames in the field to the right of the phoneme
it represents. If your drawings are already named with the phoneme letters, you do not have to do
anything.

5. Click OK.

6. Press the Play   button in the Playback toolbar to see and hear the results in the Camera view. To play

back your scene with sound, enable the Sound   button in the Playback toolbar.
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Chapter 17: How to Add Effects to your
Scene

Once your animation is completed, you can add effects such as blurs and glows to make your project look even
better! Harmony provides you with a series of essential effects that you can add to your layers.

This chapter is divided as follows:

• About Effects below

• Adding Effects on page 90

• Tone Effect on page 93

• Animating an Effect Over Time on page 95

About Effects
An effect always needs a drawing connection and sometime a matte or shape connection. Amatte provides
drawing information that will be used to determine the area where the effect will be applied on the drawing. The
details and colours within thematte drawing do not matter, as the systemwill only use the shape and
transparencies in it. Amatte is also known as mask.

Thematte principle can be demonstrated on the Tone effect.
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The drawing layer is connected in the right port of the effect and thematte (mask) in the left port. The Tone
effect then applies darker colours where thematte overlaps the image, blurs the tone edge, and finally clips out
the extra tone zone outside of the drawing before outputting a final drawing with a tone.

The tone's parameters can be adjusted in the Layer Properties view and any of them can be linked to a function
column to be animated over time. This means that all of the effects can be customized.
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Adding Effects
If you need to add new effects and other modules to theNetwork view, you will need to get them from the
Module Library.
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When you create a new project in Harmony, the default network that appears in the Network view looks similar
to the diagram below.

Module Library View Toolbar
In theModule Library View toolbar, you can switch the displaymode of the effect icons:

• View as Icons

• View as List

• View as Icons with Names

Module Tabs
TheModule Library is conveniently broken up into several sections or tabs:

• Favorites
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Includes themost commonmodules.

• To add extra modules to the Favorites tab, select anymodule from any other section and drag it onto
the Favorites tab.

• Filter

Includes effect modules, such as blurs.

• Group

Includes modules used for grouping, like Groupmodules andMulti-Port modules.

• IO

Includes Display, Drawing, Write and Notemodules.

• Move

Includes modules used to change elements over time, like Pegmodules, as well as certain
transformations.

• Plug-ins

Includes plug-inmodules.

• All modules

Lists all of themodules available.

To bring a module into theNetwork view, drag it from theModule Library and drop it into theNetwork view.
Once in theNetwork view, you can click on the input or output port of a module and drag out a cable. You can
then connect this cable to the output port or input port of another module.

If you want to connect a module between two connected modules, you can use the [Alt] key as you drag the new
module over the existing cable connection. Using the same [Alt] key, you can also disconnect a module.
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If you want to remove a module, select and press [Delete] to remove it from theNetwork view.

Tone Effect

Use a Tone effect to add a dark-coloured region to your drawing and simulate the shaded area away from a light
source. To produce the tone effect, create a drawing to control where the tone will appear. The Tone effect uses
a matte to determine the shape and position of the tone on your drawing and can be blurred at the edges to
create a softer effect.

Use the Tone editor to control the type and amount of blur, as well as the colour of the tone.
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• Truck Factor: Activated by default, this option readjusts the blur when the elements undergo a change of
depth or scale. When this option is disabled, the effect's values will remain unchanged regardless of
depth or scale changes. It is recommended that this option be disabled whenmultiple drawings are
composited and attached this effect.

• Blur Type (Directional or Radial):

• If Directional is selected, Harmony will blur thematte in the direction you select.

• If Radial is selected, Harmony will blur the edges of thematte evenly around points that make up the
edge of thematte.

• Radius: Enter a value for the size of the blur. The larger the value, the greater the blur effect. The blur
radius is affected by the drawing scale and camera position.

• Directional Angle: If you select a Directional Blur Type, you can select the direction of the blur by entering
a value from 0 to 360 in this field.

• 0: Blurs the image to the west.

• 90: Blurs the image to the south.

• 180: Blurs the image to the east.

• 270: Blurs the image to the north.

• Directional Fall-off Rate: The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.

• A fall-off rate of 0 causes the blur to fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.

• A fall-off rate of 1 causes the blur to fade out quickly so that the blur is heaviest closer to the edge of
the image.

• Invert Matte: Activate this option to invert thematte used to create the tone.

• Use Matte Colour: Uses thematte shape colour to create the tone.

• Multiplicative: Multiplies the tone colours with the background.

• Red/Green/Blue/Alpha: In the RGBA fields, you can enter the value you want added to or subtracted
from the colour channels in the drawings or you can attach these values to function curves.
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Animating an Effect Over Time
When compositing your scene, it will often happen that you want to animate the parameters of an effect over
time. Youmight want to have an object fading in or out by changing the transparency level over time or
increasing the colour contrast on one of your drawings over a certain frame range.

To animate an effect over time, create a function curve by adding keyframes to the parameters you want to
animate. To do this, you will use the Layer Properties view, the Network view and the Timeline view. You can fine
tune your animation using the Function view.

To animate an effect over time:

1. In the Network view, drag an effect module from theModule Library view and drop it into theNetwork
view.

2. Plug the effect element between the drawing element that you would like to apply the effect to and a
compositemodule. You can either do this manually by unplugging and plugging, or by holding down [Alt]
as you drag it through a connection.

The effect should also appear in the Timeline view as well.
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3. To animate the value of the parameter, youmust create a function curve and add keyframes on it. For
example, you could get the Blur-Radial effect to have no blur on the first frame and become very blurry by
the end of the scene by animating its Radius parameter. To create the function curve:

‣ In the Layer Properties view, click on the Function button you want to animate to create a function

curve.

‣

OR

‣ You can also expand the effect layer's parameters in the Timeline view by clicking on the Expand
Function button and add a keyframe to the parameter you want to animate or press [F6].

‣

4. In the Timeline view, click on the Show Data View button.

5. In the Timeline view, go to the framewhere you want to start animating the effect.

6. In the Data view, click on theAddKeyframe button.

7. In the Value field scroll to the keyframe value or type the value in the field.
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‣ If your keyframes are stop-motion keyframes, in the Timeline view, select the new keyframes. Right-
click on the selection and select Set Motion Keyframe.

8. Repeat this process for each keyframe to be added.
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Chapter 18: How to Export a Movie
To export a QuickTime Movie:

1. From the top menu, select File > Export > Movie.

The Export to QuickTimeMovie dialog box opens.

2. From the dialog box, click Browse and choose a destination path to where your movie will be saved and
an appropriate filename for the export.

3. Click Save when you are finished.
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