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Chapter 1: Introduction
The Harmony Xsheet is part of the Toon BoomHarmony solution. The Xsheet Module takes care of all of your
timing needs, from pasting cycles, to setting Tempo Markers, to printing your Xsheet. The Xsheet Module
combines drawing, function, timing and annotation columns for maximum freedom and performance.

The Xsheet Module is mainly used for traditional animation when reproducing paper exposure sheet. It only
covers Harmony Stage’s timing features. This way, the user does not have to deal with all the other advanced
animation features and can focus on his exposure sheet work.

In all Harmony Xsheet documentation, the default keyboard shortcuts that are used are the Harmony
shortcuts.

About Timing and Exposure Sheet
The exposure of a drawing is the length of time that it stays on the screen. In animation, a second often can be
divided as follows; 24, 25 or 30 images depending on the used format. We also call these images frames.

Broadcast Standards
There are two main broadcast standards used; the one selected will determine the frame rate. In North America,
Japan and some other parts of Asia, the NTSC (National Television SystemCommittee) format is used. This
format is 30 images (frames) per second.

Inmost of Europe, PAL (Phase Alternating Line) format is the broadcast standard. This format is 25 frames per
second.

The human brain is able to process an animation as slow as 12 drawings per second. Therefore, the amount of
drawings per second should be between 12 and 30. The general standard is 24 or 25 frames per second, so
these 12 drawings are set on double exposure. This means that each drawing stays on the screen for two
frames. If a drawing is exposed for 24 frames, it means that it will appear to the eye for one second.

Xsheet
The Xsheet also known as the Exposure Sheet, or Dope Sheet is used when an animator is planning a scene: the
animator creates an individual column for each element in the scene, the name of the drawings and their
exposure into the Xsheet.The Xsheet allows the user to see the timing in detail.

The Xsheet is composed of columns corresponding to the different layers. Each column is split into rows
representing the frames in the scene. A paper Xsheet usually has eighty to a hundred rows and ten columns. This
enables the animator to associate a columnwith a certain element and record at which frame each drawing will
appear.

The traditional paper Xsheet was mainly created for the animator to communicate with the cameraman
regarding the scene’s timing, the camera moves and element trajectories. It is still used today to express the
same information to the compositors and the person working on the digital Xsheet.
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Topics Covered

• Getting Started on the next page

• Interface on page 23
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Chapter 1: Getting Started
Once the software is installed, you are ready to launch the application and set the timing for your animations.

Topics Covered

• Launching the Harmony Xsheet on the facing page

• Setting the Scene Length on page 14

• Scene Settings on page 15

• Verifying Project Integrity on page 21
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Launching the Harmony Xsheet
You can run the software onMacOS X, Windows or Linux operating systems.

To open the Xsheet Module, do one of the following:

1. Launch Harmony Xsheet:

‣ MacOS X: Double-click on the Harmony Xsheet icon or select

Applications > Toon Boom Harmony 10 > Xsheet

‣ Windows/Linux: Double-click on the Harmony Xsheet icon or select

Start > Programs > Toon Boom Harmony 10 > Xsheet

‣ Linux: Double-click on the Harmony Xsheet icon or select

Applications > ToonBoom-Harmony_10 > Xsheet

or type in the command line
cd /usr/local/ToonBoomAnimation/harmony_10/lnx86/bin./Stage -xsheet

TheHarmony Xsheet opens, displaying theWelcome Screen.

2. Enter your User Name in the user name field.

Your project manager or system administrator should already have created a user name for you.

3. Click Login.

TheDatabase Selector opens.
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4. Select an Environment (for example, this could be the name of a cartoon series), the name of the Job (for
example, the name or number of an episode in that series) and then the Scene (for example, a specific
scene in that particular episode).

5. Select one of the following three options:

‣ Get rights to modify the scene: Allows the user to modify the selected version of the scene and have
access to the versionmanager during the opened session.

‣ Get rights to modify the scene version: Allows the user to modify the currently selected scene
version but locks access to the versionmanager during the opened session.

‣ Get rights to modify all scene assets: Automatically gets all the edit rights for the selected version of
the scene. This option is only recommended if you are certain that the selected scene can not be
opened for editing by several users at the same time. Large studios should avoid this option.

6. Click on theOpen button.

If you opened a scene as read only, but realize that you will need to modify it, you can easily acquire
the necessary rights without closing and reloading the scene.

To set the scene’s rights after the scene is loaded:

1. Select File > Rights toModify Scene.

Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded.
This process is done during the initial loading process of the scene.

2. From theVersion drop-downmenu, select the version you wish to work on.

3. The Saved By and SavedDate fields display the user who was the last to save the selected scene and the
date of the last save.

4. Click on theOpen button.

Related Topics

• Using the FileMenu on the facing page
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Using the File Menu
To open a scene from the File menu:

1. Select File > Open. You can also click on theOpen button in the File toolbar. The [Ctrl] + [O]

(Windows/Linux) or [⌘ ] + [O] (MacOS X).

TheOpen Scene browser opens.

TheDatabase Selector opens.

2. Select an Environment (for example, this could be the name of a cartoon series), the name of the Job (for
example, the name or number of an episode in that series) and then the Scene (for example, a specific
scene in that particular episode).

3. Select one of the following three options:

‣ Get rights to modify the scene: Allows the user to modify the selected version of the scene and have
access to the versionmanager during the opened session.

‣ Get rights to modify the scene version: Allows the user to modify the currently selected scene
version but locks access to the versionmanager during the opened session.

‣ Get rights to modify all scene assets: Automatically gets all the edit rights for the selected version of
the scene. This option is only recommended if you are certain that the selected scene can not be
opened for editing by several users at the same time. Large studios should avoid this option.

4. Click on theOpen button.

Related Topics

• Launching the Harmony Xsheet on page 11
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Setting the Scene Length
You can set the scene length from the top menu.

To set the scene length from the topmenu:

1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. In theNumber of Frames field, set the number of frames needed and click OK.

Refer to the Timing on page 51 topics to learn more about adding and removing frames and
extending the scene’s length.

Related Topics

• Getting Started on page 10

• Launching the Harmony Xsheet on page 11

• Scene Settings on the facing page

• Verifying Project Integrity on page 21
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Scene Settings
You can set up both the scene’s resolution and alignment. You can do this by going to the top menu and
selecting
Scene > Scene Settings.

The Scene Settings dialog box opens.

The different Scene Settings options are separated into three tabs:

• Resolution Tab on the next page

• Alignment Tab on page 18

• Advanced Tab on page 19

Related Topics

• Getting Started on page 10

• Launching the Harmony Xsheet on page 11

• Setting the Scene Length on the previous page

• Verifying Project Integrity on page 21
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Resolution Tab

1. Project Resolution Type

2. Scene Resolution Setting

3. Pixel Dimensions

4. Save Custom Resolution

5. Aspect Ratio

6. Project Frame Rate

7. Field of View

Resolution
1. You can select your project’s resolution type from this area so it matches your intended output.

‣ HDTV: High definition television delivers a higher quality image than standard television does,
because it has a greater number of lines of resolution. To take advantage of the superior quality your
output devicemust be compatible with HDTV technology to make this resolution setting useful.

‣ HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to how the drawing grid is fit into
the camera frame. Whenworking with 12 or 16 field drawing grids, the grid is a different aspect ratio
from the camera frame. When you fit vertically, you fit the grid with the top and bottom of the camera
frame.

‣ film-1.33: Use this resolution setting for the academy film format that conforms to the standard 4:3
aspect ratio.

‣ film-1.66: Use this resolution setting for the widescreen film format that conforms to the 16:9 aspect
ratio.

‣ film-1.66_Vertical: This is essentially the same as film-1.66. Refers to how the drawing grid is fit into
the camera frame. Whenworking with 12 or 16 field drawing grids, the grid is a different aspect ratio
from the camera frame. When you fit vertically, you fit the grid with the top and bottom of the camera
frame.

‣ NTSC: This is the standard analogue television broadcasting system used in North America and
conforms to theNorth American standards on how rectangular pixels are displayed for computer and
television screens.

‣ PAL: This resolution works best with the European format for television and computer screens, as the
rectangular pixels are displayed at a different orientation.
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‣ Low: This format is ideal for videos destined for the web, where size and fast download of a video file
might take precedence over quality.

2. Displays the scene resolution setting selection.

3. Displays the pixel dimensions for your resolution selection.

If you decide to type in the pixel dimensions, or use the up and down arrows to change the pixel
increments, you will have to save your custom selection in order to make it active (4). It will then appear in
the resolution selection list (1).

4. Click Save to save and create your custom resolution as a setting. This button becomes active when you
create a custom resolution type (3).

5. The aspect ratio is the ratio between the horizontal and vertical dimensions of the Camera framing. Each
resolution setting has a preset aspect ratio that cannot be changed.

6. Select the frame rate for your project. The higher the frame rate, for example 30 fps, the smoother your
animation will look, but the heavier it will become, the lower the frame rate, for example 12 fps, the
choppier your animationmay look, but the lighter it will be.

7. Use these options to define the FOV of the camera and how the drawing elements (and drawing grid)
align to the camera. The drawing grid is always scaled proportionally to a 4:3 (1.33) ratio, therefore
changing the Field of View setting may not show a visible difference if your project resolution is also 4:3,
such as NTSC.

‣ Horizontal Fit: The drawing grid is fitted to the vertical (side) edges of the Camera view, so that the
width of the grid matches the width of your project resolution.

‣ Vertical Fit: The drawing grid is fitted to the horizontal (top and bottom) edges of the Camera view,
so that the height of the grid matches the height of your project resolution.

‣ Custom Fov: After selecting this option, use the now-active field to the right to enter in a value, in
degrees, of the angle that you want the camera cone to be. Increasing this value will make the camera
cone wider (the angle is more obtuse), widening the FOV andmaking the grid and all elements appear
farther away. Decreasing the default value will create the opposite effect.

Related Topics

• Scene Settings on page 15

• Alignment Tab on the next page

• Advanced Tab on page 19
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Alignment Tab

1. Alignment Presets

2. Units Aspect Ratio

3. Number of Units

4. Coordinates at Centre

Alignment Rules

1. The Alignment Presets give you two preset options:

‣ 4:3 12 Fields: Defines the units of your project to have a 4:3 ratio and sets up 12 of these units to run
both vertically and horizontally in four cardinal quarters (NW, NE, SW, SE). This Alignment preset is
visible in the FOV and drawing grids.

‣ Square 12 Fields: Defines the units of your project to have a 1:1 or square ratio and sets up 12 units
to run both vertically and horizontally in four cardinal quarters (NW, NE, SW, SE). This Alignment
preset is NOT visible in the FOV and drawing grids.

2. In the Units Aspect Ratio fields, enter the aspect ratio of the grid you will use. The aspect ratio describes
the shape of the grid unit. A square grid unit would have the ratio 1:1, whereas a grid unit of aspect ratio
4:3 is a unit with one side 1.33 times as big as the other side.
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‣ If the aspect ratio you want to use is 1:1, enter 1 in the Left/Right field (X-axis) and 1 in the Up/Down
field (Y-axis). The default Aspect Ratio is set to 4:3 as it is the one used by traditional animators, who
are accustomed to working with the grid system described above.

3. In the Number of Units fields, enter the number of horizontal, vertical and depth units for your scene’s
grid.

Animators who prefer to work traditionally will understand the default setting of 24 units horizontal by 24
units vertical as it, once again, corresponds to the grid above. Twelve is a common setting for the field
depth.

Those who prefer to work in pixels should enter the pixel dimensions (3) of their project. This way if you
want to move something over 600 pixels you just need to type in 600 units.

4. In the Coordinates at Centre, you can enter a new coordinate for the centre of your scene.

By default, the (0,0) centre is set in themiddle of the grid as shown in the grid above. If you want to
change the centre of your grid, for example to the upper left corner, you would enter (-12, 12), -12 units
across and 12 units up. That is of course unless you changed the number of units to match the pixel
dimensions of your scene. Then you would enter negative half the width and positive half the height.

5. Click Save button to save your current Alignment settings and be able to select them later from the list.

The Choose Alignment Name dialog box opens.

Type in a name for your new alignment settings and click OK.

Related Topics

• Scene Settings on page 15

• Alignment Tab on the previous page

• Advanced Tab below

Advanced Tab

The Advanced tab contains an option for Toon BoomDigital Pro release 7.3 and Harmony release 7.3.

Since version 7.8, themethod in which Z-Ordering is calculated has been optimized. Enable this option if you
want to use the version 7.3 system.

Toon BoomDigital Pro and Toon BoomHarmony 7.3 allowed smaller values on the Z-axis such as 0.0001. Since
version 7.8, the Z-ordering calculation is now optimized and allows only larger values such as 0.001.

Related Topics

• Scene Settings on page 15
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• Resolution Tab on page 16

• Alignment Tab on page 18
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Verifying Project Integrity
TheCheck Files command verifies the integrity of the drawing and palette files in your project.

To open the Check Files dialog box:

‣ In the top menu, select File > Check Files.

Check Files
Use theCheck Files dialog box to verify that the data is consistent, correct, and accessible.

• Click on theCheck Colours button to open theCheck Colours dialog box.

Check Colours
TheCheck Colours dialog box checks the palette integrity and displays the colour recovery data.
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• Launching the Harmony Xsheet on page 11

• Launching the Harmony Xsheet on page 11

• Setting the Scene Length on page 14

• Scene Settings on page 15
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Chapter 1: Interface

Knowing how to manage the Harmony Xsheet interface helps you to work efficiently and organize your
workspace conveniently. There are a series of features and tools you can use as you perform different
operations. Each user has a preferred way of working in the interface and which features and tools they will use.
In this chapter, you will learn about themain elements of the interface and how to manage them.

Topics Covered

• User Interface on the next page

• Menu on page 34

• Toolbars on page 36

• Interface Navigation on page 43

• Preferences on page 46



Chapter 1: Interface User Interface

24

User Interface
This section takes you through themost common elements of the user interface.

The Harmony Xsheet has two views and a row of tools that are available at the top of the interface or view.

1. Xsheet Main Section 2. ColumnHeader

3. FrameNumbers 4. Current Drawing

5. Current Frame 6. Drawing Exposure

7. Current FrameDisplay 8. Increase/Decrease Exposure

9. Overwrite/Insert Modes 10. Column List

11. Menu 12. Toolbars

Related Topics

• Xsheet Main Section on the facing page

• ColumnHeader on page 26

• FrameNumbers on page 27

• Current Drawing on page 28

• Current Frame on page 28
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• Drawing Exposure on page 29

• Current FrameDisplay on page 29

• Increase/Decrease Exposure on page 30

• Overwrite/Insert Modes on page 30

• Function Column on page 31

• Column List on page 32

Xsheet Main Section

The Xsheet view has two sections. Only themain section is visible by default. It displays the drawing columns.

When using advanced compositing and animation techniques, unconnected functions (motion paths) also appear
in themain section. Unconnected functions mean that somemotion paths are not attached to any particular
layer.

When you reconnect functions to a layer they are still visible in the main section.
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Related Topics

• ColumnHeader below

• FrameNumbers on the facing page

• Current Drawing on page 28

• Current Frame on page 28

• Drawing Exposure on page 29

• Current FrameDisplay on page 29

• Increase/Decrease Exposure on page 30

• Overwrite/Insert Modes on page 30

• Function Column on page 31

• Column List on page 32

Column Header

Each column available in the Xsheet view has a header displaying the column’s name. The column’s name is the
same as the corresponding timeline layer. If you rename one or the other, they will both be renamed.

A quick access menu is available when you right-click. This menu contains the command affecting an entire
column such as renaming, changing the default colour or deleting a column.

In Harmony, the column header shows the layer’s name and the name of the drawing folder to which it is linked. If
the name of the layer is the same as the drawing folder, the drawing folder’s namewill not be displayed. For
example; when you link a Timing column to a certain element (and thereby the Element’s folder).

The tooltip that appears when you hover your cursor at the top of each Xsheet column shows the absolute folder
path to the source drawings for that column.

Related Topics

• Xsheet Main Section on the previous page

• FrameNumbers on the facing page

• Current Drawing on page 28

• Current Frame on page 28
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• Drawing Exposure on page 29

• Current FrameDisplay on page 29

• Increase/Decrease Exposure on page 30

• Overwrite/Insert Modes on page 30

• Function Column on page 31

• Column List on page 32

Frame Numbers

On the left side of the Xsheet view, the frame numbers are shown indicating where you are. These read vertically
instead of being displayed horizontally as they are in the Timeline view.

• To go to a particular frame, click the frame number.

• To select an entire range of frames, click and drag a selection downwards.

Related Topics

• Xsheet Main Section on page 25

• ColumnHeader on the previous page

• Current Drawing on the next page

• Current Frame on the next page

• Drawing Exposure on page 29

• Current FrameDisplay on page 29

• Increase/Decrease Exposure on page 30
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• Overwrite/Insert Modes on page 30

• Function Column on page 31

• Column List on page 32

Current Drawing

A cell selected in dark red indicates that the cell is currently selected.

Related Topics

• Xsheet Main Section on page 25

• ColumnHeader on page 26

• FrameNumbers on the previous page

• Current Frame below

• Drawing Exposure on the facing page

• Current FrameDisplay on the facing page

• Increase/Decrease Exposure on page 30

• Overwrite/Insert Modes on page 30

• Function Column on page 31

• Column List on page 32

Current Frame

The darker frame appearing in the Xsheet view represents the current selected frame.

Related Topics

• Xsheet Main Section on page 25

• ColumnHeader on page 26

• FrameNumbers on the previous page

• Current Drawing above

• Drawing Exposure on the facing page
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• Current FrameDisplay below

• Increase/Decrease Exposure on the next page

• Overwrite/Insert Modes on the next page

• Function Column on page 31

• Column List on page 32

Drawing Exposure

In the drawing columns, you can see the drawing names and their exposure. You can use any alphanumeric
symbol to name your drawing. When a drawing is exposed over more than one cell, a vertical black line is
displayed to indicate the continuity of the exposure. When there is no drawing in a cell, the cell will be blank.

Related Topics

• Xsheet Main Section on page 25

• ColumnHeader on page 26

• FrameNumbers on page 27

• Current Drawing on the previous page

• Current Frame on the previous page

• Current FrameDisplay below

• Increase/Decrease Exposure on the next page

• Overwrite/Insert Modes on the next page

• Function Column on page 31

• Column List on page 32

Current Frame Display
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At the bottom of the Xsheet view, you can see the current cell number as well as the name of the column
containing the currently selected cell.

Related Topics

• Xsheet Main Section on page 25

• ColumnHeader on page 26

• FrameNumbers on page 27

• Current Drawing on page 28

• Current Frame on page 28

• Drawing Exposure on the previous page

• Increase/Decrease Exposure below

• Overwrite/Insert Modes below

• Function Column on the facing page

• Column List on page 32

Increase/Decrease Exposure

You can quickly increase or decrease the exposure of the selected cell by clicking on the up and down arrows in
the Increase/Decrease Exposure field.

Related Topics

• Xsheet Main Section on page 25

• ColumnHeader on page 26

• FrameNumbers on page 27

• Current Drawing on page 28

• Current Frame on page 28

• Drawing Exposure on the previous page

• Current FrameDisplay on the previous page

• Overwrite/Insert Modes below

• Function Column on the facing page

• Column List on page 32

Overwrite/Insert Modes
TheOverwrite/Insert button allows you to decide the way the values are inserted into your Xsheet.
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Related Topics

• Xsheet Main Section on page 25

• ColumnHeader on page 26

• FrameNumbers on page 27

• Current Drawing on page 28

• Current Frame on page 28

• Drawing Exposure on page 29

• Current FrameDisplay on page 29

• Increase/Decrease Exposure on the previous page

• Function Column below

• Column List on the next page

Function Column

The function columns are displayed in the Functions section of the Xsheet view. They represent themotion and
rotation you applied to your drawing layer. Only the function columns related to the selected layer are displayed.

A function column can also be related to an effect. Selecting your effect layer shows you the corresponding
function column in the Xsheet view.

The function columns display the position value or effect value on each cell. If there is a keyframe on a cell, a black
square is displayed. Holding the same value for several frames displays a vertical black line.

Holding the same value for several frames displays a vertical black line.

Related Topics

• Xsheet Main Section on page 25

• ColumnHeader on page 26

• FrameNumbers on page 27

• Current Drawing on page 28

• Current Frame on page 28

• Drawing Exposure on page 29
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• Current FrameDisplay on page 29

• Increase/Decrease Exposure on page 30

• Overwrite/Insert Modes on page 30

• Column List below

Column List

The Column List section allows you to show and hide columns from your Xsheet view.

You can use the Column List to show or hide individual columns or hide an entire column type (drawing or
function) from your Xsheet view. By default, the Functions section is hidden.

To display the Column List section:

1. In the Xsheet view, click on the Expand button located on the right side of themain section to show the
Functions section. Click on the same button to collapse it. You can also use the Show Column List

button in the Xsheet View toolbar.

‣ In Harmony Xsheet, you can also go to the Xsheet View menu and select View > Show Column List.

2. Click on the Expand button on the right side of the Functions section to display the Column List section.
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The types of columns that you can show or hide by clicking on the buttons are:

• Drawing columns • 3D rotation columns

• Function columns • Sound columns

• 3D path columns • Annotation columns

For more information regarding column types, please refer to the Toon Boom Harmony User Guide.

You can also show/hide columns by checking or unchecking the column name under the Show/Hide icon . You

can use various combinations of the column type buttons and Show/Hide check boxes to reduce the amount of
visual clutter in your Xsheet.

Related Topics

• Xsheet Main Section on page 25

• ColumnHeader on page 26

• FrameNumbers on page 27

• Current Drawing on page 28

• Current Frame on page 28

• Drawing Exposure on page 29

• Current FrameDisplay on page 29

• Increase/Decrease Exposure on page 30

• Overwrite/Insert Modes on page 30

• Function Column on page 31
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Menu

The top menu contains most of the commands. Depending on the view you are working in and the element,
some commands are available and others not. The top menu is always located at the very top of the user
interface.

The top menu contains the following categories:

• File

• Edit

• Scene

• Selected

• View

• Options

• Frames

• Columns

• Help

Quick Access Menu

Each view has a quick menu containing recurring actions. TheQuick Menu is accessed by right-clicking anywhere
in the view.
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Related Topics

• Interface on page 23
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Toolbars
The Xsheet Module user interface contains toolbars which, by default, are located at the top of the interface.
These toolbars can bemoved around. You can reposition the toolbars to suit your work style or hide unused
ones.

Related Topics

• File Toolbar below

• Edit Toolbar on the facing page

• Xsheet Toolbar on the facing page

• Moving Toolbars on page 40

• Toolbar Manager on page 41

File Toolbar

Use the commands from this toolbar to preform basic file functions.

• Use theOpen button to bring up the Database Selector dialog box. Select a new Environment, Job

or Scene. The [Ctrl] + [O] (Windows/Linux) or [⌘ ] + [O] (MacOS X).

• Use the Save button to save all changes made to the open scene. The [Ctrl] + [S] (Windows/Linux) or

[⌘ ] + [S] (MacOS X).

• Use the Import Images button to open the Import Images dialog box. Use this dialog box to bring in

a single image or multiple images. Harmony Xsheet supports JPEG, BMP, PNG, TGA, PSD, IFF, SGI, TVG,
OMF, PAL and SCAN.

For a detailed description of all the options available in the Import Images dialog box, please refer to
the Toon Boom Harmony User Guide.

Related Topics

• Edit Toolbar on the facing page

• Xsheet Toolbar on the facing page

• Moving Toolbars on page 40

• Toolbar Manager on page 41
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Edit Toolbar

Use the commands from this toolbar to perform basic editing functions.

• Use theUndo command to remove the last changemade. The Harmony Xsheet supports multiple

undos, so you can reverse changes you havemade in the order that youmade them. The [Ctrl] + [Z]
(Windows/Linux) or [⌘ ] + [Z] (MacOS X).

• Use the Redo command when you have undone an operation that you decide to keep. The Redo

command becomes active only after you use theUndo command. The [Ctrl] + [Shift] + [Z] (Windows/Linux)
or [⌘ ] + [Shift] + [Z] (MacOS X).

• Use theCut command to remove selected cells, groups of cells or all the cells in a column. You can

then paste the cells into anther column in theXsheet view. The [Ctrl] + [X] (Windows/Linux) or [⌘ ] + [X]
(MacOS X).

• Use theCopy command to copy a selected cell and cell properties. The[Ctrl] + [C] (Windows/Linux) or

[⌘ ] + [C] (MacOS X).

• Use the Paste command to place cells you cut or copied into the new location you select in the

Xsheet view. The [Ctrl] + [V] (Windows/Linux) or [⌘ ] + [V] (MacOS X).

Related Topics

• File Toolbar on the previous page

• Xsheet Toolbar below

• Moving Toolbars on page 40

• Toolbar Manager on page 41

Xsheet Toolbar

The Xsheet view has its own toolbar where you can find themost common features. This toolbar is displayed by
default. Use the commands from this toolbar to preform drawing exposure functions.

You can customize the Xsheet view toolbar: refer to the Toolbar Manager on page 41 topic for a
detailed explanation.
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• Show Thumbnails: displays a thumbnail image of the drawing that is being referred to by the

selected column frame at the top of the column, just under the column header.

• Show Column List: Expands and collapses the Column List section and theMain Xsheet View so that

they can be displayed in the interface, or hidden from view.

Refer to the Column List on page 32 topic for a detailed example.

• AddColumn: Adds a column to the Xsheet to the left of the selected column. TheAddColumn

dialog box appears, allowing you to type in the column name and chose the column type from the drop-
downmenu. If you wish to addmultiple columns in one go, click on theApply button instead ofOK.

• Delete Column: Deletes the selected column. Click on the column header to make your selection.

• Clone Column: Provides you with a copy of the selected column that uses the same drawings as the

original. If youmodify a drawing in the cloned or original column, it is updated in both layers. You can
modify the timing of each column independently, one apart from the other, but the drawings remain
linked.

• Duplicate Column: Provides you with an independent copy of the drawings and their exposure. You

canmodify anything you want in the duplicated columnwithout affecting the original version.

• Add Frame: Brings up theAdd Frames dialog. Enter the number of frames that you would like to

add to a column either by typing it in, or by using the up and down arrows and then click OK. The number
of frames entered will appear under the selected row in every column.
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• Remove Frame: Removes the selected frames.

• Use the Import Images button to open the Import Images dialog box. Use this dialog box to bring in

a single image or multiple images. Harmony Xsheet supports JPEG, BMP, PNG, TGA, PSD, IFF, SGI, TVG,
OMF, PAL and SCAN.

• Create Empty Drawing: TheCreate Empty Drawing command automatically creates a drawing in

the selected cell in the Xsheet view, replacing any drawing that may already be exposed in that cell and
the following ones until it meets another drawing.

• To create an Empty Drawing:

1. In the Timeline or Xsheet view, select the cell you want to create an empty drawing in.

2. In the Xsheet View toolbar, click on theCreate Empty Drawing button.

3. The new drawing will be created in the Xsheet.

• Duplicate Drawing: If you want to modify a drawing that already exists, but keep the original

drawing intact, you can duplicate the drawing and work on the copy. When duplicating a drawing, the
selected cell is replaced with the new drawing. The exposure of the original drawing that was on the
current cell is removed. The drawing is not deleted.

• Delete: Deletes the exposure of the selected frames or columns.

• Mark as Key Drawing: Allows you to mark the key drawings by inserting a in that drawing’s cell.

This is useful for a traditional animation style work environment when pauses need to be added to the
timing of a character’s action. It helps to keep the Xsheet organized while animating.

• Mark as Breakdown Drawing: Allows you to mark the breakdown drawings by inserting a in that

drawing’s cell.

• Mark as In-between Drawing: There is no icon displayed in the cell for theMark as In-between

Drawing option, as it is used to remove themarker of a drawing identified as a key or breakdown
drawing and revert it to a normal in-between drawing.

Related Topics

• File Toolbar on page 36

• Edit Toolbar on page 37

• Moving Toolbars on the next page

• Toolbar Manager on page 41
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Moving Toolbars
You can drag and reposition the toolbars around the interfaceso that they aremore convenient for you to use.

Tomove a toolbar:

1. Select the toolbar you want to move by clicking on its anchor point and dragging it into a view

toolbar area or another position in the top or side interface toolbar area.

2. When a rectangle outline appears showing an available location for the toolbar, release themouse button
and drop the toolbar into position.

If you close a floating toolbar and would like to bring it back, simply right-click on the empty toolbar space at the
top of the interface and select themissing toolbar.

Related Topics

• File Toolbar on page 36

• Edit Toolbar on page 37

• Xsheet Toolbar on page 37

• Toolbar Manager on the facing page
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Toolbar Manager
The View toolbars can be customized to contain your favourite tools and options. Use the Toolbar Manager
window to organize your different toolbars to suit your working preferences.

To customize your toolbars:

1. Right-click on the chosen toolbar’s anchor point.

A pop-up menu appears.

2. Select Customize from the pop-up menu.

The Toolbar Managerwindow opens

3. To add a new icon to your toolbar, select the tool or command from theAvailable Tools list and click on
the
Right Arrow button to add it to the Toolbar list.

4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click on the
Left Arrow button to send it back to the Available Tools list.

5. To reorder your icons in your toolbar, select the command to bemoved in the Toolbar list and click on the
Up or Down Arrow buttons to move it to the correct location.
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6. Click on theOK button when you are finished.

Related Topics

• File Toolbar on page 36

• Edit Toolbar on page 37

• Xsheet Toolbar on page 37

• Moving Toolbars on page 40
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Interface Navigation

Topics Covered

• View Commands below

• Resizing a View below

• ColumnColours on the next page

View Commands
• Zoom In: Zooms into the view. From the top menu, select View > Zoom In. The [2].

• Zoom Out: Zooms out of the view. From the top menu, select View > Zoom Out. The [1].

• Reset Zoom: From the top menu, select View > Reset Zoom.

• Reset Pan: If you are scrolled far down across all your columns in theXsheet view and would like to return
to the first column, select View > Reset Pan. The [Shift] + [N].

• Reset View: If you have zoomed in or out of your Xsheet view and would like to return to the 100% view,
select View > Reset View. The [Shift] + [M].

Related Topics

• Resizing a View below

• ColumnColours on the next page

Resizing a View
To change the width and height of the views in the workspace, drag the side of the view.

To resize a view:

1. In the interface, position your cursor on the edge of the view youwant to resize.

2. When you see the Resizing cursor, click and drag the side of the window to the desired width or

height.
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You can also temporarily hide a view to get more working space.

To temporarily hide a view:

1. On the edge of the window youwant to hide click on the Collapse/Expand button.
The view is compressed and only the Collapse/Expand button is visible.

2. Click on the sameCollapse/Expand button to display the view again.

Related Topics

• View Commands on the previous page

• ColumnColours below

Column Colours
When you are dealing withmany different types of columns (such as drawing, function and 3D paths) or perhaps
when you are dealing with a many of the same type of columns (such as the various body parts of a character),
sometimes it is helps to colour your columns. By changing the column colours to different shades to indicate
different types of groupings, you can better visually organize your Xsheet space.

To change the colour of a column:

1. In the Xsheet view, select one or more columns to modify.

2. Right-click on the Column header of the column and from the pop-up menu, select Colour > Change
Column Colour.

The Select Colourwindow appears.

3. Click in the colour spectrum. A black cross-hair shape appears. Use your cursor to move the black cross
around until you find a suitable colour. You will be able to see a more precise sample of the selected
colour in the rectangle frame below.

4. If you intend to use the same shade for multiple columns, click on the Add to CustomColours button. This
will add the colour swatch to the Custom colours section in the Select colour window. If you then continue
to make other colour selections, you can always go back to that saved colour swatch, even after the
Select colour window has been closed.

5. When you are through, click on theOK button.

The body of the column now appears coloured with the selected shade.
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When you are finished your scene, youmight decide that you want to eliminate all your personal column colours.

To bring your column colours back to their default white state:

1. In the Xsheet view, select one or more columns to modify.

2. Right-click on the column header and from the pop-up menu select Colour > Default Column Colour.

The coloured columns revert back to their default white colour in the Xsheet view.

Related Topics

• View Commands on page 43

• Resizing a View on page 43
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Preferences
An important feature in the Harmony Xsheet is the Preferences panel. From here you can customize your
interface, tool behaviour and keyboard shortcuts. In this section you will learn how to access the Preferences
panel and also find a general description of its functionality.

The Preferences panel is divided into the following tabbed sections:

• Shortcuts

• General

• Exposure Sheet

Accessing the Preferences Panel
To access the Preferences panel:

1. In the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X). The
[Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

Some preferences require you to exit and restart the application or to close a view and reopen it.

For details about the preferences available in the Exposure Sheet tab, please refer to the Timing on
page 51 topic.

Related Topics

• User Interface Preferences below

• Keyboard Shortcuts on page 48

User Interface Preferences
To customize your interface, you will use some of the preferences located in theGeneral category.
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Levels Of Undo
The Levels Of Undo preference determines the number of actions retained by the Undo List. By default, the
system stores 50 actions in the list. You can alter this number if you want to.

This preference does not require you to restart the application.

Colours
TheColours preference allows you to modify the colours of the different elements in the Xsheet. For example,
you can change the colour of a Timing Column from peach to pale green.

• Current View Border

TheCurrent View Border preference sets the colour of the frame around the workspace view you are
currently using, also known as focus. By default, the colour is red. Click on the red colour swatch to select
a new colour in the Select Colourwindow.

• Edit Colours Button
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Click on the Edit Colours button to open theColours window.

In the Colours window, you canmodify any of the colours from the list.

‣ To restore all of the default interface’s colours, click on the Restore All Defaults button.

TheColours window is divided in three categories:

• Columns

• Function Editors

• Others

‣ Click on any of the colour swatches and select a new colour from theColour Pickerwindow.

Related Topics

• Preferences on page 46

Keyboard Shortcuts
To speed up your work, all of the Harmony Xsheet’s keyboard shortcuts can be customized and you can even
choose other software keyboard shortcut sets.

Topics Covered

• Selecting a Keyboard Shortcut Set below

• Customizing a Keyboard Shortcut on the facing page

Selecting a Keyboard Shortcut Set
In the Xsheet Module, you can choose a set of default keyboard shortcuts you are familiar with. You can choose
between the following:

• Adobe Flash
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• Toon BoomHarmony

• Toon Boom Studio

To switch keyboard shortcut sets:

1. Open the Preferences panel. The [Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

2. In the Preferences panel, go to the Shortcuts tab.

3. In the Shortcut Set drop-downmenu, select the desired set.

Related Topics

• Keyboard Shortcuts on the previous page

• Customizing a Keyboard Shortcut below

Customizing a Keyboard Shortcut
You can also customizemost of the shortcuts by opening the Preferences panel and going to the Shortcuts tab.

To set a shortcut:

1. Open the Preferences panel. The [Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

2. In the Preferences panel, go to the Shortcuts tab.

3. In the left window, select the command to modify.

4. Click on the shortcut rectangle (above the right window).

5. On your keyboard, click on the desired shortcut.

‣ To reset a command’s default keyboard shortcut, click theDefault button.

‣ To remove any keyboard shortcut associated to a command, click theClear button.

6. Click OK.
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If a keyboard shortcut is already in use, the Conflict Detected dialog box will appear notifying you of
the command to which it is already associated. You can continue to associate the shortcut or cancel
the operation and choose another command.

• The Replace button associates the selected keyboard shortcut and removes it from any command already
using it.

• TheDuplicate button associates the selected keyboard shortcut with the command and allows other
commands in the list to use the same one.

• TheCancel button stops the operation and lets you select another keyboard shortcut.

Related Topics

• Keyboard Shortcuts on page 48

• Selecting a Keyboard Shortcut Set on page 1
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Chapter 1: Timing

When you create hand-drawn animation, it is important to know how to set and modify the timing of your
drawings. You can adjust the timing in both the Timeline and Xsheet views, depending onwhich technique you
are used to working with. If you are a digital animator, you will probably use the Timeline view. If you aremore of
a traditional animator, you will probably work with the Xsheet view (exposure sheet). Harmony offers you both.

In this topic, you will learn how to work on your drawing’s exposure and length. The exposure and animation
paths for symbols are covered in separate chapters.

Topics Covered

• Understanding the Timeline View on page 1

• Understanding the Xsheet View on page 1

• Frames on the next page

• Layers and Columns on page 57

• Filling Exposure on page 78

• Navigating between Frames and Columns on page 100

• Managing Drawings on page 102

• Tempo Markers on page 106

• Annotation Columns on page 108

• Printing the Xsheet on page 114

• Element Manager on page 116

• Timing Preferences on page 117
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Frames
One of the first things to learn in Toon BoomHarmony is how to add or delete frames in your scene.

Related Topics

• Adding Frames below

• Deleting Frames on page 54

Adding Frames
There are several ways to add frames to your scene using Toon BoomHarmony.

Related Topics

• Setting the Scene Length below

• Extending the Timeline View below

• Adding Frames Before or After a Selection on the facing page

• Adding Frames to the Beginning or at the End of a Scene on the facing page

Setting the Scene Length
You can set the global scene length from the top menu.

To set the set scene length:

1. Select Scene > Set Scene Length.

The Set Scene Length dialog box opens.

2. In the Number of Frames field, type how many frames are needed.

Extending the Timeline View
You can quickly extend your scene length in the Timeline view.

To extend your scene in the Timeline view:

1. In the Timeline view, drag the scene length bracket to the right to addmore frames to your scene.
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Adding Frames Before or After a Selection
You can add frames anywhere in themiddle of the scene. If you select a frame row in the Xsheet view, the system
will add the new frames before or after the selection, depending on your choice.

To add frames before or after selection:

1. In the Xsheet view, select a frame row.

2. Do one of the following:

‣ Select Scene >Frame >Add Frames Before Selection or Add Frames After Selection.

‣ Press [Ctrl] + [G] and [Ctrl] + [H] (Windows/Linux) or [⌘ ] + [G] and [Ctrl] + [H] (MacOS X).

In Harmony Xsheet, select Frame >Add Frames Before Selection or Add Frames After Selection.

The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the amount of frames needed in the scene.

To add new frames after your selection, you can also use the Add Frames button in the Xsheet

View toolbar.

Adding Frames to the Beginning or at the End of a Scene
You can add some frames to the beginning or at the end of the scene.

To add frames at start or at end:

1. Select Scene > Frame > Add Frames at Start or Add Frames at End.

In Harmony Xsheet, select Frame > Add Frames at Start or Add Frames at End.

The Add Frames dialog box opens.
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2. In the Number of Frames to Add field, enter the number of frames needed in the scene.

To add new frames at the end of your scene, you can also use the Add Frames button found in

the Xsheet View toolbar.

Related Topics

• Deleting Frames below

Deleting Frames
There are three ways to delete frames from your scene:

• Reducing the Timeline Length below

• Removing Selected Frames on the facing page

• Deleting a Selected Frame Range on the facing page

When you remove frames from the end of your scene, the exposed drawings and symbols are not
deleted. If you extend your scene afterwards, these drawings and symbols are still available.

Reducing the Timeline Length
You can quickly reduce your scene length in the Timeline view.

To reduce your scene in the Timeline view:

1. In the Timeline view, drag the scene length bracket to the left to remove frames from your scene.
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Removing Selected Frames
You can remove any selected frame in your Xsheet view, such as the last frame of your scene.

To remove a selected frame:

1. In the Xsheet view, select a frame in a given column.

2. In the Xsheet View toolbar, click the Remove Frames button. To remove several frames, click the

button repeatedly.

You can also select Scene > Frame > Remove Selected Frames from the top menu.

In Harmony Xsheet, select Frame > Remove Selected Frames from the top menu.

Deleting a Selected Frame Range
In the Xsheet view, you can remove any selected frame range.

To delete a frame range:

1. In the Xsheet view, select a frame range by clicking the first frame’s number and then dragging the
selection highlight down to the last frame to delete.

2. Do one of the following:

‣ Press [Delete] to delete the selection.

‣ From the top menu, select Scene > Frame > Remove Selected Frames.

‣ Click Remove Frames button.

In Harmony Xsheet, go to Frame > Remove Selected Frames.

TheWarning dialog box opens.
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3. To complete the operation:

‣ Click Yes to delete the selection.

‣ Click No to only delete the exposure in the cell and not the frames.

‣ Select theDon’t Show This Message Again option to prevent the warning message from being
displayed each time you delete a frame range.

Related Topics

• Adding Frames on page 52
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Layers and Columns
In Toon BoomHarmony there are two ways to see your layers:

• As horizontal layers in the Timeline view

• As vertical columns in the Xsheet view

In Harmony, you can also see your layers displayed in theNetwork view as modules.

Whether you work in the Timeline or Xsheet view, they are the same and anymodification you do to one or the
other will be applied to both.

Related Topics

• Layer and ColumnConcepts below

• Adding New Drawing Layers on page 60

• Deleting Layers and Columns on page 65

• Modifying Layers on page 67

• Duplicating Layers and Columns on page 71

• Cloning Layers And Columns on page 72

• Xsheet Thumbnails on page 73

• Changing the Colour of a Column or Layer on page 1

• Expanding and Collapsing Layers and Columns on page 74

• Modifying the Look of the Column on page 75

When working in Harmony Xsheet, only the Xsheet view and its functionalities are available.

Layer and Column Concepts
In order to understand what happens when you duplicate a drawing, extend an exposure, create cycles or delete
a drawing, it is important to know how a layer works.

Each layer is linked to a directory, this is the location where all of that layers' drawings are saved. This directory
has the same name as the layer. When a value or drawing name is typed in a layer’s cell, the system looks in the
layer’s directory for the corresponding drawing to display. If there is no corresponding drawing, a new one is
created.

The layer’s cells are not used for storage, but are linked to the drawings contained in the layer’s directory. If you
remove a drawing from the layer exposure, it is not deleted, but is simply not displayed.
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When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This means
that when youmodify, repaint or correct a drawing named “1,” all drawings named “1” are updated
simultaneously. In order to modify a drawing independently from its other exposures, youmust duplicate the
drawing.

Related Topics

• Layers and Columns on the previous page

• Layer Types on page 1

• Advanced Column Types below

• Layer Content on page 1

• Adding New Drawing Layers on page 60

• Deleting Layers and Columns on page 65

• Modifying Layers on page 67

• Duplicating Layers and Columns on page 71

• Cloning Layers And Columns on page 72

• Xsheet Thumbnails on page 73

• Changing the Colour of a Column or Layer on page 1

• Expanding and Collapsing Layers and Columns on page 74

• Modifying the Look of the Column on page 75

• Duplicating a Drawing on page 103

Advanced Column Types
In theXsheet view, you can add several advanced column types:

• Timing column

• 3D Path column
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• 3D Rotation column

• Bezier Curve column

• Ease Curve column

• Expression column

• Annotation column

These columns are used to create particular animation paths. When you create those columns, they are not
linked to any particular drawing layer. You can create a motion path using these column and then attach several
drawing or peg layers to it.

Related Topics

• Timing Columns below

• Annotation Columns on page 108

Timing Columns

Timing columns are unique in that they can reference a source folder outside of the project folder to bring
images into the project. An example of how this feature can be used is if you havemany background scenes
created in a third party software that youmight need to update in the future. By using Timing columns, you can
dynamically link your backgrounds, expose different backgrounds at different times, and have live, automatic
updating capabilities.

The danger with this type of dynamic linking is that if the project file is moved, or the folder that the
column is linked to is moved, then the link is broken and the images that were in that folder will
disappear in Toon Boom Harmony.

To use a Timing column:

1. In the Xsheet view, click on theAddColumns button.

2. In the Add Column dialog box that appears, type in the name of the new column, then from the Type
drop-downmenu select Timing.

3. Click OK if you are finished, or on theApply button if you want to continue adding more columns and
column types.

A peach coloured column appears in your Xsheet with the name that you typed in, and for themoment,
<unused>.

4. In the Network view, add a new element module.
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5. Open the Layer Properties editor by clicking on the yellow square.

6. In the Drawing tab, select the Timing Columns option.

7. In the Name field, enter the path of the folder you want to access. If you use the Browse button to locate a
folder, you will have to select a file in the folder you want and then delete the dash and the suffix (for
example, background-01 should be renamed to background) from the file name in the field. If you leave
the full file name selected, Stage will display that file for the entire duration of the scene, regardless of the
contents of the Timing Column field.

This means that all the images in the folder that you are linking to are named using the naming
convention described above. If for some reason you are unable to access a certain directory, type the
directory extension directly in the path extension field at the top of the Browser window.

8. In the Timing Column field, click theArrow button to create a new timing column, or select the name of
the column from the drop-down list. If you have an element directory selected in theName field, the
Timing Columnwill indicate which files are called up from that element directory. Remember that the file
displayed at each frame is based on the element name, the cell label, and the extension. If the element is
toto, the timing column is labeled 1, 2, and 3, and the extension is TVG, Stage will display drawings
totobody-1.tvg, totobody-2.tvg, and totobody-3.tvg at the selected frames.

In the Xsheet, the <unused> should now have changed to the name of your module in theNetwork view.

9. From the Extension drop-down list, select the extension of the files you want to display.

10. Click OKwhen you are done.

11. In the Xsheet, in your Timing column, type in the number that corresponds to the suffix of the drawing file
that you wish to expose to make it appear in the Camera view.

Related Topics

• Layers and Columns on page 57

• Layer and ColumnConcepts on page 57

• Advanced Column Types on page 58

• Timing Columns on the previous page

• Linking your Layer to an External Image

Adding New Drawing Layers
In this section, you will learn the different ways to add a drawing layer to your project. By default, when you
create a new scene there is one Drawing layer included in your Timeline view.
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This topic is divided as follows:

• Adding Drawing Layers in the Timeline View below

• Adding a Drawing Layer from the TopMenu on the next page

• Adding Drawing Columns in the Xsheet View on the next page

Adding Drawing Layers in the Timeline View
You can add a new layer in the Timeline view in several different ways:

• Using the Layer toolbar

• Using the Add Layers dialog box

• Go to the Timeline view menu and select Insert > Drawing.

To add a Drawing layer using the Timeline’s Layer toolbar:

1. In the Timeline’s Layer toolbar, click theAdd Layers button or press [Ctrl] + [R] (Windows/Linux) or

[⌘ ] + [R] (MacOS X).

2. In the drop-downmenu, select theDrawing option.

A new layer appears in the Timeline and Xsheet views.

You can also click on the Add Drawing Layer button in the Timeline’s Layer toolbar or press [Ctrl] + [R]
(Windows/Linux) or [⌘ ] + [R] (Mac OS X).

To add drawing layers using the Add Layers dialog box:

1. In the Timeline view’s layer section,right-click and select Insert > Add Layer(s).

The Add Layers dialog box opens.

2. In the Type drop-downmenu, select theDrawing option.

3. In the Number field, use the up and down arrows or type the number of layers you want to add at once.
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4. In the Name field, type the name of the layer you want to add. If you are adding more than one layer at
once, all of the layers use that namewith a numerical suffix added.

5. To complete the operation:

‣ Click OK to add your new layers and close the dialog box.

‣ Click Apply to add your new layers and keep the dialog box open to add another layer.

‣ Click Close to cancel the operation.

Adding a Drawing Layer from the Top Menu
You can add a new layer from the top menu.

To add a new layer from the topmenu:

1. In the top menu, select Insert > Drawing.

A new layer appears in the Timeline and Xsheet views.

Adding Drawing Columns in the Xsheet View
To add a drawing column:

1. Do one of the following:

‣ In the Xsheet view, right-click and select Columns > AddColumn.

‣ In the Xsheet View toolbar, click theAddColumns button or press [Shift] + [C]].

‣ To quickly add a Drawing column, press [Ctrl] + [R] (Windows/Linux) or [⌘ ] + [R] (MacOS X).

The Add Columns dialog box opens.

2. In the ColumnName field, name your column accordingly.

3. In the Column Type field, select Drawing.

Refer to the topic Layer Types on page 1 to know more about the different column types available.

4. To complete the operation:

‣ Click OK to add your new layers and close the dialog box.

‣ Click Apply to add your new layers and keep the dialog box open to add column.

‣ Click Close to cancel the operation.

In Harmony, you can use the advanced Add Column dialog box, withmore file format and field size options, to
insert the column.
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To create a column in Toon Boom Harmony using the advancedAddColumn dialog box:

1. Select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X) and select the
Advanced tab.

2. In the Advanced Options section, select theAdvanced ElementMode option to access the advanced
Add Column dialog box.

3. Click OK.

4. In the Xsheet View menu, select Columns > AddColumn or press [Shift] + [C].

The Add Column dialog box opens.

5. In the Name field, type the new column’s name.

6. In the Type drop-downmenu, select theDrawing type.

7. In the Element section select if you either want to create a new column or link the new column to an
existing one:

‣ Create New Element: Select this option if you want your column to be an independent columnwith
its own drawing folder.

‣ Reuse Existing Folder: Select this option if you want to link your column to an existing folder within
the Element folder of your scene.

If you select the Reuse Existing Folder option, in the Folder drop-down field, select the folder to
which you want to link your new column.

‣ Use Existing Element: Select this option if you want your column to use drawings from an existing
column. Both columns will be attached to the same set of drawings, but their timing will remain
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independent from one another. If youmodify one of the drawings, it will bemodified in both columns.
This is the same principle as the Clone column.

If you select theUse Existing Element option, in the Name drop-down field, select the column to
which you want to link your new column.

8. If you select theCreate New Element option:

‣ Deselect theVector option if you want your layer to contain bitmap images or enable it if you want the
layer to contain vector drawings. Most of the time, theVector option will be enabled.

‣ If you deselected theVector option, from the Bitmap Format drop-down list, select which type of
bitmap image youwish to insert in the column. Select the SCAN type if you are planning to scan
drawings using Toon BoomHarmony’s scanmodule.

‣ If you deselected theVector option and you chose the SCAN type, from the Scan Type drop-down,
select what kind of scanning you wish to achieve.

‣ In the Field Chart field, when importing traditional animation, indicate the size of paper on which the
animation or background was drawn. If you are not using perforated animation paper, leave the 12
field default value as is.

9. Do one of the following:

‣ Click OK button to create the new column and close the dialog box.

‣ Click Apply to create the new column but keep the dialog box opened to create other new columns.

Related Topics

• Layers and Columns on page 57

• Layer and ColumnConcepts on page 57

• Advanced Column Types on page 58

• Layer Content on page 1

• Adding New Drawing Layers on page 60

• Deleting Layers and Columns on the facing page

• Modifying Layers on page 67

• Duplicating Layers and Columns on page 71

• Cloning Layers And Columns on page 72

• Xsheet Thumbnails on page 73

• Changing the Colour of a Column or Layer on page 1

• Expanding and Collapsing Layers and Columns on page 74

• Modifying the Look of the Column on page 75
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Deleting Layers and Columns
You can delete layers from your projects in two different locations:

• Deleting a layer from the Timeline view

• Deleting a column from the Xsheet view

Deleting a Layer from the Timeline View
There are two ways to delete a layer in the Timeline view, using theDelete Layers button and via the quick

access menu. This will also delete the associated modules from theNetwork view.

To delete layers in the Timeline view:

1. In the Timeline view, select the layers to be deleted.

2. In the Timeline’s Layer toolbar, click theDelete Layers button.

You can also right-click on the selection and select Delete.

The ConfirmDelete dialog box opens.

‣ Select theDelete Drawing Files and Element Folders option to delete all drawings and folder linked
to this layer.

3. Select theDelete Xsheet Columns option if you also want to delete the existing column in the Xsheet
view.

Deleting a Column from the Xsheet View
There are two ways to delete a layer in the Xsheet view, using theDelete Columns button and via the quick

access menu.

To delete layers in the Xsheet view:

1. In the Xsheet view, select the columns to be deleted by clicking on their header.
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2. In the Xsheet View toolbar, click theDelete Columns button. You can also right-click on the selection

and select Delete Columns or press [Delete].

The ConfirmDelete dialog box opens.

‣ Select theDelete Drawing Files and Element Folder option if you want to delete the drawings and
folders linked to the selected column.

3. To complete the operation:

‣ Click OK to delete the selected layers.

‣ Click Cancel cancel the operation.

‣ Click Yes button delete all the frames from your scene.

‣ Click No button to keep the frames in your scene.

‣ Select theDon’t Show This Message Again option if you do not want the dialog box to pop again in
the future.

Related Topics

• Layers and Columns on page 57

• Layer and ColumnConcepts on page 57

• Advanced Column Types on page 58

• Layer Content on page 1

• Adding New Drawing Layers on page 60

• Deleting Layers and Columns on the previous page

• Modifying Layers on the facing page

• Duplicating Layers and Columns on page 71

• Cloning Layers And Columns on page 72

• Xsheet Thumbnails on page 73

• Changing the Colour of a Column or Layer on page 1

• Expanding and Collapsing Layers and Columns on page 74

• Modifying the Look of the Column on page 75
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Modifying Layers
Once you added layers to your project, you canmodify their properties, name or ordering.

Related Topics

• Ordering Layers and Columns below

• Showing and Hiding Layers From the Timeline View on page 1

• Showing and Hiding Columns on the next page

• Layer Properties on page 1

• Renaming Layers and Columns on page 70

Ordering Layers and Columns
You can change the order of your layers in the Timeline and Xsheet views. When you change the order of your
layers in one of these views, the other one is updated.

Reordering Layers in the Timeline View

To reorder layers in the Timeline view:

1. In the Timeline view, select the layers to move.

2. Drag the selection to the new location and drop it in between the existing layers. Dropping the selection
on an existing layer would create a hierarchy. Layers located on top of the Timeline view are displayed in
front of the other ones. Layers located at the bottom are displayed behind.

Reordering Columns in the Xsheet View

You can reorder columns in the Xsheet view using themouse’s middle button.

To reorder columns in the Xsheet view:

‣ In the Xsheet view, click on the column’s header with themiddlemouse button and drag the column to its
new position.
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Related Topics

• Layers and Columns on page 57

• Modifying Layers on the previous page

• Showing and Hiding Layers From the Timeline View on page 1

• Showing and Hiding Columns below

• Layer Properties on page 1

• Renaming Layers and Columns on page 70

Showing and Hiding Columns

The Xsheet view has a Column List section that shows all the columns contained in the exposure sheet. It can be
used to hide indivisdual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without
using the Column List section.

You can also hide an entire column type, such as Drawing or Sound.

When a column is hidden in theXsheet view, the corresponding layer is disabled in the Timeline view.

To show and hide columns in the Xsheet view:

1. In the Xsheet View toolbar, click the Show Column List button.

2. Click the Expand button located on the right side of the Functions section to display the Column List

section.

3. In the Column List section, show or hide the columns by clicking in the column checkbox to add or remove
the check mark. You can also click theHide Selected Column button located in theXsheet View

toolbar’s extra buttons.

To show a hidden column from the Xsheet view:

1. In the Xsheet view, click on the thick grey line that appeared in place of the hidden column. You can also
right-click on the column header and select Show Hidden Columns.
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The Show Hidden Columns dialog box opens.

2. In the Show column, enable the hidden columns you want to display in the Xsheet view.

‣ Click Check to check all the selected columns.

‣ Click Uncheck to uncheck all the selected columns.

In Toon BoomHarmony, in the Xsheet view menu, you can select View > Unhide All Columns.

To hide and entire column type:

1. In the Column List section, click theColumn Type button corresponding to the type you want to show or
hide.

‣ The Show/Hide All Columns button shows or hides every column available in theXsheet view.

‣ The Show Drawing Columns button shows the Drawing columns.

‣ The Show Function Columns button shows the Bezier and Ease function columns.

‣ The Show 3D Path Columns button shows the 3D Path function columns.

‣ The Show Sound Columns button shows the Drawing columns.

‣ The Show 3D Rotation Columns button shows the 3D Rotation columns.

‣ The Show Annotation Columns button shows the Annotation columns.
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Column Types Manager
As youwork in Harmony Xsheet, some columns may be in the way or are used as references. You can hide these
columns to make your work area easier and less cluttered. In the Xsheet view, you have the choice of hiding or
showing certain types of columns, such as Annotation and Function.

To show and hide column types:

1. In the Xsheet View menu, select View > Column Types Manager.

The Column Types dialog box opens.

2. Select the types of columns you want to display and disable the ones you want to hide.

3. Click Set As Default to make these new settings the default ones used each time you start the
application. Click Restore Default to restore the settings used when installing the application.

Related Topics

• Layers and Columns on page 57

• Modifying Layers on page 67

• Showing and Hiding Layers From the Timeline View on page 1

• Layer Properties on page 1

• Renaming Layers and Columns below

Renaming Layers and Columns
You can rename a layer in two different ways; in the Layer Properties editor or directly on the Timeline’s layer.

To rename a layer in the Timeline view:

1. In the Timeline view, double-click on the name of the layer to rename.

2. In the Name field, rename the layer and press [Enter/Return] to validate themodifications.

To rename a layer in the Layer Properties editor:

1. In the Timeline view, double-click on the layer to rename.

The Layer Properties editor opens.

2. In the Name field, rename the layer.
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3. Click Close.

To rename a column:

1. In the Xsheet view, double-click on the column name to rename. Do not click on the drawing folder name
that the column is linked to (this also appears in the column header just below the column name).

The Column Editor dialog box opens.

2. In the Name field, rename the column.

3. Click OK.

4. Click Apply/Next to apply the new name and open the editor for the following column.

Related Topics

• Layers and Columns on page 57

• Modifying Layers on page 67

• Showing and Hiding Columns on page 68

Duplicating Layers and Columns
Duplicating a layer provides you with an independent copy of the drawings and their exposure. You canmodify
anything you want in the duplicated layer without affecting the original one. In the Network view, you can
duplicate the selected modules in the sameway.

To duplicate a layer:

1. In the Timeline or Xsheet view, click the layer you want to duplicate.

2. Select Edit > Duplicate or click theDuplicate Layer button in the Xsheet View toolbar and

TimelineView toolbar.

In Harmony Xsheet, select Edit > Duplicate Selected Element.

The new duplicated layer or column appears.

Related Topics

• Layers and Columns on page 57
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• Layer and ColumnConcepts on page 57

• Advanced Column Types on page 58

• Layer Content on page 1

• Adding New Drawing Layers on page 60

• Deleting Layers and Columns on page 65

• Modifying Layers on page 67

• Cloning Layers And Columns below

• Xsheet Thumbnails on the facing page

• Changing the Colour of a Column or Layer on page 1

• Expanding and Collapsing Layers and Columns on page 74

• Modifying the Look of the Column on page 75

Cloning Layers And Columns
Cloning a layer provides you with a copy of the selected layer that uses the same drawings as the original. If you
modify a drawing in the cloned or original layer it is updated in both layers. You canmodify the layers’ timing
independently one from the other, but the drawings remain linked. You can clone selected modules from the
Network view in the sameway.

This feature is useful when youwant to reuse a hand-drawn animation but have different timings.

To clone a layer:

1. In the Timeline or Xsheet view, click on the layer you want to clone.

2. Select Edit > Clone or click theClone Layer button in the Xsheet View toolbar and Timeline View

toolbar.

In Harmony Xsheet, select Edit > Clone Selected Columns.

The new cloned layer or column appears.

Related Topics

• Layers and Columns on page 57

• Layer and ColumnConcepts on page 57

• Advanced Column Types on page 58

• Layer Content on page 1

• Adding New Drawing Layers on page 60

• Deleting Layers and Columns on page 65

• Modifying Layers on page 67
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• Duplicating Layers and Columns on page 71

• Xsheet Thumbnails below

• Changing the Colour of a Column or Layer on page 1

• Expanding and Collapsing Layers and Columns on the next page

• Modifying the Look of the Column on page 75

Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it is not always easy to quickly identify a
particular column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail
picture of the current frame below the column header.

To display the thumbnails:

1. In the Xsheet view, click the Show Thumbnails button.

The thumbnails appear.

Related Topics

• Layers and Columns on page 57

• Layer and ColumnConcepts on page 57

• Advanced Column Types on page 58

• Layer Content on page 1

• Adding New Drawing Layers on page 60

• Deleting Layers and Columns on page 65

• Modifying Layers on page 67

• Duplicating Layers and Columns on page 71

• Cloning Layers And Columns on the previous page

• Changing the Colour of a Column or Layer on page 1

• Expanding and Collapsing Layers and Columns on the next page

• Modifying the Look of the Column on page 75
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Expanding and Collapsing Layers and Columns
To simplify the look of your Timeline and Xsheet view, you can collapse and expand your layers. If some layers are
parented to other ones, you can collapse the parent layer to hide all of its children. You can also collapse 3D Path
columns in the Xsheet view.

To collapse/expand a layer selection in the Timeline view:

1. In the Timeline view, select the layer(s) to collapse or expand.

2. Do one of the following:

‣ Right-click on the selection and select Collapse/Expand > Collapse/Expand.

‣ Click the Expand Children Arrow button on the parent layer.

‣ Press [Ctrl] + [I] (Windows/Linux) or [⌘ ] + [I] (MacOS X).

‣ Click theCollapse/Expand button in the Timeline View toolbar’s extra buttons.

To collapse or expand all layers in the Timeline view:

Do one of the following:

‣ Right-click on the layers and select Collapse/Expand > ExpandAll or Collapse All.

‣ Press [0] and [9].

‣ Click theCollapse All or ExpandAll buttons in the Timeline View toolbar’s extra buttons.

To collapse and expand 3D Path columns in the Xsheet view:

1. In the Xsheet view, display the Functions section by clicking the Show Column List button.

2. In the Functions section, select the header of the 3D Path column to collapse.

3. Do one of the following:

‣ Right-click on the column’s header and select Expand/Collapse > Collapse Selection.

‣ To expand a collapsed column, select the column’s header, right-click on the selection and select
Expand/Collapse > Expand Selection.

‣ Click theCollapse Selection or Expand Selection buttons in theXsheet View toolbar’s

extra buttons.

To collapse or expand all 3D Path columns in the Xsheet view:

Do one of the following:

‣ Right-click on any column’s header and select Collapse/Expand > ExpandAll or Collapse All.
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‣ The [0] and [9].

‣ Click theCollapse All or ExpandAll buttons in the Xsheet View toolbar’s extra buttons.

Related Topics

• Layers and Columns on page 57

• Layer and ColumnConcepts on page 57

• Advanced Column Types on page 58

• Layer Content on page 1

• Adding New Drawing Layers on page 60

• Deleting Layers and Columns on page 65

• Modifying Layers on page 67

• Duplicating Layers and Columns on page 71

• Cloning Layers And Columns on page 72

• Xsheet Thumbnails on page 73

• Changing the Colour of a Column or Layer on page 1

• Modifying the Look of the Column below

•

Modifying the Look of the Column
In Toon BoomHarmony 10.3, you canmodify the way the column displays drawings, empty cells and the column
width.

You canmodify the following elements:

• Empty Cells

• Row Units

• Held Exposure

• ColumnWidth

Tomodify the look of an empty cells:

‣ In theXsheet Viewmenu, select View > Empty Cells > With an “X” or Blank.
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Tomodify the row units:

‣ In the Xsheet View menu, select View > Row Units > Frames or Feet.

Tomodify the held exposure’s look:

‣ In the Xsheet View menu, select View > Held Exposures > Line or Value.

Tomodify the column’s width:

1. In the Xsheet view, select any column to modify the width.

2. In the Xsheet view menu, select View > Set Columns Width.

The Xsheet ColumnWidth dialog box opens.

3. In the ColumnWidth field, type the desired width in pixel.

4. To end the operation:

‣ Click on theOK button to validate and close the dialog box.

‣ Click on theApply button to validate the operation and keep the dialog box opened to adjust the
next column’s width.

‣ Click on the Set As Default to create all the new columns to this width.

‣ Click on theClose button to cancel the operation.

5. To restore all columns to the default value, in the Xsheet view menu, select All Columns to Default
Width.

Related Topics

• Layers and Columns on page 57

• Layer and ColumnConcepts on page 57

• Advanced Column Types on page 58

• Layer Content on page 1
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• Adding New Drawing Layers on page 60

• Deleting Layers and Columns on page 65

• Modifying Layers on page 67

• Duplicating Layers and Columns on page 71

• Cloning Layers And Columns on page 72

• Xsheet Thumbnails on page 73

• Changing the Colour of a Column or Layer on page 1

• Expanding and Collapsing Layers and Columns on page 74
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Filling Exposure
Toon BoomHarmony provides different tools to fill-in exposures and values, create cycles, and set increments.

Related Topics

• Filling ExposureMode below

• Typing Exposure on the facing page

• Holding Exposure on page 81

• Extending a Single Exposure on page 82

• Extending an Exposure Sequence on page 82

• Dragging Cells on page 83

• Increasing and Decreasing Exposure on page 86

• Inserting Blank Cells on page 90

• Setting the Exposure on page 91

• Filling a Selection with a Single Exposure on page 92

• Filling a Selection with a Sequence on page 93

• Filling a Selection Randomly on page 95

• Creating Cycles on page 96

Filling Exposure Mode
In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. Thesemodes
control the filling behaviour. The Timeline view only uses theOverwritemode.

To toggle between Overwrite and Insert modes:

‣ In the Xsheet view’s right bottom corner, click theOverwrite/Insert button or press [I].

Overwrite Mode
By default, the Xsheet view is set to Overwritemode. Add a new value or a new value sequence overwrites
existing ones. The existing timing sequence remains in the same place and is not pushed further down the
column.
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Insert Mode
The Insert mode is the opposite of theOverwritemode. When you add a new value or a new value sequence over
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down
the column.

Related Topics

• Filling Exposure on the previous page

• Filling ExposureMode on the previous page

Typing Exposure
To fill in your exposure, you can directly type the values in the Xsheet and Timeline views.

• Typing a Value in the Timeline View below

• Typing a Value in the Xsheet View on the next page

Typing a Value in the Timeline View
If you want to type an exact drawing name or value into the Timeline view, youmust use the Data view section of
the Timeline.
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You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

To type a value in the Timeline view:

1. In the Timeline view, click the Show Data View button.

2. In the Drawing Substitution field, type the name of the drawing youwant to create, and press
[Enter/Return].

Typing a Value in the Xsheet View
To enter a value in a column’s cell, double-click in the cell and type the numbers or letters.

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

• Press [Enter/Return] to move on to the next cell.

• Press [Esc] to exit the typing mode and return to normal mode.

To type values in the Xsheet view:

1. In an Xsheet column, double-click on one cell.

2. Type a value or drawing name in the cell.

3. Press [Enter/Return] to move on to the next cell.
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4. Press [Esc] to quit the typing mode.

Related Topics

• Filling Exposure on page 78

Holding Exposure
Drawings in an animation are not always exposed on a single frame, they are often exposed for more than one
frame. Themost common exposure of a drawing is two frames. In the industry, this type of exposure is known as
animation in double frames. A drawing can also be exposed for three, four, five cells and so on. To prevent
mistakes and to save time, the Xsheet lets you hold your cells automatically as you type.

The Xsheet’s Set Exposure option allows you to choose how many frames you want to hold your exposure for.

• This option is only available in the Xsheet view.

• The selected Set Exposure, the settings will be kept from session to session. You will not
have to set them every time you use Toon Boom Harmony

To hold exposure:

1. In the Xsheet View menu, select Exposure > Hold 2 Cells.

2. Right-click the Xsheet view and select Exposure > Set Exposure To > Set Exposure to 1, 2, 3, or Set
Exposure.

In the Harmony Xsheet, selectOption > Hold 2 Cells.

3. Type a value or drawing name in the cell.

‣ Press [Enter/Return] to move on to the next cell.

‣ Press [Esc] to quit the typing mode.

‣ If you selected Set Exposure, the Set Exposure dialog box opens. You can hold as many cells as
needed.
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Related Topics

• Filling Exposure on page 78

Extending a Single Exposure
The Extend Exposure feature allows you to select anXsheet’s cell containing a value and to pull it down to the
desired frame.

To extend a cell exposure:

1. In the Xsheet view, select the red arrow in the cell’s right side. Make sure you see the drag down

cursor.

2. Pull down the selected cell to the desired frame.

The red selection box must be visible when releasing the mouse button. If not, the action is
considered cancelled.

Related Topics

• Filling Exposure on page 78

Extending an Exposure Sequence
You can extend and create a sequence using almost the same procedure as you would when you extend a single
exposure. The only differences being that the selected cell must only contain numbers and that you need to press
the [Shift] key while pulling down on the selection.

The creation of the sequence only works with numbers in the selected cell, not letters.
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To create a sequence:

1. In the Xsheet view, select a cell containing a number.

2. In the selected cell, click on the red arrow on the cell’s right side. Make sure to see the drag down

cursor.

3. Hold down the [Shift] key. Make sure a plus (+) sign appears.

4. Pull down the selection box to the desired frame.

The red selection box must be visible when releasing the mouse button. If it is not visible, the action
is considered as cancelled.

5. First release the [Shift] key, then release themouse button.

You can also select a cell and select Animation > Cell > Extend Exposure or press [F5]. In the dialog
box, type the frame number you want to extend the cell to.

Related Topics

• Filling Exposure on page 78

Dragging Cells
To readjust your timing, you can drag one or several cells to a new location in both the Timeline and Xsheet
views.

You can drag a cell to any other frame in the same column or into another column.

To drag a cell to another location in the Timeline view:

1. In the Timeline view, select one or several cells to move.
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2. Click on the cells selection and drag it to the new location.

‣ If you drop the selection, it overwrites the existing cells.

‣ If you hold [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X) while dropping the selection, the cells are copied
and not moved.

‣ If your press [Shift] while dropping, the selection is inserted between the existing frames.

To drag a cell to another location in the Xsheet view:

1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, select the small dotted area on the left side of the selected cells.

3. Drag the selection to any other cell in the same column or in another column.
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‣ If you drop the selection, it overwrites the existing cells.

‣ If you hold [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X)while dropping the selection, the cells are copied
and not moved.

‣ If your press [Shift] while dropping, the selection is inserted between the existing frames.

You can turn off the Gestural DragMode for the Xsheet view to prevent drawings from being dragged from one
location to another. A Toggle Gestural DragMode button is available for this feature, accessible by customizing
the Xsheet View toolbar. Otherwise, access it by right-clicking on a cell or the Xsheet's Edit menu.

To turn off the Gestural Dragmode:

‣ In theXsheet view, right-click and deselect theGestural DragMode option.
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‣ You can also customize the Xsheet View toolbar and display the Toggle Gestural Dragmode button to
enable and disable this option.

The dragging pad disappears when theGestural Drag mode is off.

This feature does not apply for Annotation columns.

Related Topics

• Filling Exposure on page 78

Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

Related Topics

• Increasing Exposure below

• Decreasing Exposure on the facing page

• Increase/Decrease Exposure Field on page 88

• Clear Exposure and Pull on page 88

Increasing Exposure
Increasing the exposure adds onemore exposure to a selected cell, repeating this action adds an extra cell every
time. This is a quick way of extending a drawing exposure and is always set in the Insert mode. Increasing an
exposure always pushes the existing exposure down.

To use Increase Exposure:

1. In the Timeline or Xsheet view, select a cell.
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2. Do one of the following:

‣ In the top menu, select Animation > Cell > Increase Exposure.

‣ Right-click on the selected cell and select Exposure > Increase Exposure.

‣ Press [+].

‣ In Harmony Xsheet,select Selected > Increase Exposure.

‣ Click the Increase Exposure button in the Xsheet View and Timeline View toolbars’ extra buttons.

3. Repeat this action to addmore cells to your drawing’s exposure.

Related Topics

• Decreasing Exposure below

• Increase/Decrease Exposure Field on the next page

Decreasing Exposure
Decreasing the exposure removes one exposure from a selected cell. Repeating this action removes an extra cell
every time. This is a rapid way to reduce a drawing exposure and remove the exposed drawing.

To decrease exposure:

1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:

‣ In the top menu, select Animation > Cell > Decrease Exposure.

‣ Right-click on the selected cell and select Exposure > Decrease Exposure.

‣ Press [-].

In Harmony Xsheet,select Selected > Decrease Exposure.

‣ Click the Increase Exposure button in the Xsheet View and Timeline View toolbars’ extra buttons.

3. Repeat this action to decreasemore cells to your drawing’s exposure.
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Related Topics

• Increasing and Decreasing Exposure on page 86

• Clear Exposure and Pull below

Increase/Decrease Exposure Field
Another technique you can use to quickly increase or decrease the exposure of a selected drawing is bymaking
use of the Increase/Decrease Exposure field available in the Xsheet view.

To increase and decrease exposure using the Increase/Decrease Exposure field:

1. In the Xsheet view, select the cell to modify.

2. In the Xsheet’s bottom-right corner, increase or decrease the drawing’s exposure by clicking the up or
down arrows. To increase the exposure, press [+]. To decrease the exposure, press [-].

Related Topics

• Increasing and Decreasing Exposure on page 86

• Decreasing Exposure on the previous page

• Clear Exposure and Pull below

Clear Exposure and Pull
You can reduce a drawing’s exposure using the Clear Exposure and Pull option.

To use the Clear Exposure and Pull feature:

1. In the Timeline or Xsheet view, select a cell.
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2. Do one of the following:

‣ In the top menu, select Animation > Cell > Clear Exposure and Pull.

‣ Right-click on the selected cell and select Exposure > Clear Exposure and Pull.

‣ In Harmony Xsheet, select Selected > Clear Exposure and Pull.

‣ Click theClear Exposure button in the Xsheet View and Timeline View toolbars’ extra buttons.

‣ Press [Z].

Related Topics

• Increasing and Decreasing Exposure on page 86

Deleting Exposure
You can delete a drawing’s exposure in several simple ways. Note that when you delete a drawing’s exposure
from the Timeline or Xsheet view, you are not deleting the actual drawing file. You can always bring it back by
typing its name again in a cell.

You can delete the exposure contained in a selected cell range or delete the entire exposure of a drawing
exposed over several cells. Note that you can also delete the exposure for drawings contained inside a collapsed
group.

To delete selected exposures:

1. In the Timeline or Xsheet view, select the exposure you want to delete.

2. Right-click on the selection and select Delete or press [Delete].

To completely clear the exposure of a drawing:

1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

2. Do one of the following:

‣ In the top menu, select Animation > Cell > Clear Exposure.

‣ In the Timeline view, right-click on the selection and select Exposure > Clear Exposure.

‣ Click theClear Exposure button in the Timeline View toolbar’s extra buttons.

Related Topics

• Filling Exposure on page 78

• Layer and ColumnConcepts on page 57
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Inserting Blank Cells
Use the Insert Blank Cell option to place an empty cell between other cells. This is always done in Insert mode
and pushes down existing exposure, even if you are set to Overwritemode.

To insert blank cells:

1. In the Xsheet or Timeline view, select the cell where you want to insert a blank cell.

2. Do one of the following:

‣ In the top menu, select Animation > Cell > Insert Blank Cell.

‣ In Harmony Xsheet, select Selected > Insert Blank Cell.

‣ Right-click on the selected cell and select Exposure > Insert Blank Cell.

‣ Press [Shift] + [J].

‣ Click the Insert Blank Cell button in the Timeline View and Xsheet View toolbars’ extra buttons.

The blank cell is inserted.

To clear a selected cell range without changing the exposure and timing:

1. In the Xsheet view, select the frame range to clear.
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2. Right-click on the selected cells and select Clear.

Related Topics

• Filling Exposure on page 78

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the Set Exposure options.

To set the exposure:

1. In the Timeline or Xsheet view, select the cell range onwhich you want to set the exposure.

2. In the top menu, select one of the following:

‣ Animation > Cell > Set Exposure > Set Exposure to 1.

‣ Animation > Cell > Set Exposure > Set Exposure to 2.

‣ Animation > Cell > Set Exposure > Set Exposure to 3.

‣ Animation > Cell > Set Exposure.
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You can also click the Set Exposure buttons in the Timeline View toolbar’s extra buttons

or right-click the selected cells and choose .

3. In Harmony Xsheet, right-click and select Exposure > Set Exposure to and then select one of the
following:

‣ Set Exposure to 1

‣ Set Exposure to 2

‣ Set Exposure to 3

‣ Set Exposure

If you choose the Set Exposure option, the Set Exposure dialog box opens.

4. Type the number of frames you want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.

Related Topics

• Filling Exposure on page 78

Filling a Selection with a Single Exposure
The Fill Selection option is used to fill the same value all over a selection. The selection can be over one cell, a cell
range in one column, a cell range over many columns, an entire column or many entire columns. You can use
numbers, words, letters or any alphanumeric value.

To use Fill Selection:

1. In the Xsheet or Timeline view, select a cell range.
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2. Do one of the following:

‣ Select Animation > Cell >Fill Selection.

‣ Press [Ctrl] + [T] (Windows/Linux) or [⌘ ] + [T] (MacOS X)).

‣ In Harmony Xsheet, right-click and select Exposure > Fill Selection or press [Ctrl] + [T]
(Windows/Linux) or [⌘ ] + [T] (MacOS X).

‣ Click the Fill Selection button in theXsheet View and Timeline View toolbars’ extra buttons.

The Fill Selection dialog box opens.

3. In the Value field, type the desired value and click OK.

Related Topics

• Filling Exposure on page 78

Filling a Selection with a Sequence
The Sequence Fill option is used to create a number sequence over a selection. The sequence can be forward,
backward, single, double or higher increment, as a cycle, etc. The selection can be over one cell, a cell range in
one or more columns, an entire column, or several entire columns.

To fill a selection with a sequence:

1. In the Xsheet or the Timeline view, select a cell range.

2. If you are working in the Xsheet view, select Animation > Cell > Sequence Fill. Click the Sequence Fill
button in theXsheet View toolbar's extra buttons.

In Harmony Xsheet, select Selected > Sequence Fill. You can also click on the Sequence Fill button

available in theXsheet View toolbar's extra buttons.

OR

If you are working in the Timeline view, right-click and select Exposure > Sequence Fill.

‣ Press [Ctrl] + [M] (Windows/Linux) or [⌘ ] + [M] (MacOS X).
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The Sequence Fill dialog box opens.

3. In the Starting Value field, type the starting number for the number sequence.

4. In the Increment field, type the increment to which the number will change from frame to frame.
(1-2-3-4, 1-3-5-7, 10-9-8-7-6-5-4-3-2-1). The value can be positive or negative.

5. In the Hold field, choose an exposure holding value.

6. Select theCycle option if you want a cycle; type the number of cells for this cycle’s duration.

If you choose a two cell hold, a cycle of three drawings will last for six cells.

7. If you selected a larger range than the amount of frames needed, select the End Frame option and type
the last frame needed.

8. If you want to havemore than one digit in your numbers such as “001” instead of “1”, select the Padding
option and add as many pound signs (#) as digits needed. Also, you can type a letter or word in the field
for it to be added in front of the drawing number.

9. Click OK.
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Related Topics

• Filling Exposure on page 78

Filling a Selection Randomly
The Fill Cells Randomly option is used to fill in random values over a selection. You can give a maximum and a
minimum value and create a range for the system to choose the random values from. The selection can be over
one cell, a cell range in one column, a cell range over many columns or an entire column or several entire columns.

To use Fill Cells Randomly:

1. In the Xsheet view, select a cell range.

2. Select Animation > Cell > Fill Cells Randomly.

In Harmony Xsheet, right-click and select Exposure > Cell > Fill Cells Randomly.

‣ You can also click on the Fill Cells Randomly button available in theXsheet View toolbar’s extra

buttons.

The Fill Cells Randomly dialog box opens.

3. In theMinimumValue field, type a minimum value.

4. In theMaximumValue field, type a maximum value.

5. In theHold field, choose an exposure holding value.

6. If you are applying this option to a drawing column, enable theWhole Numbers option to avoid decimal
points.

7. Click OK.
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Related Topics

• Filling Exposure on page 78

Creating Cycles
Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.

You can loop your drawings using the following commands:

• Paste Cycle

• Paste Reverse

• Create Cycle

When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This means
that when youmodify, repaint or correct a drawing named “1” all drawings named “1” are updated
simultaneously. In order to modify a drawing independently from its other exposures, youmust duplicate the
drawing.

To use the Paste Cycle command:

1. In the Xsheet or Timeline view, select the cell range to loop.

2. In the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.
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4. In the top menu, select Edit > Paste Cycle.

In Harmony Xsheet, right-click and select Paste Cycle.

‣ The [Ctrl] + [/] (Windows/Linux) or [⌘ ] + [/] (MacOS X).

The Paste Cycle dialog box opens.

5. In the Number of Cycles field, use the up and down arrow to increase or decrease the amount of cycles
you want to paste. You can also directly type the value.

6. In the Cycle Type drop-downmenu, select the type of cycle you want to paste.

‣ Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the last
one.

‣ Reverse: Pastes your selection reversed, starting with the last cell and ending with the first one.

‣ Forward -> Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the last one
and ending with the first cell.

‣ Reverse -> Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

7. Click OK.
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You can do the same operation using the Paste Special dialog box. To open the Paste Special dialog
box, select Edit > Paste Special or press [Ctrl] + [B] (Windows/Linux) or [⌘ ] + [B] (Mac OS X).

To use the Paste Reverse command:

1. In the Xsheet or Timeline view, select the cell range to paste inverted.

2. In the top menu, select Edit > Copy.

3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. In the top menu, select Edit > Paste Reverse.

In Harmony Xsheet, right-click and select Paste Reverse.

‣ Press [Ctrl] + [.] (Windows/Linux) or [⌘ ] + [.] (MacOS X).
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To use the Create Cycle command:

1. In the Timeline view, select the cell range to loop.

2. In the Timeline View toolbar, click on theCreate Cycle button located in the toolbar’s extra buttons.

The Create Cycle dialog box opens.

3. Enter the number of cycles you want, including the current selection.

Related Topics

• Filling Exposure on page 78
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Navigating between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the layers, frames and drawings
using keyboard shortcuts that are effective in the Camera, Drawing, Timeline and Xsheet view.

You can navigate through:

• Columns

• Drawings

• Frames

To navigate through the drawings, frames and columns:

1. In the Timeline or Xsheet view, select a cell.

2. Once the cell is selected, you can navigate between:

‣ Previous and next layers from the top menu, you can select Edit > Previous Layer andNext Layer.
You can also press [H] and [J].

‣ Previous and next drawings, from the top menu, select Edit > Previous Drawing andNext Drawing
or Drawing > Previous Drawing andNext Drawing. You can also press [F] and [G].
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‣ Previous and next frames, from the top menu, select Play > Previous Frame andNext Frame. You
can also press [,] and [.].
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Managing Drawings
Drawings that are created in Toon BoomHarmony are not encapsulated in their cells. They are actual files stored
in the project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit
the file and not the cells.

You also have the option of marking your drawing as Key, Breakdown and In-betweens—see
Drawing Identification on page 1 to learn more about this feature.

Related Topics

• Renaming a Drawing below

• Renaming Drawings by Frame Position on page 1

• Deleting a Drawing on page 1

• Duplicating a Drawing on the facing page

• Copying and Pasting Drawings on page 104

• Drawing Identification on page 1

Renaming a Drawing
To rename a drawing, you do not type the new name in the cell. You need to select the cell containing the
drawing and use the RenameDrawing command.

To rename a drawing:

1. In the Timeline or Xsheet view, select the drawing to rename.

2. Do one of the following:

‣ In Harmony Stage's top menu, select Drawing > Rename Drawing or press [Ctrl] + [D]
(Windows/Linux) or [⌘ ] + [D] (MacOS X).

‣ Click the Rename Drawing button in the Timeline View or Xsheet View toolbars’ extra buttons.

‣ In Harmony Xsheet, use the Rename Drawing button in theXsheet View toolbars’ extra

buttons.

The RenameDrawing dialog box opens.
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3. In the New Name field, type the new drawing name.

Related Topics

• Managing Drawings on the previous page

• Renaming Drawings with a Prefix on page 1

• Renaming Drawings by Frame Position on page 1

• Deleting a Drawing on page 1

• Duplicating a Drawing below

• Copying and Pasting Drawings on the next page

Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing.
The exposure of the original drawing that was on the current cell is removed. The drawing is not deleted.

To duplicate a drawing:

1. In the Timeline or Xsheet view, select the drawing to duplicate.

2. In the Xsheet View toolbar, cilck theDuplicate Drawing button.

3. In Harmony Stage's top menu, select Drawing > Duplicate Drawing or press [Alt] + [Shift] + [D].

With Toon BoomHarmony you can create a keyframe at the same time as you duplicate your drawing. This way
you canmodify and reposition your drawings without affecting the original drawing.

Related Topics

• Managing Drawings on the previous page

• Renaming a Drawing on the previous page

• Renaming Drawings by Frame Position on page 1

• Deleting a Drawing on page 1

• Duplicating a Drawing above

• Copying and Pasting Drawings on the next page
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Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual
drawings, you are pasting the exposure.

If you want to copy and paste the selected drawings into a different layer or paste the selection in the same layer
to duplicate the drawings, youmust use the Paste Special feature.

There are two main ways to paste your selected drawings with the Paste Special dialog box:

• Always Create Drawings

This option pastes all of your drawings as they are. If a drawing has the same name as an existing one, it is
renamed and duplicated.

• Only Create Drawings When They Do Not Exist

This option only pastes only the drawings that are named differently from existing drawings. If a drawing
has the same name as an existing one, it is ignored and not pasted. This avoids duplicating drawings in
your layers.

This option is useful when you are pasting cut-out character templates containing drawings youmay
already have in your scene and some new ones. Using this option, you only paste the new drawings and
are not duplicating all of the other parts you already have.

To paste drawings with the Paste Special command:

1. In the Timeline or Xsheet view, select the drawings to copy.

2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

3. In the top menu, select Edit > Paste Special or press [Ctrl] + [B] (Windows/Linux) or [⌘ ] + [B] (MacOS X).
You can also click the Paste Special button in theTimeline View andXsheet View toolbars’ extra

buttons.

The Paste Special dialog box opens.
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4. Select the Basic tab.

5. In the Drawings section, select theAlways Create Drawings or theOnly Create Drawings When They
Do Not Exist option depending onwhat you need.

If you want to perform another paste special operation using the same settings you used previously,
you can use the Paste Special Again command instead of the Paste Special command. This feature
paste your selection using the same settings you used in your last paste special without opening the
Paste Special dialog box.

To use the Paste Special Again command, select Edit > Paste Special Again or press [Ctrl] + [Shift] +
[B] (Windows/Linux) or [⌘ ] + [Shift] + [B] (Mac OS X). You can also click the Paste Special Again

button in theTimeline View andXsheet View toolbars’ extra buttons.

Related Topics

• Managing Drawings on page 102

• Renaming a Drawing on page 102

• Renaming Drawings with a Prefix on page 1

• Renaming Drawings by Frame Position on page 1

• Deleting a Drawing on page 1

• Duplicating a Drawing on page 103
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Tempo Markers
Tempo markers are used to synchronize your animation with a musical score. Using this feature, you can
reproduce the FPB (Frames Per Beat) and the tempo signature as Tempo markers. The Xsheet view allows you
to pace your animation according to the tempo or beat of your soundtrack music or to any rhythmical sound,
such as the ticking of a clock or water leaking from a spout.

To set the TempoMarkers:

1. In the Xsheet View menu, select View > Set TempoMarker.

1. In the Xsheet view, right-click and select View > Set TempoMarker.

The Tempo Marker dialog box opens.

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.

‣ Starting Frame: Type the number of the framewhere you want the tempo markers to begin.

‣ Frames/Beat: Set the Frames Per Beat value. This will determine the frequency (in frames) a beat
marker will appear. Keep inmind that, by default, 24 frames represent 1 second.

‣ Beat/Bar: Set the Tempo of your music or sound. This will determine the frequency (in beats) a tempo
marker will appear in the Xsheet view.

3. Click OK.
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Related Topics

• Timing on page 51
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Annotation Columns
The Annotation columns are a more than just a useful tool. They allow you to mark actions, corrections or any
other information related to your animation that you would like to draw or write. This way, you can print your
Xsheet, take it back to your animation table and work with the annotations.

Related Topics

• Adding an Annotation Column below

• Drawing and Typing in the Annotation Column on the facing page

• Changing the Drawing Settings on page 112

• Importing an Annotation File on page 113

Adding an Annotation Column
To add an annotation column:

1. Do one of the following:

‣ In the Xsheet View menu, select Columns > AddColumns.

‣ In the Xsheet View toolbar, click theAddColumns button.

‣ Press [Shift] + [C].

The Add Columns dialog box opens.

2. In the ColumnName field, name your column accordingly.

3. In the Column Type field, select Annotation.

4. Click OK.

The new column appears.

Related Topics

• Annotation Columns above

• Drawing and Typing in the Annotation Column on the facing page

• Changing the Drawing Settings on page 112

• Importing an Annotation File on page 113
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Drawing and Typing in the Annotation Column

In the annotation column, you can not only type in your notes and relevant information, but also draw sketches
and ideas which will be useful in producing your animation.

• Drawing in the Annotation Column below

• Typing in the Annotation Column on the next page

• Erasing Annotation ColumnContent on the next page

Drawing in the Annotation Column
Before you can draw in the annotation column, youmust first activate the Enable Drawing option. Once this is
done, you can start drawing using themouse or the pen tablet.

Pen tablet pressure sensitivity is not supported in the annotation column.

To enable drawing in the annotation column:

1. In the Xsheet View menu, select Annotation > Enable Drawing. You can also click on the column’s header
icon to toggle the Drawing, Selection and Erasing modes.

‣ The Select icon indicates that the Select mode is enabled.

‣ The Brush icon indicates that the Drawing mode is enabled.

‣ The Eraser icon indicates that the Erasing mode is enabled.

When using a pen on a tablet, you MUST flip your pen to the eraser side for the eraser to work.

To draw in the annotation column:

‣ To draw in an annotation column, simply use your mouse or pen tablet.
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Typing in the Annotation Column
Typing in an annotation column is independent from the Drawing mode. You can be in either mode and the
typing will work.

To type in an annotation column:

1. In the annotation column, press [Ctrl] (Windows/Linux) or [⌘ ] (MacOS X) on the cell where you want to
write. By pressing [Ctrl] + [Shift] + click (Windows/Linux) or [⌘ ] + [Shift] + click (MacOS X) in the
annotation column, you will enter the editing mode in the cell at the current frame.

2. In the selected cell, type the desired text.

Refer to the topic Typing Exposure on page 79 to get more information about typing values in the
Xsheet view.

Erasing Annotation Column Content
You can erase part or all of the annotation column’s content.
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To erase the annotation content:

1. In the Xsheet view, enable the Erasingmode by clicking on themode icons.

2. In the Xsheet view, select the cell range youwant to clear from text or images. Do not select any cells if
you plan to clear everything.

3. In the Xsheet view, right-click in the annotation column and select:

‣ Annotation > Erase All to erase completely the content of the column.

‣ Annotation > Erase Selected Images to erase the images contained in the selected cell range. Make
sure to disable the Drawing mode to do so.

‣ Annotation > Erase Selected Texts to erase the text contained in the selected cell range. Make sure
to disable the Drawing mode to do so.

Tip: You can also use the Erasing mode to erase part of a drawn annotation.

To erase part of a drawn annotation using Erasingmode:

1. In the Annotation column’s header, enable the Erasingmode.

2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.
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Annotations that you type in are not erased using this method.

Changing the Drawing Settings
You can change the pen size and colour when you draw in the annotation column.

To change the pen width:

1. In the Xsheet View menu, select Annotation > Pen Width > 1, 2, 3, 4 or Change Current.

If you selected the Change Current option, the PenWidth dialog box opens.

2. In the PenWidth field, type the amount of pixel you want the pen size to be.

To change the pen colour:

1. In the Xsheet View menu, select Annotation > Change Pen Colour.

The Select Colour dialog box opens.

2. Choose the new colour.

Related Topics

• Annotation Columns on page 108

• Adding an Annotation Column on page 108

• Drawing and Typing in the Annotation Column on page 109

• Importing an Annotation File on the facing page
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Importing an Annotation File
If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or drawings in
your annotation columns, you can easily import them.

To import annotation files:

1. In the Xsheet view, select the first cell in the annotation columnwhere you want the imported image to
start.

2. In the Xsheet view menu, select Annotation > Import File.

3. Browse for the bitmap image to import.

4. Click Open.

The image appears in the annotation column.

Related Topics

• Annotation Columns on page 108

• Adding an Annotation Column on page 108

• Drawing and Typing in the Annotation Column on page 109

• Changing the Drawing Settings on the previous page
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Printing the Xsheet
Once your line test is completed and you havemarked all the information, corrections and timing youwant in
your Xsheet view, you can print out your exposure sheet. Printing out theXsheet allows you to take it with you
to your animation table or to give a copy to the animator. You can also use it to create your Xsheet skeleton
directly in Toon BoomHarmony.

To print your exposure sheet:

1. Select File > Print > Xsheet.

The Print dialog box opens.

2. To setup your print:

‣ Windows: In the Select Printer section, select your printer and adjust the rest of the printing settings.

Refer to the printer user guide to learnmore about its options.

‣ Linux: In the Print Destination section, select your printer and adjust the rest of the printing settings.

Refer to the printer user guide to learnmore about its options.

‣ MacOS X: In the Printer section, select your printer and adjust the rest of the settings by clicking on
the Parameters button. You can also click on the PDF button and select an option from the drop-

downmenu if you want to save a PDF version of your exposure sheet.

Refer to the printer user guide to learn more about its options.
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3. Click on the Print button.

Related Topics

• Timing on page 51
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Element Manager
Use the ElementManager to add, delete or modify elements (drawing folders) in your scene. If you have
drawing folders that are not linked to a column in your scene, use the ElementManager to delete them if need
be.

To open the ElementManager dialog box:

‣ Select Scene > ElementManager.

• Elements: Displays a list of the elements contained in your scene.

• Delete Elements: Press this button to delete the selected elements.

• Delete Elements andDirectories: Press this button to delete the selected layer, as well as its directories
(drawing folder).

• Add/Modify Element: Use the options contained in this area to add or modify an element.

• Name: Type a new name in this field to create an element or to rename the selected element.

• Vector: Check this box if the new element is a vector drawing or if you want to enable the parameters
on the selected element in the Elements list.

• Bitmap Format: Select the file format of the bitmap layer from the drop-down list.

• Scan Type: If you are planning to scan elements with Toon BoomHarmony’s Scanmodule, select the
scan type from the drop-down list.

• Field Chart: If you are importing traditional animation, select the size of the paper on which the
animation was drawn.

• Add: Press this button to create a new element with the current parameters entered in theAdd/Modify
Element section.

• Modify: Press this button to apply the parameter changes made to the selected element.

Related Topics

• Timing on page 51
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Timing Preferences
When adjusting your timing in the Timeline andXsheet view, youmay want to set some preferences.

This section covers the preferences related to timing, Timeline and Xsheet view.

The preferences related to Harmony Xsheet can be found under the Exposure Sheet tab only.

Youwill find the preferences listed under the following tabs:

• Exposure Sheet

• Timeline

• Advanced

To open the Preferences panel:

‣ Windows/Linux: Select Edit > Preferences.

‣ MacOS X: Select Stage> Preferences.

‣ The [Ctrl] + [U]Windows/Linux) or [⌘ ] + [U] (MacOS X).

Related Topics

• Exposure Sheet Preferences below

• Timeline Preferences on page 120

• Advanced Preferences on page 120

Exposure Sheet Preferences
This is the Exposure Sheet preferences tab.
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Filtering
These preferences are used to display or hide certain layer types in the Xsheet view.

• Show Drawing Columns: Displays the Drawing layers in the Xsheet view.

• Show Function Columns: Displays the Function columns layers in the Xsheet view.

• Show Annotation Columns: Displays the Annotation columns layers in the Xsheet view.

• Show 3D Path Columns: Displays the 3D Path columns in the Xsheet view.

• Show Sound Columns: Displays the Sound columns in the Xsheet view.
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• Centre of Current Frame: Turns auto-centering on or off when playing back a scene. Auto-centering
is to be used during sound breakdown with the ShuttleXpress device.

Options
• Default Add Columns: The default position where the new columnwill be added.

• Default Column Width: The default width value for the new column being created.

Element Manager
• Pixmap Format: By default, when you create a new empty bitmap column, it will use the file format
indicated in the field as the new column format. The default value is SCAN, whichmeans that it is set for
scanned-in drawings.

• Scan Type: By default, the Scan Type is set to 2 which indicates that the element is a TVG vector drawing.
This function returns a string that is the scan type of the element. The scan type is COLOR, GRAY_SCALE
or BW.

• Vector Type: By default, the Vector Type is set to 2 which indicates that the element is a TVG vector
drawing. This function returns the vector type for the given element. In theory, there is support for
multiple types of vector drawing. In practice, only TVG has been implemented. The value 0: indicates that
the element is NOT a vector drawing. It is an IMAGE type.

New Element
• Bitmap Format: By default, when you create a new empty bitmap column, it will use the file format
indicated in the field as the new column format. The default value is SCAN, whichmeans that it is set for
scanned-in drawings.

• Scan Type: By default, the Scan Type is set to 2 which equals vector import. This means that the imported bitmap
images will be placed into a Drawing layer. Scan type 1 is bitmap import.

Apply/Next
• From Left to Right: When clicking on theApply/Next button in theXsheet view Column Properties, the
next column to be displayed in theColumn Properties will be the one on the right.

• From Right to Left: When clicking on theApply/Next button in theXsheet view Column Properties, the
next column to be displayed in theColumn Properties will be the one on the left.

Related Topics

• Timing Preferences on page 117

• Timeline Preferences on the next page

• Advanced Preferences on the next page
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Timeline Preferences

Defaults
• Show Groups: Displays the Group layers in the Timeline.

• Show Effects: Displays the Effect layers in the Timeline.

• Show Sound: Displays the Sound layers in the Timeline.

Paste/Drag & Drop
• Add keyframes at beginning and end: Select this option to copy and paste a set of frames that includes
an interpolated sequence between two keyframes, but only extracts a partial section. Under normal
circumstances, cutting and pasting a function without either the start or end keyframewould render the
function null. This option caps the partial function with a new keyframewhen you perform the paste.

Related Topics

• Timing Preferences on page 117

• Exposure Sheet Preferences on page 117

• Advanced Preferences below

Advanced Preferences
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• Advanced ElementMode: Displays more options in theAddColumn dialog box and theColumn
Properties dialog box.

• Auto-rename Elements: Controls whether to rename the element whenever the corresponding
module name in theNetwork view or layer name in the Timeline view is changed.

Related Topics

• Timing Preferences on page 117

• Exposure Sheet Preferences on page 117

• Timeline Preferences on the previous page
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Keyboard Shortcuts For Harmony Xsheet
This document lists default keyboard shortcuts for Harmony Xsheet.

The Harmony keyboard shortcuts set is used throughout the Harmony Xsheet module
documentation.

To use a shortcut, press the key and the character simultaneously. The + sign, is not part of the sequence. If
there is no shortcut allocated to a command it is left blank.

General

COMMAND FLASH HARMONY
CUSTO
M

Win/Linux MacOS X Win/Linux MacOS X

Add Frame After
Selection

Ctrl+H ^+H Ctrl+H ^+H

Add Frame
At End

Add Frame
At Start

Advanced
Save

Ctrl+Shift+S ⌘+Shift+S Ctrl+Shift+S ⌘+Shift+S

Add Frame
After
Selection

Ctrl+H ^+H Ctrl+H ^+H

Copy Ctrl+C ⌘+C Ctrl+C ⌘+C

Cut Ctrl+X ⌘+X Ctrl+X ⌘+X

Delete Del Del Del Del

Delete
(secondary
key)

Backspace Backspace Backspace Backspace

Deselect All Esc Esc Esc Esc

Go to Next
Column

J J J J

Go to Next
Drawing

G G G G
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General

COMMAND FLASH HARMONY
CUSTO
M

Win/Linux MacOS X Win/Linux MacOS X

Go to
Previous
Column

H H H H

Go to
Previous
Drawing

F F F F

Help F1 F1 F1 F1

Open Ctrl+O ⌘+O Ctrl+O ⌘+O

Paste Ctrl+V ⌘+V Ctrl+V ⌘+V

Paste Special Ctrl+Shift+-
B

⌘+Shift+-
B

Ctrl+B ⌘+B

Paste Special
Again

Ctrl+Alt+B ⌘+Alt+B Ctrl+Shift+-
B

⌘+Shift+
B

Preferences Ctrl+U ⌘+U Ctrl+U ⌘+U

Redo Ctrl+Y ⌘+Y Ctrl+Shift+-
Z

⌘+Shift+
Z

Reset Pan Shift+N Shift+N Shift+N Shift+N

Reset View Shift+M Shift+M Shift+M Shift+M

Reset Zoom

Save Ctrl+S ⌘+S Ctrl+S ⌘+S

Undo Ctrl+Z ⌘+Z Ctrl+Z ⌘+Z

Zoom In Ctrl+= ⌘+= 2 2

ZoomOut Ctrl+- ⌘+- 1 1
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Xsheet

COMMAND FLASH HARMONY
CUSTO
M

Win/Linux MacOS X Win/Linux MacOS X

Add Columns Shift+C Shift+C Shift+C Shift+C

Add Drawing
Column

Ctrl+R ⌘+R Ctrl+R ⌘+R

Clear Exposure
and Pull

Z Z Z Z

Clear Selected
Cells

Clone Selected
Columns

Collapse

Collapse All 0 0s 0 0

Decrease
Exposure

- - - -

Delete
Selected
Columns

Delete
Selected
Drawings

Duplicate
Selected
Columns

Ctrl+D ⌘+D

Expand

Expand All 9 9 9 9

Fill Randomly

Fill Selection Ctrl+T ⌘+T Ctrl+T ⌘+T

Gestural Drag
Mode

Hide Selected
Column

Alt+H Alt+H Alt+H Alt+H

Increase + + + +
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Xsheet

COMMAND FLASH HARMONY
CUSTO
M

Win/Linux MacOS X Win/Linux MacOS X

Exposure

Insert Blank
Cell

X X Shift+J Shift+J

Insert Keyframe Ctrl+F6 ⌘+F6 F6 F6

Insert/Overwrit
eMode

I I I I

Paste Cycle Ctrl+/ ⌘+/ Ctrl+/ ⌘+/

Paste Reverse Ctrl+. ⌘+. Ctrl+. ⌘+.

Preview Alt+P Alt+P Alt+P Alt+P

Sequence Fill Ctrl+M ⌘+M Ctrl+M ⌘+M

Set Custom
Hold Cell

Set Hold 1 Cell Ctrl+1 ⌘+1 Ctrl+1 ⌘+1

Set Hold 2 Cell Ctrl+2 ⌘+2 Ctrl+2 ⌘+2

Set Hold 3 Cell Ctrl+3 ⌘+3 Ctrl+3 ⌘+3

Set Hold 4 Cell Ctrl+4 ⌘+4 Ctrl+4 ⌘+4

Show Column
Types

Show Hidden
Columns

Alt+Shift+
H

Alt+Shift+
H

Alt+Shift+
H

Alt+Shift+
H

Thumbnails

Function Editor

COMMAND FLASH HARMONY CUSTOM

Win/Linux MacOS X Win/Linux MacOS X

Edit Next
Function

PgDown PgDown PgDown PgDown
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Function Editor

COMMAND FLASH HARMONY CUSTOM

Win/Linux MacOS X Win/Linux MacOS X

Edit Previous
Function

PgUp PgUp PgUp PgUp

Insert Point I I I I

Lock/Unlock
Point

Select Left
Handle

[ [ [ [

Select Right
Handle

] ] ] ]

Toggle Grid G G G G

Toggle Stop-
Motion
Segment

S S S S

Zoom In X 4 4 4 4

Zoom In Y 6 6 6 6

ZoomOut X 3 3 3 3

ZoomOut Y 5 5 5 5
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