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Chapter 1: Installing on Windows
This document explains how to install Toon BoomHarmony onWindows.

There are three stages required to install Toon BoomHarmony 11.1, these are covered in the following
topics:

1. Pre-installation on page 10

2. Installing Toon BoomHarmony on page 16

3. Configuration on page 21

After completing these stages, you can verify the integrity of the installation and resolve any
configuration issues.

• Troubleshooting on page 38
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Pre-installation

Before installing Toon BoomHarmony, youmust perform the following task:

• Verifying theMinimumRequirements on page 10

• Prerequisites for Harmony Installation on page 10

• Pre-installation Configuration on page 11

Verifying the Minimum Requirements

For theminimum hardware requirements, visit: toonboom.com/products/harmony-stand-
alone/tech-specs.

For themost current Toon BoomHarmony hardware requirements, refer to theHarmony and Your
IT Department white paper available from:

• Toon BoomAnimation Sales Representative

• Toon BoomAnimation Support at: support@toonboom.com.

Prerequisites for Harmony Installation

For a fast database connection, it is necessary to set up extra network settings so clients can
perform a fast Name Resolution of the server, as well as the server to the clients.

• Obtaining the Product Activation Code on page 10

• Additional Network Settings on page 10

• Windows 2008 Server on page 11

Obtaining the Product Activation Code

You should obtain a product activation code from the Toon Boom licensor, so you can finish the
installation process without having to wait for the activation code to arrive.

To obtain a Harmony 11.1 activation code, send the following information to:
licensor@toonboom.com.

• Your name and the name of your company

• Email address where to send the license file

Additional Network Settings

You should edit the hosts file only if there are problems or slowness when a computer is resolving
names.DO NOT edit the hosts file unless there are problems resolving names on the network.
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How to edit the hosts file

1. Set up the server and clients' IP with a static (fixed) IP address.

2. Go to C:\WINDOWS\system32\drivers\etc\ folder and open the hosts file using a plain text
editor.

3. Go to the end of the file, on a new line add the static IP address and themachine name accordingly.
If you are using a domain, you need to use the fully qualified domain name (FQDN).

For example, if the server name is server.toonboom.com in the domain and the IP address of the
server is 192.168.1.1, the line should be:

192.168.1.1 server.toonboom.com

4. Add the rest of the client's IP and hostname on a new line and click Save.

5. Copy and paste the hosts file to all themachines including the server under the
C:\WINDOWS\system32\drivers\etc\ folder.

Windows 2008 Server

For a Windows 2008 server, you need to perform some additional steps to complete the task.

If you have a domain, you need to add a usabatch user on the global group where all the Harmony
users are. This user should have administrator account rights.

• The user name is usabatch

• The password is usabatch

If an error due to the password policy occurs, you can change the password policies for both the
Domain Controller Security Policy and Domain Security Policy. You also need to do this from the
Domain server if it is different from the Harmony database server.

1. From theWindows Start menu, select Control Panel.

2. In Control Panel, double-click onAdministrative Tools.

3. In Administrative Tools, select Group Policy Management.

4. In the hierarchy view of theGroup Policy Management, go into the Domain used by Harmony, right-
click onDefault Domain Policy and select Edit.

5. In the hierarchy view of theGroup Policy Management Editorwindow, go inComputer
Configuration > Policies >Windows Settings > Security Settings > Account Policies > Password
Policy.

6. On the right side of theGroup Policy Management Editorwindow, double-click on Passwordmust
meet complexity requirements.

7. Select theDefine this policy setting andDisabled options.

8. Click OK.

Wait for the changes to take effect or restart the Server. It can take several minutes for the domain
controller to update and use the new settings.

Once this is done, you can create the usabatch user, which should be inside the Harmony user
group.

Pre-installation Configuration

Before installation, configure your computer by performing the following tasks:
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• Turning off Anti-Virus Software on page 12

• Turning Off the Firewall on page 13

• Turning Off Use Simple File Sharing on page 14

Inform your System Administrator before proceeding with these tasks.

Turning off Anti-Virus Software

Inform your System Administrator before proceeding with this task.

How to turn off your anti-virus software

1. From the Start menu, select Settings > Control Panel.

Vista Users: Click the Startmenu and select Control Panel.

The Control Panel opens.

2. In the Control Panel window, double-click on the Security Center icon .

Vista Users: Turn offMalware Protection.

TheWindows Security Center dialog box opens.
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3. If your anti-virus software is not detected, open all anti-virus software applications on your
computer and disable each onemanually.

Turning Off the Firewall

Inform your System Administrator before proceeding with this task.

How to turn off the Windows firewall

1. From the Start menu, select Control Panel.

2. Double-click on theWindows Firewall icon.

3. In theWindows Firewall window, click Turn Windows Firewall On or Off on the left side of the
window.

The Customize Settings for Each Type of Network dialog box displays.

13
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4. Select the Turn off Windows Firewall option for both private and public network locations.

5. Click OK.

Turning Off Use Simple File Sharing

How to turn off simple file sharing

1. From the Start menu, select Computer.

2. From theOrganize menu, select Folder and Search Options.

The Folder Options dialog box opens.

3. In the View tab, deselect theUse SharingWizard (Recommended) option.
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Installing Toon Boom Harmony

Now that you have verified your minimum requirements and configured your hardware and software,
you are ready to install Toon BoomHarmony.

You will perform the following tasks:

1. Upgrading from a Previous Installation on page 16

2. Installing Toon BoomHarmony on page 19

Upgrading from a Previous Installation

If you are not upgrading from a previous installation of Toon BoomHarmony, go to Installing Toon
BoomHarmony on page 19.

If you are performing an upgrade, pick a timewhen Toon BoomHarmony production is slow or
stopped. During the upgrade, no users can run any of the Toon BoomHarmonymodules and all
rendering jobs must be stopped or completed.

Before you can update a previous installation of Toon BoomHarmony, youmust stop all services,
including:

• The database server

• Batch processing

• The license server

Stopping Services Affecting Harmony

How to stop all services affecting Toon Boom Harmony

1. Make sure that no one is running Toon BoomHarmony. All Toon BoomHarmonymodules must
be closed on the server and on all the clients.

2. Make sure that all batch rendering or vectorizing is complete or that the queues are empty. In the
Control Center module, use theQueuemenu to open the Vectorize and Render Queue for all
environments. The queues should be empty or the status of all jobs should be "Completed".

Upgrading from version 7.2 or earlier:

‣ From the Start menu, select All Programs > Toon Boom Harmony (or Opus) >
Configuration Tools > usa_cfg.

The USAnimation Properties window opens.

Upgrading from a previous version of 7.3:

‣ From the Start menu, select All Programs > Toon Boom Animation > Toon Boom
Harmony > Tools > Harmony Control Panel.

The Harmony Properties window opens.

Upgrading from versions 7.8, 9.2 or a previous version of 10:

‣ From the Start menu, select All Programs > Toon Boom Harmony > Tools > Control
Panel.

The Harmony Control Panel dialog box opens.
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3. From the Process Start menu, select Stop. Do this for every Toon BoomHarmony-related process
running on themachine.

You can also stop tbdbserver on the server and tbprocess onworkstations that are set as a
batch render.

4. Turn off all the client machines and the render farm.

Stopping the License Server

How to stop the license server

1. On the License server computer, from the Start menu, select All Programs > Harmony >
Configuration Tools > FLEXlm - lmtools.

The LMTOOLSwindow opens.

Upgrading from version 7.3: Click the Start menu and select All Programs > Toon Boom
Animation > Harmony > Tools > Flexlm Tools.

Upgrading from version 7.8: Click the Start menu and select All Programs > Toon Boom
Harmony 7.8 > License Tools > Flexlm Tools.

2. In the Start/Stop/Reread tab, select the license server from the FLEXnet license services installed
on this computer list.

17
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3. Click Stop Server.

4. In the Config Services tab, click Remove Service to remove the license service.

5. Close the LMTOOLSwindow.

Removing Harmony Related Environment Variables

To complete the installation, you need to remove some environment variables set by the previous
installation.

Please do this with caution.

1. Click the Startmenu and select Control Panel.

The Control Panel opens.

2. Double-click on System and select theAdvanced system settings link in the left panel.

3. In theAdvanced tab, click Environment Variables.

4. In the System Variables panel, select LM_LICENSE_FILE if it is listed, and then click Delete
button to delete LM_LICENSE_FILE.

5. Delete any of the following variables if they appear in the System or User variables lists:
TOONBOOM_LICENSE_FILE, USADB, USADIR or USAROOT.

Backing Up Configuration Files

You also need to back up any necessary configuration files from themachine in case you want to
reuse them. You can also back up the license.dat file as well.

How to back up any necessary configuration files

1. Do one of the following:

‣ Version 7.8: Go to \Program Files (x86)\Toon Boom Animation\Harmony 7.8\etc.

‣ Version 7.3: Go to \Program Files (x86)\Toon Boom Animation\Harmony\etc.

‣ Versions 7.2 and earlier: Go to the \usa\etc folder.

18
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2. Back up any of the following configuration files:

‣ Scan.conf if this workstation is to be configured as a scanning station.

‣ VectOptions.conf on anymachine (including the server) that is doing batch vectorization.

‣ Any other.conf file that is required to be used later.

You can back up the entire /usa or harmony folder to ensure all configuration file are backed up.

3. Go to the/usa/etc/flexlm folder and back up the license.dat file.

Uninstalling the Previous Version of Toon Boom Harmony or Opus

Now youwill uninstall the previous version of Harmony or Opus.

How to uninstall the previous version of Harmony or Opus.

1. From the Start menu, select Control Panel.

The Control Panel opens.

2. Double-click on Program and Features and select Harmony or Opus.

3. From the top menu, click Uninstall.

4. Reboot themachine.

5. Back up the database. For the server upgrading process, back up the database by exporting the
entire database. This will prevent you from losing any data during the upgrading process. You can,
however, back up the current /usa_db and /usadata by renaming them (this procedure can only
be used when installing on the same server). This requires extra caution. If you are at all unsure,
contact your system administrator or Toon Boom Support.

Installing Toon Boom Harmony

How to run the installation script

1. Download the build of Harmony that you are going to install.

2. Double-click on the Harmony InstallShield executable. 

3. Select the language for the installer and click OK. This will only affect the language of the installer,
not the Harmony software.

4. In the InstallShieldWelcomewindow, click Next to continue with the installation.

The License Agreement dialog box opens.

5. Read the license agreement and decide if you accept its terms.

‣ If you accept the terms in the license agreement, select I accept the terms in the license
agreement and click Next.

‣ If you do not accept the terms in the license agreement, click I do not accept the terms in
the license agreement and then click Next.
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The installation will stop immediately and Toon BoomHarmony will not be installed on your
computer.

The Destination Folder dialog box appears. You can click Cancel to interrupt the installation and
then click Yes to stop the installation completely.

You can install Toon Boom Harmony to any location. This document assumes that the installation will be
done at the default location.

6. Select the drive on which you want to install Toon BoomHarmony and click Next.

The Setup Type dialog box appears.

7. Select the type of installation you want to do. Select theComplete option to install all the
HarmonyNetwork components.
When installing a server, it is possible to do a custom install and install only the server
component. However, it is recommended to always do a full install as this will give you access to
all the applications from the server if need be.

8. Click Next.

The Ready to Install the Program dialog appears.

9. Click Install again to begin the installation.

10. When this process is complete, click Finish.
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Configuration

After installing Toon BoomHarmony, you need to configure the database parameters depending on
your machine's setup and third-party software, and restart your anti-virus settings.

1. Configuring Toon BoomHarmony on page 21

2. Sharing Toon BoomHarmony Related Directories on page 26

3. Configuring the License on page 28

4. Turning on the Anti-Virus Software on page 34

Configuring Toon Boom Harmony

You can use the Toon BoomHarmony InstallationWizard at any time to:

• Modify the Toon BoomHarmony server or client configuration

• Configure batch processing

• Configure scanners

• Prepare a client to be the client of a Linux server

• Add Harmony's path to the Path environment variable

After installation, youmust set up the database configuration for computers running Toon Boom
Harmony.

1. Setting Up the Database Server on page 22

2. Setting Up the Database Client on page 25

How to open the Toon Boom Harmony Configuration Wizard

1. From the Start menu, select All Programs > Harmony 11.1> Tools > Configuration Wizard.

The Toon BoomHarmony Configuration dialog box opens.
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Setting Up the Database Server

TheDatabase Server controls all interactions with the contents of the Toon BoomHarmony
database. It processes all requests to open, read or update files, keeping track of files that are
locked so others cannot edit them.

How to set up the Database Server

1. In the Toon BoomHarmony Configuration dialog box, click theDatabase button.

2. Select the Server/Standalone option and click Next.

3. Select the location of the database from the drop-list and set a username and password for the
user who will be running the database services.
The default account is usabatch. If the account specified does not exist, it will be created by the
wizard.
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Make sure to take note of the account name and password if an account other than the default one
is used. This information will be required later on for client workstations to connect to the server.

4. Click Next.
The configuration program creates the USA_DB database in the location you specified. The USA_DB
database tracks the location of the scene data on the file system. You can havemultiple file systems,
but only one USA_DB.

If you are upgrading from a previous version of Harmony or Opus and you have renamed USA_DB for
backup, you need to create new USA_DB at the same location where the previous USA_DB was located.

5. In the Scene Data Location window, create the storage locations for the database.

23
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‣ Filesystem: Select the file system youwant to add. The first File system is already created
for you. If you want to create additional file systems to, for example, store scene data
across multiple drives or computers, click Add.

‣ Drive: Select the drive on which you want to create the file system.

‣ Share: In this field is the name of the file system that will be created. You can change this
value. However, it is recommended to leave the default name, which increments from
usadata000.

‣ Host Computer: Enter the name of the computer on which this file systemwill be created.
By default, the current computer's name appears here. You can create file systems on
other computers if necessary.

‣ User Name and Password: Specify the user name and password that will be used to
connect to the file system. It is recommended to use the same user name and password as
the one used for the database.

6. Click Next.

The Toon BoomHarmony: Review window opens.
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7. Review the information in the window. If it is correct, click Finish.

Setting Up the Database Client

After you have configured your server, you can configure all the client machines that will connect to the
server. Use the Toon BoomHarmony ConfigurationWizard to connect client computers to the
database.

How to set up the Database client

1. In the Toon BoomHarmony Configuration dialog box, click theDatabase button.

2. In the Database Creation window, select theClient option and click Next.

3. In the Server Namewindow, enter the name of the Toon BoomHarmony server and click Next.

4. In the Review window, verify the database changes and click Finish.
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Amessage appears when the client computer is successfully connected to the database server.

It is possible to change the user account used to connect to USA_DB or the different file systems using
the Toon Boom Control Panel, which you can start from Start > Programs > Harmony 11.1 > Tools >
Control Panel.

Sharing Toon Boom Harmony Related Directories

Sharing Toon BoomHarmony related directories does not need to be done in a typical installation.
This is required only when the shares were not created correctly during server configuration. For
example, this can happenwhen simple file sharing was not turned off before running the
ConfigurationWizard on the server. Or when you have backed up the usadb and usadata folders
before installation, youmay have to share themwhen putting them back into place.

If you are upgrading from a previous version and you have changed the USA_DB and USADATA name
during upgrade, make sure to return to the normal names before continuing.

How to activate file sharing for the Toon Boom Harmony folder

1. OpenWindows Explorer.

2. Locate the following folder: C:\Program Files (x86)\Toon Boom Animation\Harmony
11.1.

3. Right-click on theHarmony 11.1 folder and select Properties.

4. Select the Sharing tab.
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5. Select the Share this folder option.

6. Click Advanced Sharing.

7. In the Share Name field, type usa.

Changing the name of the share to usamust only be done when sharing the Harmony folder. The USA_DB
and USADATA folders should keep their original name.

8. Click Permissions.

The Permissions dialog box displays.

9. Set all permissions in the Everyone group to Allow and click OK.

10. Back in the File Properties window, select the Security tab.
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11. Click Edit to prompt the permissions window. Set all permissions in each group or user to all.

12. Click OK.

13. Repeat steps 3 to 10 with the USA_DB and USADATA folders.

Configuring the License

How to configuring the license server

1. From the Start menu, select All Programs > Harmony 11.1 > License Tools > LicenseWizard.

Depending on how the LicenseWizard was started, the first page of the LicenseWizard will be
as following:

Click Activate License to open the ActivationOptions screen.
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2. Click Internet Activation.

The Internet ActivationOptions screen appears.

3. Click Network License.

The Internet Activation - Network License screen appears.
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4. Type or copy/paste the product code and type in the number of licenses this product code
grants you.

Once activated, a server license cannot be returned to the activation server. Make sure you are
activating the license on the correct computer with the proper license count.

5. Click Next.

The Install License Server screen appears.

6. Click Install License Server.

The license.dat file is created and placed in /usr/local/flexlm/licenses/license.dat. The
license.dat file contains the following information:

SERVER this_host 0 ANY

VENDOR toonboom

USE_SERVER

It will also configure and start the License Server service.

The Activation Successful screen appears.
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7. Click Finish to exit the wizard.

8. Look at the lmgrd.log to make sure it was started properly.

C:\flexlm\lmgrd.log

9. From the Start menu, select All Programs > Toon Boom Harmony 11.1> License Tools > FlexLM
Tools and verify that the license server has been configured properly and that it is running.

Below are the default parameters for the license service.

10. It is good practice to verify that the license service it properly running by going in the Server Status
tab and clicking Perform Status Enquiry.

Restoring Backed Up Data

How to restore backed up data

1. Open the Toon Boom Harmony Control Panel and select HarmonyStart0-tbdbserver from
the Process Starter menu and click Stop.

2. Press Ctrl + Alt + Delete to open the Task Manager. Select the Processes tab and verify that the
tbdbserver is no longer there.

3. Open the File Explorer and rename the new empty USA_DB database folder to USA_DB_NEW .

4. Rename the USA_DB_BAK (the one that was backed up earlier) to USA_DB to restore the previous
database.

5. Copy the dicts files from the new database (USA_DB_NEW/dicts) to the one you restored (USA_
DB/dicts).

31



Chapter 1: Installing on Windows Configuring the License

Dicts files can also be copied from C:\Program Files\Toon Boom Animation x86)\Harmony_
11.1\etc\USADB_templates\dicts

6. Share the USA_DB folder giving full control every one. Make sure that simple file sharing is turned
off before doing this.

If you cannot set permissions per use for the share, it means that simple file sharing is turned on.

7. Rename the new empty usadata000 folder (and any other file system folder) to usadata000_
NEW.

8. Share the usadata000 folder (and any other folder you have restored) giving full control to
everyone.

9. Start the tbdbserver by opening the Toon Boom Harmony Control Panel. Select
HarmonyStart0-tbdbserver from the list and click Start. After starting the tbdbserver,
look at the tbdbserver.log to make sure it was started properly.

C:\ProgramData\Toon Boom Animation\Toon Boom Harmony

10. Verify that you can open Harmony and scenes from the server.

Setting Up the License on Client Workstations

AnAdmin account is required to set this up. After activation, you can log in as client.

How to set up the license on a client workstation

1. Open the LicenseWizard on the Client machine.

2. Click Activate License.

The ActivationOptions screen appears.
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3. Click Use License Server.

The Server Activation screen appears.

4. Click Connectto Server.

The Server Activation - Shared License dialog appears.

5. In the License Server Address field, enter the hostname or the IP Address.

33



Chapter 1: Installing on Windows Turning on the Anti-Virus Software

6. Click Connect.

You are prompted for a password.

7. Enter the password and click OK.

8. Click Finish to close the LicenseWizard.

Turning on the Anti-Virus Software

Inform your SystemAdministrator before turning your anti-virus software back on.

How to turn the anti-virus software back on

1. Reactivate virus protection. If your anti-virus software is not detected, open any anti-virus
software applications on your computer and reactivate each onemanually.

Turning on the Firewall

The process to do this is basically the reverse of the procedure used to deactivate the firewall.

Inform your SystemAdministrator before proceeding with this task.

How to turn on the firewall

1. From the Start menu, select Control Panel.

2. Double-click on theWindows Firewall icon.

3. In theWindows Firewall window, click Turn Windows Firewall On or Off on the left side of the
window.

The Customize Settings for Each Type of Network dialog box displays.

4. Select the Turn on Windows Firewall option.

5. Click OK.

34



Toon Boom Harmony 11.1 Installation Guide

Creating Inbound Rules

How to create inbound rules

1. Back in theWindows Firewall window, click theAdvanced Settings link.

2. Click Inbound Rules to display the list of inbound rules.

3. On the right side of the window, click New Rule.

4. Select the Program option and click Next.

35



Chapter 1: Installing on Windows Turning on the Anti-Virus Software

5. Select the This Program Path option and click Browse.

6. Navigate to the Harmony installation path and select tbdbserver.exe. Click Open.

7. Click Next and select theAllow the Connection option
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.

8. Select the profiles for which this rule will be applied according to your network configuration and
click Next.

9. Finish the Rule creation process by clicking Finish.

10. Repeat steps 1 to 9 for tbprocess.exe and toonboom.exe.

11. Repeat steps 1 to 9 for lmgrd.exe if this computer will be used as a license server.
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Troubleshooting

If you have any outstanding issues running Toon BoomHarmony after installation, review the
installation and configuration instructions to make sure you have followed them completely. If you
continue to have problems, consult the following list to troubleshoot common installation and
configuration problems.

• Problem: License Error When Starting a Toon BoomHarmonyModule on page 38

• Problem: Unable to Import Sample Scene (Errors with the tbdbserver) on page 38

• Problem: Unable to Open Sample Scene on Clients on page 40

• Problem: resolution.conf Error Message on page 40

Problem: License Error When Starting a Toon Boom Harmony Module

If you are getting license errors when you start a Toon BoomHarmonymodule, verify the setup and
configuration of the license service.

How to verify the setup and configuration of the license service

1. Make sure that the license.dat file is in the following directory:
C:\flexlm

2. Open the license.dat file; it should contain the following information:

SERVER this_host 0 ANY

VENDOR toonboom

USE_SERVER

3. Make sure that the license service is running.

If you continue having problems with the license server, locate the file ToonBoomLicense.log
and send it to support@toonboom.com. This file is usually in C:\flexlm.

Problem: Unable to Import Sample Scene (Errors with the tbdbserver)

Check the tbdbserver.log file. It is usually stored in C:\ProgramData\Toon Boom
Animation\Toon Boom Harmony.

If there is no log file, restart the tbdbserver.

How to restart the tbdbserver

1. Open the Control Panel.

2. Double-click the Toon Boom Harmony Control Panel icon.

The Toon BoomHarmony Control Panel dialog box opens.
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3. From the Process Startermenu, select tbdbserver.

4. Click Start.

If you continue to have problems with the database server, locate the tbdbserver.log file and
send it to support@toonboom.com. This file is usually in C:\ProgramData\Toon Boom
Animation\Toon Boom Harmony.

You can also run the Dbserver from the command shell in debugmode to receive additional
information about the process.

How to run the tbdserver in debug mode

1. Open the /USA_DB/Dbserver.conf file.

2. Add the following line to the file:

debug_port 5681

3. Click the Start menu and select All Programs > Harmony 11.1> Configuration Tools > Control
Panel.

4. In the Toon BoomHarmony Control Panel window, select tbdbserver from the Process Starter
menu and click Stop.

5. Open a command prompt by selecting Start > All Programs > Accessories > Command Prompt.

6. Type the following:

tbdbserver -debug

While you are running the tbdbserver in debug mode, messages will be written to the shell for each
operation the tbdbserver performs. This is in addition to the information written to the tbdbserver.log file.

7. To output this information to a new file, type the following:

tbdbserver -debug > "C:\ProgramData\Toon Boom Animation\Toon Boom
Harmony\tbdbserver_debug.log"
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If you still cannot determine the nature of the problem, send the file to support@toonboom.com with a
detailed description of the problem.

Problem: Unable to Open Sample Scene on Clients

If clients cannot open the sample scene, it is possible that they are not connected to the database
server. Follow the instructions for connecting to the server—see Setting Up the Database Server on
page 22.

Problem: resolution.conf Error Message

When you open the sample scene, youmight get an error message that says that the
resolution.conf file cannot be opened. This file is usually stored in the environment or job
directory of your database. There is a resolution.conf file you can copy.

How to obtain a copy of the resolution.conf file

1. Open the following folder:

\Program Files\Toon Boom Animation(x86)\Harmony 11.1\resources\samples

2. Copy the resolution.conf file to one of the following folder:

‣ \USA_DB\environments\[environment_name]

‣ \USA_DB\jobs\[job_name]

‣ \USA_DB\resolution\
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Chapter 2: Installing Harmony Cloud on Windows
You can use the Toon BoomHarmony InstallationWizard at any time to install Harmony Cloud Server
as a service.

Configuring Toon Boom Harmony Cloud

How to open the Toon Boom Harmony Configuration Wizard

1. From the Start menu, select All Programs > Harmony 11.1> Tools > Configuration Wizard.

The Toon BoomHarmony Configuration dialog box opens.

How to install Harmony Cloud as a service

1. In the Toon BoomHarmony Configuration dialog box, click Harmony Cloud Server.

The Harmony Cloud Server window opens.
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2. Select the Yes option and click Next.

3. Review the information in the window. If it is correct, click Finish.

When the configuration wizard is finished, a dialog box opens which indicates the success of the
process.

Customizing the Harmony Cloud Service
The Harmony Control Panel can be used to customize the parameters for the Harmony Cloud
service.
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How to customize the Harmony Cloud Service

1. From the Start menu, select All Programs > Toon Boom Harmony 11.1 > Tools > Control Panel.

2. On the Process Starters tab, select HarmonyStarterX-HarmonyCloud from the Process Starter
menu.

3. If the service is running, click Stop.

4. In the Command Line field, modify the parameters you want to change. The customizable
parameters are:

‣ --http-port the port to deploy to

‣ --http-addressIPv4 (e.g. 0.0.0.0) or IPv6 Address (e.g. 0::0)

‣ --threadsnumber of threads

5. Click Update parameters.

6. Click Start.

Running Harmony Cloud Manually
If you do not want to run Harmony Cloud as a service, you have the option of manually starting the
Harmony Cloud server—seeCustomizing the Harmony Cloud Service on page 42.

How to run Harmony Cloud manually

1. Using a command window, navigate to the installed directory of Toon BoomHarmony 11.1. This is
usually located in:

C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 11.1

2. Navigate towin64\bin folder.

3. RunHarmonyCloud.bat.
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You can change the default port used by Harmony Cloud bymodifying the
HarmonyCloud.bat file. Open the file using your favourite text editor and update
the value of the parameter –http-port to the desired value. See bolded text below:

HarmonyCloud.exe --docroot ../../resources/cloud --http-address 0.0.0.0 --http-port
8080 --config ../../resources/cloud/wt_config.xml

Managing the Harmony Cloud Service

Using the Harmony Control Panel

If at any point you want to stop/start Harmony Cloud Services, you can do so through the Harmony
Control Panel.

How to use the Harmony Control Panel

1. From the Start menu, select All Programs > Toon Boom Harmony 11.1 > Tools > Control
Panel.

2. On the Process Starters tab, select HarmonyStarterX-HarmonyCloud from the Process Starter
menu.

3. Click Start or Stop to start or stop the service respectively.

Using Windows Services

If at any point you need to start/stop or restart the Harmony Cloud server, you can do so through
the Administrative Tools inWindows.

How to access a list of running services on your computer

1. Navigate to your system's Control Panel.

2. Depending on your setup, select System and Security > Administrative Tools > Services or
Administrative Tools > Services.
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3. LocateHarmonyStarterX-HarmonyCloud from the list of services and right-click and select Start
or Stop to start or stop the service.

Uninstalling the Harmony Cloud Service

How to uninstall the Harmony Cloud Service

1. In the Toon BoomHarmony Configuration dialog box, click Harmony Cloud Server.
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2. Select theNo option, and click Next.

3. Review the information in the window. If it is correct, click Finish.

4. When the configuration wizard is finished, a dialog box opens which indicates the success of the
process.
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Alternatively, you can use the Harmony Control Panel to remove the Harmony Cloud service or delete
the Harmony Cloud process starter.

How to uninstall through the Harmony Control Panel

1. From the Start menu, select All Programs > Toon Boom Harmony 11.1 > Tools > Control Panel.

2. On the Process Starters tab, select HarmonyStarterX-HarmonyCloud from the Process Starter
menu.

3. Click Remove then click Delete Process Starter.

4. Click OK.

Network Setup
If your server does not have a assigned IP address on your DNS server, you should set up a static IP.

Setting Up a Static IP

How to set up a static IP for accessing the Harmony Cloud application

1. Click the Startmenu and type cmd in the Search programs and files field. Press Enter.

2. In the command prompt that opens, type:

ipconfig /all

3. Make a note of the following information from the screen: IPv4 Address, Subnet Mask, Default
Gateway andDNS Servers.
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4. From the Start menu, select Control Panel.

5. Click View network status and tasks.

6. On the top-left side of the screen, click Change adapter settings.

7. It is possible to havemultiple connections listed. You need to determine which adapter is your
connection to the Internet. Right-click on your network adapter and select Properties.

The Local Area Connection Properties opens.

8. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.

The Internet Protocol Version 4 (TCP/IPv4) Properties dialog box opens.
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9. Select theUse the following IP address option. Enter the IP address, Subnet Mask, and Default
Gateway information you obtained in step 3.

10. Select theUse the followingDNS server addresses option. Enter the DNS addresses you
obtained in step 3.

11. Click Advanced.

12. Select theDNS tab.

13. Add your DNS suffix obtained in step 3.

Opening a Port for External Connection

It is necessary to open a port in your firewall to allow other computers to access your Harmony Cloud
server. Harmony Cloud is using port 8080 by default.

How to open a port for external connection

1. From the Start menu, select Control Panel.

2. Depending on your setup, youmight need to click System and Security beforemoving to the next
step.

3. ClickWindows Firewall.

4. On the top-left side, click Advanced settings.

5. On the left pane, click Inbound Rules.

6. On the right pane, click New Rule.
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7. Select Port and click Next.

8. Select the TCP and Specific local ports options.

9. In the Specific local ports field, type in 8080 and click Next.
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10. Select theAllow the connection option and click Next.

11. Select theDomain, Private and Public options and click Next.
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12. In the Name field, type in Toon Boom Harmony Cloud and click Finish.
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Chapter 3: Installing on Mac OS X
This document explains how to install Toon BoomHarmony 11.1 onMacOS X, and assumes that you
are familiar withMacOS X networking and know how to work in a command shell.

Throughout this document, you will be creating files using your favourite text editor. Be sure to convert
your files to plain text before saving them.

There are several stages required to install Toon BoomHarmony 11.1, which are covered in the
following topics:

1. Pre-installation on page 54

2. Harmony Installation on page 57

3. Configuration on page 61

4. Configuring Harmony to Share Scene Data on page 72

5. Configuring Harmony Clients on page 80

After completing these stages, you can verify the integrity of the installation and resolve any
configuration issues.

• Troubleshooting on page 83
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Pre-installation

Before installing Toon BoomHarmony 11.1, youmust perform the following tasks:

• Checking Your MinimumRequirements on page 54

• Getting the Product Activation Code on page 54

• Prerequisites for Harmony Installation on page 54

Checking Your Minimum Requirements

For themost current Toon BoomHarmony 11.1 hardware requirements, refer to the white paper
Harmony and Your IT Department available from:

• Toon BoomAnimation Sales Representative

• Toon BoomAnimation Support at: support@toonboom.com

Getting the Product Activation Code

You should obtain a Product Activation code from the Toon Boom licensor so that you can finish the
installation process without having to wait for the activation code to arrive.

To obtain a Toon BoomHarmony 11.1 activation code, send the following information to:
licensor@toonboom.com.

• Your name and the name of your company

• Email address where to send the license file

Editing Files

• When editing files, you can use your favourite text editor. In this guide, all theMacOS X
procedures use the vi text editor.

• Youmust be logged in using the root account. If not, type sudo before launching the
command. For example:

sudo vi hosts

Prerequisites for Harmony Installation

ADNS server must be configured on the network to be able to run Harmony. All the computers
running Harmonymust be registered with this server or Harmony will not be able to run properly. If
a DNS server is not configured on the network or if Harmony workstations are having problems
resolving the name of the server, the name of the server and each client along with their IP address
should be added to the /etc/hosts file on each computer.
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• Editing the hosts File on page 55

• Editing the launchd.conf File on page 56

Editing the hosts File

How to edit the hosts file

1. Make sure the server and all the client workstations are configured with a static (fixed) IP address.

2. Open the Terminal:

/Application/Utilities/Terminal

3. From the Terminal, go to the /etc folder:

cd /etc

4. Create a backup copy of the hosts file. Youmust be logged in using the root account. If not, type
sudo before launching the command.

sudo cp hosts hosts.bak

5. Edit the /etc/hosts file using the vi text editor.

6. Once the file is opened in the editor, press ito trigger the insert mode.

7. Go to the end of the file and add a new line. Type the static IP address and themachine name
(hostname) of the server. Make sure there is a space between the IP address and the hostname.

If there is a domain configured on the network, you should also type the Fully Qualified Domain
Name (FQDN) after the hostname and separate themwith a space.

Example: 192.168.1.1 server server.toonboom.com

To complete this step, add the IP address and the hostname of each workstation that will be a
client of the Harmony server. Each of them should be typed on a new line.

8. Save the file by pressing Esc to exit the insertmode.

9. Press colon (:).

A colon appears at the bottom of the Terminal. If not, then you are still in insertmode. Make sure
you did not type the colon somewhere in the files. Press Esc again to exit insertmode.

10. Type wq.

The following appears at the bottom of the Terminal.

:wq

11. Press the Return key.

The file is written and the system returns you to /etc in the Terminal.

12. Verify the content of the hosts file:

more hosts

13. Copy and paste the hosts file to all the client machines.
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Editing the launchd.conf File

How to edit the launchd.conf file

1. Open the Terminal:

/Application/Utilities/Terminal

2. From the Terminal, go to the /etc folder:

cd /etc

3. If the /etc/launchd.conf file already exists, create a backup copy:

cp launchd.conf launchd.conf.bak

4. Edit the /etc/launchd.conf file using your favourite text—see Editing Files on page 54.

5. Once the file is opened in the editor, press ito trigger the insert mode.

6. At the beginning of the file, add a line with the following:

umask 0

7. Save the file by pressing Esc to exit the insertmode.

8. Press colon (:).

A colon appears at the bottom of the Terminal. If not, then you are still in insertmode. Make
sure you did not type the colon somewhere in the files. Press Esc again to exit insertmode.

9. Type wq.

The following appears at the bottom of the Terminal.

:wq

10. Press the Return key.

The file is written and the system returns you to /etc in the Terminal.

11. Verify the content of the launchd.conf file:

more launchd.conf
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Harmony Installation

Now that you have verified theminimum requirements and configured your hardware and software,
you are ready to install Toon BoomHarmony.

Here is what you will be doing:

1. Upgrading from a Previous Installation on page 57

2. Creating the usabatch User on page 59

3. Installing Harmony on page 60

Upgrading from a Previous Installation

When upgrading previous installations of Harmony or Opus, pick a timewhen Harmony or Opus
production is slow or stopped. During the upgrade, no users can run any of the Harmony or Opus
modules and all rendering jobs must be completed.

How to update previous installations

1. Make sure that no one is running any versions of Harmony or Opus. All Harmony or Opus modules
must be closed on the server and on all the clients.

2. Verify that all batch rendering and vectorizing is completed or that the queues are empty. You can
check the status of the Vectorize and Render queues from the Control Center module.

‣ In the Control Center module, use theQueuemenu to open theVectorize and Render
Queue for all environments. TheQueues should either be empty or the status of all jobs
should be "Completed".

Be sure to stop the queues on all rendering machines. If the queues are running, those binaries will
be locked and the installer cannot update them.

3. Stop all services running on the server and the clients.

‣ If you are upgrading from version 7.3 and later, type in the Terminal:

sudo /sbin/SystemStarter stop ToonBoomQueueServer

sudo /sbin/SystemStarter stop ToonBoomLinkServer

sudo /sbin/SystemStarter stop ToonBoomDatabaseServer

sudo /sbin/SystemStarter stop ToonBoomLicense

‣ If you are upgrading fromHarmony or Opus 7.2, type in the Terminal:

sudo /sbin/SystemStarter stop USAnimation_queues

sudo /sbin/SystemStarter stop USAnimation_link_srv

sudo /sbin/SystemStarter stop USAnimation_dbserver

sudo /sbin/SystemStarter stop USAnimation_flexlm

4. Go to the applicable folder:

‣ Version 7.8 and later: /Applications/Toon Boom Harmony [version]/tba/etc

‣ Version 7.3: /Applications/Toon Boom Harmony/usa.bundle/etc
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‣ Version 7.2: /usa/etc

5. Back up any necessary configuration files:

‣ manager.conf

‣ server.ini if this server is configured to haveWindows clients.

‣ Scan.conf if this workstation is configured to be a scanning station.

‣ VectOptions.conf from anymachine (including the server) that is doing batch
vectorization.

‣ Any other configuration file that is required to be used later.

‣ You can back up the entire application folder to ensure that no configuration file is missed.

6. Go to /usr/local/flexlm/licenses/ (/usa/etc/flexlm/ if you are upgrading from
version 7.2 folder and back up the license.dat file.

7. Delete the /Applications/Toon Boom Harmony [version] folder or rename it to keep as
a backup.

8. If you are upgrading from a previous version of Harmony or Opus, youmust delete Startup Items
from the previous installation. For example:

‣ Version 7.2 and later: From /Library/StartupItems/, delete any folders that begin
with USAnimation, such as USAnimation_dbserver.

‣ Version 7.3 and later: Delete any folders that begin with ToonBoom, such as
ToonBoomDatabaseServer.

Depending on the server and client configuration, you might not see any folders starting with Toonboom
or USAnimation.

Deleting Files in Each User's Home

If you are upgrading fromHarmony or Opus, youmust also delete extra files that are located in
each user's home.

How to delete files in each user's home

1. Open the Terminal:

/Application/Utilities/Terminal

2. Go to a user's home that was configured to work with Harmony. Using the usabatch account
as an example:

cd /Users/usabatch

3. List all the files in usabatch's home:

ls -lsa

4. Look for a folder named .MacOSX in the list of files and folders that appear.

5. If the folder is there, delete it:
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sudo rm -rf .MacOSX

6. Repeat these steps for each user that was configured to work with a previous version of Harmony.

Creating the usabatch User

Before you install Harmony, youmust create the usabatch user account on the server and on all the
workstations that will performing batch processing (computers that will be part of the batch rendering
or vectorizing farm). A number of services, including the tbdbserver, license server and batch
processing are started using the usabatch account.

The usabatch account must have administrator rights on the computer.

If you are upgrading from a previous version of Harmony or Opus, you may not need to create the usabatch
account since you will use the same account that was created from the previous installation.

How to create the usabatch user account

1. Open System Preferences. By default, there is a shortcut for System Preferences in theDock.

2. In the System panel of the System Preferences dialog box:

‣ Version 10.6 (Snow Leopard): Click Accounts.

‣ Version 10.7 (Lion): Click Users & Groups.

‣ Version 10.8 (Mountain Lion):

‣ Version 10.9 (Mavericks): Click Users & Groups.

The Password tab of the Accounts window opens.

3. To make changes to the accounts on a MacOS X, click the lock icon at the bottom of the window.
Enter your username and password for an account that has administrator privileges.

4. Click the plus (+) sign button to add a new user.

5. Give the new user the following name, account name and password:

usabatch

The usabatch account name and password must be in all lower-case letters.

6. Select Administrator from themenu next toNew Account.

7. Create the account:

‣ Version 10.6 (Snow Leopard): Click Create Account.

‣ Version 10.7 (Lion): Click Create User.

‣ Version 10.8 (Mountain Lion):

‣ Version 10.9 (Mavericks): Click Create User.

8. Once the account is created, open the Terminal and log in as the usabatch user:

su -l usabatch

9. Make sure you are in home folder of usabatch, then edit or create the .profile for usabatch:

.profile
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10. Press ito trigger the insert mode.

11. Make sure the file contains the following lines:

#!/bin/bash

umask 0

12. Press Esc to exit the insertmode, then type :wq to write the file and exit vi.

Installing Harmony

In a client-server network or in a standalone setup, youmust install Harmony, as well as the following
services on the server or the standalone computer:

tbdbserver Controls access to the database.

License service
Controls the number of licenses and features available to Harmony
users.

Batch processing Controls batch vectorizing and rendering queues.

Link server
If you are installing Harmony on a MacOS X server that will support Win-
dows clients, youmust install the Link server.

To install Harmony programs and services, youmust run the installation package. Before you start
the installation, make sure you are currently logged in the systemwith administrator rights on your
local computer.

How to get administrator privileges

1. Open System Preferences. By default, there is a shortcut for System Preferences in theDock.

2. In the System Preferences dialog box, do one of the following:

‣ Version 10.6 (Snow Leopard): Click Accounts.

‣ Version 10.7 (Lion): Click Users & Groups.

‣ Version 10.9 (Mavericks): Click Users & Groups.

The Password tab of the Accounts window opens.

3. Select your user login account and verify if theAllow user to administer this computer option is
selected. To make changes to the accounts on a MacOS X, click the lock icon at the bottom of
the window. Enter your username and password for an account that has administrator privileges.

How to install Harmony

1. Double-click the Harmony .dmg file.

2. Drag the Toon Boom Harmony 11.1 folder from the .dmg file to theApplications folder.
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Configuration

After installing Harmony, configure the database parameters and the third party software based on
the role this computer will have.

• Configuring Harmony on page 61

• Configuring the Licensing on page 64

Configuring Harmony
Once Harmony is installed, additional steps are required to configure the database on the server and
to set up the startup items and register the application path for the Terminal.

Setting Up the Database Server

The database server controls all interactions with the contents of the Toon BoomHarmony 11.1
database. It processes all requests to open, read or update files, keeping track of files that are locked
so others cannot edit them.

If you already have a database set up from a previous installation of Toon BoomHarmony 11.1, youDO
NOT need to set up the database server, startup items, or register console application in the path.
However, if you are upgrading from a previous version, you need to install the startup items and
register console applications in the path. For new installations of Harmony, youmust install all of them.

How to configure the database server using the Configuration Assistant

1. From Finder, go to Applications > Toon Boom Harmony 11.1 > Tools.

2. Double-click onConfiguration Assistant.

3. For the server, select all three options if this is the first time you are installing on this machine.

‣ If you are upgrading from a previous version and a database (/USA_DB) already exists on the
server, deselect theCreate a new Toon Boom Harmony 11.1 database option.

‣ If you are upgrading from an earlier version of Toon BoomHarmony 11.1, update the dict
files in the /USA_DB. Copy the dict files from here:/Applications/Toon Boom
Harmony 11.1/tba/etc/USADB_templates/dicts/ to /USA_DB/dicts/.

61



Chapter 3: Installing on Mac OS X Configuration

4. Click Continue.

The Create Harmony Database screen opens. The default values shown in this dialog box should
be correct.

5. Click Create.

You can always create the Toon BoomHarmony 11.1 databasemanually later. To do
so, open the Terminal and type the following:

cd / [Return]

mkdir usadata000 [Return]

chmod -R 777 usadata000 [Return]

You must be logged in using the root account. If not, type sudo before launching the command.

You canmake as many data directories as you like. Name these directories using the following
syntax, where XXX represents the number of the data directory:

usadataXXX

If you want to use a name other than usadataXXX for the Toon Boom Harmony 11.1 database, edit the
Manager.conf file and add the name or search pattern for this new database. The Manager.conf file
can be edited using the Configuration Editor in the Tools folder of your Toon Boom Harmony 11.1
installation. Open the Configuration Editor and select theManager.conf tab.
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6. In the Create Startup Item screen, select the startup items required.

Parameter Description

Create Database Server Startup Item It is mandatory to install this on the server.

Create Link Server Startup Item
This is required when there will beWindows clients con-
necting to theMac server. This service creates symbolic links
when a scene is created from aWindows client workstation.

CreateQueue Server Startup Item
This is for the batch rendering. Do not install this on the
server, as it will slow it down. Install this on a standalone
machine used for batch vectorizing or rendering.

7. Click Create.

8. In the Register Path screen, choose whether you want to register the path for the current user or for
all users.
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This option appends the path of Harmony's applications to the PATH environment variable in
order to run the applications from the Terminal.

Parameter Description

Registration Path for all users
Registers the path for all accounts on the computer. You
only need to run this once.

Registration Path for my user only
Registers the path to the current account only. You need
to run this for each user that will be using the Terminal and
you need to run this each time you create a new user.

9. Click Create to go to the next page.

10. Click Done to close the Configuration Assistant.

Configuring the Licensing

The licensing must be configured before running Toon BoomHarmony 11.1.

Youmust perform the following tasks on the server:

• Setting Up the FlexLM License Server on page 64

• Setting Up the License on Client Workstations on page 69

Setting Up the FlexLM License Server

For existing installations, you must reinstall Harmony on your license server machine in order for
FlexLM to work properly.

How to configure the license server

1. Start the LicenseWizard fromApplications > Toon BoomHarmony 11.1> Tools >
LicenseWizard.

1. Depending on how the LicenseWizard was started, the first pagewill be as follows:

‣ If this screen appears, click More Options.
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‣ If this screen appears, click Activate License.

The ActivationOptions screen appears.
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2. Click Internet Activation

The Internet ActivationOptions screen appears.

3. Click Network License.
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The Internet Activation - Network License screen appears.

4. In the Product Code fields, enter your product code.

5. In the License Count field, enter the number of licenses the product code grants you.

Once activated and returned to the activation server, a server license cannot be activated again.
Make sure you are activating the license on the correct computer with the proper license count.

6. Click Activate.

The Install License Server screen appears.
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7. Click Install License Server.
The license.dat file is created in /usr/local/flexlm/licenses/license.dat. The License Server is
also configured and started.

The license.dat created contains the following:

SERVER this_host 0 ANY

VENDOR toonboom

USE_SERVER

8. Click Finish to exit the wizard.

9. Verify that the FlexLM license is working properly:

lmutil lmstat -a

You can can also look at the log:

less /tmp/lmgrd.log

If the FlexLM service needs to be restarted:

/etc/init.d/USAnimation_flexlm restart

The Activation Successful screen appears.
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10. Click Finish to exit the wizard.

11. Verify that the FlexLM license is working properly:

lmutil lmstat -a

You can also look at the ToonBoomLicense.log file:

/Library/Logs/ToonBoomLicense.log

12. If the FlexLM service needs to be restarted:

sudo /sbin/SystemStarter restart ToonBoomLicense

Setting Up the License on Client Workstations

AnAdmin account is required for setting up the license on the client workstations. After activation you
can login as client.

How to set up the license on a client workstation

1. Open the License Wizard on the client workstation.
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The Toon BoomActivationWizard appears.

2. Click Activate License.

The ActivationOptions screen appears.

3. Click Use License Server.
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The Server Activation screen appears.

4. Click Connect to Server.

The Server Activation - Shared License screen appears.

5. In the License Server Address field, enter the hostname or IP Address.

6. Click Connect.

You are prompted for a password.

7. Enter the password and click OK.

The Activation Successful screen appears.

8. Click Finish to close the LicenseWizard.
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Configuring Harmony to Share Scene Data

Before you can share scene data between a MacOS X database andMacOS X, Linux, andWindows
clients, youmust configure theMacOS X database server appropriately.

• Sharing Harmony Directories for MacOS X and Linux Clients on page 72

• Setting Up the Server for Windows Clients on page 73

Sharing Harmony Directories for Mac OS X and Linux Clients

Toon BoomHarmony 11.1 uses NFS (Network File System) to share files betweenMacOS X and
Linux computers. Youmust use NFS to export directories from the server so clients canmount them
and share the contents.

Sharing the Database for Mac OS X and Linux Clients

If your MacOS X server will haveMacOS X or Linux clients, youmust export the USA_DB and
USADATA folders using NFS. The clients will then need to be configured to mount those exported
folders from the server.

Setting Up NFS Exports on Mac OS X 10.7 and 10.6

The following procedure shows you how to export the /USADATA and /USA_DB directories on a
MacOS Xworkstation, as NFS shared points.

How to set up NFS exports on Mac OS X 10.7 and 10.6

1. From the Finder, go to Application > Utilities and double-click on Terminal.

2. Create and edit the exports file in the /etc directory:

sudo vi /etc/exports

3. Press i to enter the insert mode and type the following:

/USA_DB -maproot=nobody

/USADATA -maproot=nobody

4. Press Esc to exit the insert mode, then type :wq to write the file and exit vi.

5. Verify that the file is correct by running:

sudo nfsd checkexports

If there is no return response, then it is correct.

6. Start nfsd:

sudo nfsd enable

7. If nfsd was already started, notify the nfsd daemon that the /etc/exports file has changed:

sudo kill -1 `cat /var/run/mountd.pid`
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The back quote (`) character is located at the top-left of the Mac OS X keyboard on the same key as the
tilde (~) character. Or simply reboot the computer.

8. Verify that the folders exported correctly:

/usr/bin/showmount -e

The following should appear:

/USA_DB Everyone

/USADATA Everyone

Once the export file is created, client systems canmount /USA_DB and /USADATA located on the
MacOS X server system.

Setting Up the Server for Windows Clients

If Windows clients are going to access the Toon BoomHarmony 11.1 database on a MacOS X server,
youmust set up the Link Server, Samba and the server.ini file. These allow the server and clients to
communicate and share data.

• Configuring and Starting the Link Server on page 73

• Configuring Samba onMacOS X 10.6 and 10.7 on page 74

• Configuring the server.ini File on page 78

• Rebooting the Server on page 79

Configuring and Starting the Link Server

If you are running Toon BoomHarmony 11.1 in a mixed environment where the server is onMacOS X
and some of the clients are runningWindows, youmust start the Link Server, whichmakes it possible
for Windows machines to communicate with the database.

How to configure the Link Server on the server in a mixed network environment

1. If you did not already install the Link Server during the server installation, youmust do it now. From
the Finder, go to Applications > Toon Boom Harmony 11.1 > Tools.

2. Double-click on theConfiguration Assistant.

3. Select Create the Startup Items and deselect the other options.

4. Click Continue.

5. InCreate Startup Item, select Create Link Server Startup Item.

6. Click Create.

7. Enter a user name and password of a user with administrator rights and click OK.

8. To start the Link Server, restart the server or type the following in the Terminal.

sudo /sbin/SystemStarter start ToonBoomLinkServer

Amessage appears in the Terminal indicating that the script was successful.
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9. A log file is generated in /Library/Logs/ToonBoomLinkServer.log. Check this file to make
sure there are no errors.

Configuring Samba on Mac OS X 10.6 and 10.7

Do the following:

• Configuring the Samba Service on page 74

• Configuring the Samba Shared Files on page 76

• Configuring the smb.conf File on page 77

Mac OS X 10.7 (Lion) no longer uses the open source Samba software to share folders for Windows
workstations. It has been replaced by Apple's own Windows file sharing software, which does not
include some of the options required to support WindowsHarmony clients.

Configuring the Samba Service

By default, Samba is not set up to run automatically onMacOS X.

How to start the Samba service

1. Open System Preferences.

2. In the Internet & Wireless section, click Sharing.

3. In the Services section, select the File Sharing option.

4. In the Shared Folders section, click the plus (+) sign.
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5. Browse and select the /USA_DB folder.

6. Repeat steps 4 and 5 for the /USADATA folder.

7. Make sure to give the usabatch account Read andWrite permissions to the USA_DB and
USADATA folders.

8. Click Options.

9. Select the Share files and folders using SMB option.

10. Select the usabatch option and click Done.
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11. Close System Preferences.

Configuring the Samba Shared Files

Next, modify the /USA_DB and /USADATA shares in the /var/db/samba/smb.shares and add
a usa section to the file.

1. Open the Terminal.

2. In the Finder, go to Application > Utilities and double-click on Terminal.

3. Go to the samba shares directory:

cd /var/db/samba/

4. Open the smb.shares file.

sudo vi smb.shares

5. Press i  to enter the insert mode.

6. Add or modify options in the file.

The following is an example of entries in the smb.shares shared file. You can addmissing options
at the end of the list.

[USA_DB]

comment = Harmony database folder

path = /USA_DB

available = yes

guest ok = no

directory mask = 777

create mask = 777

browseable=yes

read only=no

[USADATA]

comment = Harmony USADATA filesystem

path = /USADATA

available = yes

guest ok = no

directory mask = 777

create mask = 777

browseable=yes

read only=no

7. Create a [USA] share bymaking a copy of the [USA_DB] section and pasting it underneath.

8. Rename [USA_DB] to [USA].
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9. Modify the following lines under [USA]:

path = /Applications/Toon Boom Harmony 11.1/tba

comment = Harmony binaries and configuration files

10. Verify that the [USA] section looks like the following:

[usa]

comment = Harmony binaries and configuration files

path = /Applications/Harmony 11.1/tba

available = yes

guest ok = no

directory mask = 777

create mask = 777

browseable = yes

read only = no

11. Press Esc and type :wq to save the changes and quit the vi editor.

Configuring the smb.conf File

Youmust also add or modify the following entries to the [global] section of the /etc/smb.conf file.

1. Create a backup copy of your current /etc/smb.conf file:

cd /etc

sudo cp smb.conf smb.conf.bak

2. Open the smb.conf file.

sudo vi /etc/smb.conf

3. Press i  to enter the insert mode.

4. Add or modify options in the file:

[global]

map to guest = Never

dos charset = 437

unix charset = UTF-8-MAC

display charset = UTF-8-MAC

blocking locks = false

oplocks = false
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mangled names = no

When set to no, the mangled names parameter will prevent older smb clients (DOS, Win9X andWindows
NT clients) from accessing files and folders that do not have an 8.3 file name.

5. Press Esc to quit the insert mode.

6. Type :wq to save the changes and quit the text editor.

7. Verify that you have not made any basic syntax errors:

testparm

8. Notify the smbdservice of the changes:

sudo kill -1 `cat /var/run/smbd.pid`

The back quote (`) character is located at the top-left of the Mac OS X keyboard on the same key as the
tilde (~) character. Or simply reboot the computer.

Configuring the server.ini File

Before you install Toon BoomHarmony 11.1 onWindows clients, youmust create the server.ini
file on the server. The server.ini file provides information necessary inWindows for the
Configuration Wizard to set up a Windows client.

When creating the server.ini file, be attentive to spelling, character spacing and case.

How to create the server.ini on the Mac server

1. In the Finder, go to Application > Toon Boom Harmony 11.1 > Tools and double-click on the
Configuration Editor.

2. In the Configuration Editor opens, click the server.ini tab.

3. Copy and paste the following example and modify it accordingly:

This is an example of the server.ini file whose server name is harmonyserver. Also there is
one directory named USADATA.

[WizardConfig]

ServerName=harmonyserver

InstallationDrive=C
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UsaShare=usa

UsadbDrive=C

UsadbShare=USA_DB

FileSystem0=C USADATA harmonyserver

The references to the C: drive in this example are necessary for Windows clients and will be ignored by
Mac OS X.

4. From the File menu, select Save and quit the Configuration Editor.

Rebooting the Server

At this point, reboot the server so all of the services which you have just configured will start up.
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Configuring Harmony Clients

The following procedure demonstrates how to mount the /USADATA and the /USA_DB server
directories, on a MacOS X 10.6 or 10.7 workstation, as NSF Shared points.

To mount NFS Export onMacOS X 10.6 and 10.7, clients do the following:

• Renaming Existing /USA_DB and /USADATADirectories on page 80

• Configuring theMounts Using the Disk Utility on page 80

Renaming Existing /USA_DB and /USADATA Directories

This only applies if you already have a /USA_DB and a /USADATA local directory.

Before starting, youmust rename these directories if you want to keep their contents.

How to rename the local /USA_DB and /USADATA directories

1. Open the Terminal.

1. From the Finder, go to Application > Utilities and double-click on Terminal.

2. Rename the local USA_DB and USADATA directories:

sudo mv /USA_DB /USA_DB.BAK

sudo mv /USADATA /USADATA.BAK

Configuring the Mounts Using the Disk Utility

How to configure the mounts using the Disk Utility

1. In the Finder, go to Application > Utilities and double-click onDisk Utility.

2. In Disk Utility, click on File > NFS Mounts.

TheNFSMounts window opens.

80



Toon Boom Harmony 11.1 Installation Guide

3. In NFSMounts screen, click the plus (+) button on the lower-right corner.

4. In the Remote NFS URL field, type the following line. Replace [server name] by the name of the
server. For example, if the server name is jarjar, you would type: nfs://jarjar/USA_DB.

nfs://[server name]/USA_DB

5. In theMount Location field, type the following:

/Volumes/USA_DB

6. If the workstation is going to connect to a Linux server, edit theAdvancedMount Parameters:

resvport

7. Click Verify.

8. Click OK on themessage that confirms that the NFS server is functional.

9. Repeat steps 3 to 8, but enter the following for the RemoteNFS URL andMount Location:

nfs://[server hostname]/USADATA

/Volumes/USADATA

10. Click Save and enter your user password to confirm the changes.

Note that on Mac OS X 10.7 there is no Save button. Changes are automatically saved and applied when
the NFS Mounts window is closed.
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11. Quit theDisk Utility.

12. Open a new Terminal window.

13. Verify that the /USA_DB and /USADATA shared points have beenmounted properly:

ls /Volumes/USA_DB

and

ls /Volumes/USADATA

14. Create symbolic links to the USA_DB and USADATA directories at the root level /

sudo ln -s /Volumes/USA_DB /USA_DB

sudo ln -s /Volumes/USADATA /USADATA

15. Verify that the symbolic links are pointing to the right directories:

ls -l /

The symbolic links for the /USA_DB and /USADATA should look like the following:

USADATA -> /Volumes/USADATA

USA_DB -> /Volumes/USA_DB

82



Toon Boom Harmony 11.1 Installation Guide

Troubleshooting

If you have any problems running Harmony after the installation, review the installation and
configuration instructions to make sure you have followed them completely. If you continue to have
problems, consult the following list to troubleshoot some common problems.

Problem: Unable to Open Sample Scene on Clients

On the Toon BoomHarmony 11.1 server, verify the following:

• The database and data directories were exported using NFS.

• Link Server, Samba and server.ini configurations for Windows clients.

• OnMacOS XToon BoomHarmony 11.1 clients, verify that the database and data directories
weremounted using NFS.

Problem: License Error When Starting Any Harmony Module

If you are getting license errors when you start a Toon BoomHarmony 11.1module, verify the setup
and configuration of the license service.

How to verify the setup and configuration of the license service

1. If you are using a license server, verify that the license.dat file is in the following directory:
/usr/local/flexlm/licenses

2. Open the license.dat file. It should contain the following:

SERVER this_host 0 ANY

VENDOR toonboom

USE_SERVER

On a client workstation, the license server hostname should be on the first line instead of this_host.

3. On theMac license server, open theActivitymonitor and make sure that the lmgrd and Toon Boom
processes are running. If both of them aremissing, start the license service by typing the following
in the Terminal:

sudo /sbin/SystemStarter start ToonBoomLicense

This line should appear followed bymessages from lmgrd:

Starting Toon Boom License Daemon...

4. If you get an error message when you try to start the license service, it is possible that you did not
install the license Startup Item. Use the LicenseWizard to install the license server Startup Item.
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5. If you continue having problems with the license server, locate the file ToonBoomLicense.log
and send it to support@toonboom.com. The file is located in: /Library/Logs and can be
accessed from the Console application.

Problem: Unable to Import Sample Scene (Errors with the Dbserver)

• Verify the ToonBoomDatabaseServer.log file located in /Library/Logs. You can access
the file in the Console application. If there is no log file, restart the Dbserver. Type the
following in the Terminal:

sudo /sbin/SystemStarter start ToonBoomDatabaseServer

If there is a log file, the last few lines will give you some indication as to the problemwith the
Dbserver.

• If you get an error in the log about themachine name, verify the
/USA_DB/Dbserver.conf file and make sure the hostnamematches themachine name of
the Toon BoomHarmony 11.1 server.

• If you get errors about the port number, another servicemight be using port 5680. You can
change the port number in Dbserver.conf to any unused number above 5000.

• Restart the Dbserver. Type the following in the Terminal:

sudo /sbin/SystemStarter start ToonBoomDatabaseServer
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Chapter 4: Installing Harmony Cloud on Mac OS X

Configuring Toon Boom Harmony Cloud

How to install Harmony Cloud as a service

1. From Finder, go to Applications > Toon Boom Harmony 11.1 > Tools.

2. Double-click onConfiguration Assistant.

3. Select theCreate the Startup Items option and click Continue.

4. Select theCreate Harmony Cloud Server Startup Item option and click Create.

Amessage box confirms that the server has been successfully installed.
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5. Click OK.

The Finish window opens.

6. Click Done.

7. Open the Terminal and start the service:

sudo SystemStarter start ToonBoomHarmonyCloudServer

Customizing the Harmony Cloud Service

You have the ability to customize the Harmony Cloud service. This can be done using your favourite
text editor. 

How to customize the Harmony Cloud service

1. Stop the service if it is active—seeManaging the Harmony Cloud service on page 87.

2. Open this file:

sudo vi
/Library/StartupItems/ToonBoomHarmonyCloudServer/ToonBoomHarmonyC
loudServer

3. Locate the StartService() function.

4. Edit the line:

sudo -u usabatch "$USADIR/macosx/bin/HarmonyCloud_starter"
"$USADIR/macosx/bin/HarmonyCloud" --pid-file
$USABATCHHOME/ToonBoomHarmonyCloudServer.pid --docroot
"$USADIR/resources/cloud" --http-port 8080 --http-address 0.0.0.0
--threads 10 --config "$USADIR/resources/cloud/wt_config.xml"
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2>>/Library/Logs/ToonBoomHarmonyCloudServer.log
>>/Library/Logs/ToonBoomHarmonyCloudServer.log &

Where the available parameters for modification are:

‣ --http-port: The port to deploy to

‣ --http-addressIPv4 (example: 0.0.0.0) or IPv6 Address (example: 0::0)

‣ --threadsnumber: Number of threads

5. Save and close the file.

6. Start the Service—seeManaging the Harmony Cloud service on page 87.

Running Harmony Cloud Manually
If you do not want to run Harmony Cloud as a service, you have the option to manually start the
Harmony Cloud server.

How to manually run Harmony Cloud

1. Open the Terminal and navigate to /Applications/Toon Boom Harmony 11.1/tba/macosx/bin.

2. Run ./HarmonyCloud.sh.

You can change the default port used by Harmony Cloud bymodifying the
HarmonyCloud.sh file. Use your favourite text editor to open the file and change the
value of the –http-port parameter. See bolded text below:

./HarmonyCloud --docroot ../../resources/cloud --http-address 0.0.0.0 --http-port 8080
--config ../../resources/cloud/wt_config.xml

Managing the Harmony Cloud service
If at any point you need to start/stop or restart the Harmony Cloud server, you can do so through the
SystemStarter inMacOS X.

To start the service sudo SystemStarter start ToonBoomHarmonyCloudServer

To stop the service
sudo SystemStarter stop
ToonBoomHarmonyCloudServer

To restart the service
sudo SystemStarter restart
ToonBoomHarmonyCloudServer

Alternatively, you can start or stop all Harmony Services with the following commands:

To start all services
/Applications/Toon BoomHarmony 11.1/tba/macosx/bin/Startus
can be used to start all services

To stop all services
/Applications/Toon BoomHarmony 11.1/tba/macosx/bin/Stopus
can be used to stop all services
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Network Setup

Setting Up a static IP

Youwill need to set up a static IP for accessing the Harmony Cloud application.

How to set up a static IP

1. Open the System Preferences window.

2. Click Network.

3. From the Locationmenu, select Edit Locations.

4. Click the plus sign (+) and enter an appropriate name. Click Done.

5. Configure your static IP with information pertaining to your connection and click Apply.
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Opening a Port for External Connection

To allow other computers to access your Harmony Cloud server, it is necessary to open a port in your
firewall. Harmony Cloud uses port 8080 by default.

How to open a port for external connection

1. Open the System Preferences window.

2. Click Sharing.

3. Click the lock icon at the bottom of the window to enable editing.

4. Enter your password when prompted.

5. Select theWeb Sharing option.

6. Click Security.

7. Click the lock icon at the bottom of the screen to enable editing.

8. Enter your password when prompted.

9. Click Turn Off Firewall.
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10. Close the System Preferences window.
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Chapter 5: Installing on Linux
This chapter explains how to install Toon BoomHarmony 11.1 on Linux Fedora, and assumes that you
are familiar with Linux and working in a command shell.

Throughout this document, you will be creating files using a text editor. The vi text editor is commonly
used and is part of the Fedora package. Another text editor you can use is nano. To start them, just
type their name on the command line.

There are three stages required to install Harmony, which are covered in the following topics:

1. Pre-installation on page 92

2. Installing a New System on page 106

3. Configuration on page 109

After completing these steps, verify the integrity of the installation and resolve any configuration
issues.
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Pre-installation

Before installing Harmony, youmust perform the following tasks:

• Verifying theMinimumRequirements on page 92

• Obtaining the Product Activation Code on page 92

• Checking Your Pre-installation Configuration on page 92

Verifying the Minimum Requirements

For theminimum hardware requirements, visit: toonboom.com/products/harmony-stand-
alone/tech-specs.

For themost current Toon BoomHarmony hardware requirements, refer to theHarmony and Your
IT Department white paper available from:

• Toon BoomAnimation Sales Representative

• Toon BoomAnimation Support at: support@toonboom.com.

Obtaining the Product Activation Code

You should obtain a product activation code from the Toon Boom licensor, so you can finish the
installation process without having to wait for the activation code to arrive.

To obtain a Harmony 11.1 activation code, send the following information to:
licensor@toonboom.com.

• Your name and the name of your company

• Email address where to send the license file

Checking Your Pre-installation Configuration

Configure your computer before installation by performing the following tasks:

• Installing Fedora on page 92

• Disabling SELinux on page 93

• Updating theNVIDIA Drivers on page 93

• on page 94

Installing Fedora

Following are some considerations for Fedora Linux installation. Explaining how to install Fedora
Linux is beyond the scope of this document—refer to the Fedora documentation.

How to Install Fedora

1. Download the Fedora Linux documentation from:
http://docs.fedoraproject.org/
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2. Before installing Linux, make sure the distribution you will be installing is 64-bit. Harmony 11.1 will
not work if theOS is not 64-bit.

3. When installing Fedora Linux, perform a Custom installation and select to install Everything to
ensure that you get all the packages necessary to run Harmony.

4. When prompted, select Firewall as disabled. Your file server should be behind a firewall, but not be
configured as one.

5. When prompted, select SELinux as disabled.

Harmony has been tested and certified for use on the KDE windows manager.

Harmony works best with a minimum screen resolution of 1280 pixels x1024 pixels x 24-bit. If
Fedora cannot detect your monitor, configure themonitor as a generic CRT or an LCD with this
resolution and a 60 Hz refresh rate. Alternatively, consult your monitor manufacturer's
documentation.

If you are new to Linux, it is recommended that you create a boot disk to facilitate recovery.

Disabling SELinux

How to disable SELinux

1. Verify if SELinux is enabled by reviewing the contents of the SELinux config file:

more /etc/selinux/config

2. Locate the line that starts with SELINUX= and verify that the value is set to disabled:

This file controls the state of SELinux on the system.

SELINUX= can take one of these three values:

enforcing - SELinux security policy is enforced.

   permissive - SELinux prints warnings instead of enforcing.

disabled - No SELinux policy is loaded.

SELINUX=disabled

SELINUXTYPE= can take one of these two values:

targeted - Targeted processes are protected.

mls - Multi Level Security protection.

SELINUXTYPE=targeted

3. If the value is set to something other than disabled, open the file using a text editor and change
the value to disabled.

4. Once the file is modified and saved, reboot the computer.

Updating the NVIDIA Drivers

Youmust install the recommended drivers for your NVIDIA video card, otherwise Harmony will not
function.

In general, you should use the latest drivers. New drivers tend to resolve past driver issues. If you
already haveNVIDIA drivers installed, find the version number by typing:

cat /var/log/Xorg.0.log | grep "X Driver"
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How to install the NVIDIA driver

1. Download the Linux driver from theNVIDIA website:

www.nvidia.com/object/unix.html

2. As a root user, switch to text modewhen installing video card drivers.

/sbin/init 3

3. Install the NVIDIA kernel driver.

sh /[path_to_driver_file]/NVIDIA-Linux-x86_64-[driver_name].run

4. Once theNVIDIA driver installation is successful, revert to graphical mode by starting X.

/sbin/init 5

OR

startx

Some recent Linux distributions include an open source driver for NVIDIA graphic cards called
"Nouveau". This driver must be disabled in order to install the NVIDIA drivers—refer to the
NVIDIA documentation.

Upgrading From a Previous Version of Toon Boom Harmony

At this point, it is assumed that the USAnimation, Opus or Toon BoomHarmony binaries (program
files) are installed on the Toon BoomHarmony server and aremounted by all the Linux clients. When
you update the installation on the server, all clients will load the new binaries from the central mount
point.

When upgrading previous installations of USAnimation, Opus or Harmony, pick a timewhen
Harmony production is slow or stopped. During the upgrade, no users can run any of the Harmony
or Opus modules and all rendering jobs must be completed.
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• Restoring Backed Up Files on page 97

• Editing usabatch's .cshrc on page 97

• Editing Other Users' .cshrc on page 97

• Editing the /etc/skel/.cshrc on page 97

• Configuring the License Server on page 97

• Restarting the Harmony Services on page 101

• Updating the nfs Export on page 102

• Updating the smb.conf on page 102

• Verifying the Parameters Required in the smb.conf File on page 103

How to update previous installations

1. Verify that no one is running any versions of USAnimation, Opus or Toon BoomHarmony. All of
their modules must be closed on the server and all the clients.

2. Verify that all batch rendering and vectorizing are completed or that the queues are empty. You can
check the status of Vectorize and Render queues from the Control Center module.

‣ In the Control Center module, use theQueuemenu, Environment > Vectorize Queue or
Render Queue to open the Vectorize queue or Rendering queue for each environment. The
queue should either be empty or the status of all jobs should beCompleted.

3. Stop all services running on the server and the clients. Depending on the services you have running,
type the following commands in the order presented:

/etc/init.d/USAnimation_queues stop

/etc/init.d/USAnimation_link_srv stop

/etc/init.d/USAnimation_dbserver stop

/etc/init.d/USAnimation_flexlm stop

It is not necessary to delete the startup scripts from /etc/init.d/ as the Harmony
install script will update them automatically.

• It is important to stop the queues on all rendering machines. If the queues are
running, those binaries will be locked and the installer cannot update them.

4. Back up Harmony's configuration files by copying them to a location where you can recover them
later. Go to the folder where the previous version of Harmony is installed and back up the
configuration files in the etc folder:

‣ Version 7.5 and earlier: /usa/etc

‣ Version 7.8 and later: /usr/local/ToonBoomAnimation/harmony_[version]/etc

Back up the following configuration files:

Manager.conf

Scan.conf (If a scanner was configured to run with the Harmony Scanmodule on this computer)
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server.ini (If the server is configured to receive connections fromWindows clients)

VectOptions.conf (If a vectorization preset had been added to it)

If plug-ins were added to the Harmony installation, back up these files as well.

‣ Version 7.5 and earlier: /usa/lnx86/plugins

‣ Version 7.8 and 9.2: /usr/local/ToonBoomAnimation/harmony_[version]
/lnx86/plugins

‣ Version 10.0 and later: /usr/local/ToonBoomAnimation/harmony_[version]
/lnx86_64/plugins

You can back up the entire Harmony folder by renaming it to make sure all config files are kept.

5. Clean the KDE menu. The shortcut to start the previous application should be removed from the
KDE menu. There are two ways to do this::

‣ Use the KDE Menu Editor which you can start from the KDE menu. The location will vary
depending on the version of Linux installed.

‣ Delete them from the command line by doing the following:

Change to:

/usr/share/applnk/cd/usr/share/applnk/

Delete the old shortcuts:

Version 7.5 and earlier: rm USAnimation-*

Version 7.8 and later: rm ToonBoom-Harmony_*

The shortcuts will be removed from the KDE menu the next time you log in.

6. Uncompress the distribution file:

tar xvfz [path_to_distribution_file]/[filename].tar.gz

7. Switch to the directory that was extracted from the tar.gz file.

8. Run the install script specifying the options required for your server.
./install -b -d -l -p -u - kde

Parameter Description

-b This is mandatory. This installs the binaries required to run Harmony.

-c
Installs Harmony Cloud as a service. This parameter is required if this
machine is the Harmony Cloud web server.

-d Configures the tbdbserver for auto startup. Required when installing a server.

-l Configures the Link_srv for auto-startup. Required if the server has Windows cli-
ents.

-p Configures the tbprocess for auto-startup. Required if the server will perform
batch processing.

-u
Updates the dict files in the /USA_DB/dicts. This is mandatory when upgrading
a server from a version previous to Toon BoomHarmony 11.1. This option will only
work if -d is also selected.

-kde Installs Harmonymenu shortcuts in the KDE menu.
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Restoring Backed Up Files

1. Copy the server.ini, Manager.conf and any other files you backed up to the new installation:
/usr/local/ToonBoomAnimation/Harmony_11.1/etc/

Editing usabatch's .cshrc

Before you can start the Harmony services, youmust makemodifications to the .cshrc in
usabatch's home.

How to edit the usabatch's .cshrc

1. If you are not logged in as usabatch, type the following:

su -  usabatch

2. Open the .cshrc file in usabatch's home:

vi .cshrc

3. Edit .cshrc.

if ( -f /usr/local/ToonBoomAnimation/harmony_11.1/etc/usa_cshrc ) then

source /usr/local/ToonBoomAnimation/harmony_11.1/etc/usa_cshrc

endif

umask 0

4. Save and quit.

Editing Other Users' .cshrc

The.cshrc of all other users of Harmony should be edited to remove the lines that are used to source
the usa_cshrc file. It is not required to source this file any longer as the path to the application was
added to the PATH variable via the files in /etc/profile.d.

1. Remove the following line if it exists:

Versions 7.8 and 9.2:

source /usr/local/ToonBoomAnimation/harmony_[version]/etc/usa_cshrc

Version 7.3:

source /usa/etc/usa_cshrc

Editing the /etc/skel/.cshrc

1. Open the file /etc/skel/.cshrc (if it exists) and remove the lines that source the usa_cshrc
file.

Configuring the License Server

1. Depending on how the LicenseWizard was started, the first pagewill be as follows:

‣ If this screen appears, click More Options.
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‣ If this screen appears, click Activate License.

The ActivationOptions screen appears.
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2. Click Internet Activation

The Internet ActivationOptions screen appears.

3. Click Network License.

The Internet Activation - Network License screen appears.
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4. In the Product Code fields, enter your product code.

5. In the License Count field, enter the number of licenses the product code grants you.

Once activated and returned to the activation server, a server license cannot be activated again.
Make sure you are activating the license on the correct computer with the proper license count.

6. Click Activate.

The Install License Server screen appears.
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7. Click Install License Server.
The license.dat file is created in /usr/local/flexlm/licenses/license.dat. The License Server is also
configured and started.

The license.dat created contains the following:

SERVER this_host 0 ANY

VENDOR toonboom

USE_SERVER

8. Click Finish to exit the wizard.

9. Verify that the FlexLM license is working properly:

lmutil lmstat -a

You can can also look at the log:

less /tmp/lmgrd.log

If the FlexLM service needs to be restarted:

/etc/init.d/USAnimation_flexlm restart

Both steps can be donemanually if needed.

‣ To configure the License Server to start automatically at boot:

/sbin/chkconfig/USAnimation_flexlm on

‣ To start the License Server manually:

/etc/init.d/USAnimation_flexlm restart

The Activation Successful screen appears.

10. Click Finish to exit the wizard.

11. Verify that the FlexLM license is working properly:

lmutil lmstat -a

You can can also look at the log:

less /tmp/lmgrd.log

If the FlexLM service needs to be restarted:

/etc/init.d/USAnimation_flexlm restart

Restarting the Harmony Services

How to restart the Harmony services

1. Once the license is properly configured and started, start the Harmony services that are required on
your server in the following order:

/etc/init.d/USAnimation_dbserver restart

/etc/init.d/USAnimation_link_srv restart

/etc/init.d/USAnimation_queues restart
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2. Check the logs to verify that the services started properly.

/tmp/lmgrd.log

/tmp/tbdbserver.log

/tmp/tbprocess.log

/tmp/Link_srv.log

3. Start Harmony and open a scene to see if the server works properly.

Updating the nfs Export

If the Linux server has Linux or MacOS X clients, the nfs exports need to be updated with the path of
the new Harmony binaries.

/etc/exports

How to update the nfs export

1. If it exists, change the path of /usa to /usr/local/ToonBoomAnimation/harmony_
11.1

/USA_DB *(rw,sync)

/usadata000 *(rw,sync)

/usr/local/ToonBoomAnimation/harmony_11.1 *(rw,sync)

2. Run the following command so the change takes effect:

/usr/sbin/exportfs -r

3. Test the exports:

/usr/sbin/showmount -e

Export list for [hostname].toonboom.com:

/USA_DB *

/usadata000 *

/usr/local/ToonBoomAnimation/harmony_11.1 *

Updating the smb.conf

How to update the smb.conf file

1. When upgrading a Linux server, a small modificationmust bemade to the usa share path to
point to the new install. "/etc/samba/smb.conf" and change the path under the [usa] share
to the path of the new Harmony install.

[usa]

comment = Harmony binaries & stuff

browseable = yes

read only = no

guest ok = no

create mask = 0777
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directory mask = 0777

path = /usr/local/ToonBoomAnimation/harmony_11.1

2. Once the file is saved, verify that you have not made any basic syntax errors.

testparm

Load smb config files from /etc/samba/smb.conf

Processing section "[homes]"

Processing section "[printers]"

Processing section "[USA_DB]"

Processing section "[usa]"

Processing section "[usadata000]"

Processing section "[tmp]"

Loaded services file OK.

Server role: ROLE_STANDALONE

3. Press Enter to see a dump of your service definitions.

If the smb.conf was configured according to the 7.3 documentation, the testparm
commandmay return the following error:

Level II oplocks can only be set if oplocks are also set.

To get rid of this error, add the level2 oplocks = No parameter in the global
section of the smb.conf—see Verifying the Parameters Required in the smb.conf File on
page 103 for all the parameters required in the smb.conf.

4. Restart smb:

/etc/init.d/smb restart

Verifying the Parameters Required in the smb.conf File

It is always a good idea to verify the configuration of the smb.conf file.

How to verify the parameters required in the smb.conf file

1. Verify the configuration of the smb.conf.

/etc/samba/smb.conf

Parameters needed in the [global] section:

encrypt passwords = no

blocking locks = no

oplocks = no
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level2 oplocks = no

follow symlinks = yes

unix extensions = no

wide links = yes

Default parameters for the shares:

[USA_DB]

comment = Toon Boom Harmony Database

browseable = yes

read only = no

guest ok = no

create mask = 0777

directory mask = 0777

path = /USA_DB

[usa]

comment = Toon Boom Harmony binaries & stuff

browseable = yes

read only = no

guest ok = no

create mask = 0777

directory mask = 0777

path = /usr/local/ToonBoomAnimation/harmony_11.1

[usadata000]

comment = Toon Boom Harmony data 000

browseable = yes

read only = no

guest ok = no

create mask = 0777

directory mask = 0777

path = /usadata000

2. Always perform a testparm after making changes to the smb.conf.

testparm

3. Restart the smb service.
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/sbin/service smb restart

4. Reboot the server, if possible, to verify that all the services are properly started.

5. Once the server is booted, check all the logs to see if the services are running properly.

/tmp/lmgrd.log

/tmp/tbdbserver.log

/tmp/tbprocess.log

/tmp/Link_srv.log
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Installing a New System

After you have installed Fedora Linux, youmust create the usabatch user account in whichmany
Toon BoomHarmony services run.

Then you can and install Harmony. There are a number of options you can choose fromwhen
installing Harmony.

Creating the usabatch User

With Fedora Linux installed, you will create the usabatch user account. Youmust also set the
usabatch user to use the tcsh shell and create a .cshrc file to start the Toon BoomHarmony
environment whenever the user logs on.

Youmust create user accounts for all Toon BoomHarmony users. All user accounts you create on
Fedora Linux that will also run Harmonymust be set up in the sameway as the usabatch account,
except for the user name and password.

How to create user accounts

1. In a shell, log in as the root user.

2. Using a text editor, create the file /etc/skel/.cshrc. This file should contain the following
line:

umask 0

Note: The above character is a zero.

3. Create the user usabatch.

useradd -m -s /bin/tcsh -r usabatch

4. Enter the password for user usabatch.

passwd usabatch

Then, type usabatch as a password.

To create additional users repeat steps 3 and 4, replacing usabatch with the user name and
password of the new user.

Setting umask to zero (0) ensures that Toon Boom Harmony users can read and write all files in the
database, which is essential for sharing their work.

5. If you are not logged in as usabatch:

su - usabatch

6. Open the .cshrc file in usabatch's home. The .cshrc file should contain the following:

if ( -f /usr/local/ToonBoomAnimation/harmony_11.1/etc/usa_cshrc )
then

source /usr/local/ToonBoomAnimation/harmony_11.1/etc/usa_cshrc
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endif

umask 0

7. Save and quit.

8. Log out of usabatch to return to the root user.

Installing Harmony

In a client-server network or in a standalone setup, youmust install Harmony binaries and the following
services:

• Dbserver: Controls access to the Harmony database.

• License Service: Controls the number of licenses and features available to Harmony users.

• Batch Processing: If you are setting up themachine for batch processing, this controls batch
vectorizing and rendering queues.

• Link Server: If you are installing Harmony on a Linux server that will support Windows clients.

To install Harmony binaries and services, youmust run the installation script. With the product
activation code in hand, you are ready to install Harmony.

How to run the installation script

1. Uncompress the distribution file.

tar xvfz [path_to_distribution_file]/[filename].tar.gz

2. Change to the directory that was extracted from the tar.gz file.

3. Run the install script as the root user, specifying the options required for your server. There are a
number of options that control the installation process. For a typical Harmony server or a
standalonemachine, run the installation script with the following parameters:

./install -b -d -kde

With these options, the binaries are installed, and the database server is installed and set up to
start automatically. These options also add Harmony entries to the KDE applicationmenu.

If your Linux server will be servingWindows clients, add the -l option.

If you are setting up the clients for batch rendering, add the -p parameter. It is not recommended
to configure batch processing on the server as it will slow it down.

Installation Options

Option Default Value Details

-binaries

-b

Inactive Installs binaries and
configuration files
required to run Harmony
applications.

Include this option when
performing a fresh install
or when you upgrade
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Option Default Value Details

Harmony.

Use option when
installing Harmony on the
server.

-
cloudserver

-c

Inactive Installs Harmony
Cloud as a service.
This parameter is
required if this
machine is the
Harmony Cloud web
server.

-dbserver

-d

Inactive Installs the tbdbserver
as a daemon. This is the
Harmony database
server daemon. It
processes data requests
from clients on the
network.

This option also creates a
fresh database when
there is no /USA_DB
directory.

Use this option when
installing Harmony on the
server and on the stand-
alonemachine.

-help

-h

Inactive Displays script usage
information.

-kde Inactive Adds Harmony entries to
the KDE application
menu.

-linkserver

-l

Inactive Installs the link_
server daemon.

This daemon is required
for Linux or IRIX servers
to create symbolic links
for Windows clients.

If you haveWindows
clients, youmust install
this daemon on the
server.

108



Toon Boom Harmony 11.1 Installation Guide

Option Default Value Details

-process

-p

Inactive Installs the process
daemon.

The process daemon
manages batch
processing (vectorizing
and rendering) for
Harmony. Usually several
computers participate in
the batch processing
pipeline.

This parameter is
required if this computer
is going to batch process
files for Harmony.

-quiet

-q

Inactive Does not output any
information during
installation.

-target
<DIRECTORY>

-t
<DIRECTORY>

/usr/local/
ToonBoomAnimation/harmony_
11.1

Directory where the
installer will install the
harmony_11.1 tree.

-udatedict

-u

Inactive Updates the dict files in
the database. Needs to
be specified when
upgrading from a
previous version.

Configuration

After installing Harmony, configure the database parameters depending on your machine's setup and
configure third-party software.

1. Configuring the Licensing on page 109

2. Configuring Harmony on page 113

Configuring the Licensing

Now that you have installed Harmony, youmust set up the licensing so it can run on the server and
client machines.

1. Depending on how the LicenseWizard was started, the first pagewill be as follows:

‣ If this screen appears, click More Options.
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‣ If this screen appears, click Activate License.

The ActivationOptions screen appears.
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2. Click Internet Activation

The Internet ActivationOptions screen appears.

3. Click Network License.

The Internet Activation - Network License screen appears.
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4. In the Product Code fields, enter your product code.

5. In the License Count field, enter the number of licenses the product code grants you.

Once activated and returned to the activation server, a server license cannot be activated again.
Make sure you are activating the license on the correct computer with the proper license count.

6. Click Activate.

The Install License Server screen appears.
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7. Click Install License Server.
The license.dat file is created in /usr/local/flexlm/licenses/license.dat. The License Server is also
configured and started.

The license.dat created contains the following:

SERVER this_host 0 ANY

VENDOR toonboom

USE_SERVER

8. Click Finish to exit the wizard.

9. Verify that the FlexLM license is working properly:

lmutil lmstat -a

You can can also look at the log:

less /tmp/lmgrd.log

If the FlexLM service needs to be restarted:

/etc/init.d/USAnimation_flexlm restart

Configuring Harmony

After installation, set up the database configuration for computers running Harmony.

1. Setting Up the Database Server on page 113

2. Creating the Toon BoomHarmony File System on page 114

Setting Up the Database Server

TheDbserver controls all interactions with the contents of the Toon BoomHarmony database. It
processes all requests to open, read or update files, keeping track of locked files so they cannot be
edited by anyone.

When installing Harmony on the server for the first time, the Harmony database folder is created
automatically. Verify that the folder was created correctly. Look for the USA_DB folder in the root
folder /USA_DB. If you do not see the folder, then create it using the create_usa_db script:

/usr/local/ToonBoomAnimation/harmony_11.1/lnx86_64/bin/create_usa_db
/USA_DB

Next, create and edit the Dbserver.conf file to set up the Dbserver. Then run a script to start it.

How to set up the Dbserver

1. Using a text editor, create the Dbserver.conf file in /USA_DB/.

2. Type the following in the Dbserver.conf file:

Assuming themachine name of the Dbserver is harmonyserver , the lines in Dbserver.conf
would look like this:

hostname harmonyserver

port 5678

debug_port 5680
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You can find the example of Dbserver.conf in /usr/local/ToonBoomAnimation/harmony_
11.1/resources/samples. You can copy and paste it from there and change it accordingly.

3. Save and close the Dbserver.conf file.

4. Change the permissions on the Dbserver.conf file to 644.

chmod 644 Dbserver.conf

5. Start the Dbserver service.

/sbin/service USAnimation_dbserver start

Amessage appears in the shell indicating that the script was successful. A log file is generated in
/tmp/tbdbserver.log.

6. Verify the log file to ensure there are no errors written to the log.

Creating the Toon Boom Harmony File System

After you set up and start the license and Dbserver, you are ready to create the file system for the
Toon BoomHarmony database.

How to create the Toon Boom Harmony file system

1. Change directories to the root:

cd /

2. Create the following directory:

mkdir usadata000

3. Change the permission of:

/usr/local/ToonBoomAnimation/harmony_11.1 /USA_DB and /usadata000
to 777.

chmod -R 777 /usr/local/ToonBoomAnimation/harmony_11.1 /USA_DB
/usadata000

You are now ready to test your installation on the server/standalonemachine.

Configuring Harmony to Share Scene Data
This section shows you how to share the Harmony scene data for different network configurations.

• Exporting Harmony Directories for MacOS X and Linux Clients on page 114

• Configuring the Link Server on page 115

• Configuring Samba on page 116

Exporting Harmony Directories for Mac OS X and Linux Clients

Before you can install Harmony on Linux clients, youmust export the Toon BoomHarmony
directories from the server. TheNFS and NFS locking services must be running so that all machines
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can access the data directories you export.

How to start NFS services and export data directories from the server

1. To share files with other Linux machines, start the NFS service:

/etc/init.d/nfs restart

/sbin/chkconfig nfs on

‣ If you are using Fedora 16:

systemctl start nfs-server.service

/sbin/chkconfig nfs-server on

2. TheNFS lock manager must run on all Linux stations on your network. Without this service, users
cannot access the database without receiving numerous "read lock"  error messages.

/etc/init.d/nfslock restart

/sbin/chkconfig nfslock on

‣ If you are using Fedora 16:

systemctl start nfs-lock.service

/sbin/chkconfig nfs-lock on

Now you are ready to export the Toon BoomHarmony directory.

3. Use a text editor to edit the /etc/exports file. Add the names /USA_DB,
/usadata000 and /usr/local/ToonBoomAnimation/harmony_11.1 directories to the
file:

/USA_DB *(rw,sync)

/usadata000 *(rw,sync)

/usr/local/ToonBoomAnimation/harmony_11.1 *(rw,sync)

4. Run the export command to finalize the exports:

/usr/sbin/exportfs -r

5. Verify what is being exported from the server:

/usr/sbin/showmount --exports

A report appears listing all the shares exported from the server.

Configuring the Link Server

If you are running Harmony in a mixed environment where the server is on Fedora Linux and some of
the clients are runningWindows, youmust start the Link Server.This server makes it possible for
Windows machines to communicate with the database.

How to configure the Link Server on the server in a mixed network environment

1. Use a text editor to create the Link_srv.conf file in the /USA_DB directory. This file must
contain the following:
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hostname harmonyserver

port 5679

Replace harmonyserver with the name of the database server. You can find the name of a
computer by using the uname -n command.

You can find the example of Link_srv.conf under /usr/local/ToonBoomAnimation/harmony_
11.1/resources/samples/. Copy and paste it from there and change it accordingly.

2. Change the permissions on the Dbserver.conf file to 644.

chmod 644 Link_srv.conf

3. Start the Link Server.

/etc/init.d/USAnimation_link_srv start

Amessage appears in the shell indicating that the script was successful. A log file is generated in
/tmp/Link_srv.log.

4. Verify this file to ensure there are no errors written to it.

Configuring Samba

Finally, modify the /etc/samba/smb.conf file. To do this, add entries for each database directory
you want to share withWindows clients in the /etc/samba/smb.conf file. Then, add options to
the [global] section of the file.

• Configuring the Samba Service to Start at Boot Time on page 118

• Configuring the server.ini File on page 118

• Rebooting on page 119

• Setting Up Linux Clients on page 119

• Installing the Start ApplicationMenu Entries and Batch Processing on Clients on page 120

The following is an example of entries in the smb.conf file. You can add these to the end of the file.

[USA_DB]

comment = Toon Boom Harmony Database

browseable = yes

read only = no

guest ok = no

create mask = 0777

directory mask = 0777

path = /USA_DB

[usa]

comment = Toon Boom Harmony binaries & stuff
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browseable = yes

read only = no

guest ok = no

create mask = 0777

directory mask = 0777

path = /usr/local/ToonBoomAnimation/harmony_11.1

[usadata000]

comment = Toon Boom Harmony data 000

browseable = yes

read only = no

guest ok = no

create mask = 0777

directory mask = 0777

path = /usadata000

[usadata001]

comment = Toon Boom Harmony data 001

browseable = yes

read only = no

guest ok = no

create mask = 0777

directory mask = 0777

path = /usadata001/

Youmust also add or modify the following entries to the [global] section of smb.conf:

[global]

encrypt passwords = no

blocking locks = no

oplocks = no

level2 oplocks = no

follow symlinks = yes

unix extensions = no

wide links = yes

117



Chapter 5: Installing on Linux Configuration

5. Once you havemade all the changes and saved the smb.conf file, validate the file for internal
correctness:

testparm

Configuring the Samba Service to Start at Boot Time

By default, Samba is not set up to run automatically.

How to start the Samba service

1. Configure Samba to run as a service at boot time:

/sbin/chkconfig smb on

2. Start the Samba service:

/sbin/service smb start

Configuring the server.ini File

Before you install Harmony onWindows clients, youmust create the
/usr/local/ToonBoomAnimation/harmony_11.1/etc/server.ini file on the database
server. The server.ini file provides information necessary for theWindows ConfigurationWizard
to set up a Windows client.

When creating the server.ini file, pay attention to the spelling, character spacing and case.

The following is an example of the/usr/local/ToonBoomAnimation/harmony_
11.1/etc/server.ini file. In this example, the database server name is harmonyserver and
there are two usadata directories: usadata000 and usadata001.

[WizardConfig]

ServerName=harmonyserver

InstallationDrive=C

UsaShare=usa

UsadbDrive=C

UsadbShare=USA_DB

FileSystem0=C usadata000 harmonyserver

FileSystem1=C usadata001 harmonyserver

Do not worry about the references to Drive = C. They are necessary for Windows clients and will
be ignored by Linux.

You can find the example of server.ini under
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/usr/local/ToonBoomAnimation/harmony_11.1/resources/samples.
You can copy and paste it from there and change it accordingly.

Any sharing folder name should be case sensitive.

Rebooting

At this point, you should reboot the Toon BoomHarmony server to verify that all the Harmony services
are properly configured to start automatically.

Setting Up Linux Clients

To run Toon BoomHarmony on Linux clients, youmust mount the binaries and data directories stored
on the server. To access the directories exported from the server, the network file server (NFS) and
NFS locking services must be running.

How to start NFS services and mount Toon Boom Harmony directories on clients

1. To access themounted directories, start the NFS service:

/etc/init.d/nfs restart

/sbin/chkconfig nfs on

If you are using Fedora 16:

systemctl start nfs-server.service

/sbin/chkconfig nfs-server on

2. TheNFS lock manager must run on all Linux stations on your network. Without this service, users
cannot access the database without receiving numerous "read lock" error messages.

/etc/init.d/nfslock restart

/sbin/chkconfig nfslock on

If you are using Fedora 16:

systemctl start nfs-lock.service

/sbin/chkconfig nfs-lock on

You are now ready to mount the directories from the server.

3. On each client computer, create directories for:

/usr/local/ToonBoomAnimation/harmony_11.1

/USA_DB

/usadata000

The directory names must match the names on the Toon BoomHarmony server.

mkdir /usr/local/ToonBoomAnimation/harmony_11.1
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mkdir /USA_DB

mkdir /usadata000

4. To mount the directories on the client machine, edit the /etc/fstab file. In the following
example, the server is themachine name of the database server.

server:/USA_DB /USA_DB nfs rw,soft,intr,bg 0 0

server:/usadata000 /usadata000 nfs rw,soft,intr,bg 0 0

server:/usr/local/ToonBoomAnimation/harmony_11.1
/usr/local/ToonBoomAnimation/harmony_11.1 nfs rw,soft,intr,bg 0 0

This will make the Toon BoomHarmony directories mount with the default version of NFS on
your system.

If you encounter errors, try using NFS version 2. In this case, you should modify the fstab file to
match the following:

server:/USA_DB /USA_DB nfs rw,soft,intr,bg,vers=2 0 0

server:/usadata000 /usadata000 nfs rw,soft,intr,bg,vers=2 0 0

server:/usr/local/ToonBoomAnimation/harmony_11.1
/usr/local/ToonBoomAnimation/harmony_11.1 nfs
rw,soft,intr,bg,vers=2 0 0

5. At a command line, type themount all command.

mount -av

To verify that all shares aremounted:

mount

A report appears listing all the shares mounted on the client.

6. To test that themount works, open one of themounted directories and list the contents.

cd /usr/local/ToonBoomAnimation/harmony_11.1

ls

A list appears of the directories in Harmony 11.1:

etc help lang lnx86 lnx86_64 Plugins resources

Installing the Start Application Menu Entries and Batch Processing on Clients

To make it easier for users to start Toon BoomHarmony, install the applicationmenu entries for
KDE. You should also include the -p installation option to start batch processing services on
rendering machines.

How to install menu entries and batch processing

1. Go to the directory that contains the Linux installation files.

2. Run the install script with the -p and -kde options.

./install -p -kde

120



Toon Boom Harmony 11.1 Installation Guide

Troubleshooting

If you have any problems running Harmony after installation, review the installation and configuration
instructions to verify that you have followed them completely. If you continue to have problems, consult
the following list to troubleshoot common installation and configuration problems.

• License Error When Starting Any HarmonyModule on page 121

• Unable to Import Scene (Errors with the Dbserver) on page 122

• Exported Directories Not Mounting on Clients on page 122

• Harmony StageWill Not Open or Crashes on Startup on page 122

• Unable to Display Images in Harmony Stage on page 123

• Unable to Open Scene on Linux Clients on page 123

• Resolving Keyboard Shortcut Conflicts and Tweaking KDE on page 124

License Error When Starting Any Harmony Module

If you are getting license errors when you start a Toon BoomHarmonymodule, verify the setup and
configuration of the license service.

How to verify the setup and configuration of the license service

1. If you are using a license server, verify that the license.dat file is in the following directory:
/usr/local/flexlm/licenses

2. Open the license.dat file. It should contain the following:

SERVER this_host 0 ANY

VENDOR toonboom

USE_SERVER

On a client workstation, the license server hostname should be on the first line instead of this_host.

3. Verify that the license service is running on the license server.

/sbin/service USAnimation_flexlm status

4. If it is not running, start the service.

/sbin/service USAnimation_flexlm start

5. Restart the Dbserver if the license server was not properly installed or activated.

/sbin/service USAnimation_dbserver restart

6. If you continue having problems with the license server, locate the file lmgrd.log and send it to
support@toonboom.com. This file is usually in /tmp.
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Unable to Import Scene (Errors with the Dbserver)

• Verify the Dbserver.log file. It is usually stored in /tmp.

If there is no log file, restart the Dbserver.

/sbin/service USAnimation_dbserver restart

If there is a log file, the last few lines in the file will give you an indication as to the problemwith the
Dbserver.

• If you get an error in the log about themachine name, verify the /USA_DB/Dbserver.conf
file and make sure the hostnamematches themachine name of the Harmony server.

• If you get errors about the port number, verify that the port name in the Dbserver.conf file
is not used by another service. Type netstat -a to see a list of port numbers used by the
machine. If another service is using port 5678, change the port number in Dbserver.conf to
any unused number above 5000.

• Restart the Dbserver.

/sbin/service USAnimation_dbserver restart

Exported Directories Not Mounting on Clients

Onmost Fedora Linux distributions, the ypbind service is started after nfs by default. This causes
directorymounting to fail when your system boots up. This will prevent Linux clients frommounting
Toon BoomHarmony directories from the server.

Youmust verify that the ypbind service is started before nfs.

How to configure the start sequence of ypbind and nfs

1. Turn the service off and remove it from the startup configuration.

/sbin/service ypbind stop

/sbin/chkconfig ypbind off

2. Edit the ypbind startup script located in /etc/init.d/ypbind. Find the following line:

chkconfig: 27 73

Change it to:

chkconfig: 24 73

3. Restart the service.

/sbin/service ypbind start

/sbin/chkconfig ypbind on

Harmony Stage Will Not Open or Crashes on Startup

Periodically, Harmony Stage does not open and displays anNVIDIA error message in the shell. This
may not happen all the time. Users may report this error after running the application several times
successfully.
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TheNVIDIA error message directs users to instructions in the Readme file:

/usr/share/doc/NVIDIA_GLX-1.0/README.txt

Problems with the security module of the PAM system can cause these periodic problems. Follow the
instructions in the NVIDIA Readme to resolve this error.

If you continue to experience problems, verify that the xorg.conf file (in /etc/X11/) contains the
correct driver information (the driver should be nvidia, not nv).

If this does not resolve the problem, reinstall your NVIDIA driver.

Unable to Display Images in Harmony Stage

Your monitor's screen settings must be set to 24-bits per pixel.

Verify your current settings.

• If you are using Fedora, verify the file /etc/X11/xorg.conf.

Unable to Open Scene on Linux Clients

• On the Harmony server, verify that all the Harmony directories were exported. The /USA_DB,
/usr/local/ToonBoomAnimation/harmony_11.1, and /usadata directories must
appear in the /etc/exports file. Verify that the entries in this file match the name of the
directories you created on the server.

Verify that the directories have been exported.

/usr/sbin/exportfs -r

• On the Linux client, verify that you created the data directories and mounted the server
directories into those directories. Verify the /etc/fstab file to see that the data directories are
listed and spelled the sameway as the directories on the client and the server.

List the contents of themounted directories to see that there are some contents.

cd /usr/local/ToonBoomAnimation/harmony_11.1

ls

A list appears of the directories in /harmony_11.1. They are:

etc help lang lnx_86 lnx86_64 Plugins resources

• If you do not see anything in the exported directories, verify that the server directories are
mounted.

mount -a

If you are able to list the contents of the exported directories and open the sample scene after
manually mounting all shares, verify the start up sequence of ypbind and NFS to verify that NFS is
started first—see Exported Directories Not Mounting on Clients on page 122.
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Resolving Keyboard Shortcut Conflicts and Tweaking KDE
Some KDE default keyboard shortcuts conflict with the shortcuts in Harmony and can prevent
normal user operation.

How to change the keyboard shortcuts and tweak KDE

1. In the KDE menu, select Computer > System Settings. In earlier versions of KDE, youmay need
to open the KDE Control Center.

2. In the System Settings window, selectWindows Behavior in the Desktop section (in earlier
versions of KDE, open the Look & Feel > Window Behaviormenu instead).

3. Select theWindowActions tab.

4. In the Inner window, title bar and frame section, do one of the following:

‣ Change your keyboard layout to chooseMeta key from theModifier Key option. The
Meta key is theWindows Start button on a 104-key keyboard. Youmust have this type of
keyboard to use this option.
Go to Desktop > Window Behavior (in earlier versions, open the Look & Feel > Window
Behavior menu). Select theActions tab. In the Inner window, title bar and frame section,
select Meta as theModifier Key.

• If theMeta key is not available in theModifier Key list, youmust change your keyboard layout.
This is set inControl Center > Regional and Accessibility > Keyboard Layout (in earlier
versions, open theControl Center > Peripherals > Keyboardmenu). Select the Enable
keyboard layouts option and then select a KeyboardModel that includes 104 keys.

‣ Set all theModifier Key + options to Nothing.

5. There are a few KDE preferences you should update to optimize Harmony.

‣ In the KDE menu, select Computer > System Settings >Window Behavior. Select the
Moving tab to disable these two options. Harmony reacts better and faster when these
are disabled.

• Display content inmoving windows

• Display content in resizing windows

‣ In the KDE menu, select Computer > System Settings > Appearance and select the
Colorsmenu. Under theOptions tab, disable the following option: Apply colours to non-
KDE4 applications.

This option may cause Toon Boom Harmony to display incorrect colours in some of the interface
controls.
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Chapter 6: Installing Harmony Cloud on Linux
Before installing Harmony Cloud, add the following to the options list:

Option Default Value Details

-cloudserver

-c

Inactive Installs Harmony Cloud as a service.
This parameter is required if this
machine is the Harmony Cloud web
server.

Configuring the Licensing

Setting Up in a Non-Gui Environment

How to install Harmony Cloud on a Linux server with no GUI

1. Contact Toon Boom support to request a copy of the Flexnet Publisher anchor script (install_
fnp.sh) and the FlexNet Publisher Licensing Service (FNPLicensingService).

2. Place both files in the bin directory of your Harmony install. Typically located here:

/usr/local/ToonBoomAnimation/harmony_11.1/lnx86_64/bin

3. Change the permissions on the anchor script to be executable:

chmod 755 install_fnp.sh

4. Execute the install_fnp.sh script

./install_fnp.sh

5. Execute the following command to install the license:

ServerActivation -batch -served -comm soap -commServer
https://licensing.toonboom.com:443/flexnet/services/ActivationServi
ce -entitlementID XXXX-XXXX-XXXX-XXXX-XXXX

6. Type the activation key next to -entitlementID to replace the Xs.

Configuring Toon Boom Harmony Cloud

Running Harmony Cloud as a Service

After installing Harmony Cloud, you will need to start the service.

How to start Harmony Cloud as a service

1. Run the following command as the root user:

/sbin/service USAnimation_harmony_cloud start
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Customizing the Harmony Cloud Service

You have the ability to customize the Harmony Cloud service. This can be done using your favorite
text editor. 

How to customize the Harmony Cloud Service

1. Stop the service if it is active—seeManaging the Harmony Cloud Service on page 127.

2. As the root user, open the following file:

/usr/sbin/start_harmony_cloud

3. At the bottom of the file, edit the line:

exec HarmonyCloud_starter \

HarmonyCloud –docroot  ../../resources/cloud –http-port 8080 –
http-address 0.0.0.0 \

--threads 1- --config ../../resources/cloud/wt_config.xml \

>>& $log < /dev/null &

Where the available parameters for modification are as follows:

‣ --http-port the port to deploy to

‣ --http-addressIPv4 (e.g. 0.0.0.0) or IPv6 Address (e.g. 0::0)

‣ --threadsnumber of threads

4. Save and close the file.

5. Start the service—seeManaging the Harmony Cloud Service on page 127.

Running Harmony Cloud Manually
If you do not want to run Harmony Cloud as a service, you canmanually start the Harmony Cloud
server.

1. Using the Terminal, navigate to:

/usr/local/ToonBoomAnimation/harmony_11.1/lnx86_64/bin

2. Run the following:

./HarmonyCloud.sh

You can change the default port used by Harmony Cloud bymodifying the
HarmonyCloud.sh. Open the file using a text editor and update the value of the
parameter –http-port to the desired value. See the following text:

./HarmonyCloud --docroot ../../resources/cloud --http-address
0.0.0.0 --http-port 8080 --config ../../resources/cloud/wt_
config.xml
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The above parameters can be customized—seeCustomizing the Harmony Cloud Service
on page 126.

Managing the Harmony Cloud Service
If at any point, you need to start/stop or restart the Harmony Cloud server. You can do so through the
/sbin/service in Linux.

To start the service /sbin/service USAnimation_harmony_cloud start

To stop the service /sbin/service USAnimation_harmony_cloud stop

To restart the service /sbin/service USAnimation_harmony_cloud restart

Alternatively, you can start or stop all Harmony Services with the following commands:

To start all services
/usr/local/ToonBoomAnimation/harmony_11.1/lnx86_
64/bin/Startus

To stop all services
/usr/local/ToonBoomAnimation/harmony_11.1/lnx86_
64/bin/Stopus

Network Setup

Setting Up a Static IP

How to set up a static IP for RedHat, Fedora or CentOS

1. Edit the file /etc/sysconfig/network:

/etc/sysconfig/network

2. Configure the file as follows; replacing the bolded text with your values:

NETWORKING=yes

HOSTNAME=cloud.toonboom.com

3. Depending on your network card, open the configuration file. For example, if you are using eth0,
then you would edit the file /etc/sysconfig/network-scripts/ifcfg-eth0.

/etc/sysconfig/network-scripts/ifcfg-eth0

4. Configure the file as follows, replacing the bolded text with your values:

DEVICE=eth0

BOOTPROTO=static

IPADDR=174.142.76.72

NETMASK=255.255.240.0

GATEWAY=10.120.0.254

ONBOOT=yes

5. Edit the following file:
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/etc/resolv.conf

6. Configure the file as follows, replacing the bolded text with your values:

search toonboom.com

nameserver 10.120.0.1

7. Restart the network service:

/etc/init.d/network restart

Opening a Port for External Connection

It is necessary to open a port in your firewall to allow other computers to access your Harmony
Cloud server. Harmony Cloud is using port 8080 by default.

How to open a port for Red Hat, Fedora or CentOS

1. Edit the following file:

/etc/sysconfig/iptables

2. Append the following rule to the file to open port 8080:

-A RH-Firewall-1-INPUT –m state –state NEW –m tcp –p tcp –dport
8080 –j ACCEPT

3. Save and close the file.

4. Restart the iptables service:

service iptables restart
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