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Chapter 1: Traditional Animation - An Introduction
Harmony is a high-performance animation software which not only offers a wide range of features, but 
also handles more than one animation type and workflow. In this guide, you will learn how to perform 
tasks related to the traditional animation workflow from start to finish using Harmony.

Before reading this guide, be sure to take some time to familiarize yourself with the basic concepts in 
the Fundamentals Guide. Each chapter is self-contained. so you can concentrate only on the chapter 
pertaining to your task. You do not need to read the entire guide, but you should read the whole 
chapter before starting to work.

Topics in this section:

• Scanning on page 9

• Timing on page 35

• Colour Styling and Colour Models on page 113

• Ink and Paint on page 153
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Chapter 2: Scanning

Once your traditional animation sequences are completed and cleaned up, you are ready to scan and 
import them in Harmony. The scan process is the point where the traditional production becomes 
digital. It is the moment where you use Harmony to control the project. 

This chapter is divided as follows:

• The Scanning Process on the next page

• Scanning and Importing Drawings on page 11

• Custom Vectorization Parameters  on page 19
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The Scanning Process

There are three steps in the scanning process which Harmony handles automatically: 

• Vectorization

• Line art and colour art creation

• Optical registration

You can choose the following vectorization styles, which are set at the vectorization step:

• Solid lines 

• Texture lines

This keeps your texture from the original drawing and applies it to your vectorized drawing as a 
bitmap filling zone.

Harmony receives images from any TWAIN device, such as  scanners or digital cameras. These images 
can either be loaded as bitmaps into your scene or converted into vector-based images that can be 
edited using Harmony.

You must install a TWAIN driver for your device in order to access its contents. Refer to the 
manufacturer of your device to get a TWAIN driver. Once all the animation layers are scanned in, you 
can set the timing in the digital exposure sheet.

10



Harmony 11.1 Traditional Animation Guide (Standalone)

Scanning and Importing Drawings

Once your scene length is set, you can start scanning drawings and importing them into Harmony in 
one of the following ways:

A bitmap image is an image composed of pixels that are both size and resolution dependent. In 
Harmony, you can scan an image as a bitmap drawing.

You can turn bitmap images into vector drawings, while maintaining the sketchiness of a pencil line or 
into vector images with a bitmap fill. Both options can add life to an animation, which straight 
vectorization with smoothing does not usually afford.

How to scan images as bitmap drawings

1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens.

2. Select your scanner from the Scanner list.

3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following 
options:

11
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Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For 
example, the filenames a-1.tga, a-2.tga and b-1.tga will create 
layers named "a" and "b", where "a" has two drawings and 
"b" has one. When creating a single layer from these three file-
names, all three drawings will be inserted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from 
the Layer list. You must scan into the same layer type if you are using an existing layer.

‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix 
bitmap images with vector drawings on the same layer, the bitmap image must be 
encapsulated in a symbol and vice versa. Symbols will also be automatically added to the 
Symbol folder in the Library view.

4. In the Import Options section, select one of the following:

‣ Keep As Bitmap: Retains the imported image as a bitmap. In the Alignment section, decide 
on the size and placement of your image within the camera frame. Depending on the Scene 
Settings (the height and width in pixels that you chose for your project), an image that you 
import may get scaled to the point where all its individual pixels become visible. There are 
three options available in the Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to 
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or 
shrink (but not distort) your image width to match that of the 
scene grid.

12
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Note that the Fit alignment rule equals the Center Fit rule in 
the layer properties.

Pan

This is the opposite of the Fit parameter. If the image 
orientation is portrait, its width will be made to match the 
width of the scene grid. As a result, part of the image’s height 
will extend beyond the height of the frame. This can be useful 
if you want to make your background move up and down, or 
from left to right to make it appear as if the camera is 
panning, or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will 
be fit to the scene grid, therefore it is possible that the image 
will extend beyond the scene grid's boundaries.
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Note that the Pan alignment rule equals the Center First Page 
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The 
system looks at the resolution of the bitmap image, for 
example 4000 x 2000, then compares it to the scene's 
resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would 
appear at 208% (4000/1920). If you import a bitmap that is 
960 x 540, it will be displayed at 50% (960/1920) of the size of 
the project resolution.

Note that the Project Resolution alignment rule is equal to 
the As Is rule in the layer properties.

‣ Import As Bitmap Drawing: Imports a bitmap drawing into a vector layer where you can 
edit the image using the drawing tools. In the Alignment section, select one of the following:

Parameter Description

Vertical Fit
Enlarges or shrinks (but not distort) to your image height to match 
the full height of the scene frame (alignment grid).
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Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match 
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system 
looks at the resolution of the bitmap image, for example 4000 x 
2000, then compares it to the scene's resolution, for example 1920 x 
1080, and adjusts the scale factor in proportion. So, in this example, 
the bitmap would appear at 208% (4000/1920). If you import a 
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the 
size of the project resolution.

5. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.
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‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

6. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.

7. Click Scan to scan your drawing.

8. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

9. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.

How to import and vectorize bitmap drawings

1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens.

2. Select your scanner from the Scanner list.

3. Click Preview to get a test scan of your drawing.

4. In the Layer section, select one of the following:

‣ Create Layer: Imports an image into a new layer. Type a name for the layer in the Name 
field. 
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‣ Add to Existing Layer: Imports the image into an existing layer. Select a layer from the 
Layer list.

5. In the Import Options section, select the Convert to Vector Drawing option.

6. In the Vectorization section, select one of the following:

‣ Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing.

‣ Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines 
keep the texture from the scan, and the white of the paper becomes transparent.

‣ New Preset: Lets you create a new preset.

‣ Delete Preset: Lets you delete any preset in the list.

‣ Custom vectorization: Lets you set custom vectorization parameters—see Creating a 
Vectorization Style  on page 27.

7. In the Drawing Options section, set the following options if desired:

‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

8. Adjust the Scale control and the sliders in the Preview Image window until you are satisfied with 
the view.

9. Click Scan to import your drawing.

10. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.
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11. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.

18
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Custom Vectorization Parameters 

You can create your own vectorization settings with Harmony. 

The vectorization parameters you will create here can be saved, shared and also inserted into the 
VectOptions.conf file used by the Harmony Scan and Control Center modules when scanning or 
vectorizing a series of drawings.

You can use an interface to select and test the different options and you can also type in some 
advanced settings.

How to open the Vectorization Parameters dialog box

1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization 
parameters (i.e. from the scanner).

2. Select your file, decide on the layer options, and click Preview.

3. In the Vectorization section, click the New Preset  button.

The Vectorization Parameters dialog box opens.

19
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• Options Tab  below

• Help Tab on page 22

Options Tab 

The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter Description

Input

The input filters are applied to the bitmap image before it is 
vectorized.

One Pass: One threshold value is applied to both the Line and 
Colour Art. For drawings with distinct vector-style lines of 
mattes, you only need one pass.

Two Passes: Applies a different threshold value to each layer.

For greyscale drawings, you may want to perform the 
vectorization process twice to apply different threshold values 
to the Line and Colour Art layers.

Threshold: Determines which values in the scanned image are 
considered part of the Line or Colour Art layer and what will be 
eliminated from the vectorized drawing; 0% is white and 100% 
is black. The threshold is between these two values.

Expand Bitmap: Lets you enter a value to scale the bitmap to 
detect small variations in the line. Use this option if you scanned 
a greyscale image and want to preserve small variations in the 
texture to apply to the line art.

Jag Filter: Lets you enter a value to scale back the bitmap to 
remove some of the line’s roughness. This is useless when you 
have a drawing that appears quite rough; the Jag filter will 
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eliminate excess strokes in the final drawing.

Output

The output filters are applied during the vectorization process.

No Colour Art: Does not generate filling zones in the Colour 
Art layer.

No Texture: Does not generate texture in the Line Art in the 
final images. Select this option to create solid lines in the final 
line art.

Generate Matte in Underlay Layer: Creates an opaque zone 
behind your drawing’s lines to avoid seeing through the layers.

Colour as Texture: Converts colour values into a texture layer.

Optical Registration

The optical registration options are used to automatically align 
drawings based on the position of the peg holes on the 
animation paper. The peg holes must appear in the scanned 
drawings for the optical registration to work.

DPI: Lets you enter the dots-per-inch value of your image. You 
must enter the same value as the DPI used to scan the image.

Peg Side: Lets you select the position of the peg holes on your 
drawings. Identify whether they are on the top, bottom, left or 
right.

Strictness: Determines how exact the location of the peg holes 
must be for the software to recognize them. You have two 
values to choose from:

• Strict: The peg holes must be in a tightly defined area to 
be recognized.

• Loose: The peg holes can be recognized somewhere in a 
larger area. This is the recommended setting.

Field Chart: Lets you indicate the size of the animation paper; 
12 or 16.

Post Processing

The Post Processing filters are applied to the final vector 
images.

Remove Holes: Removes holes of a specified value that might 
make painting difficult.

Remove Dirt: Removes stray marks and dirt of a specified 
value. Try a value around 500.

Remove Hair: Removes small strokes that have no line art.

Remove Hair: Number of Passes: The number of times the 
drawing will be analyzed to identify hair marks.

Miscellaneous

Close Gaps: Closes gaps in the Colour Art so that you can 
paint it.

Smooth Passes for Line Art before Breaking Triangles: The 
number of times the smoothing operation runs before creating 
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the triangles that break lines in your drawing. If unnecessary 
triangles are appearing in your drawing, increase this value.

Smooth Passes for Line Art: The number of times the 
smoothing operation is performed after the triangles have 
been created. This further smooths the Line Art.

Preview

Show Strokes: Shows the strokes in the Vectorized Image 
panel.

Stroke Thickness: Shows the size of the strokes.

Help Tab

The Help tab contains the most advanced vectorization settings which you type in the Advanced 
Option fields at the bottom of the Options tab.

File IO Options 

-file <filename (including extension)> [ options ]

-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode

-noforce; don't force output if image is inconsistent

-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options 

-register <dpi side strictness>; perform optical registration.
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• Side can be one of left, right, top, bottom or l, r, t, b.

• Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page

-rcph; short form of register_center_peg_holes

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)

-rlf; short form of registration_looseness_factor

-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg bars

-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0

-rmargin <inch (default 1)>; region size where to look for peg bars 

-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image 

-pdfc; short form of -peg_distance_from_center 

-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

• Can be one of right, left, top, bottom (or r, l, t, b) or same.

• A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options 

-pixel <pixel_shape (default '4x3')>; Valid values: 4x3

-gap <worldUnits (default 10)>; close gaps up to this big

-pencil; generate line art only

-keep_dirt; don't filter out dirt

-thresh <threshold (default 0.2)>; range 0.0 to 1.0

-rmv_hairs <worldUnits (default 1)> <passes (default 1)> 

• remove hairs of size smaller than "size" in "passes" passes 

-rmv_holes <area (default 7)>; remove holes smaller than "area" 

-rmv_dirt <area (default 1)>; remove dirt smaller than "area" 

• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels" 

• distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes

-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour

-noclosegap; disable all gap closing algorithms

-no_break; disable the breaking of line art

-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
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-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap

-fit_errorc <error (default 1.000000>; fitting error for the colour art

-fit_errorl <error (default 1.000000>; fitting error for the line art

-smoothl <passes (default 1>; number of smooth passes for line art

-smoothc <passes (default 1>; number of smooth passes for colour art

-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -
2pass)

-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"

(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,

-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0

-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0

-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-rmv_holesl <area (default 7)>; remove line art holes smaller than "area" 

-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area" 

-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area" 

-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area" 

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are 
in world units squared 

-margins <inch (default 0.25)>; remove margin around bitmap 

-top_margin <inch (default 0.25)>; remove margin at top of bitmap 

-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap 

-left_margin <inch (default 0.25)>; remove margin at left of bitmap 

-right_margin <inch (default 0.25)>; remove margin at right of bitmap 

-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size

-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
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-downscale_input <default 1>; downscale the raw input by this integer factor

-downscale_texture <default 1>; downscale the output texture by this integer factor

-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

Note: -buildmatte and -buildmatte_colourart are mutually exclusive

-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information 

-pixel_margins <inch (default 0)>; remove margin around bitmap 

-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap 

-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap 

-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap 

-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap 

-dpi <(default -1)>; dpi information of input bitmap 

RGB Keying Options 

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value

-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

-flatten; flatten the drawing after generating colours

-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area

-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb

-threshrgb <value> <threshold for rgb vectorization default 0.200000>;

-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on 
saturation and value to consider a pixel to be grey

Colour Vectorization Options 

-color_vectorize; perform a colour vectorization

-file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect 
(0.0-1.0)> <edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap 
file (valid filename or "" if no file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max 
variation (0.0-1.0)>; specify a pressure strategy for the centre line. 

-blur_radius <pixels (default 0)>; blur the penstyle texture generated

25



Chapter 2: Scanning     Help Tab

-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour 
before computing texture

-ccsp <times (default 3)>; short for -color_contour_smooth_passes

-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing 
texture

-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)

-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only 

-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles

-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness 
(must be >= 1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness 
(must be >= 1.0)

-uniform_gap; the space between bubbles is constant 

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:

rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value    ; between [0.0-1.0] or [0-255]

grey:value    ; between [0.0-1.0] or [0-255]

white:value   ; between [0.0-1.0] or [0-255]

dirt:value    ; dirt area. 200 is a good value

rt:value      ; between [0.0-1.0] or [0-255]

gt:value      ; between [0.0-1.0] or [0-255]

bt:value      ; between [0.0-1.0] or [0-255]

There must be no space between the colon and the key/value. For example: -4colours 
rgbdiff:20 dark:20 grey:120 white:250 dirt:200 rt:240 gt:240 bt:240

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue 
or green pencil marks you may have used to indicate highlights and shadows. The drawing will be 
vectorized into pure red, blue, green and black (RGB values), while creating colour art zones wherever 
lines connect. After painting in your tones and highlights, change your pure RGB colours to 
transparent (0 Alpha) in the Colour Picker window and watch the indicator colour zone lines 
disappear.
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Creating a Vectorization Style 
With Harmony, you have the possibility to create custom vectorization parameters that can be saved 
and reused.

You can vectorize drawings using one of the following methods:

• Black and White: All the lines become vector based and 100% black. The white areas become 
completely transparent.

• Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image 
contained inside a vector frame. The white areas become completely transparent.

• Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black 
lines and turn them into 100% vector lines, preserving their original colours—see Custom 
Vectorization Parameters  on page 19.

How to create or modify the vectorization parameters

1. Set the different options available in the Vectorization Parameters dialog box.
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2. Click the Vectorize  button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the 
Import Images dialog box. There are many options to try in the Vectorization Options dialog box. 
These are applied during the vectorization process.

3. To set advanced parameters, read the information on the Help tab, then type in the Advanced 
Options field at the bottom of the Options tab.

4. To save your vectorization parameters to reuse them later, share them, or use them to set the 
Harmony Scan module vectorization style list, click  Save.

5. In the Browser window, name and save the file.

6. To save the current settings as your default settings, click Save As Default. To restore the default 
settings, click Restore Defaults.

7. To load a vectorization style, click Load and locate the existing *.vof file.

8. Click OK.

Setting the VectOptions.conf File
Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style 
when batch vectorizing a series of drawings. A series of default styles is available in this file, but you 
will certainly want to create your own to fit your production style.

This section deals with setting the VectOptions.conf file on:

28



Harmony 11.1 Traditional Animation Guide (Standalone)

• Setting the VectOptions.conf File on Windows and Mac OS X below

• Setting the VectOptions.conf File on Linux on page 31

Setting the VectOptions.conf File on Windows and Mac OS X

How to set the VectOptions.conf file on Windows or Mac OS X

1. Open the vectOptions.conf file:

‣ Windows: Select Programs / All Programs > Harmony 11.1 > Tools > Configuration 
Editor.

‣ Mac OS X: Select Applications > Harmony 11.1 > Tools > Configuration Editor.

The Configuration Editor window opens.

2. In the bottom section of the window, select the VectOptions.conf tab.

3. Scroll down the VectOptions.conf file to see all the different options available for creating your 
custom vectorization style. These options are the same as in the Vectorization Parameters dialog 
box. It is recommended that you create your vectorization style using Harmony and the 
Vectorization Parameters window and copy the result parameters in this file—see Creating a 
Vectorization Style  on page 27

4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add 
new ones to the list using the parameters you got using the Vectorization Parameters window. 
Notice that some of the lines have a “#” sign at the beginning to indicate that the line is a comment 
and will not appear in the style list. The lines that have no sign at the beginning appear in the style 
list.
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5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black 
Lines.

6. Under the style name line, type the following: 

options:

7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization 
Parameters window.

‣ To open the *.vof file, use any plain text editor application.

8. In the Configuration Editor’s top menu, select File > Save.

9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify 
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.  
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If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.

Setting the VectOptions.conf File on Linux

These are the two methods used to edit the VectOptions.conf file on Linux. 

• Using the “vi” text editor

• Using the “gedit” text editor 

How to set the VectOptions.conf file on Linux using the “vi” text editor

1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open 
the 'VectOptions.conf using the  "vi" text editor:" on page 31: 

$ sudo vi VectOptions.conf

4. Enter the "root" password.

5. Open the 'VectOptions.conf using the  "vi" text editor:

$ vi VectOptions.conf

6. To start editing, press the [i] key on your keyboard to enter Insert mode.

7. Once you are done editing the file, press Esc to exit Insert mode.

8. To save the changes made to the file, type the following and press Enter/Return:

$ :w!
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9. To exit the "vi" editor and return to the Terminal, type the following and press Enter/Return:

$ :q

10. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify 
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.

How to set the VectOptions.conf file on Linux using the “gedit” text editor

1. Open a Terminal window:
Menu: Applications> System Tools> Terminal

2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_11.0/etc

3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to See "Open 
the 'VectorOptions.conf using the  "gedit" text editor:" on page 32: 
$ sudo gedit VectOptions.conf

4. Enter the root password.

5. Open the 'VectorOptions.conf using the  "gedit" text editor:

$ gedit VectOptions.conf

6. Edit the parameters of the VectOptions.conf file like you would do in most text editor 
application.

7. Select File > Save.

8. Select File > Quit.
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9. If you have Harmony Scan on your computer, you can start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.

If you are using the batch processing method available with Toon Boom Harmony Server 
to scan and vectorize your drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Control Center Guide to learn more about setting up and using batch 
processing.
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Chapter 3: Timing

When you create hand-drawn animation traditionally or in a paperless environment, it is important to 
know how to set and modify the timing of your drawings. 

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper 
exposure sheet created by the animator. In a paperless workflow, the animator creates and manages 
his own exposure sheet directly in Harmony without the need for reproduction.

If you are more of a traditional animator, you are more likely to work with an exposure sheet. If you are 
a digital animator, you may prefer to work with a timeline to visualize your timing. Harmony offers 
both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-
drawn animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as 
layers.

You can adjust timing in both views; your choice depends on which technique you are used to working 
with. Depending on your working style, some actions may seem preferable to do in one view instead 
of another. Many of the actions you perform in the Xsheet can also be accomplished in the Timeline. 
This chapter will often show both techniques. You will be able to choose which one you prefer.

In this topic, you will learn how to work on your drawing’s exposure and length. The exposure and 
animation paths for symbols are covered in separate chapters.

The exposure sheet is not mandatory for Cut-out animation. It can be useful for creating characters and 
parts, but is not really needed for animation and timing. If you plan to work with Cut-out animation, you can 
still gain useful tips by reviewing the section on exposure sheets.

The basic digital exposure sheet process is divided into the following steps:
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• Preparation on the facing page

• Frames on page 39

• Filling Exposure on page 65

• Managing Drawings on page 87

• Modifying the Layer and Column Display on page 94

• Printing the Xsheet on page 110
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Preparation

The digital exposure task is quite simple. There are very few things to prepare in order to get ready.

Opening the Scene

The scene is generally created during a previous step such as scanning (in a traditional animation 
workflow), scene setup, digital layout, or production organization.

Using the Workspace

The person creating the exposure sheet will need only the Xsheet view to create the digital exposure 
sheet, although the Timeline view may also be helpful. If you are doing paperless animation, use the 
Camera or Drawing view if you want to sketch at the same time.

If you work with this layout often, you can use the Workspace Manager to save it as a 
workspace,and name it Xsheet, for example.

While drawing and animating paperless animation, you can use the Workspace Manager to save a 
frequently used layout and name it Paperless Animation, for example.
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Preparing References

To start an exposure sheet, you need to prepare your references. For traditional animation, you will 
need to reproduce the animator's paper exposure sheet. If you are working remotely, the studio can 
scan the paper exposure sheet using third-party software and send the digital files to be opened and 
viewed digitally. 

In paperless animation, you will usually create an exposure sheet from the Xsheet view.The 
information from your layout and posing or storyboard will help you approximate how many 
elements are required in the scene.
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Frames

Once the references are ready, you need to set the scene length by adding the right number of frames 
to your scene. You can set the global scene length from the top menu.

In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

How to extend a scene in the Timeline view

1. In the Timeline view, drag the scene length bracket to the right to add more frames to your scene.

How to add frames before or after a selection to the extend scene length in the 
Xsheet view

You can add frames anywhere in the middle of the scene. If you select a frame row in the Xsheet view, 
Harmony will add the new frames before or after the selection, depending on your choice.

1. In the Xsheet view, select a frame row.

2. Do one of the following:

‣ From the top menu, select Scene >Frame > Add Frames Before Selection or Add 
Frames After Selection. 

‣ In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add 
Frames After Selection.
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‣ In the Xsheet view toolbar, click the Add Frames  button to add frame after your 
selection.

‣ Press Ctrl + G and Ctrl + H (Windows/Linux) or ⌘  + G and  Ctrl + H (Mac OS X).

The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the number of frames needed in the scene.

How to add frames at the start or end to extend the scene length from the top menu

1. From the top menu, select Scene > Frame > Add Frames At Start or Add Frames At End.

‣ In the Xsheet view toolbar, press the Add Frames  button to add frame after your 
selection.

The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames needed in the scene.

How to reduce the scene length in the Timeline view

When you remove frames at the end of a scene to reduce the scene length in the Timeline view, the 
exposed drawings and symbols are not deleted. They are still available if you extend the scene 
afterwards.

1. In the Timeline view, drag the scene length bracket to the left to remove frames from the scene.

How to remove a frame or a range of frames to reduce the scene length in the 
Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

1. In the Xsheet view, do one of the following:

‣ Select a frame in a given column.

‣ Select a frame range by clicking the first frame’s number and then dragging the selection 
highlight down to the last frame to delete.
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2. To delete the selected frames, do one of the following: 

‣ From the top menu, select Scene > Frame > Remove Selected Frames. 

‣ Press Delete to delete the selection. 

‣ Click Remove Frames  button. To remove several frame selections, click the button 
repeatedly.

If you selected a range of frames, the Warning dialog box may open.

3. To complete the operation:

‣ Click Yes to delete the selection.

‣ Click No to delete only the exposure in the cell and not the frames.

‣ Select the Don’t Show This Message Again option to prevent the warning message from 
being displayed each time you delete a frame range.
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Creating Drawing Elements

Before filling any value or setting any timing or exposure, you need to add different drawing elements.

Each drawing element is represented as a vertical element column in the Xsheet view and a horizontal 
element layer in the Timeline view.

In Harmony, whether you work in the Timeline or Xsheet view,  any modification you do to one view will 
be applied to both. You can also see your layers displayed in the Network view as modules.

To start an exposure sheet, you will use drawing elements. Drawing elements are drawing containers. 
Any image file, either bitmap or vector, will use a drawing element. 

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is 
named the same way as the drawing element. Its purpose is to contain all the drawings related to this 
element. For example, in cut-out animation, a character can have many heads available. All of the head 
drawings will be contained in this folder, even if they are not exposed in the Timeline or the Xsheet 
view. There is always a drawing container connected to a drawing element (layer, column).

There are different element types available such as  Sound and Expression. A sound element will contain 
sound files. Expressions, Beziers, Eases, 3D Path, Quadmaps and Pegs are for motion purposes during the 
compositing step. It is not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu.

This section is divided as follows:

• Layer and Column Concepts below

• Layer and Column Types on the facing page

• Adding New Drawing Elements on page 46

• Deleting Layers and Columns on page 50

• Layer and Column Properties on page 52

• Modifying Layers and Columns on page 53

• Duplicating Layers and Columns on page 56

• Cloning Layers and Columns on page 56

• Adding an Annotation Column on page 57

Layer and Column Concepts
A layer is linked to a directory, the location where all its drawings are saved. This directory has the 
same name as the layer. When a name is typed in a cell,Harmony searches the layer's directory for the 
corresponding drawing to display. If there is no corresponding drawing, a new one is created.

Drawings are exposed in cells, and linked to the drawings saved in the layer's directory. Removing a 
drawing from a cell means it is not displayed. It will not be deleted from the directory.

A drawing that is exposed multiple times (for example, in a walk cycle) would be linked to the same 
original drawing in the layer's directory. If you modify, repaint, or correct the drawing, all exposed 
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drawings with the same name are updated simultaneously. You must duplicate or create a new 
drawing to modify a single exposure and retain the others.

When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that 
when you modify, repaint, or correct a drawing named “1,” all drawings named “1” are updated simultaneously. 
In order to modify a drawing independently from its other exposures, you must duplicate the drawing.

Layer and Column Types
A column is also known as a layer. There are several types of layers that you can add in the Xsheet and 
Timeline view. Each layer is tagged with an icon to help differentiate them. Some layers are 
represented differently in the Xsheet view. 

Drawing Layer

The most common layer type is the drawing layer. Any time you need to create a vector drawing or 
import a symbol or image, you can use a drawing layer. You can also create bitmap artwork on a 
drawing layer.

Bitmap images are contained in Bitmap layers.

Bitmap Layer
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If you import a picture or bitmap images in your project, they are inserted in a Bitmap layer. If you 
choose to vectorize your image when you import, the bitmap object will be placed on a Drawing 
layer. This way, you can have bitmap images mixed with vector drawings on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you 
place a non-vectorized bitmap into a symbol, you will still not be able to mix vector drawings with it 
on the same layer. If you place a vectorized bitmap in a symbol, you must enter the symbol to be able 
to mix it with vector artwork. 

Camera Layer

You can only have one Camera layer at a time in your timeline. By default, there is no Camera layer 
when you create a scene. You need to add a Camera layer when you want to create a camera 
motion.

The Camera layer is not visible in the Xsheet view.

If you want to have several cameras with different settings, you can keep adding Camera layers in your 
Timeline view (however, only one will ever be visible at a time as you can only have one camera at a time 
in your timeline). To switch to a different camera, select Scene > Camera and select another camera layer.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them. In 
Harmony, there is a series of effect modules in the Module Library view.

When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in 
the Functions section of the  Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene 
has no background colour and if you render it as a QuickTime movie or image sequence, it will have a 
black background.

This layer is not visible in the Xsheet view.

Group Layer
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A Group layer can be used to organize both the Timeline and Network views. You can drag and drop 
other layers onto a Group layer and then collapse the Group layer to hide these other layers from 
view. 

If you create the Group layer in the Timeline view, a corresponding module will appear in the 
Network view. Any layers that you connect to the Group layer will appear in the Group module 
connected to an Input and Output port.

Peg Layer

A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to 
any drawing layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in 
the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the  
Functions section of the Xsheet view.

Quadmap Layer

A Quadmap layer can be described as a deformation transformation layer that does not contain 
drawings. This can be attached to any drawing layer, cut-out puppet, or even other peg layers. They 
will all follow the deformation you set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are 
displayed in the Functions section of the Xsheet view.

Sound Layer
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You can import sound files to add dialog and sound effects to your project. The sound layer will be 
added to your Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types
In the Xsheet view, you can add several advanced column types to create particular animation paths. 
When you create these columns, they are not linked automatically to any particular drawing layer. You 
can create a motion path using these columns and then link or unlink several drawing or peg layers to 
it.

Advanced column types include:

• Timing

• 3D Path

• 3D Rotation

• Bezier Curve

• Ease Curve

• Expression

• Annotation

Adding New Drawing Elements
There are different ways to add a drawing layer to your project. By default, when you create a new 
scene there is one Drawing column in the Xsheet view and one corresponding Drawing layer in the 
Timeline view.

You can add an element for each drawing and it will appear as a column in the Xsheet view,  a layer in 
the Timeline view, and a module in the Network view.

How to add a drawing element from the Timeline view

1. Do one of the following:

‣ In the Timeline View menu, select Insert > Drawing. 

‣ In the Timeline view toolbar, click the Add Layers  button. 

‣

‣ Press Ctrl + R (Windows/Linux) or ⌘  + R (Mac OS X).

The Add Drawing Layer dialog box opens.
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2. In the Name field, enter a relevant element name.

3. Do one of the following:

‣ Click OK to add the layer and close the dialog box.

‣ Click Apply to add the layer and keep the dialog box open to add another layer.

‣ Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Network Views.

How to add multiple drawing elements from the Timeline view

1. In the Timeline View menu, select Insert > Add Layer(s).

The Add Layers dialog box opens.

2. In the Type menu, select the Drawing option.

3. In the Number field, enter the number of layers you want to add.

4. In the Name field, type the name of the layer you want to add. If you are adding more than one 
layer, a numerical suffix will be added to subsequent layers.

5. Do one of the following:

‣ Click OK to add the layers and close the dialog box.

‣ Click Apply to add the layers and keep the dialog box open to add another layer.

‣ Click Close to cancel the operation.

The new drawing elements appear in the Timeline, Xsheet and Network views.

How to add a drawing element from the top menu

1. From the top menu, select Insert > Drawing.

The Add Drawing Layer dialog box opens.

2. In the Name field, type a relevant element name.

47



Chapter 3: Timing     Creating Drawing Elements

3. Click  OK.

The new drawing element appears in the Timeline, Xsheet and Network views.

How to add a drawing element from the Xsheet view

1. Do one of the following:

‣ In the Xsheet view menu, select Columns > Add Columns. 

‣ Click the Add Columns button. 

‣ Press Shift + C.

The Add Column dialog box opens.

2. In the Name field, type a relevant element name.

3. In the Type field, select Drawing. 

4. To complete the operation:

‣ Click OK to add your new layers and close the dialog box.

‣ Click Apply to add your new layers and keep the dialog box open to add column.

‣ Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Network Views—see Layer and 
Column Types on page 43.

How to create a column in Harmony using the advanced Add Column dialog box

You can use the advanced Add Column dialog box to make more file format and field size options 
available when you insert the column.
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1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS 
X) and select the Advanced tab.

2. In the Advanced Options section, select the Advanced Element Mode option to access the 
advanced Add Column dialog box.

3. Click OK.

4. In the Xsheet View menu, select Columns > Add Column or press Shift + C.

The Add Column dialog box opens.

5. In the Name field, type the new column’s name.

6. In the Type drop-down menu, select the Drawing type.

7. In the Element section, select one of the following:

‣ Create New Element: Create an independent column with its own drawing folder.

‣ Reuse Existing Folder: Link your column to an existing folder within the Element folder of 
your scene. If you select this option, in the Folder drop-down field, select the folder to which 
you want to link your new column.

‣ Use Existing Element:Use drawings from an existing column in the new column. Both 
columns will be attached to the same set of drawings, but their timing will remain  
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independent  from one another. If you modify one of the drawings, it will be modified in both 
columns. This is the same principle as the Clone column.

If you selected the Use Existing Element option, in the Name drop-down field, select the 
column to which you want to link your new column.

8. If you selected the Create New Element option:

‣ Deselect the Vector option if you want your layer to contain bitmap images or enable it if 
you want the layer to contain vector drawings. Most of the time, the Vector option will be 
enabled.

‣ If you deselected the Vector option, from the Bitmap Format  list, select which type of 
bitmap image you want to insert in the column. Select the SCAN type if you are planning to 
scan drawings using the Toon Boom Harmony Scan module.

‣ If you deselected the Vector option and you chose the SCAN type, from the Scan Type 
menu, select what kind of scanning you want to achieve.

‣ In the Field Chart field, when importing traditional animation, indicate the size of paper on 
which the animation or background was drawn. If you are not using perforated animation 
paper, leave the 12 field default value as is.

9. Do one of the following: 

‣ Click OK button to create the new column and close the dialog box. 

‣ Click Apply to create the new column but keep the dialog box opened to create other new 
columns.

Deleting Layers and Columns
You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

1. In the Timeline view, select the layers to be deleted.

2. Do one of the following:

‣ In the Timeline’s Layer toolbar, click the Delete Layers  button. 

‣ Right-click on the selection and select Delete.

The  Confirm Delete dialog box opens.
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‣ Select the Delete Drawing Files and Element Folders option to delete all drawings and 
folder linked to this layer.

3. Select the Delete Xsheet Columns option if you also want to delete the existing column in the 
Xsheet view.

How to delete columns in the Xsheet view

1. In the Xsheet view, select the columns to be deleted by clicking on their header.

2. Do one of the following

‣ Right-click on the selection and select Delete Columns. 

‣ In the Xsheet View toolbar, click the Delete Columns  button.

‣ Press Delete.

The Confirm Delete dialog box opens.

‣ Select the Delete Drawing Files and Element Folder option if you want to delete the 
drawings and folders linked to the selected column.

3. To complete the operation:

‣ Click OK to delete the selected layers.

‣ Click Cancel to cancel the operation.

The Warning dialog box may open.

4. Do one of the following:

‣ Click Yes to delete all the frames from your scene.

‣ Click No to keep the frames in your scene.

‣ Select the Don’t Show This Message Again option if you do not want the dialog box to 
display again in the future.
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Layer and Column Properties
Each element has its own set of properties that can be modified, including effect and peg layers.

If you want to modify some of the element’s properties, display the Layer Properties or Column 
Properties editor. You can display the Layer Properties editor from the Timeline or Network view as a 
dialog box or open the Layer Properties as a view of its own.

The Layer Properties editor allows you to:

• Rename the layer

• Enable or disable the layer

• Lock the layer

• Change the track colour

• Activate the onion skin preview

• Adjust the positioning and animation parameters

• Adjust many other advanced parameters

The Column Properties editor allows you to:
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• Rename the layer

• Enable or disable the layer

• Adjust parameters for bitmap format, scan type and field chart

How to display the Column Properties editor from the Xsheet view

1. Do one of the following:

‣ In the Xsheet view, double-click on a column’s header.

‣ In the Xsheet view, right-click on a column's header and select Column Editor.

‣ Press Shift + E.

How to display the Layer Properties editor 

1. Do one of the following:

‣ In the top menu, select Windows > Layer Properties.

‣ In the Timeline view, double-click on a layer.

‣ Press Shift + E.

‣ In the Network view, click on the module’s yellow properties button.

2. In the Timeline or Xsheet view, select the layer whose properties you want to view.

The Xsheet column will not open the Layer Properties editor, but it will show the column properties 
allowing you to modify settings related to the Xsheet column.

Modifying Layers and Columns
Once you add layers and columns to your project, you can modify their properties, names, or 
ordering.

You can change the order of your elements in the Timeline view and Xsheet view. When you change the 
order of your elements in one view, the other one is updated.

The Element Manager lets you add, delete or modify elements (drawing folders) in your scene. If you 
have drawing folders that are not linked to a column in your scene, use the Element Manager to delete 
them if needed.
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How to rename a layer in the Timeline view

1. In the Timeline view, double-click on the name of the layer to rename.

2. In the Name field, rename the layer and press Enter/Return.

How to rename a layer in the Layer Properties editor

1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

2. In the Name field, rename the layer.

3. Click Close.

How to rename a column

1. In the Xsheet view, double-click on a column name. Do not click on the drawing folder name that 
the column is linked to (this also appears in the column header just below the column name).

The Drawing dialog box opens.

2. In the Name field, rename the column.

3. Click OK.

How to reorder layers in the Timeline view

1. In the Timeline view, select the layers to move.

2. Drag the selection to the new location.

3. Do one of the following:

‣ Drop the selection on an existing layer to make it a child of another element layer.

‣ Drop it between the existing layers. Timeline layers that are located above the selection are 
displayed in front it. Layers located under it in the Timeline View are displayed behind it.
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How to reorder columns in the Xsheet view

1. In the Xsheet view, click on the column’s header with the middle mouse button.

2. Drag the column to its new position.

How to use the Element Manager dialog box

‣ From the top menu, select Scene > Element Manager.

Interface Element Action

Elements Displays a list of the elements 
contained in your scene.

Delete Elements Deletes the selected elements.

Delete Elements and Directories Deletes  the selected layer, as well as 
its directories (drawing folder).

Add/Modify Element Use this area to add or modify an element.

Name Type a new name in this field to create 
an element or to rename the selected 
element.

Vector Check this box if the new element is a vector 
drawing or if you want to enable the para-
meters on the selected element in the Ele-
ments list.
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Interface Element Action

Bitmap Format Select the file format of the bitmap layer 
from the drop-down list

Scan Type If you are planning to scan elements with the 
Toon Boom Harmony Scan module, select 
the scan type from the drop-down list.

Field Chart If you are importing traditional animation, 
select the size of the paper on which the 
animation was drawn.

Add Creates a new element with the current para-
meters entered in the Add/Modify Element 
section.

Modify  Applies the parameter changes made to the 
selected element.

Duplicating Layers and Columns
Duplicating an element provides you with a copy of the drawings and their exposure. You can modify 
anything you want in the duplicated element without affecting the original one. In the Network view, 
you can duplicate the selected modules in the same way.

How to duplicate an element

1. In the Timeline or Xsheet view, click the layer you want to duplicate.

2. From the top menu, select Edit > Duplicate.

3. In the Xsheet view or Timeline view toolbar, click the Duplicate Drawing  button.

The new duplicated layer or column appears.

Cloning Layers and Columns
Cloning a layer or column provides you with a copy of the selected element that uses the same 
drawings as the original. For example, if you modify a drawing in the cloned or original column, it is 
updated in both columns. 

You can choose whether or not to copy the column timing to the cloned columns. 

• You can modify the column timing independently from each other, but the drawings remain 
linked.

• You can copy the columns timing, so drawings and timings remain linked.

You can clone selected modules from the Network view in the same way.

This feature is useful when you want to reuse a hand-drawn animation but have different timings.
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How to clone an element

1. In the Timeline or Xsheet view, select the layer or column you want to clone.

2. Do one of the following:

‣ From the top menu, select Edit > Clone.

‣ In the Xsheet View toolbar, click the  Clone Selected Columns: Drawings Only  button.

‣ From the top menu, select Edit > Clone to clone the columns' drawings only.

‣ From the Timeline View menu, select Layers > Clone Selected Layers: Drawings Only or  
Layers > Clone Selected Layers: Drawings Only.

‣ In the Xsheet View or Timeline View toolbar, click the  Clone Selected Layers/Columns: 
Drawings Only  button.

The new cloned layer or column appears.

Adding an Annotation Column
The Annotation columns are useful for marking actions, corrections or other information related to 
your animation that you want to draw or write. This way, you can print your Xsheet, take it back to 
your animation table and work with the annotations.

How to add an annotation column

1. Do one of the following: 

‣ In the Xsheet View menu, select Columns > Add Columns. 

‣ In the Xsheet View toolbar, click the Add Columns  button. 

‣ Press Shift + C.

The Add Column dialog box opens.

2. In the Name field, type in an appropriate name.

3. From the Type list, select Annotation and click OK.

The new column appears.
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Drawing and Typing in the Annotation Column

In the annotation column, you can type in your notes and relevant information, as well as draw 
sketches and ideas that will be useful in producing your animation.

How to draw in the Annotation column

Before you can draw in the Annotation column, you must first activate the Enable Drawing option to 
activate the Drawing mode.

Pen tablet pressure sensitivity is not supported in the Annotation column.

1. Do one of the following:

‣ In the Xsheet View menu, select Annotation > Enable Drawing.

‣ In the Annotation column header, click to cycle through the icons, until the Brush  icon is 
displayed.

The Drawing mode is enabled.

2. To draw in an Annotation column, simply use your mouse or pen tablet.

 

How to type in an Annotation column

Typing in an Annotation column is independent from the Drawing mode. You can be in either mode 
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and the typing will work.

1. Do one of the following:

‣ In the selected cell, press Ctrl (Windows/Linux) or ⌘  (Mac OS X).

‣ In the selected cell, hold down Ctrl + Shift + click (Windows/Linux) or ⌘  + Shift + click (Mac 
OS X)..

2. In the selected cell, type the desired text.

To learn about typing values in the Xsheet view, refer to Typing Exposure on page 66.

How to erase part of a drawn annotation using Erasing mode

You can erase part or all of the Annotation column’s text and drawn annotations.

Annotations that you type in cannot be erased using this method.

1. In the Annotation column header, click to cycle through the icons until the Eraser  icon is 
displayed.

2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.
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When using a pen on a tablet, you MUST flip your pen to the eraser side for the eraser to work.

How to erase an Annotation column selection

1. In the Annotation column header, click to cycle through the icons until the Select  icon is 
displayed.

2. In the Xsheet view, select the cell range you want to clear of text or drawn annotations. A selection 
is indicated by four pairs of dots on the left side of a cell. Do not select any cells if you plan to clear 
everything.

3. In the Xsheet view, right-click in the Annotation column.

4. Do one of the following:

‣ Select Annotation > Erase All to erase the entire content of the column.

‣ Select Annotation > Erase Selected Images to erase the images contained in the selected 
cell range. 

‣ Select Annotation > Erase Selected Texts to erase the text contained in the selected cell 
range.

Changing the Drawing Settings
You can change the pen size and colour when you draw in the Annotation column.

How to change the pen width

1. Right click on a frame within an annotation column or in the Xsheet View menu, select Annotation 
> Pen Width.  

2. Do one of the following:

‣ Select a pen width preset.

‣ Select  Change Current. 

If you selected the Change Current option, the Pen Width dialog box opens.

60



Harmony 11.1 Traditional Animation Guide (Standalone)

3. In the Pen Width field, type the number of pixels you want the pen size to be.

4. Click OK.

How to change the pen colour

1. In the Xsheet View menu, select Annotation > Change Pen Colour.

The Select Colour dialog box opens.

2. Choose the new colour.

3. Click OK.

Displaying Tick Marks
When working with the Annotation columns, it is useful to display tick marks on odd-numbered 
frames.

To display the tick marks, you must run a short script.

How to display tick marks

1. From the top menu, select Windows > Script Editor.
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2. From the Script Editor menu, select File > New Script.

3. Type in a name for your script and click OK.

4. In the File list, select the script you created. 

5. On the right side of the view, type the following script:

function display_tick_marks()

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", true);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", 
false));

}

6. Click Verify.

The script is verified. 

7. From the File menu, select Play/Debug > Run.

A dialog box opens with your script selected in the Files column.

8. In the Functions column, select display_tick_marks and click OK.

Tick marks appear on odd frames in the Annotation column.

If you do not see tick marks, close and restart Harmony.

How to turn off the display of tick marks

1. Follow steps 1 to 5 of How to display tick marks and use the following script:

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", false);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", 
false));

}

2. Follow steps 6 to 8. 

All tick marks are removed from the Annotation column.

Importing an Annotation File
If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or 
drawings in the annotation columns, you can easily import them.

How to import annotation files

1. In the Xsheet view, select the first cell in the annotation column where you want the imported 
image to start.
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2. Right click on the frame or from the Xsheet view menu, select Annotation > Import File. 

3. Browse for the bitmap image to import.

4. Click Open.

The image appears in the annotation column.

Linking External Files with Timing Columns
Timing columns are unique in that they can reference a source folder outside of the project folder to 
bring images into the project. For example, you may have background scenes created in a third party 
software that you might need to update in the future; by using Timing columns, you can dynamically 
link your backgrounds, expose different backgrounds at different times, and have live, automatic 
updating capabilities.

If the project file is moved, or the folder that the column is linked to is moved, then dynamic linking is 
broken and the images that were in that folder will disappear in Toon Boom Harmony.

How to use a Timing column

1. In the Xsheet view, click on the Add Columns  button.

2. In the Add Column dialog box, type in the name of the new column, then from the Type menu, 
select Timing.

3. Do one of the following:

‣ Click OK if you are finished.

‣ Click Apply if you want to continue adding more columns and column types.

A peach coloured column appears in the Xsheet with the name you typed in, and for the header, 
<unused>.
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4. In the Network view, add a new element module.

5. Open the Layer Properties editor by clicking on the yellow square of the module.

6. In the Drawing tab, select the Timing Columns option.

7. In the Name field, enter the path of the folder you want to access. If you use the Browse button to 
locate a folder, you must select a file in the folder you want and then delete the dash and the suffix 
(for example, background-01 should be renamed to background) from the file name in the 
field. If you leave the full file name selected, Harmony will display that file for the entire duration of 
the scene, regardless of the contents of the Timing Column field.

This means that all the images in the folder that you are linking to are named using the naming convention 
described above. If for some reason you are unable to access a certain directory, type the directory 
extension directly in the path extension field at the top of the browser window.

8. In the Timing Column field, click the Arrow button to create a new timing column, or select the 
name of the column from the  list. If you have an element directory selected in the Name field, the 
Timing Column will indicate which files are called from that element directory. Remember that the 
file displayed at each frame is based on the element name, cell label, and extension. If the element 
is toto, the timing column is labeled 1, 2, and 3, and the extension is TVG, Harmony will display 
drawings totobody-1.tvg, totobody-2.tvg, and totobody-3.tvg at the selected frames. 

In the Xsheet, the <unused> header  changes to the name of the module in the Network view.

9. From the Extension  list, select the file format of the files you want to display.

10. Click OK.

11. In the Xsheet view, in the Timing column, type the number that corresponds to the suffix of the 
drawing file that you want to expose to make it appear in the Camera view.
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Filling Exposure

Harmony provides different tools to fill in exposures and values, create cycles, and set increments.

This section is divided as follows:

• Filling Exposure Mode below

• Typing Exposure on the next page

• Holding Exposure on page 68

• Extending a Single Exposure on page 69

• Extending an Exposure Sequence on page 70

• Dragging Cells on page 70

• Increasing and Decreasing Exposure on page 73

• Inserting Blank Cells on page 76

• Deleting Exposure on page 75

• Setting the Exposure on page 77

• Filling a Selection with a Single Exposure on page 78

• Filling a Selection with a Sequence on page 79

• Filling a Selection Randomly on page 81

• Filling Empty Cells on page 82

• Creating Cycles on page 83

• Managing Drawings on page 87

• Renaming a Drawing on page 87

• Deleting a Drawing on page 88

• Duplicating a Drawing on page 89

• Copying and Pasting Drawings on page 89

• Merging Drawings on page 92

Filling Exposure Mode
In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These 
modes control the filling behaviour. The Timeline view only uses the Overwrite mode.

How to toggle between Overwrite and Insert modes

1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click the Overwrite/Insert button.

‣ Press I.
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Overwrite Mode

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence 
overwrites existing ones. The existing timing sequence remains in the same place and is not pushed 
down the column.

Insert Mode

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value 
sequence over existing ones, the new values are inserted between the old ones. The existing timing 
sequence is pushed down the column.

Typing Exposure
To fill in your exposure, you can directly type the values in the Xsheet view and Timeline view.

How type a value in the Timeline view

If you want to type an exact drawing name or value into the Timeline view, you must use the Data 
view section of the Timeline.

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).
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1. In the Timeline view, click the Show Data View  button.

 

2. In the Drawing Substitution field, type the name of the drawing you want to create, and press 
Enter/Return.

How to type values in the Xsheet view

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

1. In an Xsheet column, double-click on one cell.

2. Type a value or drawing name in the cell.

3. Press Enter/Return to move to the next cell.

4. Press Esc to exit the typing mode and return to normal mode.

67



Chapter 3: Timing     Filling Exposure

Holding Exposure
Drawings in an animation project are not always exposed on a single frame; they are often exposed 
for more than one frame. The most common exposure of a drawing is two frames. In the industry, this 
type of exposure is known as animation in double frames or animation on twos. A drawing can also be 
exposed for three, four, five cells and so on. To prevent mistakes and save time, the Xsheet lets you 
hold your cells automatically as you type.

The  Set Exposure option allows you to choose how many frames you want to hold for your exposure.

• This option is only available in the Xsheet view.

• The selected Set Exposure settings will be kept from session to session. You will not 
have to set them every time you use Toon Boom Harmony.

How to hold exposure

1. In the Xsheet View menu, select Exposure > Hold Exposure > Hold 2 Cells.

2. In the Xsheet view, right-click and select Exposure > Set Exposure To > Set Exposure to 1, 2,3, 
or Set Exposure.

3. Type a value or drawing name in the cell.

‣ Press Enter/Return to move on to the next cell.

‣ Press Esc to quit the typing mode.

‣ If you selected Set Exposure, the Set Exposure dialog box opens. You can hold as many 
cells as needed.
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Extending a Single Exposure
Extending the exposure lets you select an Xsheet cell that contains a value and pull it down to the 
desired frame. 

How to extend a cell exposure gesturally

1. In the Xsheet view, select the red arrow  in the cell’s right side. Make sure you see the drag down 
 cursor.

2. Pull down the selected cell to the desired frame. 

The red selection box must be visible when releasing the mouse button. If not, the action is considered 
cancelled.

How to extend a sequence from the top menu

1. Do one of the following:

‣ In the top menu, select Animation > Cell > Extend Exposure.

‣ Press F5.

The Extend Exposure dialog box opens.

2. Enter the frame number you want to extend the cell to.
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Extending an Exposure Sequence
When working with a sequence that contains only numbers, you can extend an exposure sequence in a 
similar manner to extending a single exposure.

How to extend an exposure to create a sequence

1. In the Xsheet view, select a cell containing a number.

2. In the selected cell, click the red arrow  on the cell’s right side. Make sure to see the drag down  
cursor.

3. Hold down the Shift key. Make sure a plus (+) sign appears.

4. Pull down the selection box to the desired frame.

The red selection box must be visible when releasing the mouse button. If not, the action is considered 
cancelled.

5. First release the Shift key, then release the mouse button.

Dragging Cells
To readjust your timing, you can drag one or several cells to a new location. You can drag a cell to any 
other frame in the same column or into another column.

How to drag a cell to another location in the Timeline view

1. In the Timeline view, select one or several cells to move.
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2. Click on the cells selection and drag it to the new location.

3. Drop the selection. Do one of the following:

‣ Drop by simply releasing the mouse or pen to overwrite the existing cells.

‣ Hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the cells. 
The original cells will not be moved.

‣ Press Shift while dropping to insert the selection between the existing frames.

How to drag a cell to another location in the Xsheet view

1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, select the small dotted area  on the left side of the selected cells.
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3. Drag the selection to any other cell in the same column or in another column.

4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.

‣ Hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the 
cells. The original selection will not be moved.

‣ Press Shift while dropping the selection to insert it between the existing frames.
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You can turn off the Gestural Drag Mode for the Xsheet view to prevent drawings from being 
dragged from one location to another. 

How to turn off the Gestural Drag mode

1. Do one of the following:

‣ In the Xsheet view, right-click and deselect the Gestural Drag Mode option. 

‣ Click the Toggle Gestural Drag Mode button (you may have to customize the  toolbar to display 
it).

 

The dragging pad disappears when the Gestural Drag mode is off.

This feature does not apply to Annotation columns.

Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

How to increase exposure

Increasing the exposure adds one more exposure to a selected cell; repeating this action adds an 
extra cell each time. This is an efficient way of extending a drawing exposure and is always set in 
Insert mode. Increasing an exposure pushes the existing exposure ahead.

1. In the Timeline or Xsheet view, select a cell.
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2. Do one of the following: 

‣ In the top menu, select Animation > Cell > Increase Exposure. 

‣ Right-click on the selected cell and select Exposure > Increase Exposure. 

‣ Press +.

‣ In the Xsheet  or Timeline View toolbar, click the Increase Exposure  button.

How to decrease exposure

1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following: 

‣ In the top menu, select Animation > Cell > Decrease Exposure. 

‣ Right-click on the selected cell and select Exposure > Decrease Exposure. 

‣ In the Xsheet  or Timeline View toolbar, click the Increase Exposure  button.

‣ Press -.

How to increase and decrease exposure using the Increase/Decrease Exposure field

You can use this option in the Xsheet view to increase or decrease the exposure of a selected drawing.

1. In the Xsheet view, select the cell to modify.
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2. Do one of the following:

‣ In the Xsheet's bottom right-corner, enter the number of cells over which the drawing will be 
exposed.

‣ In the Xsheet’s bottom-right corner, increase or decrease the drawing’s exposure by 
clicking the up or down arrows. 

‣ Press + to increase exposure.

‣ Press - to decrease exposure.

How to use the Clear Exposure and Pull feature

You can use this option to reduce a drawing’s exposure.

1. In the Timeline or Xsheet view, select or range of cells.

2. Do one of the following: 

‣ From the top menu, select Animation > Cell > Clear Exposure and Pull. 

‣ Right-click on the selected cell and select Exposure > Clear Exposure and Pull.

‣ In the Xsheet  or Timeline View toolbar, click the Clear Exposure and Pull  button.

3. The exposure is reduced by the selected number of cells.

Deleting Exposure
You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the 
Timeline or Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by 
typing its name again in a cell.
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You can delete the exposure contained in a selected cell range  or delete the entire exposure of a 
drawing exposed over several cells . Note that you can also delete the exposure for drawings 
contained inside a collapsed group.

How to delete selected exposures

1. In the Timeline or Xsheet view, select the exposure you want to delete.

2. Do one of the following:

‣ Right-click and select Delete.

‣ Press Delete.

How to clear the entire exposure of a drawing

1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

2. Do one of the following: 

‣ In the top menu, select Animation > Cell > Clear Exposure.

‣ In the Timeline view, right-click on the selection and select Exposure > Clear Exposure.

‣ In the Xsheet View toolbar, click the Clear Exposure  button (you may have to customize 
the toolbar to display it).

Inserting Blank Cells
You can place an empty cell between other cells. This is always done in Insert mode and pushes down 
existing exposure, even if you are set to Overwrite mode.

How to insert blank cells

1. In the Xsheet  or Timeline view, select the cell in which you want to insert a blank cell.

2. Do one of the following: 

‣ In the top menu, select Animation > Cell > Insert Blank Cell. 

‣ Right-click on the selected cell and select Exposure > Insert Blank Cell.

‣ In the Xsheet  or Timeline view toolbar, click the Insert Blank Cell  button (you may have 
to customize the toolbar to display it).

‣ Press Shift + J.

The blank cell is inserted.
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How to clear a selected cell range without changing the exposure and timing

1. In the Xsheet view, select the frame range to clear.

2. Right-click on the selected cells and select Clear.

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the Set Exposure 
options.

How to set the exposure

1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.
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2. Do one of the following:

‣ From the top menu, Animation > Cell > Set Exposure to > Set Exposure to 1, 2, or 3, or 
Set Exposure.

‣ In the Xsheet view, right click and select Exposure > Set Exposure to > Set Exposure to 1, 
2, or 3, or Set Exposure.

‣ In the Timeline View toolbar, click one of the Set Exposure  buttons (you may 
have to customize the toolbar to display them).

3. In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 1, 2, or 
3, or Set Exposure.

If you chose the Set Exposure option, the Set Exposure dialog box opens.

4. Type the number of frames you want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.

Filling a Selection with a Single Exposure
The Fill Selection option lets you fill the same value over an entire selection. The selection can be over 
one cell, a cell range in one column, a cell range over many columns, an entire column, or many 
columns. You can use numbers, words, letters, or any alphanumeric value.
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How to fill a selection with a single exposure

1. In the Xsheet  or Timeline view, select a cell range.

2. Do one of the following: 

‣ In the top menu, select Animation > Cell >Fill Selection. 

‣ Click the Fill Selection  button in the Xsheet or Timeline view toolbar (you may have to 
customize the toolbar to display it).

‣ Press Ctrl + T (Windows/Linux) or ⌘  + T (Mac OS X)).

The Fill Selection dialog box opens.

3. In the Value field, type the desired value.

4. To insert a keyframe in the frame following the last cell in the selection, select the Add Key 
Exposure After option. Otherwise, leave it deselected.

5. Click OK.

Filling a Selection with a Sequence
You can create a numbered sequence over a selection. The sequence can be forward, backward, 
single, double or higher increment, as a cycle, and so on. The sequence can be over one cell, a cell 
range in one or more columns, or one or more columns.

How to fill a selection with a sequence

1. In the Xsheet or the Timeline view, select a cell range.
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2. Do one of the following:

‣ From the top menu, select Animation > Cell >Sequence Fill. 

‣ In the Timeline view, right-click and select Exposure > Sequence Fill.

‣ In the Xsheet View toolbar, click the Sequence Fill  button (you may have to customize 
the toolbar to display it).

‣ Press Ctrl + M (Windows/Linux) or ⌘  + M (Mac OS X).

The Sequence Fill dialog box opens.

3. In the Starting Value field, type the first number in the sequence.

4. In the Increment field, type the number by which the drawing number will increase from frame to 
frame. For example, an increment of 1 is used in this sequence:1-2-3-4; this sequence increments 
by 2: 1-3-5-7; and this one, by -2: 8-6-4-2.

5. In the Hold field, select an exposure holding value.

6. Select the Cycle option if you want a cycle; enter the number of cells for this cycle’s duration.

If you choose a two-cell hold, a cycle of three drawings will last for six cells.

7. If you selected a larger range than the amount of frames needed, select the End Frame option and 
type the last frame needed.
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8. If you want to have more than one digit in your numbers such as “001” instead of “1”, select the 
Padding option and add as many pound signs (#) as digits needed. In the field, you can type a 
letter or word to add before the drawing number.

9. To insert a keyframe in the frame following the last cell in the selection, select the Add Key 
Exposure After option. Otherwise, leave it deselected.

10. Click OK.

Filling a Selection Randomly
You can fill in random values over a selection. You can give a maximum and a minimum value and 
create a range for the system to choose the random values from. The selection can be over one cell, 
a cell range in one column or more, or an entire column or many entire columns.

How to fill cells randomly

1. In the Xsheet view, select a cell range.

2. Do one of the following:

‣ Select Animation > Cell > Fill Cells Randomly.

‣ In the Xsheet view, click the Fill Cells Randomly  button  (you may have to customize the 
toolbar to display it).

The Fill Cells Randomly dialog box opens.
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3. In the Minimum Value field, enter the lowest acceptable value.

4. In the Maximum Value field, enter the highest acceptable value.

5. In the Hold field, choose an exposure holding value.

6. If you are applying this option to a drawing column, enable the Whole Numbers option to avoid 
decimal points.

7. Click OK.

Filling Empty Cells
The Filling Empty Cells feature is used to extend the exposure of single frame drawings to fill the 
range of empty cells after each one.

When creating drawings on  cells that are not side-by-side, the exposure of the first drawing no longer 
fills automatically. You need to select the frame range where you want your drawings to hold their 
exposure up to the next drawing and use the Fill Empty Cells command.

How to fill empty cells

1. In the Xsheet view or Timeline view, select a cell range.
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2. Do one of the following:

‣ From the top menu, select Animation > Cell > Fill Empty Cells.

‣ In the Timeline View toolbar, click on the Fill Empty Cells  button.

Each drawing in the selection is exposed in the range of empty cells that follow it.

Creating Cycles
Once you have entered a series of drawings and exposures, you can create cycles out of them in 
several ways.

You can loop your drawings using the following commands:

• Paste Cycle

• Paste Reverse

• Create Cycle

When you create a drawing cycle, all of the repeated drawings are linked to the same original files. 
This means that when you modify, repaint, or correct a drawing named “1,” all drawings named “1” 
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are updated simultaneously. In order to modify a drawing independently from its other exposures, 
you must duplicate the drawing.

How to  create a cycle

1. In the Timeline view, select the cell range to loop.

2. In the Timeline View toolbar, click the Create Cycle  button (you may have to customize the 
toolbar to display it).

The Create Cycle dialog box opens.

3. Enter the number of cycles you want, including the current selection.

How to paste a cycle

1. In the Xsheet  or Timeline view, select the cell range to loop.

2. From the top menu, select Edit > Copy.

3. In the Xsheet  or Timeline  view, select the cell where you want your cycles to start.

4. Do one of the following:

84



Harmony 11.1 Traditional Animation Guide (Standalone)

‣ From the top menu, select Edit > Paste Cycle. 

‣ Right-click and select Paste Cycle. 

‣ Press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS X).

The Paste Cycle dialog box opens.

5. Do one of the following:

‣ In the Number of Cycles field, enter the number of cycles you want to paste.

‣ Increase or decrease the number of cycles you want to paste.

6. In the Cycle Type menu, select the type of cycle you want to paste.

‣ Normal (forward): Pastes cycles as for all cycles, starting with the first cell of your selection 
and ending with the last.

‣ Reverse: Pastes cycles in the reverse order of the original selection, starting with the last 
cell of your selection and ending with the first one.

‣ Forward > Reverse: Pastes the first cycle in your selection as is, then the following one in 
reverse order. This repeated until all cycles are pasted.

‣ Reverse > Forward:  Pastes the first cycle in your selectionin reverse order, then the 
following one as is. This repeated until all cycles are pasted.

7. Click OK.

You can perform the same operation using the Paste Special dialog box. To open the Paste Special dialog 
box, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘ + B (Mac OS X).    

How to paste a reversed cycle

1. In the Xsheet or Timeline view, select the cell range to paste in reverse order.
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2. From the top menu, select Edit > Copy.

3. In the Xsheet  or Timeline view, select the cell where you want your cycles to start.

4. Do one of the following:

‣ From the top menu, select Edit > Paste Reverse. 

‣ Right-click and select Paste Reverse. 

‣ Press Ctrl + . (Windows/Linux) or ⌘  + . (Mac OS X).
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Managing Drawings

Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files 
stored in the project’s folder. If you want to rename a drawing or delete a drawing from your project, 
you need to edit the file and not the cells.

This section is divided as follows:

• Renaming a Drawing below

• Deleting a Drawing on the next page

• Duplicating a Drawing on page 89

• Copying and Pasting Drawings on page 89

• Merging Drawings on page 92

Renaming a Drawing
To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

How to rename a drawing

1. In the Xsheet or Timeline view, select the drawing to rename.

2. Do one of the following:

In the Xsheet or Timeline View toolbar, click the Rename Drawing  button (you may have to 
customize the toolbar to display it).

‣ Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X).

The Rename Drawing dialog box opens.

3. In the New Name field, type in the new drawing name.

How to rename a drawing sequence with a prefix

You can rename a drawing sequence with a prefix, which can be quite useful for cut-out puppet 
breakdown and deformation animation.

1. In the Xsheet or Timeline view, select your drawing sequence. Note that you can only select a 
drawing range in one column or layer at the time.

2. Right-click and select Drawings > Rename Drawing with Prefix.

The Rename Drawing with Prefix dialog box opens.
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3. In the Prefix to Add field, type the prefix to add before the drawing name.

How to rename drawings by their frame position

You can rename a series of drawings relative to their frame position. This is useful in hand-drawn 
animation.

1. In the Xsheet or Timeline view, select the drawing sequence to be renamed.

2. From the top menu, select Drawing > Rename by Frame.

Deleting a Drawing
You can permanently delete a drawing file from a project's folder.

Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing

1. In the Xsheet  or Timeline view, select the drawings to delete.
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2. Do one of the following:

‣ From the top menu, select Drawing > Delete Selected Drawings.

‣ Right-click and select Drawings > Delete Selected Drawings.

Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can 
duplicate the drawing and work on the copy. When duplicating a drawing, the selected cell is replaced 
with the new drawing. The exposure of the original drawing that was on the current cell is removed. 
The original drawing is not deleted from the project folder or other cells in which it is exposed.

With Toon Boom Harmony you can create a keyframe at the same time as you duplicate your drawing. 
This way you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

1. In the Xsheet or Timeline view, select the drawing to duplicate.

2. Do one of the following:

‣ From the top menu, select Drawing > Duplicate Drawing.

‣ Right-click  and select Drawings > Duplicate Drawings.

‣ In the Xsheet view toolbar, click the Drawing > Duplicate Drawing  button.

‣ Press Alt + Shift + D.

Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting 
the actual drawings, you are pasting the exposure.

If you want to copy and paste the selected drawings into a different layer or paste the selection in the 
same layer to duplicate the drawings, you must use the Paste Special feature.

There are three methods of pasting your selected drawings with the Paste Special dialog box:
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• Never Create Drawing Files: Pastes all of your drawings as is. If there is a drawing in a cell, it is 
overwritten by the pasted selection.

• Always Create Drawings: Pastes all of your drawings as is, unless a pasted drawing has the 
same name as an existing one. In this case, the pasted drawing is duplicated and renamed.

• Only Create Drawings When They Do Not Exist: Pastes only the drawings that are named 
differently from existing drawings. If a drawing has the same name as an existing one, it is 
ignored and not pasted. This avoids the duplication of drawings in your layers.

This option is useful when you are pasting cut-out character templates containing drawings you 
may already have in your scene and some new ones. Using this option, you only paste the new 
drawings and are not duplicating all of the other parts you already have.

If you want to perform another Paste Special operation using the same settings you used previously, 
you can use the Paste Special Again command instead. You can paste your selection using the same 
settings as in the most recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

1. In the Xsheet or Timeline view, select the drawings to copy and press Ctrl + C (Windows/Linux) or 
⌘  + C (Mac OS X). 

2. In the Xsheet or Timeline view, select the cell where you want your pasted selection to start.

3. Do one of the following:

‣ Right-click and select Paste Special.

‣ From the top menu, select Edit > Paste Special.

‣ In the Xsheet  or Timeline View toolbar, click the Paste Special  button (you may need to 
customize the toolbar to display it).

‣ Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X). 

The Paste Special dialog box opens.
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4. Select the Basic tab.

5. In the Drawings section, select an option: Always Create Drawings or Only Create Drawings 
When They Do Not Exist.

How to paste new drawings with the previous Paste Special settings

1. Do one of the following:

‣ From the top menu, select Edit > Paste Special Again.

‣ Right-click and select Paste Special Again

‣ In the Xsheet or Timeline view toolbar, click the Paste Special Again  button (you may 
have to customize the toolbar to display it).

‣ Press Ctrl + Shift  + B (Windows/Linux) or ⌘  + Shift + B (Mac OS X).
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Merging Drawings

There are two methods of merging drawings. 

• You can merge selected drawings in adjacent elements. The columns and layers will be left 
intact, and each new merged drawing will reside in the frames of the left-most column or lower 
layer.

• You can merge elements. All drawings will be merged. Unused columns and layers will be 
deleted, but the original drawing files are still accessible.

How to merge selected drawings

1. In the Xsheet view, select the drawings you want to merge.

2. Do one of the following:

‣ In the Xsheet View menu, select Columns> Merge Selected Drawings.

‣ In the Timeline View menu, select Layers > Merge Selected Drawings.
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3. Do one of the following:

‣ In the Xsheet View menu, select Columns > Merge Selected Columns.

‣ In the Timeline View menu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most column will contain the merged drawings and the remaining 
columns will be left blank at the corresponding frames. In the Timeline view, the bottom timeline 
layer will contain the merged drawings from all layers and the other layers will be left blank at the 
corresponding frames. Drawings are not deleted and are still accessible.

How to merge drawings in entire layers or columns

1. Do one of the following:

‣ In the Timeline view,select the layers you want to merge.

‣ In the Xsheet view, Shift-click the headers of the columns you want to merge.

2. Do one of the following:

‣ In the Xsheet View menu, select Columns > Merge Selected Columns.

‣ In the Timeline View menu, select Layers > Merge Selected Layers.
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In the Xsheet view, the right-most column will contain the merged drawings and the other columns 
will be deleted. In the Timeline view, the bottom timeline layer will contain the merged drawings 
from all layers and the other layers will be deleted. Drawings are not deleted and are still accessible.

Modifying the Layer and Column Display
You can change the way a layer in the Timeline view or a column in the Xsheet view display. You can 
stay organized without changing the content of elements or your animation output.

This section is divided as follows:

• Expanding and Collapsing Layers and Columns below

• Showing and Hiding Layers on the facing page

• Showing and Hiding Columns on page 97

• Modifying the Look of the Column on page 99

• Xsheet Thumbnails on page 104

• Changing the Colour of a Layer or Column on page 104

• Setting Scene Markers on page 106

• Setting Tempo Markers on page 109

Expanding and Collapsing Layers and Columns
To simplify the look of the Xsheet or Timeline view, you can expand and collapse your timeline layers 
and 3D columns. If some timeline layers are parented to other ones, you can collapse the parent layer 
to hide its children.   

How to collapse or expand a layer selection in the Timeline view

1. In the Timeline view, select the layer(s) to collapse or expand.

2. Do one of the following:

‣ Right-click on the selection and select Collapse/Expand > Collapse/Expand. 

‣ Click the Expand Children Arrow  button on the parent layer.

‣ Press  Ctrl + I (Windows/Linux) or ⌘  + I (Mac OS X).

‣ Click the Collapse/Expand  button  (you may have to customize the toolbar to display it).
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‣

How to collapse or expand all layers in the Timeline view

1. Do one of the following:

‣ Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

‣ In the Timeline View toolbar, click the Collapse All  or Expand All  buttons (you may 
have to customize the toolbar to display them).

‣ Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

1. In the Xsheet View toolbar, click the Show Column List  button to display the Functions list.

2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or 
expand.

3. Do one of the following:

‣ Right-click on the column’s header and select Expand/Collapse > Collapse Selection or 
Expand Selection.

‣ In the Xsheet View toolbar, click the Collapse Selection  or Expand Selection  
buttons (you may have to customize the toolbar to display it).

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:

‣ Right-click on any column’s header and select Expand/Collapse > Expand All or Collapse 
All.

‣ Press 0 and 9.

‣ In the Xsheet View toolbar, click the Collapse All  or Expand All  buttons  (you may 
have to customize the toolbar to display it).

Showing and Hiding Layers
As you work in the Drawing or Camera view, some layers may be in the way or are used as references. 
You can hide these layers to make your work area less cluttered and easier to navigate. You can show 
and hide layers in the Timeline view in several different ways.

How to show or hide all layers

1. Do one of the following:

‣ In the Timeline View toolbar, click the Enable All  button (you may have to customize the 
toolbar to display it).

‣ In the Timeline view’s Layer toolbar, click the Enable/Disable All  button to show or hide all 
layers. 
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How to show or hide individual layers

1. Do one of the following:

‣ In the Timeline View toolbar, click the Enable/Disable  button (you may have to customize the 
toolbar to display it).

‣ On the right side of the Timeline view, select or deselect the layer’s checkbox. 

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet 
view.

How to enable the selected layer and disable all others

1. Do one of the following:

‣ In the Timeline View toolbar, click the Disable All Others  button (you may have to customize 
the toolbar to display it).

‣ In the Timeline view’s Layer toolbar, click the Show Selection and Hide All Others  button.

In the Timeline view, you can hide or show certain types of layers such as Group and Effect. 

How to show and hide layer types in the Timeline view

1. Do one of the following:

‣ From the Timeline View menu, select View > Show > Show Manager.

‣ You can also select View > Show > Show Sounds, Show Effects or Show Groups to 
immediately show or hide the selected type. This option will remain only for the current 
session. When you close and reopen Harmony, the default settings will return.

The Show Manager dialog box opens.

2. Select the types of layers you want to display and deselect the ones you want to turn off.

3. Click Set As Default to make these new settings the default ones that will be used each time to 
start the application. Click Restore Default to restore the settings used when installing the 
application.
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In the Xsheet view, you have the choice of hiding or showing certain types of columns such as 
Annotation and Functions.

Showing and Hiding Columns
The Xsheet view has a Column List section that can display all the columns contained in the exposure 
sheet. It can be used to hide individual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view 
without using the Column List section.

You can also hide an entire column type, such as Drawing or Sound.

When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.

How to show or hide columns in the Xsheet view

1. In the Xsheet View toolbar, click the Show Column List  button.

2. On the right side of the Functions section, click the Expand  button to display the Column List 
section.

3. Do one of the following:

‣ In the Column List section, select the columns to display and deselect the columns to hide. 

‣ In the Xsheet view toolbar, click the Hide Selected Column  button (you may have to 
customize the toolbar to display it).

How to show a hidden column in the Xsheet view

1. In the Xsheet view menu, click on the thick grey line that represents a hidden column. You can also 
right-click on the column header and select Show Hidden Columns.

The Show Hidden Columns dialog box opens.
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2. In the Show column, select the hidden columns you want to display in the Xsheet view.

‣ Click Check to select all the selected columns.

‣ Click Uncheck to deselcted all selected columns.

How to show all columns

‣ In the Xsheet view menu, select View > Unhide All Columns.

How to show and hide column types

1. In the Xsheet view, select View > Column Types Manager.

The Column Types dialog box opens.

2. Select the types of columns you want to display and disable the ones you want to hide.

3. Click Set As Default if you want to make these new settings the default ones that will be used each 
time to start the application.

4. Click Restore Default if you want to restore the settings used when installing the application.

How to show or hide Xsheet columns using the Column List

1. In the Xsheet view toolbar, click the Show Column List  button.

2. On the right side of the Functions section, click the Expand  button to display the Column List 
section.

3. In the Column List section, select the columns to display and deselect the columns to hide. 

98



Harmony 11.1 Traditional Animation Guide (Standalone)

How to show or hide an Xsheet column type using the Column List

1. In the Column List section, click the button corresponding to the type you want to show or hide.

Column Type but-
ton 

Action

Show/Hide All Columns

Show/Hide Drawing Columns

Show/Hide Function Columns

Show/Hide 3D Path Columns

Show/Hide Sound Columns

Show/Hide 3D Rotation Columns

Show/Hide Annotation Columns

How to show or hide function columns on the left side of the Xsheet view

1. Right-click on a column and select Tag > Function Columns Visible or Function Columns 
Invisible.

Modifying the Look of the Column
In Harmony, you can modify the way the column displays drawings, empty cells and the column width.

You can modify the following elements:
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• Empty cells

• Row units

• Held exposure

• Column width

How to modify the look of empty cell

1. From the Xsheet View menu, select View > Empty Cells > With an “X” or Blank.

How to modify row units

1. From the Xsheet View menu, select View > Row Units > Frames or Feet.

How to modify the look of a held exposure

‣ In the Xsheet View menu, select View > Held Exposures > Line or Value.

How to modify column width

1. In the Xsheet view, select any column to modify the width.

2. From the Xsheet view menu, select View > Set Columns Width.

The Xsheet Column Width dialog box opens.
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3. In the Column Width field, enter the desired width in pixels.

4. To end the operation:

‣ Click OK to validate and close the dialog box.

‣ Click  Apply to validate the operation and keep the dialog box opened to adjust the next 
column’s width.

‣ Click  Set As Default to create all the new columns to this width.

‣ Click  Close to cancel the operation.

5. To restore all columns to the default value, in the Xsheet View menu, select  All Columns to 
Default Width.

Drawing Identification
In the Xsheet view, you can identify drawings as Key, Breakdown or In-between. This helps to keep the 
Xsheet well organized while animating.

When working with several animators, directors, or even other studios, the necessity for retakes will 
often arise. Harmony also gives you the possibility to mark new drawings as either Retake Key, Retake 
Breakdown, or Retake Inbetweens.

If your production requires you to mark drawings with a custom marker, you also have the option to 
create your own.

Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a 
bit of code. Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing 
toolbars, but also in the Onion Skin and Flip toolbars.
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You can create custom shortcuts for the Drawing Identification options in the Preferences dialog box.

How to mark a drawing as Key, Breakdown or In-between

1. From the top menu, select Windows > Toolbars > Mark Drawing. 

The Mark Drawing toolbar displays.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline 
view.

3. In the Mark Drawing toolbar, click one of these buttons: Mark as Key Drawing , Mark as 
Breakdown Drawing  or Mark as In-between Drawing . In the Xsheet View menu, you can 
also select Drawing > Mark Drawing As > Key Drawing, Breakdown Drawing, In-between 
Drawing, Retake Key, Retake BD and Retake IB.

‣ If you selected Mark as Key Drawing, a  icon appears in the cell.

‣ If you selected Mark as Breakdown Drawing, a  icon appears in the cell.

‣ If you selected Mark as In-Between Drawing, there is no icon displayed in the cell since it is 
used to remove a Key or Breakdown marker.
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How to create custom markers

1. With a bitmap editing software, create the following icons in PNG format:

‣ Mark Drawing Toolbar icon (24 x 24 pixel)

‣ Onion Skin Toolbar icon (24 x 24 pixel)

‣ Flip Toolbar icon (24 x 24 pixel)

‣ Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.

3. When your icons are ready, open the Toon Boom Harmony drawingTypes.d folder. 

If the drawingTypes.d folder does not exist, you must create it. To do so, copy the 
resources folder from the following location.

• Windows: C:/Program Files (x86)/Toon Boom Animation/Harmony 
11.1/resources/drawingTypes.d

• Mac OS X: /Applications/Harmony 11.1/resources/drawingTypes.d

• Linux: 
/usr/local/ToonBoomAnimation/ProductNameVersion/resources/drawingTypes.d

Stand-alone

‣ Windows: C:\Users\USERNAME\AppData\Roaming\Toon Boom Animation\Toon 
Boom Harmony\full-1100-pref\drawingTypes.d

‣ Mac OS X: /Users/USERNAME/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d

The Library folder is usually hidden in the Finder. To see all the hidden folders and files, 
type the following in a terminal window:

defaults write com.apple.Finder AppleShowAllFiles YES

‣ Linux: /home/USERNAME/Toon Boom Animation/Toon Boom Harmony/full-
1100-pref/drawingTypes.d/

Network

In Harmony Network, the path is global for all users so you must create the folder and place in 
/USA_DB.

‣ /USA_DB/drawingTypes.d

4. Paste your icons in the drawingTypes.d directory.

5. In the same directory, open the drawingTypes.xml file in a text editor.

6. For each custom icon you want to create, add the following line. Make sure to place it before this 
closing tag: </DrawingTypes>.
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‣ <DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png" 
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png" 
onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:

‣ NewButtonName: Write the name of your new marker. This name will appear in the button 
tooltip.

‣ XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet 
column. Include the file extension.

‣ MarkDrawingIcon.png: Write the name of the icon that you created to appear in the Mark 
Drawing toolbar. Include the file extension.

‣ FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar. 
Include the file extension.

‣ OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin 
toolbar. Include the file extension.

8. Save the file and close it.

9. Start Harmony.

Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it is not always easy to quickly 
identify a particular column. Displaying the column thumbnails makes this easier. This option displays a 
small thumbnail picture of the current frame below the column header.

How to display the thumbnails

1. In the Xsheet view, select View > Show Thumbnails. 

The thumbnails appear.

Changing the Colour of a Layer or Column
To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and 
columns. The colours you choose will be reflected in the Network view.

How to change the layer’s colour in the Timeline view

1. Do one of the following:

‣ In the Timeline view, click the colour swatch of the layer you want to modify. 

2. In the Select Colour dialog box, select a new colour for your layer.
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3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, 
selected colour for easy identification. The corresponding column colour is also updated.

How to reset a layer’s colour in the Timeline view

1. In the Timeline view, select the layers to reset.

2. In the Timeline View toolbar, click the Default Track Colour  button (you may have to customize 
the toolbar to display it).

How to change a column’s colour in the Xsheet view

1. In the Xsheet view, select one or more columns to modify.

2. Right-click on the column’s header and select Colour > Change Columns Colour.

3. In the Select Colour dialog box, select a new colour for your columns.

4. Click OK.
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The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

1. In the Xsheet view, select the columns to reset.

2. Right-click on the column’s header and select Colour > Default Columns Colour.

Setting Scene Markers
Scene markers are visual indicators displayed at the top of the timeline in the frame counter area. You 
can use it to denote anything relevant to your work. You can indicate at the frames you want to clean 
up, a change in action, an impact, or where you intend to apply an effect. You can also add a note to a 
scene marker, which is displayed when you hover over the scene marker.

There are two ways to add a scene marker. You can make a frame range selection and mark that 
whole section or simply mark the current frame.

How to mark the current frame

1. In the Timeline view, make sure the playhead is set on the frame you want to mark. Even if you 
right-click on a different frame, the scene marker will be created on the current frame, which means 
where the red playhead is.

2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or 
the colour of the last scene marker you created.

3. Double-click the Colour box to select a colour for your scene marker.

4. In the Note field, enter text to display a tooltip.
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5. Click OK.

6. In the Timeline view, the scene marker is displayed at the current frame.  Hover over the scene 
marker to display its note as a tooltip.

How to create a scene marker on a frame range

1. In the Timeline view frame counter, select the frame range on which you want to mark your scene.

2. Right-click and select Scene Markers.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or 
the colour of the last scene marker you created.

3. Click the colour swatch and select a colour for the scene marker.

4. In the Note field, enter text to display as a tooltip.

5. Click OK.

6. In the Timeline view, the scene marker is displayed over the selected frame counters. Hover over 
the scene marker to display its note as a tooltip.
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How to edit a scene marker

If you select only a part of a scene marker, you will not open the scene marker for editing. You will only be 
able to create a new scene marker to overwrite it.

1. In the Timeline view frame counter, select the entire scene marker.

2. Right-click the selection and select Edit Scene Marker.

The Timeline Scene Marker dialog box opens.

3. Make your changes.

4. Click OK.

How to delete a scene marker

1. In the Timeline view frame counter, at least one frame counter in the scene marker you want to 
delete.

2. Right-click the selection and select Delete Scene Marker.
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Setting Tempo Markers

Tempo markers are used to synchronize your animation with a musical score. This lets you reproduce 
the FPB (Frames Per Beat) and use the tempo signature as tempo markers. The Xsheet view allows 
you to pace your animation according to the tempo or beat of the soundtrack music or to any rhythmic 
sound, such as the ticking of a clock or water leaking from a spout.

How to set the tempo markers

1. In the Xsheet View menu, select View > Set Tempo Marker or in the sound column, right-click and 
select View > Set Tempo Marker.

The Tempo Marker dialog box opens.

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.

‣ Starting Frame: Enter the number of the frame where you want the tempo markers to 
begin.

‣ Frames/Beat: Set the frames per beat value. This will determine the frequency (in frames) in 
which a beat marker will appear. Keep in mind that, by default, 24 frames represent 1 
second.

‣ Beat/Bar: Set the tempo of your music or sound. This will determine the frequency (in beats) 
in which a tempo marker will appear in the Xsheet view.

3. Click OK.
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Printing the Xsheet

Once you have marked all the information, corrections, and timing you want in the Xsheet view, you 
can print your exposure sheet. Printing the Xsheet allows you to take it with you to your animation 
table or give a copy to the animator. You can also use it to create your Xsheet skeleton directly in 
Harmony.

How to print your exposure sheet

1. Select File > Print > Xsheet.

The Print dialog box opens.
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2. To set up your print:

‣ Windows: In the Select Printer section, select your printer and adjust the rest of the printing 
settings. 

‣ Linux: In the Print Destination section, select your printer and adjust the rest of the printing 
settings. 

‣ Mac OS X: In the Printer section, select your printer and adjust the rest of the settings by 
clicking on the Parameters  button. You can also click  PDF and select an option from the 
menu if you want to save a PDF version of your exposure sheet. 

Refer to your printer user guide to learn more about its options.

3. Do one of the following:

‣ Windows and Mac OS X: Click Print. 

‣ Linux: Click OK.
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Chapter 4: Colour Styling and Colour Models

Once the characters, props and locations are designed, it is time for the colour styling and colour 
models creation. This is when the colours and moods are determined. The line models created during 
the design step are painted and organized as colour models for the colourists. 

Harmony has a great concept of colour palettes. Each character can have its own set of colours that is 
carried through the entire project called the master palette. If the master is modified, the colours in 
the entire project are updated simultanously. 

By doing the colour styling in Harmony, your master palette will be created at the same time, so you 
do not need to use third party software. Also you will not have to recreate the colour palette again in 
Harmony. It is possible to create this step in an external software, but it is a great time saver to do it 
directly in Harmony.

To create the colour style and colour models, follow these steps:

• Preparation on the next page

• Working with Palettes on page 119

• Colours on page 136

• Painting the Model on page 148

• Sharing the Colour Model on page 150
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Preparation

Before painting, you need to organize the colour model scenes and bring in your references. The 
colour styling preparation is done in five steps:

• Colour Model Storage below

• Scene Creation below

• Setting Up the Workspace on the facing page

• Naming on page 116

Colour Model Storage
First, you will need to create a storage location for all your models and palettes. The best way to do 
this is to create a colour model scene. There are different possibilities available to structure your 
designs and colour model scenes. We strongly recommend that you put all of your colour models in 
the same scenes. It is important to maintain a structure for your models so they do not end up 
scattered throughout the project.

There are four main model categories:

If you have a small project, such as a short or an advertising contract, you can always place all the 
characters, props, effects, and locations in the same scene. For large projects such as feature-length 
productions or series, you should create four separate model scenes following these categories.

Scene Creation
In order to create colour models, you need to create your scenes.

When working on a paperless or cut-out animation project, if you have designed your characters, 
props, effects and locations directly in Harmony, you can paint your models directly in your design 
scene. You can also create a new colour model scene and import your  designs in that one. Refer to the 
Fundamentals Guide to learn more about creating a scene.
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If you have not already done so, refer to the Fundamentals Guide to learn about production structure, 
file organization, and how to create a Project root directory. We recommend storing your  colour 
model scenes in the root directory or in a colour models subdirectory for even better organization.

A useful way to name your colour model scene is to include the project name, then the colour model 
type such as characters, props, effects, or locations, and finally colourmodel. For example, a 
character colour model scene for the Adventure project would be named adventure_characters_
colourmodel. This ensures that you always know what scene corresponds to what.

Colour Model Scene Structure

To store your colour models in a scene, it is recommended that you create one drawing layer for each 
character, prop, effect, or location. You should name these according to the model.

You can also load other colour references in the scene to balance your overall colours. For example, if 
you work in a character colour model scene, it is a good idea to import some of the key locations to 
compare and adjust the colours so they match well.

Setting Up the Workspace
Now that your scenes are created and structured, you can open the corresponding colour model 
scene. For the optimal workspace for inking and painting, set up your workspace with these views:
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• Xsheet

• Camera 

• Drawing

• Colour

• Model

 

Naming
Now that your models are imported, you can rename them appropriately. You should rename 
elements (layers) and drawings corresponding to the model. This will help keep the work organized 
and make it easy for others to follow.

For example, if there is a black and white character model called Erik in one drawing element and its 
colour models in another one, rename your elements to include the character's name. For example, 
the colour model for Erik's armour could be named: erik_armour_colour.
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How to rename a drawing element

1. Do one of the following:

‣ In the Xsheet view, double-click on the column header of the drawing element.

‣ In the Timeline view, double-click on the drawing element's layer.

The Layer Properties window opens.

2. Type in a new name.
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How to rename a drawing

1. In the Xsheet view, click on a drawing name.

2. Do one of the following:

‣ From the Xsheet menu, select Drawings > Rename Drawing.

‣ Right-click on the drawing name and select Drawings >Rename Drawing.

‣ Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X).

The Rename Drawing dialog box opens.

3. Type in a new name and click OK.
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Working with Palettes

In animation, specific colours are used to paint each particular character. In order to maintain absolute 
consistency, a colour palette is created for each character, prop and effect throughout the production. 
These are referred to as master palette1s.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.

Using a master colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.

• You cannot accidentally use a colour which is not in the master palette.

• Standardization and colour consistency throughout the production

• Multiple artists can use the same colour palette and produce the same results.

Toon Boom Harmony uses palettes to hold all the colours needed to paint your elements, allowing 
complete control and consistency in your painting process. 

A palette2 is created by assigning a set of colours to each character, prop or effect. You will create a 
new palette and add a new colour, known as a colour swatch, for each zone of the character, such as 
the skin, hair, tongue, shirt, pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a  *.plt 
file name extension—see Palette File Storage  on page 123. 

When a zone on the character is painted with the colour contained in a colour swatch, a link is 
automatically created between that colour swatch and the zone. This means that if the tint of the 
colour in the colour swatch is changed, any zone linked to it will update to the new tint. This is one way 
that colour palettes can save time and money in your production. 

Another advantage of this system is that you can create complete palettes for different lighting 
situations. For instance, in addition to the regular palette for a character, you could have one for that 
character in the rain using colours that are duller and less vibrant than the dry daytime colours, or yet 
another for using in a night scene. Using palettes linked to your character in this way allows you to 
instantly change its colouring to suit the mood and atmosphere of the scene without tediously 
repainting each element.

1A master palette is a group of colours attributed to a character or a prop. The palette is used throughout the 
entire production to maintain consistency in the look and to ensure that the same colours are used throughout 
the production. Also known as palette.
2A palette or master palette is a group of colours attributed to a character or a prop. The palette is used 
throughout the entire Toon Boom Studio project to maintain a consistency in the look and avoid the colour 
changing during the animation. Also referred to as a master palette.
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This section is divided as follows:

• Palette Lists below

• Palette File Storage  on page 123

• Creating a Colour Palette  on page 124

• Duplicating a Colour Palette  on page 128

• Cloning a Colour Palette  on page 129

• Importing and Linking Palettes on page 131

Palette Lists
The Colour view has two modes: basic and advanced.
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• Basic Mode

The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony, 
you only see the colours available in the Default palette which contains six basic colour swatches 
and is automatically named the same as your scene. For simple projects, you can manage with the 
default palette, but for movies, series, or shorts it is recommended that you create palettes for 
your characters. To create a palette, you have to switch to the Advanced mode of the Colour view 
and show the Palette list.

• Advanced Mode

The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes 
for your characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a 
palette list. The scene also has a palette list.  For example, a drawing layer can use three different 
palettes stored in three different locations, while another drawing layer can use two of these palettes 
plus another one coming from another scene. The palette list keep track of the locations of the 
palettes.

There are two types of palette lists:

• Scene Palette List 

The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless 
and traditional animations. A cut-out character will often be divided into 20 to 30 different drawing 
elements that use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes 
linked to this list will appear in every drawing element created in the scene. There is no need to 
manually load the palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only 
Scene Palette lists.

• Element Palette List

In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your 
palette at an element’s level. The Element Palette list is mainly used with traditional and paperless 
animation. Unlike cut-out animation, all columns (drawing elements) contain different characters, 

121



Chapter 4: Colour Styling and Colour Models     Working with Palettes

props, backgrounds, and effects. The Element Palette list is used when you do not necessarily 
want all of the palettes for all of your elements linked in every column. 

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. 
This ensures that the links to the palettes appear only in the appropriate element. If you prefer to 
access a global palette list, link your palettes to the Scene Palette list.

When you are using several cloned palettes that are related to the same original palette, Toon Boom 
Harmony uses the highest palette in the list to determine the colour of the painted zones—see Cloning 
a Colour Palette  on page 129.

How to show or hide the Palette list

‣ In the Colour view, click the Show/Hide Palette List View  button to expand or collapse 
the Palette List area.

The Palette List window opens and displays all your palettes.

How to set the Advanced Palette Lists mode

1. Do one of the following:
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‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences 
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. Select the Advanced tab.

3. Select  the Advanced Palette Lists option.

4. Click OK.

How to reorder palettes in the Palette list

Do one of the following:

‣ From the Colour View menu, select Palettes > Move Up or Move Down. 

‣ In the Palette list, click the Up  and Down  buttons.

Palette File Storage 
In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a 
palette is created from Harmony, it needs to be stored somewhere. By default, the palette file is 
stored in the scene directory in a palette-library folder unless you specify a different location. There are 
four locations where you can find palette-library folders:

• Element

The Palette Library folder is stored directly in the drawing Element folder.
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• Scene

The Palette Library folder is stored directly in the Scene folder.

• Job

The Palette Library folder is stored in a Job folder contained in the Scene folder.

• Environment

The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is 
recommended to keep it as is. If you work with a larger studio, it is recommended to verify with them 
on the file structure.

This existing structure is compatible with Toon Boom Harmony Server. Toon Boom Harmony’s 
database has a leveled structure starting from the Environment down to the Element. Its client-server 
configuration allows all data, such as palettes and scenes, to be shared between a series of client 
machines.

Element Level 

Working with Harmony as a stand alone, the Element level is very useful when there are a lot of 
different palettes. When a colour model drawing is created, it is stored in its element folder. By 
storing the corresponding palette file with the colour model, the colourist can load them both from 
the same location. This also creates a more organized structure.

Scene Level 

Working with Toon Boom Harmony as a stand alone, a palette file can also be saved at the scene level, 
so that all of the palettes from the scene are stored together. The palette naming must be structured 
so the colourist or character builders can find the correct one. Saving the palettes at the scene level 
makes it very easy to back up the palettes and retrieve their location.

The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that 
includes all of the characters, props, effects, and location, the colour palette or model will often be 
directly imported to, or created in, the character building scene. Just as with a cut-out character 
building scene, each element uses the same palette so it would not be efficient to save the palette 
inside one element. Instead, it is saved at the scene level. This prevents a palette overload because all 
of the models are in different scenes. It also allows each scene to have its own set of palettes 
corresponding to its model.

When working on a cut-out animation production, it is highly recommended that you work with the 
Scene level.

Palette Backup
When sharing palettes between scenes, some users may accidentally modify the colours, even though 
the palettes are locked by default. That is why it is a good idea to copy and back up your palette 
libraries and master palette directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble 
replacing an altered file. Harmony automatically updates all of the files and drawings linked to it.

Creating a Colour Palette 
You can create a palette in either Basic or Advanced mode.
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By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended 
to use the Basic mode.  This setting stores the palettes automatically for you and saves them at the 
Scene level. When you use the Advanced Palette Lists mode, you can decide at which level you want to 
store your palettes: Environment, Job, Scene, or Element.

Before you can create a palette in the Advanced Palette Lists mode, you must first set your 
preferences to Advanced Palette Lists mode in the Preferences dialog box.

You can remove palettes from your Palette list if they are not needed in your scene. The actual palette 
file will not be deleted and you can reimport it in your Palette list later on.

How to set the Advanced Palette Lists mode

1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences 
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

2. Select the Advanced tab.

3. Select  the Advanced Palette Lists option.

4. Click OK.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour View menu, select Palettes > New or click the New Palette button.

The Create Palette window opens.

2. Enter the palette name according to the model. 

3. Click OK.

The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode

1. In the Timeline or Xsheet view, select the drawing that requires a palette. 

2. In the Colour view, click the Show Palette List View  button to display the palette list. 
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3. Do one of the following:

‣ From the Colour view menu, select Palettes > New. 

‣ Click the Create Palette  button. 

The Palette Browser: Create Palette dialog box opens. 

4. Select the level to store the palette file. 

‣ Environment: The palette-library folder is stored in the scene's parent environment folder.

‣ Job: The  palette-library folder is stored in the scene's parent job folder. 

‣ Scene: The  palette-library folder is stored directly in the scene folder. 

‣ Element: The  palette-library folder is stored directly in the drawing element folder. 

When you select a level that has a palette stored in it, the palette names are displayed in the 
Palette field.

5. Name the palette. There is no need to add the suffix "palette"  to the name as it is always 
recognized as a palette file.

 

6. Select a Palette List option.

 

‣ The Scene Palette List is mainly used with cut-out animation. A cut-out character will often 
be divided in twenty to thirty different drawing elements that use the character's master 
palette. 
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The palette list is stored at the scene level instead of the Element directory. This way, all 
palettes linked to this list will appear in every drawing element created in the scene. There is no 
need to manually load the palette in each element. 

‣ The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-
out animation, all columns (drawing elements) contain different characters, props, 
backgrounds and effects. The Element Palette List is used because you do not necessarily 
want all of the palettes for all of your elements linked in every column. 

The palette list is stored in the drawing element's directory instead of directly in the Scene level. 
This ensures that the links to the palettes appear only in the appropriate element. If you prefer 
to access a global palette list, link your palettes to the Scene Palette List.

7. Click OK. 

The new palette appears in the palette list.

How to rename a palette

1. In the Colour view, select the palette to rename.

2. Do one of the following:

‣ Right-click and select Rename.

‣ From the Colour View menu, select Palettes > Rename.

3. In the Rename dialog box, give the palette a new name and click OK.

How to remove a palette

1. In the Colour view, select the palette to remove.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Remove. 

‣ Right-click on the selected palette and select Remove.

‣ Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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Duplicating a Colour Palette 
A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but 
has a different ID and is independent from the original palette. This ensures that both palettes are 
completely independent.

This option is used when there are similar models and you want to avoid recreating and naming all of 
the colours. You can change the values and the names afterward without affecting the original palette. 
You can also keep some RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.

How to duplicate a palette 

1. In the Colour view, select the palette to be duplicated.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Duplicate. 

‣ Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.

3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage  
on page 123.

4. In the New Palette Name field, name the palette.

5. In the New Palette Name field, name the palette.

6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette 

A character usually has only one master palette, although there are times when the characters are 
placed in different lighting conditions and require a different colour shading. The night palette is a 
popular choice when a scene or sequence changes from day to night. It can be difficult and time-
consuming to repaint everything and creating two independent palettes can be quite complex. As an 
alternative, Toon Boom Harmony provides clone palettes.

The clone palette is a copy of the master palette. The colours in each palette have the same 
properties. The colours have the same identification number pointing to the same colour zones, but 
they can have different names and RGBA values. Depending on the activated palette (night or day), the 
painted drawing will update. So there is no need to repaint the animation, but to create or import a 
clone palette (palette style).

How to clone a palette

1. In the Colour view, select a palette to clone.

2. From the Colour View  menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.
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3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage  
on page 123.

4. In the New Palette Name field, name the palette. It is recommended that you keep the "-clone" in 
the name.

5. Click OK.

The cloned palette appears in the palette list.

6. In the Palette list, select the clone palette you created to offset or blend colours—see Mixing 
Colours on page 145.

7. From the Colour View  menu, select Palettes> Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A 
(Windows/Linux) or ⌘  + A (Mac OS X).

9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

10. Select the Preview option to see a preview of the colours while you adjust them.

You can also modify the colours individually with the Colour Picker window.

Importing and Linking Palettes
Before starting colouring work such as Ink and Paint or even creating new colour models, you may 
want to load existing colour palettes to your scene. You can do so by linking colour palettes to your 
palette lists.

You may encounter a case where only a colour palette is visible when a layer is selected. If you need 
that palette in a second layer, you can link the palette to the second layer's palette list, A good 
example would be a scene where there is a character on one layer and its arm is on another. In order 
for both layers to access the palette, you must link both Element Palette lists to that palette. If you 
palette is linked to the Scene Palette list, it will be accessible by all layers.
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If you created a palette in another project and you want to import it in your current project, you can 
browse for the palette file  on your computer and add it to your scene. When the palette is imported in 
your scene, the file is copied in the project’s directory. It is not linked to the original file.

With Toon Boom Harmony as a stand-alone application, every scene is local to the machine. This 
means that all of the scene’s data is only accessible from that particular scene. Palettes are also local 
to the scene; they can be shared between all drawing layers, but not between scenes.

However, you may want to share palettes across a whole project. Harmony offers that possibility. By 
default, a palette is an independent file stored in your  scene. This file can be copied, moved, or 
deleted.

To link a palette throughout an entire project, you need to create a central directory where you can 
copy all the palettes you created. Every time you link a palette in an element, it is linked to this folder. 
If you modify the palette, it will be updated throughout the whole project.

You will notice that when you create or link a palette, a small icon appears on its left. These icons 
represent the palette linkage status.

Icon Description

Indicates that the palette is safe.

There won’t be any trouble once the scene will be exported. For example, 
the palette file is stored in the scene folder and is linked to the Scene Palette 
List. 

Indicates that the palette file is stored in a directory external to the scene’s 
structure.

The palette file is probably stored in a Master Palette directory on a hard 
drive external to the palette-libraries planned for the palette storage. The 
warning in this case is that if you move your Master Palette directory to 
another location, you may loose the palette in your scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or 
Environment is linked to a Palette list that is not on the same level. 

For example, a palette file is stored into the Environment folder and is linked 
to the Element Palette list. The palette is shared.

How to link a colour palette

1. Do one of the following:

‣ From the Colour View menu, select Palettes > Link. 

‣ Right-click and select Link.

‣ Click the Import  button.

The Palette Browser: Link Palette dialog box opens.
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2. Select the level where the palette file is stored—see Palette File Storage  on page 123.

3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—
see Palette Lists on page 120.

The palette appears in the Colour view.

How to import a palette into your project

4. Do one of the following:

‣ From the Colour View menu, select Palettes > Import. 

‣ Right-click and select Import.

The Browser window opens.

5. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in 
your project's palette-library directory.

6. Click Open.

The Palette Browser opens.
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7. If you are in Advanced Palette mode, select the level where the palette file is stored—see Palette 
File Storage  on page 123.

8. If you are in Advanced Palette mode, select the palette list linking level by enabling either Scene 
Palette List or Element Palette List—see Palette Lists on page 120.

9. In the New Palette Name, name the imported palette.

The palette appears in the Colour view and the file is copied in your project.

How to link to an external palette

1. In the Colour view, click on the Create Palette  button to create your palette to be used as 
external.

2. Save your scene by selecting File > Save from the top menu or by clicking the Save   button or 
press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

3. On your computer or server, create a master directory. Ideally, this should be created in your Root 
folder to keep it within the project directory. You could also place it inside your Colour Model’s 
subdirectory. Refer to the Fundamentals Guide to learn more about project organization.

4. Name the folder appropriately, for example: Joe_master_palette.

5. From your operating system, browse to your Toon Boom Harmony scene and open the palette-
library folder.

6. Select and copy your palette *.plt file to copy it to the master palette directory.
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7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette. 

8. In the Timeline or Xsheet view, select the element to link the palette to.

9. From the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

10. Click Browse to search for your master palettes folder and select the palette *.plt file you want 
to link.

11. In the Palette list section, select how you want to load the palette; at the scene or element level.

12. Click OK.

The linked palette appears in the Colour view.

If a palette is outside the scene, the External  icon appears beside the palette name. 

To link an element (such as a colour model) to the palette that is stored in the external palette directory, 
you must remove the original palette from the element’s palette list. You will then load the duplicated 
palette into the palette list using the Link to External command, like you did for the other elements. 

135



Chapter 4: Colour Styling and Colour Models     Colours

Colours

Toon Boom Harmony has some very powerful colouring features when it comes to painting. To paint 
your drawings, you will use different colour swatches, unlike some other painting programs where you 
modify the main swatch each time you want to paint with a different colour. 

In the Colour view, you choose a different colour swatch for each colour you want to paint in your 
drawing. You can add as many swatches as you want. You can also rename them and modify existing 
ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with 
this swatch throughout the entire project. The colour swatch has a unique ID number that associates it 
with the painted zones. This way, you can change the look of your character at any time without having 
to repaint it!

This section is divided as follows:
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• Adding a Colour Swatch  below

• Colour Display Modes  on page 143

• Copying and Pasting Colours  on page 144

• Mixing Colours on page 145

Adding a Colour Swatch 
You can use several different types of colour swatches.

In Toon Boom Harmony, when you click on the Add Colour  button, a new colour swatch is created 
using the colour of the currently selected swatch from your palette. However, you can set a default 
colour to be used every time you create a new colour in your colour palette. This might be useful if you 
want to create different shades of the same basic colour.

The default colour is also the colour used when you choose to vectorize images that you are scanning 
into your scene, however you add the Default colour swatch to your palette in a different way, so that 
it is unique. It has a unique ID number that makes it recognizable from all the other colours in your 
colour palettes. Being able to change this colour allows you to change the basic colour of all scanned 
drawings. This can be useful on more than just an aesthetic level as sometimes when you go to NTSC 
or PAL, pure colours, such as pure black, can create problems.

How to add or modify a solid colour swatch

1. In the Colour view, click the New Colour  button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens. 
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3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options 
to change the look of the colour picking area.

‣ Click the Dropper  button to select any colour on your screen. It can be from the Toon 
Boom Harmony interface, your operating system or any other open application. 

You can also click Multi Wheel Mode to open the Multiwheel Colour dialog box. This displays all 
the picking area styles together and also contains a picking undo list. To return to the regular 
Colour Picker window, click Single Wheel Mode.
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4. Click on the Shade Scale swatches to modify the shade of the selected colour. 

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha 
field.

6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can 
quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by 
double-clicking on its name.

How to change the default swatch colour for all your colour palettes

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS 
X).

2. In the Preferences dialog box, select the Drawing tab.
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3. In the New Colour Pots section, select the Create New Colour Pot Using the Default Colour 
option. You can also click on the colour swatch beside the option to change the Default colour.

How to add a new colour swatch using the default colour

‣ From the Colour View menu, select Colours > New. 

A new swatch is added to your palette using the default colour swatch colour. The new swatch 
created with the New  command will be named New 0.

How to create a gradient colour swatch

1. In the Colour view, select a colour to modify .

2. Do one of the following:

‣ Click the new colour and from the Colour View  menu, select Colours > New. 

‣ Double-click on the colour swatch.

The Colour Picker window opens.

3. Select the Gradient option.

4. Select the Linear or Radial option.

5. Adjust the Gradient arrows to modify the colours.

‣ Add extra colours by clicking between the arrows below the gradient bar. Then click on the 
Colour Preview to select a colour.

‣ Pull down the arrows to remove them.
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‣ Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures  on page 181 topic to learn how to reposition the gradient 
zones in your drawings.

How to create a texture colour

1. From the Colour View  menu, select Colours > New Texture or click the New Texture  button.

The Browser window opens.

2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.

Refer to the Editing Gradients and Textures  on page 181 topic to learn how to reposition your textured 
zones in your drawings.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool 
instead of plaid, just update the texture file in the swatch and the entire project updates. Any 
transformation previously applied to the texture’s position in your drawings will be kept.
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How to replace a texture swatch

1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

2. From the Colour View  menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

3. Browse for the new PSD or TGA bitmap file created in a third party software.

4. Click Open to update the colour swatch.

How to delete a colour swatch

1. In the Colour view, select the colour swatches to delete.

2. Do one of the following:

‣ From the Colour View menu, select Colours > Delete.

‣ Click the Delete Colour  button. 

‣ Right-click and select Delete.

‣ Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.
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3. Click OK to delete the colours or click Cancel to abort the operation.

‣ If you delete colour swatches already in use, the zones painted with them turn red so you 
can easily identify them.

Colour Display Modes 
The Colour view has two display modes:

• List

• Swatch

You can alsodisplay the RGB values and names of your solid colour swatches instead of only the name. 
This option is not available when displaying the colours in Swatch mode.

How to switch between the display modes

1. From the Colour View menu, and do one of the following: 

‣ Select Colours > Swatch Mode to display the swatches.

‣ Deselect Colours > Swatch Mode to display the colour list.
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How to display the swatch colour values

‣ From the Colour View menu, select Palettes > Display Colour Values.   

The solid colour swatches’ RGB values will be displayed between the colour swatch and its name. 
The gradient colour swatches will be identified as (gradient).

Copying and Pasting Colours 
When you are creating palettes, you may want to copy colour swatches or their values and paste them 
in other palettes to save time. You can also quickly copy a colour value from a palette in your scene to 
a selected colour swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, 
it is impossible to use the Paste as Clone command in the same palette as you copied the original 
colour swatch from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can 
copy the colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

How to copy and paste colours

1. In the Colour view, select one or more colours to copy.

2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac 
OS X).

3. In the Palette list, select the palette in which you want to paste the colours.

4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V 
(Windows/Linux) or ⌘  + V (Mac OS X).

‣ To paste the colour values of the copied swatch over an existing colour swatch, select 
Colours > Paste Colour Values.
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How to clone a colour swatch

1. In the Colour view, select the colour swatch you want to clone.

2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X).

3. In the Colour view, select the colour palette you want to paste the clone into or create a new 
palette.

4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

1. In the Colour view, select the colour swatch you want toget the ID from.

2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) 
or ⌘  + C (Mac OS X).

3. Paste the copied value as plain text in the desired document.

Mixing Colours
If you want to modify a series of colours at once to blend a tint in them or offset their RGBA values, you 
can use the Tint panel. This panel is quite useful when creating palette styles such as night and day 
styles.

How to mix colours

1. In the Colour view, select the palette that contains the colours you want to offset or blend.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Tint Panel. 

‣ Right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A 
(Windows/Linux) or ⌘  + A (Mac OS X).

4. Select Preview option.

5. Select the Offset, Blend, or Mix option.

Parameter Description

Offset
Offsets the selected colours by the adjustments made using 
the HSB and RGB sliders. Use the Amount slider to adjust the 
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degree of offset. Use the Alpha slider to adjust the opacity of 
the selected colour. 

Blend

Blends the selected colours with the colour swatch in the top-right 
corner. Use the Amount slider to adjust the degree of blend. A blend of 
100% turns the selected colours into the same colour as the swatch. 
Adjusting the HSB and RGB sliders affect the swatch colour, which in 
turn affects the selected colours on the left. Use the Alpha slider to 
adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. 
Use the slider just beneath to mix the Base and Tint colours 
by different amounts. This will affect the mixed swatch 
whether it is selected or not. Select either the Tint or Base 
swatch and use the HSB and RGB sliders to adjust its colour. 
This will affect the mixed swatch colour, which in turn affects 
the selected colours on the left.

6. Click Apply.
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Painting the Model

Now that you have created the colours and the palette, you are ready to paint your model.

The colour model needs to be painted in order to adjust the colours with the other elements in the 
production. You can paint your model regardless of the colour RGBA and adjust them later when all 
the elements are together.

Once your palette is created and your model is painted, you can import a key background and other 
characters using the Import Drawings option or the Library to compare and adjust the palettes—see 
Importing Models on page 177 to learn how to import your background file.

For paperless and cut-out animation, it is a good idea to provide a line-up template with the colour 
model to show the scale ratio between the characters, props and backgrounds. 

Once your colour model is completed, create a line-up template by pasting one of the production's 
main characters, or even just a hand, beside the colour model to show the relative size. This allows the 
animator, layout artist, or scene setup artist to retain the correct scaling throughout the entire project 
when setting the elements in the scene. You can store your template in the Library.

How to paint a colour model

1. From the Drawing or Camera View  menu, select View > Switch to Colour Art/Switch to Line Art 
or press L.
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2. Create your master colour palette—see Creating a Colour Palette  on page 124

3. Add new colours to the palette—see Adding a Colour Swatch  on page 137.

4. Select your Paint Bucket  tool. We recommend the Paint Unpainted  tool.

5. In the Colour view, select the colour you need to paint your drawing.

6. Paint the model by selecting colour swatches in the palette and clicking on your drawing. Note that 
only closed zones will be painted. If there is a gap in your artwork, you will need to close it in order 
to paint it.

7. If you would like to separate your lines and fill zones on separated art layers, see Art Layers on 
page 162.

8. Adjust the colours—see Mixing Colours on page 145.
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Sharing the Colour Model

When your colour models are prepared and have been organized in a colour model scene, it is time to 
share them. However, since the Harmony scenes are local, the palettes cannot be shared with other 
scenes. You must prepare templates from the models and store them in the Library.

The Library is a central repository for all the data which will be reused throughout the production. It 
can be accessed from any  Harmony scene; if multiple users are connected to the same network, all 
machines can access a central library. These models can be shared among all the users to ensure that 
everybody has the same set of colours and references.

A template is a set of elements created from a Harmony scene that can be imported into other scenes. 
It can contain drawings, palettes, and any other elements available in Harmony. 

A colour model template is very simple to make. When a drawing is stored in the Library, the 
corresponding palette is attached to it. This means that whenever the colour model is imported from 
the Library into the scene, the palette is also imported. To learn more about libraries and templates—
see the Harmony Cut-Out Animation Guide.

It is recommended that you add a colour model subfolder to your library.

There are two ways to create In the Timeline view, you can create a template by selecting the drawing 
element's module. This contains all drawings from the drawing element, palettes, and exposure. A 
template that has been created by selecting the drawing exposure contains the selected drawings, 
their exposures, and the palettes.

How to create a template from the Timeline view

1. In the Library, select a folder to store the template. Right-click and select Right to Modify.

2. From the Timeline view, select the drawings, pegs, effects,  keyframes, sounds, exposures, and 
modules, and  drag them to the Library's folder. Anything that is available in the Timeline view can 
be stored as a template.

The Rename window opens.

3. Type in a name for the template and click OK.
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There is no need to save the library. Everything is automatically stored and saved as soon as it is 
pasted in the library.
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Chapter 5: Ink and Paint

When traditional animation is traced, cleaned up, scanned in and properly exposed, it is time for the 
ink and paint process. This consists of cleaning all dirt and hair (for example, dust that was in the 
scanner, dots that do not belong in the drawing, extra floating artwork around the drawing that must 
be removed), painting the lines and filling the colours in the empty zones on an entire animation 
sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt 
to clean, only painting and inking. 

For cut-out animation, once the character builder paints the pieces, there is no more ink and paint 
process because the same parts are always reused and moved around. The ink and paint process 
applies only to traditional and paperless animation workflows.

Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-
based, the colour zones are completely filled and there are no scattered spots left blank. Also, there 
are some actions that can be applied on an entire animation sequence at once, like dirt removal, some 
colour filling, line repainting, and so on.

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by 
assigning a set of colours to each character, prop or effect. The colour styling artist will create a new 
palette and add a new colour for each zone of the character, such as the skin, hair, tongue, shirt, 
pants, and so on. Each colour is known as a colour swatch—see Working with Palettes on page 119. 

  

When a zone on the character is painted with the colour contained in a colour swatch, a link is 
automatically created between that colour swatch and the zone. This means that if the tint of the 
colour in the colour swatch is changed, any zone linked to it will update to the new tint. This is one way 
that colour palettes can save time and money in your production. 
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Another advantage of this system is that you can create complete palettes for different lighting 
situations. For instance, in addition to the regular palette for a character, you could have one for that 
character in the rain using colours that are duller and less vibrant than the dry daytime colours, or yet 
another for using in a night scene. Using palettes linked to your character in this way allows you to 
instantly change its colouring to suit the mood and atmosphere of the scene without tediously 
repainting each element.

The ink and paint process is divided into the following steps:

• Preparation on the facing page

• Dirt Clean Up on page 159

• Art Layers on page 162

• Creating Strokes  on page 168

• Painting on page 170

• Inking the Lines on page 190

• Verifying the Zones are Painted on page 195

• Ink and Paint Tool Properties on page 198
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Preparation

The optimal workspace for creating colour models and inking/painting in traditional animation 
includes the following views:

• Xsheet

• Camera

• Drawing

• Colour

• Model

As there is no default workspace for these tasks you will need to create a custom workspace for 
yourself—refer to the Fundamentals Guide.

You may have a character or element palette that has colours that are very similar to the Drawing and 
Camera view's background colour. For example, a white eyeball colour on a white background which 
makes it difficult to know if the zone was painted. You can change the background colour of the 
Camera or Drawing view in the Preferences dialog box.
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How to change a view's background colour

1. Do one of the following:

‣ From the top menu, select Edit > Preferences.

‣ Mac OS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

2. Select the General tab.

3. In the Colours section, click Edit Colours.

The Colours dialog box opens.
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4. Select the Camera or Drawing tab.

5. Change the background colour of: 

‣ Camera View: Click the Clear colour swatch.

‣ Drawing View: Click the Background colour swatch.
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The Select Colour dialog box opens.

6. Select a colour by clicking a colour swatch, clicking a colour in the colour gradient, or entering a 
HSV/RGB Value.

7. Click OK in the three opened dialog boxes to apply your changes.

When you need to paint drawings with similar colours throughout the palette, you can 
create a clone of that palette and change all the colours to very bright tints to facilitate 
the paint process—see .
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Dirt Clean Up

When paper drawings are passed through a scanner, there can be some hair and dirt scattered across 
them. These lines and dots need to be cleaned. Harmony provides different tools to help get rid of 
them quickly.

The Remove Dirt tool selects small dots and hairs on the drawing. Raising the Remove Dirt level will 
select bigger dots. When selecting larger dots, be careful not to lose small details like pupils and 
nostrils. Once you have chosen the level, you can apply it to the current drawing or the entire 
animation sequence. This is a quick way to get rid of most dirt and dust.

During this process, the dirt that will be removed is highlighted in red.

The Remove Art Outside Selection option lets you remove any art existing outside a selection. It is 
recommended that you clean your Colour Art level as well. If you have a stroke accumulation in your 
Colour Art, it can result in large output files, especially if you work in high-definition resolutions.
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If there are some marks that cannot be removed with the automated tools, you can erase them with 
the Eraser tool or select them with the Select tool and then delete them. It is always safer to select and 
delete them than to erase them, so you do not overlook anything.

How to use the Remove Dirt tool

1. Do one of the following:

‣ From the top menu, select Drawing > Clean Up > Remove Dirt.

‣ From the Camera or Drawing View  menu, select Drawing > Clean Up > Remove Dirt.

‣ Press Shift + D.

2. Increase the Remove Dirt value by moving the slider to the right.

3. Enable the Apply to All Drawings if you want to operation to be apply to all drawings in the layer.

How to clean dirt with Remove Art Outside Selection

1. In the Tools toolbar, select the  Select  tool.

2. In the Tool Properties view, enable the Permanent Selection option.

3. Draw a selection around the animation making sure to include the entire animation sequence.
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4. In the Camera or Drawing View  menu, select Drawing > Clean Up and one of the following 
options:

‣ Remove Art Outside Selection to delete artwork outside your selection on a single 
drawing.

‣ Remove Art Outside Selection on All Drawings to delete artwork outside your selection 
on all the drawings.

The art outside the selection is removed.

How to access the Eraser tool

‣ From the Tools toolbar, click the Eraser button.

‣ From the top menu, select Drawing > Drawing Tools > Eraser.

‣ From the Camera or Drawing View menu, select Drawing Tools > Eraser.

‣ Press Alt + E.

How to access the Select tool

‣ From the Tools toolbar, click the Select button.

‣ From the top menu, select Drawing > Drawing Tools > Select.

‣ From the Camera or Drawing View menu, select Drawing Tools > Select.

‣ Press Alt + S.
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Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For 
example, you can separate the outline and colour fill on two art layers, similar to 1950s traditional cell 
animation. These art layers are contained within a single drawing as opposed to the timeline layers or 
Xsheet columns where individual drawings with individual timing are stacked one on top of the other—
see Creating Strokes  on page 168. 

Toon Boom Harmony drawings include four art layers. 

• Overlay on the facing page

• Line Art on page 164

• Colour Art on page 164

• Underlay on page 165

You can access the art layers through the Art Layer toolbar. By default, only the Line Art and Colour 
Art are displayed. You need to enable the Support Overlay and Underlay Arts option in the 
Preferences dialog box.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and 
facilitate creation and revision.
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Overlay

The Overlay layer can serve multiple purposes:

• Highlights and tones

• Annotations and corrections

• Sketching

You can also draw in the Overlay layer as it is a regular layer.
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Line Art

In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The 
outline is drawn in the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn 
in the Line Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are 
generated from Line Art to contain the painted area.

When you are doing rough animation, you may want to send a clip to somebody for feedback or 
approval before carrying on with your work. If you have several characters in your project that are 
overlapping, it may be difficult to understand what is going on as you can see through the 
characters. Toon Boom Harmony can generate a matte automatically in the Underlay, or even in the 
Colour Art layer, and fill all the zones inside your characters making them opaque. This process is 
fast and easy and allows you to send easy-to-understand movies.
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Underlay

The Underlay layer can serve multiple purposes. It is frequently used by animators to sketch rough 
animation or generate a matte colour when doing line testing.

How to enable the Support Overlay and Underlay Arts option

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( Mac 
OS X ).

2. In the Preferences dialog box, select the Advanced tab.

3. In the Advanced Options section, select the Support Overlay and Underlay Arts option.

4. Click OK.

How to switch between drawing layers

1. In the  Art Layer toolbar, click the Line Art   or Colour Art    buttons. When switching art layer, 
it will allow you to edit the select layer without affecting the other one.

2. Click the Preview All Enabled Art Layers   button to display both layers together. Even when the 
Preview mode is enabled, you will only be able to edit the select art layer. The other ones are only 
displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You 
will only be able to see the select art layer by itself if you enable the Current Drawing on Top  
option located in the Camera bottom toolbar.

To edit both Line Art and Colour Art at the same time, you must enable the Apply to 
Line Art and Colour Art  button in the Tool Properties of the tools supporting the 
operation.

How to switch between the drawing layers in Advanced Art mode

1. In the  Art Layer toolbar, click the Overlay Art , Line Art , Colour Art  or Underlay Art  
buttons to display the appropriate layer—see How to enable the Support Overlay and Underlay 
Arts option above. When switching art layer, it will allow you to edit the select layer without 
affecting the other one.
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2. Click the Preview All Enabled Art Layers  button to display all the layers together. The other 
ones are only displayed as a reference. By default, the Preview mode is always enabled in the 
Camera view. You will only be able to see the select art layer by itself if you enable the Current 
Drawing on Top  option located in the Camera bottom toolbar.

How to generate a matte

1. Do one of the following:

‣ In the Tools toolbar, select the Select  tool.

‣ Press Alt + S.

2. In the Camera or Drawing view, select the drawing you want to create a matte for. 

You can also apply the operation to all the drawings in the layer at the same time.

3. Do one of the following:

‣ From the top menu, select Drawing > Generate Auto-Matte. 

‣ In the Camera or Drawing view menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, select the Apply to 
Multiple Drawings option.

5. Depending on how precise or rough your line is, increase or decrease the radius value. The lower 
the value is, the closer to your lines’ contours the matte will be shaped. The higher the value is, the 
looser the matte will be shaped.
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6. In the Source Art menu, select the layer from which you want the matte created: Line Art, Colour 
Art, Underlay or Overlay.

7. In the Destination Art menu, select the layer you want the matte to be created on: Line Art, Colour 
Art, Underlay or Overlay.

8. If you already have artwork on the destination layer and you want the content to be deleted before 
the matte is added into it, select the Clear Destination Art First option.

9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case 
you ever need to keep them for later), select the Copy Stroke in Destination option.

10. Click OK.
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Creating Strokes 

A  drawing is composed of Line and Colour filling layers. Lines and colours can be separated or kept 
together, depending on which animation process you use. The following diagram presents Line Art 
and Colour Art recommendations based on the selected animation workflow.

When a traditional drawing is scanned, strokes are automatically created in the Colour Art from the 
Line Art when drawings are vectorized unless you specified otherwise.

When working with Cut-out animation, we recommend that you do all of the work in the Line Art. 

Once the drawing sequence is completed for paperless drawings, you can proceed with creating 
Colour Art strokes if you plan to paint the animation in the Colour Art. Use the Create Colour Art from 
Line Art option to create strokes from your lines.

You can create strokes in the Colour Art during the following stages:

• After the full drawing is completed in Line Art

• While drawing in Line Art

You may have some traditional drawings that need to be fixed; for example, needing extra lines to 
patch gaps. Use the Auto-Create Colour Art from Brush option to create the strokes at the same time 
as the lines are drawn. This creates strokes from the lines and brush strokes created in the Line Art 
while you draw and is useful for fixing drawings. However, if you are drawing a new sketch, it is better 
to create the strokes afterward using the Create Colour Art from Line Art option.

How to create Colour Art zones out of the Line Art content

1. In the Tools toolbar, select the Select  tool or press Alt + S.

2. In the Tool Properties view, enable the Permanent Selection  option if you want to apply the 
operation on all drawings in the layer.

3. In the Camera or Drawing view, select the artwork to transfer to the Colour Art. Create a selection 
around the entire animation sequence if you want to apply the operation to all your drawings.
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4. In the Drawing View toolbar, click the Create Colour Art from Line Art  button or press *.

How to create strokes with the Auto-Create Colour Art From Brush option

1. From the Camera or Drawing View  menu,  select Drawing >Auto-Create Colour Art from Brush 
or press [Shift]+[F2].

2. Draw the required lines. 

3. Once you are done, deselect the Auto-Create Colour Art from Brush option. You are now ready 
to paint your model.
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Painting

You can choose to paint your animation in the Line Art or Colour Art level. You can paint in Line Art, 
but for traditional and paperless animation, you should fill your colour zones in Colour Art. You can 
access the art layers through the Art Layer toolbar—see Art Layers on page 162.

There are many advantages to separating the lines and colour zones, but the main one concerns the 
painting process. To paint very quickly, it is useful to not worry about painting over the lines. If the 
lines are separated, you can fill the zones very quickly and you will never accidentally paint the lines. 
Conversely, if you are inking the lines, you will not repaint the colour zones either.

If you have transparent lines, bitmap lines or textured lines with transparency, it is better to have your 
colour zones bleeding under your lines to avoid seeing the backgrounds and other elements through 
the lines.

To avoid painting in Line Art by mistake, turn off the Preview  mode and paint in the Drawing view rater 
than the Camera view. Press P to turn the mode on or off. 

This section is divided as follows:

• Painting Using the Paint Tool on the facing page

• Advanced Painting Features on page 172

• Selecting a Colour in a Drawing  on page 176

• Importing Models on page 177

• Editing Gradients and Textures  on page 181

• Closing Gaps on page 186

• Protecting Colours  on page 188

• Highlighting the Selected Colour  on page 188

• Inverting a Colour Selection on page 189
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Painting Using the Paint Tool

The main tool you will use to paint your drawings with is the Paint  tool. The Paint tool can be used in 
several different modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the 
lines defining a zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic 
Close Gap option.

How to paint with the Paint tool

1. In the Timeline or Xsheet view, select the cell on which you want to paint.

2. Do one of the following:

‣ In the Tools toolbar, click the Paint  tool.

‣ Press Alt + I. 

3. In the Colour view, select a colour.

4. In the  Drawing or Camera view, start painting. You can click on a zone or pencil line to paint it, or 
you can trace a lasso or marquee selection to paint several zones or pencil lines at once.

The last colour you select while using the Paint tool will be remembered the next time you select the Paint 
tool if you are using the unlocked painting tools in the Colour view.
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Advanced Painting Features
The following advanced painting features are available in Toon Boom Harmony and are described in 
this section:

• Repaint Selection 

• Repaint Selection On All Drawings 

• Repaint Outside Selection   

• Repaint Outside Selection On All Drawings 

• Unpaint Selection 

• Unpaint Selection On All Drawings 

• Unpaint Outside Selection 

• Unpaint Outside Selection On All Drawings

The Repaint Selection command is used to repaint any art inside a selection. You must first draw a 
selection using the Select  tool in order for this command to be available.

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the 
drawings contained within the same layer. You must enable the Permanent Selection  option in the 
Select tool Tool Properties view and then select an area of your drawing using the Select  tool in order 
for this command to be available. The Permanent Selection option lets you maintain the same 
selection throughout the drawings of a same layer.
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The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection 
has been drawn using the Select   tool, the entire drawing will be repainted.

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection 
on all the drawings contained within the same layer. You must enable the Permanent Selection  
option in the Select tool Tool Properties view and then select an area of your drawing using the Select  
tool in order for this command to be available. The Permanent Selection option lets you maintain the 
same selection throughout the drawings of a same layer.

The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first 
draw a selection using the Select  tool in order for this command to be available.

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection 
on all the drawings within the same layer. 
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You must enable the Permanent Selection  option in the Select tool Tool Properties view and then 
select an area of your drawing using the Select  tool in order for this command to be available. The 
Permanent Selection option lets you maintain the same selection throughout the drawings of a same 
layer.

The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no 
selection have been drawn using the Select  tool, the entire drawing will be unpainted.

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection 
on all the drawings within the same layer. You must enable the Permanent Selection  option in the 
Select tool Tool Properties view and then select an area of your drawing using the Select  tool in order 
for this command to be available. The Permanent Selection option lets you maintain the same 
selection throughout the drawings of a same layer.

How to access the Repaint Selection command

‣ From the top menu, select Drawing > Paint > Repaint Selection.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Repaint Selection. 

How to access the Repaint Selection On All Drawings command

‣ From the top menu, select Drawing > Paint > Repaint Selection On All Drawings.
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‣ From the Camera or Drawing view menu, select Drawing > Paint > Repaint Selection On 
All Drawings. 

How to access the Repaint Outside Selection command

‣ From the top menu, select Drawing > Paint > Repaint Outside Selection.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Repaint Outside 
Selection. 

How to access the Repaint Outside Selection on All Drawings command

‣ From the top menu, select Drawing > Paint > Repaint Outside Selection on All Drawings.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Repaint Outside 
Selection on All Drawings. 

How to access the Unpaint Selection command:

‣ From the top menu, select Drawing > Paint > Unpaint Selection.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Selection. 

How to access the Unpaint Selection On All Drawings command:

‣ From the top menu, select Drawing > Paint > Unpaint Selection On All Drawings.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Selection On 
All Drawings. 

How to access the Unpaint Selection command

‣ From the top menu, select Drawing > Paint > Unpaint Outside Selection.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Outside 
Selection. 

How to use the Unpaint Outside Selection On All Drawings command

‣ From the top menu, select Drawing > Paint > Unpaint Outside Selection On All 
Drawings.

‣ From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Outside 
Selection On All Drawings. 
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Selecting a Colour in a Drawing 

While working in your Camera  or Drawing view, you can use the Dropper  tool to pick a colour from 
your drawing without going to the Colour view. 

How to use the Dropper tool

1. Do one of the following:

‣ In the Tools toolbar, select the Dropper  tool.

‣ From the top menu, select Drawing > Drawing Tools > Dropper.

‣ Press Alt + D. 

2. In the Camera or Drawing view, click on the desired colour.

‣ If you are using another drawing tool such as the Paint tool, you can temporarily hold down 
the D key and click in your drawing before releasing the key to pick your colour. When you 
release the key, Toon Boom Harmony will return to your previous tool. You may also want 
to select the zones painted with the colour currently selected in the Colour view. This can be 
useful for removing rough lines from a clean drawing.

How to select the zones painted with the current colour

1. In the Colour view, select the colour you want to select the corresponding zones from.

2. Do one of the following:

‣ Select Drawing > Select Strokes with Current Colour. 

‣ Press Ctrl + Shift + A (Windows/Linux) or ⌘  + Shift + A (Mac OS X).
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Importing Models

Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. 
That drawing can be used and loaded in any of your Harmony scenes. 

Once a drawing is loaded in the Model view, you can use the Dropper  to select a colour from the 
model and use it to paint in your Camera or Drawing view without having to pick the colour from the 
colour palette.

You can do more than just copy colours from a colour model. Harmony gives you the ability to copy 
parts of the character directly from its colour model and paste these elements into the Drawing or 
Camera views.

How to load a colour model from the Timeline or Xsheet view

1. In the Timeline or Xsheet view, select a drawing (*.tvg).

2. Bring the model into the Model view by doing one of the following:

‣ In the Timeline view, drag the selected drawing and drop it directly in the Model view.

‣ From the Model View menu, select Use Current Drawing as Model. 

‣ In the Model View toolbar’s extra buttons, click Current Drawing  button.

The model appears in the Model view.

How to browse for a colour model drawing on your hard drive

1. Do one of the following: 

‣ From the Model View menu, select Import Model. 

‣ Click the Import Model  button or from the Model View’s toolbar.

‣ Select File > Import > Colour Model.

2. In the Browser window, browse for any *.tvg drawing file on your hard drive.

3. Click Open. 
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The model appears in the Model view.

How to load the default models

1. In your scene’s folder, create a new folder and name it models.

2. On your hard drive copy the *.tvg drawing file you want to use as colour models in your scene.

3. Do one of the following:

‣ From the Model View menu, select Load Default Model. 

‣ In the Model View toolbar’s extra buttons, click the Load Default Model  button .

How to load a single drawing from the Library view

1. In the Library view, click the template containing the drawing to import in the Model view.

2. Right-click on the template and select Open As Folder.

3. In the Library view’s left side, select the template’s folder and continuing expanding its subfolders 
until *.tvg files appear on the right side.

4. In the Library view’s right side, select the TVG drawing to import and drag it into the Model view.

How to load a template with multiple drawings from the Library view

1. In the Library view, find the template you want to import in the Model view.

2. In the Library view’s right side, drag the template (*.tpl file) and drop it directly in the Model view.

3. Use the Previous Model   and Next Model  buttons in the Model view’s toolbar to view all 
the drawings contained in the template. This can often be the front, profile, and 3/4 views of a 
character.
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How to load a symbol from the Library view

1. In the Library view’s left side, select the Symbols folder.

2. In the Library view’s right side, select the symbol that you want to use as a model, and drag and 
drop it directly into the Model view.

3. Use the Previous Model  and Next Model  buttons in the Model view’s toolbar to view all the 
drawings contained in the template. This can often be the front, profile, and 3/4 views of a 
character.

How to clear a colour model

‣ In the Model View menu, select Clear Model or press Delete.

How to copy the entire model from the Model view

1. In the Model view’s toolbar, select the Select  tool.

2. In the Model view, select your model.

179



Chapter 5: Ink and Paint     Importing Models

3. From the top menu, select Edit > Copy Drawing Object or press Ctrl + C (Windows/Linux) or ⌘  + 
C (Mac OS X).

4. In the Timeline view, make sure that you have the correct layer and frame selected.

5. Select either the Drawing or Camera view then go to the top menu and select Edit > Paste 
Drawing Object, or select the Timeline view and from the top men select Edit > Paste cells in the 
Timeline or pressCtrl + V (Windows/Linux) or ⌘  + V (Mac OS X). 

The model now appears in the selected view.

How to copy part of the model from the Model view

1. In the Model view’s toolbar, select the Cutter  tool or press Alt + T.

2. In the Model view, use the Cutter tool to create a selection around the part of your model that you 
want to copy.

3. From the top menu, select Edit > Copy Drawing Object or press Ctrl + C (Windows/Linux) or ⌘  + 
C (Mac OS X).

4. In the Timeline view, make sure you have the correct layer and frame selected.

5. Do one of the following:

‣ Select the Drawing or Camera view and select Edit > Paste Drawing Object. 

‣ Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V 
(Windows/Linux) or ⌘  + V (Mac OS X). 

The model appears in the selected view.
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Editing Gradients and Textures 

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to 
modify its position in the zone. You can move, scale, rotate and skew. If you want to match the colour 
to the animation, set the first texture position and copy the Edit Gradient/Texture position. When 
moving to the next drawing, you can select the next texture and paste the previous position to 
continue the modifications.

If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your 
gradient’s position, angle and scale settings instead of the default ones, you can store your own 
settings and reuse them afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn 
with textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and 
then edit both elements independently at the same time.

How to use Edit Gradient/Texture tool

1. Do one of the following: 

‣ In the Tools toolbar, click the Edit Texture  tool.

‣ From the  Camera or Drawing View  menu, select Drawing Tools > Edit Gradient/Texture

‣ Press Shift + F3.

2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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3. Edit the gradient or texture by adjusting the control handles around the selection frame.

How to store your gradient and texture settings

1. In the Tools toolbar, select the Select  tool or press Alt + S.

2. In the Camera or Drawing view, select the gradient or texture zone to store.

3. In the Tool Properties view, click the Store Colour Gradient  button.

How to use the stored gradient and texture settings

1. In the Tools toolbar, select the Brush  or Paint  tool.

2. In the Tool Properties view, click the Use Stored Colour Gradient  button.

3. In the Camera or Drawing view, draw and paint.

How to use Pencil Editor tool to edit the texture or gradient on a pencil line

1. Do one of the following:

‣ In the Tools toolbar, select the Pencil Editor  tool. 

‣ From the top menu, Drawing > Drawing Tools > Pencil Editor.

‣ Press Alt + W.

2. Click on the pencil line to be modified to bring up its contour envelope.
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3. Select one of the contour points around the envelope and move its position to change the size of 
the tiled texture or gradient. You can also pull directly on the lines of the contour envelope or play 
with the Bezier handles of any given point in order to continue to modify the envelope form.

Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled 
texture to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to 
look squashed.

Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the 
number of tiles, while expanding it will increase the number of tiled images. 

This editing technique does not just work on texture fills, but can also be applied to pencil lines 
drawn with a textured “brush”.

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line

1. In the Tools toolbar, select the Edit Gradient/Texture  tool. You can also select this tool from 
the top menu under Drawing > Tools > Edit Gradient/Texture or press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.
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3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull 
on the top of the editor controls to stretch the tiled texture throughout the length of the stroke. 

As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is 
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or 
gradient.

 

4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central 
vector line. This is another way to resize the texture tile. Instead of stretching or shrinking it 
vertically, this motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s 
central vector, stretching them vertically gives no visual result.
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How to use Edit Gradient/Texture tool to edit both the texture and the gradient of a 
pencil line

1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, Drawing > Drawing Tools > Edit Gradient/Texture.

‣ Press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.

3. Use the top editor controls edit the gradient.

4. Use the bottom controls edit the “brush” texture.
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Closing Gaps

When painting, you may notice that some drawing areas are not closed. To close the zone, you can 
either draw the missing line with the Brush or Pencil tool, or close the gap with an invisible line using 
the Close Gap tool. 

The Close Gap tool lets you close small gaps in a drawing by creating small, invisible strokes between 
the two closest points to close the colour zone. You do not need to trace directly over the gap. You 
can draw it a few millimeters away. The two closest points automatically close the gap.

How to close gaps

1. From the top menu, select View > Show > Show Strokes or press K to see a preview of the result.

2. Enable the Auto-Flatten  option in the Tool Properties view if you want the strokes you draw to 
be flattened in your drawing instead of being on top. 

3. From the top menu, select Drawing > Clean Up > Close Gaps or pressShift + F10 (Windows/Linux 
only).

The Close Gaps dialog box opens.

4. Adjust the slider to set the size of the gap you want to be closed.

5. To close all gaps in the drawings of the selected layer, select the Apply to all drawings option and 
click OK.

6. In the Tools toolbar, select the Close Gaps tool.

7. In the Camera or Drawing view, trace a line near the gap to be closed. Your strokes will be invisible

The gap automatically closes.
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Protecting Colours 

When you are finished painting some zones, you can protect the colour swatch they are associated 
with, so the work cannot be accidentally painted over. 

When you are done inking one colour, you can lock it so that if you ever paint over it accidentally, the 
work already done will not be affected. You can also use the Protect Colour feature to block the filling 
colours if you painted all of the animation in Line Art and you plan to repaint the lines.

How to protect colours

1. In the Colour view, select the colour to be protected.

2. Do one of the following:

‣ Right-click and select Protect Colour.

‣ From the Colour view menu, select Colours > Protect Colour. 

A red bar appears beside the colour to indicate that it is locked.

Respecting Protected Colours 
When painting, the Respect Protected Colour option is enabled by default. In the Colour view, you 
can protect a colour swatch to avoid repainting or unpainting the zones linked to that swatch. If you 
disable this option, the Paint tool will not follow the protect colour rule and you will repaint or unpaint 
the protected colours on your drawings until you enable the option again.

How to toggle the Respect Protected Colours option

Do one of the following:

‣ Paint tool properties, click the Respect Protected Colour button.

‣ From the top menu, select Drawing > Colour Protection > Respect Colour Protection.

‣ Press Shift + S.

Highlighting the Selected Colour 
The Highlight Selected Colour option is used to identify colour swatch used in a drawing. For example, 
if you have unnamed colours in your palette and want to know if a particular colour was used on the 
current model or drawing, you can select the colour and use the Highlight Selected Colour option. 
Harmony will dim all the colours in the drawing except the selected one, so it stands out and can be 
identified. You can rename it accordingly.
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How to use the Highlight Selected Colour option

1. In the Colour view, select the colour you want to highlight.

2. From the Camera or Drawing menu, select View > Show > Highlight Selected Colour.

Inverting a Colour Selection
When you need to select all colour swatches but one, or select only a few swatches here and there,  it 
might be faster to select the only colour you do not need, in order to select and invert the selection.

How to invert a colour swatch selection in the Colour view

1. In the Colour view, select the colour swatch you DO NOT want to have in your final selection.

2. Do one of the following:

‣ From the Camera or Drawing View menu, select Edit > Invert Selection

‣ Press Ctrl + Shift + I (Windows/Linux) or ⌘  + Shift + I (Mac OS X).

189



Chapter 5: Ink and Paint     Inking the Lines

Inking the Lines

Some animation styles require you to paint the lines, a process also be called inking. To ink your lines, 
you must be in Line Art mode. You can repaint any type of lines including the texture lines—see Art 
Layers on page 162.

Unless you are repainting all of the lines on the whole animation sequence, do not use the Apply Tool 
to All Drawings option. Since the line positions change a lot over time, you risk painting lines that are 
not supposed to be painted.

These are the main tools used to ink the lines:

• Repaint Tool

• Repaint Brush Tool

• Ink Tool

• Protecting Colours

• Breaking Triangles

The main tool used to ink the lines is the Repaint tool. As the colour filling is probably done in the 
Colour Art, you will not have to worry about not touching it. The Repaint tool will not paint empty 
zones either.

During the vectorization process on traditional scanned drawings, triangles are added on the lines' 
intersections to break the artwork in segments. This way, when you paint a line, it will not repaint the 
whole drawing, only the relevant segment.

 

The Repaint Brush tool is used to paint a section by manually painting over the lines. This is useful 
when the vectorization triangles are not placed as you would like or you simply need to repaint a 
section of a segment. It is also useful for paperless animation, where there are no triangles. So, the 
Repaint Brush is used to paint a certain area. It acts like the Brush tool, but will only show on painted 
areas that are already painted. 

Unlike the Brush tool, the Repaint Brush flattens automatically. The brush strokes are not added one 
on top of each other.

When you are done inking one colour, you can lock it so if you ever paint over it accidentally, the work 
already done will not be affected. You can also use the Protect Colour feature to block the filling 
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colours if you painted all of the animation in Line Art and you plan to repaint the lines—see Protecting 
Colours  on page 188.

The Brush tool is often the most intuitive and rapid tool for creating rough sketches and clean lines. A 
single colour, such as black, is often used when tracing a clean version of a rough sketch. However, 
when it comes time to soft trace the lines in different colours, the flattened or unflattened clean brush 
strokes can suddenly become time consuming to ink. 

Toon Boom Harmony lets you create triangular breaks at natural line intersections. These 
intersections are the probable locations where colour line breaks may occur, such as where a sleeve 
meets a hand.

Although pencil lines can be painted in much the same way as closed zones, you can use the Paint, 
Repaint, Repaint Brush, and Ink tools to make painting segmented lines easier. Normally when you 
have a drawing, such as the one below, and you use the Paint tool to paint one of the lines, the entire 
line is painted.

However, if you select the Ink  tool instead and click on the same pencil line, only the segment that 
you clicked on between two intersections will be painted.

The newly inked segment will always be moved to the front of all other pencil strokes, even if it was 
behind all other pencil strokes before it was inked.

That is, unless you hold down Alt while clicking a segment. Then the opposite becomes true. The inked 
segment will be sent to the back, even if it was in front of all other segments to begin with.

191



Chapter 5: Ink and Paint     Inking the Lines

Painting and Inking can be used in combination depending on what it is that you need to paint. If you 
need to ink a character’s outline in black, it might be easier to use the Paint tool. If you need to paint 
the outline of a character’s neck with a tan colour and its shirt outline blue and both the neck and shirt 
belong to the same continuous outline, then the Ink tool might prove more useful.

How to select the Repaint Tool

1. In the Tools toolbar, select the Repaint  tool located in the Paint tool drop-down menu.

How to select the Repaint Brush

1. In the Tools toolbar, select the Brush  tool.

2. In the Tool Properties view, enable the Repaint Brush  mode.

How to select the Ink Tool

1. In the Tools toolbar, select the Ink  tool located in the Paint tool drop-down menu.

How to protect colours

1. In the Colour view, select a colour to lock.

2. Do one of the following:
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‣ Right-click and select Protect Colour.

‣ From the Colour view menu, select Colours > Protect Colour. 

A red bar appears beside the colour to indicate that it is locked.

How to create breaking triangles on a drawing

1. In the  Drawing or Camera view, use the Select tool to select part or all of the drawing to be 
broken.

2. From the top menu, select Drawing > Create Breaking Triangles. If your brush strokes are not 
flattened, they will be flattened automatically before the breaking occurs.

3. Use the Repaint tool  to paint the outline of different colour zones with different colours.
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Verifying the Zones are Painted

When the ink and paint process is completed, it is always a good idea to verify that every zone was 
painted properly.

The first step to check your ink and paint is to go through all  your drawings and verify that there are no 
colour mistakes. You can use the F and G keyboard shortcuts or the Preview option available in the 
Xsheet.

The backlight produces a silhouette effect by changing the drawing’s coloured areas into a single 
dark, solid colour use this to verify the completeness of the ink and paint process. Any unpainted 
zones can be seen as the light shows through the unpainted areas of the silhouetted drawing.

How to preview drawings from the Xsheet

1. First, save your scene. 

2. Do one of the following:

‣ From the top menu, select File> Save. 

‣ Click the Save  button. 

‣ Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

3. In the Xsheet view, select the range of drawings or the whole column to preview.

4. In the Xsheet View  menu, select View > Preview Selected Drawings or press Alt + P.

The Play window opens.
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5. Play your drawings.

6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence 
while looping the playback.

How to use the backlight

This feature is only available in the Drawing view.

1. Do one of the following:

‣ From  the top menu, select View > Backlight.

‣ In the Drawing View toolbar, click the Backlight button.

‣ Press Alt + Shift + B. 

2. Verify the drawings in the Colour Art to make sure that all the areas are painted. From the Camera 
or Drawing View menu , select View > Switch to Colour Art or press L.

3. In the Art Layer toolbar, click the Preview All Art Layers  button  to see the colour zones with 
lines to ensure that you did not forget any spots between the colour filling and lines.
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Ink and Paint Tool Properties

The Ink and Paint tool properties contain many options that will help you along with your task.

• Ink Tool Properties below

• Paint Tool Properties  on the facing page

Ink Tool Properties
When you select the Ink tool, its properties and options appear in the Tool Properties view.

Icon Tool Name Tool

Lasso and Marquee

The Lasso and Marquee options let you 
choose the type of selection the current tool 
will perform. The default selection mode is 
Marquee.

• Lasso  lets you draw a custom selection 
box around zones.

• Marquee  makes a rectangle selection 
box.

Hold down the Alt key to switch 
to the opposite mode of your 
selection.

How to invert a selection

1. Do one of the following:

‣ From the top menu, select Edit > 
Invert Selection. 

‣ From the Camera or Drawing 
menu, select Edit > Invert 
Selection.

‣ Press Ctrl + Shift + I 
(Windows/Linux) or ⌘  + Shift + I 
(Mac OS X). 

Show Inkable Lines

Highlights all pencil lines (no brush strokes) 
on the selected layer. Pencil line segments 
that are already inked with the selected 
swatch colour from the colour palette are 
also not highlighted.
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Be Smart on Con-
necting Lines

As you hover and move the cursor across 
intersecting pencil lines, the path that you 
create will be highlighted. When you click on 
your mouse or stylus the highlighted 
segments are inked.

With this option disabled, all the intersecting 
segments that your cursor comes near will 
be highlighted and become part of the 
selection, even if they were not situated in 
the direction of the chosen path.

Note: This option only works if the Ink tool 
is in Hover mode.

Select Mode

Use this  mode instead of the Hover 
Mode. In the Hover Mode, any potentially 
inkable pencil line will have its central vector 
line highlighted as the Ink tool’s cursor 
hovers over it. Use Ctrl (Windows/Linux) or 
⌘  (Mac OS X) to toggle between the two 
modes.

Select Newly Painted, 
Repainted, Unpainted 
Contours and Lines

Keeps a selection highlighted around the 
latest painted zone after using the Paint, 
Repaint, Unpaint, or Paint Unpainted tool.

Arrange Ink Lines
Brings all newly-inked lines to the front. Disable this 
option if you want all newly-inked lines to be sent to 
the back. Press Alt to toggle between the two options.

Mitre

As you hover over two perpendicular or 
nearly perpendicular segments, a 
highlighted path with a corner is created. 
Clicking on these highlighted segments inks 
both segments and makes them appear as a 
single stroke with a corner or bend.

Click the Mitre    button to choose from 
As is, Round, Mitre, and Bevel. 

Tip Style

Lets you customize the  edge of the Ink tool. 
Options include: Round, Flat, and Bevel.

Paint Tool Properties 
When you select the Paint tool, its properties and options appears in the Tools Properties view.
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Icon Tool

Lasso and Marquee  below

Painting Modes  below

Paint and Remove Texture  on page 202

Apply to Multiple Drawings  on page 202

Apply to All Visible Drawings  on page 203Apply to All Visible 
Drawings  on page 203

Respect Protected Colour  on page 203

Use Stored Colour Gradient  on page 204

Select Newly Painted/Repainted/Unpainted Contours/Lines on 
page 204

Automatic Close Gap  on page 204

Lasso and Marquee 

The Lasso and Marquee options let you choose the type of selection the current tool will perform. The 
default selection mode is Marquee.

• Lasso  lets you draw a custom selection box around zones.

• Marquee  makes a rectangle selection box.

Hold down the Alt key to switch to the opposite mode of your selection.

How to invert a selection

1. Do one of the following:

‣ From the top menu, select Edit > Invert Selection. 

‣ From the Camera or Drawing menu, select Edit > Invert Selection.

‣ Press Ctrl + Shift + I (Windows/Linux) or ⌘  + Shift + I (Mac OS X). 

Painting Modes 

The Paint tool has four different modes available:
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You can also find these tools directly in the Tools toolbar and in the Drawing Tools menu.

Paint Mode 

  

The Paint  mode paints everything it touches, including empty and filled zones.

Paint Unpainted Mode 

The Paint Unpainted  mode paints only empty zones. Any line or filled zone will remain unchanged.

 Repaint Mode 

The Repaint  mode paints everything it touches except empty zones. Any zone that is not painted 
will remain intact.
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Unpaint Mode 

The Unpaint  mode unpaints everything it touches, including empty and filled zones.

Paint and Remove Texture 

The Paint and Remove Texture  option is used when you vectorized images as greyscale texture 
style. An image vectorized as texture is a mix of bitmap filling encapsulated in a vector-based frame. 
Painting a textured zones with the Paint tool will change the tint of the textured lines. Painting the 
textured zones using the Paint and Remove Texture option transforms the bitmap filling into a 100% 
vector based zone and fills it with a solid colour.

Apply to Multiple Drawings 
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The Apply to Multiple Drawings  option is used for fast painting in hand-drawn animation. When 
you want to paint several drawings in a same layer at once, such as a walk cycle, you can enable this 
option and make a selection in your Camera or Drawing view. All the closed zones located within your 
Paint tool selection are painted with the selected colour swatch.

You do not need to enable the Onion Skin preview to use this option. The option will stay enabled only 
for the next action. If you want to use it again, you must click on the Apply to Multiple Drawings 
button again, or press Alt + A.

Apply to All Visible Drawings 

The Apply to All Visible Drawings  option is used to paint several drawings on separated layers on 
the current frames. If you have a character broken in several layers, you can enable this option to paint 
all your layers at once. The operation is only applied on the current frame. This option will stay enabled 
only for the next action. If you want to use it again, you must click on the Apply to All Visible Drawings 
button again.

This option is only available in the Camera view and does not affect symbols.

Respect Protected Colour 

The Respect Protected Colour option is enabled by default. In your Colour view, you can protect 
some colour swatches to avoid repainting or unpainting the zones linked to that swatch. 

If you disable this option the Paint tool will not follow the protect colour rule and will repaint or 
unpaint the protected colours on your drawings until you enable the option again—see Protecting 
Colours  on page 188.
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Use Stored Colour Gradient 

When you paint a zone with a gradient or textured colour swatch, the gradient or texture’s position is 
set relative to the size of the zone your are painting. If you want the Paint tool to use a particular size 
and position, you must first store your desired position and size using the Select  tool and then 
enable the Use Stored Colour Gradient   option in the Paint tool Tool Properties view—see Editing 
Gradients and Textures  on page 181.

Select Newly Painted/Repainted/Unpainted Contours/Lines

In the Paint   tool Tool Properties view, enabling this option  will keep a selection highlighted 
around the latest painted zone after using the Paint, Repaint, Unpaint, or Paint Unpainted tool.

Automatic Close Gap 

The Automatic Close Gap option has four modes available:
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The Automatic Close Gap options are used while painting drawings with small gaps. 
Instead of having to close them manually with the Brush tool or Close Gap tool, Toon Boom Harmony 
will analyze the drawing and close the gaps while you paint according to the selected mode. The 
automated gap closing should be done using the zoom function setting of your Camera or Drawing 
view. If your eye does not see the gap, Toon Boom Harmony won’t either—see Closing Gaps on 
page 186.
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Glossary

alpha channel

The image's channel carrying the transparency information. An 
image already has three channels: red, green and blue (RGB). The 
alpha channel is the fourth channel (RGBA). The matte, or the 
transparency information, is stored in this fourth channel. An image 
without an alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The 
storyboard panel is exposed for the duration of the scene and at 
times, the characters are placed on a trajectory to indicate motion. 
The camera moves are also animated. The animatic is used to 
determine the rhythm of a project and provides a good overview of 
the project before beginning production.

animation
A simulation of movement created by displaying a series of pictures 
or frames.

anime
An animation style known for its sinister and dark feel; popular in 
Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically 
unfolds in what storytellers refer to as an arc. The purpose of a 
story arc is to move a character or a situation from one state or 
scenario to the next.

aspect ratio
The relationship between the width and height dimensions for any 
scene, frame or film format. Television ratio is 4:3 and widescreen 
ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which 
multiple drawings are stacked into a sheet feeder. When the 
scanner is activated, the drawings are scanned consecutively, 
without further user intervention.

automatic lip-sync detection
Automatically mapping drawings in an element to the mouth chart 
generated for a sound. This can save time when lip-syncing a voice 
track.

axis

An imaginary line around which an object rotates.

For 2D graphics, there are two axes:

• X: Horizontal

• Y: Vertical

For 3D graphics, there are three axes:

• X: Horizontal

• Y: Vertical

• Z: Depth

background
The part of a scene that is farthest to the rear. The background is 
the artwork, or decor, against which the animation takes place.

Bézier A method of defining curved lines invented by French 
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mathematician Pierre Bézier. A Bézier curve is a mathematical or 
parametric curve. Bézier curves use at least three points to define a 
curve. 

In Toon Boom, a function can be hooked to a Bézier curve and vary 
along with the curve value information. Bézier curves are also very 
useful in vector graphics. They are used to model smooth curves 
and can be scaled indefinitely.

bitmap
An image composed of pixels with a single resolution (size). If it is 
enlarged too much, it will lose definition and pixels will begin to 
appear. This is known as pixelation.

breakdown

In cut-out animation, breakdown is the action of breaking a 
character into pieces to create a puppet with articulations. To 
break down a character, the artist cuts part, such as hands and 
arms, from the character's model and pastes them in separate 
layers. Next, the joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose 
generally found between two key poses. The key poses are the 
main poses in an animation and the breakdowns are secondary 
poses, ones that help to describe the motion and the rotation 
curve.

camera shake
Camera shake occurs in a scene when the camera moves slightly 
and quickly in several directions. This gives the impression of an 
impact, vibration or, for example, bumps on the road.

caption
In a storyboard, a caption is a text field containing dialogue, 
effects, sound, or slugging information.

cel

In traditional animation, a cel, also known as a celluloid, is a 
transparent sheet on which the animation is inked and painted 
before being sent to the camera.The picture's outline is drawn on 
the front of the cel and then coloured along the back. 

In Toon Boom, a cel is an individual space encountered in an 
Xsheet's column, from which you can expose a drawing or a 
function`s coordinate.

character design
Each character in an animated film is drawn from multiple angles in 
poster-style format, called a model sheet, which serves as a 
reference for the animators.

clean up 

After rough drawings have been tested and approved, all the noise 
in the image (excess lines, notes, etc) is removed to create final 
drawings which can be inked, painted and shot. The cleanup 
process refers to either tracing a clean line over a rough drawing to 
achieve the final version, or removing dirt and extra lines left by the 
scanning process.

CMYK
Cyan, Magenta, Yellow, Black. Refers to the process used by 
printers to define colour on the printed page.

colour card
A Colour Card is a solid colour card that is the same size as the 
camera. The Colour Card can be used to fill the background with a 
solid colour when there is no background image included.
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colour model

In animation, a colour model is the official colour design that must 
be used to paint the animation. A model is the definitive character, 
prop, or location design that each artist must follow for the 
production. 

colour wheel A display of the colour spectrum in the form of a circle. 

compositing

Compositing is the action of incorporating all of a scene's elements 
to create the final result prior to rendering. For example, the 
compositing artist will import all the animation sequences, 
background, overlays and underlays in the scene and position them 
correctly. The artist will then set the camera frame and animate it, if 
needed. Finally, the animator will create all the computer-
generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut
A direct transition between two scenes. When a cut is used, there 
are no transition effects inserted to pass from one scene to the 
next. The first scene ends and the second one starts immediately.

cut-out animation
The action of animating characters made of several pieces by 
moving them around frame by frame. Cut-out animation can either 
be computer generated or done traditionally using paper.

cycle
A group of images that together make up an action, such as 
walking. A cycle is an action repeated as a loop over a period of 
time. It can be a series of animated drawings or keyframes. 

dialogue The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to 
track the sequence and timing of images, dialogue, sound effects, 
sound tracks and camera moves. Also known as an exposure sheet 
or Xsheet.

doping To assig a particular drawing to a range of frames.

DPI

Dots Per Inch is the standard measure of resolution for 
computerized printers. It is sometimes applied to screens, in which 
case it should more accurately be referred to as pixels per inch. 
Either way, the dot is the smallest discrete element making up the 
image.

ease/velocity

In animation, the ease, also known as velocity, is the acceleration 
and deceleration of a motion. It can be a motion created by a 
function curve, or a series of animated drawings. Other common 
terms for ease-in and ease-out are slow-in and slow-out.

ease-in
Gradual acceleration in the action. Another common term for ease-
in is slow-in.

ease-out 
Gradual deceleration in the action. Another common term for ease-
out is slow-out.

establishing shot
A scene in which the viewer can see the whole area in which a 
sequence is happening. For example, if a child is playing on the 
ground in front of his house, the establishing shot would be a scene 
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where the viewer can see the house, the ground, a part of the 
street and the buildings around the central point of action. This 
helps the viewer understand the story location and scene 
orientation.

exposure
In animation, an exposure is the number of cels on which a drawing 
appears in the scene. For a drawing to appear longer, the 
exposure must be extended over a greater number of cels.

exposure sheet (Xsheet)

The exposure sheet or Xsheet, is a sheet with several vertical 
columns and horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the 
drawing's numbers are indicated and repeated over the particular 
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other 
members of a crew to track the sequence and timing of images, 
dialogue, sound effects, sound tracks and camera moves. Also 
known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a 
sequence. A fade in occurs when the first scene appears 
progressively, from complete transparency to its complete opacity. 
A fade out occurs when the last scene progressively disappears, 
going from complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field
In animation, a field is a measurement unit used to calculate 
motion, registration and camera positioning. A standard animation 
scene will vary between 6 to 12 fields.

field chart
A guide containing all the field units that animation and layout artists use to 
determine a scene size or camera motion.

film-1.33 
Use this resolution setting for the widescreen film format that 
conforms to the standard 4:3 pixel aspect ratio.

film-1.66 
Use this resolution setting for the widescreen film format that 
conforms to the 16:9 pixel aspect ratio. (The pixels are wider than 
they are high).

flipping

In traditional animation, flipping is the action of going through the 
drawings of an animation sequence very quickly in order to see the 
animation in motion. Flipping can also be the action of creating a 
mirror transformation of an object.

follow-through

The follow-through is the secondary motion caused by the main 
action. For example, a character wearing a cloak is running. The 
main action is the body running. This will cause the cloak to follow 
the motion, although it will not move at the same time, but react a 
few frames later and follow the main motion curve.

forward kinematics
Forward kinematics is a feature used to animate principally 3D 
characters and cut-out puppets with hierarchy. It is used to animate 
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a puppet from one of parent parts, such as a shoulder, and make 
the rest of the arm move with it as a single piece.

frame

A frame is a single photographic image in a movie. In traditional 
animation, the North American standard generally contains 24 
frames per second, while in Europe the standard is 25 frames per 
second.

frame rate

This is the measurement of the frequency (rate) at which an imaging 
device produces unique consecutive images, called frames. The 
term applies equally to computer graphics, video cameras, film 
cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (FPS) and 
in progressive-scan monitors as hertz (Hz).

The frame rate is the speed at which the frames are played. They 
are generally calculated by frame per second. For example, a scene 
could be played back at 12, 24, 25, 30 or 60 frames per second or 
any other number

functions

A function is a computer generated motion, trajectory or path that 
elements, other trajectories and effects parameters can be 
attached to. The function can be controlled by adding keyframes 
and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV 

High Definition Television delivers a higher quality image than 
standard television does because it has a greater number of lines 
of resolution. To take advantage of the superior quality and make 
full use of your resolution setting, your output device must be 
compatible with HDTV technology.

hold
This is a frame in the animation in which the character maintains its 
position without moving. A hold can be created between any two 
keyframes.

HSV
Hue, Saturation, Value. A method of defining colours in terms of 
hue (tint), saturation (shade) and value (tone or luminance).

in-between
The drawings that exist between the key poses. These are drawn 
to create fluid transitions between poses.

ink and paint
The ink and paint process is the action of painting the empty zones 
and colouring the lines on the final animation drawings, while 
following a colour model.

interpolation
In animation, the interpolation is the computer generated motion 
created between two keyframes. You have the choice to create 
interpolation, or not, between your keyframes.

jump cut

A jump cut is a jerky cut between two scenes. Typically, a jump cut 
is not visually pleasing. It is generally caused by one scene ending, 
and a second one starting, with similar a image. The lack of 
difference causes the eye to see a little jump between the two 
scenes. 
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key pose

Important positions in the action defining the starting and ending 
points of any smooth transition. Keys, or key poses, are the main 
drawings in an animation sequence describing the motion. For 
example, if an arm is waving, the keys will be of the arm at one 
extremity of the wave motion and the other extremity. By flipping 
those drawings, the animator can see the skeleton of the motion 
without having all of the drawings.

keyboard shortcuts 

One or more keyboard keys which, when used, cause an operation 
to be performed. Keyboard shortcuts are used throughout the 
Toon Boom software and form an integral part of the workflow. It 
is, in most cases, possible to customize the shortcuts in the 
Preferences dialog of the software.

The shortcuts are written as follows in the Toon Boom user 
documentation: Each key in a sequence is shown inside square 
brackets as in: [Ctrl]+[A]. The brackets "[ ]"  separate the key from 
the plus  sign (+). Neither the brackets, nor the plus sign are part of 
the sequence. To use a shortcut, press the key and the character 
simultaneously.

keyframe 
Important positions in the action defining the starting and ending 
points of any action. A keyframe is a computer generated position 
at a specific moment (frame) on a given trajectory.

layer
In animation, a layer is an individual column, level or character. A 
scene's layers are superposed to form the final image.

layout

The layout process is the communication step between the 
storyboard and the animation. The layout and posing process is 
the action of putting the storyboard on model, that is drawing the 
character following the design in the model pack, so that the 
animator can start his work. The layout artist will draw the 
background, create the camera and field guide matching the scene 
and the camera motion. Lastly, he will draw on model the main 
action poses.

layout and posing
The action of putting on model, that is, at the right scale, the 
storyboard for the animator to start his work.

library
A library is a storage area containing templates and assets that can 
be reused in any project or scenes.

light table
The Light Table feature allows you to see the other layers in 
transparency while you are working on a particular one in the 
Drawing view.

line of action
Direction that the action will follow. Also known as the Path of 
Action

lip-sync
The lip-sync is the character`s mouth synchronization with the 
dialogue sound track. Frame by frame, the mouth will be adjusted 
to fit the sound to give the illusion of the character is speaking.

low resolution
This format is ideal for videos destined for the web, where size and 
fast download of a video file might take precedence over quality. A 
low-resolution image is one that lacks fine detail.
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manual lip-sync detection

The manual swapping of mouth position drawings to match a voice 
track. For this process, both sound scrubbing (listening to a sound 
wave broken up frame-by-frame) and drawing substitutions from 
the Library view are used.

master palette

A master palette is a group of colours attributed to a character or 
a prop. The palette is used throughout the entire production to 
maintain consistency in the look and to ensure that the same 
colours are used throughout the production. Also known as 
palette.

model/colour model

In animation, a model is the definitive character, prop or location 
design that each artist must follow for the production. A colour 
model is the official colour design that must be used to paint the 
animation.

motion keyframe 
In Toon Boom, the motion keyframe is a keyframe with computer-
generated interpolation.

mouth chart 

Adding a lip-sync to a project can really enhance its quality and 
storytelling. However, it can be difficult to shape a character's 
mouth so that it matches the sound at the precise frame. To solve 
this problem, Toon Boom provides a lip-sync feature which 
analyses the contents of a sound element and generates a mouth 
chart based on the eight animation phonemes (A, B, C, D, E, F, G, 
and X, which is used to represent silence).

multiplane 

The effect of passing through multiple levels of drawings to create 
a sense of depth in a shot. A multiplane is a scene in which the 
layers are placed at different distances from the camera so that 
when the camera moves, a depth illusion occurs. With a multiplane, 
all the perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in 
North America. NTSC conforms to North American standards on 
how rectangular pixels are displayed for computer and television 
screens.

nudge
A small push (left, right, up, down, forward or backward) done 
with the keyboard arrow keys on a selected element. Nudging is 
used to move a selection very slightly and precisely.

onion skin
A feature that lets you see the previous and next drawings of a 
sequence.

overlay
A part of the scene environment, such as a chair or a bush, that is 
placed in front of the main animation.

PAL
A resolution that works best with the European format for 
television and computer screens, as the rectangular pixels are 
displayed at a different orientation.

palette/master palette

A palette or master palette is a group of colours attributed to a 
character or a prop. The palette is used throughout the entire 
project to maintain a consistency in the look and avoid the colour 
changing during the animation. Also referred to as a master 
palette.
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palette style

A palette style is a second version of an existing palette with a 
slight change in the tint and value. A palette style can be used to 
create the night version of a palette. It may also be called a clone 
palette.

pan To move the camera across the scene in any direction.

panel 
In a storyboard, a panel is a frame in a shot. A shot can be 
composed of one or several panels.

paperless animation/tradigital
The paperless animation process is the action of animating 
digitally. The main paperless animation process is to draw, frame 
by frame, the animation directly in the software.

passing position 
When drawing a walk sequence for a character, the passing 
position is the point at which one leg passes the other.

path of action
Direction that the action will follow. Also known as the Line of 
Action.

peg

In traditional animation, a tool used to ensure accurate registration 
of action as cel layers move. In digital animation, in which you are 
doing a more advanced puppet rigging, you can use peg layers. 
Peg layers are trajectory layers that do not contain drawings. They 
are motion paths that you can use to add path articulations. For 
the latter, you can also use the Inverse Kinematics tool.

phoneme Unit of sound in a language.

pivot A pivot is the point around which a peg or a drawing rotates.

pixel

Smallest element of an image displayed on a monitor or TV screen.

Pixel, short for Picture Element, is a single point in a graphic image. 
It is a small sample of an image, a dot, a square, or a very small 
section made out of smooth filtering. If you zoom in close enough 
on a digital image, you will see the pixels, which look like small 
squares of different colours and intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all the 
main action poses, called key poses, and then placing the 
secondary poses between the keys. The secondary poses are 
called breakdown. Finally, the animator fills the gaps with the in-
between drawings to achieve a smooth animation.

rendering 

The final step when animating by computer. During rendering, the 
computer takes each pixel that appears on screen and processes 
all of the components as well as adding motion blur before it 
produces a final image. In animation, the rendering process is the 
action of calculating the final images after the compositing 
process.

resolution

The resolution is the size of a scene, generally calculated in pixel. 
For example, the NTSC resolution is 720 x 480. Resolution type 
should match your final output: HDTV, film-1.33, film-1.66, NTSC, 
PAL, low.

RGB Red, Green, Blue: method of defining colour by specifying amounts 
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of these three colour components.

rigging 
The rigging process is the action of attaching the cut-out puppet 
parts one to the other.

rotary table
The Rotary Table is equivalent to the animation disk/table and 
allows one to rotate the workspace to be more comfortable while 
drawing.

rotoscoping 

Is an animation technique in which animators trace over live-action 
film movement, frame by frame, for use in animated films. The act 
of sketching over live-action footage to create an animated 
sequence.

roughs 
The roughs are the skeleton sketch of an animation or a design. 
Roughs mainly consist of sketch lines and shapes, though they can 
also contain design details.

safey area

In animation and movie parlance, the safey area is the zone at the 
centre of the scene's frame, one safe from being cropped by the TV 
frame. As a TV frame cuts a margin off the original frame size, 
maintaining a safey area ensures that the scene's main action will 
remain clearly visible once the film is screened on television.

scene 
A scene is a shot in a movie or show. A sequence is composed of 
several scenes. A scene changes to another scene by a simple cut, 
or a transition.

script 

The script is the original text containing all the movie or show 
information. In animation, the script contains all of the location 
descriptions, dialogues, time and more. A project starts with a 
script.

sequence 
In animation, a sequence is a series of scenes or shots forming a 
distinct part of the story or movie, usually connected by unity of 
location or time.

shot 
A shot is a scene in a movie or show. A sequence is composed of 
several shots. A shot changes to another shot by a simple cut, or a 
transition.

slow-in
Gradual acceleration in the action. Another common term for slow-
in is ease-in.

slow-out 
Gradual deceleration in the action. Another common term for slow-
out is ease-out.

slugging
In Storyboard Pro, slugging refers to indicating the start and stop 
times of dialogue and relevant actions.

sound scrubbing
A process that lets you hear sound in real time while you move the 
playhead forward or backward. This is very useful for finely-tuned 
lip-syncing.

stop-motion keyframe 
A stop-motion keyframe is a keyframe with no computer generated 
interpolation.

storyboard 
A visual plan of all the scenes and shots in an animation. The 
storyboard indicates what will happen, when it will happen and 
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how the objects in a scene are laid out.

straight-ahead 

A technique in which an entire sequence is drawn from the first 
position to the last, in order. There is very little planning in this 
methodology, and where the character ends up and how it gets 
there can be a surprise for both the audience and the animator. 
While this approach is a lot more spontaneous and creative, it can 
create inaccurate results.

strokes
Strokes are invisible vector lines forming the drawing zones. They 
can be adjusted with Bézier handles.

tablet/pen 
Device used in conjunction with, or instead of, a mouse to move a 
mouse pointer (sometimes referred to as the cursor) around the 
computer screen.

template 

In Toon Boom, a template is an asset stored in the library, one that 
can be reused in any project. A template can be a drawing, a series 
of keyframes, a sound file, a panel, a cut-out character, an effect, a 
trajectory, an animation, or anything else used in the software.

thumbnails A thumbnail is a very small image used as a reference or indicator.

timecode 
Timecode is timing information printed on a movie clip to indicate 
what scene, hour, minute and second is currently displayed on the 
screen.

timeline 
The timeline is a horizontal representation of the scene`s elements, 
timing and keyframes.

trace and paint 

After the rough animations have gone through cleanup and a final 
line or pencil test, each drawing is traced and painted for the final 
animation. In today's digital world, this may be done in a variety 
ways other than via the traditional celluloid or acetate methods.

track breakdown 
The soundtrack for animated film is broken down into individual 
sounds documenting the precise frame-by-frame position of each 
sound.

traditional animation 
The traditional animation process is the action of drawing on paper 
all of the animation sequences, before either scanning them or 
inking them on cels.

trajectory 
A computer generated path or trajectory that elements can follow. 
The trajectory can be controlled by control points, keyframes and 
velocity.

transition 
A transition is an effect placed between two scenes as they pass 
from one to the other. Common transition effects are cross-
dissolve and wipe.

underlay
In animation, an underlay is a specific part of the decor placed 
behind the main animation.

aspect ratio
The aspect ratio describes the shape of the grid unit. A square grid 
unit would have the ratio 1:1, whereas a grid unit of aspect ratio 
4:3 is a unit with one side 1.33 times as big as the other side.
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vector

A vector-based image is composed of points and Bézier curves. 
The computer reads the points and traces the segments, linking 
them to reproduce the image shape. There is no fixed size or 
resolution in a vector image. The graphic can be enlarged and 
distorted as much as desired and the system will simply recalculate 
the segments and rebuild the shapes. Vector images are translated 
and displayed in pixels once the calculation is done.

velocity/ease

In animation, the velocity, also known as ease, is the acceleration or 
deceleration of a motion. This can be achieved by a function curve, 
or via a series of animated drawings. Other common terms for 
ease-in and ease-out are slow-in and slow-out.

walk cycle 

To avoid making innumerable drawings, animators routinely make 
a walk cycle for their character. This comprises a series of drawings 
``on the spot``  that describe the walk for that character. The illusion 
of movement is created via the use of background pans.

workspace
In Toon Boom, the workspace is made up of the views, toolbars, 
and menus.

Xsheet (exposure sheet)

The Xsheet or exposure sheet, is a sheet with several vertical 
columns and horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the 
drawing numbers are indicated and spread over the specific 
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other 
members of a crew to track the sequence and timing of images, 
dialogue, sound effects, sound tracks and camera moves. Also 
known as a Dope Sheet.

zone An area which can be painted with colour.
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Index

A
alpha channel

_defined  206

animatic

_defined  206

animation

_defined  206

anime

_defined  206

Annotation column  57

changing drawing settings  60

drawing  58

erasing annotations  59-60

importing Annotation file  62

pen colour  61

pen width  60

tick marks, displaying  61

typing  58

annotations

changing drawing settings  60

changing pen colour  61

changing pen width  60

drawing  58

erasing  59-60

typing  58

arc

_defined  206

aspect ratio

_defined  206

defined  215

auto-feed

_defined  206
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axis

_defined  206

B
background

_defined  206

backing up

palettes  124

Bezier

_defined  206

bitmap images

_defined  207

Bitmap layer  43

breakdown

_defined  207

C
Camera layer  44

camera shake

_defined  207

caption

_defined  207

cel

_defined  207

celluloid

See cel.  207

character design

_defined  207

clean up

_defined  207

cloning

layers and columns  56

CMYK

_defined  207

Colour-Card

layer  44
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colour card

_defined  207

colour model

_defined  212

defined  208

colour palettes

back up  124

location  123

colour wheel

defined  208

Column Properties editor

displaying in Xsheet  53

columns

advanced types  46

cloning  56

deleting  50

duplicating  56

modifying  53

properties  52

renaming  54

reordering  55

Timing  63

types  43

Xsheet  42

compositing

defined  208

cross dissolve

defined  208

cut

defined  208

cut-out animation

defined  208

cycle

defined  208
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D
dialogue

defined  208

dope sheet

defined  208

doping

defined  208

DPI

defined  208

drawing elements

adding  46

creating  42

duplicating  56

Drawing layer  43

drawings

importing  11

scanning  11

E
ease

defined  208

ease-in

defined  208

ease-out

defined  208

editors

Column Properties  53

Effect layer  44

Element Manager dialog box

parameters  55

establishing shot

defined  208

exposure

_defined  209

exposure sheet

_defined  209, 216
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F
fade-in

_defined  209

fade-out

_defined  209

field

_defined  209

field chart

_defined  209

film-1.33

_defined  209

film-1.66

_defined  209

flipping

_defined  209

follow-through

_defined  209

forward kinematics

_defined  209

frame

_defined  210

frame rate

_defined  210

frames  39

adding  40

adding before/after selection  39

functions

_defined  210

G
gamut

_defined  210

H
HDTV

_defined  210
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Hold

_defined  210

HSV

_defined  210

I
importing

Annotation file  62

bitmap drawings  16

drawings  11

in-between

_defined  210

ink and paint

_defined  210

interpolation

_defined  210

J
jump cut

_defined  210

K
key pose

_defined  211

keyboard shortcuts

_defined  211

keyframes

_defined  211

L
Layer Properties editor

displaying  53

renaming layers  54

layers  42

_defined  211

bitmap  43

camera  44

cloning  56

Colour-Card  44

deleting  50
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drawing  43

duplicating  56

effect  44

Group  44

modifying  53

Peg  45

properties  52

Quadmap  45

renaming  54

reordering  54

Sound  45

types  43

layout

_defined  211

layout and posing

_defined  211

library

_defined  211

light table

_defined  211

line of action

_defined  211

linking

external files  63

lip-sync

_defined  211

auto detection, defined  206

lip-sync detection

manual, defined  212

low resolution

_defined  211

M
manual lip-sync detection

_defined  212
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master palette

_defined  212

model

_defined  212

model sheet  See character design

motion keyframe

_defined  212

mouth

chart  212

multiplane

_defined  212

N
NTSC

_defined  212

nudge

_defined  212

O
onion skinng

_defined  212

overlay

_defined  212

P
PAL

_defined  212

palettes

_defined  212

backup  124

location  123

style, defined  213

panel

_defined  213

panning

_defined  213

paperless animation

_defined  213
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passing position

_defined  213

path of action

_defined  213

Peg layer  45

pegs

_defined  213

pen

_defined  215

phoneme

_defined  213

pivot

_defined  213

pixel

_defined  213

pixelation  See bitmap image

pose-to-pose

_defined  213

Q
Quadmap layer  45

R
rendering

_defined  213

resolution

_defined  213

RGB

_defined  213

rigging

_defined  214

rotary table

_defined  214

rotoscoping

_defined  214

roughs

_defined  214
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S
safe area

_defined  214

scanning  9

drawings  11

images as bitmap drawings  11

process  10

VectOptions.conf file  28

scenes

_defined  214

adding frames before/after selection  39

extending  39-40

reducing length  40

removing frames  40

setting length  39

script

_defined  214

scrubbing

_defined  214

sequences

_defined  214

shot

_defined  214

slow-in

_defined  214

slow_out

_defined  214

slugging

_defined  214

sound

scrubbing

_defined  214

Sound layer  45
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stop-motion keyframe

_defined  214

storyboard

_defined  214

straight-ahead

_defined  215

strokes

_defined  215

T
tablet

_defined  215

templates

_defined  215

thumbnails

_defined  215

tick marks, Xsheet

displaying  61

turning off  62

timecode

_defined  215

timeline

_defined  215

Timeline view

cloning layers and columns  56

modifying layers and columns  53

reducing scene length  40

renaming layers  54

reordering layers  54

timing

adding frames before/after selection  39

Annotation column, adding  57

changing drawing settings  60

drawing in Annotation column  58

erasing annotation  59-60
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extending scenes  39-40

frames  39

importing Annotation file  62

linking external files  63

preparing  37

reducing scene length  40

references  38

removing frames  40

scene length  39

Timing column  63

typing in Annotation column  58

Timing column  63

linking external files  63

using  63

trace and paint

_defined  215

track breakdown

_defined  215

tradigital

_defined  213

traditional animation

_defined  215

introduction  7

scanning  9

trajectory

_defined  215

transition

_defined  215

U
underlay

_defined  215

V
VectOptions.conf file  28

Linux  31

Mac  29
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setting  29

Windows  29

vector

_defined  216

vectorization

creating a style  27

parameters, creating  27

parameters, custom  19

parameters, modifying  27

Vectorization Parameters dialog box

Help tab  22

opening  19

Options tab  20

vectorizing

bitmap drawings  16

velocity

defined  208, 216

W
walk cycle

_defined  216

workspace

_defined  216

X
Xsheet

typing in Annotation column  58

Xsheet view

_defined  53, 216

adding frames before/after selection  39

advanced column types  46

Annotation column, adding  57

changing drawing settingss  60

cloning layers and columns  56

columns  42

erasing annotations  59-60

importing Annotation file  62
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layers  42

modifying layers and columns  53

removing frames  40

renaming columns  54

reordering columns  55

tick marks, displays  61

Timing column  63

Z
zone

_defined  216
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