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Chapter 1: Introduction

Harmony is a great tool for creating character rigs and animation for games. Artists and programmers can work
together to create content for many platforms, including Windows, Mac, Mobile, iOS, PS, XBOX, and so on.

The Toon Boom gaming pipeline is evolving constantly. For more information:

» Toon Boom Gaming: https://www.toonboom.com/games

» Forinformation: sales@toonboom.com.

» Technical inquiries: store.toonboom.com/contact/support.

This guide is divided as follows:

* About Gaming in on page 1

* Guidelines and Resources on page 1

» Design and Drawing Tools on page 19

» Colour Styling on page 195
* Timing on page 243
* Character Building on page 331

» Gaming Deformation on page 407

» Library on page 427

»  Cut-out Animation on page 455

* Importing Animations into Unity on page 1

» Troubleshooting on page 1


https://www.toonboom.com/games
mailto:sales@toonboom.com
https://store.toonboom.com/contact/support
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Chapter 2: About Gaming in Harmony

As gaming pipelines are constantly evolving, Toon Boom is breaking the boundaries of how to create 2D animation
for games.

There are two main pipelines for exporting data from Harmony to your game engine:

* Raw Game Data Export on page 10

*  Frame-by-Frame Export on page 11

Creating Animation in Harmony

When creating character rigs and animation for games, there are a few things to think about before starting. Artists
and programmers should work together to make sure their needs are met.

»  What platform will your game be going on? Windows, Mac, Mobile, iOS, PS, XBOX, etc.
*  What game engine will you be using?
+ What is the style of the game? Hand drawn, cut-out, with textures, etc.

These are just a few of the questions to consider before getting started. They all have an impact on how you design,
build, and animate characters.

For example, if you're planning a mobile game for smart phones, then you will most likely want to keep your game
under 50 MB, so it can be downloaded without having to be on Wi-Fi. In that case, your most important consideration
is to create efficient characters with very tight sprite sheets and reuse a lot of the animation to keep the file sizes
small. During the process, you will need to:

* Rigand animate characters in Harmony.
+ Extract out the Harmony data.

* Import the Harmony data into the game engine.
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Keep in mind, if you're working with a custom engine, you can also process the Harmony data that’s exported and
use it in a custom game engine. If you need assistance with adapting data for your engine, contact
store.toonboom.com/contact/support.

If you're making a game for consoles, like the PS or Xbox, then you have the freedom to create larger textures.
You may want to animate frame-by-frame, or you may want to animate with a cut-out character.

If you're simply going to export on a frame-by-frame sequence, then you can use all tool in Harmony without
limitations. You can then process an exported image sequence into a sprite sheet.

Raw Game Data Export
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Raw game data export is appropriate when you want the file sizes to be as small as possible. Toon Boom lets you
extract all the data from Harmony to incorporate into a game engine. You can extract the skeleton information,
drawing information, and keyframe animation data, as well as deformations (bones and articulations only), cutter,
transparency nodes, and timing columns.

» Advantage: This is the lightest export, and will keep file sizes small which is ideal for mobile applications.

» Disadvantage: You are somewhat limited in the tools you can use in Harmony. You can use tools like
Morphing as well as Curve and Envelope deformers, but you'll need to bake it out to drawings so they're
interpreted properly in the game engine. You can use Cutter effects (masking), but you cannot cascade
them, meaning you cannot have more than one in a hierarchy chain. The Game Bone deformers can be
used on your rig with having to bake it to drawings.

However, even with these limitations, you can create really great cut-out character animation in Harmony and
extract all the data. By moving, rotating, scaling, and skewing the different drawing layers, you can create
advanced looking animation.

When you extract the data, you'll have sprite sheets that contain only the drawings of the body parts used in your
Harmony scene file. You can also support multiple animations, such as idle, run, and jump, and reuse the same
skeleton and drawings when possible by simply exporting new animation data.

10
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Toon Boom has fully integrated this solution with the Unity game development rendering engine. If you are creating
your game in Unity, you have a seamless pipeline without the need to re-treat the data in your game engine.

Frame-by-Frame Export

B

You can export from Harmony using an image sequence, which can be recompiled into a sprite sheet.
Advantage: You can use any of the tools in Harmony when you animate!

Disadvantage: These sprite sheets can become quite heavy and end up as large textures to process in the game.
This may be fine for many games, like console games, but when you’re doing game development for mobile devices,
such as iOS or Android, you need to be very light on your texture space. Also, file sizes should be kept under 50 MB
to facilitate downloading without needing to be connected to Wi-Fi.

There is a script available in Harmony that allows you to export your animation in frame-by-frame to the EaselJS
game engine EaselJS is a javascript web compatible game engine. It uses a json data structure to map each frame
to an entry in the sprite sheet. The data structure is easy to understand and can be adapted or converted to a
different game engine if you need to.

To export to EaseldJS, you need to add the script in the Scripting toolbar (TB_ExportToEaselJS). This script is
included in Harmony. See Export Animations to Unity on page 1 for more information on how to add the script to your
Scripting toolbar and the interface parameters.

11
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Chapter 3: Guidelines and Resources

In this chapter, you'll find guidelines for rigging, deformation, cutter and many useful animation tips.
This chapter contains the following topics:
* onpage 14

» Deformation Guidelines on page 15

» Cutter Guidelines on page 15

* Animation Tips on page 16

13



Chapter 3: Guidelines and Resources

Rigging Guidelines

The following is a list of general guidelines to keep in mind when rigging your character. As you're planning the
character rig for your game, keep in mind the style of the character, and create your custom colour palette.
However, there are some limitations to consider if you plan to extract the game data:

Set your Harmony scene to be a square resolution (e.g. 1024 x 1024). You can do this in the Scene Setting
dialog box.

Draw the art on the Line Art and Colour Art layers only. The information contained in the Overlay and
Underlay will not be exported to Unity. It is however safe for using as a reference layer, just not anything
that will be exported.

Create rigs in the Timeline view only. The Node view can have complex connections that are not always
interpreted well by game engines.

Nudge layers in Z space if you need to reorder layers. However, significant Z offsets are not supported
within a character rig.

Make every layer in your game engine a separate scene in Harmony. If you have two characters at
different depths, put them in separate scene files.

Character rigs in groups at the root level of your Harmony scene will render to a single plane in Unity, but
use separate sprite sheet and animation data sets. Keep this in mind for scenes in which you may have
more than one character interacting with each other.

Don't use any effects. Effects like colour overrides are not interpreted by game engines. Use only direct
hierarchy, drawing swaps, and keyframe animation.

Don'’t use 3D space. If you want to set things up in 3D space, you can do this when you get to your game
engine.

Set your pivot points on Peg layers using the Rotate tool to set the pivot on the entire layer. Peg pivots are
recommended over drawing pivots. You should also set the pivot points on your drawing layers, even if
you don’t animate on them, as this will allow you to retrieve the information later on in the game engine if
you need to put a locator on a drawing layer.

Don’t use Morphing. This is not yet supported in game engines.

Both Morphing and Deform can be used and then baked out to individual drawings. These drawings will
then show up as new drawings in your sprite sheet. Be wary of doing this too often as it will increase your
texture space!

For your pegs, when you animate, use Bezier curves and set them to Separate. If you use 3D Path, it's
heavier than Separate.

Be mindful of where you put your character before exporting. The master pivot of your exported game
object will be the center of your Harmony scene (0,0).

Be sure to have a Display at the end of your hierarchy.

Keeping these tips in mind will allow you to create a tight, efficient 2D game character in Harmony while taking
advantage of all the great tools.

Here are some things you should do:

Create a simple parent-child relationship hierarchy in the Timeline view.

Use peg layers to contain keyframe animation data, set to Separate Position.

14
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» Usedrawing layers to draw on, creating new drawings when needed.
* Usethe Rotate tool to set the pivot points on the peg layers.

* Name your layers properly so if you need to fetch a specific layer’s pivot point later on in the game engine,
you can easily recognize the layer you need. If you have a top-level Group A, which has a child group inside it
(Group B), and the drawing layer is a child of Group B, then the drawing layer is exported as A_B_
DrawingLayer.

You can use any of the drawing tools you want: Pencil and Brush tools, textured lines, solid areas, and gradients.
Each individual drawing will be rendered out and assembled into a sprite sheet later.

NOTE: Because the Unity game engine does not support Unicode characters, itis recommended to avoid using itin
scenes intended for games.

Deformation Guidelines

Harmony can export deformations to the game engine XML format. Only hierarchies made of Game Bones can be
successfully exported. In addition, Kinematic Outputs were implemented to complement your game bones.

Although deformation comes equipped with a wide range of features, many were restrained to ensure that
performance is on par with gaming industry standards. The following features are not compatible with the game
engine SDK:

» Zones of influence
* Curve and Envelope deformations
* Only asingle pose is allowed per deformation hierarchy
The deformation in the game engine SDK does not behave exactly as the deformation in Harmony.

To comply with most game engines and maintain fast calculations, the SDK implements a linear base skinning
algorithm to linearly blend the bones at articulations. You may notice some differences depending on the curvature of
the articulations used.

NOTE: * Not currently available in the Cocos2d-x implementation of the game engine SDK.

Cutter Guidelines

The cutter, or mask, operation in Harmony is used for cutting off drawings with custom shapes. The game engine
SDK implements both cutters and inverted cutters with the following limitations:

* Fora sprite, only a single cutter drawing can be applied when it is rendered. This also applies to a composite
of multiple matte drawings. The game engine SDK will only use the first matte drawing during rendering and
discard the others.

» A deformed drawing cannot be cut, but a cut drawing can be deformed.

15
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NOTE: * Not currently available in the Cocos2d-x implementation of the game engine SDK.

Animation Tips

When animating for games, depending on the type of game you're creating, you may need to limit your animation.
For example, if you’re creating mobile games and you want to keep the file sizes small and playback fast on all
devices, then limit yourself to simple keyframe animation with as few drawing swaps as possible. If you're
creating console games, you have the freedom to create more drawings and have a higher complexity. You can
explore with your programmer the limitations of the platforms you're exporting to, and what your game engine
supports.

Here are some tips for efficient, lightweight animation:
» Use mainly transformations, such as move, rotate, scale, and skew.
» Create additional drawing swaps when needed.

» If you use Curve and Envelope deformers or Morphing, you'll need to bake out the drawings for export. Be
careful when doing this, as you may want to keep the number of drawings small. Don’t bake out an entire
sequence, just selected drawings. You don't need to bake the Game Bone deformers.

» The bigger the drawings are in the Drawing view, the more pixels they will occupy in the texture size on the
sprite sheet. When setting up your rig, make sure to not scale individual layers by using a keyframe with
the Transform tool. If you want to scale things up or down, use the Select tool. This will keep things the
same relative size on the sprite sheet. When you export the sprite sheets, in the script you can also set the
resolution of the sprite sheet so the drawings can be scaled down for smaller devices.

» Only drawings which are exposed in the scene will be exported to the sprite sheet. For example, if you
have 10 drawings in your Library view, but only two of them are showing in your scene, only those two will
be exported. This keeps the sprite sheet as tight as possible.

Animating Multiple Sequences

You will always have multiple animations for your characters. For example, an idle sequence, a run sequence, an
action sequence, and so on. You need to work in a specific structure so you can export all of these animations to
a single sprite sheet.

First, create a scene file with the name of the character, such as Space Duck. This is the file where you can
create or import your game rig. In the top menu, select File > Save As New Version, and give this new version
the name of the animation. For example, Idle.

Every time you need to do a new animation using the same character, perform a Save As New Version. In the
end, you may have something like this:

Scene: Space Duck

Versions:
* Run
+ lIdle
e Jump
+ Shoot

16
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When you run the export script, it will export the drawings from the current scene into the export folder. It will also let
you know if there are any other scene versions that were already exported to that folder. If so, then it will recompile
the sprite sheet to include all the drawings from all the animations. This allows the maximum possible reuse of
drawings.
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Chapter 4: Design and Drawing Tools

Another important step in the project creation is the character, prop and location design. This determines the style
and models to follow for the entire project.

This is also the step where you will need to use most of Harmony's drawing tools.

The design can be created on paper and scanned in or it can be created digitally. You can draw and even create the
colours entirely on paper, while others like to design on paper and scan the drawings to create the colour model in a
software program. The most popular method is to design directly in Harmony.

To save paper and time and avoid having to recreate colour palettes, Harmony gives you the ability to design all
elements directly in the application. This keeps all your work within the same software, avoids using a lot of paper
and losing time scanning in elements and importing them.

The character and prop design process is divided in three steps:

*  Preparationon page 19
»  Sketching the Model on page 20

» Cleaning and Inking the Model on page 34

Harmony has an extensive set of drawing tools that can be used to design your characters. You can learn more
about this in the following topic:

» Drawing Tasks on page 39

Each drawing tool has a series of options to customize its behaviour and drawing style. You can learn more about
them in the following section:

» Drawing Tool References on page 119

Preparation

To prepare for the design task, you will need to go through a few steps:

» Getting References on page 20

* Using the Workspace on page 20

19
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Getting References

Creating models requires two main reference sources, the script and the storyboard. Once you have the script in
hand, you can learn about the characters and their personalities, the props, the ambiances, and so on. This will be
your main reference, so it is very important to read it carefully.

The storyboard is the second reference source and it can be quite useful as well. Although it will not yet be the
final version of the storyboard, it will show you what the character is doing and what props need to be designed.

Using the Workspace

Once your scene is created, you can open it and set your workspace.

To sketch the characters, props or locations directly in Harmony, you will mostly use the Camera or Drawing
views along with the Colour, Timeline and Tool Properties views.

Sketching the Model

20
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Now that your references and scene are created, you can start designing. To draw your characters, props and key
locations, you will need to learn the following:

Drawing with the Brush or Pencil Tool

Brush line

Pencil line

The Brush  andPencil & tools are used for drawing and sketching. Both tools support pressure sensitivity,

allowing you to create lines with variable thickness. The Brush tool produces contour vector lines. The Pencil and
shape tools produce central vector lines. This means that a pencil line’s control points (used to deform its shape) are
located along the length of the central spine, while the Brush line’s control points are located along the contour.

+ If you draw with the Brush tool and want to modify the thickness variation, use the Contour Editor tool.
* If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor »¢ tool.

* You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line 5 option.

If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the Brush tool as it
produces a more realistic and natural feel. The pencil line is very useful for tracing clean or final drawings.

S

-—
-

Pencil line Brush line
Also, it is recommended to use brush lines when designing cut-out puppet articulations which use patches.
Override Tool
The Override tool lets you increase productivity by rapidly switching between tools used for short tasks and your

previous tool. Most drawing tool shortcuts are accessed using the Alt key followed by another key, such as the
Eraser tool which is accessed by pressing Alt + E.

21
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If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold down the E
key while you are erasing. Once you are done, release the E key to return to the previous tool; in this case, the
Brush tool. You can do the same for most drawing tools that have a shortcut composed of Alt followed by another
key.

Selected tool

LA |

IA W]

Cwverride tool

Relative Size

The size relation between the props, characters and backgrounds is very important in maintaining consistency
and structure throughout the project.

A production can contain many characters and props. It is not unusual for these to be created by different people.
If there is no size control implemented, the characters and elements created by different artists can vary greatly.
When this occurs, the characters that are placed together in a scene will be out of proportion. The animator or
person doing the scene setup will then have to scale them to the correct size.

When a character or prop is scaled down, the outline will become increasingly thinner. By the time the element is
scaled to its proper size, the outline may be so thin that a difference between one character's outline and the one
beside it will not look very good.

Here are a few tips you can use to create a suitable size relation.
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Line Up
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A line up consists of copying and pasting all your character designs into the same drawing and then scaling them to
the correct proportion in relation to the other characters. This line up is very important and should be handed to any
animator, layout and posing artist or scene setup person working on the project.

For the prop design, it is recommended that you paste one of the main character's hands or even the full body beside
the prop. This enables the animator to know what size to draw the prop.

In your character design scene, it is a good idea to create a column for the character line up.The line up is usually
done during the character design step. When the character builder imports the model to the breakdown scene, the
size relation should be correct.

Field Chart

Harmony includes a field chart in its Drawing and Camera views. This tool is very useful in setting the characters'
and props' heights.

It is recommended that you keep the character design and breakdown inside the 12 field size. This ensures that it
fits the default camera size and the template thumbnails. If some parts were drawn too big or too far apart, you can

23
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use the Reposition All Drawings tool and reposition, scale or rotate multiple drawings from different layers all at

once.

Use the Show Grid option to display a grid in the Drawing or Camera views.

Name Button Description Keyboard Shortcut

Show Grid | | View > Grid > Show Grid
Displays the grid. Press Ctrl +' (Windows/Linux) or 3£

+' (Mac OS X).

Grid Outline Only Displays the outline of the grid only. | View > Grid > Grid Outline Only

Square Displays a standard square grid. View > Grid > Square

12 Field Grid 2 Displays a 12-field size grid. View > Grid > 12 Field Grid

16 Field Grid 6 Displays a 16-field size grid. View > Grid > 16 Field Grid

Undertay S Displays the grid under the drawing View > Grid > Underlay
elements.

Overlay 5 rl?qzal:ys the grid over the drawing ele- View > Grid > Overlay

How to reposition all drawings

1. Inthe Tools toolbar from the Select drop-down menu, select the Reposition All Drawings v tool. This
also automatically selects every stroke in your drawing in the Drawing and Camera views.

2. To deform or reposition a selection:

>

To reposition, click and drag your selection to a new area.

>

To scale, pull or push on the top, side, bottom or corer control points. Hold down Shift to lock the

selection’s ratio.

24
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3. When you release your cursor, every drawing contained in the drawing layer you repositioned, scaled, rotated
or skewed will follow the same transformation.

Brush Size

Harmony provides a variety of pens and brushes and also allows you to create and save your own through creating a
tool preset.

It is a good idea to create and save pens with precise sizes and parameters to trace and design your models and
breakdowns.

How to create a tool preset

1. Inthe Tools toolbar, select a tool, for example the Brush tool.
2. Use the Tool Properties view to customize the tool.

To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the tool. Note
that when using this preset in another scene not using that colour palette, upon selecting this new preset, a
colour recovery dialog box will appear asking to add this colour to your scene.

4. Inthe Tool Presets toolbar, click the New Tool Preset button.

5. Inthe New Preset dialog box, in the Name field, type a name for your new preset.

25
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6. From theicon list, select an icon to quickly identify your preset or upload your own by clicking the File
button.

7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset. By default, the
shortcuts are unassigned. To assign a keyboard shortcut, go to the top menu and select Edit > Prefer-
ences > Shortcuts > Tool Presets (Windows/Linux) or Stage Advanced > Preferences >Shortcuts >
Tool Presets (Mac OS X).

8. When you select any of the following options, they will take effect when you use the tool preset. If an
option is deselected, then using a tool preset will not override your current settings.

» Colour: Saves the current colour into the tool preset.

9. Click OK.

For more information on Tool Presets—see Tool presets let you save a variety of settings and are very handy and
efficient for accessing the tools you use most often. That way, the tool is already set with the desired properties,
such as colour, line thickness, whether to enable Draw Behind or Auto Flatten mode, and so on. You can create
presets for these tools and many more: Brush, Pencil, Eraser, Rectangle, Ellipse, and Line. First, select a tool,
adjust the properties, and then create a tool preset for it. Once you have created a tool preset, you can always
make adjustments to fine-tune it, as well as create a keyboard shortcut for it.

Palettes and Colours

Harmony has an integrated palette system. Each character, prop or background can have its own set of colours
and each colour in the palette can be associated to colour fill zones on a drawing. You can create as many
palettes and colours as you need.

26
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Hat Tone

Pants

Each scene created in Harmony includes a default colour palette which contains a standard set of colours for
sketching and painting.

Black

White

Red

Green

Blue
Vectorized Line

QO

You can sketch and design using the default palette without any problem. However, it is not recommended that you
use the default palette for the colour models. A different colour palette should be created for each colour model.

To sketch and design with a different colour swatch or create a palette for each character, prop or key location, you
will need to learn how to manage the Harmony palettes.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour view menu, select Palettes > New or click the New Palette button.
The Create Palette dialog box opens.

2. Enterthe palette name according to the model.

27
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3. Click OK.

The palette appears in the drawing element’s palette list.

Scene Palettes

How to create a palette from the Advanced Palette Lists mode

1. Inthe Timeline or Xsheet view, select the drawing that requires a palette.

2. Inthe Colour view, click the Show Palette List View button to display the palette list.

Show/Hide Palette button

3. Do one of the following:

» From the Colour view menu, select Palettes > New.
» Click the Create Palette button.

The Palette Browser: Create Palette dialog box opens.

4. Select the level to store the palette file.

» Environment: The palette-library folder is stored in the scene's parent environment folder.
» Job: The palette-library folder is stored in the scene's parent job folder.

» Scene: The palette-library folder is stored directly in the scene folder.

» Element: The palette-library folder is stored directly in the drawing element folder.
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When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

5. Name the palette. There is no need to add the suffix "palette” to the name as it is always recognized as a
palette file.

6. Select a Palette List option.

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in twenty to
thirty different drawing elements that use the character's master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to this list
will appear in every drawing element created in the scene. There is no need to manually load the palette in each
element.

The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out animation, all
columns (drawing elements) contain different characters, props, backgrounds and effects. The Element Palette List
is used because you do not necessarily want all of the palettes for all of your elements linked in every column.

The palette list is stored in the drawing element's directory instead of directly in the Scene level. This ensures that
the links to the palettes appear only in the appropriate element. If you prefer to access a global palette list, link your
palettes to the Scene Palette List.

7. Click OK.

The new palette appears in the palette list.

How to add or modify a solid colour swatch

1. Inthe Colour view, click the Add Colour button.

2. From the Colour view menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens.

Colour Picker

Multi Wheel Mode
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3. Toset your colour, do one of the following:

» Inthe colour wheel, select a colour.

» Enterthe HSV or RGB values in the corresponding fields. Select the R,G,B,H,S orV options to
change the look of the colour picking area.

» Hold down the Dropper 2 button as you move along the desktop to preview colours, then release to

select the colour. It can be from the Toon Boom Harmony interface, your operating system or any other
open application.

NOTE: If the Sticky Eye Dropper option in the Preferences dialog box (Drawing tab > Options section) is selected,
the dropper will not have this behaviour.

NOTE: The Dropper does not work on Macs with Retina display.

Colour Picker

You can also click Multi Wheel Mode to open the Multiwheel Colour dialog box. This displays all the
picking area styles together and also contains a picking undo list. To return to the regular Colour Picker
window, click Single Wheel Mode.
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Single Wheel Mode

Picking areas

Picking Undo list

Click on the Shade Scale swatches to modify the shade of the selected colour.

i ——

Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha field.

Click the Add button to add the current selected colour to the Colour Storage Library, so you can quickly
access it later.

You can rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking
onits name.

Multi Wheel Mode

Colour Picker window Colour list
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Sketching the Character
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You are now ready to sketch your models. There are two tasks to perform in order to draw your characters:

o Add adrawing layer
o Sketch the model

You have the choice to sketch your model as a bitmap or vector drawing. If you like the feel of drawing with
bitmap lines, you can set your layer as bitmap. If you like drawing with vectors, you can set your layer as vector.
If you use vector, you will be able to enlarge your drawing and zoom into it without losing quality or resolution. You
can also use the Contour Editor and Select tools to resize and modify lines. If you draw with bitmap, you will not
be able to scale the drawing beyond 100% of its resolution without encountering pixelization issues.

If you would like to separate your lines and colours on separated art layers, see Art Layers on page 343
How to add a drawing layer

1. Inthe Timeline view, click the Add Drawing Layer «. button or press Ctrl + R (Windows/Linux) or 3§ + R
(Mac OS X).

The Add Drawing Layer window opens.

Add and Close Add Close
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In the Name field, name your new layer.

Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap layer.

Do one of the following:

» Click Add to add a first layer and keep the window open to add more layers.
» Click Add and Close to add a new layer and close the window.
A new drawing layer is added to the Timeline view.

How to sketch a model

1.

2.

3.

4.

5.

In the Tools toolbar, select the Brush - tool or press Alt + B.

In the Tool Properties view, select a brush preset and adjust its parameters.

Brush Freed Width 1
1

Brush Fixed Width 2
10

In the Timeline or Xsheet view, click in the first cell of the drawing layer.

In the Drawing or Camera view, enable the Grid (Field Chart). You can press Ctrl +' (Windows/Linux) or 3£ +
" (Mac OS X).

» Make sure the Drawing or Camera view is the active view while using the keyboard shortcut.

In the Drawing or Camera view, start drawing.
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6. To select a different colour, in the Colour view, select a different colour swatch. Double-click on the colour
swatch to open the Colour Picker window and modify the colour. Remember that anything already painted
with that colour swatch will update to the new colour.

7. Inthe Camera or Drawing view, use the Rotary Table @ to rotate your workspace.You can press Ctrl+Alt
(Windows/Linux) or Ctri+3£ (Mac OS X).

» The default keyboard shortcut to reset the workspace rotation is Shift + X.

8. If you decide to draw in the next cell and need to see your previous drawing, enable the Onion Skin by
pressing Alt + O.

Cleaning and Inking the Model

34



Harmony 12.2 Advanced - Gaming Animation Guide

When your rough models are ready, it is time to clean and ink them. You can still use the default palette and colours
to do so, especially if you are not the one doing the colour styling. If you have already created a palette for your
model, you can add new colours for tracing.

If you want to keep your roughs and sketches, add a new drawing layer and trace in it using the Light Table. This is
the equivalent of adding a sheet of paper and tracing over the rough using the animation disk light table. You only
need to disable the rough layer to prevent it from appearing in the final scene render.

If you would like to separate your lines and colours on separated art layers, see Art Layers on page 343

How to trace your character in a new layer

1. Inthe Timeline view, add a new drawing layer and name it: clean.
2. If youwork in the Drawing view, enable the Light Table or press Shift + L.

3. Do one of the following:

» Inthe Tools toolbar, select a drawing tool.
» From the top menu, select Drawing > Drawing Tools > desired tool.

4. Inthe Timeline or Xsheet view, select the cell in which you want to draw.

5. Trace the model.

~3

6. To make perfect points and corners, you can intersect the two strokes to create a point. Using the Cutter ~
tool, you can automatically trim the excess portion. In the Tool Properties view, enable the Lasso selec-
tion type. Make sure the Use Mouse Gesture % button is enabled. In this mode, you can automatically
delete any extra sections of line in your artwork by simply clicking, holding and dragging your mouse over it.
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T

7. If you are using the Pencil tool to clean your drawing, you will need to merge your pencil lines together after
cropping the points.

» Inthe Tools toolbar, select the Select w tool.

» Inthe Camera or Drawing view, select the two strokes to be merged.

» Inthe Tool Properties view, click the Merge Pencil Lines . button.

Y

» You can also set the Join option to Mitre.
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Tapered Thickness Sten Ll
12

Tapered Beginning Thickness Stencil
an -

How to add thick and thin Lines

1. Inthe Tools toolbar, select the Pencil Editor X tool located in the Contour Editor menu.

2. Inthe Camera or Drawing view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking on them or circling around.

4. Press Delete to delete a selected point.

5. Press Ctrl (Windows/Linux) or 3£ (Mac OS X) and click the central spine to add a set of points to adjust the
contour.

6. To modify the shape, you can:

» Move the selected points to a new area.
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» Pull the Bézier handle to move both points' handles as one.

-

» Hold Alt down and pull one of the Bézier handles to move it independently from the other one.

[ALT]

» Pull directly on the line in-between two points. No selection is necessary. Holding down the Shift key
limits the contour modification to the curve between the two first points.

» If an anchor point has no visible bezier, hold down the Alt key to display them.

7. Youcanalsousethe Brush s tool to draw some of the lines and change the tip to an oblique shape or
use a pen tablet which provides pressure sensitivity and lets you draw lines of variable thickness.
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10

Brush 3
20

Brush Fixed Width 1
1

Brush Fixed Width 2
10

Drawing with the Brush tool does not allow you to reshape your lines as easily as with the Polyline or Pencil
tool. The Brush tool creates contour vector lines (also known as fills) where the vector points are situated on
the line’s contour. Pencil lines are central vector lines in which the points follow the centre of the line.

Drawing Tasks

Harmony has a wide variety of drawing tools for all kinds of drawing tasks. This section covers how to use these
tools. For the complete details on their options in the Tool Properties view, see Drawing Tool References on page
119.

In this topic, you will learn about:

» Current Drawing on Top on page 40

» Drawing with the Pencil Tool on page 41

»  Drawing with the Brush Tool on page 53

» Drawing with Textured Brushes on Vector Drawing Layeron page 61

» Viewing the Final Lines as You Draw on page 83

» Selecting the Current Colour of a Tool on page 84Selecting the Current Colour of a Tool

» Selecting Drawing Objects on page 87

» Erasing Parts of a Drawing on page 91
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* Reshaping a Drawing Using the Contour Editor Tool on page 94

» Reshaping Pencil Lines on page 96

* Drawing Shapes on page 99
* Drawing with the Polyline Tool on page 100

»  Drawing with Invisible Lines on page 101

» Deforming a Drawing with the Perspective Tool on page 103

*  Warping a Drawing with the Envelope Tool on page 104

» Cutting Drawing Parts on page 106

* Smoothing Lines on page 107

»  Working With Text on page 108

» Tool presets let you save a variety of settings and are very handy and efficient for accessing the tools you
use most often. That way, the tool is already set with the desired properties, such as colour, line
thickness, whether to enable Draw Behind or Auto Flatten mode, and so on. You can create presets for
these tools and many more: Brush, Pencil, Eraser, Rectangle, Ellipse, and Line. First, select a tool, adjust
the properties, and then create a tool preset for it. Once you have created a tool preset, you can always
make adjustments to fine-tune it, as well as create a keyboard shortcut for it. on page 109

»  More Drawing Tools on page 112

Current Drawing on Top

In Harmony, when you draw on a layer, the artwork is displayed in the correct order. For example, if the layer on
which you are drawing is located behind an object on another layer, the lines you are drawing will be hidden behind
that object.

This lets you display the selected drawing on top of everything while you draw. By enabling this option, each time
you select a drawing tool, the selected drawing is displayed in front of everything in the Camera view. The
Timeline view ordering remain unchanged.

The Current Drawing on Top status (enabled or disabled) is remembered when you exit Harmony. When you
restart the application, the last status will be used.

You only need to enable this option once, it is not necessary to do it each time you select a drawing tool.
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How to display the drawing on top

1. Do one of the following:

» From the top menu, select View > Show > Current Drawing on Top.

> Inthe Camera bottom toolbar, click the Current Drawing on Top <> button.
2. Inthe Tools toolbar, select a drawing tool.

3. Inthe Camera view, start drawing.

Drawing with the Pencil Tool

The Pencil tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation. The
pencil creates a central vector shape. Pencil lines support pressure sensitivity and texture.

How to draw with the Pencil tool

1. Inthe Timeline or Xsheet view, select the cell on which you want to draw.

2. Inthe Tools toolbar, select the Pencil & tool or press Alt + /.

3. Inthe Colour view, click a colour swatch to select a colour.

4. Inthe Drawing or Camera view, start drawing.

» When you get close to an existing pencil line, hold Alt to draw and connect your stroke to the existing one.
Pencil lines are central vector lines and you might think your line is connected, but in fact, only the contour
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is touching the other one. Also, make sure the central vector crosses the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

» Todraw a straight line, press Shift + Alt as you draw.

&

How to modify the pencil settings

1. Inthe Tools toolbar, select the Pencil & tool or press Alt + /.

2. Inthe Tool Properties view, the preview area displays the stroke that will be produced after you customize
the different parameters in the Tool Properties view. Click the arrow button.

The Pencil Properties window opens.
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This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and
thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter

Description

Size and Smoothness tab

Maximum Size

Sets the maximum width of the line.

Minimum Size

Sets the minimum width of the line in relation to the maximum size.

Lets you modify the central line smoothness of the line. This parameter smooths

Smoothness the initial movement of your line. Increasing the value will result in a smoother line
with fewer control points.
Optimizes the contour line smoothness of the line. This parameter will smooth the

Contour Smoothness contour of the line once it has been traced; the higher the value, the fewer control
points will compose your line.

Shape

You can adjust the start, end, and joint style of a selected pencil line.

+ Start: Lets you select the style of the start tip, which is the first tip you
drew. You can choose between Round or Flat style.

+ End: Lets you select the style of the end tip, which is the last tip you drew.
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You can choose between Round or Flat style.

* Join: Lets you select the joint style. The joints are where the line curves
abruptly. You could also define the Join style as the corner style. You can
choose between Round, Mitre and Bevel style.

Texture tab

Texture See Pencil Line Texture on page 49.

Working with Pencil Presets

A pencil preset is a pencil with specific properties. You can work with regular pencil presets and thickness
stencils.

Regular pencil presets allow you to set the size and smoothing of the line or shape. As you draw, the thickness of
the line varies according the amount of pressure you apply with a pen and tablet.

Thickness stencils that are indicated with this < icon are also set with specific properties, but disregards the
pressure you use with your pen and tablet. The line thickness varies. You can access thickness stencils from the
list of presets on the Tool Properties view or create your own.

How to select a pencil preset

1. Inthe Tools toolbar, select the Pencil # , Line , , Ellipse (3 , or Rectangle — tool.

2. Inthe Tool Properties view, use the Presets menu to select a pencil preset.

3. Inthe Drawing or Camera view, draw your pencil line or shape.
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How to select a pencil thickness stencil

1. Inthe Tools toolbar, select the Pencil ¢ , Line , , Ellipse 3 , or Rectangle — tool.

2. Inthe Tool Properties view, use the Presets menu to select a thickness stencil. They are marked with this <
icon.

Tapered Thickness Stencil
12

Tapered Beginning Thickness Ste... _
12 RN
Ly
lapered End Thickness Stencil
12

3. Inthe Drawing or Camera view, draw your pencil line or shape.

How to create a pencil preset

1. Inthe Tools toolbar, select the Pencil & , Line , , Ellipse (3 , or Rectangle — tool.

2. Inthe Tool Properties view, adjust your pencil settings—see How to modify the pencil settings on page 42.

3. Inthe Tool Properties view, click the New Brush <4 button.

The New Preset dialog box opens.
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4. Type inaname for your new pencil thickness stencil and click OK.
5. Start drawing in the Drawing or Camera view.
How to create a pencil thickness stencil

1. Inthe Tools toolbar, select the Select x tool.

2. Inthe Camera view, select the pencil line or shape from which you want to take the style.

3. Inthe Tool Properties view, click the New Thickness Stencil 4 button.
A new thickness stencil is added to the end of the list in the Presets menu.
4. Inthe Presets menu, select a new thickness stencil and click on a line or shape in the Drawing or Camera

view to apply the thickness stencil you created.

How to apply a thickness stencil to a pencil line or shape

1. Inthe Tools toolbar, select the Select w tool.

2. Inthe Drawing or Camera view, select the pencil line or shape on which you want to apply a style.

3. Inthe Tool Properties view, select the style you want to apply from the Presets list.
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Tapered Thickness Stencil
12

Tapered Beginning Thickness Ste... _
12 &
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lapered End Thickness Stencil
12

The style you selected is applied to your selection.

How to rename a thickness stencil or pencil preset

1. Inthe Tools toolbar, select the Pencil ¢ , Line , , Ellipse 3 , or Rectangle — tool.

2. Inthe Presets menu, select the thickness stencil or preset you want to rename.

3. From the Brush menu =] , select Rename Brush.

The Rename Preset dialog box opens.

4. Inthe Name field, type in the new name.

5. Click OK.

How to delete a thickness stencil or pencil preset

1. Inthe Tools toolbar, select the Pencil & tool.
2. Inthe Presets menu, select the thickness stencil or preset to delete.

3. Click the Delete Preset -4 button.

How to import pencils, brushes and erasers

1. From the Brush menu =] , select Import Brushes.
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2. Inthe browser window that appears, navigate to and select the . xm1 file.
3. Click Open.

4. Inthe Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also
import pencils at the same time.

MyBrush
10 B

MyEraser
30 E

hashes
066.2 BB

Soft Eraser
130 BE

<]

5}
m
&

<<
i
m

Import

5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the
imported tips to create other brush, eraser and pencil style presets.

How to export pencils, brushes and erasers

1. From the Brush menu, select Export.

2. Inthe Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as
any pencils.
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3. Click Export.

4. Inthe Export Brushes window that appears, browse to the location where you want to save the .xml file and
give it a name.

5. Click Save.

How to change the Presets Library thumbnail display

1. From the Brush menu, select one of the following:

Parameter Description

Reduces the size of the thumbnails in order to view more at the same time. Dis-

Small Thumbnail . . . . .
plays an image of the tool's tip and its maximum size.

Increases the size of the thumbnails in order to see the images more clearly. Dis-

Large Thumbnail . - . . .
arge Thumbna plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.

Pencil Line Texture

You can apply a texture to a pencil line. Pencil lines support texture. Before drawing, you can select or import a
texture and apply it to your lines. You can also change it afterwards using the Select tool. Textures are independent
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from pencil templates.

When you import a texture in your pencil styles, it is saved in your scene. If you want to add that texture to a bank
that you will reuse in different scenes, you can add that texture to your preferences.

How to apply a preset texture to a pencil line

1. Inthe Tools toolbar, select the Pencil & tool.

2. Inthe Tool Properties view, the preview area displays the stroke that will be produced after you customize
the different parameters in the Tool Properties view. Click the arrow button.

3. Inthe Pencil Properties editor, select the Texture tab.

Size and Sme

Chalk | Charcoal | Rough

Felt_R... Felt Gradient..., Grain
WP | I | —

Bumpy... | Bumpy_...| Bumpy_...| Dash

4. Inthe Texture library, select a texture for the pencil.

5. Inthe Camera or Drawing view, draw a pencil line.

How to create a pencil texture template with the Pencil tool

1. Inthe Tools toolbar, select the Pencil & tool.

2. Inthe Tool Properties view, click the arrow button beside the stroke preview area.
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3. Inthe Pencil Properties editor, click the New Texture
menu.
» Todelete a preset style, click the Delete Texture
= menu.
4. Browse for your bitmap texture file.
NOTE:

button or select New Texture from the Texture =

button or select Delete Texture from the Texture

The following file formats are supported: .jpg, .png, .psd, .sgi, .tif. Your texture MUST HAVE an alpha channel.

5.

6.

Click Open.

The imported texture is saved in your texture list.

In the Pencil Properties editor, select your new texture.

Chalk | Charcoal | Rough

Felt_R... Felt Gradient..., Grain

VAP I | —

Bumpy... | Bumpy_...| Bumpy_...| Dash
|

Click the Texture menu = and select Rename Texture.

The Rename Opacity Texture dialog box opens.

In the Name field, type the template name and click OK.

In the Camera or Drawing view, draw your pencil line with your new texture.
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How to add a texture to your preferences

1. Inthe Tools toolbar, select the Pencil & tool.

2. Inthe Tool Properties view, click the arrow button beside the stroke preview area.

3. Inthe Pencil Properties editor, select a texture from the Textures area to add to your preferences.

4. Click the Copy to Preference 0 button.

How to apply a preset texture to a pencil line

1. Inthe Tools toolbar, select the Select x tool.

2. Inthe Drawing or Camera view, select a pencil line.
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3. Inthe Tool Properties view, select a texture from the Textures area to apply to the selected stroke.

The Brush tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if it was
created with a paint brush.

With the Brush tool, you can draw as vector or bitmap, depending on your preference. When you add a drawing
layer, you can simply select the vector or bitmap option. If you draw with vector, you can enlarge your drawing and
zoom into it without losing quality or resolution. You can also use the Contour Editor and Select tools to resize and
modify lines. If you draw with bitmap, you will not be able to scale your drawing beyond 100% of its resolution
without encountering pixelization issues.

You can create your own brush styles. A variety of brush styles are provided allowing you to create and save your
own.This way you can create brushes with precise sizes and parameters and save them so you can draw and
design with them. Renaming a brush can make it easier to identify and access the brushes you use most frequently.

A dynamic brush can be created for drawing using patterns created from your artwork. Create a new dynamic brush
to copy a pattern you have drawn to reproduce it quickly. You can create dynamic brushes using a single or multiple
patterns that automatically switch through the patterns as you draw.

53



Chapter 4: Design and Drawing Tools

How to draw with the Brush tool

1.

8.

In the Timeline view, click the Add Drawing Layer «. button or press Ctrl + R (Windows/Linux) or 38 + R
(Mac OS X).

The Add Drawing Layer window opens.

®
o

Add and Close Close

In the Name field, name your new layer.
Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap layer.

Do one of the following:

» Click Add to add a first layer and keep the window open to add more layers.
» Click Add and Close to add a new layer and close the window.
A new drawing layer is added to the Timeline view.

In the Timeline or Xsheet view, select the cell on which you want to draw.

In the Tools toolbar, select the Brush ~ tool or press Alt + B.

In the Colour view, click a colour swatch to select a colour.

In the Drawing or Camera view, start drawing.

» Hold Ctrl (Windows/Linux) or 3£ (Mac OS X) to force a line to join the start and end of the shape while
drawing.
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&

How to select a brush style

1. Inthe Tools toolbar, select the Brush s tool or press Alt + B.

2. Inthe Tool Properties view, select a brush style from the Presets section.

Brush Fixed Width 1
1

Brush Fixed Width 2

How to modify the brush settings

1. Inthe Tools toolbar, select the Brush s tool or press Alt + B.

2. Inthe Tool Properties view, the preview area displays the stroke that will be produced after you customize
the different parameters. Click the arrow button.

The Brush Properties window opens.

55



Chapter 4: Design and Drawing Tools

This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description
Size and Smoothness Tab
Maximum Size Sets the maximum width of the line.
Minimum Size Sets the minimum width of the line in relation to the maximum size.
Lets you modify the central line smoothness of the line. This parameter
Smoothness smooths the initial movement of your line. Increasing the value will result in a
smoother line with fewer control points.
Optimizes the contour line smoothness of the line. This parameter smooths the
Contour Smoothness contour of the line once it has been traced. The higher the value, the fewer con-
trol points will compose your line.
Lets you select a tip shape—from round and square ones to star shaped. This
] option is disabled when using a textured brush.
Tip Shape
ONI|//—~ \\Vl@®kX
Texture Tab
Texture See Drawing with Textured Brushes on Vector Drawing Layeron page 61

NOTE: If you are trying to create artwork on a bitmap drawing layer, and therefore with a bitmap brush, see
Drawing with Bitmap Brushes on Bitmap Drawing Layers on page 72

How to create a brush preset

1. Make sure your current brush has the settings you want in the preset you will create.
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2. Inthe Tool Properties view, do one of the following:

> Click the arrow button to display the Brush Properties window and click the New Brush 4 button in the
upper-right corner.

> Click the New Brush 74 button.

» From the Brush |z menu, select New Brush Preset.

3. Inthe New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush presets.

How to update a brush preset

1. Select the brush preset to update and click the arrow button to display the Brush Properties window.

2. Change the brush settings and click the Update Brush Preset 74 button in the upper-right corner.

How to rename a brush

1. Inthe Tool Properties view, select a brush to rename.

2. Fromthe Brush |z menu, select Rename Brush.

3. Typeinanew name for the brush and click OK.

How to delete a brush preset

1. Inthe Tool Properties view, select the brush preset you want to delete.

2. Do one of the following:
» Click the Delete Brush -4 button.

» From the Brush menu , select Delete Brush.

How to create a new dynamic brush

1. Inthe Tools toolbar, select a drawing tool.

2. Inthe Camera or Drawing view, draw the pattern you want to use as your dynamic brush stamp.
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3. Inthe Tools toolbar, click the Select w tool and select the parts of the drawing you want to repeat.

for

4. Inthe Tools toolbar, select the Brush -+ tool or press Alt + B.

5. Inthe Tool Properties view, click the Add Dynamic Brush 14 button to add your selection as a new
dynamic brush preset.

6. Fromthe Brush |z menu, select Rename Brush.

7. Typein a name for the new dynamic brush and click OK.

8. Inthe Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.

WA

9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, adjust the Maximum Size
value in the Tool Properties view.

How to create a dynamic brush with multiple drawings

1. Inthe Timeline view, click the Add Drawing Layers «. button to create the layers you want to use as pat-
terns in your dynamic brush. Make sure to rename your layers.
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2. Inthe Camera view, draw the individual drawings of your pattern on separate layers.

3. Inthe Tools toolbar, select the Select w tool.

4. Inthe Tool Properties view, disable the Works on Single Drawing £ option to allow the Select tool to grab
artwork on multiple layers.

5. Inthe Camera view, select all the drawings you want to add to your new dynamic brush.
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6. Inthe Tools toolbar, select the Brush - tool or press Alt + B.

7. Click the Add Dynamic Brush 14 button to add your selection as a new Dynamic Brush preset.
8. From the Brush menu, select Rename Brush.

The Rename Preset dialog box opens.
9. Typein a name for the new dynamic brush and click OK.

10. Inthe Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern. When
you use this brush, you will cycle through the drawings.
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Drawing with Textured Brushes on Vector Drawing Layer
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In Harmony, you can use the Brush  tool to draw bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured "brushes", but you can also create and
import your own custom collection. In Harmony, when using a textured brush on a vector layer, the texture of a brush
is referred to as the Paper Texture. In other words, we are attributing the texture not to the tool, but to the texture of
the surface that is revealed when a stroke passes over it. You will understand why when you work with bitmap
brushes on bitmap layers, where it is possible to have both a textured brush tip and a paper texture.

To create your own textured brush, you must prepare your texture file ahead of time, either in Harmony or in a third-
party software, such as Adobe Photoshop. Colour is not supported and transparency is not supported in the
traditional sense. Black appears as 100% opaque, white appears as 100% transparent, and all the shades of grey in
between appear as varying degrees of semitransparenty. A range of file formats are supported—.jpeg, .png, -tif, .psd,
.tga to name a few. Alpha channels are disregarded on import. It is recommended that you maintain the texture
resolution between 100 x 100 pixels and 400 x 400 pixels.

You can import your custom paper textures in the extended Brush Properties window. Browsing for a texture file with
a brush selected that is already using a paper texture will replace the file currently in use. It will not, however, replace
the texture in lines already drawn. The replaced texture swatch will no longer be the selected texture, but it will
remain in the texture library and not be deleted.

Harmony also allows you to import textures as an .xml file that was exported from another project. In this way, you
do not have to import individual image files one-by-one to have the same texture library and brush presets as others
who you are collaborating with. You can also export brush presets and textures, in order to share your default or
customized textures and presets with other project collaborators.

61



Chapter 4: Design and Drawing Tools

When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and you lose the
feather created while drawing with the Brush tool. In Harmony, a special option in the Eraser Tool Properties lets
you create a soft edge on your textured lines. You can also cut or keep the vector frame as is.

At some point, you may want to modify the look of a textured drawing if you suddenly find that your lines look too
hard or too light. You can adjust those parameters by using the Adjust Line Texture Opacity command.

To draw with textured lines, use the Brush tool and the correct brush in the list. You can also draw with pencil line
texture—see Pencil Line Texture on page 49

How to draw with textured lines

1. Inthe Tools toolbar, select the Brush -~ tool or press Alt + B.

2. Inthe Tool Properties view, select a brush and click the Arrow button to open the Brush Properties view.

4. Set the following parameters:

Parameter Description
The hardness value corresponds to the softness of the line edge. The lower the
Hardness value, the softer the line edge will be. The higher the value, the sharper the line
edge will be.
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Maximum Opacity

This value corresponds to the transparency of the stroke when the pressure is
heavy.

Minimum Opacity

This value corresponds to the transparency of the stroke when the pressure is
light and is a percentage of the Maximum Opacity value.

6. Adjust the Texture Scale to change the size of the texture in the lines you draw. If you are using a plaid tex-
ture, the squares will be larger if you increase the value and smaller if you decrease it.
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7. Inthe Camera or Drawing view, start drawing.

]
T e

-l""'.

How to add a paper texture

1. Do one of the following:

» From the Paper Texture menu , select Add.
» Click the Add Paper Texture button.
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2. Inthe browser window that appears, navigate to where you saved your texture file.

3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.

How to rename a paper texture

1. Inthe Paper Texture library, select a texture.

2. From the Paper Texture menu, select Rename.

3. Inthe Rename Texture dialog box that appears, type in the new name for the texture.

4. Click OK.

How to delete a paper texture

1. Inthe Paper Texture library, select a texture.

2. Do one of the following:

» Inthe Paper Texture menu, select Delete.
» Click the Delete button.
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NOTE: You can delete any texture in the texture library as long as there is no brush preset using it.

How to change the Paper Texture thumbnail display

1. From the Paper Texture menu, select one of the following:

Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.
Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.
List View Allows you to see the name, as well as the thumbnail.

How to import paper textures

1. Inthe Paper Texture menu, select Import.

2. Inthe browser window that appears, navigate to and select the . xm1 file.

3. Click Open.

4. Inthe Import Textures dialog box, select the paper textures that you wish to import. You can import any
available brush tips at the same time too.
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Select items from the list:

Import

5. Click Import.

The imported paper textures will appear in the Paper Texture Library. You can reuse any of the imported paper
textures to create other brush style presets.

How to export paper textures

1. Inthe Paper Texture menu, select Export.

2. Inthe Export Tips and Textures window, scroll down the textures list to the paper textures and select or
deselect any textures to create the list that you wish to export. You can export brush tips at the same time

too.
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3. Click on the Export button.

4. Inthe Export Textures window that appears, browse to a location where you would like to save the .xml
file and give it a name.

5. Click Save.

How to erase textured lines

1. Inthe Tools toolbar, select the Eraser ¢ tool, press Alt + E.

2. Inthe Tool Properties view, click the arrow button.

The Eraser Properties window opens.
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nd Smoothness

3. Adjust the following:

Soft Eraser

Parameter

Description

Size and Smoothness Tab

Maximum Size

Sets the maximum width of the line.

Minimum Size

Sets the minimum width of the line in relation to the maximum size.

Lets you modify the central line smoothness of the line. This parameter smooths

Smoothness the initial movement of your line. Increasing the value will result in a smoother line
with fewer control points.
Optimizes the contour line smoothness of the line. This parameter smooths the

Contour Smoothness contour of the line once it has been traced. The higher the value, the fewer control
points will compose your line.
Lets you select a tip shape—from round and square ones to star shaped. This

] option is disabled when using a textured brush.
Tip Shape

ONI// . —~ \\VlexX

Soft Eraser Tab

Defines the softness of the stroke edge. The lower the value, the softer the stroke

Hardness edge will be. The higher the value, the sharper the stroke edge will be.
Lets you adjust the softness of edge feathering. Works in conjunction with the
Saturation Hardness, e.g. 100% Hardness will yield no results in saturation change. 0%

Hardness will allow a fine tuning of the feathering of the soft stroke edge.

Maximum Opacity

The transparency of the brush when the pressure is heavy. A smaller value will
leave semi-transparent colour and texture. A larger value will ensure that
everything is properly erased. This option in unavailable if the Keep Vectors
option is disabled.
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Sets the minimum transparency of the brush, in relation to the Maximum Opacity,
when the pressure is very light. A smaller value will leave semi-transparent colour
and texture. A larger value will ensure that everything is properly erased. This
option in unavailable if the Keep Vectors option is disabled.

Minimum Opacity

Keeps the vector frames around your strokes intact, only the texture fill dis-
appears. Disabling this option will cut the stroke's vector frame into different
pieces when the Eraser tool passes over it. If you disable this option, the max-
imum and minimum opacity sliders are disabled as well.

Keep Vectors

4. Inthe Camera or Drawing view, erase your textures lines.

) ) )
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Max. Opacity = 753% Meoe. Opacity = T5% Maoe. Opacity = 100% Max. Opacity = 100%
Hardness = 0% Hardnass = 1003% Hardrass = 5% Hardness = 100%
Saturation = 100% Saturation = RA& Saturatgn = 100% Soturaton = MNA

How to adjust the line texture opacity

1. If you are in Camera view, select the Current Drawing on Top option—see Current Drawing on Top on
page 40.

2. Inthe Timeline or Xsheet view, select the drawing that contains the opacity you want to adjust.

3. Inthe Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line Texture Opacity dialog box opens.

Adjust Line Texture Opacity |2 |
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4. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.

5. If you want to apply the changes to all drawings exposed on the layer, select the Apply to All Drawings

option and click OK.
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Drawing with Bitmap Brushes on Bitmap Drawing Layers

N

With Harmony, you have the choice to draw with vector or bitmap brushes. This is decided by what modes you
select for your layer. When adding a new drawing layer in Harmony, you can set your art layers (Line Art, Colour
Art) to vector or bitmap. This way, you can draw in bitmap and paint in vector, draw everything in bitmap, or any
other combination that suits your needs. If you are using the Overlay and Underlay layers, you can also set them
to either bitmap or vector.

Not all drawing tools are available when working on a bitmap layer. You can use the following tools:

¢ Brush
e Cutter
»  Dropper

« Edit Gradient/Texture

« Ellipse
* Eraser
+ Line

* Paint

* Paint Unpainted
*  Pivot

* Rectangle

*  Repaint

* Reposition All Drawings

* Select
e Text
* Unpaint

Any tool that is unavailable for use will be greyed out.

On a bitmap layer, a temporary vector layer is created when painting with a gradient. Until a modification is made
on your layer with a bitmap drawing tool, you can edit your last painted zone—by either editing the gradient
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swatch, which is dynamically linked to the painted zone or with the Edit Gradient texture tool. The moment a bitmap
drawing tool or action is used, a vector-to-bitmap conversion occurs. If there are vector elements on the layer (such
as if you switched your art mode from vector to bitmap after having created vector artwork), they too will be
converted to bitmap.

Here is a list of tools and actions that will trigger a vector-to-bitmap conversion:

* Brush
+ Ellipse
+ Eraser
* Line

+ Paint

+ Paint Unpainted
* Rectangle
* Repaint
* Unpaint
» Performing a paste with the Select tool selected
» Performing a paste with the Cutter tool selected
This means that certain tools, such as the Text tool or the Cutter tool, will not trigger a conversion.

If you selected the incorrect art modes for your layer, you can open the Layer Properties view and change them. If
you switch the art mode for a layer that already has strokes onit, the artwork will NOT be converted for bitmap
artwork, but will be for vector artwork, though not immediately. A drawing with bitmap strokes on a newly converted
vector layer will remain bitmap. This means that the bitmap artwork will not be editable by some tools, such as the
Eraser tool, but will be editable by other tools, such as the Cutter tool. However, a drawing with vector lines on a
newly converted bitmap layer will remain vector temporarily, until a bitmap drawing tool or action is used. Then the
vector-to-bitmap conversion will occur.

To always reuse the same art mode settings, you can adjust them in the Preferences dialog box.
If you want to be able to edit the artwork in the new mode, you need to convert the drawings.

Vector-to-bitmap conversion includes flattening individual drawings into a single image. Flattening means that it will
not be possible to select non-overlapping or overlapping elements as individual objects with the Select tool. Instead,
the selection of one drawing will initiate the selection of all elements, with a single vector frame surrounding them.

Resampling is also triggered on bitmap layers with the use of a bitmap drawing tool. For example, if you draw the
outline of a circle, scale it down and then zoom into it, you will see tiny square pixels along the edge of the line. If you
then draw a line right next to it, you will notice two things: first that the square pixels of the new line are gigantic by
comparison and that the pixels in the line of your circle suddenly become the same size. This is because the circle
was resampled. It was not resampled when you scaled it down. It was resampled when you used a bitmap drawing
tool. It is resampled so that all the drawn objects are scaled to the same bitmap grid, in other words that their basic
unit, the pixel, is the same size. The grid is defined by the bitmap layer's resolution.
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Before resampling After resampling

Before you start drawing in bitmap, it is important to understand that your artwork will now be resolution
dependent. If you zoom in your scene, you artwork will be enlarged. It is important to plan ahead and decide how
high of a resolution you need your artwork to be. If you plan to zoom in your scene, the smallest section of the
image that the camera will frame must be 100% the size of your scene resolution. For example, if your scene
resolution is set to 1920 x 1080 and you zoom- in 300% with your camera, then the resolution of the bitmap layer
also has to be set to 300%, otherwise its elements will look pixelated in the final render. It is important to change
the bitmap layer resolution before you start drawing.

5760/ 1920 x 100 = 300%

1080 x 3 = 3240

1920 x 3 = 5760
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The bitmap resolution can be set at the scene level or drawing level. The setting at the scene level affects newly
created bitmap art layers.

Note that even if your drawing resolution is set to be very large, it doesn't mean that your file will be very heavy. It
depends on the amount of artwork you draw in it.

The yellow tiles are the spaces containing artwork. The white tiles are empty spaces.
—, Making the bitmap image much lighter.

The bitmap resolution (width and height) is the resalution of the tiles in relation to the
project resolution.

There is a function to change the resolution of bitmap art for individual drawings. You can reduce the resolution of
your bitmap file as well as increase it. Be careful because enlarging the bitmap resolution on an existing drawing will
result in a loss of quality.Harmony will perform a pixel smoothing pass (resampling) and create additional pixels to
avoid losing too much quality, but only to a certain extent. For example, what if you used the default scene’s
resolution for some bitmap art, but then discover you are zooming-in quite close? If you do not want to see the pixels
appear too much when you are zoomed in, you can set the bitmap resolution to 200% and the bitmap art will have a
higher resolution with smaller pixels, but will NOT retain 100% of its quality. You can use this function on multiple
drawings using the Apply to All Drawings option. Changing this option will affect existing and selected bitmap art
layers.

If you draw an outline on a bitmap layer, you can still vectorize it. Using a vector drawing layer, simply select your
bitmap drawing and the vector cell of where you want your vectorized line to be, and use the Vectorize Line Art in
Selected Drawing function.

You should avoid scaling up your bitmap strokes using the Select tool. If you do, keep in mind that when you
continue drawing, your image will be resampled and your new strokes will be scaled to the scene resolution.

Scaled-up bitmap drawing before Scaled-up bitmap drawing resampled.
reesampling The new brush stroke triggers the
resampling.
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NOTE: Your drawing should be scaled up using the Transform ;-; tool when animating, instead of the Select

tool, in order to avoid creating very large bitmap layers. Harmony calculates the scaling of your drawings when
you use the Transform tool; your image is mathematically transformed. When you use the Select tool to scale, you
are physically scaling the drawing.

How to add a bitmap layer

1. Inthe Timeline view, click the Add Drawing Layer 4. button,

The Add Drawing Layer window opens.

®
oy

Add and Close

Add and Close

2. Foreach art layer, select the Vector or Bitmap option.

3. Click OK.

How to change the art mode

1. Open the Layer Properties view.
2. Inthe Timeline view, select the layer you want to edit.

3. Inthe Layer Properties view, select the Drawing tab.
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4. Inthe Art Layers section, select the art mode for each art layer.

How to convert drawings to match the art mode

1. Inthe Timeline view, select the layer that contains the drawings you want to convert.

2. From the Timeline view menu, select Layers > Convert Drawings to Match Art Layer Type.

You can also right-click on the selected layer and select Convert Drawings to Match Art Layer Type.

All drawings in the layer are converted to the selected art mode. Note that bitmap strokes are not vectorized
when converted to a vector art layer. They are simply inserted in a square vector frame containing a bitmap

texture.
How to change the bitmap layer resolution at the scene level

1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.
2. Select the Bitmap Resolution tab.

3. Change the bitmap resolution settings and click OK.

The bitmap resolution settings at the scene level affects newly created bitmap art layers.
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The yellow tiles are the spaces containing artwork. The white tiles are empty spaces.

-"2---.__ making the bitmap image much lighter.

The bitmap resolution (width and height) is the resolution of the tiles in relation to the

project resolution.

Parameter

Description

Scene Resolution

This is the scene resolution preset name and size in pixels.

This is the width of the resolution for the bitmap that will be created. This is not
the actual size of the bitmap. TVG drawings (Toon Boom drawing native
format) have an infinite size. Bitmap TVGs are composed of small tiles. There-

Width fore it does not mean that because you have artwork at the four corners of your
camera frame or even quite far outside of your drawing that your bitmap image
will be very large and heavy. By default, it is set to the same width as the
scene resolution.

Height This is the height of the resolution for the bitmap that will be created. By

default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If
you increase the percentage, the width and height fields will increase accord-
ingly. If you plan to animate the camera and zoom into your background, you
will need to set a higher resolution so that the smaller area in which you will
zoom will be 100% of the scene resolution.

How to change the bitmap resolution at the drawing level

1. Inthe Timeline view, select the drawing whose resolution you want to change.

NOTE: Note that the drawing can be enlarged slightly and retain its original look, but you may lose quality if you
enlarge it too much. Pixels are created and a smoothing pass is applied. You should set your resolution before
drawing. If you need to change the resolution of a drawing to be larger than the one setin the Scene Settings
dialog box, create an empty drawing first and then follow this procedure.

2. From the top menu, select Drawing > Change Bitmap Drawing Resolution.

The Change Bitmap Drawing Resolution window opens.
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Parameter

Description

Scene Resolution

This is the scene resolution preset name and size in pixels.

This is the width of the resolution for the bitmap that will be created. This is not
the actual size of the bitmap. TVG drawings (Toon Boom drawing native format)
have an infinite size. Bitmap TVGs are composed of small tiles. Therefore it does

Width not mean that because you have artwork at the four corners of your camera frame
or even quite far outside of your drawing that your bitmap image will be very large
and heavy. By default, it is set to the same width as the scene resolution.

Height This is the height of the resolution for the bitmap that will be created. By default, it

is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If you
increase the percentage, the width and height fields will increase accordingly. If
you plan to animate the camera and zoom into your background, you will need to
set a higher resolution so that the smaller area in which you will zoom will be
100% of the scene resolution.

Resample Bitmap

When this option is selected, the existing bitmap image is modified to match the
new resolution. If the width and height are increased, more pixels will be created
to enlarge the image. Visually, the existing artwork will look the same, maybe a
little bit smoothed out, but the size will look the same. When this option is
deselected, the artwork is not modified. Only the reference grid is resized. If the
scene resolution is 1920 x 1080 and you reduce the bitmap resolution to 960 x
540, the image will be scaled up to twice the size of the scene.

Apply to All Drawings

The modified settings are applied to all drawings in the drawing layer for a given
art layer. If the Apply to Line Art and Colour Art option is enabled, it will then be
applied to all bitmap art layers.

3. Change the bitmap resolution.

4. Click OK.

How to draw with bitmap brushes

1. Inthe Timeline view, add a bitmap drawing layer—see How to add a bitmap layeron page 76.

2. Inthe Tools toolbar, select the Brush - tool or press Alt + B.

3. Inthe Colour view, select a colour.
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» To switch the bitmap colour picker from HSV to RGB, in the Colour view menu, select Colour >
Bitmap Colour Sliders > HSV Sliders or RGB Sliders. You can also right-click on the colour sliders
and select RGB Sliders or HSV Sliders.

Wb

When using bitmap colours, there is no longer a link between the painted zones and selected colour. You can edit
the colour as much as you want, but your drawing will not be affected. You can still select colours from your
vector colour palette to use the same tint, but you will not create links between your drawing and the swatches.

4. Inthe Camera or Drawing view, start drawing.

How to vectorize a bitmap drawing

1. Inthe Timeline view, add a vector drawing layer BELOW the bitmap drawing layer containing the drawing
to vectorize. In your bitmap drawing, the artwork to vectorize must be placed on the Line Art layer (default
drawing layer).
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NOTE:
If you place the vector drawing on top of the bitmap layer, you will not be able to perform the operation. A warning

dialog box will display.

2. Ontheright side of the Timeline view, select the bitmap drawing and corresponding cell in the vector drawing
layer.

3. Right-click and select Drawings > Vectorize Line Art in Selected Drawing.

The Convert to Vector Drawing dialog box opens.

4. Inthe Vectorization section, select a vectorization preset. You can customize your own preset using the Add
or Edit buttons.

5. Click OK.

Your vectorized drawing is created in the vector drawing layer. Your bitmap drawing remains intact.

Creating Bitmap Brushes

With bitmap brushes in Harmony, you can create an infinite range of fuzzy, textured and watercolour lines. You can
combine two different brush tips, with separate sets of parameters, with the Dual Tip feature. You can also select a
paper texture that will mimic the texture of the surface that is being painted on. Uses these features separately orin
combination to create distinct, natural-looking strokes.

How to create a Bitmap Brush

1. Inthe Timeline view, create a new Bitmap drawing layer.
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2. Inthe Tools toolbar, select the Brush - tool or press Alt + B.

3. Inthe Tool Properties view, select a brush and click the Arrow button to open the Bitmap Brush Properties
view.

Tip | Transparency W o Tip =

Default | brush0l | brush02 | brush03

_JL

brush04 | brush05 | brush06 | brush07

i

brush08 | brush02 | brushl0 | brushll
™

5. Click on the different tabs to access the options available for adjustment. You can use the brush stroke pre-
view at the top to view all your adjustments in real time.
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» Tip tab: Make adjustments to size, brush tip angle, hardness and spacing—see Bitmap Brush Tool
Options on page 129.

» Transparency tab: Make adjustments to flow and opacity—see Transparency Tab on page 140.

» Dual Tip tab: Select this option to enable the Dual Tip feature. Select a dual brush tip and make
adjustments to its size, brush tip angle, hardness and spacing—see Dual Tip Tab on page 143.

» Paper Texture tab: Select this option to enable the Paper Texture feature. Select a paper texture and
make adjustments to its scale, alignment and additivity—see Paper Texture tab on page 147.

6. When you are satisfied with the look of your bitmap brush, click the Add New Brush Preset 4 button at the
top-right corner of the Bitmap Brush Properties window.

7. Inthe New Preset dialog box that appears, enter the name for your brush preset.

8. Click OK.

If you continue to make adjustments to your new brush preset and want to save these changes, click the
Update Preset f'db/, button. Otherwise, your modifications will only be saved until another brush preset or
drawing tool is selected.

Viewing the Final Lines as You Draw

Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. Although, when
you draw in the Drawing or Camera view, notice that your lines may appear jagged. This is caused by the fast real-
time display called OpenGL. If you prefer to see smooth lines as you draw, you can enable the antialiasing
preference.
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Full Scene Antialiasing

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias your
drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on and off;
by default, it is disabled.

There is no need to modify your graphic card settings.

NOTE: Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be
rendered to 100% of its resolution regardless of your preference settings or graphic card panel.

How to customize the full scene antialiasing parameters

4.

NOTE: You must restart Harmony after you change the parameters.

Do one of the following:

» From the top menu, select Edit > Preferences (Windows/Linux) or Stage Advanced > Preferences
(Mac OS X).
» Press Ctrl + U (Windows/Linux) or &£ + U (Mac OS X).

The Preferences dialog box opens.

In the OpenGL tab, go to the Full Scene Antialiasing section.

» Enable: Select this option to enable/disable the Full Scene Antialiasing.

Number or samples: Enter the number of samples you want to be used for the antialiasing process. The
number of samples is basically equivalent to the amount of times a pixel will be enlarged to calculate the
antialiasing. This technique is called supersampling. The higher the number of samples, the better the anti-
aliasing quality will be, but the longer it will take to calculate.

Restart Harmony.

Selecting the Current Colour of a Tool
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While drawing and painting, you can let Harmony retain the last colour you selected for each one of the following
tools:

* Brush
* Paint
» Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint, and Pencil tools.
How to unlink the storage swatches

1. Inthe Colour view, if the storage swatches are linked, click the Link button to unlink them.

TIEIETEE
III‘*

Unlink Three Colours

‘'m 48 <0
"

Set Current Brush Colour

nirt
shirt

3. Inthe Colour list, select the desired colour.

4. Click the Pencil g storage swatch.

5. Inthe Colour list, select a colour.

6. Click the Paint ® storage swatch.

*m /408 W

Set Current Paint Colour

7. Inthe Colour list, select a colour.
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NOTE: If you prefer to have Harmony use the same colour swatches regardless of the selected tool, you can link
the three swatches together.

How to link the storage swatches

1. Inthe Tools toolbar, select one of the following tools:

> Brush
> Paint
Pencil
Polyline
Line

Ellipse

OO0 N ORI @G

Rectangle

2. Inthe Colour view, if the storage swatches are unlinked, click the Link button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

How to link the storage swatches

1. Inthe Tools toolbar, select one of the following tools:

> Brush
> Paint
Pencil
Polyline
Line

Ellipse

OO0 N ORI @

Rectangle
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2. Inthe Colour view, if the storage swatches are unlinked, click the Link button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

Using Independent Colours when Working with Bitmap Layers

When working in the Colour view, by default the current colour is active for both vector and bitmap layers. You can
however, use different reference colours for each layer.

When using bitmap colours, there is no longer a link between the painted zones and selected colour. You can edit
the colour as much as you want, but your drawing will not be affected. You can still select colours from your vector
colour palette to use the same tint, but you will not create links between your drawing and the swatches.

How to use independent colours

» From the Colour view menu, select Colours > Independent Bitmap Colour.

Whichever colour you choose as the reference color is retained for that layer type.

Selecting Drawing Objects

Scale

Scale

Skew

Pivot point

i

Skew Rotate
The Select tool is used to select strokes in both the Drawing and Camera views, and apply basic transformations,
such as repositioning, rotating, scaling or skewing using the different handles of the bounding box.

Sometimes, when you want to select multiple objects while leaving one unselected, it can be handy to select only
the stroke or line that you do not want included in your selection. Then, you can invert the selection so that
everything else becomes selected. This can be quite a time saver.
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By default, when you draw a selection box, the Select tool will select only the drawing strokes of the current
drawing. If you prefer the Select tool to select all the strokes on all layers, you can disable the Works on Single

Drawing option in the Tool Properties view or the Select Tool Works on Single Drawing option in the Preferences
dialog box.

Some of the transformations, such as rotation, scale, skew, and flip are done relative to the position of the pivot
point. You can temporarily reposition this pivot point for a transformation using the Select tool.

How to select with the Select tool

1. Inthe Timeline view, select the cell on which you want to select drawing objects.

2. Inthe Tools toolbar, select the Select w tool or press Alt + S.

3. Inthe Camera or Drawing view, select the drawing objects.

» You can select all the drawing objects in a drawing by using Edit > Select All or by pressing Ctrl + A
(Windows/Linux) or 38 + A (Mac OS X).

4. To deform or reposition a selection:

» Toreposition, click the selected drawing object and drag the selection to a new area.

e

¥

» Torotate, grab the selection box handle and rotate it.

2

» Toscale, pull or push on the top, side, bottom or corner control point. Hold down Shift to lock the
selection’s ratio.
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» Toskew, drag sideways or up and down the sides or top and bottom segments, between the control
points.

How to invert a selection

1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + .

» You can also find the Invert Selection option in the Camera or Drawing View menu by selecting Edit >
Invert Selection.

How to enable and disable the Select Tool Works on Single Drawing preference

1. Inthe Tools toolbar, select the Select w tool or press Alt + S.

2. Do one of the followings:

» From the top menu, select Edit > Preferences (Windows/Linux) or Stage Advanced > Preferences
(Mac OS X). In the Camera tab, go to the Tools section and select or deselect the Select Tool Works on

Single Drawing option and click OK.
> Inthe Tool Properties view, disable the Works on Single Drawing £ option.

3. Inthe Camera view, make your selection. It is possible that you will have to restart Harmony depending on
your system.
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How to temporarily reposition the pivot point

1. Inthe Camera or Drawing view, select the drawing object you want to transform.

The pivot point appears in the middle of your selection.

Y

2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain there until
you make a new selection.
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Y

Erasing Parts of a Drawing

R

. "%@

7

The Eraser tool is pressure sensitive, like the Brush tool, giving you more precision when erasing parts of a drawing.
You can also use the Select tool to select drawing objects and delete them instead of erasing.

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when drawing
and designing. There are two icons located at the top, right corner of the Eraser Properties window. One is to create
a new preset, while the other is to update the currently selected preset. Use them after you have set all the

parameters for the new eraser preset.
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» New Brush Preset: Click on this button to create a new eraser brush style. The new eraser style will
appear at the bottom of the list in the Presets section of the Tool Properties window. All the values and
selected options in the Eraser Properties window will be attributed to this new style.

» Update Preset: Click on this button to update the selected eraser preset with any changes made in
the Eraser Properties window. If you make changes and do not click on the Update Preset button, then
all the changes made will only be applied to the selected eraser preset temporarily. The moment you
switch to another eraser preset or to another drawing tool, these modifications to the eraser preset will
disappear.

How to erase with the Eraser tool

1. Inthe Timeline or Xsheet view, select the cell that contains objects you want to erase.

2. Inthe Tools toolbar, select the Eraser & tool or press Alt + E.

3. Inthe Camera or Drawing view, start erasing.

How to modify the eraser settings

1. Inthe Tools toolbar, select the Eraser & tool .

2. Inthe Tool Properties view, the preview area displays the stroke that will be produced after you customize
the different parameters in the Eraser Properties view. Click the arrow button.

The Eraser Properties window opens.

nd Smoothness | [l soft Eraser

Soft Eraser
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The Size and Smoothness tab is where you set the minimum and maximum sizes of your drawing tool which will
produce the thick and thin effect on your stroke.

The Soft Eraser tab needs to be enable for its parameters to become active. This feature only works on soft or
textured brush strokes. Both tabs works with the pressure sensitivity of a pen tablet.

Parameter

Description

Size and Smoothness Tab

Maximum Size

Sets the maximum width of the line.

Minimum Size

Sets the minimum width of the line in relation to the maximum size.

Lets you modify the central line smoothness of the line. This parameter smooths

Smoothness the initial movement of your line. Increasing the value will result in a smoother line
with fewer control points.
Optimizes the contour line smoothness of the line. This parameter smooths the
Contour Smoothness contour of the line once it has been traced. The higher the value, the fewer control
points will compose your line.
Lets you select a tip shape—from round and square ones to star shaped. This
) option is disabled when using a textured brush.
Tip Shape
ONM|//—~ \\V ok X
Soft Eraser Tab
Hardness Defines the softness of the stroke edge. The lower the value, the softer the stroke
edge will be. The higher the value, the sharper the stroke edge will be.
Lets you adjust the softness of edge feathering. Works in conjunction with the
Saturation Hardness, e.g. 100% Hardness will yield no results in saturation change. 0%

Hardness will allow a fine tuning of the feathering of the soft stroke edge.

Maximum Opacity

The transparency of the brush when the pressure is heavy. A smaller value will
leave semi-transparent colour and texture. A larger value will ensure that
everything is properly erased. This option in unavailable if the Keep Vectors
option is disabled.

Minimum Opacity

Sets the minimum transparency of the brush, in relation to the Maximum Opacity,
when the pressure is very light. A smaller value will leave semi-transparent colour
and texture. A larger value will ensure that everything is properly erased. This
option in unavailable if the Keep Vectors option is disabled.

Keep Vectors

Keeps the vector frames around your strokes intact, only the texture fill dis-
appears. Disabling this option will cut the stroke's vector frame into different
pieces when the Eraser tool passes over it. If you disable this option, the max-
imum and minimum opacity sliders are disabled as well.
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Reshaping a Drawing Using the Contour Editor Tool

The Contour Editor tool is a powerful tool that allows you to add, remove or modify points on a vector line and
control them with Bezier handles. It is used to correct line shapes and modify a single part of a colour zone. If a
line is too thin or has a gap in it, you can modify and correct it with the Contour Editor tool. You can also use this
tool to create elaborate shapes.

The Contour Editor displays vector points around a shape and the central vector points in a pencil line. Pulling or
pushing on these points adjusts the brush’s line thickness. Points can be selected and deleted. Each point has
two Bezier handles for correcting the curves between two points. Shapes can be modified by pulling and pushing
directly on the segment between the points. You can use it to perfect a central shape pencil line, a contour shape
brush line, or even create an elaborate shape from a basic ellipse or square.

How to reshape with the Contour Editor tool

1. Inthe Timeline or Xsheet view, select the cell in which you want to draw.

2. Inthe Tools toolbar, select ashapetool: , & .

3. Inthe Tool Properties view, click the Ellipse 3 button, click the Auto Fill g button and set the pencil
sizeto 0.

4. Inthe Drawing or Camera view, draw a circle.

5. Inthe Tools toolbar, select the Contour Editor tool.
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In the Drawing or Camera view, click the line to reshape it.

Select one or several points by clicking on them or circling around.

m

Press Delete to delete a selected point.

Press Ctrl (Windows/Linux) or 3£ (Mac OS X)and click on the contour to add a new point to adjust the
contour.

To modify the shape, you can:

» Pull on the Bezier handle. Both point’s handles will move as one.

Hold down Alt and pull on one of the Bezier handles. The point’s handle will move independently from the
other one.

Move the selected points to a new area.

‘\'

Pull directly on the line between two points. No selection is necessary. Holding down Shift will limit the
contour modification to the curve between the two first points.
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» If an anchor point has no visible Bezier handles, hold down the Alt key to display them.
» To add control points, press Ctrl (Windows/Linux) or 3£ (Mac OS X) and click the line.
» Toremove control points, select the control point and press Delete.

Reshaping Pencil Lines

The Pencil Editor tool is used to modify the thick and thin contour o f a pencil line. A pencil line is a central vector
shape. The shape control points are located all along the central spine allowing you to adjust the stroke curve and
position. When using the Contour Editor tool, you can repos ition the spine of the stroke. When using the Pencil
Editor tool, you can ad just the thick and thin areas of lines.

Pencil Editor
Contour control poines
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How to use the Pencil Editor tool

1. Inthe Tools toolbar, select the Pencil Editor ¢ tool or press Alt + W.

2. Inthe Camera or Drawing view, select a pencil line and click the line to reshape it.

Contour Editor
Central spine control poink

Pencal Editor
Caontour contral points

3. Select one or several points by clicking them or circling around.
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4. Press Delete to delete a selected point.

5. Press Ctrl (Windows/Linux) or 3£ (Mac OS X) and click the central spine to add a set of points to adjust
the contour.

6. To modify the shape, you can:

» Move the selected points to a new area. If you select matching points on each side of the line, holding
the Shift key will move them both. This way you can thicken or thin a line from both sides at the same
time.

l

» Pull on the Bezier handle to move both points’ handles s one.

N

» Hold down Alt and pull on one of the Bezier handles. It moves the handle independently from the other
one.
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Alt

» Pull directly on the line between two points. No selection is necessary. Holding down the Shift key will
limit the contour modification to the curve between the two first points.

» If an anchor point has no visible Bezier handle, hold down Alt to display them.

Drawing Shapes

In Harmony, you can use the shape tools to draw circles, lines and squares. You can also easily reshape a square or
circle into a much more complex drawing such as these butterfly wings—see Reshaping a Drawing Using the
Contour Editor Tool on page 94 and Reshaping Pencil Lines on page 96.

How to draw with a Shape tool

1. Inthe Timeline or Xsheet view, select the cell on which you want to draw.

2. Inthe Tools toolbar, select ashapetool: , & .
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3. Toautomatically fill the shape, in the Tool Properties view, select the Auto Fill g option.

4. Inthe Camera view, click and drag to draw the shape.

» Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

» Hold down Alt to draw the rectangle or ellipse from its centre.

» Hold down Shift to snap the line every 15 degrees.

» Hold down Alt to snap the start or end of the line to a nearby stroke.

5. Use the Contour Editor tool to deform the shape and create your drawing.

Drawing with the Polyline Tool
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The Polyline tool is used to draw shapes with a central vector type of line. To form a shape, you click to add a point
and then, without releasing the mouse, pull the handle in the desired direction before adding the next point and repeat
the operation. To edit the shape, you can use the Contour Editor tool.

How to draw with the Polyline tool

1. Inthe Timeline view, select the cell on which you want to draw.
2. Inthe Tools toolbar, select the Polyline C, tool or press Alt + _.

3. Inthe Camera or Drawing view, click and drag to create a point and a Bezier handle to shape your line.

» Press Alt to pull only one handle, instead of two.
» Press Shift to snap the handles to 45, 90, or 180 degrees.

4. Click a new area and drag to create a second point and Bezier handle.

5. Repeat the previous step until your shape is completed.

6. Press Ctrl (Windows/Linux) or 3£ (Mac OS X) and click to release the Polyline tool from the current path or
shape that it is creating. Continue to use the tool to make multiple, independent paths or shapes.

7. If necessary, reshape the lines using the Contour Editor tool—-see Reshaping a Drawing Using the Con-
tour Editor Tool on page 94.

Drawing with Invisible Lines

There are two different ways to draw invisible lines.
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Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful for
drawing tones and highlights directly on the character.

The Stroke tool draws invisible lines only. You cannot add thickness to the line. Unlike the Close Gap tool that
creates a short, straight line between two points, the stroke line will stay exactly where you draw it. This tool can
be useful for closing a zone in a particular way or creating some hard shadows or highlight areas.

Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue stroke colour.
In Harmony, you can display the strokes in washed-out colours so that the invisible lines stand out.

How to draw invisible lines with the Pencil tool

1. Inthe Timeline or Xsheet view, select the cell on which you want to draw.

2. Inthe Tools toolbar, select the Pencil & tool or press Alt + /.
3. From the top menu, select View > Drawing > Show Strokes > or press K.

4. Inthe Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.

5. Inthe Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option.

6. Click OK.

7. You can modify the stroke shape with the Contour Editor tool.

How to draw invisible lines with the Stroke tool

1. Inthe Timeline or Xsheet view, select the cell on which you want to draw.
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2. Inthe Tools toolbar from the Paint drop-down menu, select the Stroke (» tool or press Alt + V.
3. From the top menu, select View > Show Drawing > Show Strokes > orpress K.

4. Inthe Tool Properties view, you can adjust the smoothness.

5. Inthe Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about the
Show Strokes option.

6. Click OK.
7. You can modify the stroke shape with the Contour Editor tool.
How to show the strokes with washed-out colours

» From the top menu, select View > Show > Show Stroke With Colour Wash.

Deforming a Drawing with the Perspective Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.
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How to deform a drawing with the Perspective tool

1. Inthe Tools toolbar, select the Perspective 1 tool from the Contour Editor drop-down menu or press Alt +
0.

2. Inthe Camera or Drawing view, select a drawing to deform.

3. Click and drag the different anchor points to deform the shape.

The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles.

How to warp a drawing with the Envelope tool

1. Inthe Tools toolbar, select the Envelope % tool from the Contour Editor drop-down menu.

2. Inthe Timeline view, select a drawing to deform.

3. Inthe Camera or Drawing view, select the region you want to deform
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4. Click and drag the different anchor points and handles to deform the image.

Anchor Point
-

Handle

5. Todisplay more controls, in the Tool Properties view, click the Show Advanced Controls *+ *¥ button.

(TR
S
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6. Increase the height and width of the grid to get more control points to deform your image.

/9 |\

Cutting Drawing Parts

The Cutter tool lets you cut a drawing area to move, copy, cut or delete it.

How to cut with the Cutter tool

1. Inthe Tools toolbar, select the Cutter ~ tool or press Alt + T.
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2. Inthe Camera or Drawing view, make a selection around an area to cut away.

» Todelete the selected zone, press Delete.

>

To move the selection, click the selection and drag it to a new area.

>

Use the bounding box controls to scale, skew, or rotate the cut piece.

ol

Skew
A —

esize

Smoothing Lines

23 points

38 points
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When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw may
look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of your
lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the lines,
the Smooth Editor tool.

How to optimize lines with the Smooth Editor tool

1. Inthe Tools toolbar, select the Smooth Editor 3 tool or select Drawing > Tools > Smooth Editor.

2. Inthe Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass over
the same line several times to remove more points and make the line smoother. Note that by default, the
Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—see Smooth Editor
Tool Options on page 186 to learn about the various settings available.

Working With Text

My Project

Il

With the Text tool, you can type text in your project using various fonts and texts attributes. Text objects are part
of a drawing, so you can manipulate them in the same way. OTF fonts are also supported.

How to add text to drawings

1. Do one of the following:

» Inthe Tools toolbar, select the Text T tool.

» From the top menu, select Drawing > Tools > Text.
» Press Alt+9.

2. Inthe Timeline view, select the cell containing the drawing on which you want to add text.

3. Inthe Drawing or Camera view, click on the location you want the text to begin.
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4. You can use the Tool Properties view to select the font, font size and format of the text you will type—see
Text Tool on page 188.

5. Typeinthe desired text.

My Project

Il

6. Click outside the text box to exit the typing mode.
If you want to create another text object, click outside the currently active text box. You can always return to

edit the text by selecting the Text T tool and clicking in the text.

Working with Tool Presets

Tool presets let you save a variety of settings and are very handy and efficient for accessing the tools you use most
often. That way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable
Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush, Pencil,
Eraser, Rectangle, Ellipse, and Line. First, select a tool, adjust the properties, and then create a tool preset for it.
Once you have created a tool preset, you can always make adjustments to fine-tune it, as well as create a keyboard
shortcut forit.

What's the difference between a tool preset and a brush preset? When you save a tool preset, you have the option of
saving the colour, which you cannot do with brush presets.

The Tool Presets Toolbar
oK -

The Tool Presets toolbar lets you create new tool presets and manage them.
How to display the Tool Presets toolbar

1. Do one of the following:

» From the top menu, select Windows > Toolbars > Tool Presets.
» Right-click an empty area below the top menu and select Tool Presets.

Tool Presets toolbar

W

New Tool Preset Manage Presets
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How to create a tool preset

1. Inthe Tools toolbar, select a tool, for example the Brush tool.
Use the Tool Properties view to customize the tool.

To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the tool. Note
that when using this preset in another scene not using that colour palette, upon selecting this new preset, a
colour recovery dialog box will appear asking to add this colour to your scene.

4. Inthe Tool Presets toolbar, click the New Tool Preset button.

5. Inthe New Preset dialog box, in the Name field, type a name for your new preset.

6. From theicon list, select an icon to quickly identify your preset or upload your own by clicking the File
button.

default_brush01
default_brush02

default_br

[ 4 efault_brush04

default_brush05

default_brush(é

7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset. By default, the
shortcuts are unassigned. To assign a keyboard shortcut, go to the top menu and select Edit > Prefer-
ences > Shortcuts > Tool Presets (Windows/Linux) or Stage Advanced > Preferences >Shortcuts >
Tool Presets (Mac OS X).
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8. When you select any of the following options, they will take effect when you use the tool preset. If an option
is deselected, then using a tool preset will not override your current settings.

» Colour: Saves the current colour into the tool preset.

9. Click OK.

How to select a tool preset

» Inthe Tool Presets toolbar, click the tool preset ¢ icon you assigned when creating the preset. Note
that when using this preset in a new scene not using the assigned colour swatch, a colour recovery dialog
box appears prompting you to add the colour to the scene.

How to delete a tool preset

1. Inthe Tool Presets toolbar, click the Manage Tool Presets & button.

Manage Tool Presets =)

Import...

2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.

How to import a tool preset

1. Inthe Tool Presets toolbar, click the Manage Tool Presets &, button.

&

The Manage Tool Presets dialog box opens.
1. Click Import.

2. Inthe Select Folder window that opens, locate and select the preset(s) to import and click Select Folder.

How to export a tool preset

1. Inthe Tool Presets toolbar, click the Manage Tool Presets &, button.

&
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The Manage Tool Presets dialog box opens.
3. Click Export.

2. Inthe Export Brush Presets window that opens, click Export.

4. Select afolder and click Select Folder.

How to update a tool preset

1. To update the colour of your preset, you must first select it in the Colour view.

2. Inthe Tool Presets toolbar, click the Manage Tool Presets ¢, button.

3. Inthe Manage Tool Presets window that opens, select the tool preset from the left side.
4. Make any changes you want to the preset.

5. Click Update.

More Drawing Tools

Harmony offers a wide variety of useful tools to optimize your drawings and work more efficiently; tools such as
Group, Arrange, and the animation disk to rotate your workspace.

* Arrangeon page 112

» Convert Brush Strokes to Pencil Lines on page 113

* Pencil Lines to Brush Strokes on page 113

» Strokes to Pencil Lines on page 114

* Optimize on page 114

* Remove Extra Strokes on page 115

* Reduce Drawing Texture Resolution on page 115

» Crop Brush Textures on page 116

*  Create Contour Stroke on page 117

* Remove Contour Stroke on page 117

* Gridon page 118

*  Group/Ungroup on page 118
e Handon page 118

* Rotate View on page 119

Arrange

The different Arrange options let you reorder drawing objects inside a single layer in the Drawing or Camera view.

Name Button Description Access Method

- Moves the selected art to the front (on | From the top menu, select Drawing

Bring to Front top). > Arrange > Bring to Front.

112



Harmony 12.2 Advanced - Gaming Animation Guide

Press Ctrl + Shift + PgUp
(Windows/Linux) or &£ + Shift +
PgUp (Mac OS X).

From the top menu, select Drawing
> Arrange > Bring Forward.

Moves the selected art one level for-

ward (closer to the front). Press Ctrl + PgUp (Windows/Linux)
or 3 + PgUp (Mac OS X).

Bring Forward =

From the top menu, select Drawing

> Arrange > Send Backward.
Send Backward Moves the selected art one level
end backwan . lower (behind). Press Ctrl + PgDown

(Windows/Linux) or 3§ + PgDown
(Mac OS X).

From the top menu, select Drawing
> Arrange > Send to Back.

Moves the selected art behind

everything (bottom / back). Press Ctrl + Shift + PgDown
(Windows/Linux) or & + Shift +

PgDown (Mac OS X).

Send to Back =

Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines operation converts selected contour strokes into centreline pencil strokes. The
brush stroke thickness will be lost.

How to convert brush strokes to pencil lines

» From the top menu, select Drawing > Convert > Brush Strokes to Pencil Lines or press *.
» Right-click on the selection, select Convert > Brush Strokes to Pencil Lines or press *

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into contour strokes
brush lines.
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How to convert pencil lines to brush strokes

» From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press &.
» Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &

Strokes to Pencil Lines

The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

» From the top menu, select Drawing > Convert > Strokes to Pencil Lines or press Shift + F12
(Windows/Linux only).

» Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12
(Windows/Linux only)

Optimize

Not flattened

Flattened

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected
drawing objects. Drawing objects will only be flattened and optimized if the selected objects do not change the
appearance of the final image when they are merged.

For example, if you have selected a number of partially transparent objects, which you layered to create an
additive colour effect, the selected transparent drawing objects will not be merged. This is because merging the
transparent drawing objects will cause them to lose the effect of the layered transparent colours.

How to optimize

» Use the Select tool to select the drawing objects you want to optimize.
» From the top menu, select Drawing > Optimize > Optimize.
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» From the Camera or Drawing view menu, select Drawing > Optimize > Optimize.

Remove Extra Strokes

The Remove Extra Strokes option lets you remove the invisible lines in your selection.

How to remove extra strokes

1. Inthe Tools toolbar, select the Select tool.

2. Inthe Camera or Drawing view, use the Select tool to select the drawing objects from which you want to
remove invisible lines.

3. From the top menu, select Drawing > Optimize > Remove Extra Strokes.

» From the Camera or Drawing view menu, select Drawing > Optimize > Remove Extra Strokes.

Reduce Drawing Texture Resolution

When you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be heavy.
You can reduce the size and resolution of the textures in a drawing.

When you import and vectorize drawings using the grey or colour preset styles, you don't have control on the size of
the bitmap texture. You can reduce that bitmap texture.

How to reduce the drawing texture resolution

1. Inthe Tools toolbar, select the Select tool.

2. Inthe Camera or Drawing view, use the Select tool to select the drawing objects whose texture resolution
you wan to reduce.

3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.

» From the Camera or Drawing view menu, select Drawing > Optimize > Reduce Drawing Texture
Resolution.

4. Inthe dialog box, drag the slider toward the left to reduce the texture resolution.

5. Enable the Apply to All Drawings option if you want the modification to be applied to all the drawings in your
layer.

6. Click OK.
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Crop Brush Textures
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The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen beneath
the vector contour of a textured line. This often occurs when you cut and paste textured lines from one drawing
into another. If you cut a portion from a textured line and paste it into a different drawing, Harmony pastes the
entire unseen texture bitmap from the source drawing into the new one, even if you only took a small portion of the
source drawing. Using the Crop Brush Texture command will crop away extraneous texture that does not touch
the vector area. If there are many textured lines in your scene, this will greatly reduce the file size.

In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first, it
appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well. However, using
the Contour Editor tool to expand the vector envelope of the textured line, it is revealed that more texture bitmap
exists beyond the cropped boundary. If you use the Crop Brush Texture command, the bitmap texture is cropped
to the boundaries of the textured line’s vector contour (as seen in the fourth image where the vector envelope has
been pulled out to reveal empty space).

How to crop the brush texture

1. Inthe Timeline or Xsheet view, select the drawing whose texture you want to crop.
2. From the top menu, select Drawing > Optimize > Crop Brush Textures.

3. From the Camera or Drawing menu, select Drawing > Optimize > Crop Brush Textures.
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Create Contour Stroke

Before unpainting Unpainting without strokes Unpainting with contour

The Create Contour Stroke > option is used to add a permanent invisible line around a shape that was drawn
directly in Harmony. This allows you to unpaint your lines with the Paint ® tool but maintain the shape of the lines,
should you need to repaint later.

This command is useful when inking and painting and using the Apply to All Drawings in Layer ; option.

How to create contour strokes

1. Inthe Tools toolbar, select the Select tool.

2. Inthe Camera or Drawing view, use the Select tool to select the drawing objects you want to create contour
strokes for.

3. From the top menu, select Drawing > Optimize > Create Contour Strokes.

Remove Contour Stroke

The Remove Contour Stroke option is used to remove any permanently invisible lines that were created while
scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove the
intersection triangles created during vectorization.

How to remove contour strokes

1. Inthe Tools toolbar, select the Select tool.

2. Inthe Camera or Drawing view, use the Select tool to select the drawing objects you want to remove contour
strokes for.

3. From the top menu, select Drawing > Optimize > Remove Contour Strokes.
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Grid

Use the Show Grid option to display a grid in the Drawing or Camera views.

Name Button Description Keyboard Shortcut

Show Grid | | View > Grid > Show Grid
Displays the grid. Press Ctrl + ' (Windows/Linux) or 38

+' (Mac OS X).

Grid Outline Only Displays the outline of the grid only. | View > Grid > Grid Outline Only

Square Displays a standard square grid. View > Grid > Square

12 Field Grid 2 Displays a 12-field size grid. View > Grid > 12 Field Grid

16 Field Grid % Displays a 16-field size grid. View > Grid > 16 Field Grid

Undertay S Displays the grid under the drawing View > Grid > Underlay
elements.

Overlay 5 Displays the grid over the drawing ele- View > Grid > Overlay
ments.

Group/Ungroup

Use the Group option to group selected drawing objects. This can help in the selection, repositioning, re-scaling
and other transformations to be applied to multiple objects of a drawing.

* From the top menu, select Edit > Group > Group or Edit > Group > Ungroup.

* From the Camera or Drawing view menu, select Edit > Group > Group or Edit > Group > Ungroup.

* Press Ctrl + G and Ctrl + Shift + G (Windows/Linux) or 3 + G and &£ + Shift + G (Mac OS X).

Hand

Use the Hand tool to pan through the Drawing or Camera view.

* Inthe Tools toolbar, select the Hand & tool, click in the Drawing or Camera view and drag.
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*  You can also Hold down the Spacebar, click in the Drawing or Camera view and move your mouse in the
direction you want to pan the view.

Rotate View

The Rotate View @ tool lets you rotate the Drawing or Camera view, the same way as you would do with a real
animation disc. This tool can also be used in the Perspective view.

How to use the Rotate View tool

1. Do one of the following:

» From the top menu, select Drawing > Tools > Rotate View.
» Press Ctrl + Alt (Windows/Linux) or 3£ + Alt (Mac OS X).
» Inthe Tools toolbar, select the Rotate View @ tool.

» Inthe Drawing or Camera view, right-click and select Drawing Tools > Rotate View.
2. Inthe Drawing or Camera view, click and drag to rotate the space.

Drawing Tool References

Harmony has a wide variety of drawing tools and each one of them has a series of options and modes available. This
section covers these options. For details on how to use these tools, see Drawing Tasks on page 39.

*  Pencil Tool Options on page 120

»  Vector Brush Tool Options on page 125

+ Bitmap Brush Tool Options

» Select Tool Options on page 153

» Eraser Tool Options on page 162

» Bitmap Eraser Options

» Contour Editor Options on page 166
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» Pencil Editor Options on page 169

» Shape Tool Options on page 173

» Polyline Tool Options on page 177

» Stroke Tool Options on page 179

» Perspective Tool Options on page 180

» Envelope Tool Options on page 181

e Cutter Tool Options on page 184

»  Smooth Editor Tool Options on page 186

» Text Tool on page 188
» Drawing Pivot Tool on page 192

Pencil Tool Options

When you select the Pencil ¢ tool, its properties and options appears in the Tool Properties view.

Tool Properties == (%

Fixed Thickness 1
2

Fixed Thickness 2

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to
the style you want to create.
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2. Click on the Show Extended Properties arrow to display advanced customization parameters.

Maximum Size and Smoothing

This is where you set the maximum size of your drawing tool.

» MaximumsSize: Defines the width of the stroke.

» Smoothing: Defines the number of control points added to the centre line. The fewer the control points
the smoother (but less faithful) the line.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

+ Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

* End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between Round
or Flat style.

» Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Presets and Thickness Stencils

Harmony provides a variety of pencil presets and thickness stencils and also lets you create and save your own. It
is a good idea to create and save pencils with precise sizes and parameters when you draw and design for efficiency
and consistency.

A thickness stencil saves the thickness information across the length of the line. When drawing with a thickness
stencil, the pressure sensitivity of the tablet is discarded. A thickness stencil can be used while drawing, or applied
afterwards.

You also have the possibility to apply different textures to your lines by either using the default presets or importing
your own—See Pencil Line Texture on page 49.

You can export the pencil presets that you have created and import those that others have created. This is a good
way for you and project collaborators to keep a consistent look for the project—see Working with Pencil Presets on
page 44
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Pencil Line Texture

You can apply a bitmap texture on your pencil line and adjust it as needed—see Pencil Line Texture on page 49

Draw Behind

When drawing on vector layers, the Draw Behind +, mode lets you paint behind existing art. By default, strokes
appear over your work until you release the tool.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically 4, option automatically creates the
corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flatten = mode
automatically merges lines created with the existing ones into one single object as you draw.

When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened. You can no
longer access the individual stroke after you draw it.

NOTE:
Using the Select tool, you can use select and remove a segment of flattened pencil lines. Overlapping pencil lines
drawn with the Auto-Flatten mode enabled are essentially cut into segments by the overlap and can therefore be

treated as individual lines.

Middle mouse
button drag
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Auto-Close Gap

OO

Auto Close Gap off Auto Close Gap on

When using the pencil tool, you can automatically close strokes with an invisible stroke.

It is recommended to keep this option enabled when drawing with the Pencil tool.

Line Building Mode

The Line Building  mode is very useful when drawing long lines and curves in small increments with pencil lines

ortheline , tool. As the pencil lines are central vector lines, it may be difficult to align the line tips perfectly to
create a uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tips are merge into one single stroke.

NOTE: This mode only works with pencil lines or the line tool.

Auto Adjust Thickness
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The Auto Adjust Thickness .3 tool is useful when you want to render a portion of a line thicker. When tracing a

drawing on paper, you will often go back to a section of a curve to make it thicker to add dynamism to the line.
Using the Auto Adjust Thickness tool, you can draw highlight strokes over the section to make thicker. Once you
release the pen or mouse, the line becomes thicker following the shape and curve of the original stroke. This way
is much faster and smoother than using the Pencil Editor tool. You do not have to add extra points and adjust the
position and Bezier handles.

The default overlay colour is light yellow. If this colour is difficult to see because of the background or drawing
colour, you can adjust the colour.

How to change the Auto Adjust Thickness Colour

1. Inthe Tools toolbar, select the Pencil & tool.
2. Inthe Tool Properties view, click the Auto Adjust Thickness .3 button.

3. Click the colour swatch.

The Colour Picker window opens.

4. Inthe Colour Picker window, select a new colour.

Line Pushing Mode

The Line Pushing Mode (. option lets you draw highlight strokes over existing pencil lines. You can reshape the

curves. Depending how you draw the pushing stroke over your line, the highlighted section will be reshaped in one
direction or the other.

The default overlay colour is light yellow. If this colour is difficult to see because of the background or drawing
colour, you can adjust the colour.

To change the Line Pushing Mode colour

1. Inthe Tools toolbar, select the Pencil & tool.

2. Inthe Tool Properties view, select the Line Pushing Mode (. button.
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3. Click the colour swatch.

The Colour Picker window opens.

4. Inthe Colour Picker window, select a new colour.

Vector Brush Tool Options

When you're drawing on a vector layer and select the Brush  tool, its properties and options appear in the Tool

Properties view.

Tool Properties 4%

Brush Fixed Width 1
1

Brush Fixed Width 2
10

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to the
style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.
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Maximum Size and Smoothing

This is where you set the maximum size of your drawing tool.

» MaximumSize: Defines the width of the stroke.

» Smoothing: Defines the number of control points added to the centre line. The fewer the control points
the smoother (but less faithful) the line.

Brush Presets

Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for
repeated tasks. You can create as many brush presets as you need—see Drawing with the Brush Tool on page
53.

How to import pencils, brushes and erasers

1. From the Brush menu = , select Import Brushes.
2. Inthe browser window that appears, navigate to and select the . xm1 file.

3. Click Open.

4. Inthe Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also
import pencils at the same time.
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5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the
imported tips to create other brush, eraser and pencil style presets.

How to export pencils, brushes and erasers

1. From the Brush menu, select Export.

2. Inthe Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as any
pencils.

3. Click Export.

4. Inthe Export Brushes window that appears, browse to the location where you want to save the .xml file and
give it a name.

5. Click Save.

How to change the Presets Library thumbnail display

1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time. Dis-

127




Chapter 4: Design and Drawing Tools

plays an image of the tool's tip and its maximum size.

Increases the size of the thumbnails in order to see the images more clearly. Dis-

Large Thumbnail . o . . .
arge Thumbna plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.

Draw Behind

When the Draw Behind «, mode is enabled, the lines you draw will appear behind the art that already exists.

Repaint Brush Mode

— ?
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The Repaint Brush 4 is used to repaint zones that have already been painted, it will not affect empty zones or
pencil lines. It also automatically flattens each of its brush lines so it does not add new brush lines on top of
existing ones. You can use this mode to paint tones or highlights onto your character.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically &/, option automatically creates the
corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten
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= mode automatically flattens the new lines created with the existing artwork as you draw in the Drawing or
Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten with pencil lines.

Respect Protected Colour

The Respect Protected Colour ¢4 option prevent the colours you marked as protected, in the Colour view, to be
repainted using the Repaint Brush mode or any of the painting tools.

Use Stored Colour Gradient

The Use Stored Colour Gradient g2 option makes your tool use the previously stored gradient position. This way,

every new brush line or colour fill will use the stored gradient position.

Bitmap Brush Tool Options

When you're drawing on a bitmap layer and select the Brush -~ tool, its properties and options appear in the Tool
Properties view.

Soft Shading
200

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to the
style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.
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Maximum Size

This is where you set the maximum size of your drawing tool. This parameter defines the width of the stroke.

Flow
The Flow parameter lets you set the range for the rate at which paint flows from your brush. The analogy works
better with a pen. The greater the flow, the more ink comes out, hence the more consistent the colour and texture

of the line. If the flow is light, then the colour and texture of the line may look spotty. This feature works with the
pressure sensitivity of a pen tablet.

Opacity

The Opacity parameter are where you set the opacity for a brush mark. This works with the pressure sensitivity of
a pen tablet.

Brush Presets

Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for
repeated tasks. You can create as many brush presets as you need.

How to create a brush preset

1. Make sure your current brush has the settings you want in the preset you will create.

2. Inthe Tool Properties view, do one of the following:

» Click the arrow button to display the Brush Properties window and click the New Brush <4 buttonin
the upper-right corner.

> Click the New Brush 4 button.

» Fromthe Brush =z menu, select New Brush Preset.

3. Inthe New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush presets.

How to update a brush preset

1. Select the brush preset to update and click the arrow button to display the Brush Properties window.
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2. Change the brush settings and click the Update Brush Preset 7“4 button in the upper-right corner.

Draw Behind

When the Draw Behind , mode is enabled, the lines you draw will appear behind the art that already exists.

Repaint Brush Mode
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The Repaint Brush 4 is used to repaint zones that have already been painted, it will not affect empty zones or
pencil lines. You can use this mode to paint tones or highlights onto your character.
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Tip Tab

Tip | Transparency Dual Tip Paper Texture

Default | brushll | brushl2 | brushi3

@7 N

brushl4 | brush05 | brush06 | brush07

Wm0

brushl8 | brush02 | brushl0 | brushll
-
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Brush Tips Library

Default | brush0l | brushl2 | brush03 .
Brush Tipmenu

brush04 | brush05 | brushl& | brush07

mw

This is where you select the shape of the brush tip. By default it is round. Note that some tips are designed to have
semitransparent areas, even when the maximum brush opacity is set to 100%.

To create a custom brush tip, you must prepare the file ahead of time, either in Harmony or in a third-party software,
such as Adobe Photoshop. Colour is not supported and transparency is not supported in the traditional sense. Black
appears as 100% opaque, white appears as 100% transparent and all the shades of grey in between appear as
varying degrees of semitransparency. A range of file formats are supported—.jpeg, .png, .tif, .psd, .tgato name a
few. Alpha channels are disregarded on import. It is recommended that your file be between 100 x 100 pixels and
400 x 400 pixels.

You can also import brush tips that you exported from Harmony, so you can share them with colleagues.

How to add a brush tip

1. Do one of the following:

» From the Brush Tip menu, select Add.
» Click the Add button.

2. Inthe browser window that appears, navigate to where you saved your file.

3. Click Open to import the file into the Brush Tip Library.

By default, an imported brush tip is given the name of the image file.

How to rename a brush tip

1. Inthe Brush Tip Library, select a brush tip.
2. From the Brush Tip menu, select Rename.
3. Inthe Rename dialog box that appears, type in the new name of the brush tip.

4. Click OK.
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How to delete a brush tip

1. Inthe Brush Tip Library, select a brush tip.

2. Do one of the following:

» Inthe Brush Tip menu, select Delete.
» Click the Delete button.

The linked brush tip file does not get deleted and can therefore be reimported.

How to import brush tips

1. Inthe Brush Tip menu, select Import.
2. Inthe browser window that appears, navigate to and select the . xm1 file.
3. Click Open.

4. Inthe Import Textures dialog box, select the brush tips to import. You can also import paper textures at the
same time.

Select items from the list:

TexturedBrushEx

Impart

5. Click Import.
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The imported brush tips appear in the Brush Tips Library. You can reuse any of the imported tips to create
other brush style presets.

How to export brush tips

1. Inthe Brush Tip menu, select Export.

2. Inthe Export Tips and Textures window, select or deselect any of the brush tips to create the list to export.
You can also export paper textures at the same time.

brushog

3. Click Export.

4. Inthe Export Textures window that appears, browse to a location where you want save the . xml file and
give it a name.

5. Click Save.

How to change the Brush Tips thumbnail display

1. From Brush Tip menu, select one of the following options:

Parameter Description
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Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.
Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.
List View Allows you to see the name, as well as the thumbnail.

Minimum and Maximum Size

The minimum and maximum sizes of your drawing tool produce the thick and thin effect on your stroke. This
works with the pressure sensitivity of a pen tablet.
» Maximum Size: Defines the maximum width of the stroke.

» Minimum Size: Defines the minimum width of the stroke in relation to and as a percentage of the
maximum size.

NOTE: Setting the Minimum Size value to 100% eliminates the possibility of creating width variation on your
stroke. In other words, you would be forcing a uniform line width using the Maximum Size value.

Roundness and Angle

The Roundness and Angle parameters allow you to change the shape and orientation of the brush tip.

» Roundness: Squashes the height of the brush tip from its centre point. 100% roundness = the native
height of the brush tip. A smaller percentage will make the brush tip look flatter and more narrow. The
squashing is NOT relative to the angle value—if the brush tip is rotated, the squashing function still
uses the brush tip's original orientation.

» Angle: Rotates the brush tip counter-clockwise. 0° = the brush tip's native orientation.

& - L 2 P

oy

Roundness = 100% Roundness = 33% Roundness = 100% Roundness = 33%
Angle=0° Angle=0° Angle =457 Angle = 457

Hardness and Spacing

The Hardness and Spacing parameters allow you to change the softness and spacing of the marks made by the
brush tip. You can preview the hardness and spacing at the top of the Bitmap Brush Properties window, stroke
preview area.

» Hardness: The hardness value corresponds to the softness of the brush tip's edges. The lower the
value, the softer the tip edge. The higher the value, the sharper the tip edge. Be aware that some brush
tips are not 100% opaque, so they will always appear somewhat soft, even at 100% hardness.
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#® ®
100% Hardness 10% Hardness

» Spacing: Defines the amount of space between each stamp of the brush. A value of 100% sets the
stamp marks edge to edge, if there is no white space around the shape. The larger the value, the greater
the space between marks. A really large value can make the brush stroke appear as a string of individual
marks. Conversely, a small spacing value will give the appearance of a fluid brush stroke.

Spacing is only evident when making a continuous stroke.

4 s 28 7
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Spacing = 100%

Spacing = 10%

Randomness

The Randomness parameters let you create a varied bitmap brush stroke. Refining these options can give your
stroke a lovely, non-mechanical look.

» Random Size: You can create variation between the thick and thin of your brush stroke just by setting the
Maximum and Minimum Size values. If you add randomness to the mix, pressure sensitivity from your
drawing tablet will still be applied. Light pressure will create random values around the minimum, while
heavy pressure will create random values closer to the maximum. The larger the percentage, the larger
the range of random variation.

NOTE: Setting the Minimum Size to 100% eliminates the possibility of creating width variation on your stroke,
whether you are applying randomness or not. Therefore, you would be forcing a uniform line width using the
Maximum Size value.
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e

Random Size = 0%
Spacing = 10%

~

Random Size =
E0%

» Random Angle: Sets the range for random rotation around the set Angle value. For example, if the
Angle is set to 45° and the Random Angle set to 10°, the software will choose values between 40°-50°
(plus or minus 5 degrees, equaling a total of 10 degrees).

Roundness & Angle

.-

Handom Angle = 0%
Random Angle = 60%

» Random Spacing: Sets the range for random spacing around the set Spacing value. For example, if
the Spacing is set to 50% and the Random Spacing is set to 10%, then Harmony will choose values
between 45%-55% (plus or minus 5 percent, equaling a total of 10 percent).
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~

Spacing = 10%
Random Spacing = 0%

Spacing = 10%
Random Spacing = 80%

-=e9900 0 --

Spacing = 100%
Random Spacing = 0%

Spacing = 100%
Random Spacing = 80%
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Transparency Tab

Tip Transparency | Dual Tip ] Paper Texture

Maximum and Minimum Flow

The Maximum and Minimum Flow parameters let you set the range for the rate at which paint flows from your
brush. The analogy works better with a pen. The greater the flow, the more ink comes out, hence the more
consistent the colour and texture of the line. If the flow is light, then the colour and texture of the line may look
spotty. This feature works with the pressure sensitivity of a pen tablet.

» Maximum Flow: Sets the maximum rate at which colour and texture are applied as you create a fluid
stroke.

» Minimum Flow: Sets the minimum rate at which colour and texture are applied as you create a fluid
stroke. It is defined as a percentage of the Maximum Flow value. If the Minimum Flow value is set to
100%, then tablet pressure sensitivity will no longer be applicable. The flow will be set to the constant
rate of the Maximum Flow value.
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——

Maximum Flow =8
Opacity = 100%

Maximum Flow = 100
Opacity = 100%

Maximum Opacity and Minimum Opacity

The Maximum and Minimum Opacity parameters are where you set the opacity range for a brush mark. This works
with the pressure sensitivity of a pen tablet.

>

Maximum Opacity: Sets the transparency limit of the brush mark when the pressure is heavy.

>

Minimum Opacity: Sets the transparency limit of the brush mark when the pressure is very light. It is
defined as a percentage of the Maximum Opacity value. If the Minimum Opacity value is set to 100%,
then tablet pressure sensitivity will no longer be applicable. The opacity will be set to the constant rate of

the Maximum Opacity value.

Maximum Flow= 8§
Opacity = 25%

Mazcimum Flow = 100

Opacity = 25%

Randomness

Th Randomness parameter lets you set the range for the randomness of the flow and opacity. This works with the
pressure sensitivity of a pen tablet.

Random Flow: You can create variation in the flow of your brush stroke just by setting the Maximum and
Minimum Flow values. If you add randomness to the mix, pressure sensitivity from your drawing tablet
will still be applied. Light pressure will create random values around the minimum, while heavy pressure
will create random values closer to the maximum. The larger the percentage, the larger the range of

random variation.

>
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NOTE: Setting the Minimum Flow value to 100% eliminates the possibility of creating flow variation on your stroke,
whether you are applying randomness or not. That is, you would be forcing a uniform flow using the Maximum

Flow value.

Maximum Flow = 100

Random Flow = 0%

~

Maximum Flow = 100
Random Flow = 100%

-

Maximum Flow =50
Random Flow = 100%

» Random Opacity: You can create variation in the opacity of your brush stroke just by setting the
Maximum and Minimum Opacity values. If you add randomness to the mix, pressure sensitivity from
your drawing tablet will still be applied. Light pressure will create random values around the minimum,
while heavy pressure will create random values closer to the maximum. The larger the percentage, the

larger the range of random variation.

NOTE: Setting the Minimum Opacity value to 100% eliminates the possibility of creating opacity variation on your
stroke, whether you are applying randomness or not. That s, you would be forcing a uniform opacity using the

Maximum Opacity value.
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l

Maximum Opacity = 100
Minimum Opacity = 10%
Random Opacity = 0%

I

Maximum Opacity = 100
Minimum Opacity = 10%
Random Opacity = 10%

l

Maximum Opacity = 100
Minimum Opacity = 10%
Random Opacity = 50%

Dual Tip Tab

The Dual Tip tab lets you set the parameters for creating a dual tip brush. The primary bitmap brush tip and the dual
tip always work together. You can set the parameters for the primary tip in the Tip tab and those for the dual tip in the
Dual Tip tab. The Blend mode you select determines how the tips are combined.

You must select the Dual Tip option to access the tab's parameters.

By default, the Blend Mode is set to Multiply and the Random Angle to 360°.
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Tip  Transparency Dual Tp [N Paper Texture

brush0l | brush02 | brush03

brush04 | brush05 | brush06 | brush07

Blend Mode

The Blend modes let you decide how the primary tip and the dual tip are combined.

» Multiply: This is the default blend mode. When the two brush tips are combined in this mode, they
essentially cut each other out in overlapping areas, where one or both tips have an area of 100%
transparency. The less opaque the brush tips are, the lighter their combination.
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Default

Primary tip

e T TT

brush(2

Dual tip

Blend Mode = Multiphy

.”.ﬁﬂ e

Blend Mode = Multiply
Random Angle = 360°

» Colour Dodge: In this mode, the primary tip cuts out the shape of the dual tip. Where the tip shapes
overlap, within the boundaries of the primary shape, the colour and opacity appear darker.
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Default

Primary tip

brush(2

Dual tip

‘%—

Combined

'......o

Blend Mode = Colour Dodge

s 7YY

Blend Mode = Colour Dodge
Random Angle = 360°

» Combine: This mode treats the two tips as two different and separate brushes that have the same
colour and follow the same path.

146



Harmony 12.2 Advanced - Gaming Animation Guide

Default

Primary tip

brush(2

Dual tip

‘W

Combined

M

Elend Mode = Combine

N T

Blend Mode = Combine
Random Angle = 360°

Paper Texture tab

The Paper Texture tab lets you view and select a paperlike texture for your brush. You can also import paper
textures that were previously exported.

You must select this option to access the tab's parameters.
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Tip  Transparency Dual Tip Paper Texture

Texture_1

/ T i
A W | 3

Textured... | Tetured

A
v

How to add a paper texture

1. Do one of the following:

» From the Paper Texture menu , select Add.
» Click the Add Paper Texture button.
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Mone Crayon Marker

Texture_3

Lo ey

Test
wi

ure_1

b1

re_d

2. Inthe browser window that appears, navigate to where you saved your texture file.

3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.

How to rename a paper texture

1. Inthe Paper Texture library, select a texture.

2. From the Paper Texture menu, select Rename.

3. Inthe Rename Texture dialog box that appears, type in the new name for the texture.

4. Click OK.

How to delete a paper texture

1. Inthe Paper Texture library, select a texture.

2. Do one of the following:

» Inthe Paper Texture menu, select Delete.
» Click the Delete button.
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Marker

Mone

o S e
Texture_2 | Texture_3 | Texture 4

: T ] wm- = i
|| BN

Texture_1

B

NOTE: You can delete any texture in the texture library as long as there is no brush preset using it.

How to import paper textures

1. Inthe Paper Texture menu, select Import.
2. Inthe browser window that appears, navigate to and select the . xm1 file.
3. Click Open.

4. Inthe Import Textures dialog box, select the paper textures that you wish to import. You can import any
available brush tips at the same time too.

Import
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5. Click Import.

The imported paper textures will appear in the Paper Texture Library. You can reuse any of the imported paper
textures to create other brush style presets.

How to export paper textures

1. Inthe Paper Texture menu, select Export.

2. Inthe Export Tips and Textures window, scroll down the textures list to the paper textures and select or
deselect any textures to create the list that you wish to export. You can export brush tips at the same time
too.

Crayaon

Marker

Texture_1

Texture_2

Texture 3

Texture_4

3. Click on the Export button.

4. Inthe Export Textures window that appears, browse to a location where you would like to save the .xml file
and give it a name.

5. Click Save.

How to change the Paper Texture thumbnail display

1. From the Paper Texture menu, select one of the following:
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Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.
Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.
List View Allows you to see the name, as well as the thumbnail.

» Texture Scale: Increase or decreases the size of the paper texture.

» Additive: This option layers the texture on top of itself as you scribble overlapping lines in one
continuous stroke. If this option is turned off, areas of overlapping lines from a single, continuous
stroke will appear the same, in terms of darkness and texture, as non-overlapping areas.

Additive enabled Additive disabled

» Aligned: This option defines the way separate, overlapping strokes behave. If this option is enabled,
the paper texture's position does not change with each sweep of the brush. If this option is disabled,
each sweep of the brush produces a different texture position. The texture orientation always stays the
same.

Aligned enabled Aligned disabled
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Select Tool Options

When you use the Select x tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso ( and Marquee |,/ options to change the selection style of the tool.

» Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

You can enable different snapping modes to help you when repositioning drawings using the Select tool.

* — Snap to Contour: Snaps your selection or point to any line you position it on. As soon as you move it
close enough to another line, your point or selection will snap to it.

* ~ Snap and Align: Snaps the selected anchor point to any existing line while displaying temporary rulers
as a guide that you can also snap your anchor point to.

* — Snap to Grid: Snaps your selection following the currently enabled grid.

How to snap to the grid

1. Do one of the following:

» Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press Ctrl +'
(Windows/Linux) or 3§ + ' (Mac OS X).

» Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.
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2. Inthe Tools toolbar, select the Contour Editor tool or press Alt + Q.
3. Inthe Tool Properties view, click the Snap to Grid — button.

4. Inthe Camera or Drawing view, click on the anchor point you want to snap to the grid, drag it to the desired
position and release.

—

L

EEEEERE=

Selecting by Colour

The Select by Colour mode lets you select all the zones and lines in your drawing painted with the same colour
swatch.

NOTE: Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured with the
exact same RGB value (same colour), but not painted with the same colour swatch, it will not be selected.

How to select areas by colour

1. Inthe Tools toolbar, select the Select
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» tool or press Alt + S.
2. Inthe Tool Propetties view, click the Select by Colour w button.

3. Inthe Camera or Drawing view, click on any zone or line in your drawing.

All zones and lines of the same colour are selected.

4. Click the Select tool again to return to the regular Select mode.

Permanent Selection

The Permanent Selection < option lets you maintain a selection over multiple drawings. Once this option is

enabled, the selection zone made using the Select tool will remain as you navigate through drawings of the same
layer and drawings from other drawing layers. This option can be used to simultaneously delete artwork inside or
outside of the selection on several drawings when combined with the Apply to Multiple Drawings option.

Apply to All Drawings in Layer
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The Apply to All Drawings in Layer ; option is used to perform an action on all the drawings contained in a

layer. For example, you could enable the option to paint a section on all the drawings simultaneously. The Apply
Tool to All Drawings option must be activated before performing the action and will stay enabled only for the next
action.

Apply to Line and Colour Art

The Apply to Line and Colour Art = option uses the concept of Line Art and Colour Art layers. Use this option to

apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as well as
the Overlay and Underlay layers.

Single Mode

By default, when you draw a selection box in the Camera view, the Select tool will select only the drawing strokes
of the current drawing. If you prefer the Select tool to select all the strokes on all layers, you can disable the
Works on Single Drawing £ option in the Tool Properties view or disable the Select tool Works on Single
Drawing preference. To do this, go to the top menu, select Edit > Preferences > Camera (Windows/Linux) or
Stage Advanced > Preferences > Camera (Mac OS X) and uncheck the Select tool Works on Single Drawing
option.

Flip Horizontal and Vertical
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The Flip Horizontal qIp and Flip Vertical @ operations flip the current selection horizontally or vertically.

» From the top menu, select Drawing > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

™

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

» From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees
CCw.

» Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or & + 7 and 3£ + 9 (Mac OS X).

Smooth

The Smooth ,# operation lets you smooth out selected drawing strokes and remove extra points.

» From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.

Flatten

The Flatten = operation is used to merge drawing objects and brush strokes into a single layer. If you draw new
lines to fix a drawing or line with many brush strokes, it can be useful to flatten them all into a single shape. By
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default, lines are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it will be
easier if they are flattened.

» From the top menu, select Drawing > Optimize > Flatten or pres Alt + Shift + F.

Create Colour Art from Line Art

Lets you use the outline you traced on one of the four embedded layers (line art, colour art, overlay, underlay) and
create invisible strokes to paint your drawings on separate layers. This provides more inking and painting
flexibility.

You can also configure this option to create the invisible strokes on any of the four embedded layers.

How to create Colour Art zones out of the Line Art content

1. Inthe Tools toolbar, select the Select w tool or press Alt + S.
2. Inthe Camera or Drawing view, select the artwork to transfer to the Colour Art.

3. Inthe Tool Properties view or the Drawing View toolbar, click the Create Colour Art from Line Art ... but-

ton or press *.

How to configure the Create Colour Art from Line Art option

1. Inthe Tools toolbar, select the Select w tool or press Alt + S.

2. Inthe Tool Properties view or the Drawing View toolbar, Shift + click the Create Colour Art from Line Art
button.

&

The Configure Line Art to Colour Art dialog box opens.

Configure Line Art to Colour Art RS

on Immediately

Cancel

Parameter Description
Use rendered version of the Renders the drawing and vectorize it to calculate the position of the centreline
drawing that will produce the colour art stroke.

Maximum Resolution for

. The size of the rendered image.
rendered image

Threshold for rendered image | The value of grey processed to create the rendered vectorized arts.
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Fitting error for rendered Bez- | This value represents how precise the fitting of the colour art zone in relation to
iers the line art will be.

Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you want

rce layer
Source laye the colour art to be created from.

Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you want

Destination | r
estination laye the colour art to be created on.

Clear Destination Art Layer Deletes the content before the colour art is added. This is useful when you
First already have artwork on the destination layer.

Perform Line Art to Colour Art
Operation Immediately

Performs the Create Colour Art from Line Art command when you click OK.

Distribute to Layers

The Distribute to Layers gz option is used to separate the selected art strokes and send them to new drawing
layers. In the Camera view, once you have drawn your artwork, you can select the strokes you want to distribute
using the Select w tool and click on the Distribute to Layers gz button; you can also select Drawing > Distribute
to Layers. It will automatically take every stroke from the drawing selection made in the Camera view and separate
them into a different layer for each. If an artwork is composed of several strokes, you must group them using Edit >
Group > Group before using the Distribute to Layers option. This option cannot be done from the Drawing view.

Store Colour Gradient
Use the Store Colour Gradient [} operation to record the selected gradient’s position. This reuses the stored

position of the gradient when drawing new brush lines or painting colour zones. Enable the Use Stored Colour
Gradient 2= option in the Paint or Brush Tool Properties view to do this.

Pencil to Brush

The Pencil to Brush ¢, operation converts the selected centre line pencil strokes into contour strokes brush lines.

From the top menu, select Drawing > Convert > Pencil Lines to Brush or press &.
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Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using the Merge Pencil Lines . option. The ends of your lines are adjusted to form one single

line.

NOTE: Points must be close enough to be merged. If there is a large gap between the lines, they will not be
merged.

Reverse Pencil Thickness

- Thick

Thick s

The Reverse Pencil Thickness = option inverts the thick and thin section on a selected pencil line. This option
will take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the thickest.

Offset Xand Y

Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition the selected
shape.

1. X: Type avalue in this field to reposition your selection along the X-axis.
2. Y:Type avalue in this field to reposition your selection along the Y-axis.

3. Up/Down arrows: Use the up and down arrows to modify the value in the X or Y value field.
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Width and Height

Use the Width and Height operation fields to enter specific values to resize the selected shape with precision.

Width: Type a value in this field to resize the width of your selection.
Height: Type a value in this field to resize the height of your selection.

1
2
3. Up/Down arrows: Use the up and down arrows to modify the value in the Width or Height fields.
4. Lockicon: Click the lock icon to lock or unlock the ratio between the Width and Height values.
Angle
The Angle operation lets you to enter specific values and accurately rotate the selected shape.
'~ -

1. Angle: Type a degree value in this field to rotate your selection.
2. Up/Down arrows: Use the up and down arrows to modify the value in the Angle value field.

When you select a pencil line with the Select tool, additional options appear in the Tool Properties view.
Adjusting the Pencil Line Thickness

Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes. This operation
is not permitted on contour line shapes, such as brush strokes or shape fills.

3

1. Minimum Size: Type a value in this field to set the minimum thickness of the selected centreline stroke.
2. Maximum Size: Type a value in this field to set the maximum thickness of the selected centreline stroke.

3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness value field.

Adjusting the Pencil Line Style
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You can adjust the start, end, and joint style of a selected pencil line.

» Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

* End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

» Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define
the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Stencils

Toon Boom Harmony gives you the flexibility to change the style and thickness of your pencil lines even after
they are drawn. You can apply preset pencil stencils or create your own—see Working with Pencil Presets on
page 44.

Adding Texture to a Pencil Line

Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your own.
Textures are independent from pencil stencils—see Pencil Line Texture on page 49.

Adjusting the Text Selection

When you select text with the Select tool, the tool properties will display the Text tool options on the bottom of the
view. You can also press Alt + 9 to display only the Text properties in the Tool Properties view—see Text Tool on
page 188.

Y
-
Y
-
Y
-

Eraser Tool Options

When you're drawing on vector layer and you select the Eraser & tool, its properties and options appear in the
Tool Properties view.

For information on erasing textured lines—see See How to erase textured lines on page 68.

For information on Bitmap Eraser tool options—see See Bitmap Eraser Options on page 166.
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Tool Properties =%

Eraser Big Square
500

Soft Eraser
30

Very Soft Eraser
30

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the different

parameters in the Tool Properties view. Click on the Show Extended Properties arrow to display advanced
customization parameters,

o | TN

Maximum Size and Smoothing

This is where you set the maximum size of your drawing tool.

» MaximumSize: Defines the width of the stroke.

» Smoothing: Defines the number of control points added to the centre line. The fewer the control points
the smoother (but less faithful) the line.

Eraser Presets

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when drawing
and designing. Toon Boom Harmony provides you with a variety of default eraser styles and allows you to create
and save your own.

Eraser presets are created by saving the properties of the current eraser as a preset, in order to reuse it again and
again. You can create a new preset from the Eraser Tool Properties view, but it is better to do it from the Eraser
Properties—see Erasing Parts of a Drawing on page 91.

The Eraser tool uses its own preset list, separated from the Brush tool.
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How to import pencils, brushes and erasers

1. From the Brush menu =| , select Import Brushes.

2. Inthe browser window that appears, navigate to and select the . xm1 file.
3. Click Open.

4. Inthe Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also
import pencils at the same time.

MyBrush
10 B

MyEraser
30 E

hashes
066.2 BB

Soft Eraser

! 150 BE

5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the
imported tips to create other brush, eraser and pencil style presets.

How to export pencils, brushes and erasers

1. From the Brush menu, select Export.

2. Inthe Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as
any pencils.
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3. Click Export.

4. Inthe Export Brushes window that appears, browse to the location where you want to save the .xml file and
give it a name.

5. Click Save.

How to change the Presets Library thumbnail display

1. From the Brush menu, select one of the following:

Parameter Description

Reduces the size of the thumbnails in order to view more at the same time. Dis-

Small Thumbnail . . . . .
plays an image of the tool's tip and its maximum size.

Increases the size of the thumbnails in order to see the images more clearly. Dis-

Large Thumbnail . - . . .
arge Thumbna plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.

Apply to Line and Colour Art

The Apply to Line and Colour Art == option uses the concept of Line Art and Colour Art layers. Use this option to
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apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as well as
the Overlay and Underlay layers.

Tip Style

Round

Flat

Bevel

If you erase the end of a pencil line or erase a pencil line through the centre, new line tips or line ends are created.
Use the Tip Style option to customize the shape of the new line tips that are created.

Bitmap Eraser Options

The bitmap eraser options are identical to those of the bitmap brush with one obvious exception. Instead of
customizing the parameters of a mark or stroke, you will be customizing the parameters for the absence of a mark
or stroke.

Itis a good idea to create an eraser preset with the identical properties of a brush preset and to use them as a pair.
That way, when part of a stroke is erased, its soft textured look is not interrupted with a hard edged eraser mark.

Contour Editor Options

When you select the Contour Editor tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso and Marquee 1,/ options to change the selection style of the tool.

* Click and hold Alt to temporarily switch from the current mode to the other.

Snap to Contour
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The Snap to Contour —. option will snap the selected anchor point to any line you position it on.

How to shap two shapes together

1. Inthe Tools toolbar, select the Contour Editor tool or press Alt + Q.
2. Inthe Tool Properties view, click the Snap to Contour —. button.

3. Inthe Camera or Drawing view, click on an anchor point you want to snap to the other shape, drag it on top of
the contour line area and release it.

Snap and Align

The Snap and Align —; option lets you snap the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to.

How to snap and align

1. Inthe Tools toolbar, select the Contour Editor tool or press Alt + Q.
2. Inthe Tool Properties view, click the Snap and Align —; button.

3. Inthe Camera or Drawing view, click on an anchor point you want to snap, drag it until a ruler is displayed,

position it on the ruler or on the contour line and release.
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Show Contour Editor Controls

1u1 \Q\S

AN

-

Use the Show Contour Editor Controls ;. option to show the contour editor controls. You can use these controls

to scale, reposition and rotate the selected anchor points.

Apply to Line and Colour Art
The Apply to Line and Colour Art = option uses the concept of Line Art and Colour Art layers. Use this option to

apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as well as
the Overlay and Underlay layers.

Smooth Selection

—-

The Smooth ,# operation lets you smooth out selected drawing strokes and remove extra points.

» From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.

Split Pencil Line and Join Pencil Lines

When drawing with the Polyline tool, your drawing has an even line thickness. You can use the Pencil Editor to
adjust the thickness point by point, but if you want to adjust it quicker, you can use the Split Pencil Line and Point
Pencil Lines options to create segments and apply a pencil stencil to your drawing. Note that if you did not join the
pencil lines on your polyline stroke, the segments between the points will act as separated segments.
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Joined Polyline Drawing Pencil Stencil Applied on Single Segment

AR
AP

Split and Joined Pencil Line Segments Pencil Stencil on Multiple Segments

How to split and join pencil lines

1. Inthe Tools toolbar, select the Contour Editor tool.
2. Inthe Drawing or Camera view, select the contour points you want to split or join.

3. Inthe Tool Properties view, click on the Join Pencil Lines or Separate Pencil Line buttons.

Pencil Editor Options

When you select the Pencil Editor ¢ tool, its properties and options appear in the Tool Properties view.
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Tool Properties == |3

Tapered Thickness Stencil
12 A

Tapered Beginning Thickness Stencil
12 &

Tapered End Thickness Stencil
12 A

Medium Tapered Thickness Stencil

Chalk | Charcoal | Rough Felt_R... Felt

DR e IV W e

Gradient...| Grain Bumnpy... | Bumpy_...| Bumpy_..., Dash
| e G VY VY m—
Dash_Soft| Dots |Grain_5qg... Grain_5qg...| Long_Br.. | Long_Br..
— gl NI A A
Ropy |Ropy_Soft| Spots Square | Stringy | Stringy_...

PR P ST e | e

Lasso and Marquee

Choose between the Lasso  and Marquee 1,/ options to change the selection style of the tool.

* Click and hold Alt to temporarily switch from the current mode to the other.

Maximum Size and Smoothing

This is where you set the maximum size of your drawing tool.
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» MaximumSize: Defines the width of the stroke.

» Smoothing: Defines the number of control points added to the centre line. The fewer the control points
the smoother (but less faithful) the line.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

» Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

* End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between Round
or Flat style.

» Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define the
Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Preset

To work with Pencil line presets, see Working with Pencil Presets on page 44.

Textures

To work with Pencil Line Texture, see Pencil Line Texture on page 49

Smooth

—

The Smooth ,# operation lets you smooth out selected drawing strokes and remove extra points.

» From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.
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Pump Pencil Pressure

The Pump Pencil Pressure option is used to increase the line thickness of a selected area on a pencil line.

Deflate Pencil Pressure

—
>

F 4

The Deflate Pencil Pressure option is used to decrease the line thickness of a selected area on a pencil line.

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align them and
make it look like it is one single line. With the Select tool, you can select several pencil lines and merge them as
one single object using the Merge Pencil Lines . option. The ends of your lines are adjusted to form one single

line.
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Reverse Pencil Thickness

< Thick

Thick

The Reverse Pencil Thickness — option inverts the thick and thin section on a selected pencil line. This option will
take the thickest size on the line and apply it to the thinnest, and it will apply the thinnest to the thickest.

Shape Tool Options

When you select a shape tool (Rectangle, Ellipse, Line), its properties and options appear in the Tool Properties
view.

If the Tool Properties looks different than the image below, you maybe on a bitmap drawing layer instead of a vector
drawing layer. If you want to use a shape tool on a bitmap drawing layer—See Bitmap Brush Tool Options on
page 129.

Pencil 2 Pencil 3 Fixed Thick...

10 20 2
Charcoal |Tapered Thi...| Tapered Be...

25 12 & | 12 &
... | Medium Ta...|Pointy Penc... Fat Ends Th...

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
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parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to
the style you want to create.

2. Click onthe Show Extended Properties arrow to display advanced customization parameters.

Size

Move the Size slider left to reduce the line thickness and to the right to increase its width.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

» Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

* End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

« Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define
the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Presets and Thickness Stencils

Harmony provides a variety of pencil presets and thickness stencils and also lets you create and save your own.
It is a good idea to create and save pencils with precise sizes and parameters when you draw and design for
efficiency and consistency.

A thickness stencil saves the thickness information across the length of the line. When drawing with a thickness
stencil, the pressure sensitivity of the tablet is discarded. A thickness stencil can be used while drawing, or
applied afterwards.

You also have the possibility to apply different textures to your lines by either using the default presets or
importing your own—See Pencil Line Texture on page 49.

You can export the pencil presets that you have created and import those that others have created. This is a good
way for you and project collaborators to keep a consistent look for the project—see Working with Pencil Presets
on page 44
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Draw Behind

When the Draw Behind ;, mode is enabled, the lines you draw will appear behind the art that already exists.

Automatic Filling

_Tb

Use the Automatic Filling @ option to automatically fill your shape with the selected colour as you draw. By
default, the Shape tool creates the outline of an empty shape that you can later fill using the Paint tool. This option is
unavailable for the line tool.

Snap Options

When drawing a shape, you can enable different snap modes to help you create your shape.
» The Snapto Contour —. option snaps your shape to any line you position it on.

* The Snap and Align —; option snaps the selected anchor point to any existing line, while displaying
temporary rulers as a guide that you can also snap your anchor point to.

» The Snapto Grid — snaps your shape to the currently enabled grid.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically 4, option automatically creates the
corresponding strokes in the Colour Art layer.

Auto-Flatten Mode

When enabled, the Auto-Flatten
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mode automatically flattens the new lines created with the existing artwork as you draw in the Drawing or
Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten with pencil lines.

Using the Select tool, you can use the middle mouse button to select a segment of flattened pencil line. This
creates a nice finish on the lines and corners of your artwork.

G
\
;9 / N
‘ \ - Middle mouse button drag
—_

Auto-Close Gap

Auto-Close Gap disabled Auto-Close Gap enabled

OO

When enabled, the Auto-Close Gap mode automatically connects, with an invisible stroke, the pencil lines
you draw close to each other in the Camera or Drawing view.

NOTE: Itis recommended to leave this option enabled when drawing with the Pencil tool.

Use Stored Colour Gradient

The Use Stored Colour Gradient 22 option makes your tool use the previously stored gradient position. This
way, every new brush line or colour fill will use the stored gradient position.

Line Building Mode

w I T
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The Line Building « mode is very useful when drawing long lines and curves in small increments with pencil lines
ortheline , tool. As the pencil lines are central vector lines, it may be difficult to align the line tips perfectly to
create a uniform stroke and close all gaps.

In this mode, you can draw lines in small increments and the tips are merge into one single stroke.

NOTE: This mode only works with pencil lines or the line tool.

Keep Proportion

When the Ellipse or Rectangle mode is enabled in the Tool Properties view, the Draw Circle or Draw Square option
appears. When selecting these options, the shape produced will be a perfect circle or square (as opposed to an oval
or rectangle).

Enabling this option is a good idea if you plan to create many squares or circles. However, if you only need to create
one, holding down the Shift key as you create your shape will maintain the proportion in the same way.

Polyline Tool Options

When you select the Polyline G tool, its properties and options appear in the Tool Properties view.

Pencil 2 Pencil 3 Fixed Thick... Fixed Thick...
L]

10 20 2 10
Charcoal  Tapered Thi... Tapered Beg... Tapered End... Medium Ta...

A 12 A 12 A 12 &

25
Pointy Penci... Fat Ends Thi...Curved Abo...Curved Belo...Uniform Thi...

A 17 &
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to
the style you want to create.

2. Click onthe Show Extended Properties arrow to display advanced customization parameters.

Size

The Size parameter lets you set the size of the polyline that you will draw.

Pencil Presets and Thickness Stencils

Harmony provides a variety of pencil presets and thickness stencils and also lets you create and save your own.
It is a good idea to create and save pencils with precise sizes and parameters when you draw and design for
efficiency and consistency.

A thickness stencil saves the thickness information across the length of the line. When drawing with a thickness
stencil, the pressure sensitivity of the tablet is discarded. A thickness stencil can be used while drawing, or
applied afterwards.

You also have the possibility to apply different textures to your lines by either using the default presets or
importing your own—See Pencil Line Texture on page 49.

You can export the pencil presets that you have created and import those that others have created. This is a good
way for you and project collaborators to keep a consistent look for the project—see Working with Pencil Presets
on page 44

Snap to Contour

The Snap to Contour —;. option will snap your selection to any line you position it on.

Create Colour Art Automatically
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As you draw in the Line Art layer, the Create Colour Art Automatically 4, option automatically creates the
corresponding strokes in the Colour Art layer.

Auto-Flatten Mode
When enabled, the Auto-Flatten = mode automatically flattens the new lines created with the existing artwork as

you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Stroke Tool Options

When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Draw Stroke as Straight Lines

Enable the Draw Stroke as Straight Lines <. option if you want the new strokes you draw to be a perfect straight
line. Disable the option if you want the stroke to follow the mouse gesture.

Connect Line Ends

Enable the Connect Line Ends > option if you want the start or end point of your new stroke to connect to your
existing strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode
When enabled, the Auto-Flatten = mode automatically flattens the new lines created with the existing artwork as

you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Apply to Line and Colour Art
The Apply to Line and Colour Art = option uses the concept of Line Art and Colour Art layers. Use this option to

apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

Smoothness
You can modify the central line smoothness of your line using this option. This parameter smooths the initial

movement of your line. Increasing the value will result in a smoother line with fewer control points. Use the left and
right arrows to increment the value by one full unit. Use the Up - Down slider to quickly increment the value.
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Perspective Tool Options

Selecting the Perspective tool displays its properties and options in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso and Marquee 1,/ options to change the selection style of the tool.

» Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

+ The Snapto Contour —. option will snap the selected anchor point to any line you position it on—see
Contour Editor Options on page 166.

» The Snap and Align —; option lets you snap the selected anchor point to any existing line while displaying

temporary rulers as a guide that you can also snap your anchor point to—see Contour Editor Options on
page 166.

* The Snapto Grid — option snaps your selection according to the currently enabled grid.

Apply to Line and Colour Art
The Apply to Line and Colour Art = option uses the concept of Line Art and Colour Art layers. Use this option to

apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as well as
the Overlay and Underlay layers.

Flip Horizontal and Vertical
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The Flip Horizontal qIp and Flip Vertical @ operations flip the current selection horizontally or vertically.

» From the top menu, select Drawing > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

» From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90 Degrees
CCw.

» Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or & + 7 and 3£ + 9 (Mac OS X).

Envelope Tool Options

Selecting the Envelope tool displays its properties and options in the Tool Properties view.

Width and Height

Increase the width and height values to add more columns and rows to the deformation grids.
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Lasso and Marquee

Choose between the Lasso and Marquee 1,/ options to change the selection style of the tool.

» Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

+ The Snapto Contour — option will snap the selected anchor point to any line you position it on—see
Contour Editor Options on page 166.

» The Snap and Align —; option lets you snap the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to—see Contour Editor Options on
page 166.

* The Snapto Grid — option snaps your selection according to the currently enabled grid.

Show Advanced Controls

To display more controls,you can click on the Show Advanced Controls :: : ! button.

]
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Apply to Line and Colour Art

The Apply to Line and Colour Art = option uses the concept of Line Art and Colour Art layers. Use this option to
apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as well as the
Overlay and Underlay layers.

Flip Horizontal and Vertical

The Flip Horizontal qIp and Flip Vertical @ operations flip the current selection horizontally or vertically.

» From the top menu, select Drawing > Flip Horizontal and Flip Vertical.
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Rotate 90 Degrees CW and CCW

P

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

» From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.
» Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or 3£ + 7 and 3£ + 9 (Mac OS X).

Smoothness

You can modify the central line smoothness of your line using this option. This parameter smooths the deformed
lines. Increasing the value will result in a smoother line with fewer control points. The more you increase the
value, the less details and curves you will get. Use the left and right arrows to increment the value by one full unit.
Use the Up - Down slider to quickly increment the value.

Cutter Tool Options

When you select the Cutter _

tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso and Marquee 1,/ options to change the selection style of the tool.
» Click and hold Alt to temporarily switch from the current mode to the other.
Apply to Line and Colour Art
The Apply to Line and Colour Art = option uses the concept of Line Art and Colour Art layers. Use this option to

apply an action such as selecting, resizing or erasing a drawing on both Line Art and Colour Art layers, as well as
the Overlay and Underlay layers.

Use Mouse Gesture

When using the Lasso
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selection type, the Use Mouse Gesture =« option lets you automatically delete any extra sections of line in
your artwork by simply dragging your mouse over it.

NOTE: For this operation to work, you lines CANNOT be flattened.

P

Use Mouse Gesture Breaker Mode

When using the Lasso selection type, the Use Mouse Gesture Breaker Mode ¢ option lets you draw an

invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with this option, you will be
able to select the two portions independently with either the Cutter tool, Pencil Editor tool or Select tool.

Single pencil line Use Mouse Gesture Breaker mode Two pencil lines

NOTE: This option only works with pencil lines.

Tip Style

Round

Flat

Bevel

If you erase the end of a pencil line or erase a pencil line through the centre, new line tips or line ends are created.
Use the Tip Style option to customize the shape of the new line tips that are created.

Antialiasing

When drawing on a bitmap layer, lines are no longer clean vector shapes. For the edges to be smooth, a slight
amount of antialiasing is used. When using the Cutter tool, you can cut a portion of your drawing with or without
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antialiasing. By default, the option is enabled. If you want to cut your drawing using a hard edge, you can select
the Antialiasing Off option.

Flip Horizontal and Vertical

The Flip Horizontal qp and Flip Vertical @ operations flip the current selection horizontally or vertically.

» From the top menu, select Drawing > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

P

The Rotate 90 Degrees CW and Rotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

» From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

» Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or 3£ + 7 and 3£ + 9 (Mac OS X).

Smooth Editor Tool Options

When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view.
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Brush, Marquee and Lasso Smoothing Style

The Smoothing Style options allow you to smooth a portion of your drawing by tracing a smoothing stroke over the
zone to optimize or by selecting an area of the drawing with the Marquee or Lasso.

Note that by default, the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity.

Show Control Points

The Show Control Points 2 option allows you to show or hide the Bezier points around lines. When the Bezier

points are displayed, you can see the result of your smoothing and the number of points left on the curve. When it is
turned off, only the original artwork is displayed.

Minimum Size and Maximum Size

This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

This options is available while using the Brush Smoothing - style.

» Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.
* Up/Down arrows: Use the up and down arrows to set the minimum and maximum size value.

Smoothness

The Smoothness -/ impacts the strength of the smoothing result. The higher the value, the more points are
removed and the smoother the curve. The Smoothness range is from 0 to 100; the default value is 20.
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NN\

Smoothness = Smoothness =10

Colour

You can modify the colour of the control points displayed on the artwork while working with the Smooth Editor tool
by double-clicking on the colour swatch.

N\

Text Tool

Use the Text tool's properties to select the font type and other formatting options you want to apply to the text.

If you already wrote your text, you must first use the Text tool and select the text portion you want to format.

Yy
-
Y
-
Y
-

Font Type

Use the Font drop-down menu to select a font. OTF fonts are supported.
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Vivaldi

Cly Rrgect

Font Style

Copperplate Gothic Light

~
MY PROJECT

Use these buttons to select a style for your text:

. Bold

My Project

. Italic

My Project

Alignment

Use these buttons to align the paragraph.

Left

CONSECTETUR ADIPISCING
ELIT. AENEAN VESTIBULUM,
METUS AC FERMENTUM
PORTTITOR, ODIO TURPIS
PORTTITOR NIBH, ID
CONSEQUAT MAGNA LIGULA ET
ELIT. CURABITUR SOLLICITUDIN
ELIT AC LOREM MOLLIS ACC
UMSAN.

LOREM IPSUM DOLOR SIT AMET,

Centered

LOREM IPSUM DOLOR SIT AMET,
CONSECTETUR ADIPISCING
ELIT. AENEAN VESTIBULUM,

METUS AC FERMENTUM
PORTTITOR, ODIO TURFIS
PORTTITOR NIBH, ID

CONSEQUAT MAGNA LIGULA ET

ELIT. CURABITUR SOLLICITUDIN
ELIT AC LOREM MOLLIS ACC

UMSAMN.

Right

LOREM IPSUM DOLOR SIT AMET,
CONSECTETUR ADIPISCING
ELIT. AENEAN VESTIBULUM,
METUS AC FERMENTUM
PORTTITOR, ODIO TURPIS
PORTTITOR NIBH, 1D

CONSEQUAT MAGNA LIGULA ET

ELIT. CURABITUR SOLLICITUDIN

ELIT AC LOREM MOLLIS ACC
UMSAN.

Justified

LOREM IPSUM DOLOR SIT AMET,
CONSECTETUR ADIPISCING
ELIT. AENEAN VESTIBULUM,
METUS AC FERMENTUM
FPORTTITOR, ODIO TURFIS
PORTTITOR NIBH, ID
CONSEQUAT MAGNA LIGULA ET
ELIT. CURABITUR SOLLICITUDIN
ELIT AC LOREM MOLLIS ACC
UMSAN.

Font Size

Enter a size for the text.
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small text blg teXt

Kerning

Use the kerning field to modify the spacing between letters and characters. You can select the Auto Kern option
to set the kerning automatically based on the font’s predefined standard. A negative value decreases spacing
between each character, creating a letter overlap and a positive value increases it.

Lorem ipsum dolor

sit amet, consectetur

adipiscing elit.
Aenean vestibulum,
metus ac fermentum
porttitor, odio turpis
porttitor nibh, id
consequat magna
ligula et elit.
Curabitur
sollicitudin elit ac
lorem mollis acc
umsan.

Indent

Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive
value sets the first line of your paragraph farther to the right and a negative value sets it farther to the left.

Lorem ipsum dolor sit amet,
consectetur adipiscing elit. Aenean
vestibulum, metus ac fermentum
porttitor, odio turpis porttitor nibh, id
consequat magna ligula et elit
Curabitur sollicitudin elit ac lorem
mollis acc umsan.

Line Spacing

Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Lorem ipsum dolor sit amet,
consectetur adipiscing elit Aenean
wvestibulum, metus ac fermentum
porttitor, odio turpis porttitor nibh, id
consequat magna ligula et elit.
Curabitur sollicitudin elit ac lorem
mollis acc umsan.

Lorem ipsum dolor sit amet,
consectetur adipiscing elit.
Aenean vestibulum, metus ac
fermentum porttitor, odio turpis
porttitor nibh, id consequat
magna ligula et elit. Curabitur
sollicitudin elit ac lorem mollis
acc umsan.

Lorem ipsum dolor sit amet,
consectetur adipiscing elit. Aenean
wvestibulum, metus ac fermentum

porttitor, odio turpis porttitor nibh, id

consequat magna ligula et elit

Curabitur sollicitudin elit ac lorem
mollis acc umsan.

Lorem ipsum dolor sit amet,
consectetur adipiscing elit. Aenean
vestibulum, metus ac fermentum
porttitor, odio turpis porttitor nibh, id
consequat magna ligula et elit.
Curabitur sollicitudin elit ac lorem
mollis acc umsan.

Resizing the Text Box
You can resize the text box by selecting your text box with the Text T tool and moving the anchor point right or

left. Using the Select tool will distort and scale your text itself rather than changing the width and height of your
text box.
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P

Lorem ipsum dolor sit
amet, consectetur
adipiscing elit. Aenean
vestibulum, metus ac
fermentum porttitor, odio
turpis porttitor nibh, id
consequat magna ligula et
elit. Curabitur sollicitudin
elit ac lorem mollis acc
umsan.

Converting Text into Separate Objects

Text contained in a text field is treated as a single drawing object. You can easily separate the text so each
character becomes an individual drawing object that you can select and modify independently.

How to break a text object

1.

2.

In the Tools toolbar, click the Select w tool or press Alt + S.

In the Drawing or Camera view, select the text object you want to break.

L orenmvipsum

From the top menu, select Drawing > Convert > Break ApartText Layers.

» From the Drawing or Camera view menu, select Drawing > Convert > Break ApartText Layers.

L orem: ipsum

Each character is surrounded by a bounding box that you can modify; they remain text objects that you can
edit.

If you want to convert your independent letter to a complete vector object that you can deform, use the Select
tool to select the letters to convert.

From the top menu, select Drawing > Convert > Break Apart Text Layers to break the selection into a reg-
ular drawing object, with no more text attributes.

» From the Drawing or Camera view menu, select Drawing > Convert > Break Apart Text Layers to
break the selection into a regular drawing object, with no more text attributes.
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‘E/orem ipsum

Drawing Pivot Tool

The Drawing Pivot - tool lets you set the pivots on your character. You can set the drawing pivots on drawings
and symbols.

Setting the Drawing Pivot for Symbols on All Frames

The Set the Pivot for Symbol on All Frames - option is enabled by default. When you set a drawing pivot on a
symbol, all of its cells use the same drawing pivot. This means you do not have to set a drawing pivot on all
frames. Once you set it, it is done.

If you prefer to set a different drawing pivot for a series of cells, you can deselect the option and set your pivots on
each cell or cell range.

NOTE: If you have already set several different pivots on your symbol's cells and selected the Set the Pivot for
Symbol on All Frames option, once you set a new pivot on the same symbol, all of its pivots will be reset and will
use your new pivot.

Snapping
When you drag the drawing pivot around, you can enable a shap option so that when the drawing pivot is

released, it either snaps to the reference grid, drawing's contour, or aligns with an existing drawing stroke.

Reset Pivot

When you click the Reset Pivot  option, the drawing pivot of the selected drawing or symbol is reset to the
centre of the Camera view.

Copying Pivot on Parent Symbol

When you import new extra drawings, such as hands and mouths, you can use the drawing pivot that was set on
your drawings and report them to the symbol's cells. Use the Copy Pivot to Parent Symbol <3 command for this.
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NOTE: When you copy drawing pivots to the parent symbol, there is no link between the drawings' pivots and the
symbol's pivots. If you modify the drawing pivot later, it will not link to the symbol. You would need to perform the
operation again. If you need to modify the symbol's pivots, you can do it directly on the symbol's cells.
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Chapter 5: Colour Styling

I Ins. Mouth & m
[ Tongue /T =/
[ Tongue Trace P L~
[ JEyes Teeth

Limited, Corusd Inc.

Once the characters, props and locations are designed, it's time for the colour styling and colour models creation.
This is when the colours and moods are determined. The line models created during the design step are painted and
organized as colour models for the colourists.

Harmony has a great concept of colour palettes. Each character can have its own set of colours that is carried
through the entire project called the master palette. If the master is modified, the colours in the entire project are
updated simultaneously.

By doing the colour styling in Harmony, your master palette will be created at the same time, so you do not need to
use third party software. Also you will not have to recreate the colour palette again in Harmony. It is possible to
create this step in an external software, but it is a great time saver to do it directly in Harmony.

NOTE: Throughout this section, there may be slight differences between your interface and the illustrations in this
guide. This is because the images are taken from Harmony Premium.

To create the colour style and colour models, follow these steps:

*  Preparation on page 195
»  Working with Palettes on page 200

» Colours on page 217

* Painting the Model on page 233

» Sharing the Colour Model on page 235

Preparation

Before painting, you need to organize the colour model scenes and bring in your references. The colour styling
preparation is done in five steps:
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»  Colour Model Storage on page 196

» Scene Creation on page 196

» Setting Up the Workspace on page 197

* Naming on page 197

Colour Model Storage

First, you will need to create a storage location for all your models and palettes. The best way to do this is to
create a colour model scene. There are different possibilities available to structure your designs and colour model
scenes. We strongly recommend that you put all of your colour models in the same scenes. It is important to
maintain a structure for your models so they do not end up scattered throughout the project.

There are four main model categories:

Characters Props

~\g

Effects Locations

Limited, C: Ine.

If you have a small project, such as a short or an advertising contract, you can always place all the characters,
props, effects, and locations in the same scene. For large projects such as feature-length productions or series,
you should create four separate model scenes following these categories.

Scene Creation

In order to create colour models, you need to create your scenes.

When working on a paperless or cut-out animation project, if you have designed your characters, props, effects
and locations directly in Harmony, you can paint your models directly in your design scene. You can also create a
new colour model scene and import your designs in that one. Refer to the Fundamentals Guide to learn more
about creating a scene.

If you have not already done so, refer to the Fundamentals Guide to learn about production structure, file
organization, and how to create a Project root directory. We recommend storing your colour model scenes in the
root directory or in a colour models subdirectory for even better organization.
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A useful way to name your colour model scene is to include the project name, then the colour model type such as
characters, props, effects, or locations, and finally colourmodel. For example, a character colour model scene for
the Adventure project would be named adventure_characters_colourmodel. This ensures that you always
know what scene corresponds to what.

2. Adventure_project

] @‘ Colour_Models

”‘Q adventure_characters_colourmodels

S

m adventure_props_colourmodels
T

Q adventure_effects_colourmodels

‘\E adventure_locations_colourmodels

Colour Model Scene Structure

To store your colour models in a scene, you should create one drawing layer for each character, prop, effect, or
location. You should name these according to the model.

You can also load other colour references in the scene to balance your overall colours. For example, if you work in a
character colour model scene, it's a good idea to import some of the key locations to compare and adjust the colours
so they match well.

Setting Up the Workspace

Now that your scenes are created and structured, you can open the corresponding colour model scene. For the
optimal workspace for inking and painting, set up your workspace with these views:

*  Xsheet

+ Camera

*  Drawing

+ Colour

*  Model
Naming

Now that your models are imported, you can rename them appropriately. You should rename elements (layers) and
drawings corresponding to the model. This will help keep the work organized and make it easy for others to follow.

For example, if there is a black and white character model called Exik in one drawing element and its colour models
in another one, rename your elements to include the character's name. For example, the colour model for Erik's
armour could be named: erik_armour_colour.

197



Chapter 5: Colour Styling

How to rename a drawing element

1. Do one of the following:

» Inthe Xsheet view, double-click on the column header of the drawing element.

[ E |

nour_Colour |DGO01_3

it B

erik_armour_colour

» Inthe Timeline view, double-click on the drawing element's layer.

The Layer Properties window opens.
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2. Typeinanew name.

How to rename a drawing

1. Inthe Xsheet view, click on a drawing name.

Erik_Armour_Colour

erik_armour_colour

2. Do one of the following:

» From the Xsheet view menu, select Drawings > Rename Drawing.
» Press Ctrl + D (Windows/Linux) or 3£ + D (Mac OS X).
The Rename Drawing dialog box opens.
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3. Typeinanew name and click OK.

Working with Palettes

In animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. This is
referred to as a master palette.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.
Using a master colour palette has many benefits, including:

» Each character consistently retains their dedicated colours.

* You cannot accidentally use a colour which is not in the master palette.

» Standardization and colour consistency throughout the production

* Multiple artists can use the same colour palette and produce the same results.

Toon Boom Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete
control and consistency in your painting process.

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a * . p1t file name
extension—see Palette File Storage.

When a zone on the character is painted with the colour contained in a colour swatch, a link is automatically
created between that colour swatch and the zone. This means that if the tint of the colour in the colour swatch is
changed, any zone linked to it will update to the new tint. This is one way that colour palettes can save time and
money in your production.

Another advantage of this system is that you can create complete palettes for different lighting situations. For
instance, in addition to the regular palette for a character, you could have one for that character in the rain using
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene.
Using palettes linked to your character in this way allows you to instantly change its colouring to suit the mood
and atmosphere of the scene without tediously repainting each element.

A group of colours attributed to a character or prop. The palette is used throughout the entire production to
maintain consistency in the look and to ensure that the same colours are used throughout the production. Also
known as palette.
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This section is divided as follows:
« Palette Lists

+ Palette File Storage

» Creating a Colour Palette on page 205

* Duplicating a Colour Palette on page 209

* Cloning a Colour Palette on page 210

* Importing and Linking Palettes on page 212

Palette Lists

The Colour view has two modes: basic and advanced.

Scene Palettes

e

Basic mode Advanced mode

* Basic Mode
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The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony, you only
see the colours available in the Default palette which contains six basic colour swatches and is
automatically named the same as your scene. For simple projects, you can manage with the default
palette, but for movies, series, or shorts it is recommended that you create palettes for your characters. To
create a palette, you have to switch to the Advanced mode of the Colour view and show the Palette list.

Advanced Mode

The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes for your
characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a palette list.
The scene also has a palette list. For example, a drawing layer can use three different palettes stored in three
different locations, while another drawing layer can use two of these palettes plus another one coming from
another scene. The palette list keep track of the locations of the palettes.

There are two types of palette lists:

Scene Palette List

The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless and
traditional animations. A cut-out character will often be divided into 20 to 30 different drawing elements that
use the character's master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to
this list will appear in every drawing element created in the scene. There is no need to manually load the
palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only
Scene Palette lists.

Xsheet Colour =4[

+ - = r )} £

Scene Palettes

bl_r_hair bl_head

Element Palette List
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In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your palette at
an element’s level. The Element Palette list is mainly used with traditional and paperless animation. Unlike
cut-out animation, all columns (drawing elements) contain different characters, props, backgrounds, and
effects. The Element Palette list is used when you do not necessarily want all of the palettes for all of your
elements linked in every column.

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This ensures
that the links to the palettes appear only in the appropriate element. If you prefer to access a global palette
list, link your palettes to the Scene Palette list.

When you are using several cloned palettes that are related to the same original palette, Toon Boom Harmony uses
the palette located highest in the list to determine the colour of the painted zones—see Cloning a Colour Palette .

How to show or hide the Palette list

» Inthe Colour view, click the Show/Hide Palette List View u button to expand or collapse the Palette
List area.
The Palette List window opens and displays all your palettes.

Show/Hide Palette button

Palette List window

IA W]

+
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How to set the Advanced Palette Lists mode

1. Do one of the following:

» From the top menu, select Edit > Preferences (Windows/Linux) or Stage Advanced > Preferences
(Mac OS X).

» Press Ctrl + U (Windows/Linux) or 3£ + U (Mac OS X).
2. Select the Advanced tab.
3. Inthe Advanced Options section, select the Advanced Palette Lists option.

4. Click OK.

How to reorder palettes in the Palette list

Do one of the following:

» From the Colour View menu, select Palettes > Move Up or Move Down.
» Inthe Palette list, click the Up and Down buttons.

In Harmony, palettes are individual * . p1t files that can be copied, transferred and stored. When a palette is
created from Harmony, it needs to be stored somewhere. By default, the palette file is stored in the scene
directory in a palette-library folder unless you specify a different location.

There are four locations where you can find palette-library folders:
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« Element: The Palette Library folder is stored directly in the drawing Element folder.
« Scene: The Palette Library folder is stored directly in the Scene folder.
« Job: The Palette Library folder is stored in a Job folder contained in the Scene folder.

« Environment: The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is recommended
tokeep it as is. If you work with a larger studio, it is recommended to verify with them on the file structure.

This existing structure is compatible with Harmony Server. Harmony’s database has a leveled structure starting
from the Environment down to the Element. Its client-server configuration allows all data, such as palettes and
scenes, to be shared between a series of client machines.

Element Level

Working with Harmony Stand Alone, the Element level is very useful when there are a lot of different palettes. When
a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette file with the
colour model, the colourist can load them both from the same location. This also creates a more organized structure.

Scene Level

Working with Harmony Stand Alone, a palette file can also be saved at the scene level, so that all of the palettes
from the scene are stored together. The palette naming must be structured so the colourist or character builders can
find the correct one. Saving the palettes at the scene level makes it very easy to back up the palettes and retrieve
their location.

The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that includes all of
the characters, props, effects, and location, the colour palette or model will often be directly imported to, or created
in, the character building scene. Just as with a cut-out character building scene, each element uses the same
palette so it would not be efficient to save the palette inside one element. Instead, it is saved at the scene level. This
prevents a palette overload because all of the models are in different scenes. It also allows each scene to have its
own set of palettes corresponding to its model.

When working on a cut-out animation production, it is highly recommended that you work with the Scene level.

Palette Backup

When sharing palettes between scenes, some users may accidentally modify the colours, even though the palettes
are locked by default. That is why it is a good idea to copy and back up your palette libraries and master palette
directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble replacing an
altered file. Harmony automatically updates all of the files and drawings linked to it.

Creating a Colour Palette

You can create a palette in either Basic or Advanced mode.

By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended to use the
Basic mode. This setting stores the palettes automatically for you and saves them at the Scene level. When you
use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: Environment,
Job, Scene, or Element.
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Before you can create a palette in the Advanced Palette Lists mode, you must first set your preferences to
Advanced Palette Lists mode in the Preferences dialog box.

You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will not
be deleted and you can reimport it in your Palette list later on.

How to set the Advanced Palette Lists mode

1. Do one of the following:

» From the top menu, select Edit > Preferences (Windows/Linux) or Stage Advanced > Preferences
(Mac OS X).

» Press Ctrl + U (Windows/Linux) or 3£ + U (Mac OS X).
2. Select the Advanced tab.
3. Inthe Advanced Options section, select the Advanced Palette Lists option.

4. Click OK.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour view menu, select Palettes > New or click the New Palette button.
The Create Palette dialog box opens.

2. Enter the palette name according to the model.

Cancel

3. Click OK.

The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode

1. Inthe Timeline or Xsheet view, select the drawing that requires a palette.

2. Inthe Colour view, click the Show Palette List View button to display the palette list.

Show/Hide Palette button
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3. Do one of the following:

» From the Colour view menu, select Palettes > New.
» Click the Create Palette button.

The Palette Browser: Create Palette dialog box opens.

4. Select the level to store the palette file.

» Environment: The palette-library folder is stored in the scene's parent environment folder.

» Job: The palette-library folder is stored in the scene's parent job folder.

» Scene: The palette-library folder is stored directly in the scene folder.

» Element: The palette-library folder is stored directly in the drawing element folder.

When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

5. Name the palette. There is no need to add the suffix "palette” to the name as it is always recognized as a
palette file.

6. Select a Palette List option.

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in twenty to
thirty different drawing elements that use the character's master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to this list
will appear in every drawing element created in the scene. There is ho need to manually load the palette in each
element.
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The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out animation, all
columns (drawing elements) contain different characters, props, backgrounds and effects. The Element Palette
List is used because you do not necessarily want all of the palettes for all of your elements linked in every
column.

The palette list is stored in the drawing element's directory instead of directly in the Scene level. This ensures that
the links to the palettes appear only in the appropriate element. If you prefer to access a global palette list, link
your palettes to the Scene Palette List.

7. Click OK.

The new palette appears in the palette list.

How to rename a palette

1. Inthe Colour view, select the palette to rename.

2. Do one of the following:

» Right-click and select Rename.
» From the Colour View menu, select Palettes > Rename.

3. Inthe Rename dialog box, give the palette a new name and click OK.

Cancel

How to remove a palette

1. Inthe Colour view, select the palette to remove.

2. Do one of the following:

» From the Colour View menu, select Palettes > Remove.
» Right-click on the selected palette and select Remove.
» Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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Duplicating a Colour Palette

A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but has a
different ID and is independent from the original palette. This ensures that both palettes are completely independent.

This option is used when there are similar models and you want to avoid recreating and naming all the colours. You
can change the values and the names afterward without affecting the original palette. You can also keep some
RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.

How to duplicate a palette

1. Inthe Colour view, select the palette to be duplicated.

2. Do one of the following:

» From the Colour menu, select Palettes > Duplicate.
» Right-click on the selected palette and select Duplicate.
The Palette Browser: Duplicate Palette window opens.

3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage .

4. Inthe New Palette Name field, name the palette.

5. Inthe New Palette Name field, name the palette.

6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette

H0E L L
LR

A character usually has only one master palette, although there are times when the characters are placed in
different lighting conditions and require a different colour shading. The night palette is a popular choice when a
scene or sequence changes from day to night. It can be difficult and time-consuming to repaint everything and
creating two independent palettes can be quite complex. As an alternative, Toon Boom Harmony provides clone
palettes.

The clone palette is a copy of the master palette. The colours in each palette have the same properties. The
colours have the same identification number pointing to the same colour zones, but they can have different
names and RGBA values. Depending on the palette (night or day) you're currently using, the painted drawing will
update. So there's no need to repaint the animation. All you have to do is create or import a clone palette (palette
style).

How to clone a palette

1. Inthe Colour view, select a palette to clone.

2. From the Colour menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.
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Basic palette Advanced Palette List mode

If you're in Advanced Palette List mode, select the palette storage level—see Palette File Storage on page
204.

In the New Palette Name field, name the palette. We recommend keeping the "-clone" in the name.

Click OK.

The cloned palette appears in the palette list.

In the Palette list, select the clone palette you created to offset or blend colours—see Mixing Colours on page
232.

From the Colour View menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A (Win-
dows/Linux) or & + A (Mac OS X).

9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.
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10. Select the Preview option to see a preview of the colours while you adjust them.

NOTE: You can also modify the colours individually with the Colour Picker window.

Importing and Linking Palettes

Before starting colouring work such as ink and paint or even creating new colour models, you may want to load
existing colour palettes to your scene. You can do so by linking colour palettes to your palette lists.

You may encounter a case where only a colour palette is visible when a layer is selected. If you need that palette
in a second layer, you can link the palette to the second layer's palette list. A good example would be a scene
where there is a character on one layer and its arm is on another. In order for both layers to access the palette,
you must link both Element Palette lists to that palette. If your palette is linked to the Scene Palette list, it will be
accessible by all layers.
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If you created a palette in another project and you want to import it in your current project, you can browse for the
palette file on your computer and add it to your scene. When the palette is imported in your scene, the file is copied in
the project’s directory. It is not linked to the original file.

With Toon Boom Harmony as a stand-alone application, every scene is local to the machine. This means that all of
the scene’s data is only accessible from that particular scene. Palettes are also local to the scene; they can be
shared between all drawing layers, but not between scenes.

However, you may want to share palettes across a whole project. Harmony offers that possibility. By default, a
palette is an independent file stored in your scene. This file can be copied, moved, or deleted.

To link a palette throughout an entire project, you need to create a central directory where you can copy all the
palettes you created. Every time you link a palette in an element, it is linked to this folder. If you modify the palette, it
will be updated throughout the whole project.

You will notice that when you create or link a palette, a small icon appears on its left. These icons represent the
palette's link status.

Icon Description

Indicates that the palette is safe.

@ There won't be any problems once the scene is exported. For example, the palette file is stored
in the scene folder and is linked to the Scene Palette List.

Indicates that the palette file is stored in a directory external to the scene’s structure.

® The palette file is probably stored in a Master Palette directory on a hard drive external to the
palette-libraries planned for the palette storage. The warning in this case is that if you move your
Master Palette directory to another location, you may loose the palette in your scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is
linked to a Palette list that is not on the same level.

@
For example, a palette file is stored into the Environment folder and is linked to the Element
Palette list. The palette is shared.
Indicates a potentially dangerous situation.

@ Problems may occur when trying to export or link to the palette file. For example, a palette file is

stored into the element folder and is linked to the Scene Palette list. The issue in this case is
that if you decide to delete the layer containing the palette, it will be lost from your scene.

How to link a colour palette

1. Do one of the following:

» From the Colour View menu, select Palettes > Link.
» Right-click and select Link.
» Click the Import 5 button.

The Palette Browser: Link Palette dialog box opens.
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2. Select the level where the palette file is stored—see Palette File Storage on page 204.

3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—see
Palette Lists on page 201.

The palette appears in the Colour view.

How to import a palette into your project

1. Do one of the following:

» From the Colour menu, select Palettes > Import.
» Right-click and select Import.

The Browser window opens.

2. Browse for a palette file located (* . p1t) on your hard drive. You will generally find the palettes in your pro-
ject's palette-library directory.

3. Click Open.

The Palette Browser opens.
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Palette Location
Element

@ Environment

@ Element

Palel

Cancel

Basic Palette List mode Advanced Palette List mode

4. If you're in Advanced Palette mode, select the level where the palette file is stored—see Palette File Storage .

5. If you're in Advanced Palette mode, select the palette list linking level by enabling either Scene Palette List
or Element Palette List—see Palette Lists.

6. Inthe New Palette Name, nhame the imported palette.

The palette appears in the Colour view and the file is copied in your project.

How to link to an external palette

1. Inthe Colour view, click on the Create Palette button to create a palette to be used as external.

2. Save your scene by selecting File > Save from the top menu or by clicking the Save = button or press Ctrl
+ S (Windows/Linux) or 3§ + S (Mac OS X).

3. Onyour computer or server, create a master directory. ldeally, this should be created in your Root folder to
keep it within the project directory. You could also place it inside your Colour Model’s subdirectory—see
Chapter 6: Project Organization and File Structure in the Fundamentals Guide.

= [5) Joe's_project
I3 Anirnatic
# |2 Animation
| Backgrounds

= Colour_models
|2 Joe_master_palette
sc001_Characters

| scO01_Effects
| sc001_Locations
I sc001_Props

| Designs

# 5 Models

) References

) Renders

I Storvboards

4. Name the folder appropriately, for example: Joe_master_palette.

5. From your operating system, browse to your Toon Boom Harmony scene and open the palette-library folder.
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6.

10.

11.

12.

= (53 Joes_sco01
=
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Select and copy your palette *.plt file to copy it to the master palette directory.

=1 |23 Joe's_project
@ Animakic
=1 23 Animation
=53 Joes_sco01
I3 elements
[C3) environments

joe_master,plt
= Harrnory PLT. 1
B (] [u] Mnode e 1KB

[ Joe_master_palette 4_

sc01_Characters

[C5) sco01_Effects
@ sc001_Locations
@ sc001_Props

@ Designs

125) Models

IC5) References

I5) Renders

I3 Storyboards

Create a new Toon Boom Harmony scene or open the scene where you will link this palette.

In the Timeline or Xsheet view, select the element to link the palette to.

From the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

Cancel

Click Browse to search for your master palettes folder and select the palette * . p1t file you want to link.
In the Palette list section, select how you want to load the palette; at the scene or element level.

Click OK.

The linked palette appears in the Colour view.

If a palette is outside the scene, the External () icon appears beside the palette name.
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NOTE: To link an element (such as a colour model) to the palette that is stored in the external palette directory, you
must remove the original palette from the element’s palette list. You will then load the duplicated palette into the
palette list using the Link to External command, like you did for the other elements.

Colours

Toon Boom Harmony has some very powerful colouring features when it comes to painting. To paint your drawings,
you will use different colour swatches, unlike some other painting programs where you modify the main swatch each
time you want to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You can
add as many swatches as you want. You can also rename them and modify existing ones.

0anoomm

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones.
This way, you can change the look of your character at any time without having to repaint it!

This section is divided as follows:
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* Adding a Colour Swatch

» Editing Gradients and Textures on page 224

* Colour Display Modes on page 229

» Copying and Pasting Colours on page 230

*  Mixing Colours on page 232

Adding a Colour Swatch

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap texture
swatches.

Solid Colour Swatch Gradient Colour Swatch Bitmap Texture Swatch

In Toon Boom Harmony, when you click the Add Colour button, a new colour swatch is created using the
colour of the currently selected swatch from your palette. However, you can set a default colour to be used every

time you create a new colour in your colour palette. This is useful for creating different shades of the same basic
colour.

The default colour is also the colour used when you choose to vectorize images you're scanning into your scene,
however you add the Default colour swatch to your palette in a different way, so it's unique. It has a unique ID
number that makes it easily recognizable from all the other colours in your colour palettes. Being able to change
this colour allows you to change the basic colour of all scanned drawings. This can be useful on more than just an
aesthetic level as sometimes when you go to NTSC or PAL, pure colours, such as pure black, can create
problems.

How to add or modify a solid colour swatch

1. Inthe Colour view, click the Add Colour button.

2. From the Colour view menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens.
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Colour Picker
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To set your colour, do one of the following:

» Inthe colour wheel, select a colour.

» Enterthe HSV or RGB values in the corresponding fields. Select the R,G,B,H,S orV options to change
the look of the colour picking area.

» Click the Dropper 2 button to select any colour on your screen. It can be from the Harmony interface,
your operating system or any other open application.

Colour Picker @

You can also click Multi Wheel Mode to open the Multiwheel Colour window. This displays all the picking
area styles together and also contains a picking undo list. To return to the regular Colour Picker window, click
Single Wheel Mode.
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Single Wheel Mode

Picking areas

Picking Undo list

4. Click onthe Shade Scale swatches to modify the shade of the selected colour.

i

5. Adjust the transparency with the Alpha slider or type the value directly in the Alpha field.

6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can quickly
access it later.

7. Rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking on
its name.

Colour Picker window Colour list

How to change the default swatch colour for all your colour palettes

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage Advanced > Preferences
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(Mac OS X).
2. Inthe Preferences dialog box, select the Drawing tab.

3. Inthe New Colour Pots section, select the Create New Colour Pots Using the Default Colour option. You
can also click on the colour swatch beside the option to change the default colour.

How to add a new colour swatch using the default colour

» From the Colour View menu, select Colours > New.

A new swatch is added to your palette using the default colour swatch colour. The new swatch created with
the New command will be named New 0.

How to create a gradient colour swatch

1. Inthe Colour view, select a colour to modify .

2. Do one of the following:

» Click the new colour and from the Colour View menu, select Colours > New.

» Double-click on the colour swatch.

3. Select the Gradient option.
4. Select the Linear or Radial option.

5. Adjust the Gradient arrows to modify the colours.

221



Chapter 5: Colour Styling

v

Add extra colours by clicking between the arrows below the gradient bar. Then click on the Colour
Preview to select a colour.

v

Pull down the arrows to remove them.

» Move the arrows left and right to modify the gradient distance.

| |
A @ (]

NOTE: To learn how to reposition the gradient zones in your drawings, see Editing Gradients and Textures on
page 224.

How to create a texture colour

1. From the Colour menu, select Colours > New Texture or click the New Texture button.
The Browser window opens.

2. Browse fora PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.

NOTE:
To learn how to reposition the textured zones in your drawings, see Editing Gradients and Textures on page 224.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of plaid,
just update the texture file in the swatch and the entire project updates. Any transformation previously applied to
the texture’s position in your drawings will be kept.
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How to replace a texture swatch

1. Inthe Colour view, select the texture swatch that contains the bitmap texture you want to replace.

2. From the Colour View menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

3. Browse for the new PSD or TGA bitmap file created in a third party software.

How to delete a colour swatch

1. Inthe Colour view, select the colour swatches to delete.
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2. Do one of the following:

» From the Colour View menu, select Colours > Delete.

» Click the Delete Colour button.

» Right-click and select Delete.

» Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OKto delete the colours or click Cancel to abort the operation.

» If you delete colour swatches already in use, the zones painted with them turn red so you can easily
identify them.

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its
position in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set
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the first texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you can
select the next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your gradient’s
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them
afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with textured
“brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both elements
independently at the same time.

How to use Edit Gradient/Texture tool

1. Do one of the following:

» Inthe Tools toolbar, click the Edit Texture [ tool.

» From the Camera or Drawing View menu, select Drawing Tools > Edit Gradient/Texture.
» Press Shift + F3.

2. Click the gradient or texture colour to modify.

Erik, Di-Gata Defenders @ Nelvana Limited. Corus® Entertainment

A blue selection frame surrounds the selected gradient or texture.

Texture was scaled

Blue selection frame down and skewed

3. Edit the gradient or texture by adjusting the control handles around the selection frame.
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How to store gradient and texture settings

1. Inthe Tools toolbar, select the Select w tool or press Alt + S.

2. Inthe Camera or Drawing view, select the gradient or texture zone to store.

3. Inthe Tool Properties view, click the Store Colour Gradient o button.

How to use the stored gradient and texture settings

1. Inthe Tools toolbar, select the Brush ,+ orPaint ® tool.
2. Inthe Tool Properties view, click the Use Stored Colour Gradient 2z button.

3. Inthe Camera or Drawing view, draw and paint.

How to use Pencil Editor tool to edit the texture or gradient on a pencil line

1. Do one of the following:

> Inthe Tools toolbar, select the Pencil Editor ¢ tool.

» Press Alt+W.

2. Click on the pencil line to be modified to bring up its contour envelope.

ot ] el
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3. Select one of the contour points around the envelope and move its position to change the size of the tiled tex-
ture or gradient. You can also pull directly on the lines of the contour envelope or play with the Bezier handles
of any given point in order to continue to modify the envelope form.
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Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled texture to be
stretched. Conversely, reducing the envelope’s width will cause the tiled texture to look squashed.

Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the number of tiles,
while expanding it will increase the number of tiled images.

This editing technique does not just work on texture fills, but can also be applied to pencil lines drawn with a
textured “brush”.

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line

1. Do one of the following:

» Inthe Tools toolbar, select the Edit Gradient/Texture [ tool.
» From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture.
» Press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.

.
—
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3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull on the top
of the editor controls to stretch the tiled texture throughout the length of the stroke.

As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or gradient.

4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central vector
line. This is another way to resize the texture tile. Instead of stretching or shrinking it vertically, this motion
stretches or shrinks it vertically. As gradients are parallel to the pencil line’s central vector, stretching them
vertically gives no visual result.

/

How to use Edit Gradient/Texture tool to edit the texture and gradient of a pencil line

1. Do one of the following:
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» Inthe Tools toolbar, select the Edit Gradient/Texture [ tool.

» From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture.
» Press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.

~-e"7 %

3. Use the top editor controls edit the gradient.

=" %

4. Use the bottom controls edit the “brush” texture.

Colour Display Modes
The Colour view has two display modes:
+ List

+ Swatch
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You can also display the RGB values and names of your solid colour swatches instead of only the name. This
option is not available when displaying the colours in Swatch mode.

How to switch between the display modes

1. From the Colour View menu, and do one of the following:

» Select Colours > Swatch Mode to display the swatches.
» Deselect Colours > Swatch Mode to display the colour list.

Swatch mode

List mode

How to display the swatch colour values

» From the Colour View menu, select Palettes > Display Colour Values.

The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The
gradient colour swatches will be identified as (gradient).

Copying and Pasting Colours

When you're creating palettes, you may want to copy colour swatches or their values and paste them in other

palettes to save time. You can also quickly copy a colour value from a palette in your scene to a selected colour
swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, it is

impossible to use the Paste as Clone command in the same palette as you copied the original colour swatch
from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can copy the
colour swatch IDs. Here is an example of colour ID: 075¢c£5b552401130.
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ToonEoominimationIne PaletteFile 2

golid
golid
golid
3olid
golid
golid
golid

Black

White

Red

GFreen

Elue

Custoﬂ
"Yectorized Line"

How to copy and paste colours

0x075cf5hl15fe006al
0x075cf5hl15fel06al
0x075cf5hl15fel06al
0x075<f5h15fe006a7
0x075c£5hl15fe006a?
0x075cf5hl15fel06al
0x0000000000000003

u] u] 0 255
255 Z55 255 255
255 u] 0 255

0 235 0 235

u] 0 2535 Z55

u] 0 150 55

u] u] 0 255

In the Colour view, select one or more colours to copy.

mouth

In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or 3£ + C (Mac OS X).

In the Palette list, select the palette in which you want to paste the colours.

From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V (Windows/Linux) or

3£ +V (Mac OS X).

» To paste the colour values of the copied swatch over an existing colour swatch, select Colours > Paste

Colour Values.

How to clone a colour swatch

In the Colour view, select the colour swatch you want to clone.

From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or 3§ + C (Mac OS

X).

In the Colour view, select the colour palette you want to paste the clone into or create a new palette.

From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

1.

In the Colour view, select the colour swatch you want toget the ID from.
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2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or 3£ +
C (Mac OS X).

3. Paste the copied value as plain text in the desired document.

Mixing Colours

If you want to modify a series of colours to blend a tint in them or offset their RGBA values, you can use the Tint
panel. You can also create palette styles, such as night and day styles.

How to mix colours

1. Inthe Colour view, select the palette that contains the colours you want to offset or blend.

2. Do one of the following:
» From the Colour View menu, select Palettes > Tint Panel.
» Right-click and select Tint Panel.
The Tint Blend/Offset panel opens.

Tint Offset/Blend (=]

3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A (Win-
dows/Linux) or 3£ + A (Mac OS X).
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4. Select Preview option.

5. Select the Offset, Blend, or Mixer option.

Click the colour swatch to
change the tintin the Colour
Pickerwindow

Click Apply to implement the Click Reset button to
modification to your palette. reset the transformation.

Parameter

Description

Offset

Offsets the selected colours by the adjustments made using the HSB and RGB
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider
to adjust the opacity of the selected colour.

Blend

Blends the selected colours with the colour swatch in the top-right corner. Use the
Amount slider to adjust the degree of blend. A blend of 100% turns the selected
colours into the same colour as the swatch. Adjusting the HSB and RGB sliders
affect the swatch colour, which in turn affects the selected colours on the left.
Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use the slider just
beneath to mix the Base and Tint colours by different amounts. This will affect the
mixed swatch whether it is selected or not. Select either the Tint or Base swatch
and use the HSB and RGB sliders to adjust its colour. This will affect the mixed
swatch colour, which in turn affects the selected colours on the left.

6. Click Apply.

Painting the Model

Now that you've created the colours and the palette, you're ready to paint your model.
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The colour model needs to be painted in order to adjust the colours with the other elements in the production. You
can paint your model regardless of the colour RGBA and adjust them later when all the elements are together.

Once your palette is created and your model is painted, you can import a key background and other characters
using the Import Drawings option or the Library to compare and adjust the palettes—see Sharing the Colour Model
on page 235 to learn how to import your background file.

- btk < 22 g, oF

Abigail Archer. Grossology © Netvana Limited, Corus® Entertanment inc

For paperless and cut-out animation, it's a good idea to provide a line-up template with the colour model to show
the scale ratio between the characters, props and backgrounds.

Once your colour model is completed, create a line-up template by pasting one of the production's main
characters, or even just a hand, beside the colour model to show the relative size. This allows the animator,
layout artist, or scene setup artist to retain the correct scaling throughout the entire project when setting the
elements in the scene. You can store your template in the Library.

How to paint a colour model

1. From the Drawing or Camera View menu, select View > Switch to Colour Art/Switch to Line Art or press
L.

2. Create your master colour palette—see Creating a Colour Palette on page 205

3. Add new colours to the palette—see Adding a Colour Swatch on page 218.
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4. SelectyourPaint Bucket ® ® & tool. We recommend the Paint Unpainted & tool.

5. Inthe Colour view, select a colour to paint your drawing.

Colour == (%

+ - = Vv

IA W]

Colour view when working with vector layers Colour view when working with bitmap layers

6. Paint the model by selecting colour swatches in the palette and clicking on your drawing. Note that only
closed zones will be painted. If there's a gap in your artwork, you must close before you can paint it.

Abigail Archer, gy Limited, C . Inc.

7. To separate the lines and fill zones on separated art layers, see Art Layers on page 343.
8. Adjust the colours—see Mixing Colours on page 232.

Sharing the Colour Model

When your colour models are prepared and organized in a colour model scene, it's time to share them. However,
since the Harmony scenes are local, the palettes cannot be shared with other scenes. You must prepare templates

from the models and store them in the Library.

The Library is a central repository for all the data which will be reused throughout the production. It can be accessed
from any Harmony scene; if multiple users are connected to the same network, all machines can access a central
library. These models can be shared among all the users to ensure that everyone has the same set of colours and

references.
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A template is a set of elements created from a Harmony scene that can be imported into other scenes. It can
contain drawings, palettes, and any other elements available in Harmony.

A colour model template is very simple to make. When a drawing is stored in the Library, the corresponding
palette is attached to it. This means that whenever the colour model is imported from the Library into the scene,
the palette is also imported. To learn more about libraries and templates—see the Harmony Cut-Out Animation
Guide.

NOTE: Itis recommended that you add a colour model subfolder to your library.

In the Timeline view, you can create a template by selecting the drawing element's node. This contains all
drawings from the drawing element, palettes, and exposure. A template that was created by selecting the drawing
exposure contains the selected drawings, their exposures, and the palettes.

How to create a template from the Timeline view

1. Inthe Library, select afolder to store the template. Right-click and select Right to Modify.

2. From the Timeline view, select the drawings, pegs, effects, keyframes, sounds, exposures, and nodes,
and drag them to the Library's folder. Anything that is available in the Timeline view can be stored as a tem-
plate.

3. Typein aname for the template and click OK.

There is no need to save the library. Everything is automatically stored and saved as soon as it is pasted in
the library.

How to load a colour model from the Timeline or Xsheet view

1. Inthe Timeline or Xsheet view, select a drawing (*.tvg).
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@ Joe_rough_1

L .

@ Joe_dean

2. Bring the model into the Model view by doing one of the following:

» Inthe Timeline view, drag the selected drawing and drop it directly in the Model view.
» From the Model View menu, select Use Current Drawing as Model.

NOTE: The Use Current Drawing as Model button is not part of the default Model View toolbar. To add the Use
Current Drawing as Model button to the Model toolbar, right-click in the Model view toolbar and select Customize.
Drag the Use Current Drawing as Model = button from the Available Tools column and move it to the right

(Toolbar) column. Click OK.

» Inthe Model View toolbar, click Current Drawing & button.

The model appears in the Model view.

How to browse for a colour model drawing on your hard drive

1. Do one of the following:

» Inthe Model View toolbar, click the Import Model 75 button.

» From the Model View menu, select Import Model.
» Select File > Import > Colour Model.

2. Inthe Browser window, browse for any *.tvg drawing file on your hard drive.

3. Click Open.

The model appears in the Model view.

How to load the default models

1. Inyourscene’s folder, create a new folder and name it: models.
2. Onyour hard drive, copy the *.tvg drawing file you want to use as colour models in your scene.

3. Do one of the following:

» From the Model View menu, select Load Default Models.
» Inthe Model View toolbar, click the Load Default Model 1 button.

237



Chapter 5: Colour Styling

NOTE: The Load Default Model button is not part of the default Model View toolbar. To add the Load Default
Model button to the Model toolbar, right-click in the Model view toolbar and select Customize. Drag the Load
Default Model - button from the Available Tools column and move it to the right (Toolbar) column. Click OK.

How to load a single drawing from the Library view

1. Inthe Library view, click the template containing the drawing to import in the Model view.
2. Right-click on the template and select Open As Folder.

3. Inthe Library view’s left side, select the template’s folder and continuing expanding its subfolders until
*.tvg files appear on the right side.

Library |3
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4. Inthe Library view’s right side, select the TVG drawing to import and drag it into the Model view.

How to load a template with multiple drawings from the Library view

1. Inthe Library view, find the template you want to import in the Model view.
2. Inthe Library view’s right side, drag the template (*.tpl file) and drop it directly in the Model view.

3. Usethe Previous Model = and Next Model G buttons in the Model View toolbar to view all the draw-
ings contained in the template. This can often be the front, profile, and 3/4 views of a character.
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Front view Profile view 34 view

How to load a symbol from the Library view

1. Inthe Library view’s left side, select the Symbols folder.

2. Inthe Library view’s right side, select the symbol you want to use as a model, and drag and drop it into the
Model view.

Library  ==|%

AT

3. Usethe Previous Model =1 and Next Model 1 buttons in the Model View toolbar to view all the drawings
contained in the template. This can often be the front, profile, and 3/4 views of a character.

How to clear a colour model

» Inthe Model View menu, select Clear Model or press Delete.

How to copy the entire model from the Model view
1. Inthe Model View toolbar, select the Select x tool.

1. Inthe Model view, select your model.
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2. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or 3§ + C (Mac
OS X).

2. Inthe Timeline view, make sure you have the correct layer and frame selected.

3. Select the Drawing or Camera view, then go to the top menu and select Edit > Paste Drawing Object, or
select the Timeline view and from the top menu, select Edit > Paste cells in the Timeline or pressCtrl + V
(Windows/Linux) or 35 +V (Mac OS X).

The model appears in the selected view.

How to copy part of the model in the Model view
1. Inthe Model View toolbar, select the Cutter ~ tool or press Alt + T.

1. Inthe Model view, use the Cutter tool to create a selection around the part of your model that you want to

copy.
U

2. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or &£ + C (Mac
OS X).

2. Inthe Timeline view, make sure you have the correct layer and frame selected.

3. Do one of the following:

» Select the Drawing or Camera view and select Edit > Paste Drawing Object.
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» Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V (Windows/Linux)
or 3t +V (Mac OS X).

The model appears in the selected view.
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Chapter 6: Timing

1—»3—»5—>p 7 —»9—»11—>»13—>»15—»17—»19—» 21— 23—>25

When you create hand-drawn animation traditionally or in a paperless environment, it's important to know how to set
and modify the timing of your drawings.

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper exposure sheet
created by the animator. In a paperless workflow, the animator creates and manages their own exposure sheet
directly in Harmony without the need for reproduction.

If you're more of a traditional animator, you will probably work with an exposure sheet. If you're a digital animator,
you may prefer to work with a timeline to visualize your timing. Harmony offers both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-drawn
animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as layers.

You can adjust timing in both views; your choice depends on which technique you're accustomed to using.
Depending on your working style, some actions may seem preferable to do in one view instead of another. Many of
the actions you perform in the Xsheet can also be accomplished in the Timeline. This chapter will often show both
techniques. You can choose which one you prefer.

In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and animation paths
for symbols are covered in separate chapters.

NOTE: The exposure sheet is not mandatory for cut-out animation. It can be useful for creating characters and parts,
butis not really needed for animation and timing. If you plan to work with cut-out animation, you can still learn useful
tips by reviewing the section on exposure sheets.

The basic digital exposure sheet process is divided into the following steps:

Preparation

The digital exposure task is quite simple. There are very few things to prepare in order to get ready.

Opening the Scene

The scene is generally created during a previous step, such as scanning (in a traditional animation workflow), scene
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set up, digital layout, or production organization.

Using the Workspace

The person creating the exposure sheet will need only the Xsheet view to create the digital exposure sheet,
although the Timeline view may also be helpful. If you're doing paperless animation, use the Camera or Drawing
view if you want to sketch at the same time.

If you work with this layout often, you can use the Workspace Manager to save it as a workspace,and name it
Xsheet, for example.
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While drawing and animating paperless animation, you can use the Workspace Manager to save a frequently
used layout and name it Paperless Animation, for example.

Preparing References

To start an exposure sheet, you need to prepare your references. For traditional animation, you will need to
reproduce the animator's paper exposure sheet. If you're working remotely, the studio can scan the paper
exposure sheet using third-party software and send the digital files to be opened and viewed digitally.
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In paperless animation, you will usually create an exposure sheet from the Xsheet view.The information from your
layout and posing or storyboard will help you approximate how many elements are required in the scene.

Setting the Scene Length

Once the references are ready, you need to set the scene length by adding the right number of frames to your scene.
You can set the global scene length from the top menu.

In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. Inthe Number of Frames field, enter the number of frames needed.

How to extend or reduce the scene length in the Timeline view

When you remove frames at the end of a scene to reduce the scene length in the Timeline view, the exposed
drawings and symbols are not deleted. They're still available if you extend the scene afterward.

1. Inthe Timeline view, drag the scene length bracket:

» Right: To add more frames to your scene.
» Left: To reduce the number of frames in your scene.

How to add frames in the middle of a scene

You can add frames anywhere in the middle of the scene—before or after a selection. If you select a frame row in the
Xsheet view, Harmony will add the new frames before or after the selection, depending on your choice.

1. Do one of the following:

» Inthe Timeline view, select the frame to which you want to add frames before or after.

» Inthe Xsheet view, select a frame row.
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2. Do one of the following:
» From the top menu, select Scene > Frame > Add Frames Before Selection or Add Frames After
Selection.

» Inthe Xsheet view, right-click and select Frames > Add Frames Before Selection or Add Frames
After Selection.

» Inthe Xsheet toolbar, click the Add Frames button to add frame after your selection.
» Press Ctrl + Gand Ctrl + H (Windows/Linux) or 3£ + G and Ctrl + H (Mac OS X).
The Add Frames dialog box opens.

3. Inthe Number of Frames to Add field, enter the number of frames needed in the scene.

4. Click OK.

Two frames were added
before selected frame

How to add frames at the start or end of a scene

1. Inthe top menu, select Scene > Frames > Add Frames at Start or Add Frames at End.

The Add Frames dialog box opens.

2. Inthe Number of Frames to Add field, enter the number of frames needed in the scene.
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3. Click OK.

How to remove a frame or a range of frames to reduce the scene length in the Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

1. Inthe Xsheet view, do one of the following:

» Select aframe in a given column.

» Select a frame range by clicking the first frame’s number and then dragging the selection highlight down to
the last frame to delete.

[=RE=-RRNE o [=/BLE RSN IER )

2. Todelete the selected frames, do one of the following:
» From the top menu, select Scene > Frame > Remove Selected Frames.
» Press Delete to delete the selection.
» Click the Remove Frames button. To remove several frame selections, click the button repeatedly.

If you selected a range of frames, the Warning dialog box may open.

3. Tocomplete the operation:

» Click Yes to delete the selection.
» Click No to delete only the exposure in the cell and not the frames.

» Select the Don’t Show This Message Again option to prevent the warning message from being
displayed each time you delete a frame range.

Creating Drawings

Before filling any value or setting any timing or exposure, you need to add different drawing elements.
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Each drawing element is represented as a vertical element column in the Xsheet view and a horizontal element
layer in the Timeline view.

In Harmony, whether you work in the Timeline or Xsheet view, any modification you do to one view will be applied
to both. You can also see your layers displayed in the Node view as nodes.

To start an exposure sheet, you will use drawing elements. Drawing elements are drawing containers. Any image
file, either bitmap or vector, will use a drawing element.

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is named the
same way as the drawing element. Its purpose is to contain all the drawings related to this element. For example,
in cut-out animation, a character can have many heads available. All of the head drawings will be contained in this
folder, even if they are not exposed in the Timeline or the Xsheet view. There is always a drawing container
connected to a drawing element (layer, column).

NOTE: There are different element types available, such as sound and expression. A sound element contains
sound files. Expressions, Beziers, 3D path, Quadmaps and Pegs are for motion purposes during the compositing
step. It's not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu.
This section is divided as follows:

» Layerand Column Basics on page 248

» Layerand Column Types on page 249

* Adding Layers and Columns on page 252

» Deleting Layers and Columns on page 255

» Layerand Column Properties on page 256

*  Modifying Layers and Columns on page 259

» Duplicating Layers and Columns on page 262

* Cloning Layers and Columns on page 262

* Adding an Annotation Column on page 263

Layer and Column Basics

A layer is linked to a directory, the location where all its drawings are saved. This directory has the same name as
the layer. When a name is typed in a cell ,Harmony searches the layer's directory for the corresponding drawing
to display. If there is no corresponding drawing, a new one is created.

Drawings are exposed in cells and linked to the drawings saved in the layer's directory. When you remove a
drawing from a cell, it is not displayed and still exists in the directory.

A drawing that is exposed multiple times (for example, in a walk-cycle) would be linked to the same original
drawing in the layer's directory. If you modify, repaint, or correct the drawing, all exposed drawings with the same
name are updated simultaneously. You must duplicate or create a new drawing to modify a single exposure and
retain the others.
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When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that when
you modify, repaint, or correct a drawing named “1,” all drawings named “1” are updated simultaneously. In order to
modify a drawing independently from its other exposures, you must duplicate the drawing.

Layer and Column Types

A column is also known as a layer. There are several types of layers that you can add in the Xsheet and Timeline
view. Each layer is indicated by an icon to help you differentiate them. Some layers are represented differently in the
Xsheet view.

Drawing Layer
M

The most common layer type is the drawing layer. Any time you need to create a vector drawing or import a symbol
or image, you can use a drawing layer. You can also create bitmap artwork on a drawing layer.

NOTE: Bitmap images are contained in bitmap layers.

Bitmap Layer

oA

If you import a bitmap images (as original bitmap) in your project, they are inserted in a Bitmap layer. If you choose to
vectorize your image when you import, the vectorized object will be placed on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a bitmap
into a symbol, you will be able to mix vector drawings with it on the same layer.
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Camera Layer

%

You can only have one Camera layer at a time in the Timeline view. By default, there is no Camera layer when
you create a scene. You need to add a Camera layer when you want to create a camera motion.

The Camera layer is not visible in the Xsheet view.

NOTE: If you want to have several cameras with different settings, you can keep adding Camera layers in your
Timeline view (however, only one will ever be visible at a time as you can only have one camera at a time in your
timeline). To switch to a different camera, select Scene > Camera and select another camera layer.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them.
In Harmony, there is a series of effect nodes in the Node Library view.

When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in the
Functions section of the Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene has no
background colour and if you render it as a QuickTime movie or image sequence, it will have a black background.

This layer is not visible in the Xsheet view.

Group Layer

A Group layer can be used to organize the Timeline view. You can drag and drop other layers onto a Group layer
and then collapse the Group layer to hide these other layers from view.

If you create the Group layer in the Timeline view.
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Peg Layer

A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to any drawing
layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the Functions
section of the Xsheet view.

Quadmap Layer

A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This can
be attached to any drawing layer, cut-out puppet, or even other Peg layers. They will all follow the deformation you
set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are displayed in the
Functions section of the Xsheet view.

Sound Layer

t)

You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your
Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types

In the Xsheet view, you can add several advanced column types to create particular animation paths. When you
create these columns, they are not linked automatically to any particular drawing layer. You can create a motion path
using these columns and then link or unlink several drawing or peg layers to it.

Advanced column types include:
+ Timing
« 3D Path
+ 3D Rotation
» BezierCurve
» Expression

* Annotation
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Adding Layers and Columns

There are different ways to add a drawing layer to your project. By default, when you create a new scene there is
one Drawing column in the Xsheet view and one corresponding Drawing layer in the Timeline view.

You can add an element for each drawing and it will appear as a column in the Xsheet view or as, a layerin the
Timeline view, and a node in the Node view.
How to add a drawing element from the Timeline view
1. Inthe Timeline view, click the Add Drawing Layer «. button or press Ctrl + R (Windows/Linux) or 3§ + R
(Mac OS X).

The Add Drawing Layer window opens.

G vect
G Vector

Add and Close Add Close

2. Inthe Name field, name your new layer.
3. Setthe Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap layer.

4. Do one of the following:

» Click Add to add a first layer and keep the window open to add more layers.
» Click Add and Close to add a new layer and close the window.
A new drawing layer is added to the Timeline view.

How to add a drawing element from the top menu

1. From the top menu, select Insert > Drawing.

The Add Drawing Layer dialog box opens.

2. Inthe Name field, type a relevant element name and click OK.

The new drawing element appears in your scene.
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How to add a drawing element from the Xsheet view

1. Do one of the following:
» Inthe Xsheet menu, select Columns > Add Columns.
» Click the Add Columns [}, button.

» Press Shift + C.
The Add Column dialog box opens.

@ BGitmap
@ Gitmap

2. Inthe Name field, type a relevant element name.

3. Inthe Type field, select Drawing.

4. To complete the operation:

» Click OK to add your new layers and close the dialog box.
» Click Apply to add your new layers and keep the dialog box open to add column.
» Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Node views—see Layer and Column Types on
page 249.

How to create a column using the advanced Add Column dialog box

You can use the advanced Add Column dialog box to make more file format and field size options available when
you insert a column.

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage Advanced > Preferences (Mac
OS X) and select the Advanced tab.

2. Inthe Advanced Options section, select the Advanced Element Mode option to access the advanced Add
Column dialog box.
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3. Click OK.

4. Inthe Xsheet menu, select Columns > Add Column or press Shift + C.

The Add Column dialog box opens.
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5. Inthe Name field, type the new column’s name.
6. Inthe Type menu, select the Drawing type.

7. Inthe Element section, select one of the following:

» Create New Element: Creates an independent column with its own drawing folder.

» Use Existing Element: Uses drawings from an existing column in the new column. Both columns will be
attached to the same set of drawings, but their timing will remain independent from one another. If you
modify one of the drawings, it will be modified in both columns. This is the same principle as the Clone
column.

In the Name menu, select the column to which you want to link your new column.

Drawing_1

N When a column is linked to
an existing layer

8. If you selected the Create New Element option:
» Deselect the Vector option if you want your layer to contain bitmap images or enable it if you want the
layer to contain vector drawings. Most of the time, the Vector option will be enabled.

» If you deselected the Vector option, from the Bitmap Format list, select which type of bitmap image you
want to insert in the column. Select the SCAN type if you are planning to scan drawings using the Toon
Boom Harmony Scan module.

» If you deselected the Vector option and you chose the SCAN type, from the Scan Type menu, select
what kind of scanning you want to achieve.

» Inthe Field Chart field, when importing traditional animation, indicate the size of paper on which the
animation or background was drawn. If you are not using perforated animation paper, leave the 12 field
default value as is.

9. Do one of the following:

» Click OK button to create the new column and close the dialog box.

» Click Apply to create the new column but keep the dialog box opened to create other new columns.

Deleting Layers and Columns

You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

1. Inthe Timeline view, select the layers to delete.
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2. Do one of the following:

» Inthe Timeline’s Layer toolbar, click the Delete Layers button.

» Right-click on the selection and select Delete.

How to delete columns in the Xsheet view

1. Inthe Xsheet view, select the columns to be deleted by clicking on their header.

Drawing_3 Drawing_2 Jrawing_1

2. Do one of the following
» Right-click on the selection and select Delete Columns.
» Inthe Xsheet toolbar, click the Delete Columns []- button.

» Press Delete.
The Confirm Delete dialog box opens.

Cancel

» Select the Delete Drawing Files and Element Folder option if you want to delete the drawings and
folders linked to the selected column.

3. Tocomplete the operation:

» Click OK to delete the selected layers.
» Click Cancel to cancel the operation.

The Warning dialog box may open.

4. Do one of the following:

» Click Yes to delete all the frames from your scene.
» Click No to keep the frames in your scene.

» Select the Don’t Show This Message Again option if you do not want the dialog box to display again
in the future.

Layer and Column Properties

Each element has its own set of properties that you can modify, including effect and peg layers.
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If you want to modify an element’s properties, you can display the properties of a selected layer in the Timeline view
or selected node in the Node view. If you're working with the Xsheet, you can display its properties as well. You can
display a layer's properties as a window or as a view of its own.

The Layer Properties editor allows you to:
* Rename the layer
+ Enable or disable the layer
* Lock the layer
* Change the track colour
» Activate the onion skin preview
* Adjust the positioning and animation parameters
* Adjust many other advanced parameters
The Column Properties editor allows you to:
* Rename the layer

+ Enable or disable the layer
How to display a layer's properties

1. Do one of the following:

» Inthe Layer Properties view is not part of your workspace, from the top menu, select Windows > Layer
Properties. In the Timeline view, select a layer

» Inthe Timeline view, double-click on a layer.

» Press Shift + E.

The properties display.
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How to display a column's properties in the Xsheet view

1. Inthe Xsheet view, do one of the following:

» Double-click on a column header.
» Right-click on a column header and select Column Editor.

The properties for the column are displayed.

2. (Optional) To view additional properties, select Edit > Preferences from the top menu.

3. Inthe Preferences dialog box, select the Advanced tab, then select the Advanced Element Mode
option.
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4. Inthe Xsheet view, double-click on a column header.

Additional properties for the column are displayed.

Modifying Layers and Columns

Once you add layers and columns to your project, you can modify their properties, names, or ordering.

You can change the order of your elements in the Timeline view and Xsheet view. When you change the order of
your elements in one view, the other one is updated.

The Element Manager window lets you add, delete or modify elements (drawing folders) in your scene. If you have
drawing folders that are not linked to a column in your scene, use the Element Manager to delete them if needed.

How to rename a layer in the Timeline view

1. Inthe Timeline view, double-click on the name of the layer to rename.

2. Inthe Name field, rename the layer and press Enter/Return.

259



Chapter 6: Timing

How to rename a layer in the Layer Properties editor

1. Inthe Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

2. Inthe Name field, rename the layer.

3. Click Close.

How to rename a column

1. Inthe Xsheet view, double-click on a column name. Do not click on the drawing folder name that the
column is linked to (this also appears in the column header just below the column name).

The Drawing dialog box opens.

2. Inthe Name field, rename the column.

3. Click OK.

How to reorder layers in the Timeline view

1. Inthe Timeline view, select the layers to move.
2. Drag the selection to the new location.

3. Do one of the following:

» Drop the selection on an existing layer to make it a child of another element layer.
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» Drop it between the existing layers. Timeline layers that are located above the selection are displayed in
front it. Layers located under it in the Timeline View are displayed behind it.

How to reorder columns in the Xsheet view

1. Inthe Xsheet view, click on the column’s header with the middle mouse button.

2. Drag the column to its new position.

How to use the Element Manager

» From the top menu, select Scene > Element Manager.

Delete Elements  Delete Elements and Directories

Parameter Description
Elements Elements
Delete Elements Deletes the selected elements.

Deletes the selected layer and its directories

Delete Elements and Directories (drawing folder).

Add/Modify Element Add/Modify Element

Type in a new name in this field to create an
element or to rename the selected element.

Name
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Parameter Description

Select this option if the new element is a vector
Vector drawing or if you want to enable the parameters on
the selected element in the Elements list.

Bitmap Format Lets you select the file format of the bitmap layer.

If you're planning to scan elements with the Toon
Scan Type Boom Harmony Scan module, select the scan
type from the list.

If you're importing traditional animation, select the
Field Chart size of the paper on which the animation was
drawn.

Creates a new element with the current para-
Add meters entered in the Add/Modify Element sec-
tion.

Applies the parameter changes made to the selec-

Modify ted element.

Duplicating Layers and Columns

Duplicating an element provides you with a copy of the drawings and their exposure. You can modify anything
you want in the duplicated element without affecting the original one.

How to duplicate an element

1. Inthe Timeline or Xsheet view, click the layer or column to duplicate.

. g_z

2. Do one of the following:

>

(Xsheet) Right-click on the column and select Duplicate Selected Columns.
» (Xsheet) Inthe Xsheet menu, select Drawings > Duplicate Drawings.
(

>

Timeline) Right-click on the layer and select Duplicate Selected Layers.
» (Timeline) In the Timeline menu, select Layers > Duplicate Selected Layers.
The new duplicated layer or column appears.

Cloning Layers and Columns

Cloning a layer or column provides you with a copy of the selected element that uses the same drawings as the
original. For example, if you modify a drawing in the cloned or original column, it is updated in both columns.

You can choose whether or not to copy the column timing to the cloned columns.

* You can modify the column timing independently from each other, but the drawings remain linked.
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*  You can copy the columns timing, so drawings and timings remain linked.
You can clone selected nodes from the Node view in the same way.

This is useful when you want to reuse a hand-drawn animation but have different timings.

How to clone an element

1. Inthe Timeline or Xsheet view, select the layer or column to clone.

.

2. Do one of the following:

» From the top menu, select Edit > Clone: Drawings Only to clone only the layer or column drawings.
» From the Timeline menu, select Layers > Clone Selected Layers: Drawings Only.

» From the Xsheet menu, select Columns: Clone Selected Columns: Drawings Only.

The new cloned layer or column appears.

Adding an Annotation Column

The annotation columns are useful for marking actions, corrections or other information related to your animation that
you want to draw or write. This way, you can print your Xsheet, take it back to your animation table and work with
the annotations.

Before you can draw in the Annotation column, you must first activate the Enable Drawing option to activate the
Drawing mode. Pen tablet pressure sensitivity is not supported in the annotation column.

y

Jump

In the annotation column, you can type in your notes and relevant information, as well as draw sketches and ideas
that will be useful in producing your animation.

Typing in an annotation column is independent from the Drawing mode. You can be in either mode and the typing will
work. To learn about typing values in the Xsheet view, see Typing Exposure on page 1.

You can erase part or all of the annotation column’s text and drawn annotations. Annotations that you type in cannot
be erased using this method.

You can change the pen size and colour when you draw in the annotation column.

When working with the annotation columns, it is useful to display tick marks on odd-numbered frames.
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Tick marks in Annotation column

I e b e (] e ] et [k (] e ] P [t (] e
fNCTR S SR ) SN Y S PR S P S A ) S P S S—

To display the tick marks, you must run a short script.

If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or drawings in the
Annotation columns, you can easily import them.

How to add an annotation column

1. Do one of the following:
» Inthe Xsheet menu, select Columns > Add Columns.
» Inthe Xsheet toolbar, click the Add Columns ). button.

» Press Shift + C.
The Add Column dialog box opens.

Add and Close

2. Inthe Name field, type in an appropriate name.

3. From the Type list, select Annotation and click OK.

The new column appears.

How to draw in the annotation column

1. Do one of the following:

» Inthe Xsheet menu, select Annotation > Enable Drawing.
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» Inthe Annotation column header, click the icon in the upper-right corner to cycle through the icons until the
Brush s iconis displayed.

The Drawing mode is enabled.

2. Todraw in an Annotation column, simply use your mouse or pen tablet.

Annotation

s

How to type in an annotation column

1. Do one of the following:

» Inthe selected cell, press Ctrl (Windows/Linux) or &£ (Mac OS X).
» Inthe selected cell, hold down Ctrl + Shift + click (Windows/Linux) or 3£ + Shift + click (Mac OS X).

Annotation

2. Inthe selected cell, type the desired text.

y

Jump
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How to erase part of a drawn annotation using Erasing mode

1. Inthe annotation column header, click the icon in the upper-right corner to cycle through the icons until the
Eraser ¢ iconis displayed.

2. Inthe column, click and drag the cursor on top of the drawn annotation to erase parts of it.

Annotation &

NOTE: When using a pen on a tablet, you MUST flip your pen to the eraser side for the eraser to
work.

How to change the pen width

1. Inthe Xsheet menu, select Annotation > Pen Width and do one of the following:

» Select a pen width preset.

» Select Change Current to display the Pen Width dialog box. In the Pen Width field, type the number
of pixels for the pen size and click OK.

Pen width

How to change the pen colour

1. Inthe Xsheet menu, select Annotation > Change Pen Colour.

The Select Colour dialog box opens.
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2. Choose a new colour.

3. Click OK.

How to display tick marks

1. From the top menu, select Windows > Script Editor.
2. From the Script Editor menu, select File > New Script.
3. Typein a name for your script and click OK.

4. Inthe File list, select the script you created.

5. Onthe right side of the view, type the following script:

function display _tick_marks()
{

preferences.setBool("XSHEET ANNOTATION_ FRAME MARKER" true);
Messagelog.trace(preferences.getBool("XSHEET ANNOTATION FRAME MARKER', false));

}
6. Click Verify.

The script is verified.

7. From the Script Editor menu, select Play/Debug > Run.

A dialog box opens with your script selected in the Files column.

8. Inthe Functions column, select display_tick_marks and click OK.

Tick marks appear on odd frames in the Annotation column. If you do not see tick marks, close and restart
Harmony.
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How to turn off the display of tick marks

1. Follow steps 1to 5 of How to display tick marks and use the following script:

{

preferences.setBool("XSHEET ANNOTATION FRAME_MARKER', false);
MessageLog.trace(preferences.getBool("XSHEET_ANNOTATION FRAME MARKER' false)),

}

2. Follow steps 610 8.

All tick marks are removed from the Annotation column.

How to import annotation files

1. Inthe Xsheet view, select the first cell in the Annotation column where you want the imported image to
start.

Annotation2

2. Do one of the following:

» Right-click on the cell and select Annotation > Import File.
» From the Xsheet menu, select Annotation > Import File.

3. Browse for the bitmap image to import.

4. Click Open.

The image appears in the Annotation column.

Annotation2 ®

Filling Exposure
Harmony provides different tools to fill in exposures and values, create cycles, and set increments.
This section is divided as follows:

» Filling Exposure Mode on page 269

» Typing Exposure on page 270

*  Holding Exposure on page 271
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» Extending a Single Exposure on page 272

» Extending an Exposure Sequence on page 273

» Extending the Exposure of Previous Drawings on page 275

» Dragging Cells on page 276

* Increasing and Decreasing Exposure on page 279

» Inserting Blank Cells on page 282

» Setting the Exposure on page 283

* Filling a Selection with a Single Exposure on page 284

* Filling a Selection with a Sequence on page 285

* Filling a Selection Randomly on page 287

* Filling Empty Cells on page 288

» Deleting Exposure on page 281

* Creating Cycles on page 289
» Managing Key Exposures on page 293

Filling Exposure Mode

In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes control
the filling behaviour. The Timeline view only uses the Overwrite mode.

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence overwrites
existing ones. The existing timing sequence remains in the same place and is not pushed down the column.

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence over
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down the
column.
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How to switch between Overwrite and Insert modes

1. Do one of the following:

» Inthe bottom-right corner of the Xsheet view, click Overwrite/Insert.
» Pressl.

Typing Exposure
Tofill in your exposure, you can type the values directly in the Xsheet view.

If you want to type an exact drawing name or value in the Timeline view, you must use the Parameters section of
the Timeline.

NOTE: You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

How to type a value in the Timeline view

1. Inthe Drawing Substitution field, double-click to edit the field and type the name of the drawing you want to
create.
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2. Press Enter/Return to validate the value.

How to type values in the Xsheet view

In an Xsheet column, double-click on a cell.

2. Type avalue or drawing name in the cell.

3. Press Enter/Return to move to the next cell.

Drawing

4. Press Esc to exit the typing mode and return to normal mode.

Holding Exposure

Drawings in an animation project are often exposed for more than one frame. The most common exposure of a
drawing is two frames. In the industry, this type of exposure is known as animation in double frames or animation on
twos. A drawing can also be exposed for three, four, or five cells and so on. To prevent mistakes and save time, you
can hold cells automatically as you type in the Xsheet view.
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How to hold exposure

1. Do one of the following:

» Inthe Xsheet menu, select Exposure > Hold Exposure > Hold 2 Cells.

» From the top menu, select Animation > Cell > Hold Exposure > the desired option.
2. Type avalue or drawing name in the cell.

» Press Enter/Return to move on to the next cell.
» Press Esc to quit the typing mode.

Extending a Single Exposure

Extending the exposure lets you select a cell that contains a value and pull it down to the desired frame.

How to extend a cell exposure gesturally

1. Inthe Xsheet view, select the red arrow lin the cell’s right side. Make sure you see the drag down 1
cursor.

2. Pull down the selected cell to the desired frame.

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is
considered cancelled.
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How to extend a sequence from the top menu

1. Select a cell and do one of the following:

» From the top menu, select Animation > Cell > Extend Exposure.
» PressFb5.
The Extend Exposure dialog box opens.

2. Enterthe frame number you want to extend the cell to.

Extending an Exposure Sequence

When working with a sequence that contains only numbers, you can extend an exposure sequence in a similar
manner to extending a single exposure.

How to extend an exposure to create a sequence

1. Inthe Xsheet view, select a cell containing a number.

2. Inthe selected cell, click the red arrow I on the cell’s right side. Make sure to see the drag down I cursor.

3. Hold down the Shift key. Make sure a plus sign (+) appears.

4. Pull down the selection box to the desired frame.

273



Chapter 6: Timing

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is
considered cancelled.

5. First release the Shift key, then release the mouse button.
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Extending the Exposure of Previous Drawings

When drawing on a blank frame you can automatically create a new drawing and extend the timing from the previous
exposed drawing.

In the following example, a cell is selected on the timeline for creating a new drawing inimage A. Inimage B, the
previous exposure does not extend to the new drawing, while inimage C, it does.

A A cellis selected for a new drawing.

How to extend the exposure of previous drawings

1. Open the Preferences dialog box by doing one of the following:

» From the top menu, select Edit > Preferences.
» Press Ctrl + U (Windows/Linux) or &£ + U (Mac OS X).

The Preferences dialog box opens.

2. Select the Exposure Sheet tab.
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4. On the left side of the Timeline view, select a cell and create a new drawing.

The previous exposure automatically extends to the beginning of the new drawing.

Dragging Cells

To readjust your timing, you can drag one or more cells to a new location. You can drag a cell to any other frame in
the same column or into another column.

You can turn off the Gestural Drag mode for the Xsheet view to prevent drawings from being dragged from one
location to another. This feature does not apply to Annotation columns.

How to drag a cell to another location in the Timeline view

1. Inthe Timeline view, select one or more cells to move.
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3. Drop the selection by doing one of the following:

» Drop by simply releasing the mouse or pen.

» Hold Ctrl (Windows/Linux) or 3 (Mac OS X) while dropping the selection to copy the cells. The original
cells will not be moved.

» Press Shift while dropping the selection to insert them between existing frames.

How to drag a cell to another location in the Xsheet view

1. Inthe Xsheet view, select one or more cells.

2. Inthe Xsheet view, position the pointer over the small dotted area = = on the left side of the selected cells.
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3. Drag the selection to any other cell in the same column or in another column.

4. Do one of the following:

» Drop the selection to overwrite the existing cells.

» Hold down Ctrl (Windows/Linux) or 3£ (Mac OS X) while dropping the selection to copy the cells. The
original selection will not be moved.

» Press Shift while dropping the selection to insert it between existing frames.
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Drawing_1

How to turn off the Gestural Drag mode

1. Do one of the following:

» Inthe Xsheet view, right-click and deselect Gestural Drag Mode.
» From the Xsheet menu, select Edit > Gestural Drag Mode

» Inthe Xsheet toolbar, click the Toggle Gestural Drag Mode l button (you may have to customize the
toolbar to display it).

The dragging pad disappears on selected cells when the Gestural Drag mode is off.

Increasing and Decreasing Exposure

Once avalue is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

Increasing the exposure adds one more exposure to a selected cell; repeating this action adds an extra cell each
time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing an
exposure pushes the existing exposure forward.

Decreasing the exposure removes one exposure from a selected cell and pulls any cells following it to the beginning
of selection.

How to increase exposure

1. Inthe Timeline or Xsheet view, select a cell.

fun
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2. Do one of the following:
» From the top menu, select Animation > Cell > Increase Exposure.
» Inthe Xsheet toolbar, click the Increase Exposure button.

» At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be
exposed.

Current: 1: Drawing

» Right-click and select Exposure > Increase Exposure.

» Press +.

How to decrease exposure

1. Inthe Timeline or Xsheet view, select a cell.

Jrawing_2

2. Do one of the following:
» From the top menu, select Animation > Cell > Decrease Exposure.
» Inthe Xsheet toolbar, click the Decrease Exposure button.

» At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be
exposed.

Current: 1 : Drawing E::-.:|:|| 8 o | Cverwrite

» Right-click and select Exposure > Decrease Exposure.
» Press -
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How to use the Clear Exposure and Pull feature

1. Inthe Timeline or Xsheet view, select a range of cells.

2. Do one of the following:

» From the top menu, select Animation > Cell > Clear Exposure and Pull.
» Right-click and select Exposure > Clear Exposure and Pull.
» Inthe Xsheet toolbar, click the Clear Exposure and Pull > button.

The exposure is reduced by the selected number of cells.

Deleting Exposure

You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the Timeline or
Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by typing its name againina
cell.

You can delete the exposure in a selected cell range or delete the entire exposure of a drawing exposed over several
cells. Note that you can also delete the exposure for drawings inside a collapsed group.

How to delete selected exposures

1. Inthe Timeline or Xsheet view, select the exposure you want to delete.

2. Do one of the following:

» Right-click and select Delete.

» Press Delete.

How to clear the entire exposure of a drawing

1. Inthe Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

2. Do one of the following:

» From the top menu, select Animation > Cell > Clear Exposure.
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» Inthe Timeline view, right-click and select Exposure > Clear Exposure.

» Inthe Xsheet toolbar, click the Clear Exposure
display it).

button (you may have to customize the toolbar to

Inserting Blank Cells
You can place an empty cell between other cells.

How to insert blank cells

1. Inthe Timeline or Xsheet view, select the cell in which you want to insert a blank cell.

2. Do one of the following:

» Inthe top menu, select Animation > Cell > Insert Blank Cell.
» Right-click and select Exposure > Insert Blank Cell.

» Inthe Timeline or Xsheet toolbar, click the Insert Blank Cell #, button (you may have to customize
the toolbar to display it).

» Press Shift + J.
A blank cell is inserted.
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How to clear a selected cell range without changing the exposure and timing

1. Inthe Xsheet view, select a frame range to clear.

2. Right-click and select Clear.

3
4
5
6
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8
9

=
=

Setting the Exposure

You can easily increase or decrease the exposure for a selected cell range.

How to set the exposure

1. Inthe Timeline or Xsheet view, select the cell range on which you want to set the exposure.
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2. Do one of the following:
» From the top menu, select Animation > Cell > Set Exposure to > Set Exposure to 1, 2, 3, or Set
Exposure.

» Inthe Timeline toolbar, click one of the Set Exposure buttons (you may have to
customize the toolbar to display them).

» Inthe Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 1, 2, or 3,
or Set Exposure.

3. If you chose the Set Exposure option, the Set Exposure dialog box opens. Enter the number of frames you
want the drawings to display and click OK.

Filling a Selection with a Single Exposure

You can fill the same value over an entire selection. The selection can be over one cell, a cell range in one
column, a cell range over many columns, an entire column, or many columns. You can use numbers, words,
letters, or any alphanumeric value.
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How to fill a selection with a single exposure

1. Inthe Timeline or Xsheet view, select a cell range.

2. Do one of the following:

» From the top menu, select Animation > Cell > Fill Selection.

> Inthe Xsheet toolbar, click the Fill Selection [ button (you may have to customize the toolbar to display
it).

» Press Ctrl + T (Windows/Linux) or 3§ + T (Mac OS X)).

The Fill Selection dialog box opens.

3. Inthe Value field, type the desired value.

4. Toinsert a key exposure in the frame following the last cell in the selection, select the Add Key Exposure
After option. Otherwise, leave it deselected.

5. Click OK.

Filling a Selection with a Sequence

You can create a numbered sequence over a selection. The sequence can be forward, backward, single, double or
higher increment, as a cycle, and so on. The selection can be over one cell or a cell range in one column or more or
an entire column or many entire columns.
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How to fill a selection with a sequence

1. Inthe Timeline or Xsheet view, select a cell range.

2. Do one of the following:

» From the top menu, select Animation > Cell > Sequence Fill.

» Inthe Timeline view, right-click and select Exposure > Sequence Fill.

> Inthe Xsheet toolbar, click the Sequence Fill |z button (you may have to customize the toolbar to
display it).

» Press Ctrl + M (Windows/Linux) or 38 + M (Mac OS X)).

The Sequence Fill dialog box opens.

3. Inthe Starting Value field, type the first number in the sequence.
4. Inthe Increment field, type the number by which the drawing number will increase from frame to frame. For

example, an increment of 1 gives you: 1-2-3-4; an increment of 2 gives you: 1-3-5-7; and -2 gives you
this: 8-6-4-2.
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Filling a Selection Randomly

You can fill in random values over a selection. You can give a maximum and a minimum value and create a range for
Harmony to choose the random values from. The selection can be over one cell or a cell range in one column or more
or an entire column or many entire columns.

How to fill cells randomly

1. Inthe Timeline or Xsheet view, select a cell range.

2. Do one of the following:

» Select Animation > Cell > Fill Cells Randomly.

» Inthe Xsheet view, click the Fill Cells Randomly button (you may have to customize the toolbar to
display it).

The Fill Cells Randomly dialog box opens.
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3.

In the Minimum Value field, enter the lowest acceptable value.
In the Maximum Value field, enter the highest acceptable value.
In the Hold field, choose an exposure holding value.

If you are applying this option to a drawing column, select the Whole Numbers option to avoid decimal
points.

Click OK.

Filling Empty Cells

You can fill empty cells to extend the exposure of single frame drawings to fill the range of empty cells after each
one.When creating drawings on cells that are not side-by-side, the exposure of the first drawing no longer fills
automatically. You must select the frame range where you want your drawings to hold their exposure up to the
next drawing and use the Fill Empty Cells command.

How to fill empty cells

1.

In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:

» Right-click and select Exposure > Fill Empty Cells.
» From the top menu, select Animation > Cell > Fill Empty Cells.
» Inthe Timeline toolbar, click the Fill Empty Cells 00 button.
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Each drawing in the selection is exposed in the range of empty cells that follow it.

Creating Cycles

Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.
You can loop your drawings using the following commands:

* Create Cycle

+ Paste Cycle

+ Paste Reverse

When you create a drawing cycle, all the repeated drawings are linked to the same original files. When modify,
repaint, or correct a drawing named “1” for example, all drawings named “1” are updated simultaneously. In order to
modify a drawing independently from its other exposures, you must duplicate the drawing.

How to create a cycle

1. Inthe Timeline or Xsheet view, select the cell range to loop.

2. Inthe Timeline toolbar, click the Create Cycle button (you may have to customize the toolbar to display
it).

The Create Cycle dialog box opens.
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3. Enter the number of cycles you want, including the current selection.

How to paste a cycle

1. Inthe Timeline or Xsheet view, select the cell range to loop.

o
ol
=1

@~ o e g

-

1. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C (Windows/Linux)
or &£ + C (Mac OS X).

2. Inthe Timeline or Xsheet view, select the cell where you want your cycles to start.
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3. Do one of the following:

» From the top menu, select Edit > Paste Cycle.

» Right-click and select Paste Cycle.

» Press Ctrl +/ (Windows/Linux) or 3£ +/ (Mac OS X).
The Paste Cycle dialog box opens.
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4. Do one of the following:

» Inthe Number of Cycles field, enter the number of cycles you want to paste.
» Increase or decrease the number of cycles you want to paste.

5. Inthe Cycle Type menu, select the type of cycle you want to paste.

» Normal (forward): Pastes cycles as for all cycles, starting with the first cell of your selection and ending
with the last.

» Reverse: Pastes cycles in the reverse order of the original selection, starting with the last cell of your
selection and ending with the first one.

» Forward > Reverse: Pastes the first cycle in your selection as is, then the following one in reverse order.
This repeated until all cycles are pasted.

» Reverse > Forward: Pastes the first cycle in your selectionin reverse order, then the following one as is.
This repeated until all cycles are pasted.

6. Click OK.

NOTE: You can perform the same operation using the Paste Special dialog box. To open the Paste
Special dialog box, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or 3£ + B (Mac OS
X).

How to paste a reversed cycle

1. Inthe Timeline or Xsheet view, select the cell range to paste in reverse order.
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2. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C (Windows/Linux)
or 3£ + C (Mac OS X).

3. Inthe Timeline or Xsheet view, select the cell where you want your cycles to start.

4. Do one of the following:

» From the top menu, select Edit > Paste Reverse.
» Right-click and select Paste Reverse.
» Press Ctrl + . (Windows/Linux) or 3£ + . (Mac OS X).

Mo |~ o (| LR =

Overwriting Exposures and Keyframes

If the area on which you are dropping a selection contains exposures and/or keyframes, they are overwritten by
the content you are selected by dragging. You can set this mode in two places: the Timeline toolbar and the
Preferences dialog box.

How to override exposure and keyframes

1. Inthe Timeline or Xsheet view, drag to select the drawings you want to move.

2. Do one of the following:

» Inthe Timeline toolbar, click the Toggle Override Exposure and Keyframe During Drag and Drop
button (you may have to customize the toolbar to display it).
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» From the top menu, select Edit > Preferences or press Ctrl + U (Windows/Linux) or 3£ + U (Mac OS X).
Select the Timeline tab, then select the Override Exposure and Keyframe During Drag and Drop
option.

zte  Timeline

3. Drop your selection at the desired location.

Managing Key Exposures

Before working with key exposures, it's important to understand how keyframes, exposure and key exposure work
in Harmony:

+ Keyframe: A keyframe is a point in time where a change to the properties of the object or character occurs. In
Harmony, keyframes consist of the coordinates that determine how an entire layer and its contents are
moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

+ Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames. In
Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. Keyframes
can be moved independently from the drawing exposure.

+ Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed on
a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for another
one, then the original drawing is retained. This preserves the key drawing. Note that Harmony automatically
sets a key exposure when you perform a drawing swap.

Adding Key Exposures

Key exposures are mainly used for swapping drawings in cut-out animation where you will have numerous drawings
for the various positions of the mouth or eyes of a character for example.

If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This prevents
it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property of an exposure
that forces it to be exposed on a certain frame regardless of whether the previous exposure is the same drawing or
not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be automatically
updated even if set as a key exposure. This keeps your existing animation key poses intact. It is frequently used on a
mouth or eyes layer.

Example: Swapping a drawing with no key exposure
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In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure.

Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is
positioned in the middle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing 5 for
drawing 1, the second drawing 5 retains its exposure.

A location is selected for a new key exposure.

DR5

New key exposure

A key exposure is added at the location of the playhead.

How to add a key exposure

1. Inthe Timeline view, select the drawing cell to set as the key exposure.

2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure . button.

» Inthe Timeline toolbar, click the Add Key Exposure LS button.

» Inthe Timeline menu, select Exposure > Add Key Exposure.
» Right-click and select Exposure > Add Key Exposure.
A new key exposure is added.
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If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing is
split in two and both parts contain the same drawing.

Removing Key Exposures

When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure is
replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When the
key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).

Before: Key exposure is set to drawing 1.

How to remove a key exposure

1. Inthe Timeline view, select a key exposure to remove.

2. Do one of the following:

» Inthe Timeline toolbar, click the Remove Key Exposure = button.

» Inthe Timeline menu, select Exposure > Remove Key Exposure.
» Right-click and select Exposure > Remove Key Exposure.
The key exposure is removed and replaced by the preceding exposure.

Removing Duplicate Key Exposures

When working with drawings to adjust the timing of a mouth in a lipsync, for example, and forcing the use of specific
key exposures, unnecessary key exposures will be created. You can delete these duplicates without affecting the
rest of the drawing. The first drawing of the selection will be used for the range.

NOTE: Duplicate key exposures may occur when pasting with the Enforce Key Exposure option selected.

How to remove duplicate key exposures

1. Inthe Timeline view, select the layer that contains duplicate key exposures.
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2. Inthe Timeline toolbar, click the Remove Duplicate Key Exposurezlé-c button (you may have to customize
the toolbar to display it).

Pasting Key Exposures Using Different Modes

As you animate, you will find that you reuse key exposures. There are different options to paste your selected
drawings when they contain key exposures:

» Enforce Key Exposure: If there are key exposures that exist on copied drawings, they are preserved
when pasting. No key exposures are added. This is the default behavior when pasting.

» Fill Gap with Previous Drawing: Fills selected area in the Xsheet or Timeline view with the previous
drawing.

+ Fillto Next Key Exposure: Fills selected area till the next key exposure.

How to paste using different modes

1. Inthe Timeline or Xsheet view, select the drawings you want to copy and press Ctrl + C (Windows/Linux)
or 3£ + C (Mac OS X).

2. Inthe Timeline or Xsheet view, select the cell where you want your pasted selection to start.

3. Do one of the following:

» Press Ctrl + B (Windows/Linux) or &£ + B (Mac OS X).

The Paste Special dialog box opens.
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Advanced

» From the Timeline menu, select Edit > Modify Paste Presets > Exposure.
The Edit Exposure Paste Preset dialog box opens.

o Default
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4. Select the Enforce Key Exposure or Fill to Next Key Exposure option. In the Paste Special dialog box,
these options are on the Basic tab.

Click OK.
6. Press Ctrl + V (Windows/Linux) or & + V (Mac OS X) to paste your selection.

Navigating between Frames and Columns

Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, and
layers using keyboard shortcuts that work in the Camera, Drawing, Xsheet and Timeline views.

You can navigate through:

* Drawings
*«  Frames
e Columns

How to navigate through drawings, and frames and columns

1. Inthe Timeline or Xsheet view, select a cell.

2. Oncethecell is selected, you can navigate between:

» Previous and next layers: From the top menu, select Drawing > Previous Layer and Next Layer or
press H and J.
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» Previous and next drawings: From the top menu, select Drawing > Previous Drawing and Next
Drawing or press F and G..
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» Previous and next frames: From the top menu, select Play > Previous Frame and Next Frame or
press comma (,) and period (.).
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Managing Drawings

Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files stored in the
project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit the file and
not the cells.

This section is divided as follows:

* Renaming a Drawing on page 299

» Deleting a Drawing on page 301

» Duplicating a Drawing on page 302

» Copying and Pasting Drawings on page 302

* Merging Drawings on page 304

Renaming a Drawing

To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

How to rename a drawing

1. Inthe Timeline or Xsheet view, select the drawing to rename.
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2. Do one of the following:

» Right-click and select Drawings > Rename Drawing.

» Inthe Timeline toolbar, click the Rename Drawing button (you may have to customize the toolbar
to display it).

» Press Ctrl + D (Windows/Linux) or 3£ + D (Mac OS X).

The Rename Drawing dialog box opens.

3. Inthe New Name field, type in the new drawing name.

How to rename a drawing sequence with a prefix

You can rename a drawing sequence with a prefix, which can be quite useful for cut-out puppet breakdown and
deformation animation.

1. Inthe Timeline or Xsheet view, select a drawing sequence. Note that you can only select a drawing range
in one column or layer at a time.

2. Right-click and select Drawings > Rename Drawing with Prefix.

The Rename Drawing with Prefix dialog box opens.

3. Inthe Prefix to Add field, type the prefix to add before the drawing name.

How to rename drawings by their frame position

You can rename a series of drawings relative to their frame position. This is useful in hand-drawn animation.

1. Inthe Timeline or Xsheet view, select the drawing sequence to rename.
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2. From the top menu, select Drawing > Rename by Frame.

Deleting a Drawing

You can permanently delete a drawing file from a project's folder.

NOTE: Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing

1. Inthe Timeline or Xsheet view, select the drawings to delete.

2. Do one of the following:

» From the top menu, select Drawing > Delete Selected Drawings.
» Right-click and select Drawings > Delete Selected Drawings.
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Duplicating a Drawing

If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing.
The exposure of the original drawing that was on the current cell is removed. The original drawing is not deleted
from the project folder or other cells in which it is exposed.

With Toon Boom Harmony, you can create a keyframe at the same time as you duplicate your drawing. This way,
you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

1. Inthe Timeline or Xsheet view, select the drawing to duplicate.

2
I
2. Do one of the following:

» From the top menu, select Drawing > Duplicate Drawings.
» Right-click and select Drawings > Duplicate Drawings.
» Inthe Xsheet toolbar, click the Duplicate Drawing #; button.

» Press Alt + Shift + D.

Copying and Pasting Drawings

When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual
drawings, you are pasting the exposure. Exposure is a property; it is the length of time that a drawing is visible
over a series of frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to
drawings. Keyframes can be moved independently from the drawing exposure.

If you want to copy and paste selected drawings into a different layer or paste the selection in the same layer to
duplicate the drawings, you must use the Paste Special feature.

There are four different ways to paste your selected drawings with the Paste Special dialog box:
When adding exposures to a drawing layer, drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures to a drawing layer,
new drawings will be created only when drawings with the same name do not already exist in the
destination.
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Replace existing drawings. Create drawing files when they do not exist: Replace drawings with
the same names to update a scene with new modified drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a template, such as
when placing new drawings after the animation, then delete the template's animation. It
will still have updated the drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new drawings will always
be created. If drawing files with the same name already exist, Harmony will create a new name for the
drawing.

If you want to perform another Paste Special operation using the same settings you used previously, you can use
the Paste Special Again command instead. You can paste your selection using the same settings as in the most
recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

1. Inthe Timeline or Xsheet view, select the drawings to copy and press Ctrl + C (Windows/Linux) or 3§ + C
(Mac OS X).

2.

3. Do one of the following:

» Right-click and select Paste Special.
» From the top menu, select Edit > Paste Special.

» Inthe Xsheet or Timeline toolbar, click the Paste Special . button (you may need to customize the
toolbar to display it).

» Press Ctrl + B (Windows/Linux) or 3£ + B (Mac OS X).

The Paste Special dialog box opens.

303



Chapter 6: Timing Extending the Exposure of Previous Drawings

4. Select the Basic tab.

5. Inthe Drawings section, select the Always Create Drawings or Only Create Drawings When They Do
Not Exist option.

How to paste new drawings with the previous Paste Special settings

1. Do one of the following:

» From the top menu, select Edit > Paste Special Again.
» Right-click and select Paste Special Again
> Inthe Timeline or Xsheet toolbar, click the Paste Special Again ;- button (you may have to customize
the toolbar to display it).
» Press Ctrl + Shift + B (Windows/Linux) or 3§ + Shift + B (Mac OS X).
Merging Drawings

There are two methods of merging drawings.
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* You can merge selected drawings in adjacent elements. The columns and layers will be left intact, and each
new merged drawing will reside in the frames of the left-most column or lower layer.

* You can merge elements. All drawings will be merged. Unused columns and layers will be deleted, but the
original drawing files are still accessible.

How to merge selected drawings

1. Inthe Xsheet view, select the drawings to merge.

= B

Camp k Moon

2. Do one of the following:

» Inthe Xsheet menu, select Columns> Merge Selected Drawings.
» Inthe Timeline menu, select Layers > Merge Selected Drawings.
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3. Do one of the following:

» Inthe Xsheet menu, select Columns > Merge Selected Columns.
» Inthe Timeline menu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most column will contain the merged drawings and the remaining columns will be left
blank at the corresponding frames. In the Timeline view, the bottom timeline layer will contain the merged
drawings from all layers and the other layers will be left blank at the corresponding frames. Drawings are not
deleted and are still accessible.

How to merge drawings in entire layers or columns

1. Do one of the following:

» Inthe Timeline view, select the layers you want to merge.
» Inthe Xsheet view, Shift-click the headers of the columns you want to merge.

EEEEE

» Inthe top menu, select Edit > Merge.
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» Inthe Xsheet menu, select Columns > Merge Selected Columns.
» Inthe Timeline menu, select Layers > Merge Selected Layers.
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In the Xsheet view, the right-most column will contain the merged drawings and the other columns will be
deleted. In the Timeline view, the bottom timeline layer will contain the merged drawings from all layers and
the other layers will be deleted. Drawings are not deleted and are still accessible.

Customizing Layers and Columns

You can change the way a column in the Xsheet view displays. You can change the way a layer in the Timeline view
or a column in the Xsheet view displays. You can stay organized without changing the content of elements or your
animation output.

This section is divided as follows:

Expanding and Collapsing Layers and Columns on page 307

Showing or Hiding Layers on page 308

Showing and Hiding Columns on page 310

Customizing Columns on page 313

Displaying Thumbnails in the Xsheet on page 319

Changing the Layer or Column Colour on page 319

Setting Scene Markers on page 321

Setting Tempo Markers on page 324

Expanding and Collapsing Layers and Columns

To simplify the look of the Timeline or Xsheet view, you can expand and collapse the layers and columns. If some
layers are parented to other ones, you can collapse the parent layer to hide its children.

How to collapse or expand selected layers in the Timeline view

1.

In the Timeline view, select the layer(s) to collapse or expand.

2. Do one of the following:
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» Right-click on the selection and select Collapse/Expand > Collapse/Expand.
» Click the Expand Children Arrow & button on the parent layer.

» Click the Collapse/Expand button (you may have to customize the toolbar to display it).

» Press Ctrl + | (Windows/Linux) or 3 + | (Mac OS X).

How to collapse or expand all layers in the Timeline view

1. Do one of the following:

» Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

» Inthe Timeline toolbar, click the Collapse All or Expand All buttons (you may have to
customize the toolbar to display them).

» Press0and9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

1. Inthe Xsheet toolbar, click the Show Column List [; button to display the Functions list.
2. Inthe Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or expand.

3. Do one of the following:

» Right-click on the column’s header and select Expand/Collapse > Collapse Selection or Expand
Selection.

» Inthe Xsheet toolbar, click the Collapse Selection or Expand Selection buttons (you may
have to customize the toolbar to display it).

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:

» Right-click on any column’s header and select Expand/Collapse > Collapse All or Expand All.
» Press0and9.

» Inthe Xsheet toolbar, click the Collapse All or Expand All buttons (you may have to customize
the toolbar to display it).

Showing or Hiding Layers

As you work in the Drawing or Camera view, some layers may be in the way or are used as references. You can
hide these layers to make your work area less cluttered and easier to navigate. You can show and hide layers in
the Timeline view in several different ways.

When using the Solo mode to show or hide layers, here's how it works:

« Ifyou have anything selected, it is not affected.
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+  When multiple layers are selected and you enable/disable the Solo mode on any of those layers, it is applied
to all the selected layers.

*  When multiple layers are selected and you enable/disable the Solo mode on layers that are not part of the
selection, it is applied only to those particular layers.

When exporting or rendering a scene, the Solo mode setting of layers is ignored.

NOTE: When a layer is affected by an inverted cutter, enabling the Solo mode for this layer will not show it unless the
mask is also enabled.

How to show or hide all layers

1. Click one of the following in the Layers toolbar:

» Enable/Disable All , button to show or hide all layers.

Any hidden layers are unhidden, so you can view all layers.

» Solo Mode @ button to view disable your current Solo mode selection. Any soloed drawing or sound
layers are disabled, so you can view all layers. When you click again on the Solo Mode button, you last
Solo selection is displayed.

How to show or hide individual layers

1. Do one of the following:

» Inthe Layer toolbar, click the Solo Mode @ button.
» Click the layer's Enable/Disable All , button to show or hide that layer.

» Press Ato show alayer or D to hide selected layers.

» Inthe Timeline toolbar, click the Enable/Disable «~ button (you may have to customize the toolbar to
display it).
When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet view.

How to enable the selected layer and disable all others

1. Do one of the following:

» Hold down Alt and click the Solo Mode @ button of the layer you want to solo and hide all other layers.

» Inthe Timeline toolbar, click the Disable All Others g button (you may have to customize the toolbar to
display it).
In the Timeline view, you can hide or show certain types of layers such as Effect.
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How to show and hide layer types in the Timeline view

1. From the Timeline menu, select View > Show > Show Manager.

The Show Manager dialog box opens.

Restore Default

2. Select the types of layers you want to display and deselect the ones you want to turn off.

3. Click Set As Default to make these new settings the default ones that will be used each time to start the
application. Click Restore Default to restore the settings used when installing the application.

In the Xsheet view, you have the choice of hiding or showing certain types of columns such as Annotation

and Functions.

Showing and Hiding Columns

The Xsheet view has a Column List section that displays all the columns contained in the exposure sheet. It can
be used to hide individual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without
using the Column List section.

You can also hide a column type, such as Drawing or Sound. When you do this, its corresponding layer is
disabled in the Timeline view.

How to show or hide columns in the Xsheet view
1. Inthe Xsheet toolbar, click the Show Column List 7 button.

2. Onthe right side of the Functions section, click the Expand < button to display the Column List section.

3. Do one of the following:

» Inthe Column List section, select the columns to display and deselect the columns to hide.

» Inthe Xsheet toolbar, click the Hide Selected Column g5 button (you may have to customize the
toolbar to display it).
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How to show a hidden column in the Xsheet view

1. Inthe Xsheet view, do one of the following:

» Click the thick grey line that represents a hidden column.
» Right-click on the column header and select Show Hidden Columns.
» Press Alt + Shift + H.

Drawing_1

The Show Hidden Columns dialog box opens.

Uncheck

Close

2. Inthe Show column, select the hidden columns you want to display in the Xsheet view.

» Click Check to select all the selected columns.
» Click Uncheck to deselect all selected columns.

How to show all columns

» Inthe Xsheet menu, select View > Unhide All Columns.

How to show and hide column types

1. Inthe Xsheet view, select View > Column Types Manager.

The Column Types dialog box opens.
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2. Select the types of columns you want to display and disable the ones you want to hide.
Click Set As Default if you want to make these new settings the default ones used each time you start Harmony.

Click Restore Default if you want to return the settings to their defaults.
How to show or hide Xsheet columns using the Column List
1. Inthe Xsheet toolbar, click the Show Column List [ button.

2. Onthe right side of the Functions section, click the Expand < button to display the Column List section.

3. Inthe Column List section, select the columns to display and deselect the columns to hide.

How to show or hide an Xsheet column type using the Column List

1. Inthe Column List section, click the button corresponding to the column type you want to show or hide.

Column Type Action
oo Show/Hide All Columns
& Show/Hide Drawing Columns

Show/Hide Function Columns

“ Show/Hide 3D Path Columns

Show/Hide 3D Rotation Columns
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> Show/Hide Sound Columns

Show/Hide Annotation Columns

Customizing Columns

In Harmony, you can customize the way the column displays drawings, empty cells and the column width.
You can modify the following elements:

+  Empty cells

* Row units

* Held exposure

e Column width

How to modify the look of empty cell

1. From the Xsheet menu, select View > Empty Cells > With an “X” or Blank.

Blank ‘With an "X"

How to modify row units

1. From the Xsheet menu, select View > Row Units > Frames or Feet.

Frames Feet

How to modify the look of a held exposure

1. Inthe Xsheet menu, select View > Held Exposures > Line or Value.
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Line Value

How to modify column width

1. Inthe Xsheet view, select a column.

2. From the Xsheet menu, select View > Set Columns Width.
The Xsheet Column Width dialog box opens.

Columns Wid

Apply Set As Default

3. Inthe Column Width field, enter the desired width in pixels.

4. Do one of the following:

» Click OKto validate and close the dialog box.

» Click Apply to validate the operation and keep the dialog box opened to adjust the next column’s width.
» Click Set As Default to create all the new columns to this width.

» Click Close to cancel the operation.

5. Torestore all columns to the default value, in the Xsheet menu, select View > All Columns to Default
Width.

Drawing Identification

In the Xsheet view, you can identify drawings as Key, Breakdown or In-between.
This helps to keep the Xsheet well organized while animating.

When working with several animators, directors or even other studios, the necessity for retakes will often arise.
Harmony gives you the possibility to mark new drawings as either Retake Key, Retake Breakdown, or Retake In-
betweens.

If your production requires you to mark drawings with a custom marker, you also have the option to create your
own.

Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a bit of code.
Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing toolbars, but also in the
Onion Skin and Flip toolbars.
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Mark Drawing toolbar

Onion Skin toolbar

Flip toolbar

NOTE: You can create custom shortcuts for the Drawing Identification options in the Preferences dialog box.

Key Drawing

A key drawing is a visually significant pose in a movement, often an extreme position. For example, if a character
that is sitting down falls on his back, the key poses would be the character sitting and the character on his back. Of
course, it may vary from one animation to another.
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Breakdown Drawing

A breakdown drawing is a pose somewhere between two key poses that better shows the movement. Most
animation moves are arcs, such as an arm waving, somebody bending, or a leg walking. All of these movements
are rotations. The breakdown pose is used to describe this curve better.

The breakdown drawing is then used to indicate secondary poses, also called the follow-through. These actions
can be a big stomach jiggle as somebody jumps, a cloak floating behind somebody that is running, or arms
moving after the main body action. These moves will generally have a different timing than the primary action.
They will mainly start later and finish later. So, the breakdown drawings are used to complete the key drawings.

Note that a breakdown drawing is not always placed exactly in the middle of two keys. It will often be closer to
one or the other depending on the timing and the action. Also, you can have more than one breakdown pose
between two keys.

How to mark a drawing as Key, Breakdown or In-between

1. From the top menu, select Windows > Toolbars > Mark Drawing.

The Mark Drawing toolbar displays.

2. Inthe Xsheet view, select the cell you want to identify. This option is not available in the Timeline view.

3. Inthe Mark Drawing toolbar, click one of these buttons: Mark as Key Drawing @ , Mark as Breakdown
Drawing - orMark as In-between Drawing 1 . Inthe Xsheet menu, you can also select Drawing >

Mark Drawing As > Key Drawing, Breakdown Drawing, In-between Drawing, Retake Key, Retake
BD and Retake IB.

» If you selected Mark as Key Drawing, a | icon appears in the cell.
> If you selected Mark as Breakdown Drawing, a | icon appears in the cell.

» If you selected Mark as In-Between Drawing, there is no icon displayed in the cell since it is used to
remove a Key or Breakdown marker.
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How to create custom markers

1. With a bitmap editing software, create the following icons in PNG format:

» Mark Drawing Toolbar icon (24 x 24 pixel)
»  Onion Skin Toolbar icon (24 x 24 pixel)

» Flip Toolbar icon (24 x 24 pixel)

» Xsheet Columnicon (16 x 16 pixel)

2. Close Harmony.

3. When youricons are ready, open the Toon Boom Harmony drawingTypes .d folder.
*  Windows:

*  Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon
Boom Animation\Toon Boom Harmony\full-1200-pref\drawingTypes.d

» Toon Boom Harmony Advanced: C:\Users\[user_
name]\AppData\Roaming\Toon Boom Animation\Toon Boom
StageAdvanced\full-1200-prefidrawingTypes.d

« MacOSX:
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On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told
down the Alt key.

* Toon Boom Harmony Premium: /Users/[user_
name]/Library/Preferences/Toon Boom Animation/Toon Boom Harmony/full-
1200-pref/drawingTypes.d

*  Toon Boom Harmony Advanced: /Users/[user_
name)/Library/Preferences/Toon Boom Animation/Toon Boom Stage
Advanced/full-1200-pref/drawingTypes.d

¢ Linux:

* /home/user_name/Toon Boom Animation/Toon Boom Harmony/full-1200-
pref/drawingTypes.d

» /home/user_name/Toon Boom Animation/Toon Boom StageAdvanced/full-
1200-pref/drawingTypes.d

NOTE:
If the drawingTypes.d folder does not exist, you must create it. To do so, copy the resources
folder from the following location.

+ Windows: Start > Programs > Harmony 12.2 Advanced

* Mac OS X: Applications > Toon Boom Harmony 12.2.1 Advanced > resources >
drawingTypes.d

» Linux: /usr/local/ToonBoomAnimation/harmony_12/Inx86_
64/bin/StageAdvanced/resources/drawingTypes.d

4. Paste youricons inthe drawingTypes . d directory.

5. Inthe same directory, open the drawingTypes .xml file in atext editor.

6. Foreach custom icon you want to create, add the following line. Make sure to place it before this closing
tag: </DrawingTypes>.

>

<DrawingType text="NewButtonName" pixmapFile="Xsheetlcon.png"
commandlcon="MarkDrawinglcon.png" fliplcon="Fliplcon.png" onionlcon="Onionlcon.png" />

7. Inthat line, replace the following information with your new icon information:

>

>

NewButtonName: Write the name of your new marker. This name will appear in the button tooltip.

Xsheetlcon.png: Write the name of the icon that you created to appear in the Xsheet column. Include
the file extension.

MarkDrawinglcon.png: Write the name of the icon that you created to appear in the Mark Drawing
toolbar. Include the file extension.

Fliplcon.png: Write the name of the icon that you created to appear in the Flip toolbar. Include the file
extension.

Onionlcon.png: Write the name of the icon that you created to appear in the Onion Skin toolbar. Include
the file extension.
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8. Savethefile and close it.

9. Start Harmony.

Displaying Thumbnails in the Xsheet

When there are a large number of columns in the exposure sheet, it's not easy to quickly identify a particular column.
Displaying the column thumbnails makes this easier. This option displays a small thumbnail picture of the current
frame below the column header.

How to display the thumbnails

1. Do one of the following:
» Inthe Xsheet toolbar, click the Show Thumbnails === button.
» Inthe Xsheet menu, select View > Show Thumbnails.

The thumbnails appear.

Bg_Camp

Moon

Changing the Layer or Column Colour

To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and columns.

How to change the layer’s colour in the Timeline view

1. Inthe Timeline view, click the Change Track Colour |:| button of the layer you want to modify.

2. Inthe Select Colour dialog box, select a new colour for your layer.
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Add t urs

3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, selected
colour for easy identification. The corresponding column colour is also updated in the Xsheet.

How to reset a layer’s colour in the Timeline view

1. Inthe Timeline view, select the layers to reset.
2. Inthe Timeline toolbar, click the Default Track Colour = button (you may have to customize the toolbar
to display it).

How to change a column’s colour in the Xsheet view

1. Inthe Xsheet view, select one or more columns to modify.
2. Right-click on the column’s header and select Colour > Change Columns Colour.

3. Inthe Select Colour dialog box, select a new colour for your columns.
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4. Click OK.

The column'’s colour is updated. The corresponding column colour is also updated.

Tower2_000 Moon

Plant_000 Tower_000

1

1 1

How to reset the column’s colour in the Xsheet view

1. Inthe Xsheet view, select the columns to reset.

2. Right-click on the column’s header and select Colour > Default Columns Colour.

Setting Scene Markers

Scene markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can use
it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in action, an

impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is displayed when

you hover over the scene marker.

There are two ways to add a scene marker. You can mark the current frame or make a frame range selection and
mark the whole section.

How to mark the current frame

1. Inthe Timeline view, make sure the red playhead is set on the frame you want to mark. Even if you right-click
on a different frame, the scene marker will be created on the current frame on which the playhead is posi-
tioned.

2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

w e

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the colour of
the last scene marker you created.

Colour swatch

3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene marker. Click
OK.
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Add ]

4. Inthe Note field, enter text to display as the tooltip and click OK.

In the Timeline view, the scene marker is displayed at the current frame.

5. Hoverover the scene marker to display its tooltip.

How to create a scene marker on a frame range

1. Inthe frame counter area, select the frame range you want to mark.

m e e

2. Right-click and select Create Scene Marker.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the
colour of the last scene marker you created.
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Colour swatch

3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene marker. Click
OK.

4. Inthe Note field, enter text to display as the tooltip and click OK.

In the Timeline view, the scene marker is displayed over the selected frame counters.

5. Hover over the scene marker to display its tooltip.

How to edit a scene marker

1. Inthe frame counter area, select the entire scene marker.

NOTE: It's important to select the entire length of the scene marker, otherwise the Timeline Scene Marker dialog box
will not open for editing.
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2. Right-click and select Scene Markers > Edit Scene Marker.

The Timeline Scene Marker dialog box opens.

3. Make your changes.

4. Click OK.

How to delete a scene marker

1. Inthe frame counter area, select at least one frame in the scene marker you want to delete.

2. Right-click and select Scene Markers > Delete Scene Marker.

Setting Tempo Markers

Tempo markers are used to synchronize your animation with a musical score. This lets you reproduce the FPB
(Frames Per Beat) and use the tempo signature as tempo markers. The Xsheet view lets you pace your animation
according to the tempo or beat of the soundtrack music or to any rhythmic sound, such as the ticking of a clock or
water leaking from a spout.
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How to set the tempo markers

1. Inthe Xsheet menu, select View > Set Tempo Marker.

The Tempo Marker dialog box opens.

Starting Frame: 1

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.

» Starting Frame: Enter the number of the frame where you want the tempo markers to begin.

» Frames/Beat: Set the frames per beat value. This will determine the frequency (in frames) in which a
beat marker will appear. Keep in mind that, by default, 24 frames represent 1 second.

» Beat/Bar: Set the tempo of your music or sound. This will determine the frequency (in beats) in which a
tempo marker will appear in the Xsheet view.

3. Click OK.

Printing the Xsheet

Once you have marked all the information, corrections, and timing you want in the Xsheet view, you can print your
exposure sheet. Printing the Xsheet allows you to take it with you to your animation table or give a copy to the
animator. You can also use it to create your Xsheet skeleton directly in Harmony.

How to print your exposure sheet

1. Select File > Print > Xsheet.

The Print dialog box opens.
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2. Toset up your print:

» Windows: In the Select Printer section, select your printer and adjust the rest of the printing settings.
» Linux: In the Print Destination section, select your printer and adjust the rest of the printing settings.

» Mac OS X: In the Printer section, select your printer and adjust the rest of the settings by clicking on
the Parameters @ button. You can also click PDF and select an option from the menu if you want to
save a PDF version of your exposure sheet.
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NOTE: Refer to your printer user guide to learn more about its options.

3. Do one of the following:
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Windows and Mac OS X: Click Print.
Linux: Click OK.
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Annotation

When pasting key frames and exposures, you can modify the existing presets to your liking. There are three presets
you can modify: the default presets for both key frames and exposures, key frames only and exposures only.

How to modify paste presets

1. From the Timeline view menu, select Edit > Modify Paste Presets and one of the following options:

>

>

>

The Edit Paste Presets dialog box opens.

All to edit the default paste preset settings.

Key Frame to edit the preset settings for pasting key frames.

Exposure to edit the preset settings for pasting exposures.
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Reset To Default

Cancel

2. Referto the following table and edit the presets as desired.

Edit Paste Preset Dialog Box Parameters

Parameter

Description

Drawings

Add/Remove Exposure

Never create drawing files: When adding exposures to a drawing layer,
drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures
to a drawing layer, new drawings will be created only when drawings with the
same name do not already exist in the destination.

Always create drawing files: When adding exposures to a drawing layer, new
drawings will always be created. If drawing files with the same name already
exist, Harmony will create a new name for the drawing.

Enforce Key Exposure

If there are key exposures that exist on copied drawings, they are preserved
when pasting. No key exposures are added. This is the default behavior when
pasting.

Fill Gap with Previous
Drawing

Fills selected area in the Xsheet or Timeline view with the previous drawing.

Fill to Next Key

Fills selected area till the next key exposure.

Exposure
Keyframes

Motion: Copies the properties of the selected motion keyframe to the new
frame.
Velocity: Copies the properties of the selected velocity keyframe to the new
f .

Add/Remove rame

Keyframes Rotation: Copies the properties of the selected rotation keyframe to the new

frame.

Scale: Copies the properties of the selected scale keyframe to the new frame.

Skew: Copies the properties of the selected skew keyframe to the new frame.
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Force Keyframes at Function's Beginning and End: Adds a keyframe to the
beginning and end of the pasted function, reproducing the source function.
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Chapter 7: Character Building

1
'

Harmony is a great tool for building characters. You can use different techniques and features to break down your
puppets.

This chapter will guide you through all the steps to create a complete simple rig. Harmony allows you to create very
advanced puppets using deformations, hierarchies and z ordering. As you practice and get familiar with those
concepts, you will be able to develop more complex rigs and combine various advanced features.

This chapter contains the following topics:

Importing a Model on page 1

Relative Sizes on page 1

Studying the Model on page 336

Setting the Default Separate Position Preferences on page 339

Naming Conventions on page 339

Disabling the Animation on Drawing Layers on page 341

Art Layers on page 343
Breaking Down the Characteron page 348

Ordering the Layers on page 354

Rigging on page 356
Adding Extra Drawings on page 372

Setting the Pivots on page 374

Storing the Character in the Library on page 381

Appendix on page 383
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About the Model

To begin breaking down your puppet, you must first import your character into a new project. You can also draw
your character directly in the scene.

You can import your character in several different formats:
+ Library template—see Library on page 427
» Bitmap image or picture—see Compositing Guide > Import chapter > Import Bitmap Images topic

» External vector format—see Compositing Guide > Import chapter > Import Al and PDF Files topic

Model Alignment

When setting the character model in your scene, we recommend that you to center it in the Camera view and
scale it to fit inside the safe area frame—see Field Chart on page 1.
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If you have several views of your character, place each view in a separate cell and center them one on top of
another. This will facilitate the break down process and ensure that all of your puppets are aligned and the same
size.

Photo Puppets

If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software. Then,
import your parts and vectorize them as textured images.

A good way to set and import your bitmap parts is to organize them in a multilayered PSD file.

In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all the
elements you want to import as a single layer in Harmony are grouped together in their own folder. Any layer that is
not in a folder group, by itself or otherwise, will not be imported.

4
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Relative Sizes

Understanding the relative size of every character and prop is important for maintaining consistency and structure
throughout your project.

A production may contain many characters and props. It is not unusual for these to have been created by different
people. If there is no size control implemented, the characters and elements created by different artists can vary
greatly in size. When this occurs, the characters that are put together in a scene will be out of proportion. The
animator or person doing the scene setup will then have to scale them to the correct size.
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When a character or a prop is scaled down, the outline will get increasingly thinner. By the time the element is

scaled to its proper size, the outline may be so thin that the difference between one character's outline and
another's will not look very good.

These tips will help you to create and determine the correct relative sizes for each puppet:
» Line Upon page 334
» Field Chart on page 335
* Brush Size on page 335

Line Up
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A line up consists of copying and pasting all of your character designs into the same drawing and then scaling
them so they are in proportion with each other. This line up is very important and should be handed to any
animator, layout and posing artist, or scene setup person working on the project.

For the prop design, it is recommended that you paste one of the main character's hands or even the full body
beside the prop. This enables the animator to know what size to draw or set the prop.

In your character design scene, it is a good idea to create a layer for the character line up. The line up is usually

done during the character design step. When the character builder imports the model to the break down scene,
the size relation should be correct.
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Field Chart

The field chart in Harmony is a tool that is very useful when setting the height of characters and props. You can
display the field chart using the Show Grid option in the Camera and Drawing views.

How to display the field chart

1. Do one of the following:

» From the top menu, select View > Grid > Show Grid.
» Press Ctrl +' (Windows/Linux) or 38 +' (Mac OS X).
» Click the Show Grid button in the Camera View and Drawing View toolbars.

Brush Size

There are a variety of pens and brushes in Harmony and you can also create and save your own. It is a good idea to
create and save pens with precise sizes and parameters to trace and design your models and break downs—see
Drawing with the Brush Tool on page 53.
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Studying the Model

Now that you have imported or designed your model, the next step is to analyze it. This is to determine what parts
will be broken apart and how they will be divided. Will the hair be separated into one, two or three sections? Will
the hand be separated from the sleeve? To determine what is best for your character, observe the model in the
Camera or Drawing view.

» Eyelids and Pupils on page 337

»  Separating the Mouth Elements and Jaw on page 337

» Keeping Fingers Attached to the Hand on page 337

*  Flipping Logos on page 338
» Complete and Overlapping Pieces on page 338
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Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil and the

eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of the eyeball. Fora
more advanced break down, the two eyes are separated on their own individual three-layer sets.

Separating the Mouth Elements and Jaw

A

OFf

To get a greater level of flexibility, you can separate the jaw from the head. You can also separate the mouth shape,
teeth, tongue and interior one from another.

Keeping Fingers Attached to the Hand

337



Chapter 7: Character Building

To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full

hand is a single layer with a bank of different hands stored inside. This technique is easy to work with and
produces a less mechanical effect.

Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a
character's puppet.

Complete and Overlapping Pieces

Head and Meck Pieces with Overlap Mormal Position

Head Tilt with Overlap Head Tilt without Overlap

For a better result with animated parts, it is important to understand that they must be properly overlapping and
complete. A common mistake is to trace the part just as it appears on the model.
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Setting the Default Separate Position Preferences

Before you adding layers to your puppets, make sure the Default Separate Position for Elements and the Default
Separate Position for Pegs preferences are enabled.

With the Default Separate Position preferences selected, when you create new layers, their X, Y and Z axes are
independent from each other.

By default, the Default Separate Position for Elements preference is enabled. For cut-out animation, you want to
have three independent axes so you can control them individually.

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at the
same time.

XY.Zaxes
Velocity (Ezse)

When you separate the three positions and add a keyframe on one axis, it is not added on the other two. This gives
you more freedom when animating with motion keyframes and nudging parts forward and backward over time.

Left - Right () motion not
affected by the Z nudge

(Z) Body part pushed backward

How to set the Default Separate Position options

1. Do one of the following:

»  Windows/Linux: Select Edit > Preferences.
» Mac OS X: Select Stage Advanced > Preferences.
» Press Ctrl + U (Windows/Linux) or 3£ + U (Mac OS X).

2. Inthe Preferences dialog box, select the General tab.

3. Inthe Settings section, select the Default Separate Position for Elements and the Default Separate Pos-
ition for Pegs options.

4. Click OK.

Naming Conventions

When working on a production, it is critical to keep work well organized with a naming convention chart before
starting the project. It is crucial that everyone follows the criteria laid out in the naming convention chart. When
dealing with thousands of characters, pieces and puppets, it is easy to get lost.
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Adding a Prefix or Suffix to a Layer

It is highly recommended that you incorporate a naming convention for the layers. This will be very convenient in
later steps. We suggest that you add one or two letters for the character/prop name before the part name and an
"R" or"L" for right and left to identify the corresponding character/prop:

Character Abby's right arm = ab_r_arm.

If you plan to work with different angles for your characters (front, side, three-quarter, back), you can add one or
two letters to identify the angle:

Character Abby's right arm, front view = ab_r_arm_f.

How to add a prefix to a series of layers

5.

In the Network or Timeline view, select all the nodes or layers to rename or press Ctrl + A (Win-
dows/Linux) or 3£ + A (Mac OS X).

In the Scripting toolbar, click the Add Prefix or Suffix Script button. If the Scripting toolbar is not vis-

ible, you can display it by selecting Windows > Toolbars from the top menu. If the script is not available
in your Scripting toolbar, refer to Fundamentals Guide > Interface chapter > Managing Toolbars topic to
learn how to add it.

The Add Prefix or Suffix dialog box opens.

Select the Prefix or Suffix option depending on what you want to add to the layer's name.
Type the prefix or suffix information to be added to the layer's name.

Click OK.

Naming the Drawings

We recommend that you use a naming convention for your drawings. If you combine all the angles of a character
in the same breakdown scene, it is a good idea to identify each angle used.

ab_arm_| ab_hand_| ab_head

Front angle drawings

Side angle drawings

Biack angle drawings
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Before breaking down the characters for your production, we recommend that you create a drawing name convention
that represents the angle used. For example, use "f* for front, "s" for side, "q" for three-quarter so that the drawing
name looks like this: f1, 2, f3, s1, s2, etc. This will be quite useful during animation and drawing substitution. Since
drawings are displayed in alphabetical and numerical order, all the drawings for the front view will be together, then
all the drawings for the three quarter view, and so on.

How to add a prefix to one or more drawings

1. Inthe Timeline view, select the drawing range to rename.

2. Do one of the following:

» Right-click on the selection and select Drawings > Rename Drawing with Prefix.
» From the top menu, select Drawing > Rename Drawing with Prefix.
The Rename Drawing with Prefix dialog box opens.

I | Rename Drawing with Prefix

Type the characters you want to add before the current drawing name.
Click OK.

nlwn T

NOTE: To rename a drawing, select the drawing and use the Rename Drawing option. Do not double-click on the
frame and write a new name, as this will create a new drawing and hide your actual one. Note that the hidden
drawing has not been deleted and is still located within the element folder. Simply retype the name and it will
reappear.

Disabling the Animation on Drawing Layers

By default, a drawing layer can be animated, but Harmony lets you disable this feature. Being able to switch your
drawings so they can no longer be animated without a peg has certain advantages. It means that you can access the
drawing substitution feature for this drawing layer, while being able to create keyframes on its parent peg. This
feature is also available for backward compatibility when bringing in templates created in older versions of Harmony,
s0 as not to lose their offset keyframes or drawing substitution keyframes.
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When selecting the element in the Camera view, the actual drawing layer is selected, but the motion you will
create will automatically be transposed to the peg layer. You cannot animate (add keyframes) directly onto the
drawing layer if the option is disabled. You will still be able to perform certain offset movements in the
Transformation tab of the Layer Properties, but not using any of the animation tools in the Tools toolbar.

There are two ways to disable animation on drawing layers, via the Layer Properties window and the Preferences
dialog box. When you disable animation in the Layer Properties window, it affects only the selected layer and not
any others.

If you prefer this style of animation and want every drawing element that you create to not be animated, you can
disable the Element Node “Animate Using Animation Tools” Default Value preference. This will disable the
Animate Using Animation Tools option on all the new layers you will create from that point on so you don't have to
do this through the Layers Properties window for every layer. It is recommended to disable this preference before
starting a new character rig.

How to disable animation in the Layer Properties view
1. Inthe Timeline view, double-click on a layer.
The Layer Properties window opens.

2. Inthe Controls tab, disable the Animate Using Animation Tools option.

Notice that the layer functions are no longer available in the Timeline view.

Layer without functions

Layer with functions available

3. Click Close.

How to disable the option in the Preferences dialog box

1. Do one of the following:

» Windows/Linux: Select Edit > Preferences.
» Mac OS X: Select Stage Advanced > Preferences.
» The keyboard shortcut is Ctrl + U (Windows/Linux) or &£ + U (Mac OS X).

2. Select the Advanced tab.

3. Inthe Advanced Options section, deselect the Element Node "Animate Using Animation Tools"
Default Value option.
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Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For example, you can
separate the outline and colour fill on two art layers, similar to 1950s traditional cell animation. These art layers are
contained within a single drawing as opposed to the layers in the Timeline view or Xsheet columns where individual
drawings with individual timing are stacked one on top of the other—see Creating Strokes on page 346.

Toon Boom Harmony drawings include two layers in Advanced Art mode.

L

* o~ Line Art on page 343
. g" Colour Art on page 344

You can access the Art layers through the Camera and Drawing views bottom toolbar. By default, the art layers are
hidden. Everything is drawn on the Line Art layer. You need to enable the Use Advanced Art Mode option.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and facilitate
creation and revision.

Line Art
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In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The outline is drawn in
the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn in the Line Art

layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are generated from Line Art to contain
the painted area.
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When you are doing rough animation, you may want to send a clip for feedback or approval before carrying on with
your work. If you have several characters in your project that are overlapping, it may be difficult to understand
what is going on as you can see through the characters. Toon Boom Harmony can generate a matte automatically
in the Underlay, or even in the Colour Art layer, and fill all the zones inside your characters to make them opaque.
This process is fast and easy, and allows you to send easy-to-understand movies.

How to enable the Support Overlay and Underlay Arts option
1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage Advanced > Preferences (
Mac OS X).

2. Inthe Preferences dialog box, select the Advanced tab.

3. Inthe Advanced Options section, select the Support Overlay and Underlay Arts option.
Click OK.

How to switch between drawing layers

1. Inthe Art Layer toolbar, click the Line Art Q" or Colour Art 0‘: buttons. When switching art layers, you
can edit the select layer without affecting the other one.
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@
)

2. Click the Preview All Enabled Art Layers @% button to display both layers together. Even when the Preview
mode is enabled, you will only be able to edit the select art layer. The other ones are only displayed as a ref-
erence. By default, the Preview mode is always enabled in the Camera view. You will only be able to see the
select art layer by itself if you enable the Current Drawing on Top < option located in the Camera bottom

toolbar.

NOTE:
To edit both Line Art and Colour Art at the same time, you must enable the Apply to Line Artand Colour Art _—

button in the Tool Properties of the tools supporting the operation.

How to generate a matte

1. Do one of the following:

» Inthe Tools toolbar, select the Select w tool.

» Press Alt+S.

2. Inthe Camera or Drawing view, select the drawing you want to create a matte for.

NOTE: You can also apply the operation to all the drawings in the layer at the same time.

3. Do one of the following:

» From the top menu, select Drawing > Generate Auto-Matte.
» Inthe Camera or Drawing menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If youwant to create a matte for all the drawings included in your layer, select the Apply to All Drawings
option.

5. Depending on how precise or rough your line is, increase or decrease the radius value. Use a lower value, the
closer to your lines’ contours the matte will be shaped. The higher the value, the looser the matte will be
shaped.
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Radius: 20

6. Inthe Source Art menu, select the layer from which you want the matte created: Line Art orColour Art.

7. Inthe Destination Art menu, select the layer on which you want the matte to be created: Line Art orColour

Art.

8. If you already have artwork on the destination layer and you want the content to be deleted before the
matte is added into it, select the Clear Destination Art First option.

9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case you ever
need to keep them for later), select the Copy Stroke in Destination option.

10. Click OK.

Radius: 100

Creating Strokes

A drawing is composed of Line and Colour filling layers. Lines and colours can be separated or kept together,
depending on which animation process you use. The following diagram presents Line Art and Colour Art

Radius: 300

recommendations based on the selected animation workflow.

'WORKFLOW:

Traditional

Paperless

Cut-Out

When a traditional drawing is scanned, strokes are automatically created in the Colour Art from the Line Art when

MODE:

Line Art

Colour Art

Line Art

Colour Art

Line Art

Colour Art

IKE CREATIC

Only lines

Created when
vectorizing

Only lines

Created after all the
drawings are drawn

All lines and colours

Not Used

drawings are vectorized unless you specified otherwise.

When working with Cut-out animation, we recommend that you do all of the work in the Line Art.
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Once the drawing sequence is completed for paperless drawings, you can proceed with creating Colour Art strokes
if you plan to paint the animation in the Colour Art. Use the Create Colour Art from Line Art option to create strokes
from your lines.

You can create strokes in the Colour Art during the following stages:
» After the full drawing is completed in Line Art
*  While drawing in Line Art

You may have some traditional drawings that need to be fixed; for example, needing extra lines to patch gaps. Use
the Auto-Create Colour Art from Brush option to create the strokes at the same time as the lines are drawn. This
creates strokes from the lines and brush strokes created in the Line Art while you draw and is useful for fixing
drawings. However, if you are drawing a new sketch, it is better to create the strokes afterward using the Create
Colour Art from Line Art option.

How to create Colour Art zones out of the Line Art content

1. Inthe Tools toolbar, select the Select w tool or press Alt + S.

2. Inthe Tool Properties view, click the Permanent Selection £ button if you want to apply the operation on all
drawings in the layer.

3. Inthe Camera or Drawing view, select the artwork to transfer to the Colour Art. Create a selection around the
entire animation sequence if you want to apply the operation to all your drawings.

4. Inthe Drawing View toolbar, click the Create Colour Art from Line Art . button or press *.

How to create strokes with the Create Colour Art Automatically option

1. Inthe Tools toolbar, select the Brush tool.

2. Inthe Tool Properties view, enable the Create Colour Art Automatically 4/, option.

3. Draw the required lines.
4. Once you're done, deselect the Create Colour Art Automatically 4 option.

You are now ready to paint your model.

347



Chapter 7: Character Building

Breaking Down the Character

There are many techniques you can use to break down a puppet. In this section, you will learn about one of the
most common and simplest methods. For your first character breakdown 1, follow these instructions to get an
idea of the way Harmony works. Once you understand Harmony's basic functions and commands, you will be
able to create your own techniques to satisfy the needs of your production.

Refer to the Appendix on page 383 at the end of the chapter for altenate tips.
This section is divided as follows:

» Tracing the Model on page 1

* Articulations on page 351

Tracing the Model

The main breakdown technique shown here is to trace your model—see the Appendix on page 383 to learn about
more techniques.

How to break down a character

1. Inthe Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R (Win-
dows/Linux) or 3£ + R (Mac OS X)—see Naming Conventions on page 339.

TIn cut-out animation, breakdown is the action of breaking a character into pieces to create a puppet with
articulations. To break down a character, the artist cuts parts, such as the hands and arms, from the character's
model and pastes them in separate layers. Next, the joints are fixed and the pivots set. In traditional animation, a
breakdown is an animation pose generally found between two key poses. The key poses are the main poses in an
animation and the breakdowns are secondary poses, ones that help describe the motion and the rotation curve
(usually referred to as an arc).
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In the Timeline view, select the layer's first cell in which you want to draw the part.

In the Tools toolbar, select a drawing tool.

In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see Colour
Styling on page 195.

In the Camera or Drawing view, draw the new part with as with as few points as possible so the pieces are
easy to manipulation, modify or redraw. Using the Polyline C, tool would make it easy to do this.

If you are working in the Drawing view, click the Light Table button in the Drawing View toolbar to display
the other layers as washed out colours. You can also press Shift + L.

You can use the Stroke tool in the Tools toolbar to create an invisible hairline if you want to close a shape
without drawing an actual stroke.

» Select View > Show > Show Strokes or press K to display the invisible lines.
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7. Inthe Tools toolbar, select the Paint ® or Paint Unpainted & tool to colour your drawing.

8. Inthe Colour view, select the corresponding colour.

9. Inthe Camera or Drawing view, paint your drawing.

10. Inthe Tools toolbar, select the Select w tool. Select your drawing and flatten the lines by clicking the Flat-
ten = button in the Tool Properties view.

11. If your lines are composed of several pencil strokes, you might want to combine them into one single
smooth pencil line. Using the Select tool, select the pencil lines to be merged and in the Tool Properties
view, click the Merge Pencil Lines > button.

12. Repeat the entire process until the break down is completed.
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Articulations

4\

Once your pieces are traced, you can go ahead and complete the articulations.

Articulations are an important aspect of any cut-out break down because without them, a puppet cannot move
properly and will not look good.

351



Chapter 7: Character Building

If you are using deformations to animate the limbs, your articulations don't need to overlap. The deformer effect
will create the joint for you.

Classical Articulation

Classical articulation is the most popular technique for basic characters. It is quite simple and produces excellent
results, but it's not the most efficient method. In many instances, it causes limitations and extra drawing
corrections. For example, there may be a gap in the articulation if the part is bent too far. Joint design is usually a
circle; the overlapping part cannot be sent behind without showing the joint.

4\

Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping the
bottom layer. You can use this technique for all the articulations on your puppet.

How to create a classical articulation

1. Inthe Timeline view, select the cell containing the part to modify (piece located behind), such as the upper
arm.
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10.

11.

In the Tools toolbar, select the Pencil # , Polyline C , Ellipse ¢ , Cutter ~ , or Contour Editor tool.

In the Colour view, select an outline colour.

In the Drawing or Camera view, use your drawing tool to make sure the joint overlaps the other part in a half-
circle shape.

8004

If you are working in the Drawing view, click the Light Table button in the Drawing toolbar or press Shift +
L.

From the top menu, select View > Show > Show Strokes or press K to display the invisible lines that may
be present in your drawing.

In the Drawing or Camera view, select all the strokes in your drawing.

In the Tools Properties view, click the Flatten = button.

In the Drawing or Camera view, select all the strokes in your drawing.

In the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary, invis-
ible lines in your drawing.

Repeat the previous steps for the other articulations.

In the Timeline view, select the cell of the part that will be on top of the joint.

NOTE: When placing rotation pivots later on, make sure they are positioned at the centre of the
articulation.
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Ordering the Layers

At this point, it is possible that your character's pieces may show up in the wrong order.

There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level in
the Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind.
Second, you can use the Z-axis nudging (forward and backward) if you have extra views included in the same
layers (front, three-quarter, back, etc.).

This topic is divided as follows:

*  Ordering the Timeline Layers on page 354

*  Nudging Parts Backwards and Forwards on page 355

Ordering the Timeline Layers

In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be displayed
behind. If you have multiple views, you should order your layers based on the most common view, which is
generally the three-quarter front.
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How to order the layers

» Inthe Timeline view, drag a layer to reorder it and drop it between other layers.

+ i+ | o H  +

Nudging Parts Backwards and Forwards

If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as the
hand, to appear in front of its parent. Yet, if you move the hand layer above the arm layer, you will break the
hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.

NOTE: You will do the same for the layers that are notin the right order on the extra views. Do not place the drawing
on another layer. You want to keep all your drawings of the body parts in the same layers like a box containing all of
the hands or all of the shoes.

Harmony allows you to move your elements in three dimensions:
* Upand down (Y-axis)
» Left and right (X-axis)

» Backwards and forwards (Z-axis)
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In the same way you create multiplane backgrounds (depth), you can perform a micro nudge of the part to be
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the Timeline
view. The forward-backward position can also be animated over time.

Repeat the following instructions for all the views.

How to nudge your parts backward and forward

1. Inthe Tools toolbar, select the Transform ;-: tool. Make sure to enable the Animate mode.

2. Inthe Camera view, select the element you want to reorder. Make sure the focus (red outline) is around the
Camera view before selecting the element.

3. Tomove the element forward, press Alt + Down Arrow and to move the element backward, press Alt + Up
Arrow.

The rigging process is where building a puppet can take several different directions.

356



Harmony 12.2 Advanced - Gaming Animation Guide

In this section, you will learn how to create a simple rig. Afterwards, you will learn how to add pegs and create a
hierarchy. You can also see more advanced tricks in the Appendix on page 383.

» About Rigging on page 357
* Adding Pegs on page 361
* Rigging the Head on page 362

* Rigging the Body on page 363

» Creating a Hierarchy on page 364

* Ordering the Layers on page 1

* Adding the Master Peg on page 366

» Creating the Keyframes on page 367

» Setting Properties for Many Layers on page 368

* Masking on page 369

About Rigging
There are some basic concepts to know when rigging and layer parenting:

+ Simple Rigging on page 357
* Parenting Layers on page 359

* Rigging Using Pegs on page 360

Simple Rigging
Simple rigging is very fast and easy to do. It is built as follows:
+ All the body parts are independent
+ Allthe timeline layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being influenced by a
parent layer.
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However, since the parts are not parented to each other, the parts will move from point A to point B along a
straight trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the hand to
move along a curved path.

358



Harmony 12.2 Advanced - Gaming Animation Guide

Parenting Layers

When you want one part to follow another part, such as the forearm following the arm, you can attach the layers one
to the other. For example, you can attach the forearm layer to the arm layer without having to encapsulate the
forearm into the arm layer. They will still be parented, but you can access the forearm directly without having to enter
the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to select
them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able to move the parent independently of its children, since
the child layers receive all the transformation information from their parent.

359



Chapter 7: Character Building

Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from them is often
a good solution.

NOTE:
To attach one layer to another, you must drag the desired layer onto the other one in the Timeline view.

Harmony offers powerful techniques to create hierarchies between your layers without having to encapsulate
layers into each other. These techniques are a greatimprovement over the less efficient and time consuming
method of creating parenting between your layers by inserting symbols into other symbols. Therefore, rigging with
symbols inside symbols is NOT recommended.

Rigging Using Pegs

Peg layer are useful when you are doing more advanced puppet rigging. Peg layers are trajectory layers that do
not contain drawings. They are motion paths that you can use to control your entire puppet or advanced
hierarchies.

Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. You can scale a
body part up the chain of pegs directly on the drawing layer. This way, you do not affect any child layers that could
be attached to that part.

Then, you can perform your translation and rotation on the peg layer so all the parts attached to that peg layer
follow the same trajectory.
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Translation and Rotation on
the forearm and hand

Scale, Squash and Stretch onthe forearm,
independentlyfrom the hand

Adding Pegs

It is recommended to add parent pegs to your drawing layers which are path layers that let you add keyframes to
modify the positions of pieces over time. It is not mandatory, but it is helpful to have your drawings and keyframes
separated—see Disabling the Animation on Drawing Layers on page 341.

How to parent drawing layers to pegs

1. Inthe Timeline view, select all the layers.
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2. Inthe Timeline Layer toolbar, click the Add Parent Peg 2 button to add a parent peg to all selected layers.
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Rigging the Head

You will start by attaching the facial features to the head.

The advantage of parenting the head and the facial features to the same peg is that you can easily animate each
facial feature, and they will all follow the head motion.

You can also use additional pegs to control smaller groups of pieces such as the facial features or all the left eye
pieces. You can parent as many pegs as you want to obtain a maximum of control on your rig.

How to parent the facial features to the head

1. Inthe Timeline view, deselect any selected layers.
2. Select the head peg layer.

3. Inthe Timeline View Layer toolbar, click the Add Parent Peg 2. button to add a new peg layer to your
timeline. You can rename the peg to keep your work organized.

A new peg is added and parented to the head peg layer.
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1. Select all the remaining head and facial feature layers and drag them ONTO the peg layer or BETWEEN the
head peg layer and the new head peg to parent them.
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Rigging the Body

When the character's head is ready, you can move on to rigging the body. You can do a simple rigging where all the
body parts are independent of each other, or create parenting between some of the layers. Referto Creating a
Hierarchy on page 364 to learn how to parent your layers.

Simple rigging consists of leaving the layers in the Timeline view without doing any kind of parenting. Later on, you
will attach those layers to a master peg and organize them in the correct order—see Adding the Master Peg on page
366 and Ordering the Layers on page 354.
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Creating a Hierarchy

Harmony lets you extend your rigging techniques beyond normal boundaries and sets hew standards. You can
create hierarchies without encapsulating pieces inside each other by creating a linked structure between layers.

You should create a hierarchy on the arms and legs, and keep them separated from the body. This gives you more
animation freedom, and when you need to scale or skew the torso, it will not affect the entire body.
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¥, /7| <= Head hierarchy

Right arm hierarchy =g -@— Left arm hierarchy

Independent torso and hips

Right leg hierarchy == - | eft leg hierarchy

How to create a hierarchy in the Timeline view

1. Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you can drag the parent (forearm)
piece onto another parent piece (upper arm).

‘Without pegs

b %
+
+
+
+
+
+
+
+

» You can unparent layers by holding down Shift and dragging the selected parents away from the child
layer. Drop your selected between other layers.
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Adding the Master Peg

When you animate your character, you will probably need to resize and reposition it to fit your scene. When you
need to scale down or move your character, it is a good idea to hook (attach) the whole puppet to a trajectory.

Attaching your puppet to a peg1 will allow you to scale it and reposition it without having to do this to the different
parts and pieces. Only one layer will contain the position information, which makes your animation easier to
modify and control.

How to add a master peg

1. Inthe Timeline view, select the top layer to parent a peg to it. You need to select a layer to be able to add a
peg to your scene.

2. Inthe Timeline view, click on the Add Peg & button.

A new peg is added to the timeline as a parent of the selected layer.

Name the new peg Master plus the character's name.

4. Inthe Timeline view, select all the layers you want to attach to your new peg. Remember that one item is
already parented to that peg.

5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers are
added above the already parented layers, move that parented layer back on top of the layer stack.

Tn traditional animation, a tool used to ensure accurate registration of action as cel layers move. In digital
animation, in which you are doing a more advanced puppet rigging, you can use peg layers. Peg layers are
trajectory layers that do not contain drawings. They are motion paths that you can use to add path articulations.
For the latter, you can also use an inverse kinematics tool.
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Creating the Keyframes

Once all your drawings are ordered and your master peg is added, you need to insert keyframes on each cell to
create all of the function curves and block your pose in place.

How to create the keyframes

1. Inthe Timeline view, collapse the master peg by clicking the Expand = . arrow.

2. Inthe Timeline view, select the first cell.

3. Do one of the following:

» From the top menu, select Insert > Keyframe.
» Inthe Timeline View toolbar, click the Add Keyframe # button.

» Press F6.
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NOTE: If you use the F6 shortcut when working Flash keyboard shortcuts flavour, this not only creates a keyframe
but also duplicates a drawing.

Setting Properties for Many Layers

When working with several nodes, you may frequently want to modify a series of settings. Instead of opening the
properties for each individual layer, you can set the properties for many layers so you can change a common
setting in a single click.

This allows you to modify the following settings:
» 3D Path or Separate mode

* Use Embedded Pivot

*  Overlay

* LineArt

+ Colour Art
* Underlay

* Animate Using Animation Tools

NOTE: You can add the button to the Timeline View toolbar through the Toolbar Manager. In the
Toolbar Manager, you will find the feature in the script section under the name Script: TB_Set_Properties_on_
manu_layers in TB_Set_Properties_on_many_layers.js.

How to set properties for many layers

1. Inthe Timeline view, select all the layers you want to modify at the same time.

2. Inthe Timeline View toolbar, click the Set Properties for Many Layers 7, button. This option is not avail-
able by default in the Timeline View toolbar. You must add it through the Customize option. Right-click on
the toolbar and select Customize. In the Available Tools list, select Script: TB_Set_Properties_on_many_

layers and move it to the Toolbar list.

The Set Properties for Many Layers dialog box opens.

368



Harmony 12.2 Advanced - Gaming Animation Guide

3. Modify the properties. If your nodes have different parameters enabled for a certain setting, leave the As Is
option selected to avoid modifying it. Each node will keep its original setting. Select any other options for all
nodes to change to this parameter regardless of their original setting.

4. Click OK.

Masking

%

When rigging a character, there may be instances when you want to have the ability to move a particular piece to
give the illusion of a rotation or move the pupil within the white of an eye without having the extra bit of the drawing
sticking out of the character or eyeball. To do so, you can use masks to cut anything you don't want to be visible.
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How to mask an object in the Timeline view

1. Inthe Timeline view, make sure the keyframe is added on the object that will be masking the piece to cut.

2. Select the layer that will act as the mask.

3. Inthe Timeline view, right-click on the layer and select Clone Selected Layers: Drawings and Timing.

Cloned Layer linked to the same
motion paths as the original layer.

4. Select the layer to be masked.

5. Inthe Layer toolbar, click the Add Layer button and select Effects > Cutter.

Layer to be masked g
Masking Effect

6. Click the Expand Parameters button to display the Cutter properties.

7. Drag the cloned layer ONTO the Matte parameter connection area.

The masking layer name appears in the Matte parameter area and the masking layer is repositionned
above the effect.
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hero_Upper_&m_F_1

The masking layer is no longer visible in the Camera view. You can see that the masking layer is connected
to the Cutter effect by clicking the Show/Hide Additional Links s button to display the Additional Links

section.

hera_Upper_fmn_F_1

8. Your masking effect is most likely inverted and what you want to cut is probably showing. Double-click on the
Mask layer to open the Layer Properties window. In the Layer Properties window, enable the Inverted option.

E]

Layer Properties

9. Inthe Tools toolbar, select the Transform ;3 tool and move the cut object within the masking zone.
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Adding Extra Drawings
- V4 ~ -~ =~ = \
\

Your break down is now complete. You can move on to adding the extra drawings your character needs, such as
principal hand positions and mouth shapes. If you ever forget to add extra drawings in your main character's
template, you can easily add them later.

NOTE: Add your extra drawings in the layer corresponding to the part you are drawing. You should see the layers

as containers for the different pieces. Each body part has its own container in which you can add more drawings of
the same part.

If you want to use the auto lip-sync detection feature to animate your dialog, you should create the following
mouths for your puppet.

The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.

NOTE: If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter,
"Adding Extra Drawings" topic to learn how to add extra drawings to your character.

//:/ /\ - /i 5 7,/ N
o \

A B C D
;- S Y
N 1 N ;;}_A\ L:_——a
E F G X
(
Extra mouth

Here is an approximation of the sound each mouth shape can produce:
« A:m,b,ph
« B:s,d,j, ikt
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+ C:ea
- D:AE
+ E:o

e F:uy, 00
« G:f,ph

+ X: Silence, undetermined sound
You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to the mouth chart positions as you draw the shape of the character's mouth.

How to add extra drawings

1. Inthe Timeline view, select the cell where you want to add a new drawing. If you want to duplicate the current
drawing and work from it, you can select Drawing > Duplicate Drawings or press Alt + Shift + D.

A new drawing is created in the selected cell and automatically extended to the next one. The new drawing is
a duplicate of the one that was selected so it contains a duplicate of the art. You can modify it to create your
new drawing or delete its contents in the Camera or Drawing view and start from scratch.

1. Inthe Tools toolbar, select a drawing tool for drawing your extra part.
2. Inthe Camera or Drawing view, draw your new drawing.

-

\

2. Usingthe Select w tool, select your drawing and flatten the lines by clicking the Flatten = button in the
Tool Properties view.
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Setting the Pivots

One of the last steps before storing the character in the library is to set the pivots for the different parts.

Harmony has three types of pivots:

Permanent Pivot

This is a permanent pivot, sometime referred to as peg pivot, that is applied to the entire drawing or peg
layer. If you modify its position, it will be changed for the entire layer, modifying the animation, scale and
rotation interpolation. The permanent pivot is set using the Rotate, Translate or Scale tool. The Transform
tool will only move that pivot temporarily for positioning purposes, but the animation interpolation will be
done from the original permanent pivot's position. The Transform tool is designed to move the pivot
temporarily during the animation process. It also permits you to select multiple pegs and apply a common
temporary pivot.

To permanently move a peg pivot, use the Rotate or Scale tool. You can also directly type the values in the
Layer Properties window in the Pivot section's (x) Axis and (y) Axis fields.

In the Layer Properties window, in the Drawing Pivot section, select the Don't Use Embedded Pivot
option to use the permanent pivot.

Drawing Pivot

The Drawing pivot is contained within each drawing. In one layer, each drawing can have its own pivot. If

you have many different views of a character within one layer, the pivot can be different and the animation
will adjust to the pivot. The Drawing pivot can also be referred to as embedded pivot. If you are not mixing
different views within the same layers or are using pegs to animate your layers, it is recommended to use

the permanent pivot.
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You can set a different pivot for each one of your drawings. For example, if you have a series of drawings
from different views, they are not likely to rotate from the same location. In that case, you can set a different
pivot for these drawings by using the Drawing Pivot 4} tool.

In the Layer Properties window, in the Drawing Pivot section, select the Apply Embedded Pivot on
Drawing Layer option to use the drawing pivot directly on the drawing layer. If you want to apply the drawing
pivot to a parent peg to force the peg to follow the drawing pivot variations, enable the Apply Embedded
Pivot on Parent Peg option.

+ Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can have its own pivot and act the same
as the Drawing pivot. The Symbol pivot can also be referred to as embedded pivot. Inside a symbol, each
drawing can have its own pivot. If you are not mixing different views within the same layers or are using pegs
to animate your layers, it is recommended to use the Peg pivot.

For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the Rotate @&
tool.

If you want the puppet's pieces to rotate correctly, you must set the pivot points right in the middle of an articulation,
such as an elbow or a knee.

By default, your master peg pivot is placed at the centre of the Camera view, which generally equates to your
character's hips. A good way to set your peg's pivot is to move it between the character's feet.

How to set the pivots with the Rotate tool

1. Inthe Advanced Animation toolbar, select the Rotate v tool.

2. Inthe Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view, you can
also hold down Ctrl (Windows/Linux) or 3£ (Mac OS X) and click on the piece whose pivot you want to set.

3. Inthe Camera view, drag the blue pivot to reposition it.
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4. Repeat the previous steps for all the pieces, including the eyes, nose and mouth. If you are unsure as
where to place the pivot, put it in the center of the selected piece or group of pieces.

NOTE: If you added other pegs to your rig, you must set their pivot using the same method.

Setting Anchors and Props

An anchor is an attachment point you can use to bind one or several props to a specific location that is predefined
by the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’'s hand, a
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and easily
swappable from within Harmony or Unity.

How to create an anchor

1. Create a new Drawing node and rename it according to the anchor you are creating.

2. Inside the Layer Properties of your drawing node, make sure that pivot option is set to Don’t Use Embed-
ded Pivot or Apply Embedded Pivot on Drawing Layer. The Apply Embedded Pivot on Parent Peg
does not transition well to Unity and you will lose your pivot information.

3. Once this is done, you can use any of the animation tools to reposition the pivot point of your node, such
as the Rotate tool in the Advanced Animation toolbar. You should be able to see the pivot coordinates from
the Layer Properties of your Drawing node. If the pivot is not repositioned, its default place will be at the
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centre of your Harmony scene (0,0).
4. Oncethis is set up, select the Drawing node and click the Toggle Anchor &, button in the Game toolbar.
The Drawing node is highlighted in red in the Timeline and Node views. Your anchor can now be used to

attach a prop.

How to create a prop

1. Create a new Drawing node or take an existing prop on which you want to attach an anchor.

2. Position the Drawing Pivot of the prop node using a tool on the Advanced Animation toolbar, such as the
Rotate tool. The position of the prop’s pivot will align with that of the anchor. Make sure it is positioned accord-

ingly.
3. With the prop Drawing Node selected, click the Toggle Prop o button in the Game toolbar.

The prop Drawing node is highlighted in green in the Timeline and Node views.

4. Do one of the following:

» Connect the anchor and prop to the parent peg.
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Metadata Editor == %

Add or remove Scene
Metadata Entry

ame.Armorl01

gameArmorUz

Add or remave Node
Metadata Entry

game.sAnc hor

The Metadata Editor view lets you access the information of the props and anchors to be exported to Unity.

NOTE: Because the Unity game engine does not support Unicode characters, itis recommended to avoid using it
in scenes intended for games.
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How to access the Metadata Editor view

1. Inthe top-right comner of a view, click the Add View button and select Metadata Editor.

Parameter

Description

Scene Metadata

This is a list of optional parameters you can create in a scene project to be
exported to Unity. It will not have any incentive towards your scene assets, but
can help developers know what to do with the assets contained in your Harmony
scene.

Once in Unity, scene Metadata will appear in Inspector view > Metadata when
the Asset is selected in the Hierarchy view.

Name: Name of the Scene entry. (e.g. game.Armor001)

Value: This can be anything that describes the state of an object. You could, for
example, have three different stages of armour: new, damaged and destroyed.

Node Metadata

Displays only the props and anchors held inside your selection. If nothing is

selected, no information will display. Name and value appear in this box as well.
Name will show you the associated .tvg nhame and value will be set as either On
or Off, depending on whether you want the connection to be set as active or not.

Once in Unity, scene Metadata will appear in the Hierarchy view.

Name: Name of the selected anchor or prop. (e.g. game.isAnchor). Notice that it
differs from the drawing layer name on the top-left corner of the Node Metadata
section.

Value: Can be set to be active (On) or inactive (Off).

NOTE: For any anchor or prop information created within the Metadata Editor, the naming convention must always
use the prefix "game.". The term "game." is recognized automatically by Unity as a metadata information. For

example: game.Armor001.

Storing the Character in the Library

For maximum efficiency and reuse of your character in different scenes, you must store a template in the Library
view. You can create different kinds of templates, such as templates that include all the layers, a template for a
body, key pose or even some containing only the head.

When you create a template from the Timeline view's right side, you must first import your master template in order
for everything to work properly when you reimport it into a scene. Once the master template is imported, you can
import the key pose (action) template's content into the right side of the Timeline view.

How to create a template from the Timeline view

1. Inthe Library view, right-click on the desired library folder and select Right To Modify.

2. Inthe Timeline view, collapse the master peg layer.
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4+ — % % Parameters

+

3. If your scene has a series of blank cells, they will also be included in the template if you drag the layer to
the Library view. Reduce the scene length to have no empty cells before creating your template.

4. Inthe Timeline view, select your master peg and drag it to the Library view.

)
5] Library = [@][=])|

The Rename dialog box opens.

!E Renarme

ne For the template,

5. Inthe Name field, name the new template.

6. Click OK.

How to create a key pose (action template)

1. Inthe Library view, right-click on the desired library folder and select Right To Modify.

2. Inthe Timeline view, collapse the master peg layer.

3. Select the cell containing the desired view and drag it into the desired library folder.
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The Rename dialog box opens.

@ Rename

4. Inthe Name field, type in a name for the template.

5. Click OK.

Appendix

The many options and animation techniques available for building a puppet make it impossible to determine only one
method to break down a character. Here are some advanced tips on breaking down puppets. As you become more
familiar with the software, you will find more ways to improve the construction of your puppet.

This section is divided as follows:

* Break Down: Cutting the Character in Pieces on page 384

» Break Down: Distribute to Layers on page 395

» Converting the Layers into Symbols on page 396

» Patch Articulation on page 399

» Setting Different Pivots for a Puppet Using Symbols on page 402

» Setting Pivots on a Frame Range on page 404

* Adding New Drawings to an Existing Template
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Break Down: Cutting the Character in Pieces

Leftarm

Rightleg Leftleg

If you do not want to redraw all the artwork for your character, you can use the cut away technique where, with the
Cutter tool, you select and send pieces of the model on a new layer.

The first step in breaking down your character is to do a rough cut down of the main parts, such as the body,
arms, legs and head. Using the Create Drawing from Drawing Selection feature lets you automatically create
layers and copy your selection init.

This section is divided as follows:

* Breaking Down the Main Parts on page 384

» Breaking Down the Secondary Parts on page 387

» Selecting and Incorporating to an Existing Layer

» Breaking Down the Extra View Main Parts on page 390

» Breaking Down Secondary Parts in the Extra Views on page 391

Breaking Down the Main Parts
To break down the main body parts, you will use the Create Drawing From Drawing Selection feature.

There is no need to create any layers prior to this process. Make sure your model is well centered and sized in the
Camera view.

You do not need to make clean cuts around your parts; a rough one is sufficient as long as it includes all the
artwork of the part you want to break down. You will clean the extra bits and pieces later.
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Using the Cutter tool, you can roughly cut the main sections, and then use the Select tool to select precise lines and
colour zones.

How to break down the main parts

1. Inthe Timeline view, select the cell of the model that corresponds to the first view to break down.

2. Inthe Tools toolbar, select the Cutter ~ tool.

» If you prefer to use the Select tool, choose the Select w tool from the Tools toolbar or press Alt + S.

» Inthe Tool Properties view, you can switch to the Lasso ¢ selection mode.

3. Inthe Camera view, create a selection around the first part to break down. If you click on a zone, the Cutter
tool will select the zone. It will end the selection at the first point of intersection that it meets.

2
D
/’

Cutthe entire arm, not just the hand or forearm.

~-

» Hold down Shift to create a new lasso selection around another zone and add it to your previous selection.

385



Chapter 7: Character Building

4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Win-
dows/Linux) or ¥ + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

5. Inthe Layer Name field, type the name of the layer you want to create following the naming convention you
established previously.

6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original drawing. You
do not want to cut the artwork from the colour model.

7. Click OK.

The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.
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Breaking Down the Secondary Parts

Foream

hhaaes o

You should now have a layer for each main part of the character for the first view to break down. You are now ready
to break down those main pieces into smaller ones.

Breaking down the secondary parts is similar to the main part break down process except that this time you will cut
away the artwork from the layer it has been selected from.

How to break down the secondary parts

1. Inthe Timeline view, lock your model layer by clicking its Lock button.

2. Inthe Timeline view, select the cell that corresponds to the main part you want to break down.

3. Inthe Tools toolbar, select the Cutter ~ tool.

» If you prefer to use the Select tool, choose the Select wx tool from the Tools toolbar or press Alt + S.

4. Inthe Camera view, create a selection around the part to break down.
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Cutthe forearm from the arm layer

!

L

» Ifyouclick onazone, the Cutter ~ tool will select the zone and end the selection at the first point of

intersection that it meets. Click on the line with the Cutter tool to select it up to the next intersection.

5. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Win-
dows/Linux) or 3£ + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

6. Inthe Layer Name field, type the name of the layer you want to create following the naming convention you
established previously.

7. Select the Cut Artwork From Source option to remove the selected artwork from your original drawing. In
this case, you want to cut the artwork from the colour model.

8. Click OK.
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The new layer is created and your selection is copied in it. The drawing is created in the same frame number
as the cell it was taken from.
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9. Repeat the previous steps for each body part.

Cutthe hand from the forearm layer

}

NOTE:
If you forgot to add some artwork to a layer you previously created, you can always add it later.

In the Camera view, select the artwork to send to the existing layer. Open the Create Drawing from Drawing Selection
dialog box by pressing F9 (Windows/Linux) or & + F9 (Mac OS X). In the dialog box, select an existing layer from the
listinstead of typing a new name. Click OK to add the artwork to the existing drawing in the layer you selected.
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Selecting and Incorporating to an Existing Layer

Your first view should now be completely broken down. If your articulations are still rough and bits and pieces are
missing you will fix those in the next step.

If your character model has more than one view, now is the time to break them down.
The process is very similar to breaking down the first view. You have two choices:
* Breaking down the new view in a net set of layers

* Braking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are
breaking down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down later on.

Breaking Down the Extra View Main Parts

Repeat the following steps for each extra view you need to break down.

How to break down the other views

1. Inthe Timeline view, selected the model's cell corresponding to the view to break down. Don't forget to
unlock the layer.

o
o
o
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2. Inthe Tools toolbar, select the Cutter ~ tool.

» If you prefer to use the Select tool, in the Tools toolbar select the Select w tool or press Alt + S.

3. Inthe Camera view, create a selection around the first part to break down.
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4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Windows/Linux) or
3£ + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

5. Inthe Layer Name field, select the corresponding layer from the list if you want to use the same layers or type
a new name if you want to create a new layer.

6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original drawing. You do
not want to cut the artwork from the colour model.

7. Click OK.

The artwork is inserted into the existing layer. The drawing is created in the same frame number as the cell it
was taken from. It is not incorporated in the other view's drawings.

8883838888838
|

8. Repeat step 1to 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views

To break down the secondary parts for your extra views, follow the exact same process as you did for the first view
you broke down, but you will incorporate the new parts in the existing layers—see Breaking Down the Secondary
Parts on page 387.

Each view can have its own set of layers in the Timeline view, therefore each view does not necessarily need to
have the same layer structure.

Here is an example of how your timeline should look at this stage:
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Completing the Parts and Articulation

7

Now that all the layers are created and the parts are basically broken down, it is time to clean up the parts and
complete the articulation.

Cleaning the Parts
You will need to use a series of drawing tools to clean the parts:
*  Brushtool
* & Erasertool
* w Selecttool
_~ Cuttertool
. Contour Editor tool

Paint tool

€ )

* (» Close Gaptool
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How to clean your drawings

1. Inthe Tools toolbar, select the drawing tool you need to fix your drawings.

2. Inthe Timeline view, select the cell containing the drawing to fix.

3. Inthe Camera view, delete the extra bits using the Select w or Cutter ~ tool. You can also use the Eraser
4 tool.
L

4. Draw the missing lines using the Brush s tool. If you use the Brush tool, it is recommended that you enable
the Auto-Flatten = option in the Tool Properties view.

5. Usingthe Paint ® tool, paint the gaps. You can close some gaps with invisible lines using the Close Gap
~» tool or press Alt + C.
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6. Reshape your lines using the Contour Editor tool or press Alt + Q.

-

7. Usingthe Select w tool, select the entire drawing and click the Flatten = button in the Tool Properties
view to flatten your drawings.

8. From the top menu, select View > Show > Show Strokes to display the invisible lines that could be
present in your drawing or press K.

9. From the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary
invisible lines in the drawing.

10. Repeat this entire process for each drawing to fix.
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Break Down: Distribute to Layers

When breaking down a character, you can distribute each selected art stroke to a new layer.
Each stroke you select in the Camera view is automatically placed on a new layer. One layer per stroke.

If one part of your puppet is composed of several strokes, you must group them before distributing them onto new
layers.

NOTE: You cannot distribute layers in the Drawing view; it must be done in the Camera view.

How to distribute to layers

1. Inthe Tools toolbar, click the Select w tool.

2. Inthe Camera view, select the art strokes you want to distribute to different layers.

3. From the top menu, select Drawing > Distribute to Layers or click the Distribute to Layers & button in the
Tool Properties view.
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Drawing layers are created in the Timeline view, each corresponding to the different strokes or groups of
strokes selected. Each stroke or group of strokes is distributed into each new Drawing layer. The selected
strokes in the original drawing layer are removed.

NOTE: Converting your layers into symbols is optional. When animating, you will need to enter the symbol to
create a new drawing. If you want to use morphing when animating, keep your layers as drawings. Do NOT use
symbols.

Once the breakdown is completed, you can create symbols out of each drawing. The symbol will encapsulate
each drawing of the layer. Later on, even if you only expose the first frame, such as the front head, you will still
have access to all of the head drawings you placed in the symbol. This will also allow you to add more drawings,
as your characters' master templates will evolve throughout the production of your movie or series.

All your layers should be stored in the library as symbols. Before building your puppet, remove all the current
layers in your scene. All of your work is saved in the library.

If you are not sure that you put everything in your library, you can always perform a Save As on your scene and
work on a new version.
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How to create a symbol

1. Create a symbol by doing one of the following:

» From the Timeline view, drag the layer to the Symboals library folder.
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» Inthe Timeline view, select the layer to convert to a symbol. From the top menu, select Edit > Create
Symbol or press F8. You can also click on the Create Symbol ga button available in the Edit toolbar.

The Create Symbol dialog box opens.

2. Inthe Enter Symbol's Name field, type the new symbol's name. It is recommended that you keep your ori-
ginal layer's name.

3. Click OK.

4. Repeat this process for each layer in the Timeline view.

NOTE: Make sure all your layers are stored in the symbol library.
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How to save your scene as a new version

» From the top menu, select File > Save As. You can also click the Save As [§ button available in the File
toolbar.

How to clean the Timeline view

1. Inthe Timeline view, select all of your layers.
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2. Inthe Timeline's Layer toolbar, click the Delete Layers button.

3. Inthe Confirm Delete dialog box, click OK.

Your timeline is now ready to receive the body part symbols for the rigging process.
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Patch Articulation

The Harmony advanced rigging can use an articulation fixing technique called Patch Articulation. This technique is a
colour fill patch that is drawn on a third layer and is used to cover the joint lines. It is a simple, yet powerful method.

-

With this technique, you avoid having to create a correction layer at the end of the animation to fill the gaps in the
joints. You do not need to worry about the articulations at all. Once a patch is set, the articulation is fixed for the
entire length of the animation.

To make this technique even more efficient, Harmony lets you draw the patch inside the same drawing, but on a
separate contained layer. The Line Art and Colour Art layers are not only useful in traditional ink and paint, but also in
advanced cut-out breakdown. You can draw the patch in the Colour Art layer and extract it in the Node view. The
advantage of doing it this way is that when animating and using the drawing substitution, the patch drawing will
change at the same time as the main drawing.

How to create a patch articulation

1. Inthe Tools toolbar, select the Transform :; tool or press Shift + T.

2. If you plan to create your patch on an independent layer, do the following. If not, go the next step.

» Inthe Timeline view, add a new drawing layer by clicking the Add Drawing Layer «. button or press Ctrl
+ R (Windows/Linux) or &£ + R (Mac OS X).
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3. Inthe Camera view, select the part for which you want to create a patch. For example, if you are fixing the
elbow articulation, select the arm or forearm drawing to edit it.

4. Inthe Tools toolbar, select the Select w tool or press Alt + S.

5. If you drew your lines with pencil lines, it is recommended to convert them to brush lines (fill shapes):

» Inthe Camera view, select the pencil lines.

» Inthe Tools Properties view, click the Convert Brush Strokes to Pencil Lines ¢¢ button.
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» Inthe Camera view, select the piece's outline and fill.

» Inthe Tool Properties view, click the Flatten = button to remove the excess colour fill located under the
contour stroke.

6. Inthe Camera view, select the fill zone of the part's drawing.

7. Inthe Camera view, right-click and select Copy.
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8. Inthe Camera view, right-click and select Paste.

9. Inthe Tools toolbar, select the Cutter ~ tool.

10. Inthe Camera view, make a selection around the pasted zone to cut everything out but a small overlapping
zone to cover the articulation.

1. Repeat the process for each articulation which requires fixing.

Setting Different Pivots for a Puppet Using Symbols

If you want the puppet's pieces to rotate correctly, you must set the pivot points onto the articulations. You can
set the pivots using the Rotate tool which sets it for the entire layer or you can set the pivots directly on your
symbol and have a different pivot for each symbol cell. By default, when you create symbols, the symbol pivot is
located at the centre of your drawing. You will need to move it onto the shoulder or elbow.

You will set the pivot on the symbol's cells, not directly on the drawings. To set your pivots, you must be at the
top level of your character building scene and not inside the symbols.

By default, when you set the pivot onto a symbol, all the cells use the same pivot. If you need different pivots for
different cells, refer to the following procedure.

Do the following steps for each layer in the Timeline view.
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How to set the pivots for the body parts

1. Inthe Tools toolbar, select the Drawing Pivot - tool or select Drawing > Tools > Drawing Pivot.

2. Inthe Camera or Timeline view, select the symbol on which you want to set a pivot.

3. If you only want to set one pivot for your symbol, in the Tool Properties view, select the Set the Pivot for Sym-
bol on All Frames @ button.

Tool Properties == |%

» Deselect this button if you want to set a series of different pivots for your symbol's cells.

4. Inthe Camera view, click where you want the pivot to be. You can also drag the pivot marker to the desired
location.

5. If youwant to set a different pivot for another drawing or symbol cell, select the drawing or cell and in the Cam-
era view, set the new pivot.
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Make sure the Set the Pivot for Symbol on All Frames button is deselected.

Setting Pivots on a Frame Range

If you are using the drawing pivots rather than the Rotate tool pivot and if some elements need the same drawing
pivot, such as all of the three-quarter hands, you can select all of these hands cells and set the pivot all at once. If

your pivot is already correctly set on your first drawing, copy and paste that pivot onto the other drawings in the
Timeline or Xsheet view.

You must have the same drawing pivots on the extra parts from the same angle. If you substitute a drawing while
the part is rotating, the animation risks popping out of place if the pivot is uneven.

How set the drawing pivot of a frame range

1. Inthe Drawing or Camera view, set the first drawing pivot of the series. For example, set it on hand-1.

2. Inthe Timeline view, select the cell that contains the correct pivot.
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From the top menu, select Edit > Copy.

In the Timeline view, select the cell range that requires the same pivot.

5. From the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or 3£ + B (Mac OS X).

The Paste Special dialog box opens.

6. Inthe Paste Special dialog box, select the Advanced tab.
7. Inthe Drawings section, select the Update Drawing Pivot option.

8. Click OK.

NOTE: You can also copy and paste the pivot from one drawing to another using the keyboard
shortcuts Ctrl + C and Ctrl + V (Windows/Linux) or 38 + C and £ + V (Mac OS X) when the drawing
pivot tool is active and the focus is around the Camera view.

Adding New Drawings to an Existing Template

How to add new drawings to an existing drawing template

1. Inthe Library view, right-click on the library folder containing the template to modify and select Right To
Modify.

2. Inthe Library view's right side, right-click on the extra drawings template to modify and select Edit Template.

A new instance of Harmony opens.
3. Inthe Tools toolbar, select a drawing tool.
4. Inthe Colour view, select a colour.

In the template's timeline, select the blank cell where you want to draw your new piece.

In the Camera or Drawing view, draw the new pieces.
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7. If you are using drawing pivots, in the Tools toolbar, select the Drawing Pivot @ tool and in the Camera
view, set the pivot directly on the new drawing's cell. If you are using symbols and symbol pivots, you do
not set the pivot on the symbol's cell.

8. From the top menu, select File > Save or press Ctrl + S (Windows/Linux) or &8 + S (Mac OS X).

9. From the top menu, select File > Quit (Windows/Linux) or Stage Advanced > Quit Toon Boom Stage
(Mac OS X).
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Chapter 8: Gaming Deformation

Harmony provides you with the deformation technology for producing light, high-quality animations for your 2D
games. You can use Harmony's Game Bone deformer to rig your characters and export your animations in
spreadsheets to game engines like Unity.

Harmony provides even more advanced deformation features, but they are not supported by game engines. This
chapters will only cover the features supported by the gaming export. For additional information on the Harmony
deformation features, refer to the Cut-out Animation Guide.

This chapter is divided as follows:

» About Game Bone Deformations on page 407

» Creating a Basic Deformation Rig on page 408

+ Setting Up the Resting Position on page 410

» Displaying the Deformation Controls on page 415

» Assembling Pieces on page 416

* Animating Deformations on page 418

» Deformation Toolbaron page 422

» Deformation Nodes on page 423

About Game Bone Deformations

Deformations let you animate bitmap or vector-based graphics, including gradients and textures. Deformations act
as a skeleton with limbs and articulations you can bend, reshape, and curve. You can deform a character made out
of one, or many, drawing or image layers and make it move as if it were a cut-out puppet. A deformation skeleton is
composed of deformation nodes, which are the various pieces (here represented as layers or nodes) required to
articulate or deform your drawings, such as a series of bones or game bones.

407



Chapter 8: Gaming Deformation

== Bone

4 == [ncluded articulation

The Game Bone deformation is very similar to the Bone deformation and allows you to create a skeleton structure
in which the parent bone moves the child bone. The difference is that the Game Bone deformation is optimized to
export to game engines, mainly Unity.

The Game Bone deformation is mostly used when animating the extremities of a character, such as the arms or
legs, adding fluidity and a natural feel to the animation. The Game Bone deformation can be manipulated to rotate
a limb at an articulation joint and to shorten or elongate the extremities of a limb. It's also quite useful for bending
the torso.

The main difference between the Bone and Game Bone deformations is that the Game Bone deformation doesn't
have the Bias parameter. The rendered result is also different for the articulation folds. They are slightly rounded.

Creating a Basic Deformation Rig

Using the Rigging tool, you can quickly create a basic deformation rig.

As you create your chains, the controls will be showing. However, whenever you close your project, the
deformation controls display is turned off. When you reopen the project, you can display all controls or only some
of them—see Displaying the Deformation Controls on page 415.

How to select an element on which to add deformation

1. From the Deformation toolbar, click the Rigging ¢t tool.

2. Inthe Camera or Timeline view, select the element on which you want to add a deformation. When select-
ing a drawing node, the deformation components will be automatically added on top of the drawing node.
When selecting a peg node, the deformation components will be added below the peg.
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NOTE: Never place a deformation node above a peg node. Having a peg below a deformation node (Bone, Game
Bone, etc.) will cause unexpected result. The animation on the peg will move the image out of the defined
deformation zone. The same applies to animations created on the drawing layer itself. A drawing layer has an
embedded peg.

3. Inthe Camera view, create your rig. See the following procedures to learn how to add a specific deformation
type.

How to add a Bone or Game Bone deformation chain

1. Once your element and the Rigging tool selected, in the Tool Properties view, enable the Bone £ mode or
the Game Bone mode depending on your purpose—see Main Types of Deformations.

2. Place the cursor at the root of your drawing or group of drawings, click once and release. For example, on the
shoulder.

L N

3. Click again at the location where you want your first bone to finish and your second bone to start. An artic-
ulation control point will automatically be inserted between each bone you create. Note that the articulation
parameters are part of the Bone and Game Bone nodes since Harmony 12.

4. Repeat this until you are finished creating the Bone chain.

5. If you need to insert a bone between existing ones, hold down the Alt key. When the Insert Bone cursor is dis-
played, click on the existing bone segment at the location where you want to add an additional bone.
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« Note that you can click on any Bone articulation point to start a new bone chain from that
point. Once the articulation point is selected (white), click on the location where you want to
add a bone and a new bone chain will be created, parented to the previous one.

« When you have several chains controlling the same drawing or group of drawings, a Deform-
ation Composite node is automatically be created and appears in the Timeline view. In the
Additional Links section of the Timeline view, you can see which nodes are connected to the
Deformation Composite.
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6. With the deformation nodes still selected, in the Deformation toolbar, click the Reset Current Keyframe
CE‘; button. This will set the current resting position as the current frame one.

Setting Up the Resting Position

Once you have a deformation chain created, you can optimize its positioning to fit the element it will deform.
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A deformation rig has a resting position and an animated position. The resting position is the original pose the
character is in when not animated with keyframes. You can always revert your animated character to its resting
position to recover the initial scale, angle, and shape. You can revert the entire character or only certain deformation
chains, such as the arm or leg. Just make sure your resting position is fully set before deploying the character in
production.

How to set up Bone and Game Bone deformation chains

1. Inthe Timeline view, select the deformation nodes you want to set.

2. Inthe Deformation toolbar, click the Show Selected Deformers and Hide All Others - button to display the
deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

3. Inthe Deformation toolbar, click the Rigging ¢t tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red chain
indicates the puppet is in a resting position. Make sure your chain is red.

N

4. Inthe Camera view, set up the deformation chain.

» Rotate the first bone to change the angle of the chain.
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» Use the root control to reposition (offset) the entire chain.
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» Use the control points to reposition the articulations. This will elongate, shorten or change the direction
of the bone and offset the subsequent children.
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» Usethe articulation's control (square) to change the size of the articulation. For quality purposes, it is
recommended to have an articulation which fits the diameter of the part it controls.

)

Repeat until all the articulations and bones of the chain are correctly aligned to the element to whichiit is
linked. You can also set additional parameters in the Layer Properties window.

With the deformation nodes still selected, in the Deformation toolbar, click the Reset Current Keyframe gi‘
button. This will set the current resting position as the current frame one.

Use the Transform ;-3 tool. For optimal results, make sure the size of the articulation is approximately the

1

same size as the drawing.

If you need to insert a bone between existing ones, hold down the Alt key. When the Insert Bone cursor is dis-
played, click on the existing bone segment at the location where you want to add an additional bone.
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Displaying the Deformation Controls

Before you can manipulate the deformer outside of the Rigging mode, you must display the deformation controls.

If you just created the deformation rig, the controls will still be showing. However, when you close your project, the
deformers are turned off. When reopening a project, you must display the controls so you can you see the ones you
need while animating.

How to display the selected deformation controls

1. Inthe Camera, Timeline view, select the drawing layer or deformation nodes you want to display.

2. Do one of the following:
» Inthe Camera toolbar, click the Show Control = button.

» From the top menu, select View > Show > Control.
» Press Shift + F11.

How to display the selected deformation controls and hide all the others

1. Inthe Camera, Timeline view, select the drawing layer or deformation nodes you want to display.
2. Inthe Deformation toolbar, click the Show Selected Deformers and Hide All Others - button.

The selected deformation controls appear in the Camera view and all the others are hidden.

How to display all the deformer controls at the same time

1. Inthe Timeline view, select Edit > Select All from the top menu to select all the nodes or press Ctrl + A (Win-
dows/Linux) or 3§ + A (Mac OS X).

2. Inthe Camera toolbar, click the Show Control .+ button or press Shift + F11.

All deformation controls in scene are displayed.

How to hide the deformer controls

1. Do one of the following:
» Inthe Camera toolbar, click the Hide All Controls button.

» From the top menu, select View > Hide All Controls.
» Press Shift + C.
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Assembling Pieces

After you have created all the deformation chains for your character, you will need to assemble these separate
body parts into a puppet. Your pieces should be properly overlapping and not set apart.

To avoid problems such as having the head stretched by the neck deformers or a hand modified by the body
deformers, you can use the Kinematic Output node to assemble your pieces without propagating the
deformations down the hierarchy chains.

The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation chain
but not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will follow the
movement of the chain just like a regular cut-out character hierarchy piece without being influenced by the
deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the deformation.

When building a cut-out puppet with deformations, each part controlled by a deformation chain will automatically
rotate from the chain root point, which acts like a pivot. Because it is unlikely that every piece of your character
will be rigged with a deformation chain, you must set pivot points for the pieces that are not using deformations—
see Setting the Pivots on page 374.

Assembling Guidelines

When assembling a puppet with deformers, there are some guidelines to keep in mind:

« You cannot parent deformers directly because deformers are not designed to be used on other deformers.
To assemble deformers, you must insert a Kinematic Output node.
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2. From the top menu, select Insert > Kinematic Output.

The node appears in the Timeline view as a parent of your selection.

3. Inthe Timeline view, drag and drop the Kinematic Output layer ONTO the deformation layer you want your
limb or piece to follow. For example, onto the neck deformer if you want your head to follow it without being
deformed or onto the arm deformer if you want your hand to follow.
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« If your pieces are no longer ordered properly, use the Z-nudging feature to reorder them—see
Nudging Parts Backwards and Forwards on page 355.

« It's good practice to rename the Kinematic Output layer to reflect which deformer it is
assigned to as the Timeline view can become very large and layers can be positioned far
apart. Select the Kinematic Output node and in the Layer Properties window, rename the
node. You can also double-click on the layer's name.

Animating Deformations

The controls to animate deformations work the same as those for setting up the chains. You simply need to
create keyframes and position the control points.

How to animate Bone and Game Bone deformations

1. Inthe Timeline view, go the frame on which you want to create the first animation pose.

2. Inthe Tools toolbar, select the Transform -3 tool.
3. If you want to create animation keyframes, enable the Animate -2 mode in the Tools toolbar.

4. Do one of the following:

« Inthe Timeline toolbar, click the Add Keyframe # button.

» Right-click and select Add Keyframe.
o Press F6.

A keyframe is added on the current frame.

5. Inthe Timeline view, select the deformation nodes you want to animate—see Displaying the Deformation

Controls on page 415.
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6. Inthe Deformation toolbar, click the Show Selected Deformers and Hide All Others -©— button to display the
deformer of the selected piece.

7. Inthe Camera view, do the following:

« Rotate the first bone to rotate the limb.

« Use the root control to reposition (offset) the entire chain.

« Use the control points to reposition the articulations. This will elongate, shorten, or change the
direction of the bone and offset the subsequent children.
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« Use the articulation's control (square) to change the size of the articulation. For quality pur-
poses, it is recommended to have an articulation which fits the diameter of the part it con-
trols.
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8. Inthe Timeline view, go the frame on which you want to set the next key pose. You will need to expend the
exposure to see your drawings further down the Timeline view.

9. Add a keyframe on the current frame by doing one of the following:

« Inthe Timeline toolbar, click the Add Keyframe # button.

« Right-click and select Add Keyframe.
« Press F6.

10. Repeat the previous steps to animate your character.

You can also manipulate the deformer by typing values directly in the Layer Properties of the deformation
effect nodes.
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'm Parameters

Bone layer properties Game Bone layer properties (no Bias)
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Deformation Toolbar

The Deformation toolbar contains the various tools and options used to create a deformation rig. This toolbar is

displayed in the default interface.

By default, the Deformation toolbar only contains the essential options. If you right-click on the toolbar and select

Customize, you can add additional buttons.

Default toolbar
Rigging tool e Enable Deformations Rigging tool R <
Reset Current Keyframe Show Selected Deformers and Hide All Others |

Show Selected Deformers and Hide All Others

Customized toolbar

Enable Deformations
Remove All Keyframes
Show All Manipulators

Reset Current Keyframe | ‘

Icon Tool Name

Description

iT Rigging Tool

The Rigging tool is used to create a Bone deformation
chain. You also use it to set up the resting position.

To learn more about the Rigging tool's properties, see
Rigging Tool Properties on page 1.

Show Selected Manip-
& ulators and Hide All Oth-
ers

The Show Selected Manipulators and Hide All Others
button hides all manipulators displayed in the Camera view.
Only the manipulators of the selected deformation node are
displayed—see Displaying the Deformation Controls on
page 415 to learn how to make the manipulators visible in
the Camera view.

W

Reset Current Keyframe

The Reset Current Keyframe copies the resting position,
the original setup of your skeleton before undergoing any
deformation, to your current frame. Once you have created
a deformation chain, you can use the Rigging tool to adjust
the position and appearance of the rig to fit the element.
When the skeleton is in place, you can use the Reset
Current Keyframe button to reset the current frame position
to the resting position.

g Enable Deformations

The Enable Deformations button allows you to display your
drawings in their original state or with deformations while
creating additional drawings. Depending on the artwork you
need to create, you might need to refer to the other images
either deformed or in their original position.

Note that this will not affect the exported images. It's only a
display mode. You can see the result in OpenGL and
Render modes in the Camera view, but the exported images
will always be deformed.

5

Remove All Keyframes

The Remove All Keyframes option removes all keyframes
on the selected deformation chain.
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Show All Controls

o?

The Show All Controls button lets you visualize the resting
position in red (Setup mode) and the active position
(Animation) in green at the same time—see Displaying the
Deformation Controls on page 415 to learn how to make the
manipulators visible in the Camera view.

$

.

Deformation Nodes

The deformation rigs are composed of several different types of nodes. Additional ones such as the Kinematic
Output can be used to enhanced the results. Not all deformation nodes are compatible with the Game export. Only

the compatible nodes are listed here.
This section is divided as follows:

» Adding Deformation Nodes on page 423

» Deformation Nodes on page 423

Adding Deformation Nodes

How to add a deformation node

1. Inthe top menu, select Insert > desired deformation node.

Deformation Nodes

From the Insert menu, you can insert the following nodes.

Game Bone

The Bone node is one of the main hode used to build a deformation rig. Each Bone node consists of a bone and an
articulation. Chaining Bone nodes will create a skeleton chain for your character. The Rigging tool can be used to

create and connect those nodes automatically.
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Resting Parameters
Rest Offset

Parameter

Descriptions

Resting Parameters Rest Offset

(x) Axis This is the bone X-axis (horizontal) coordinates for the resting position.
(y) Axis This is the bone Y-axis (vertical) coordinates for the resting position.
Rest Radius This is the articulation's radius value (articulation size) for the resting position.

Rest Orientation

This is the bone's orientation angle for the resting position.

Rest Length

This is the bone's length for the resting position.

Deform Parameters Offset

When this option is enabled, the X and Y axis parameters are controlled by the

2D Path )
same 2D path function.
When this option is enabled, the X and Y axis parameters are individual from
Separate
each other.
Path When using a 2D Path, this field displays the name of the function curve.
(x) Axis This is the bone X-axis (horizontal) coordinates for the animation position. This
parameter can be linked to a function curve to be animated over time.
. This is the bone Y-axis (vertical) coordinates for the animation position. This
(y) Axis . . . .
parameter can be linked to a function curve to be animated over time.
This is the articulation's radius value (articulation size) for the animation pos-
Radius ition. This parameter can be linked to a function curve to be animated over
time.
. . This is the bone's orientation angle for the animation position. This parameter
Orientation , . . .
can be linked to a function curve to be animated over time.
Length This is the bone's length for the animation position. This parameter can be

linked to a function curve to be animated over time.
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Kinematic Output

The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation chain but
not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will follow the
movement of the chain just like a regular cut-out character hierarchy piece without being influenced by the
deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the deformation.

Connect a Kinematic Output node below the deformation node you want your drawing to follow.

0~ Display |
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Chapter 9: Library

Using templates and symbols , you can share and reuse any elements you create in Harmony. The Harmony library
lets you store several different elements such as puppets, backgrounds, animations and key poses. In fact,
anything you create in Harmony can be stored in the library.

This chapter contains the following topics:

» Understanding the Library Concept on page 427

» Library View on page 429
* Organizing the Library on page 431

» Templates on page 435
* Symbols on page 437
* Importing Symbols and Templates on page 445

* Importing Files Through the Library on page 449

* Using Paste Special on page 449

Understanding the Library Concept

The Library view is where you can store and reuse your artwork and animation in other scenes or build props and
puppets.

*  Whatis a Library? on page 428

* Understanding the Library Concept on page 427

*  What is a Symbol? on page 428

» Understanding the Library Concept on page 427
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What is a Library?

The library is a storage centre for all production assets; the elements stored in the library are called templates.
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional animation
processes. The library can contain any asset used in a Toon Boom Harmony production.

Using the library is as simple as dragging the content into the library to store your artwork and then dragging it to
the Timeline or Camera view when you want to reuse it.

You can organize your library using several different subfolders and store them on your hard drive or network.

What is a Template?

A template is an individual copy of the artwork stored in the library which you can reuse in different scenes. Once
atemplate is stored in the library, you can access it from any project.

Dragging a template into your scene copies the content in your Timeline and does not link it to the original. You
can modify this individual copy at any time.

What is a Symbol?

A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain
artwork and animation and manipulate them as a single object. You can also use symbols as a placeholder in
which you place a series of different drawings for each body part of your puppets or when you have a repeating
cycle. However, symbols are not necessary for creating characters.

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library into
your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the
Timeline view, they will all be linked to the original symbol. If you modify one, they will all be modified.
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A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content in
another scene, you must create a template out of it.

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

MO=agl Loes A s ("p  Parameters

Regular drawing cells
Symbol cells

Library View

Library menu , Library

Preview window

Flag_Animation.ty

Library search tool

I llA

Library list

Night_Scene.tpl

Templates and symbols list

You use the Library view to create and manage your symbols and templates, display the folders and manage and all
of the content.

Library View Menu

The Library menu lets you access commands specific to the Library view, such as opening a Library or getting the
rights to modify a library folder.

Preview Window
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The Preview window lets you preview the content of a symbol or template, and swap between drawings and
symbol cells in the Timeline view. This window is also used as the Drawing Substitution window.

How to preview a template or symbol's content

1. Inthe Library view's right side, click or double-click on the symbol or template to preview.

2. Inthe Preview window, click the Play » button or drag the slider to scrub through the frames.

Library Search Tool

When working on a movie or series, you will probably end up with many templates and symbols in your library.
Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

1. From the left side of the Library view, select the library in which you want to search.

2. Inthe Search field, type the name or partial name of the symbol or template you are looking for.

TATIWI

3. Click the left and right arrows to see the previous and next results. The Search engine will look for
results within the library master folder and its subfolders. It will not look in other libraries.

Library List
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The Library list lets you navigate through the different libraries and subfolders. You can also open, close and create
new libraries from here.

The Library folders have these default libraries:

+ Symbols: The only library folder containing symbols for your project. You can organize the symbols library
folder using subfolders, but you cannot create a second library for your symbols. This library is local to your
project.

» Harmony Library: This folder contains templates and is stored on your hard drive. You can organize the
Harmony library folder using subfolders. This folder does not contain symbols.

Templates and Symbols List

Flag_Animatio

Limpa_|

S

The symbols and templates contained in the selected Library list can be displayed on the right side of the Library
view as thumbnails, in a list or as details.

How to access the templates and symbols list display options

» Inthe Library view's right side, right-click and select View > List, Thumbnails or Details.
» Inthe Library View toolbar, you can click the following buttons:

Thumbnails

List

Details

Organizing the Library

As you will probably create a large number of symbols and templates, you will soon realize they need to be
organized. You can create different libraries and subfolders to easily access your assets. For example, you can
create a different library for each project and divide it into several categories, such as:

» Characters
*  Props
» Backgrounds

Although you can only have one symbol library folder, you can organize it by creating subfolders.

431



Chapter 9: Library

There are two ways to create library folders.
» Directly through your operating system
* Using Harmony's interface

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network as
a library. Opening a library means linking the folder to your Library view. You only need to open the library once.
The library folder is available every time you open the application until you decide to close the library and unlink it.

You may not always require all the library folders in the Library List. If so, you can close the ones you do not need.
Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it on your
hard drive or network and open it in the Library view.

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in
the Harmony Library view, so you can easily access assets. By default, any new library you link to your Library
view is locked to prevent accidental deletion or modification of symbols and templates. You must obtain the right
to modify it before being able to add a new folder to it.

You can delete a folder from the library if its contents are no longer needed.

NOTE: Warning: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the
data cannot be retrieved.

Once you add a folder, you can rename it. This also renames the folder on your hard drive.

If you update the content of your libraries through your operating system, you will need to refresh your library
folders in the Library view.

When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.

You can also delete thumbnails if you want to send a template to another user or studio and keep your packages
small.

How to create a library folder through your operating system

1. Onyour computer, create a new folder with a relevant name in the location where you want the library to be
stored.

How to create a library folder in Harmony

1. Inthe Library View menu, select Folders > Open Library.

The Browser window opens.
2. Browse for the location where you want to store your new library folder.

3. Click the New Folder button.

A new folder appears.

4. Name the new library folder with a relevant name and click OK.
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The new library appears in the Library List section.

How to open a library

1. Inthe Library View menu, select Folders > Open Library.

The Browser window opens.
2. Browse to the location of the library folder.

3. Select the folder and click OK.

The new library appears in the Library Folders section.

How to close a library

1. Ontheright side of the Library view, select the library folder to close.

2. Inthe Library View menu, select Folders > Close Library.

The library closes.

How to create a folder

1. Onthe left side of the Library view, select the library folder to which you want to add a subfolder.
2. Inthe Library View menu, select Edit > Right to Modify.

3. Inthe Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the plus [+] sign
to expand it.

How to delete a folder

1. Inthe Library view's left side, select the folder to delete.
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2. Inthe Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.

3. Inthe Library View menu, select Folders > Delete Folder or press Delete.

How to rename a folder

1. Inthe Library view's left side, select the folder to rename.

2. Inthe Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.

3. Inthe Library View menu, select Folders > Rename Folder.

4. Rename the selected folder.

5. Press Enter/Return to validate the operation.

How to refresh a library

1. Inthe Library view's left side, select the folder to refresh.

2. Inthe Library View menu, select Folders > Refresh or press F5.

The library displays the new content.

How to generate thumbnails

1. Inthe Library view's right side, select the template in which you want to generate thumbnails.

Ballerina_Puppet.tpl

Flag_Animation.tpl Joetpl

~mtt!
ot

-
ot

2. Inthe Library View menu, select View > Generate Thumbnails.

The progress bar appears.

How to delete thumbnails

1. Inthe Library View menu, select Edit > Delete Thumbnails.
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All the thumbnails contained in the library are removed.

Templates

When you want to reuse artwork and animation from your project in other scenes, you must create a template from
it. A template can be seen as a portable scene or package that you can drag inside your project. You can open a
template and edit it just like any other project. If you want modify your templates, you can edit them using the Edit
Template command.

You can create a template using the Timeline view.

To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary.

How to create a template from the Timeline view

1. Inthe Timeline view, select some cells or layers.
2. Inthe Library view, select a folder to store the template.
3. Ifalibrary folder is locked, right-click and select Right to Modify.

4. Drag the selection to the Stage Advanced Library folder or any other library folder.
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Tool Properties

TATTWI

5. Inthe Rename dialog box, give the new template a name.

To rename a template once it is created, right-click on the symbol and select Rename.

6. Click OK.

How to delete a template

1. Inthe Library view, select the folder containing the template to delete.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Delete or press Delete.

How to edit a template

1. Inthe Library view, select the folder containing the template to edit.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.
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2. Right-click on the selection and select Edit Template.

A new Harmony application opens.
3. Edit the template.
4. From the top menu, select File > Save.

5. Inthe top menu, select File > Quit (Windows/Linux) or Stage Advanced > Quit (Mac OS X).

Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can also
create symbols out of each body part in your cut-out puppets.

You do not need to create symbols in order to create drawings or characters in Toon Boom Harmony.

When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve the data.
The symbol cannot be retrieved once you close the application.

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. If you
import a symbol into your scene several times in the Timeline view, they will all be linked to the original symbol. If
you modify one, they will all be modified.

If you want to edit a symbol without modifying the other instances, you must duplicate the symbol first. If other
symbols are nested inside the new symbol, they are not duplicated. If you modify them, the original and other
instances will also be modified.

You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located in the
position where they were created. The pivot is translated at the centre of the symbol.
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When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest
many symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the
Editing stack at the top of the Camera view which displays the path to your symbol's location. You can click on
the symbol's name to move up the chain.

You can share a symbol and use its contents (the drawings) in another scene. To do this, you must first convert
your symbol into a template. This conversion breaks the drawing's link with both the original scene and symbol. It
then becomes a separate entity that you can import into other projects.

How to create a symbol from a drawing selection

1. Inthe Tools toolbar, select the Select w or Cutter ~ tool.

2. Inthe Camera view, select the drawing elements to create a symbol.

3. From the top menu, select Edit > Create Symbol or press F8.

» Clicking the Create Symbol ga button in the Edit toolbar will create a symbol from the entire layer.

The Create Symbol from Drawing Selection dialog box opens.

438



Harmony 12.2 Advanced - Gaming Animation Guide

!E Create Symbol from Drawing Selection

&

4. Inthe Symbol Name field, type the name of the symbol.

» You can also select an existing layer from the Symbol Name drop-down menu. It will add your symbol on
the layer's current cell. If there is already an exposure on that cell, the symbol will be added to a new
layer.

5. You can choose to place the current selected artwork in the drawing or remove it:

» Toremove currently selected artwork from the drawing and place it in the new symbol, select the Cut
Artwork From Source Drawing option.

» Tokeep currently selected artwork in both the drawing and in the new symbol, deselect the Cut Artwork
From Source Drawing option.

6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.

How to create a symbol from the Timeline view

1. Inthe Timeline view, select the layer or cells from which your want to create a symbol.

2. Do one of the following:

» From the top menu, select Edit > Create Symbol.
» Inthe Edit toolbar, click the Create Symbol ga button.

» Press F8.

» Drag your selection to the Symbol folder in the Library view.
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_-1‘ Stage Library
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The Create Symbol dialog box opens

3. Inthe Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the
new symbol. The new symbol only appears in the library. You must drag it into your scene to use it.

How to create an empty symbol

1. Inthe Library view, select the Symbol folder.

2. Do one of the following:

» Inthe Library view's right side, right-click and select New Symbol.
» From the top menu, select Insert > Create Empty Symbol in Library.
The new empty symbol appears in the Library view.

440



Harmony 12.2 Advanced - Gaming Animation Guide

Library — ==|%

I TTAT

AT

IA W]
Timeline  ==|%

The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top ¢ button
in the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.
How to delete a symbol

1. Inthe Library view, select the symbol to delete.

2. Right-click and select Delete or press Delete.

» If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the symbol
from the library and scene.

ill also remove all references to this symbol from

How to edit a symbol from the Timeline view

1. Do one of the following:

» Inthe Timeline view, double-click on the symbol's cell to edit the symbol.
» Inthe Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or 3§ + E (Mac OS X)).
> Click the Edit Selected Symbol g@ button in the Camera View toolbar's extra buttons.
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2. Do one of the following:

To return to the project's timeline, click the Top ¢y button in the Camera view's top-left comer, press Ctrl + Shift
+ E (Windows/Linux) or 3§ + Shift + E (Mac OS X).

» Inthe Timeline view's right side, right-click and select Symbols > Leave Current Symbol.

How to edit a symbol from the Library view

1. Inthe Library view, select the symbol to edit.

2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.
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To return to the project's timeline, click the Top ¢y button in the Camera view's top-left comer, press Ctrl + Shift +
E (Windows/Linux) or &§ + Shift + E (Mac OS X).

How to duplicate a symbol

1. Inthe Timeline view, go to the frame where you want to duplicate the symbol.

2. Select the symbol's cell.

3. From the top menu, select Edit > Duplicate Selected Symbol.

In the Library view, the symbol is duplicated and in the Timeline view, the current cell and its held exposure is
replaced with the new symbol. You can now modify the symbol's content.

How to convert a symbol into a template

1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline
view. If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in the
centre of your camera frame, but rather wherever your cursor drops it within the camera frame.
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2. Inthe Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any other
library folder. Make sure you have the right to modify the library folder.

[ Al W]
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3. Inthe Rename dialog box, rename the new template.
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Enter a new file name for the template.

Cancel

4. Click OK.

Importing Symbols and Templates

There are several ways you can import symbols and templates in your scene.

Sometimes a character rig is not a straightforward matter. Rigs, which are usually saved as templates, can contain
symbols such as a leg that was made with a patch. However, a symbol does not work in the same way as an action
template. In the Timeline view, you can add an action template into another template of the same structure. When
working on a layer on the right side of the Timeline view and you place a symbol into a symbol of the same structure,
instead of being added to the previous symbol, the new symbol becomes a copy.

For greater control over how the action template behaves when brought into the Timeline view, you can use the
Paste Special feature—see Using Paste Special on page 449.

Since a template is like a scene, you can open the template's folder and select elements inside it such as drawings.

Instead of importing the entire contents of a template, you may only want to import a few drawings or a palette. In
this case, use the Open As Folder command to import the items you want.

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root timeline.
The symbol's layers will be parented to it in case you created motions and transformations on the drawing layer that
contains the symbol. Breaking the hierarchy could result in the loss of any scaling and animation you may have
created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to import a template into the Timeline or Camera view

1. Inthe Library view, select the template you want to import.

2. Drag the selected template to the Camera view or to the left side of the Timeline view.

445



Chapter 9: Library

3. You can also drag a template to the right side of the Timeline view and into existing layers if the layer struc-
ture is the same as the existing one.

How to import a symbol in the Timeline view

1. Inthe Library view, select the symbol you want to import.

2. Drag the selected symbol to one of the following:

» The Timeline view's left side to import it into the centre of the camera frame.
» The Camera view to place it at the location where you release your cursor.
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NOTE: This may be useful if you saved a character's body parts as separate symbols. If you dropped them into the
Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would be more
efficient to arrange them into their correct places as you bring them into the scene.

How to import a template with symbols

1. From the right side of the Library view, select the action template that contains symbols.

2. Hold down Alt (Windows/Linux) or 3£ (Mac OS X) as you drag it from the Library view to the right side of the
Timeline view and drop it next to a template with the exact same rig.

The Paste Special window opens.

3. Select the Advanced tab.

4. Select one of the following options from the Symbols menu:

Options

Palettes:

» Copy symbols if they do not exist: This is the default setting for this operation and will prevent symbols
in an action template from being copied.

» Duplicate symbols: Makes copies of the symbols in your template.

How to open a template as a folder

1. Inthe Library view, select the folder that contains the template to open. If the library folder is locked, right-
click on the folder and select Right to Modify.

2. Right-click on the selection and select Open As Folder.

3. Inthelibrary list section, click on the template's folder to display its content.
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4. Dragthe content to the Timeline or Colour view.
How to expand a symbol

1. Inthe Timeline view, select the symbol to expand.

How to expand a symbol in a group

1. Inthe Timeline or Node view, select the symbol cell or symbol node you want to expand.

2. From the top menu, select Edit > Expand Selected Symbolin a Group.

3. Inthe Timeline view, click the plus sign (+) to see the group content. In the Node view, click the Expand
Arrow to enter the group.
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Importing Files Through the Library

Harmony lets you import sound files and images directly through the library. Simply open the folder containing your
files in the Library view and drag them directly from there.

How to open a file through the Library

1. Inthe Library View menu, select Folders > Open Library.
2. Browse for the folder containing the files you want to import.
3. Click Open.

4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.

Using Paste Special

When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You can
choose to import only the keyframes without the drawings or import only the drawings that are not already in your
layers. You can adjust the behaviour using the Paste Special dialog box.When you import a symbol in your scene,
its full length is exposed by default. If you import a symbol in the Timeline view’s left side, all the frames will be
exposed. However, if you import it into an existing layer, you can use the Paste Special dialog box to adjust the
import behaviour to fit your requirements.Once you set the parameters, Harmony will reuse them each time you
import a symbol in the Timeline view’s right side until you set new parameters.

How to open the Paste Special dialog box

1. Inthe Library view, select the symbol or template to import.

2. Press Ctrl + B (Windows/Linux) or 3£ + B (Mac OS X) and drag the selection to the Timeline view.
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NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

3. Set the parameters and click OK.

Basic Tab

Parameter

Description

Drawings

Only create drawing
files when they do not
exist

When adding exposures to a drawing layer, new drawings will be created only
when drawings with the same name do not already exist in the destination.

Always create drawing
files

When adding exposures to a drawing layer, new drawings will always be cre-
ated. If drawing files with the same name already exist, Harmony will create a
new name for the drawing.

Paste all Frames of the
Symbols (full movie)

When enabled, the Paste Special command exposes all the symbol's frames
instead of only the first one.

Enforce Key Drawings

Creates a key exposure on the same drawing.

Cycle

Number of Cycles

Lets you set the number of cycles.

Cycle Type

Normal (forward): Pastes your selection as is, starting with the first cell and
ending with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and
ending with the first.

Forward > Reverse: Pastes your selection as a yo-yo, starting with the first
cell, going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with
the last cell, going to the first one and ending with the last cell.
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Advanced Tab

Parameter Description
Drawings
Do Nothing Does not create or overwrite drawings.
Revises the drawing pivot in the destination to use the same drawing pivot as the
Update Drawing Pivot | first drawing in the template. If you have a range of drawings selected in the

destination, the pivot points of all selected drawings will be updated.

Add/Remove Exposure

Never create drawing files: When adding exposures to a drawing layer, drawing
files will not be created.

Only create drawing files when they do not exist: When adding exposures to a
drawing layer, new drawings will be created only when drawings with the same
name do not already exist in the destination.

Replace existing drawings. Create drawing files when they do not exist:
Replace drawings with the same names to update a scene with new modified
drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a

451




Chapter 9: Library

template, such as when placing new drawings after the animation,
then delete the template's animation. It will still have updated the
drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new
drawings will always be created. If drawing files with the same name already
exist, Harmony will create a new name for the drawing.

Paste all frames of the symbol (full movie): When enabled, the Paste Special
command exposes all the symbol's frames instead of only the first one.

Enforce Key Exposure: If there are key exposures that exist on copied draw-
ings, they are preserved when pasting. No key exposures are added. This is the
default behavior when pasting.

Fill Gap with Previous Drawing: Fills selected area in the Xsheet or Timeline
view with the previous drawing.

Fill to Next Key Exposure: Fills selected area till the next key exposure.

Add Remove/Keyframes

Motion Copies the properties of the selected motion keyframe to the new frame.
Velocity Copies the properties of the selected velocity keyframe to the new frame.
Rotation Copies the properties of the selected rotation keyframe to the new frame.
Scale Copies the properties of the selected scale keyframe to the new frame.
Skew Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at
Function's Beginning
and End

Adds a keyframe to the beginning and end of the pasted function, reproducing the
source function.

Offset Keyframes

When pasting functions, offsets keyframes from the function's last frame value
by the values in the pasted function. This will continue the progression of a func-
tion instead of repeating the values.

Options
Do nothing: Does not create, overwrite, merge or link palettes.
Reuse palettes. Copy palettes if they do not exist: Palettes in the destination
drawings are left as they are.
Copy and overwrite existing palettes: Overwrites destination palettes with the
palettes from the source drawings.
Copy and create new palette files: Creates new palette files, placing them at

Palettes the same relative environment and scene level as the source. If the palettes in the

templates were stored at the environment level of the source scene, the paste
operation will place the palettes in the environment level of the destination scene.

Copy and create new palette files in element folder: Creates new palette files
in the element folders of the destination scene, rather than in the same relative job
or environment.

Copy palette and merge colours. Add new colours only: Adds new colours to
the destination palettes and ignores colours that are the same in the two palettes.
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Copy palettes and update existing colours: Adds new colours to the
destination palette and updates duplicate colours in the destination with colour
values from the source.

Link to original palettes (colour model): Links the colour palettes in the
destination scene to the palettes in the source. Use this to link drawings to the
palettes in a colour model.

Copy scene palettes and merge colours. Add new colours only: Adds new
colours to the destination scene palettes and ignores colours that are the same in
the two palettes.

Copy scene palettes and update existing colours: Adds new colours to the
destination scene palette and updates duplicate colours in the destination with the
colour values from the source.

Symbols

Copy symbols if they do not exist: This is the default setting for this operation
and will prevent Symbols in an Action template from being copied.

Duplicate symbols: Creates a duplicate of the symbol instead of linking the Sym-
bol instance to the original one. The new Symbol is created in the Library.

Cycles

Normal (forward):Pastes your selection as is, starting with the first cell and end-
ing with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and ending
with the first.

Forward > Reverse:Pastes your selection as a yo-yo, starting with the first cell,
going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with the
last cell, going to the first one and ending with the last cell.

Nodes

Create New Columns: A new column is created when you copy and paste
nodes from the layer in the Timeline view. If the layers are linked to function
curves, the function curves, drawings and timing will be duplicated.

Elements

Reuse existing elements: Lets you paste existing elements without creating
new ones. This should be used only when pasting within versions of the same
scene.
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Chapter 10: Cut-out Animation

Harmony provides some great tools for animating puppets. You can create simple animation using the Transform
tool, as well as create advanced animation using both forward and inverse kinematics. Harmony has advanced
onion skinning and image swapping features to help you animate efficiently and quickly. For animation freedom, you
have the ability to mix several different techniques of animation, such as simple rigging, hierarchy and symbol
animation.

» Getting the Characteron page 456

» Keyframes and Drawing Blocks on page 459

» Creating a Simple Cut-out Animation on page 461

» Selecting Layers to Animate or Position on page 463

* Navigating the Hierarchy on page 465

* Animating Using the Transform Tool on page 467

* Animating in Stop-motion on page 469

* Animating Using Computer-generated Interpolation on page 470

*  Marking the Timeline on page 476

*  Flipping Through Poses on page 479

» Using the Onion Skin in Cut-out Animation on page 480

* Flipping Parts on page 483
»  Swapping Drawings on page 485

* Animating Lip-Sync on page 491

* Adding a New Drawing on page 494

* Ordering Layers Over Time on page 498

» Resetting a Transformation on page 499

» Creating Cycles on page 500
» Copying and Pasting Animation on page 502

* Adding Pegs on page 503

455



Chapter 10: Cut-out Animation

Getting the Character

The first step in animating your character is to import a master template from the library.

How to import a character from the library

1. Create a new Harmony project.

2. Inthe Library view, select a character master template to animate.
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o

4. Inthe Timeline view, drag the red scene length bracket to extend or shorten the scene length.
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How to import a network template (master template)

1. Create a new Harmony project.

2. Inthe Library view, select the character's master template you want to animate.

<
>

3. Drag the selected template in the Node view.

@» ballerinz-_MASTER >

1~ Display |

4. Inthe Node view, connect the template's group node to the Composite node by clicking its out-port and drag-
ging the connection to the Composite node until an in-port appears.
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5. Inthe Timeline view, extend or shorten the scene length by dragging the scene length bracket.

Extending the Exposure

Once you have chosen a pose, all that's left to do is extend the exposure of the character to the end of the scene.

How to extend the exposure of the character

1. Inthe Timeline view, collapse the character.

2. Inthe Timeline view’s right side, select the last cell of the character.

3. Right-click and select Extend Exposure or press F5. You can also copy the first pose and paste it in the
last cell.

The drawing exposure is extended to the end. You will not see any changes in the Timeline view when the
master peg is collapsed.
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Keyframes and Drawing Blocks

When you extend the exposure of a drawing, it is represented by a grey block in the Timeline view. When you
expose a second drawing, a second grey block is displayed.

You can consider these blocks as drawing blocks.

Drawing exposure duration

DR1 DR2 DR3 DR 4 DR5 DR& DR7

To animate the position of a block over time, you don't need to create a second block, just add a position keyframe.
The position keyframes are coordinates indicating the position of your drawing on a particular frame. These appear
as black squares in the Timeline view.

In the example below, notice that the keyframes are positioned on frames independently from the beginning and end
of each drawing block.

KF 1 KF 2 KF 3 KF 4 KF 5 KF 6

DR1 DR2 DR3 DR4 DR5 DR6

You can keyframe three different positions for a drawing in the same drawing block and create a motion path
between them.

Creating Keyframes and Drawings in the Timeline View

You can see how the Timeline view behaves differently depending on whether you create a new drawing, a new
keyframe, or both at the same time.

How to create a drawing in the Timeline view

1. Do one of the following:

» From the top menu, select Drawing > Create Empty Drawing.
» Inthe Timeline toolbar, click the Create Empty Drawing % button.
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» Press Alt + Shift + R.
A new drawing block is inserted.

How to create a keyframe in the Timeline view

1. Do one of the following:
» From the top menu, select Insert > Keyframe
» Inthe Timeline toolbar, click the Add Keyframe # button.

» Press F6.
A keyframe is created in the layer.

How to create a drawing and a keyframe simultaneously in the Timeline view

1. From the top menu, select Insert > Keyframe and Duplicate Drawing.

A drawing block is created which contains copies of the selected drawing and a keyframe.
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Creating a Simple Cut-out Animation

Here is how you can create a simple cut-out animation. Follow these steps so you can try the animation tools you'll
be learning in the next topics.

How to create a simple cut-out animation

1. Inthe Tools toolbar, select the Transform :-3 tool or press Shift + T.
2. Inthe Tools toolbar, enable the Animate mode so everything you move will be keyframed automatically.

3. From the top menu, select Animation > Stop-Motion Keyframe so the interpolation is not created auto-
matically between keyframes.

4. Inthe Timeline view, collapse your character.

6. To ensure that nothing moves on the new pose, in the Timeline view, select the frame corresponding to the
pose, right-click and select Add Keyframe or press F6.

7. Inthe Camera view, select the parts to animate.
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8. Usethe Transform -3 tool to rotate, skew, scale or translate the selection to its new position. To rotate
the piece, place your cursor slightly outside of a corner until you see the rotation cursor.

A new keyframe appears in the Timeline view if you did not create one previously. Always create your
keyframe first.

9. Inthe Tools toolbar, enable the Onion Skin = feature.

10. Inthe Timeline view, go to the frame where you want to set the second keyframe. You will need to expend
the exposure to see your drawings further down the Timeline view.

11. To ensure that nothing moves on the new pose, in the Timeline view, select the frame corresponding to the
pose, right-click and select Add Keyframe or press F6.

12. Inthe Camera view, animate your character.
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Child
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Selected parent

13. Repeat this process for all the poses.

Selecting Layers to Animate or Position

When you're animating characters, it's important to understand how the Animate mode allows you to create
keyframes on the current frame or reposition the entire layer.

Animate Mode

The Animate button, in the Tools toolbar, turns keyframing on or off. With this mode enabled, as soon as you

move an element in the Camera view, a keyframe is positioned on the current frame in the Timeline view to indicate
the new position.

When you turn off the Animate mode, and you select and move an element, the entire animation in the layer will be
offset.
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This means that when you are animating a character, you must enable the Animate mode. If you are scaling down
your puppet to fit the scene composition and want to resize the entire animation, you must disable the Animate
mode.

How to turn the Animate mode on or off
1. Inthe Tools toolbar, click the Animate button or select Animation > Animate.

Selecting Drawing Layers Using the Transform Tool

To manipulate the drawing layers in order to animate them, you must use the Transform ;-1 tool. The Select tool
is used to modify the drawing strokes and not the actual drawing layer.

When selecting the drawing layers with the Transform tool, make sure the Peg Selection Mode option is turned off
in the Transform Tool Properties view. Otherwise, if it's left on, it will limit the selection in the Camera view to
pegs only.

How to select using the Transform tool

1. Do one of the following:

» Inthe Tools toolbar, click the Transform -1 tool.

» From the top menu, select Animation > Tools > Transform.
» Press Shift + T.

2. Inthe Transform Tool Properties view, make sure the Peg Selection  mode is deselected.

3. Inthe Camera view, select the element to animate.
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Selecting an Element in the Camera View Using the Transform Tool

When you select an element in the Camera view using the Transform tool, make sure the Peg Selection  mode is

disabled in the Transform Tool Properties view. The element selected is the actual drawing layer corresponding to
the selected element. If you have a layer parented to a peg, you must use the keyboard shortcuts to go up the

hierarchy chain, select it in the Timeline view, or enable the Peg Selection - mode option in the Transform Tool

Properties view. This will limit the selection in the Camera view to pegs only.

If the layer has child layers, they will also be highlighted. Depending on whether you're using pegs or only drawing
layers in your rig, the selection can be magenta, yellow or both.

Child —P.

Selected ——p | _
parent [

Selecting a Layer in the Timeline View

When you select a layer in the Timeline view, the corresponding element is highlighted in the Camera view. If the
selected layer has child layers, they are also highlighted.

+
=
+
=
+
=
+
]
. +
=
+

Navigating the Hierarchy

If there is a layer hierarchy in the puppet you built, use the keyboard shortcuts to travel up and down the parent-child
chain. You can also navigate between the children of the same parent.

How to select the parent or child layer

1. Inthe Tools toolbar, select the Transform ;-3 tool.
2. Inthe Transform Tool Properties view, make sure the Peg Selection  mode is deselected.

3. Inthe Camera or Timeline view, select a layer attached to a hierarchy.
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4. From the top menu, select Animation > Select Parent or press B to select the parent layer. Select Anim-
ation > Select Child or press Shift + B to select the child layer.

How to select the children layers

1. Inthe Tools toolbar, select the Transform ;-3 tool.

2. Inthe Camera or Timeline view, select a layer attached to a parent layer with several children or not par-
ented at all.

3. From the top menu, select:

» Animation > Select Previous Sibling or press / to select the previous child layer.
» Animation Select Next Sibling or press ? to select the next child layer.
» Animation > Select Children to select all child layers at the same time.
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Animating Using the Transform Tool

The Transform tool is the main tool to use when working with a cut-out character. The Transform tool has many
useful functions:

Horizontal skew

Vertical and horizontal scale \

A Vertical skew

Honzontal scale + +

\ Temporary pivol offset

‘) Angle rotation

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece from
their own pivot point. They are compositing tools. The Transform tool creates a global selection, so when many parts
are selected, you can move them as one unit. The Transform tool is highly recommended for cut-out animation.

Vertical scale

When animating with the Transform tool, make sure to select the right selection mode. In this example, make sure
that the Peg Selection  Mode is disabled in the Tool Properties view or it will limit the selection in the Camera

view to pegs only.
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Rotate tool k Transform tool %

If there are hierarchy connections in the cut-out character, the Transform tool will also be used as the Forward
Kinematics equivalent.
The Transform tool can be used on any kind of rigging.

When many parts are selected with the Transform tool, the first selected part's pivot will be used as the global
selection's pivot. This pivot can be moved temporarily for the animation. When you offset the pivot, the
permanent pivot is displayed as a ghost.

NOTE: The interpolation of the animation poses is always calculated from each individual part's permanent pivot.
If there's a parent peg on a limb, make sure to select it instead of making a selection of each part to avoid setting
individual keyframes.

How to use the Transform tool

1. Inthe Tools toolbar, click the Transform :*: tool or press Shift + T.
2. Inthe Transform Tool Properties view, make sure the Peg Selection ;5 mode is deselected.

3. Inthe Timeline view, go to the frame on which you want to set the first position.

4. Inthe Timeline toolbar, click the Add Keyframe # button or press F6. It is recommended to add a key-

frame before moving the character. Moving a character's part without setting a keyframe will create key-
frames only on certain parameters of the animation. You could run into issues later on when setting poses
between existing ones. Creating a keyframe on all layers and parameters will ensure your pose is set and
will not be modified by other poses later on.

5. Inthe Camera view, select the element to animate and move it.
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6. Inthe Timeline view, go to the frame where you want to set the next position.

7. Inthe Timeline toolbar, click the Add Keyframe # button or press F6.

8. Inthe Camera view, animate the character.

Animating in Stop-motion

To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing key
poses. It is better to work with stop-motion keyframes so Harmony does not automatically create the interpolation
between your keyframes.

When using stop-motion keyframes, also known as step keyframes, the segment between two keyframes is
constant. There is no animation generated by the computer between the poses. The drawing remains in position until
the next keyframe, then moves to its new position.

Constant segment

Moves to next position

Creating a Stop-motion Keyframe

You can create a stop-motion keyframe in several different ways. You can have Harmony create it automatically,
transform a motion keyframe into a stop-motion keyframe, or even switch your preferences to get Harmony to
always create stop-motion keyframes by default.
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How to automatically create stop-motion keyframes

1. Inthe top menu, make sure the Animation > Stop-motion Keyframe option is selected.

2. Inthe Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:

» Right-click and select Insert Keyframe.
» Inthe Timeline toolbar, click the Add Keyframe # button.
» Press F6.

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a
keyframe is automatically created on the current frame.

How to convert a motion keyframe into a stop-motion keyframe

1. Inthe Timeline view, select the motion keyframes to convert into stop-motion keyframes or press S.

2. Do one of the following:
» Right-click and select Set Stop-Motion Keyframes.
» Inthe Timeline toolbar, click the Stop-Motion Keyframe . . button.
» Press Ctrl + L (Windows/Linux) or 38 + L (Mac OS X).

Animating Using Computer-generated Interpolation

After you have created the key poses, you can animate the in-between poses yourself or let Harmony do it using
motion keyframes. When you use motion keyframes, the drawings gradually move to the next position instead of
staying on the spot until the next keyframe.
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Creating a Motion Keyframe

You can create a motion keyframe in several different ways. You can have Harmony create it automatically,
transform a stop-motion keyframe into a motion keyframe and even switch your preferences to have Harmony
always create motion keyframes by default.

How to automatically create motion keyframes

1. Inthe top menu, make sure the Animation > Stop-Motion Keyframe option is disabled.

2. Inthe Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:

» Right-click on the selection and select Insert Keyframe.

» Click the Add Keyframe # button in the Timeline toolbar.

» Press F6.

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a keyframe
will be automatically created on the current frame.

How to convert a stop-motion keyframe into a motion keyframe

1. Inthe Timeline view, select the stop-motion keyframes to convert into motion keyframes.
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2. Do one of the following:

» Right-click on the selection and select Set Motion Keyframe.
» Click the Motion Keyframe _~ button in the Timeline View toolbar.

» Press Ctrl + K (Windows/Linux) or & + K (Mac OS X).

Adjusting the Ease

To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease
curve. To apply an ease to multiple functions and keyframes, use the Set Ease for Multiple Parameters feature
and set the amount desired.

The velocity, or ease, is used on motion keyframes. The velocity must be adjusted directly on the function curve
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and
left handle fields, as well as the Bezier handle or Ease wheel controls on each selected keyframe. You can pull on
them to adjust the ease in and ease out, or type values in the fields.

If there are several functions whose velocity you want to adjust at the same time, such as the hand, forearm and
arm of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in one
frame.

How to adjust the velocity in the Function view

1. Inthe Timeline view, click the Expand Function -~ button to display all the layer’s functions.
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2. Double-click on a function.

The Function Editor opens.

Bezier Editor @

NOTE: The Function editor will not display if the function does not already exist. Add a keyframe to create the
function.

3. Select akeyframe and pull on its Bezier handles or Ease wheel to adjust the velocity. Refer to the Com-
positing and Effects Guide to learn how to create Ease curves instead of Bezier curves.
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How to set ease on multiple parameters

1. Inthe Timeline view, select a keyframe from one or more layers.

NOTE: Only the first keyframe selected on each layer is considered when using the Set Ease for Multiple
Parameter function. If many keyframes are selected on the same layer, the ease values will be applied only to the
first one and the rest will be ignored.

2. Do one of the following:

» Inthe Timeline view, right-click and select Set Ease For Multiple Parameters.

» Inthe Timeline toolbar, you can click the Set Ease For Multiple Parameters Z- button. If the button is
not in the toolbar, you can add it through the Toolbar Manager. Right-click on the toolbar and select
Customize.

The Set Ease For Multiple Parameters dialog box opens.
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Graph ==

3. Inthe graph, pull on the Bezier handle to adjust the velocity for all the selected functions.

4. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the Filters
section, deselect the function types you do not want to affect.

>

Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 3D Path
functions

Rotation: Applies the easing parameters to the selected Angle functions.
Scale: Applies the easing parameters to the selected Scale functions.
Skew: Applies the easing parameters to the selected Skew functions.

Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note that it is
applied to the Morphing Velocity function in the Layer Properties window, not to the basic Morphing ease
in the Tool Properties view.

Other: Applies the easing parameters to all the other selected functions, such as all functions created to
animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are cal-
culated in percentage.

>

In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the length
of time you want the easing to last. The value must be between 0% and 100%.

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you want the
easing out. The value must be between 0% and 100%.

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.
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6. Click one of the following buttons:

» Apply: Applies the easing parameters to the selected keyframes.

» Apply/Previous: Applies the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

» Apply/Next: Applies the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

» Close: Closes the dialog box. If you did not apply the modifications, they will be cancelled.

Marking the Timeline

As you animate, the Timeline view will contain many layers and keyframes. You might want to identify them
using coloured layers and scene markers.

Scene markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can
use it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in
action, an impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is
displayed when you hover over the scene marker.

There are two ways to add a scene marker. You can mark the current frame or make a frame range selection and
mark the whole section.

How to mark the current frame

1. Inthe Timeline view, make sure the red playhead is set on the frame you want to mark. Even if you right-
click on a different frame, the scene marker will be created on the current frame on which the playhead is
positioned.

2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

w e

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the
colour of the last scene marker you created.

Colour swatch

3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene marker.
Click OK.
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Add to C

4. Inthe Note field, enter text to display as the tooltip and click OK.

In the Timeline view, the scene marker is displayed at the current frame.

5. Hover over the scene marker to display its tooltip.

How to create a scene marker on a frame range

1. Inthe frame counter area, select the frame range you want to mark.

2. Right-click and select Create Scene Marker.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the colour of
the last scene marker you created.

477



Chapter 10: Cut-out Animation

Colour swatch

3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene marker.
Click OK.

Add to Cu =

4. Inthe Note field, enter text to display as the tooltip and click OK.

In the Timeline view, the scene marker is displayed over the selected frame counters.

5. Hover over the scene marker to display its tooltip.

How to modify a layer's colour

1. Click the Change Track Colour D button of a layer.

Change Track Colour

The Select Colour dialog box opens.
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2. Select a colour for the layer. You can modify the colour for any type of layer, such as group, peg, drawing and
effects.

Change Track Colour

Flipping Through Poses

R D S S |

When animating, it is useful to flip through poses to see the flow of your animation without going through each frame
in the Timeline view. Harmony lets you flip between the selected element’s keyframes.
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How to flip through poses

1. Inthe Camera or Timeline view, select a layer that contains the poses you want to view.

o
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2. Do one of the following:

» From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe
» Press semicolon (;) and single quote ().

Using the Onion Skin in Cut-out Animation

When animating cut-out characters, it is useful to see the previous and next frames on the animation. However, it
can sometimes be confusing to see the onion skin for every part of the character. You will often only want to see
the onion skin on a single part or a few parts, such as the arm that is currently being animated. Harmony offers
that possibility.

While animating in the Camera view, there is a series of different onion skin options. You can enable these
options in the menu or manually in the Timeline view using the layer's Show Onion Skin & button. Unless you
=
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change the onion skin options when you display the onion skin, only the selected layers will be displayed in the onion
skin preview.

How to use the onion skin

1. Inthe Tools toolbar, click the Onion Skin button or press Alt + O.

2. Inthe Tools toolbar, click the Transform -1 tool or press Shift + T.

3. Inthe Camera view, select one or more elements.

4. From the top menu, select View > Onion Skin > Add to Onion Skin, Remove From Onion Skin, Remove
Unselected from Onion Skin, Add All to Onion Skin or Remove All from Onion Skin.

Add to Onion Skin

The Add to Onion Skin command is used to add a series of selected elements to the onion skin preview. The
keyboard shortcut is Shift + S.

Remove from Onion Skin

The Remove From Onion Skin command is used to remove a series of selected elements from the onion skin
preview.
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Remove Unselected from Onion Skin
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The Remove Unselected from Onion Skin command is used to remove all elements except the ones selected
from the onion skin preview.

Add All to Onion Skin

The Add All to Onion Skin command is used to add all of the scene's elements to the onion skin preview. The
keyboard shortcut is Alt + Shift + O.

Remove All from Onion Skin
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The Remove All Onion Skin command is used to remove all of the scene's elements from the onion skin preview.
The keyboard shortcut is Ctrl + Shift + O (Windows/Linux) or 3£ + Shift + O (Mac OS X).

Flipping Parts

If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip Vertical
options. If the Scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

How to flip a selection

1. Inthe Tools toolbar, select the Transform :; tool or press Shift + T.

2. Inthe Tool Properties view, make sure the Peg Selection Mode ;. is disabled.

3. Inthe Camera view, select the parts to be flipped.
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4. Inthe Tool Properties view, click the Flip Horizontal s> or Flip Vertical -~ option or press 4 or 5 respectively.
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Reusing animation and assets is an important aspect of cut-out animation. This is why Harmony includes a
library for storing all the reusable information.

When you created the character rig, you most likely created a master template along with some action templates

To save time, you can take an action that you've already animated, such as a walk-cycle or jump, and reuse it.
You can store the initial animation's keyframes in the Library view, then drag it into a master template of a new
scene.

You can import a master template into the Timeline view and start animating with it. You can import an action
template into the right side of the Timeline view. An action template is composed of drawings (like a blink) or
keyframes (like a walk cycle) that you can reuse in an animation sequence.

Toinsert an action template into a master template, the layer ordering has to be exactly the same. Ifit's
inconsistent, the templates cannot be combined.
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Ordering in hierarchy of the layers have
to be exactly the same
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You can create a single keyframe action template of the different views (front, three-quarter or side view). Then
import and insert them into the animation to turn the character. The same pattern can be created for a head, arm, full
upper body, etc.

If you created templates for different body parts, you can reuse them in your scene by dragging them to your layers.
You can also open a template as a folder and select a particular drawing from it and drag it onto a drawing layer.

Swapping Drawings

Cut-out animation is not only about moving parts around. It's also about swapping drawings to give the animation a
more traditional animation look. You can add as many new drawings as you want in your scene and use them in your

current animation. You can also add new drawings to the library and use them in other scenes. But before starting to
swap drawings, it's important to understand how keyframes, exposure and key exposure work in Harmony:

+ Keyframe: A keyframe is a point in time where a change to the properties of the object or character occurs. In
Harmony, keyframes consist of the coordinates that determine how an entire layer and its contents are
moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.
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» Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames.
In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings.
Keyframes can be moved independently from the drawing exposure.

» Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed
on a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for
another one, then the original drawing is retained. This preserves the key drawing. Note that Harmony
automatically sets a key exposure when you perform a drawing swap.

When you want to swap drawings, you can do so in the Timeline or Library view. In the Timeline view, the
Parameters area is where you can select a drawing to swap. In the Library view, the Drawing Substitution window
lets you see the drawings before selecting one for swapping. In this view, you are actually selecting drawings in
your scene layers, not drawings in the Library.

NOTE: Keep in mind that when you swap a drawing, its entire exposure is replaced up to the next drawing
exposure.

Drawing exposure duration

DR1 DR2 DR3 DR 4 DR5 DR& DR7

When selecting a certain frame range to be swapped, the behaviour of the Timeline and Library views is different.
If you are using the Parameters area of the Timeline view to select a drawing to replace a selected frame range,
the new drawing will replace the frame range and continue until the next key exposure. In the following example,
drawing 2 (DR2) is replaced by a new drawing, starting at the beginning of the selected frame range and ending at
the next key exposure.

Selected frame range

DR2 New drawing

Selected frame range is replaced by a drawing selected from the Parameters area of the Timeline view. The
exposure starts at the beginning of the frame range and continues until the next key exposure.

If you use the Drawing Substitution window in the Library view to select a drawing, the drawing is split in two and
the exposure before and after the frame range remain the same. In the following example, drawing 2 (DR 2) is split
in two and the selected frame range is filled with a new drawing.

Selected frame range New drawing

DR 2 DR 2 s split in two

Selected frame range is replaced by a drawing selected from the Library view. The drawing is splitin two. The
exposure remains the same before and after the new drawing.
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How to swap a drawing in the Timeline view

In the Timeline view’s right side, select the cell containing the drawing or symbol cell to swap.

In the Drawing Substitution field, position the pointer over the value and drag left or right to change the cell or

drawing exposed for another one. You can also type in the drawing name or symbol’s cell number if you know
it.

Drawing Substitution field

How to swap images in the Library view

1. Inthe Tools toolbar, select the Transform ;-3 tool.

2. Inthe Transform Tool Properties view, make sure the Peg Selection - button is deselected.

3. Inthe Camera view, use the Transform ;-3 tool to select a part of the drawing to swap.

NOTE: You can swap the frames in symbols or the drawings in a layer. However, you cannot swap one symbol for
another.

4. Inthe Timeline view, select the cell range in which you want to swap the drawing.

5. Inthe Library view, go to the Drawing Substitution window.
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6. Scroll through the symbol's frames or drawings by doing one of the following:

» From the top menu, select Animation > Substitute Drawing Previous or Substitute Drawing Next.
» Drag the slider left or right.
» Press +.

Adding Key Exposures

If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property of
an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is the
same drawing or not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be automatically

updated even if set as a key exposure. This keeps your existing animation key poses intact. It is frequently used on
a mouth or eyes layer.

488



Harmony 12.2 Advanced - Gaming Animation Guide

Example: Swapping a drawing with no key exposure

In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure.

Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is
positioned in the middle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key
exposure is added, drawing 5 is spilit in two; both halves contain drawing 5. Now if you swap the first drawing 5 for
drawing 1, the second drawing 5 retains its exposure.

A location is selected for a new key exposure.

DR5

New key exposure

A key exposure is added at the location of the playhead.

How to add a key exposure

1. Inthe Timeline view, select the drawing cell to set as the key exposure.
2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure L button.

» Inthe Timeline toolbar, click the Add Key Exposure K button.

» Inthe Timeline menu, select Exposure > Add Key Exposure.
» Right-click and select Exposure > Add Key Exposure.
A new key exposure is added.
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If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing
is split in two and both parts contain the same drawing.

Removing Key Exposures

When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure
is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When
the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).

Before: Key exposure is set to drawing 1.

How to remove a key exposure

1. Inthe Timeline view, select a key exposure to remove.

2. Do one of the following:

» Inthe Timeline toolbar, click the Remove Key Exposure £ button.
» Inthe Timeline menu, select Exposure > Remove Key Exposure.
» Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.

How to remove a key exposure

1. Inthe Timeline view, select a key exposure to remove.

2. Do one of the following:
» Inthe Timeline toolbar, click the Remove Key Exposure = button.

» Inthe Timeline menu, select Exposure > Remove Key Exposure.
The key exposure is removed and replaced by the preceding exposure.
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Animating Lip-Sync
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Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth to match the sound at a precise frame.

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound element and
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X for silence).

The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.

NOTE: If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter, "Adding
Extra Drawings" topic to learn how to add extra drawings to your character.

//:/; /\ - /i 5 7,/ N
o \

A B C D
;- S Y
N 1 N ;;}_A\ L:_——a
E F G X
(
Extra mouth

Here is an approximation of the sound each mouth shape can produce:

* Am,b,ph

* B:s,d,j,ik,t
+ C:ea

- D:AE

+ E:o

e F:uy, 00

« G:f,ph

+ X: Silence, undetermined sound
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You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to the mouth chart positions as you draw the shape of the character's mouth.

How to generate a sound detection for lip-sync using the Layer Properties view

1. Inthe Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

2. Inthe Layer Properties, click Detect.

Layer Properties == |3

Sound Editor

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

3. Click the Map button to open the Lip-Sync Mapping dialog box.
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4.

From the Destination Layer menu, select the layer that contains the mouth positions for the character's voice
track.

If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the layer
or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to use the
drawings or select the desired symbol from the drop-down menu.

In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it rep-
resents. If your drawings are already named with the phoneme letters, you do not have to do anything.

Click OK.

Press the Play » button in the Playback toolbar to see and hear the results in the Camera view. To play
back your scene with sound, enable the Sound - button in the Playback toolbar.

Harmony allows for the manual swapping of mouth position drawings to match a voice track. For this process, both
sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing substitutions are used.

How to animate lip-sync using the Timeline view

1.

2.

In the Playback toolbar, enable the Sound Scrubbing «s button.

In the Timeline view, drag the red playhead along the sound layer waveform.

When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for
an "oh" sound, click on that frame on your mouth shapes layer.

In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing name
(often a letter) until it changes to the swapping ‘{5 pointer.

Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing auto-
matically changes to the new selection.

How to animate lip-sync using the Library view

1.

2.

In the Playback toolbar, click the Sound Scrubbing «s button.

In the Timeline view, drag the red playhead along the waveform of your sound layer.
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3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips
for an "oh" sound, click on that frame on your mouth shapes layer.

4. Inthe Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The cur-
rent drawing is swapped for the one in the preview window.

Adding a New Drawing

If you need to add a new drawing to a scene, you can do so by duplicating the existing drawing on the current
frame. If you're using symbols, you can also add a new drawing inside the body part’s symbol.

Duplicating a Drawing
If your character doesn't use symbols, you must duplicate the drawing on the cell on which you need to a new
drawing. You could also create a new blank drawing, but duplicating the existing drawing allows you to keep the

pivot you previously set (if you're using drawing pivots) and you can also reuse a portion of the existing artwork.
When you create a new drawing, you get a blank cell with a pivot set at the centre of the Camera view.

How to duplicate a drawing

1. Inthe Timeline or Camera view, select the drawing to duplicate.

o
o
tt:
o
o
o
o
o
o

2. From the top menu, select Drawing > Duplicate Drawing or press Alt + Shift + D.

The new drawing appears in the currently selected cell.
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3. Inthe Camera view, draw the new piece.
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Repositioning Drawings

When creating additional drawings for a cut-out puppet, you should generally try to create them in the same location
as the original drawings (resting position) so you can scale and rotate the same pivot.

Although, when adding drawings that are specific to an animation, it may be easier to draw it in relation to the
character's position and scene's composition. If you draw a series of drawings that are not in the same location, you
can use the Reposition Drawing /4 tool to reposition the drawing strokes while simultaneously creating keyframes
in the Timeline view to compensate for the repositioning. In the Camera view, the drawings will retain the location
and position in which you drew them while in the Drawing view, all your drawings will be aligned.

How to reposition and alignh drawings

1. Inthe Advanced Animation toolbar, select the Reposition Drawing . tool.

2. Inthe Camera view, Ctrl + click (Windows/Linux) or &£ + click (Mac OS X) to select the drawing to repos-
ition. You can also select the drawing layer or the parented peg in the Timeline view.

The Reposition Drawing controls appear in the Camera view. They are positioned on top of each other. The
source controls are represented by black lines. The destination controls are represented by dotted blue lines.

3. Onyourfirst drawing (reference drawing), position the black source controls to indicate the position at which
all other drawings will be aligned.
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Destination confrol =~ ==

Source control

N|

4. Inthe Timeline view, move to the next drawing.

5. Inthe Camera view, move the blue destination controls to match the reference position you set on the ori-
ginal drawing. You can use the long handle to rotate the position. If you rotate the control multiple times,
the drawing will rotate multiple times.

= Select the Checkbox once
the position is correct
a

6. Select the blue checkbox once the position is correct.

7. Repeat the previous two steps for all drawings in your animation.
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P

8. Once all the drawings are completed, in the Drawing view, verify that the drawing strokes are correctly
aligned.

]

9. If necessary, delete the last keyframe if the last drawing moves back to the reference drawing's position.

10. If the animation does not require interpolation, in the Timeline view, select the newly created keyframes. In
the Timeline toolbar, click the Set Stop-Motion Keyframe . button to remove any computer-generated inter-

polation.
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Ordering Layers Over Time

The layer ordering system in Harmony saves time and simplifies your work. There is no need to create a new
layer or copy and paste artwork into other layers to change the order. The Z-axis (forward/backward) allows you to
create a multiplane and move elements closer or farther from the camera. This allows you to move the puppet’s
pieces in front of or behind other ones without physically changing the layer position.

B8 88888888888
.
o

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe is created
where different Z values can be entered. This allows the piece to move forward and backwards in space without
requiring you to change the drawing’s original position or break the layer hierarchy. This also means that the layer
ordering is maintained throughout the scene. You can combine animation assets so Harmony can interpolate
them.

How to nudge elements on the Z-axis

1. Inthe Tools toolbar, select the Transform -: tool or press Shift + T.
2. Inthe Tools toolbar, click the Animate -2 button.

3. Inthe Camera view, select the part to be repositioned and hold down the Alt key.

4. Usingthe Up or Down arrow keys, nudge the part until it moves to the desired position.
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Resetting a Transformation

If you made too many transformations and it's not going where you want it to go, or simply because you want to
reset a pose you're reusing from another animation, you can reset your character's position. Once the layers are
positioned in the Camera view, you can easily return them to their original position. There are three different ways to
reset a transformation.

Using the Reset command, you can reset the value of the selected element to the initial value of the active tool. For
example, if the Rotate (v tool is active, the transformation angle will be reset to 0 and if the Transform :-; tool is

active, all the transformation values will be reset.

The Reset All option resets all transformations on the current frame in a selected layer. Your keyframe will remain,
but all the values will return to the default position. All transformations are reset regardless of the tool you're using.

The Reset All Except Z option resets all transformations on the current frame except the Z position. This is useful
when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the different views of a
character. You might want to reset the transformation, but not necessarily the Z position.

In the Timeline view, you can also use the Clear All Values command to reset all transformation values on the
selected layers. Right-click on the selected layers and select Layers > Clear All Values.

NOTE: When using the Transform tool to select elements in the Camera view, always make sure the Peg Selection
Mode option in the Tool Properties view is disabled or it will limit the selection to peg only.

How to reset the transformation on the current frame

1. Inthe Tools toolbar, select the Transform :i:: tool or any Advanced Animation (& tool.

2. Inthe Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

3. From the top menu, select Animation > Reset or press Shift + R.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

1. Inthe Tools toolbar, select the Transform i tool or any Advanced Animation & tool.
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2. Inthe Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to reset all transformations except the Z position on the current frame

1. Inthe Tools toolbar, select the Transform :-: tool or any Advanced Animation @ tool.

2. Inthe Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

3. From the top menu, select Animation > Reset All Except Z.

The selected layer(s) return to their original position, except for the Z values.
Creating Cycles

You can create cycles from a portion of your animation or completely reverse the flow of your animation.

How to create an animation cycle

1. Inthe Xsheet or Timeline view, select the cell range and keyframes to loop.
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2. From the top menu, select Edit > Copy Cells From the Timeline.

3. Inthe Xsheet or Timeline view, select the cell where you want your cycles to start.
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4. From the top menu, select one of the following:

» Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or 3£ +/ (Mac OS X).
The Paste Special dialog box opens.
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» Edit > Paste Special or press Ctrl + B (Windows/Linux) or 3§ + B (Mac OS X).
The Paste Special dialog box opens.

5. Inthe Number of Cycles field, enter the number of cycles to paste.

6. Inthe Cycle Type menu, select a type of cycle to paste.

» Normal (forward): Pastes the selection as is, starting with the first cell and ending with the last.
» Reverse: Pastes the selection reversed, beginning with the last cell and ending with the first.

» Forward -> Reverse: Pastes the selection as a yo-yo, starting with the first cell, going to the last cell and
ending with the first cell.

» Reverse -> Forward: Pastes the selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

7. Click OK.

888888883883

How to create a reverse animation cycle

1. Inthe Xsheet or Timeline view, select the cell range and keyframes to paste inverted.
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2. From the top menu, select Edit > Copy.

3. Inthe Xsheet or Timeline view, select the cell where you want the cycles to start.
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Copying and Pasting Animation

As you animate, you will find that you reuse many positions, drawings, and keys. However, you may only want to
paste the drawings or just the keys or maybe everything. There are different paste options available in the
Timeline view which give you maximum flexibility when reusing and pasting.

Note that these modes also apply when you drag instead of copying and pasting.

There are three different modes for pasting your selection:
* a Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.
. Paste Mode: Keyframes Only: Pastes only the keyframes.

. Paste Mode: Exposures Only: Pastes only the drawing exposure.

How to paste a selection using different modes

1. Inthe Timeline view, select the cells you want to copy and paste.
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2. Inthe Timeline toolbar, click the desired Paste [a mode button.

3. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or 3£ + C
(Mac OS X).

4. Inthe Timeline view's right side, select the cell on which you want to paste your selection.

5. Select Edit > Paste Cells in the Timeline or press Ctrl + V (Windows/Linux) or 3£ + V (Mac OS X).

Paste Mode: All Drawing Attributes

Paste Mode: Keyframes Only

Paste Mode: Exposures Only

Adding Pegs

Now that you have your puppet on stage, you probably need to resize and reposition it to fit the scene. When you
need to scale down or move a character, it's a good idea to hook (attach) the whole puppet to a trajectory.
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In Harmony, there is a type of layer you can add to your timeline, allowing you to create a motion path or
reposition drawings. This trajectory layer is called a peg. Any drawing or layer you hook to a peg will follow the
defined motion path, rotation, scaling and skewing information.

Attaching your puppet to a peg allows you to scale and reposition it without having to do the same on all the
different parts and pieces. Only one layer will contain the position information, making your animation easier to
modify and control.

Next, position your character on the stage by moving it and scaling it to the correct size. You will not scale each
layer individually. You can do it on the top symbol or top peg layer.

How to add a repositioning peg

1. Inthe Timeline view, select the top layer on which you want to parent a peg.

NOTE: You must select a layer to be able to add a peg to your scene. Unless you use the Display All mode from
the Display toolbar, an error message will display if you try to add a peg without any selection.

2. Inthe Timeline view, click the Add Peg & button.

A new peg is added to the timeline as a parent of the selected layer.

4. Inthe Timeline view, select all the layers you want to attach to the new peg. Remember that one item is
already parented to that peg.
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5. Drag the selection and drop it on the peg layer to parent all the character's pieces to the peg. If your layers
are added above the already-parented layers, move that parented layer back on top of the layer stack.
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How to reposition a character

1. Inthe Timeline view, select the top peg layer (master peg).
2. Inthe Tools toolbar, select the Transform ;-3 tool and disable the Animate £ mode.

3. Inthe Camera view, position the character.

Offsetting a Portion of an Animation

If there is a section of the animation that you want to reposition, such as the head's height or the puppet's position,
you can do so using the function curve.

How to repaosition a portion of an animation

1. Inthe Timeline view, click the Expand Function button of the body part layer to reposition. If you want to
reposition the entire body, expand the master peg's parameters.

2. Double-click on the layer's parameter controlling the keyframes you want to reposition.
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The Function Editor opens.

3. Inthe Function editor, select the keyframes you want to reposition by tracing a selection box.

4. Click the Show Current Frame - button to view the transformation results in the Camera view as you do
them.

5. Drag the keyframe selection up or down to reposition the sequence.

6. Close the Function editor.
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At this point, if you have a custom game engine, you can take the exported data and proceed with your usual
process. Or you can modify the export script to fit your convention.

If you’re going into Unity, here are some things you need to do:

» Exporting the Animation on page 507

*  Opening the Sample Unity Project on page 1

»  Working in Unity on page 1
Exporting the Animation

If you were using Harmony 12.1 or earlier, it is strongly suggested that you clear your scripts before exporting
animation for the first time. This will ensure there's no conflict with previous versions of the scripts and you have the
most up-to-date script.

How to clear your scripts

1. Close Harmony if it is open.

2. Browse to the script folder location:
*  Windows:

» Toon Boom Harmony Advanced: C:\Users\[user_
name]\AppData\Roaming\Toon Boom Animation\Toon Boom Stage
AdvancedAdvanced\1200-scripts

« MacOSX:

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down
the Alt key.

* Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon
Boom Animation/Toon Boom Stage Advanced/1200-scripts
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3. Delete the 1200-scripts folder.

4. Restart Harmony and test the export.

Setting Anchors and Props

Before exporting your scene, you must set the anchors and props.

An anchor is an attachment point you can use to bind one or several props to a specific location that is predefined
by the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’'s hand, a
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and easily
swappable from within Harmony or Unity.

For more information, see Setting Anchors and Props on page 376.

Before Exporting a Scene

Before making the export, be sure to set your Display as <Display> and not <Display All>

Be certain to save your scene. Harmony makes the export based on the tvg files, any unsaved updates
you have added will not be exported.

Set your Harmony scene to be a square resolution (ex. 1024 x 1024). Select Scene > Scene Settings.

How display the Game toolbar

From the top menu, select Windows > Toolbars > Game.
The Game toolbar appears above the Camera view, to the left.

Export to Sprite Sheets  Export to Easel JS

BT

Toggle Anchor Toggle Prop

Run the script by clicking the Export to Sprite Sheets& button in the Game toolbar.

The Export to Sprite Sheets window opens.
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3. Set the Save Path to the correct folder in your Unity project if you want it to update automatically. If not, you
can save anywhere, then transfer the animation into your Unity project, or any other game engine you want to

use.

4. Set your sprite sheet preferences:

Parameter

Description

Max Width, Max Height

This is a value, in pixels, for the maximum width and height the exported sprite
sheet should be. By default, both values are set to 2048 pixels.

Expand Sprite Sheet

Uses the minimum size necessary up until it reaches the maximum resolution.

Fixed Resolution

Creates a texture of the specified size (Max Width and Max Height) even if it does
not fill it up completely.

Resolution Type

POT: Exports to sprite sheets with sizes that are a power of 2. For example: 1024
x 1024. This is optimized for many graphics cards, but consumes more memory.

NPOT: Some game engines are optimized specifically to render to non powers of
two, so that it will avoid those numbers. Example: 1000 x 1000.
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Reuse Frames

Threshold

Sprite Resolutions

Size of the render of the individual sprite, when it exports each drawing out.

The exporter will export to multiple resolutions based on the settings.

Saves different animations of the same character into the same Save Name. For
example, if there's an idle, run, and jump animation, these should all share the
same Save Name. You can think of it as the overall collection of animations.
Inside are the different saved scene versions whose drawings you can reuse for
all the animations in that character set. Each scene version will be displayed as
an item in the list.

When you export an animation, only the drawings used in that scene are
exported. All the drawings are exported individually first and then atlased together
into a sprite sheet.

If you save multiple animations to the same Save Name (i.e. SpaceDuck: run,
idle), then it will re-atlas the sprite sheet to include all the drawings from all the
animations in that folder, creating a new animation file, but reusing the same
skeleton.

Precalculate Curves

Makes linear values for interpolation. This increases the amount of memory used
but frees up the calculation so it is not done on the fly.

5. Click Export.

NOTE:

Programmers may be interested to note that the XML data exported by Harmony can be converted afterwards to a

more optimized binary data structure. The binary converter is not yet available for Harmony, but it can be compiled
manually in the game engine package. The C++ code that handles the data structure can be reused and parsed in
your own code if you want to integrate with other game engines.

Additional Note

» The Transparency parameter attached to the element node is exported along with the animation. You can
set the transparency through the Layer Properties window (Advanced tab).
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Harmony Game Previewer

If you are not a developer and would like to see if your animations and rigs will work once imported in Unity, you can
use the Harmony Previewer application. You can visualize your characters in the Unity game engine with no
programming required.

How to use the previewer on Windows

1. Download the Harmony Game Previewer for Windows:

» https://docs.toonboom.com/go/download/GamePreviewer-12-2-windows

2. Extract the following to your hard drive:

» GamePreviewer-[version].exe

» GamePreviewer-[version]_Data folder

3. Copy your export from Harmony to this folder:

» GamePreviewer-[version]_Data\StreamingAssets\HarmonyResources\
4. Start the Game Previewer application.

5. Select the export you want to preview.

How to use the previewer on Mac OS X

1. Download the Harmony Game Previewer for Mac OS X:

» https://docs.toonboom.com/go/download/GamePreviewer-12-2-mac

2. Extract the GamePreviewer-[version].app.
3. Right-click on the GamePreviewer-|version].app and select Show Package Contents.

4. Copy your export from Harmony to this folder: Contents/Data/StreamingAssets/HarmonyResources/
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5. Start the Game Previewer application.

6. Choose the export you want to preview

Opening the Sample Unity Project

Toon Boom includes a sample Unity project that contains all the scripts necessary to import the data exported
from Harmony. Inside this project is an Assets folder which contains the following folders:

*  Plugins

» Scenes (demo scenes and a previewer)

» Scripts (all Harmony scripts)

» StreamingAssets (this is where all the Harmony scene files should be exported to)

By configuring the Harmony script, you can automatically export animations into the StreamingAssets folder.
This way, Unity will dynamically load the most up-to-date assets as soon as they appear in the folder. You can
also manually place exported Harmony data into this location.

Working in Unity

The Harmony Gaming Animation Guide is a basic guide on how to import Harmony projects and configure them,
design and animate characters, and includes some tips. It is not meant as a guide on how to program games.

The Unity Interface

Here are the main components of the Unity interface and their equivalents in Harmony:

Unity Harmony Description
This is where you set the scene, selecting and positioning
Scene view Perspective view environments, the player, the camera, enemies, and all
other GameObjects.
. . The rendered view from the camera(s) in your game. It is
Game view Camera view . ) .
representative of the final, published game.
Displays detailed information about the selected GameOb-
Inspector Layer Properties ject, including all attached Components and their prop-
erties.
Displays the hierarchy of elements in the scene, and lets
Hierarchy Layers in Timeline view you set up parent-child relationships for different game
objects.
Project Browser Lets you access and manage a project's assets.

The main camera displays the scene and is located in the Hierarchy. To show a Harmony object, you must add a
special component. With the main camera selected, in the Inspector, select Add Component > Scripts >

Harmony Camera.
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Inspector (Unity) =
Scene view (Unity) = Perspective view (Harmony) Game view (Unity) = Camera view (Harmony) Layer Properties (Harmony)

21.18 FPS

E~EEwmAA™

Hierarchy (Unity) = Layers in Project Browser (Unity)
Timeline view (Harmony)

Importing Harmony Files Directly into Unity

How to import Harmony files directly into Unity
1. Create a Unity 2D project.

2. The SDK Harmony project needs to be imported to your project in order for the assets to be brought in. Do
one of the following:

» Gotothe Unity Asset Store (assetstore.unity3d.com/en/#!/content/31211) and save the Harmony
Game SDK file on your computer. Then import it in your project from the following: Top Menu >
Asset > Import Package > Custom Package.

» Search for the Harmony Game SDK in the Unity Asset Store, then download and import the
package. You can access the Asset Store from the following: Top Menu > Window > Asset
Store.

NOTE: For each new Unity project, you must repeat step 2 as it contains the necessary files and folders to
make the Harmony import process work.

3. Add the exported game object to the scene by going to Top Menu > GameObject > Harmony >

» Harmony Object: Lets you browse for the exported Harmony project folder. If you've already saved this
to your StreamingAssets folder, you can browse to it through there. Then it adds the Harmony scene to
your Unity file, and sets up the rendering, audio, and animation scripts you need to get going.
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» Harmony Texture Object: Lets you browse for the exported Harmony project folder similarly to
Harmony Object, but creates a Unity plane to render your animation on it.

Importing your Hamony files from an empty GameObject

GameObjects are the fundamental objects in Unity that represent characters, props and scenery. Basically
everything you create in Unity will be a GameObject. There are two main types of GameObject you can use to
import Harmony data:

Create Empty: This creates a regular GameObject in which you can load the exported Harmony data. All
the individual body parts on the sprite sheet come in as separate elements, but are treated as one whole
object with a dynamically created bounding box. If you put a transparency on this object, you would see
the overlapping transparencies of all the individual objects. This creates a higher-quality render and should
be the default if you're not animating the transparency of an object. With this option, direct rendering will
read the depth information in the scene but not write it. Note that with this option, the rendering cannot be
customized.

Create Other > Plane: Renders the entire character to a plane. This renders your character to texture
data. If you animate the transparency of the plane, then the transparency of the rendered output is
animated; you won't see the transparencies of the overlapping elements. However, you will have one
static bounding box the size of the plane that you render to.

Use this option when you want to animate the transparency of a character in a scene. Also, you can write
your own custom shaders. Simply set the Render Target to eRenderTarget. You can see an example of
this in the sample project DemoRenderTarget.

To understand fully the process, here's are two examples using an empty GameObject and a plane GameObject
with the SpaceCat demo file. Everything you do will be based on the GameObject you create to load your
Harmony data.

How to use an empty GameObject

Select GameObject > Create Empty.

Rename the empty GameObject so it's clear in the Hierarchy. Since we're using the SpaceCat demo file,
rename the GameObject to SpaceCat by doing one of the following:

» Double-click on the name and rename it in the Hierarchy.

» Select the GameObject and rename it in the Inspector.

At this point, it’s an empty object. Accessing Harmony data is done through scripts.

» Select the SpaceCat GameObject.
» Inthe Inspector, go to Add Component > Scripts > Harmony Renderer.
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£] Harmony Renderer
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new section appears in the Inspector called Harmony Renderer (Script).

This will let you load an animation file. You must put the path of the asset relative to the HarmonyResources
folder. Before this, you must export from Harmony directly to this folder, or manually copy and paste the data
here.

You exported a scene called SpaceCat. In the Project Folder, place HarmonyResources/SpaceCat under
the Transform information at the top, under Scale. Set the values to 0.01 for X, Y, and Z because the default
Harmony project is foran HD screen.

You won't see anything until you define a few parameters:
» Set the Clip Name Size to 1. A second field will appear, Element 0.

» Enter the clip name for the animation you want to load.

Double-check on the right Clip Name to put in Element 0; you can check the output you exported from Har-
mony.

Double-check the stage . xm1 file, which was exported to the folder you specified when exporting from Har-
mony. Our default export path is to StreamingAssets, so it will automatically load in the game engine.

Look in the Project tab, under Assets > StreamingAssets > HarmonyResources > [ExportName].

You'll find the data that was exported. In this case, we're looking for SpaceCat. Select the file marked stage
to load the data you want to double-check.
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10.

The name to use for loading the object is the stage name. In this case, SpaceDuck_SpaceCatIdle.

If your GameObject has animation in it, and you want it to load the animation data from the Harmony
export, add one more component by doing the following:

» Select the GameObject.

» Inthe Inspector, select Add Component and select Scripts > Harmony Animation.

To loop the animation, you must set a GameObject to define it:

» Select GameObject > Create Empty and rename it: LoopAll.
» Click the LoopAll GameObject to display its properties in the Inspector.
» Click Add Component > Scripts > Loop All.

When you play the animation, it will loop as it plays back. The Loop All command simply iterates on all
GameObjects on runtime and asks them to loop, which is useful when testing the animation. When
programming the actual game, you should write additional scripts to control the different elements
separately.

How to use a plane GameObject

a ~ v Dd o=

Select GameObject > Create Other > Plane.

Select Add Component > Scripts > Harmony Renderer.

Set Size to 1 and Element to 0 on the clip name as per previous instructions.

Set Render Target to eRender Texture.

Render Texture Viewport:

» X: To reposition the animation correctly; it should be -¥ the width of your Harmony project.

» Y: Toreposition the animation correctly; it should be -%2 the height of your Harmony project.
»  W: Width of your Harmony project
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» H: Height of your Harmony project.
6. Use the custom Shader created by Toon Boom to have a transparent background with premultiplied alpha
channel. This is what produces nice, antialiased drawings in your output.

7. With the Plane selected in the Inspector, go to Mesh Renderer > Materials. Under Element O, select
UnlitTransparentPremultiplied.

8. If you're starting with the Toon Boom demo project, this renderer should already be loaded in your list.

® UnlitTransparentPremultiplied

You can also write your own custom shaders and use them here.

9. You must also add the animation component. Select the Plane. In the inspector, click Add Component >
Scripts > Harmony Animation.

Attaching Props to Anchors in Unity

Once your Harmony GameObject is imported, you should be able to see your character both in the Scene and the
Hierarchy views. From here you can attach one or several props to an anchor.

How to attach the prop to an anchor

1. Open up your character in the Hierarchy view to have access to both the props and the anchors.

2. Click on the prop you wish to attach, and drag it onto the appropriate anchor.
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Repeat these steps for each prop and anchor in your project.

In the Inspector view, under Frame, you can select which frame you wish to show. If you only had one
drawing in your prop, then you will not have multiple options.

5. If part of your character is cut off by the plane of the character, now that the props are showing, you will
need to regenerate the mesh. To do so, select your GameObject. After this is done, go to Inspector View
> Render > Generate Mesh.

Placing a Target in an Imported Animation

It's possible that after importing the Harmony animation into the Unity scene, you may want to assign a target to
some piece of the animation. For example, in the Space Duck scene, the character has a gun. Perhaps you want
to attach some other action, such as shooting spheres and cubes out of the end of the gun.

You can see some examples of this in the provided Unity project. The first example in the demo scene is called
DemoLocatorwhich shows a simple cylinder attaching to the end of the gun.

The second example called DemoCallback shows the gun shooting spheres and cubes.

When you set up your character in Harmony, you can access any drawing layer in Unity later and use its pivot
point to attach things. For this reason, you should set the pivot points on your drawing layers with the Rotate tool.

You can also create an empty drawing layer. Use Create Empty Drawing to create a blank drawing, ensuring that
this drawing layer will be exported. Then you can use the Rotate tool to set the pivot point on this drawing layer. In
the Space Duck example, an empty drawing layer called hook _gun was created on which you can attach the
locator.

When you access the imported Harmony character in Unity, you can access the data with a script.

How to set a target to a part of a character

1. Select Game Object > Create Empty to add a new GameObject to extract the target's position, rotation,
and scale.

2. Drag and drop the new object so that it's a child of the character.

It becomes indented.

1. Rename the GameObject to: Hook Gun.

Hook Gun
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2. Inthe Inspector of the target object, select Add Component > Scripts > Harmony Locator.

3. Enter the name of the drawing layer to which you want to attach.

Right-aligned text

Add Component

4. Tofind the exact name for the Locator Name, look at the skeleton . xml file in the Streaming Assets folder.
You canfind it in Streaming Assets > Harmony Resources > Name of Harmony File > skeleton.

All the drawing and peg layers are listed. In this example, look for space_duck _hook_gun. Having drawing
layers with distinctive names makes them easy to recognize when you need to retrieve them.

You can copy the name of the layer into the Locator Name to see the Transform information updating
dynamically as you run the simulation.

5. Now you can attach anything as a child of this Locator Object. For testing purposes, you could attach a cyl-
inder for example. In a real example, you’d want something to shoot out of the end of the gun, so you can see
the Callback example to verify how that works.

Bounding Boxes and Collisions

Extracting the bounding box information is useful when you want to make something collide with your character.
When you put a 2D character into a 3D scene, you may want to use Physics to make the 2D character collide with
the 3D plane. To use the following scripts, you will need Unity 4.3 or higher.

In the Demo scene, open the DemoPhysics example to see collisions and bounding boxes. In this example, there’s
a 3D plane and some 2D characters. The 2D characters have a collision defined with their bounding box, and they're
also reacting to the physics of the scene to fall with gravity.

Colliders were improved to provide several different types of colliders for use in Unity. You can select polygon
colliders and box colliders for a more accurate bounding box.

How to enable a collision based on the bounding box of the character

1. Select yourimported character.

3. Intheinspector, select Add Component > Physics 2D > Box Collider 2D.
4. Toenablethe Physics on the character, go to Add Component > Physics 2D > Rigid Body 2D.
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NOTE: You can also use 3D physics on the imported files.

You can now adjust the variables and see the results.

Working with Audio

When you create scene files in Harmony with audio, the audio is exported into the project folder. However it’s
important to understand how the game is built to determine the best way to handle audio.

When a game is built from Unity, it creates its own database for holding the assets. Within the export, the
Streaming Assets folder is preserved intact. This is what enables the Toon Boom plugin to access those assets
on the fly, and render them in the camera to create the final animation you see on the screen.

However when it comes to audio, the game first looks for the audio in the Unity database. So this is the most
efficient place to store the audio for the real game.

Unity

Streaming

Assets

Database

1. Looks here first 2. Copies from here
to Unity Database

If audio can't be found in the Unity database, then the game looks in the Streaming Assets folder to find the audio.
When it does, it copies the audio on-the-fly back into the Unity database. Since this action is quite costly, don’t
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leave the audio in the Streaming Assets folder for the final game. It’s fine to leave it there while you're testing, but not
for the final game.

The audio should be copied back into the Unity database, either manually or by automating this process with a
script.

Export to Sprite Sheets

The Export to Sprite Sheets window export to multiple resolutions, generating multiple .xml files and one or multiple
sprites sheets depending how many sprite resolutions you defined.

This saves different animations of the same character into the same name. For example, if there's an idle, run, and
jump animation, these should all share the same Save Name. You can think of it as the overall collection of
animations. Inside are the different saved scene versions whose drawings you can reuse for all the animations in
that character set. Each scene version will be displayed as an item in the list.

When you export an animation, only the drawings used in that scene are exported. All the drawings are exported
individually first and then atlased together into a sprite sheet.

If you saved multiple animations to the same Save Name (i.e. SpaceDuck: run, idle), then it will reatlas the sprite
sheet to include all the drawings from all the animations in that folder, creating a new animation file, but reusing the
same skeleton.

Cancel
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How to access the Export to Sprite Sheets window

1. From the top menu, select Windows > Toolbars > Game.
The Game toolbar appears above the Camera view, to the left.

Export to Sprite Sheets  Export to Easel JS

BT

Toggle Anchor Toggle Prop

2. Click the Export to Sprite Sheets ﬁﬁ button.

Parameter

Description

Select Directory

Save Path

The folder path where you want to save your export.

Save Name

The folder name in which you will save your export. This will also be the name
of your asset in Unity. Your scene file name will be used as the clip name.

Existing Clips in Folder

Overwrite Project

The folder name in which you will save your export. This will also be the name
of your asset in Unity. Your scene file name will be used as the clip name.

Clear Texture Folder

Removes any information from the texture folder within the Harmony file. This
has no incidence towards the Unity export but contributes to a lighter Harmony
file.

Project Settings

Unit Scale

Lets you change the scale when exporting to Unity to accommodate the size of
the export without it affecting the Harmony scene. This helps you resize
assets properly for Unity without having to resize them in Harmony. The basic
scale is one Animation Field for one Unity unit.

Sprite Sheet Preferences

This is a value, in pixels, for the maximum width and height the exported sprite

Max Width sheet should be. By default, both values are set to 2048 pixels.
Max Heiaht Makes linear values for interpolation. This increases the amount of memory
9 used but frees up the calculation so it is not done on the fly.
Expand Sprite Sheet Uses the minimum size necessary up until it reaches the maximum resolution.
Fixed Sprite Sheet Creates a texture of the specified size (Max Width and Max Height) even if it

does not fill it up completely by all the drawings in your scene.

Resolution Type

POT: Exports to sprite sheets with sizes that are a power of 2. For example:
1024 x 1024. This is optimized for many graphics cards, but consumes more
memory.

NPOT: Some game engines are optimized specifically to render to non powers
of two, so that it will avoid those numbers. Example: 1000 x 1000.
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This option works in tandem with the Threshold option. The export will
compare the drawings in your project to reuse a maximum of similar drawings
Reuse Frames and reduce the amount of information found in the sprite sheet, making it
lighter. The export will omit the creation of new drawings if the difference is
less than the threshold percentage.

Calculates the differences between multiple drawings. A 2% threshold will
prevent the creation of a new drawing if the drawing is too similar to an existing
drawing. For instance, with a 2% threshold, and my drawing is 100 pixels big,

Threshold only 2 of those pixels need to be different from my other drawing in order to
create a new one. The higher the threshold, the fewer similar drawings you will
have.

Sprite Resolutions Size of the render of the individual sprite, when it exports each drawing out.

Makes linear values for interpolation. This increases the amount of memory

Precalculate Curves ) .
used but frees up the calculation so it is not done on the fly.

Export to Easel JS

The Export to Easel JS window lets you a flattened image sequence of your animation. Even if you have a fully
rigged puppet or a single drawing layer with your animation sequence, the outcome will still be a flattened output of
each frame, grouped together in your sprite sheet. This allows for more flexibility and freedom of work as you have
access to any tools or effect modules you want to use. However, this can result in heavier files depending on the
length, complexity and export size of your animation.
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How to access the Export to Easel JS window

1. From the top menu, select Windows > Toolbars > Game.

The Game toolbar appears above the Camera view, to the left.

Export to Sprite Sheets

Toggle Anchor

Export to Easel JS

2. Click the Export to Easel JS &; button.

Parameter

Description

Select Directory

Save Path

The folder path where you want to save your export.

Save Name

The folder name in which you will save your export. This will also be the name
of your asset in Unity. Your scene file name will be used as the clip name.
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Existing Clips in Folder Displays the clips in the folder.

Scene Options

Here, you must select the Display of your character. This is the one that will be
used to render out all of the information attached to that Display node. If the
Unconnected_Display option is selected, all of the visual information in your
scene will be rendered out.

Display

Sprite Sheet Preferences

Max Width This is a value, in pixels, for the maximum width and height the exported sprite

Max Height sheet should be. By default, both values are set to 2048 pixels.

Expand Sprite Sheet Uses the minimum size necessary up until it reaches the maximum resolution.

Creates a texture of the specified size (Max Width and Max Height) even if it

Fixed Sprite Sheet does not fill it up completely by all the drawings in your scene.

POT: Exports to sprite sheets with sizes that are a power of 2. For example:
1024 x 1024. This is optimized for many graphics cards, but consumes more

Resolution Type memory.

NPOT: Some game engines are optimized specifically to render to non powers
of two, so that it will avoid those humbers. Example: 1000 x 1000.

This option works in tandem with the Threshold option. The export will
compare the drawings in your project to reuse a maximum of similar drawings
Reuse Frames and reduce the amount of information found in the sprite sheet, making it
lighter. The export will omit the creation of new drawings if the difference is
less than the threshold percentage.

Calculates the differences between multiple drawings. A 2% threshold will
prevent the creation of a new drawing if the drawing is too similar to an existing
drawing. For instance, with a 2% threshold, and my drawing is 100 pixels big,

Threshold only 2 of those pixels need to be different from my other drawing in order to
create a new one. The higher the threshold, the fewer similar drawings you will
have.

Sprite Resolutions Size of the render of the individual sprite, when it exports each drawing out.
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Chapter 12: Troubleshooting

Unity Questions

Q. My Harmony asset does not appear in the Unity Editor.
A. There are several possible reasons for this. Check the following:
» Has the HarmonyRenderer plugin been copied to the Assets/Plugins directory? The plugin is named
HarmonyRenderer .bundle on Mac OS X and HarmonyRenderer.d11 on Windows.
» s the clip name valid ? Make sure the clip name exists in the stage.xml file.
» Are the binary files up to date? If you updated the Toon Boom Game Engine SDK to a newer version,
make sure to regenerate the binary files if you use them so they’re compatible with the SDK.
Q. My Harmony asset does not appear in iOS or Android when exported from Unity.

A. There are several possible reasons for this. Check the following:

» Make sure the Harmony assets are copied in the StreamingAssets directory. Since the
HarmonyRenderer plugin cannot use Unity’s asset database, the Harmony assets were packaged as
plain files so they are accessible to the plugin.

» Is the plugin for iOS the same version as the one used for the editor? The plugin for iOS is in the
Assets/Plugins/iOS directory.

» Is the clip name spelled correctly? Windows and Mac OS X aren’t usually case sensitive file systems, but
iOS and Android are. This implies that an asset that is visible on the editor will not appear on the mobile
platform because it cannot be found.

» Make sure the size of your sprite sheets does not exceed the hardware limit of the device you're working
on. Otherwise, the texture might not appear at all.

» Is the path to the project folder an absolute path? If it is, it might not work on the mobile device as that
path will not exist on the platform. Make sure to use relative paths to the StreamingAssets directory.

Q. My Harmony asset does not composite properly with other 2D sprites in Unity. The 2D sprites always appear
behind the Harmony assets even if | change the order index in the GameObjects.

A. The 2D sprites from Unity and the Harmony assets cannot currently composite together. There are, however,
several solutions for working around this problem:

Use 2D textures instead of 2D sprites. The 2D textures, when attached to a geometry in Unity, will composite like
the other 3D elements in the scene and you can change the compositing order by incrementing or decrementing the
Z value of the transform.

Use multiple cameras to render your scene in parts. Here’s how:

Harmony Camera
1. Create a new camera.
2. Make sure you set the Harmony GameObijects to a specific layer (top-right of the game object inspector).
3. Inthe camera, set the culling mask to this layer (and the other layers you want rendered in the background).

4. Addthe HarmonyCamera component to this camera so the Harmony GameObjects render properly.

Sprite Camera
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1. Create a new camera.
2. Make sure to set the 2D sprite objects to a specific layer.

3. Inthe camera, set the culling mask to this layer (and the other layers you want rendered in front of the 2D
sprites).

4. Make sure to set the clear flags to Depth Only or Don't Clear.
5. Set the depth to be higher than the Harmony camera.

6. Afterwards, if you move the camera, make sure to move both cameras simultaneously if you want to keep
Game Ojects in sync.

Q. How can you specify the frame rate of the animation? My animation does not play at the same frame rate in
Harmony and in the Game Previewer in the Unity Editor.

A. The Game Previewer previews the animation at a default of 24 frames per second. In your game, using the
HarmonyAnimation component, you can schedule animations at the speed you want.

Example
HarmonyAnimation animation = GetComponent<HarmonyAnimation>() ;
if (animation !'= null)
{
animation.PlayAnimation( frameRate, clipName ) ;
}
Q. | cannot see my character in the Scene view in Unity. Is there any way to preview the Harmony asset?

A. Since the rendering of Harmony assets is implemented in a plugin, it does not update any Renderer component
in the GameObject, and so cannot be shown directly in the Scene view.

However, you should still be able to preview your assets in the Game view (even when not playing). To help find
and position assets, we also added bounding box shapes rendered in the editor and the Game view.

Q. How is memory management handled in Unity for Harmony assets?

A. Most of the memory extensive algorithms are executed in the C++ plugin. The data structure is maintained
alive as long as a GameObject refers to it. This means you can instantiate as many clones of a character without
reloading the data. Upon destruction, the GameObject will issue a clean-up call to the plugin and delete its
associated rendering object. The sprite sheet and animation data are kept alive as long as a single GameObject
uses them and a cleanup call is issued once they are destroyed.

Q. The Harmony assets memory does not appear in the Unity profiler. Can we profile the assets memory?

A. The Unity profiler does not pick up Harmony assets in its traces. Since the Harmony GameObject refers to a
C++ plugin for its asset management and rendering, its memory cannot be recorded in the profiler. Profilers such
as the one provided with XCode or Visual Studio should allow you to track your application’s memory including
the Harmony assets and should also provide a more accurate result.

General Questions

Q. How can you specify the resolution used for the drawings in the sprite sheet?
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A. The drawing resolution is not fixed in Harmony. Since you're exporting the scene to multiple sprite sheets in
multiple resolutions, every drawing will have a different resolution in the end. You can use the Drawing view to see
the resolution of a drawing compared to the rest of the scene. By enabling the light table in the Drawing view, you will
see all of the scene’s drawings untransformed in the same proportion as they will appear in the sprite sheet. More
specifically, the resolution used in the sprite sheet for a drawing is the size it appears untransformed in the Camera
view, scaled to the sprite sheet resolution ("Sprite Resolutions" in the Export Sprite Sheet dialog box).

Once you know that, you can easily adjust the size of a single drawing. Use the Select tool to scale down a drawing
and use the Transform tool to scale it back up so it does not change visually in the Camera view. This should allow
you to alter the size of drawings in the sprite sheet.

Q. The assets take time to load on mobile devices. Is there any way to speed up the process?

A. Harmony exports an interchange XML format that is intended to be compatible with multiple game engines.
However, reading data from the XML files is slow and this is mostly intended to test the assets in your project. At
some point, they should be converted to a binary compact data structure that can be read into memory a lot faster
than the XML.

You can use the XmI2Bin tool provided with the game engine SDK to convert your XML files to binary. This tool is in
the Utils/Xm12Bin folder and a precompiled version for Mac OS X is available in the Utils/macosx folder.

Q. There are problems with the character | exported in the game engine. Pieces are not exported or are not showing
in the proper order. What can | do ?

A. To integrate with the game engine SDK, all animations in Harmony must follow certain guidelines. Here are some
of the key points for building a character that is compatible with the rendering in the game engine SDK:

» Build yourrig in the Timeline view. The game engine SDK data structure is similar to what is displayed in
the Timeline view and an advanced node system might not always export properly.

» Because every top level node in your scene will render separately in the game engine SDK, they may not
intersect. A top level node is also isolated in its separate sprite sheet to allow the artist better memory
segmentation of the character. If you created a character with top level nodes and this was not the
intended result, create a top level group or peg to group them all together.

» Use micro-Z ordering if necessary. With no Z ordering, a child layer will appear behind its parent (as it
does in Harmony). To change the ordering, add some Z offset to the child layer.

» The export script does not handle plain bitmap images. Toon Boom vector drawings and Toon Boom
bitmap drawings are supported though.

» The export script does not handle symbols.
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Glossary

3D stereoscopic

The ability to create stereo images which, when animated and viewed through 3D active
shutter glasses or using glasses with one red and one blue lens, will appear as a three-
dimensional movie.

alpha channel

An image channel that carries transparency information. An image already has three
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The
matte, or the transparency information, is stored in this fourth channel. An image without an
alpha channel is always opaque.

animatic A movie with sound that is developed from the storyboard. The storyboard panel is exposed
for the duration of the scene and at times, the characters are placed on a trajectory to
indicate motion. The camera moves are also animated. The animatic is used to determine
the rhythm of a project and provides a good overview of the project before beginning
production.

animation A simulation of movement created by displaying a series of pictures or frames.

anime An animation style known for its sinister and dark feel; popular in Japan.

arc Action rarely occurs in a straight-forward manner; rather it typically unfolds in what

storytellers refer to as an arc. The purpose of a story arc is to move a character or situation
from one state or scenario to the next.

aspect ratio

The relationship between the width and height dimensions for any scene, frame or film
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which multiple drawings are
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned
consecutively, without further user intervention.

automatic lip-sync
detection

Automatically mapping drawings in an element to the mouth chart generated for a sound.
This can save time when lip-syncing a voice track.

axis

An imaginary line around which an object rotates.
For 2D graphics, there are two axes: X (horizontal and Y (vertical).
For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).

In animations that constantly rotate, the axis element specifies what axis the object rotates
around. A negative number causes an animation to rotate counter clockwise whereas a
positive number causes an animation to rotate clockwise.

background

The part of a scene that is farthest to the rear. The background is the artwork, or decor,
against which the animation takes place.

Bézier

A method of defining curved lines invented by French mathematician Pierre Bézier. A Bézier
curve is a mathematical or parametric curve. Bézier curves use at least three points to
define a curve.

bitmap

An image composed of pixels with a single resolution (size). If it is enlarged too much, it will
lose definition and individual pixels will begin to appear. This is known as pixelation.

Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each
individual pixel contains a value that represents a specific colour.
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breakdown

In cut-out animation, breakdown is the action of breaking a character into pieces to create a
puppet with articulations. To break down a character, the artist cuts parts, such as the
hands and arms, from the character's model and pastes them in separate layers. Next, the
joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose generally found between two key
poses. The key poses are the main poses in an animation and the breakdowns are
secondary poses, ones that help describe the motion and the rotation curve (usually referred
to as an arc).

camera shake

Camera shake occurs in a scene when the camera moves slightly and quickly in several
directions. This gives the impression of an impact, vibration or, for example, bumps on the
road.

caption

A text field containing dialogue, effects, sound or slugging information in a storyboard.

cel

In traditional animation, a cel (also known as celluloid) is a transparent sheet on which the
animation is inked and painted before being sent to the camera. The picture's outline is
drawn on the front of the cel and then coloured along the back.

character design

Each character in an animated film is drawn from multiple angles in poster-style format,
called a model sheet, which serves as a reference for the animators.

chromatic In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of

aberration distortion in which there is a failure of a lens to focus all colours to the same convergence
point.

clean up After rough drawings have been tested and approved, all the noise in the image (excess
lines, notes, etc.) is removed to create final drawings which can be inked, painted and shot.
The clean up process refers to either tracing a clean line over a rough drawing to achieve the
final version or removing dirt and extra lines left by the scanning process.

CMYK Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model used in a
process called offset printing.

colour card A colour card is a card containing one solid colour that is the same size as the camera. The
colour card fills the background with a solid colour when there is no background image
included.

colour model The official colour design that must be used to paint the animation. A model is the definitive
character, prop or location design that each artist must follow for the production.

colour wheel A display of the colour spectrum in the form of a circle.

compositing Compositing is the action of incorporating all of a scene's elements to create the final result

prior to rendering. For example, the compositing artist will import all the animation
sequences, background, overlays and underlays in the scene and position them correctly.
The artist will then set the camera frame and animate it, if needed. Finally, the animator will
create all the computer-generated effects for the project.

cross dissolve

An effect used to fade two scenes, one into the other.

cut

A direct transition between two scenes. When a cut is used, there are no transition effects
inserted to pass from one scene to the next. The first scene ends and the second one starts
immediately.

cut-out animation

The process known as cut-out animation is the action of animating characters made out of
several pieces by moving them around frame by frame. Cut-out animation can either be
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computer generated or done traditionally using paper.

cycle A group of images that together make up an action, such as walking. A cycle is an action
repeated as a loop over a period of time. It can be a series of animated drawings or
keyframes.

dialogue The text spoken by a character in a movie or animation.

dope sheet Used by animators, directors and other members of a crew to track the sequence and timing
of images, dialogue, sound effects, sound tracks and camera moves. Also known as an
exposure sheet.

doping To assign a particular drawing to a range of frames.

double bounce
walk

In the key frames and passing positions in a double bounce walk, the body is lower than a
reference line drawn in the upright position. During the in-betweens, the body is above this
line giving the appearance of a bounce.

DPI Dots perinch is the standard measure of resolution for computerized printers. It is
sometimes applied to screens, in which case it should more accurately be referred to as
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease In animation, the ease, also known as velocity, is the acceleration and deceleration of a
motion. It can be a motion created by a function curve, or a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.

ease-out Gradual deceleration in the action. Also known as slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a sequence is happening. For
example, if a child is playing on the ground in front of his house, the establishing shot would
be a scene where the viewer can see the house, the ground, a part of the street and the
buildings around the central point of action. This helps the viewer understand the story
location and scene orientation.

exposure

In animation, an exposure is the number of cels on which a drawing appears in the scene.
For a drawing to appear longer, the exposure must be extended over a greater number of
cels.

exposure sheet

A sheet with several vertical columns and horizontal frames used to indicate a scene's
timing. Each column represents a scene layer. The drawing numbers in each column are
indicated and repeated over the particular amount of frames they need to appear.

The exposure sheet is used by animators, directors and other members of a crew to track
the sequence and timing of images, dialogue, sound effects, sound tracks and camera
moves. Also known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a sequence. A fade in occurs
when the first scene appears progressively, from complete transparency to its complete
opacity. A fade out occurs when the last scene progressively disappears, going from
complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.
fast-out Dramatic acceleration at the end of the action.
field A measurement unit used to calculate motion, registration and camera positioning. A

standard animation scene will vary between 6 to 12 fields.
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field chart

A guide containing all the field units that animation and layout artists use to determine a
scene size or camera motion.

film-1.33

A resolution that is ideal for the widescreen film format that conforms to the standard 4:3
pixel aspect ratio.

film-1.66

A resolution that is ideal for the widescreen film format that conforms to the 16:9 pixel
aspect ratio. (The pixels are wider than they are high).

flipping

In traditional animation, flipping is the action of going through the drawings of an animation
sequence very quickly in order to see the animation in motion. Flipping can also be the
action of creating a mirror transformation of an object.

follow-through

The secondary motion caused by the main action. For example, a character wearing a cloak
is running. The main action is the body running. This will cause the cloak to follow the
motion, although it will not move at the same time, but react a few frames later and follow
the main motion curve.

forward kinematics

Forward kinematics is a feature used to animate principally 3D characters and cut-out
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a
shoulder, and make the rest of the arm move with it as a single piece.

frame

An animation frame is a single photographic image in a movie. In traditional animation, the
North American standard generally contains 24 frames per second, while in Europe the
standard is 25 frames per second.

frame rate

The frame rate is the speed at which the frames are played. They are generally calculated
by frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60
frames per second or any other number.

This is the measurement of the frequency (rate) at which an imaging device produces
unique consecutive images, called frames. The term applies equally to computer graphics,
video cameras, film cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (fps) and in progressive-scan
monitors as hertz (Hz).

function

A computer-generated motion, trajectory or path on which elements, other trajectories and
effects parameters can be attached. The function can be controlled by adding keyframes
and control points on the function curve.

gamut

The range of colours that a particular device can represent.

HDTV

Acronym for High Definition Television which delivers a higher quality image than standard
television because it has a greater number of lines of resolution. To take advantage of the
superior quality and make full use of your resolution setting, the output device must be
compatible with HDTV technology.

hold

A frame in the animation in which the character maintains its position without moving. A
hold can be created between any two keyframes.

HSV

Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation
(shade) and value (tone or luminance).

in-between

The drawings that exist between the key poses. These are drawn to create fluid transitions
between poses.

ink and paint

The ink and paint process is the action of painting the empty zones and colouring the lines
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on the final animation drawings, while following a colour model.

interpolation

The computer-generated motion created between two keyframes. You have the choice to
create interpolation, or not, between your keyframes.

inverse kinematics

(1K)

A feature used mainly to animate 3D characters and cut-out puppets with hierarchy. Inverse
kinematics will animate a puppet from one of the extremities, such as a hand, and make the
rest of the body follow naturally.

jump cut A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is generally
caused by one scene ending, and a second one starting, with a similarimage. The lack of
difference causes the eye to see a little jump between the two scenes.

key pose Important positions in the action defining the starting and ending points of any smooth
transition. Keys, or key poses, are the main drawings in an animation sequence describing
the motion. For example, if an arm is waving, the keys will be of the arm at one extremity of
the wave motion and the other extremity. By flipping those drawings, the animator can see
the skeleton of the motion without having all the drawings.

keyboard One or more keyboard keys which, when used, cause an operation to be performed.

shortcuts

keyframe Important positions in the action defining the starting and ending points of any action. A
keyframe is a computer-generated position at a specific moment (frame) on a given
trajectory.

layer In animation, a layer is an individual column, level or character. A scene's layers are
superimposed to form the final image.

layout The communication step between the storyboard and the animation. It is the action of

putting the storyboard on model. That is, drawing the character by following the design in the
model pack, so the animator can start working.

The layout artist draws the background, creates the camera and field guide matching the
scene and camera motion. Lastly, the animator draws on model the main action poses.

layout and posing

The action of putting on model (at the right scale) the storyboard for the animator to start
working.

layout artist

The artist who draws the background, and creates the camera and field guide to match the
scene and camera motion. They will draw on model the main action poses.

layout planning

Drawing of the main features of the scene used as reference when planning the animation
and executing the initial stages of it.

layout process The communication step between the storyboard and the animation.

library A storage area containing templates and assets that can be reused in any project or scene.

light table A device that allows you to see other layers in transparency while you are working on a
particular layer.

line of action The direction that the action will follow. Also known as path of action.

lip-sync The process of synchronizing a character's mouth to sounds in the dialogue soundtrack.

The mouth is adjusted frame-by-frame to match the sound of the dialogue and provide the
illusion that the character is speaking. Lip-sync can be used for any sound sequence, not
only speech, you could for instance have a bird chirping or a wolf howling at the moon.

low resolution

A format that is ideal for videos destined for the web, where size and fast download of a
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video file take precedence over quality. A low-resolution image is one that lacks fine detail.

manual lip-sync
detection

The manual swapping of mouth position drawings to match a voice track. For this process,
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing
substitutions are used.

master palette

A group of colours attributed to a character or prop. The palette is used throughout the entire
production to maintain consistency in the look and to ensure that the same colours are used
throughout the production. Also known as palette.

model/colour
model

The definitive character, prop or location design each artist must follow for a production. A
colour model is the official colour design that must be used to paint the animation.

morphing

A feature for creating computer-generated drawings between a source drawing and a
destination drawing. Animation created with the morphing feature can be reused in different
projects.

motion keyframe

A keyframe with computer-generated interpolation.

mouth chart

A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used
to represent silence) used for lip-sync.

multiplane The effect of passing through multiple levels of drawings to create a sense of depthina
shot. A multiplane is a scene in which the layers are placed at different distances from the
camera so that when the camera moves, a depth illusion occurs. With a multiplane, all the
perspective and scale is calculated automatically.

NTSC The standard analogue television broadcasting system used in North America. NTSC
conforms to North American standards on how rectangular pixels are displayed for
computer and television screens.

nudge A small push (left, right, up, down, forward or backward) done with the keyboard arrow keys
on a selected element. Nudging is used to move a selection very slightly and precisely.

onion skin A feature that lets you see the previous and next drawings of a sequence.

overlay A part of the scene environment, such as a chair or a bush, that is placed in front of the main
animation.

PAL A resolution that works best with the European format for television and computer screens,

as the rectangular pixels are displayed at a different orientation.

palette/master
palette

A palette or master palette is a group of colours attributed to a character or a prop. The
palette is used throughout the entire project to maintain a consistency in the look and avoid
the colour changing during the animation. Also referred to as a master palette.

palette style

A palette style is a second version of an existing palette with a slight change in the tint and
value. A palette style can be used to create the night version of a palette. It may also be
called a clone palette.

animation/tradigital

pan To move the camera across the scene in any direction.

panel In a storyboard, a panel is a frame in a shot. A shot can be composed of one or several
panels.

paperless The paperless animation process is the action of animating digitally. The main paperless

animation process is to draw, frame by frame, the animation directly in the software.

passing position

When drawing a walk sequence for a character, the passing position is the point at which
one leg passes the other.
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path of action

Direction that the action will follow. Also known as line of action.

ped In traditional animation, a tool used to ensure accurate registration of action as cel layers
move. In digital animation, in which you are doing a more advanced puppet rigging, you can
use peg layers. Peg layers are trajectory layers that do not contain drawings. They are
motion paths that you can use to add path articulations. For the latter, you can also use an
inverse kinematics tool.

phoneme A unit of sound in a language.

pivot The point around which a peg or drawing rotates.

pixel The smallest element of an image displayed on a monitor or TV screen.

Pixel, short for picture element, is a single point in a graphic image. It is a small sample of
an image, a dot, a square, or a very small section made out of smooth filtering. If you zoom
in close enough on a digital image, you will see the pixels, which look like small squares of
different colours and intensity.

pose-to-pose
animation

The pose-to-pose animation process is the action of creating all the main action poses,
called key poses, and then placing the secondary poses between the keys. The secondary
poses are called breakdown. Finally, the animator fills the gaps with the in-between
drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the computer takes each
pixel that appears on screen and processes all of the components, as well as adding motion
blur before it produces a final image. The process of calculating the final images after the
compositing process.

resolution

The size of a scene, generally calculated in pixels. For example, the NTSC resolution is 720
x 480. The resolution should match the final output: HDTV, film-1.33, film-1.66, NTSC,
PAL, low.

RGB

Red, Green, Blue. A method of defining colour by specifying amounts of these three colour
components.

rigging

The process of attaching the various parts of a cut-out puppet.

rotary table

Equivalent to the animation disk/table, a device that allows you to rotate the workspace for
greater comfort while drawing.

rotoscoping

An animation technique in which animators trace over live-action film movement, frame by
frame, for use in animated films. The act of sketching over live-action footage to create an
animated sequence.

roughs

Rough is a common name in an animation movie for a drawing that is used as a reference
but which does not form part of the final image. A layout is a rough.

The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines and
shapes, but can also contain design details.

safe area

The zone at the center of a scene's frame that is safe from being cropped by the TV frame.
As a TV frame cuts a margin off the original frame size, maintaining a safe area ensures that
the scene's main action will remain clearly visible once the film is screened on television.

scene

A shot in a movie or show. A sequence is composed of several scenes. A scene changes to
another scene by a simple cut or transition.
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script The original text containing all the movie or show information. In animation, the script
contains all of the location descriptions, dialogue, time and more. A project starts with a
script.

sequence A series of scenes or shots forming a distinct part of the story or movie, usually connected
by unity of location or time.

shot A scene in a movie or show. A sequence is composed of several shots. A shot changes to
another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.

slugging To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing

A process that lets you hear sound in real time while you move the playhead forward or
backward. This is very useful for finely-tuning a lip-sync.

stop-motion A keyframe with no computer-generated interpolation.
keyframe
storyboard A visual plan of all the scenes and shots in an animation. The storyboard indicates what will

happen, when it will happen and how the objects in a scene are laid out.

straight-ahead

A technigue in which an entire sequence is drawn from the first position to the last, in order.

animation There is very little planning in this methodology. Where the character ends up and how it
gets there can be a surprise for both the audience and the animator. While this approach is
spontaneous and creative, it can create inaccurate results.

strokes Invisible vector lines forming the drawing zones. They can be adjusted with Bézier handles.

symbol A symbol combines animation, artwork or layers into a single object that you can control in
one layer. You can also create symbols out of each body part in your cut-out puppets.
You can place whatever you want in a symbol. You can use symbols to animate a puppet or
create reusable animations such as blinking.

tablet/pen A device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.

template An asset stored in the library that can be reused in any project. A template can be a drawing,
a series of keyframes, a sound file, a panel, a cut-out character, an effect, a trajectory, an
animation, or anything else used in the animation.

thumbnail A very small image used as a reference or indicator.

timecode The timing information printed on a movie clip to indicate the scene, hour, minute and
second that is currently displayed on the screen.

timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final line or pencil test, each
drawing is traced and painted for the final animation. In today's digital world, this may be
done in a variety ways other than the traditional celluloid or acetate methods.

track breakdown

The break down of an animated film's soundtrack into individual sounds to produce the
precise frame-by-frame position of each sound.

traditional

A type of animation process whereby all the animation sequences are drawn by hand on

538




Harmony 12.2 Advanced - Gaming Animation Guide

paper before scanning or inking them on cels.

trajectory

A computer-generated path or trajectory that elements can follow. The trajectory can be
controlled by control points, keyframes and velocity.

transition

An effect placed between two scenes as they pass from one to the other. Common
transition effects are cross-dissolve and wipe.

underlay

In animation, an underlay is a specific part of the decor placed behind the main animation.

vector

A vector-based image is composed of points and Bézier curves. The computer reads the
points and traces the segments, linking them to reproduce the image shape. There is no
fixed size or resolution in a vector image. The graphic can be enlarged and distorted as
much as desired and the system will simply recalculate the segments and rebuild the
shapes. Vector images are translated and displayed in pixels once the calculation is done.

velocity

In animation, the velocity, also known as ease, is the acceleration or deceleration of a
motion. This can be achieved by a function curve, or via a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle

A series of drawings "on the spot" that describe the walk for a character. The illusion of
movement is created by the use of background pans. To avoid making innumerable
drawings, animators routinely make a walk cycle for a character.

Zone

An area which can be painted with colour.
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Index

alpha channel 531
animatic 531

animating

multiple sequences, gaming 16

animation 531
tips, gaming 16

anime 531

Annotation column 263
erasing annotations 266
pen colour 266
pen width 266

annotations

changing pen colour 266

changing pen width 266
erasing 266
arc 531
aspectratio 531
auto-feed 531
axis 531
background 531
backing up
palettes 205
Bezier 531
bitmap images 531
Bitmap layer 249
bitmap resolution
height 78-79
resolution factor 78-79
width 78-79
Bone deformer
basic rig 408
Bone rig 409
Bone rig

creating 409

breakdown 532
character 348
brush size 25
Brush tool
drawing 21
presets 25,110
size 25
brushes
exporting 48, 127, 164
importing 47, 126, 164
Camera layer 250
camera shake 532
caption 532
cel 532
celluloid
See cel. 532
character building
breaking down 348
character design 532
drawing with brush 21
drawing with pencil 21
getting references 20
preparation 19

sketching model 20

chart
field 23
clean up 532
cleaning
model 34
cloning

layers and columns 262
CMYK 532
Colour-Card

layer 250
colour card 532

colour model 532,536

541

colour palettes
back up 205
location 204

colour swatch
adding 29

colour wheel 532

colours 26

adding colour swatch 29

Column Properties editor

displaying in Xsheet 258

columns
advanced types 251
changing colour 319
cloning 262
collapsing 307
deleting 255
duplicating 262
expanding 307
modifying 259
modifying look 313
navigating 298
properties 256
renaming 260
reordering 261
types 249
Xsheet 248

compositing 532

copying
drawings 302

cross dissolve 532

cut 532

cut-out animation 532
creating 461
selecting layers 465

Cutter
gaming guidelines 15

cycle 533
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cycles

exposure, creating 289
deformation

basicrig 408

Bone rig 409

chain, setting up bone and
articulation 411

gaming guidelines 15
deleting
drawings 301
design tools 19
Override 21
designing
brush size 25
characters 32
drawing with brush 21
drawing with pencil 21
field chart 23
getting references 20
line up 23
preparation 19
relative size 22
sketching model 20
tool presets 25,110
dialogue 533
dope sheet 533
doping 533
DPI 533
drawing
applying thickness stencil 46
brush size 25
Brush tool 21
brushes, exporting 48, 127, 164
brushes, importing 47, 126, 164
characters 32
cleaning model 34

colour swatch, adding 29

colours 26
creating thickness stencil 46
current drawing on top 40
deletiing thickness stencil 47
exporting brushes 48, 127, 164
field chart 23
importing brushes 47, 126, 164
inking model 34
line up 23
model 33
Override tool 21
palettes 26
pencil presets, creating 45
pencil presets, selecting 44
Pencil tool 21, 41
presets, pencil 45
relative size 22
stencils 44
tasks 39
thickness stencil, applying 46
thickness stencil, creating 46
thickness stencil, deleting 47
thickness stencil, renaming 47
thickness stencil, selecting 45
tool presets 25,110

drawing elements
adding 252
creating 247
duplicating 262

Drawing layer 249

drawing tools 19

drawings
copying/pasting 302
deleting 301
duplicating 302
identifying 316
managing 299

542

marking 316

merging 304

navigating 298

renaming 299

repositioning 24
duplicating

drawings 302
ease 533

setting on multiple parameters 474

ease-in 533
ease-out 533
editors
Column Properties 258
Effect layer 250
Element Manager dialog box
parameters 261
establishing shot 533
exporting
brushes 48, 127, 164
erasers 48,127,164
frame-by-frame, gaming 11
pencils 48,127,164
exposure 533
creating cycles 289
decreasing 279
deleting 281
extending 272
extending sequence 273
Fill Exposure mode 269
filling 268
filling empty cells 288
filling selection 285
filling selection randomly 287

filling sequence with single
exposure 284

holding 271

increasing 279
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inserting blank cells 282
moving cells 276
setting 283
typing in values 270
exposure sheet 533
printing 325
extending
exposure 272
exposure sequence 273
fade-in 533
fade-out 533
field chart 23,534
Fill Exposure mode 269
film-1.33 534
film-1.66 534
flipping 534
follow-through 534
forward kinematics 534
frame 534
frame rate 534

frames 245

adding before/after selection 245

navigating 298
functions 534

gaming 9

animating multiple sequences 16

animation tips 16

Cutter guidelines 15

deformation guidelines 15

frame-by-frame export 11
guidelines 13
Harmony 9
raw game data export 10
resources 13
rigging guidelines 14
gamut 534
Gestural Drag mode 279

Group layer 250

HDTV 534

hiding
columns 310
layers 308

Hold 534

holding exposure 271

HSV 534

importing
brushes 47,126, 164
erasers 47,126, 164
pencils 47,126, 164
templates 445

in-between 534

ink and paint 534

inking
model 34

interpolation 535

jump cut 535

key pose 535

keyboard shortcuts 535

keyframes 535

Layer Properties editor
displaying 257
renaming layers 260

layers 248,535
bitmap 249
camera 250
changing colour 319
cloning 262
collapsing 307
Colour-Card 250
deleting 255
drawing 249
duplicating 262
effect 250

expanding 307

543

Group 250

hiding 308
modifying 259
Peg 251
properties 256
Quadmap 251
renaming 259-260
reordering 260

selecting parent or child layer 465

showing 308
Sound 251
types 249
layout 535
layout and posing 535
library 535
Library view
importing templates 445
lighttable 535
line of action 535
lineup 23
lip-sync 535
auto detection 531
lip-sync detection
manual 536

low resolution 535

manual lip-sync detection 536

markers

tempo, setting 324
markers, scene

setting 321
marking

drawings 316
master palette 536
master peg

adding 366
merging

drawings 304
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model 536
cleaning 34
inking 34
rough 35
sketching 20, 33

model sheet See character design

motion keyframe 536
mouth
chart 536
multiplane 536
navigating
columns 298
drawings 298
frames 298
NTSC 536
nudge 536
onion skinning 536
overlay 536
Overrride tool 21
PAL 536
palettes 26,536
backup 205

creating, Advanced Palette List

mode) 28,206

creating, Basic Palette List
mode) 27,206

location 204

style 536
panel 536
panning 536
paperless animation 536
passing position 536
Paste Special

pasting with 303
pasting

drawings 302-303
path of action 537

Peg layer 251

pegs 537
adding master 366
pen 538
pencil line
texture 49
pencil presets 44
creating 45
renaming 47
selecting 44
Pencil tool
drawing 21, 41
settings, modify 42
phoneme 537
pivot 537
pixel 537
pixelation See bitmap image
pose-to-pose 537
presets
creating 25,110
pencil 44
pencil, creating 45
pencil, selecting 44
printing
exposure sheet 325
Quadmap layer 251
relative size 22
renaming
drawings 299
rendering 537
repositioning
drawings 24
resolution 537
factor, bitmap 78-79
height, bitmap 78-79
scene 78-79
width, bitmap 78-79
RGB 537

544

rigging 537
adding master peg 366
basic deformation rig 408
Bone rig 409

chain, setting up bone and
articulation 411

gaming guidelines 14
rotary table 537
rotoscoping 537
rough

models 35
roughs 537
safe area 537
scene markers

setting 321
scene resolution 78-79
scenes 537

adding frames before/after
selection 245

extending 245
removing frames 247
setting length 245
script 538
scrubbing 538
sequences 538
shot 538
showing
columns 310
layers 308
size
brush 25
relative 22
sketching
characters 32
model 20, 33
slow-in 538
slow-out 538

slugging 538
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sound
scrubbing 538
Sound layer 251
stencils, thickness
applying 46
deleting 47
pencil 46
renaming 47
selecting 45
thickness 44
stop-motion keyframe 538
storyboard 538
straight-ahead 538
strokes 538
tablet 538
templates 538
creating 435
importing 445
tempo markers
setting 324
textures
pencil line 49
thickness stencil 44
applying 46
deleting 47
pencil, creating 46
pencil, selecting 45
renaming 47
thumbnails 538
tick marks, Xsheet
turning off 268
timecode 538
timeline 538

Timeline view

modifying layers and columns 259
renaming layers 259-260

reordering layers 260

timing

adding frames before/after
selection 245

Annotation column, adding 263
creating cycles 289

decreasing exposure 279
deleting exposure 281

erasing annotation 266

extending exposure 272
extending exposure sequence 273
extending scenes 245

Fill Exposure mode 269

filling empty cells 288

filling exposure 268

filling selection randomly 287
filling selection with sequence 285

filling sequence with single
exposure 284

frames 245

holding exposure 271
increasing exposure 279
inserting blank cells 282
moving cells 276
preparing 243

references 244

removing frames 247
scene length 245

setting exposure 283
setting scene markers 321
setting tempo markers 324

typing in exposure values 270

tools

Override 21
trace and paint 538
track breakdown 538
tradigital 536
traditional animation 538
trajectory 539
transition 539
underlay 539
vector 539
velocity 533, 539
walk cycle 539
Xsheetview 259

adding frames before/after
selection 245

advanced column types 251
Annotation column, adding 263
cloning layers and columns 262

collapsing/expanding 3D path or
rotation columns 308

columns 248
displaying thumbnails 319
erasing annotations 266

expanding and collapsing
layers/columns 307

layers 248
modifying layers and columns 259
printing exposure sheet 325
removing frames 247
renaming columns 260
reordering columns 261
showing/hiding columns 310

zone 539

tips
cloning layers and columns 262 gaming animation 16

expanding and collapsing

tool presets
layers/columns 307 P

creating 25,110
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