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Chapter 1: Cut-out Animation - An Introduction
Harmony is a high-performance animation software which not only offers a wide range of features, but also handles
more than one animation type and workflow. In this guide, you will learn how to perform tasks related to the cut-out
animation workflow from start to finish using Harmony.

Before reading this guide, be sure to take some time to familiarize yourself with the basic concepts in the
Fundamentals Guide. Each chapter is self-contained. so you can concentrate only on the chapter pertaining to your
task. You do not need to read the entire guide, but you should read the whole chapter before starting to work.

Topics in this section:

• Design and Drawing Tools on page 9

• Colour Styling on page 99

• Timing on page 135

• Character Building on page 181

• Library on page 255

• Cut-out Animation on page 279
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• Deformation on page 231
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Chapter 2: Design and Drawing Tools

Another important step in the project creation is the character, prop and location design. This determines the style
andmodels to follow for the entire project.

This is also the step where you will need to usemost of Harmony's drawing tools.

The design can be created on paper and scanned in or it can be created digitally. You can draw and even create the
colours entirely on paper, while others like to design on paper and scan the drawings to create the colour model in a
software program. Themost popular method is to design directly in Harmony.

To save paper and time and avoid having to recreate colour palettes, Harmony gives you the ability to design all
elements directly in the application. This keeps all your work within the same software, avoids using a lot of paper
and losing time scanning in elements and importing them.

The character and prop design process is divided in three steps:

• Preparation on page 9

• Sketching theModel on page 10

• Cleaning and Inking theModel on page 24

Harmony has an extensive set of drawing tools that can be used to design your characters. You can learnmore
about this in the following topic:

• Drawing Tasks on page 25

Each drawing tool has a series of options to customize its behaviour and drawing style. You can learnmore about
them in the following section:

• Drawing Tool References on page 61

Preparation
To prepare for the design task, you will need to go through a few steps:

• Getting References on page 10

• Using theWorkspace on page 10
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Getting References

Creatingmodels requires twomain reference sources, the script and the storyboard. Once you have the script in
hand, you can learn about the characters and their personalities, the props, the ambiances, and so on. This will be
your main reference, so it is very important to read it carefully.

The storyboard is the second reference source and it can be quite useful as well. Although it will not yet be the
final version of the storyboard, it will show you what the character is doing and what props need to be designed.

Using the Workspace

Once your scene is created, you can open it and set your workspace.

To sketch the characters, props or locations directly in Harmony, you will mostly use the Camera or Drawing
views along with the Colour, Timeline and Tool Properties views.

Sketching the Model
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Now that your references and scene are created, you can start designing. To draw your characters, props and key
locations, you will need to learn the following:

Drawing with the Brush or Pencil Tool

The Brush tool takes account of pressure sensitivity, allowing you to create lines with variable thicknesses
when using a pen tablet, creating a contour vector shape. You can set different parameters, such as the size and
smoothness of the Brush tool in the Tool Properties view. If you draw with the Brush tool and want to modify the
thickness variation, use the Contour Editor tool.

The Pencil , Polyline and Shape tools let you create a central vector line of uniform thickness. Pressure
sensitivity is not supported with pencil lines. You can set different parameters, such as the size and smoothness of
the Pencil tool in the Tool Properties view.

Override Tool

TheOverride tool lets you increase productivity by rapidly switching between tools used for short tasks and your
previous tool. Most drawing tool shortcuts are accessed using the Alt key followed by another key, such as the
Eraser tool which is accessed by pressing Alt + E.

If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold down the E key
while you are erasing. Once you are done, release the E key to return to the previous tool; in this case, the Brush
tool. You can do the same for most drawing tools that have a shortcut composed of Alt followed by another key.
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Relative Size

The size relation between the props, characters and backgrounds is very important in maintaining consistency
and structure throughout the project.

A production can contain many characters and props. It is not unusual for these to be created by different people.
If there is no size control implemented, the characters and elements created by different artists can vary greatly.
When this occurs, the characters that are placed together in a scene will be out of proportion. The animator or
person doing the scene setup will then have to scale them to the correct size.

When a character or prop is scaled down, the outline will become increasingly thinner. By the time the element is
scaled to its proper size, the outlinemay be so thin that a difference between one character's outline and the one
beside it will not look very good.

Here are a few tips you can use to create a suitable size relation.
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Line Up

A line up consists of copying and pasting all your character designs into the same drawing and then scaling them to
the correct proportion in relation to the other characters. This line up is very important and should be handed to any
animator, layout and posing artist or scene setup person working on the project.

For the prop design, it is recommended that you paste one of themain character's hands or even the full body beside
the prop. This enables the animator to know what size to draw the prop.

In your character design scene, it is a good idea to create a column for the character line up.The line up is usually
done during the character design step. When the character builder imports themodel to the breakdown scene, the
size relation should be correct.

Field Chart

Harmony includes a field chart in its Drawing and Camera views. This tool is very useful in setting the characters'
and props' heights.

It is recommended that you keep the character design and breakdown inside the 12 field size. This ensures that it
fits the default camera size and the template thumbnails. If some parts were drawn too big or too far apart, you can

13
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use the Reposition All Drawings tool and reposition, scale or rotate multiple drawings from different layers all at
once.

Use the Show Grid option to display a grid in the Drawing or Camera views.

Name Button Description Keyboard Shortcut

Show Grid
Displays the grid.

View > Grid > Show Grid

Press Ctrl + ' (Windows/Linux) or⌘
+ ' (Mac OS X).

Grid Outline Only Displays the outline of the grid only. View > Grid > Grid Outline Only

Square Displays a standard square grid. View > Grid > Square

12 Field Grid Displays a 12-field size grid. View > Grid > 12 Field Grid

16 Field Grid Displays a 16-field size grid. View > Grid > 16 Field Grid

Underlay
Displays the grid under the drawing
elements.

View > Grid > Underlay

Overlay
Displays the grid over the drawing ele-
ments.

View > Grid > Overlay

How to reposition all drawings

1. In the Tools toolbar from the Select drop-downmenu, select the Reposition All Drawings tool. This
also automatically selects every stroke in your drawing in the Drawing and Camera views.

2. To deform or reposition a selection:

‣ To reposition, click and drag your selection to a new area.

‣ To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift to lock the
selection’s ratio.
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3. When you release your cursor, every drawing contained in the drawing layer you repositioned, scaled, rotated
or skewed will follow the same transformation.

Brush Size

Harmony provides a variety of pens and brushes and also allows you to create and save your own through creating a
tool preset.

It is a good idea to create and save pens with precise sizes and parameters to trace and design your models and
breakdowns.

Palettes and Colours

Harmony has an integrated palette system. Each character, prop or background can have its own set of colours and
each colour in the palette can be associated to colour fill zones on a drawing. You can create as many palettes and
colours as you need.
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Each scene created in Harmony includes a default colour palette which contains a standard set of colours for
sketching and painting.

You can sketch and design using the default palette without any problem. However, it is not recommended that
you use the default palette for the colour models. A different colour palette should be created for each colour
model.

To sketch and design with a different colour swatch or create a palette for each character, prop or key location,
you will need to learn how tomanage the Harmony palettes.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour view menu, select Palettes > New or click the New Palette button.

The Create Palette dialog box opens.

2. Enter the palette name according to themodel.

16
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3. Click OK.

The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode

1. In the Timeline or Xsheet view, select the drawing that requires a palette.

2. In the Colour view, click the Show Palette List View button to display the palette list.

3. Do one of the following:

‣ From the Colour view menu, select Palettes > New.

‣ Click the Create Palette button.

The Palette Browser: Create Palette dialog box opens.

4. Select the level to store the palette file.

‣ Environment: The palette-library folder is stored in the scene's parent environment folder.

‣ Job: The palette-library folder is stored in the scene's parent job folder.

‣ Scene: The palette-library folder is stored directly in the scene folder.

‣ Element: The palette-library folder is stored directly in the drawing element folder.
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When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

5. Name the palette. There is no need to add the suffix "palette"  to the name as it is always recognized as a
palette file.

6. Select a Palette List option.

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in twenty to
thirty different drawing elements that use the character's master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to this
list will appear in every drawing element created in the scene. There is no need tomanually load the palette in
each element.

The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out animation, all
columns (drawing elements) contain different characters, props, backgrounds and effects. The Element Palette
List is used because you do not necessarily want all of the palettes for all of your elements linked in every
column.

The palette list is stored in the drawing element's directory instead of directly in the Scene level. This ensures that
the links to the palettes appear only in the appropriate element. If you prefer to access a global palette list, link
your palettes to the Scene Palette List.

7. Click OK.

The new palette appears in the palette list.

How to add or modify a solid colour swatch

1. In the Colour view, click the Add Colour button.

2. From the Colour view menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens.
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3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options to change
the look of the colour picking area.

‣ Hold down the Dropper button as youmove along the desktop to preview colours, then release to
select the colour. It can be from the Toon Boom Harmony interface, your operating system or any other
open application.

NOTE: If the Sticky Eye Dropper option in the Preferences dialog box (Drawing tab > Options section) is selected, the
dropper will not have this behaviour.

NOTE: The Dropper does not work on Macs with Retina display.
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You can also click Multi Wheel Mode to open theMultiwheel Colour dialog box. This displays all the
picking area styles together and also contains a picking undo list. To return to the regular Colour Picker
window, click Single Wheel Mode.

4. Click on the Shade Scale swatches tomodify the shade of the selected colour.

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha field.

20



Harmony 12.2 Essentials - Cut-out Animation Guide

6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can quickly
access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking
on its name.

Sketching the Character

You are now ready to sketch your models. There are two tasks to perform in order to draw your characters:

l Add a drawing layer

l Sketch themodel

You have the choice to sketch your model as a bitmap or vector drawing. If you like the feel of drawing with bitmap
lines, you can set your layer as bitmap. If you like drawing with vectors, you can set your layer as vector. If you use
vector, you will be able to enlarge your drawing and zoom into it without losing quality or resolution. You can also use
the Contour Editor and Select tools to resize andmodify lines. If you draw with bitmap, you will not be able to scale
the drawing beyond 100% of its resolution without encountering pixelization issues.
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How to add a drawing layer

1. In the Timeline view, click the Add Drawing Layer button or press Ctrl + R (Windows/Linux) or⌘ + R
(Mac OS X).

The Add Drawing Layer window opens.

2. In the Name field, name your new layer.

3. Do one of the following:

‣ Click Add to add a first layer and keep the window open to addmore layers.

‣ Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

How to sketch a model

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties view, select a brush preset and adjust its parameters.

3. In the Timeline or Xsheet view, click in the first cell of the drawing layer.

4. In the Drawing or Camera view, enable the Grid (Field Chart). You can press Ctrl + ' (Windows/Linux) or
⌘ + ' (Mac OS X).

‣ Make sure the Drawing or Camera view is the active view while using the keyboard shortcut.

5. In the Drawing or Camera view, start drawing.
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6. To select a different colour, in the Colour view, select a different colour swatch. Double-click on the colour
swatch to open the Colour Picker window andmodify the colour. Remember that anything already painted
with that colour swatch will update to the new colour.

7. In the Camera or Drawing view, use the Rotary Table to rotate your workspace.You can press Ctrl+Alt
(Windows/Linux) or Ctrl+⌘ (Mac OS X).

‣ The default keyboard shortcut to reset the workspace rotation is Shift + X.

8. If you decide to draw in the next cell and need to see your previous drawing, enable the Onion Skin by press-
ing Alt + O.
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Cleaning and Inking the Model

When your roughmodels are ready, it is time to clean and ink them. You can still use the default palette and
colours to do so, especially if you are not the one doing the colour styling. If you have already created a palette for
your model, you can add new colours for tracing.

If you want to keep your roughs and sketches, add a new drawing layer and trace in it using the Light Table. This
is the equivalent of adding a sheet of paper and tracing over the rough using the animation disk light table. You
only need to disable the rough layer to prevent it from appearing in the final scene render.

How to trace your character in a new layer

1. In the Timeline view, add a new drawing layer and name it: clean.

2. If you work in the Drawing view, enable the Light Table or press Shift + L.

3. Do one of the following:

‣ In the Tools toolbar, select a drawing tool.

‣ From the topmenu, select Drawing > Drawing Tools > desired tool.

4. In the Timeline or Xsheet view, select the cell in which you want to draw.

5. Trace themodel.

6. Tomake perfect points and corners, you can intersect the two strokes to create a point. Using the Cutter
tool, you can automatically trim the excess portion. In the Tool Properties view, enable the Lasso
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selection type. Make sure the UseMouseGesture button is enabled. In this mode, you can automatically
delete any extra sections of line in your artwork by simply clicking, holding and dragging your mouse over it.
The intersection will not work well with the Pencil tool. It is recommended to use the Brush tool.

Drawing Tasks
Harmony has a wide variety of drawing tools for all kinds of drawing tasks. This section covers how to use these
tools. For the complete details on their options in the Tool Properties view, see Drawing Tool References on page
61.

In this topic, you will learn about:

• Current Drawing on Top on page 26

• Drawing with the Pencil Tool on page 27

• Drawing with the Brush Tool on page 32

• Viewing the Final Lines as You Draw on page 36

• Selecting DrawingObjects on page 38

• Erasing Parts of a Drawing on page 42

• Reshaping a Drawing Using the Contour Editor Tool on page 44

• Drawing Shapes on page 46

• Drawing with the Polyline Tool on page 48

• Drawing with Invisible Lines on page 49

• Deforming a Drawing with the Perspective Tool on page 51

• Warping a Drawing with the Envelope Tool on page 52

• Cutting Drawing Parts on page 54
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• Smoothing Lines on page 55

• WorkingWith Text on page 56

• More Drawing Tools on page 57

Current Drawing on Top

In Harmony, when you draw on a layer, the artwork is displayed in the correct order. For example, if the layer on
which you are drawing is located behind an object on another layer, the lines you are drawing will be hidden behind
that object.

This lets you display the selected drawing on top of everything while you draw. By enabling this option, each time
you select a drawing tool, the selected drawing is displayed in front of everything in the Camera view. The
Timeline view ordering remain unchanged.

The Current Drawing on Top status (enabled or disabled) is remembered when you exit Harmony. When you
restart the application, the last status will be used.

You only need to enable this option once, it is not necessary to do it each time you select a drawing tool.

How to display the drawing on top

1. Do one of the following:

‣ From the topmenu, select View > Show > Current Drawing on Top.

‣ In the Camera bottom toolbar, click the Current Drawing on Top button.

2. In the Tools toolbar, select a drawing tool.

3. In the Camera view, start drawing.
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Drawing with the Pencil Tool

The Pencil tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation. The
pencil creates a central vector shape.

How to draw with the Pencil tool

1. In the Timeline view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Pencil tool or press Alt + /.

3. In the Colour view, click a colour swatch to select a colour.

4. In the Drawing or Camera view, start drawing.

‣ When you get close to an existing pencil line, hold Alt to draw and connect your stroke to the existing one.
Pencil lines are central vector lines and youmight think your line is connected, but in fact, only the contour
is touching the other one. Also, make sure the central vector crosses the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

‣ To draw a straight line, press Shift + Alt as you draw.
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Working with Pencil Presets

A pencil preset is a pencil with specific properties.

Regular pencil presets allow you to set the size and smoothing of a pencil line, or the size of a shape.

How to select a pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, use the Presets menu to select a pencil preset.

3. In the Drawing or Camera view, draw your pencil line or shape.
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How to create a pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Tool Properties view, adjust your pencil settings.

3. In the Tool Properties view, click the New Brush button.

The New Preset dialog box opens.

4. Type in a name for your new pencil thickness stencil and click OK.

5. Start drawing in the Drawing or Camera view.

How to rename a pencil preset

1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle tool.

2. In the Presets menu, select the preset you want to rename.

3. From the Brushmenu , select Rename Brush.

The Rename Preset dialog box opens.

4. In the Name field, type in the new name.

5. Click OK.

How to delete a thickness stencil or pencil preset

1. In the Tools toolbar, select the Pencil tool.

2. In the Presets menu, select the thickness stencil or preset to delete.
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3. Click the Delete Preset button.

How to import pencils, brushes and erasers

1. From the Brushmenu , select Import Brushes.

2. In the browser window that appears, navigate to and select the .xml file.

3. Click Open.

4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also
import pencils at the same time.

5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the
imported tips to create other brush, eraser and pencil style presets.

How to export pencils, brushes and erasers

1. From the Brushmenu, select Export.

2. In the Export Brushes dialog box, select the vector brushes and erasers to export, as well as any pencils.
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3. Click Export.

4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file and
give it a name.

5. Click Save.

How to change the Presets Library thumbnail display

1. From the Brushmenu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. Dis-
plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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Drawing with the Brush Tool

The Brush tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if it
was created with a paint brush.

With the Brush tool, you can draw as vector or bitmap, depending on your preference. When you add a drawing
layer, you can simply select the vector or bitmap option. If you draw with vector, you can enlarge your drawing
and zoom into it without losing quality or resolution. You can also use the Contour Editor and Select tools to
resize andmodify lines. If you draw with bitmap, you will not be able to scale your drawing beyond 100% of its
resolution without encountering pixelization issues.

You can create your own brush styles. A variety of brush styles are provided allowing you to create and save your
own.This way you can create brushes with precise sizes and parameters and save them so you can draw and
design with them. Renaming a brush canmake it easier to identify and access the brushes you usemost
frequently.

A dynamic brush can be created for drawing using patterns created from your artwork. Create a new dynamic
brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic brushes using a single or
multiple patterns that automatically switch through the patterns as you draw.

How to draw with the Brush tool

1. In the Timeline view, click the Add Drawing Layer button or press Ctrl + R (Windows/Linux) or⌘ + R
(Mac OS X).

The Add Drawing Layer window opens.
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2. In the Name field, name your new layer.

3. Do one of the following:

‣ Click Add to add a first layer and keep the window open to addmore layers.

‣ Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

4. In the Timeline view, select the cell on which you want to draw.

5. In the Tools toolbar, select the Brush tool or press Alt + B.

6. In the Colour view, click a colour swatch to select a colour.

7. In the Drawing or Camera view, start drawing.

‣ Hold Ctrl (Windows/Linux) or⌘ (Mac OS X) to force a line to join the start and end of the shape while
drawing.

How to select a brush style

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties view, select a brush style from the Presets section.
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How to modify the brush settings

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize
the different parameters. Click the arrow button.

The Brush Properties window opens.
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This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Size and Smoothness

Maximum Size Sets themaximum width of the line.

Minimum Size Sets theminimum width of the line in relation to themaximum size.

Smoothness
Lets youmodify the central line smoothness of the line. This parameter smooths
the initial movement of your line. Increasing the value will result in a smoother line
with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter smooths the
contour of the line once it has been traced. The higher the value, the fewer control
points will compose your line.

Tip Shape

Lets you select a tip shape—from round and square ones to star shaped. This
option is disabled when using a textured brush.

How to create a brush preset

1. Make sure your current brush has the settings you want in the preset you will create.

2. In the Tool Properties view, do one of the following:

‣ Click the arrow button to display the Brush Properties window and click the New Brush button in the
upper-right corner.

‣ Click the New Brush button.

‣ From the Brush menu, select New Brush Preset.

3. In the New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush presets.

How to update a brush preset

1. Select the brush preset to update and click the arrow button to display the Brush Properties window.

2. Change the brush settings and click the Update Brush Preset button in the upper-right corner.
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How to rename a brush

1. In the Tool Properties view, select a brush to rename.

2. From the Brush menu, select Rename Brush.

3. Type in a new name for the brush and click OK.

How to delete a brush preset

1. In the Tool Properties view, select the brush preset you want to delete.

2. Do one of the following:

‣ Click the Delete Brush button.

‣ From the Brush menu , select Delete Brush.

Viewing the Final Lines as You Draw

Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. Although,
when you draw in the Drawing or Camera view, notice that your lines may appear jagged. This is caused by the
fast real-time display called OpenGL. If you prefer to see smooth lines as you draw, you can enable the
antialiasing preference.

Full Scene Antialiasing

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias your
drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on and off;
by default, it is disabled.

There is no need tomodify your graphic card settings.
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NOTE: Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be rendered
to 100% of its resolution regardless of your preference settings or graphic card panel.

How to customize the full scene antialiasing parameters

NOTE: You must restart Harmony after you change the parameters.

1. Do one of the following:

‣ From the topmenu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (Mac OS X).

The Preferences dialog box opens.

2. In the OpenGL tab, go to the Full Scene Antialiasing section.

‣ Enable: Select this option to enable/disable the Full Scene Antialiasing.

3. Number or samples: Enter the number of samples you want to be used for the antialiasing process. The
number of samples is basically equivalent to the amount of times a pixel will be enlarged to calculate the anti-
aliasing. This technique is called supersampling. The higher the number of samples, the better the anti-
aliasing quality will be, but the longer it will take to calculate.

4. Restart Harmony.
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Selecting Drawing Objects

The Select tool is used to select strokes in both the Drawing and Camera views, and apply basic transformations,
such as repositioning, rotating, scaling or skewing using the different handles of the bounding box.

Sometimes, when you want to select multiple objects while leaving one unselected, it can be handy to select only
the stroke or line that you do not want included in your selection. Then, you can invert the selection so that
everything else becomes selected. This can be quite a time saver.

By default, when you draw a selection box, the Select tool will select only the drawing strokes of the current
drawing. If you prefer the Select tool to select all the strokes on all layers, you can disable theWorks on Single
Drawing option in the Tool Properties view or the Select Tool Works on Single Drawing option in the Preferences
dialog box.

Some of the transformations, such as rotation, scale, skew, and flip are done relative to the position of the pivot
point. You can temporarily reposition this pivot point for a transformation using the Select tool.

How to select with the Select tool

1. In the Timeline view, select the cell on which you want to select drawing objects.

2. In the Tools toolbar, select the Select tool or press Alt + S.

3. In the Camera view, select the drawing objects.

‣ You can select all the drawing objects in a drawing by using Edit > Select All or by pressing Ctrl + A
(Windows/Linux) or⌘ + A (Mac OS X).

4. To deform or reposition a selection:

‣ To reposition, click the selected drawing object and drag the selection to a new area.
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‣ To rotate, grab the selection box handle and rotate it.

‣ To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift to lock the
selection’s ratio.

‣ To skew, drag sideways or up and down the sides or top and bottom segments, between the control
points.
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How to invert a selection

1. From the topmenu, select Edit > Invert Selection or press Ctrl + Shift + I.

How to enable and disable the Select Tool Works on Single Drawing preference

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. Do one of the followings:

‣ From the topmenu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences
(Mac OS X). In the Camera tab, go to the Tools section and select or deselect the Select Tool Works
on Single Drawing option and click OK.

‣ In the Tool Properties view, disable theWorks on Single Drawing option.

3. In the Camera view, make your selection. It is possible that you will have to restart Harmony depending on
your system.

How to temporarily reposition the pivot point

1. In the Camera or Drawing view, select the drawing object you want to transform.

The pivot point appears in themiddle of your selection.
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2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain there until you
make a new selection.
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving youmore precision when erasing parts of a
drawing. You can also use the Select tool to select drawing objects and delete them instead of erasing.

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when drawing
and designing. There are two icons located at the top, right corner of the Eraser Properties window. One is to
create a new preset, while the other is to update the currently selected preset. Use them after you have set all the
parameters for the new eraser preset.

‣ New Brush Preset: Click on this button to create a new eraser brush style. The new eraser style will
appear at the bottom of the list in the Presets section of the Tool Properties window. All the values and
selected options in the Eraser Properties window will be attributed to this new style.

‣ Update Preset: Click on this button to update the selected eraser preset with any changes made in
the Eraser Properties window. If youmake changes and do not click on the Update Preset button, then
all the changes made will only be applied to the selected eraser preset temporarily. Themoment you
switch to another eraser preset or to another drawing tool, thesemodifications to the eraser preset will
disappear.

How to erase with the Eraser tool

1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.

2. In the Tools toolbar, select the Eraser tool or press Alt + E.

3. In the Camera or Drawing view, start erasing.
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How to modify the eraser settings

1. In the Tools toolbar, select the Eraser tool .

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize
the different parameters in the Eraser Properties view. Click the arrow button.

The Eraser Properties window opens.

The Size and Smoothness tab is where you set theminimum andmaximum sizes of your drawing tool which will
produce the thick and thin effect on your stroke.

The Soft Eraser tab needs to be enable for its parameters to become active. This feature only works on soft or
textured brush strokes. Both tabs works with the pressure sensitivity of a pen tablet.

Parameter Description

Size and Smoothness

Maximum Size Sets themaximum width of the line.

Minimum Size Sets theminimum width of the line in relation to themaximum size.

Smoothness
Lets youmodify the central line smoothness of the line. This parameter smooths
the initial movement of your line. Increasing the value will result in a smoother line
with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter smooths the
contour of the line once it has been traced. The higher the value, the fewer control
points will compose your line.
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Tip Shape

Lets you select a tip shape—from round and square ones to star shaped. This
option is disabled when using a textured brush.

Reshaping a Drawing Using the Contour Editor Tool

The Contour Editor tool is a powerful tool that allows you to add, remove or modify points on a vector line and
control them with Bezier handles. It is used to correct line shapes andmodify a single part of a colour zone. If a
line is too thin or has a gap in it, you canmodify and correct it with the Contour Editor tool. You can also use this
tool to create elaborate shapes.

The Contour Editor displays vector points around a shape and the central vector points in a pencil line. Pulling or
pushing on these points adjusts the brush’s line thickness. Points can be selected and deleted. Each point has
two Bezier handles for correcting the curves between two points. Shapes can bemodified by pulling and pushing
directly on the segment between the points. You can use it to perfect a central shape pencil line, a contour shape
brush line, or even create an elaborate shape from a basic ellipse or square.

How to reshape with the Contour Editor tool

1. In the Timeline or Xsheet view, select the cell in which you want to draw.

2. In the Tools toolbar, select a shape tool: .

3. In the Tool Properties view, click the Ellipse button, click the Auto Fill button and set the pencil
size to 0.

4. In the Drawing or Camera view, draw a circle.
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5. In the Tools toolbar, select the Contour Editor tool.

6. In the Drawing or Camera view, click the line to reshape it.

7. Select one or several points by clicking on them or circling around.

8. Press Delete to delete a selected point.

Press Ctrl (Windows/Linux) or⌘ (Mac OS X)and click on the contour to add a new point to adjust the
contour.

9. Tomodify the shape, you can:

‣ Pull on the Bezier handle. Both point’s handles will move as one.

‣ Hold down Alt and pull on one of the Bezier handles. The point’s handle will move independently from the
other one.
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‣ Move the selected points to a new area.

‣ Pull directly on the line between two points. No selection is necessary. Holding down Shift will limit the
contour modification to the curve between the two first points.

‣ If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

‣ To add control points, press Ctrl (Windows/Linux) or⌘ (Mac OS X) and click the line.

‣ To remove control points, select the control point and press Delete.

Drawing Shapes

In Harmony, you can use the shape tools to draw circles, lines and squares. You can also easily reshape a
square or circle into amuchmore complex drawing such as these butterfly wings—see Reshaping a Drawing
Using the Contour Editor Tool on page 44 .
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How to draw with a Shape tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select a shape tool: .

3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill option.

4. In the Camera view, click and drag to draw the shape.

‣ Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

‣ Hold down Alt to draw the rectangle or ellipse from its centre.

‣ Hold down Shift to snap the line every 15 degrees.

‣ Hold down Alt to snap the start or end of the line to a nearby stroke.

5. Use the Contour Editor tool to deform the shape and create your drawing.
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Drawing with the Polyline Tool

The Polyline tool is used to draw shapes with a central vector type of line. To form a shape, you click to add a
point and then, without releasing themouse, pull the handle in the desired direction before adding the next point
and repeat the operation. To edit the shape, you can use the Contour Editor tool.

How to draw with the Polyline tool

1. In the Timeline view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Polyline tool or press Alt + _.

3. In the Camera or Drawing view, click and drag to create a point and a Bezier handle to shape your line.

‣ Press Alt to pull only one handle, instead of two.

‣ Press Shift to snap the handles to 45, 90, or 180 degrees.

4. Click a new area and drag to create a second point and Bezier handle.

5. Repeat the previous step until your shape is completed.

6. Press Ctrl (Windows/Linux) or⌘ (Mac OS X) and click to release the Polyline tool from the current path or
shape that it is creating. Continue to use the tool to makemultiple, independent paths or shapes.

7. If necessary, reshape the lines using the Contour Editor tool—see Reshaping a Drawing Using the
Contour Editor Tool on page 44.
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Drawing with Invisible Lines

There are two different ways to draw invisible lines.

Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful for
drawing tones and highlights directly on the character.

The Stroke tool draws invisible lines only. You cannot add thickness to the line. Unlike the CloseGap tool that
creates a short, straight line between two points, the stroke line will stay exactly where you draw it. This tool can be
useful for closing a zone in a particular way or creating some hard shadows or highlight areas.

Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue stroke colour. In
Harmony, you can display the strokes in washed-out colours so that the invisible lines stand out.

How to draw invisible lines with the Pencil tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Pencil tool or press Alt + /.

3. From the topmenu, select View > Drawing > Show Strokes or press K.

4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.
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5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option.

6. Click OK.

7. You canmodify the stroke shape with the Contour Editor tool.

How to draw invisible lines with the Stroke tool

1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar from the Paint drop-downmenu, select the Stroke tool or press Alt + V.

3. From the topmenu, select View > Show Drawing > Show Strokes or press K.

4. In the Tool Properties view, you can adjust the smoothness.

5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about
the Show Strokes option.

6. Click OK.

7. You canmodify the stroke shape with the Contour Editor tool.
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Deforming a Drawing with the Perspective Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.

How to deform a drawing with the Perspective tool

1. In the Tools toolbar, select the Perspective tool from the Contour Editor drop-downmenu or press Alt + 0.

2. In the Camera or Drawing view, select a drawing to deform.

3. Click and drag the different anchor points to deform the shape.
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Warping a Drawing with the Envelope Tool

The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles.

How to warp a drawing with the Envelope tool

1. In the Tools toolbar, select the Envelope tool from the Contour Editor drop-downmenu.

2. In the Timeline view, select a drawing to deform.

3. In the Camera or Drawing view, select the region you want to deform

4. Click and drag the different anchor points and handles to deform the image.
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5. To display more controls, in the Tool Properties view, click the Show Advanced Controls button.

6. Increase the height and width of the grid to get more control points to deform your image.
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Cutting Drawing Parts

The Cutter tool lets you cut a drawing area tomove, copy, cut or delete it.

How to cut with the Cutter tool

1. In the Tools toolbar, select the Cutter tool or press Alt + T.

2. In the Camera or Drawing view, make a selection around an area to cut away.

‣ To delete the selected zone, press Delete.

‣ Tomove the selection, click the selection and drag it to a new area.
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‣ Use the bounding box controls to scale, skew, or rotate the cut piece.

Smoothing Lines

When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw may
look as if they were drawnwith an unsteady hand. When this occurs, youmay need to correct the look of your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the lines, the
Smooth Editor tool.

How to optimize lines with the Smooth Editor tool

1. In the Tools toolbar, select the Smooth Editor tool or select Drawing > Tools > Smooth Editor.

2. In the Camera or Drawing view, place your pointer over the lines to smooth. Youmay need to pass over the
same line several times to removemore points andmake the line smoother. Note that by default, the Smooth
Editor tool colour is yellow, it was changed to orange for screen grab clarity—see Smooth Editor Tool Options
on page 91 to learn about the various settings available.
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Working With Text

With the Text tool, you can type text in your project using various fonts and texts attributes. Text objects are part
of a drawing, so you canmanipulate them in the sameway. OTF fonts are also supported.

How to add text to drawings

1. Do one of the following:

‣ In the Tools toolbar, select the Text tool.

‣ From the topmenu, select Drawing > Tools > Text.

‣ Press Alt + 9.

2. In the Timeline view, select the cell containing the drawing on which you want to add text.

3. In the Drawing or Camera view, click on the location you want the text to begin.

4. You can use the Tool Properties view to select the font, font size and format of the text you will type—see
Text Tool on page 93.

5. Type in the desired text.

6. Click outside the text box to exit the typingmode.
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If you want to create another text object, click outside the currently active text box. You can always return to
edit the text by selecting the Text tool and clicking in the text.

More Drawing Tools

Harmony offers a wide variety of useful tools to optimize your drawings and work more efficiently; tools such as
Group, Arrange, and the animation disk to rotate your workspace.

• Arrange on page 57

• Convert Brush Strokes to Pencil Lines on page 58

• Pencil Lines to Brush Strokes on page 58

• Strokes to Pencil Lines on page 58

• Optimize on page 59

• Grid on page 59

• Group/Ungroup on page 60

• Hand on page 60

• Rotate View on page 60

Arrange

The different Arrange options let you reorder drawing objects inside a single layer in the Drawing or Camera view.

Name Button Description Access Method

Bring to Front
Moves the selected art to the front (on
top).

From the topmenu, select Drawing >
Arrange > Bring to Front.

Press Ctrl + Shift + PgUp
(Windows/Linux) or⌘ + Shift + PgUp
(Mac OS X).

Bring Forward
Moves the selected art one level for-
ward (closer to the front).

From the topmenu, select Drawing >
Arrange > Bring Forward.

Press Ctrl + PgUp (Windows/Linux) or
⌘ + PgUp (Mac OS X).

Send Backward
Moves the selected art one level
lower (behind).

From the topmenu, select Drawing >
Arrange > Send Backward.

Press Ctrl + PgDown (Windows/Linux)
or⌘ + PgDown (Mac OS X).

Send to Back
Moves the selected art behind
everything (bottom / back).

From the topmenu, select Drawing >
Arrange > Send to Back.

Press Ctrl + Shift + PgDown
(Windows/Linux) or⌘ + Shift +
PgDown (Mac OS X).
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Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines operation converts selected contour strokes into centreline pencil strokes.
The brush stroke thickness will be lost.

How to convert brush strokes to pencil lines

‣ From the topmenu, select Drawing > Convert > Brush Strokes to Pencil Lines or press ^.

‣ Right-click on the selection, select Convert > Brush Strokes to Pencil Lines or press ^

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into contour strokes
brush lines.

How to convert pencil lines to brush strokes

‣ From the topmenu, select Drawing > Convert > Pencil Lines to Brush Strokes or press &.

‣ Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &

Strokes to Pencil Lines

The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

‣ From the topmenu, select Drawing > Convert > Strokes to Pencil Lines or press Shift + F12
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(Windows/Linux only).

‣ Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12
(Windows/Linux only)

Optimize

TheOptimize command reduces the number of layers, such as overlapping brush strokes, in the selected drawing
objects. Drawing objects will only be flattened and optimized if the selected objects do not change the appearance of
the final image when they aremerged.

For example, if you have selected a number of partially transparent objects, which you layered to create an additive
colour effect, the selected transparent drawing objects will not bemerged. This is becausemerging the transparent
drawing objects will cause them to lose the effect of the layered transparent colours.

How to optimize

‣ Use the Select tool to select the drawing objects you want to optimize.

‣ From the topmenu, select Drawing > Optimize > Optimize.

‣ From the Camera or Drawing view menu, select Drawing > Optimize > Optimize.

Grid

Use the Show Grid option to display a grid in the Drawing or Camera views.
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Name Button Description Keyboard Shortcut

Show Grid
Displays the grid.

View > Grid > Show Grid

Press Ctrl + ' (Windows/Linux) or⌘
+ ' (Mac OS X).

Grid Outline Only Displays the outline of the grid only. View > Grid > Grid Outline Only

Square Displays a standard square grid. View > Grid > Square

12 Field Grid Displays a 12-field size grid. View > Grid > 12 Field Grid

16 Field Grid Displays a 16-field size grid. View > Grid > 16 Field Grid

Underlay
Displays the grid under the drawing
elements.

View > Grid > Underlay

Overlay
Displays the grid over the drawing ele-
ments.

View > Grid > Overlay

Group/Ungroup

Use theGroup option to group selected drawing objects. This can help in the selection, repositioning, re-scaling
and other transformations to be applied tomultiple objects of a drawing.

• From the topmenu, select Edit > Group > Group or Edit > Group > Ungroup.

• From the Camera or Drawing view menu, select Edit > Group > Group or Edit > Group > Ungroup.

• Press Ctrl + G and Ctrl + Shift + G (Windows/Linux) or⌘ + G and⌘ + Shift + G (Mac OS X).

Hand

Use the Hand tool to pan through the Drawing or Camera view.

• In the Tools toolbar, select the Hand tool, click in the Drawing or Camera view and drag.

• You can also Hold down the Spacebar, click in the Drawing or Camera view andmove your mouse in the
direction you want to pan the view.

Rotate View

The Rotate View tool lets you rotate the Drawing or Camera view, the sameway as you would do with a real
animation disc. This tool can also be used in the Perspective view.
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How to use the Rotate View tool

1. Do one of the following:

‣ From the topmenu, select Drawing > Tools > Rotate View.

‣ Press Ctrl + Alt (Windows/Linux) or⌘ + Alt (Mac OS X).

‣ In the Tools toolbar, select the Rotate View tool.

‣ In the Drawing or Camera view, right-click and select Drawing Tools > Rotate View.

2. In the Drawing or Camera view, click and drag to rotate the space.

Drawing Tool References
Harmony has a wide variety of drawing tools and each one of them has a series of options andmodes available. This
section covers these options. For details on how to use these tools, see Drawing Tasks on page 25.

• Pencil Tool Options on page 62

• Vector Brush Tool Options on page 64

• Select Tool Options on page 67

• Eraser Tool Options on page 73

• Contour Editor Options on page 77

• Shape Tool Options on page 79

• Polyline Tool Options on page 82

• Stroke Tool Options on page 84

• Perspective Tool Options on page 85

• Envelope Tool Options on page 86

• Cutter Tool Options on page 89

• Smooth Editor Tool Options on page 91
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• Text Tool on page 93

Pencil Tool Options

When you select the Pencil tool, its properties and options appears in the Tool Properties view.

Maximum Size and Smoothing

This is where you set themaximum size of your drawing tool.

‣ MaximumSize: Defines the width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line. The fewer the control points
the smoother (but less faithful) the line.

Pencil Presets

Harmony provides a variety of pencil presets and also lets you create and save your own. It is a good idea to
create and save pencils with precise sizes and parameters when you draw and design for efficiency and
consistency.
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You can export the pencil presets that you have created and import those that others have created. This is a good
way for you and project collaborators to keep a consistent look for the project—seeWorking with Pencil Presets on
page 28

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint behind existing art. By default, strokes
appear over your work until you release the tool.

Auto-Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flatten mode automatically
merges lines created with the existing ones into one single object as you draw.

NOTE:
Using the Select tool, you can use select and remove a segment of flattened pencil lines. Overlapping pencil lines
drawn with the Auto-Flatten mode enabled are essentially cut into segments by the overlap and can therefore be
treated as individual lines.

Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an invisible stroke.

It is recommended to keep this option enabled when drawing with the Pencil tool.
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Vector Brush Tool Options

When you're drawing on a vector layer and select the Brush tool, its properties and options appear in the Tool
Properties view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to
the style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.

Maximum Size and Smoothing

This is where you set themaximum size of your drawing tool.
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‣ MaximumSize: Defines the width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line. The fewer the control points
the smoother (but less faithful) the line.

Brush Presets

Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for
repeated tasks. You can create as many brush presets as you need—see Drawing with the Brush Tool on page 32.

How to import pencils, brushes and erasers

1. From the Brushmenu , select Import Brushes.

2. In the browser window that appears, navigate to and select the .xml file.

3. Click Open.

4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also
import pencils at the same time.

5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the
imported tips to create other brush, eraser and pencil style presets.
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How to export pencils, brushes and erasers

1. From the Brushmenu, select Export.

2. In the Export Brushes dialog box, select the vector brushes and erasers to export, as well as any pencils.

3. Click Export.

4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file
and give it a name.

5. Click Save.

How to change the Presets Library thumbnail display

1. From the Brushmenu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly.
Displays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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Draw Behind

When the Draw Behind mode is enabled, the lines you draw will appear behind the art that already exists.

Repaint Brush Mode

The Repaint Brush is used to repaint zones that have already been painted, it will not affect empty zones or
pencil lines. It also automatically flattens each of its brush lines so it does not add new brush lines on top of existing
ones. You can use this mode to paint tones or highlights onto your character.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Select Tool Options

When you use the Select tool, its properties and options appear in the Tool Properties view.
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Lasso and Marquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

You can enable different snappingmodes to help you when repositioning drawings using the Select tool.

• Snap to Contour: Snaps your selection or point to any line you position it on. As soon as youmove it
close enough to another line, your point or selection will snap to it.

• Snap and Align: Snaps the selected anchor point to any existing line while displaying temporary
rulers as a guide that you can also snap your anchor point to.

• Snap to Grid: Snaps your selection following the currently enabled grid.

How to snap to the grid

1. Do one of the following:

‣ Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press Ctrl + '
(Windows/Linux) or⌘ + ' (Mac OS X).

‣ Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.

2. In the Tools toolbar, select the Contour Editor tool or press Alt + Q.

3. In the Tool Properties view, click the Snap to Grid button.

4. In the Camera or Drawing view, click on the anchor point you want to snap to the grid, drag it to the desired
position and release.
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Selecting by Colour

The Select by Colour mode lets you select all the zones and lines in your drawing painted with the same colour
swatch.

NOTE: Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured with the
exact same RGB value (same colour), but not painted with the same colour swatch, it will not be selected.

How to select areas by colour

1. In the Tools toolbar, select the Select tool or press Alt + S.

2. In the Tool Properties view, click the Select by Colour button.

3. In the Camera or Drawing view, click on any zone or line in your drawing.

All zones and lines of the same colour are selected.

4. Click the Select tool again to return to the regular Select mode.
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Single Mode

By default, when you draw a selection box in the Camera view, the Select tool will select only the drawing strokes
of the current drawing. If you prefer the Select tool to select all the strokes on all layers, you can disable the
Works on Single Drawing option in the Tool Properties view or disable the Select tool Works on Single
Drawing preference. To do this, go to the topmenu, select Edit > Preferences > Camera (Windows/Linux) or
Stage Essentials > Preferences > Camera (Mac OS X) and uncheck the Select tool Works on Single Drawing
option.

Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

‣ From the topmenu, select Drawing > Flip Horizontal and Flip Vertical.
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Rotate 90 Degrees CW and CCW

TheRotate 90 Degrees CW andRotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

‣ From the topmenu, select Drawing > Transform > Rotate 90 Degrees CW andRotate 90 Degrees
CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or⌘ + 7 and⌘ + 9 (Mac OS X).

Smooth

The Smooth operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the topmenu, select Drawing> Optimize > Smooth or press Alt + Shift + S.

Flatten

The Flatten operation is used tomerge drawing objects and brush strokes into a single layer. If you draw new
lines to fix a drawing or line with many brush strokes, it can be useful to flatten them all into a single shape. By
default, lines are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it will be
easier if they are flattened.

‣ From the topmenu, select Drawing > Optimize > Flatten or pres Alt + Shift + F.
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Distribute to Layers

The Distribute to Layers option is used to separate the selected art strokes and send them to new drawing
layers. In the Camera view, once you have drawn your artwork, you can select the strokes you want to distribute
using the Select tool and click on the Distribute to Layers button; you can also select Drawing >
Distribute to Layers. It will automatically take every stroke from the drawing selectionmade in the Camera view
and separate them into a different layer for each. If an artwork is composed of several strokes, youmust group
them using Edit > Group > Group before using the Distribute to Layers option. This option cannot be done from
the Drawing view.

Pencil to Brush

The Pencil to Brush operation converts the selected centre line pencil strokes into contour strokes brush
lines.

From the topmenu, select Drawing > Convert > Pencil Lines to Brush or press &.

Offset X and Y

Use theOffset X andOffset Y operation fields to enter specific values and precisely reposition the selected
shape.

1. X: Type a value in this field to reposition your selection along the X-axis.

2. Y: Type a value in this field to reposition your selection along the Y-axis.

3. Up/Down arrows: Use the up and down arrows tomodify the value in the X or Y value field.

Width and Height

Use theWidth and Height operation fields to enter specific values to resize the selected shape with precision.

1. Width: Type a value in this field to resize the width of your selection.

2. Height: Type a value in this field to resize the height of your selection.

3. Up/Down arrows: Use the up and down arrows tomodify the value in theWidth or Height fields.

4. Lock icon: Click the lock icon to lock or unlock the ratio between theWidth and Height values.
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Angle

The Angle operation lets you to enter specific values and accurately rotate the selected shape.

1. Angle: Type a degree value in this field to rotate your selection.

2. Up/Down arrows: Use the up and down arrows tomodify the value in the Angle value field.

When you select a pencil line with the Select tool, additional options appear in the Tool Properties view.

Adjusting the Pencil Line Thickness

Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes. This operation
is not permitted on contour line shapes, such as brush strokes or shape fills.

Adjusting the Text Selection

When you select text with the Select tool, the tool properties will display the Text tool options on the bottom of the
view. You can also press Alt + 9 to display only the Text properties in the Tool Properties view—see Text Tool on
page 93.

Eraser Tool Options

When you're drawing on vector layer and you select the Eraser tool, its properties and options appear in the Tool
Properties view.
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view. Click on the Show Extended Properties arrow to display advanced
customization parameters,

Maximum Size and Smoothing

This is where you set themaximum size of your drawing tool.

‣ MaximumSize: Defines the width of the stroke.

‣ Smoothing: Defines the number of control points added to the centre line. The fewer the control points
the smoother (but less faithful) the line.

Eraser Presets

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when drawing
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and designing. Toon Boom Harmony provides you with a variety of default eraser styles and allows you to create
and save your own.

Eraser presets are created by saving the properties of the current eraser as a preset, in order to reuse it again and
again. You can create a new preset from the Eraser Tool Properties view, but it is better to do it from the Eraser
Properties—see Erasing Parts of a Drawing on page 42.

The Eraser tool uses its own preset list, separated from the Brush tool.

How to import pencils, brushes and erasers

1. From the Brushmenu , select Import Brushes.

2. In the browser window that appears, navigate to and select the .xml file.

3. Click Open.

4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also
import pencils at the same time.

5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the
imported tips to create other brush, eraser and pencil style presets.
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How to export pencils, brushes and erasers

1. From the Brushmenu, select Export.

2. In the Export Brushes dialog box, select the vector brushes and erasers to export, as well as any pencils.

3. Click Export.

4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file
and give it a name.

5. Click Save.

How to change the Presets Library thumbnail display

1. From the Brushmenu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly.
Displays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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Contour Editor Options

When you select the Contour Editor tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Snap to Contour

The Snap to Contour option will snap the selected anchor point to any line you position it on.

How to snap two shapes together

1. In the Tools toolbar, select the Contour Editor tool or press Alt + Q.

2. In the Tool Properties view, click the Snap to Contour button.

3. In the Camera or Drawing view, click on an anchor point you want to snap to the other shape, drag it on top of
the contour line area and release it.
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Snap and Align

The Snap and Align option lets you snap the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to.

How to snap and align

1. In the Tools toolbar, select the Contour Editor tool or press Alt + Q.

2. In the Tool Properties view, click the Snap and Align button.

3. In the Camera view, click on an anchor point you want to snap, drag it until a ruler is displayed, position it
on the ruler or on the contour line and release.

Show Contour Editor Controls

Use the Show Contour Editor Controls option to show the contour editor controls. You can use these controls
to scale, reposition and rotate the selected anchor points.

Smooth Selection
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The Smooth operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the topmenu, select Drawing> Optimize > Smooth or press Alt + Shift + S.

Shape Tool Options

When you select a shape tool (Rectangle, Ellipse, Line), its properties and options appear in the Tool Properties
view.

Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to the
style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.
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Size

Move the Size slider left to reduce the line thickness and to the right to increase its width.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.

• Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose between
Round or Flat style.

• End: Lets you select the style of the end tip, which is the last tip you drew. You can choose between
Round or Flat style.

• Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also define
the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Presets

Harmony provides a variety of pencil presets and also lets you create and save your own. It is a good idea to
create and save pencils with precise sizes and parameters when you draw and design for efficiency and
consistency.

You can export the pencil presets that you have created and import those that others have created. This is a good
way for you and project collaborators to keep a consistent look for the project—seeWorking with Pencil Presets
on page 28

Draw Behind

When the Draw Behind mode is enabled, the lines you draw will appear behind the art that already exists.
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Automatic Filling

Use the Automatic Filling option to automatically fill your shape with the selected colour as you draw. By
default, the Shape tool creates the outline of an empty shape that you can later fill using the Paint tool. This option is
unavailable for the line tool.

Snap Options

When drawing a shape, you can enable different snapmodes to help you create your shape.

• The Snap to Contour option snaps your shape to any line you position it on.

• The Snap and Align option snaps the selected anchor point to any existing line, while displaying
temporary rulers as a guide that you can also snap your anchor point to.

• The Snap to Grid snaps your shape to the currently enabled grid.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork as
you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will flatten
with pencil lines.

Using the Select tool, you can use themiddlemouse button to select a segment of flattened pencil line. This creates
a nice finish on the lines and corners of your artwork.
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Auto-Close Gap

When enabled, the Auto-CloseGap mode automatically connects, with an invisible stroke, the pencil lines
you draw close to each other in the Camera view.

NOTE: It is recommended to leave this option enabled when drawing with the Pencil tool.

Keep Proportion

When the Ellipse or Rectanglemode is enabled in the Tool Properties view, the Draw Circle or Draw Square
option appears. When selecting these options, the shape produced will be a perfect circle or square (as opposed
to an oval or rectangle).

Enabling this option is a good idea if you plan to createmany squares or circles. However, if you only need to
create one, holding down the Shift key as you create your shape will maintain the proportion in the sameway.

Polyline Tool Options

When you select the Polyline tool, its properties and options appear in the Tool Properties view.
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Previewing the Stroke

The Preview area lets you see a preview of the stroke that will be produced after you customize the different
parameters in the Tool Properties view.

1. Select a brush style from the Presets section. It's a good idea to choose a brush preset that is closest to the
style you want to create.

2. Click on the Show Extended Properties arrow to display advanced customization parameters.

Size

The Size parameter lets you set the size of the polyline that you will draw.

83



Chapter 2: Design and Drawing Tools

Pencil Presets

Harmony provides a variety of pencil presets and also lets you create and save your own. It is a good idea to
create and save pencils with precise sizes and parameters when you draw and design for efficiency and
consistency.

You can export the pencil presets that you have created and import those that others have created. This is a good
way for you and project collaborators to keep a consistent look for the project—seeWorking with Pencil Presets
on page 28

Snap to Contour

The Snap to Contour option will snap your selection to any line you position it on.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork
as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will
flatten with pencil lines.

Stroke Tool Options

When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Draw Stroke as Straight Lines

Enable the Draw Stroke as Straight Lines option if you want the new strokes you draw to be a perfect straight
line. Disable the option if you want the stroke to follow themouse gesture.

Connect Line Ends

Enable the Connect Line Ends option if you want the start or end point of your new stroke to connect to your
existing strokes tomake sure no gaps are left in your drawing.

Auto-Flatten Mode

When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing artwork
as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes and pencil lines will
flatten with pencil lines.

Smoothness

You canmodify the central line smoothness of your line using this option. This parameter smooths the initial
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movement of your line. Increasing the value will result in a smoother line with fewer control points. Use the left and
right arrows to increment the value by one full unit. Use the Up - Down slider to quickly increment the value.

Perspective Tool Options

Selecting the Perspective tool displays its properties and options in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

• The Snap to Contour option will snap the selected anchor point to any line you position it on—see Contour
Editor Options on page 77.

• The Snap and Align option lets you snap the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to—see Contour Editor Options on page
77.

• The Snap to Grid option snaps your selection according to the currently enabled grid.

Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

‣ From the topmenu, select Drawing > Flip Horizontal and Flip Vertical.
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Rotate 90 Degrees CW and CCW

TheRotate 90 Degrees CW andRotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

‣ From the topmenu, select Drawing > Transform > Rotate 90 Degrees CW andRotate 90
Degrees CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or⌘ + 7 and⌘ + 9 (Mac OS X).

Envelope Tool Options

Selecting the Envelope tool displays its properties and options in the Tool Properties view.

Width and Height

Increase the width and height values to addmore columns and rows to the deformation grids.
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Lasso and Marquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options

• The Snap to Contour option will snap the selected anchor point to any line you position it on—see Contour
Editor Options on page 77.

• The Snap and Align option lets you snap the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to—see Contour Editor Options on page
77.

• The Snap to Grid option snaps your selection according to the currently enabled grid.

Show Advanced Controls

To display more controls,you can click on the Show Advanced Controls button.
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Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

‣ From the topmenu, select Drawing > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW
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The Rotate 90 Degrees CW andRotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

‣ From the topmenu, select Drawing > Transform > Rotate 90 Degrees CW andRotate 90 Degrees
CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or⌘ + 7 and⌘ + 9 (Mac OS X).

Smoothness

You canmodify the central line smoothness of your line using this option. This parameter smooths the deformed
lines. Increasing the value will result in a smoother line with fewer control points. Themore you increase the value,
the less details and curves you will get. Use the left and right arrows to increment the value by one full unit. Use the
Up - Down slider to quickly increment the value.

Cutter Tool Options

When you select the Cutter tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee

Choose between the Lasso andMarquee options to change the selection style of the tool.

• Click and hold Alt to temporarily switch from the current mode to the other.

Use Mouse Gesture

When using the Lasso selection type, the UseMouseGesture option lets you automatically delete any
extra sections of line in your artwork by simply dragging your mouse over it.

NOTE: For this operation to work, you lines CANNOT be flattened.

Use Mouse Gesture Breaker Mode

When using the Lasso selection type, the UseMouseGesture Breaker Mode option lets you draw an
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invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with this option, you will
be able to select the two portions independently with either the Cutter tool, Pencil Editor tool or Select tool.

NOTE: This option only works with pencil lines.

Tip Style

If you erase the end of a pencil line or erase a pencil line through the centre, new line tips or line ends are created.
Use the Tip Style option to customize the shape of the new line tips that are created.

Antialiasing

When drawing on a bitmap layer, lines are no longer clean vector shapes. For the edges to be smooth, a slight
amount of antialiasing is used. When using the Cutter tool, you can cut a portion of your drawing with or without
antialiasing. By default, the option is enabled. If you want to cut your drawing using a hard edge, you can select
the Antialiasing Off option.
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Flip Horizontal and Vertical

The Flip Horizontal and Flip Vertical operations flip the current selection horizontally or vertically.

‣ From the topmenu, select Drawing > Flip Horizontal and Flip Vertical.

Rotate 90 Degrees CW and CCW

TheRotate 90 Degrees CW andRotate 90 Degrees CCW operations rotate the current selection 90
degrees clockwise or counter-clockwise.

‣ From the topmenu, select Drawing > Transform > Rotate 90 Degrees CW andRotate 90 Degrees
CCW.

‣ Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or⌘ + 7 and⌘ + 9 (Mac OS X).

Smooth Editor Tool Options

When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view.
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Brush, Marquee and Lasso Smoothing Style

The Smoothing Style options allow you to smooth a portion of your drawing by tracing a smoothing stroke over the
zone to optimize or by selecting an area of the drawing with theMarquee or Lasso.

Note that by default, the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity.

Show Control Points

The Show Control Points option allows you to show or hide the Bezier points around lines. When the Bezier
points are displayed, you can see the result of your smoothing and the number of points left on the curve. When it
is turned off, only the original artwork is displayed.

Minimum Size and Maximum Size

This is where you set theminimum andmaximum sizes of your drawing tool which will produce the thick and thin
effect on your stroke. This works with the pressure sensitivity of a pen tablet.

This options is available while using the Brush Smoothing style.

‣ Maximum and Minimum Size: Defines themaximum andminimum width of the stroke.

• Up/Down arrows: Use the up and down arrows to set theminimum andmaximum size value.

Smoothness

The Smoothness impacts the strength of the smoothing result. The higher the value, themore points are
removed and the smoother the curve. The Smoothness range is from 0 to 100; the default value is 20.
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Colour

You canmodify the colour of the control points displayed on the artwork while working with the Smooth Editor tool by
double-clicking on the colour swatch.

Text Tool

Use the Text tool's properties to select the font type and other formatting options you want to apply to the text.

If you already wrote your text, youmust first use the Text tool and select the text portion you want to format.

Font Type

Use the Font drop-downmenu to select a font. OTF fonts are supported.
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Font Style

Use these buttons to select a style for your text:

• Bold

• Italic

Alignment

Use these buttons to align the paragraph.

Left Centered

Right Justified

Font Size

Enter a size for the text.
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Kerning

Use the kerning field to modify the spacing between letters and characters. You can select the Auto Kern option to
set the kerning automatically based on the font’s predefined standard. A negative value decreases spacing between
each character, creating a letter overlap and a positive value increases it.

Indent

Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive value
sets the first line of your paragraph farther to the right and a negative value sets it farther to the left.

Line Spacing

Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box

You can resize the text box by selecting your text box with the Text tool andmoving the anchor point right or left.
Using the Select tool will distort and scale your text itself rather than changing the width and height of your text box.
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Converting Text into Separate Objects

Text contained in a text field is treated as a single drawing object. You can easily separate the text so each
character becomes an individual drawing object that you can select andmodify independently.

How to break a text object

1. In the Tools toolbar, click the Select tool or press Alt + S.

2. In the Drawing or Camera view, select the text object you want to break.

3. From the topmenu, select Drawing > Convert > Break ApartText Layers.

‣ From the Drawing or Camera view menu, select Drawing > Convert > Break ApartText Layers.

Each character is surrounded by a bounding box that you canmodify; they remain text objects that you
can edit.

4. If you want to convert your independent letter to a complete vector object that you can deform, use the
Select tool to select the letters to convert.

5. From the topmenu, select Drawing > Convert > Break Apart Text Layers to break the selection into a
regular drawing object, with nomore text attributes.

‣ From the Drawing or Camera view menu, select Drawing > Convert > Break Apart Text Layers to
break the selection into a regular drawing object, with nomore text attributes.
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Chapter 3: Colour Styling

Once the characters, props and locations are designed, it's time for the colour styling and colour models creation.
This is when the colours andmoods are determined. The linemodels created during the design step are painted and
organized as colour models for the colourists.

Harmony has a great concept of colour palettes. Each character can have its own set of colours that is carried
through the entire project called themaster palette. If themaster is modified, the colours in the entire project are
updated simultaneously.

By doing the colour styling in Harmony, your master palette will be created at the same time, so you do not need to
use third party software. Also you will not have to recreate the colour palette again in Harmony. It is possible to
create this step in an external software, but it is a great time saver to do it directly in Harmony.

NOTE: Throughout this section, there may be slight differences between your interface and the illustrations in this
guide. This is because the images are taken from Harmony Premium.

To create the colour style and colour models, follow these steps:

• Preparation on page 99

• Working with Palettes on page 104

• Colours on page 121

• Painting theModel on page 132

Preparation
Before painting, you need to organize the colour model scenes and bring in your references. The colour styling
preparation is done in five steps:

• Colour Model Storage on page 100
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• Scene Creation on page 100

• Setting Up theWorkspace on page 101

• Naming on page 102

Colour Model Storage

First, you will need to create a storage location for all your models and palettes. The best way to do this is to
create a colour model scene. There are different possibilities available to structure your designs and colour model
scenes. We strongly recommend that you put all of your colour models in the same scenes. It is important to
maintain a structure for your models so they do not end up scattered throughout the project.

There are four mainmodel categories:

If you have a small project, such as a short or an advertising contract, you can always place all the characters,
props, effects, and locations in the same scene. For large projects such as feature-length productions or series,
you should create four separatemodel scenes following these categories.

Scene Creation

In order to create colour models, you need to create your scenes.

When working on a paperless or cut-out animation project, if you have designed your characters, props, effects
and locations directly in Harmony, you can paint your models directly in your design scene. You can also create a
new colour model scene and import your designs in that one. Refer to the Fundamentals Guide to learnmore
about creating a scene.

If you have not already done so, refer to the Fundamentals Guide to learn about production structure, file
organization, and how to create a Project root directory. We recommend storing your colour model scenes in the
root directory or in a colour models subdirectory for even better organization.

A useful way to name your colour model scene is to include the project name, then the colour model type such as
characters, props, effects, or locations, and finally colourmodel. For example, a character colour model scene
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for the Adventure project would be named adventure_characters_colourmodel. This ensures that you
always know what scene corresponds to what.

Colour Model Scene Structure

To store your colour models in a scene, you should create one drawing layer for each character, prop, effect, or
location. You should name these according to themodel.

You can also load other colour references in the scene to balance your overall colours. For example, if you work in a
character colour model scene, it's a good idea to import some of the key locations to compare and adjust the colours
so they match well.

Setting Up the Workspace

Now that your scenes are created and structured, you can open the corresponding colour model scene. For the
optimal workspace for inking and painting, set up your workspace with these views:

• Xsheet

• Camera

• Drawing

• Colour
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Naming

Now that your models are imported, you can rename them appropriately. You should rename elements (layers)
and drawings corresponding to themodel. This will help keep the work organized andmake it easy for others to
follow.

For example, if there is a black and white character model called Erik in one drawing element and its colour
models in another one, rename your elements to include the character's name. For example, the colour model for
Erik's armour could be named: erik_armour_colour.

How to rename a drawing element

1. Do one of the following:

‣ In the Xsheet view, double-click on the column header of the drawing element.
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‣ In the Timeline view, double-click on the drawing element's layer.

The Layer Properties window opens.

2. Type in a new name.

How to rename a drawing

1. In the Xsheet view, click on a drawing name.
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2. Do one of the following:

‣ Press Ctrl + D (Windows/Linux) or⌘ + D (Mac OS X).

The RenameDrawing dialog box opens.

3. Type in a new name and click OK.

Working with Palettes
In animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. This is
referred to as amaster palette.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.

Using amaster colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.

• You cannot accidentally use a colour which is not in themaster palette.

• Standardization and colour consistency throughout the production

• Multiple artists can use the same colour palette and produce the same results.

Toon Boom Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete
control and consistency in your painting process.

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a *.plt file name
extension—see Palette File Storage.

When a zone on the character is painted with the colour contained in a colour swatch, a link is automatically
created between that colour swatch and the zone. This means that if the tint of the colour in the colour swatch is
changed, any zone linked to it will update to the new tint. This is one way that colour palettes can save time and
money in your production.

Another advantage of this system is that you can create complete palettes for different lighting situations. For
instance, in addition to the regular palette for a character, you could have one for that character in the rain using
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene.
Using palettes linked to your character in this way allows you to instantly change its colouring to suit themood
and atmosphere of the scene without tediously repainting each element.
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This section is divided as follows:

• Palette Lists

• Palette File Storage

• Creating a Colour Palette on page 109

• Duplicating a Colour Palette on page 113

• Cloning a Colour Palette on page 114

• Importing and Linking Palettes on page 116

Palette Lists

The Colour view has twomodes: basic and advanced.

• Basic Mode
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The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony, you only
see the colours available in the Default palette which contains six basic colour swatches and is
automatically named the same as your scene. For simple projects, you canmanage with the default
palette, but for movies, series, or shorts it is recommended that you create palettes for your characters. To
create a palette, you have to switch to the Advancedmode of the Colour view and show the Palette list.

• Advanced Mode

The Advancedmode displays the list of all palettes that are linked to the scene. To create palettes for your
characters, youmust display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a palette list.
The scene also has a palette list. For example, a drawing layer can use three different palettes stored in three
different locations, while another drawing layer can use two of these palettes plus another one coming from
another scene. The palette list keep track of the locations of the palettes.

There are two types of palette lists:

• Scene Palette List

The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless and
traditional animations. A cut-out character will often be divided into 20 to 30 different drawing elements that
use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to
this list will appear in every drawing element created in the scene. There is no need tomanually load the
palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only
Scene Palette lists.

• Element Palette List
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In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your palette at
an element’s level. The Element Palette list is mainly used with traditional and paperless animation. Unlike
cut-out animation, all columns (drawing elements) contain different characters, props, backgrounds, and
effects. The Element Palette list is used when you do not necessarily want all of the palettes for all of your
elements linked in every column.

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This ensures
that the links to the palettes appear only in the appropriate element. If you prefer to access a global palette
list, link your palettes to the Scene Palette list.

When you are using several cloned palettes that are related to the same original palette, Toon Boom Harmony uses
the palette located highest in the list to determine the colour of the painted zones—see Cloning a Colour Palette .

How to show or hide the Palette list

‣ In the Colour view, click the Show/Hide Palette List View button to expand or collapse the Palette
List area.

The Palette List window opens and displays all your palettes.
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How to set the Advanced Palette Lists mode

1. Do one of the following:

‣ From the topmenu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (Mac OS X).

2. Select the Advanced tab.

3. In the section, select the Advanced Palette Lists option.

4. Click OK.

How to reorder palettes in the Palette list

Do one of the following:

‣ From the Colour View menu, select Palettes > Move Up orMove Down.

‣ In the Palette list, click the Up and Down buttons.

Palette File Storage

In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is
created from Harmony, it needs to be stored somewhere. By default, the palette file is stored in the scene
directory in a palette-library folder unless you specify a different location.

There are four locations where you can find palette-library folders:
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l Element: The Palette Library folder is stored directly in the drawing Element folder.

l Scene: The Palette Library folder is stored directly in the Scene folder.

l Job: The Palette Library folder is stored in a Job folder contained in the Scene folder.

l Environment: The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is recommended
to keep it as is. If you work with a larger studio, it is recommended to verify with them on the file structure.

This existing structure is compatible with Harmony Server. Harmony’s database has a leveled structure starting
from the Environment down to the Element. Its client-server configuration allows all data, such as palettes and
scenes, to be shared between a series of client machines.

Element Level

Working with Harmony Stand Alone, the Element level is very useful when there are a lot of different palettes. When
a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette file with the
colour model, the colourist can load them both from the same location. This also creates amore organized structure.

Scene Level

Working with Harmony Stand Alone, a palette file can also be saved at the scene level, so that all of the palettes
from the scene are stored together. The palette namingmust be structured so the colourist or character builders can
find the correct one. Saving the palettes at the scene level makes it very easy to back up the palettes and retrieve
their location.

The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that includes all of
the characters, props, effects, and location, the colour palette or model will often be directly imported to, or created
in, the character building scene. Just as with a cut-out character building scene, each element uses the same
palette so it would not be efficient to save the palette inside one element. Instead, it is saved at the scene level. This
prevents a palette overload because all of themodels are in different scenes. It also allows each scene to have its
own set of palettes corresponding to its model.

When working on a cut-out animation production, it is highly recommended that you work with the Scene level.

Palette Backup

When sharing palettes between scenes, some users may accidentally modify the colours, even though the palettes
are locked by default. That is why it is a good idea to copy and back up your palette libraries andmaster palette
directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble replacing an
altered file. Harmony automatically updates all of the files and drawings linked to it.

Creating a Colour Palette

You can create a palette in either Basic or Advancedmode.

By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended to use the
Basic mode. This setting stores the palettes automatically for you and saves them at the Scene level. When you
use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: Environment,
Job, Scene, or Element.
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Before you can create a palette in the Advanced Palette Lists mode, youmust first set your preferences to
Advanced Palette Lists mode in the Preferences dialog box.

You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will not
be deleted and you can reimport it in your Palette list later on.

How to set the Advanced Palette Lists mode

1. Do one of the following:

‣ From the topmenu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (Mac OS X).

2. Select the Advanced tab.

3. In the section, select the Advanced Palette Lists option.

4. Click OK.

How to create a new palette (Basic Palette Lists mode)

1. From the Colour view menu, select Palettes > New or click the New Palette button.

The Create Palette dialog box opens.

2. Enter the palette name according to themodel.

3. Click OK.

The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode

1. In the Timeline or Xsheet view, select the drawing that requires a palette.

2. In the Colour view, click the Show Palette List View button to display the palette list.
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3. Do one of the following:

‣ From the Colour view menu, select Palettes > New.

‣ Click the Create Palette button.

The Palette Browser: Create Palette dialog box opens.

4. Select the level to store the palette file.

‣ Environment: The palette-library folder is stored in the scene's parent environment folder.

‣ Job: The palette-library folder is stored in the scene's parent job folder.

‣ Scene: The palette-library folder is stored directly in the scene folder.

‣ Element: The palette-library folder is stored directly in the drawing element folder.

When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

5. Name the palette. There is no need to add the suffix "palette"  to the name as it is always recognized as a
palette file.

6. Select a Palette List option.

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in twenty to
thirty different drawing elements that use the character's master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to this list
will appear in every drawing element created in the scene. There is no need tomanually load the palette in each
element.
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The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out animation, all
columns (drawing elements) contain different characters, props, backgrounds and effects. The Element Palette
List is used because you do not necessarily want all of the palettes for all of your elements linked in every
column.

The palette list is stored in the drawing element's directory instead of directly in the Scene level. This ensures that
the links to the palettes appear only in the appropriate element. If you prefer to access a global palette list, link
your palettes to the Scene Palette List.

7. Click OK.

The new palette appears in the palette list.

How to rename a palette

1. In the Colour view, select the palette to rename.

2. Do one of the following:

‣ Right-click and select Rename.

‣ From the Colour View menu, select Palettes > Rename.

3. In the Rename dialog box, give the palette a new name and click OK.

How to remove a palette

1. In the Colour view, select the palette to remove.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Remove.

‣ Right-click on the selected palette and select Remove.

‣ Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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Duplicating a Colour Palette

A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but has a
different ID and is independent from the original palette. This ensures that both palettes are completely independent.
This option is used when there are similar models and you want to avoid recreating and naming all the colours. You
can change the values and the names afterward without affecting the original palette. You can also keep some
RGBA values, such as the eyes, teeth, tongue, insidemouth, etc.

How to duplicate a palette

1. In the Colour view, select the palette to be duplicated.

2. Do one of the following:

‣ From the Colour menu, select Palettes > Duplicate.

‣ Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.

3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage .

4. In the New Palette Name field, name the palette.

5. In the New Palette Name field, name the palette.

6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette

A character usually has only onemaster palette, although there are times when the characters are placed in
different lighting conditions and require a different colour shading. The night palette is a popular choice when a
scene or sequence changes from day to night. It can be difficult and time-consuming to repaint everything and
creating two independent palettes can be quite complex. As an alternative, Toon Boom Harmony provides clone
palettes.
The clone palette is a copy of themaster palette. The colours in each palette have the same properties. The
colours have the same identification number pointing to the same colour zones, but they can have different
names and RGBA values. Depending on the palette (night or day) you're currently using, the painted drawing will
update. So there's no need to repaint the animation. All you have to do is create or import a clone palette (palette
style).

How to clone a palette

1. In the Colour view, select a palette to clone.

2. From the Colour menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.
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3. If you're in Advanced Palette List mode, select the palette storage level—see Palette File Storage on page
108.

4. In the New Palette Name field, name the palette. We recommend keeping the "-clone" in the name.

5. Click OK.

The cloned palette appears in the palette list.

6. In the Palette list, select the clone palette you created to offset or blend colours—seeMixing Colours on page
130.

7. From the Colour View menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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8. Select one or more colours tomodify. You can select all your colours by pressing Ctrl + A (Win-
dows/Linux) or⌘ + A (Mac OS X).

9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

10. Select the Preview option to see a preview of the colours while you adjust them.

NOTE: You can also modify the colours individually with the Colour Picker window.

Importing and Linking Palettes

Before starting colouring work such as ink and paint or even creating new colour models, youmay want to load
existing colour palettes to your scene. You can do so by linking colour palettes to your palette lists.

Youmay encounter a case where only a colour palette is visible when a layer is selected. If you need that palette
in a second layer, you can link the palette to the second layer's palette list. A good example would be a scene
where there is a character on one layer and its arm is on another. In order for both layers to access the palette,
youmust link both Element Palette lists to that palette. If your palette is linked to the Scene Palette list, it will be
accessible by all layers.
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If you created a palette in another project and you want to import it in your current project, you can browse for the
palette file on your computer and add it to your scene. When the palette is imported in your scene, the file is copied in
the project’s directory. It is not linked to the original file.

With Toon Boom Harmony as a stand-alone application, every scene is local to themachine. This means that all of
the scene’s data is only accessible from that particular scene. Palettes are also local to the scene; they can be
shared between all drawing layers, but not between scenes.

However, youmay want to share palettes across a whole project. Harmony offers that possibility. By default, a
palette is an independent file stored in your scene. This file can be copied, moved, or deleted.

To link a palette throughout an entire project, you need to create a central directory where you can copy all the
palettes you created. Every time you link a palette in an element, it is linked to this folder. If youmodify the palette, it
will be updated throughout the whole project.

You will notice that when you create or link a palette, a small icon appears on its left. These icons represent the
palette's link status.

Icon Description

Indicates that the palette is safe.

There won’t be any problems once the scene is exported. For example, the palette file is stored
in the scene folder and is linked to the Scene Palette List.

Indicates that the palette file is stored in a directory external to the scene’s structure.

The palette file is probably stored in aMaster Palette directory on a hard drive external to the
palette-libraries planned for the palette storage. The warning in this case is that if youmove your
Master Palette directory to another location, youmay loose the palette in your scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is
linked to a Palette list that is not on the same level.

For example, a palette file is stored into the Environment folder and is linked to the Element
Palette list. The palette is shared.

Indicates a potentially dangerous situation.

Problems may occur when trying to export or link to the palette file. For example, a palette file is
stored into the element folder and is linked to the Scene Palette list. The issue in this case is
that if you decide to delete the layer containing the palette, it will be lost from your scene.

How to link a colour palette

1. Do one of the following:

‣ From the Colour View menu, select Palettes > Link.

‣ Right-click and select Link.

‣ Click the Import button.

The Palette Browser: Link Palette dialog box opens.
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2. Select the level where the palette file is stored—see Palette File Storage on page 108.

3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—see
Palette Lists on page 105.

The palette appears in the Colour view.

How to import a palette into your project

1. Do one of the following:

‣ From the Colour menu, select Palettes > Import.

‣ Right-click and select Import.

The Browser window opens.

2. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in your pro-
ject's palette-library directory.

3. Click Open.

The Palette Browser opens.
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4. If you're in Advanced Palette mode, select the level where the palette file is stored—see Palette File Storage .

5. If you're in Advanced Palette mode, select the palette list linking level by enabling either Scene Palette List
or Element Palette List—see Palette Lists.

6. In the New Palette Name, name the imported palette.

The palette appears in the Colour view and the file is copied in your project.

How to link to an external palette

1. In the Colour view, click on the Create Palette button to create a palette to be used as external.

2. Save your scene by selecting File > Save from the topmenu or by clicking the Save button or press Ctrl
+ S (Windows/Linux) or⌘ + S (Mac OS X).

3. On your computer or server, create amaster directory. Ideally, this should be created in your Root folder to
keep it within the project directory. You could also place it inside your Colour Model’s subdirectory—see
Chapter 6: Project Organization and File Structure in the Fundamentals Guide.

4. Name the folder appropriately, for example: Joe_master_palette.

5. From your operating system, browse to your Toon Boom Harmony scene and open the palette-library folder.
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6. Select and copy your palette *.plt file to copy it to themaster palette directory.

7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette.

8. In the Timeline or Xsheet view, select the element to link the palette to.

9. From the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

10. Click Browse to search for your master palettes folder and select the palette *.plt file you want to link.

11. In the Palette list section, select how you want to load the palette; at the scene or element level.

12. Click OK.

The linked palette appears in the Colour view.

If a palette is outside the scene, the External icon appears beside the palette name.
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NOTE: To link an element (such as a colour model) to the palette that is stored in the external palette directory, you
must remove the original palette from the element’s palette list. You will then load the duplicated palette into the
palette list using the Link to External command, like you did for the other elements.

Colours
Toon Boom Harmony has some very powerful colouring features when it comes to painting. To paint your drawings,
you will use different colour swatches, unlike some other painting programs where youmodify themain swatch each
time you want to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You can
add as many swatches as you want. You can also rename them andmodify existing ones.

When youmodify the colour of an existing swatch, it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones.
This way, you can change the look of your character at any time without having to repaint it!

This section is divided as follows:
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• Adding a Colour Swatch

• Editing Gradients and Textures on page 127

• Colour Display Modes on page 128

• Copying and Pasting Colours on page 129

• Mixing Colours on page 130

Adding a Colour Swatch

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap texture
swatches.

How to add or modify a solid colour swatch

1. In the Colour view, click the Add Colour button.

2. From the Colour view menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens.

3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options to
change the look of the colour picking area.
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‣ Click the Dropper button to select any colour on your screen. It can be from the Harmony interface,
your operating system or any other open application.

How to add a new colour swatch using the default colour

‣ From the Colour View menu, select Colours > New.

A new swatch is added to your palette using the default colour swatch colour. The new swatch created with
the New commandwill be named New 0.

How to create a gradient colour swatch

1. In the Colour view, select a colour to modify .

2. Do one of the following:

‣ Click the new colour and from the Colour View menu, select Colours > New.

‣ Double-click on the colour swatch.

The Colour Picker window opens.
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3. Select the Gradient option.

4. Select the Linear or Radial option.

5. Adjust the Gradient arrows tomodify the colours.

‣ Add extra colours by clicking between the arrows below the gradient bar. Then click on the Colour
Preview to select a colour.

‣ Pull down the arrows to remove them.

‣ Move the arrows left and right to modify the gradient distance.

NOTE: To learn how to reposition the gradient zones in your drawings, see Editing Gradients and Textures on
page 127.

How to create a texture colour

1. From the Colour menu, select Colours > New Texture or click the New Texture button.

The Browser window opens.

2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.
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NOTE:
To learn how to reposition the textured zones in your drawings, see Editing Gradients and Textures on page 127.

You can also replace a texture once it is painted. If you decide tomake the character’s shirt wool instead of plaid,
just update the texture file in the swatch and the entire project updates. Any transformation previously applied to the
texture’s position in your drawings will be kept.

How to replace a texture swatch

1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

2. From the Colour View menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

3. Browse for the new PSD or TGA bitmap file created in a third party software.
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4. Click Open to update the colour swatch.

How to delete a colour swatch

1. In the Colour view, select the colour swatches to delete.

2. Do one of the following:

‣ From the Colour View menu, select Colours > Delete.

‣ Click the Delete Colour button.

‣ Right-click and select Delete.

‣ Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OK to delete the colours or click Cancel to abort the operation.

‣ If you delete colour swatches already in use, the zones painted with them turn red so you can easily
identify them.
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Editing Gradients and Textures

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its position
in the zone. You canmove, scale, rotate and skew. If you want to match the colour to the animation, set the first
texture position and copy the Edit Gradient/Texture position. Whenmoving to the next drawing, you can select the
next texture and paste the previous position to continue themodifications.

If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your gradient’s
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them
afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawnwith textured
“brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both elements
independently at the same time.

How to use Edit Gradient/Texture tool

1. Do one of the following:

‣ In the Tools toolbar, click the Edit Texture tool.

‣ Press Shift + F3.

2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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3. Edit the gradient or texture by adjusting the control handles around the selection frame.

Colour Display Modes

The Colour view has two display modes:

• List

• Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This
option is not available when displaying the colours in Swatchmode.

How to switch between the display modes

1. From the Colour View menu, and do one of the following:

‣ Select Colours > Swatch Mode to display the swatches.

‣ Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

‣ From the Colour View menu, select Palettes > Display Colour Values.

128



Harmony 12.2 Essentials - Cut-out Animation Guide

The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The gradient
colour swatches will be identified as (gradient).

Copying and Pasting Colours

When you're creating palettes, youmay want to copy colour swatches or their values and paste them in other
palettes to save time. You can also quickly copy a colour value from a palette in your scene to a selected colour
swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, it is
impossible to use the Paste as Clone command in the same palette as you copied the original colour swatch from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can copy the
colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

How to copy and paste colours

1. In the Colour view, select one or more colours to copy.

2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or⌘ + C (Mac OS X).

3. In the Palette list, select the palette in which you want to paste the colours.

4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V (Windows/Linux) or
⌘ + V (Mac OS X).

‣ To paste the colour values of the copied swatch over an existing colour swatch, select Colours > Paste
Colour Values.

How to clone a colour swatch

1. In the Colour view, select the colour swatch you want to clone.
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2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or⌘ + C (Mac
OS X).

3. In the Colour view, select the colour palette you want to paste the clone into or create a new palette.

4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

1. In the Colour view, select the colour swatch you want toget the ID from.

2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or⌘ +
C (Mac OS X).

3. Paste the copied value as plain text in the desired document.

Mixing Colours

If you want to modify a series of colours to blend a tint in them or offset their RGBA values, you can use the Tint
panel. You can also create palette styles, such as night and day styles.

How to mix colours

1. In the Colour view, select the palette that contains the colours you want to offset or blend.

2. Do one of the following:

‣ From the Colour View menu, select Palettes > Tint Panel.

‣ Right-click and select Tint Panel.

The Tint Blend/Offset panel opens.
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3. Select one or more colours tomodify in the colour list. To select all the colours, press Ctrl + A (Win-
dows/Linux) or⌘ + A (Mac OS X).

4. Select Preview option.

5. Select the Offset, Blend, or Mixer option.

Parameter Description
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Offset
Offsets the selected colours by the adjustments made using the HSB and RGB
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider
to adjust the opacity of the selected colour.

Blend

Blends the selected colours with the colour swatch in the top-right corner. Use the
Amount slider to adjust the degree of blend. A blend of 100% turns the selected
colours into the same colour as the swatch. Adjusting the HSB and RGB sliders
affect the swatch colour, which in turn affects the selected colours on the left.
Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use the slider just
beneath tomix the Base and Tint colours by different amounts. This will affect the
mixed swatch whether it is selected or not. Select either the Tint or Base swatch
and use the HSB and RGB sliders to adjust its colour. This will affect themixed
swatch colour, which in turn affects the selected colours on the left.

6. Click Apply.

Painting the Model
Now that you've created the colours and the palette, you're ready to paint your model.

The colour model needs to be painted in order to adjust the colours with the other elements in the production. You
can paint your model regardless of the colour RGBA and adjust them later when all the elements are together.

For paperless and cut-out animation, it's a good idea to provide a line-up template with the colour model to show
the scale ratio between the characters, props and backgrounds.
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Once your colour model is completed, create a line-up template by pasting one of the production's main characters,
or even just a hand, beside the colour model to show the relative size. This allows the animator, layout artist, or
scene setup artist to retain the correct scaling throughout the entire project when setting the elements in the scene.
You can store your template in the Library.

How to paint a colour model

1. Create your master colour palette—see Creating a Colour Palette on page 109

2. Add new colours to the palette—see Adding a Colour Swatch on page 122.

3. Select your Paint Bucket tool. We recommend the Paint Unpainted tool.

4. In the Colour view, select a colour to paint your drawing.

5. Paint themodel by selecting colour swatches in the palette and clicking on your drawing. Note that only
closed zones will be painted. If there's a gap in your artwork, youmust close before you can paint it.
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6. Adjust the colours—seeMixing Colours on page 130.
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Chapter 4: Timing

When you create hand-drawn animation traditionally or in a paperless environment, it's important to know how to set
andmodify the timing of your drawings.

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper exposure sheet
created by the animator. In a paperless workflow, the animator creates andmanages their own exposure sheet
directly in Harmony without the need for reproduction.

If you're more of a traditional animator, you will probably work with an exposure sheet. If you're a digital animator,
youmay prefer to work with a timeline to visualize your timing. Harmony offers both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-drawn
animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as layers.

You can adjust timing in both views; your choice depends on which technique you're accustomed to using.
Depending on your working style, some actions may seem preferable to do in one view instead of another. Many of
the actions you perform in the Xsheet can also be accomplished in the Timeline. This chapter will often show both
techniques. You can choose which one you prefer.

In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and animation paths
for symbols are covered in separate chapters.

NOTE: The exposure sheet is not mandatory for cut-out animation. It can be useful for creating characters and parts,
but is not really needed for animation and timing. If you plan to work with cut-out animation, you can still learn useful
tips by reviewing the section on exposure sheets.

The basic digital exposure sheet process is divided into the following steps:

Preparation
The digital exposure task is quite simple. There are very few things to prepare in order to get ready.

Opening the Scene

The scene is generally created during a previous step, such as scanning (in a traditional animation workflow), scene
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set up, digital layout, or production organization.

Using the Workspace

The person creating the exposure sheet will need only the Xsheet view to create the digital exposure sheet,
although the Timeline view may also be helpful. If you're doing paperless animation, use the Camera or Drawing
view if you want to sketch at the same time.

If you work with this layout often, you can use theWorkspaceManager to save it as a workspace,and name it
Xsheet, for example.

While drawing and animating paperless animation, you can use theWorkspaceManager to save a frequently
used layout and name it Paperless Animation, for example.

Preparing References

To start an exposure sheet, you need to prepare your references. For traditional animation, you will need to
reproduce the animator's paper exposure sheet. If you're working remotely, the studio can scan the paper
exposure sheet using third-party software and send the digital files to be opened and viewed digitally.
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In paperless animation, you will usually create an exposure sheet from the Xsheet view.The information from your
layout and posing or storyboard will help you approximate how many elements are required in the scene.

Setting the Scene Length
Once the references are ready, you need to set the scene length by adding the right number of frames to your scene.
You can set the global scene length from the topmenu.

In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length

1. From the topmenu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

How to extend or reduce the scene length in the Timeline view

When you remove frames at the end of a scene to reduce the scene length in the Timeline view, the exposed
drawings and symbols are not deleted. They're still available if you extend the scene afterward.

1. In the Timeline view, drag the scene length bracket:

‣ Right: To addmore frames to your scene.

‣ Left: To reduce the number of frames in your scene.

How to add frames in the middle of a scene

You can add frames anywhere in themiddle of the scene—before or after a selection. If you select a frame row in the
Xsheet view, Harmony will add the new frames before or after the selection, depending on your choice.

1. Do one of the following:

‣ In the Timeline view, select the frame to which you want to add frames before or after.

‣ In the Xsheet view, select a frame row.
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‣ In the Timeline view, select the frame to which you want to add frames before or after.

2. Do one of the following:

‣ From the topmenu, select Scene > Frame > Add Frames Before Selection or Add Frames After
Selection.

‣ In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add Frames
After Selection.

‣ In the Xsheet toolbar, click the Add Frames button to add frame after your selection.

‣ Press Ctrl + G and Ctrl + H (Windows/Linux) or⌘ + G and Ctrl + H (Mac OS X).

The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the number of frames needed in the scene.

4. Click OK.

How to add frames at the start or end of a scene

1. In the topmenu, select Scene > Frames > Add Frames at Start or Add Frames at End.

The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames needed in the scene.
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3. Click OK.

How to remove a frame or a range of frames to reduce the scene length in the Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

1. In the Xsheet view, do one of the following:

‣ Select a frame in a given column.

‣ Select a frame range by clicking the first frame’s number and then dragging the selection highlight down to
the last frame to delete.

2. To delete the selected frames, do one of the following:

‣ From the topmenu, select Scene > Frame > Remove Selected Frames.

‣ Press Delete to delete the selection.

‣ Click the Remove Frames button. To remove several frame selections, click the button repeatedly.

If you selected a range of frames, theWarning dialog box may open.

3. To complete the operation:

‣ Click Yes to delete the selection.

‣ Click No to delete only the exposure in the cell and not the frames.

‣ Select the Don’t Show This Message Again option to prevent the warningmessage from being
displayed each time you delete a frame range.

Creating Drawings
Before filling any value or setting any timing or exposure, you need to add different drawing elements.
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Each drawing element is represented as a vertical element column in the Xsheet view and a horizontal element
layer in the Timeline view.

In Harmony, whether you work in the Timeline or Xsheet view, any modification you do to one view will be applied
to both.

To start an exposure sheet, you will use drawing elements. Drawing elements are drawing containers. Any image
file, either bitmap or vector, will use a drawing element.

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is named the
sameway as the drawing element. Its purpose is to contain all the drawings related to this element. For example,
in cut-out animation, a character can havemany heads available. All of the head drawings will be contained in this
folder, even if they are not exposed in the Timeline or the Xsheet view. There is always a drawing container
connected to a drawing element (layer, column).

NOTE: There are different element types available, such as sound and expression. A sound element contains
sound files. Expressions, Beziers, 3D path, Quadmaps and Pegs are for motion purposes during the compositing
step. It's not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scenemenu.

This section is divided as follows:

• Layer Basics on page 140

• Layer and Column Types on page 141

• Adding Layers and Columns on page 143

• Deleting Layers and Columns on page 144

• Layer and Column Properties on page 145

• Modifying Layers and Columns on page 146

• Duplicating Layers and Columns on page 147

• Cloning Layers and Columns on page 148

• Adding an Annotation Column

Layer Basics

A layer is linked to a directory, the location where all its drawings are saved. This directory has the same name as
the layer. When a name is typed in a cell ,Harmony searches the layer's directory for the corresponding drawing
to display. If there is no corresponding drawing, a new one is created.

Drawings are exposed in cells and linked to the drawings saved in the layer's directory. When you remove a
drawing from a cell, it is not displayed and still exists in the directory.

A drawing that is exposedmultiple times (for example, in a walk-cycle) would be linked to the same original
drawing in the layer's directory. If youmodify, repaint, or correct the drawing, all exposed drawings with the same
name are updated simultaneously. Youmust duplicate or create a new drawing tomodify a single exposure and
retain the others.
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When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that when
youmodify, repaint, or correct a drawing named “1,” all drawings named “1” are updated simultaneously. In order to
modify a drawing independently from its other exposures, youmust duplicate the drawing.

Layer and Column Types

A column is also known as a layer. There are several types of layers that you can add in the Xsheet and Timeline
view. Each layer is indicated by an icon to help you differentiate them. Some layers are represented differently in the
Xsheet view.

Drawing Layer

Themost common layer type is the drawing layer. Any time you need to create a vector drawing or import a symbol
or image, you can use a drawing layer. You can also create bitmap artwork on a drawing layer.

NOTE: Bitmap images are contained in bitmap layers.

Bitmap Layer

If you import a bitmap images (as original bitmap) in your project, they are inserted in a Bitmap layer. If you choose to
vectorize your image when you import, the vectorized object will be placed on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a bitmap
into a symbol, you will be able tomix vector drawings with it on the same layer.

Camera Layer

You can only have one Camera layer at a time in the Timeline view. By default, there is no Camera layer when you
create a scene. You need to add a Camera layer when you want to create a cameramotion.

The Camera layer is not visible in the Xsheet view.

NOTE: If you want to have several cameras with different settings, you can keep adding Camera layers in your
Timeline view (however, only one will ever be visible at a time as you can only have one camera at a time in your
timeline). To switch to a different camera, select Scene > Camera and select another camera layer.
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Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them.

When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in the
Functions section of the Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene has no
background colour and if you render it as a QuickTimemovie or image sequence, it will have a black background.

This layer is not visible in the Xsheet view.

Group Layer

A Group layer can be used to organize the Timeline view. You can drag and drop other layers onto aGroup layer
and then collapse the Group layer to hide these other layers from view.

If you create the Group layer in the Timeline view.

Peg Layer

A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to any drawing
layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the Functions
section of the Xsheet view.

Quadmap Layer
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A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This can
be attached to any drawing layer, cut-out puppet, or even other Peg layers. They will all follow the deformation you
set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are displayed in the
Functions section of the Xsheet view.

Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your
Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types

In the Xsheet view, you can add several advanced column types to create particular animation paths. When you
create these columns, they are not linked automatically to any particular drawing layer. You can create amotion path
using these columns and then link or unlink several drawing or peg layers to it.

Advanced column types include:

• Timing

• 3D Path

• 3D Rotation

• Bezier Curve

• Expression

• Annotation

Adding Layers and Columns

There are different ways to add a drawing layer to your project. By default, when you create a new scene there is one
Drawing column in the Xsheet view and one corresponding Drawing layer in the Timeline view.

You can add an element for each drawing and it will appear as a column in the Xsheet view, a layer in the Timeline
view.

How to add a drawing element from the Timeline view

1. In the Timeline view, click the Add Drawing Layer button or press Ctrl + R (Windows/Linux) or⌘ + R
(Mac OS X).

The Add Drawing Layer window opens.
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2. In the Name field, name your new layer.

3. Do one of the following:

‣ Click Add to add a first layer and keep the window open to addmore layers.

‣ Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

How to add a drawing element from the top menu

1. From the topmenu, select Insert > Drawing.

The Add Drawing Layer dialog box opens.

2. In the Name field, type a relevant element name and click OK.

The new drawing element appears in your scene.

Deleting Layers and Columns

You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

1. In the Timeline view, select the layers to delete.

2. Do one of the following:

‣ In the Timeline’s Layer toolbar, click the Delete Layers button.

‣ Right-click on the selection and select Delete.

How to delete columns in the Xsheet view

1. In the Xsheet view, select the columns to be deleted by clicking on their header.
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2. Do one of the following

‣ Right-click on the selection and select Delete Columns.

‣ In the Xsheet toolbar, click the Delete Columns button.

‣ Press Delete.

The Confirm Delete dialog box opens.

3. To complete the operation:

‣ Click OK to delete the selected layers.

‣ Click Cancel to cancel the operation.

Layer and Column Properties

Each element has its own set of properties that you canmodify, including effect and peg layers.

If you want to modify an element’s properties, you can display the properties of a selected layer in the Timeline view.
If you're working with the Xsheet, you can display its properties as well. You can display a layer's properties as a
window or as a view of its own.

The Layer Properties editor allows you to:

• Rename the layer

• Enable or disable the layer

• Lock the layer

• Change the track colour

The Column Properties editor allows you to:

• Rename the layer

• Enable or disable the layer

How to display a layer's properties

1. Do one of the following:

‣ In the Layer Properties view is not part of your workspace, from the topmenu, select Windows > Layer
Properties. In the Timeline view, select a layer

‣ In the Timeline view, double-click on a layer.

‣ Press Shift + E.
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The properties display.

Modifying Layers and Columns

Once you add layers and columns to your project, you canmodify their properties, names, or ordering.

You can change the order of your elements in the Timeline view and Xsheet view. When you change the order of
your elements in one view, the other one is updated.

How to rename a layer in the Timeline view

1. In the Timeline view, double-click on the name of the layer to rename.

2. In the Name field, rename the layer and press Enter/Return.

How to rename a layer in the Layer Properties editor

1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

2. In the Name field, rename the layer.
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3. Click Close.

How to reorder layers in the Timeline view

1. In the Timeline view, select the layers tomove.

2. Drag the selection to the new location.

3. Do one of the following:

‣ Drop the selection on an existing layer to make it a child of another element layer.

‣ Drop it between the existing layers. Timeline layers that are located above the selection are displayed in
front it. Layers located under it in the Timeline View are displayed behind it.

How to reorder columns in the Xsheet view

1. In the Xsheet view, click on the column’s header with themiddlemouse button.

2. Drag the column to its new position.

Duplicating Layers and Columns

Duplicating an element provides you with a copy of the drawings and their exposure. You canmodify anything you
want in the duplicated element without affecting the original one.

How to duplicate an element

1. In the Timeline or Xsheet view, click the layer or column to duplicate.
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2. Do one of the following:

‣ (Xsheet) Right-click on the column and select Duplicate Selected Columns.

‣ (Timeline) Right-click on the layer and select Duplicate Selected Layers.

The new duplicated layer or column appears.

Cloning Layers and Columns

Cloning a layer or column provides you with a copy of the selected element that uses the same drawings as the
original. For example, if youmodify a drawing in the cloned or original column, it is updated in both columns.

You can choose whether or not to copy the column timing to the cloned columns.

• You canmodify the column timing independently from each other, but the drawings remain linked.

• You can copy the columns timing, so drawings and timings remain linked.

You can clone selected nodes from the Node view in the sameway.

This is useful when you want to reuse a hand-drawn animation but have different timings.

How to clone an element

1. In the Timeline or Xsheet view, select the layer or column to clone.

2. Do one of the following:

‣ From the topmenu, select Edit > Clone: Drawings Only to clone only the layer or column drawings.

The new cloned layer or column appears.

Filling Exposure
Harmony provides different tools to fill in exposures and values, create cycles, and set increments.

This section is divided as follows:

• Filling ExposureMode on page 149

• Typing Exposure on page 150

• Holding Exposure on page 151
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• Extending a Single Exposure on page 151

• Extending an Exposure Sequence on page 152

• Extending the Exposure of Previous Drawings on page 154

• Dragging Cells on page 155

• Increasing and Decreasing Exposure on page 157

• Inserting Blank Cells on page 160

• Setting the Exposure on page 161

• Filling a Selection with a Single Exposure on page 163

• Filling a Selection with a Sequence on page 163

• Filling a Selection Randomly on page 164

• Filling Empty Cells on page 165

• Deleting Exposure on page 159

• Creating Cycles on page 166

• Managing Key Exposures on page 167

Filling Exposure Mode

In the Xsheet view, you can fill columns using two different fillingmodes: Overwrite or Insert. Thesemodes control
the filling behaviour. The Timeline view only uses the Overwrite mode.

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence overwrites
existing ones. The existing timing sequence remains in the same place and is not pushed down the column.

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence over
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down the
column.
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How to switch between Overwrite and Insert modes

1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click Overwrite/Insert.

‣ Press I.

Typing Exposure

If you want to type an exact drawing name or value in the Timeline view, youmust use the Parameters section of
the Timeline.

NOTE: You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

How to type a value in the Timeline view

1. In the Drawing Substitution field, double-click to edit the field and type the name of the drawing you want to
create.

2. Press Enter/Return to validate the value.
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Holding Exposure

Drawings in an animation project are often exposed for more than one frame. Themost common exposure of a
drawing is two frames. In the industry, this type of exposure is known as animation in double frames or animation on
twos. A drawing can also be exposed for three, four, or five cells and so on. To prevent mistakes and save time, you
can hold cells automatically as you type in the Xsheet view.

How to hold exposure

1. Do one of the following:

‣ From the topmenu, select Animation > Cell > Hold Exposure > the desired option.

2. Type a value or drawing name in the cell.

‣ Press Enter/Return tomove on to the next cell.

‣ Press Esc to quit the typingmode.

Extending a Single Exposure

Extending the exposure lets you select a cell that contains a value and pull it down to the desired frame.

How to extend a cell exposure gesturally

1. In the Xsheet view, select the red arrow in the cell’s right side. Make sure you see the drag down cursor.

2. Pull down the selected cell to the desired frame.

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is considered
cancelled.
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How to extend a sequence from the top menu

1. Select a cell and do one of the following:

‣ From the topmenu, select Animation > Cell > Extend Exposure.

‣ Press F5.

The Extend Exposure dialog box opens.

2. Enter the frame number you want to extend the cell to.

Extending an Exposure Sequence

Whenworking with a sequence that contains only numbers, you can extend an exposure sequence in a similar
manner to extending a single exposure.

How to extend an exposure to create a sequence

1. In the Xsheet view, select a cell containing a number.

2. In the selected cell, click the red arrow on the cell’s right side. Make sure to see the drag down
cursor.

3. Hold down the Shift key. Make sure a plus sign (+) appears.

4. Pull down the selection box to the desired frame.
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NOTE: The red selection box must be visible when releasing the cursor. If not, the action is considered
cancelled.

5. First release the Shift key, then release themouse button.
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Extending the Exposure of Previous Drawings
When drawing on a blank frame you can automatically create a new drawing and extend the timing from the
previous exposed drawing.

In the following example, a cell is selected on the timeline for creating a new drawing in image A. In image B, the
previous exposure does not extend to the new drawing, while in image C, it does.

How to extend the exposure of previous drawings

1. Open the Preferences dialog box by doing one of the following:

‣ From the topmenu, select Edit > Preferences.

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (Mac OS X).

The Preferences dialog box opens.

2. Select the General tab.
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3. In the Timeline section, select the Extend Exposure of Previous Drawing option.

4. On the left side of the Timeline view, select a cell and create a new drawing.

The previous exposure automatically extends to the beginning of the new drawing.

Dragging Cells

To readjust your timing, you can drag one or more cells to a new location. You can drag a cell to any other frame in
the same column or into another column.

You can turn off the Gestural Dragmode for the Xsheet view to prevent drawings from being dragged from one
location to another. This feature does not apply to Annotation columns.

How to drag a cell to another location in the Timeline view

1. In the Timeline view, select one or more cells to move.

2. Drag the cells to the new location.

3. Drop the selection by doing one of the following:

‣ Drop by simply releasing themouse or pen.

‣ Hold Ctrl (Windows/Linux) or⌘ (Mac OS X) while dropping the selection to copy the cells. The original
cells will not bemoved.

‣ Press Shift while dropping the selection to insert them between existing frames.
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How to drag a cell to another location in the Xsheet view

1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, position the pointer over the small dotted area on the left side of the selected cells.

3. Drag the selection to any other cell in the same column or in another column.

4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.
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‣ Hold downCtrl (Windows/Linux) or⌘ (Mac OS X) while dropping the selection to copy the cells. The
original selection will not bemoved.

‣ Press Shift while dropping the selection to insert it between existing frames.

Increasing and Decreasing Exposure

Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

Increasing the exposure adds onemore exposure to a selected cell; repeating this action adds an extra cell each
time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing an
exposure pushes the existing exposure forward.

Decreasing the exposure removes one exposure from a selected cell and pulls any cells following it to the beginning
of selection.
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How to increase exposure

1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:

‣ From the topmenu, select Animation > Cell > Increase Exposure.

‣ In the Xsheet toolbar, click the Increase Exposure button.

‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be
exposed.

‣ Right-click and select Exposure > Increase Exposure.

‣ Press +.

How to decrease exposure

1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:

‣ From the topmenu, select Animation > Cell > Decrease Exposure.

‣ In the Xsheet toolbar, click the Decrease Exposure button.

158



Harmony 12.2 Essentials - Cut-out Animation Guide

‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be
exposed.

‣ Right-click and select Exposure > Decrease Exposure.

‣ Press -.

How to use the Clear Exposure and Pull feature

1. In the Timeline or Xsheet view, select a range of cells.

2. Do one of the following:

‣ From the topmenu, select Animation > Cell > Clear Exposure and Pull.

‣ Right-click and select Exposure > Clear Exposure and Pull.

‣ In the Xsheet toolbar, click the Clear Exposure and Pull button.

The exposure is reduced by the selected number of cells.

Deleting Exposure

You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the Timeline or
Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by typing its name again in a
cell.

You can delete the exposure in a selected cell range or delete the entire exposure of a drawing exposed over several
cells. Note that you can also delete the exposure for drawings inside a collapsed group.

How to delete selected exposures

1. In the Timeline or Xsheet view, select the exposure you want to delete.

2. Do one of the following:

‣ Right-click and select Delete.

‣ Press Delete.
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How to clear the entire exposure of a drawing

1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

2. Do one of the following:

‣ From the topmenu, select Animation > Cell > Clear Exposure.

‣ In the Timeline view, right-click and select Exposure > Clear Exposure.

Inserting Blank Cells

You can place an empty cell between other cells.

How to insert blank cells

1. In the Timeline or Xsheet view, select the cell in which you want to insert a blank cell.

2. Do one of the following:

‣ In the topmenu, select Animation > Cell > Insert Blank Cell.

‣ Right-click and select Exposure > Insert Blank Cell.

‣ In the Timeline or Xsheet toolbar, click the Insert Blank Cell button (youmay have to customize
the toolbar to display it).

‣ Press Shift + J.

A blank cell is inserted.

160



Harmony 12.2 Essentials - Cut-out Animation Guide

How to clear a selected cell range without changing the exposure and timing

1. In the Xsheet view, select a frame range to clear.

2. Right-click and select Clear.

Setting the Exposure

You can easily increase or decrease the exposure for a selected cell range.

How to set the exposure

1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.
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2. Do one of the following:

‣ From the topmenu, select Animation > Cell > Set Exposure to > Set Exposure to 1, 2, 3, or Set
Exposure.

‣ In the Timeline toolbar, click one of the Set Exposure buttons (youmay have to
customize the toolbar to display them).

‣ In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 1, 2, or 3,
or Set Exposure.

3. If you chose the Set Exposure option, the Set Exposure dialog box opens. Enter the number of frames you
want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.
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Filling a Selection with a Single Exposure

You can fill the same value over an entire selection. The selection can be over one cell, a cell range in one column, a
cell range over many columns, an entire column, or many columns. You can use numbers, words, letters, or any
alphanumeric value.

How to fill a selection with a single exposure

1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:

‣ From the topmenu, select Animation > Cell > Fill Selection.

‣ Press Ctrl + T (Windows/Linux) or⌘ + T (Mac OS X)).

The Fill Selection dialog box opens.

3. In the Value field, type the desired value.

4. To insert a key exposure in the frame following the last cell in the selection, select the Add Key Exposure
After option. Otherwise, leave it deselected.

5. Click OK.

Filling a Selection with a Sequence

You can create a numbered sequence over a selection. The sequence can be forward, backward, single, double or
higher increment, as a cycle, and so on. The selection can be over one cell or a cell range in one column ormore or
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an entire column ormany entire columns.

How to fill a selection with a sequence

1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:

‣ From the topmenu, select Animation > Cell > Sequence Fill.

‣ In the Timeline view, right-click and select Exposure > Sequence Fill.

‣ Press Ctrl + M (Windows/Linux) or⌘ + M (Mac OS X)).

The Sequence Fill dialog box opens.

3. In the Starting Value field, type the first number in the sequence.

4. In the Increment field, type the number by which the drawing number will increase from frame to frame. For
example, an increment of 1 gives you: 1-2-3-4; an increment of 2 gives you: 1-3-5-7; and -2 gives you
this: 8-6-4-2.

Filling a Selection Randomly

You can fill in random values over a selection. You can give amaximum and aminimum value and create a range
for Harmony to choose the random values from. The selection can be over one cell or a cell range in one column
ormore or an entire column ormany entire columns.

How to fill cells randomly

1. In the Timeline or Xsheet view, select a cell range.
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1. In the Xsheet view, click the Fill Cells Randomly button (youmay have to customize the toolbar to dis-
play it).

The Fill Cells Randomly dialog box opens.

2. In theMinimum Value field, enter the lowest acceptable value.

3. In theMaximum Value field, enter the highest acceptable value.

4. In the Hold field, choose an exposure holding value.

5. If you are applying this option to a drawing column, select theWhole Numbers option to avoid decimal
points.

6. Click OK.

Filling Empty Cells

You can fill empty cells to extend the exposure of single frame drawings to fill the range of empty cells after each
one.When creating drawings on cells that are not side-by-side, the exposure of the first drawing no longer fills
automatically. Youmust select the frame range where you want your drawings to hold their exposure up to the next
drawing and use the Fill Empty Cells command.
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How to fill empty cells

1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:

‣ Right-click and select Exposure > Fill Empty Cells.

‣ From the topmenu, select Animation > Cell > Fill Empty Cells.

‣ In the Timeline toolbar, click the Fill Empty Cells button.

Each drawing in the selection is exposed in the range of empty cells that follow it.

Creating Cycles

Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.

You can loop your drawings using the following command:

• Create Cycle

When you create a drawing cycle, all the repeated drawings are linked to the same original files. Whenmodify,
repaint, or correct a drawing named “1” for example, all drawings named “1” are updated simultaneously. In order
to modify a drawing independently from its other exposures, youmust duplicate the drawing.

How to create a cycle

1. In the Timeline or Xsheet view, select the cell range to loop.

2. In the Timeline toolbar, click the Create Cycle button (youmay have to customize the toolbar to dis-
play it).

The Create Cycle dialog box opens.
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3. Enter the number of cycles you want, including the current selection.

Managing Key Exposures
Before working with key exposures, it's important to understand how keyframes, exposure and key exposure work
in Harmony:

• Keyframe: A keyframe is a point in time where a change to the properties of the object or character occurs. In
Harmony, keyframes consist of the coordinates that determine how an entire layer and its contents are
moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

• Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames. In
Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. Keyframes
can bemoved independently from the drawing exposure.

• Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed on
a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for another
one, then the original drawing is retained. This preserves the key drawing. Note that Harmony automatically
sets a key exposure when you perform a drawing swap.

Adding Key Exposures

Key exposures aremainly used for swapping drawings in cut-out animation where you will have numerous drawings
for the various positions of themouth or eyes of a character for example.

If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This prevents
it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property of an exposure
that forces it to be exposed on a certain frame regardless of whether the previous exposure is the same drawing or
not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be automatically
updated even if set as a key exposure. This keeps your existing animation key poses intact. It is frequently used on a
mouth or eyes layer.

Example: Swapping a drawing with no key exposure

In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure.

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.
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Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is
positioned in themiddle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing 5 for
drawing 1, the second drawing 5 retains its exposure.

How to add a key exposure

1. In the Timeline view, select the drawing cell to set as the key exposure.

2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure button.

‣ In the Timeline toolbar, click the Add Key Exposure button.

‣ Right-click and select Exposure > Add Key Exposure.

A new key exposure is added. 

If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing
is split in two and both parts contain the same drawing.

Removing Key Exposures

When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure
is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When
the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).
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How to remove a key exposure

1. In the Timeline view, select a key exposure to remove.

2. Do one of the following:

‣ In the Timeline toolbar, click the Remove Key Exposure button.

‣ Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.

Removing Duplicate Key Exposures

Whenworking with drawings to adjust the timing of amouth in a lipsync, for example, and forcing the use of specific
key exposures, unnecessary key exposures will be created. You can delete these duplicates without affecting the
rest of the drawing. The first drawing of the selection will be used for the range.

NOTE: Duplicate key exposures may occur when pasting with the Enforce Key Exposure option selected.

How to remove duplicate key exposures

1. In the Timeline view, select the layer that contains duplicate key exposures.

2. In the Timeline toolbar, click the Remove Duplicate Key Exposure button (youmay have to customize
the toolbar to display it).

Navigating between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, and layers
using keyboard shortcuts that work in the Camera, Drawing, Xsheet and Timeline views.

You can navigate through:

• Drawings

• Frames
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• Columns

How to navigate through drawings, and frames and columns

1. In the Timeline or Xsheet view, select a cell.

2. Once the cell is selected, you can navigate between:

‣ Previous and next layers: From the topmenu, select Drawing > Previous Layer and Next Layer or
press H and J.

‣ Previous and next drawings: From the topmenu, select Drawing > Previous Drawing and Next
Drawing or press F andG..

‣ Previous and next frames: From the topmenu, select Play > Previous Frame and Next Frame or
press comma (,) and period (.).
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Managing Drawings
Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files stored in the
project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit the file and
not the cells.

This section is divided as follows:

• Renaming a Drawing on page 171

• Deleting a Drawing on page 172

• Duplicating a Drawing on page 172

• Copying and Pasting Drawings on page 173

• Merging Drawings on page 175

Renaming a Drawing

To rename a drawing, you need to select the drawing cell and use the RenameDrawing command.

How to rename a drawing

1. In the Timeline or Xsheet view, select the drawing to rename.

2. Do one of the following:

‣ Right-click and select Drawings > Rename Drawing.

‣ In the Timeline toolbar, click the RenameDrawing button (youmay have to customize the toolbar to
display it).

‣ Press Ctrl + D (Windows/Linux) or⌘ + D (Mac OS X).

The RenameDrawing dialog box opens.
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3. In the New Name field, type in the new drawing name.

Deleting a Drawing

You can permanently delete a drawing file from a project's folder.

NOTE: Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing

1. In the Timeline or Xsheet view, select the drawings to delete.

2. Do one of the following:

‣ From the topmenu, select Drawing > Delete Selected Drawings.

‣ Right-click and select Drawings > Delete Selected Drawings.

Duplicating a Drawing

If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing.
The exposure of the original drawing that was on the current cell is removed. The original drawing is not deleted
from the project folder or other cells in which it is exposed.

With Toon Boom Harmony, you can create a keyframe at the same time as you duplicate your drawing. This way,
you canmodify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

1. In the Timeline or Xsheet view, select the drawing to duplicate.

2. Do one of the following:

‣ From the topmenu, select Drawing > Duplicate Drawings.

‣ Right-click and select Drawings > Duplicate Drawings.

‣ In the Xsheet toolbar, click the Duplicate Drawing button.
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‣ Press Alt + Shift + D.

Copying and Pasting Drawings

When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual
drawings, you are pasting the exposure. Exposure is a property; it is the length of time that a drawing is visible over a
series of frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings.
Keyframes can bemoved independently from the drawing exposure.

If you want to copy and paste selected drawings into a different layer or paste the selection in the same layer to
duplicate the drawings, youmust use the Paste Special feature.

There are four different ways to paste your selected drawings with the Paste Special dialog box:

When adding exposures to a drawing layer, drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new
drawings will be created only when drawings with the same name do not already exist in the
destination.

Replace existing drawings. Create drawing files when they do not exist: Replace drawings with
the same names to update a scene with new modified drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a template, such as
when placing new drawings after the animation, then delete the template's animation. It
will still have updated the drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new drawings will always
be created. If drawing files with the same name already exist, Harmony will create a new name for the
drawing.

If you want to perform another Paste Special operation using the same settings you used previously, you can use
the Paste Special Again command instead. You can paste your selection using the same settings as in themost
recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

1. In the Timeline or Xsheet view, select the drawings to copy and press Ctrl + C (Windows/Linux) or⌘ + C
(Mac OS X).
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2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

3. Do one of the following:

‣ Right-click and select Paste Special.

‣ From the topmenu, select Edit > Paste Special.

‣ In the Xsheet or Timeline toolbar, click the Paste Special button (youmay need to customize the
toolbar to display it).

‣ Press Ctrl + B (Windows/Linux) or⌘ + B (Mac OS X).

The Paste Special dialog box opens.

4. In the Drawings section, select the Always Create Drawings or Only Create Drawings When They Do
Not Exist option.
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How to paste new drawings with the previous Paste Special settings

1. Do one of the following:

‣ From the topmenu, select Edit > Paste Special Again.

‣ Right-click and select Paste Special Again

‣ In the Timeline or Xsheet toolbar, click the Paste Special Again button (youmay have to customize
the toolbar to display it).

‣ Press Ctrl + Shift + B (Windows/Linux) or⌘ + Shift + B (Mac OS X).

Merging Drawings
Combines all drawings. Unused columns and layers will be deleted, but the original drawing files are still accessible.

How to merge drawings in entire layers or columns

1. In the Timeline view, select the layers you want to merge.

2. In the topmenu, select Edit > Merge.

Customizing Layers and Columns

You can change the way a column in the Xsheet view displays. You can change the way a layer in the Timeline view
or a column in the Xsheet view displays. You can stay organized without changing the content of elements or your
animation output.

This section is divided as follows:

• Expanding and Collapsing Layers and Columns on page 175

• Showing or Hiding Layers on page 176

• Showing and Hiding Columns on page 1

• Xsheet Thumbnails on page 1

• Changing the Layer or ColumnColour on page 178

Expanding and Collapsing Layers and Columns

To simplify the look of the Timeline or Xsheet view, you can expand and collapse the layers and columns. If some
layers are parented to other ones, you can collapse the parent layer to hide its children.
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How to collapse or expand selected layers in the Timeline view

1. In the Timeline view, select the layer(s) to collapse or expand.

2. Do one of the following:

‣ Right-click on the selection and select Collapse/Expand > Collapse/Expand.

‣ Click the Expand Children Arrow button on the parent layer.

‣ Click the Collapse/Expand button (youmay have to customize the toolbar to display it).

‣ Press Ctrl + I (Windows/Linux) or⌘ + I (Mac OS X).

How to collapse or expand all layers in the Timeline view

1. Do one of the following:

‣ Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

‣ In the Timeline toolbar, click the Collapse All or Expand All buttons (youmay have to
customize the toolbar to display them).

‣ Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

1. In the Xsheet toolbar, click the Show Column List button to display the Functions list.

2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or expand.

3. Do one of the following:

‣ Right-click on the column’s header and select Expand/Collapse > Collapse Selection or Expand
Selection.

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:

‣ Right-click on any column’s header and select Expand/Collapse > Collapse All or Expand All.

‣ Press 0 and 9.

Showing or Hiding Layers

As you work in the Drawing or Camera view, some layers may be in the way or are used as references. You can
hide these layers tomake your work area less cluttered and easier to navigate. You can show and hide layers in
the Timeline view in several different ways.

When using the Solomode to show or hide layers, here's how it works:
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• If you have anything selected, it is not affected.

• Whenmultiple layers are selected and you enable/disable the Solomode on any of those layers, it is applied
to all the selected layers.

• Whenmultiple layers are selected and you enable/disable the Solomode on layers that are not part of the
selection, it is applied only to those particular layers.

When exporting or rendering a scene, the Solomode setting of layers is ignored.

NOTE: When a layer is affected by an inverted cutter, enabling the Solo mode for this layer will not show it unless the
mask is also enabled.

How to show or hide all layers

1. Click one of the following in the Layers toolbar:

‣ Enable/Disable All button to show or hide all layers.

Any hidden layers are unhidden, so you can view all layers.

‣ SoloMode button to view disable your current Solomode selection. Any soloed drawing or sound
layers are disabled, so you can view all layers. When you click again on the SoloMode button, you last
Solo selection is displayed.

How to show or hide individual layers

1. Do one of the following:

‣ In the Layer toolbar, click the SoloMode button.

‣ Click the layer's Enable/Disable All button to show or hide that layer.

‣ Press A to show a layer or D to hide selected layers.

‣ In the Timeline toolbar, click the Enable/Disable button (youmay have to customize the toolbar to
display it).

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet view.

How to enable the selected layer and disable all others

1. Do one of the following:

‣ Hold down Alt and click the SoloMode button of the layer you want to solo and hide all other layers.

‣ In the Timeline toolbar, click the Disable All Others button (youmay have to customize the toolbar to
display it).

In the Timeline view, you can hide or show certain types of layers such as Effect.
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Changing the Layer or Column Colour

To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and columns.

How to change the layer’s colour in the Timeline view

1. In the Timeline view, click the Change Track Colour button of the layer you want to modify.

2. In the Select Colour dialog box, select a new colour for your layer.

3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, selected
colour for easy identification. The corresponding column colour is also updated in the Xsheet.

How to reset a layer’s colour in the Timeline view

1. In the Timeline view, select the layers to reset.

2. In the Timeline toolbar, click the Default Track Colour button (youmay have to customize the toolbar
to display it).

How to change a column’s colour in the Xsheet view

1. In the Xsheet view, select one or more columns tomodify.

2. Right-click on the column’s header and select Colour > Change Columns Colour.

3. In the Select Colour dialog box, select a new colour for your columns.
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4. Click OK.

The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

1. In the Xsheet view, select the columns to reset.

2. Right-click on the column’s header and select Colour > Default Columns Colour.
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Chapter 5: Character Building

Harmony is a great tool for building characters. You can use different techniques and features to break down your
puppets.

This chapter will guide you through all the steps to create a complete simple rig. Harmony allows you to create very
advanced puppets using deformations, hierarchies and z ordering. As you practice and get familiar with those
concepts, you will be able to developmore complex rigs and combine various advanced features.

For more great options and features to create powerful rigs, refer to Deformation on page 231.

This chapter contains the following topics:

• Importing aModel on page 1

• Relative Sizes on page 1

• Studying theModel on page 186

• Setting the Default Separate Position Preferences on page 189

• Naming Conventions on page 189

• Breaking Down the Character on page 190

• Ordering the Layers on page 196

• Rigging on page 198

• Adding Extra Drawings on page 212

• Setting the Pivots on page 214

• Storing the Character in the Library on page 220

• Appendix on page 222
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About the Model

To begin breaking down your puppet, youmust first import your character into a new project. You can also draw
your character directly in the scene.

You can import your character in several different formats:

• Library template—see Library on page 255

• External vector format—see Compositing Guide > Import chapter > Import AI and PDF Files topic

Model Alignment

When setting the character model in your scene, we recommend that you to center it in the Camera view and
scale it to fit inside the safe area frame—see Field Chart on page 1.
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If you have several views of your character, place each view in a separate cell and center them one on top of
another. This will facilitate the break down process and ensure that all of your puppets are aligned and the same
size.

Photo Puppets

If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software. Then,
import your parts and vectorize them as textured images.

A good way to set and import your bitmap parts is to organize them in amultilayered PSD file.

In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all the
elements you want to import as a single layer in Harmony are grouped together in their own folder. Any layer that is
not in a folder group, by itself or otherwise, will not be imported.

Relative Sizes
Understanding the relative size of every character and prop is important for maintaining consistency and structure
throughout your project.

A productionmay contain many characters and props. It is not unusual for these to have been created by different
people. If there is no size control implemented, the characters and elements created by different artists can vary
greatly in size. When this occurs, the characters that are put together in a scene will be out of proportion. The
animator or person doing the scene setup will then have to scale them to the correct size.
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When a character or a prop is scaled down, the outline will get increasingly thinner. By the time the element is
scaled to its proper size, the outlinemay be so thin that the difference between one character's outline and
another's will not look very good.

These tips will help you to create and determine the correct relative sizes for each puppet:

• Line Up on page 184

• Field Chart on page 185

• Brush Size on page 185

Line Up

A line up consists of copying and pasting all of your character designs into the same drawing and then scaling
them so they are in proportion with each other. This line up is very important and should be handed to any
animator, layout and posing artist, or scene setup person working on the project.

For the prop design, it is recommended that you paste one of themain character's hands or even the full body
beside the prop. This enables the animator to know what size to draw or set the prop.

In your character design scene, it is a good idea to create a layer for the character line up. The line up is usually
done during the character design step. When the character builder imports themodel to the break down scene,
the size relation should be correct.
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Field Chart

The field chart in Harmony is a tool that is very useful when setting the height of characters and props. You can
display the field chart using the Show Grid option in the Camera and Drawing views.

How to display the field chart

1. Do one of the following:

‣ From the topmenu, select View > Grid > Show Grid.

‣ Press Ctrl + ' (Windows/Linux) or⌘ + ' (Mac OS X).

‣ Click the Show Grid button in the Camera View and Drawing View toolbars.

Brush Size

There are a variety of pens and brushes in Harmony and you can also create and save your own. It is a good idea to
create and save pens with precise sizes and parameters to trace and design your models and break downs—see
Drawing with the Brush Tool on page 32.
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Studying the Model

Now that you have imported or designed your model, the next step is to analyze it. This is to determine what parts
will be broken apart and how they will be divided. Will the hair be separated into one, two or three sections?Will
the hand be separated from the sleeve? To determine what is best for your character, observe themodel in the
Camera or Drawing view.

• Eyelids and Pupils on page 187

• Separating theMouth Elements and Jaw on page 187

• Keeping Fingers Attached to the Hand on page 187

• Flipping Logos on page 188

• Complete andOverlapping Pieces on page 188
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Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil and the
eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of the eyeball. For a
more advanced break down, the two eyes are separated on their own individual three-layer sets.

Separating the Mouth Elements and Jaw

To get a greater level of flexibility, you can separate the jaw from the head. You can also separate themouth shape,
teeth, tongue and interior one from another.

Keeping Fingers Attached to the Hand
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To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full
hand is a single layer with a bank of different hands stored inside. This technique is easy to work with and
produces a less mechanical effect.

Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a
character's puppet.

Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that they must be properly overlapping and
complete. A commonmistake is to trace the part just as it appears on themodel.
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Setting the Default Separate Position Preferences
Before you adding layers to your puppets, make sure the Default Separate Position is enabled.

With the Default Separate Position preference selected, when you create new peg layers, their X, Y and Z axes are
independent from each other.

For cut-out animation, you want to have three independent axes so you can control them individually.

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at the
same time.

When you separate the three positions and add a keyframe on one axis, it is not added on the other two. This gives
youmore freedom when animating with motion keyframes and nudging parts forward and backward over time.

How to set the Default Separate Position option

1. Do one of the following:

‣ Windows/Linux: Select Edit > Preferences.

‣ Mac OS X: Select Stage Essentials > Preferences.

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (Mac OS X).

2. In the Preferences dialog box, select the General tab.

3. In the Settings section, select the Default Separate Position for Pegs option.

4. Click OK.

Naming Conventions
Whenworking on a production, it is critical to keep work well organized with a naming convention chart before
starting the project. It is crucial that everyone follows the criteria laid out in the naming convention chart. When
dealing with thousands of characters, pieces and puppets, it is easy to get lost.
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Adding a Prefix or Suffix to a Layer

It is highly recommended that you incorporate a naming convention for the layers. This will be very convenient in
later steps. We suggest that you add one or two letters for the character/prop name before the part name and an
"R" or "L" for right and left to identify the corresponding character/prop:

• Character Abby's right arm = ab_r_arm.

If you plan to work with different angles for your characters (front, side, three-quarter, back), you can add one or
two letters to identify the angle:

• Character Abby's right arm, front view = ab_r_arm_f.

Breaking Down the Character

There aremany techniques you can use to break down a puppet. In this section, you will learn about one of the
most common and simplest methods. For your first character breakdown, follow these instructions to get an idea
of the way Harmony works. Once you understand Harmony's basic functions and commands, you will be able to
create your own techniques to satisfy the needs of your production.

This section is divided as follows:

• Tracing theModel on page 1

• Articulations on page 193

Tracing the Model

Themain breakdown technique shown here is to trace your model.

How to break down a character

1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R (Win-
dows/Linux) or⌘ + R (Mac OS X)—see Naming Conventions on page 189.
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2. In the Timeline view, select the layer's first cell in which you want to draw the part.

3. In the Tools toolbar, select a drawing tool.

4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see Colour
Styling on page 99.

5. In the Camera or Drawing view, draw the new part with as with as few points as possible so the pieces are
easy tomanipulation, modify or redraw. Using the Polyline tool wouldmake it easy to do this.

If you are working in the Drawing view, click the Light Table button in the Drawing View toolbar to display
the other layers as washed out colours. You can also press Shift + L.

6. You can use the Stroke tool in the Tools toolbar to create an invisible hairline if you want to close a shape
without drawing an actual stroke.

‣ Select View > Show > Show Strokes or press K to display the invisible lines.
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7. In the Tools toolbar, select the Paint or Paint Unpainted tool to colour your drawing.

8. In the Colour view, select the corresponding colour.

9. In the Camera or Drawing view, paint your drawing.

10. In the Tools toolbar, select the Select tool. Select your drawing and flatten the lines by clicking the Flat-
ten button in the Tool Properties view.

11. Repeat the entire process until the break down is completed.
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Articulations

Once your pieces are traced, you can go ahead and complete the articulations.

Articulations are an important aspect of any cut-out break down because without them, a puppet cannot move
properly and will not look good.
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If you are using deformations to animate the limbs, your articulations don't need to overlap. The deformer effect
will create the joint for you.

Classical Articulation

Classical articulation is themost popular technique for basic characters. It is quite simple and produces excellent
results, but it's not themost efficient method. In many instances, it causes limitations and extra drawing
corrections. For example, theremay be a gap in the articulation if the part is bent too far. Joint design is usually a
circle; the overlapping part cannot be sent behind without showing the joint.

Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping the
bottom layer. You can use this technique for all the articulations on your puppet.

How to create a classical articulation

1. In the Timeline view, select the cell containing the part to modify (piece located behind), such as the upper
arm.
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2. In the Tools toolbar, select the Pencil , Polyline , Ellipse , Cutter , or Contour Editor tool.

3. In the Colour view, select an outline colour.

4. In the Drawing or Camera view, use your drawing tool to make sure the joint overlaps the other part in a half-
circle shape.

If you are working in the Drawing view, click the Light Table button in the Drawing toolbar or press Shift +
L.

5. From the topmenu, select View > Show > Show Strokes or press K to display the invisible lines that may
be present in your drawing.

6. In the Drawing or Camera view, select all the strokes in your drawing.

7. In the Tools Properties view, click the Flatten button.

8. In the Drawing or Camera view, select all the strokes in your drawing.

9. Repeat the previous steps for the other articulations.

10. In the Timeline view, select the cell of the part that will be on top of the joint.

NOTE: When placing rotation pivots later on, make sure they are positioned at the centre of the
articulation.
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Ordering the Layers

At this point, it is possible that your character's pieces may show up in the wrong order.

There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level in
the Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind.
Second, you can use the Z-axis nudging (forward and backward) if you have extra views included in the same
layers (front, three-quarter, back, etc.).

This topic is divided as follows:

• Ordering the Timeline Layers on page 196

• Nudging Parts Backwards and Forwards on page 197

Ordering the Timeline Layers

In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be displayed
behind. If you havemultiple views, you should order your layers based on themost common view, which is
generally the three-quarter front.
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How to order the layers

‣ In the Timeline view, drag a layer to reorder it and drop it between other layers.

If you drop it on a layer, it will create a parent hierarchy, somake sure to drop it between layers.

Nudging Parts Backwards and Forwards

If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as the
hand, to appear in front of its parent. Yet, if youmove the hand layer above the arm layer, you will break the
hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.

NOTE: You will do the same for the layers that are not in the right order on the extra views. Do not place the drawing
on another layer. You want to keep all your drawings of the body parts in the same layers like a box containing all of
the hands or all of the shoes.

Harmony allows you tomove your elements in three dimensions:

• Up and down (Y-axis)

• Left and right (X-axis)

• Backwards and forwards (Z-axis)
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In the sameway you createmultiplane backgrounds (depth), you can perform amicro nudge of the part to be
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the Timeline
view. The forward-backward position can also be animated over time.

Repeat the following instructions for all the views.

How to nudge your parts backward and forward

1. In the Tools toolbar, select the Transform tool. Make sure to enable the Animate   mode.

2. In the Camera view, select the element you want to reorder. Make sure the focus (red outline) is around the
Camera view before selecting the element.

3. Tomove the element forward, press Alt + Down Arrow and tomove the element backward, press Alt + Up
Arrow.

Rigging

s

The rigging process is where building a puppet can take several different directions.
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In this section, you will learn how to create a simple rig. Afterwards, you will learn how to add pegs and create a
hierarchy. You can also seemore advanced tricks in the Appendix on page 222. For a very flexible and advanced rig,
see Deformation on page 231.

• About Rigging on page 199

• Adding Pegs on page 203

• Rigging the Head on page 204

• Rigging the Body on page 205

• Creating a Hierarchy on page 206

• Ordering the Layers on page 1

• Adding theMaster Peg on page 208

• Creating the Keyframes on page 209

• Masking on page 210

About Rigging

There are some basic concepts to know when rigging and layer parenting:

• Simple Rigging on page 199

• Parenting Layers on page 201

• Rigging Using Pegs on page 202

Simple Rigging

Simple rigging is very fast and easy to do. It is built as follows:

• All the body parts are independent

• All the timeline layers are attached to amaster peg layer (trajectory layer)

The advantage of using this technique is that you are free tomove any part around without being influenced by a
parent layer.
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However, since the parts are not parented to each other, the parts will move from point A to point B along a
straight trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the hand to
move along a curved path.
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Parenting Layers

When you want one part to follow another part, such as the forearm following the arm, you can attach the layers one
to the other. For example, you can attach the forearm layer to the arm layer without having to encapsulate the
forearm into the arm layer. They will still be parented, but you can access the forearm directly without having to enter
the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to select
them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able tomove the parent independently of its children, since
the child layers receive all the transformation information from their parent.
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Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from them is often
a good solution.

NOTE:
To attach one layer to another, you must drag the desired layer onto the other one in the Timeline view.

Harmony offers powerful techniques to create hierarchies between your layers without having to encapsulate
layers into each other. These techniques are a great improvement over the less efficient and time consuming
method of creating parenting between your layers by inserting symbols into other symbols. Therefore, rigging with
symbols inside symbols is NOT recommended.

Rigging Using Pegs

Peg layer are useful when you are doingmore advanced puppet rigging. Peg layers are trajectory layers that do
not contain drawings. They aremotion paths that you can use to control your entire puppet or advanced
hierarchies.

Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. You can scale a
body part up the chain of pegs directly on the drawing layer. This way, you do not affect any child layers that could
be attached to that part.

Then, you can perform your translation and rotation on the peg layer so all the parts attached to that peg layer
follow the same trajectory.
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Adding Pegs

It is recommended to add parent pegs to your drawing layers which are path layers that let you add keyframes to
modify the positions of pieces over time. It is not mandatory, but it is helpful to have your drawings and keyframes
separated.

How to parent drawing layers to pegs

1. In the Timeline view, select all the layers.

2. In the Timeline Layer toolbar, click the Add Parent Peg button to add a parent peg to all selected layers.

s
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Rigging the Head

Youwill start by attaching the facial features to the head.

The advantage of parenting the head and the facial features to the same peg is that you can easily animate each
facial feature, and they will all follow the headmotion.

You can also use additional pegs to control smaller groups of pieces such as the facial features or all the left eye
pieces. You can parent as many pegs as you want to obtain amaximum of control on your rig.

How to parent the facial features to the head

1. In the Timeline view, deselect any selected layers.

2. Select the head peg layer.

3. In the Timeline View Layer toolbar, click the Add Parent Peg button to add a new peg layer to your
timeline. You can rename the peg to keep your work organized.

A new peg is added and parented to the head peg layer.
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1. Select all the remaining head and facial feature layers and drag themONTO the peg layer or BETWEEN the
head peg layer and the new head peg to parent them.

Rigging the Body

When the character's head is ready, you canmove on to rigging the body. You can do a simple rigging where all the
body parts are independent of each other, or create parenting between some of the layers. Refer to Creating a
Hierarchy on page 206 to learn how to parent your layers.

Simple rigging consists of leaving the layers in the Timeline view without doing any kind of parenting. Later on, you
will attach those layers to amaster peg and organize them in the correct order—see Adding theMaster Peg on page
208 andOrdering the Layers on page 196.
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Creating a Hierarchy

Harmony lets you extend your rigging techniques beyond normal boundaries and sets new standards. You can
create hierarchies without encapsulating pieces inside each other by creating a linked structure between layers.

You should create a hierarchy on the arms and legs, and keep them separated from the body. This gives youmore
animation freedom, and when you need to scale or skew the torso, it will not affect the entire body.
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How to create a hierarchy in the Timeline view

1. Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you can drag the parent (forearm)
piece onto another parent piece (upper arm).

‣ You can unparent layers by holding down Shift and dragging the selected parents away from the child
layer. Drop your selected between other layers.
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Adding the Master Peg

When you animate your character, you will probably need to resize and reposition it to fit your scene. When you
need to scale down ormove your character, it is a good idea to hook (attach) the whole puppet to a trajectory.

Attaching your puppet to a peg will allow you to scale it and reposition it without having to do this to the different
parts and pieces. Only one layer will contain the position information, whichmakes your animation easier to
modify and control.

How to add a master peg

1. In the Timeline view, select the top layer to parent a peg to it. You need to select a layer to be able to add a
peg to your scene.

2. In the Timeline view, click on the Add Peg button.

A new peg is added to the timeline as a parent of the selected layer.

3. Name the new peg Master plus the character's name.

4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that one item is
already parented to that peg.

5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers are
added above the already parented layers, move that parented layer back on top of the layer stack.
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Creating the Keyframes

Once all your drawings are ordered and your master peg is added, you need to insert keyframes on each cell to
create all of the function curves and block your pose in place.

How to create the keyframes

1. In the Timeline view, collapse themaster peg by clicking the Expand arrow.

2. In the Timeline view, select the first cell.

3. Do one of the following:

‣ From the topmenu, select Insert > Keyframe.

‣ In the Timeline View toolbar, click the Add Keyframe button.

‣ Press F6.
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NOTE: If you use the F6 shortcut when working Flash keyboard shortcuts flavour, this not only creates a keyframe
but also duplicates a drawing.

Masking

When rigging a character, theremay be instances when you want to have the ability to move a particular piece to
give the illusion of a rotation or move the pupil within the white of an eye without having the extra bit of the drawing
sticking out of the character or eyeball. To do so, you can usemasks to cut anything you don't want to be visible.

How to mask an object in the Timeline view

1. In the Timeline view, make sure the keyframe is added on the object that will bemasking the piece to cut.

2. Select the layer that will act as themask.

3. In the Timeline view, right-click on the layer and select Clone Selected Layers: Drawings and Timing.

4. Select the layer to bemasked.
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5. In the Layer toolbar, click the Add Layer button and select Effects > Cutter.

6. Click the Expand Parameters button to display the Cutter properties.

7. Drag the cloned layer ONTO theMatte parameter connection area.

Themasking layer name appears in theMatte parameter area and themasking layer is repositionned above
the effect.

Themasking layer is no longer visible in the Camera view. You can see that themasking layer is connected
to the Cutter effect by clicking the Show/Hide Additional Links button to display the Additional Links
section.

8. Your masking effect is most likely inverted and what you want to cut is probably showing. Double-click on the
Mask layer to open the Layer Properties window. In the Layer Properties window, enable the Inverted option.
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9. In the Tools toolbar, select the Transform tool andmove the cut object within themasking zone.

Adding Extra Drawings

Your break down is now complete. You canmove on to adding the extra drawings your character needs, such as
principal hand positions andmouth shapes. If you ever forget to add extra drawings in your main character's
template, you can easily add them later.

NOTE: Add your extra drawings in the layer corresponding to the part you are drawing. You should see the layers
as containers for the different pieces. Each body part has its own container in which you can add more drawings of
the same part.

If you want to use the auto lip-sync detection feature to animate your dialog, you should create the following
mouths for your puppet.

Themouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.
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NOTE: If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter, "Adding
Extra Drawings" topic to learn how to add extra drawings to your character.

Here is an approximation of the sound eachmouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to themouth chart positions as you draw the shape of the character's mouth.

How to add extra drawings

1. In the Timeline view, select the cell where you want to add a new drawing. If you want to duplicate the current
drawing and work from it, you can select Drawing > Duplicate Drawings or press Alt + Shift + D.
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A new drawing is created in the selected cell and automatically extended to the next one. The new drawing
is a duplicate of the one that was selected so it contains a duplicate of the art. You canmodify it to create
your new drawing or delete its contents in the Camera or Drawing view and start from scratch.

1. In the Tools toolbar, select a drawing tool for drawing your extra part.

2. In the Camera or Drawing view, draw your new drawing.

2. Using the Select tool, select your drawing and flatten the lines by clicking the Flatten button in the
Tool Properties view.

Setting the Pivots

One of the last steps before storing the character in the library is to set the pivots for the different parts.

If you want the puppet's pieces to rotate correctly, youmust set the pivot points right in themiddle of an
articulation, such as an elbow or a knee.

By default, your master peg pivot is placed at the centre of the Camera view, which generally equates to your
character's hips. A good way to set your peg's pivot is to move it between the character's feet.
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How to set the pivots with the Rotate tool

1. In the Advanced Animation toolbar, select the Rotate tool.

2. In the Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view, you can
also hold downCtrl (Windows/Linux) or⌘ (Mac OS X) and click on the piece whose pivot you want to set.

3. In the Camera view, drag the blue pivot to reposition it.

4. Repeat the previous steps for all the pieces, including the eyes, nose andmouth. If you are unsure as where
to place the pivot, put it in the center of the selected piece or group of pieces.

NOTE: If you added other pegs to your rig, you must set their pivot using the same method.

Setting Anchors and Props
An anchor is an attachment point you can use to bind one or several props to a specific location that is predefined by
the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a helmet
attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and easily
swappable from within Harmony or Unity.

How to create an anchor

1. Create a new Drawing node and rename it according to the anchor you are creating.

2. Inside the Layer Properties of your drawing node, make sure that pivot option is set to Don’t Use Embedded
Pivot or Apply Embedded Pivot on Drawing Layer. The Apply Embedded Pivot on Parent Peg does not
transition well to Unity and you will lose your pivot information.
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3. Once this is done, you can use any of the animation tools to reposition the pivot point of your node, such
as the Rotate tool in the Advanced Animation toolbar. You should be able to see the pivot coordinates from
the Layer Properties of your Drawing node. If the pivot is not repositioned, its default place will be at the
centre of your Harmony scene (0,0).

4. Once this is set up, select the Drawing node and click the Toggle Anchor button in the Game toolbar.

The Drawing node is highlighted in red in the Timeline and Node views. Your anchor can now be used to
attach a prop.

How to create a prop

1. Create a new Drawing node or take an existing prop on which you want to attach an anchor.

2. Position the Drawing Pivot of the prop node using a tool on the Advanced Animation toolbar, such as the
Rotate tool. The position of the prop’s pivot will align with that of the anchor. Make sure it is positioned
accordingly.

3. With the prop Drawing Node selected, click the Toggle Prop button in the Game toolbar.

The prop Drawing node is highlighted in green in the Timeline and Node views.

4. Do one of the following:

‣ Connect the anchor and prop to the parent peg.

‣ Connect the prop under the anchor to create a parent/child hierarchy.
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Metadata Editor View

TheMetadata Editor view lets you access the information of the props and anchors to be exported to Unity.

NOTE: Because the Unity game engine does not support Unicode characters, it is recommended to avoid using it in
scenes intended for games.

How to access the Metadata Editor view

1. In the top-right corner of a view, click the Add View button and select Metadata Editor.

Parameter Description

SceneMetadata

This is a list of optional parameters you can create in a scene project to be
exported to Unity. It will not have any incentive towards your scene assets, but
can help developers know what to do with the assets contained in your Harmony
scene.

Once in Unity, sceneMetadata will appear in Inspector view > Metadata when
the Asset is selected in the Hierarchy view.
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Name: Name of the Scene entry. (e.g. game.Armor001)

Value: This can be anything that describes the state of an object. You could, for
example, have three different stages of armour: new, damaged and destroyed.

NodeMetadata

Displays only the props and anchors held inside your selection. If nothing is
selected, no information will display. Name and value appear in this box as well.
Namewill show you the associated .tvg name and value will be set as either On
or Off, depending on whether you want the connection to be set as active or not.

Once in Unity, sceneMetadata will appear in the Hierarchy view.

Name: Name of the selected anchor or prop. (e.g. game.isAnchor). Notice that it
differs from the drawing layer name on the top-left corner of the NodeMetadata
section.

Value: Can be set to be active (On) or inactive (Off).

NOTE: For any anchor or prop information created within the Metadata Editor, the naming convention must always
use the prefix "game.". The term "game." is recognized automatically by Unity as a metadata information. For
example: game.Armor001.

Storing the Character in the Library
Formaximum efficiency and reuse of your character in different scenes, youmust store a template in the Library
view. You can create different kinds of templates, such as templates that include all the layers, a template for a
body, key pose or even some containing only the head.

When you create a template from the Timeline view's right side, youmust first import your master template in
order for everything to work properly when you reimport it into a scene. Once themaster template is imported, you
can import the key pose (action) template's content into the right side of the Timeline view.

How to create a template from the Timeline view

1. In the Library view, right-click on the desired library folder and select Right To Modify.

2. In the Timeline view, collapse themaster peg layer.

3. If your scene has a series of blank cells, they will also be included in the template if you drag the layer to
the Library view. Reduce the scene length to have no empty cells before creating your template.

4. In the Timeline view, select your master peg and drag it to the Library view.
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The Rename dialog box opens.

5. In the Name field, name the new template.

6. Click OK.

How to create a key pose (action template)

1. In the Library view, right-click on the desired library folder and select Right To Modify.

2. In the Timeline view, collapse themaster peg layer.

3. Select the cell containing the desired view and drag it into the desired library folder.
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The Rename dialog box opens.

4. In the Name field, type in a name for the template.

5. Click OK.

Appendix

Themany options and animation techniques available for building a puppet make it impossible to determine only
onemethod to break down a character. Here are some advanced tips on breaking down puppets. As you become
more familiar with the software, you will findmore ways to improve the construction of your puppet.

This section is divided as follows:

• Converting the Layers into Symbols on page 222

• Patch Articulation on page 225

• Adding New Drawings to an Existing Template

Converting the Layers into Symbols

222



Harmony 12.2 Essentials - Cut-out Animation Guide

NOTE: Converting your layers into symbols is optional. When animating, you will need to enter the symbol to create a
new drawing. If you want to use morphing when animating, keep your layers as drawings. Do NOT use symbols.

Once the breakdown is completed, you can create symbols out of each drawing. The symbol will encapsulate each
drawing of the layer. Later on, even if you only expose the first frame, such as the front head, you will still have
access to all of the head drawings you placed in the symbol. This will also allow you to addmore drawings, as your
characters' master templates will evolve throughout the production of your movie or series.

All your layers should be stored in the library as symbols. Before building your puppet, remove all the current layers
in your scene. All of your work is saved in the library.

If you are not sure that you put everything in your library, you can always perform a Save As on your scene and work
on a new version.

How to create a symbol

1. Create a symbol by doing one of the following:

‣ From the Timeline view, drag the layer to the Symbols library folder.

‣ In the Timeline view, select the layer to convert to a symbol. From the topmenu, select Edit > Create
Symbol or press F8. You can also click on the Create Symbol button available in the Edit toolbar.

The Create Symbol dialog box opens.
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2. In the Enter Symbol's Name field, type the new symbol's name. It is recommended that you keep your ori-
ginal layer's name.

3. Click OK.

4. Repeat this process for each layer in the Timeline view.

NOTE: Make sure all your layers are stored in the symbol library.

How to save your scene as a new version

‣ From the topmenu, select File > Save As. You can also click the Save As button available in the File
toolbar.

How to clean the Timeline view

1. In the Timeline view, select all of your layers.

2. In the Timeline's Layer toolbar, click the Delete Layers button.

3. In the Confirm Delete dialog box, click OK.

224



Harmony 12.2 Essentials - Cut-out Animation Guide

Your timeline is now ready to receive the body part symbols for the rigging process.

Patch Articulation

The Harmony advanced rigging can use an articulation fixing technique called Patch Articulation. This technique is a
colour fill patch that is drawn on a third layer and is used to cover the joint lines. It is a simple, yet powerful method.

With this technique, you avoid having to create a correction layer at the end of the animation to fill the gaps in the
joints. You do not need to worry about the articulations at all. Once a patch is set, the articulation is fixed for the
entire length of the animation.

Tomake this technique evenmore efficient, Harmony lets you draw the patch inside the same drawing, but on a
separate contained layer. The Line Art and Colour Art layers are not only useful in traditional ink and paint, but also in
advanced cut-out breakdown. You can draw the patch in the Colour Art layer and extract it in the Node view. The
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advantage of doing it this way is that when animating and using the drawing substitution, the patch drawing will
change at the same time as themain drawing.

How to create a patch articulation

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. If you plan to create your patch on an independent layer, do the following. If not, go the next step.

‣ In the Timeline view, add a new drawing layer by clicking the Add Drawing Layer   button or press
Ctrl + R (Windows/Linux) or⌘ + R (Mac OS X).

3. In the Camera view, select the part for which you want to create a patch. For example, if you are fixing the
elbow articulation, select the arm or forearm drawing to edit it.

4. In the Tools toolbar, select the Select tool or press Alt + S.

5. If you drew your lines with pencil lines, it is recommended to convert them to brush lines (fill shapes):
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‣ In the Camera view, select the pencil lines.

‣ In the Tools Properties view, click the Convert Brush Strokes to Pencil Lines button.

‣ In the Camera view, select the piece's outline and fill.

‣ In the Tool Properties view, click the Flatten button to remove the excess colour fill located under the
contour stroke.

6. In the Camera view, select the fill zone of the part's drawing.
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7. In the Camera view, right-click and select Copy.

8. Select the cell in which you want to create the patch.

9. In the Camera view, right-click and select Paste.

10. In the Tools toolbar, select the Cutter tool.

11. In the Camera view, make a selection around the pasted zone to cut everything out but a small overlapping
zone to cover the articulation.
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1. Repeat the process for each articulation which requires fixing.

Adding New Drawings to an Existing Template

How to add new drawings to an existing drawing template

1. In the Library view, right-click on the library folder containing the template tomodify and select Right To
Modify.

2. In the Library view's right side, right-click on the extra drawings template tomodify and select Edit Template.

A new instance of Harmony opens.

3. In the Tools toolbar, select a drawing tool.

4. In the Colour view, select a colour.

5. In the template's timeline, select the blank cell where you want to draw your new piece.

6. In the Camera or Drawing view, draw the new pieces.

229



Chapter 5: Character Building

7. From the topmenu, select File > Save or press Ctrl + S (Windows/Linux) or⌘ + S (Mac OS X).

8. From the topmenu, select File > Quit (Windows/Linux) or Stage Essentials > Quit Toon Boom Stage
(Mac OS X).
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Chapter 6: Deformation

Deformations let you animate bitmap or vector-based graphics, including gradients and textures. Deformations act
as a skeleton with limbs and articulations you can bend, reshape, and curve. You can deform a character made out
of one, or many, drawing or image layers andmake it move as if it were a cut-out puppet. A deformation skeleton is
composed of deformation nodes, which are the various pieces (here represented as layers or nodes) required to
articulate or deform your drawings, such as a series of bones or game bones—see Deformation Nodes on page 251.

Main Types of Deformations
These are the types of deformations.

Bone Deformation

The Bone deformation allows you to create a skeleton structure in which the parent bonemoves the child bone. The
Bone deformation is useful when animating the extremities of a character, such as the arms or legs, adding fluidity
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and a natural feel to the animation. It can bemanipulated to rotate a limb at an articulation joint and to shorten or
elongate the extremities of a limb. It's also quite handy for bending the torso.

NOTE: If you are creating a rig to be used in a game, use the Game Bone deformation.

Game Bone Deformation

TheGameBone deformation is very similar to the Bone deformation and allows you to create a skeleton structure
in which the parent bonemoves the child bone. The difference is that the GameBone deformation is optimized to
export to game engines, mainly Unity.

TheGameBone deformation is mostly used when animating the extremities of a character, such as the arms or
legs, adding fluidity and a natural feel to the animation. TheGameBone deformation can bemanipulated to rotate
a limb at an articulation joint and to shorten or elongate the extremities of a limb. It's also quite useful for bending
the torso.

Themain difference between the Bone andGameBone deformations is that the Game Bone deformation doesn't
have the Bias parameter. The rendered result is also different for the articulation folds. They are slightly rounded.
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Adding Basic Deformation Chains
Using the Rigging tool, you can quickly create a basic deformation rig.

As you create your chains, the controls will be showing. However, whenever you close your project, the deformation
controls display is turned off. When you reopen the project, you can display all controls or only some of them—see
Displaying the Deformation Controls on page 240.

The Insert menu allows you tomanually add the nodes necessary to create the deformation skeleton. Additional
nodes such as the Kinematic Output are available to create advanced rigs.

How to select an element on which to add deformation

1. From the Deformation toolbar, click the Rigging tool.

2. In the Camera or Timeline view, select the element on which you want to add a deformation. When selecting
a drawing node, the deformation components will be automatically added on top of the drawing node. When
selecting a peg node, the deformation components will be added below the peg.

NOTE: Never place a deformation node above a peg node. Having a peg below a deformation node (Bone, Game
Bone, etc.) will cause unexpected result. The animation on the peg will move the image out of the defined
deformation zone. The same applies to animations created on the drawing layer itself. A drawing layer has an
embedded peg.

3. In the Camera view, create your rig. See the following procedures to learn how to add a specific deformation
type.

How to add a Bone or Game Bone deformation chain

1. Once your element and the Rigging tool selected, in the Tool Properties view, enable the Bone mode or
the GameBonemode depending on your purpose—seeMain Types of Deformations on page 231.

2. Place the cursor at the root of your drawing or group of drawings, click once and release. For example, on the
shoulder.
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3. Click again at the location where you want your first bone to finish and your second bone to start. An artic-
ulation control point will automatically be inserted between each bone you create. Note that the articulation
parameters are part of the Bone andGameBone nodes since Harmony 12.

4. Repeat this until you are finished creating the Bone chain.

5. If you need to insert a bone between existing ones, hold down the Alt key. When the Insert Bone cursor is
displayed, click on the existing bone segment at the location where you want to add an additional bone.

l Note that you can click on any Bone articulation point to start a new bone chain from that
point. Once the articulation point is selected (white), click on the location where you want to
add a bone and a new bone chain will be created, parented to the previous one.
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l When you have several chains controlling the same drawing or group of drawings, a Deform-
ation Composite node is automatically be created and appears in the Timeline view. In the Addi-
tional Links section of the Timeline view, you can see which nodes are connected to the
Deformation Composite.

6. With the deformation nodes still selected, in the Deformation toolbar, click the Reset Current Keyframe
button. This will set the current resting position as the current frame one.

How to add a deformation node

1. In the topmenu, select Insert > desired deformation node.
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Setting the Resting Position
Once you have a deformation chain created, you can optimize its positioning to fit the element it will deform.

A deformation rig has a resting position and an animated position. The resting position is the original pose the
character is in when not animated with keyframes. You can always revert your animated character to its resting
position to recover the initial scale, angle, and shape. You can revert the entire character or only certain
deformation chains, such as the arm or leg. Just make sure your resting position is fully set before deploying the
character in production.

You can also set additional parameters in the Layer Properties window—see Deformation Nodes on page 251.

How to set up Bone and Game Bone deformation chains

1. In the Timeline view, select the deformation nodes you want to set.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to display
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

3. In the Deformation toolbar, click the Rigging tool.

The chain turns from green to red. A green chain indicates the puppet is in animationmode. A red chain
indicates the puppet is in a resting position. Make sure your chain is red.

4. In the Camera view, set up the deformation chain.

‣ Rotate the first bone to change the angle of the chain.
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‣ Use the root control to reposition (offset) the entire chain.

‣ Use the control points to reposition the articulations. This will elongate, shorten or change the direction of
the bone and offset the subsequent children.
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‣ Use the articulation's control (square) to change the size of the articulation. For quality purposes, it is
recommended to have an articulation which fits the diameter of the part it controls.

5. Repeat until all the articulations and bones of the chain are correctly aligned to the element to which it is
linked. You can also set additional parameters in the Layer Properties window—see Deformation Nodes on
page 251.

6. With the deformation nodes still selected, in the Deformation toolbar, click the Reset Current Keyframe
button. This will set the current resting position as the current frame one.

7. Use the Transform tool. For optimal results, make sure the size of the articulation is approximately the
same size as the drawing.

8. If you need to insert a bone between existing ones, hold down the Alt key. When the Insert Bone cursor is
displayed, click on the existing bone segment at the location where you want to add an additional bone.
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Displaying the Deformation Controls
Before you canmanipulate the deformer outside of the Riggingmode, youmust display the deformation controls.

If you just created the deformation rig, the controls will still be showing. However, when you close your project,
the deformers are turned off. When reopening a project, youmust display the controls so you can you see the
ones you need while animating.

How to display the selected deformation controls

1. In the Camera, Timeline view, select the drawing layer or deformation nodes you want to display.

2. Do one of the following:

‣ In the Camera toolbar, click the Show Control button.

‣ From the topmenu, select View > Show > Control.

‣ Press Shift + F11.

How to display the selected deformation controls and hide all the others

1. In the Camera, Timeline view, select the drawing layer or deformation nodes you want to display.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button.

The selected deformation controls appear in the Camera view and all the others are hidden.

How to display all the deformer controls at the same time

1. In the Timeline view, select Edit > Select All from the topmenu to select all the nodes or press Ctrl + A
(Windows/Linux) or⌘ + A (Mac OS X).

2. In the Camera toolbar, click the Show Control button or press Shift + F11.

All deformation controls in scene are displayed.

How to hide the deformer controls

1. Do one of the following:

‣ In the Camera toolbar, click the Hide All Controls button.

‣ From the topmenu, select View > Hide All Controls.

‣ Press Shift + C.
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Assembling Pieces
After you have created all the deformation chains for your character, you will need to assemble these separate body
parts into a puppet. Your pieces should be properly overlapping and not set apart.

To avoid problems such as having the head stretched by the neck deformers or a handmodified by the body
deformers, you can use the Kinematic Output node to assemble your pieces without propagating the deformations
down the hierarchy chains.

The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation chain but
not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will follow the
movement of the chain just like a regular cut-out character hierarchy piece without being influenced by the
deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the deformation.

When building a cut-out puppet with deformations, each part controlled by a deformation chain will automatically
rotate from the chain root point, which acts like a pivot. Because it is unlikely that every piece of your character will
be rigged with a deformation chain, youmust set pivot points for the pieces that are not using deformations—see
Setting the Pivots on page 214.

Assembling Guidelines

When assembling a puppet with deformers, there are some guidelines to keep inmind:

l You cannot parent deformers directly because deformers are not designed to be used on other deformers. To
assemble deformers, youmust insert a Kinematic Output node.
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l Your pegmust be placed above the deformer.

How to assemble a puppet using the Kinematic Output node in the Timeline view

1. Select the element to attach to the Kinematic Output node, such as the hand or head peg.

2. From the topmenu, select Insert > Kinematic Output.

The node appears in the Timeline view as a parent of your selection.

3. In the Timeline view, drag and drop the Kinematic Output layer ONTO the deformation layer you want your
limb or piece to follow. For example, onto the neck deformer if you want your head to follow it without being
deformed or onto the arm deformer if you want your hand to follow.
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l If your pieces are no longer ordered properly, use the Z-nudging feature to reorder them—see
Nudging Parts Backwards and Forwards on page 197.

l It's good practice to rename the Kinematic Output layer to reflect which deformer it is assigned
to as the Timeline view can become very large and layers can be positioned far apart. Select
the Kinematic Output node and in the Layer Properties window, rename the node. You can also
double-click on the layer's name.
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Animating Deformations
The controls to animate deformations work the same as those for setting up the chains. You simply need to
create keyframes and position the control points.

If you need to reset the current pose of the entire chain for the entire scene, you have the possibility to reset the
deformation chain to the resting position on the current or all frames.

When adding new drawings while animating, youmay need to see the reference drawings as their original resting
position as it may be quite difficult to draw on a deformed canvas. You have the possibility to disable the
deformations to see the resting position while drawing. Note that this will not affect the exported images. It's only
a display mode. You can see the result in OpenGL and Render modes in the Camera view, but the exported
images will always be deformed.

How to animate Bone and Game Bone deformations

1. In the Timeline view, go the frame on which you want to create the first animation pose.

2. In the Tools toolbar, select the Transform tool.

3. If you want to create animation keyframes, enable the Animate mode in the Tools toolbar.

4. Do one of the following:

l In the Timeline toolbar, click the Add Keyframe button.

l Right-click and select Add Keyframe.

l Press F6.

A keyframe is added on the current frame.

5. In the Timeline view, select the deformation nodes you want to animate—see Displaying the Deformation
Controls on page 240.

6. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to display
the deformer of the selected piece.

7. In the Camera view, do the following:

l Rotate the first bone to rotate the limb.
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l Rotate the subsequent bones to bend the limb.

l Use the root control to reposition (offset) the entire chain.

l Use the control points to reposition the articulations. This will elongate, shorten, or change the
direction of the bone and offset the subsequent children.

l Use the articulation's control (square) to change the size of the articulation. For quality pur-
poses, it is recommended to have an articulation which fits the diameter of the part it controls.
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8. In the Timeline view, go the frame on which you want to set the next key pose. You will need to expend the
exposure to see your drawings further down the Timeline view.

9. Add a keyframe on the current frame by doing one of the following:

l In the Timeline toolbar, click the Add Keyframe button.

l Right-click and select Add Keyframe.

l Press F6.

10. Repeat the previous steps to animate your character.

You can alsomanipulate the deformer by typing values directly in the Layer Properties of the deformation
effect nodes.

How to remove keyframes and reset positions

1. In the Timeline view, move the playhead to the framewhere you want to reset the puppet to the resting pos-
ition.

2. In the Timeline or Node view, select the deformation group or node you want to reset.

3. In the Deformation toolbar, click on the Reset Current Keyframe button to reset the position of the
selected chain on the current frame.

l To completely reset the position and remove all keyframes on all frames, click on the Reset

246



Harmony 12.2 Essentials - Cut-out Animation Guide

All Keyframes button.

How to disable the deformations to create new drawings

1. In the Timeline or Camera view, create or duplicate your new drawing.

2. In the Deformation toolbar, enable or disable the Enable Deformations button, depending on your needs.

3. In the Camera view, start drawing.

4. To continue animating, in the Deformation toolbar, reactivate the Enable Deformations button.
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Deformation Toolbar
The Deformation toolbar contains the various tools and options used to create a deformation rig. This toolbar is
displayed in the default interface.

By default, the Deformation toolbar only contains the essential options. If you right-click on the toolbar and select
Customize, you can add additional buttons.

Icon Tool Name Description

Rigging Tool

The Rigging tool is used to create a Bone deformation
chain. You also use it to set up the resting position—see
Adding Basic Deformation Chains on page 233 and Setting
the Resting Position on page 236.

To learnmore about the Rigging tool's properties, see
Rigging Tool Properties on page 250.

Show SelectedManip-
ulators and Hide All Oth-
ers

The Show SelectedManipulators and Hide All Others
button hides all manipulators displayed in the Camera view.
Only themanipulators of the selected deformation node are
displayed—see Displaying the Deformation Controls on
page 240 to learn how tomake themanipulators visible in
the Camera view.

Reset Current Keyframe

The Reset Current Keyframe copies the resting position,
the original setup of your skeleton before undergoing any
deformation, to your current frame. Once you have created
a deformation chain, you can use the Rigging tool to adjust
the position and appearance of the rig to fit the element.
When the skeleton is in place, you can use the Reset
Current Keyframe button to reset the current frame position
to the resting position.

Enable Deformations

The Enable Deformations button allows you to display your
drawings in their original state or with deformations while
creating additional drawings. Depending on the artwork you
need to create, youmight need to refer to the other images
either deformed or in their original position.

Note that this will not affect the exported images. It's only a
display mode. You can see the result in OpenGL and
Render modes in the Camera view, but the exported images
will always be deformed.

Remove All Keyframes The Remove All Keyframes option removes all keyframes
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on the selected deformation chain.

Show All Controls

The Show All Controls button lets you visualize the resting
position in red (Setupmode) and the active position
(Animation) in green at the same time—see Displaying the
Deformation Controls on page 240 to learn how tomake the
manipulators visible in the Camera view.
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Rigging Tool Properties
In the Tool Properties view, you can customize not only the behaviour of the tool but also the settings of the
deformers that you will create.

l Mode on page 250

l Rig Tool Options on page 250

l Operations on page 250

Mode

Name Button Description

BoneMode Sets the Rigging tool to create Bone deformers.

Game BoneMode Sets the Rigging tool to create GameBone deformers.

Rig Tool Options

Parameter Button Description

Show All Manipulators
(Show All Controls)

Lets you immediately see the resting position in red (Setup)
and the animated position in green.

Operations

Name Button Description

Reset Deform (Reset Cur-
rent Keyframe)

Copies the resting position of the deformation skeleton to
the current frame.
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Deformation Nodes
The deformation rigs are composed of several different types of nodes. Additional ones such as the Kinematic
Output node can be used to enhance the results.

From the Insert menu, you can insert the following nodes.

Bone

The Bone node is one of themain nodes used to build a deformation rig. Each Bone node consists of a bone and an
articulation. You can chain Bone nodes to create a skeleton chain for your character. The Rigging tool can be used to
create and connect those nodes automatically—see Adding Basic Deformation Chains on page 233.

Parameter Descriptions

Resting Parameters Rest Offset

(x) Axis This is the bone x-axis (horizontal) coordinates for the resting position.

(y) Axis This is the bone y-axis (vertical) coordinates for the resting position.

Rest Radius This is the articulation's radius value (articulation size) for the resting position.

Rest Orientation This is the bone's orientation angle for the resting position.

Rest Bias This is the articulation's bias (roundness and smoothness) for the resting position.

Rest Length This is the bone's length for the resting position.

Deform Parameters Offset

2D Path
When this option is enabled, the X and Y-axis parameters are controlled by the
same 2D path function.

Separate
When this option is enabled, the X and Y-axis parameters are individual one from
another.
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Path When using a 2D Path, this field displays the name of the function.

(x) Axis
This is the bone X-axis (horizontal) coordinates for the animation position. This
parameter can be linked to a function to be animated over time.

(y) Axis
This is the bone y-axis (vertical) coordinates for the animation position. This para-
meter can be linked to a function to be animated over time.

Radius
This is the articulation's radius value (articulation size) for the animation position.
This parameter can be linked to a function to be animated over time.

Orientation
This is the bone's orientation angle for the animation position. This parameter can
be linked to a function to be animated over time.

Bias
This is the articulation's bias (roundness and smoothness) for the animation pos-
ition. This parameter can be linked to a function to be animated over time.

Length
This is the bone's length for the animation position. This parameter can be linked
to a function to be animated over time.

Game Bone

The Bone node is one of themain node used to build a deformation rig. Each Bone node consists of a bone and an
articulation. Chaining Bone nodes will create a skeleton chain for your character. The Rigging tool can be used to
create and connect those nodes automatically—see Adding Basic Deformation Chains on page 233.

Parameter Descriptions

Resting Parameters Rest Offset

(x) Axis This is the bone X-axis (horizontal) coordinates for the resting position.

(y) Axis This is the bone Y-axis (vertical) coordinates for the resting position.

Rest Radius This is the articulation's radius value (articulation size) for the resting position.

Rest Orientation This is the bone's orientation angle for the resting position.
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Rest Length This is the bone's length for the resting position.

Deform Parameters Offset

2D Path
When this option is enabled, the X and Y axis parameters are controlled by the
same 2D path function.

Separate
When this option is enabled, the X and Y axis parameters are individual from
each other.

Path When using a 2D Path, this field displays the name of the function curve.

(x) Axis
This is the bone X-axis (horizontal) coordinates for the animation position. This
parameter can be linked to a function curve to be animated over time.

(y) Axis
This is the bone Y-axis (vertical) coordinates for the animation position. This
parameter can be linked to a function curve to be animated over time.

Radius
This is the articulation's radius value (articulation size) for the animation pos-
ition. This parameter can be linked to a function curve to be animated over
time.

Orientation
This is the bone's orientation angle for the animation position. This parameter
can be linked to a function curve to be animated over time.

Length
This is the bone's length for the animation position. This parameter can be
linked to a function curve to be animated over time.

Kinematic Output

The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation chain but
not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will follow the
movement of the chain just like a regular cut-out character hierarchy piece without being influenced by the
deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the deformation.

Connect a Kinematic Output node below the deformation node you want your drawing to follow.
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Chapter 7: Library

Using templates and symbols , you can share and reuse any elements you create in Harmony. The Harmony library
lets you store several different elements such as puppets, backgrounds, animations and key poses. In fact,
anything you create in Harmony can be stored in the library.

This chapter contains the following topics:

• Understanding the Library Concept on page 255

• Library View on page 257

• Organizing the Library on page 259

• Templates on page 263

• Symbols on page 265

• Importing Symbols and Templates on page 273

• Importing Files Through the Library on page 277

• Using Paste Special on page 277

Understanding the Library Concept
The Library view is where you can store and reuse your artwork and animation in other scenes or build props and
puppets.

• What is a Library? on page 256

• Understanding the Library Concept on page 255

• What is a Symbol? on page 256

• Understanding the Library Concept on page 255
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What is a Library?

The library is a storage centre for all production assets; the elements stored in the library are called templates.
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional animation
processes. The library can contain any asset used in a Toon Boom Harmony production.

Using the library is as simple as dragging the content into the library to store your artwork and then dragging it to
the Timeline or Camera view when you want to reuse it.

You can organize your library using several different subfolders and store them on your hard drive or network.

What is a Template?

A template is an individual copy of the artwork stored in the library which you can reuse in different scenes. Once
a template is stored in the library, you can access it from any project.

Dragging a template into your scene copies the content in your Timeline and does not link it to the original. You
canmodify this individual copy at any time.

What is a Symbol?

A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain
artwork and animation andmanipulate them as a single object. You can also use symbols as a placeholder in
which you place a series of different drawings for each body part of your puppets or when you have a repeating
cycle. However, symbols are not necessary for creating characters.

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library into
your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the
Timeline view, they will all be linked to the original symbol. If youmodify one, they will all bemodified.
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A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content in
another scene, youmust create a template out of it.

When a symbol is exposed in the Timeline view, the symbol's cells are represented as amovie strip.

Library View

You use the Library view to create andmanage your symbols and templates, display the folders andmanage and all
of the content.

Library View Menu

The Library menu lets you access commands specific to the Library view, such as opening a Library or getting the
rights to modify a library folder.

Preview Window
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The Preview window lets you preview the content of a symbol or template, and swap between drawings and
symbol cells in the Timeline view. This window is also used as the Drawing Substitution window.

How to preview a template or symbol's content

1. In the Library view's right side, click or double-click on the symbol or template to preview.

2. In the Preview window, click the Play button or drag the slider to scrub through the frames.

Library Search Tool

When working on amovie or series, you will probably end up with many templates and symbols in your library.
Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

1. From the left side of the Library view, select the library in which you want to search.

2. In the Search field, type the name or partial name of the symbol or template you are looking for.

3. Click the left and right arrows to see the previous and next results. The Search engine will look for
results within the library master folder and its subfolders. It will not look in other libraries.

Library List
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The Library list lets you navigate through the different libraries and subfolders. You can also open, close and create
new libraries from here.

The Library folders have these default libraries:

• Symbols: The only library folder containing symbols for your project. You can organize the symbols library
folder using subfolders, but you cannot create a second library for your symbols. This library is local to your
project.

• Harmony Library: This folder contains templates and is stored on your hard drive. You can organize the
Harmony library folder using subfolders. This folder does not contain symbols.

Templates and Symbols List

s

The symbols and templates contained in the selected Library list can be displayed on the right side of the Library
view as thumbnails, in a list or as details.

How to access the templates and symbols list display options

‣ In the Library view's right side, right-click and select View > List, Thumbnails or Details.

‣ In the Library View toolbar, you can click the following buttons:

Thumbnails

List

Details

Organizing the Library
As you will probably create a large number of symbols and templates, you will soon realize they need to be
organized. You can create different libraries and subfolders to easily access your assets. For example, you can
create a different library for each project and divide it into several categories, such as:

• Characters

• Props

• Backgrounds

Although you can only have one symbol library folder, you can organize it by creating subfolders.
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There are two ways to create library folders.

• Directly through your operating system

• Using Harmony's interface

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network as
a library. Opening a library means linking the folder to your Library view. You only need to open the library once.
The library folder is available every time you open the application until you decide to close the library and unlink it.

Youmay not always require all the library folders in the Library List. If so, you can close the ones you do not need.
Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it on your
hard drive or network and open it in the Library view.

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in
the Harmony Library view, so you can easily access assets. By default, any new library you link to your Library
view is locked to prevent accidental deletion or modification of symbols and templates. Youmust obtain the right
to modify it before being able to add a new folder to it.

You can delete a folder from the library if its contents are no longer needed.

NOTE: Warning: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the
data cannot be retrieved.

Once you add a folder, you can rename it. This also renames the folder on your hard drive.

If you update the content of your libraries through your operating system, you will need to refresh your library
folders in the Library view.

When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.

You can also delete thumbnails if you want to send a template to another user or studio and keep your packages
small.

How to create a library folder through your operating system

1. On your computer, create a new folder with a relevant name in the location where you want the library to be
stored.

How to create a library folder in Harmony

1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

2. Browse for the location where you want to store your new library folder.

3. Click the New Folder button.

A new folder appears.

4. Name the new library folder with a relevant name and click OK.
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The new library appears in the Library List section.

How to open a library

1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

2. Browse to the location of the library folder.

3. Select the folder and click OK.

The new library appears in the Library Folders section.

How to close a library

1. On the right side of the Library view, select the library folder to close.

2. In the Library View menu, select Folders > Close Library.

The library closes.

How to create a folder

1. On the left side of the Library view, select the library folder to which you want to add a subfolder.

2. In the Library View menu, select Edit > Right to Modify.

3. In the Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the plus [+] sign
to expand it.

How to delete a folder

1. In the Library view's left side, select the folder to delete.
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2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.

3. In the Library View menu, select Folders > Delete Folder or press Delete.

How to rename a folder

1. In the Library view's left side, select the folder to rename.

2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.

3. In the Library View menu, select Folders > Rename Folder.

4. Rename the selected folder.

5. Press Enter/Return to validate the operation.

How to refresh a library

1. In the Library view's left side, select the folder to refresh.

2. In the Library View menu, select Folders > Refresh or press F5.

The library displays the new content.

How to generate thumbnails

1. In the Library view's right side, select the template in which you want to generate thumbnails.

2. In the Library View menu, select View > Generate Thumbnails.

The progress bar appears.

How to delete thumbnails

1. In the Library View menu, select Edit > Delete Thumbnails.
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All the thumbnails contained in the library are removed.

Templates

When you want to reuse artwork and animation from your project in other scenes, youmust create a template from
it. A template can be seen as a portable scene or package that you can drag inside your project. You can open a
template and edit it just like any other project. If you want modify your templates, you can edit them using the Edit
Template command.

You can create a template using the Timeline view.

To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary.

How to create a template from the Timeline view

1. In the Timeline view, select some cells or layers.

2. In the Library view, select a folder to store the template.

3. If a library folder is locked, right-click and select Right to Modify.

4. Drag the selection to the Stage Essentials Library folder or any other library folder.
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5. In the Rename dialog box, give the new template a name.

To rename a template once it is created, right-click on the symbol and select Rename.

6. Click OK.

How to delete a template

1. In the Library view, select the folder containing the template to delete.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Delete or press Delete.

How to edit a template

1. In the Library view, select the folder containing the template to edit.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.
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2. Right-click on the selection and select Edit Template.

A new Harmony application opens.

3. Edit the template.

4. From the topmenu, select File > Save.

5. In the topmenu, select File > Quit (Windows/Linux) or Stage Essentials > Quit (Mac OS X).

Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can also
create symbols out of each body part in your cut-out puppets.

You do not need to create symbols in order to create drawings or characters in Toon Boom Harmony.

When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve the data.
The symbol cannot be retrieved once you close the application.

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. If you
import a symbol into your scene several times in the Timeline view, they will all be linked to the original symbol. If
youmodify one, they will all bemodified.

If you want to edit a symbol without modifying the other instances, youmust duplicate the symbol first. If other
symbols are nested inside the new symbol, they are not duplicated. If youmodify them, the original and other
instances will also bemodified.

You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located in the
position where they were created. The pivot is translated at the centre of the symbol.
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When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest
many symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the
Editing stack at the top of the Camera view which displays the path to your symbol's location. You can click on
the symbol's name tomove up the chain.

You can share a symbol and use its contents (the drawings) in another scene. To do this, youmust first convert
your symbol into a template. This conversion breaks the drawing's link with both the original scene and symbol. It
then becomes a separate entity that you can import into other projects.

How to create a symbol from a drawing selection

1. In the Tools toolbar, select the Select or Cutter tool.

2. In the Camera view, select the drawing elements to create a symbol.

3. From the topmenu, select Edit > Create Symbol or press F8.

‣ Clicking the Create Symbol button in the Edit toolbar will create a symbol from the entire layer.

The Create Symbol from Drawing Selection dialog box opens.
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4. In the Symbol Name field, type the name of the symbol.

‣ You can also select an existing layer from the Symbol Name drop-downmenu. It will add your symbol on
the layer's current cell. If there is already an exposure on that cell, the symbol will be added to a new
layer.

5. You can choose to place the current selected artwork in the drawing or remove it:

‣ To remove currently selected artwork from the drawing and place it in the new symbol, select the Cut
Artwork From Source Drawing option.

‣ To keep currently selected artwork in both the drawing and in the new symbol, deselect the Cut Artwork
From Source Drawing option.

6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.

How to create a symbol from the Timeline view

1. In the Timeline view, select the layer or cells from which your want to create a symbol.

2. Do one of the following:

‣ From the topmenu, select Edit > Create Symbol.

‣ In the Edit toolbar, click the Create Symbol button.

‣ Press F8.

‣ Drag your selection to the Symbol folder in the Library view.
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The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the
new symbol. The new symbol only appears in the library. Youmust drag it into your scene to use it.

How to create an empty symbol

1. In the Library view, select the Symbol folder.

2. Do one of the following:

‣ In the Library view's right side, right-click and select New Symbol.

‣ From the topmenu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.
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The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top button
in the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.

How to delete a symbol

1. In the Library view, select the symbol to delete.

2. Right-click and select Delete or press Delete.

‣ If the symbol is currently in use in the scene, a warningmessage displays. Click OK to delete the symbol
from the library and scene.

How to edit a symbol from the Timeline view

1. Do one of the following:

‣ In the Timeline view, double-click on the symbol's cell to edit the symbol.

‣ In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or⌘ + E (Mac OS X)).

‣ Click the Edit Selected Symbol button in the Camera View toolbar's extra buttons.
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You are now inside the symbol and you are able to edit it.

2. Do one of the following:

To return to the project's timeline, click the Top button in the Camera view's top-left corner, press Ctrl + Shift
+ E (Windows/Linux) or⌘ + Shift + E (Mac OS X).

‣ In the Timeline view's right side, right-click and select Symbols > Leave Current Symbol.

How to edit a symbol from the Library view

1. In the Library view, select the symbol to edit.

2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.
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To return to the project's timeline, click the Top button in the Camera view's top-left corner, press Ctrl + Shift +
E (Windows/Linux) or⌘ + Shift + E (Mac OS X).

How to duplicate a symbol

1. In the Timeline view, go to the framewhere you want to duplicate the symbol.

2. Select the symbol's cell.

3. From the topmenu, select Edit > Duplicate Selected Symbol.

In the Library view, the symbol is duplicated and in the Timeline view, the current cell and its held exposure is
replaced with the new symbol. You can now modify the symbol's content.

How to convert a symbol into a template

1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline
view. If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in the
centre of your camera frame, but rather wherever your cursor drops it within the camera frame.
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2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any other
library folder. Make sure you have the right to modify the library folder.

3. In the Rename dialog box, rename the new template.
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4. Click OK.

Importing Symbols and Templates
There are several ways you can import symbols and templates in your scene.

Sometimes a character rig is not a straightforwardmatter. Rigs, which are usually saved as templates, can contain
symbols such as a leg that was made with a patch. However, a symbol does not work in the sameway as an action
template. In the Timeline view, you can add an action template into another template of the same structure. When
working on a layer on the right side of the Timeline view and you place a symbol into a symbol of the same structure,
instead of being added to the previous symbol, the new symbol becomes a copy.

For greater control over how the action template behaves when brought into the Timeline view, you can use the
Paste Special feature—see Using Paste Special on page 277.

Since a template is like a scene, you can open the template's folder and select elements inside it such as drawings.

Instead of importing the entire contents of a template, youmay only want to import a few drawings or a palette. In
this case, use the Open As Folder command to import the items you want.

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root timeline.
The symbol's layers will be parented to it in case you createdmotions and transformations on the drawing layer that
contains the symbol. Breaking the hierarchy could result in the loss of any scaling and animation youmay have
created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to import a template into the Timeline or Camera view

1. In the Library view, select the template you want to import.

2. Drag the selected template to the Camera view or to the left side of the Timeline view.
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3. You can also drag a template to the right side of the Timeline view and into existing layers if the layer struc-
ture is the same as the existing one.

How to import a symbol in the Timeline view

1. In the Library view, select the symbol you want to import.

2. Drag the selected symbol to one of the following:

‣ The Timeline view's left side to import it into the centre of the camera frame.

‣ The Camera view to place it at the location where you release your cursor.
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NOTE: This may be useful if you saved a character's body parts as separate symbols. If you dropped them into the
Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would be more
efficient to arrange them into their correct places as you bring them into the scene.

How to import a template with symbols

1. From the right side of the Library view, select the action template that contains symbols.

2. Hold down Alt (Windows/Linux) or⌘ (Mac OS X) as you drag it from the Library view to the right side of the
Timeline view and drop it next to a template with the exact same rig.

The Paste Special window opens.

3. Select the Advanced tab.

4. Select one of the following options from the Symbols menu:

‣ Copy symbols if they do not exist: This is the default setting for this operation and will prevent symbols
in an action template from being copied.

‣ Duplicate symbols: Makes copies of the symbols in your template.

How to open a template as a folder

1. In the Library view, select the folder that contains the template to open. If the library folder is locked, right-
click on the folder and select Right to Modify.

2. Right-click on the selection and select Open As Folder.

3. In the library list section, click on the template's folder to display its content.
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4. Drag the content to the Timeline or Colour view.

How to expand a symbol

1. In the Timeline view, select the symbol to expand.

2. From the topmenu, select Edit > Expand Symbol or press Shift + F8.

How to expand a symbol in a group

1. In the Timeline or Node view, select the symbol cell or symbol node you want to expand.

2. From the topmenu, select Edit > Expand Selected Symbol in a Group.

3. In the Timeline view, click the plus sign (+) to see the group content. In the Node view, click the Expand
Arrow to enter the group.
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Importing Files Through the Library
Harmony lets you import sound files and images directly through the library. Simply open the folder containing your
files in the Library view and drag them directly from there.

How to open a file through the Library

1. In the Library View menu, select Folders > Open Library.

2. Browse for the folder containing the files you want to import.

3. Click Open.

4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.

Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You can
choose to import only the keyframes without the drawings or import only the drawings that are not already in your
layers. You can adjust the behaviour using the Paste Special dialog box.When you import a symbol in your scene,
its full length is exposed by default. If you import a symbol in the Timeline view’s left side, all the frames will be
exposed. However, if you import it into an existing layer, you can use the Paste Special dialog box to adjust the
import behaviour to fit your requirements.Once you set the parameters, Harmony will reuse them each time you
import a symbol in the Timeline view’s right side until you set new parameters.

How to open the Paste Special dialog box

1. In the Library view, select the symbol or template to import.

2. Press Ctrl + B (Windows/Linux) or⌘ + B (Mac OS X) and drag the selection to the Timeline view.
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NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

3. Set the parameters and click OK.
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Chapter 8: Cut-out Animation

Harmony provides some great tools for animating puppets. You can create simple animation using the Transform
tool, as well as create advanced animation using both forward and inverse kinematics. Harmony has advanced
onion skinning and image swapping features to help you animate efficiently and quickly. For animation freedom, you
have the ability to mix several different techniques of animation, such as simple rigging, hierarchy and symbol
animation.

• Getting the Character on page 280

• Keyframes and Drawing Blocks on page 283

• Creating a Simple Cut-out Animation on page 285

• Selecting Layers to Animate or Position on page 288

• Navigating the Hierarchy on page 290

• Animating Using the Transform Tool on page 292

• Animating in Stop-motion on page 294

• Animating Using Computer-generated Interpolation on page 295

• Marking the Timeline on page 301

• Flipping Through Poses on page 302

• Using the Onion Skin in Cut-out Animation on page 303

• Flipping Parts on page 305

• Using Action Templates on page 306

• Swapping Drawings on page 307

• Animating Lip-Sync on page 313

• Adding a New Drawing on page 317

• Ordering Layers Over Time on page 321

• Resetting a Transformation on page 322

• Creating Cycles on page 323

• Adding Pegs on page 325
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• Offsetting a Portion of an Animation on page 327

Getting the Character
The first step in animating your character is to import a master template from the library.

In Harmony, you can create your character template from the Node view.

NOTE: If the template you are importing was created in the Node view, make sure to import it first and drop it into
the Node view or the left side of the Timeline view. Otherwise, some network connections may be broken.

How to import a character from the library

1. Create a new Harmony project.

2. In the Library view, select a character master template to animate.

3. Drag the selected template to the Camera or Timeline view’s left side. You can also import a template dir-
ectly in the Node view.

4. In the Timeline view, drag the red scene length bracket to extend or shorten the scene length.

280



Harmony 12.2 Essentials - Cut-out Animation Guide

How to import a network template

1. In the Library view, select the template or symbol you want to import.

2. Drag the selected template to the Network or Camera view or the left side of the Timeline view.

3. If necessary, in the Node view, connect your template to the Composite node. To do this, click its out-port
and drag the connection to the Composite node until an in-port appears.

NOTE: If the template you are importing was created in the Node view, make sure to drop it in the Node view or on
the left side of the Timeline view. Otherwise, some network connections may be broken. If you are importing a
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template containing the exact same connections as a template you imported previously, you can drop it on the
Timeline view's right side over the existing layer. This will combine both templates and keep the existing layers.

How to import a network template (master template)

1. Create a new Harmony project.

2. In the Library view, select the character's master template you want to animate.

3. Drag the selected template in the Node view.

4. In the Node view, connect the template's group node to the Composite node by clicking its out-port and
dragging the connection to the Composite node until an in-port appears.

5. In the Timeline view, extend or shorten the scene length by dragging the scene length bracket.
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Extending the Exposure

Once you have chosen a pose, all that's left to do is extend the exposure of the character to the end of the scene.

How to extend the exposure of the character

1. In the Timeline view, collapse the character.

2. In the Timeline view’s right side, select the last cell of the character.

3. Right-click and select Extend Exposure or press F5. You can also copy the first pose and paste it in the last
cell.

The drawing exposure is extended to the end. You will not see any changes in the Timeline view when the
master peg is collapsed.

Keyframes and Drawing Blocks
When you extend the exposure of a drawing, it is represented by a grey block in the Timeline view. When you
expose a second drawing, a second grey block is displayed.

You can consider these blocks as drawing blocks.
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To animate the position of a block over time, you don't need to create a second block, just add a position
keyframe. The position keyframes are coordinates indicating the position of your drawing on a particular frame.
These appear as black squares in the Timeline view.

In the example below, notice that the keyframes are positioned on frames independently from the beginning and
end of each drawing block.

You can keyframe three different positions for a drawing in the same drawing block and create amotion path
between them.

Creating Keyframes and Drawings in the Timeline View

You can see how the Timeline view behaves differently depending on whether you create a new drawing, a new
keyframe, or both at the same time.

How to create a drawing in the Timeline view

1. Do one of the following:

‣ From the topmenu, select Drawing > Create Empty Drawing.

‣ In the Timeline toolbar, click the Create Empty Drawing button.

‣ Press Alt + Shift + R.

A new drawing block is inserted.

284



Harmony 12.2 Essentials - Cut-out Animation Guide

How to create a keyframe in the Timeline view

1. Do one of the following:

‣ From the topmenu, select Insert > Keyframe

‣ In the Timeline toolbar, click the Add Keyframe button.

‣ Press F6.

A keyframe is created in the layer.

How to create a drawing and a keyframe simultaneously in the Timeline view

1. From the topmenu, select Insert > Keyframe and Duplicate Drawing.

A drawing block is created which contains copies of the selected drawing and a keyframe.

Creating a Simple Cut-out Animation

Here is how you can create a simple cut-out animation. Follow these steps so you can try the animation tools you'll
be learning in the next topics.
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How to create a simple cut-out animation

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. In the Tools toolbar, enable the Animate mode so everything youmove will be keyframed auto-
matically.

3. From the topmenu, select Animation > Stop-Motion Keyframe so the interpolation is not created auto-
matically between keyframes.

4. In the Timeline view, collapse your character.

5. In the Timeline view, go to the framewhere you want to set the first pose.

6. To ensure that nothingmoves on the new pose, in the Timeline view, select the frame corresponding to the
pose, right-click and select Add Keyframe or press F6.

7. In the Camera view, select the parts to animate.

8. Use the Transform tool to rotate, skew, scale or translate the selection to its new position. To rotate
the piece, place your cursor slightly outside of a corner until you see the rotation cursor.
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A new keyframe appears in the Timeline view if you did not create one previously. Always create your
keyframe first.

9. In the Tools toolbar, enable the Onion Skin feature.

10. In the Timeline view, go to the framewhere you want to set the second keyframe. You will need to expend the
exposure to see your drawings further down the Timeline view.

11. To ensure that nothingmoves on the new pose, in the Timeline view, select the frame corresponding to the
pose, right-click and select Add Keyframe or press F6.

12. In the Camera view, animate your character.

13. Repeat this process for all the poses.
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Selecting Layers to Animate or Position

When you're animating characters, it's important to understand how the Animatemode allows you to create
keyframes on the current frame or reposition the entire layer.

Animate Mode

The Animate button, in the Tools toolbar, turns keyframing on or off. With this mode enabled, as soon as you
move an element in the Camera view, a keyframe is positioned on the current frame in the Timeline view to
indicate the new position.

When you turn off the Animatemode, and you select andmove an element, the entire animation in the layer will
be offset.

This means that when you are animating a character, youmust enable the Animatemode. If you are scaling down
your puppet to fit the scene composition and want to resize the entire animation, youmust disable the Animate
mode.
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How to turn the Animate mode on or off

1. In the Tools toolbar, click the Animate button or select Animation > Animate.

Selecting Drawing Layers Using the Transform Tool

Tomanipulate the drawing layers in order to animate them, youmust use the Transform   tool. The Select tool is
used tomodify the drawing strokes and not the actual drawing layer.

When selecting the drawing layers with the Transform tool, make sure the Peg SelectionMode option is turned off in
the Transform Tool Properties view. Otherwise, if it's left on, it will limit the selection in the Camera view to pegs
only.

How to select using the Transform tool

1. Do one of the following:

‣ In the Tools toolbar, click the Transform tool.

‣ From the topmenu, select Animation > Tools > Transform.

‣ Press Shift + T.

2. In the Transform Tool Properties view, make sure the Peg Selection mode is deselected.

3. In the Camera view, select the element to animate.

Selecting an Element in the Camera View Using the Transform Tool

When you select an element in the Camera view using the Transform tool, make sure the Peg Selection mode is
disabled in the Transform Tool Properties view. The element selected is the actual drawing layer corresponding to
the selected element. If you have a layer parented to a peg, youmust use the keyboard shortcuts to go up the
hierarchy chain, select it in the Timeline view, or enable the Peg Selection mode option in the Transform Tool
Properties view. This will limit the selection in the Camera view to pegs only.

If the layer has child layers, they will also be highlighted. Depending on whether you're using pegs or only drawing
layers in your rig, the selection can bemagenta, yellow or both.

289



Chapter 8: Cut-out Animation

Selecting a Layer in the Timeline View

When you select a layer in the Timeline view, the corresponding element is highlighted in the Camera view. If the
selected layer has child layers, they are also highlighted.

Selecting in the Network View

As with the Timeline view, when you select a node in the Node view, the corresponding element will be
highlighted in the Camera view. If the selected node has child layers, they will also be highlighted.

Navigating the Hierarchy
If there is a layer hierarchy in the puppet you built, use the keyboard shortcuts to travel up and down the parent-
child chain. You can also navigate between the children of the same parent.

How to select the parent or child layer

1. In the Tools toolbar, select the Transform tool.

2. In the Transform Tool Properties view, make sure the Peg Selection mode is deselected.

3. In the Camera or Timeline view, select a layer attached to a hierarchy.
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4. From the topmenu, select Animation > Select Parent or press B to select the parent layer. Select Anim-
ation > Select Child or press Shift + B to select the child layer.

How to select the children layers

1. In the Tools toolbar, select the Transform tool.

2. In the Camera or Timeline view, select a layer attached to a parent layer with several children or not parented
at all.

3. From the topmenu, select:

‣ Animation > Select Previous Sibling or press / to select the previous child layer.

‣ Animation Select Next Sibling or press ? to select the next child layer.

‣ Animation > Select Children to select all child layers at the same time.
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Animating Using the Transform Tool
The Transform tool is themain tool to use when working with a cut-out character. The Transform tool has many
useful functions:

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece from
their own pivot point. They are compositing tools. The Transform tool creates a global selection, so whenmany
parts are selected, you canmove them as one unit. The Transform tool is highly recommended for cut-out
animation.

When animating with the Transform tool, make sure to select the right selectionmode. In this example, make
sure that the Peg Selection Mode is disabled in the Tool Properties view or it will limit the selection in the
Camera view to pegs only.
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If there are hierarchy connections in the cut-out character, the Transform tool will also be used as the Forward
Kinematics equivalent.
The Transform tool can be used on any kind of rigging.

Whenmany parts are selected with the Transform tool, the first selected part's pivot will be used as the global
selection's pivot. This pivot can bemoved temporarily for the animation. When you offset the pivot, the permanent
pivot is displayed as a ghost.

NOTE: The interpolation of the animation poses is always calculated from each individual part's permanent pivot. If
there's a parent peg on a limb, make sure to select it instead of making a selection of each part to avoid setting
individual keyframes.

How to use the Transform tool

1. In the Tools toolbar, click the Transform tool or press Shift + T.

2. In the Transform Tool Properties view, make sure the Peg Selection mode is deselected.

3. In the Timeline view, go to the frame on which you want to set the first position.

4. In the Timeline toolbar, click the Add Keyframe button or press F6. It is recommended to add a keyframe
beforemoving the character. Moving a character's part without setting a keyframewill create keyframes only
on certain parameters of the animation. You could run into issues later on when setting poses between exist-
ing ones. Creating a keyframe on all layers and parameters will ensure your pose is set and will not bemod-
ified by other poses later on.

5. In the Camera view, select the element to animate andmove it.
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6. In the Timeline view, go to the framewhere you want to set the next position.

7. In the Timeline toolbar, click the Add Keyframe button or press F6.

8. In the Camera view, animate the character.

Animating in Stop-motion
To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing key
poses. It is better to work with stop-motion keyframes so Harmony does not automatically create the interpolation
between your keyframes.

When using stop-motion keyframes, also known as step keyframes, the segment between two keyframes is
constant. There is no animation generated by the computer between the poses. The drawing remains in position
until the next keyframe, thenmoves to its new position.

Creating a Stop-motion Keyframe

You can create a stop-motion keyframe in several different ways. You can have Harmony create it automatically,
transform amotion keyframe into a stop-motion keyframe, or even switch your preferences to get Harmony to
always create stop-motion keyframes by default.
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How to automatically create stop-motion keyframes

1. In the topmenu, make sure the Animation > Stop-motion Keyframe option is selected.

2. In the Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:

‣ Right-click and select Insert Keyframe.

‣ In the Timeline toolbar, click the Add Keyframe   button.

‣ Press F6.

In the Camera view, if the Animatemode is enabled, as soon as youmove the selected element, a keyframe
is automatically created on the current frame.

How to convert a motion keyframe into a stop-motion keyframe

1. In the Timeline view, select themotion keyframes to convert into stop-motion keyframes or press S.

2. Do one of the following:

‣ Right-click and select Set Stop-Motion Keyframes.

‣ In the Timeline toolbar, click the Stop-Motion Keyframe   button.

‣ Press Ctrl + L (Windows/Linux) or⌘ + L (Mac OS X).

Animating Using Computer-generated Interpolation
After you have created the key poses, you can animate the in-between poses yourself or let Harmony do it using
motion keyframes. When you usemotion keyframes, the drawings gradually move to the next position instead of
staying on the spot until the next keyframe.
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Creating a Motion Keyframe

You can create amotion keyframe in several different ways. You can have Harmony create it automatically,
transform a stop-motion keyframe into amotion keyframe and even switch your preferences to have Harmony
always createmotion keyframes by default.

How to automatically create motion keyframes

1. In the topmenu, make sure the Animation > Stop-Motion Keyframe option is disabled.

2. In the Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:

‣ Right-click on the selection and select Insert Keyframe.

‣ Click the Add Keyframe   button in the Timeline toolbar.

‣ Press F6.

In the Camera view, if the Animatemode is enabled, as soon as youmove the selected element, a
keyframewill be automatically created on the current frame.

How to convert a stop-motion keyframe into a motion keyframe

1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.
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2. Do one of the following:

‣ Right-click on the selection and select Set Motion Keyframe.

‣ Click theMotion Keyframe  button in the Timeline View toolbar.

‣ Press Ctrl + K (Windows/Linux) or⌘ + K (Mac OS X).

Adjusting the Ease

To add ease in and ease out onmotion paths, you can display the function curve andmodify the Bezier or Ease
curve. To apply an ease tomultiple functions and keyframes, use the Set Ease for Multiple Parameters feature and
set the amount desired.

The velocity, or ease, is used onmotion keyframes. The velocity must be adjusted directly on the function curve in
the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and left
handle fields, as well as the Bezier handle or Ease wheel controls on each selected keyframe. You can pull on them
to adjust the ease in and ease out, or type values in the fields.

If there are several functions whose velocity you want to adjust at the same time, such as the hand, forearm and arm
of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in one frame.

How to adjust the velocity in the Function view

1. In the Timeline view, click the Expand Function button to display all the layer’s functions.
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2. Double-click on a function.

The Function Editor opens.

NOTE: The Function editor will not display if the function does not already exist. Add a keyframe to create the
function.

3. Select a keyframe and pull on its Bezier handles or Ease wheel to adjust the velocity. Refer to the Com-
positing and Effects Guide to learn how to create Ease curves instead of Bezier curves.

298



Harmony 12.2 Essentials - Cut-out Animation Guide

How to set ease on multiple parameters

1. In the Timeline view, select a keyframe from one or more layers.

NOTE: Only the first keyframe selected on each layer is considered when using the Set Ease for Multiple Parameter
function. If many keyframes are selected on the same layer, the ease values will be applied only to the first one and
the rest will be ignored.

2. Do one of the following:

‣ In the Timeline view, right-click and select Set Ease For Multiple Parameters.

‣ In the Timeline toolbar, you can click the Set Ease For Multiple Parameters   button. If the button is not
in the toolbar, you can add it through the Toolbar Manager. Right-click on the toolbar and select
Customize.

The Set Ease For Multiple Parameters dialog box opens.
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3. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.

4. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the Fil-
ters section, deselect the function types you do not want to affect.

‣ Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 3D Path
functions

‣ Rotation: Applies the easing parameters to the selected Angle functions.

‣ Scale: Applies the easing parameters to the selected Scale functions.

‣ Skew: Applies the easing parameters to the selected Skew functions.

‣ Morphing: Applies the easing parameters to the selectedMorphing Velocity functions. Note that it is
applied to theMorphing Velocity function in the Layer Properties window, not to the basic Morphing
ease in the Tool Properties view.

‣ Other: Applies the easing parameters to all the other selected functions, such as all functions created
to animate effect parameters.

5. You can also adjust the easing by typing values in the TimeRatio and Value Ratio fields. The values are
calculated in percentage.

‣ In the Left Time Ratio and Right TimeRatio fields, type the percentage value corresponding to the
length of time you want the easing to last. The valuemust be between 0% and 100%.

‣ In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you want
the easing out. The valuemust be between 0% and 100%.

‣ If your TimeRatio and Value Ratio values are equal, you will have a linear motion.
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6. Click one of the following buttons:

‣ Apply: Applies the easing parameters to the selected keyframes.

‣ Apply/Previous: Applies the easing parameters to the selected keyframes and then selects the previous
keyframe in the timeline.

‣ Apply/Next: Applies the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

‣ Close: Closes the dialog box. If you did not apply themodifications, they will be cancelled.

Marking the Timeline
As you animate, the Timeline view will contain many layers and keyframes. Youmight want to identify them using
coloured layers and scenemarkers.

Scenemarkers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can use
it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in action, an
impact, or where you intend to apply an effect. You can also add a note to a scenemarker, which is displayed when
you hover over the scenemarker.

There are two ways to add a scenemarker. You canmark the current frame ormake a frame range selection and
mark the whole section.

How to modify a layer's colour

1. Click the Change Track Colour button of a layer.

The Select Colour dialog box opens.

2. Select a colour for the layer. You canmodify the colour for any type of layer, such as group, peg, drawing and
effects.
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Flipping Through Poses

When animating, it is useful to flip through poses to see the flow of your animation without going through each
frame in the Timeline view. Harmony lets you flip between the selected element’s keyframes.

How to flip through poses

1. In the Camera or Timeline view, select a layer that contains the poses you want to view.
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2. Do one of the following:

‣ From the topmenu, select Animation > Go to Previous Keyframe or Go to Next Keyframe

‣ Press semicolon (;) and single quote (').

Using the Onion Skin in Cut-out Animation

When animating cut-out characters, it is useful to see the previous and next frames on the animation. However, it
can sometimes be confusing to see the onion skin for every part of the character. You will often only want to see the
onion skin on a single part or a few parts, such as the arm that is currently being animated. Harmony offers that
possibility.

While animating in the Camera view, there is a series of different onion skin options. You can enable these options in
themenu or manually in the Timeline view using the layer's Show Onion Skin button. Unless you change the
onion skin options when you display the onion skin, only the selected layers will be displayed in the onion skin
preview.

How to use the onion skin

1. In the Tools toolbar, click the Onion Skin button or press Alt + O.

2. In the Tools toolbar, click the Transform tool or press Shift + T.

3. In the Camera view, select one or more elements.

4. From the topmenu, select View > Onion Skin > Add to Onion Skin, Remove From Onion Skin, Remove
Unselected from Onion Skin, Add All to Onion Skin or Remove All from Onion Skin.
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Add to Onion Skin

The Add to Onion Skin command is used to add a series of selected elements to the onion skin preview. The
keyboard shortcut is Shift + S.

Remove from Onion Skin

The Remove From Onion Skin command is used to remove a series of selected elements from the onion skin
preview.

Remove Unselected from Onion Skin

The Remove Unselected from Onion Skin command is used to remove all elements except the ones selected
from the onion skin preview.
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Add All to Onion Skin

The Add All to Onion Skin command is used to add all of the scene's elements to the onion skin preview. The
keyboard shortcut is Alt + Shift + O.

Remove All from Onion Skin

The Remove All Onion Skin command is used to remove all of the scene's elements from the onion skin preview.
The keyboard shortcut is Ctrl + Shift + O (Windows/Linux) or⌘ + Shift + O (Mac OS X).

Flipping Parts
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If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip Vertical
options. If the Scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

How to flip a selection

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. In the Tool Properties view, make sure the Peg SelectionMode is disabled.

3. In the Camera view, select the parts to be flipped.

4. In the Tool Properties view, click the Flip Horizontal or Flip Vertical option or press 4 or 5 respect-
ively.

Using Action Templates

Reusing animation and assets is an important aspect of cut-out animation. This is why Harmony includes a
library for storing all the reusable information.

When you created the character rig, youmost likely created amaster template along with some action templates
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To save time, you can take an action that you've already animated, such as a walk-cycle or jump, and reuse it. You
can store the initial animation's keyframes in the Library view, then drag it into amaster template of a new scene.

You can import a master template into the Timeline view and start animating with it. You can import an action
template into the right side of the Timeline view. An action template is composed of drawings (like a blink) or
keyframes (like a walk cycle) that you can reuse in an animation sequence.

To insert an action template into amaster template, the layer ordering has to be exactly the same. If it's
inconsistent, the templates cannot be combined.

You can create a single keyframe action template of the different views (front, three-quarter or side view). Then
import and insert them into the animation to turn the character. The same pattern can be created for a head, arm, full
upper body, etc.

If you created templates for different body parts, you can reuse them in your scene by dragging them to your layers.
You can also open a template as a folder and select a particular drawing from it and drag it onto a drawing layer.

Swapping Drawings
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Cut-out animation is not only about moving parts around. It's also about swapping drawings to give the animation
amore traditional animation look. You can add as many new drawings as you want in your scene and use them in
your current animation. You can also add new drawings to the library and use them in other scenes. But before
starting to swap drawings, it's important to understand how keyframes, exposure and key exposure work in
Harmony:

• Keyframe: A keyframe is a point in time where a change to the properties of the object or character
occurs. In Harmony, keyframes consist of the coordinates that determine how an entire layer and its
contents aremoved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

• Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames.
In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings.
Keyframes can bemoved independently from the drawing exposure.

• Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed
on a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for
another one, then the original drawing is retained. This preserves the key drawing. Note that Harmony
automatically sets a key exposure when you perform a drawing swap.

When you want to swap drawings, you can do so in the Timeline or Library view. In the Timeline view, the
Parameters area is where you can select a drawing to swap. In the Library view, the Drawing Substitution window
lets you see the drawings before selecting one for swapping. In this view, you are actually selecting drawings in
your scene layers, not drawings in the Library.

NOTE: Keep in mind that when you swap a drawing, its entire exposure is replaced up to the next drawing
exposure.

When selecting a certain frame range to be swapped, the behaviour of the Timeline and Library views is different.
If you are using the Parameters area of the Timeline view to select a drawing to replace a selected frame range,
the new drawing will replace the frame range and continue until the next key exposure. In the following example,
drawing 2 (DR2) is replaced by a new drawing, starting at the beginning of the selected frame range and ending at
the next key exposure.
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If you use the Drawing Substitution window in the Library view to select a drawing, the drawing is split in two and the
exposure before and after the frame range remain the same. In the following example, drawing 2 (DR 2) is split in two
and the selected frame range is filled with a new drawing.

How to swap a drawing in the Timeline view

1. In the Timeline view’s right side, select the cell containing the drawing or symbol cell to swap.

2. In the Drawing Substitution field, position the pointer over the value and drag left or right to change the cell or
drawing exposed for another one. You can also type in the drawing name or symbol’s cell number if you know
it.

How to swap images in the Library view

1. In the Tools toolbar, select the Transform tool.

2. In the Transform Tool Properties view, make sure the Peg Selection button is deselected.

3. In the Camera view, use the Transform tool to select a part of the drawing to swap.

NOTE: You can swap the frames in symbols or the drawings in a layer. However, you cannot swap one symbol for
another.
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4. In the Timeline view, select the cell range in which you want to swap the drawing.

5. In the Library view, go to the Drawing Substitution window.

6. Scroll through the symbol's frames or drawings by doing one of the following:

‣ From the topmenu, select Animation > Substitute Drawing Previous or Substitute Drawing Next.

‣ Drag the slider left or right.

‣ Press +.

The drawing or symbol’s cell on the current frame is replaced.
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Adding Key Exposures

If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This prevents
it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property of an exposure
that forces it to be exposed on a certain frame regardless of whether the previous exposure is the same drawing or
not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be automatically
updated even if set as a key exposure. This keeps your existing animation key poses intact. It is frequently used on a
mouth or eyes layer.

Example: Swapping a drawing with no key exposure

In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure.

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.

Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is
positioned in themiddle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing 5 for
drawing 1, the second drawing 5 retains its exposure.
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How to add a key exposure

1. In the Timeline view, select the drawing cell to set as the key exposure.

2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure button.

‣ In the Timeline toolbar, click the Add Key Exposure button.

‣ Right-click and select Exposure > Add Key Exposure.

A new key exposure is added. 

If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing
is split in two and both parts contain the same drawing.

Removing Key Exposures

When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure
is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When
the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).
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How to remove a key exposure

1. In the Timeline view, select a key exposure to remove.

2. Do one of the following:

‣ In the Timeline toolbar, click the Remove Key Exposure button.

‣ Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.

How to remove a key exposure

1. In the Timeline view, select a key exposure to remove.

2. In the Timeline toolbar, click the Remove Key Exposure button.

The key exposure is removed and replaced by the preceding exposure.

Animating Lip-Sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth to match the sound at a precise frame.

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound element and
generates amouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X for silence).

Themouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.

NOTE: If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter, "Adding
Extra Drawings" topic to learn how to add extra drawings to your character.

313



Chapter 8: Cut-out Animation

Here is an approximation of the sound eachmouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to themouth chart positions as you draw the shape of the character's mouth.

How to generate a sound detection for lip-sync using the Layer Properties view

1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

2. In the Layer Properties, click Detect.
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A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

3. Click theMap button to open the Lip-Sync Mapping dialog box.

4. From the Destination Layer menu, select the layer that contains themouth positions for the character's voice
track.
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5. If the selected layer contains symbols, you canmap the lip-sync using drawings located directly on the
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to
use the drawings or select the desired symbol from the drop-downmenu.

6. In theMapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it
represents. If your drawings are already namedwith the phoneme letters, you do not have to do anything.

7. Click OK.

8. Press the Play button in the Playback toolbar to see and hear the results in the Camera view. To play
back your scene with sound, enable the Sound button in the Playback toolbar.

Harmony allows for themanual swapping of mouth position drawings tomatch a voice track. For this process,
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing substitutions are used.

How to animate lip-sync using the Timeline view

1. In the Playback toolbar, enable the Sound Scrubbing  button.

2. In the Timeline view, drag the red playhead along the sound layer waveform.

3. When you reach a framewhere amouth position should go, for example, an openmouth with rounded lips
for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing
name (often a letter) until it changes to the swapping pointer.

5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing
automatically changes to the new selection.

How to animate lip-sync using the Library view

1. In the Playback toolbar, click the Sound Scrubbing   button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

3. When you reach a framewhere amouth position should go, for example, an openmouth with rounded lips
for an "oh" sound, click on that frame on your mouth shapes layer.

4. In the Drawing Substitution window of the Library view, drag the slider to choose amouth shape. The cur-
rent drawing is swapped for the one in the preview window.

316



Harmony 12.2 Essentials - Cut-out Animation Guide

Adding a New Drawing
If you need to add a new drawing to a scene, you can do so by duplicating the existing drawing on the current frame.
If you're using symbols, you can also add a new drawing inside the body part’s symbol.

Duplicating a Drawing

If your character doesn't use symbols, youmust duplicate the drawing on the cell on which you need to a new
drawing. You could also create a new blank drawing, but duplicating the existing drawing allows you to keep the
pivot you previously set (if you're using drawing pivots) and you can also reuse a portion of the existing artwork.
When you create a new drawing, you get a blank cell with a pivot set at the centre of the Camera view.

How to duplicate a drawing

1. In the Timeline or Camera view, select the drawing to duplicate.

2. From the topmenu, select Drawing > Duplicate Drawing or press Alt + Shift + D.

The new drawing appears in the currently selected cell.

3. In the Camera view, draw the new piece.

Repositioning Drawings

When creating additional drawings for a cut-out puppet, you should generally try to create them in the same location
as the original drawings (resting position) so you can scale and rotate the same pivot.
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Although, when adding drawings that are specific to an animation, it may be easier to draw it in relation to the
character's position and scene's composition. If you draw a series of drawings that are not in the same location,
you can use the Reposition Drawing tool to reposition the drawing strokes while simultaneously creating
keyframes in the Timeline view to compensate for the repositioning. In the Camera view, the drawings will retain
the location and position in which you drew them while in the Drawing view, all your drawings will be aligned.

How to reposition and align drawings

1. In the Advanced Animation toolbar, select the Reposition Drawing tool.

2. In the Camera view, Ctrl + click (Windows/Linux) or⌘ + click (Mac OS X) to select the drawing to repos-
ition. You can also select the drawing layer or the parented peg in the Timeline view.

The Reposition Drawing controls appear in the Camera view. They are positioned on top of each other.
The source controls are represented by black lines. The destination controls are represented by dotted
blue lines.

3. On your first drawing (reference drawing), position the black source controls to indicate the position at
which all other drawings will be aligned.
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4. In the Timeline view, move to the next drawing.

5. In the Camera view, move the blue destination controls to match the reference position you set on the original
drawing. You can use the long handle to rotate the position. If you rotate the control multiple times, the draw-
ing will rotate multiple times.

6. Select the blue checkbox once the position is correct.

7. Repeat the previous two steps for all drawings in your animation.
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8. Once all the drawings are completed, in the Drawing view, verify that the drawing strokes are correctly
aligned.

9. If necessary, delete the last keyframe if the last drawingmoves back to the reference drawing's position.

10. If the animation does not require interpolation, in the Timeline view, select the newly created keyframes. In
the Timeline toolbar, click the Set Stop-Motion Keyframe button to remove any computer-generated
interpolation.
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Ordering Layers Over Time

The layer ordering system in Harmony saves time and simplifies your work. There is no need to create a new layer or
copy and paste artwork into other layers to change the order. The Z-axis (forward/backward) allows you to create a
multiplane andmove elements closer or farther from the camera. This allows you tomove the puppet’s pieces in
front of or behind other ones without physically changing the layer position.

Harmony provides you with a shortcut to move the piece with amicro nudge on the Z-axis. A keyframe is created
where different Z values can be entered. This allows the piece tomove forward and backwards in space without
requiring you to change the drawing’s original position or break the layer hierarchy. This alsomeans that the layer
ordering is maintained throughout the scene. You can combine animation assets so Harmony can interpolate them.

How to nudge elements on the Z-axis

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. In the Tools toolbar, click the Animate button.

3. In the Camera view, select the part to be repositioned and hold down the Alt key.

4. Using the Up or Down arrow keys, nudge the part until it moves to the desired position.
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Resetting a Transformation
If youmade toomany transformations and it's not going where you want it to go, or simply because you want to
reset a pose you're reusing from another animation, you can reset your character's position. Once the layers are
positioned in the Camera view, you can easily return them to their original position. There are three different ways
to reset a transformation.

Using the Reset command, you can reset the value of the selected element to the initial value of the active tool.
For example, if the Rotate tool is active, the transformation angle will be reset to 0 and if the Transform
tool is active, all the transformation values will be reset.

The Reset All option resets all transformations on the current frame in a selected layer. Your keyframewill
remain, but all the values will return to the default position. All transformations are reset regardless of the tool
you're using.

The Reset All Except Z option resets all transformations on the current frame except the Z position. This is useful
when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the different views of a
character. Youmight want to reset the transformation, but not necessarily the Z position.

In the Timeline view, you can also use the Clear All Values command to reset all transformation values on the
selected layers. Right-click on the selected layers and select Layers > Clear All Values.

NOTE: When using the Transform tool to select elements in the Camera view, always make sure the Peg
Selection Mode option in the Tool Properties view is disabled or it will limit the selection to peg only.

How to reset the transformation on the current frame

1. In the Tools toolbar, select the Transform tool or any Advanced Animation tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

3. From the topmenu, select Animation > Reset or press Shift + R.

The selected layer(s) return to their original position.
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How to reset all transformations on the current frame

1. In the Tools toolbar, select the Transform tool or any Advanced Animation tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

3. From the topmenu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to reset all transformations except the Z position on the current frame

1. In the Tools toolbar, select the Transform tool or any Advanced Animation tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

3. From the topmenu, select Animation > Reset All Except Z.

The selected layer(s) return to their original position, except for the Z values.

Creating Cycles
You can create cycles from a portion of your animation or completely reverse the flow of your animation.

How to create an animation cycle

1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

2. From the topmenu, select Edit > Copy Cells From the Timeline.

3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. From the topmenu, select one of the following:

‣ Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or⌘ + / (Mac OS X).
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The Paste Special dialog box opens.

‣ Edit > Paste Special or press Ctrl + B (Windows/Linux) or⌘ + B (Mac OS X).

The Paste Special dialog box opens.

5. In the Number of Cycles field, enter the number of cycles to paste.

6. In the Cycle Typemenu, select a type of cycle to paste.

‣ Normal (forward): Pastes the selection as is, starting with the first cell and ending with the last.

‣ Reverse: Pastes the selection reversed, beginning with the last cell and ending with the first.

‣ Forward -> Reverse: Pastes the selection as a yo-yo, starting with the first cell, going to the last cell
and ending with the first cell.

‣ Reverse -> Forward: Pastes the selection as a reversed yo-yo, starting with the last cell, going to the
first one and ending with the last cell.

7. Click OK.
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How to create a reverse animation cycle

1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. From the topmenu, select Edit > Copy.

3. In the Timeline view, select the cell where you want the cycles to start.

4. From the topmenu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or⌘ + . (Mac OS X).

Adding Pegs
Now that you have your puppet on stage, you probably need to resize and reposition it to fit the scene. When you
need to scale down ormove a character, it's a good idea to hook (attach) the whole puppet to a trajectory.

In Harmony, there is a type of layer you can add to your timeline, allowing you to create amotion path or reposition
drawings. This trajectory layer is called a peg. Any drawing or layer you hook to a peg will follow the definedmotion
path, rotation, scaling and skewing information.

Attaching your puppet to a peg allows you to scale and reposition it without having to do the same on all the different
parts and pieces. Only one layer will contain the position information, making your animation easier to modify and
control.

Next, position your character on the stage by moving it and scaling it to the correct size. You will not scale each
layer individually. You can do it on the top symbol or top peg layer.
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How to add a repositioning peg

1. In the Timeline view, select the top layer on which you want to parent a peg.

NOTE: You must select a layer to be able to add a peg to your scene. Unless you use the Display All mode from
the Display toolbar, an error message will display if you try to add a peg without any selection.

2. In the Timeline view, click the Add Peg button.

A new peg is added to the timeline as a parent of the selected layer.

3. Double-click on the name of new peg layer and rename it: Master_Peg.

4. In the Timeline view, select all the layers you want to attach to the new peg. Remember that one item is
already parented to that peg.

5. Drag the selection and drop it on the peg layer to parent all the character's pieces to the peg. If your layers
are added above the already-parented layers, move that parented layer back on top of the layer stack.
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How to reposition a character

1. In the Timeline view, select the top peg layer (master peg).

2. In the Tools toolbar, select the Transform tool and disable the Animate mode.

3. In the Camera view, position the character.

Offsetting a Portion of an Animation
If there is a section of the animation that you want to reposition, such as the head's height or the puppet's position,
you can do so using the function curve.

How to reposition a portion of an animation

1. In the Timeline view, click the Expand Function button of the body part layer to reposition. If you want to
reposition the entire body, expand themaster peg's parameters.

2. Double-click on the layer's parameter controlling the keyframes you want to reposition.

The Function Editor opens.
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3. In the Function editor, select the keyframes you want to reposition by tracing a selection box.

4. Click the Show Current Frame button to view the transformation results in the Camera view as you do
them.

5. Drag the keyframe selection up or down to reposition the sequence.

6. Close the Function editor.
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Glossary
3D stereoscopic The ability to create stereo images which, when animated and viewed through 3D active

shutter glasses or using glasses with one red and one blue lens, will appear as a three-
dimensional movie.

alpha channel An image channel that carries transparency information. An image already has three
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The
matte, or the transparency information, is stored in this fourth channel. An image without an
alpha channel is always opaque.

animatic A movie with sound that is developed from the storyboard. The storyboard panel is exposed
for the duration of the scene and at times, the characters are placed on a trajectory to
indicatemotion. The cameramoves are also animated. The animatic is used to determine
the rhythm of a project and provides a good overview of the project before beginning
production.

animation A simulation of movement created by displaying a series of pictures or frames.

anime An animation style known for its sinister and dark feel; popular in Japan.

arc Action rarely occurs in a straight-forwardmanner; rather it typically unfolds in what
storytellers refer to as an arc. The purpose of a story arc is to move a character or situation
from one state or scenario to the next.

aspect ratio The relationship between the width and height dimensions for any scene, frame or film
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed An automatedmethod of feeding drawings into a scanner in whichmultiple drawings are
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned
consecutively, without further user intervention.

automatic lip-sync
detection

Automatically mapping drawings in an element to themouth chart generated for a sound.
This can save time when lip-syncing a voice track.

axis An imaginary line around which an object rotates.

For 2D graphics, there are two axes: X (horizontal and Y (vertical).

For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).

In animations that constantly rotate, the axis element specifies what axis the object rotates
around. A negative number causes an animation to rotate counter clockwise whereas a
positive number causes an animation to rotate clockwise.

background The part of a scene that is farthest to the rear. The background is the artwork, or decor,
against which the animation takes place.

Bézier A method of defining curved lines invented by Frenchmathematician Pierre Bézier. A Bézier
curve is amathematical or parametric curve. Bézier curves use at least three points to
define a curve.

bitmap An image composed of pixels with a single resolution (size). If it is enlarged toomuch, it will
lose definition and individual pixels will begin to appear. This is known as pixelation.

Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each
individual pixel contains a value that represents a specific colour.
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breakdown In cut-out animation, breakdown is the action of breaking a character into pieces to create a
puppet with articulations. To break down a character, the artist cuts parts, such as the
hands and arms, from the character's model and pastes them in separate layers. Next, the
joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose generally found between two key
poses. The key poses are themain poses in an animation and the breakdowns are
secondary poses, ones that help describe themotion and the rotation curve (usually referred
to as an arc).

camera shake Camera shake occurs in a scene when the cameramoves slightly and quickly in several
directions. This gives the impression of an impact, vibration or, for example, bumps on the
road.

caption A text field containing dialogue, effects, sound or slugging information in a storyboard.

cel In traditional animation, a cel (also known as celluloid) is a transparent sheet on which the
animation is inked and painted before being sent to the camera. The picture's outline is
drawn on the front of the cel and then coloured along the back.

character design Each character in an animated film is drawn frommultiple angles in poster-style format,
called amodel sheet, which serves as a reference for the animators.

chromatic
aberration

In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of
distortion in which there is a failure of a lens to focus all colours to the same convergence
point.

clean up After rough drawings have been tested and approved, all the noise in the image (excess
lines, notes, etc.) is removed to create final drawings which can be inked, painted and shot.
The clean up process refers to either tracing a clean line over a rough drawing to achieve the
final version or removing dirt and extra lines left by the scanning process.

CMYK Acronym for Cyan, Magenta, Yellow, Black. These colours are the standardmodel used in a
process called offset printing.

colour card A colour card is a card containing one solid colour that is the same size as the camera. The
colour card fills the background with a solid colour when there is no background image
included.

colour model The official colour design that must be used to paint the animation. A model is the definitive
character, prop or location design that each artist must follow for the production.

colour wheel A display of the colour spectrum in the form of a circle.

compositing Compositing is the action of incorporating all of a scene's elements to create the final result
prior to rendering. For example, the compositing artist will import all the animation
sequences, background, overlays and underlays in the scene and position them correctly.
The artist will then set the camera frame and animate it, if needed. Finally, the animator will
create all the computer-generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut A direct transition between two scenes. When a cut is used, there are no transition effects
inserted to pass from one scene to the next. The first scene ends and the second one starts
immediately.

cut-out animation The process known as cut-out animation is the action of animating characters made out of
several pieces by moving them around frame by frame. Cut-out animation can either be
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computer generated or done traditionally using paper.

cycle A group of images that together make up an action, such as walking. A cycle is an action
repeated as a loop over a period of time. It can be a series of animated drawings or
keyframes.

dialogue The text spoken by a character in amovie or animation.

dope sheet Used by animators, directors and other members of a crew to track the sequence and timing
of images, dialogue, sound effects, sound tracks and cameramoves. Also known as an
exposure sheet.

doping To assign a particular drawing to a range of frames.

double bounce
walk

In the key frames and passing positions in a double bounce walk, the body is lower than a
reference line drawn in the upright position. During the in-betweens, the body is above this
line giving the appearance of a bounce.

DPI Dots per inch is the standardmeasure of resolution for computerized printers. It is
sometimes applied to screens, in which case it shouldmore accurately be referred to as
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease In animation, the ease, also known as velocity, is the acceleration and deceleration of a
motion. It can be amotion created by a function curve, or a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.

ease-out Gradual deceleration in the action. Also known as slow-out.

establishing shot A scene in which the viewer can see the whole area in which a sequence is happening. For
example, if a child is playing on the ground in front of his house, the establishing shot would
be a scene where the viewer can see the house, the ground, a part of the street and the
buildings around the central point of action. This helps the viewer understand the story
location and scene orientation.

exposure In animation, an exposure is the number of cels on which a drawing appears in the scene.
For a drawing to appear longer, the exposuremust be extended over a greater number of
cels.

exposure sheet A sheet with several vertical columns and horizontal frames used to indicate a scene's
timing. Each column represents a scene layer. The drawing numbers in each column are
indicated and repeated over the particular amount of frames they need to appear.

The exposure sheet is used by animators, directors and other members of a crew to track
the sequence and timing of images, dialogue, sound effects, sound tracks and camera
moves. Also known as a dope sheet.

fade in/fade out Fade in or fade out is a transition effect used to open or close a sequence. A fade in occurs
when the first scene appears progressively, from complete transparency to its complete
opacity. A fade out occurs when the last scene progressively disappears, going from
complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field A measurement unit used to calculate motion, registration and camera positioning. A
standard animation scene will vary between 6 to 12 fields.
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field chart A guide containing all the field units that animation and layout artists use to determine a
scene size or cameramotion.

film-1.33 A resolution that is ideal for the widescreen film format that conforms to the standard 4:3
pixel aspect ratio.

film-1.66 A resolution that is ideal for the widescreen film format that conforms to the 16:9 pixel
aspect ratio. (The pixels are wider than they are high).

flipping In traditional animation, flipping is the action of going through the drawings of an animation
sequence very quickly in order to see the animation in motion. Flipping can also be the
action of creating amirror transformation of an object.

follow-through The secondary motion caused by themain action. For example, a character wearing a cloak
is running. Themain action is the body running. This will cause the cloak to follow the
motion, although it will not move at the same time, but react a few frames later and follow
themainmotion curve.

forward kinematics Forward kinematics is a feature used to animate principally 3D characters and cut-out
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a
shoulder, andmake the rest of the armmove with it as a single piece.

frame An animation frame is a single photographic image in amovie. In traditional animation, the
North American standard generally contains 24 frames per second, while in Europe the
standard is 25 frames per second.

frame rate The frame rate is the speed at which the frames are played. They are generally calculated
by frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60
frames per second or any other number.

This is themeasurement of the frequency (rate) at which an imaging device produces
unique consecutive images, called frames. The term applies equally to computer graphics,
video cameras, film cameras, andmotion capture systems.

Frame rate is most often expressed in frames per second (fps) and in progressive-scan
monitors as hertz (Hz).

function A computer-generatedmotion, trajectory or path on which elements, other trajectories and
effects parameters can be attached. The function can be controlled by adding keyframes
and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV Acronym for High Definition Television which delivers a higher quality image than standard
television because it has a greater number of lines of resolution. To take advantage of the
superior quality andmake full use of your resolution setting, the output devicemust be
compatible with HDTV technology.

hold A frame in the animation in which the character maintains its position without moving. A
hold can be created between any two keyframes.

HSV Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation
(shade) and value (tone or luminance).

in-between The drawings that exist between the key poses. These are drawn to create fluid transitions
between poses.

ink and paint The ink and paint process is the action of painting the empty zones and colouring the lines
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on the final animation drawings, while following a colour model.

interpolation The computer-generatedmotion created between two keyframes. You have the choice to
create interpolation, or not, between your keyframes.

inverse kinematics
(IK)

A feature usedmainly to animate 3D characters and cut-out puppets with hierarchy. Inverse
kinematics will animate a puppet from one of the extremities, such as a hand, andmake the
rest of the body follow naturally.

jump cut A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is generally
caused by one scene ending, and a second one starting, with a similar image. The lack of
difference causes the eye to see a little jump between the two scenes.

key pose Important positions in the action defining the starting and ending points of any smooth
transition. Keys, or key poses, are themain drawings in an animation sequence describing
themotion. For example, if an arm is waving, the keys will be of the arm at one extremity of
the wavemotion and the other extremity. By flipping those drawings, the animator can see
the skeleton of themotion without having all the drawings.

keyboard
shortcuts

One or more keyboard keys which, when used, cause an operation to be performed.

keyframe Important positions in the action defining the starting and ending points of any action. A
keyframe is a computer-generated position at a specific moment (frame) on a given
trajectory.

layer In animation, a layer is an individual column, level or character. A scene's layers are
superimposed to form the final image.

layout The communication step between the storyboard and the animation. It is the action of
putting the storyboard onmodel. That is, drawing the character by following the design in the
model pack, so the animator can start working.

The layout artist draws the background, creates the camera and field guidematching the
scene and cameramotion. Lastly, the animator draws onmodel themain action poses.

layout and posing The action of putting onmodel (at the right scale) the storyboard for the animator to start
working.

layout artist The artist who draws the background, and creates the camera and field guide tomatch the
scene and cameramotion. They will draw onmodel themain action poses.

layout planning Drawing of themain features of the scene used as reference when planning the animation
and executing the initial stages of it.

layout process The communication step between the storyboard and the animation.

library A storage area containing templates and assets that can be reused in any project or scene.

light table A device that allows you to see other layers in transparency while you are working on a
particular layer.

line of action The direction that the action will follow. Also known as path of action.

lip-sync The process of synchronizing a character's mouth to sounds in the dialogue soundtrack.
Themouth is adjusted frame-by-frame tomatch the sound of the dialogue and provide the
illusion that the character is speaking. Lip-sync can be used for any sound sequence, not
only speech, you could for instance have a bird chirping or a wolf howling at themoon.

low resolution A format that is ideal for videos destined for the web, where size and fast download of a
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video file take precedence over quality. A low-resolution image is one that lacks fine detail.

manual lip-sync
detection

Themanual swapping of mouth position drawings tomatch a voice track. For this process,
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing
substitutions are used.

master palette A group of colours attributed to a character or prop. The palette is used throughout the entire
production tomaintain consistency in the look and to ensure that the same colours are used
throughout the production. Also known as palette.

model/colour
model

The definitive character, prop or location design each artist must follow for a production. A
colour model is the official colour design that must be used to paint the animation.

morphing A feature for creating computer-generated drawings between a source drawing and a
destination drawing. Animation created with themorphing feature can be reused in different
projects.

motion keyframe A keyframewith computer-generated interpolation.

mouth chart A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used
to represent silence) used for lip-sync.

multiplane The effect of passing throughmultiple levels of drawings to create a sense of depth in a
shot. A multiplane is a scene in which the layers are placed at different distances from the
camera so that when the cameramoves, a depth illusion occurs. With amultiplane, all the
perspective and scale is calculated automatically.

NTSC The standard analogue television broadcasting system used in North America. NTSC
conforms to North American standards on how rectangular pixels are displayed for
computer and television screens.

nudge A small push (left, right, up, down, forward or backward) done with the keyboard arrow keys
on a selected element. Nudging is used tomove a selection very slightly and precisely.

onion skin A feature that lets you see the previous and next drawings of a sequence.

overlay A part of the scene environment, such as a chair or a bush, that is placed in front of themain
animation.

PAL A resolution that works best with the European format for television and computer screens,
as the rectangular pixels are displayed at a different orientation.

palette/master
palette

A palette or master palette is a group of colours attributed to a character or a prop. The
palette is used throughout the entire project to maintain a consistency in the look and avoid
the colour changing during the animation. Also referred to as amaster palette.

palette style A palette style is a second version of an existing palette with a slight change in the tint and
value. A palette style can be used to create the night version of a palette. It may also be
called a clone palette.

pan Tomove the camera across the scene in any direction.

panel In a storyboard, a panel is a frame in a shot. A shot can be composed of one or several
panels.

paperless
animation/tradigital

The paperless animation process is the action of animating digitally. Themain paperless
animation process is to draw, frame by frame, the animation directly in the software.

passing position When drawing a walk sequence for a character, the passing position is the point at which
one leg passes the other.
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path of action Direction that the action will follow. Also known as line of action.

peg In traditional animation, a tool used to ensure accurate registration of action as cel layers
move. In digital animation, in which you are doing amore advanced puppet rigging, you can
use peg layers. Peg layers are trajectory layers that do not contain drawings. They are
motion paths that you can use to add path articulations. For the latter, you can also use an
inverse kinematics tool.

phoneme A unit of sound in a language.

pivot The point around which a peg or drawing rotates.

pixel The smallest element of an image displayed on amonitor or TV screen.

Pixel, short for picture element, is a single point in a graphic image. It is a small sample of
an image, a dot, a square, or a very small sectionmade out of smooth filtering. If you zoom
in close enough on a digital image, you will see the pixels, which look like small squares of
different colours and intensity.

pose-to-pose
animation

The pose-to-pose animation process is the action of creating all themain action poses,
called key poses, and then placing the secondary poses between the keys. The secondary
poses are called breakdown. Finally, the animator fills the gaps with the in-between
drawings to achieve a smooth animation.

rendering The final step when animating by computer. During rendering, the computer takes each
pixel that appears on screen and processes all of the components, as well as addingmotion
blur before it produces a final image. The process of calculating the final images after the
compositing process.

resolution The size of a scene, generally calculated in pixels. For example, the NTSC resolution is 720
x 480. The resolution shouldmatch the final output: HDTV, film-1.33, film-1.66, NTSC,
PAL, low.

RGB Red, Green, Blue. A method of defining colour by specifying amounts of these three colour
components.

rigging The process of attaching the various parts of a cut-out puppet.

rotary table Equivalent to the animation disk/table, a device that allows you to rotate the workspace for
greater comfort while drawing.

rotoscoping An animation technique in which animators trace over live-action film movement, frame by
frame, for use in animated films. The act of sketching over live-action footage to create an
animated sequence.

roughs Rough is a common name in an animationmovie for a drawing that is used as a reference
but which does not form part of the final image. A layout is a rough.

The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines and
shapes, but can also contain design details.

safe area The zone at the center of a scene's frame that is safe from being cropped by the TV frame.
As a TV frame cuts amargin off the original frame size, maintaining a safe area ensures that
the scene's main action will remain clearly visible once the film is screened on television.

scene A shot in amovie or show. A sequence is composed of several scenes. A scene changes to
another scene by a simple cut or transition.
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script The original text containing all themovie or show information. In animation, the script
contains all of the location descriptions, dialogue, time andmore. A project starts with a
script.

sequence A series of scenes or shots forming a distinct part of the story or movie, usually connected
by unity of location or time.

shot A scene in amovie or show. A sequence is composed of several shots. A shot changes to
another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.

slugging To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing A process that lets you hear sound in real time while youmove the playhead forward or
backward. This is very useful for finely-tuning a lip-sync.

stop-motion
keyframe

A keyframewith no computer-generated interpolation.

storyboard A visual plan of all the scenes and shots in an animation. The storyboard indicates what will
happen, when it will happen and how the objects in a scene are laid out.

straight-ahead
animation

A technique in which an entire sequence is drawn from the first position to the last, in order.
There is very little planning in this methodology. Where the character ends up and how it
gets there can be a surprise for both the audience and the animator. While this approach is
spontaneous and creative, it can create inaccurate results.

strokes Invisible vector lines forming the drawing zones. They can be adjusted with Bézier handles.

symbol A symbol combines animation, artwork or layers into a single object that you can control in
one layer. You can also create symbols out of each body part in your cut-out puppets.

You can place whatever you want in a symbol. You can use symbols to animate a puppet or
create reusable animations such as blinking.

tablet/pen A device used in conjunction with, or instead of, a mouse tomove amouse pointer
(sometimes referred to as the cursor) around the computer screen.

template An asset stored in the library that can be reused in any project. A template can be a drawing,
a series of keyframes, a sound file, a panel, a cut-out character, an effect, a trajectory, an
animation, or anything else used in the animation.

thumbnail A very small image used as a reference or indicator.

timecode The timing information printed on amovie clip to indicate the scene, hour, minute and
second that is currently displayed on the screen.

timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and paint After the rough animations have gone through cleanup and a final line or pencil test, each
drawing is traced and painted for the final animation. In today's digital world, this may be
done in a variety ways other than the traditional celluloid or acetatemethods.

track breakdown The break down of an animated film's soundtrack into individual sounds to produce the
precise frame-by-frame position of each sound.

traditional A type of animation process whereby all the animation sequences are drawn by hand on
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paper before scanning or inking them on cels.

trajectory A computer-generated path or trajectory that elements can follow. The trajectory can be
controlled by control points, keyframes and velocity.

transition An effect placed between two scenes as they pass from one to the other. Common
transition effects are cross-dissolve and wipe.

underlay In animation, an underlay is a specific part of the decor placed behind themain animation.

vector A vector-based image is composed of points and Bézier curves. The computer reads the
points and traces the segments, linking them to reproduce the image shape. There is no
fixed size or resolution in a vector image. The graphic can be enlarged and distorted as
much as desired and the system will simply recalculate the segments and rebuild the
shapes. Vector images are translated and displayed in pixels once the calculation is done.

velocity In animation, the velocity, also known as ease, is the acceleration or deceleration of a
motion. This can be achieved by a function curve, or via a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle A series of drawings "on the spot" that describe the walk for a character. The illusion of
movement is created by the use of background pans. To avoidmaking innumerable
drawings, animators routinely make a walk cycle for a character.

zone An area which can be painted with colour.
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Index
alpha channel 329

animatic 329

animation 329

anime 329

arc 329

aspect ratio 329

auto-feed 329

axis 329

background 329

backing up

palettes 109

Bezier 329

bitmap images 329

Bitmap layer 141

Bone deformer

basic rig 233

Bone rig 233

Bone rig

creating 233

breakdown 330

character 190

brush size 15

Brush tool

drawing 11

size 15

brushes

exporting 30, 66, 76

importing 30, 65, 75

Camera layer 141

camera shake 330

caption 330

cel 330

celluloid

See cel. 330

character building

breaking down 190

character design 330

drawing with brush 11

drawing with pencil 11

getting references 10

preparation 9

sketching model 10

chart

field 13

clean up 330

cleaning

model 24

cloning

layers and columns 148

CMYK 330

Colour-Card

layer 142

colour card 330

colour model 330, 334

colour palettes

back up 109

location 108

colour swatch

adding 18

colour wheel 330

colours 15

adding colour swatch 18

columns

advanced types 143

changing colour 178

cloning 148

collapsing 175

deleting 144

duplicating 147

expanding 175

modifying 146

navigating 169

properties 145

reordering 147

types 141

Xsheet 140

compositing 330

copying

drawings 173

cross dissolve 330

cut 330

cut-out animation 330

creating 286

selecting layers 290

cycle 331

cycles

exposure, creating 166

deformation

basic rig 233

Bone rig 233

chain, setting up bone and
articulation 236

deleting

drawings 172

design tools 9

Override 11

designing

brush size 15

characters 21

drawing with brush 11

drawing with pencil 11

field chart 13

getting references 10

line up 13

preparation 9

relative size 12

sketching model 10

dialogue 331
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dope sheet 331

doping 331

DPI 331

drawing

brush size 15

Brush tool 11

brushes, exporting 30, 66, 76

brushes, importing 30, 65, 75

characters 21

cleaning model 24

colour swatch, adding 18

colours 15

current drawing on top 26

deletiing thickness stencil 29

exporting brushes 30, 66, 76

field chart 13

importing brushes 30, 65, 75

inking model 24

line up 13

model 22

Override tool 11

palettes 15

pencil presets, creating 29

pencil presets, selecting 28

Pencil tool 11, 27

presets, pencil 29

relative size 12

tasks 25

thickness stencil, deleting 29

thickness stencil, renaming 29

drawing elements

adding 143

creating 139

duplicating 147

Drawing layer 141

drawing tools 9

drawings

copying/pasting 173

deleting 172

duplicating 172

managing 171

merging 175

navigating 169

renaming 171

repositioning 14

duplicating

drawings 172

ease 331

setting on multiple parameters 299

ease-in 331

ease-out 331

Effect layer 142

establishing shot 331

exporting

brushes 30, 66, 76

erasers 30, 66, 76

pencils 30, 66, 76

exposure 331

creating cycles 166

decreasing 157

deleting 159

extending 151

extending sequence 152

Fill Exposure mode 149

filling 148

filling empty cells 165

filling selection 163

filling selection randomly 164

filling sequence with single
exposure 163

holding 151

increasing 157

inserting blank cells 160

moving cells 155

setting 161

typing in values 150

exposure sheet 331

extending

exposure 151

exposure sequence 152

fade-in 331

fade-out 331

field chart 13, 332

Fill Exposure mode 149

film-1.33 332

film-1.66 332

flipping 332

follow-through 332

forward kinematics 332

frame 332

frame rate 332

frames 137

adding before/after selection 137

navigating 169

functions 332

gamut 332

Group layer 142

HDTV 332

hiding

layers 176

Hold 332

holding exposure 151

HSV 332

importing

brushes 30, 65, 75

erasers 30, 65, 75

pencils 30, 65, 75

templates 273

in-between 332

ink and paint 332
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inking

model 24

interpolation 333

jump cut 333

key pose 333

keyboard shortcuts 333

keyframes 333

Layer Properties editor

displaying 145

renaming layers 146

layers 140, 333

bitmap 141

camera 141

changing colour 178

cloning 148

collapsing 175

Colour-Card 142

deleting 144

drawing 141

duplicating 147

effect 142

expanding 175

Group 142

hiding 176

modifying 146

Peg 142

properties 145

Quadmap 142

renaming 146

reordering 147

selecting parent or child layer 290

showing 176

Sound 143

types 141

layout 333

layout and posing 333

library 333

Library view

importing templates 273

light table 333

line of action 333

line up 13

lip-sync 333

auto detection 329

lip-sync detection

manual 334

low resolution 333

manual lip-sync detection 334

master palette 334

master peg

adding 208

merging

drawings 175

model 334

cleaning 24

inking 24

rough 24

sketching 10, 22

model sheet See character design

motion keyframe 334

mouth

chart 334

multiplane 334

navigating

columns 169

drawings 169

frames 169

NTSC 334

nudge 334

onion skinning 334

overlay 334

Overrride tool 11

PAL 334

palettes 15, 334

backup 109

creating, Advanced Palette List
mode) 17, 110

creating, Basic Palette List
mode) 16, 110

location 108

style 334

panel 334

panning 334

paperless animation 334

passing position 334

Paste Special

pasting with 173

pasting

drawings 173

path of action 335

Peg layer 142

pegs 335

adding master 208

pen 336

pencil presets 28

creating 29

renaming 29

selecting 28

Pencil tool

drawing 11, 27

phoneme 335

pivot 335

pixel 335

pixelation See bitmap image

pose-to-pose 335

presets

pencil 28

pencil, creating 29

pencil, selecting 28

Quadmap layer 142

relative size 12
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renaming

drawings 171

rendering 335

repositioning

drawings 14

resolution 335

RGB 335

rigging 335

adding master peg 208

basic deformation rig 233

Bone rig 233

chain, setting up bone and
articulation 236

rotary table 335

rotoscoping 335

rough

models 24

roughs 335

safe area 335

scenes 335

adding frames before/after
selection 137

extending 137

removing frames 139

setting length 137

script 336

scrubbing 336

sequences 336

shot 336

showing

layers 176

size

brush 15

relative 12

sketching

characters 21

model 10, 22

slow-in 336

slow-out 336

slugging 336

sound

scrubbing 336

Sound layer 143

stencils, thickness

deleting 29

renaming 29

stop-motion keyframe 336

storyboard 336

straight-ahead 336

strokes 336

tablet 336

templates 336

creating 263

importing 273

thickness stencil

deleting 29

renaming 29

thumbnails 336

timecode 336

timeline 336

Timeline view

cloning layers and columns 148

expanding and collapsing
layers/columns 175

modifying layers and columns 146

renaming layers 146

reordering layers 147

timing

adding frames before/after
selection 137

creating cycles 166

decreasing exposure 157

deleting exposure 159

extending exposure 151

extending exposure sequence 152

extending scenes 137

Fill Exposure mode 149

filling empty cells 165

filling exposure 148

filling selection randomly 164

filling selection with sequence 163

filling sequence with single
exposure 163

frames 137

holding exposure 151

increasing exposure 157

inserting blank cells 160

moving cells 155

preparing 135

references 136

removing frames 139

scene length 137

setting exposure 161

typing in exposure values 150

tools

Override 11

trace and paint 336

track breakdown 336

tradigital 334

traditional animation 336

trajectory 337

transition 337

underlay 337

vector 337

velocity 331, 337

walk cycle 337

Xsheet view 146

adding frames before/after
selection 137

advanced column types 143

cloning layers and columns 148

collapsing/expanding 3D path or
rotation columns 176

columns 140
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expanding and collapsing
layers/columns 175

layers 140

modifying layers and columns 146

removing frames 139

reordering columns 147

zone 337
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