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Chapter 1: Dialog Boxes
Dialog boxes contain controls such as options and lists through which you can carry out a particular command or 
task. For example, in the Scene Settings dialog box, you must indicate the resolution and alignment. A typical dialog 
box looks as follows:

Add Drawing Layer Dialog Box
The Add Drawing Layer dialog box lets you add a drawing layer  to your project. 

By default, when you create a new scene, there is one drawing column in the Xsheet view and one corresponding 
drawing layer in the Timeline view.
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You can add an element for each drawing and it will appear as a column in the Xsheet view,  a layer in the Timeline 
view.

For tasks related to this dialog box, see Adding New Drawing Elements on page 1.

How to access the Add Drawing Layer dialog box

 1. Do one of the following: 

‣ In the Timeline view, click the Add Drawing Layer  button.

‣ From the top menu, select Insert > Drawing.

‣ Press Ctrl + R (Windows/Linux) or ⌘  + R (Mac OS X).

Parameter Description

Name Lets you give the new layer a meaningful name.

Line Art Creates a vector or bitmap drawing layer in the Line Art layer. 

Colour Art Creates a vector or bitmap drawing layer in the Colour Art layer. 

Add and Close
Adds the selected type of layers to the Timeline view and corresponding 
column in the Xsheet view and closes the dialog box. The names of the lay-
ers/columns are automatically numbered incrementally.

Add

Adds the selected type of layers to the Timeline view and corresponding 
column in the Xsheet view. The dialog box remains open for you to add as 
many layers/columns as needed. The names of the layers/columns are 
automatically numbered incrementally.

Close Closes the dialog box.

Create Palette Dialog Box
The Create Palette dialog box lets you create a palette in Basic mode. For simple productions, it is recommended 
to use the Basic mode.  This setting stores the palettes automatically for you and saves them at the Scene level. 
When you use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: 
Environment, Job, Scene, or Element. 

For tasks related to this dialog box, see Creating a Colour Palette  on page 1.

How to access the Create Palette dialog box

 1. From the Colour view menu, select Palettes > New or click the New Palette button.

The Create Palette dialog box opens.

 2. Enter the palette name according to the model. 
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 3. Click OK.

The palette appears in the drawing element’s palette list.

Parameter Description

New Palette Name Lets you enter a name for the new palette.

Export to QuickTime Movie Dialog Box
The Export to QuickTime Movie dialog box lets you export your animation as a QuickTime movie. To render a 
QuickTime movie with transparency, you need to set the Depth to Millions of Colours +. You can set this this when 
exporting a QuickTime movie.

For tasks related to this dialog box, see Exporting a QuickTime Movie on page 1.

How to access the Export to QuickTime Movie dialog box

 1. From the top menu, select File > Export > Movie.

Parameter Description

Output

Browse
Lets you select a folder in which to save your movie and give it a file name for the 
export.

Export Range

All Exports the entire frame range.
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Frames Lets you enter the frame range to export.

Resolution

Resolution list
Lets you select a resolution ratio. If you select Custom, you can enter the width 
and height.

Width and Height Lets you specify the width and height of the resolution.

Options

Movie Options
Opens the Movie Settings dialog box in which you can set the the compression 
settings for the movie you will export—see Movie Settings Dialog Box.

Extend Exposure Dialog Box
The Extend Exposure dialog box lets you extend the exposure of a selected cell in the Timeline or Xsheet.

For tasks related to this dialog box, see Filling Exposure on page 1.

How to access the Extend Exposure dialog box

 1. Select a cell and do one of the following:

‣ From the top menu, select Animation > Cell > Extend Exposure.

‣ Press F5.

The Extend Exposure dialog box opens.

Parameter Description

Extend to Frame Lets you enter the frame up to which you want to extend the exposure.

Overwrite
Lets you expose the drawing in the frames and replace the drawings that were 
orginally there.

Insert
Lets you expose the drawing in the frames and move the subsequent frames 
forward in the Timeline view.

Fill Cells Randomly Dialog Box
The Fill Cells Randomly dialog box lets you fill in random values over a selection. You can give a maximum and a 
minimum value and create a range for Harmony to choose the random values from. The selection can be over one 
cell or a cell range in one column or more or an entire column or many entire columns.

For tasks related to this dialog box, see Filling a Selection Randomly on page 1.

How to access the Fill Cells Randomly dialog box

 1. In the Timeline or Xsheet view, select a cell range.
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 2. Do one of the following:

‣ Select Animation > Cell > Fill Cells Randomly.

‣ In the Xsheet view, click the Fill Cells Randomly  button  (you may have to customize the toolbar to 
display it).

The Fill Cells Randomly dialog box opens.

Parameter Description

Minimum Value The lowest acceptable value. 

Maximum Value The highest acceptable value. 

Hold The exposure holding value.

Whole Numbers
If you are applying this to a drawing column, this option lets you avoid having 
decimal points.

Add Key Exposure After Inserts a key exposure after the frame following the last cell. 

Import Images Dialog Box
The Import Images dialog box lets you  import bitmap images and vectorize them, making the images editable. Then 
you can use a variety of drawing tools to edit the image. Or you can always keep the original bitmap image as is.

Also, you can choose to import bitmap images on bitmap or vector layers depending on your project..

For tasks related to this dialog box, see How to Import Bitmap Images on page 1 and Importing Bitmap Images  on 
page 1.
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How to open the Import Images dialog box

 1. Do one of the following:

‣ From the top menu, select File > Import > Images. 

‣ In the File toolbar, click the Import Images  button.

‣ In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.

Parameter Description

Files

Browse Lets you find and select images on your computer.

Layer

Create Layers(s) Lets you create layers for imported images.

Create Single Layer 
Named

Creates a layer you can name.

Create Layer(s) Based 
on Filenames

Creates a layer based on each unique filename prefix. For example, the 
filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", 
where "a" has two drawings and "b" has one. When creating a single layer from 
these three filenames, all three drawings will be inserted in the new layers.

Add to Existing Layer Lets you select an existing layer to which imported images will be added.

Vectorization

Vectorize Image  

Colour Imports the bitmap image as a colour image.

Black and White
Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing.

Threshold
Determines what values in the scanned image will be considered as part of the 
drawing, and what will be ignored and eliminated in the vectorized drawing. The 
lower the value, the darker the image and vice versa.
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Smooth
Determines how smooth the lines will be. The lower the value, the more detail 
will be retained and vice versa.

New Preset Lets you create a new preset.

Delete Preset Lets you delete any preset in the list.

Custom Vectorization
Lets you set custom vectorization parameters—see Creating a Vectorization 
Style  on page 1.

Movie Settings Dialog Box
The Movie Settings dialog box lets you set the compression settings for the movie you will export.

For tasks related to this dialog box, see Exporting a QuickTime Movie on page 1.

How to access the Movie Settings dialog box

 1. From the top menu, select File > Export > Movie.

 2. In the Export to QuickTime Movie dialog box that opens, click Movie Options.

Parameter Description

Video

Settings
Opens the Standard Video Compression Settings dialog box. This is where you 
can set the video compression settings for the movie you will export—see 
Standard Video Compression Settings Dialog Box on page 32.

Filter
Opens the Choose Video Filter dialog box, where you can select from a range of 
filters to apply to your video export.

Size
Opens the Export Size Settings dialog box. The size settings are overridden by 
the Harmony's scene settings.

Sound  

Settings Opens the Standard Video Compression Settings dialog box. This is where you 
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can you set the sound compression settings for the movie you will export—see 
Sound Settings Dialog Box on page 31.

Paste Special Dialog Box
The Paste Special dialog box lets you determine how templates and symbols are imported in the Timeline view. 

When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You 
can choose to import only the keyframes without the drawings or import only the drawings that are not already in 
your layers. You can adjust the behaviour using the Paste Special dialog box.When you import a symbol in your 
scene, its full length is exposed by default. If you import a symbol in the Timeline view’s left side, all the frames 
will be exposed. However, if you import it into an existing layer, you can use the Paste Special dialog box to 
adjust the import behaviour to fit your requirements.Once you set the parameters, Harmony will reuse them each 
time you import a symbol in the Timeline view’s right side until you set new parameters.

For tasks related to this dialog box, see Using Paste Special on page 1.

How to access the Paste Special dialog box

 1. In the Library view, select the symbol or template to import.

 2. Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X) and drag the selection to the Timeline view.

NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

Preferences Dialog Box
The Preferences dialog box lets you adjust preferences to suit your work style, allowing you to work more 
efficiently.

NOTE: Some preferences require you to exit and restart the application, or close a view and reopen it.
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How to access the Preferences dialog box

Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences 
(Mac OS X). 

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

Shortcuts Tab

To speed up your work, all of the keyboard shortcuts can be customized. You can even choose other software 
keyboard shortcut sets.

In Toon Boom Harmony, you can choose a set of default keyboard shortcuts you are familiar with. You can choose 
between the following:

• Adobe Flash

• Toon Boom Harmony

• Toon Boom Studio

You can also customize most of the shortcuts and use the search feature to find particular shortcuts.
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For tasks related to this dialog box, see Shortcut Preferences on page 1.

Parameter Description

Keyboard Shortcut List
Lets you choose a set of keyboard shortcuts to use, including Toon Boom 
Harmony, Adobe Flash and Toon Boom Studio.

Keyboard Shortcut Categories
Each category lists all the keyboard shortcuts. Some commands may not have 
a keyboard shortcut assigned to it. Selecting a shortcut displays its description 
on the right.

Restore All Defaults
Restores all the default keyboard shortcuts. This erases any custom shortcuts 
you made.

Press Shortcut Key Displays the keyboard shortcut assigned to a command.

Clear Lets you remove the keyboard shortcut assigned to a command.

Default Lets you return a keyboard shortcut to its default.

Search
Lets you search for a command. The result is highlighted in the Keyboard 
Shortcut Categories on the left.

Search by Name/Shortcut Lets you search for a command by its name or keyboard shortcut keys.
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General Tab

Parameter Description

Save 

Auto-Save:

• Interval (minutes): This is the frequency at which the auto-save 
takes place.

• Inactivity Interval (seconds): When Auto-save is about to take 
place, it verify if you are drawing or doing anything in the application. 
If so, Auto-save waits this number of seconds before attempting 
another save.

• Ask Before Saving: Before performing an auto-save, the system will 
prompt you with a message to confirm if you want to save or not. You 
can choose to turn off this option.

• Enabled: This enables the Auto-save feature. If you do not want the 
system to automatically save your work, deselect this option. The 
auto-save is off by default.

Automatically Save Workspace: This option is enabled by default. Every 
time you add a view to your workspace, remove a toolbar or change a view’s 
width, these modifications are saved when you quit the application. If you do 
not want the system to save these modifications, disable the preference. 
This preference does not require you to restart the application.

Options

Touch Interface:

• Support Gestures: Enable the gestural touch interface for the 
OpenGL views. Note, on Mac OS, this determines whether a 2 finger 
drag gesture is interpreted as a zoom or a pan. 

• Invert Scroll Direction: Invert the scroll direction. 
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• Touch Sensitivity: Control touch sensitivity. On Mac OS, higher 
numbers give a slower response to pans. On Windows, higher 
numbers favour scale/rotates over pans.

Focus on Mouse Enter: 

Disabled by default. In Toon Boom Harmony, for the operations or keyboard 
shortcuts to work in the view in which you are working, the focus must be in 
that view. When the focus is on a particular view, a red rectangle appears 
around its frame. You must click in the view or on the view’s header for the 
focus to be done.

If you enable the Focus on Mouse Enter preference, you will not need to 
click in the view to get the focus. It will be done as soon as your mouse 
enters the view.

NOTE: If you enable the Focus On Mouse Enter preference, certain 
operations from the top menu may not be available since the view focus 
may change as you make your way to the top menu. In this case use 
keyboard shortcuts and quick access menus (right-click menus).

Auto Render: Automatically enables the Auto-Render option.

Use Dark StyleSheet (Requires Relaunch): Application loads a dark skin 
for the User Interface. 

Settings

Stop-Motion Keyframes: New keyframes are created as stop-motion 
keyframes. 

Default Separate Position for Pegs: New pegs are created with separate 
position functions.

Default Separate Scale for Pegs: New pegs are created with separate 
scale functions.

Timeline

Add Keyframe at Beginning and End: Add keyframes at beginning and 
end: Select this option to copy and paste a set of frames that includes an 
interpolated sequence between two keyframes, but only extracts a partial 
section. Under normal circumstances, cutting and pasting a function without 
either the start or end keyframe would render the function null. This option 
caps the partial function with a new keyframe when you perform the paste.

Extend Exposure of Previous Drawing: When drawing on a blank frame, 
a new drawing is created and the timing is extended from the previous 
exposed drawing.
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Camera Tab

Parameter Description

Settings

Set Keyframe At Frame One With First Application of the Transform Tool: 
When this option is selected, wherever you set a keyframe on a layer, a keyframe 
is added on your frame 1. If this options is deselected, a keyframe is only added 
to the current frame. If later on, you add a keyframe on your frame 1, it may 
modify the first keyframe you added.

Small Bitmap Resolution: The size, in pixels, of the smaller bitmap version of 
your image. When you import a bitmap image into a scene, a smaller version of it 
is created in order to accelerate the compositing and playback processes.

Control Points

Show Control Points On Selected Layers: By default, when you select an 
element with the Transform tool, the motion path related to the object is 
displayed.

Control Point Tension: The default Tension value for new keyframes and control 
points.

Control Point Continuity: The default Continuity value for new keyframes and 
control points.

Control Point Bias: The default Bias value for new keyframes and control points.

Colours Background Colour: Lets you change the background colour.
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Drawing Tab

Parameter Description

Light Table Onion Skin Render Style:
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• Normal: The onion skinned drawings are displayed in washed out 
colours.

• Enable Shade: The previous onion skinned drawings are displayed in 
washed out red shades and the next onion skinned drawings are 
displayed in washed out green shades.

• Outlines Only: The onion skinned drawings are displayed as outlines 
only.

Light Table: Enable Shade: When enabled, the drawings appearing on the 
Light Table are displayed in washed out colours in the Drawing view. When 
this option is disabled, the drawings appearing in the Light Table are displayed 
using normal colours. This option is for the Drawing view only.

Light Table: Shade in Camera View: When enabled, the drawings appearing 
on other layers are displayed in washed-out colours in the Camera view. When 
this option is disabled, the drawings appearing on other layers are displayed 
using normal colours. This option is for the Camera view only.

Options

Grid On By Default: When opening the Drawing view, the grid displays 
automatically.

Select Tool is Lasso: When this option is enabled, the Select tool behaves as 
a lasso selector. When this option is disabled, the Select tool behaves as a 
rectangle selector.

Brush Size Cursor: When this option is enabled, the brush tool displays the 
brush size as a circle around the cursor.

Auto Gap Closing in Pixel Units: Disabling this option will cause your gap to 
be zoom dependent. Zoom dependent means that the more you zoom in, the 
smaller the gap you can close with the Close Gap tools. By enabling this 
option, you choose to make the gap display available in pixel units, which is 
not zoom dependent.

Auto Gap Closing on Startup: The values for automatic gap closing while 
painting drawings are: 0 = Disabled, 1=Small, 2=Medium, 3=Big.

Colours
Background Colour: Lets you change the background colour.

Grid Colour: Lets you change the colour of the grid.

Zoom

Enable Paper Zoom: Enabling this option allows you to set the 100% Zoom 
level onscreen, in order to physically match the measurements of your paper 
drawing.

Number of Pixels per Inch: Enter the PPI for your monitor. To obtain the PPI 
of your screen, divide the height or width of your monitor's resolution setting by 
the corresponding physical height or width  of your monitor screen (resolution 
height divided by physical height, or resolution width divided by physical width) 
in inches.

Quick Close Up Zoom Factor: Sets the zoom level for the Quick Close up 
Zoom keyboard shortcut. 

Maximum Zoom Factor: Sets the maximum zoom level for the paper zoom.
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OpenGL Tab

Parameter Description

Settings

Conservative Texture Management: Turns on and off conservative memory 
management for bitmap texture files. Performance will improve when this is 
enabled. If disabled, you will have a better on-screen rendering of bitmap files 
at the expense of slower performance.

Smooth Textures: Smooths out the pixels of bitmap images when zooming in; 
this improves bitmap image quality.

Alternate Gradient and Cutter: This is an alternative way to disable write in 
the OpenGL Backbuffer, required for some video cards (i.e. GeForce FX5200). 
Do not enable this option unless you are experiencing problems with gradients 
and cutters in OpenGL.

Use PBuffer for Picking: This will use an off-screen buffer for picking, 
resulting in a quicker response. This option should not be enabled if using a 
small capacity video card (32MB).

Support Triple Buffer: Enable this option for a better compatibility with 
Windows Vista if your video card driver does not allow to disable the triple 
buffering option. Not enabling this option may result in a dashing line when 
drawing a brush stroke.

Support Desktop Effects: Enable this option for better compatibility with 
Windows 7, Windows Vista and Mac OS X desktop effects. This will prevent 
graphic compositing problems from happening when the full-scene anti-aliasing 
option is enabled.

Maximum Texture Size: The size that the bitmap file will be reduced to when 
using the Conservative Texture Management.

Texture Memory: The amount of temporary memory used to store bitmap 
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texture files.

Vector Drawing Maximum Texture Size: This is the size that the .tvg file will 
be reduced to for better performance when in OpenGL render mode.

Full Scene Antialiasing

The Full Scene Antialiasing is generated by your computer’s graphic card. It 
provides a smooth line display in OpenGL. This antialiasing will not only 
antialias your drawings but all the different views in the interface.

This option lets you see smooth lines as you draw as well as an antialiased 
drawing area. You can change the value of the Full Scene Antialiasing using 
the Preferences dialog box to fit the current level used in the Camera or 
Drawing view.

Enable (Requires Relaunch): By default, this option is off. Select to turn on 
the Full Scene Antialiasing option. You'll need to restart Toon Boom Harmony.

Number of samples (For Mac OS): Enter the number of samples you want to 
be used for the antialiasing process. The number of samples is basically 
equivalent to the amount of time a pixel will be enlarged to calculate the 
antialiasing. This technique is called supersampling. The higher the number of 
samples, the better the antialiasing quality will be, but the longer it will take to 
calculate. The recommended value is 4.

NOTE: If you are using Windows or Linux, you must enable your graphic 
card’s antialiasing parameter. Refer to user guide of your graphics card. For 
example, the parameters for an NVIDIA GeForce card may look like this: 
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Advanced Tab

Parameter Description

Advanced Options

Support CMYK in PDF/Illustrator Import: Lets you import .pdf and .ai files 
that were created or exported in CMYK mode. The colours of the resulting 
imported image may still not look 100% faithful to its CMYK original due to the 
RGB conversion. It is recommended that you convert these files to RGB 
images before importing them into Toon Boom Harmony. Disabling this option 
will cause all the colours of the imported image to be displayed as red to 
indicate that the file was not converted to RBG before import.

PDF/Illustrator Import as Separate Layers: Imports  the different 
groups/elements of the .pdf or .ai file as separate layers. For Illustrator files, 
the import will use the top level group as separate layer names. Deselect this 
option to import pdf or .ai files as a single layer.

Tablet Support
Use Qt Wintab Tablet Support (Requires Relaunch): If you are using a 
tablet other than Wacom, deselect this option (and relaunch) if you are having 
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issues with offset or pressure sensitivity.

Unicode

Allow Unicode Names: Lets you use up to 120 ASCII characters for names of 
environments, jobs and scenes. This means you can use characters for 
languages, such as Japanese, Chinese, French, Spanish, and others, 
characters for names in your database setup—see Advanced Tips and 
Guidelines on page 1.

Remove Dirt Dialog Box
The Remove Dirt dialog box lets you select small dots and hairs on a drawing for removal.

When paper drawings are passed through a scanner, there can be some hair and dirt scattered across them. These 
lines and dots need to be cleaned. Harmony provides different tools to help get rid of them quickly.

For tasks related to this dialog box, see Dirt Clean Up on page 1.

How to access the Remove Dirt dialog box

 1. Do one of the following:

‣ From the top menu, select Drawing > Clean Up > Remove Dirt.

‣ From the Camera or Drawing View  menu, select Drawing > Clean Up > Remove Dirt.

‣ Press Shift + D.

Parameter Description

Slider

Lets you adjust the amount of detail removed from the layer. 

Raising the Remove Dirt level will select bigger dots. When selecting larger dots, 
be careful not to lose small details like pupils and nostrils. Once you have chosen 
the level, you can apply it to the current drawing or the entire animation sequence. 
This is a quick way to get rid of most dirt and dust.

During this process, the dirt that will be removed is highlighted in red.

Apply to all drawings Applies the operation to all drawings in the layer.

Remove Hair Dialog Box
The Remove Hair dialog box lets you remove any small strokes created in the Colour Art layer from very thick lines 
or filled zones. Increasing the Remove Hair level value will select larger strokes for removal from the drawing.

When paper drawings are passed through a scanner, there can be some hair and dirt scattered across them. These 
lines and dots need to be cleaned. Harmony provides different tools to help get rid of them quickly.

For tasks related to this dialog box, see Dirt Clean Up on page 1.
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How to access the Remove Hair dialog box

 1. In the Timeline or Xsheet view, select the drawing containing the drawing to clean.

 2. From the top menu, select View > Show > Show Strokes to display the invisible lines or press K.

 3. In the top menu, select Drawing > Clean Up > Remove Hair.

Parameter Description

Slider Lets you adjust the number of length of hairs selected. 

Apply to all drawings Applies the operation to all drawings in the layer.

Scene Settings Dialog Box
The Scene Settings dialog box lets you parameters for your scene. 

When you created your new scene, you set up the resolution and the alignment. However, if you want to change 
these initial settings later, you can do it using the Scene Settings dialog box. The different Scene Settings options 
are separated into four tabs.
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How to access the Scene Settings dialog box

 1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.

Resolution Tab

Parameter Description

Resolution Presets

You can select your project’s resolution (camera frame size) from this preset list.

‣ HDTV: High definition television delivers a higher quality image than 
standard television (4:3) does, because it has a greater number of lines of 
resolution. To take advantage of the superior quality your output device 
must be compatible with HDTV technology to make this resolution setting 
useful.

‣ HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to how 
the images will be aligned in relation to the actual scene frame (default 4:3 
grid). Note that the camera resolution and the scene frame are not the 
same. When working with 12 or 16 field drawing grids, the grid is a different 
aspect ratio from the camera frame. When you fit vertically, you fit the 
images with the top and bottom of the scene grid.

‣ film-1.33: Use this resolution setting for the academy film format that 
conforms to the standard 4:3 aspect ratio.

‣ film-1.66:  Use this resolution setting for the widescreen film format that 
conforms to the 16:9 aspect ratio.

‣ film-1.66_Vertical: This is essentially the same as film-1.66. Refers to 
how the drawing is fit into the scene frame. When working with 12 or 16 
field drawing grids, the grid is a different aspect ratio from the camera 
frame. When you fit vertically, you fit the images with the top and bottom 
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of the scene frame.

‣ NTSC: This is the standard analogue television broadcasting system used 
in North America and conforms to the North American standards on how 
rectangular pixels are displayed for computer and television screens.

‣ PAL: This resolution works best with the European format for television 
and computer screens, as the rectangular pixels are displayed at a 
different orientation.

‣ Low: This format is ideal for videos destined for the web, where size and 
fast download of a video file might take precedence over quality.

‣ Cloud Preview: This is the resolution used by Web Control Center to 
create its preview.

Selected Resolution Preset Displays the selected resolution preset.

Save Resolution Setting
Click the Save Resolution button after you define your new resolution to save it 
as a preset.

Pixel Dimensions

Displays the pixel dimensions for your project resolution.

If you decide to type in the pixel dimensions, or use the up and down arrows to 
change the pixel increments, you will have to save your custom selection in order 
to save it as a new preset. It will then appear in the resolution selection list. It 
doesn't modify the current resolution preset.

Aspect Ratio
Displays the ratio between the horizontal and vertical dimensions of the camera 
framing. Each resolution setting has a preset aspect ratio that cannot be changed.

Frame per second

Sets the frame rate for your project. The higher the frame rate, for example 30 fps, 
the faster the animation will pla. The lower the frame rate, for example 12 fps, the 
slower your animation will play. Avoid going under 12 frames per second as your 
animation will have a choppy playback. The human eye requires a minimum of 12 
frames per second to perceive a fluid animation.

Field of View

Use these options to define the FOV (field of view) of the camera (angle of the 
camera cone) and how the drawing elements (and drawing grid) align to the scene 
grid. The drawing grid is always scaled proportionally to a 4:3 ratio (unless you 
change the scene alignment), therefore changing the Field of View setting may 
not show a visible difference if your project resolution is also 4:3, such as NTSC.

‣ Horizontal Fit: The camera resolution is set to fit the left and right edges of 
the scene grid.
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‣ Vertical Fit: The camera resolution is set to fit the top and bottom edges of 
the scene grid. 

Scripts Manager Dialog Box
The Scripts Manager dialog box lets you link a script to a toolbar button for quick and easy access. Once you select 
a script, you can add it to the toolbar, load a custom icon and add a tooltip.
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For tasks related to this dialog box, see Linking a Script to a Toolbar Button on page 1.

How to access the Scripts Manager Dialog Box

 1. In the Scripting toolbar, click the Manage Scripts  button.

The Scripts Manager dialog box opens.

Parameter Description

Files A list of the available JavaScript files.

Functions A list of the available functions for the selected script.

In Toolbar Adds the selected script to the toolbar.

Execute Runs the script you selected. Press Esc to interrupt the execution of the script.

Customize Icon Lets you load a custom icon for the function. You can browse for a *.png, 
*.jpg or *.xpm file.

Customize Tooltip Lets you type in a tooltip for the function. When you hover over the button in the 
toolbar, your tooltip will appear.

Select Colour Dialog Box
The Select Colour dialog box lets you set the colour of layers and columns.  Using colours for layers and columns 
helps to differentiate them visually, making them easy to identify. 

You can select a colour by choosing from a basic set of colours, using the colour wheel or by specifying the HSV 
or RGB values. Once you have selected a colour, you can adjust its intensity and save it as a custom colour that 
you can reuse.
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For tasks related to this dialog box, see Changing the Colour of a Layer or Column on page 1.

How to access the Select Colour dialog box in the Timeline view

 1. In the Timeline view, click the Change Track Colour  button of the layer you want to modify. 

The Select Colour dialog box opens.

How to access the Select Colour dialog box in the Xsheet view

 1. In the Xsheet view, select one or more columns to modify.

 2. Right-click on the column’s header and select Colour > Change Columns Colour.

The Select Colour dialog box opens.

Parameter Description

Basic colours The basic set of colours in the system? 

Custom colours Displays the custom colours you created. 

Add to custom colours Lets you add the selected colour to the Custom colours list above.

Colour wheel Lets you select a colour by dragging the T-shaped pointer.

Value slider
Once you select a colour, you can drag the slider to change the intensity and see 
it previewed in the Colour Preview window below.. 

Colour Preview Displays the colour you are currently selecting. To apply the colour, click OK.

Hue, Saturation, Value
Lets you set the hue (colour), saturation (amount of colour) and brightness (value) 
of the colour.

Red, Green, Blue Lets you set the red, green and blue values.
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Set Ease for Multiple Parameters Dialog Box
The Edit Set Ease for Multiple Parameters dialog box lets you apply ease to multiple functions and keyframes. 
You can display the function curve and modify the Bezier or Ease curve—see Adjusting the Velocity on page 1.

How to access the Set Ease for Multiple Parameters dialog box

 1. In the Timeline view, select a keyframe on one or more layers.

 2. Do one of the following:

‣ In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

‣ In the Timeline toolbar, click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

Parameter Description

Filters

Motion

 

Motion: Applies the easing parameters to the selected Position X, Position Y, 
Position Z and 3D Path functions.

Rotation: Applies the easing parameters to the selected Angle functions.

Scale: Applies the easing parameters to the selected Scale functions.

Skew: Applies the easing parameters to the selected Skew functions.

Morphing: Applies the easing parameters to the selected Morphing Velocity 
functions. Note that it applies to the Morphing velocity function found in the 
Layer Properties window, not the basic morphing ease in the Tool Properties 
view.

Other: Applies the easing parameters to all the other the selected functions, 
such as all functions created to animate effect parameters.
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Left and Right Time Ratio
Lets you type the percentage value corresponding to the length of time you 
want the easing to last. Stay between 0% and 100%. If you go beyond 100%, 
your motion will overshoot. 

Left and Right Value Ratio
Lets you type the percentage value of how strong you want the easing out to 
be. Stay between 0% and 100%. If you go beyond 100%, your motion will 
overshoot. 

Apply/Previous
Applies the easing parameters to the selected keyframes and then selects the 
previous keyframe in the timeline.

Apply Applies the easing parameters to the selected keyframes.

Apply/Next
Applies the easing parameters to the selected keyframes and then selects the 
next keyframe in the timeline.

Close
Close the dialog box. If you did not apply the modifications, they will be 
cancelled.

Sound Settings Dialog Box
The Sound Settings dialog box lets you set the compression settings for the movie you will export.

For tasks related to this dialog box, see Exporting a QuickTime Movie on page 1.

How to access the Sound Settings Dialog Box

 1. From the top menu, select File > Export > Movie.

 2. In the Export to QuickTime Movie dialog box that opens, click Movie Options.

 3. In the Movie Setting dialog box that opens, click Settings in the Sound section.

Parameter Description

Compressor

Lets you select a compression type. The default setting is None. This will 
preserve your original sound file without the loss of information. However, an 
uncompressed sound file will inevitably add “weight” to the overall size of your 
video export.

Rate

Lets you select a rate. 
It is best to check and match the original properties of your sound file. For 
example, if your file has an audio sample rate of 48 kHz and you choose a con-
version rate of 22.05 kHz, the sound will play at the same speed, but with higher 
frequencies missing. For a standard film sound quality, choose 44.1 kHz, or 48 
kHz for DVD quality. Anything less will make the sound “dull” or less bright. For 
things like recorded voice, this doesn't matter so much, but for music it can make 
an audible difference. If file size is a consideration, such as with videos for the 
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Internet, then a lower rate might be more practical.

Size and Use

Size and Use are related. It is advisable to check your original sound file 
properties. If the file was recorded in one channel (mono), there is no point in 
choosing the two channel (stereo) option. Although Mono can support a 16-bit 
channel, the extra information is unnecessary. Mono is generally paired with 8-bit 
and Stereo with 16-bit.

Standard Video Compression Settings Dialog Box
The Standard Video Compression Settings dialog box lets you set the compression settings for the movie you will 
export.

For tasks related to this dialog box, see Exporting a QuickTime Movie on page 1.

How to access the Standard Video Compression Settings Dialog Box

 1. From the top menu, select File > Export > Movie.

 2. In the Export to QuickTime Movie dialog box that opens, click Movie Options.

 3. In the Movie Setting dialog box that opens, click Settings in the Video section.

Parameter Description

Compression Type
Lets you select a codec. The availability of certain compression settings 
depends on the Compression Type selected. For example, Animation is the 
default compression type and as a result the Data Rate option is greyed out. 

Motion

Frame Rate
Lets you select a frame rate. By default, it is set to match the frames-per-
second (fps) of your Harmony project. If you choose a lower frame rate, your 
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export playback will be faster than your actual project. The reverse is also true 
for a higher frame rate. 

Key Frames

Automatic: 

Every: Inserts keyframes. This is the option is recommended by QuickTime. 
For further details, refer to the QuickTime documentation.

All: 

Frame Rendering: 

Frames: Lets you set the number of keyframes to insert.

Compressor

Depth
Lets you select a depth based on your movie’s needs. For example, Millions of 
Colours+ houses an alpha channel.

Quality
Lets you choose a quality setting. The higher the quality of the export, the 
larger the resulting file.

Data Rate

Date Rate

Automatic: Lets the system automatically select the most optimal bit rate.

Restrict To: Lets you enter a rate to save space and allow for faster 
downloading at a cost to the quality of the export. 

Optimized For: Lets you select the intended viewing method.

Preview Displays a preview of the movie to be exported.

Timeline Scene Marker Dialog Box
The Timeline Scene Marker dialog box lets you create and manage scene markers in the Timeline view. Scene 
markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can use it to 
denote anything relevant to your work. You can indicate the frames you want to clean up, a change in action, an 
impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is displayed when 
you hover over the scene marker.

For tasks related to this dialog box, see Setting Scene Markers on page 1.

How to access the Timeline Scene Marker dialog box

 1. In the frame counter area of the Timeline view, do one of the following:

‣ Drag to select the frame range to mark.

‣ Right-click and select Scene Markers > Mark Current Frame.

Parameter Description
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Colour swatch
Opens the Mark Colour dialog box where you can select a colour for the scene 
marker.

Note (Tooltip)
Lets you type in a name for your scene marker. Making the name meaningful will 
help you to quickly identify scene markers especially when there are many of 
them in the frame counter area of the Timeline view.

Toolbar Manager Dialog Box
The Toolbar Manager dialog box lets you customize the toolbar in any of the views. You can add your favourite 
tools to a toolbar for an efficient workflow.

For tasks related to this dialog box, see Managing the Toolbars on page 1.

How to access the Toolbar Manager dialog box

 1. Right-click on a toolbar in any view and select Customize.

Parameter Description

Available Tools Displays the complete list of tools available for customizing a toolbar.

Toolbar Displays a list of the tools currently available on the toolbar.

Default Restores the toolbar with its default items.

Vectorization Parameters Dialog Box
The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green 
pencil marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure red, 
blue, green and black (RGB values), while creating colour art zones wherever lines connect. After painting in your 
tones and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker window and 
watch the indicator colour zone lines disappear.
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For tasks related to this dialog box, see Custom Vectorization Parameters  on page 1.

How to open the Vectorization Parameters dialog box

 1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization parameters 
(i.e. from the scanner).

 2. In the Scan Drawings window, do the following:

‣ In the Layer section, decide on the layer options.

‣ In the Import Options section, select the Convert to Toon Boom Vector Drawing option

‣ Click Preview.

 3. In the Vectorization section, click the Vectorization Parameters button.

Options Tab

The Options tab contains the main vectorization settings. More settings are available in the Help tab.
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Parameter Description

Input The input filters are applied to the bitmap image before it is vectorized.

One Pass
One threshold value is applied to both the Line and Colour Art. For drawings 
with distinct vector-style lines of mattes, you only need one pass.

Two Passes
Applies a different threshold value to each layer. For greyscale drawings, you 
may want to perform the vectorization process twice to apply different 
threshold values to the Line and Colour Art layers.

Threshold
Determines which values in the scanned image are considered part of the Line 
or Colour Art layer and what will be eliminated from the vectorized drawing; 0% 
is white and 100% is black. The threshold is between these two values.

Expand Bitmap
Lets you enter a value to scale the bitmap to detect small variations in the line. 
Use this option if you scanned a greyscale image and want to preserve small 
variations in the texture to apply to the line art.

Jag Filter
Lets you enter a value to scale back the bitmap to remove some of the line’s 
roughness. This is useless when you have a drawing that appears quite rough; 
the Jag filter will eliminate excess strokes in the final drawing.

Line Art Threshold (%)

Colour Art Threshold 
(%)

Output The output filters are applied during the vectorization process.

No Colour Art Does not generate filling zones in the Colour Art layer.

No Texture
Does not generate texture in the Line Art layer in the final images. Select this 
option to create solid lines in the final line art.

Generate Matte in 
Underlay Layer

Creates an opaque zone behind your drawing’s lines to avoid seeing through 
the layers.

Colour as Texture Converts colour values into a texture layer.

Optical Registration
The optical registration options are used to automatically align drawings based 
on the position of the peg holes on the animation paper. The peg holes must 
appear in the scanned drawings for the optical registration to work.

DPI Lets you enter the dots-per-inch value of your image. You must enter the same 
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value as the DPI used to scan the image.

Peg Side
Lets you select the position of the peg holes on your drawings. Identify whether 
they are on the top, bottom, left or right.

Strictness

Determines how exact the location of the peg holes must be for the software to 
recognize them. There are two values to choose from:

Strict: The peg holes must be in a tightly defined area to be recognized.

Loose: The peg holes can be recognized somewhere in a larger area. This is 
the recommended setting.

Field Chart Lets you indicate the size of the animation paper, 12 or 16.

Post Processing The Post Processing filters are applied to the final vector images.

Remove Holes Removes holes of a specified value that might make painting difficult.

Remove Dirt Removes stray marks and dirt of a specified value. Try a value around 500.

Remove Hair Size Removes small strokes that have no line art.

Remove Hair: Number 
of Passes

The number of times the drawing will be analyzed to identify hair marks.

Miscellaneous

Close Gaps Closes gaps in the Colour Art so you can paint it.

Smooth Passes for Line 
Art Before Breaking 
Triangles

The number of times the smoothing operation runs before creating the triangles 
that break lines in the drawing. If unnecessary triangles are appearing in the 
drawing, increase this value.

Smooth Passes for Line 
Art

The number of times the smoothing operation is performed after the triangles 
have been created. This further smooths the line art.

Preview

Show Strokes Shows the strokes in the Vectorized Image panel.

Stroke Thickness Shows the size of the strokes.

Help Tab

The Help tab contains the most advanced vectorization settings which you type in the Advanced Option fields at the 
bottom of the Vectorization Parameters dialog box.
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File IO Options

-file <filename (including extension)> [ options ]

-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode

-noforce; don't force output if image is inconsistent

-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options 

-register <dpi side strictness>; perform optical registration.

• Side can be one of left, right, top, bottom or l, r, t, b.

• Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page

-rcph; short form of register_center_peg_holes

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)

-rlf; short form of registration_looseness_factor

-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg bars

-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0

-rmargin <inch (default 1)>; region size where to look for peg bars 

-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image 
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-pdfc; short form of -peg_distance_from_center 

-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

• Can be one of right, left, top, bottom (or r, l, t, b) or same.

• A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options 

-pixel <pixel_shape (default '4x3')>; Valid values: 4x3

-gap <worldUnits (default 10)>; close gaps up to this big

-pencil; generate line art only

-keep_dirt; don't filter out dirt

-thresh <threshold (default 0.2)>; range 0.0 to 1.0

-rmv_hairs <worldUnits (default 1)> <passes (default 1)> 

• remove hairs of size smaller than "size" in "passes" passes 

-rmv_holes <area (default 7)>; remove holes smaller than "area" 

-rmv_dirt <area (default 1)>; remove dirt smaller than "area" 

• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels" 

• distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes

-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour

-noclosegap; disable all gap closing algorithms

-no_break; disable the breaking of line art

-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap

-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap

-fit_errorc <error (default 1.000000>; fitting error for the colour art

-fit_errorl <error (default 1.000000>; fitting error for the line art

-smoothl <passes (default 1>; number of smooth passes for line art

-smoothc <passes (default 1>; number of smooth passes for colour art

-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -2pass)
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-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"

(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,

-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0

-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0

-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-rmv_holesl <area (default 7)>; remove line art holes smaller than "area" 

-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area" 

-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area" 

-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area" 

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are in 
world units squared 

-margins <inch (default 0.25)>; remove margin around bitmap 

-top_margin <inch (default 0.25)>; remove margin at top of bitmap 

-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap 

-left_margin <inch (default 0.25)>; remove margin at left of bitmap 

-right_margin <inch (default 0.25)>; remove margin at right of bitmap 

-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size

-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art

-downscale_input <default 1>; downscale the raw input by this integer factor

-downscale_texture <default 1>; downscale the output texture by this integer factor

-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

NOTE: -buildmatte and -buildmatte_colourart are mutually exclusive
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-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information 

-pixel_margins <inch (default 0)>; remove margin around bitmap 

-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap 

-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap 

-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap 

-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap 

-dpi <(default -1)>; dpi information of input bitmap 

RGB Keying Options 

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value

-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

-flatten; flatten the drawing after generating colours

-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area

-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb

-threshrgb <value> <threshold for rgb vectorization default 0.200000>;

-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on saturation and 
value to consider a pixel to be grey

Colour Vectorization Options 

-color_vectorize; perform a colour vectorization

-file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect (0.0-1.0)> 
<edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap file (valid filename or "" if no 
file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max variation (0.0-
1.0)>; specify a pressure strategy for the centre line. 

-blur_radius <pixels (default 0)>; blur the penstyle texture generated

-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour before 
computing texture

-ccsp <times (default 3)>; short for -color_contour_smooth_passes

-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing texture
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-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)

-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only 

-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles

-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness (must be >= 
1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness (must be 
>= 1.0)

-uniform_gap; the space between bubbles is constant 

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:

rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value    ; between [0.0-1.0] or [0-255]

grey:value    ; between [0.0-1.0] or [0-255]

white:value   ; between [0.0-1.0] or [0-255]

dirt:value    ; dirt area. 200 is a good value

rt:value      ; between [0.0-1.0] or [0-255]

gt:value      ; between [0.0-1.0] or [0-255]

bt:value      ; between [0.0-1.0] or [0-255]

NOTE: There must be no space between the colon and the key/value. For example: -4colours rgbdiff:20 dark:20 
grey:120 white:250 dirt:200 rt:240 gt:240 bt:240

42



Harmony 12.1 Essentials - Traditional Animation Guide

Chapter 2: Layer Properties
Intro...

Drawing Layer Properties
The Layer Properties editor or view lets you adjust the properties of a layer in the Timeline view The Layer Properties 
can be viewed as a floating window or as a view (docked).

Each layer has its own set of properties that can be modified, including effect and peg layers. Display the Layer 
Properties editor or view if you want to modify some of the layer’s properties, such as the name or the antialiasing 
quality. 

How to access the Layer Properties editor

‣ Double-click on a layer in the Timeline view

‣ Right-click on a layer in the Timeline view and select Layer Properties.

‣ Select a layer in the Timeline view and press Shift + E.

How to access the  Layer Properties view

 1. Do one of the following:

‣ Select the view you want to add from Windows > Layer Properties.

‣ In the top-right corner of a view, click the Add View  button and select Layer Properties from the list.

By default, the Layer Properties view appears as a tab.
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Transformation Tab

The Transformation tab contains parameters for adjusting the position, scale, rotation, skew and pivots of an 
element.

Parameter Description

Position

3D Path: Lets you use a 3D path function to animate an element.

Separate: Lets you independently edit the different coordinate fields.

Path (x) Axis: Lets you type in a new East/West coordinate corresponding to 
the desired position.

Path (y) Axis: Lets you type in a new North/South coordinate corresponding to 
the desired position.

Path (z) Axis: Lets you ype in a new Forward/Backward coordinate 
corresponding to the desired position.
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Velocity: When the 3D Path option is selected, lets you set the speed at which 

Scale

Locked: Resizes the element while keeping its ratio. The X and Y axes scale 
proportionally

Separate: Resizes the element allowing to modify the ratio (squash and 
stretch).

(x) Axis: Lets you type in the horizontal scale value.

(y) Axis: Lets you type in the vertical scale value.

Rotation
Angle z: Lets you  type in a degree value for the rotation angle. Note that you 
can enter values greater than 360 and -360 degrees. If you enter 720, the object 
will rotate twice.

Skew Skew: Lets you type in a degree value between -90 to 90 for the skew angle.

Pivot

(x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

(y) Axis: Lets you ype in a new North/South coordinate corresponding to the 
desired position.
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Chapter 3: Menus
There are several types of menus in Harmony: main menus, quick-access menus and view menus.

• Main Menus on page 47

• Quick-access Menus on page 60

• View Menus on page 61

Main Menus
The main menus contain most of the commands. Depending on the view you're working in and the element, some 
commands are available and others not. The main menu is always located at the very top of the interface.

On Mac OS X, there is also a Stage Essentials category that contains the following commands:

• Preferences

• About

• Quit

Animation Menu

The Animation menu lets you access tools, adjust animation timing, set  and  parameters, lock or unlock layers, and 
select elements in the Xsheet and Timeline views.

How to access the Animation menu

‣ At the top of the interface, select Animation.

Command Description

Animate

Enables the Animate mode which lets you keyframe drawing layers to 
create computer-generated animation. When working in the Animate 
mode, you can animate a layer's position and then turn off the mode to 
reposition a layer for the entire scene. When the Animate mode is 
disabled, keyframes are created on selected layers at the current 
frame. Depending on what transformations were performed (rotation, 
translation, skew), the new keyframes are added on the corresponding 
parameters (function curves).

Stop-Motion Keyframe

Sets a stop-motion keyframe which there is no computer-generated 
motion between two keyframes. The segment is constant or flat. The 
drawing remains still until the playback reaches the next keyframe, 
then the drawing pops to its new location.

Delete Keyframe Deletes the selected keyframe.

Tools

Transform
Lets you create a global selection so you can reposition, scale, rotate 
and skew as one unit, which is useful for cut-out characters.
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Translate Lets you move the selected element along the X and Y axes.

Rotate Turns a selected element around its pivot point. 

Scale
Increases or decreases the size of a selected element. You can scale 
an object up to make it larger or down to make it smaller. Press Shift to 
scale the element while maintaining its proportions.

Skew Slants the selected element.

Maintain Size
Keeps elements the same size aspect ratio in the Camera view as you 
move them towards or away from the camera.

Spline Offset

Lets you reposition the visual trajectory without offsetting or modifying 
your animation. By default, the trajectory is located at 0,0,0 fields. If 
your elements were drawn in a different location than the centre of the 
drawing area, it will look like the trajectory is not aligned with your 
drawing. Also, if you have several elements attached to one trajectory, 
you might want your trajectory to be at a different location to represent 
the group's motion better.

Cell

Increase Exposure

Adds one more exposure to a selected cell; repeating this action adds 
an extra cell each time. This is an efficient way to extend a drawing's 
exposure and is always set in Insert mode. Increasing an exposure 
pushes the existing exposure forward.

Decrease Exposure

Decreases exposure of a selected cell by one; repeating this action 
decreases one exposure adds an extra cell each time. This is an 
efficient way to shorten a drawing's exposure. Decreasing an exposure 
pulls in the existing exposure.

Set Exposure to Lets you set the exposure to 1, 2, 3 or a custom exposure.

Extend Exposure

Lets you enter the frame up to which you want to extend the exposure. 
You can expose the drawing in the frames and replace the drawings 
that were originally there or move the subsequent frames forward in 
time.

Add Key Exposure Adds a key exposure to the selected cell. 

Remove Key Exposure
Removes only the key exposure (key frames) not all the exposures. 
The existing key exposure is replaced by the preceding exposure.

Remove Duplicate Key Exposure

When working with drawings to adjust the timing of a mouth in a 
lipsync, for example, and forcing the use of specific key exposures, 
unnecessary key exposures will be created. You can delete these 
duplicates without affecting the rest of the drawing. The first drawing of 
the selection will be used for the range.

NOTE: Duplicate key exposures may occur when pasting with the 
Enforce Key Exposure option selected.

Fill Empty Cells

Lets you fill empty cells to extend the exposure of single frame 
drawings to fill the range of empty cells after each one.When creating 
drawings on  cells that are not side-by-side, the exposure of the first 
drawing no longer fills automatically. You must select the frame range 
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where you want your drawings to hold their exposure up to the next 
drawing and use the Fill Empty Cells command.

Insert Blank Cell Adds an empty cell between other cells.

Clear Exposure Removes the exposure from the selected cell.

Clear Exposure and Pull
Replaces the exposure from the selected cell with exposures that 
follow it.

Fill Selection

Lets you fill the same value over an entire selection. The selection can 
be over one cell, a cell range in one column, a cell range over many 
columns, an entire column, or many columns. You can use numbers, 
words, letters, or any alphanumeric value.

Sequence Fill

Lets you create a numbered sequence over a selection. The sequence 
can be forward, backward, single, double or higher increment, as a 
cycle, and so on. The selection can be over one cell or a cell range in 
one column or more or an entire column or many entire columns.

Lip-Sync

Auto Lip-Sync Detection Generates a sound detection for lip-sync.

Map Lip-Sync
Automatically maps drawings in an element to the mouth chart you 
have generated for a sound. This can save time when you are lip-
synching a voice track.

Flip

Flip Horizontal
Flips the selection horizontally or vertically.

Flip Vertical

Flip Scale X

Once your drawing layer is rotated, the original horizontal and vertical 
axes change. The Flip Scale X and Flip Scale Y will perform a flip on 
your drawing layer following its original axis.Remembers the original X-
axis of the layer and flips the element following it.

Flip Scale Y
Remembers the original Y-axis of the layer and flips the element fol-
lowing it.

Lock in Time
Indicates if the point is locked to a specific frame (keyframe) or only 
locked to a specific position and the curve can flow through it freely as 
other points are being added, moved, or adjusted (control point).

Substitute Drawing Previous Replaces the drawing or cell's symbol on the current frame by the pre-
vious or next drawing.Substitute Drawing Next

Go to Previous Keyframe
Go to the previous or next keyframe.

Go to Next Keyframe

Select Child
Lets you select the first element parented to the selected peg element 
in the Timeline view.

Select Children
Lets you select all elements parented to the selected peg element in 
the Timeline view.

Lock

Lock Locks one or a multiple selection of layers. 
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Unlock Unlocks one or a multiple selection of locked layers.

Lock All Locks all the layers in the Timeline view. 

Unlock All Unlocks all the layers in the Timeline view. 

Lock All Others Locks every layer except the selected ones.

Reset

Returns the value of the selected element to the initial value of the 
active tool. For example, if the Rotate  tool is active, the 
transformation angle will be reset to 0 and if the Transform  tool is 
active, all the transformation values will be reset.

Reset All

Resets all transformations on the current frame in a selected layer. 
Your keyframe will remain, but all the values will return to the default 
position. All transformations are reset regardless of the tool you're 
using.

Drawing Menu

The Drawing menu lets you access many tools related to drawing, painting, dirt removal, optimizing strokes, and 
more.

How to access the Drawing menu

‣ At the top of the interface, select Drawing.

Command Description

Drawing Tools

Activates a drawing tool including: 

Select, Contour Editor, Cutter, Smooth Editor, Perspective, 
Envelope, Reposition All Drawings,  Brush, Pencil, Text, Eraser, 
Dropper, Line, Rectangle, Ellipse, Polyline, Paint, Ink, Repaint 
Brush, Close Gap, Stroke, Edit Gradient/Texture, Hand, Zoom and 
Rotate View.

These drawing tools are available on the Tools toolbar.

Convert

Pencil Lines to Brush Strokes
Converts the selected centreline pencil strokes into contour strokes 
brush lines.

Brush Strokes to Pencil Lines
Converts selected contour strokes into centreline pencil strokes. 
The brush stroke thickness will be lost.

Strokes to Pencil Lines Converts the selected invisible line to a pencil line.

Break Apart Text Layers
Text is treated as a single drawing object. This separates the text so 
each character becomes an individual drawing object you can select 
and modify independently.

Optimize

Flatten

Merges drawing objects and brush strokes into a single layer. If you 
draw new lines to fix a drawing or line with many brush strokes, it 
can be useful to flatten them all into a single shape. By default, lines 
are drawn one on top of each other. If you intend to repaint the lines 
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or modify their shape, it will be easier if they are flattened. 

Smooth Smooths selected drawing strokes and removes extra points.

Optimize

Reduces the number of layers, such as overlapping brush strokes, 
in the selected drawing objects. Drawing objects will only be 
flattened and optimized if the selected objects do not change the 
appearance of the final image when they are merged. 

Transform

Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 CW Rotates the current selection 90 degrees clockwise.

Rotate 90 CCW Rotates the current selection 90 degrees counter-clockwise.

Rotate 180 Rotates the current selection 180 degrees.

Arrange

Bring to Front Moves the selected art to the front (on top).

Bring Forward Moves the selected art one level forward (closer to the front).

Send Backward Moves the selected art one level lower (behind).

Send to Back Moves the selected art behind everything (bottom / back).

Create Empty Drawing
Creates a drawing in the selected cell, replacing any drawing that 
may already be exposed in that cell and the following ones until it 
meets another drawing, key exposure or a blank cell. 

Duplicate Drawings

Lets  you duplicate the drawing and work on a copy of it. This lets 
you modify an existing drawing but retain the original. 

When duplicating a drawing, the selected cell is replaced with the 
new drawing. The exposure of the original drawing that was on the 
current cell is removed. The original drawing is not deleted from the 
project folder or other cells in which it is exposed.

Delete Selected Drawings
Permanently removes selected drawings. Once you save your 
project, these drawings cannot be recovered.

Rename Drawing Lets you give a selected drawing a new name.

Select Strokes with Current Colour
Lets you select drawing elements and painted areas with the same 
colour as the currently selected colour in your colour palette.

Previous Drawing Once a cell is selected in the Timeline or Xsheet view, you can 
navigate between the drawings, frames, and layers.

Displays the previous drawing, next drawing, previous layer or next 
layer.

Next Drawing

Previous Layer

Next Layer

Edit Menu

The Edit menu lets you repeat and undo actions, cut/copy/paste selected objects, select and manipulate objects, 
work with symbols, and access the Preferences dialog box.
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How to access the Edit menu

‣ From the top menu, select Edit.

Command Description

Undo
Removes the last change made to your project. Harmony supports 
multiple undo, so you can undo changes you made in the order you 
made them.

Redo
Redoes an operation you have undone. This command is active only 
after you use the Undo command.

Cut
Removes selected objects. You can then paste the object or its prop-
erties to another object.

Copy Copies selected objects and properties.

Paste
Places an object you cut or copied into the location you select in a 
view.

Paste Special

Opens the Paste Special dialog box which lets you determine how 
templates and symbols are imported in the Timeline view. 

There are advanced paste options for drawings, timings, keyframes, 
layers, as well as palettes and symbols.

Paste Special Again Pastes new drawings with the previous Paste Special settings.

Delete Removes selected objects.

Select All
Selects all drawing objects in the current drawing window in the 
Drawing, Timeline and Camera views. This helps you manage 
multiple objects as one when moving them.

Deselect All Deselects all selected objects in the Drawing and Camera views.

Invert Selection

Deselects the currently selected items and selected all other items 
that were not selected. For example, if some lines are selected in a 
drawing, this command will deselect them and select any other lines 
in the drawing that were not selected.

Not clear for me. Missing information: This however unselects the 
currently selected drawing (e.g. unselect current selected lines and 
select everything else that is unselected).

Create Symbol
Creates a symbol from selected drawing elements in the Drawing or 
Camera view or a layer or cells in the Timeline view.

Expand Symbol

Extracts a symbol's contents and places it on the root timeline. Its 
contents will be copied and inserted into the root timeline. The 
symbol will not be removed from the Timeline view once it is 
expanded. 

The symbol's layers will be parented to it in case you created 
motions and transformations on the drawing layer that contain the 
symbol. Breaking the hierarchy could result in the loss of any scaling 
and animation you may have created.

Duplicate Selected Symbol
Creates a duplicate of a selected symbol. If other symbols are nes-
ted inside the new symbol, they are not duplicated. If you modify 
them, the original and other instances will also be modified.
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Clone: Drawings Only
Creates a copy of the drawings in the selected layer in the Timeline 
view or column in the Xsheet view. The timing it not copied.

Clone: Drawings and Timing
Creates a copy of the drawings and their timings in the selected 
layer in the Timeline view or column in the Xsheet view.

Duplicate

Duplicates a layer to have a copy of the drawings that are inde-
pendent from the original ones, as well as an independent timing 
(exposure). When you need the drawings to be modified inde-
pendently, you will want to duplicate the layer instead of cloning it.

Merge
Combines all drawings. Unused columns and layers will be deleted, 
but the original drawing files are still accessible.

Group

Group Groups selected drawing objects in the Camera or Drawing view.

Ungroup
Ungroups a selected group of drawing objects in the Camera or 
Drawing view.

Preferences
Opens the Preferences dialog box where you can set your 
preferences for Harmony.

File Menu

The File menu lets you open, close, save, scan, print, and import and export files.

How to access the File menu

‣ From the top menu, select File.

Command Description

New
Creates a new scene while closing any scene already open. The New 
Scene dialog box opens, asking for directory, name, and resolution 
information.

Open
Displays the Open Scene dialog box where you can browse for a scene 
file.  You can open a new scene from the current one and the previous 
scene will close.

Open Recent Displays a list of the most recently opened scenes.

Clear Clears the list of recently opened scenes.

Close
Closes the currently opened scene, but does not close the Harmony 
application.

Save
Saves all changes made to the opened scene, drawings, palettes, and 
palette lists.

Save As

Saves the current file with a different name and at a different location.

Saves the current state of a scene as another scene. The Save As 
window prompts you for a new name and a different location for this 
scene before saving it. This will create a complete scene directory for 
the new scene.
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NOTE: The scene name cannot exceed 23 characters.

Save as New Version
Saves the current scene as another version. The Save Version dialog 
box prompts you to give a name for this new version. This will create a 
new .xstage file in your current project directory.

Acquire

From TWAIN
Opens the Acquire from Scanner window from which you can set para-
meters before scanning. 

Import

Images
Imports bitmap images which you can choose to vectorize—see Import-
ing Bitmap Images  on page 1.

Movie
Lets you convert a QuickTime movie to an image sequence and audio 
file.

Sound Lets you import sound files into your project.

SWF, Illustrator Files to Library Lets you import SWF files into your project.

Export

Images
Exports a scene as a bitmap image sequence. If there is sound in your 
scene, it will not be exported with the images.

Movie
Exports animation as a QuickTime movie—see Exporting a QuickTime 
Movie on page 1.

SWF

Exports a Flash movie file. 

The SWF export supports some bitmap effects (which can be 
previewed in Render View  mode) and SWF Blend Modes (vector 
effects which can be previewed in OpenGL View  mode).
See Exporting an SWF Movie on page 1.

Quit Closes the application.

Help Menu

The Help menu lets you display the Harmony documentation, Welcome screen and end user license agreement, 
as well as access the Toon Boom website, and identify the product name and version number.

How to access the Help menu

‣ At the top of the interface, select Help.

Command Description

Online Help
Opens the Harmony Help system, complete with instructions on 
how to use the system. This requires an internet connection.

Getting Started
Opens the Harmony Getting Started Guide (in PDF format) in a 
browser window. Requires Acrobat Reader.

Toon Boom on the Web
Opens the Harmony website, which features a Support and 
Community > Forum section.
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Customer Experience Improvement 
Program

The Customer Experience Improvement Program allows Toon 
Boom to collect usage information. The data does not contain any 
personally identifiable information and cannot be used to identify 
you. The data will consist of a basic hardware description, a project 
summary and usage information. The information is used only for 
software improvement purposes, as well as for sharing with third 
parties for the same reason.

This program is enabled by default but is voluntary. If you prefer not 
to participate, you can opt out when you first launch the software, by 
using a global preference, or by a command line argument.

About Identifies the product name and version number. 

Show Welcome Screen Displays the Harmony Welcome screen.

Show End User License Agreement Displays the End User License Agreement.

Command Description

Online Help
Opens the Harmony Help system, complete with instructions on how 
to use the system. This requires an internet connection.

Getting Started
Opens the Harmony Getting Started Guide (in PDF format) in a browser 
window. Requires Acrobat Reader.

Toon Boom on the Web
Opens the Harmony website, which features a Support and 
Community > Forum section.

Customer Experience Improvement 
Program

The Customer Experience Improvement Program allows Toon Boom to 
collect usage information. The data does not contain any personally 
identifiable information and cannot be used to identify you. The data will 
consist of a basic hardware description, a project summary and usage 
information. The information is used only for software improvement 
purposes, as well as for sharing with third parties for the same reason.

This program is enabled by default but is voluntary. If you prefer not to 
participate, you can opt out when you first launch the software, by 
using a global preference, or by a command line argument.

About Identifies the product name and version number. 

Show Welcome Screen Displays the Harmony Welcome screen.

Show End User License Agreement Displays the End User License Agreement.

Insert Menu

The Insert menu lets you create empty symbols in the Library view, different types of layers in the Timeline view, 
keyframes and control points.

How to access the Insert menu

‣ At the top of the interface, select Insert.

Command Description

Create Empty Symbol in Library
Creates an empty symbol in the Library view to which you can edit (add 
content).
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Bone Adds a new Bone layer to the Timeline view.

Camera Adds a new Camera layer to the Timeline view.

Colour-Card Adds a new Colour-Card layer to the Timeline view.

Drawing
Adds a new Drawing layer to the Timeline view and a column in the 
Xsheet view.

Game Bone Adds a new Game Bone layer to the Timeline view.

Kinematic Output Adds dd a new Kinematic Output layer to the Timeline view.

Peg Adds a new Peg layer to the Timeline view.

Quadmap Adds a new Quadmap layer to the Timeline view.

Effects
Adds a new layer in the Timeline view with the effect you select: Blur, 
Brightness-Contrast, Colour-Scale, Cutter, Glow, Shadow, or 
Transparency.

Keyframe Adds a keyframe to the selected cell in the Timeline view.

Keyframe and Duplicate Drawing
Adds a keyframe to the selected drawing layer cell in the Timeline view 
and creates a duplicate of the drawing, which sits on top of the original 
drawing.

Control Point

Adds a control point to the trajectory of the selected element or peg in 
the Camera view when the element or peg is in a 3D path. Note that 
you must have a 3D path in the peg portion in order to add a control 
point.

Play Menu

The Play menu lets you play back animation and sound. Use it to scrub the sound to create your lip-sync, loop the 
playback, navigate through frames, and change the playback range and speed.

How to access the Play menu

‣ At the top of the interface, select Play.

Command Description

Play Plays and stops the animation.

Render and Play
Creates a render of your scene to play back the final result including 
the effects.

Test SWF Movie
Creates a SWF format movie and a report to test your result before 
proceeding to the final movie.

Stop Stops playback.

Playback Speed
Opens the Set New Frame Rate dialog box where you can set the 
frame rate at which the playback plays.

Loop Repeatedly plays back your animation indefinitely.

Enable Sound Turns on sound during playback.

Enable Sound Scrubbing Turns on sound scrubbing during playback.

Start Frame Opens the Set Playback Start Frame dialog box where you can set 
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the frame number on which to start playback.

Stop Frame
Opens the Set Playback Stop Frame dialog box where you can set 
the frame number on which to stop playback.

First Frame Moves the red playhead to the first frame.

Previous Frame Moves the red playhead to the previous frame.

Next Frame Moves the red playhead to the next frame.

Last Frame Moves the red playhead to the last frame.

Go to Frame
Opens the Go to Frame dialog box where you can enter the frame 
number on which the red playhead to be positioned in the Timeline 
view.

Enable Playback

Top View

Plays back your animation in the Top, Side or Perspective views.Side View

Perspective View

Scene Menu

The Scene menu lets you set the scene length, add frames to the scene, view different displays of the scene, set 
render options, access the Scene Settings dialog box and Elements Manager window, and verify the drawing and 
palette files in your project.

How to access the Scene menu

‣ At the top of the interface, select Scene.

Command Description

Scene Length Lets you set the length of the scene in frames.

Frame

Add Frames at Start Adds the number of frames you specify to be added at the beginning or 
end of the scene.Add Frames at End

Add Frames Before Selection
Adds the number of frames you specify before or after your selection.

Add Frames After Selection

Remove Selected Frames Deletes the selected frames from your scene.

Camera

Default Camera
Lets you select a camera. If you only add one camera to your scene, 
you will only see Default Camera in your list.

Scene Settings
Opens the Scene Settings dialog box where you can set the resolution, 
alignment, bitmap resolution and many other parameters.

Render

Auto Render
Automatically recalculates the preview image whenever you modify a 
parameter. If your scene is heavy and you do not want the preview 
rendered automatically, deselect the Auto-Render option and do the pre-
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view update manually.Note that this will slow down Harmony as it 
takes resources to update every frame.

Cancel Preview Render Cancels a render that was started.

View Menu

The View menu lets you manipulate the view by zooming, panning, or rotating. You can also display the grid and 
change its size, use the onion skin feature to help with drawing, and set the preview resolution. 

How to access the View menu

‣ At the top of the interface, select View.

Command Description

Toggle Full Screen

Enlarges the selected view to full screen which is done in three 
stages. 

First, the selected view enlarges to the maximum width or height, 
but keeps the tool views such as Colour or Tool Properties view. 

Second, the view enlarges to full screen. 

Third, the view returns to its original size.

Zoom In Zooms in the view.

Zoom Out Zooms out the view.

Rotate View CW
Rotates the Camera view 30 degrees clockwise, like an animation 
table.

Rotate View CCW
Rotates the Camera view 30 degrees counter-clockwise, like an 
animation table.

Reset Zoom Resets the view’s zoom to its default position.

Reset Rotation Resets the view’s rotation to its default position.

Reset Pan Resets the view’s pan to its default position.

Reset View Resets the view to its default position.

Grid

Show Grid Displays the grid.

Underlay Displays the grid under the drawing elements.

Overlay Displays the grid over the drawing elements.

Square Grid Displays a standard square grid.

12 Field Grid Displays a 12-field size grid.

16 Field Grid Displays a 16-field size grid.

Onion Skin

Show Onion Skin

Lets you preview the previous and next drawings. By default, the pre-
vious drawings appear in a shade of red and the next drawings are 
displayed with a shade of green. You can change these colours in 
the Preferences dialog box. 
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Add to Onion Skin Adds a series of selected elements to the onion skin preview.

Remove from Onion Skin Removes a series of selected elements from the onion skin preview.

Remove Unselected from Onion 
Skin

Removes all elements except the ones selected from the onion skin 
preview.

Add All to Onion Skin Adds all of the scene's elements to the onion skin preview.

Remove All from Onion Skin Removes all of the scene's elements from the onion skin preview. 

Onion Skinning by Drawing
In Camera view, the onion skin by default is per frame, this option 
lets you set it by drawing so you don't see any exposure's onion skin 
from the same drawing.

Reduce One Previous Drawing Reduces the number of previous visible drawings by one.

Add One Previous Drawing Adds one drawing to the number of previous visible drawings.

Reduce One Next Drawing Reduces the number of next visible drawings by one.

Add One Next Drawing Adds one drawing to the number of next visible drawings.

Light Table
Turns on the light table so you can see the previous and subsequent 
active layers in washed-out colours. It is useful for seeing the other 
layers when designing, animating or cleaning up your animation. 

Show

Safe Area
Displays the TV safety zone and the centre of the camera frame. 
The safe area adapts to the scene resolution, as well as the safety 
zone and frame’s centre.

Camera Mask

Displays a black mask around the scene’s frame to avoid seeing the 
unnecessary artwork. This option is handy when you're animating 
and setting up the scene. It allows you to see your scene’s com-
position better.

Control Displays the controls of the selected element.

Current Drawing on Top

Displays the selected drawing on top of everything while you draw. 
By enabling this option, each time you select a drawing tool, the 
selected drawing is displayed in front of everything in the Camera 
view. The Timeline view ordering remain unchanged. 

You only need to enable this option once, it is not necessary to do it 
each time you select a drawing tool.

Show Strokes
Displays the strokes in your drawings so that the invisible lines 
stand out.

Hide All Controls Hides the controls of the selected element.

Preview Resolution

Same as Scene Resolution

Lets you choose a resolution for previewing a scene.

3/4 of Scene Resolution

1/2 of Scene Resolution

1/3 of Scene Resolution

1/4 of Scene Resolution

Custom Lets you select a resolution from a list of presets or enter X and Y val-
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ues for a  custom preview resolution.

Bitmap File Quality
Lets you change the quality of the preview of the bitmap file in the 
Camera view. It will not affect the final render.

Windows Menu

The Windows menu lets you customize your workspace to suit your working style, save it as a new workspace, 
and load it from the Workspace toolbar. You can also show or hide the different toolbars and views in Harmony.

How to access the Windows menu

‣ From the top menu, select Windows.

Command Description

Restore Default Workspace
Returns modified workspaces to their original default layout if you do 
not like the current modifications or inadvertently closed some 
windows.

Workspace

Workspace Manager
Opens the Workspace Manager where you can modify, create, 
delete, rename and reorder your workspaces.

Workspace
Lets you open workspaces designed specifically for animating, com-
positing, hand drawing, scripting and the default workspace.

Toolbars
Lets you show or hide these toolbars: Playback, File, Edit, 
Advanced Animation, Scripting, Tools,  Workspace, Deformation, 
Xsheet View and Timeline View—see  Toolbars on page 1.

Camera Shows or hides the Camera view.

Colour Shows or hides the Colour view.

Drawing Shows or hides the  Drawing view.

Function Shows or hides the Function view.

Layer Properties Shows or hides the Layer Properties view.

Library Shows or hides the Library view.

Message Log Shows or hides the Message Log view.

Side Shows or hides the Side view.

Timeline Shows or hides the Timeline view.

Tool Properties Shows or hides the Tool Properties view.

Top Shows or hides the  Top view.

Xsheet Shows or hides the Xsheet view.

Script Editor Shows or hides the Script Editor view.

Quick-access Menus
A quick-access menu lets you open a list of the commands you will use most often.
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 How to access a quick-access menu

 1. Right-click anywhere in a view.

View Menus
A view menu contains commands specifically related to that view.

How to access a  view menu 

In the top-left corner of a view, click the Menu  button.

Colour Menu

The Colour  menu lets you access commands related to the Colour view such as creating new palettes, adding new 
colour swatches, and displaying the Tint panel.

How to access the Colour menu

‣ In the upper-left corner of the Colour view, click the menu button.

Command Description

Palettes

New

Creates a new colour palette.

By default, Toon Boom Harmony is set to the Basic mode. For simple 
productions, it is recommended to use the Basic mode.  This setting stores the 
palettes automatically for you and saves them at the Scene level. When you use 
the Advanced Palette Lists mode, you can decide at which level you want to store 
your palettes: Environment, Job, Scene, or Element.

Link
Lets you access other palettes created in the project and link them to your scene—
see Importing and Linking Palettes on page 1.

Import Imports a colour palette located on your hard drive.

Remove Deletes the selected colour palette.

Rename Lets you five the selected colour palette a new name.

Duplicate
Creates a copy of the original palette, using the same names and colour values, 
but has a different ID and is independent from the original palette. This ensures 
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that both the duplicate and original palettes are completely independent.

Clone
Creates a copy of the master palette. The colours in each palette have the same 
properties. The colours have the same identification number pointing to the same 
colour zones, but they can have different names and RGBA values.

Pencil Texture Palette

Move Up Moves the selected colour palette up one level.

Move Down Moves the selected colour palette down one level.

Colour Editor Opens the Colour Editor where you can 

Tint Panel
Opens the Tint panel where you can modify a series of colours to blend a tint in 
them or offset their RGBA values. 

Current Palette 
Overrides

Display Colour Values Display the colour values beside their colour swatches in the palette list.

Colours

Cut Cuts the selected colour swatch from the palette.

Copy Copies the selected colour swatch which you can paste in a different palette.

Copy Colour ID
Copies a colour swatch's colour ID so you can keep a reference file of colour IDs 
or use them with custom plug-ins. Example of a colour ID: 075cf5b552401130.

Paste Colour Values Pastes the colour value of the copied swatch over an existing colour swatch.

Paste As New Colours Creates a new colour swatch from the colour value of the copied swatch.

Paste As Clones

New Creates a new colour swatch from the colour swatch that was last selected.

Edit
Opens the Colour Picker window in which you can edit the selected colour 
swatch.

Delete Deletes the selected colour swatch from the palette.

New Texture
Lets you add a bitmap colour swatch to your palette. You can load photos and 
textures and paint your drawings with it. The bitmap image must be a .tga or .psd 
file format.

Edit Texture

Scale Down Texture Lets you set a new maximum texture size or scaling factor.

New Default Colour

Protect Colour
Locks a selected colour, so if you ever paint over it accidentally, the work already 
done will not be affected. You can also block the filling colours if you painted all of 
the animation in Line Art and plan to repaint the lines.

Swatch Mode
Displays the colour swatches with its corresponding name inside the swatch. 
When this option is not selected, the names of the colour swatches are displayed 
beside the swatch.

Independent Bitmap 
Colour

Bitmap Colour Sliders
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RGB

HSV

Function Menu

The Functions menu lets you do many things in the Camera view, including selecting and editing objects in different 
views, changing the display, setting morphing parameters, accessing tools and many more.

How to access the Function menu

‣ In the upper-left corner of the Function view, click the menu button.

Command Description

Edit

Cut
Removes selected objects. You can then paste the object or its properties to 
another object.

Copy Copies selected objects and properties.

Paste Places an object you cut or copied into the location you select in a view.

Delete Removes selected objects.

Select Next Keyframe Selects the next keyframe.

Select Previous 
Keyframe

Selects the previous keyframe.

Select Left Handle Selects the left handle of the selected keyframe.

Select Right Handle Selects the right handle of the selected keyframe.

Select All
Selects all objects in the Function view. This helps you manage multiple objects 
as one.

Deselect All Deselects all selected objects in the Function view.

View

Show Current Frame Displays the current frame 

Toggle Grid Enables the display of the grid.

Reset Zoom Resets the view’s zoom to its default position.

Reset Pan Resets the view’s pan to its default position.

Reset View Resets the view to its default position.

Function List

Auto Load Selection

Clear

Load Selection

Add Selection

Remove Selection

Show Show Motion: 
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Show Rotation: 

Show Scale: 

Show Skew: 

Show Other: 

Library Menu

The Library menu lets you access commands specific to the Library view, such as opening a Library or getting the 
rights to modify a library folder.

How to access the Library menu

‣ In the upper-left corner of the Library view, click the menu button.

Command Description

View

List Displays the contents of the selected folder as a list.

Thumbnails Displays the contents of the selected folder as a thumbnails.

Details Displays the details of the selected file.

Generate Thumbnails Creates a thumbnail to display in the preview window.

Edit

New Symbol

Creates a new symbol from a drawing or part of a drawing in the 
Drawing or Camera view, or a layer in the Timeline view. 

If your selection is in the Timeline , the new symbol appears in the  Symbol 
folder. The current selection is not replaced by the new symbol. The new 
symbol only appears in the library. You must drag it into your scene to use it.

If your selection is in the Drawing or Camera view, the new symbol appears in 
the Symbol folder and in the Timeline view as a new layer.

Cut Cuts the selected file in the Library view.

Copy Copies the selected file in the Library view.

Paste Pastes the selected file in the Library view.

Delete Deletes the selected file in the Library view.

Delete Thumbnails Deletes any thumbnails that were generated for display in the preview window.

Edit Symbol

Places you inside the symbol where you can edit it. 

To return to the project's timeline, click the Top  button in the Camera 
view's top-left corner, press  Ctrl + Shift + E (Windows/Linux) or ⌘  + Shift + E 
(Mac OS X). 

Remove Unused Files Removes any files not in use in the 

Rename Template Lets you rename a selected template.

Import Files Opens the 
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Folders

New Folder
Creates a new folder in the Library view. Before you can create a new folder, 
you must have the right to modify the folder in which you are creating the new 
folder.

Refresh Updates the view and its contents.

Open Library Lets you open a library on your computer.

Close Library
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Chapter 4: Toolbars
Harmony contains toolbars which, by default, are located at the top of the interface. Some views also have a toolbar 
which you can reposition to suit your work style. You can show or hide toolbars, as well as customize it with the 
tools you use most often and hide the ones you don't.

Main Toolbars

View Toolbars
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Chapter 5: Views
Intro...

Layer Properties
The Layer Properties editor or view lets you adjust the properties of a layer in the Timeline view The Layer Properties 
can be viewed as a floating window or as a view (docked).

Each layer has its own set of properties that can be modified, including effect and peg layers. Display the Layer 
Properties editor or view if you want to modify some of the layer’s properties, such as the name or the antialiasing 
quality. 

How to access the Layer Properties editor

‣ Double-click on a layer in the Timeline view

‣ Right-click on a layer in the Timeline view and select Layer Properties.

‣ Select a layer in the Timeline view and press Shift + E.

How to access the  Layer Properties view

 1. Do one of the following:

‣ Select the view you want to add from Windows > Layer Properties.

‣ In the top-right corner of a view, click the Add View  button and select Layer Properties from the list.

By default, the Layer Properties view appears as a tab.
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Transformation Tab

The Transformation tab contains parameters for adjusting the position, scale, rotation, skew and pivots of an 
element.

Parameter Description

Position

3D Path: Lets you use a 3D path function to animate an element.

Separate: Lets you independently edit the different coordinate fields.

Path (x) Axis: Lets you type in a new East/West coordinate corresponding to 
the desired position.

Path (y) Axis: Lets you type in a new North/South coordinate corresponding to 
the desired position.

Path (z) Axis: Lets you ype in a new Forward/Backward coordinate 
corresponding to the desired position.
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Velocity: When the 3D Path option is selected, lets you set the speed at which 

Scale

Locked: Resizes the element while keeping its ratio. The X and Y axes scale 
proportionally

Separate: Resizes the element allowing to modify the ratio (squash and 
stretch).

(x) Axis: Lets you type in the horizontal scale value.

(y) Axis: Lets you type in the vertical scale value.

Rotation
Angle z: Lets you  type in a degree value for the rotation angle. Note that you 
can enter values greater than 360 and -360 degrees. If you enter 720, the object 
will rotate twice.

Skew Skew: Lets you type in a degree value between -90 to 90 for the skew angle.

Pivot

(x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

(y) Axis: Lets you ype in a new North/South coordinate corresponding to the 
desired position.
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Chapter 6: Windows
Intro...

Export to Easel JS
The Export to Easel JS window lets you a flattened image sequence of your animation. Even if you have a fully 
rigged puppet or a single drawing layer with your animation sequence, the outcome will still be a flattened output of 
each frame, grouped together in your sprite sheet. This allows for more flexibility and freedom of work as you have 
access to any tools or effect modules you want to use. However, this can result in heavier files depending on the 
length, complexity and export size of your animation.

How to access the Export to Easel JS window

 1. From the top menu, select Windows > Toolbars > Game.

The Game toolbar appears above the Camera view, to the left.
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 2. Click the Export to Easel JS  button.

Parameter Description

Select Directory

Save Path The folder path where you want to save your export.

Save Name
The folder name in which you will save your export. This will also be the name 
of your asset in Unity. Your scene file name will be used as the clip name.

Existing Clips in Folder Displays the clips in the folder.

Scene Options

Display

Here, you must select the Display of your character. This is the one that will be 
used to render out all of the information attached to that Display node. If the 
Unconnected_Display option is selected, all of the visual information in your 
scene will be rendered out.

Sprite Sheet Preferences

Max Width This is a value, in pixels, for the maximum width and height the exported sprite 
sheet should be. By default, both values are set to 2048 pixels.Max Height

Expand Sprite Sheet Uses the minimum size necessary up until it reaches the maximum resolution.

Fixed Sprite Sheet
Creates a texture of the specified size (Max Width and Max Height) even if it 
does not fill it up completely by all the drawings in your scene.

Resolution Type

POT: Exports to sprite sheets with sizes that are a power of 2. For example: 
1024 x 1024.  This is optimized for many graphics cards, but consumes more 
memory.

NPOT: Some game engines are optimized specifically to render to non powers 
of two, so that it will avoid those numbers.  Example: 1000 x 1000.

Reuse Frames

This option works in tandem with the Threshold option. The export will 
compare the drawings in your project to reuse a maximum of similar drawings 
and reduce the amount of information found in the sprite sheet, making it 
lighter. The export will omit the creation of new drawings if the difference is 
less than the threshold percentage.

Threshold

Calculates the differences between multiple drawings. A 2% threshold will 
prevent the creation of a new drawing if the drawing is too similar to an existing 
drawing. For instance, with a 2% threshold, and my drawing is 100 pixels big, 
only 2 of those pixels need to be different from my other drawing in order to 
create a new one. The higher the threshold, the fewer similar drawings you will 
have.

Sprite Resolutions Size of the render of the individual sprite, when it exports each drawing out.
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Export to Sprite Sheets
The Export to Sprite Sheets window export to multiple resolutions, generating multiple .xml files and one or multiple 
sprites sheets depending how many sprite resolutions you defined.

This saves different animations of the same character into the same name. For example, if there's an idle, run, and 
jump animation, these should all share the same Save Name. You can think of it as the overall collection of 
animations. Inside are the different saved scene versions whose drawings you can reuse for all the animations in 
that character set. Each scene version will be displayed as an item in the list.

When you export an animation, only the drawings used in that scene are exported. All the drawings are exported 
individually first and then atlased together into a sprite sheet.

If you saved multiple animations to the same Save Name (i.e. SpaceDuck: run, idle), then it will reatlas the sprite 
sheet to include all the drawings from all the animations in that folder, creating a new animation file, but reusing the 
same skeleton.
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How to access the Export to Sprite Sheets window

 1. From the top menu, select Windows > Toolbars > Game.

The Game toolbar appears above the Camera view, to the left.

 2. Click the Export to Sprite Sheets  button.

Parameter Description

Select Directory

Save Path The folder path where you want to save your export.

Save Name
The folder name in which you will save your export. This will also be the name 
of your asset in Unity. Your scene file name will be used as the clip name.

Existing Clips in Folder

Overwrite Project
The folder name in which you will save your export. This will also be the name 
of your asset in Unity. Your scene file name will be used as the clip name.

Clear Texture Folder
Removes any information from the texture folder within the Harmony file. This 
has no incidence towards the Unity export but contributes to a lighter Harmony 
file.

Project Settings

Unit Scale

Lets you change the scale when exporting to Unity to accommodate the size of 
the export without it affecting the Harmony scene. This helps you resize 
assets properly for Unity without having to resize them in Harmony. The basic 
scale is one Animation Field for one Unity unit.

Sprite Sheet Preferences

Max Width
This is a value, in pixels, for the maximum width and height the exported sprite 
sheet should be. By default, both values are set to 2048 pixels.

Max Height
Makes linear values for interpolation. This increases the amount of memory 
used but frees up the calculation so it is not done on the fly.

Expand Sprite Sheet Uses the minimum size necessary up until it reaches the maximum resolution.

Fixed Sprite Sheet
Creates a texture of the specified size (Max Width and Max Height) even if it 
does not fill it up completely by all the drawings in your scene.

Resolution Type

POT: Exports to sprite sheets with sizes that are a power of 2. For example: 
1024 x 1024.  This is optimized for many graphics cards, but consumes more 
memory.

NPOT: Some game engines are optimized specifically to render to non powers 
of two, so that it will avoid those numbers.  Example: 1000 x 1000.
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Reuse Frames

This option works in tandem with the Threshold option. The export will 
compare the drawings in your project to reuse a maximum of similar drawings 
and reduce the amount of information found in the sprite sheet, making it 
lighter. The export will omit the creation of new drawings if the difference is 
less than the threshold percentage.

Threshold

Calculates the differences between multiple drawings. A 2% threshold will 
prevent the creation of a new drawing if the drawing is too similar to an existing 
drawing. For instance, with a 2% threshold, and my drawing is 100 pixels big, 
only 2 of those pixels need to be different from my other drawing in order to 
create a new one. The higher the threshold, the fewer similar drawings you will 
have.

Sprite Resolutions Size of the render of the individual sprite, when it exports each drawing out.

Precalculate Curves
Makes linear values for interpolation. This increases the amount of memory 
used but frees up the calculation so it is not done on the fly.
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