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Chapter 1: Traditional Animation - An Introduction
Harmony is a high-performance animation software which not only offers a wide range of features, but also handles 
more than one animation type and workflow. In this guide, you will learn how to perform tasks related to the 
traditional animation workflow from start to finish using Harmony.

Before reading this guide, be sure to take some time to familiarize yourself with the basic concepts in the 
Fundamentals Guide. Each chapter is self-contained. so you can concentrate only on the chapter pertaining to your 
task. You do not need to read the entire guide, but you should read the whole chapter before starting to work.

Topics in this section:

• Scanning on page 7

• Timing on page 29

• Colour Styling on page 75

• Ink and Paint on page 111
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Chapter 2: Scanning

Once your traditional animation sequences are completed and cleaned up, you're ready to scan and import them in 
Harmony. The scanning process is the point where the traditional production becomes digital. It's the moment where 
you use Harmony to control the project.

This chapter is divided as follows:

• The Scanning Process on page 1

• Scanning and Importing Drawings on page 8

• Creating Custom Vectorization Parameters  on page 15

The Scanning Process
There are three steps in the scanning process which Harmony handles automatically: 

• Vectorization

• Line art and colour art creation

• Optical registration

You can choose the following vectorization styles, which are set at the vectorization step:

• Solid lines 

• Texture lines
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This retains the texture from the original drawing and applies it to the vectorized drawing as a bitmap filling 
zone.

Harmony can receive images from any TWAIN device, such as  scanners or digital cameras. You can load these 
images as bitmaps into your scene or convert them into vector-based images that can be edited using Harmony.

You must install a TWAIN driver for your device in order to access its contents. Refer to the manufacturer of your 
device to get a TWAIN driver. Once all the animation layers are scanned in, you can set the timing in the digital 
exposure sheet.

Scanning and Importing Drawings
Once your scene length is set, you can start scanning drawings and importing them into Harmony in one of the 
following ways:

A bitmap image is an image composed of pixels that are both size and resolution dependent. In Harmony, you can 
scan an image as a bitmap drawing.

You can turn bitmap images into vector drawings, while maintaining the sketchiness of a pencil line or into vector 
images with a bitmap fill. Both options can add life to an animation, which straight vectorization with smoothing 
does not usually afford.

How to scan images as bitmap drawings

 1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens.
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 2. Select your scanner from the Scanner list.

 3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing layer. 

‣ Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter Description

Create Single Layer Named Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For example, the 
filenames a-1.tga, a-2.tga and b-1.tga will create layers named "a" and 
"b", where "a" has two drawings and "b" has one. When creating a 
single layer from these three filenames, all three drawings will be inser-
ted in the new layers.

‣ Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer 
list. You must scan into the same layer type if you're using an existing layer.
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‣ Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap 
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol 
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.

 4. In the Import Options section, select one of the following:

‣ Keep As Bitmap: Retains the imported image as a bitmap. In the Alignment section, decide on the 
size and placement of your image within the camera frame. Depending on the Scene Settings (the 
height and width in pixels that you chose for your project), an image that you import may get scaled to 
the point where all its individual pixels become visible. There are three options available in the 
Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to match the full height 
of the scene grid.

If the image orientation is landscape, this will enlarge or shrink (but not distort) 
the image width to match that of the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in the layer 
properties.

Pan This is the opposite of the Fit parameter. If the image orientation is portrait, its 
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width will be made to match the width of the scene grid. As a result, part of the 
image’s height will extend beyond the height of the frame. This can be useful if 
you want to make your background move up and down, or from left to right to 
make it appear as if the camera is panning or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will be fit to the scene 
grid, therefore it is possible that the image will extend beyond the scene grid's 
boundaries.

Note that the Pan alignment rule equals the Center First Page rule in the layer 
properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The system looks at 
the resolution of the bitmap image, for example 4000 x 2000, then compares it 
to the scene's resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would appear at 208% 
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50% 
(960/1920) of the size of the project resolution.
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Note that the Project Resolution alignment rule is equal to the As Is rule in the 
layer properties.

‣ Import As Bitmap Drawing: Imports a bitmap drawing into a vector layer where you can edit the image 
using the drawing tools. In the Alignment section, select one of the following:

Parameter Description

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match the full 
height of the scene frame (alignment grid).

Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match the full width 
of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system looks at 
the resolution of the bitmap image, for example 4000 x 2000, then compares it 
to the scene's resolution, for example 1920 x 1080, and adjusts the scale 
factor in proportion. So, in this example, the bitmap would appear at 208% 
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50% 
(960/1920) of the size of the project resolution.

 5. In the Drawing Options section, set the following options if desired:
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‣ Drawing Name: Name of the drawing to import.

‣ Hold Value: Type the number of frames that the drawing will be exposed.

‣ Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣ Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 6. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

 7. Click Scan to scan your drawing.

 8. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to cap-
ture your next frame.

 9. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have 
finished scanning all your drawings.

How to import and vectorize bitmap drawings

 1. From the top menu, select File > Acquire from TWAIN or press Ctrl + Shift + S (Windows/Linux) or ⌘  + 
Shift + S (Mac OS X).

The Acquire from scanner window opens.
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 2. Select your scanner from the Scanner list.

 3. Click Preview to get a test scan of your drawing.

 4. In the Layer section, select one of the following:

‣ Create Layer: Imports an image into a new layer. Type a name for the layer in the Name field. 

‣ Add to Existing Layer: Imports the image into an existing layer. Select a layer from the Layer list.

 5. In the Vectorization section, select the Vectorize Image option and then set the following:

‣ Colour: Creates a vector rectange with the bitmap as a texture inside.

‣ Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing. 
Set the Threshold and Smooth parameters.

Threshold: Determines which black, white or grey pixels become a black line. 0% means all the light 
pixels will be kept as black vector line. A value of 100% means only the very dark pixels become a 
black line.

Smooth: Determines the smoothness of lines. The higher the value, the less angular and bumpt the 
resulting lines will be.

Auto Apply: Automatically applies the colour or black and white settings to the scanned images.
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 6. Adjust the Scale control and the sliders in the Preview Image window until you're satisfied with the view.

 7. Click Scan to import your drawing.

 8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have 
finished scanning all your drawings.

Creating Custom Vectorization Parameters 
You can create your own vectorization settings with Harmony. The vectorization parameters you create can be 
saved, shared and also inserted into the VectOptions.conf file used by the Scan and Control Center modules 
when scanning or vectorizing a series of drawings.

You can use an interface to select and test the different options, as well as type in some advanced settings.

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green pencil 
marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure red, blue, 
green and black (RGB values), while creating colour art zones wherever lines connect. After painting in your tones 
and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker window and watch the 
indicator colour zone lines disappear.

How to open the Vectorization Parameters dialog box

 1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization parameters 
(i.e. from the scanner).

 2. In the Scan Drawings window, do the following:

‣ In the Layer section, decide on the layer options.

‣ In the Import Options section, select the Convert to Toon Boom Vector Drawing option

‣ Click Preview.

 3. In the Vectorization section, click the Vectorization Parameters button.

The Vectorization Parameters dialog box opens.
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• Options Tab  on page 16

• Help Tab on page 18

Options Tab 

The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter Description
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Input

The input filters are applied to the bitmap image before it is vectorized.

One Pass: One threshold value is applied to both the Line and Colour Art. For 
drawings with distinct vector-style lines of mattes, you only need one pass.

Two Passes: Applies a different threshold value to each layer. For greyscale 
drawings, you may want to perform the vectorization process twice to apply dif-
ferent threshold values to the Line and Colour Art layers.

Threshold: Determines which values in the scanned image are considered 
part of the Line or Colour Art layer and what will be eliminated from the 
vectorized drawing; 0% is white and 100% is black. The threshold is between 
these two values.

Expand Bitmap: Lets you enter a value to scale the bitmap to detect small 
variations in the line. Use this option if you scanned a greyscale image and 
want to preserve small variations in the texture to apply to the line art.

Jag Filter: Lets you enter a value to scale back the bitmap to remove some of 
the line’s roughness. This is useless when you have a drawing that appears 
quite rough; the Jag filter will eliminate excess strokes in the final drawing.

Output

The output filters are applied during the vectorization process.

No Colour Art: Does not generate filling zones in the Colour Art layer.

No Texture: Does not generate texture in the Line Art layer in the final images. 
Select this option to create solid lines in the final line art.

Generate Matte in Underlay Layer: Creates an opaque zone behind your 
drawing’s lines to avoid seeing through the layers.

Colour as Texture: Converts colour values into a texture layer.

Optical Registration

The optical registration options are used to automatically align drawings based 
on the position of the peg holes on the animation paper. The peg holes must 
appear in the scanned drawings for the optical registration to work.

DPI: Lets you enter the dots-per-inch value of your image. You must enter the 
same value as the DPI used to scan the image.

Peg Side: Lets you select the position of the peg holes on your drawings. 
Identify whether they are on the top, bottom, left or right.

Strictness: Determines how exact the location of the peg holes must be for the 
software to recognize them. There are two values to choose from:

• Strict: The peg holes must be in a tightly defined area to be recognized.

• Loose: The peg holes can be recognized somewhere in a larger area. 
This is the recommended setting.

Field Chart: Lets you indicate the size of the animation paper, 12 or 16.
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Post Processing

The Post Processing filters are applied to the final vector images.

Remove Holes: Removes holes of a specified value that might make painting 
difficult.

Remove Dirt: Removes stray marks and dirt of a specified value. Try a value 
around 500.

Remove Hair Size: Removes small strokes that have no line art.

Remove Hair: Number of Passes: The number of times the drawing will be 
analyzed to identify hair marks.

Miscellaneous

Close Gaps: Closes gaps in the Colour Art so you can paint it.

Smooth Passes for Line Art Before Breaking Triangles: The number of 
times the smoothing operation runs before creating the triangles that break 
lines in the drawing. If unnecessary triangles are appearing in the drawing, 
increase this value.

Smooth Passes for Line Art: The number of times the smoothing operation is 
performed after the triangles have been created. This further smooths the line 
art.

Preview
Show Strokes: Shows the strokes in the Vectorized Image panel.

Stroke Thickness: Shows the size of the strokes.

Help Tab

The Help tab contains the most advanced vectorization settings which you type in the Advanced Option fields at 
the bottom of the Vectorization Parameters dialog box.

File IO Options 

-file <filename (including extension)> [ options ]

-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode
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-noforce; don't force output if image is inconsistent

-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options 

-register <dpi side strictness>; perform optical registration.

• Side can be one of left, right, top, bottom or l, r, t, b.

• Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page

-rcph; short form of register_center_peg_holes

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)

-rlf; short form of registration_looseness_factor

-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg bars

-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0

-rmargin <inch (default 1)>; region size where to look for peg bars 

-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image 

-pdfc; short form of -peg_distance_from_center 

-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

• Can be one of right, left, top, bottom (or r, l, t, b) or same.

• A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options 

-pixel <pixel_shape (default '4x3')>; Valid values: 4x3

-gap <worldUnits (default 10)>; close gaps up to this big

-pencil; generate line art only

-keep_dirt; don't filter out dirt

-thresh <threshold (default 0.2)>; range 0.0 to 1.0

-rmv_hairs <worldUnits (default 1)> <passes (default 1)> 

• remove hairs of size smaller than "size" in "passes" passes 

-rmv_holes <area (default 7)>; remove holes smaller than "area" 
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-rmv_dirt <area (default 1)>; remove dirt smaller than "area" 

• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels" 

• distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes

-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour

-noclosegap; disable all gap closing algorithms

-no_break; disable the breaking of line art

-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap

-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap

-fit_errorc <error (default 1.000000>; fitting error for the colour art

-fit_errorl <error (default 1.000000>; fitting error for the line art

-smoothl <passes (default 1>; number of smooth passes for line art

-smoothc <passes (default 1>; number of smooth passes for colour art

-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -2pass)

-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"

(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,

-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0

-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0

-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-rmv_holesl <area (default 7)>; remove line art holes smaller than "area" 

-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area" 

-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area" 

-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area" 

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are in 
world units squared 

-margins <inch (default 0.25)>; remove margin around bitmap 

-top_margin <inch (default 0.25)>; remove margin at top of bitmap 
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-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap 

-left_margin <inch (default 0.25)>; remove margin at left of bitmap 

-right_margin <inch (default 0.25)>; remove margin at right of bitmap 

-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size

-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art

-downscale_input <default 1>; downscale the raw input by this integer factor

-downscale_texture <default 1>; downscale the output texture by this integer factor

-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

Note: -buildmatte and -buildmatte_colourart are mutually exclusive

-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information 

-pixel_margins <inch (default 0)>; remove margin around bitmap 

-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap 

-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap 

-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap 

-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap 

-dpi <(default -1)>; dpi information of input bitmap 

RGB Keying Options 

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value

-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

-flatten; flatten the drawing after generating colours

-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area

-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb

-threshrgb <value> <threshold for rgb vectorization default 0.200000>;
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-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on saturation 
and value to consider a pixel to be grey

Colour Vectorization Options 

-color_vectorize; perform a colour vectorization

-file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect (0.0-1.0)> 
<edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap file (valid filename or "" if 
no file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max variation 
(0.0-1.0)>; specify a pressure strategy for the centre line. 

-blur_radius <pixels (default 0)>; blur the penstyle texture generated

-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour before 
computing texture

-ccsp <times (default 3)>; short for -color_contour_smooth_passes

-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing texture

-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)

-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only 

-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles

-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness (must be >= 
1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness (must be 
>= 1.0)

-uniform_gap; the space between bubbles is constant 

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:

rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value    ; between [0.0-1.0] or [0-255]

grey:value    ; between [0.0-1.0] or [0-255]

white:value   ; between [0.0-1.0] or [0-255]

dirt:value    ; dirt area. 200 is a good value

rt:value      ; between [0.0-1.0] or [0-255]

gt:value      ; between [0.0-1.0] or [0-255]
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bt:value      ; between [0.0-1.0] or [0-255]

NOTE: 
There must be no space between the colon and the key/value. For example: -4colours rgbdiff:20 dark:20 grey:120 
white:250 dirt:200 rt:240 gt:240 bt:240

Creating a Vectorization Style 

With Harmony, you can create custom vectorization parameters that can be saved, reused, shared, or used to set 
the Scan module vectorization style list.

You can vectorize drawings using one of the following methods:

• Black and White: All the lines become vector based and 100% black. The white areas become completely 
transparent.

• Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image contained inside 
a vector frame. The white areas become completely transparent.

• Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black lines and turn 
them into 100% vector lines, preserving their original colours—see Creating Custom Vectorization 
Parameters  on page 15.

How to create or modify the vectorization parameters

 1. Set the different options available in the Vectorization Parameters dialog box.
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 2. Click the Vectorize  button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the Import 
Images dialog box. There are many options to try in the Vectorization Parameters dialog box. These are 
applied during the vectorization process.

 3. To set advanced parameters, read the information on the Help tab, then type in the Advanced Options field 
at the bottom of the dialog box.

 4. To save your vectorization parameters to reuse them later, share them, or use them to set the Scan mod-
ule vectorization style list, click  Save.

 5. In the Browser window, name and save the file.

 6. To save the current settings as your default settings, click Save As Default. To restore the default set-
tings, click Restore Defaults.

 7. To load a vectorization style, click Load and locate the existing *.vof file.

 8. Click OK.

Setting the VectOptions.conf File

Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style when batch 
vectorizing a series of drawings. A series of default styles is available in this file, but you will certainly want to 
create your own to fit your production style.

How to set the VectOptions.conf file on Windows or Mac OS X

 1. Open the vectOptions.conf file:

‣ Windows: Select Programs / All Programs > Harmony 12.2 > Tools > Configuration Editor.

‣ Mac OS X: Select Applications > Harmony 12.2 > Tools > Configuration Editor.

The Configuration Editor window opens.
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 2. In the bottom section of the window, select the VectOptions.conf tab.

 3. Scroll down the VectOptions.conf file to see all the different options available for creating your custom vec-
torization style. These options are the same as in the Vectorization Parameters dialog box. It is recom-
mended that you create your vectorization style using Harmony and the Vectorization Parameters window 
and copy the result parameters in this file—see Creating a Vectorization Style  on page 1.

 4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new ones to 
the list using the parameters you got using the Vectorization Parameters window. Notice that some of the 
lines have a “#” sign at the beginning to indicate that the line is a comment and will not appear in the style list. 
The lines that have no sign at the beginning appear in the style list.

 5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black Lines.

 6. Under the style name line, type the following: 

options:
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 7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization Para-
meters window.

‣ To open the *.vof file, use any plain text editor application.

 8. In the Configuration Editor’s top menu, select File > Save.

 9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify that the 
new style appears in the Vectorization Style list under Edit > Vectorization Style.  

NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize 
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the vi text editor

 1. Open a Terminal window:
Menu: Applications > System Tools > Terminal
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 2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_12.2/etc

 3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to step 5. 

$ sudo vi VectOptions.conf

 4. Enter the root password.

 5. Open the VectOptions.conf file:

$ vi VectOptions.conf

 6. To start editing, press I to enter Insert mode.

 7. When you're finished editing the file, press Esc to exit Insert mode.

 8. To save the changes made to the file, type the following and press Enter/Return:

$ :w!

 9. To exit the vi editor and return to the Terminal, type the following and press Enter/Return:

$ :q

 10. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize 
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the gedit text editor

 1. Open a Terminal window:
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Menu: Applications > System Tools > Terminal

 2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_12.2/etc

 3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to step 5.

$ sudo gedit VectOptions.conf

 4. Enter the root password.

 5. Open the VectorOptions.conf file:

$ gedit VectOptions.conf

 6. Edit the parameters of the VectOptions.conf file as you would do in most text editor applications.

 7. Select File > Save.

 8. Select File > Quit.

 9. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the 
new style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize 
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.
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Chapter 3: Timing

When you create hand-drawn animation traditionally or in a paperless environment, it's important to know how to set 
and modify the timing of your drawings. 

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper exposure sheet 
created by the animator. In a paperless workflow, the animator creates and manages their own exposure sheet 
directly in Harmony without the need for reproduction.

If you're more of a traditional animator, you will probably work with an exposure sheet. If you're a digital animator, 
you may prefer to work with a timeline to visualize your timing. Harmony offers both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-drawn 
animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as layers.

You can adjust timing in both views; your choice depends on which technique you're accustomed to using. 
Depending on your working style, some actions may seem preferable to do in one view instead of another. Many of 
the actions you perform in the Xsheet can also be accomplished in the Timeline. This chapter will often show both 
techniques. You can choose which one you prefer.

In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and animation paths 
for symbols are covered in separate chapters.

NOTE: The exposure sheet is not mandatory for cut-out animation. It can be useful for creating characters and parts, 
but is not really needed for animation and timing. If you plan to work with cut-out animation, you can still learn useful 
tips by reviewing the section on exposure sheets.

The basic digital exposure sheet process is divided into the following steps:

Preparation
The digital exposure task is quite simple. There are very few things to prepare in order to get ready.

Opening the Scene

The scene is generally created during a previous step, such as scanning (in a traditional animation workflow), scene 
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set up, digital layout, or production organization.

Using the Workspace

The person creating the exposure sheet will need only the Xsheet view to create the digital exposure sheet, 
although the Timeline view may also be helpful. If you're doing paperless animation, use the Camera or Drawing 
view if you want to sketch at the same time.

If you work with this layout often, you can use the Workspace Manager to save it as a workspace,and name it 
Xsheet, for example.

While drawing and animating paperless animation, you can use the Workspace Manager to save a frequently 
used layout and name it Paperless Animation, for example.

Preparing References

To start an exposure sheet, you need to prepare your references. For traditional animation, you will need to 
reproduce the animator's paper exposure sheet. If you're working remotely, the studio can scan the paper 
exposure sheet using third-party software and send the digital files to be opened and viewed digitally. 
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In paperless animation, you will usually create an exposure sheet from the Xsheet view.The information from your 
layout and posing or storyboard will help you approximate how many elements are required in the scene.

Setting the Scene Length
Once the references are ready, you need to set the scene length by adding the right number of frames to your scene. 
You can set the global scene length from the top menu.

In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length

 1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.

How to extend or reduce the scene length in the Timeline view

When you remove frames at the end of a scene to reduce the scene length in the Timeline view, the exposed 
drawings and symbols are not deleted. They're still available if you extend the scene afterward.

 1. In the Timeline view, drag the scene length bracket:

‣ Right: To add more frames to your scene.

‣ Left: To reduce the number of frames in your scene.

How to add frames in the middle of a scene

You can add frames anywhere in the middle of the scene—before or after a selection. If you select a frame row in the 
Xsheet view, Harmony will add the new frames before or after the selection, depending on your choice.

 1. Do one of the following: 

‣ In the Timeline view, select the frame to which you want to add frames before or after.

‣ In the Xsheet view, select a frame row. 
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‣ In the Timeline view, select the frame to which you want to add frames before or after.

 2. Do one of the following:

‣ From the top menu, select Scene > Frame > Add Frames Before Selection or Add Frames After 
Selection. 

‣ In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add Frames 
After Selection.

‣ In the Xsheet toolbar, click the Add Frames  button to add frame after your selection.

‣ Press Ctrl + G and Ctrl + H (Windows/Linux) or ⌘  + G and  Ctrl + H (Mac OS X).

The Add Frames dialog box opens.

 3. In the Number of Frames to Add field, enter the number of frames needed in the scene.

 4. Click OK.

How to add frames at the start or end of a scene

 1. In the top menu, select Scene > Frames > Add Frames at Start or Add Frames at End.

The Add Frames dialog box opens.

 2. In the Number of Frames to Add field, enter the number of frames needed in the scene.
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 3. Click OK.

How to remove a frame or a range of frames to reduce the scene length in the Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

 1. In the Xsheet view, do one of the following:

‣ Select a frame in a given column.

‣ Select a frame range by clicking the first frame’s number and then dragging the selection highlight down to 
the last frame to delete.

 

 2. To delete the selected frames, do one of the following: 

‣ From the top menu, select Scene > Frame > Remove Selected Frames. 

‣ Press Delete to delete the selection. 

‣ Click the Remove Frames  button. To remove several frame selections, click the button repeatedly.

If you selected a range of frames, the Warning dialog box may open.

 3. To complete the operation:

‣ Click Yes to delete the selection.

‣ Click No to delete only the exposure in the cell and not the frames.

‣ Select the Don’t Show This Message Again option to prevent the warning message from being 
displayed each time you delete a frame range.

Creating Drawings
Before filling any value or setting any timing or exposure, you need to add different drawing elements.
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Each drawing element is represented as a vertical element column in the Xsheet view and a horizontal element 
layer in the Timeline view.

In Harmony, whether you work in the Timeline or Xsheet view,  any modification you do to one view will be applied 
to both.

To start an exposure sheet, you will use drawing elements. Drawing elements are drawing containers. Any image 
file, either bitmap or vector, will use a drawing element. 

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is named the 
same way as the drawing element. Its purpose is to contain all the drawings related to this element. For example, 
in cut-out animation, a character can have many heads available. All of the head drawings will be contained in this 
folder, even if they are not exposed in the Timeline or the Xsheet view. There is always a drawing container 
connected to a drawing element (layer, column).

NOTE: There are different element types available, such as sound and expression. A sound element contains 
sound files. Expressions, Beziers, 3D path, Quadmaps and Pegs are for motion purposes during the compositing 
step. It's not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu.

This section is divided as follows:

• Layer  Basics on page 34

• Layer and Column Types on page 35

• Adding Layers and Columns on page 37

• Deleting Layers and Columns on page 38

• Layer and Column Properties on page 39

• Modifying Layers and Columns on page 40

• Duplicating Layers and Columns on page 41

• Cloning Layers and Columns on page 42

• Adding an Annotation Column

Layer  Basics

A layer is linked to a directory, the location where all its drawings are saved. This directory has the same name as 
the layer. When a name is typed in a cell ,Harmony searches the layer's directory for the corresponding drawing 
to display. If there is no corresponding drawing, a new one is created.

Drawings are exposed in cells and linked to the drawings saved in the layer's directory. When you remove a 
drawing from a cell, it is not displayed and still exists in the directory.

A drawing that is exposed multiple times (for example, in a walk-cycle) would be linked to the same original 
drawing in the layer's directory. If you modify, repaint, or correct the drawing, all exposed drawings with the same 
name are updated simultaneously. You must duplicate or create a new drawing to modify a single exposure and 
retain the others.
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When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that when 
you modify, repaint, or correct a drawing named “1,” all drawings named “1” are updated simultaneously. In order to 
modify a drawing independently from its other exposures, you must duplicate the drawing.

Layer and Column Types

A column is also known as a layer. There are several types of layers that you can add in the Xsheet and Timeline 
view. Each layer is indicated by an icon to help you differentiate them. Some layers are represented differently in the 
Xsheet view. 

Drawing Layer

The most common layer type is the drawing layer. Any time you need to create a vector drawing or import a symbol 
or image, you can use a drawing layer. You can also create bitmap artwork on a drawing layer.

NOTE: Bitmap images are contained in bitmap layers.

Bitmap Layer

If you import a bitmap images (as original bitmap) in your project, they are inserted in a Bitmap layer. If you choose to 
vectorize your image when you import, the vectorized object will be placed on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a bitmap 
into a symbol, you will be able to mix vector drawings with it on the same layer.

Camera Layer

You can only have one Camera layer at a time in the Timeline view. By default, there is no Camera layer when you 
create a scene. You need to add a Camera layer when you want to create a camera motion.

The Camera layer is not visible in the Xsheet view.

NOTE: If you want to have several cameras with different settings, you can keep adding Camera layers in your 
Timeline view (however, only one will ever be visible at a time as you can only have one camera at a time in your 
timeline). To switch to a different camera, select Scene > Camera and select another camera layer.
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Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them. 

When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in the 
Functions section of the  Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene has no 
background colour and if you render it as a QuickTime movie or image sequence, it will have a black background.

This layer is not visible in the Xsheet view.

Group Layer

A Group layer can be used to organize the Timeline view. You can drag and drop other layers onto a Group layer 
and then collapse the Group layer to hide these other layers from view. 

If you create the Group layer in the Timeline view.

Peg Layer

A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to any drawing 
layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the  Functions 
section of the Xsheet view.

Quadmap Layer
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A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This can 
be attached to any drawing layer, cut-out puppet, or even other Peg layers. They will all follow the deformation you 
set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are displayed in the 
Functions section of the Xsheet view.

Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your 
Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types

In the Xsheet view, you can add several advanced column types to create particular animation paths. When you 
create these columns, they are not linked automatically to any particular drawing layer. You can create a motion path 
using these columns and then link or unlink several drawing or peg layers to it. 

Advanced column types include:

• Timing

• 3D Path

• 3D Rotation

• Bezier Curve

• Expression 

• Annotation

Adding Layers and Columns

There are different ways to add a drawing layer to your project. By default, when you create a new scene there is one 
Drawing column in the Xsheet view and one corresponding Drawing layer in the Timeline view.

You can add an element for each drawing and it will appear as a column in the Xsheet view,  a layer in the Timeline 
view.

How to add a drawing element from the Timeline view

 1. In the Timeline view, click the Add Drawing Layer  button or press Ctrl + R (Windows/Linux) or ⌘  + R 
(Mac OS X).

The Add Drawing Layer window opens.
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 2. In the Name field, name your new layer.

 3. Do one of the following: 

‣ Click Add to add a first layer and keep the window open to add more layers. 

‣ Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

How to add a drawing element from the top menu

 1. From the top menu, select Insert > Drawing.

The Add Drawing Layer dialog box opens.

 2. In the Name field, type a relevant element name and click  OK.

The new drawing element appears in your scene.

Deleting Layers and Columns

You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

 1. In the Timeline view, select the layers to delete.

 2. Do one of the following:

‣ In the Timeline’s Layer toolbar, click the Delete Layers  button. 

‣ Right-click on the selection and select Delete.

How to delete columns in the Xsheet view

 1. In the Xsheet view, select the columns to be deleted by clicking on their header.
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 2. Do one of the following

‣ Right-click on the selection and select Delete Columns. 

‣ In the Xsheet toolbar, click the Delete Columns  button.

‣ Press Delete.

The Confirm Delete dialog box opens.

 3. To complete the operation:

‣ Click OK to delete the selected layers.

‣ Click Cancel to cancel the operation.

Layer and Column Properties

Each element has its own set of properties that you can modify, including effect and peg layers.

If you want to modify an element’s properties, you can display the properties of a selected layer in the Timeline view. 
If you're working with the Xsheet, you can display its properties as well. You can display a layer's properties as a 
window or as a view of its own.

The Layer Properties editor allows you to:

• Rename the layer

• Enable or disable the layer

• Lock the layer

• Change the track colour

The Column Properties editor allows you to:

• Rename the layer

• Enable or disable the layer

How to display a layer's properties

 1. Do one of the following:

‣ In the Layer Properties view is not part of your workspace, from the top menu, select Windows > Layer 
Properties. In the Timeline view, select a layer

‣ In the Timeline view, double-click on a layer.

‣ Press Shift + E.
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The properties display.

Modifying Layers and Columns

Once you add layers and columns to your project, you can modify their properties, names, or ordering.

You can change the order of your elements in the Timeline view and Xsheet view. When you change the order of 
your elements in one view, the other one is updated.

How to rename a layer in the Timeline view

 1. In the Timeline view, double-click on the name of the layer to rename.

 2. In the Name field, rename the layer and press Enter/Return.

How to rename a layer in the Layer Properties editor

 1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

 2. In the Name field, rename the layer.
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 3. Click Close.

How to reorder layers in the Timeline view

 1. In the Timeline view, select the layers to move.

 2. Drag the selection to the new location.

 3. Do one of the following:

‣ Drop the selection on an existing layer to make it a child of another element layer.

‣ Drop it between the existing layers. Timeline layers that are located above the selection are displayed in 
front it. Layers located under it in the Timeline View are displayed behind it.

How to reorder columns in the Xsheet view

 1. In the Xsheet view, click on the column’s header with the middle mouse button.

 2. Drag the column to its new position.

Duplicating Layers and Columns

Duplicating an element provides you with a copy of the drawings and their exposure. You can modify anything you 
want in the duplicated element without affecting the original one.

How to duplicate an element

 1. In the Timeline or Xsheet view, click the layer or column to duplicate.
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 2. Do one of the following: 

‣ (Xsheet) Right-click on the column and select Duplicate Selected Columns.

‣ (Timeline) Right-click on the layer and select Duplicate Selected Layers.

The new duplicated layer or column appears.

Cloning Layers and Columns

Cloning a layer or column provides you with a copy of the selected element that uses the same drawings as the 
original. For example, if you modify a drawing in the cloned or original column, it is updated in both columns. 

You can choose whether or not to copy the column timing to the cloned columns. 

• You can modify the column timing independently from each other, but the drawings remain linked.

• You can copy the columns timing, so drawings and timings remain linked.

You can clone selected nodes from the Node view in the same way.

This is useful when you want to reuse a hand-drawn animation but have different timings.

How to clone an element

 1. In the Timeline or Xsheet view, select the layer or column to clone.

 2. Do one of the following:

‣ From the top menu, select Edit > Clone: Drawings Only to clone only the layer or column drawings.

The new cloned layer or column appears.

Filling Exposure
Harmony provides different tools to fill in exposures and values, create cycles, and set increments.

This section is divided as follows:

• Filling Exposure Mode on page 43

• Typing Exposure on page 44

• Holding Exposure on page 45
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• Extending a Single Exposure on page 45

• Extending an Exposure Sequence on page 46

• Extending the Exposure of Previous Drawings on page 48

• Dragging Cells on page 49

• Increasing and Decreasing Exposure on page 51

• Inserting Blank Cells on page 54

• Setting the Exposure on page 55

• Filling a Selection with a Single Exposure on page 57

• Filling a Selection with a Sequence on page 57

• Filling a Selection Randomly on page 58

• Filling Empty Cells on page 59

• Deleting Exposure on page 53

• Creating Cycles on page 60

• Managing Key Exposures on page 61

Filling Exposure Mode

In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes control 
the filling behaviour. The Timeline view only uses the Overwrite mode.

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence overwrites 
existing ones. The existing timing sequence remains in the same place and is not pushed down the column.

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence over 
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down the 
column.

43



Chapter 3: Timing     

How to switch between Overwrite and Insert modes

 1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click Overwrite/Insert.

‣ Press I.

Typing Exposure

If you want to type an exact drawing name or value in the Timeline view, you must use the Parameters section of 
the Timeline.

NOTE: You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

How to type a value in the Timeline view

 1. In the Drawing Substitution field, double-click to edit the field and type the name of the drawing you want to 
create.

 2. Press Enter/Return to validate the value.
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Holding Exposure

Drawings in an animation project are often exposed for more than one frame. The most common exposure of a 
drawing is two frames. In the industry, this type of exposure is known as animation in double frames or animation on 
twos. A drawing can also be exposed for three, four, or five cells and so on. To prevent mistakes and save time, you 
can hold cells automatically as you type in the Xsheet view.

How to hold exposure

 1. Do one of the following:

‣ From the top menu, select Animation > Cell > Hold Exposure > the desired option.

 2. Type a value or drawing name in the cell.

‣ Press Enter/Return to move on to the next cell.

‣ Press Esc to quit the typing mode.

Extending a Single Exposure

Extending the exposure lets you select a cell that contains a value and pull it down to the desired frame. 

How to extend a cell exposure gesturally

 1. In the Xsheet view, select the red arrow  in the cell’s right side. Make sure you see the drag down  cursor.

 2. Pull down the selected cell to the desired frame. 

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is considered 
cancelled.
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How to extend a sequence from the top menu

 1. Select a cell and do one of the following:

‣ From the top menu, select Animation > Cell > Extend Exposure.

‣ Press F5.

The Extend Exposure dialog box opens.

 2. Enter the frame number you want to extend the cell to.

Extending an Exposure Sequence

When working with a sequence that contains only numbers, you can extend an exposure sequence in a similar 
manner to extending a single exposure.

How to extend an exposure to create a sequence

 1. In the Xsheet view, select a cell containing a number.

 2. In the selected cell, click the red arrow  on the cell’s right side. Make sure to see the drag down  
cursor.

 3. Hold down the Shift key. Make sure a plus sign (+) appears.

 4. Pull down the selection box to the desired frame.
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NOTE: The red selection box must be visible when releasing the cursor. If not, the action is considered 
cancelled.

 5. First release the Shift key, then release the mouse button.
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Extending the Exposure of Previous Drawings
When drawing on a blank frame you can automatically create a new drawing and extend the timing from the 
previous exposed drawing. 

In the following example, a cell is selected on the timeline for creating a new drawing in image A. In image B, the 
previous exposure does not extend to the new drawing, while in image C, it does.

How to extend the exposure of previous drawings

 1. Open the Preferences dialog box by doing one of the following:

‣ From the top menu, select Edit > Preferences.

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

 2. Select the General tab.
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 3. In the Timeline section, select the Extend Exposure of Previous Drawing option.

 4. On the left side of the Timeline view, select a cell and create a new drawing.

The previous exposure automatically extends to the beginning of the new drawing.

Dragging Cells

To readjust your timing, you can drag one or more cells to a new location. You can drag a cell to any other frame in 
the same column or into another column.

You can turn off the Gestural Drag mode for the Xsheet view to prevent drawings from being dragged from one 
location to another. This feature does not apply to Annotation columns.

How to drag a cell to another location in the Timeline view

 1. In the Timeline view, select one or more cells to move.

 2. Drag the cells to the new location.

 3. Drop the selection by doing one of the following:

‣ Drop by simply releasing the mouse or pen.

‣ Hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the cells. The original 
cells will not be moved.

‣ Press Shift while dropping the selection to insert them between existing frames.
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How to drag a cell to another location in the Xsheet view

 1. In the Xsheet view, select one or more cells.

 2. In the Xsheet view, position the pointer over the small dotted area  on the left side of the selected cells.

 3. Drag the selection to any other cell in the same column or in another column.

 4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.
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‣ Hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the cells. The 
original selection will not be moved.

‣ Press Shift while dropping the selection to insert it between existing frames.

Increasing and Decreasing Exposure

Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

Increasing the exposure adds one more exposure to a selected cell; repeating this action adds an extra cell each 
time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing an 
exposure pushes the existing exposure forward. 

Decreasing the exposure removes one exposure from a selected cell and pulls any cells following it to the beginning 
of selection.
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How to increase exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

‣ From the top menu, select Animation > Cell > Increase Exposure. 

‣ In the Xsheet  toolbar, click the Increase Exposure  button.

‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be 
exposed. 

‣ Right-click and select Exposure > Increase Exposure.

‣ Press +.

How to decrease exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

‣ From the top menu, select Animation > Cell > Decrease Exposure. 

‣ In the Xsheet toolbar, click the Decrease Exposure  button.
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‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be 
exposed. 

‣ Right-click and select Exposure > Decrease Exposure. 

‣ Press -.

How to use the Clear Exposure and Pull feature

 1. In the Timeline or Xsheet view,  select a range of cells.

 2. Do one of the following: 

‣ From the top menu, select Animation > Cell > Clear Exposure and Pull. 

‣ Right-click and select Exposure > Clear Exposure and Pull.

‣ In the Xsheet toolbar, click the Clear Exposure and Pull  button.

The exposure is reduced by the selected number of cells.

Deleting Exposure

You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the Timeline or 
Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by typing its name again in a 
cell.

You can delete the exposure in a selected cell range  or delete the entire exposure of a drawing exposed over several 
cells. Note that you can also delete the exposure for drawings inside a collapsed group.

How to delete selected exposures

 1. In the Timeline or Xsheet view, select the exposure you want to delete.

 2. Do one of the following:

‣ Right-click and select Delete.

‣ Press Delete.
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How to clear the entire exposure of a drawing

 1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

 2. Do one of the following: 

‣ From the top menu, select Animation > Cell > Clear Exposure.

‣ In the Timeline view, right-click and select Exposure > Clear Exposure.

Inserting Blank Cells

You can place an empty cell between other cells. 

How to insert blank cells

 1. In the Timeline or Xsheet view, select the cell in which you want to insert a blank cell.

 2. Do one of the following:

‣ In the top menu, select Animation > Cell > Insert Blank Cell. 

‣ Right-click and select Exposure > Insert Blank Cell.

‣ In the Timeline or Xsheet toolbar, click the Insert Blank Cell  button (you may have to customize 
the toolbar to display it).

‣ Press Shift + J.

A blank cell is inserted.
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How to clear a selected cell range without changing the exposure and timing

 1. In the Xsheet view, select a frame range to clear.

 2. Right-click and select Clear.

Setting the Exposure

You can easily increase or decrease the exposure for a selected cell range.

How to set the exposure

 1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.
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 2. Do one of the following:

‣ From the top menu, select Animation > Cell > Set Exposure to > Set Exposure to 1, 2, 3, or Set 
Exposure.

‣ In the Timeline toolbar, click one of the Set Exposure  buttons (you may have to 
customize the toolbar to display them).

‣ In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 1, 2, or 3, 
or Set Exposure.

 3. If you chose the Set Exposure option, the Set Exposure dialog box opens. Enter the number of frames you 
want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.
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Filling a Selection with a Single Exposure

You can fill the same value over an entire selection. The selection can be over one cell, a cell range in one column, a 
cell range over many columns, an entire column, or many columns. You can use numbers, words, letters, or any 
alphanumeric value.

How to fill a selection with a single exposure

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following: 

‣ From the top menu, select Animation > Cell > Fill Selection. 

‣ Press Ctrl + T (Windows/Linux) or ⌘  + T (Mac OS X)).

The Fill Selection dialog box opens.

 3. In the Value field, type the desired value.

 4. To insert a key exposure in the frame following the last cell in the selection, select the Add Key Exposure 
After option. Otherwise, leave it deselected.

 5. Click OK.

Filling a Selection with a Sequence

You can create a numbered sequence over a selection. The sequence can be forward, backward, single, double or 
higher increment, as a cycle, and so on. The selection can be over one cell or a cell range in one column or more or 
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an entire column or many entire columns.

How to fill a selection with a sequence

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

‣ From the top menu, select Animation > Cell > Sequence Fill. 

‣ In the Timeline view, right-click and select Exposure > Sequence Fill.

‣ Press Ctrl + M (Windows/Linux) or ⌘  + M (Mac OS X)).

The Sequence Fill dialog box opens.

 3. In the Starting Value field, type the first number in the sequence.

 4. In the Increment field, type the number by which the drawing number will increase from frame to frame. For 
example, an increment of 1 gives you: 1-2-3-4; an increment of 2 gives you: 1-3-5-7; and -2 gives you 
this: 8-6-4-2.

Filling a Selection Randomly

You can fill in random values over a selection. You can give a maximum and a minimum value and create a range 
for Harmony to choose the random values from. The selection can be over one cell or a cell range in one column 
or more or an entire column or many entire columns.

How to fill cells randomly

 1. In the Timeline or Xsheet view, select a cell range.
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 1. In the Xsheet view, click the Fill Cells Randomly  button  (you may have to customize the toolbar to dis-
play it).

The Fill Cells Randomly dialog box opens.

 2. In the Minimum Value field, enter the lowest acceptable value.

 3. In the Maximum Value field, enter the highest acceptable value.

 4. In the Hold field, choose an exposure holding value.

 5. If you are applying this option to a drawing column, select the Whole Numbers option to avoid decimal 
points.

 6. Click OK.

Filling Empty Cells

You can fill empty cells to extend the exposure of single frame drawings to fill the range of empty cells after each 
one.When creating drawings on  cells that are not side-by-side, the exposure of the first drawing no longer fills 
automatically. You must select the frame range where you want your drawings to hold their exposure up to the next 
drawing and use the Fill Empty Cells command.
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How to fill empty cells

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

‣ Right-click and select Exposure > Fill Empty Cells.

‣ From the top menu, select Animation > Cell > Fill Empty Cells.

‣ In the Timeline toolbar, click the Fill Empty Cells  button.

Each drawing in the selection is exposed in the range of empty cells that follow it.

Creating Cycles

Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.

You can loop your drawings using the following command:

• Create Cycle

When you create a drawing cycle, all the repeated drawings are linked to the same original files. When modify, 
repaint, or correct a drawing named “1” for example, all drawings named “1” are updated simultaneously. In order 
to modify a drawing independently from its other exposures, you must duplicate the drawing.

How to  create a cycle

 1. In the Timeline or Xsheet view, select the cell range to loop.

 2. In the Timeline toolbar, click the Create Cycle  button (you may have to customize the toolbar to dis-
play it).

The Create Cycle dialog box opens.
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 3. Enter the number of cycles you want, including the current selection.

Managing Key Exposures
Before working with key exposures, it's important to understand how keyframes, exposure and key exposure work 
in Harmony:

• Keyframe: A keyframe is a point in time where a change to the properties of the object or character occurs. In 
Harmony, keyframes consist of the coordinates that determine how an entire layer and its contents are 
moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

• Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames. In 
Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. Keyframes 
can be moved independently from the drawing exposure. 

• Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed on 
a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for another 
one, then the original drawing is retained. This preserves the key drawing. Note that Harmony automatically 
sets a key exposure when you perform a drawing swap.

Adding Key Exposures

Key exposures are mainly used for swapping drawings in cut-out animation where you will have numerous drawings 
for the various positions of the mouth or eyes of a character for example. 

If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This prevents 
it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property of an exposure 
that forces it to be exposed on a certain frame regardless of whether the previous exposure is the same drawing or 
not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be automatically 
updated even if set as a key exposure.  This keeps your existing animation key poses intact. It is frequently used on a 
mouth or eyes layer. 

Example: Swapping a drawing with no key exposure

In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure. 

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.
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Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is 
positioned in the middle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key 
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing 5 for 
drawing 1, the second drawing 5 retains its exposure.

How to add a key exposure

 1. In the Timeline view, select the drawing cell to set as the key exposure.

 2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure  button.

‣ In the Timeline toolbar, click the Add Key Exposure  button.

‣ Right-click and select Exposure > Add Key Exposure.

A new key exposure is added. 

If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same 
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing 
is split in two and both parts contain the same drawing. 

Removing Key Exposures

When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure 
is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When 
the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).
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How to remove a key exposure

 1. In the Timeline view, select a key exposure to remove.

 2. Do one of the following:

‣ In the Timeline toolbar, click the Remove Key Exposure button.

‣ Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.

Removing Duplicate Key Exposures

When working with drawings to adjust the timing of a mouth in a lipsync, for example, and forcing the use of specific 
key exposures, unnecessary key exposures will be created. You can delete these duplicates without affecting the 
rest of the drawing. The first drawing of the selection will be used for the range.

NOTE: Duplicate key exposures may occur when pasting with the Enforce Key Exposure option selected.

How to remove duplicate key exposures

 1. In the Timeline view, select the layer that contains duplicate key exposures. 

 2. In the Timeline toolbar, click the Remove Duplicate Key Exposure  button (you may have to customize 
the toolbar to display it).

Navigating between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, and layers 
using keyboard shortcuts that work in the Camera, Drawing, Xsheet and Timeline views.

You can navigate through:

• Drawings

• Frames
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• Columns

How to navigate through drawings, and frames and columns

 1. In the Timeline or Xsheet view, select a cell.

 2. Once the cell is selected, you can navigate between:

‣ Previous and next layers: From the top menu, select Drawing > Previous Layer and Next Layer or 
press H and J.

‣ Previous and next drawings: From the top menu, select Drawing > Previous Drawing and Next 
Drawing or press F and G..

‣ Previous and next frames: From the top menu, select Play > Previous Frame and Next Frame or 
press comma (,) and period (.).
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Managing Drawings
Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files stored in the 
project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit the file and 
not the cells.

This section is divided as follows:

• Renaming a Drawing on page 65

• Deleting a Drawing on page 66

• Duplicating a Drawing on page 66

• Copying and Pasting Drawings on page 67

• Merging Drawings on page 69

Renaming a Drawing

To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

How to rename a drawing

 1. In the Timeline or Xsheet view, select the drawing to rename.

 2. Do one of the following:

‣ Right-click and select Drawings > Rename Drawing.

‣ In the Timeline toolbar, click the Rename Drawing  button (you may have to customize the toolbar to 
display it).

‣ Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X).

The Rename Drawing dialog box opens.
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 3. In the New Name field, type in the new drawing name.

Deleting a Drawing

You can permanently delete a drawing file from a project's folder.

NOTE: Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing

 1. In the Timeline or Xsheet view, select the drawings to delete.

 2. Do one of the following:

‣ From the top menu, select Drawing > Delete Selected Drawings.

‣ Right-click and select Drawings > Delete Selected Drawings.

Duplicating a Drawing

If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the 
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing. 
The exposure of the original drawing that was on the current cell is removed. The original drawing is not deleted 
from the project folder or other cells in which it is exposed.

With Toon Boom Harmony, you can create a keyframe at the same time as you duplicate your drawing. This way, 
you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

 1. In the Timeline or Xsheet view, select the drawing to duplicate.

 2. Do one of the following:

‣ From the top menu, select Drawing > Duplicate Drawings.

‣ Right-click  and select Drawings > Duplicate Drawings.

‣ In the Xsheet toolbar, click the Duplicate Drawing  button.
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‣ Press Alt + Shift + D.

Copying and Pasting Drawings

When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual 
drawings, you are pasting the exposure. Exposure is a property; it is the length of time that a drawing is visible over a 
series of frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. 
Keyframes can be moved independently from the drawing exposure. 

If you want to copy and paste selected drawings into a different layer or paste the selection in the same layer to 
duplicate the drawings, you must use the Paste Special feature.

There are four different ways to paste your selected drawings with the Paste Special dialog box:

When adding exposures to a drawing layer, drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new 
drawings will be created only when drawings with the same name do not already exist in the 
destination.

Replace existing drawings. Create drawing files when they do not exist: Replace drawings with 
the same names to update a scene with new modified drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a template,  such as 
when placing new drawings after the animation, then delete the template's animation.  It 
will still have updated the drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new drawings will always 
be created. If drawing files with the same name already exist, Harmony will create a new name for the 
drawing.

If you want to perform another Paste Special operation using the same settings you used previously, you can use 
the Paste Special Again command instead. You can paste your selection using the same settings as in the most 
recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

 1. In the Timeline or Xsheet view, select the drawings to copy and press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X). 
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 2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

 3. Do one of the following:

‣ Right-click and select Paste Special.

‣ From the top menu, select Edit > Paste Special.

‣ In the Xsheet  or Timeline toolbar, click the Paste Special  button (you may need to customize the 
toolbar to display it).

‣ Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X). 

The Paste Special dialog box opens.

 

 

 4. In the Drawings section, select the Always Create Drawings or Only Create Drawings When They Do 
Not Exist option.
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How to paste new drawings with the previous Paste Special settings

 1. Do one of the following:

‣ From the top menu, select Edit > Paste Special Again.

‣ Right-click and select Paste Special Again

‣ In the Timeline or Xsheet  toolbar, click the Paste Special Again  button (you may have to customize 
the toolbar to display it).

‣ Press Ctrl + Shift  + B (Windows/Linux) or ⌘  + Shift + B (Mac OS X).

Merging Drawings
Combines all drawings. Unused columns and layers will be deleted, but the original drawing files are still accessible.

How to merge drawings in entire layers or columns

 1. In the Timeline view, select the layers you want to merge.

 2. In the top menu, select Edit > Merge.

Customizing Layers and Columns

You can change the way a column in the Xsheet view displays. You can change the way a layer in the Timeline view 
or a column in the Xsheet view displays. You can stay organized without changing the content of elements or your 
animation output.

This section is divided as follows:

• Expanding and Collapsing Layers and Columns on page 69

• Showing or Hiding Layers on page 70

• Showing and Hiding Columns on page 1

• Xsheet Thumbnails on page 1

• Changing the Layer or Column Colour on page 72

Expanding and Collapsing Layers and Columns

To simplify the look of the Timeline or Xsheet view, you can expand and collapse the layers and columns. If some 
layers are parented to other ones, you can collapse the parent layer to hide its children.   
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How to collapse or expand selected layers in the Timeline view

 1. In the Timeline view, select the layer(s) to collapse or expand.

 2. Do one of the following:

‣ Right-click on the selection and select Collapse/Expand > Collapse/Expand. 

‣ Click the Expand Children Arrow  button on the parent layer.

‣ Click the Collapse/Expand  button  (you may have to customize the toolbar to display it).

‣ Press  Ctrl + I (Windows/Linux) or ⌘  + I (Mac OS X).

How to collapse or expand all layers in the Timeline view

 1. Do one of the following:

‣ Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

‣ In the Timeline toolbar, click the Collapse All  or Expand All  buttons (you may have to 
customize the toolbar to display them).

‣ Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

 1. In the Xsheet toolbar, click the Show Column List  button to display the Functions list.

 2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or expand.

 3. Do one of the following:

‣ Right-click on the column’s header and select Expand/Collapse > Collapse Selection or Expand 
Selection.

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:

‣ Right-click on any column’s header and select Expand/Collapse > Collapse All or Expand All.

‣ Press 0 and 9.

Showing or Hiding Layers

As you work in the Drawing or Camera view, some layers may be in the way or are used as references. You can 
hide these layers to make your work area less cluttered and easier to navigate. You can show and hide layers in 
the Timeline view in several different ways.

When using the Solo mode to show or hide layers, here's how it works:
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• If you have anything selected, it is not affected.

• When multiple layers are selected and you enable/disable the Solo mode on any of those layers, it is applied 
to all the selected layers. 

• When multiple layers are selected and you enable/disable the Solo mode on layers that are not part of the 
selection, it is applied only to those particular layers. 

When exporting or rendering a scene, the Solo mode setting of layers is ignored. 

NOTE: When a layer is affected by an inverted cutter, enabling the Solo mode for this layer will not show it unless the 
mask is also enabled.

How to show or hide all layers

 1. Click one of the following in the Layers toolbar: 

‣ Enable/Disable All  button to show or hide all layers. 

Any hidden layers are unhidden, so you can view all layers.

‣ Solo Mode  button to view disable your current Solo mode selection. Any soloed drawing or sound 
layers are disabled, so you can view all layers. When you click again on the Solo Mode button, you last 
Solo selection is displayed.

How to show or hide individual layers

 1. Do one of the following:

‣ In the Layer toolbar, click the Solo Mode  button.

‣ Click the layer's Enable/Disable All  button to show or hide that layer. 

‣ Press A to show a layer or D to hide selected layers.

‣ In the Timeline toolbar, click the Enable/Disable  button (you may have to customize the toolbar to 
display it).

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet view.

How to enable the selected layer and disable all others

 1. Do one of the following:

‣ Hold down Alt and click the Solo Mode  button of the layer you want to solo and hide all other layers.

‣ In the Timeline toolbar, click the Disable All Others  button (you may have to customize the toolbar to 
display it).

In the Timeline view, you can hide or show certain types of layers such as Effect. 
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Changing the Layer or Column Colour

To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and columns. 

How to change the layer’s colour in the Timeline view

 1. In the Timeline view, click the Change Track Colour  button of the layer you want to modify. 

 2. In the Select Colour dialog box, select a new colour for your layer.

 3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, selected 
colour for easy identification. The corresponding column colour is also updated in the Xsheet.

How to reset a layer’s colour in the Timeline view

 1. In the Timeline view, select the layers to reset.

 2. In the Timeline toolbar, click the Default Track Colour  button (you may have to customize the toolbar 
to display it).

How to change a column’s colour in the Xsheet view

 1. In the Xsheet view, select one or more columns to modify.

 2. Right-click on the column’s header and select Colour > Change Columns Colour.

 3. In the Select Colour dialog box, select a new colour for your columns.
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 4. Click OK.

The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

 1. In the Xsheet view, select the columns to reset.

 2. Right-click on the column’s header and select Colour > Default Columns Colour.
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Chapter 4: Colour Styling

Once the characters, props and locations are designed, it's time for the colour styling and colour models creation. 
This is when the colours and moods are determined. The line models created during the design step are painted and 
organized as colour models for the colourists. 

Harmony has a great concept of colour palettes. Each character can have its own set of colours that is carried 
through the entire project called the master palette. If the master is modified, the colours in the entire project are 
updated simultaneously. 

By doing the colour styling in Harmony, your master palette will be created at the same time, so you do not need to 
use third party software. Also you will not have to recreate the colour palette again in Harmony. It is possible to 
create this step in an external software, but it is a great time saver to do it directly in Harmony.

NOTE: Throughout this section, there may be slight differences between your interface and the illustrations in this 
guide. This is because the images are taken from Harmony Premium.

To create the colour style and colour models, follow these steps:

• Preparation on page 75

• Working with Palettes on page 80

• Colours on page 97

• Painting the Model on page 108

Preparation
Before painting, you need to organize the colour model scenes and bring in your references. The colour styling 
preparation is done in five steps:

• Colour Model Storage on page 76
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• Scene Creation on page 76

• Setting Up the Workspace on page 77

• Naming on page 78

Colour Model Storage

First, you will need to create a storage location for all your models and palettes. The best way to do this is to 
create a colour model scene. There are different possibilities available to structure your designs and colour model 
scenes. We strongly recommend that you put all of your colour models in the same scenes. It is important to 
maintain a structure for your models so they do not end up scattered throughout the project.

There are four main model categories:

If you have a small project, such as a short or an advertising contract, you can always place all the characters, 
props, effects, and locations in the same scene. For large projects such as feature-length productions or series, 
you should create four separate model scenes following these categories.

Scene Creation

In order to create colour models, you need to create your scenes.

When working on a paperless or cut-out animation project, if you have designed your characters, props, effects 
and locations directly in Harmony, you can paint your models directly in your design scene. You can also create a 
new colour model scene and import your  designs in that one. Refer to the Fundamentals Guide to learn more 
about creating a scene.

If you have not already done so, refer to the Fundamentals Guide to learn about production structure, file 
organization, and how to create a Project root directory. We recommend storing your  colour model scenes in the 
root directory or in a colour models subdirectory for even better organization.

A useful way to name your colour model scene is to include the project name, then the colour model type such as 
characters, props, effects, or locations, and finally colourmodel. For example, a character colour model scene 
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for the Adventure project would be named adventure_characters_colourmodel. This ensures that you 
always know what scene corresponds to what.

Colour Model Scene Structure

To store your colour models in a scene, you should create one drawing layer for each character, prop, effect, or 
location. You should name these according to the model.

You can also load other colour references in the scene to balance your overall colours. For example, if you work in a 
character colour model scene, it's a good idea to import some of the key locations to compare and adjust the colours 
so they match well.

Setting Up the Workspace

Now that your scenes are created and structured, you can open the corresponding colour model scene. For the 
optimal workspace for inking and painting, set up your workspace with these views:

• Xsheet

• Camera 

• Drawing

• Colour
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Naming

Now that your models are imported, you can rename them appropriately. You should rename elements (layers) 
and drawings corresponding to the model. This will help keep the work organized and make it easy for others to 
follow.

For example, if there is a black and white character model called Erik in one drawing element and its colour 
models in another one, rename your elements to include the character's name. For example, the colour model for 
Erik's armour could be named: erik_armour_colour.

How to rename a drawing element

 1. Do one of the following:

‣ In the Xsheet view, double-click on the column header of the drawing element.
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‣ In the Timeline view, double-click on the drawing element's layer.

The Layer Properties window opens.

 2. Type in a new name.

How to rename a drawing

 1. In the Xsheet view, click on a drawing name.
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 2. Do one of the following:

‣ Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X).

The Rename Drawing dialog box opens.

 3. Type in a new name and click OK.

Working with Palettes
In animation, specific colours are used to paint each particular character. In order to maintain absolute 
consistency, a colour palette is created for each character, prop and effect throughout the production. This is 
referred to as a master palette.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.

Using a master colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.

• You cannot accidentally use a colour which is not in the master palette.

• Standardization and colour consistency throughout the production

• Multiple artists can use the same colour palette and produce the same results.

Toon Boom Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete 
control and consistency in your painting process. 

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette 
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue, 
shirt, pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a  *.plt file name 
extension—see Palette File Storage. 

When a zone on the character is painted with the colour contained in a colour swatch, a link is automatically 
created between that colour swatch and the zone. This means that if the tint of the colour in the colour swatch is 
changed, any zone linked to it will update to the new tint. This is one way that colour palettes can save time and 
money in your production. 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain using 
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene. 
Using palettes linked to your character in this way allows you to instantly change its colouring to suit the mood 
and atmosphere of the scene without tediously repainting each element.
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This section is divided as follows:

• Palette Lists

• Palette File Storage 

• Creating a Colour Palette  on page 85

• Duplicating a Colour Palette  on page 89

• Cloning a Colour Palette  on page 90

• Importing and Linking Palettes on page 92

Palette Lists

The Colour view has two modes: basic and advanced.

• Basic Mode
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The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony, you only 
see the colours available in the Default palette which contains six basic colour swatches and is 
automatically named the same as your scene. For simple projects, you can manage with the default 
palette, but for movies, series, or shorts it is recommended that you create palettes for your characters. To 
create a palette, you have to switch to the Advanced mode of the Colour view and show the Palette list.

• Advanced Mode

The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes for your 
characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a palette list. 
The scene also has a palette list.  For example, a drawing layer can use three different palettes stored in three 
different locations, while another drawing layer can use two of these palettes plus another one coming from 
another scene. The palette list keep track of the locations of the palettes.

There are two types of palette lists:

• Scene Palette List 

The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless and 
traditional animations. A cut-out character will often be divided into 20 to 30 different drawing elements that 
use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to 
this list will appear in every drawing element created in the scene. There is no need to manually load the 
palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only 
Scene Palette lists.

• Element Palette List
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In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your palette at 
an element’s level. The Element Palette list is mainly used with traditional and paperless animation. Unlike 
cut-out animation, all columns (drawing elements) contain different characters, props, backgrounds, and 
effects. The Element Palette list is used when you do not necessarily want all of the palettes for all of your 
elements linked in every column. 

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This ensures 
that the links to the palettes appear only in the appropriate element. If you prefer to access a global palette 
list, link your palettes to the Scene Palette list.

When you are using several cloned palettes that are related to the same original palette, Toon Boom Harmony uses 
the palette located highest in the list to determine the colour of the painted zones—see Cloning a Colour Palette .

How to show or hide the Palette list

‣ In the Colour view, click the Show/Hide Palette List View  button to expand or collapse the Palette 
List area.

The Palette List window opens and displays all your palettes.
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How to set the Advanced Palette Lists mode

 1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences 
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the Advanced tab.

 3. In the  section, select  the Advanced Palette Lists option.

 4. Click OK.

How to reorder palettes in the Palette list

Do one of the following:

‣ From the Colour View menu, select Palettes > Move Up or Move Down. 

‣ In the Palette list, click the Up  and Down  buttons.

Palette File Storage 

In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is 
created from Harmony, it needs to be stored somewhere. By default, the palette file is stored in the scene 
directory in a palette-library folder unless you specify a different location.

There are four locations where you can find palette-library folders:
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 l Element: The Palette Library folder is stored directly in the drawing Element folder.

 l Scene: The Palette Library folder is stored directly in the Scene folder.

 l Job: The Palette Library folder is stored in a Job folder contained in the Scene folder.

 l Environment: The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is recommended 
to keep it as is. If you work with a larger studio, it is recommended to verify with them on the file structure.

This existing structure is compatible with Harmony Server. Harmony’s database has a leveled structure starting 
from the Environment down to the Element. Its client-server configuration allows all data, such as palettes and 
scenes, to be shared between a series of client machines.

Element Level 

Working with Harmony Stand Alone, the Element level is very useful when there are a lot of different palettes. When 
a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette file with the 
colour model, the colourist can load them both from the same location. This also creates a more organized structure.

Scene Level 

Working with Harmony Stand Alone, a palette file can also be saved at the scene level, so that all of the palettes 
from the scene are stored together. The palette naming must be structured so the colourist or character builders can 
find the correct one. Saving the palettes at the scene level makes it very easy to back up the palettes and retrieve 
their location.

The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that includes all of 
the characters, props, effects, and location, the colour palette or model will often be directly imported to, or created 
in, the character building scene. Just as with a cut-out character building scene, each element uses the same 
palette so it would not be efficient to save the palette inside one element. Instead, it is saved at the scene level. This 
prevents a palette overload because all of the models are in different scenes. It also allows each scene to have its 
own set of palettes corresponding to its model.

When working on a cut-out animation production, it is highly recommended that you work with the Scene level.

Palette Backup

When sharing palettes between scenes, some users may accidentally modify the colours, even though the palettes 
are locked by default. That is why it is a good idea to copy and back up your palette libraries and master palette 
directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble replacing an 
altered file. Harmony automatically updates all of the files and drawings linked to it.

Creating a Colour Palette 

You can create a palette in either Basic or Advanced mode.

By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended to use the 
Basic mode.  This setting stores the palettes automatically for you and saves them at the Scene level. When you 
use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: Environment, 
Job, Scene, or Element.
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Before you can create a palette in the Advanced Palette Lists mode, you must first set your preferences to 
Advanced Palette Lists mode in the Preferences dialog box.

You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will not 
be deleted and you can reimport it in your Palette list later on.

How to set the Advanced Palette Lists mode

 1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences 
(Mac OS X).

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the Advanced tab.

 3. In the  section, select  the Advanced Palette Lists option.

 4. Click OK.

How to create a new palette (Basic Palette Lists mode)

 1. From the Colour view menu, select Palettes > New or click the New Palette button.

The Create Palette dialog box opens.

 2. Enter the palette name according to the model. 

 3. Click OK.

The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode

 1. In the Timeline or Xsheet view, select the drawing that requires a palette. 

 2. In the Colour view, click the Show Palette List View  button to display the palette list. 
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 3. Do one of the following:

‣ From the Colour view menu, select Palettes > New. 

‣ Click the Create Palette  button. 

The Palette Browser: Create Palette dialog box opens. 

 4. Select the level to store the palette file. 

‣ Environment: The palette-library folder is stored in the scene's parent environment folder.

‣ Job: The  palette-library folder is stored in the scene's parent job folder. 

‣ Scene: The  palette-library folder is stored directly in the scene folder. 

‣ Element: The  palette-library folder is stored directly in the drawing element folder. 

When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

 5. Name the palette. There is no need to add the suffix "palette"  to the name as it is always recognized as a 
palette file.

 

 6. Select a Palette List option.

 

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided in twenty to 
thirty different drawing elements that use the character's master palette. 

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to this list 
will appear in every drawing element created in the scene. There is no need to manually load the palette in each 
element. 
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The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out animation, all 
columns (drawing elements) contain different characters, props, backgrounds and effects. The Element Palette 
List is used because you do not necessarily want all of the palettes for all of your elements linked in every 
column. 

The palette list is stored in the drawing element's directory instead of directly in the Scene level. This ensures that 
the links to the palettes appear only in the appropriate element. If you prefer to access a global palette list, link 
your palettes to the Scene Palette List.

 7. Click OK. 

The new palette appears in the palette list.

How to rename a palette

 1. In the Colour view, select the palette to rename.

 2. Do one of the following:

‣ Right-click and select Rename.

‣ From the Colour View menu, select Palettes > Rename.

 3. In the Rename dialog box, give the palette a new name and click OK.

How to remove a palette

 1. In the Colour view, select the palette to remove.

 2. Do one of the following:

‣ From the Colour View menu, select Palettes > Remove. 

‣ Right-click on the selected palette and select Remove.

‣ Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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Duplicating a Colour Palette 

A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but has a 
different ID and is independent from the original palette. This ensures that both palettes are completely independent.
This option is used when there are similar models and you want to avoid recreating and naming all the colours. You 
can change the values and the names afterward without affecting the original palette. You can also keep some 
RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.

How to duplicate a palette 

 1. In the Colour view, select the palette to be duplicated.

 2. Do one of the following:

‣ From the Colour menu, select Palettes > Duplicate. 

‣ Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.

 3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage .

 4. In the New Palette Name field, name the palette.

 5. In the New Palette Name field, name the palette.

 6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette 

A character usually has only one master palette, although there are times when the characters are placed in 
different lighting conditions and require a different colour shading. The night palette is a popular choice when a 
scene or sequence changes from day to night. It can be difficult and time-consuming to repaint everything and 
creating two independent palettes can be quite complex. As an alternative, Toon Boom Harmony provides clone 
palettes.
The clone palette is a copy of the master palette. The colours in each palette have the same properties. The 
colours have the same identification number pointing to the same colour zones, but they can have different 
names and RGBA values. Depending on the palette (night or day) you're currently using, the painted drawing will 
update. So there's no need to repaint the animation. All you have to do is create or import a clone palette (palette 
style).

How to clone a palette

 1. In the Colour view, select a palette to clone.

 2. From the Colour  menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.
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 3. If you're in Advanced Palette List mode, select the palette storage level—see Palette File Storage  on page 
84.

 4. In the New Palette Name field, name the palette. We recommend keeping the "-clone" in the name.

 5. Click OK.

The cloned palette appears in the palette list.

 6. In the Palette list, select the clone palette you created to offset or blend colours—see Mixing Colours on page 
106.

 7. From the Colour View  menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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 8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A (Win-
dows/Linux) or ⌘  + A (Mac OS X).

 9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

 10. Select the Preview option to see a preview of the colours while you adjust them.

NOTE: You can also modify the colours individually with the Colour Picker window.

 

Importing and Linking Palettes

Before starting colouring work such as ink and paint or even creating new colour models, you may want to load 
existing colour palettes to your scene. You can do so by linking colour palettes to your palette lists.

You may encounter a case where only a colour palette is visible when a layer is selected. If you need that palette 
in a second layer, you can link the palette to the second layer's palette list. A good example would be a scene 
where there is a character on one layer and its arm is on another. In order for both layers to access the palette, 
you must link both Element Palette lists to that palette. If your palette is linked to the Scene Palette list, it will be 
accessible by all layers.
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If you created a palette in another project and you want to import it in your current project, you can browse for the 
palette file  on your computer and add it to your scene. When the palette is imported in your scene, the file is copied in 
the project’s directory. It is not linked to the original file.

With Toon Boom Harmony as a stand-alone application, every scene is local to the machine. This means that all of 
the scene’s data is only accessible from that particular scene. Palettes are also local to the scene; they can be 
shared between all drawing layers, but not between scenes.

However, you may want to share palettes across a whole project. Harmony offers that possibility. By default, a 
palette is an independent file stored in your  scene. This file can be copied, moved, or deleted.

To link a palette throughout an entire project, you need to create a central directory where you can copy all the 
palettes you created. Every time you link a palette in an element, it is linked to this folder. If you modify the palette, it 
will be updated throughout the whole project.

You will notice that when you create or link a palette, a small icon appears on its left. These icons represent the 
palette's link status.

Icon Description

Indicates that the palette is safe.

There won’t be any problems once the scene is exported. For example, the palette file is stored 
in the scene folder and is linked to the Scene Palette List. 

Indicates that the palette file is stored in a directory external to the scene’s structure.

The palette file is probably stored in a Master Palette directory on a hard drive external to the 
palette-libraries planned for the palette storage. The warning in this case is that if you move your 
Master Palette directory to another location, you may loose the palette in your scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is 
linked to a Palette list that is not on the same level. 

For example, a palette file is stored into the Environment folder and is linked to the Element 
Palette list. The palette is shared.

Indicates a potentially dangerous situation.

Problems may occur when trying to export or link to the palette file. For example, a palette file is 
stored into the element folder and is linked to the Scene Palette list. The issue in this case is 
that if you decide to delete the layer containing the palette, it will be lost from your scene.

How to link a colour palette

 1. Do one of the following:

‣ From the Colour View menu, select Palettes > Link. 

‣ Right-click and select Link.

‣ Click the Import  button.

The Palette Browser: Link Palette dialog box opens.
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 2. Select the level where the palette file is stored—see Palette File Storage  on page 84.

 3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—see 
Palette Lists on page 81.

The palette appears in the Colour view.

How to import a palette into your project

 1. Do one of the following:

‣ From the Colour menu, select Palettes > Import. 

‣ Right-click and select Import.

The Browser window opens.

 2. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in your pro-
ject's palette-library directory.

 3. Click Open.

The Palette Browser opens.
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 4. If you're in Advanced Palette mode, select the level where the palette file is stored—see Palette File Storage .

 5. If you're in Advanced Palette mode, select the palette list linking level by enabling either Scene Palette List 
or Element Palette List—see Palette Lists.

 6. In the New Palette Name, name the imported palette.

The palette appears in the Colour view and the file is copied in your project.

How to link to an external palette

 1. In the Colour view, click on the Create Palette  button to create a palette to be used as external.

 2. Save your scene by selecting File > Save from the top menu or by clicking the Save   button or press Ctrl 
+ S (Windows/Linux) or ⌘  + S (Mac OS X).

 3. On your computer or server, create a master directory. Ideally, this should be created in your Root folder to 
keep it within the project directory. You could also place it inside your Colour Model’s subdirectory—see 
Chapter 6: Project Organization and File Structure in the Fundamentals Guide.

 4. Name the folder appropriately, for example: Joe_master_palette.

 5. From your operating system, browse to your Toon Boom Harmony scene and open the palette-library folder.
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 6. Select and copy your palette *.plt file to copy it to the master palette directory.

 7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette. 

 8. In the Timeline or Xsheet view, select the element to link the palette to.

 9. From the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

 10. Click Browse to search for your master palettes folder and select the palette *.plt file you want to link.

 11. In the Palette list section, select how you want to load the palette; at the scene or element level.

 12. Click OK.

The linked palette appears in the Colour view.

If a palette is outside the scene, the External  icon appears beside the palette name. 
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NOTE: To link an element (such as a colour model) to the palette that is stored in the external palette directory, you 
must remove the original palette from the element’s palette list. You will then load the duplicated palette into the 
palette list using the Link to External command, like you did for the other elements. 

Colours
Toon Boom Harmony has some very powerful colouring features when it comes to painting. To paint your drawings, 
you will use different colour swatches, unlike some other painting programs where you modify the main swatch each 
time you want to paint with a different colour. 

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You can 
add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch 
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones. 
This way, you can change the look of your character at any time without having to repaint it!

This section is divided as follows:
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• Adding a Colour Swatch 

• Editing Gradients and Textures  on page 115

• Colour Display Modes  on page 104

• Copying and Pasting Colours  on page 105

• Mixing Colours on page 106

Adding a Colour Swatch 

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap texture 
swatches.

How to add or modify a solid colour swatch

 1. In the Colour view, click the Add Colour  button.

 2. From the Colour view menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens. 

 3. To set your colour, do one of the following:

‣ In the colour wheel, select a colour.

‣ Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options to 
change the look of the colour picking area.
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‣ Click the Dropper  button to select any colour on your screen. It can be from the Harmony interface, 
your operating system or any other open application. 

 

How to add a new colour swatch using the default colour

‣ From the Colour View menu, select Colours > New. 

A new swatch is added to your palette using the default colour swatch colour. The new swatch created with 
the New  command will be named New 0.

How to create a gradient colour swatch

 1. In the Colour view, select a colour to modify .

 2. Do one of the following:

‣ Click the new colour and from the Colour View  menu, select Colours > New. 

‣ Double-click on the colour swatch.

The Colour Picker window opens.
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 3. Select the Gradient option.

 4. Select the Linear or Radial option.

 5. Adjust the Gradient arrows to modify the colours.

‣ Add extra colours by clicking between the arrows below the gradient bar. Then click on the Colour 
Preview to select a colour.

‣ Pull down the arrows to remove them.

‣ Move the arrows left and right to modify the gradient distance.

NOTE: To learn how to reposition the gradient zones in your drawings, see Editing Gradients and Textures  on 
page 115.

How to create a texture colour

 1. From the Colour  menu, select Colours > New Texture or click the New Texture  button.

The Browser window opens.

 2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.
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NOTE: 
To learn how to reposition the textured zones in your drawings, see Editing Gradients and Textures  on page 115.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of plaid, 
just update the texture file in the swatch and the entire project updates. Any transformation previously applied to the 
texture’s position in your drawings will be kept.

How to replace a texture swatch

 1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

 2. From the Colour View  menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

 3. Browse for the new PSD or TGA bitmap file created in a third party software.
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 4. Click Open to update the colour swatch.

How to delete a colour swatch

 1. In the Colour view, select the colour swatches to delete.

 2. Do one of the following:

‣ From the Colour View menu, select Colours > Delete.

‣ Click the Delete Colour  button. 

‣ Right-click and select Delete.

‣ Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

 3. Click OK to delete the colours or click Cancel to abort the operation.

‣ If you delete colour swatches already in use, the zones painted with them turn red so you can easily 
identify them.
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Editing Gradients and Textures 

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its position 
in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set the first 
texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you can select the 
next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your gradient’s 
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them 
afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with textured 
“brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both elements 
independently at the same time.

How to use Edit Gradient/Texture tool

 1. Do one of the following: 

‣ In the Tools toolbar, click the Edit Texture  tool.

‣ Press Shift + F3.

 2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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 3. Edit the gradient or texture by adjusting the control handles around the selection frame.

Colour Display Modes 

The Colour view has two display modes:

• List

• Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This 
option is not available when displaying the colours in Swatch mode.

How to switch between the display modes

 1. From the Colour View menu, and do one of the following: 

‣ Select Colours > Swatch Mode to display the swatches.

‣ Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

‣ From the Colour View menu, select Palettes > Display Colour Values.   
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The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The gradient 
colour swatches will be identified as (gradient).

Copying and Pasting Colours 

When you're creating palettes, you may want to copy colour swatches or their values and paste them in other 
palettes to save time. You can also quickly copy a colour value from a palette in your scene to a selected colour 
swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, it is 
impossible to use the Paste as Clone command in the same palette as you copied the original colour swatch from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can copy the 
colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

How to copy and paste colours

 1. In the Colour view, select one or more colours to copy.

 2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

 3. In the Palette list, select the palette in which you want to paste the colours.

 4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V (Windows/Linux) or 
⌘  + V (Mac OS X).

‣ To paste the colour values of the copied swatch over an existing colour swatch, select Colours > Paste 
Colour Values.

How to clone a colour swatch

 1. In the Colour view, select the colour swatch you want to clone.
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 2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac 
OS X).

 3. In the Colour view, select the colour palette you want to paste the clone into or create a new palette.

 4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

 1. In the Colour view, select the colour swatch you want toget the ID from.

 2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or ⌘  + 
C (Mac OS X).

 3. Paste the copied value as plain text in the desired document.

Mixing Colours

If you want to modify a series of colours to blend a tint in them or offset their RGBA values, you can use the Tint 
panel. You can also create palette styles, such as night and day styles.

How to mix colours

 1. In the Colour view, select the palette that contains the colours you want to offset or blend.

 2. Do one of the following:

‣ From the Colour View menu, select Palettes > Tint Panel. 

‣ Right-click and select Tint Panel.

The Tint Blend/Offset panel opens.
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 3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A (Win-
dows/Linux) or ⌘  + A (Mac OS X).

 4. Select Preview option.

 5. Select the Offset, Blend, or Mixer option.

Parameter Description
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Offset
Offsets the selected colours by the adjustments made using the HSB and RGB 
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider 
to adjust the opacity of the selected colour. 

Blend

Blends the selected colours with the colour swatch in the top-right corner. Use the 
Amount slider to adjust the degree of blend. A blend of 100% turns the selected 
colours into the same colour as the swatch. Adjusting the HSB and RGB sliders 
affect the swatch colour, which in turn affects the selected colours on the left. 
Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use the slider just 
beneath to mix the Base and Tint colours by different amounts. This will affect the 
mixed swatch whether it is selected or not. Select either the Tint or Base swatch 
and use the HSB and RGB sliders to adjust its colour. This will affect the mixed 
swatch colour, which in turn affects the selected colours on the left.

 6. Click Apply.

Painting the Model
Now that you've created the colours and the palette, you're ready to paint your model.

The colour model needs to be painted in order to adjust the colours with the other elements in the production. You 
can paint your model regardless of the colour RGBA and adjust them later when all the elements are together.

For paperless and cut-out animation, it's a good idea to provide a line-up template with the colour model to show 
the scale ratio between the characters, props and backgrounds. 
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Once your colour model is completed, create a line-up template by pasting one of the production's main characters, 
or even just a hand, beside the colour model to show the relative size. This allows the animator, layout artist, or 
scene setup artist to retain the correct scaling throughout the entire project when setting the elements in the scene. 
You can store your template in the Library.

How to paint a colour model

 1. Create your master colour palette—see Creating a Colour Palette  on page 85

 2. Add new colours to the palette—see Adding a Colour Swatch  on page 98.

 3. Select your Paint Bucket  tool. We recommend the Paint Unpainted  tool.

 4. In the Colour view, select a colour to paint your drawing.

 5. Paint the model by selecting colour swatches in the palette and clicking on your drawing. Note that only 
closed zones will be painted. If there's a gap in your artwork, you must close before you can paint it.
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 6. Adjust the colours—see Mixing Colours on page 106.
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Chapter 5: Ink and Paint

When traditional animation is traced, cleaned up, scanned in and properly exposed, it's time for the ink and paint 
process. This consists of cleaning all dirt and hair (for example, dust that was in the scanner, dots that do not belong 
in the drawing, extra floating artwork around the drawing that must be removed), painting the lines and filling the 
colours in the empty zones on an entire animation sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt to clean, only 
painting and inking. 

For cut-out animation, once the character builder paints the pieces, there is no more ink and paint process because 
the same parts are always reused and moved around. The ink and paint process applies only to traditional and 
paperless animation workflows.

Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-based, the colour 
zones are completely filled and there are no scattered spots left blank. Also, there are some actions that can be 
applied on an entire animation sequence at once, like dirt removal, some colour filling, line repainting, and so on.

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by assigning a 
set of colours to each character, prop or effect. The colour styling artist will create a new palette and add a new 
colour for each zone of the character, such as the skin, hair, tongue, shirt, pants, and so on. Each colour is known as 
a colour swatch—see Working with Palettes on page 80. 

  

When a zone on the character is painted with the colour contained in a colour swatch, a link is automatically created 
between that colour swatch and the zone. This means that if the tint of the colour in the colour swatch is changed, 
any zone linked to it will update to the new tint. This is one way that colour palettes can save time and money in your 
production. 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain using 
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colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene. 
Using palettes linked to your character in this way allows you to instantly change its colouring to suit the mood 
and atmosphere of the scene without tediously repainting each element.

The ink and paint process is divided into the following steps:

Preparation 112

Painting 112

Painting Using the Paint Tool 113

Inking the Lines 116

Verifying the Zones are Painted 117

Preparation
The optimal workspace for creating colour models and inking/painting in traditional animation includes the 
following views:

• Xsheet

• Camera

• Drawing

• Colour

As there is no default workspace for these tasks, you will need to create a custom workspace for yourself—see 
the Fundamentals Guide.

Painting
This section is divided as follows:
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• Painting Using the Paint Tool on page 113

• Selecting a Colour in a Drawing  on page 114

• Editing Gradients and Textures  on page 115

• Inverting a Colour Selection on page 116

Painting Using the Paint Tool

The main tool you will use to paint your drawings with is the Paint  tool. The Paint tool can be used in several different 
modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the lines defining a 
zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic Close Gap option.

How to paint with the Paint tool

 1. In the Timeline or Xsheet view, select the cell on which you want to paint.

 2. Do one of the following:

‣ In the Tools toolbar, click the Paint  tool.

‣ Press Alt + I. 

 3. In the Colour view, select a colour.

 4. In the  Drawing or Camera view, start painting. Click on a zone or pencil line to paint it, or trace a lasso or mar-
quee selection to paint several zones or pencil lines at the same time.
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NOTE: The last colour you select while using the Paint tool will be used the next time you select the Paint tool if 
you're using the unlocked painting tools in the Colour view.

Selecting a Colour in a Drawing 

While working in the Camera or Drawing view, you can use the Dropper  tool to pick a colour from your drawing 
without going to the Colour view. 

How to use the Dropper tool

 1. Do one of the following:

‣ In the Tools toolbar, select the Dropper  tool.

‣ From the top menu, select Drawing > Drawing Tools > Dropper.

‣ Press Alt + D. 

 2. In the Camera or Drawing view, click on the desired colour.

‣ If you're using another drawing tool such as the Paint tool, you can temporarily hold down the D key 
and click in your drawing before releasing the key to pick your colour. When you release the key,  you 
will return to your previous tool. You may also want to select the zones painted with the colour currently 
selected in the Colour view. This can be useful for removing rough lines from a clean drawing.

How to select the zones painted with the current colour

 1. In the Colour view, select the colour from which you want to select the corresponding zones.

 2. Do one of the following:

‣ Select Drawing > Select Strokes With Current Colour. 

‣ Press Ctrl + Shift + A (Windows/Linux) or ⌘  + Shift + A (Mac OS X).
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Editing Gradients and Textures 

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its position 
in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set the first 
texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you can select the 
next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your gradient’s 
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them 
afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with textured 
“brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both elements 
independently at the same time.

How to use Edit Gradient/Texture tool

 1. Do one of the following: 

‣ In the Tools toolbar, click the Edit Texture  tool.

‣ Press Shift + F3.

 2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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 3. Edit the gradient or texture by adjusting the control handles around the selection frame.

Inverting a Colour Selection

When you need to select all colour swatches but one, or select only a few swatches here and there,  it might be 
faster to select the only colour you do not need in order to select and invert the selection.

How to invert a colour swatch selection in the Colour view

 1. In the Colour view, select the colour swatch you DO NOT want to have in your final selection.

 2. Do one of the following:

Inking the Lines

Repaint Brush Mode

The Repaint Brush mode is used to paint a section by manually painting over the lines. This is useful when the 
vectorization triangles are not placed as you would like or you simply need to repaint a section of a segment. It is 
also useful for paperless animation, where there are no triangles. So, the Repaint Brush is used to paint a certain 
area. It acts like the Brush tool, but will only show on painted areas that are already painted. 

Unlike the Brush tool, the Repaint Brush mode flattens automatically. The brush strokes are not added one on top 
of each other.

How to enable the Repaint Brush mode

 1. In the Tools toolbar, select the Brush  tool.

 2. In the Tool Properties view, enable the Repaint Brush  mode.
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Verifying the Zones are Painted
When the ink and paint process is completed, it's always a good idea to verify that every zone was painted properly.

The first step to check your ink and paint is to go through all  your drawings and verify that there are no colour 
mistakes. You can use the F and G keyboard shortcuts or the Preview option available in the Xsheet.

How to preview drawings from the Xsheet

 1. First, save your scene. 

 2. Do one of the following:

‣ From the top menu, select File> Save. 

‣ Click the Save  button. 

‣ Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

 3. In the Xsheet view, select the range of drawings or the whole column to preview.

 4. In the Xsheet View  menu, select View > Preview Selected Drawings or press Alt + P.

The Play window opens.
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 5. Play your drawings.

 6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence while 
looping the playback.

Paint Tool Properties 

When you select the Paint tool, its properties and options appears in the Tools Properties view.

Icon Tool Name

Lasso and Marquee  on page 119

Painting Modes  on page 119

Apply to Multiple Drawings  on page 120

Select Newly Paintedand Unpainted Contours/Lines on page 121

Close Gap  on page 121
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Lasso and Marquee 

The Lasso and Marquee options let you choose the type of selection the current tool will perform. The default 
selection mode is Marquee.

• Lasso  lets you draw a custom selection box around zones.

• Marquee  makes a rectangle selection box.

NOTE: 
Hold down the Alt key to switch to toggle between the selection modes.

Painting Modes 

The Paint tool has four different modes available:

You can also find these tools directly in the Tools toolbar and in the Drawing Tools menu.

Paint Mode 

  

The Paint  mode paints everything it touches, including empty and filled zones—see Painting Using the Paint 
Tool on page 113.

Paint Unpainted Mode 
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The Paint Unpainted  mode paints only empty zones. Any line or filled zone will remain unchanged.

Unpaint Mode 

The Unpaint  mode unpaints everything it touches, including empty and filled zones.

Apply to Multiple Drawings 

The Apply to Multiple Drawings  option is used for fast painting in hand-drawn animation. When you want to 
paint several drawings in a same layer at once, such as a walk cycle, you can enable this option and make a 
selection in the Camera or Drawing view. All the closed zones located within your Paint tool selection are painted 
with the selected colour swatch.

You do not need to enable the Onion Skin preview to use this option. The option will stay enabled only for the next 
action. If you want to use it again, you must click on the Apply to Multiple Drawings button again, or press Alt + A.
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Select Newly Paintedand Unpainted Contours/Lines

In the Paint   tool properties, this option  keeps a selection highlighted around the latest painted zone after using 
the Paint, Unpaint, or Paint Unpainted tool.

Close Gap 

The Close Gap option has four modes available:

When painting, you may notice that some drawing areas are not closed. To close the zone, you can draw the 
missing line with the Brush or Pencil tool, or close the gap with an invisible line using the Close Gap tool. 

The Close Gap tool lets you close small gaps in a drawing by creating small, invisible strokes between the two 
closest points to close the colour zone. You do not need to trace directly over the gap. You can draw it a few 
millimeters away. The two closest points automatically close the gap.
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Glossary
3D stereoscopic The ability to create stereo images which, when animated and viewed through 3D active 

shutter glasses or using glasses with one red and one blue lens, will appear as a three-
dimensional movie. 

alpha channel An image channel that carries transparency information. An image already has three 
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The 
matte, or the transparency information, is stored in this fourth channel. An image without 
an alpha channel is always opaque.

animatic A movie with sound that is developed from the storyboard. The storyboard panel is 
exposed for the duration of the scene and at times, the characters are placed on a 
trajectory to indicate motion. The camera moves are also animated. The animatic is used 
to determine the rhythm of a project and provides a good overview of the project before 
beginning production.

animation A simulation of movement created by displaying a series of pictures or frames.

anime An animation style known for its sinister and dark feel; popular in Japan.

arc Action rarely occurs in a straight-forward manner; rather it typically unfolds in what 
storytellers refer to as an arc. The purpose of a story arc is to move a character or 
situation from one state or scenario to the next.

aspect ratio The relationship between the width and height dimensions for any scene, frame or film 
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed An automated method of feeding drawings into a scanner in which multiple drawings are 
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned 
consecutively, without further user intervention.

automatic lip-sync 
detection

Automatically mapping drawings in an element to the mouth chart generated for a sound. 
This can save time when lip-syncing a voice track.

axis An imaginary line around which an object rotates.

For 2D graphics, there are two axes: X (horizontal and Y (vertical).

For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).

In animations that constantly rotate, the axis element specifies what axis the object 
rotates around. A negative number causes an animation to rotate counter clockwise 
whereas a positive number causes an animation to rotate clockwise.

background The part of a scene that is farthest to the rear. The background is the artwork, or decor, 
against which the animation takes place.

Bézier A method of defining curved lines invented by French mathematician Pierre Bézier. A 
Bézier curve is a mathematical or parametric curve. Bézier curves use at least three 
points to define a curve.

bitmap An image composed of pixels with a single resolution (size). If it is enlarged too much, it 
will lose definition and individual pixels will begin to appear. This is known as pixelation.

Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each 
individual pixel contains a value that represents a specific colour.
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breakdown In cut-out animation, breakdown is the action of breaking a character into pieces to create 
a puppet with articulations. To break down a character, the artist cuts parts, such as the 
hands and arms, from the character's model and pastes them in separate layers. Next, 
the joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose generally found between two 
key poses. The key poses are the main poses in an animation and the breakdowns are 
secondary poses, ones that help describe the motion and the rotation curve (usually 
referred to as an arc).

camera shake Camera shake occurs in a scene when the camera moves slightly and quickly in several 
directions. This gives the impression of an impact, vibration or, for example, bumps on 
the road.

caption A text field containing dialogue, effects, sound or slugging information in a storyboard.

cel In traditional animation, a cel (also known as celluloid) is a transparent sheet on which 
the animation is inked and painted before being sent to the camera. The picture's outline 
is drawn on the front of the cel and then coloured along the back.

character design Each character in an animated film is drawn from multiple angles in poster-style format, 
called a model sheet, which serves as a reference for the animators.

chromatic 
aberration

In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of 
distortion in which there is a failure of a lens to focus all colours to the same convergence 
point.

clean up After rough drawings have been tested and approved, all the noise in the image (excess 
lines, notes, etc.) is removed to create final drawings which can be inked, painted and 
shot. The clean up process refers to either tracing a clean line over a rough drawing to 
achieve the final version or removing dirt and extra lines left by the scanning process.

CMYK Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model used 
in a process called offset printing.

colour card A colour card is a card containing one solid colour that is the same size as the camera. 
The colour card fills the background with a solid colour when there is no background 
image included.

colour model The official colour design that must be used to paint the animation. A model is the 
definitive character, prop or location design that each artist must follow for the 
production. 

colour wheel A display of the colour spectrum in the form of a circle. 

compositing Compositing is the action of incorporating all of a scene's elements to create the final 
result prior to rendering. For example, the compositing artist will import all the animation 
sequences, background, overlays and underlays in the scene and position them 
correctly. The artist will then set the camera frame and animate it, if needed. Finally, the 
animator will create all the computer-generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut A direct transition between two scenes. When a cut is used, there are no transition 
effects inserted to pass from one scene to the next. The first scene ends and the second 
one starts immediately.

cut-out animation The process known as cut-out animation is the action of animating characters made out 
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of several pieces by moving them around frame by frame. Cut-out animation can either 
be computer generated or done traditionally using paper.

cycle A group of images that together make up an action, such as walking. A cycle is an action 
repeated as a loop over a period of time. It can be a series of animated drawings or 
keyframes. 

dialogue The text spoken by a character in a movie or animation.

dope sheet Used by animators, directors and other members of a crew to track the sequence and 
timing of images, dialogue, sound effects, sound tracks and camera moves. Also known 
as an exposure sheet.

doping To assign a particular drawing to a range of frames.

double bounce 
walk

In the key frames and passing positions in a double bounce walk, the body is lower than a 
reference line drawn in the upright position. During the in-betweens, the body is above 
this line giving the appearance of a bounce.

DPI Dots per inch is the standard measure of resolution for computerized printers. It is 
sometimes applied to screens, in which case it should more accurately be referred to as 
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease In animation, the ease, also known as velocity, is the acceleration and deceleration of a 
motion. It can be a motion created by a function curve, or a series of animated drawings. 
Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.

ease-out Gradual deceleration in the action. Also known as slow-out.

establishing shot A scene in which the viewer can see the whole area in which a sequence is happening. 
For example, if a child is playing on the ground in front of his house, the establishing shot 
would be a scene where the viewer can see the house, the ground, a part of the street 
and the buildings around the central point of action. This helps the viewer understand the 
story location and scene orientation.

exposure In animation, an exposure is the number of cels on which a drawing appears in the scene. 
For a drawing to appear longer, the exposure must be extended over a greater number of 
cels.

exposure sheet A sheet with several vertical columns and horizontal frames used to indicate a scene's 
timing. Each column represents a scene layer. The drawing numbers in each column are 
indicated and repeated over the particular amount of frames they need to appear.

The exposure sheet is used by animators, directors and other members of a crew to track 
the sequence and timing of images, dialogue, sound effects, sound tracks and camera 
moves. Also known as a dope sheet.

fade in/fade out Fade in or fade out is a transition effect used to open or close a sequence. A fade in 
occurs when the first scene appears progressively, from complete transparency to its 
complete opacity. A fade out occurs when the last scene progressively disappears, going 
from complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field A measurement unit used to calculate motion, registration and camera positioning. A 
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standard animation scene will vary between 6 to 12 fields.

field chart A guide containing all the field units that animation and layout artists use to determine a 
scene size or camera motion.

film-1.33 A resolution that is ideal for the widescreen film format that conforms to the standard 4:3 
pixel aspect ratio.

film-1.66 A resolution that is ideal for the widescreen film format that conforms to the 16:9 pixel 
aspect ratio. (The pixels are wider than they are high).

flipping In traditional animation, flipping is the action of going through the drawings of an 
animation sequence very quickly in order to see the animation in motion. Flipping can 
also be the action of creating a mirror transformation of an object.

follow-through The secondary motion caused by the main action. For example, a character wearing a 
cloak is running. The main action is the body running. This will cause the cloak to follow 
the motion, although it will not move at the same time, but react a few frames later and 
follow the main motion curve.

forward kinematics Forward kinematics is a feature used to animate principally 3D characters and cut-out 
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a 
shoulder, and make the rest of the arm move with it as a single piece.

frame An animation frame is a single photographic image in a movie. In traditional animation, 
the North American standard generally contains 24 frames per second, while in Europe 
the standard is 25 frames per second.

frame rate The frame rate is the speed at which the frames are played. They are generally calculated 
by frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60 
frames per second or any other number.

This is the measurement of the frequency (rate) at which an imaging device produces 
unique consecutive images, called frames. The term applies equally to computer 
graphics, video cameras, film cameras, and motion capture systems.

Frame rate is most often expressed in frames per second (fps) and in progressive-scan 
monitors as hertz (Hz).

function A computer-generated motion, trajectory or path on which elements, other trajectories 
and effects parameters can be attached. The function can be controlled by adding 
keyframes and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV Acronym for High Definition Television which delivers a higher quality image than 
standard television because it has a greater number of lines of resolution. To take 
advantage of the superior quality and make full use of your resolution setting, the output 
device must be compatible with HDTV technology.

hold A frame in the animation in which the character maintains its position without moving. A 
hold can be created between any two keyframes.

HSV Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation 
(shade) and value (tone or luminance).

in-between The drawings that exist between the key poses. These are drawn to create fluid 
transitions between poses.
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ink and paint The ink and paint process is the action of painting the empty zones and colouring the 
lines on the final animation drawings, while following a colour model.

interpolation The computer-generated motion created between two keyframes. You have the choice to 
create interpolation, or not, between your keyframes.

inverse kinematics 
(IK)

A feature used mainly to animate 3D characters and cut-out puppets with hierarchy. 
Inverse kinematics will animate a puppet from one of the extremities, such as a hand, 
and make the rest of the body follow naturally.

jump cut A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is 
generally caused by one scene ending, and a second one starting, with a similar image. 
The lack of difference causes the eye to see a little jump between the two scenes. 

key pose Important positions in the action defining the starting and ending points of any smooth 
transition. Keys, or key poses, are the main drawings in an animation sequence 
describing the motion. For example, if an arm is waving, the keys will be of the arm at one 
extremity of the wave motion and the other extremity. By flipping those drawings, the 
animator can see the skeleton of the motion without having all the drawings.

keyboard 
shortcuts 

One or more keyboard keys which, when used, cause an operation to be performed.

keyframe Important positions in the action defining the starting and ending points of any action. A 
keyframe is a computer-generated position at a specific moment (frame) on a given 
trajectory.

layer In animation, a layer is an individual column, level or character. A scene's layers are 
superimposed to form the final image.

layout The communication step between the storyboard and the animation. It is the action of 
putting the storyboard on model. That is, drawing the character by following the design in 
the model pack, so the animator can start working.

The layout artist draws the background, creates the camera and field guide matching the 
scene and camera motion. Lastly, the animator draws on model the main action poses.

layout and posing The action of putting on model (at the right scale) the storyboard for the animator to start 
working.

layout artist The artist who draws the background, and creates the camera and field guide to match 
the scene and camera motion. They will draw on model the main action poses.

layout planning Drawing of the main features of the scene used as reference when planning the 
animation and executing the initial stages of it.

layout process The communication step between the storyboard and the animation. 

library A storage area containing templates and assets that can be reused in any project or 
scene.

light table A device that allows you to see other layers in transparency while you are working on a 
particular layer.

line of action The direction that the action will follow. Also known as path of action.

lip-sync The process of synchronizing a character's mouth to sounds in the dialogue soundtrack. 
The mouth is adjusted frame-by-frame to match the sound of the dialogue and provide the 
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illusion that the character is speaking. Lip-sync can be used for any sound sequence, not 
only speech, you could for instance have a bird chirping or a wolf howling at the moon.

low resolution A format that is ideal for videos destined for the web, where size and fast download of a 
video file take precedence over quality. A low-resolution image is one that lacks fine 
detail.

manual lip-sync 
detection

The manual swapping of mouth position drawings to match a voice track. For this 
process, both sound scrubbing (listening to a sound wave broken up frame-by-frame) and 
drawing substitutions are used.

master palette A group of colours attributed to a character or prop. The palette is used throughout the 
entire production to maintain consistency in the look and to ensure that the same colours 
are used throughout the production. Also known as palette.

model/colour 
model

The definitive character, prop or location design each artist must follow for a production. 
A colour model is the official colour design that must be used to paint the animation.

morphing A feature for creating computer-generated drawings between a source drawing and a 
destination drawing. Animation created with the morphing feature can be reused in 
different projects.

motion keyframe A keyframe with computer-generated interpolation.

mouth chart A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is 
used to represent silence) used for lip-sync.

multiplane The effect of passing through multiple levels of drawings to create a sense of depth in a 
shot. A multiplane is a scene in which the layers are placed at different distances from 
the camera so that when the camera moves, a depth illusion occurs. With a multiplane, 
all the perspective and scale is calculated automatically.

NTSC The standard analogue television broadcasting system used in North America. NTSC 
conforms to North American standards on how rectangular pixels are displayed for 
computer and television screens.

nudge A small push (left, right, up, down, forward or backward) done with the keyboard arrow 
keys on a selected element. Nudging is used to move a selection very slightly and 
precisely.

onion skin A feature that lets you see the previous and next drawings of a sequence.

overlay A part of the scene environment, such as a chair or a bush, that is placed in front of the 
main animation.

PAL A resolution that works best with the European format for television and computer 
screens, as the rectangular pixels are displayed at a different orientation.

palette/master 
palette

A palette or master palette is a group of colours attributed to a character or a prop. The 
palette is used throughout the entire project to maintain a consistency in the look and 
avoid the colour changing during the animation. Also referred to as a master palette.

palette style A palette style is a second version of an existing palette with a slight change in the tint 
and value. A palette style can be used to create the night version of a palette. It may also 
be called a clone palette.

pan To move the camera across the scene in any direction.

panel In a storyboard, a panel is a frame in a shot. A shot can be composed of one or several 
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panels.

paperless 
animation/tradigital

The paperless animation process is the action of animating digitally. The main paperless 
animation process is to draw, frame by frame, the animation directly in the software.

passing position When drawing a walk sequence for a character, the passing position is the point at which 
one leg passes the other.

path of action Direction that the action will follow. Also known as line of action.

peg In traditional animation, a tool used to ensure accurate registration of action as cel layers 
move. In digital animation, in which you are doing a more advanced puppet rigging, you 
can use peg layers. Peg layers are trajectory layers that do not contain drawings. They 
are motion paths that you can use to add path articulations. For the latter, you can also 
use an inverse kinematics tool.

phoneme A unit of sound in a language.

pivot The point around which a peg or drawing rotates.

pixel The smallest element of an image displayed on a monitor or TV screen.

Pixel, short for picture element, is a single point in a graphic image. It is a small sample of 
an image, a dot, a square, or a very small section made out of smooth filtering. If you 
zoom in close enough on a digital image, you will see the pixels, which look like small 
squares of different colours and intensity.

pose-to-pose 
animation

The pose-to-pose animation process is the action of creating all the main action poses, 
called key poses, and then placing the secondary poses between the keys. The 
secondary poses are called breakdown. Finally, the animator fills the gaps with the in-
between drawings to achieve a smooth animation.

rendering The final step when animating by computer. During rendering, the computer takes each 
pixel that appears on screen and processes all of the components, as well as adding 
motion blur before it produces a final image. The process of calculating the final images 
after the compositing process.

resolution The size of a scene, generally calculated in pixels. For example, the NTSC resolution is 
720 x 480. The resolution should match the final output: HDTV, film-1.33, film-1.66, 
NTSC, PAL, low.

RGB Red, Green, Blue. A method of defining colour by specifying amounts of these three 
colour components.

rigging The process of attaching the various parts of a cut-out puppet.

rotary table Equivalent to the animation disk/table, a device that allows you to rotate the workspace 
for greater comfort while drawing.

rotoscoping An animation technique in which animators trace over live-action film movement, frame 
by frame, for use in animated films. The act of sketching over live-action footage to 
create an animated sequence.

roughs Rough is a common name in an animation movie for a drawing that is used as a reference 
but which does not form part of the final image. A layout is a rough.

The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines 
and shapes, but can also contain design details.
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safe area The zone at the center of a scene's frame that is safe from being cropped by the TV 
frame. As a TV frame cuts a margin off the original frame size, maintaining a safe area 
ensures that the scene's main action will remain clearly visible once the film is screened 
on television.

scene A shot in a movie or show. A sequence is composed of several scenes. A scene 
changes to another scene by a simple cut or transition.

script The original text containing all the movie or show information. In animation, the script 
contains all of the location descriptions, dialogue, time and more. A project starts with a 
script.

sequence A series of scenes or shots forming a distinct part of the story or movie, usually 
connected by unity of location or time.

shot A scene in a movie or show. A sequence is composed of several shots. A shot changes 
to another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.

slugging To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing A process that lets you hear sound in real time while you move the playhead forward or 
backward. This is very useful for finely-tuning a lip-sync.

stop-motion 
keyframe 

A keyframe with no computer-generated interpolation.

storyboard A visual plan of all the scenes and shots in an animation. The storyboard indicates what 
will happen, when it will happen and how the objects in a scene are laid out.

straight-ahead 
animation

A technique in which an entire sequence is drawn from the first position to the last, in 
order. There is very little planning in this methodology. Where the character ends up and 
how it gets there can be a surprise for both the audience and the animator. While this 
approach is spontaneous and creative, it can create inaccurate results.

strokes Invisible vector lines forming the drawing zones. They can be adjusted with Bézier 
handles.

symbol A symbol combines animation, artwork or layers into a single object that you can control 
in one layer. You can also create symbols out of each body part in your cut-out puppets.

You can place whatever you want in a symbol. You can use symbols to animate a puppet 
or create reusable animations such as blinking. 

tablet/pen A device used in conjunction with, or instead of, a mouse to move a mouse pointer 
(sometimes referred to as the cursor) around the computer screen.

template An asset stored in the library that can be reused in any project. A template can be a 
drawing, a series of keyframes, a sound file, a panel, a cut-out character, an effect, a 
trajectory, an animation, or anything else used in the animation.

thumbnail A very small image used as a reference or indicator.

timecode The timing information printed on a movie clip to indicate the scene, hour, minute and 
second that is currently displayed on the screen.
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timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and paint After the rough animations have gone through cleanup and a final line or pencil test, each 
drawing is traced and painted for the final animation. In today's digital world, this may be 
done in a variety ways other than the traditional celluloid or acetate methods.

track breakdown The break down of an animated film's soundtrack into individual sounds to produce the 
precise frame-by-frame position of each sound.

traditional 
animation 

A type of animation process whereby all the animation sequences are drawn by hand on 
paper before scanning or inking them on cels.

trajectory A computer-generated path or trajectory that elements can follow. The trajectory can be 
controlled by control points, keyframes and velocity.

transition An effect placed between two scenes as they pass from one to the other. Common 
transition effects are cross-dissolve and wipe.

underlay In animation, an underlay is a specific part of the decor placed behind the main animation.

vector A vector-based image is composed of points and Bézier curves. The computer reads the 
points and traces the segments, linking them to reproduce the image shape. There is no 
fixed size or resolution in a vector image. The graphic can be enlarged and distorted as 
much as desired and the system will simply recalculate the segments and rebuild the 
shapes. Vector images are translated and displayed in pixels once the calculation is 
done.

velocity In animation, the velocity, also known as ease, is the acceleration or deceleration of a 
motion. This can be achieved by a function curve, or via a series of animated drawings. 
Other common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle A series of drawings "on the spot"  that describe the walk for a character. The illusion of 
movement is created by the use of background pans. To avoid making innumerable 
drawings, animators routinely make a walk cycle for a character.

zone An area which can be painted with colour.
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Index
alpha channel  122

animatic  122

animation  122

anime  122

arc  122

aspect ratio  122

auto-feed  122

axis  122

background  122

backing up

palettes  85

Bezier  122

bitmap images  122

Bitmap layer  35

breakdown  123

Camera layer  35

camera shake  123

caption  123

cel  123

celluloid

See cel.  123

character design  123

clean up  123

cloning

layers and columns  42

CMYK  123

Colour-Card

layer  36

colour card  123

colour model  123, 127

colour palettes

back up  85

location  84

colour wheel  123

columns

advanced types  37

changing colour  72

cloning  42

collapsing  69

deleting  38

duplicating  41

expanding  69

modifying  40

navigating  63

properties  39

reordering  41

types  35

Xsheet  34

compositing  123

copying

drawings  67

cross dissolve  123

cut  123

cut-out animation  123

cycle  124

cycles

exposure, creating  60

deleting

drawings  66

dialogue  124

dope sheet  124

doping  124

DPI  124

drawing elements

adding  37

creating  33

duplicating  41

Drawing layer  35

drawings

copying/pasting  67

deleting  66

duplicating  66

importing  8

managing  65

merging  69

navigating  63

renaming  65

scanning  8

duplicating

drawings  66

ease  124

ease-in  124

ease-out  124

Effect layer  36

establishing shot  124

exposure  124

creating cycles  60

decreasing  51

deleting  53

extending  45

extending sequence  46

Fill Exposure mode  43

filling  42

filling empty cells  59

filling selection  57

filling selection randomly  58

filling sequence with single 
exposure  57

holding  45

increasing  51

inserting blank cells  54

moving cells  49

setting  55

typing in values  44

exposure sheet  124

extending

exposure  45

exposure sequence  46
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fade-in  124

fade-out  124

field chart  125

Fill Exposure mode  43

film-1.33  125

film-1.66  125

flipping  125

follow-through  125

forward kinematics  125

frame  125

frame rate  125

frames  31

adding before/after selection  31

navigating  63

functions  125

gamut  125

Group layer  36

HDTV  125

hiding

layers  70

Hold  125

holding exposure  45

HSV  125

importing

bitmap drawings  13

drawings  8

in-between  125

ink and paint  126

interpolation  126

jump cut  126

key pose  126

keyboard shortcuts  126

keyframes  126

Layer Properties editor

displaying  39

renaming layers  40

layers  34, 126

bitmap  35

camera  35

changing colour  72

cloning  42

collapsing  69

Colour-Card  36

deleting  38

drawing  35

duplicating  41

effect  36

expanding  69

Group  36

hiding  70

modifying  40

Peg  36

properties  39

Quadmap  36

renaming  40

reordering  41

showing  70

Sound  37

types  35

layout  126

layout and posing  126

library  126

light table  126

line of action  126

lip-sync  126

auto detection  122

lip-sync detection

manual  127

low resolution  127

manual lip-sync detection  127

master palette  127

merging

drawings  69

model  127

model sheet  See character design

motion keyframe  127

mouth

chart  127

multiplane  127

navigating

columns  63

drawings  63

frames  63

NTSC  127

nudge  127

onion skinning  127

overlay  127

PAL  127

palettes  127

backup  85

creating, Advanced Palette List 
mode)  86

creating, Basic Palette List mode)  86

location  84

style  127

panel  127

panning  127

paperless animation  128

passing position  128

Paste Special

pasting with  67

pasting

drawings  67

path of action  128

Peg layer  36

pegs  128

pen  129

phoneme  128

pivot  128

pixel  128
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pixelation  See bitmap image

pose-to-pose  128

Quadmap layer  36

renaming

drawings  65

rendering  128

resolution  128

RGB  128

rigging  128

rotary table  128

rotoscoping  128

roughs  128

safe area  129

scanning  7

drawings  8

images as bitmap drawings  8

process  7

VectOptions.conf file  24

scenes  129

adding frames before/after 
selection  31

extending  31

removing frames  33

setting length  31

script  129

scrubbing  129

sequences  129

shot  129

showing

layers  70

slow-in  129

slow-out  129

slugging  129

sound

scrubbing  129

Sound layer  37

stop-motion keyframe  129

storyboard  129

straight-ahead  129

strokes  129

tablet  129

templates  129

thumbnails  129

timecode  129

timeline  130

Timeline view

cloning layers and columns  42

expanding and collapsing 
layers/columns  69

modifying layers and columns  40

renaming layers  40

reordering layers  41

timing

adding frames before/after 
selection  31

creating cycles  60

decreasing exposure  51

deleting exposure  53

extending exposure  45

extending exposure sequence  46

extending scenes  31

Fill Exposure mode  43

filling empty cells  59

filling exposure  42

filling selection randomly  58

filling selection with sequence  57

filling sequence with single 
exposure  57

frames  31

holding exposure  45

increasing exposure  51

inserting blank cells  54

moving cells  49

preparing  29

references  30

removing frames  33

scene length  31

setting exposure  55

typing in exposure values  44

trace and paint  130

track breakdown  130

tradigital  128

traditional animation  130

introduction  5

scanning  7

trajectory  130

transition  130

underlay  130

VectOptions.conf file  24

Mac  24

Windows  24

vector  130

vectorization

creating a style  23

parameters, creating  23

parameters, custom  15

parameters, modifying  23

Vectorization Parameters dialog box

Help tab  18

opening  15

Options tab  16

vectorizing

bitmap drawings  13

velocity  124, 130

walk cycle  130

Xsheet view  40

adding frames before/after 
selection  31

advanced column types  37

cloning layers and columns  42

collapsing/expanding 3D path or 
rotation columns  70

columns  34

133



Harmony 12.2 Essentials - Traditional Animation Guide

expanding and collapsing 
layers/columns  69

layers  34

modifying layers and columns  40

removing frames  33

reordering columns  41

zone  130
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