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Chapter 1: Reference 
Harmony has several commands, dialog boxes, and buttons. The Reference section lists all of them along with the 
matching definition. To understand how to use these functions in a production context, read the User guide. 

In the Reference guide, you will learn about the various parameters available in dialog boxes, menus, nodes, 
toolbars, views, and windows. 

The Preferences guide provides additional details about each individual preference. 
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Chapter 2: Dialog Boxes
Dialog boxes contain controls such as options and lists through which you can carry out a particular command or 
task. For example, in the Scene Settings dialog box, you must indicate the resolution and alignment. A typical dialog 
box looks as follows:

Add Column Dialog Box 11

Add Drawing Layer Dialog Box 13

Create Function Step On Dialog Box 14

Create Palette Dialog Box 17

Export to Easel JS Dialog Box 18

Export to QuickTime Movie Dialog Box 20

Export to Sprite Sheet Dialog Box 21

Extend Exposure Dialog Box 24

Fill Cells Randomly Dialog Box 25

Import Images Dialog Box 26

Movie Settings Dialog Box 28

New Scene Dialog Box 29

Paste Preset Dialog Box 31

Paste Special Dialog Box 33

Preferences Dialog Box 35

Scene Settings Dialog Box 36

Resolution Tab 36

Scripts Manager Dialog Box 40

9



Chapter 2: Dialog Boxes     
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Set Ease for Multiple Parameters Dialog Box 43

Sound Settings Dialog Box 45

Standard Video Compression Settings Dialog Box 46

Timeline Scene Marker Dialog Box 48

Tint Offset/Blend  Dialog Box 49

Toolbar Manager Dialog Box 50

Vectorization Parameters Dialog Box 51

Options Tab 51

Help Tab 53
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Add Column Dialog Box
The Add Column dialog box lets you add a column in the Xsheet view.

By default, when you create a new scene, there is one drawing column in the Xsheet view and one corresponding 
drawing layer in the Timeline view.

You can add an element for each drawing and it will appear as a column in the Xsheet view,  a layer in the Timeline 
view.

How to access the Add Column dialog box

 1. Do one of the following:

 l In the Xsheet menu, select Columns > Add Columns. 

 l Click the Add Columns  button. 

 l Press Shift + C.

Parameter Description

Name Lets you give the new column a meaningful name.

Type
Lets you select a type of column to create. Choices include: Drawing, Timing, 
Sound, 3D Path, 3D Rotation, Bezier Curve, Ease Curve, Expression and 
Annotation. 

Drawing Layer Options

Line Art Creates a vector or bitmap drawing column in the Line Art layer. 

Colour Art Creates a vector or bitmap drawing column in the Colour Art layer. 

Element

Create New Element Creates an independent column with its own drawing folder.

Vector
Select this option if you want the layer to contain vector drawings. 
Deselect this  option if you want the layer to contain bitmap images. 
Most of the time, the Vector option will be enabled.

Bitmap Format
Lets you select the type of bitmap image to insert in the column. Select SCAN 
from the list if you are planning to scan drawings using the Toon Boom Harmony 
Scan module.

Scan Type
If you chose SCAN from the Bitmap Format list, select the kind of scanning you 
want to achieve.

Field Chart
When importing traditional animation, lets you indicate the size of paper on which 
the animation or background was drawn. If you are not using perforated animation 
paper, leave the 12 field default value as is.

Use Existing Element

Uses drawings from an existing column in the new column. Both columns will be 
attached to the same set of drawings, but their timing will remain  independent  
from one another. If you modify one of the drawings, it will be modified in both 
columns. This is the same principle as the Clone column.

Name Lets you select the column to which you want to link your new column.
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Add and Close
Adds the selected type of layers to the Timeline view and corresponding column 
in the Xsheet view and closes the dialog box. The names of the layers/columns 
are automatically numbered incrementally.

Add

Adds the selected type of layers to the Timeline view and corresponding column 
in the Xsheet view. The dialog box remains open for you to add as many 
layers/columns as needed. The names of the layers/columns are automatically 
numbered incrementally.

Close Closes the dialog box.
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Add Drawing Layer Dialog Box
The Add Drawing Layer dialog box lets you add a drawing layer  to your project. 

By default, when you create a new scene, there is one drawing column in the Xsheet view and one corresponding 
drawing layer in the Timeline view.

You can add an element for each drawing and it will appear as a column in the Xsheet view,  a layer in the Timeline 
view.

How to access the Add Drawing Layer dialog box

 1. Do one of the following: 

 l In the Timeline view, click the Add Drawing Layer  button.

 l From the top menu, select Insert > Drawing.

 l Press Ctrl + R (Windows/Linux) or ⌘  + R (Mac OS X).

Parameter Description

Name Lets you give the new layer a meaningful name.

Add and Close
Adds the selected type of layers to the Timeline view and corresponding column 
in the Xsheet view and closes the dialog box. The names of the layers/columns 
are automatically numbered incrementally.

Add

Adds the selected type of layers to the Timeline view and corresponding column 
in the Xsheet view. The dialog box remains open for you to add as many 
layers/columns as needed. The names of the layers/columns are automatically 
numbered incrementally.

Close Closes the dialog box.
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Create Function Step On Dialog Box
The Create Function Step On dialog box lets you  hold the same value over a selected number of frames for 
multiple parameters (pos x, scale y, etc.). This works well when you are animating drawings on 2s or 3s, for 
example, and you want to hold the same value for a function over those two or three frames.

How to access the Create Function Step On dialog box

 1. Add the Scripting toolbar to your interface:

 l Go to the top menu and select Windows > Toolbars > Scripting.

 l Right-click on the empty space near the top of the interface  and from the quick-access menu select-
ing Scripting.

 l Right-click on the empty space near the top of a view and from the quick-access menu selecting 
Scripting.

 2. In the Scripting toolbar, click on the Manage Scripts  button to open the Scripts Manager window.

 3. In the Scripts Manager, in the Files section, select the file TB_CreateStepsOn.js.

The functions associated with that file appear in the Functions section.

 4. In the Functions section, select TB_CreateStepsOn.

The Add script to toolbar button becomes active.
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 5. Click on the Add script to toolbar button.

The TB_CreateStepsOn script  button is added to the Scripting toolbar.

 6. Click Apply.

 7. Click OK.

 8. In the Timeline view, select the layer whose parameter values you would like to hold. 

 9. In the Scripting toolbar, click on the TB_CreateStepsOn script  button.

The Create Function Step On dialog box appears.

Parameter Description

Settings

Every Number of Frames Enter in the number of frames you would like to hold your functions.

Selection

First Frame

Enter in the frame number of where you would like the stepped holds to 
start.  The playhead location determines the lowest value you can enter for 
the first frame. You need to move the playhead to frame one if you would 
like to set frame one as the lowest possible starting value. 
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Last Frame
Enter in the frame number of where you would like the stepped holds to 
stop.
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Create Palette Dialog Box
The Create Palette dialog box lets you create a palette in Basic mode. For simple productions, it is recommended to 
use the Basic mode.  This setting stores the palettes automatically for you and saves them at the Scene level. When 
you use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: 
Environment, Job, Scene, or Element. 

How to access the Create Palette dialog box

 1. From the Colour view menu, select Palettes > New or click the New Palette button.

Parameter Description

New Palette Name Lets you enter a name for the new palette.

17



Chapter 2: Dialog Boxes     Export to Easel JS Dialog Box

Export to Easel JS Dialog Box
The Export to Easel JS window lets you flatten an image sequence of your animation. Even if you have a fully 
rigged puppet or a single drawing layer with your animation sequence, the outcome will still be a flattened output 
of each frame, grouped together in your sprite sheet. This allows for more flexibility and freedom of work as you 
have access to any tools or effect modules you want to use. However, this can result in heavier files depending 
on the length, complexity and export size of your animation.

How to access the Export to Easel JS window

 1. Select Windows > Toolbars > Game.

 2. Click the Export to Easel JS  button.

Parameter Description

Select Directory

Save Path The folder path where you want to save your export.

Save Name
The folder name in which you will save your export. This will also be the name 
of your asset in Unity. Your scene file name will be used as the clip name.

Existing Clips in Folder Displays the clips in the folder.

18



Harmony 14 Essentials - Reference Guide

Scene Options

Display

Here, you must select the Display of your character. This is the one that will be 
used to render out all of the information attached to that Display node. If the 
Unconnected_Display option is selected, all of the visual information in your 
scene will be rendered out.

Sprite Sheet Preferences

Max Width This is a value, in pixels, for the maximum width and height the exported sprite 
sheet should be. By default, both values are set to 2048 pixels.Max Height

Expand Sprite Sheet Uses the minimum size necessary up until it reaches the maximum resolution.

Fixed Sprite Sheet
Creates a texture of the specified size (Max Width and Max Height) even if it 
does not fill it up completely by all the drawings in your scene.

Resolution Type

POT: Exports to sprite sheets with sizes that are a power of 2. For example: 
1024 x 1024.  This is optimized for many graphics cards, but consumes more 
memory.

NPOT: Some game engines are optimized specifically to render to non powers 
of two, so that it will avoid those numbers.  Example: 1000 x 1000.

Reuse Frames

This option works in tandem with the Threshold option. The export will 
compare the drawings in your project to reuse a maximum of similar drawings 
and reduce the amount of information found in the sprite sheet, making it 
lighter. The export will omit the creation of new drawings if the difference is 
less than the threshold percentage.

Threshold

Calculates the differences between multiple drawings. A 2% threshold will 
prevent the creation of a new drawing if the drawing is too similar to an existing 
drawing. For instance, with a 2% threshold, and my drawing is 100 pixels big, 
only 2 of those pixels need to be different from my other drawing in order to 
create a new one. The higher the threshold, the fewer similar drawings you will 
have.

Sprite Resolutions Size of the render of the individual sprite, when it exports each drawing out.
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Export to QuickTime Movie Dialog Box
The Export to QuickTime Movie dialog box lets you export your animation as a QuickTime movie. If you want to 
render a QuickTime movie with lossless compression and transparency, you can use the Animation video codec 
with the colour depth set to Millions of Colours +. 

How to access the Export to QuickTime Movie dialog box

 1. From the top menu, select File > Export > Movie.

Parameter Description

Output

Browse
Lets you select a folder in which to save your movie and give it a file name for 
the export.

Export Range

All Exports the entire frame range.

Frames Lets you enter the frame range to export.

Resolution

Resolution list
Lets you select a resolution ratio. If you select Custom, you can enter the 
width and height.

Width and Height Lets you specify the width and height of the resolution.

Options

Movie Options
Opens the Movie Settings dialog box in which you can set the the compression 
settings for the movie you will export—see Movie Settings Dialog Box.
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Export to Sprite Sheet Dialog Box
The Export to Sprite Sheets window export to multiple resolutions, generating multiple .xml files and one or multiple 
sprites sheets depending how many sprite resolutions you defined.

This saves different animations of the same character into the same name. For example, if there's an idle, run, and 
jump animation, these should all share the same Save Name. You can think of it as the overall collection of 
animations. Inside are the different saved scene versions whose drawings you can reuse for all the animations in 
that character set. Each scene version will be displayed as an item in the list.

When you export an animation, only the drawings used in that scene are exported. All the drawings are exported 
individually first and then atlased together into a sprite sheet.

If you saved multiple animations to the same Save Name (i.e. SpaceDuck: run, idle), then it will reatlas the sprite 
sheet to include all the drawings from all the animations in that folder, creating a new animation file, but reusing the 
same skeleton.

How to access the Export to Sprite Sheets window

 1. Select Windows > Toolbars > Game.
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 2. Click the Export to Sprite Sheets  button.

Parameter Description

Select Directory

Asset Path The folder path where you want to save your export.

Asset Name
The folder name in which you will save your export. This will also be the name 
of your asset in Unity. Your scene file name will be used as the clip name.

Existing Clips in Folder

Preview Window
Displays a list of pre-existing clips in the same export folder location, most  
likely exported there from a previous time.

Use Scene Markers to 
Export Clips

Uses scene markers to define the export range, instead of exporting the entire 
scene.

Project Settings

Unit Scale

Lets you change the scale when exporting to Unity to accommodate the size of 
the export without it affecting the Harmony scene. This helps you resize 
assets properly for Unity without having to resize them in Harmony. The basic 
scale is one Animation Field for one Unity unit.

Preset
Lets you select the unit conversion from Harmony to Unity, by selecting one of 
4 presets. Note: a field is a unit of measure in traditional animation grid.

Sprite Sheet Preferences

Max Width
This is a value, in pixels, for the maximum width and height the exported sprite 
sheet should be. By default, both values are set to 2048 pixels.

Max Height
Makes linear values for interpolation. This increases the amount of memory 
used but frees up the calculation so it is not done on the fly.

Expand Sprite Sheet Uses the minimum size necessary up until it reaches the maximum resolution.

Fixed Sprite Sheet
Creates a texture of the specified size (Max Width and Max Height) even if it 
does not fill it up completely by all the drawings in your scene.

Resolution Type

POT: Exports to sprite sheets with sizes that are a power of 2. For example: 
1024 x 1024.  This is optimized for many graphics cards, but consumes more 
memory.

NPOT: Some game engines are optimized specifically to render to non powers 
of two, so that it will avoid those numbers.  Example: 1000 x 1000.

Reuse Frames

This option works in tandem with the Threshold option. The export will 
compare the drawings in your project to reuse a maximum of similar drawings 
and reduce the amount of information found in the sprite sheet, making it 
lighter. The export will omit the creation of new drawings if the difference is 
less than the threshold percentage.

Threshold Calculates the differences between multiple drawings. A 2% threshold will 
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prevent the creation of a new drawing if the drawing is too similar to an existing 
drawing. For instance, with a 2% threshold, and my drawing is 100 pixels big, 
only 2 of those pixels need to be different from my other drawing in order to 
create a new one. The higher the threshold, the fewer similar drawings you will 
have.

Sprite Resolutions Size of the render of the individual sprite, when it exports each drawing out.

Delete Existing Clips Select this option to delete any pre-existing clips in the export location.

Bake Animation Curves
Makes linear values for interpolation. This increases the amount of memory 
used but frees up the calculation so it is not done on the fly.

Clear Texture Folder
Removes any information from the texture folder within the Harmony file. This 
has no incidence towards the Unity export but contributes to a lighter Harmony 
file.
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Extend Exposure Dialog Box
The Extend Exposure dialog box lets you extend the exposure of a selected cell in the Timeline or Xsheet. 

How to access the Extend Exposure dialog box

 1. Select a cell and do one of the following:
 l From the top menu, select Animation > Cell > Extend Exposure.

 l Press F5.

The Extend Exposure dialog box opens.

Parameter Description

Extend to Frame
Lets you enter the frame up to which you want to extend the exposure. You can 
expose the drawing in the frames and replace the drawings that were originally 
there or move the subsequent frames forward in time.

Overwrite
Lets you expose the drawing in the frames and replace the drawings that were 
orginally there.

Insert
Lets you expose the drawing in the frames and move the subsequent frames 
forward in the Timeline view.
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Fill Cells Randomly Dialog Box
The Fill Cells Randomly dialog box lets you Lets you fill in random values over a selection. You can give a maximum 
and a minimum value and create a range for Harmony to choose the random values from. The selection can be over 
one cell or a cell range in one column or more or an entire column or many entire columns.

How to access the Fill Cells Randomly dialog box

 1. Do one of the following:

 l Select Animation > Cell > Fill Cells Randomly.

 l In the Xsheet view, click the Fill Cells Randomly  button  (you may have to customize the 
toolbar to display it).

The Fill Cells Randomly dialog box opens.

Parameter Description

Minimum Value The lowest value to be used in the randomized exposure or keyframe value.

Maximum Value The highest value to be used in the randomized exposure or keyframe value.

Hold The exposure holding value.

Whole Numbers
If you are applying this to a drawing column, this option lets you avoid having 
decimal points.

Add Key Exposure After Inserts a key exposure on the frame following the last cell of the selection.
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Import Images Dialog Box
T-HFND-007-011

The Import Images dialog box lets you  import bitmap images and vectorize them, making the images editable. 
Then you can use a variety of drawing tools to edit the image. Or you can always keep the original bitmap image 
as is.

Also, you can choose to import bitmap images on bitmap or vector layers depending on your project..

How to open the Import Images dialog box

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.

Parameter Description

Files

Browse Lets you find and select images on your computer.

Layer

Create Layers(s) Create layers for imported images.

Create Single Layer 
Named

Creates a new layer with the specified name and imports the images into it.

Create Layer(s) Based 
on Filenames

Creates a layer based on each unique filename prefix. For example, if you 
import three files named a-1.tga, a-2.tga and b-1.tga, this will create two 
layers, one named "a" and one named "b". Layer "a" will contain the two first 
images and "b" will contain the third one.

Add to Existing Layer Imports the images into the specified layer. Note that you can only import into 
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layers that are compatible with your import options. For example, if you're 
importing images as vector drawings, you can only import them into vector 
drawing layers. 

Vectorization

Vectorize Image Imports a drawing and converts it to a Toon Boom vector drawing.

Colour Imports bitmaps as vector objects with their image as a texture. 

Black and White
Vectorizes drawings with a solid black line. This creates a 100% vector-based 
drawing and paints it with the Vectorized Line colour swatch from your scene's 
palette.

Threshold
Determines what values in the scanned image will be considered as part of the 
drawing, and what will be ignored and eliminated in the vectorized drawing. The 
lower the value, the darker the image and vice versa.

Smooth
Determines how smooth the lines will be. The lower the value, the more detail 
will be retained. The higher the value, the more polished and easy to edit the 
lines will be.
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Movie Settings Dialog Box
The Movie Settings dialog box lets you set the compression settings for the movie you will export.

How to access the Movie Settings dialog box

 1. From the top menu, select File > Export > Movie.

 2. In the Export to QuickTime Movie dialog box that opens, click Movie Options.

Parameter Description

Video

Settings
Opens the Standard Video Compression Settings dialog box. This is where 
you can set the video compression settings for the movie you will export—see 
Standard Video Compression Settings Dialog Box on page 46.

Filter
Opens the Choose Video Filter dialog box, where you can select from a range 
of filters to apply to your video export.

Size
Opens the Export Size Settings dialog box. The size settings are overridden by 
the Harmony's scene settings.

Sound  

Settings
Opens the Standard Video Compression Settings dialog box. This is where 
you can you set the sound compression settings for the movie you will export—
see Sound Settings Dialog Box on page 45.
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New Scene Dialog Box
The New Scene window lets you create a new scene.

How to access the New Scene window

 1. Do one of the following:

 l From the top menu, select File > New. 

 l In the File toolbar, click the New  button. 

 l Press Ctrl + N (Windows/Linux) or ⌘  + N (Mac OS X).

The New Scene dialog box opens.

Parameter Description

Name Lets you type in a name for the new scene.

Location Lists the locations you used most frequently for storing scenes.

Browse
Opens a browser in which you can specify a location for the new scene that is not 
listed in the Location list.

Camera Size Opens a list of resolutions.

+ (Create Custom Resolution)
Opens the New Resolution window in which you can create a custom resolution 
that is added to the Camera Size list.

- (Delete Custom Resolution) Lets you remove a custom resolution from the Camera Size list.

Width Indicates the width of the resolution you chose from the Camera Size list.
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Frame Rate Indicates the frame rate of the resolution you chose from the Camera Size list.
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Paste Preset Dialog Box
When pasting key frames and exposures, you can modify the existing presets to your liking. There are three presets 
you can modify: the default presets for both key frames and exposures, key frames only and exposures only.

Parameter Description

Drawings

Add/Remove Exposure

 

Never create drawing files: When adding exposures to a drawing layer, drawing 
files will not be created.

Only create drawing files when they do not exist: When adding exposures to a 
drawing layer, new drawings will be created only when drawings with the same 
name do not already exist in the destination.

Always create drawing files: When adding exposures to a drawing layer, new 
drawings will always be created. If drawing files with the same name already 
exist, Harmony will create a new name for the drawing.

Enforce Key Exposure
If there are key exposures that exist on copied drawings, they are preserved when 
pasting. No key exposures are added. This is the default behavior when pasting.

Fill Gap with Previous 
Drawing

Fills selected area in the Xsheet or Timeline view with the previous drawing.

Fill to Next Key 
Exposure

Fills selected area till the next key exposure.

Keyframes

Add/Remove 
Keyframes

Motion: Copies the properties of the selected motion keyframe to the new frame.

Velocity: Copies the properties of the selected velocity keyframe to the new 
frame.

Rotation: Copies the properties of the selected rotation keyframe to the new 
frame.

Scale: Copies the properties of the selected scale keyframe to the new frame.

Skew: Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at Function's Beginning and End: Adds a keyframe to the 
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beginning and end of the pasted function, reproducing the source function.
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Paste Special Dialog Box
The Paste Special dialog box lets you determine how templates and symbols are imported in the Timeline view. 

When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You can 
choose to import only the keyframes without the drawings or import only the drawings that are not already in your 
layers. You can adjust the behaviour using the Paste Special dialog box.When you import a symbol in your scene, 
its full length is exposed by default. If you import a symbol in the Timeline view’s left side, all the frames will be 
exposed. However, if you import it into an existing layer, you can use the Paste Special dialog box to adjust the 
import behaviour to fit your requirements.Once you set the parameters, Harmony will reuse them each time you 
import a symbol in the Timeline view’s right side until you set new parameters.

How to access the Paste Special dialog box

 1. In the Library view, select the symbol or template to import.

 2. Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X) and drag the selection to the Timeline view.

NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

Parameter Description

Drawings

Do Nothing Does not create or overwrite drawings.

Add/Remove Exposure

Never create drawing files: When adding exposures to a drawing layer, drawing 
files will not be created.

Only create drawing files when they do not exist: When adding exposures to a 
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drawing layer, new drawings will be created only when drawings with the same 
name do not already exist in the destination.

Replace existing drawings. Create drawing files when they do not exist: 
Replace drawings with the same names to update a scene with new modified 
drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a 
template,  such as when placing new drawings after the animation, 
then delete the template's animation.  It will still have updated the 
drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new 
drawings will always be created. If drawing files with the same name already 
exist, Harmony will create a new name for the drawing.

Symbols

Copy symbols if they 
do not exist

This is the default setting for this operation and will prevent Symbols in an Action 
template from being copied.

Duplicate symbols
Creates a duplicate of the symbol instead of linking the Symbol instance to the ori-
ginal one. The new Symbol is created in the Library.

Paste all Frames of the 
symbol (full movie)

When enabled, the Paste Special command exposes all the symbol's frames 
instead of only the first one.

Add Remove/Keyframes

Motion Copies the properties of the selected motion keyframe to the new frame.

Velocity Copies the properties of the selected velocity keyframe to the new frame.

Rotation Copies the properties of the selected rotation keyframe to the new frame.

Scale Copies the properties of the selected scale keyframe to the new frame.

Skew Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at 
Function's Beginning 
and End

Adds a keyframe to the beginning and end of the pasted function, reproducing the 
source function.

Cycles

Cycle Type

Normal (forward): Pastes your selection as is, starting with the first cell and 
ending with the last.

Reverse: Pastes your selection in reverse, starting with the last cell and ending 
with the first.

Forward > Reverse: Pastes your selection as a yo-yo, starting with the first 
cell, going to the last one and ending with the first cell.

Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with the 
last cell, going to the first one and ending with the last cell.

Number of Cycles Lets you set the number of cycles.
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Preferences Dialog Box
The Preferences dialog box lets you adjust preferences to suit your work style, allowing you to work more efficiently.

NOTE: To learn more about the individual preferences, refer to the Preferences guide.

NOTE: Some preferences require you to exit and restart the application, or close a view and reopen it.

How to access the Preferences dialog box

Do one of the following:

 l Select Edit > Preferences (Windows/Linux) or Harmony Essentials > Preferences (Mac OS X). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).
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Scene Settings Dialog Box
The Scene Settings dialog box lets you parameters for your scene. 

When you created your new scene, you set up the resolution and the alignment. However, if you want to change 
these initial settings later, you can do it using the Scene Settings dialog box. The different Scene Settings options 
are separated into four tabs.

How to access the Scene Settings dialog box

 1. Select Scene > Scene Settings.

The Scene Settings dialog box opens.

 

Resolution Tab
 

Parameter Description

Resolution Presets

You can select your project’s resolution (camera frame size) from this preset 
list.

‣ HDTV: High definition television delivers a higher quality image than 
standard television (4:3) does, because it has a greater number of lines 
of resolution. To take advantage of the superior quality your output 
device must be compatible with HDTV technology to make this 
resolution setting useful.

‣ HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to 
how the images will be aligned in relation to the actual scene frame 
(default 4:3 grid). Note that the camera resolution and the scene frame 
are not the same. When working with 12 or 16 field drawing grids, the 
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grid is a different aspect ratio from the camera frame. When you fit 
vertically, you fit the images with the top and bottom of the scene grid.

‣ film-1.33: Use this resolution setting for the academy film format that 
conforms to the standard 4:3 aspect ratio.

‣ film-1.66:  Use this resolution setting for the widescreen film format that 
conforms to the 16:9 aspect ratio.

‣ film-1.66_Vertical: This is essentially the same as film-1.66. Refers to 
how the drawing is fit into the scene frame. When working with 12 or 16 
field drawing grids, the grid is a different aspect ratio from the camera 
frame. When you fit vertically, you fit the images with the top and 
bottom of the scene frame.

‣ NTSC: This is the standard analogue television broadcasting system 
used in North America and conforms to the North American standards 
on how rectangular pixels are displayed for computer and television 
screens.

‣ PAL: This resolution works best with the European format for television 
and computer screens, as the rectangular pixels are displayed at a 
different orientation.

‣ Low: This format is ideal for videos destined for the web, where size 
and fast download of a video file might take precedence over quality.

‣ Cloud Preview: This is the resolution used by Web Control Center to 
create its preview.

Selected Resolution Preset Displays the selected resolution preset.

Save Resolution Setting

Click the Save Resolution button after you define your new resolution to save it 
as a preset.

If you are working in Harmony Server, you will be prompter a dialog box asking 
you to name the new resolution as well as the level at which you want to save 
the resolution,conf file.

Pixel Dimensions

Displays the pixel dimensions for your project resolution.

If you decide to type in the pixel dimensions, or use the up and down arrows to 
change the pixel increments, you will have to save your custom selection in 
order to save it as a new preset. It will then appear in the resolution selection 
list. It doesn't modify the current resolution preset.

Aspect Ratio
Displays the ratio between the horizontal and vertical dimensions of the 
camera framing. Each resolution setting has a preset aspect ratio that cannot 
be changed.
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Frame per second

Sets the frame rate for your project. The higher the frame rate, for example 30 
fps, the faster the animation will play. The lower the frame rate, for example 12 
fps, the slower your animation will play. Avoid going under 12 frames per 
second as your animation will have a choppy playback. The human eye 
requires a minimum of 12 frames per second to perceive a fluid animation.

Field of View

Use these options to define the FOV (field of view) of the camera (angle of the 
camera cone) and how the drawing elements (and drawing grid) align to the 
scene grid. The drawing grid is always scaled proportionally to a 4:3 ratio 
(unless you change the scene alignment), therefore changing the Field of View 
setting may not show a visible difference if your project resolution is also 4:3, 
such as NTSC.

 l Horizontal Fit: The camera resolution is set to fit the left and right 
edges of the scene grid.

 l Vertical Fit: The camera resolution is set to fit the top and bottom edges 
of the scene grid. 
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NOTE: If you change your scene‘s alignment from 4:3 12 Fields to Square 12 Fields part way though your pro-
ject, you may find that the animation grid becomes offset. To correct this, choose the following setting from the 
Layer Properties panel‘s Advanced tab: Alignment > Alignment Rule > Centre First Page.
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Scripts Manager Dialog Box
The Scripts Manager dialog box lets you link a script to a toolbar button for quick and easy access. Once you 
select a script, you can add it to the toolbar, load a custom icon and add a tooltip.

How to access the Scripts Manager Dialog Box

 1. In the Scripting toolbar, click the Manage Scripts  button.

The Scripts Manager dialog box opens.

 

Parameter Description

Files A list of the available JavaScript files.

Functions A list of the available functions for the selected script.

In Toolbar Adds the selected script to the toolbar.

Execute Runs the script you selected. Press Esc to interrupt the execution of the script.

Customize Icon Lets you load a custom icon for the function. You can browse for a *.png, 
*.jpg or *.xpm file.

Customize Tooltip Lets you type in a tooltip for the function. When you hover over the button in the 
toolbar, your tooltip will appear.
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Select Colour Dialog Box
The Select Colour dialog box lets you set the colour of layers and columns.  Using colours for layers and columns 
helps to differentiate them visually, making them easy to identify. 

You can select a colour by choosing from a basic set of colours, using the colour wheel or by specifying the HSV or 
RGB values. Once you have selected a colour, you can adjust its intensity and save it as a custom colour that you 
can reuse.

How to access the Select Colour dialog box in the Timeline view

 1. In the Timeline view, click the Change Track Colour  button of the layer you want to modify. 

The Select Colour dialog box opens.

How to access the Select Colour dialog box in the Xsheet view

 1. In the Xsheet view, select one or more columns to modify.

 2. Right-click on the column’s header and select Colour > Change Columns Colour.

The Select Colour dialog box opens.

 

Parameter Description

Basic colours A basic set of colours to choose from.

Custom colours
Displays the custom colours you previously stored using the Add to Custom 
Colours button.

Add to custom colours Lets you add the selected colour to the Custom colours list above.

Colour wheel Lets you select a colour by dragging the T-shaped pointer.

Value slider Once you select a colour, you can drag the slider to change the intensity and see 
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it previewed in the Colour Preview window below.. 

Colour Preview Displays the colour you are currently selecting. To apply the colour, click OK.

Hue, Saturation, Value
Lets you set the hue (colour), saturation (amount of colour) and brightness (value) 
of the colour.

Red, Green, Blue Lets you set the red, green and blue values.
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Set Ease for Multiple Parameters Dialog Box
The Edit Set Ease for Multiple Parameters dialog box lets you apply ease to multiple functions and keyframes. You 
can display the function curve and modify the Bezier or Ease curve.

How to access the Set Ease for Multiple Parameters dialog box

 1. In the Timeline view, select a keyframe on one or more layers.

 2. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 

Parameter Description

Filters

Motion

 

Motion: Applies the easing parameters to the selected Position X, Position Y, 
Position Z and 3D Path functions.

Rotation: Applies the easing parameters to the selected Angle functions.

Scale: Applies the easing parameters to the selected Scale functions.

Skew: Applies the easing parameters to the selected Skew functions.

Morphing: Applies the easing parameters to the selected Morphing Velocity 
functions. Note that it applies to the Morphing velocity function found in the Layer 
Properties window, not the basic morphing ease in the Tool Properties view.
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Other: Applies the easing parameters to all the other the selected functions, such 
as all functions created to animate effect parameters.

Left and Right Time Ratio
Lets you type the percentage value corresponding to the length of time you want 
the easing to last. Stay between 0% and 100%. If you go beyond 100%, your 
motion will overshoot. 

Left and Right Value Ratio
Lets you type the percentage value of how strong you want the easing out to be. 
Stay between 0% and 100%. If you go beyond 100%, your motion will overshoot. 

Apply/Previous
Applies the easing parameters to the selected keyframes and then selects the 
previous keyframe in the timeline.

Apply Applies the easing parameters to the selected keyframes.

Apply/Next
Applies the easing parameters to the selected keyframes and then selects the 
next keyframe in the timeline.

Close Close the dialog box. If you did not apply the modifications, they will be cancelled.
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Sound Settings Dialog Box
The Sound Settings dialog box lets you set the compression settings for the movie you will export.

How to access the Sound Settings Dialog Box

 1. From the top menu, select File > Export > Movie.

 2. In the Export to QuickTime Movie dialog box that opens, click Movie Options.

 3. In the Movie Setting dialog box that opens, click Settings in the Sound section.

 

Parameter Description

Compressor

Lets you select a compression type. The default setting is None. This exports 
your audio as is without performing any lossy compression or conversion, 
preserving its fidelity. Other compressors can be used if you need your movie's 
audio track to be exported in a specific format, or if disk space or download speed 
is critical, but they may impact the quality of your movie's soundtrack negatively. 

Rate

Lets you select the audio rate at which to export.                          It is best to export your audio at 
a rate that matches the rate of your original sound files. For example, if your file 
has an audio sample rate of 48 kHz and you choose a conversion rate of 22.05 
kHz, the sound will play at the same speed, but higher frequencies will be 
missing, making it sound muffled. For reference, the standard sound quality is 
44.1 kHz for films, and 48 kHz for DVD. Lower rates are liable to impact the 
quality of your movie's soundtrack negatively, but they can be useful if disk space 
or download speed is critical.

Size

Lets you select the encoding size. Also known as Bit Depth, this determines the 
amount of precision used to record each wavelength in the soundtrack. The 
standard size is 16-bit. If you choose 8-bit, the amount of disk space your sound 
track requires is halved, but the audio will sound muffled.

Use

Lets you decide whether to use the Mono or Stereo channel mode.  Stereo sound 
has a separate sound track for the left and the right speakers, allowing to make 
the origin of each sound realistically match the origin of their corresponding 
action. If you choose Mono, your sound track may use less disk space, but both 
the left and right channels will be merged into a single track. 
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Standard Video Compression Settings Dialog Box
The Standard Video Compression Settings dialog box lets you set the compression settings for the movie you will 
export.

How to access the Standard Video Compression Settings Dialog Box

 1. From the top menu, select File > Export > Movie.

 2. In the Export to QuickTime Movie dialog box that opens, click Movie Options.

 3. In the Movie Setting dialog box that opens, click Settings in the Video section.

 

Parameter Description

Compression Type
Lets you select a codec. The availability of certain compression settings 
depends on the Compression Type selected. For example, Animation is the 
default compression type and as a result the Data Rate option is greyed out. 

Motion

Frame Rate

Lets you select a frame rate. By default, it is set to match the frames-per-
second (fps) of your Harmony project. If you choose a lower frame rate, your 
export playback will be faster than your actual project. The reverse is also true 
for a higher frame rate. 

Key Frames

Automatic: 

Every: Inserts keyframes. This is the option is recommended by QuickTime. 
For further details, refer to the QuickTime documentation.

All: 

Frame Rendering: 

Frames: Lets you set the number of keyframes to insert.
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Compressor

Depth
Lets you select a depth based on your movie’s needs. For example, Millions of 
Colours+ houses an alpha channel.

Quality
Lets you choose a quality setting. The higher the quality of the export, the 
larger the resulting file.

Data Rate

Date Rate

Automatic: Lets the system automatically select the most optimal bit rate.

Restrict To: Lets you enter a rate to save space and allow for faster 
downloading at a cost to the quality of the export. 

Optimized For: Lets you select the intended viewing method.

Preview Displays a preview of the movie to be exported.
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Timeline Scene Marker Dialog Box
The Timeline Scene Marker dialog box lets you create and manage scene markers in the Timeline view. Scene 
markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can use it to 
denote anything relevant to your work. You can indicate the frames you want to clean up, a change in action, an 
impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is displayed 
when you hover over the scene marker.

How to access the Timeline Scene Marker dialog box

 1. In the frame counter area of the Timeline view, do one of the following:

‣ Drag to select the frame range to mark.

‣ Right-click and select Scene Markers > Mark Current Frame.

Parameter Description

Colour swatch
Opens the Mark Colour dialog box where you can select a colour for the scene 
marker.

Note (Tooltip)
Lets you type in a name for your scene marker. Making the name meaningful 
will help you to quickly identify scene markers especially when there are many 
of them in the frame counter area of the Timeline view.
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Tint Offset/Blend  Dialog Box 
You can offset, blend, or mix the colours in a colour palette using the sliders and increasing the Amount value.

How to access the Tint Offset/Blend dialog box

 1. From the Colour View  menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.

 

Parameter Description

Offset
Offsets the selected colours by the adjustments made using the HSB and RGB 
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider 
to adjust the opacity of the selected colour. 

Blend

Blends the selected colours with the colour swatch in the top-right corner. Use the 
Amount slider to adjust the degree of blend. A blend of 100% turns the selected 
colours into the same colour as the swatch. Adjusting the HSB and RGB sliders 
affect the swatch colour, which in turn affects the selected colours on the left. 
Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use the slider just 
beneath to mix the Base and Tint colours by different amounts. This will affect the 
mixed swatch whether it is selected or not. Select either the Tint or Base swatch 
and use the HSB and RGB sliders to adjust its colour. This will affect the mixed 
swatch colour, which in turn affects the selected colours on the left.
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Toolbar Manager Dialog Box
The Toolbar Manager dialog box lets you customize the toolbar in any of the views. You can add your favourite 
tools to a toolbar for an efficient workflow.

How to access the Toolbar Manager dialog box

 1. Right-click on a toolbar in any view and select Customize. Note that the menu will not appear if you right-
click on a disabled icon.

 

Parameter Description

Available Tools Displays the complete list of tools available for customizing a toolbar.

Toolbar Displays a list of the tools currently available on the toolbar.

Default Restores the toolbar with its default items.
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Vectorization Parameters Dialog Box
The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green pencil 
marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure red, blue, 
green and black (RGB values), while creating colour art zones wherever lines connect. After painting in your tones 
and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker window and watch the 
indicator colour zone lines disappear.

How to open the Vectorization Parameters dialog box

 1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization parameters 
(i.e. from the scanner).

 2. In the Scan Drawings window, do the following:

 l In the Layer section, decide on the layer options.

 l In the Import Options section, select the Convert to Toon Boom Vector Drawing option

 l Click Preview.

 3. In the Vectorization section, click the Vectorization Parameters button.

 

Options Tab
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The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter Description

Input The input filters are applied to the bitmap image before it is vectorized.

One Pass
One threshold value is applied to both the Line and Colour Art. For drawings 
with distinct vector-style lines of mattes, you only need one pass.

Two Passes
Applies a different threshold value to each layer. For greyscale drawings, you 
may want to perform the vectorization process twice to apply different 
threshold values to the Line and Colour Art layers.

Threshold
Determines which values in the scanned image are considered part of the Line 
and Colour Art layer and what will be eliminated from the vectorized drawing; 
0% is white and 100% is black. The threshold is between these two values.

Expand Bitmap
Lets you enter a value to scale the bitmap to detect small variations in the line. 
Use this option if you scanned a greyscale image and want to preserve small 
variations in the texture to apply to the line art.

Jag Filter
Lets you enter a value to scale back the bitmap to remove some of the line’s 
roughness. This is useless when you have a drawing that appears quite rough; 
the Jag filter will eliminate excess strokes in the final drawing.

Line Art Threshold (%)
Determines which values in the scanned image are considered part of the Line 
Art layer and what will be eliminated from the vectorized drawing; 0% is white 
and 100% is black. The threshold is between these two values.

Colour Art Threshold 
(%)

Determines which values in the scanned image are considered part of the 
Colour Art layer and what will be eliminated from the vectorized drawing; 0% is 
white and 100% is black. The threshold is between these two values.

Output The output filters are applied during the vectorization process.

No Colour Art Does not generate filling zones in the Colour Art layer.

No Texture
Does not generate texture in the Line Art layer in the final images. Select this 
option to create solid lines in the final line art.

Generate Matte in 
Underlay Layer

Creates an opaque zone behind your drawing’s lines to avoid seeing through 
the layers.

Colour as Texture Converts colour values into a texture layer.

Optical Registration The optical registration options are used to automatically align drawings based 
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on the position of the peg holes on the animation paper. The peg holes must 
appear in the scanned drawings for the optical registration to work.

DPI
Lets you enter the dots-per-inch value of your image. You must enter the same 
value as the DPI used to scan the image.

Peg Side
Lets you select the position of the peg holes on your drawings. Identify whether 
they are on the top, bottom, left or right.

Strictness

Determines how exact the location of the peg holes must be for the software to 
recognize them. There are two values to choose from:

Strict: The peg holes must be in a tightly defined area to be recognized.

Loose: The peg holes can be recognized somewhere in a larger area. This is 
the recommended setting.

Field Chart Lets you indicate the size of the animation paper, 12 or 16.

Post Processing The Post Processing filters are applied to the final vector images.

Remove Holes Removes holes of a specified value that might make painting difficult.

Remove Dirt Removes stray marks and dirt of a specified value. Try a value around 500.

Remove Hair Size Removes small strokes that have no line art.

Remove Hair: Number 
of Passes

The number of times the drawing will be analyzed to identify hair marks.

Miscellaneous

Close Gaps Closes gaps in the Colour Art so you can paint it.

Smooth Passes for Line 
Art Before Breaking 
Triangles

The number of times the smoothing operation runs before creating the triangles 
that break lines in the drawing. If unnecessary triangles are appearing in the 
drawing, increase this value.

Smooth Passes for Line 
Art

The number of times the smoothing operation is performed after the triangles 
have been created. This further smooths the line art.

Preview

Show Strokes Shows the strokes in the Vectorized Image panel.

Stroke Thickness Shows the size of the strokes.

 

Help Tab
The Help tab contains the most advanced vectorization settings which you type in the Advanced Option fields at the 
bottom of the Vectorization Parameters dialog box.
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File IO Options

-file <filename (including extension)> [ options ]

-infile <filename (including extension)>; same as -file

-outfile <filename>; alternate output file

-informat <format>; the input format. Used if reading from stdin

-debug; turn on debug mode

-noforce; don't force output if image is inconsistent

-version; print version information and quit

-output_version <version>; output files of this version. Valid versions can be: 0 or 604

-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options 

-register <dpi side strictness>; perform optical registration.

• Side can be one of left, right, top, bottom or l, r, t, b.

• Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page

-rcph; short form of register_center_peg_holes

-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)

-rlf; short form of registration_looseness_factor

-rdebug; output registration debug messages

-pegpitch <inch (default 8.000000)>; distance between peg bars

-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0

-rmargin <inch (default 1)>; region size where to look for peg bars 

-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image 
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-pdfc; short form of -peg_distance_from_center 

-out_peg_position <side (default same)>; wanted position of the peg on the drawing.

• Can be one of right, left, top, bottom (or r, l, t, b) or same.

• A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.

-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options 

-pixel <pixel_shape (default '4x3')>; Valid values: 4x3

-gap <worldUnits (default 10)>; close gaps up to this big

-pencil; generate line art only

-keep_dirt; don't filter out dirt

-thresh <threshold (default 0.2)>; range 0.0 to 1.0

-rmv_hairs <worldUnits (default 1)> <passes (default 1)> 

• remove hairs of size smaller than "size" in "passes" passes 

-rmv_holes <area (default 7)>; remove holes smaller than "area" 

-rmv_dirt <area (default 1)>; remove dirt smaller than "area" 

• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels" 

• distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes

-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour

-noclosegap; disable all gap closing algorithms

-no_break; disable the breaking of line art

-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap

-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap

-fit_errorc <error (default 1.000000>; fitting error for the colour art

-fit_errorl <error (default 1.000000>; fitting error for the line art

-smoothl <passes (default 1>; number of smooth passes for line art

-smoothc <passes (default 1>; number of smooth passes for colour art

-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles

-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -2pass)

-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"
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(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,

-rmv_holesc, -rmv_dirtl and -rmv_dirtc)

-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0

-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0

-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art

-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art

-rmv_holesl <area (default 7)>; remove line art holes smaller than "area" 

-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area" 

-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area" 

-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area" 

try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are in 
world units squared 

-margins <inch (default 0.25)>; remove margin around bitmap 

-top_margin <inch (default 0.25)>; remove margin at top of bitmap 

-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap 

-left_margin <inch (default 0.25)>; remove margin at left of bitmap 

-right_margin <inch (default 0.25)>; remove margin at right of bitmap 

-remove_peg_bars; remove the peg bar holes

-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size

-fs; short hand for -field_size

-peg_bar_size <inch (default 1)>; the size of the peg bar region

-noframe; do not put a frame around the colour art

-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art

-downscale_input <default 1>; downscale the raw input by this integer factor

-downscale_texture <default 1>; downscale the output texture by this integer factor

-buildmatte; generate a matte on underlay for line test

-buildmatte_colourart; generate a matte on colour art for line test

NOTE: -buildmatte and -buildmatte_colourart are mutually exclusive

-copystrokes; copy original strokes when building matte.
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Options for bitmap that has no registration information 

-pixel_margins <inch (default 0)>; remove margin around bitmap 

-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap 

-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap 

-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap 

-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap 

-dpi <(default -1)>; dpi information of input bitmap 

RGB Keying Options 

-rgb; generate separate zones for red, green and blue lines

-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value

-no_red; ignore red colour in vectorization

-no_green; ignore green colour in vectorization

-no_blue; ignore blue colour in vectorization

-flatten; flatten the drawing after generating colours

-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area

-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb

-threshrgb <value> <threshold for rgb vectorization default 0.200000>;

-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on saturation and 
value to consider a pixel to be grey

Colour Vectorization Options 

-color_vectorize; perform a colour vectorization

-file2 <colour art filename>; specify the colour art bitmap

-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect (0.0-1.0)> 
<edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap file (valid filename or "" if no 
file)>; generate brush texture for the line art

-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max variation (0.0-
1.0)>; specify a pressure strategy for the centre line. 

-blur_radius <pixels (default 0)>; blur the penstyle texture generated

-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour before 
computing texture

-ccsp <times (default 3)>; short for -color_contour_smooth_passes

-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing texture

-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art
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Bubble Usage (implemented only for colour vectorization's line art)

-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only 

-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles

-bubble_length <value (default 10)>; max number of circles in a bubble

-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness (must be >= 
1.0)

-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness (must be 
>= 1.0)

-uniform_gap; the space between bubbles is constant 

4 Colour Vectorization

-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:

rgbdiff:value ; between [0.0-1.0] or [0-255]

dark:value    ; between [0.0-1.0] or [0-255]

grey:value    ; between [0.0-1.0] or [0-255]

white:value   ; between [0.0-1.0] or [0-255]

dirt:value    ; dirt area. 200 is a good value

rt:value      ; between [0.0-1.0] or [0-255]

gt:value      ; between [0.0-1.0] or [0-255]

bt:value      ; between [0.0-1.0] or [0-255]

NOTE: There must be no space between the colon and the key/value. For example: -4colours rgbdiff:20 
dark:20 grey:120 white:250 dirt:200 rt:240 gt:240 bt:240
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Chapter 3: Menus
The Menus section covers all the menu entries available in Harmony. There are several types of menus in Harmony: 
main menus, quick-access menus and view menus. Menus contains most of the functions available. They may also 
have a toolbar button or keyboard shortcut equivalent.

Main Menus 60

Animation Menu 61

Drawing Menu 64

Edit Menu 66

File Menu 68

Help Menu 70

Insert Menu 71

Play Menu 72

Scene Menu 73

View Menu 74

Windows Menu 77

Quick-access Menus 78

View Menus 79

Colour View Menu 80

Function View Menu 82

Library View Menu 84
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Main Menus
The main menu contain most of the commands. Depending on the view you're working in and the element, some 
commands are available and others not. The main menu is always located at the very top of the interface.

On Mac OS X, there is also a Harmony Essentials category that contains the following commands: Preferences, 
About, and Quit.

Animation Menu 61

Drawing Menu 64

Edit Menu 66

File Menu 68

Help Menu 70

Insert Menu 71

Play Menu 72

Scene Menu 73

View Menu 74

Windows Menu 77
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Animation Menu
The Animation menu lets you access tools, adjust animation timing, set  and  parameters, lock or unlock layers, and 
select elements in the Xsheet and Timeline views.

How to access the Animation menu

 l At the top of the interface, select Animation.

Command Description

Animate

Enables the Animate mode which records the position, rotation, scale, 
skew, etc. of objects as keyframes in the Timeline view. Turn off the 
Animate mode to reposition objects for the entire scene. When the 
Animate mode is disabled, keyframes are not created when an object's 
parameters change.

Stop-Motion Keyframe

Sets a stop-motion keyframe which there is no computer-generated 
motion between two keyframes. The segment is constant or flat. The 
drawing remains still until the playback reaches the next keyframe, 
then the drawing pops to its new location.

Delete Keyframe Deletes the selected keyframes.

Tools

Transform
Lets you create a global selection so you can reposition, scale, rotate 
and skew as one unit, which is useful for cut-out characters.

Translate Lets you move the selected element along the X and Y axes.

Rotate Turns a selected element around its pivot point. 

Scale
Increases or decreases the size of a selected element. You can scale 
an object up to make it larger or down to make it smaller. Press Shift to 
scale the element while maintaining its proportions.

Skew Slants the selected element.

Maintain Size
Keeps elements the same size aspect ratio in the Camera view as you 
move them towards or away from the camera.

Spline Offset

Lets you reposition the visual trajectory without offsetting or modifying 
your animation. By default, the trajectory is located at 0,0,0 fields. If 
your elements were drawn in a different location than the centre of the 
drawing area, it will look like the trajectory is not aligned with your 
drawing. Also, if you have several elements attached to one trajectory, 
you might want your trajectory to be at a different location to represent 
the group's motion better.

Cell

Increase Exposure

Adds one more exposure to a selected cell; repeating this action adds 
an extra cell each time. This is an efficient way to extend a drawing's 
exposure and is always set in Insert mode. Increasing an exposure 
pushes the existing exposure forward.

Decrease Exposure
Decreases exposure of a selected cell by one; repeating this action 
decreases one exposure adds an extra cell each time. This is an 
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efficient way to shorten a drawing's exposure. Decreasing an exposure 
pulls in the existing exposure.

Set Exposure to Lets you set the exposure to 1, 2, 3 or a custom exposure.

Extend Exposure

Lets you enter the frame up to which you want to extend the exposure. 
You can expose the drawing in the frames and replace the drawings 
that were originally there or move the subsequent frames forward in 
time. 

Add Key Exposure Adds a key exposure to the selected cell. 

Remove Key Exposure
Removes only the key exposure (key frames) not all the exposures. 
The existing key exposure is replaced by the preceding exposure.

Remove Duplicate Key Exposure

When working with drawings to adjust the timing of a mouth in a 
lipsync, for example, and forcing the use of specific key exposures, 
unnecessary key exposures will be created. You can delete these 
duplicates without affecting the rest of the drawing. The first drawing of 
the selection will be used for the range.

NOTE: Duplicate key exposures may occur when pasting with the 
Enforce Key Exposure option selected.

Fill Empty Cells

Lets you fill empty cells to extend the exposure of single frame 
drawings to fill the range of empty cells after each one.When creating 
drawings on  cells that are not side-by-side, the exposure of the first 
drawing no longer fills automatically. You must select the frame range 
where you want your drawings to hold their exposure up to the next 
drawing and use the Fill Empty Cells command.

Insert Blank Cell Adds an empty cell between other cells.

Clear Exposure Removes the exposure from the selected cell.

Clear Exposure and Pull
Replaces the exposure from the selected cell with exposures that 
follow it.

Fill Selection

Lets you fill the same value over an entire selection. The selection can 
be over one cell, a cell range in one column, a cell range over many 
columns, an entire column, or many columns. You can use numbers, 
words, letters, or any alphanumeric value.

Sequence Fill

Lets you create a numbered sequence over a selection. The sequence 
can be forward, backward, single, double or higher increment, as a 
cycle, and so on. The selection can be over one cell or a cell range in 
one column or more or an entire column or many entire columns.

Lip-Sync

Auto Lip-Sync Detection Generates a sound detection for lip-sync.

Map Lip-Sync
Automatically maps drawings in an element to the mouth chart you 
have generated for a sound. This can save time when you are lip-
synching a voice track.

Flip
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Flip Horizontal Flips the selection horizontally.

Flip Vertical Flips the selection vertically.

Flip Scale X

Once your drawing layer is rotated, the original horizontal and vertical 
axes change. The Flip Scale X and Flip Scale Y will perform a flip on 
your drawing layer following its original axis.Remembers the original X-
axis of the layer and flips the element following it.

Flip Scale Y
Remembers the original Y-axis of the layer and flips the element fol-
lowing it.

Lock in Time

Indicates whether the point is locked to a specific frame (keyframe) or 
only locked to a specific position and the curve can flow through it 
freely as other points are being added, moved, or adjusted (control 
point).

Substitute Drawing Previous
Replaces the drawing or cell's symbol on the current frame by the 
previous drawing.

Substitute Drawing Next
Replaces the drawing or cell's symbol on the current frame by the next 
drawing.

Go to Previous Keyframe Goes to the previous keyframe.

Go to Next Keyframe Goes to the next keyframe.

Select Child
Lets you select the first element parented to the selected peg element 
in the Timeline view.

Select Children
Lets you select all elements parented to the selected peg element in 
the Timeline view.

Lock

Lock Locks one or a multiple selection of layers. 

Unlock Unlocks one or a multiple selection of locked layers.

Lock All Locks all the layers in the Timeline view. 

Unlock All Unlocks all the layers in the Timeline view. 

Lock All Others Locks every layer except the selected ones.

Reset

Returns the value of the selected element to the initial value of the 
active tool. For example, if the Rotate  tool is active, the transformation 
angle will be reset to 0 and if the Transform  tool is active, all the 
transformation values will be reset.

Reset All
Resets all transformations on the current frame in a selected layer. 
Your keyframe will remain, but all the values will return to the starting 
value. All transformations are reset regardless of the tool you're using.

63



Chapter 3: Menus     Main Menus

Drawing Menu
The Drawing menu lets you access many tools related to drawing, painting, dirt removal, optimizing strokes, and 
more.

How to access the Drawing menu

 l At the top of the interface, select Drawing.

Command Description

Drawing Tools

Activates a drawing tool including: 

Select, Contour Editor, Cutter, Smooth Editor, Perspective, 
Envelope, Reposition All Drawings,  Brush, Pencil, Text, Eraser, 
Dropper, Line, Rectangle, Ellipse, Polyline, Paint, Ink, Repaint 
Brush, Close Gap, Stroke, Edit Gradient/Texture, Hand, Zoom and 
Rotate View.

These drawing tools are available on the Tools toolbar.

Convert

Pencil Lines to Brush Strokes
Converts the selected centreline pencil strokes into contour strokes 
brush lines.

Brush Strokes to Pencil Lines
Converts selected contour strokes into centreline pencil strokes. 
The brush stroke thickness will be lost.

Strokes to Pencil Lines Converts the selected invisible line to a pencil line.

Break Apart Text Layers
Text is treated as a single drawing object. This separates the text so 
each character becomes an individual drawing object you can select 
and modify independently.

Optimize

Flatten

Merges drawing objects and brush strokes into a single layer. If you 
draw new lines to fix a drawing or line with many brush strokes, it 
can be useful to flatten them all into a single shape. By default, lines 
are drawn one on top of each other. If you intend to repaint the lines 
or modify their shape, it will be easier if they are flattened. 

Smooth Smooths selected drawing strokes and removes extra points.

Optimize

Reduces the number of layers, such as overlapping brush strokes, 
in the selected drawing objects. Drawing objects will only be 
flattened and optimized if the selected objects do not change the 
appearance of the final image when they are merged. 

Transform

Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 CW Rotates the current selection 90 degrees clockwise.

Rotate 90 CCW Rotates the current selection 90 degrees counter-clockwise.
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Rotate 180 Rotates the current selection 180 degrees.

Arrange

Bring to Front Moves the selected art to the front (on top).

Bring Forward Moves the selected art one level forward (closer to the front).

Send Backward Moves the selected art one level lower (behind).

Send to Back Moves the selected art behind everything (bottom / back).

Create Empty Drawing
Creates a drawing in the selected cell, replacing any drawing that 
may already be exposed in that cell and the following ones until it 
meets another drawing, key exposure or a blank cell. 

Duplicate Drawings

Lets  you duplicate the drawing and work on a copy of it. This lets 
you modify an existing drawing but retain the original. When 
duplicating a drawing, the selected cell is replaced with the new 
drawing. The exposure of the original drawing that was on the 
current cell is removed. The original drawing is not deleted from the 
project folder or other cells in which it is exposed. 

Delete Selected Drawings
Permanently removes selected drawings. Once you save your 
project, these drawings cannot be recovered.

Rename Drawing Lets you give a selected drawing a new name.

Select Strokes with Current Colour
Lets you select drawing elements and painted areas with the same 
colour as the currently selected colour in your colour palette.

Previous Drawing
When a cell is selected in the Timeline or Xsheet view, displays the 
previous drawing.

Next Drawing
When a cell is selected in the Timeline or Xsheet view, displays the 
next drawing.

Previous Layer
When a cell is selected in the Timeline or Xsheet view, displays the 
previous layer.

Next Layer

Once a cell is selected in the Timeline or Xsheet view, you can 
navigate between the drawings, frames, and layers. Displays the 
previous drawing, next drawing, previous layer or next layer.

When a cell is selected in the Timeline or Xsheet view, displays the 
next layer.
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Edit Menu
The Edit menu lets you repeat and undo actions, cut/copy/paste selected objects, select and manipulate objects, 
work with symbols, and access the Preferences dialog box.

How to access the Edit menu

 l From the top menu, select Edit.

Command Description

Undo
Removes the last change made to your project. Harmony supports 
multiple undo, so you can undo changes you made in the order you 
made them.

Redo
Redoes an operation you have undone. This command is active only 
after you use the Undo command.

Cut
Removes selected objects. You can then paste the object or its prop-
erties to another object.

Copy Copies selected objects and properties.

Paste
Places an object you cut or copied into the location you select in a 
view.

Paste Special

Opens the Paste Special dialog box which lets you determine how 
templates and symbols are imported in the Timeline view. 

There are advanced paste options for drawings, timings, keyframes, 
layers, as well as palettes and symbols.

Paste Special Again Pastes new drawings with the previous Paste Special settings.

Delete Removes selected objects.

Select All
Selects all drawing objects in the current drawing window in the 
Drawing, Timeline and Camera views. This helps you manage 
multiple objects as one when moving them.

Deselect All Deselects all selected objects in the Drawing and Camera views.

Invert Selection

Deselects the currently selected items and selects all other items 
that were not selected. For example, if some lines are selected in a 
drawing, this command will deselect them and select any other lines 
in the drawing that were not selected.

Create Symbol
Creates a symbol from selected drawing elements in the Drawing or 
Camera view or a layer or cells in the Timeline view.

Expand Symbol

Extracts a symbol's contents and places it on the root timeline. Its 
contents will be copied and inserted into the root timeline. The 
symbol will not be removed from the Timeline view once it is 
expanded. 

The symbol's layers will be parented to it in case you created 
motions and transformations on the drawing layer that contain the 
symbol. Breaking the hierarchy could result in the loss of any scaling 
and animation you may have created.
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Duplicate Selected Symbol
Creates a duplicate of a selected symbol. If other symbols are nes-
ted inside the new symbol, they are not duplicated. If you modify 
them, the original and other instances will also be modified.

Clone: Drawings Only
Creates a copy of the drawings in the selected layer in the Timeline 
view or column in the Xsheet view. The timing it not copied.

Clone: Drawings and Timing
Creates a copy of the drawings and their timings in the selected 
layer in the Timeline view or column in the Xsheet view.

Duplicate

Duplicates a layer to have a copy of the drawings that are inde-
pendent from the original ones, as well as an independent timing 
(exposure). When you need the drawings to be modified inde-
pendently, you will want to duplicate the layer instead of cloning it.

Merge
Combines all drawings. Unused columns and layers will be deleted, 
but the original drawing files are still accessible.

Group

Group Groups selected drawing objects in the Camera or Drawing view.

Ungroup
Ungroups a selected group of drawing objects in the Camera or 
Drawing view.

Edit Drawing Mode

When the Auto-Get Rights to Modify Drawings option is selected in 
the Preferences dialog box (General tab), the system automatically 
gets the rights to modify drawings when you select a drawing. 
Otherwise, you must manually get the rights to modify drawings.

Edit Palette List Mode

When the Auto-Get Rights to Modify Palette option is selected in the 
Preferences dialog box (General tab), the system automatically gets 
the rights to modify palettes and palette lists when you select a 
colour from a palette. Otherwise, you must manually get the rights to 
modify a palette or palette list.

Get Rights to Modify Drawing Manually releases the rights to modify a selected drawing.

Release Rights to Modify Drawing Manually releases rights to modify a selected drawing.

Force Release Rights to Modify Drawing
This option is always available even if the Get Rights to Modify All 
Scene Assets option is not selected in the Database Selector dialog 
box.

Preferences
Opens the Preferences dialog box where you can set your 
preferences for Harmony.
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File Menu
The File menu lets you open, close, save, scan, print, and import and export files.

How to access the File menu

 l From the top menu, select File.

Command Description

New
Creates a new scene while closing any scene already open. The 
New Scene dialog box opens, asking for directory, name, and 
resolution information.

Open
Displays the Open Scene dialog box where you can browse for a 
scene file.  You can open a new scene from the current one and the 
previous scene will close.

Open Recent Displays a list of the most recently opened scenes.

Clear Clears the list of recently opened scenes.

Close
Closes the currently opened scene, but does not close the Harmony 
application.

Save
Saves all changes made to the opened scene, drawings, palettes, 
and palette lists.

Advanced Save

Rights to Modify Scene Version
Allows you to modify the selected version of the scene and access 
the version manager during the opened session

Rights to Modify Scene
Allows you to modify the currently selected scene version, but locks 
access to the version manager during the opened session.

Read Changed Drawings

Determines which drawing files have been modified on disk since 
you loaded them. All updated drawings will be reloaded. 

NOTE: Reloading a locked drawing will discard unsaved 
changes.

Manage Versions Allows you to manage all the versions of the current scene.

Save As

Saves the current file with a different name and at a different 
location.

Saves the current state of a scene as another scene. The Save As 
window prompts you for a new name and a different location for this 
scene before saving it. This will create a complete scene directory 
for the new scene.

NOTE: The scene name cannot exceed 23 characters.
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Save as New Version
Saves the current scene as another version. The Save Version 
dialog box prompts you to give a name for this new version. This will 
create a new .xstage file in your current project directory.

Acquire

From TWAIN
Opens the Acquire from Scanner window from which you can set 
parameters before scanning. 

Import

Images Imports bitmap images which you can choose to vectorize.

Movie
Lets you convert a QuickTime movie to an image sequence and 
audio file.

Sound Lets you import sound files into your project.

SWF, Illustrator Files to Library Lets you import SWF files into your project.

Export

Images
Exports a scene as a bitmap image sequence. If there is sound in 
your scene, it will not be exported with the images.

Movie Exports animation as a QuickTime movie.

SWF

Exports a Flash movie file. 

The SWF export supports some bitmap effects (which can be 
previewed in Render View  mode) and SWF Blend Modes (vector 
effects which can be previewed in OpenGL View  mode).

Quit Closes the application.
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Help Menu
The Help menu lets you display the Harmony documentation, Welcome screen and end user license agreement, 
as well as access the Toon Boom website, and identify the product name and version number.

How to access the Help menu

 l At the top of the interface, select Help.

Command Description

Online Help
Opens the Harmony Help system, complete with instructions on 
how to use the system. This requires an internet connection.

Getting Started
Opens the Harmony Getting Started Guide (in PDF format) in a 
browser window. Requires Acrobat Reader.

Toon Boom on the Web
Opens the Toon Boom website, which features a Support and 
Community > Forum section.

Customer Experience Improvement 
Program

The Customer Experience Improvement Program allows Toon 
Boom to collect usage information. The data does not contain any 
personally identifiable information and cannot be used to identify 
you. The data will consist of a basic hardware description, a project 
summary and usage information. The information is used only for 
software improvement purposes, as well as for sharing with third 
parties for the same reason.

This program is enabled by default but is voluntary. If you prefer not 
to participate, you can opt out when you first launch the software, by 
using a global preference, or by a command line argument.

About Identifies the product name and version number. 

Show Welcome Screen Displays the Harmony Welcome screen.

Show End User License Agreement Displays the End User License Agreement.
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Insert Menu
The Insert menu lets you create empty symbols in the Library view, different types of layers in the Timeline view, 
keyframes and control points.

How to access the Insert menu

 l At the top of the interface, select Insert.

Command Description

Create Empty Symbol in Library
Creates an empty symbol in the Library view to which you can edit (add 
content).

Bone Adds a new Bone layer to the Timeline view.

Camera Adds a new Camera layer to the Timeline view.

Colour-Card Adds a new Colour-Card layer to the Timeline view.

Drawing
Adds a new Drawing layer to the Timeline view and a column in the 
Xsheet view.

Game Bone Adds a new Game Bone layer to the Timeline view.

Kinematic Output Adds dd a new Kinematic Output layer to the Timeline view.

Peg Adds a new Peg layer to the Timeline view.

Quadmap Adds a new Quadmap layer to the Timeline view.

Effects
Adds a new layer in the Timeline view with the effect you select: Blur, 
Brightness-Contrast, Colour-Scale, Cutter, Glow, Shadow, or 
Transparency.

Keyframe Adds a keyframe to the selected cell in the Timeline view.

Keyframe and Duplicate Drawing
Adds a keyframe to the selected drawing layer cell in the Timeline view 
and creates a duplicate of the drawing, which sits on top of the original 
drawing.

Control Point

Adds a control point to the trajectory of the selected element or peg in 
the Camera view when the element or peg is in a 3D path. Note that 
you must have a 3D path in the peg portion in order to add a control 
point.
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Play Menu
The Play menu lets you play back animation and sound. Use it to scrub the sound to create your lip-sync, loop the 
playback, navigate through frames, and change the playback range and speed.

How to access the Play menu

 l At the top of the interface, select Play.

Command Description

Play Plays and stops the animation.

Render and Play
Creates a render of your scene to play back the final result including 
the effects.

Test SWF Movie
Creates a SWF format movie and a report to test your result before 
proceeding to the final movie.

Stop Stops playback.

Playback Speed
Opens the Set New Frame Rate dialog box where you can set the 
frame rate at which the playback plays.

Loop Repeatedly plays back your animation indefinitely.

Enable Sound Turns on sound during playback.

Enable Sound Scrubbing Turns on sound scrubbing during playback.

Start Frame
Opens the Set Playback Start Frame dialog box where you can set 
the frame number on which to start playback.

Stop Frame
Opens the Set Playback Stop Frame dialog box where you can set 
the frame number on which to stop playback.

First Frame Moves the red playhead to the first frame.

Previous Frame Moves the red playhead to the previous frame.

Next Frame Moves the red playhead to the next frame.

Last Frame Moves the red playhead to the last frame.

Go to Frame
Opens the Go to Frame dialog box where you can enter the frame 
number on which the red playhead to be positioned in the Timeline 
view.

Enable Playback

Top View Plays back your animation in the Top view.

Side View Plays back your animation in the Side view.

Perspective View Plays back your animation in the Perspective view.
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Scene Menu
The Scene menu lets you set the scene length, add frames to the scene, view different displays of the scene, set 
render options, access the Scene Settings dialog box and Elements Manager window, and verify the drawing and 
palette files in your project.

How to access the Scene menu

 l At the top of the interface, select Scene.

Command Description

Scene Length Lets you set the length of the scene in frames.

Frame

Add Frames at Start Adds the number of frames you specify to the beginning of the scene.

Add Frames at End Adds the number of frames you specify to the end of the scene.

Add Frames Before Selection
Adds the number of frames you specify before or after your selection.

Add Frames After Selection

Remove Selected Frames Deletes the selected frames from your scene.

Camera

Default Camera
Lets you select a camera. If you only add one camera to your scene, 
you will only see Default Camera in your list.

Scene Settings
Opens the Scene Settings dialog box where you can set the resolution, 
alignment, bitmap resolution and many other parameters.

Render

Auto Render

Automatically recalculates the preview image whenever you modify a 
parameter. If your scene is heavy and you do not want the preview 
rendered automatically, deselect the Auto-Render option and do the pre-
view update manually.Note that this will slow down Harmony as it 
takes resources to update every frame.

Cancel Preview Render Cancels a render that was started.
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View Menu
The View menu lets you manipulate the view by zooming, panning, or rotating. You can also display the grid and 
change its size, use the onion skin feature to help with drawing, and set the preview resolution. 

How to access the View menu

 l At the top of the interface, select View.

Command Description

Toggle Full Screen

Cycles through the following display modes:

 l Normal Full-Screen: The main application window becomes 
full screen.

 l View Full-Screen: The selected view becomes full screen 
and all other views are collapsed.

 l Normal: The main application window is restored to its ori-
ginal size and collapsed views are expanded.

Zoom In Zooms in the view.

Zoom Out Zooms out the view.

Rotate View CW
Rotates the Camera view 30 degrees clockwise, like an animation 
table.

Rotate View CCW
Rotates the Camera view 30 degrees counter-clockwise, like an 
animation table.

Reset Zoom Resets the view’s zoom to its default position.

Reset Rotation Resets the view’s rotation to its default position.

Reset Pan Resets the view’s pan to its default position.

Reset View Resets the view to its default position.

Grid

Show Grid Displays the grid.

Underlay Displays the grid under the drawing elements.

Overlay Displays the grid over the drawing elements.

Square Grid Displays a standard square grid.

12 Field Grid Displays a 12-field size grid.

16 Field Grid Displays a 16-field size grid.

Onion Skin

Show Onion Skin

Lets you preview the previous and next drawings. By default, the pre-
vious drawings appear in a shade of red and the next drawings are 
displayed with a shade of green. You can change these colours in 
the Preferences dialog box. 

Add to Onion Skin Adds a series of selected elements to the onion skin preview.
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Remove from Onion Skin Removes a series of selected elements from the onion skin preview.

Remove Unselected from Onion 
Skin

Removes all elements except the ones selected from the onion skin 
preview.

Add All to Onion Skin Adds all of the scene's elements to the onion skin preview.

Remove All from Onion Skin Removes all of the scene's elements from the onion skin preview. 

Onion Skinning by Drawing
In Camera view, the onion skin by default is per frame, this option 
lets you set it by drawing so you don't see any exposure's onion skin 
from the same drawing.

Reduce One Previous Drawing Reduces the number of previous visible drawings by one.

Add One Previous Drawing Adds one drawing to the number of previous visible drawings.

Reduce One Next Drawing Reduces the number of next visible drawings by one.

Add One Next Drawing Adds one drawing to the number of next visible drawings.

Light Table
Turns on the light table so you can see the previous and subsequent 
active layers in washed-out colours. It is useful for seeing the other 
layers when designing, animating or cleaning up your animation. 

Show

Safe Area
Displays the TV safety zone and the centre of the camera frame. 
The safe area adapts to the scene resolution, as well as the safety 
zone and frame’s centre.

Camera Mask

Displays a black mask around the scene’s frame to avoid seeing the 
unnecessary artwork. This option is handy when you're animating 
and setting up the scene. It allows you to see your scene’s com-
position better.

Control Displays the controls of the selected element.

Current Drawing on Top

Displays the selected drawing on top of everything while you draw. 
By enabling this option, each time you select a drawing tool, the 
selected drawing is displayed in front of everything in the Camera 
view. The Timeline view ordering remain unchanged.You only need 
to enable this option once, it is not necessary to do it each time you 
select a drawing tool. 

Show Strokes
Displays the strokes in your drawings so that the invisible lines 
stand out.

Hide All Controls Hides the controls of the selected element.

Preview Resolution

Same as Scene Resolution

Lets you choose a resolution for previewing a scene.

3/4 of Scene Resolution

1/2 of Scene Resolution

1/3 of Scene Resolution

1/4 of Scene Resolution

Custom
Lets you select a resolution from a list of presets or enter X and Y 
values for a  custom preview resolution.
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Bitmap File Quality
Lets you change the quality of the preview of the bitmap file in the 
Camera view. It will not affect the final render.

76



Harmony 14 Essentials - Reference Guide

Windows Menu
The Windows menu lets you customize your workspace to suit your working style, save it as a new workspace, and 
load it from the Workspace toolbar. You can also show or hide the different toolbars and views in Harmony.

How to access the Windows menu

 l From the top menu, select Windows.

Command Description

Restore Default Workspace
Returns modified workspaces to their original default layout if you do 
not like the current modifications or inadvertently closed some 
windows.

Workspace

Workspace Manager
Opens the Workspace Manager where you can modify, create, delete, 
rename and reorder your workspaces.

Workspace
Lets you open workspaces designed specifically for animating, 
compositing, hand drawing, scripting and the default workspace.

Toolbars
Lets you show or hide these toolbars: Playback, File, Edit, Advanced 
Animation, Scripting, Tools,  Workspace, Deformation, Camera View, 
Xsheet View and Timeline View.

Camera Shows or hides the Camera view.

Colour Shows or hides the Colour view.

Drawing Shows or hides the  Drawing view.

Function Shows or hides the Function view.

Layer Properties Shows or hides the Layer Properties view.

Library Shows or hides the Library view.

Message Log Shows or hides the Message Log view.

Side Shows or hides the Side view.

Timeline Shows or hides the Timeline view.

Tool Properties Shows or hides the Tool Properties view.

Top Shows or hides the  Top view.

Xsheet Shows or hides the Xsheet view.

Integrated Help Shows or hides the Integrated Help view.

Metadata Editor Shows or Hides the Metadata Editor view.

Script Editor Shows or hides the Script Editor view.
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Quick-access Menus
A quick-access menu lets you open a list of the commands you will use most often.

 How to access a quick-access menu

 1. Right-click anywhere in a view.
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View Menus
A view menu contains commands specifically related to that view.

How to access a  view menu 

 1. In the top-left corner of a view, click the Menu  button.

Colour View Menu 80

Function View Menu 82

Library View Menu 84
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Colour View Menu
The Colour View menu lets you access commands related to the Colour view such as creating new palettes, 
adding new colour swatches, and displaying the Tint panel.

How to access the Colour menu

 l In the upper-left corner of the Colour view, click the menu button.

Command Description

Palettes

New

Creates a new colour palette.

By default, Toon Boom Harmony is set to the Basic mode. For simple 
productions, it is recommended to use the Basic mode.  This setting stores the 
palettes automatically for you and saves them at the Scene level. When you 
use the Advanced Palette Lists mode, you can decide at which level you want 
to store your palettes: Environment, Job, Scene, or Element.

Link
Lets you access other palettes created in the project and link them to your 
scene.

Import Imports a colour palette located on your hard drive.

Remove Deletes the selected colour palette.

Rename Lets you five the selected colour palette a new name.

Duplicate

Creates a copy of the original palette, using the same names and colour 
values, but has a different ID and is independent from the original palette. This 
ensures that both the duplicate and original palettes are completely 
independent.

Clone
Creates a copy of the master palette. The colours in each palette have the 
same properties. The colours have the same identification number pointing to 
the same colour zones, but they can have different names and RGBA values.

Move Up Moves the selected colour palette up one level.

Move Down Moves the selected colour palette down one level.

Colour Editor Opens the Colour Editor where you can pick and edit colour swatches.

Tint Panel
Opens the Tint panel where you can modify a series of colours to blend a tint in 
them or offset their RGBA values. 

Display Colour Values Display the colour values beside their colour swatches in the palette list.

Colours

Cut Cuts the selected colour swatch from the palette.

Copy Copies the selected colour swatch which you can paste in a different palette.

Copy Colour ID
Copies a colour swatch's colour ID so you can keep a reference file of colour 
IDs or use them with custom plug-ins. Example of a colour ID: 
075cf5b552401130.

Paste Colour Values Pastes the colour value of the copied swatch over an existing colour swatch.
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Paste As New Colours Creates a new colour swatch from the colour value of the copied swatch.

Paste As Clones
Pastes a copied colour to a new palette as a clone of the original one. Both 
colour use the same colour ID. They have to be in different palettes.

New Creates a new colour swatch from the colour swatch that was last selected.

Edit
Opens the Colour Picker window in which you can edit the selected colour 
swatch.

Delete Deletes the selected colour swatch from the palette.

New Texture
Lets you add a bitmap colour swatch to your palette. You can load photos and 
textures and paint your drawings with it. The bitmap image must be a .tga or 
.psd file format.

Edit Texture
Opens the browser to replace the texture used in a textured colour swatch. All 
zones using the swatch will be updated with the new texture.

Scale Down Texture Lets you set a new maximum texture size or scaling factor.

Protect Colour
Locks a selected colour, so if you ever paint over it accidentally, the work 
already done will not be affected. You can also block the filling colours if you 
painted all of the animation in Line Art and plan to repaint the lines.

Swatch Mode
Displays the colour swatches with its corresponding name inside the swatch. 
When this option is not selected, the names of the colour swatches are 
displayed beside the swatch.

Independent Bitmap 
Colour

Bitmap colour selection is independent from the vector colour selection.

Bitmap Colour Sliders

RGB Displays the colour picking sliders as RGB (red, green, blue).

HSV Displays the colour picking sliders as HSV (hue, saturation, value).
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Function View Menu
The Functions View menu lets you do many things in the Camera view, including selecting and editing objects in 
different views, changing the display, setting morphing parameters, accessing tools and many more.

How to access the Function menu

 l In the upper-left corner of the Function view, click the menu button.

Command Description

Edit

Cut
Removes selected objects. You can then paste the object or its properties to 
another object.

Copy Copies selected objects and properties.

Paste Places an object you cut or copied into the location you select in a view.

Delete Removes selected objects.

Select Next Keyframe Selects the next keyframe.

Select Previous 
Keyframe

Selects the previous keyframe.

Select Left Handle Selects the left handle of the selected keyframe.

Select Right Handle Selects the right handle of the selected keyframe.

Select All
Selects all objects in the Function view. This helps you manage multiple 
objects as one.

Deselect All Deselects all selected objects in the Function view.

View

Show Current Frame Displays the current frame 

Toggle Grid Enables the display of the grid.

Reset Zoom Resets the view’s zoom to its default position.

Reset Pan Resets the view’s pan to its default position.

Reset View Resets the view to its default position.

Function List

Auto Load Selection

Clear

Load Selection

Add Selection

Remove Selection

Show

Show Motion: 

Show Rotation: 

Show Scale: 
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Show Skew: 

Show Other: 
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Library View Menu
The Library View menu lets you access commands specific to the Library view, such as opening a Library or 
getting the rights to modify a library folder.

How to access the Library menu

 l In the upper-left corner of the Library view, click the menu button.

Command Description

View

List Displays the contents of the selected folder as a list.

Thumbnails Displays the contents of the selected folder as a thumbnails.

Details Displays the details of the selected file.

Generate Thumbnails Creates a thumbnail to display in the preview window.

Edit

New Symbol

Creates a new symbol from a drawing or part of a drawing in the 
Drawing or Camera view, or a layer in the Timeline view. 

If your selection is in the Timeline , the new symbol appears in the  Symbol 
folder. The current selection is not replaced by the new symbol. The new 
symbol only appears in the library. You must drag it into your scene to use it.

If your selection is in the Drawing or Camera view, the new symbol appears in 
the Symbol folder and in the Timeline view as a new layer.

Cut Cuts the selected file in the Library view.

Copy Copies the selected file in the Library view.

Paste Pastes the selected file in the Library view.

Delete Deletes the selected file in the Library view.

Delete Thumbnails Deletes any thumbnails that were generated for display in the preview window.

Edit Symbol

Places you inside the symbol where you can edit it. 

To return to the project's timeline, click the Top  button in the Camera 
view's top-left corner, press  Ctrl + Shift + E (Windows/Linux) or ⌘  + Shift + E 
(Mac OS X). 

Remove Unused Files Removes any files not in use in the selected template.

Rename Template Lets you rename a selected template.

Import Files
Imports vector files such as AI, PDF, and SWF. You requires the right to 
modify the library in which you want to import the files.

Folders

New Folder
Creates a new folder in the Library view. Before you can create a new folder, 
you must have the right to modify the folder in which you are creating the new 
folder.
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Refresh Updates the view and its contents.

Open Library Lets you open a library on your computer.

Close Library Unlinks a library folder from your library list.
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Chapter 4: Nodes
The Node view uses a visual set of connections (nodes) to show how each element in the scene is connected and 
brought to the final image. It allows you to add extra elements and effects, and to move beyond the possibilities 
offered by the Timeline and Xsheet views. Each node corresponds to a layer in the Timeline view. Very few nodes 
are only visible in the Node view.

The basic rules of the Node view are quite simple. Once you understand them, a lot can be accomplished.

Each node used to build a node system is available in the Node Library view as well as through the Insert menu in 
the Node view. In addition, each time you create a layer from the Timeline or Xsheet views, the corresponding node 
is created in the Node view.

Combine Nodes 88

Cutter Node 89

Deformation Nodes 91

Bone Node 92

Deformation Composite Node 94

Game Bone Node 96

Kinematic Output Node 98

Filter Nodes 99

Blur Node 100

Colour-Scale Node 102

Glow Node 104

Shadow Node 107

Transparency 109

Generator Nodes 111

Colour-Card Node 112

Element / Drawing Node 113

Move Nodes 115

Camera Node 116

Peg Node 117

Transformation Tab 117

Quadmap Node 118

Sound Layer Properties 120
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Combine Nodes
The nodes found in the Combine category are used to take two or more elements are combine them into a new 
image.

Cutter Node 89
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Cutter Node
T-HFND-010-009

The Cutter effect cuts out a portion of an image. To accomplish this, it needs to be connected to the drawing it is 
intended to cut as well as to a matte  layer. The cutter will take the shape of the drawing in its matte layer and cut this 
shape out of the drawing layer. This is especially useful if you want to make a character disappear between a 
background element, or if you want to cut out a hole in the middle of a character. 

The Cutter effect has an Inverted parameter, which is disabled by default. When enabled, the Cutter will have the 
revert effect: Instead of cutting the matte's shape out of the drawing, it will cut everything outside of the matte's 
shape out of the drawing, leaving only the parts of the drawing that are covered by the matte.

The Cutter effect can be used with 2D-3D integration. Rendered 2D drawings, integrated with 3D models, display 
soft, anti-aliased edges, even where the Cutter effect is applied.

Refer to the following example to connect this node.
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Properties

Parameter Description

Enable/Disable
Enables or disables the selected node in the Camera, Timeline, and Node 
views.

Colour Swatch Changes the layer colour.

Name Allows you to change the node's name.

Inverted
When this option is enabled, the Cutter node will invert the matte shape to cut 
the drawing. Instead of cutting the image intersecting with the matte, it will cut 
any artwork outside of the matte shape.
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Deformation Nodes
The deformation rigs are composed of several different types of nodes. Additional ones such as the Kinematic 
Output node can be used to enhance the results.

Bone Node 92

Deformation Composite Node 94

Game Bone Node 96

Kinematic Output Node 98
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Bone Node
The Bone node is one of the main nodes used to build a deformation rig. Each Bone node consists of a bone and 
an articulation. You can chain Bone nodes to create a skeleton chain for your character. The Rigging tool can be 
used to create and connect those nodes automatically. 

Properties

Parameter Descriptions

Enable/Disable
Enables or disables the selected node in the Camera, Timeline, and Node 
views.

Colour Swatch Changes the layer colour.

Name Use this field to rename the node.

Resting Parameters Rest Offset

(x) Axis This is the bone x-axis (horizontal) coordinates for the resting position.

(y) Axis This is the bone y-axis (vertical) coordinates for the resting position.

Rest Radius This is the articulation's radius value (articulation size) for the resting position.

Rest Orientation This is the bone's orientation angle for the resting position.

Rest Bias
This is the articulation's bias (roundness and smoothness) for the resting pos-
ition.

Rest Length This is the bone's length for the resting position.

Deform Parameters Offset

2D Path
When this option is enabled, the X and Y-axis parameters are controlled by the 
same 2D path function.

Separate
When this option is enabled, the X and Y-axis parameters are individual one 
from another.
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Path When using a 2D Path, this field displays the name of the function.

(x) Axis
This is the bone X-axis (horizontal) coordinates for the animation position. This 
parameter can be linked to a function to be animated over time.

(y) Axis
This is the bone y-axis (vertical) coordinates for the animation position. This 
parameter can be linked to a function to be animated over time.

Radius
This is the articulation's radius value (articulation size) for the animation pos-
ition. This parameter can be linked to a function to be animated over time.

Orientation
This is the bone's orientation angle for the animation position. This parameter 
can be linked to a function to be animated over time.

Bias
This is the articulation's bias (roundness and smoothness) for the animation 
position. This parameter can be linked to a function to be animated over time.

Length
This is the bone's length for the animation position. This parameter can be 
linked to a function to be animated over time.
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Deformation Composite Node
Just like a standard Composite node, the Deformation-Composite node is used to bring together all the elements 
that are connected to it, allowing you to customize parameters that will influence the result of the output. The 
Deformation-Composite links the deformation chain to the graphic element to which it is related. 

Properties

Parameter Description

Enable/Disable
Enables or disables the selected node in the Camera, Timeline, and 
Node views.

Colour Swatch Changes the layer colour.

Name Use this field to rename the node.

Output Kinematic Only

This option is disabled by default, allowing the deformation chain to 
output deformation and position information. This option should be 
enabled in order to output the chain information position only. This will 
allow you to connect a part to the hierarchy without it undergoing the 
deformation applied to the rest of the chain.

Output Selected Port Only 
This option is important if you have several deformation chains for 
one element. 

Output Kinematic Chain

Lets you select a deformation chain option to use. This parameter is 
used when the Output Selected Port Only option is enabled. 

 

Rightmost: Only the first chain connected to the right of the com-
posite node will be used.

Leftmost: Only the first chain connected to the left of the composite 
node will be used.

Select: If you select this option, you can define which chain to output 
according to the order they are connected from left to right. 

Use First Connected Element’s Exposure as Key: Allows the 
deformation effect to automatically detect which deformation chain to 
use (subgroup) by detecting the exposure of the first element con-
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nected to the deformation. This option is used in the case of a multiple 
pose rig.

Use Parent Composite’s Connected Element Exposure: When 
the Output Kinematic Only option enabled, the information from the 
parent element’s exposure is used to attach the child to the correct 
chain, following which pose is exposed—see 

Output Kinematic Chain Selection

When the Output Selected Port Only option is selected AND the 
Select option is used as the Output Kinematic Chain setting, this field 
defines which deformation chain you want to use on your element. 
Select the number which corresponds to the left to right order that the 
chains are connected to the Deformation-Composite node.

You can attach this value to a function and enable different chains 
over a period of time on specific frames. This value can be modified in 
the Timeline view by using the Deformation-Switch layer. Since the 
Deformation-Composite node is only visible in the Node view, the 
layer has a reference to this parameter enabling you to easily edit the 
value when working in the Timeline view.
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Game Bone Node
The Bone node is one of the main node used to build a deformation rig. Each Bone node consists of a bone and an 
articulation. Chaining Bone nodes will create a skeleton chain for your character. The Rigging tool can be used to 
create and connect those nodes automatically.

Parameter Descriptions

Resting Parameters Rest Offset

(x) Axis This is the bone X-axis (horizontal) coordinates for the resting position.

(y) Axis This is the bone Y-axis (vertical) coordinates for the resting position.

Rest Radius This is the articulation's radius value (articulation size) for the resting position.

Rest Orientation This is the bone's orientation angle for the resting position.

Rest Length This is the bone's length for the resting position.

Deform Parameters Offset

2D Path
When this option is enabled, the X and Y axis parameters are controlled by the 
same 2D path function.

Separate
When this option is enabled, the X and Y axis parameters are individual from 
each other.

Path When using a 2D Path, this field displays the name of the function curve.

(x) Axis
This is the bone X-axis (horizontal) coordinates for the animation position. This 
parameter can be linked to a function curve to be animated over time.

(y) Axis
This is the bone Y-axis (vertical) coordinates for the animation position. This 
parameter can be linked to a function curve to be animated over time.

Radius
This is the articulation's radius value (articulation size) for the animation pos-
ition. This parameter can be linked to a function curve to be animated over 
time.

Orientation
This is the bone's orientation angle for the animation position. This parameter 
can be linked to a function curve to be animated over time.
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Length
This is the bone's length for the animation position. This parameter can be 
linked to a function curve to be animated over time.
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Kinematic Output Node
The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation chain 
but not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will follow the 
movement of the chain just like a regular cut-out character hierarchy piece without being influenced by the 
deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the deformation.

Connect a Kinematic Output node below the deformation node you want your drawing to follow.
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Filter Nodes
Here is the list of the main filter effects available in Harmony.

Blur Node 100

Colour-Scale Node 102

Glow Node 104

Shadow Node 107

Transparency 109
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 Blur Node
T-HFND-010-007

The Blur-Radial effect creates an effect that softens, fogs or obscures the image evenly in all directions. This 
effect is useful when you want to make cloudy images not realistically seen in detail, such as a drawing object 
that is farther back or in the background of your scene, usually blurry due to the laws of atmospheric perspective. 
Other uses include the general softening of objects such as snow, stars and shadows that do not naturally have a 
hard outline.

Refer to the following example to connect this node.
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Properties

Parameter Description

Name Use this field to rename the node.

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a 
change of depth or scale. When this option is deselected, the effect's values 
remain unchanged regardless of any depth or scale changes. This option should 
be deselected when multiple drawings are composited and attached to this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of the blur. 
The blur radius is affected by the drawing scale and camera position. Click the 
Edit Curve button to change these values over time by adjusting the function 
curve.

Quality
Select High for a slow and accurate operation or Low for a faster operation with a 
more raw look.
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Colour-Scale Node
The Colour-Scale effect offsets an image's colours. This effect is useful in creating ambient transitions, such as 
from daytime to nighttime.

Refer to the following example to connect this node.

Properties

Parameter Description

Name Use this field to rename the node.

Red, Green, Blue, Alpha The red, green, blue and alpha used to offset the image.

Hue The colour or hue to offset the image.

Saturation The amount of colour to offset the image.

Value
Enter the value for the colour to offset the image. The actual colour values of 
the image are not changed; instead, the channels are multiplied by a selected 
amount. For example:
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 l A value of 1 does not change the colour values.

 l A value greater than 1 brings the colour channel value closer to 255 (or 
white).

 l A value less than 1 brings the colour channel value closer to zero (0 or 
black).
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Glow Node
T-HFND-010-009B

The Glow effect turns your image into a glow area with a bright soft-edged light or diffuse light region around an 
image. The Glow effect is useful for creating a shining rim around objects, such as the sun or stars. Clone your 
layer to display the original image on top of the glow.

Refer to the following example to connect this node.
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Properties

Parameter Description

Enable/Disable Enables or disables the selected node in the Camera, Timeline, and Node views.

Colour Swatch Changes the layer colour.

Name Use this field to rename the node.

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a 
change of depth or scale. When disabled, the effect's values will remain 
unchanged regardless of depth or scale changes. It is recommended that this 
option be disabled when multiple drawings are composited and attached this 
effect.

Blur Type

Radial: The edges of the matte are blurred evenly around points that make up the 
edge of the matte.

Directional: The matte is blurred in the direction you select.

Radius
Enter a value for the size of the blur. The larger the value, the greater the blur 
effect. The blur radius is affected by the drawing scale and camera position.

Directional Angle

If you selected the Directional Blur type, you can set the direction of the blur by 
entering a value from 0 to 360 in this field.

0: Blurs the image to the west.

90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of the 
character to the farthest edge of the blur.
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1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of the 
image.

Invert Matte Inverts the matte used to create the tone, shadow, or highlight.

Use Matte/Source Colour

Creates the shadow or tone using the matte shape's colour. Be sure that you are 
in render mode  to see this effect and that your background is NOT white and 
that you do NOT have a white colour card node attached to the composite. As the 
matte only gives colour information, but no alpha, the matte is automatically mul-
tiplied with the background colours. If there is no colour card attached and the 
background appears black, you will see the matte colour at full opacity. If it is mul-
tiplied with a white background, the colours disappear into the full 255.

Multiplicative Multiplies the tone or shadow colours with the background.

Colour

RGBA
Enter a value to add or subtract from the colour channels in the drawings or attach 
these values to function curves.

Colour Swatch Opens the Colour Picker where you can specify the colour.

Intensity
Lets you set a value to determine the strength of the effect or attach a function to 
animate the effect.
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Shadow Node
With the Shadow effect, you can turn a drawing into a shadow. It doesn't matter if the drawing layer is a fully 
coloured character. The Shadow effect will render it into a grey, semitransparent, slightly blurry silhouette. Clone 
your image or connect it a second time to the final Composite node to see the original image displayed on top of the 
shadow.

Refer to the following example to connect this node.

Properties

Parameter Description

Enable/Disable Enables or disables the selected node in the Camera, Timeline, and Node views.

Colour Swatch Changes the layer colour.

Name Use this field to rename the node.

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a 
change of depth or scale. When disabled, the effect's values will remain 
unchanged regardless of depth or scale changes. It is recommended that this 
option be disabled when multiple drawings are composited and attached this 
effect.

Blur Type

Radial: The edges of the matte are blurred evenly around points that make up the 
edge of the matte.

Directional: The matte is blurred in the direction you select.

Radius
Enter a value for the size of the blur. The larger the value, the greater the blur 
effect. The blur radius is affected by the drawing scale and camera position.

Directional Angle

If you selected the Directional Blur type, you can set the direction of the blur by 
entering a value from 0 to 360 in this field.

0: Blurs the image to the west.
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90: Blurs the image to the south.

180: Blurs the image to the east.

270: Blurs the image to the north.

Directional Falloff Rate

The distance where the blur fades from the edge of the image. Select a value 
between 0 and 1.

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of the 
character to the farthest edge of the blur.

1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of the 
image.

Invert Matte Inverts the matte used to create the tone, shadow, or highlight.

Use Matte/Source Colour

Creates the shadow or tone using the matte shape's colour. Be sure that you are 
in render mode  to see this effect and that your background is NOT white and 
that you do NOT have a white colour card node attached to the composite. As the 
matte only gives colour information, but no alpha, the matte is automatically mul-
tiplied with the background colours. If there is no colour card attached and the 
background appears black, you will see the matte colour at full opacity. If it is mul-
tiplied with a white background, the colours disappear into the full 255.

Multiplicative Multiplies the tone or shadow colours with the background.

Colour

RGBA
Enter a value to add or subtract from the colour channels in the drawings or attach 
these values to function curves.

Colour Swatch Opens the Colour Picker where you can specify the colour.

Intensity
Lets you set a value to determine the strength of the effect or attach a function to 
animate the effect.
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Transparency 
T-HFND-010-008

The Transparency effect is used to make an image partially transparent. The Transparency effect is useful when 
fading images in and out, such as a phantom or to make something partially see-through, such as a window.

Author

Christina Halstead
2D Animator and Character Designer

shadowbrushcreations.com

Refer to the following example to connect this node.

You can enter a value in the Transparency field or change the transparency value over time by linking it to a function 
curve. Entering a value of 100 in the Transparency field will make the element 100% transparent, in other words, 
invisible. Entering a value of 0 will render the element completely opaque.
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Properties

Parameter Description

Name Allows you to change the node's name.

Transparency
Lets you set the opacity of an element.  Values range from 0 to 100. A value of 
100 will make the element 100% transparent and a value of 0 will render the ele-
ment completely opaque.
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Generator Nodes
The nodes found in the Generator category are nodes that generate an image on their without using any external 
TVG or bitmap drawings. You can adjust the parameters to control the image outputted by these nodes.

Colour-Card Node 112

Element / Drawing Node 113
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Colour-Card Node

The Colour Card is a solid background the same size as the camera. The Colour Card lets you fill the scene's 
background with a solid colour when there is no background image. If no background or colour card is added to the 
scene, the resulting export will appear with a black background. 

By default, the Colour Card has a Z ordering value of 12 Backward. This puts the Colour card behind all elements 
that have a value lower than 12 Backward. Most of the time, the Colour card will appear automatically behind all 
the scene elements as they are all set to 0 Backward, unless you have changed the Z ordering of the scene 
components. If so, the Colour Card will be in front of the elements that are pushed back to more than 12 fields 
backward.

Colour Card Properties

Parameter Description

Depth
The value used to determine composition order when the Z value of two ele-
ments is the same.

Offset Z
The front-back position of the Colour Card layer in 3D space. This value can be 
verified in the Top view.

Red/Green/Blue/Alpha

The colour and transparency of the Colour Card. You can also attach these 
parameters to function columns to change their values over time. 

Click the colour swatch to open the Colour Picker window and select a colour.

Colour Swatch Opens the Colour Picker window in which you can specify the colour.
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Element / Drawing Node
The drawing layer's properties is composed of the following tabs:

Transformation Tab

The Transformation tab contains parameters for adjusting the position, scale, rotation, skew and pivots of an 
element.

Parameter Description

Position

3D Path: Lets you use a 3D path function to animate an element.

Separate: Lets you independently edit the different coordinate fields.

Path (x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

Path (y) Axis: Lets you type in a new North/South coordinate corresponding to 
the desired position.

Path (z) Axis: Lets you ype in a new Forward/Backward coordinate 
corresponding to the desired position.

Velocity: When the 3D Path option is selected, lets you set the speed at which 

Scale

Locked: Resizes the element while keeping its ratio. The X and Y axes scale 
proportionally

Separate: Resizes the element allowing to modify the ratio (squash and stretch).

(x) Axis: Lets you type in the horizontal scale value.
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(y) Axis: Lets you type in the vertical scale value.

Rotation
Angle z: Lets you  type in a degree value for the rotation angle. Note that you can 
enter values greater than 360 and -360 degrees. If you enter 720, the object will 
rotate twice.

Skew Skew: Lets you type in a degree value between -90 to 90 for the skew angle.

Pivot

(x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

(y) Axis: Lets you ype in a new North/South coordinate corresponding to the 
desired position.
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Move Nodes
The nodes found in the Move category are used to animate layers as well as camera motions.

Camera Node 116

Peg Node 117

Transformation Tab 117

Quadmap Node 118
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Camera Node
You can setup the camera position by entering coordinates and values in the Layer Properties view.

Parameter Description

Enable/Disable Turns the camera layer on or off.

Change Track Colour

The Change Track Colour  button lets you change the colour of the exposed 
frames; this helps you to quickly locate a layer in the Timeline view. Click the 
Change Track Colour  button to open the Select Colour window and choose a 
new colour. You can modify the colour for any type of layer, such as group, 
peg, drawing, and effects.

Name
Displays the current layer name. You can rename the layer by typing in a new 
layer name.

Position

Displays the current position of the camera layer using X-axis (East/West), Y-
axis (North/South) and Z-axis (Forward/Backward) coordinates. To reposition 
your camera frame, type in the new values corresponding to the desired pos-
ition coordinates. You can also use the up and down arrows to set the value of 
each field.

Angle
Displays the current rotation value. To set a new rotation position, type in a 
new angle value. You can also use the up and down arrows to set the new 
angle value.

Pivot

Displays the current position of the rotation pivot of the camera layer. The cam-
era will perform a rotation taking the position of the pivot as its angle centre. By 
default, the pivot is set at the centre of the camera frame. To reposition the 
pivot point, enter new X and Y coordinates values in the appropriate field. To 
see the pivot's position, the Rotate tool must be selected.
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Peg Node
Find below a description of all the Peg node parameters.

Transformation Tab
Parameter Description

Position

3D Path: Lets you use a 3D path function to animate an element.

Separate: Lets you independently edit the different coordinate fields.

Path (x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

Path (y) Axis: Lets you type in a new North/South coordinate corresponding to 
the desired position.

Path (z) Axis: Lets you ype in a new Forward/Backward coordinate 
corresponding to the desired position.

Velocity: When the 3D Path option is selected, lets you set the speed at which 

Scale

Locked: Resizes the element while keeping its ratio. The X and Y axes scale 
proportionally

Separate: Resizes the element allowing to modify the ratio (squash and stretch).

(x) Axis: Lets you type in the horizontal scale value.

(y) Axis: Lets you type in the vertical scale value.

Rotation
Angle z: Lets you  type in a degree value for the rotation angle. Note that you can 
enter values greater than 360 and -360 degrees. If you enter 720, the object will 
rotate twice.

Skew Skew: Lets you type in a degree value between -90 to 90 for the skew angle.

Pivot

(x) Axis: Lets you type in a new East/West coordinate corresponding to the 
desired position.

(y) Axis: Lets you ype in a new North/South coordinate corresponding to the 
desired position.
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Quadmap Node
The Quadmap transformation layer lets you deform the shape of an element. For example, you can use it to 
create a drop-shadow effect on an element.

You can edit the Quadmap visually in the Camera view.

How to edit the Quadmap in the Camera view

 1. In the Timeline view, click the Add Layer  button and select Quadmap.

 2. Connect the drawing you want to deformto the Quadmap.

 3. In the Tools toolbar, disable the Animate mode to change the value for the Quadmap over the entire dur-
ation of the element.

 4. In the Timeline view, click on the Quadmap layer to select it.

 5. From the top menu, select View > Show > Control or pressShift + F11.

The quadmap handles appear around the element in the window. There is also a pivot point at the centre of 
the quadmap frame that you can reposition.

 6. In the Camera view window, use the Transform tool to move the points on the quadmap. Shift + click to 
select multiple points.
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The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap node Layer 
Properties to attach the points to function curves.

Only the X and Y values of each point in the quadmap can be changed.

Properties

Parameter Description

Name Lets you rename the node.

2D Path
Changes the X and Y values simultaneously and control the velocity of the 
change.

Separate
Changes the X and Y values separately. Each one can be attached to separate 
function curves.

 

119



Chapter 4: Nodes     Sound Layer Properties

Sound Layer Properties
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer 
Properties view.
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Chapter 5: Tools Properties
Harmony has a wide variety of drawing and manipulation tools and each one of them has a series of options and 
modes available in the Tool Properties view. This section covers these options.  

 

Brush Tool Properties 123

Size and Smoothness Tab 124

Close Gap Tool Properties 126

Contour Editor Tool Properties 127

Cutter Tool Properties 129

Ellipse Tool Properties 130

Envelope Tool Properties 133

Eraser Tool Properties 135

Size and Smoothness Tab 136

Line Tool Properties 137

Paint Tool Properties 140

Pencil Tool Properties 142

Perspective Tool Properties 144

Polyline Tool Properties 145

Rectangle Tool Properties 147

Reposition All Drawings Tool Properties 150

Rigging Tool Properties 152

Mode 152

Options 152

Operations 152

Select Tool Properties 153

Smooth Editor Tool Properties 158

Stroke Tool Properties 160

Text Tool Properties 161
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Transform Tool Properties 164

Zoom Tool Properties 166
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Brush Tool Properties
When you're drawing on a vector layer and select the Brush  tool, its properties and options appear in the Tool 
Properties view.

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to display 
advanced customization parameters.

 Maximum Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Smoothing
Defines the number of control points added to the centre line. The fewer 
the control points the smoother (but less faithful) the line.

 Brush Presets
Presets are created by saving the properties of the current tool to a new 
preset, which you can reuse for repeated tasks. You can create as many 
presets as you need.

New Brush Allows to create a new preset.
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New Dynamic Brush Allows you to create a new dynamic brush to clone custom patterns. 

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Repaint Brush

The Repaint Brush  is used to repaint zones that have already been 
painted, it will not affect empty zones or pencil lines. You can use this 
mode to paint tones or highlights onto your character.

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines 
created with the existing artwork as you draw in the Drawing or Camera 
view. Brush strokes will flatten with brush strokes and pencil lines will 
flatten with pencil lines.

Size and Smoothness Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 
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Tool Name Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter defines the  width of 
the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the maximum size. If 
you do not have pressure sensitivity from a pen table, the minimum size value will be 
ignored. 

Smoothing
Defines the number of control points added to the centre line. The fewer the control 
points the smoother (but less faithful) the line.

Contour Smoothing
Defines the number of points on the contour share of your stroke. This will smooth 
out the bumps and waves on tour contour shape of your brush strokes.

Tip Shape

Lets you select a tip shape—from round and square ones to star shaped. This option 
is disabled when using a textured brush.
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Close Gap Tool Properties
When you select the Close Gap tool, its properties and options appears in the Tool Properties view. 

Icon Tool Name Description

Auto-Flatten Mode When enabled, the Auto-Flatten  mode automatically 
flattens the new lines created with the existing 
artwork as you draw in the Drawing or Camera view. 
Brush strokes will flatten with brush strokes and 
pencil lines will flatten with pencil lines.
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Contour Editor Tool Properties
When you select the Contour Editor tool, its properties and options appear in the Tool Properties view.

Icon Tool Name Description

Lasso Sets the selection mode to Lasso. Click and hold Alt to 
temporarily switch between the Marquee and Lasso 
modes.

Marquee Sets the selection mode to Marquee. Click and hold Alt 
to temporarily switch between the Marquee and Lasso 
modes.

Snap to Contour Snaps your selection or point to any line you position it 
on. As soon as you move it close enough to another 
line, your point or selection will snap to it. 

 

Snap and Align Snaps the selected anchor point to any existing line 
while displaying temporary rulers as a guide that you 
can also snap your anchor point to. 

Show Contour Editor Con-
trols

Use the Show Contour Editor Controls  option to show 
the contour editor controls. You can use these controls 
to scale, reposition and rotate the selected anchor 
points.

Smooth Selection The Smooth operation lets you smooth out selected 
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drawing strokes and remove extra points.

 l From the top menu, select Drawing> Optimize 
> Smooth or press Alt + Shift + S.
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Cutter Tool Properties
When you select the Cutter  tool, its properties and options appear in the Tool Properties view.

Icon Tool Name Description

Lasso Sets the selection mode to Lasso. Click and hold Alt to 
temporarily switch between the Marquee and Lasso 
modes.

Marquee Sets the selection mode to Marquee. Click and hold Alt to 
temporarily switch between the Marquee and Lasso 
modes.

Use Mouse Gesture When using the Lasso  selection type, the Use Mouse 
Gesture  option lets you automatically delete any extra 
sections of line in your artwork by simply dragging your 
mouse over it. 

NOTE: For this operation to work, you lines 
CANNOT be flattened.

Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 Degrees CW Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW Rotates the current selection 90 degrees counter-clock-
wise.
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Ellipse Tool Properties
When you select the Ellipse tool, its properties and options appear in the Tool Properties view. 

Icon Tool Name Description

 Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Presets

Harmony provides a variety of presets and also lets you create and 
save your own. It is a good idea to create and save pencils with precise 
sizes and parameters when you draw and design for efficiency and 
consistency. 

All tools using pencil lines share the same preset list. Therefore, the 
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same 
preset list.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously 
exported via the Export Brushes command. 

 Export Brushes Allows you to export Harmony presets to backup or import on a 
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different computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Automatic Filling

Use the Automatic Filling  option to automatically fill your shape with the 
selected colour as you draw. By default, the Shape tool creates the 
outline of an empty shape that you can later fill using the Paint tool. 
This option is unavailable for the line tool. 

Snap to Contour
Snaps your selection or point to any line you position it on. As soon as 
you move it close enough to another line, your point or selection will 
snap to it.

Snap and Align
Snaps the selected anchor point to any existing line while displaying 
temporary rulers as a guide that you can also snap your anchor point to.

Snap to Grid

Snaps your selection following the currently enabled grid. 

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new 
lines created with the existing artwork as you draw in the Drawing or 
Camera view. Brush strokes will flatten with brush strokes and pencil 
lines will flatten with pencil lines.
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NOTE: 
Using the Select tool, you can use select and remove a segment of 
flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.
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Envelope Tool Properties
Selecting the Envelope tool displays its properties and options in the Tool Properties view. 

Icon Tool Name Description

 Width and Height Increase the width and height values to add more 
columns and rows to the deformation grids.

Lasso Sets the selection mode to Lasso. Click and hold Alt to 
temporarily switch between the Marquee and Lasso 
modes.

Marquee Sets the selection mode to Marquee. Click and hold Alt 
to temporarily switch between the Marquee and Lasso 
modes.

Snap to Contour Snaps your selection or point to any line you position it 
on. As soon as you move it close enough to another 
line, your point or selection will snap to it.

Snap and Align Snaps the selected anchor point to any existing line 
while displaying temporary rulers as a guide that you 
can also snap your anchor point to.

Snap to Grid Snaps your selection following the currently enabled 
grid. 
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Show Advanced Controls To display more controls,you can click on the Show 
Advanced Controls  button.

Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 Degrees CW Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW Rotates the current selection 90 degrees counter-clock-
wise.

Smooth You can modify the central line smoothness  of your line 
using this option. This parameter smooths the deformed 
lines. Increasing the value will result in a smoother line 
with fewer control points. The more you increase the 
value, the less details and curves you will get. Use the 
left and right arrows to increment the value by one full 
unit. Use the Up - Down slider to quickly increment the 
value.
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Eraser Tool Properties
When you're drawing on vector layer and you select the Eraser  tool, its properties and options appear in the Tool 
Properties view.

Icon Tool Name Description

 Previewing the Stroke

The Preview area lets you see a preview of the selected or customized 
stroke. You can click on the Show Extended Properties arrow to display 
advanced customization parameters.

 Maximum Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Smoothing
Defines the number of control points added to the centre line. The fewer 
the control points the smoother (but less faithful) the line.

 Eraser Presets
Presets are created by saving the properties of the current tool to a new 
preset, which you can reuse for repeated tasks. You can create as many 
presets as you need.
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New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Size and Smoothness Tab 
You can access advanced properties by clicking on the Previewing the Stoke button in the Tool Properties view. 

Tool Name Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter defines the  width 
of the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the maximum size. If 
you do not have pressure sensitivity from a pen table, the minimum size value will 
be ignored. 

Smoothing
Defines the number of control points added to the centre line. The fewer the control 
points the smoother (but less faithful) the line.

Contour Smoothing
Defines the number of points on the contour share of your stroke. This will smooth 
out the bumps and waves on tour contour shape of your brush strokes.

Tip Shape

Lets you select a tip shape—from round and square ones to star shaped. This 
option is disabled when using a textured brush.
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Line Tool Properties
When you select the Line tool, its properties and options appear in the Tool Properties view. 

Icon Tool Name Description

 Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Presets

Harmony provides a variety of presets and also lets you create and save 
your own. It is a good idea to create and save pencils with precise sizes 
and parameters when you draw and design for efficiency and consistency.
 

All tools using pencil lines share the same preset list. Therefore, the 
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same preset 
list.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 
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Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Snap to Contour
Snaps your selection or point to any line you position it on. As soon as you 
move it close enough to another line, your point or selection will snap to it.

Snap and Align
Snaps the selected anchor point to any existing line while displaying tem-
porary rulers as a guide that you can also snap your anchor point to.

Snap to Grid

Snaps your selection following the currently enabled grid. 

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines 
created with the existing artwork as you draw in the Drawing or Camera 
view. Brush strokes will flatten with brush strokes and pencil lines will 
flatten with pencil lines.

NOTE: 
Using the Select tool, you can use select and remove a segment of 
flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.

Auto-Close Gap
When using the pencil tool, you can automatically close strokes with an 
invisible stroke. 
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It is recommended to keep this option enabled when drawing with the 
Pencil tool.
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Paint Tool Properties 
When you select the Paint tool, its properties and options appears in the Tools Properties view.

Icon Tool Name Description

Lasso Sets the selection mode to Lasso. Click and hold Alt 
to temporarily switch between the Marquee and 
Lasso modes. 

Marquee Sets the selection mode to Marquee. Click and hold 
Alt to temporarily switch between the Marquee and 
Lasso modes. 

Paint Modes The Paint tool has three different modes available: 

 l The Paint  mode paints everything it touches, 
including empty and filled zones. 

 l The Paint Unpainted  mode paints only empty 
zones. Any line or filled zone will remain 
unchanged.

 l The Unpaint  mode unpaints everything it 
touches, including empty and filled zones.

Apply to Multiple Drawings The Apply to Multiple Drawings  option is used for 
fast painting in hand-drawn animation. When you 
want to paint several drawings in a same layer at 
once, such as a walk cycle, you can enable this 
option and make a selection in the Camera or 
Drawing view. All the closed zones located within 
your Paint tool selection are painted with the 
selected colour swatch.

You do not need to enable the Onion Skin preview to 
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use this option. The option will stay enabled only for 
the next action. If you want to use it again, you must 
click on the Apply to Multiple Drawings button again, 
or press Alt + A.

Select Newly Painted, and 
Unpainted Contours/Lines

In the Paint   tool properties, this option  keeps a 
selection highlighted around the latest painted zone 
after using the Paint, Unpaint, or Paint Unpainted 
tool.

Close Gap The Close Gap option has four modes available. 
When the option is enabled, Harmony will consume 
more resources while painting.

 l No Close Gap: The moment a zone has a gap 
in it, the Paint tool will not fill the area. 

 l Close Small Gap: If a zone has a small gap in 
it, the Paint tool will fill the area. You can 
zoom out to make the gap appear smaller and 
the Paint tool will paint. 

 l Close Medium Gap: If a zone has a medium 
gap in it, the Paint tool will fill the area. You 
can zoom out to make the gap appear smaller 
and the Paint tool will paint.  

 l Close Large Gap: If a zone has a large gap in 
it, the Paint tool will fill the area. You can 
zoom out to make the gap appear smaller and 
the Paint tool will paint. 
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 Pencil Tool Properties
When you select the Pencil  tool, its properties and options appears in the Tool Properties view. 

Icon Tool Name Description

 Maximum Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Smoothing
Defines the number of control points added to the centre line. The fewer 
the control points the smoother (but less faithful) the line.

 Presets

Harmony provides a variety of pencil presets and also lets you create 
and save your own. It is a good idea to create and save pencils with 
precise sizes and parameters when you draw and design for efficiency 
and consistency.

You can  export the pencil presets that you have created and import 
those that others have created. This is a good way for you and project 
collaborators to keep a consistent look for the project.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.
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 Import Brushes
Allows you to import a set of XML Harmony presets previously 
exported via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a 
different computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new 
lines created with the existing artwork as you draw in the Drawing or 
Camera view. Brush strokes will flatten with brush strokes and pencil 
lines will flatten with pencil lines.

NOTE: 
Using the Select tool, you can use select and remove a segment of 
flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.
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Perspective Tool Properties
Selecting the Perspective tool displays its properties and options in the Tool Properties view. 

Icon Tool Name Description

Selection Tool Options

Lasso Sets the selection mode to Lasso. Click and hold Alt 
to temporarily switch between the Marquee and 
Lasso modes.

Marquee Sets the selection mode to Marquee. Click and hold 
Alt to temporarily switch between the Marquee and 
Lasso modes.

Snap to Contour Snaps your selection or point to any line you position 
it on. As soon as you move it close enough to 
another line, your point or selection will snap to it.

Snap and Align Snaps the selected anchor point to any existing line 
while displaying temporary rulers as a guide that you 
can also snap your anchor point to.

Snap to Grid Snaps your selection following the currently enabled 
grid. 

Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 Degrees CW Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW Rotates the current selection 90 degrees counter-
clockwise.
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Polyline Tool Properties
When you select the Polyline  tool, its properties and options appear in the Tool Properties view. 

Icon Tool Name Description

 Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Presets

Harmony provides a variety of presets and also lets you create and save 
your own. It is a good idea to create and save pencils with precise sizes 
and parameters when you draw and design for efficiency and consistency.
 

All tools using pencil lines share the same preset list. Therefore, the 
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same preset 
list.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes Allows you to export Harmony presets to backup or import on a different 
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computer. 

 
Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Snap to Contour
Snaps your selection or point to any line you position it on. As soon as you 
move it close enough to another line, your point or selection will snap to it.

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines 
created with the existing artwork as you draw in the Drawing or Camera 
view. Brush strokes will flatten with brush strokes and pencil lines will 
flatten with pencil lines.

NOTE: 
Using the Select tool, you can use select and remove a segment of 
flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.
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Rectangle Tool Properties
When you select the Rectangle tool, its properties and options appear in the Tool Properties view. 

Icon Tool Name Description

 Size
Defines the maximum size of your drawing tool. This parameter defines 
the  width of the stroke.

 Presets

Harmony provides a variety of presets and also lets you create and save 
your own. It is a good idea to create and save pencils with precise sizes 
and parameters when you draw and design for efficiency and consistency.
 

All tools using pencil lines share the same preset list. Therefore, the 
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same preset 
list.

New Brush Allows to create a new preset.

Delete Brush Allows you to delete your custom presets. 

 Rename Brush Allows you to rename a custom preset.

 Import Brushes
Allows you to import a set of XML Harmony presets previously exported 
via the Export Brushes command. 

 Export Brushes
Allows you to export Harmony presets to backup or import on a different 
computer. 
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Small Thumbnail, Large 
Thumbnail, and Stroke 
View

Allows you to display the presets as small square thumbnails, large 
square thumbnails or a list of stroke preview. 

Draw Behind

When drawing on vector layers, the Draw Behind mode lets you paint 
behind existing art. By default, strokes appear over your work until you 
release the tool.

Automatic Filling

Use the Automatic Filling  option to automatically fill your shape with the 
selected colour as you draw. By default, the Shape tool creates the outline 
of an empty shape that you can later fill using the Paint tool. This option is 
unavailable for the line tool. 

Snap to Contour
Snaps your selection or point to any line you position it on. As soon as you 
move it close enough to another line, your point or selection will snap to it.

Snap and Align
Snaps the selected anchor point to any existing line while displaying tem-
porary rulers as a guide that you can also snap your anchor point to.

Snap to Grid

Snaps your selection following the currently enabled grid. 

Auto-Flatten Mode

When enabled, the Auto-Flatten  mode automatically flattens the new lines 
created with the existing artwork as you draw in the Drawing or Camera 
view. Brush strokes will flatten with brush strokes and pencil lines will 
flatten with pencil lines.

NOTE: 
Using the Select tool, you can use select and remove a segment of 
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flattened pencil lines. Overlapping pencil lines drawn with the Auto-
Flatten mode are essentially cut into segments by the overlap and 
can be treated as individual lines.
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Reposition All Drawings Tool Properties
When you use the Reposition All Drawings tool, its properties and options appear in the Tool Properties view. 

Icon Option Description

Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 Degrees CW
Rotates the current selection 90 degrees 
clockwise.

Rotate 90 Degrees CCW
Rotates the current selection 90 degrees 
counter-clockwise.

 Offset X and Y

Use the Offset X and Offset Y operation fields 
to enter specific values and precisely 
reposition the selected shape.

 1. X: Type a value in this field to repos-
ition your selection along the X-axis.

 2. Y: Type a value in this field to repos-
ition your selection along the Y-axis.

 3. Up/Down arrows: Use the up and 
down arrows to modify the value in the 
X or Y value field.

 Width and Height
Use the Width and Height operation fields to 
enter specific values to resize the selected 
shape with precision.
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 1. Width: Type a value in this field to res-
ize the width of your selection.

 2. Height: Type a value in this field to res-
ize the height of your selection.

 3. Up/Down arrows: Use the up and 
down arrows to modify the value in the 
Width or Height fields.

 4. Lock icon: Click the lock icon to lock 
or unlock the ratio between the Width 
and Height values.

 Angle

The Angle operation lets you to enter specific 
values and accurately rotate the selected 
shape.

 1. Angle: Type a degree value in this field 
to rotate your selection.

 2. Up/Down arrows: Use the up and 
down arrows to modify the value in the 
Angle value field.
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Rigging Tool Properties
In the Tool Properties view, you can customize not only the behaviour of the tool but also the settings of the 
deformers that you will create.

Mode
Name Button Description

Bone Mode Sets the Rigging tool to create Bone deformers.

Game Bone Mode Sets the Rigging tool to create Game Bone deformers.

Options
Parameter Button Description

Show All Manipulators 
(Show All Controls)

Lets you immediately see the resting position in red (Setup) 
and the animated position in green.

Operations
Name Button Description

Reset Deform (Reset Cur-
rent Keyframe)

Copies the resting position of the deformation skeleton to 
the current frame.
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Select Tool Properties
When you use the Select  tool, its properties and options appear in the Tool Properties view. 

Icon Tool Name Description

Selection Tool Options

Lasso Sets the selection mode to Lasso. Click and hold Alt to 
temporarily switch between the Marquee and Lasso modes. 

Marquee Sets the selection mode to Marquee. Click and hold Alt to 
temporarily switch between the Marquee and Lasso modes. 

Snap to Contour Snaps your selection or point to any line you position it on. As 
soon as you move it close enough to another line, your point or 
selection will snap to it.

Snap and Align Snaps the selected anchor point to any existing line while dis-
playing temporary rulers as a guide that you can also snap your 
anchor point to.

Snap to Grid Snaps your selection following the currently enabled grid. 

Select by Colour Lets you select all the zones and lines in your drawing painted 
with the same colour swatch. 
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In the Camera or Drawing view, click on any zone or line in your 
drawing. All zones and lines of the same colour are selected. 
Click the Select tool again to return to the regular Select mode.

NOTE: Only the zones painted with the SAME colour 
swatch will be selected. If another zone is coloured with the 
exact same RGB value (same colour), but not painted with 
the same colour swatch, it will not be selected.

Works on Single Draw-
ing

By default, when you draw a selection box in the Camera view, 
the Select tool will select only the drawing strokes of the current 
drawing. If you prefer the Select tool to select all the strokes on 
all layers, you can disable the Works on Single Drawing option in 
the Tool Properties view or disable the Select tool Works on 
Single Drawing preference. To do this, go to the top menu, select 
Edit > Preferences > Camera (Windows/Linux) or Harmony 
Essentials > Preferences > Camera (Mac OS X) and uncheck 
the Select tool Works on Single Drawing option.

 

Icon Tool Name Description

Selection Tool Operations
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Flip Horizontal Flips the current selection horizontally.

Flip Vertical Flips the current selection vertically.

Rotate 90 Degrees 
CW

Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees 
CCW

Rotates the current selection 90 degrees counter-clockwise.

Smooth Smooth out selected drawing strokes and remove extra points.

Flatten Merges drawing objects and brush strokes into a single layer. If 
you draw new lines to fix a drawing or line with many brush 
strokes, it can be useful to flatten them all into a single shape. By 
default, lines are drawn one on top of each other. If you intend to 
repaint the lines or modify their shape, it will be easier if they are 
flattened. 

Create Colour Art 
from Line Art

Lets you use the outline you traced on one of the four embedded 
layers (line art, colour art, overlay, underlay) and create invisible 
strokes to paint your drawings on separate layers. This provides 
more inking and painting flexibility. 

You can also configure this option to create the invisible strokes 
on any of the four embedded layers.

Distribute to Layers The Distribute to Layers  option is used to separate the selected 
art strokes and send them to new drawing layers. In the Camera 
view, once you have drawn your artwork, you can select the 
strokes you want to distribute using the Select  tool and click on 
the Distribute to Layers  button; you can also select Drawing > 
Distribute to Layers. It will automatically take every stroke from 
the drawing selection made in the Camera view and separate 
them into a different layer for each. If an artwork is composed of 
several strokes, you must group them using Edit > Group > 
Group before using the Distribute to Layers option. This option 
cannot be done from the Drawing view.
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Pencil to Brush Converts the selected centre line pencil strokes into contour 
strokes brush lines.

 Offset X and Y Use the Offset X and Offset Y operation fields to enter specific 
values and precisely reposition the selected shape.

 1. X: Type a value in this field to reposition your selection 
along the X-axis.

 2. Y: Type a value in this field to reposition your selection 
along the Y-axis.

 3. Up/Down arrows: Use the up and down arrows to modify 
the value in the X or Y value field.

 Width and Height Use the Width and Height operation fields to enter specific values 
to resize the selected shape with precision.

 1. Width: Type a value in this field to resize the width of your 
selection.

 2. Height: Type a value in this field to resize the height of 
your selection.

 3. Up/Down arrows: Use the up and down arrows to modify 
the value in the Width or Height fields.

 4. Lock icon: Click the lock icon to lock or unlock the ratio 
between the Width and Height values.

 Angle The Angle operation lets you to enter specific values and 
accurately rotate the selected shape.

 1. Angle: Type a degree value in this field to rotate your 
selection.

 2. Up/Down arrows: Use the up and down arrows to modify 
the value in the Angle value field.
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 Adjusting the Pencil 
Line Thickness

When you select a pencil line with the Select tool, additional 
options appear in the Tool Properties view. 

Use the Adjusting the Pencil Line Thickness operation field to 
resize the selected centreline strokes. This operation is not 
permitted on contour line shapes, such as brush strokes or shape 
fills.

 Adjusting the Text 
Selection

When you select text with the Select tool, the  tool properties will 
display the Text tool options on the bottom of the view. You can 
also press Alt + 9 to display only the Text properties in the Tool 
Properties view—see Text Tool Properties on page 161.
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Smooth Editor Tool Properties
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view. 

Icon Tool Name Description

Smoothing 
Style 

The Smoothing Style options allow you to smooth a portion of your drawing by tracing a 
smoothing stroke over the zone to optimize or by selecting an area of the drawing with 
the Marquee or Lasso.

Note that by default, the Smooth Editor tool colour is yellow, it was changed to orange 
for screen grab clarity.

 

Show Control 
Points 

The Show Control Points  option allows you to show or hide the Bezier points around 
lines. When the Bezier points are displayed, you can see the result of your smoothing 
and the number of points left on the curve. When it is turned off, only the original artwork 
is displayed.

 Minimum 
Size and Max-
imum Size 

This is where you set the minimum and maximum sizes of your drawing tool which will 
produce the thick and thin effect on your stroke. This works with the pressure sensitivity 
of a pen tablet.

This options is available while using the Brush Smoothing  style.

 l Maximum and Minimum Size: Defines the maximum and minimum width of the 
stroke.

 l Up/Down arrows: Use the up and down arrows to set the minimum and max-
imum size value.

Smoothness The Smoothness impacts the strength of the smoothing result. The higher the value, the 
more points are removed and the smoother the curve. The Smoothness range is from 0 
to 100; the default value is 20.
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 Colour You can modify the colour of the control points displayed on the artwork while working 
with the Smooth Editor tool by double-clicking on the colour swatch.
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Stroke Tool Properties
When you select the Stroke tool, its properties and options appears in the Tool Properties view. 

Icon Tool Name Description

Draw Stroke as Straight 
Lines 

Enable the Draw Stroke as Straight Lines  option if 
you want the new strokes you draw to be a perfect 
straight line. Disable the option if you want the stroke 
to follow the mouse gesture.

Connect Line Ends Enable the Connect Line Ends  option if you want the 
start or end point of your new stroke to connect to 
your existing strokes to make sure no gaps are left in 
your drawing.

Auto-Flatten Mode When enabled, the Auto-Flatten  mode automatically 
flattens the new lines created with the existing 
artwork as you draw in the Drawing or Camera view. 
Brush strokes will flatten with brush strokes and 
pencil lines will flatten with pencil lines.

 Smoothness You can modify the central line smoothness  of your 
line using this option. This parameter smooths the 
initial movement of your line. Increasing the value 
will result in a smoother line with fewer control 
points. Use the left and right arrows to increment the 
value by one full unit. Use the Up - Down slider to 
quickly increment the value.
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Text Tool Properties
Use the Text tool's properties to select the font type and other formatting options you want to apply to the text.

If you already wrote your text, you must first use the Text tool and select the text portion you want to format. You 
can modify the parameters of an entire text box using the Select tool. 

Icon Tool Name Description

 Font Type Use the Font drop-down menu to select a font. OTF 
fonts are supported.

Bold Use this option to bold your text selection. 

Italic Use this option to italicize your text selection. 

 

Left Alignment Use this option to left align the paragraph. 

Centered Alignment Use this option to center align the paragraph. 
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Right Alignment Use this option to right align the paragraph. 

Justified Alignment Use this option to justify align the paragraph. 

 Font Size Enter a size for the text. 

 Kerning Use the kerning field to modify the spacing between 
letters and characters. You can select the Auto Kern 
option to set the kerning automatically based on the 
font’s predefined standard. A negative value decreases 
spacing between each character, creating a letter 
overlap and a positive value increases it.

 Indent Enter a value in the Indent field to increase or decrease 
the indentation on the first line of your text. A positive 
value sets the first line of your paragraph farther to the 
right and a negative value sets it farther to the left.

162



Harmony 14 Essentials - Reference Guide

 Line Spacing Enter a value in the Line Spacing field to decrease or 
increase the space between each line of text.
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Transform Tool Properties 
When selecting the Transform tool, several options are available in the Tool Properties view.

Icon Tool Name Description

Lasso
Sets the selection mode to Lasso. Click and hold Alt to temporarily 
switch between the Marquee and Lasso modes. 

Marquee
Sets the selection mode to Marquee. Click and hold Alt to temporarily 
switch between the Marquee and Lasso modes. 

Peg Selection Mode

In the Camera view, the Peg Selection Mode limits the selection to peg 
layers instead of drawing layers. This mode is useful when you have 
created a character rig using peg layers for each drawing.  That way, you 
do not accidentally select the drawing layer when you want to animate 
on the peg.

When disabled, the Transform  tool selects the drawing layers.

Snap and Align
Snaps the selected anchor point to any existing line while displaying tem-
porary rulers as a guide that you can also snap your anchor point to.

Snap to Grid

Snaps your selection following the currently enabled grid. 

Hide Manipulator Con-
trols

The Hide Manipulator Controls  button lets you hide the bounding box and 
manipulator controls from the Camera view when an element is 
selected.

Flip Horizontal

Flips the current selection horizontally. 

You can also select Animation > Flip > Flip Horizontal from the top 
menu or press 4 or 5.

Flip Vertical

Flips the current selection vertically.  

You can also select Animation > Flip > Flip Vertical from the top menu 
or press 4 or 5.
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Rotate 90 Degrees CW Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW Rotates the current selection 90 degrees counter-clockwise.

 Offset X and Y

Use the Offset X and Offset Y operation fields to enter specific values 
and precisely reposition the selected shape.

 1. X: Type a value in this field to reposition your selection along the 
X-axis.

 2. Y: Type a value in this field to reposition your selection along the 
Y-axis.

 3. Up/Down arrows: Use the up and down arrows to modify the 
value in the X or Y value field.

 Width and Height

Use the Width and Height operation fields to enter specific values to 
resize the selected shape with precision.

 1. Width: Type a value in this field to resize the width of your selec-
tion.

 2. Height: Type a value in this field to resize the height of your selec-
tion.

 3. Up/Down arrows: Use the up and down arrows to modify the 
value in the Width or Height fields.

 4. Lock icon: Click the lock icon to lock or unlock the ratio between 
the Width and Height values.

 Angle

The Angle operation lets you to enter specific values and accurately 
rotate the selected shape.

 1. Angle: Type a degree value in this field to rotate your selection.

 2. Up/Down arrows: Use the up and down arrows to modify the 
value in the Angle value field.
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Zoom Tool Properties
When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Parameter Button Description

Zoom Tool Options
Zoom In Zooms in

Zoom Out Zooms out

Operations

Perform Zoom In
Zoom in the Camera or Drawing view. 

The keyboard shortcut is 2.

Perform Zoom Out
Zoom out the Camera or Drawing view. 

The keyboard shortcut is 1.

Reset Zoom Restores the current zoom level to 100%.

Reset View
Restores the original display by resetting any 
pan, rotation or zoom actions.
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Chapter 6: Toolbars
Harmony contains toolbars which, by default, are located at the top of the interface. Some views also have a toolbar 
which you can reposition to suit your work style. You can show or hide toolbars, as well as customize it with the 
tools you use most often and hide the ones you don't.

Top Toolbars 168

Advanced Animation Toolbar 169

Deformation Toolbar 170

Edit Toolbar 172

File Toolbar 173

Game Toolbar 174

Playback Toolbar 175

Scripting Toolbar 176

Tools Toolbar 177

Workspace Toolbar 180

View Toolbars 181

Timeline View Toolbar 182

Xsheet View Toolbar 183
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Top Toolbars
Harmony has a series of toolbars that are added by default at the top of the interface. These toolbars can be 
moved on the sides of the interface as well as within specific views. 

All top toolbars can be added through the top menu Windows > Toolbars > desired toolbar.

Advanced Animation Toolbar 169

Deformation Toolbar 170

Edit Toolbar 172

File Toolbar 173

Game Toolbar 174

Playback Toolbar 175

Scripting Toolbar 176

Tools Toolbar 177

Workspace Toolbar 180
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Advanced Animation Toolbar
The Advanced Animation toolbar contains tools to position and animate layers. The Scale, Translate and Rotate 
tools can be used to reposition the permanent pivot position of a layer. Unlike the Transform tool, each tool in the 
Advanced Animation toolbar performs a single operation, either rotate, scale, translate or scale in relation to the 
camera distance.

How to access the Advance Animation toolbar

 1. Select Windows > Toolbars > Advanced Animation.

Icon Tool Name Description

Translate Lets you move the selected element along the X and Y 
axes.

Rotate Turns a selected element around its pivot point. 

Scale Increases or decreases the size of a selected element. 
You can scale an object up to make it larger or down to 
make it smaller. Press Shift to scale the element while 
maintaining its proportions.

Skew Slants the selected element.

Maintain Size Keeps elements the same size aspect ratio in the Cam-
era view as you move them towards or away from the 
camera.

Spline Offset Lets you reposition the visual trajectory without off-
setting or modifying your animation. By default, the tra-
jectory is located at 0,0,0 fields. If your elements were 
drawn in a different location than the centre of the draw-
ing area, it will look like the trajectory is not aligned with 
your drawing. Also, if you have several elements 
attached to one trajectory, you might want your tra-
jectory to be at a different location to represent the 
group's motion better.
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Deformation Toolbar
T-RIG-007-009

The Deformation toolbar contains the various tools and options used to create a deformation rig. This toolbar is 
displayed in the default interface.

By default, the Deformation toolbar only contains the essential options. If you right-click on the toolbar and select 
Customize, you can add additional buttons.

 

Icon Tool Name Description

Rigging Tool

The Rigging tool is used to create a Bone deformation 
chain. You also use it to set up the resting position.

To learn more about the Rigging tool's properties, see 
Rigging Tool Properties on page 152.

Show Selected Manip-
ulators and Hide All Oth-
ers

The Show Selected Manipulators and Hide All Others  
button hides all manipulators displayed in the Camera view. 
Only the manipulators of the selected deformation node are 
displayed

Reset Current Keyframe

The Reset Current Keyframe copies the resting position, 
the original setup of your skeleton before undergoing any 
deformation, to your current frame. Once you have created 
a deformation chain, you can use the Rigging tool to adjust 
the position and appearance of the rig to fit the element. 
When the skeleton is in place, you can use the Reset 
Current Keyframe button to reset the current frame position 
to the resting position.

Enable Deformations

The Enable Deformations button allows you to display your 
drawings in their original state or with deformations while 
creating additional drawings. Depending on the artwork you 
need to create, you might need to refer to the other images 
either deformed or in their original position.

NOTE: Disabling deformations is only a display mode. 
Although drawings will not appear deformed in the 
Camera view, even in Render View mode, they will still 
be deformed in the rendered images.

Remove All Keyframes The Remove All Keyframes option removes all keyframes 
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on the selected deformation chain.

Show All Controls

The Show All Controls button lets you visualize the resting 
position in red (Setup mode) and the active position 
(Animation) in green at the same time
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Edit Toolbar
The Edit toolbar contains common operations such as Copy, Paste, Cut, Undo and Redo. These options can also 
be found in the Edit menu.

How to access the Edit toolbar

 1. Select Windows > Toolbars > Edit.

 

Icon Tool Name Description

Undo Removes the last change made to your project. 
Harmony supports multiple undo, so you can undo 
changes you made in the order you made them.

Redo Redoes an operation you have undone. This 
command is active only after you use the Undo 
command.

Cut Removes selected objects. You can then paste the 
object or its properties to another object.

Copy Copies selected objects and properties.

Paste Places an object you cut or copied into the location 
you select in a view.

Create Symbol Creates a symbol from selected drawing elements in 
the Drawing or Camera view or a layer or cells in the 
Timeline view.
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File Toolbar
The File toolbar contains the common file operations such as New, Save and Open. These options can also be 
found in the File menu.

How to access the File toolbar

 1. Select Windows > Toolbars > File.

 

Icon Tool Name Description

New (Harmony Stand 
Alone)

Creates a new scene while closing any scene already 
open. The New Scene dialog box opens, asking for 
directory, name, and resolution information.

Open Displays the Open Scene dialog box where you can 
browse for a scene file.  You can open a new scene from 
the current one and the previous scene will close.

Save Saves all changes made to the opened scene, 
drawings, palettes, and palette lists.

Save As Saves the current file with a different name and at a 
different location.

Saves the current state of a scene as another scene. 
The Save As window prompts you for a new name and 
a different location for this scene before saving it. This 
will create a complete scene directory for the new 
scene.

NOTE: The scene name cannot exceed 23 char-
acters.

Import Images Imports bitmap images which you can choose to 
vectorize.
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Game Toolbar
The Game toolbar contains tools for setting anchors and props, as well as exporting to sprite sheets and Easel 
JS.

How to access the Game toolbar

 1. Select Windows > Toolbars > Game.

Icon Tool Name Description

Toggle Anchor Adds the Anchor parameter to the selected layer.

Toggle Prop Adds the Prop parameter to the selected layer.

Export to Sprite Sheets Opens the Export to Sprite Sheets window where 
you can export your animation as sprite sheets .

Export to Easel JS Opens the Export to Easel JS window where you can 
export your animation as Easel JS.
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Playback Toolbar
The Playback toolbar lets you play back animation and sound. Use it to scrub the sound to create your lip-sync, loop 
the playback, navigate through frames, and change the playback range and speed.

Name Button Description

Play

Plays and stops the animation.

You can also select Play > Play Scene 
Forward or Stop.

Render and Play
Creates a render of your scene to play back the 
final result including the effects.

Loop

Repeatedly plays back your animation 
indefinitely.

You can also select Play > Loop.

Sound
Enables sound in the playback. 

You can also select Play > Enable Sound.

Sound Scrubbing

Enables sound scrubbing in the playback.

You can also select Play > Enable Sound 
Scrubbing.

Jog Frames Lets you scroll through the playback’s frames.

Frame ---
Lets you move the playhead by entering a frame 
number.

Start ---

Lets you change the start frame by entering a 
new value in the Start field.

You can also click on Start button to set the start 
frame at the current frame.

Stop ---

Lets you change the end frame by entering a new 
value in the Stop field.

You can also click on Stop button to set the end 
frame at the current frame.

FPS ---
Lets you enter a new value to change the speed 
of the playback.

175



Chapter 6: Toolbars     Top Toolbars

Scripting Toolbar
The Scripting toolbar lets you import and access scripts for automating actions and operations.

How to access the Scripting toolbar

 1. Select Windows > Toolbars > Scripting.

Icon Tool Name Description

Manage Scripts Opens the Scripts Manager dialog box where you 
can add scripts and functions to your Scripting 
toolbar.

Stop Script Stops the execution of a script launched from the 
Scripting toolbar.
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Tools Toolbar
The Tools toolbar contains all the main tools you need to work in Harmony. In the default workspace, this toolbar 
located on the left-most side of the interface. A small triangle at the lower-right corner of a tool indicates additional 
tools under the main tool. To access these tools, hold down the left mouse button until the additional tools appear, 
then select one. 

You can display the Tools toolbar horizontally if you find it more efficient for your workflow. Be sure to restart 
Harmony in order to see the new position of the Tools toolbar.

How to display the Tools toolbar as a flat (horizontal) toolbar

 1. Do one of the following:

 l Select Edit > Preferences (Windows/Linux) or Harmony Essentials > Preferences (Mac 
OS X). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the General tab.

 3. In the Options section, select the Flat Tool Toolbar option.
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 4. Click OK and restart Harmony.

 

Tool Name Icon Description

Select
Lets you select elements from the Camera and Drawing 
views.

Cutter Lets you cut a drawing area to move, copy, cut or delete it.

Reposition All 
Drawings

Lets you reposition, scale, rotate or skew all drawing strokes 
on every drawing included in a layer.

Contour Editor
Lets you add, remove or modify points on a vector line and 
control them.

Pencil Editor Lets you modify the thick and thin contours of a pencil line.

Smooth Editor
Lets you optimize contours and reduce the number of points 
on a line.

Perspective Lets you deform a drawing selection and alter its perspective.

Envelope
Lets you deform and warp part of a drawing using a grid 
envelope and Bezier handles.

Edit 
Gradient/Texture

Lets you modify the position of a gradient or texture colour 
within a specific zone.

Brush
A pressure-sensitive tool for creating a contour shape with a 
thick and thin line effect, as if created with a paint brush.

Pencil
A pressure-sensitive tool for  drawing the final images, such 
as character nodes, cut-out puppet and clean animation. 
Creates a central vector shape.

Text
Lets you type text in your project using various fonts and text 
attributes.

Eraser
A pressure-sensitive tool for precisely erasing parts of a 
drawing.

Paint Lets you paint both empty and filled zones.

Ink
Lets you paint only the segment you clicked on between two 
intersections to be painted.

Paint Unpainted
Lets you paint only empty zones. Lines and filled zones 
remain unchanged.

178



Harmony 14 Essentials - Reference Guide

Repaint
Lets  you paint zones except empty zones. Any zone that is 
not painted remains intact.

Unpaint Lets you unpaint empty and filled zones.

Stroke Lets you draw stokes, connect line ends and flatten lines.

Close Gap
Lets you close small gaps in a drawing by creating small, 
invisible strokes between the two closest points.

Line Lets you draw straight lines which you can then edit.

Rectangle Lets you draw rectangles which you can then edit.

Ellipse Lets you draw ellipses which you can then edit.

Polyline Lets you draw polylines lines which you can then edit.

Dropper Lets you pick a colour directly from a drawing.

Drawing Pivot Lets you set pivots on a characters, drawings and symbols.

Morphing
Lets you control a morphing sequence by placing different 
types of hints to help Harmony morph the animation the way 
you want it.

Hand Lets you pan the Drawing or Camera view.

Zoom Lets you zoom in and out of the Drawing or Camera view.

Rotate View
Lets you rotate the Drawing or Camera view just like with a 
real animation disc. Can also be used in Perspective view.

Animate Mode
Automatically creates a keyframe on the drawing layer. Used 
to animate layers over time.

Transform
Lets you create a global selection so you can reposition, 
scale, rotate and skew as one unit, which is useful for cut-out 
characters.

Inverse Kinematics
Lets you pull on a character's extremities, such as the hands 
and feet, and have the rest of the body follow. Can be used 
on any piece connected in a hierarchy. 

Onion Skin
Displays the previous and next frames of an animation. 
Useful when animating cut-out characters.
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Workspace Toolbar
The Workspace toolbar lets you load other workspaces. The first time you start Harmony, the default workspace 
is loaded. Other workspaces are available such as the Hand-Drawn Animation and Compositing workspaces; 
these display different views and toolbars. You can access these workspaces and any you create, from the 
Windows menu and the Workspace toolbar.

How to access the Workspace toolbar

 1. Select Windows > Toolbars > Workspace.

 

Icon Tool Name Description

 Workspace List Allows you to select an existing workspace.

Workspace Manager Opens the Workspace Manager where you can 
organize, display, and remove workspace from your 
list.

Save Workspace When the Automatically Save Workspace pref-
erence is disabled, the Save Workspace button 
becomes available. This allows you to manually 
save your new workspace configuration.
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View Toolbars
Harmony has a series of view specific toolbars that are only available in a given view. These toolbars can be moved 
only within their view. 

All view toolbars can be added, as long as the view is visible, through the top menu Windows > Toolbars > desired 
toolbar.

Timeline View Toolbar 182

Xsheet View Toolbar 183
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Timeline View Toolbar
The 3D Graph toolbar works in conjunction with the elements in the 3D Graph view.

Button Name Description

 Set Ease Type  

Create Empty Drawing  

Duplicate Drawing  

Insert Keyframe  

Delete Keyframes  

Set Motion Keyframe  

Set Stop-Motion Keyframe  

Go to Previous Keyframe  

Go to Next Keyframe  

Add Key Exposure  

Delete Key Exposure  

Centre On Selection  

Set Ease for Multiple Parameters  

Fill Empty Cells  

Paste Special  

Enable/Disable  

How to access the Timeline view toolbar

You can add the Timeline view toolbar to the Timeline view by:

 l Going to the top menu and selecting Windows > Toolbars > Timeline view.

 l Right-clicking on the space at the top of the Timeline view and selecting Timeline view.
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Xsheet View Toolbar
The Xsheet toolbar contains the common timing operations such as Add Column, Delete Column, Clone Column, 
and so on. These options can also be found in the top menu.
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Chapter 7: Views
The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify 
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a view.  

When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are 
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing or 
other type of selection or the option does not apply to the active view.

Camera View 186

Colour View 191

Drawing View 195

Function View 197

Integrated Help View 199

Layer Properties View 200

Library View 202

Message Log View 204

Script Editor View 205

Side View 207

Timeline View 209

Tool Properties View 216

Top View 217

Xsheet View 219
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Camera View
The Camera view is the centre of operations in Harmony. In this view, you will draw, paint, animate, create 
animation paths and see your results. You can also move through your symbol’s hierarchy.

The Camera view has a top and bottom toolbar that you can use to navigate in the view, change the display 
mode, or go back up your symbols hierarchy. 

How to access the Camera view

Do one of the following:

 l From the top menu, select Windows > Camera.

 l From any of the other views, click the Add View  button and select Camera.

 

Ico-
n

Section Description

Editing 
Stack

The Editing Stack menu displays the names of the symbols and their hierarchy when you are 
editing a symbol. You can click on the different names to go back up to the different parent 
symbols or the top/current project.

 Camera 
View 
Toolbar

The Camera View toolbar contains all the tools and options you can use in the Camera view to 
draw, animate or set up the scene. The toolbar can be displayed or hidden by right-clicking on it 
and selecting or deselecting the Camera View toolbar—see Camera View Toolbar.

Light 
Table

When you have a drawing layer or drawing selected, the Light Table button  button allows you to 
fade the colours of the other layers so you can see the current artwork better as you edit with a 
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drawing tool. Note that the light table does not work when using a layer editing tool, such as the 
Transform  tool.

Current 
Drawing 
on Top

When this button is enabled, the drawing that you are currently editing with a drawing tool is 
temporarily displayed in front of all the other elements. The actual scene is not modified.

Camera 
Mask

The Camera Mask  button shows or hides Displays a black mask around the scene’s frame to 
avoid seeing the unnecessary artwork. This option is handy when you're animating and setting 
up the scene. It allows you to see your scene’s composition better.

You can also access this from the top menu by selecting View > Show > Camera Mask.

Safe 
Area 

The Safe Area  button shows or hides Displays the TV safety zone and the centre of the camera 
frame. The safe area adapts to the scene resolution, as well as the safety zone and frame’s 
centre.

You can also access this feature from the top menu by selecting View > Show > Safe Area.
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Outline 
Locked 
Drawing
s

Drawings that are locked in the Timeline view (cannot be selected in the Camera view) are 
displayed as wireframes.

Reset 
View 

The Reset View  button resets any panning, zooming or rotation done in the Camera view and 
returns the display to the initial settings. You can also press Shift + M.

 Zoom 
Menu

The Zoom menu lets you enlarge or reduce the Camera or Drawing view display. 

To make the camera frame size always match the size of your view, select the Fit to View 
option. Click the drop-down arrow and select a zoom level or press 1 and 2.

OpenGL 
View 
Mode 

The OpenGL View Mode  button switches the Camera view to fast display, letting you see your 
animation play in real time. The OpenGL display requires less memory. The final look of your 
effects is not shown in the OpenGL View Mode. You must switch to the Render View Mode to 
see your effects.
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Render 
View 
Mode

The Render View Mode  button swithes the Camera view to a fully rendered display showing 
the final image of the current frame. If a modification is done to your current frame or if you 
move to a different frame, click the Update Preview button to update the display if your 
preview does not update automatically.The Render View Mode display lets you see the final 
look of your frames including effects and antialiasing. You cannot play back your scene in 
Render View Mode. To see your scene fully rendered and to play it back, you must press the 
Render and Play  button in the Playback toolbar.

Matte 
View 
Mode

The Matte View Mode  button switches the Camera view to a matte display showing the alpha 
channel of the elements in your scene. The transparency level ranges from 0 to 100 percent. 
Zero percent is completely transparent and represented by black and 100 percent is completely 
opaque and represented by white. Everything in between these extremes has a transparency 
level somewhere between 1 and 99 percent and is represented in various shades of grey. 

 l To access the Matte View mode, click on the Render View  button and select Matte 
View  from the drop-down menu.
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Depth 
View 
Mode

The Depth View mode displays images in a relative white to black gradient scale. The object(s) 
closest to the camera are displayed in white and the object(s) furthest from the camera are 
displayed in black. If the position of the last object changes along the z-axis, that object will still 
remain black, so long as it retains its position as the object the farthest back. It does not matter 
where that object is in 3D space, it just matters what its position is relative to the other object in 
the same space. The objects closest and farthest from the camera set the range of the white to 
black scale. All the other objects fall somewhere in between.

 l To access the Depth View mode, click on the Render View  button and select Depth 
View  from the drop-down menu.

 Drawing 
Name 

The Drawing Name field displays the name of the selected drawing, as well as the layer 
containing it. If the cell does not contain any drawing, an Empty Cell text is shown in the 
field.

 Tool 
Name 

The Tool Name field displays the name of the selected tool. If you temporarily override a 
drawing tool using a keyboard shortcut, the tool’s name will be highlighted in red. You can 
temporarily override a tool by holding its keyboard shortcut without the Alt key. For example, 
the Select tool shortcut is Alt + S. If you hold down the S key, you will switch to the Select tool. 
When you release the key, you will return to the tool you were using.

 Frame 
Number 

The Frame Number field displays the number of the current frame.

 Selected 
Colour

The colour swatch displays the currently selected colour in the Colour view.
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Colour View
The Colour view is where you create colours and palettes and import existing palettes into your project. The Colour 
view is also necessary for drawing, painting and creating colour styling.

How to access the Colour view

Do one of the following:

 l From the top menu, select Windows > Colour.

 l From any of the other views, click the Add View  button and select Colour.

Icon Section Description

View Menu The View menu contains all the commands and options 
that you can use in the Colour view to manage colours 
and palettes.

 Show/Hide Palette List 
View

The Show/Hide Palette List View   button lets you 
display the Palette List view in the Colour view. This 
option is for the advanced user who wants to create 
colour palettes for their props and characters.
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Add Palette The Add Palette  button lets you add a new palette to the 
bottom of your palette list.

Remove Palette The Remove Palette  button lets you delete the currently 
selected palette. If the colour swatch is used in your 
project, zones painted with colour swatches which have 
been deleted will turn red, easily identifying them so you 
can repaint them with another colour swatch.

Link Palette The Link Palette button lets you access other palettes 
created in the project and link them to your scene.

Order Palette List The Up and Down arrows let you reorder the selected 
palette. When using clone palettes (colour styles), the 
highest palette is the list will override its clone located 
lower in the list.

Add Colour The Add Colour  button lets you add a new colour 
swatch to the bottom of your colour list.

Remove Colour The Remove Colour  button lets you delete the currently 
selected colour swatches. If the colour swatch is used 
in your project, the Delete Colour dialog box will appear 
asking you to confirm the operation. Click OK to 
confirm the operation or Cancel to cancel it.

192



Harmony 14 Essentials - Reference Guide

Zones painted with colour swatches which have been 
deleted will turn red, easily identifying them so you can 
repaint them with another colour swatch.

Add Texture The Add Texture  button lets you add a bitmap colour 
swatch to your palette. You can load photos and 
textures and paint your drawings with it. The bitmap 
image must be a .tga or .psd file format.

 Colour Swatch Name Each colour swatch available in the Colour view can 
have its own name, making it easy to identify which 
colour is used to paint what part of your character or 
background. 

Two colours can have the same name.

 Colour Swatch A colour swatch is a specific colour used to paint a 
certain zone of a character or background. Colour 
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palettes are composed of colour swatches. They can 
also be called colour pots. When you paint a zone with a 
colour swatch, the zone is linked to the swatch. So if 
you update the swatch’s tint, the zone will be updated 
along with it. This allows you to modify your animation 
colours even after it is completely painted.
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Drawing View
In Harmony, you can draw in the Drawing or Camera view. Although the two views are similar, when it comes to 
drawing, there are some differences.

Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light table 
to display the current drawing of all the enabled layers of your scene in washed-out colours, or the Onion Skin to 
display the previous and next drawings of the currently selected drawing layer.

How to access the Drawing view

Do one of the following:

 l From the top menu, select Windows > Drawing .

 l From any of the other views, click the Add View  button and select Drawing.

 

Icon Section Description

 Drawing Area This is the main space in the Drawing view. It is where 
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you draw and where the drawings are displayed.

 Zoom Menu The Zoom menu lets you enlarge or reduce the Camera 
or Drawing view display. 

To make the camera frame size always match the size 
of your view, select the Fit to View option. Click the 
drop-down arrow and select a zoom level or press 1 and 
2.

 Drawing Name The Drawing Name field displays the name of the 
selected drawing, as well as the layer containing it. If 
the cell does not contain any drawing, an Empty Cell 
text is shown in the field.

 Tool Name The Tool Name field displays the name of the selected 
tool. If you temporarily override a drawing tool using a 
keyboard shortcut, the tool’s name will be highlighted in 
red. You can temporarily override a tool by holding its 
keyboard shortcut without the Alt key. For example, the 
Select tool shortcut is Alt + S. If you hold down the S 
key, you will switch to the Select tool. When you 
release the key, you will return to the tool you were 
using.

 Frame Number This field displays the current frame of the animation 
you are working on.

 Cursor Coordinates This indicates the position of the your pointer in the 
drawing area.

 Colour Picker The Colour Picker allows you to select a colour for 
drawing.
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Function View
The Function view lets you edit function curves and parameters. It contains a visual graph for adding, removing, and 
editing keyframes, as well as adjusting the velocity. The Function view allows you to display multiple functions in 
the background as a reference.

How to access the Function view

Do one of the following:

 l From the top menu, select Windows > Function.

 l From any of the other views, click the Add View  button and select Function.

How to display functions in the Function view

 1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

 2. To display a function in the Function view, click on the layer containing the functions to adjust in the Timeline 
view.
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 3. To select the functions you want to edit, select them in the Function list.

Parameter Description

Function List

When selecting a layer in the Timeline view, all the corresponding functions are 
displayed (if any).  Select the functions you want to see and edit, and hide the 
ones you don't.

Display Toolbar

Allows you to modify how the editing area is displayed. You can hide the grid, 
disable the synchronization with the current frame, reset the zoom level and 
normalize the function display by stacking them one over the other to compare 
them regardless of their value range.

Current Frame Displays the current scene frame.

Selected Keyframe Value Displays the value of the selected keyframe.

Display Advanced Parameter 
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the 
curve around the selected keyframe.

Keyframe, Velocity and Inter-
polation Options

This toolbar lets you add and delete keyframes, adjust the velocity curve, 
adjust the segments to motion or stop-motion keyframes and set the velocity 
to create steps instead of a constant progression.

Function Types
This toolbar lets you click on the different function types to enable or disable all 
the listed functions of that type.

Value Scale
Displays the value range for the displayed editing area. It can be referenced to 
know the value of a keyframe.

Selected Keyframe
The selected keyframe is displayed in red. When selected, the keyframe val-
ues are displayed in the corresponding fields.

Bezier Handles
The Bezier handles let you adjust the ease in and ease out of each keyframe. 
The more the handle is pulled out horizontally, the slower the animation will be. 
The more the handle is pulled out vertically, the faster the animation will be.

Function Curve
The thin line going from keyframe to keyframe is the actual curve. The section 
of a curve located between two keyframes is called a segment.

Frame Scale
The Frame Scale displays the frame range for the displayed editing area. It can 
be referenced to know the current frame of a keyframe.
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Integrated Help View
Use the Integrated Help when you are unsure about what a certain menu item is or the function of a specific 
preference in the Preferences panel, 

If you keep the Integrated Help window open for the entire duration of your work session, then you can use the 
forward and backward arrows to scroll through  a history of the help information that you called up during your 
session.

How to access the Integrated Help view

 1. Do one of the following:

 l From the top menu, select Windows > Integrated Help.

 l From any of the other views, click the Add View  button and select Integrated Help.
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Layer Properties View
The Layer Properties editor or view lets you adjust the properties of a layer in the Timeline view The Layer 
Properties can be viewed as a floating window or as a view (docked).

Each layer has its own set of properties that can be modified, including effect and peg layers. Display the Layer 
Properties editor or view if you want to modify some of the layer’s properties, such as the name or the antialiasing 
quality. 

NOTE: To know more about the parameters displayed in the Layer Properties view, see Nodes.

How to access the Layer Properties view

Do one of the following:

 l From the top menu, select Windows > Layer Properties.

 l From any of the other views, click the Add View  button and select Layer Properties.
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How to access the Layer Properties editor

 l Double-click on a layer in the Timeline view

 l Right-click on a layer in the Timeline view and select Layer Properties.

 l Select a layer in the Timeline view and press Shift + E.
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Library View
The Library view is used to store elements such as animation, drawings, backgrounds and puppets to reuse in 
different projects. You can also use the Library view to create and store symbols.

To reuse an element from another project, you must create a template from your drawings. A template is a mini 
scene that you import in other projects. A template has no link to the original scene. When you create a template, 
the full content of your selection is copied in the template.

Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's 
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's 
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from. 

How to access the Library view

Do one of the following:

 l From the top menu, select Windows > Library.

 l From any of the other views, click the Add View  button and select Library.

Icon Section Description

View Menu The Library menu lets you access commands related to 
the Library view, importing .swf movies and Illustrator 
files, add a new folder, and refresh the library’s content.

 Preview Window The Preview window lets you see the content of the 
currently selected template or symbol in the 
Template/Symbol list.
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 Preview Playback The Preview Playback button lets you play back the 
content of the selected template or symbol if it contains 
more than one frame. Press the Play  button to play back 
the preview.

 Library Folder List The Library Folder List displays all the folders linked to 
the Library view. 

There are two default folders:

 l Symbols: This folder is the only folder containing 
symbols. You can organize it by adding subfolders 
inside.

 l Harmony Essentials Library: This is a default 
folder found on the hard drive in your user doc-
uments. This folder can contain templates, but no 
symbols.

You can link new library folders to the Library view and 
organize them with subfolders.

 Library Search tool When working on a movie or series, you will probably end 
up with many templates and symbols in your library. 
Using the Search tool, you can quickly find the templates 
and symbols in your folders.

 Template/Symbol List The Template/Symbol list displays the templates or 
symbols contained in the selected library folder. You can 
display the templates by right-clicking the symbols’ 
thumbnails and selecting View > Thumbnails.
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Message Log View
The Message log view displays information gathered during a render task, such as which frames and at what time 
they were each rendered. The view also contains a list of the colour recovery operations.

How to access the Message Log view

Do one of the following:

 l From the top menu, select Windows > Message Log.

 l From any of the other views, click the Add View  button and select Message Log.
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Script Editor View
Qt Script provides access to many of the functions supported in the  interface. With Qt Script, you can automate a 
number of Harmony functions to speed the completion of various repetitive tasks. The Script Editor view allows you 
to edit existing scripts and create new ones. Refer to the Scripting guide to learn more about scripting with Harmony.

How to access the Script Editor view

Do one of the following:

 l From the top menu, select Windows > Script Editor.

 l From any of the other views, click the Add View  button and select Script Editor.

Parameter Description

Script list On the left side of the Script Editor view, all existing script files are listed and can 
be modified in this view. The script format is JavaScript. Click on a  file to display 
its content in the Script Content window of the view.

Script content On the right side of the Script Editor view, the contents of the selected script are 
displayed and can be edited.
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Search toolbar The Search toolbar allows you to search a string within the selected script 
content. You can use the Previous and Next buttons to navigate through the 
results.

Verify This function verifies the syntax of the currently displayed script and lists any 
errors found.

Save Once you are satisfied with the modifications made to the script, click Save 
Changes to save the modifications.
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Side View
T-HFND-008-015

The Side view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see a 
scene’s stage  from  the side. This lets the camera cone and spacing between the elements to be seen.

How to access the Side view

Do one of the following:

 l From the top menu, select Windows > Side.

 l From any of the other views, click the Add View  button and select Side.

Icon Section Description

 Thumbnails A thumbnail of each drawing layer in the scene. The 
order of the thumbnail images is based on each 
element’s FB position in the scene space. You can see 
a representation of the FB position of each layer in the 
camera cone.

 Camera Cone The camera cone represents the camera’s position and 
field-of-view (FOV). 

 Axis Reference Arrows  The axis reference arrows let you maintain your ori-
entation when navigating in the view.

Show/Hide Camera Shows or hides camera frame in the Perspective view. 
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Reset View Resets the pan, rotation, and zoom of the Perspective 
view.

 Zoom Menu This field displays the current zoom level in the 
Perspective view. You can use the Zoom level drop-
down menu to select a specific zoom level from the list. 
Zoom levels from 2.5% to 6400% are available; you can 
also select Fit To View to automatically use a zoom 
level that lets you see all your scene layers and 
information in the Perspective view at once.

 Layer Name  This field displays the currently selected layer and draw-
ing name.

 Tool Name This field displays the currently selected tool.

 Frame Number This field displays the currently selected frame of your 
animation.

 Colour Swatch  This field displays the currently selected colour in the 
palette.
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Timeline View
T-HFND-006-002

To set your animation timing, you will mostly work with the Timeline and Xsheet views. It's extremely useful to 
become familiar with the Timeline view, how it works, and its interface.

The Timeline view is the main view used when adjusting the timing of drawings, adding keyframes and ordering 
layers. The Timeline view displays layers, effects,  sounds, keyframe values, scene length, layer names, drawings, 
keyframes, timing, and frames.

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their 
simplest form. You can also see the layers and their names, as well as the drawing’s exposure. The drawing name is 
displayed when you place your pointer over the drawing’s exposure.

How to access the Timeline view

Do one of the following:
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 l From the top menu, select Windows > Timeline.

 l From any of the other views, click the Add View  button and select Timeline.

Ico-
n

Section Description

 Model View 
Toolbar

The Model View toolbar contains all the tools and options you can use in the Model view to 
navigate through and manage models.

Enable/Disab
le All 

The Enable/Disable All  button lets you show or hide layers.

When you deselect a layer in the Timeline view, the corresponding column is hidden in the 
Xsheet view. When a column is hidden in the Xsheet view, the corresponding layer is 
disabled in the Timeline view.

To disable a layer, click the layer's Enable/Disable All  button or press D.

To enable a layer, click the layer's Enable/Disable All  button or press A.

Solo The Solo  button lets you view drawing or sound layers in the Camera view. You can enable 
this mode on multiple layers. When the Sole mode button is deselected, everything is 
visible in the Camera view. When one or more layers are soloed, only those layers appear 
in the Camera view. 

Onion Skin The Onion Skin  button enables the Onion Skin option on a particular layer. If you want to 
see the previous and next frames of a specific layer, go to the Timeline view and click the 
Onion Skin button for that particular layer. Blue arrows appear on both sides of the play 
head. Drag the blue arrows to add more frames to the onion skin display.

To activate the general Onion Skin preview, in the Tools toolbar, click the Onion Skin  
button.
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Lock/Unlock 
Layer 

The Lock/Unlock Layer button lets you prevent the selection or editing of a layer in the 
Camera view. To select some of the layers without selecting others, in the Timeline view, 
lock the layers you do not want to select. When a layer is locked, its name is displayed in 
red.

In the top menu, there is a series of locking options. Select Animation > Lock > select one 
of the following:

 l Lock: Locks the currently selected element.

 l Unlock: Unlocks the currently selected element.

 l Lock All: Locks all the elements in the Camera view. 

 l Unlock All: Unlocks all the elements in the Camera view.

 l Lock All Others: Locks all the elements in the Camera view except the currently 
selected one.

You can display the locked drawings as outlines in the Camera view to quickly find out 
which drawings are locked. 

Change 
Track Colour 

The Change Track Colour  button lets you change the colour of the exposed frames; this 
helps you to quickly locate a layer in the Timeline view. Click the Change Track Colour  but-
ton to open the Select Colour window and choose a new colour. You can modify the colour 
for any type of layer, such as group, peg, drawing, and effects.
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Add Layers The Add Layers  button lets you add new layers to the Timeline view. When you click the 
Add Layers button, a menu appears displaying the layer types available. You can add 
several different types of layers: 

 l  Camera

 l  Deformation

 l  Drawing

 l  Generator

 l  Group

 l  Transformation

 l   Effects

 l  Sound

Delete 
Layers

The Delete Layers  button lets you delete the currently selected layers in the Timeline view.

Add Drawing 
Layer

The Add Drawing Layer  button lets you automatically add a new drawing layer to the 
Timeline view. By default, the layer is named Drawing.

Add Peg The Add Peg  button lets you add a peg layer to the timeline. If several layers are selected, 
a peg is added and parented to each layer.

 Expand/Colla
pse

The Expand/Collapse  button is used to display the children layers of a parent layer. Once a 
layer is parented to another layer, it is indented to the right and the Collapse/Expand 
Children button appears on the parent layer allowing you to show or hide the child layer.
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Show/Hide 
Functions

The Show/Hide Functions  button lets you display the functions embedded in each layer. 
The functions are the different coordinates and values used to record a layer’s parameters 
at each frame. This information is stored on the function curves using keyframes.

Parameters The Parameters section lets you add, remove or modify a keyframe at the current frame. 
You can show or hide the Parameters section by clicking the Show/Hide Parameters 
button.

Add Key-
frame

Adds a keyframe at the current frame.

Delete Key-
frame

Removes an existing keyframe at the current frame.

Hand Cursor Lets you change the current keyframe or drawing exposure. When you hover the cursor 
over the value, the hand cursor appears. Drag left or right to change the value. Or double-
click on the keyframe value and enter a new value.

Previous Key-
frame

Lets you navigate through the previous keyframes.

Next Key-
frame

Lets you navigate through the next keyframes.
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Show Func-
tion Menu

Displays the Function menu where you can link a layer to an existing function or create a 
new function.

 Keyframe A black or red square is displayed in the Timeline view when a keyframe exists. You can 
select these keyframes and drag them wherever you want on the timeline. You can also 
copy, cut, and delete them.

NOTE: To delete a keyframe without deleting the drawing exposure, go to the 
Timeline view and select the keyframe to be deleted and then select Animation > 
Delete Keyframe from the top menu or press F7.

When a parent layer is collapsed and a child layer contains a keyframe, a white square will 
be displayed.

Split The Split  button lets you split the Timeline view in two sections, allowing you to see two 
different portions of the Timeline view. This way, if your scene length is very long, you can 
see the beginning and the end at the same time.

 Drawing 
Exposure 

In the Timeline view, when a drawing is exposed, it is represented as a grey block. If the 
drawing is exposed for several frames, the block is extended. When a second drawing is 
exposed, a new grey block is displayed.

The exposure’s colour can be changed. To pick a new colour, click the Change Track 
Colour  button in the corresponding layer.

View Modes The View Modes  button lets you streamline the process of working with elements in the 
Timeline view. There are three different view modes you can choose to work in. With each 
mode you select, certain elements may or may not be visible in the Timeline view. 
Depending on your workflow, this can be useful for quickly hiding elements when you want 
to focus on specific ones. To select a view mode, use the drop-down menu in the bottom-
left corner of the Timeline view.

Show/Hide 
Additional 
Links

The Show/Hide Additional Links  button lets you display links associated with a layer. For 
example, if you connect a mask to more than one effect such as a Tone and a Highlight, 
you can see these connections in the Additional Links section.
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 Zoom The Zoom tool increases or reduces the width of the frames in the Timeline view. Move the 
slider right to increase the width or left to reduce it. You can also press 1 and 2. Reset the 
zoom by click the Reset Zoom button.
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Tool Properties View
T-HFND-004-002

The Tool Properties view contains the most common options and operations related to the currently selected tool. 
When you select a tool from the Tools toolbar, the Tool Properties view updates.

For example, if you choose the Select  tool, the Tool Properties view will display the options and operations 
related to it, such as Snap to Contour, Apply to All Drawings, Flip Horizontal, and Flatten.

NOTE: To learn more about the options appearing in the Tool Properties view, see Tools Properties on page 
121.

How to access the Tool Properties view

Do one of the following:

 l From the top menu, select Windows > Tool Properties.

 l From any of the other views, click the Add View  button and select Tool Properties.
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Top View
T-HFND-008-014

The Top view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see the 
scene’s stage  from above. This lets the camera cone and the spacing between the elements be seen.

How to access the Top view

Do one of the following:

 l From the top menu, select Windows > Top.

 l From any of the other views, click the Add View  button and select Top.

Icon Section Description

 Thumbnails A thumbnail of each drawing layer in the scene. The 
order of the thumbnail images is based on each 
element’s FB position in the scene space. You can see 
a representation of the FB position of each layer in the 
camera cone.

 Camera Cone The camera cone represents the camera’s position and 
field-of-view (FOV). 

 Axis Reference Arrows  The axis reference arrows let you maintain your ori-
entation when navigating in the view.

Show/Hide Camera Shows or hides camera frame in the Perspective view. 
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Reset View Resets the pan, rotation, and zoom of the Perspective 
view.

 Zoom Menu This field displays the current zoom level in the 
Perspective view. You can use the Zoom level drop-
down menu to select a specific zoom level from the list. 
Zoom levels from 2.5% to 6400% are available; you can 
also select Fit To View to automatically use a zoom 
level that lets you see all your scene layers and 
information in the Perspective view at once.

 Layer Name  This field displays the currently selected layer and draw-
ing name.

 Tool Name This field displays the currently selected tool.

 Frame Number This field displays the currently selected frame of your 
animation.

 Colour Swatch  This field displays the currently selected colour in the 
palette.
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Xsheet View
T-HFND-006-003

The Xsheet view lets you read the timing vertically, displays the drawing layers as columns, and shows the 
drawing’s name. You can also see the functions and keyframes of the motion paths in the Xsheet’s function 
columns. The value of each keyframe is shown in the Xsheet view; these are displayed as black squares in the 
Timeline view. The Xsheet view contains more detail than the Timeline view, and is faster and easier to read.

How to access the Xsheet view

Do one of the following:

 l From the top menu, select Windows > Xsheet.

 l From any of the other views, click the Add View  button and select Xsheet.

Icon Section Description

 View Toolbar The view toolbar contains all the tools and options you can 
use in the Xsheet view to manage columns and timing.

 Xsheet Main Section The Xsheet view has three sections. By default, only the 
main section is visible. It displays the drawing layers, also 
known as drawing columns.
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When using advanced compositing and animation 
techniques, unconnected functions (motion paths) also 
appear in the main section. Unconnected functions mean 
that some motion paths are not attached to any particular 
layer.

When you reconnect functions to a layer, they are still 
visible in the main section.

 Functions Section The Functions section is used for more advanced 
techniques. This section displays the functions (paths) 
related to the selected layer in the Timeline view. By 
default, the Functions section is hidden.

In the Xsheet view, click the Expand button located on the 
right side of the main section. Click on the same button to 
collapse it. You can also use the Show Column List  button 
in the Xsheet View toolbar. If you select a drawing column 
in the main section of the Xsheet view, the function 
columns will not be displayed. You must select the layer 
from the Timeline view.
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 Column List Section The Column List section allows you to show and hide 
columns in the Xsheet view. When you hide a layer in the 
Xsheet view, it is also disabled in the Timeline view.

You can use the Column List to hide individual columns or 
hide an entire column type (drawing or function) from the 
Xsheet view. By default, the Functions section is hidden.

In the Xsheet view, click the Expand button on the right side 
of the main section to show the Functions section. Click on 
the same button to collapse it. You can also use the Show 
Column List  button in the Xsheet toolbar.

Go to the Xsheet view menu and select View > Show 
Column List. Click the Expand button on the right side of 
the Functions section to display the Column List section.

 Column Header Each column available in the Xsheet view has a header 
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displaying the column’s name. The column’s name is the 
same as the corresponding timeline layer. If you rename 
one or the other, they will both be renamed.

A quick access menu is available when you right-click. This 
menu contains the command affecting an entire column 
such as renaming, changing the default colour, or deleting a 
column.

The tooltip that appears when you hover at the top of each 
Xsheet column shows the folder path to the source 
drawings for that column.

In Harmony, the column header shows the layer’s name and 
the name of the drawing folder to which it is linked. If the 
name of the layer is the same as the drawing folder, the 
drawing folder’s name will not be displayed.  To modify the 
name of the element folder independently from the column 
and layer name, you must select the Advanced Element 
Mode option preference in the Advanced tab of the 
Preferences dialog box.

 Current Drawing A drawing selected in dark red indicates that the drawing is 
currently displayed in the Drawing and Camera views. The 
current drawing selection is not linked to the drawing 
displayed in the Camera view since drawings from each 
visible layer are displayed at once.

 Current Frame The darker frame appearing in the Xsheet view represents 
the current frame.

 Drawing Exposure In the drawing columns, you can see the drawing names 
and their exposure. You can use any alphanumeric symbol 
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to name your drawing. When a drawing is exposed over 
more than one cell, a vertical black line is displayed to 
indicate the continuity of the exposure. When there is no 
drawing in a cell, the cell will be blank.

 Frame Numbers On the left side of the Xsheet view, the frame numbers are 
shown indicating where you are. These read vertically 
instead of being displayed horizontally as they are in the 
Timeline view.

 l To go to a particular frame, click the frame number.

 l To select an entire range of frames, click and drag a 
selection downwards.

 Current Frame Display At the bottom-right of the Xsheet view, you can see the 
current frame number, as well as the column containing the 
drawing currently displayed in the Drawing view.

 Functions Column The functions columns are displayed in the Functions 
section of the Xsheet view. They represent the motion and 
rotation you applied to a drawing layer. 

A function column can also be related to an effect. Selecting 
the effect layer shows you the corresponding function 
column in the Xsheet view.
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The function columns display the position value or effect 
value on each cell. If there is a keyframe on a cell, a black 
square is displayed. Holding the same value for several 
frames displays a vertical black line.

 Increase/Decrease 
Exposure

You can quickly increase or decrease the exposure of the 
selected cell by clicking on the up and down arrows in the 
Increase/Decrease Exposure field.

 Overwrite/Insert Modes The Overwrite/Insert button allows you to decide the way 
the values are inserted into the Xsheet.
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