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Chapter 1: User Guide
The Harmony core functionality are explained in this User guide. All the steps required to create and complete a 
project are covered in the following chapters with concept descriptions and detailed step-by-step procedures 
focused on the task at hand.  

Detailed parameter descriptions for all buttons, commands, and functions are covered in the Reference guide and 
Preference guide. Some of them are explained here where necessary to the understanding of a given concept or 
procedure.  
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Chapter 2: Project Creation
Once Harmony is installed, you are ready to start the application and animate! In this chapter, you will learn about 
starting the application, creating scenes, setting the resolution and opening the scenes. 
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About the Database

Harmony can be used in database mode (online) via the server connection (Harmony Server) or as a standalone 
application (offline).

Several animators can work simultaneously on the same project while the asset library provides users with easy 
access to up-to-date media assets. Harmony is scalable; more than 100 staging clients can share animation just 
as easily as a few can. 

Harmony Server is the link between the client machines and the server. It lets you work on the different projects 
stored in the central Harmony database. 

At the heart of the Harmony solution is the server, which centralizes all the production assets in a repository. The 
server is compatible with Windows, Linux or Mac OS X. To learn more, refer to the Control Center Guide.

If you installed the complete version (Harmony Server / Network), when you start Harmony, you can opt to either 
work offline in the application as a standalone software, or connect to the database to work on projects via the 
database.

When working with Harmony Server, the scenes and their data are stored directly on the server. No data is saved 
or stored on the client machine. The client machines access the database and load the scenes and drawings 
directly from the server. Each time the user saves his scene, the data is updated directly on the server. There are 
no upload or download operations (check-in, check-out) done between the server and the clients.

NOTE: If you have a standalone license, you will not have access to the database. You will automatically 
start the application in standalone mode.
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About the Database Structure
Harmony Server has a client-server configuration linked through a network. Although the user is working on a client 
machine, all of the data is saved on the server.

You can compare the Harmony Server structure to a filing cabinet. Every element is structured and follows a strictly 
organized hierarchy.

The following production structure hierarchy is used:

 l Environment: Production, project, feature film, series—see Environment Structure on page 15

 l Job: Episode and sequence from each environment

 l Scene: Scene from each job

 l Element: Layers and columns from each scene

 l Drawing: Drawings from each element

If you imagine the environment as a filing cabinet containing all the folders and information, then the following 
structure is used:

 l The job is a drawer in the filing cabinet containing all the folders related to the drawer’s topic.

 l The scenes are the folders contained in that drawer

 l The elements are the papers contained in the folder

 l The drawings are the information contained on the paper

A Harmony Server scene can only be saved inside the structure. This maintains structural organization so nothing is 
lost. By adhering to this structure, every user working in the database always knows where to find the scenes to 
work on.

Environment Structure

Before you create or save any elements in your production, you should decide upon a project name. This should 
reflect the content or title. Use the name to create the project’s environment, where you will store all of your 
production elements.

For example, the environment could be called adventure_movie. An environment can be used for movies, series, 
commercials, student work database, etc.
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For a series, you can create an environment with the same name as the series, such as smith_family. Then 
you can create a job per episode: smep_001, smep_002, and so on. Here is what the letters and numbers 
represent:

 l sm: The first two letters of the name smith

 l ep: Episode

 l 001: The number of the episode

For commercials, which are rather short, you can create an environment, such as commercials. Then you can 
create one job per commercial: toothpaste, soap, car, and so on. As commercials are short and do not require 
splitting into episodes or sequences, you can group them all in the same environment.

For a database of student’s work, you can create an environment and name it with the class or group name, such 
as gr402a. Then you can create one job per student: smith_john, robertson_jane. And then store the 
different student exercises in separate scenes under their job name.

16
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Starting Harmony Paint
T-HFND-001-002

You can run Harmony on Linux, Mac OS X or Windows operating systems.

NOTE: On Mac OS X 10.10.5 and more recent versions, Harmony and its modules will not start the first time if 
your security is set to Mac App Store and Identified Developers. Change your security to Anywhere or right-
click on Harmony or its modules to open it for the first time only.

How to start Harmony Paint

 1. Do one of the following:
 l Windows: Start > Programs > Harmony 14.0 > 

 l Mac OS X: Applications > Toon Boom Harmony 14.0 > 

 l Linux: /usr/local/ToonBoomAnimation//lnx86_64/bin/ -paint

Toon Boom Harmony opens. If you have the complete version installed, the login dialog box opens.

 2. To connect to the database, in the User Name field, enter your username. It is generally provided by the 
supervisor, system administrator or team lead.

 3. Click OK.
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Connecting to the Database

Before you can work in Harmony Paint via Harmony Server, you must be connected to the Harmony database. 
When you connect to the database, you cannot create new scenes directly from . The available scenes will be the 
ones that were previously created using the Control Center module. 

How to connect to the Harmony database

 1. Start  Harmony Paint—see Starting Harmony Paint on page 17.

 2. In the User Name field, type in your Harmony username which is provided by your project lead or system 
administrator. 

 

 3. Click OK. 

The Database Selector dialog box opens, displaying the environments available in Harmony database.

 

 4. In the Environments column, select the scene's environment (project, movie). 
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 5. In the Jobs column, select the scene's job (episode, sequence). 

 6. In the Scenes column, select the scene. 

 7. Get the permissions needed for this session by selecting one of the following options:

 

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be 
locked. Locking means that you have the rights to modify a scene or its assets. Other users cannot 
modify locked items. If someone tries to open a locked scene, it will be displayed as read-only.

Here are the different lock possibilities:

Lock Description

Scene or Version Lock
Controls the Xsheet timing, layers, nodes but not the drawing, 
palettes, palette-lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.

Library Folder lock Only one user can edit and save into that folder in the Library.

 8. Choose the version you want to open from the Version menu—see Saving Scenes on page 38.

 

 l The Saved By and Saved Date fields display the user who last saved the selected scene and 
the date of the last save.
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 9. Click Open.
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Acquiring Rights to Loaded Scenes
If you opened a scene in read-only mode, but realize that you need to modify it, you can easily acquire the necessary 
rights without closing and reloading the scene. 

Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded. This process is 
done during the initial loading of the scene. To learn more about enabling the rights to modify while creating 
environments, jobs and scenes, refer to the  Control Center Guide.

How to set the scene's rights after the scene is loaded

 1. In the top menu, select File and one of the following:

 l Rights to Modify Scene: Allows you to modify the selected version of the scene and access 
the version manager during the opened session

 l Rights to Modify Scene Version: Allows you to modify the currently selected scene ver-
sion, but locks access to the version manager during the opened session.
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About Documentation
The documentation is a way to help you find answers to your questions about how things work in Harmony. The 
documentation of features and procedures exists online, but you can access it through the software.

A simple, but fast way to find a description of certain menu items and preferences is through the Integrated Help.

22



Harmony 14 Paint - User Guide

Accessing the Documentation
T-HFND-001-004

The Harmony documentation can be accessed from the Welcome Screen and the Help menu.

How to access the Harmony documentation

 1. In the Support section, click on the Get Help  button.

Your default web browser opens to the Toon Boom Support page.

 2. From the Support page, under the Learn Toon Boom Software section, click on the Documentation button.

The Toon Boom Help page opens.

 3. From the Toon Boom Help page, click on the Harmony icon.

The Harmony Help page opens.

All the Harmony guides can also be opened directly in the software. Select Help > Online Help.
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Using the Integrated Help
If you are unsure about what a certain menu item is in the Top menu or the function of a specific preference in the 
Preferences panel, use the Integrated Help.

If you keep the Integrated Help window open for the entire duration of your work session, then you can use the 
forward and backward arrows to scroll through a history of the help information that you called up during your 
session.

How to use the Integrated Help with Menu Items

 1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘  + / on Mac OS X.

The Integrated Help window appears.

 2. In the top menu, click on a menu heading to display its contents.

 3. Use your mouse to hover over a menu item.

 4. Press  F1 on Windows/Linux or ⌘  + / on Mac OS X.

In the Integrated Help window, a description of the menu item appears.
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How to use the Integrated Help with Preferences

 1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘  + / on Mac OS X.

The Integrated Help window appears.

 2. In the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS X).

The Preferences window appears.

 3. In the Preferences window, use your mouse to hover over a preference.

 4. Press  F1 on Windows/Linux or ⌘  + / on Mac OS X.

In the Integrated Help window, a description of the preference appears.
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How to scroll through the bank of searched items

 l In the Integrated Help window, click on the forward or backward arrow buttons.

NOTE: The moment you close the Integrated Help window all searched items will be erased from the 
memory bank. In order to keep an on-going record of all the search requests made, you must keep the win-
dow open.
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Creating Custom Resolutions
T-HFND-001-006

You can create your own custom resolution presets for your projects.

How to create a custom resolution

 1. Create a new scene from the Welcome screen or from the File menu in Harmony.

 2. Set the scene resolution by doing one of the following:

 l Select a scene resolution from the Camera sizes drop-down menu.

 l Set a custom resolution by changing the values in the Width and Height fields. This preset will 
not be saved.

 l Add a new resolution to the list by clicking the Add   button. You can delete a custom res-
olution from the Resolution list by selecting it, and clicking the Delete button.

 3. In the New Resolution dialog box, fill in the following fields and click Create.

 l Resolution Name: Name your new resolution.

 l Resolution: Set the width, height and aspect ratio of the resolution.

 l Field of View: Set the horizontal fit and vertical fit.

 l Frame Rate: Type the scene's frame rate per second.
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Opening Scenes
T-HFND-001-007

You can open scenes from the Welcome Screen and the File menu. You can also open your recent scenes.

How to open a scene from the Welcome screen

 1. In the Recent Scenes section, click Open.

The Open Scene browser opens.

 2. Browse and select an *.xstage file.

 3. Click Open.

How to open a scene from the File menu

 1. Do one of the following:

 l From the top menu, select File > Open. 

 l In the File toolbar, click the Browse  button. 

 l Press Ctrl + O (Windows/Linux) or ⌘  + O (Mac OS X).

The Open Scene browser opens.

 2. Browse and select the desired *.xstage file.

 3. Click Open.

How to open a recent scene from the Welcome screen

 1. In the Open a Scene section, select a scene from the list.

How to open a recent scene from the File menu

 1. From the top menu, select File > Open Recent.

 2. Select a scene from the displayed list.

28



Harmony 14 Paint - User Guide

Advanced Saving in the Harmony Server
Use the Advanced Save dialog box to save specific drawings, palettes and palette lists as a version of your scene. 

How to use the Advanced Save dialog box

 1. Make sure that you have the necessary rights to save the current scene version. 

 2. From the top menu, select File > . 

The Advanced Save dialog box opens—see  the Reference guide for detailed parameter descriptions.
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Loading Drawings and Elements 
Once you launch Paint, you need to load a scene’s drawings from the Database Selector, in order to start the ink 
and paint process. The drawings must have previously gone through the Xsheet and Scanning processes. 

There are two ways of loading drawings:

 l Open Drawings

 l Open Elements
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Opening Drawings in Paint
This option will let you load drawings from one element at a time, for quick ink and paint on a single layer animation.

How to open drawings in Paint

 1. Once Paint is launched and you are logged in, select File > Open Drawings. Press Ctrl + O (Win-
dows/Linux) or ⌘  + O (Mac OS X).

The Database Selector opens, displaying the Environments available from the Harmony database.

 

 2. Select the Environment, Job, Scene and Element where the drawings you need to paint are located.

 

 3. Choose the version you want to open from the Version drop-down menu.

 

 l The Saved By and Saved Date fields display the user who was the last to save the selected 
scene and the date of the last save. 
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 4. Click on the Open button.

The Drawings Selector dialog box opens.

 5. Select the desired drawings from the drawings list:

 l Click on a single drawing to select it.

 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘  (Mac OS X) 
key.

 l Click on the All button to select all the drawings that are listed in the Drawings Selector.

 l Click on the Unpainted button to select all the drawings whose status appears as 
UNPAINTED.

 l Click on the Painted button to select all the drawings whose status appears as PAINTED.

 6. Click OK.

The selected drawings appear in the Drawing Thumbnails view

 7. Use the Control panel to navigate between the previous and next drawings. Press F and G.
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You are now ready to ink and paint!
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Opening Elements in Paint
This option will let you load drawings from several elements at once. This can be useful when an animation is 
separated in many layers, to insure that they are well aligned and that the painted shapes and lines fit together. A 
good example of this would be a dialogue with the chin and mouth separated from the rest of the head.

How to open elements in Paint

 1. Once Paint is launched and you are logged in, select File > Open Elements. Press Ctrl + E (Win-
dows/Linux) or ⌘  + E (Mac OS X).

The Database Selector opens, displaying the Environments available from the Harmony database.

 

 2. Select the Environment, Job and Scene where the elements containing the drawings you need to paint are 
located. 

 

 3. Choose the version you want to open from the Version drop-down menu.
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 l The Saved By and Saved Date fields display the user who was the last to save the selected 
scene and the date of the last save. 

 

 4. Click on the Open button.

The Open Elements dialog box opens.

 5. Select the elements you need to paint from the Elements list:
 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘  (Mac OS X) key.

 6. Select the frames you wish to load from the Frames list:
 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘  (Mac OS X) key.

 l Click on the All Frames button to load all the frames of the scene.

 7. Click OK.

The Drawing Thumbnails view is hidden and your selected elements are loaded in Paint.

 8. Enable the Light Table  option from the Drawing view toolbar to display all the drawing layers.

The selected layer are displayed in original colours and the other layers are displayed as washed out colours.
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 9. Use the Control Panel to navigate between previous and next layers. Press H and J.

 10. Use the Control panel to navigate between previous and next drawings. Press F and G.

You are now ready to ink and paint!
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About Saving
It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in the title bar 
beside the scene name to indicate that the scene contains unsaved changes.

To save the current state of a scene as another scene, you can use the Save As command. The Save As window 
prompts you to give a new name and choose a different location to this scene before saving it. This will create a 
complete scene directory for the new scene. The Save As command is not available in Harmony Server.

When you use Harmony Server and work in a scene on the database, there are many choices and options available 
when you save your work. 

Lets you do the following:

 l Save the scene as the current version.

 l Choose specific assets that you want to save, such as drawings or palettes. 

You might want to save some specific aspects of your scene or save a new version. The Advance Save feature 
allows you to do this. Once you have chosen the components to save, you will conclude the procedure by following 
the instructions in the  section. All the specific components that are selected throughout the different tabs of the 
Advanced Save dialog box will be saved. 
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Saving Scenes
T-HFND-001-011

You can save your scene, save a new copy or save a new version. Don't forget that saving a new version uses 
the same drawings in all versions. Harmony Server doesn't let you save your scenes as new copies.

How to save a scene

 l Select File > Save.

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).
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Saving Scenes as Copies
Saving a copy of your scene allows you to choose a new file name and location for your scene.

How to save a scene as a copy (Harmony Stand Alone)

 1. Select File > Save As.

 2. In the Save As dialog box, browse to the location of the new archive and give the copy of the scene a new 
name. The name cannot exceed 23 characters.

 3. Click Save.
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Saving Scenes as New Versions
Saving a new version of your scene allows you to save your scene at it's current location, under a new file name. 

How to save a new version of a scene (Harmony Stand Alone)

 1. Select File > Save As New Version.

The Save Version dialog box opens.

 2. In the Save Version dialog box, type the new version name.

 3. Click OK.
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Auto-Saving Scenes
T-ANIMPA-001

You can allow the software to automatically save your scene, as well as decide on the length of time between 
saves.

How to auto-save a scene

 1. Do one of the following:

 l Windows/Linux: Select Edit > Preferences.

 l Mac OS X: Select Harmony Paint > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the General tab.

 3. In the Save section, set the Auto-Save parameters:

 l Interval (minutes): This is the frequency at which the auto-save takes place.

 l Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you are 
drawing or doing anything in the application. If so, Auto-save waits this number of seconds 
before attempting another save.

 l Ask Before Saving: Before performing an auto-save, you are prompted with a message to con-
firm if you want to save or not. You can choose to turn off this option.

 l Enabled: This enables the Auto-save feature. If you do not want the system to automatically 
save your work, deselect this option. The auto-save is off by default.
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Locking Drawings
You can acquire and release the rights to modify drawings when working with Harmony Server.

How to enable the Edit Drawing Mode

 l From the top menu, select Edit > Edit Drawing Mode.

How to get the rights on a selection of drawings

 1. Make sure that the Edit Drawing Mode is disabled.

 2. In the Xsheet view, select the drawings you want to edit.

 3. Select Edit > Get Rights to Modify Drawings or press Alt + L.

How to release the rights on a selection of drawings

 1. In the Xsheet view, select the drawings you want to release.

 2. Select Edit > Release Rights to Modify Drawings or press Alt + Shift + L.

How to force the release of the rights of locked drawings

 1. In the Xsheet view, select the drawings you want to release.

 2. Select Edit > Force Release Rights to Modify Drawings.

A Warning dialog box opens.

 l Click Yes if you want to continue to force the release.

 l Click No if you want to cancel the force release.

How to read changed drawings

 l Select File > Read Changed Drawings.
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Verifying the Project Integrity
The Check Files commandVerifies the integrity of the drawing and palette files in your project.  Use the Check Files 
dialog box to verify that the data is consistent, correct, and accessible.

How to open the Check Files dialog box

 1. From the top menu, select File > Check Files.

 2. Click Check Colours to open the Check Colours dialog box.

The Check Colours dialog box checks the palette integrity and displays the colour recovery data.
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About Preferences
An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can customize your 
interface, tool behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences 
dialog box to set parameters and options.

NOTE: To learn about the different preferences available, refer to the Preferences Guide.

When working with Harmony Stand Alone, your custom preferences are stored in:

 l Windows:

 l Toon Boom HarmonyPremium: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Premium \full-1400-pref

 l Toon Boom HarmonyAdvanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Advanced\full-1400-pref

 l Toon Boom HarmonyEssentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Essentials\full-1400-pref

 l Mac OS X: 

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony Premium/full-1400-pref

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony Advanced/full-1400-pref

 l Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony Essentials/full-1400-pref
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On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.

 l Linux: 

 l /home/[user_name]/Toon Boom Animation/Toon Boom Harmony Premium/full-1400-pref/

 l /home/[user_name]/Toon Boom Animation/Toon Boom Harmony Advanced/full-1400-pref/

When working with Harmony Server, your custom preferences are stored in:

 l User: [Server_Name] > USA_DB > users > [user_name] > stage > full-1400-pref

How to open the Preferences dialog box

 1. Do one of the following:

 l Windows/Linux: From the top menu, select Edit > Preferences.

 l Mac OS X: Select Harmony Paint > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).
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Chapter 3: Interface
T-HFND-003-001

Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize your 
workspace conveniently. There are a series of views and toolbars you can use as you perform different operations. 
Usually, each person has a specific way of working in the interface and prefer particular views and toolbars. In this 
chapter, you will learn about the main elements of the interface and how to manage them.

NOTE: To learn more about each view's properties, see the Reference guide.

NOTE: 
On Windows, the default high-dpi setting was disabled so that text and UI element are shown properly. The 
application will appear a bit blurry but the text and UI elements will be displayed properly.

The previous behaviour is available by starting the application, Harmony[edition].exe, from the command 
line using the -enableHighDpi option.

To not have to start using the command line, the shortcut to start Harmony can be modified to add the option at 
the end of the target:

"C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 14.0 Premium\win64\bin\wstart.exe" 
Harmony[edition].exe -enableHighDpi

Replace the [edition] portion with the name of your edition (capitalized).
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Changing the Theme Colours
The Harmony interface is set to a dark theme by default. You have the option of switching to a light theme.

How to change the interface theme

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Paint > Preferences (Mac 
OS X) .

The Preferences dialog box opens.

 2. Select the General tab.

 3. In the Options section, deselect the Use Dark StyleSheet option to use the light theme.

 4. Restart Harmony.
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Changing the User Interface Language
Harmony is available in English, Spanish, Japanese, and Chinese. Harmony will automatically change to you 
OS language if it corresponds to one of these four languages. If you would like to start Harmony in one of those 
language independently from your OS, you can use the command prompt or terminal to do so. 

How to start Harmony using a specific user interface language 

 1. Start a termninal, command prompt, or shell on your OS. 

 2. Using the change drive command (cd), navigate to the Harmony executable file location: 

 l Windows: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 14.0 Premi-
um\win64\bin 

 l Mac OS X: /Applications/Toon Boom Harmony 14.0 Premium/tba/macosx/bin/ 

 l Linux: /usr/local/ToonBoomAnimation/harmonyPremium_14/lnx86_64/bin/

 3. To start Harmony in a specific language, type in the name of the Harmony application including the language 
argument (-lang) and language code (two letters): 

 l Windows: 
 l English:  HarmonyPremium.exe -lang en

 l Chinese: HarmonyPremium.exe -lang zh 

 l Japanese: HarmonyPremium.exe -lang ja 

 l Spanish: HarmonyPremium.exe -lang es

 l Mac OS X: 
 l English:  Harmony\ Premium -lang en

 l Chinese: Harmony\ Premium -lang zh

 l Japanese: Harmony\ Premium -lang ja

 l Spanish: Harmony\ Premium -lang es 

 l Linux: 
 l English:  HarmonyPremium -lang en

 l Chinese: HarmonyPremium -lang zh

 l Japanese: HarmonyPremium -lang ja

 l Spanish: HarmonyPremium -lang es

 4. Press Enter/Return to validate and launch Harmony in the desired language.
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About Menus
T-HFND-003-002

Harmony contains three types of menus from which you can access many commands and options:

Top Menu 

The top menu contains most of the commands. Depending on the view you're working in and the element, some 
commands are available and others are not. The top menu is always located at the very top of the interface.

The top menu contains the following categories:

 l File

 l Edit

 l View

 l Drawing

 l Selected

 l Tools

 l Options

 l Colours

 l Palettes

 l Frames

 l Columns

 l Windows

 l Help

On Mac OS X, there is also a Harmony Paint category that contains the following commands:

 l Preferences

 l About

 l Quit

View Menu 

A view menu contains commands specifically related to that view.

To access a  view menu, click the Menu  button in the top-left corner of a view.
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A view menu is available in the following views:

 l Colour

Quick Access Menu 

A quick access menu lets you open a list of the commands you will use most often.

To access this menu, right-click anywhere in a view.
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About Toolbars
T-HFND-003-003

Harmony contains toolbars which, by default, are located at the top of the interface. Some of the views also have 
their own toolbars which you can move around. You can reposition the toolbars to suit your work style or hide unused 
ones.

NOTE: Throughout this section, there may be slight differences between your interface and the illustrations in 
this guide. This is because the images are taken from Harmony Premium.

You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars of the views 
that are displayed in the workspace. As you show or hide views in your workspace, the Toolbar menu updates.

The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be displayed. If a 
toolbar is already displayed in the top area and you decide to display it in a view, the selected toolbar will move from 
the top area to the view.

The toolbars in any of the views can be customized with your favourite tools. Using the Toolbar Manager dialog box, 
you can organize different toolbars to suit your working style.

If the default toolbar does not contain the tools you require, you can customize the toolbar.
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Adding Toolbars
T-HFND-003-004

You can add toolbars simply by using menus.

How to add or close a toolbar

 1. Select Windows > Toolbars > toolbar.

 l You can right-click anywhere in the toolbar area to access Harmony toolbars. View toolbars, 
however, are not available by right-clicking the toolbar area. You can access the toolbar of 
any open and active view by right-clicking in the view's top area or the Windows menu. 
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Moving Toolbars
T-HFND-003-005

You can move toolbars simply by dragging them to a new location.

How to move a toolbar

 1. Select the toolbar you want to move by clicking its anchor point  and dragging it into a view toolbar area or 
another position in the top or side interface toolbar area.

 2. When a highlighted zone appears showing an available location for the toolbar, release the mouse button and 
drop the toolbar into position.
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Resizing Toolbars
T-HFND-003-006

You can resize a toolbar by sliding its tail-end.

How to resize a toolbar

 1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end. 

 2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.
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Customizing View Toolbars
T-HFND-003-007

You can customize a view toolbar to add, remove, and reorder icons.

How to customize a view toolbar

 1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a new button. 
You can also reorder the buttons. Make sure the button you right-click on is active.

 2. From the menu, select Customize.

The Toolbar Manager window opens.

 3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and click the Right 
Arrow   button to switch it to the Toolbar list.
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 4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the Left Arrow  
 button to switch to the Available Tools list.

 5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and click the Up 
 or Down  buttons to move it to the correct location.

 6. Click OK when you are finished.
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About Views
T-HFND-003-008

The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify 
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a view.

When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are 
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing or 
other type of selection or the option does not apply to the active view.

NOTE: To learn move about each view's properties, refer to 

Workspace modifications are automatically saved when you exit the application unless you deselected the 
Automatically Save Workspace option in the Preferences dialog box.
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Showing and Hiding Views
T-HFND-003-012

You can temporarily show and hide views using the collapsing buttons.

How to temporarily hide a view

 1. On the edge of the window you want to hide, click the Collapse/Expand button.

The view is compressed and only the Collapse/Expand button is visible.

 2. Click the Collapse/Expand button again to redisplay the view.
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Moving Views
T-HFND-003-011

You can move views by dragging their name tab to a new location.
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Resizing Views
T-HFND-003-013

You can resize a view by sliding its edges.

How to resize a view

 1. Place the pointer on the edge of the view to resize.

 2. When you see the Resizing  icon, drag the side of the view to the desired size.
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Loading Workspaces
T-HFND-003-015

You can load an existing workspace from the drop-down menu.

How to load a workspace

 1. Do one of the following:

 l Select Windows > Workspace > Workspace.

 l Select a workspace from the Workspace toolbar.
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Creating Workspaces
T-HFND-003-016

You can create new workspaces through the Workspace Manager dialog box.

How to create a new workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select an existing workspace.

 3. At the bottom of the Available Workspaces list, click the Add  button to add a workspace.

 4. Select the new workspace that was created. Click Rename and give it a new name.
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 5. Select the new workspace and click the Right Arrow  button to move it to the Workspace toolbar.

 6. Click OK.
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Renaming Workspaces
You can rename a workspace through the Workspace Manager dialog box.

How to rename a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. Choose the workspace to be renamed from the list.

 3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit the 
name. 

 4. Type in the new name of the workspace.

 5. Press the Enter/Return key to validate the name.

 6. Click OK. 
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Saving Workspaces
T-HFND-003-017

You can either save your workspaces automatically or manually.

How to save your workspace as a new version

 1. From the top menu, select Windows > Workspace > Save Workspace As.

The Save Workspace As dialog box opens.

 2. Type in a workspace name and click OK. 

How to disable the Automatically Save Workspace preference

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Paint > Preferences (Mac 
OS X) to open the Preferences dialog box.

 2. Select the General tab.

 3. In the Options section, deselect the Automatically Save Workspace option.

 4. Click OK. 

The Save Workspace   button appears in the Workspace toolbar.

How to save a workspace manually

 1. Do one of the following:

 l In the Workspace toolbar, click the Save Workspace   button. 

 l You can also select Windows > Workspace > Save Workspace.
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Deleting Workspaces
You can delete a workspace through the Workspace Manager dialog box.

How to delete a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow   button to 
move it to the Available Workspaces list.

 3. Select the workspace from the Available Workspaces list, then click the Delete  button to delete the 
workspace.

 4. Click OK.
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Showing and Hiding Workspaces
You can show and hide workspaces from your drop-down list through the Workspace Manager dialog box.

How to show a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow   button 
to move it to the Workspace toolbar.

 3. Click OK. 

How to hide a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow   button to move it 
to the Available Workspaces list.

 3. Click OK. 
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Reordering Workspaces
You can reorder workspaces in your drop-down list through the Workspace Manager dialog box.

How to reorder workspaces

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace toolbar, select the workspace to be reordered and on the Up  or Down  buttons to 
move it up or down.

 3. Click OK. 
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Restoring the Default Workspace
T-HFND-003-018

You can restore modified workspaces to their original layout.

How to restore the default workspaces

 l Select Windows > Restore Default Workspace.
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About Interface Navigation
Toon Boom Harmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the interface.

Command Action Access Methods

Zoom In Zooms in the view. 

View > Zoom In

Press 2

Roll the mouse wheel up (except in the 
Timeline and Xsheet views)

Zoom Out Zooms out the view.

View > Zoom Out

Press 1 

Roll the mouse wheel down(except in the 
Timeline and Xsheet views)

Zoom In or Out Zooms in or out of the view.

Roll the middle mouse button up or down.

Hold down the Spacebar and the middle 
mouse button while dragging the mouse up 
or down.

Pan
Moves the view horizontally or 
vertically.

Hold down the Spacebar and drag in the 
direction you want to pan the view.

Reset Pan
Resets the view’s pan to its default 
position.

View > Reset Pan

Press Shift + N

Reset View Resets the view to its default position.

View > Reset View

Press Shift + M

 

Reset Rotation
Resets the view’s rotation to its default 
position.

View > Reset Rotation

Press Shift + X

Reset Zoom
Resets the view’s zoom to its default 
position.

View > Reset Zoom

Rotate View Rotates the view.
Press Ctrl+Alt (Windows/Linux) or Ctrl+⌘  
(Mac OS X) and drag in the direction you 
want to rotate the view.

Rotate 30 CW Rotates the Camera view 30 degrees 
clockwise, like an animation table.

View > Rotate View CW

Rotate 30 CCW
Rotates the Camera view 30 degrees 
counter-clockwise, like an animation 
table.

View > Rotate View CCW

Toggle Quick Close-up

Instantly multiplies the view's Zoom 
Factor by 4. For example, if the Camera 
View's Zoom Factor is at 100%, this will 
make it toggle between 400% and 
100%. 

Shift+Z
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Chapter 4: Drawing  
Harmony has a wide array of drawing tools and drawing features to allow flexible design, work methods and styles.

Depending on the type of layer you select, here are the drawing tools available:

Tool Name Icon Vector Layer Bitmap Layer

Select • •

Cutter • •

Reposition All Drawings •  

Contour Editor •  

Pencil Editor •  

Smooth Editor •  

Perspective •  

Envelope   

Edit Gradient/Texture •  

Brush • •

Pencil •  

Text • •

Eraser • •

Paint • •

Ink •  

Paint Unpainted • •

Repaint •  

Unpaint • •

Stroke •  

Close Gap •  

Line • •

Rectangle • •

Ellipse • •

Polyline •  

Dropper • •

Each drawing tool has a series of options to customize its behaviour and drawing style.
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The Tool Properties view displays the properties of the currently selected tool on the current layer you are 
working. If you are editing a vector layer, then all of the tools are available to you. If you are drawing on a bitmap 
layer, some tools are not available. When tools are not available, they are grayed out in the Tools toolbar.
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About the Brush Tool
T-HFND-004-003

The Brush    tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if it was 
created with a paint brush.

With the Brush tool, you can draw as vector or bitmap, depending on the type of drawing layer you are using.  

If you draw with vector, you can enlarge your drawing and zoom into it without losing quality or resolution. You can 
also use the Contour Editor and Select tools to resize and modify lines. 

If you draw with bitmap, you will not be able to scale your drawing beyond 100% of its resolution without 
encountering pixelization issues.

There are a variety of brush styles provided with Harmony, which you can use to create and save your own brush 
style. This lets you create brushes with precise sizes and parameters and save them so you can draw and design 
with them. Renaming a brush can make it easier to identify and access the brushes you use most frequently.

You can also create a dynamic brush for drawing with patterns created from your artwork. Create a new dynamic 
brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic brushes using a single or 
multiple patterns that automatically switch through the patterns as you draw.

NOTE: To learn more about the Brush tool options, see the Reference guide .
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Drawing with the Brush Tool
T-HFND-004-003A 

In the Drawing view, you can draw on any drawing layer type with the Brush tool. 

NOTE: To learn more about the Brush tool options, see the Reference guide .

How to draw with the Brush tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Colour view, click a colour swatch to select a colour.

 4. In the Drawing or Camera view, start drawing.

 l Hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) to force a line to join the start and end of the 
shape while drawing.
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Modifying the Brush Settings
You can modify several parameters such as the brush size and smoothing. 

NOTE: If you are trying to create artwork on a bitmap drawing layer, and therefore with a bitmap brush, see 
About Bitmap Brushes on page 106

How to modify the brush settings

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters. Click the arrow button.

The Brush Properties window opens.

Parameter Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter 
defines the  width of the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the 
maximum size. If you do not have pressure sensitivity from a 
pen table, the minimum size value will be ignored. 

Smoothing
Defines the number of control points added to the centre line. 
The fewer the control points the smoother (but less faithful) the 
line.
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Contour Smoothness

Optimizes the contour line smoothness of the line. This 
parameter smooths the contour of the line once it has been 
traced. The higher the value, the fewer control points will 
compose your line. 

Tip Shape

Lets you select a tip shape—from round and square ones to star 
shaped. This option is disabled when using a textured brush.

NOTE: To learn more about the Brush tool options, see the Reference guide .
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Selecting a Brush Preset
Harmony provides you with default brush presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset from the Presets section.
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Creating a Brush Preset
You can create your own custom brush presets and add them to the existing list.  

How to create a brush preset

 1. Make sure your current brush has the settings you want in the preset you will create—see the Reference guide
 .

 2. In the Tool Properties view, do one of the following:

 l Click the arrow button to display the Brush Properties window and click the New Brush  but-
ton  in the upper-right corner.

 l Click the New Brush  button.

 l From the Brush  menu, select New Brush Preset.

 3. In the New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush presets.
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Creating Dynamic Brush Presets
You can create dynamic brush presets allowing you to stamp custom patterns. You can either repeat the same 
pattern or loop a pattern made of several drawings. 

How to create a new dynamic brush

 1. In the Tools toolbar, select a drawing tool.

 2. In the Drawing view, draw the pattern you want to use as your dynamic brush stamp.

 3. In the Tools toolbar, click the Select  tool and  select the parts of the drawing you want to repeat.

 4. In the Tools toolbar, select the Brush  tool or press Alt + B.

 5. In the Tool Properties view, click the Add Dynamic Brush  button to add your selection as a new 
dynamic brush preset.

 6. From the Brush  menu, select Rename Brush.

 7. Type in a name for the new dynamic brush and click OK.

 8. In the  Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.
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 9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, adjust the Maximum Size 
value in the Tool Properties view.
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Renaming a Brush Preset
To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tool Properties view, select a brush to rename. 

 2. From the Brush  menu, select Rename Brush. 

 3. Type in a new name for the brush and click OK.
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Deleting a Brush Preset
You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tool Properties view, select the brush preset you want to delete.

 2. Do one of the following:

 l Click the Delete Brush  button.

 l From the Brush  menu , select Delete Brush.
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Updating a Brush Preset
If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in the 
Tool Properties view and then update the preset. 

How to update a brush preset

 1. Select the brush preset to update and click the arrow button to display the Brush Properties window.

 2. Change the brush settings and click the Update Brush Preset  button  in the upper-right corner.
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Exporting Brush Presets
You can export your presets to either backup. share, or install on a different computer. 

How to export pencils, brushes and erasers

 1. From the Brush menu, select Export.

 2. In the Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as any 
pencils.

 3. Click Export.

 4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file and 
give it a name.

 5. Click Save.
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Importing Brush Presets
You can import Harmony brush presets that you previously exported. 

How to import pencils, brushes and erasers

 1. From the Brush menu , select Import Brushes.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also 
import pencils at the same time.

 5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the 
imported tips to create other brush, eraser and pencil style presets.
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Changing the Brush Preset Display
You can display your preset list as thumbnails or a list. 

How to change the Presets Library thumbnail display

 1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. Dis-
plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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About Vector Textured Brushes
In Harmony, you can use the Brush  tool to draw with bitmap textured brushes on vector layers. Those 
brushes are a mix of vector contours with bitmap texture fills.

In the Brush Tool Properties view, you will find a series of default textured "brushes", but you can also create and 
import your own custom collection. In Harmony, when using a textured brush on a vector layer, the texture of a 
brush is referred to as the Paper Texture. In other words, we are attributing the texture not to the tool, but to the 
texture of the surface that is revealed when a stroke passes over it. You will understand why when you work with 
bitmap brushes on bitmap layers, where it is possible to have both a textured brush tip and a paper texture.

To create your own textured brush, you must prepare your texture file ahead of time, either in Harmony or in a 
third-party software, such as Adobe Photoshop. Colour is not supported and transparency is not supported in the 
traditional sense. Black appears as 100% opaque, white appears as 100% transparent, and all the shades of grey 
in between appear as varying degrees of semitransparenty. A range of file formats are supported—.jpeg, .png, .tif, 
.psd, .tga to name a few. Alpha channels are disregarded on import. It is recommended that you maintain the 
texture resolution between 100 x 100 pixels and 400 x 400 pixels. 

You can import your custom paper textures in the extended Brush Properties window. Browsing for a texture file 
with a brush selected that is already using a paper texture will replace the file currently in use. It will not, however, 
replace the texture in lines already drawn. The replaced texture swatch will no longer be the selected texture, but 
it will remain in the texture library and not be deleted.

Harmony also allows you to import  textures as an .xml file that was exported from another project. In this way, 
you do not have to import individual image files one-by-one to have the same texture library and brush presets as 
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others who you are collaborating with. You can also export brush presets and textures, in order to share your default 
or customized textures and presets with other project collaborators.

When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and you lose the 
feather created while drawing with the Brush tool. In Harmony, a special option in the Eraser Tool Properties lets you 
create a soft edge on your textured lines. You can also cut or keep the vector frame as is.

At some point, you may want to modify the look of a textured drawing if you suddenly find that your lines look too 
hard or too light. You can adjust those parameters by using the Adjust Line Texture Opacity command.

To draw with textured lines, use the Brush tool and the correct brush in the list. You can also draw with pencil line 
texture—see About Pencil Line Texture on page 139
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Drawing with Vector Textured Brushes
Delete this text and replace it with your own content. 

How to draw with textured lines

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. Select a texture for your brush from the textures presets available at the end of the list.

 3. If you want to modify the settings, in the Tool Properties view,  click the Arrow button to open the Brush 
Properties view.

 4. Click the Texture tab, select the Paper Texture option.

 5. Set the following parameters: 

Parameter Description

Hardness The hardness value corresponds to the softness of the line edge. 

94



Harmony 14 Paint - User Guide

The lower the value, the softer the line edge will be. The higher 
the value, the sharper the line edge will be.  

Maximum Opacity
This value corresponds to the transparency of the stroke when 
the pressure is heavy.  

Minimum Opacity

This value corresponds to the transparency of the stroke when 
the pressure is light and is a percentage of the Maximum Opacity 
value. 

 6. In the  Drawing view, start drawing.
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Adding a Paper Texture
You can add custom paper textures to your presets. 

How to add a paper texture

 1. Do one of the following:

 l From the Paper Texture menu , select Add.

 l Click the Add Paper Texture button.

 2. In the browser window that appears, navigate to where you saved your texture file.

 3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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Renaming a Paper Texture
You can rename your paper textures to keep your list organized. 

How to rename a paper texture

 1. In the Paper Texture library, select a texture.

 2. From the Paper Texture menu, select Rename.

 3. In the Rename Texture dialog box that appears, type in the new name for the texture. 

 4. Click OK.
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Deleting Paper Textures
You can delete unnecessary paper textures from your preset list. 

How to delete a paper texture

 1. In the Paper Texture library, select a texture.

 2. Do one of the following:

‣ In the Paper Texture menu, select Delete.

‣ Click the Delete  button.

NOTE: You can delete any texture in the texture library as long as there is no brush preset using it.
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Erasing Textured Lines
You can erase vector textures lines with a smooth eraser edge. 

How to erase textured lines

 1. In the Tools toolbar, select the Eraser  tool, press Alt + E.

 2. In the Tool Properties view, click the arrow button.

The Eraser Properties window opens.

 3. Adjust the following: 

Hardness
Defines the softness of the stroke edge. The lower the value, the 
softer the stroke edge will be. The higher the value, the sharper 
the stroke edge will be.

Saturation

Lets you adjust the softness of edge feathering. Works in con-
junction with the Hardness, e.g. 100% Hardness will yield no res-
ults in saturation change. 0% Hardness will allow a fine tuning of 
the feathering of the soft stroke edge.

Maximum Opacity

The transparency of the brush when the pressure is heavy.  A 
smaller value will leave semi-transparent colour and texture. A 
larger value will ensure that everything is properly erased. This 
option in unavailable if the Keep Vectors option is disabled.

Minimum Opacity
Sets the minimum transparency of the brush, in relation to the 
Maximum Opacity, when the pressure is very light. A smaller 
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value will leave semi-transparent colour and texture. A larger 
value will ensure that everything is properly erased.  This option 
in unavailable if the Keep Vectors option is disabled.

Keep Vectors

Keeps the vector frames around your strokes intact, only the tex-
ture fill disappears. Disabling this option will cut the stroke's vec-
tor frame into different pieces when the Eraser tool passes over 
it. If you disable this option, the maximum and minimum opacity 
sliders are disabled as well.

 

 4. In the  Drawing view, erase your textures lines.
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Exporting Paper Textures
You can export paper textures for either backup, sharing, or installing on a different computer. 

How to export paper textures

 1. In the Paper Texture menu, select Export.

 2. In the Export Tips and Textures window, scroll down the textures list to the paper textures and select or 
deselect any textures to create the list that you wish to export.  You can export brush tips at the same time 
too.

 3. Click on the Export button.

 4. In the Export Textures window that appears, browse to a location where you would like to save the .xml 
file and give it a name.

 5. Click Save.
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Importing Paper Textures
You can import paper texture presets you previously exported from Harmony. 

How to import paper textures

 1. In the Paper Texture menu, select Import.

 2. In the browser window that appears, navigate to and select  the .xml file.

 3. Click Open.

 4. In the Import Textures dialog box, select the paper textures that you wish to import. You can import any avail-
able brush tips at the same time too.

 5. Click Import.

The imported paper textures will appear in the Paper Texture Library. You can reuse any of the imported paper 
textures to create other brush style presets.
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Adjusting the Line Texture Opacity
If you drew with textured lines that are either too light or too dark, you can adjust the line texture opacity of your 
drawings.

How to adjust the line texture opacity

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the  Drawing view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line Texture Opacity dialog box opens. 

 3. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.

 4. If you want to apply the changes to all drawings exposed on the layer, select the Apply to All Drawings 
option and click OK.
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Changing the Paper Texture Display
You can change the display of the paper texture presets to thumbnails or a list. 

How to change the Paper Texture thumbnail display

 1. From the Paper Texture menu, select one of the following:

Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.

Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.

List View Allows you to see the name, as well as the thumbnail.
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About Bitmap Brushes
With Harmony, you have the choice to draw with vector or bitmap brushes. This is decided by what modes you 
select for your layer. When adding a new drawing layer in Harmony, you can set your art layers (Line Art, Colour 
Art) to vector or bitmap. This way, you can draw in bitmap and paint in vector, draw everything in bitmap, or any 
other combination that suits your needs. If you are using the Overlay and Underlay layers, you can also set them 
to bitmap or vector.

When drawing on a bitmap layer, these are the tools available:

 l Brush

 l Cutter

 l Dropper

 l Edit Gradient/Texture

 l Ellipse

 l Eraser

 l Line

 l Paint

 l Paint Unpainted

 l Pivot

 l Rectangle

 l Repaint

 l Reposition All Drawings

 l Select

 l Text

 l Unpaint

On a bitmap layer, a temporary vector layer is created when painting with a gradient. Until a modification is made 
on your layer with a bitmap drawing tool, you can edit your last painted zone, by editing the gradient swatch, 
which is dynamically linked to the painted zone or using the Edit Gradient texture tool. When a bitmap drawing 
tool or action is used, a vector-to-bitmap conversion occurs. If there are vector elements on the layer (such as if 
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you switched your art mode from vector to bitmap after having created vector artwork), they too will be converted to 
bitmap.

Here is a list of tools and actions that will trigger a vector-to-bitmap conversion:

 l Brush

 l Ellipse 

 l Eraser

 l Line

 l Paint

 l Paint Unpainted

 l Rectangle

 l Repaint

 l Unpaint

 l Performing a paste with the Select tool selected

 l Performing a paste with the Cutter tool selected

This means that certain tools, such as the Text or Cutter tool, will not trigger a conversion. 

If you selected the incorrect art modes for your layer, you can open the Layer Properties view and change them. If 
you switch the art mode for a layer that already has strokes on it, the artwork will NOT be converted for bitmap 
artwork, but will be for vector artwork, though not immediately.  A drawing with bitmap strokes on a newly converted 
vector layer will remain bitmap. This means that the bitmap artwork will not be editable by some tools, such as the 
Eraser tool, but will be editable by other tools, such as the Cutter tool. However, a drawing with vector lines on a 
newly converted bitmap layer will remain vector temporarily, until a bitmap drawing tool or action is used. Then the 
vector-to-bitmap conversion will occur.

To always reuse the same art mode settings, you can adjust them in the Preferences dialog box.

If you want to be able to edit the artwork in the new mode, you need to convert the drawings.

Vector-to-bitmap conversion includes flattening individual drawings into a single image. Flattening means that it will 
not be possible to select non-overlapping or overlapping elements as individual objects with the Select tool. Instead, 
the selection of one drawing will initiate the selection of all elements, with a single vector frame surrounding them.

Resampling is also triggered on bitmap layers with the use of a bitmap drawing tool. For example, if you draw the 
outline of a circle, scale it down and then zoom into it, you will see tiny square pixels along the edge of the line. If you 
then draw a line right next to it, you will notice two things: first that the square pixels of the new line are gigantic by 
comparison and that the pixels in the line of your circle suddenly become the same size. This is because the circle 
was resampled. It was not resampled when you scaled it down. It was resampled when you used a bitmap drawing 
tool. It is resampled so that all the drawn objects are scaled to the same bitmap grid, in other words that their basic 
unit, the pixel, is the same size. The grid is defined by the bitmap layer's resolution.
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Before you start drawing in bitmap, it is important to understand that your artwork will now be resolution 
dependent. If you zoom in your scene, you artwork will be enlarged. It is important to plan ahead and decide how 
high of a resolution you need your artwork to be. If you plan to zoom in your scene, the smallest section of the 
image that the camera will frame must be 100% the size of your scene resolution. For example, if your scene 
resolution is set to 1920 x 1080 and you zoom- in 300% with your camera, then the resolution of the bitmap layer 
also has to be set to 300%, otherwise its elements will look pixelated in the final render. It is important to change 
the bitmap layer resolution before you start drawing.

The bitmap resolution can be set at the scene level or drawing level. The setting at the scene level affects newly 
created bitmap art layers. 

Note that even if your drawing resolution is set to be very large, it doesn't mean that your file will be very heavy. It 
depends on the amount of artwork you draw in it.
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There is a function to Lets you change the resolution of bitmap art for individual drawings. You can reduce the 
resolution of your bitmap file as well as increase it. Be careful because enlarging the bitmap resolution on an existing 
drawing will result in a loss of quality.Harmony will perform a pixel smoothing pass (resampling) and create 
additional pixels to avoid losing too much quality, but only to a certain extent. This feature is very useful when you 
need to have a full resolution of a bitmap image (such as imported bitmaps as .psd or .tga for the background) for 
tracing to create a matte directly in Harmony.By default, Harmony creates small thumbnail images when imported 
as bitmap in order to increase performance by using a small thumbnail image instead of using the original large size 
bitmap for animation work in Harmony. This will make difficult to view details or trace due to the low resolution 
(blurry). This option temporary increases the resolution of bitmaps up to their original bitmap resolution to make 
tracing easier. 

For example, what if you used the default scene’s resolution for some bitmap art, but then discover you are zooming-
in quite close?  If you do not want to see the pixels appear too much when you are zoomed in, you can set the bitmap 
resolution to 200% and the bitmap art will have a higher resolution with smaller pixels, but will NOT retain 100% of its 
quality. You can use this function on multiple drawings using the Apply to All Drawings option. Changing this option 
will affect existing and selected bitmap art layers.

If you draw an outline on a bitmap layer, you can still vectorize it. Using a vector drawing layer, simply select your 
bitmap drawing and the vector cell of where you want your vectorized line to be, and use the Vectorize Line Art in 
Selected Drawing function.

You should avoid scaling up your bitmap strokes using the Select tool. If you do, keep in mind that when you 
continue drawing, your image will be resampled and your new strokes will be scaled to the scene resolution. 
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NOTE: Your drawing should be scaled up using the Transform  tool when animating, instead of the Select 
tool, in order to avoid creating very large bitmap layers. Harmony calculates the scaling of your drawings 
when you use the Transform tool; your image is mathematically transformed. When you use the Select tool 
to scale, you are physically scaling the drawing.
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Drawing with Bitmap Brushes
You can use the Brush tool to draw on bitmap layers.

How to draw with bitmap brushes

 1. In the Drawing Thumbnails panel, select a bitmap drawing.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Colour view, select a colour.

 l To switch the bitmap colour picker from HSV to RGB, in the Colour view menu, select Colour 
> Bitmap Colour Sliders > HSV Sliders or RGB Sliders. You can also right-click on the col-
our sliders and select RGB Sliders or HSV Sliders.

When using bitmap colours, there is no longer a link between the painted zones and selected colour. 
You can edit the colour  as much as you want, but your drawing will not be affected. You can still select 
colours from your vector colour palette to use the same tint, but you will not create links between your 
drawing and the swatches.

 4. In the Camera or Drawing view, start drawing.

111



Chapter 4: Drawing      Changing the Paper Texture Display

112



Harmony 14 Paint - User Guide

Creating Bitmap Brushes
With bitmap brushes in Harmony, you can create an infinite range of fuzzy, textured and watercolour lines. You can 
combine two different brush tips, with separate sets of parameters, with the Dual Tip feature. You can also select a 
paper texture that will mimic the texture of the surface that is being painted on. Uses these features separately or in 
combination to create distinct, natural-looking strokes.

How to create a bitmap brush preset

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B.

 2. In the Tools toolbar, select the Brush  tool or press  Alt + B.

 3. In the Tool Properties view, select a brush and click the Arrow button to open the Bitmap Brush Properties 
view.

 4. In the Tip tab, select a brush tip.
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 5. Click on the different tabs to access the options available for adjustment. You can use the brush stroke pre-
view at the top to view all your adjustments in real time.

 l Tip tab: Make adjustments to size, brush tip angle, hardness and spacing.

 l Transparency tab: Make adjustments to flow and opacity.

 l Dual Tip tab: Select this option to enable the Dual Tip feature. Select a dual brush tip and 
make adjustments to its size, brush tip angle, hardness and spacing.

 l Paper Texture tab: Select this option to enable the Paper Texture feature. Select a paper 
texture and make adjustments to its scale, alignment and additivity. To learn more about 
using paper textures, see:
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 l Adding a Paper Texture on page 97

 l Renaming a Paper Texture on page 98

 l Deleting Paper Textures

 l Exporting Paper Textures

 l Importing Paper Textures

 l Changing the Paper Texture Display on page 105

 6. When you are satisfied with the look of your bitmap brush, click the Add New Brush Preset  button at the 
top-right corner of the Bitmap Brush Properties window.

 7. In the New Preset dialog box that appears, enter the name for your brush preset.

 8. Click OK.

If you continue to make adjustments to your new brush preset and want to save these changes, click the 
Update Preset  button. Otherwise, your modifications will only be saved until another brush preset or 
drawing tool is selected.

How to add a brush tip

 1. Do one of the following:

‣ From the Brush Tip menu, select Add.

‣ Click the Add  button.

 2. In the browser window that appears, navigate to where you saved your file.

 3. Click Open to import the file into the Brush Tip Library.

By default, an imported brush tip is given the name of the image file.
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Renaming Brush Tips
You can rename your bitmap brush tips to keep your list organized. 

How to rename a brush tip

 1. In the Brush Tip Library, select a brush tip.

 2. From the Brush Tip menu, select Rename.

 3. In the Rename  dialog box that appears, type in the new name of the brush tip. 

 4. Click OK.
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Deleting Brush Tips 
You can delete unnecessary brush tips to keep your list organized. 

How to delete a brush tip

 1. In the Brush Tip Library, select a brush tip.

 2. Do one of the following:

‣ In the Brush Tip menu, select Delete.

‣ Click the Delete  button.

The linked brush tip file does not get deleted and can therefore be reimported. 
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Exporting Brush Tips
You can export brush tips to share, backup or install on a new computer. 

How to export brush tips

 1. In the Brush Tip menu, select Export.

 2. In the Export Tips and Textures window,  select or deselect any of the brush tips to create the list to export. 
You can also export paper textures at the same time.

 3. Click Export.

 4. In the Export Textures window that appears, browse to a location where you want save the .xml file and 
give it a name.

 5. Click Save.
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Importing Brush Tips
You can import Harmony brush tips you previously exported.

How to import brush tips

 1. In the Brush Tip menu, select Import.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Textures dialog box, select the brush tips to import. You can also import paper textures at the 
same time.

 5. Click Import.

The imported brush  tips appear in the Brush Tips Library. You can reuse any of the imported tips to create 
other brush style presets.
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Changing the Brush Tip Display
You can display your preset list as thumbnails or a list.

How to change the Brush Tips thumbnail display

 1. From Brush Tip menu, select one of the following options:

Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.

Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.

List View Allows you to see the name, as well as the thumbnail.
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About the Pencil Tool
T-HFND-004-004

The Pencil  tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation. The 
pencil creates a central vector shape. Pencil lines support pressure sensitivity and texture.

The Brush  and Pencil  tools are used for drawing and sketching. Both  tools support pressure sensitivity, allowing you 
to create lines with variable thickness. The Brush tool produces contour vector lines. The Pencil and shape tools 
produce central vector lines. This means that a pencil line’s control points (used to deform its shape) are located 
along the length of the central spine, while the Brush line’s control points are located along the contour.

 l If you draw with the Brush tool and want to modify the thickness variation, use the Contour Editor  tool. 

 l If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor  tool. 

 l You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line   option.

If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the Brush tool as it 
produces a more realistic and natural feel. The pencil line is very useful for tracing clean or final drawings.
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Also, it is recommended to use brush lines when designing cut-out puppet articulations which use patches.

NOTE: To learn more about the Pencil tool options, see the Reference guide .

122



Harmony 14 Paint - User Guide

Drawing with the Pencil Tool
T-HFND-004-004A

Using the Pencil tool, you can draw central vector lines which easily reshapeable.

NOTE: To learn more about the Pencil tool options, see the Reference guide .

How to draw with the Pencil tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Colour view, click a colour swatch to select a colour.

 4. In the Drawing view, start drawing.

 l When you get close to an existing pencil line, hold Alt to draw and connect your stroke to the 
existing one. Pencil lines are central vector lines and you might think your line is connected, but 
in fact, only the contour is touching the other one. Also, make sure the central vector crosses 
the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

 l To draw a straight line, press Shift + Alt as you draw.
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Modifying the Pencil Settings
You can modify the Pencil tool settings such as the size, smoothing, and ends, 

How to modify the pencil settings

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters in the Tool Properties view. Click the arrow button.

The Pencil Properties window opens.
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This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick 
and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Size and Smoothness tab

Maximum Size Sets the maximum width of the line.

Minimum Size Sets the minimum width of the line in relation to the maximum size.

Smoothness
Lets you modify the central line smoothness  of the line. This parameter 
smooths the initial movement of your line. Increasing the value will result in a 
smoother line with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter will smooth 
the contour of the line once it has been traced; the higher the value, the fewer 
control points will compose your line.

Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip you 
drew. You can choose between Round or Flat style.
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 l End: Lets you select the style of the end tip, which is the last tip you 
drew. You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line curves 
abruptly. You could also define the Join style as the corner style. You 
can choose between Round, Mitre and Bevel style.

Texture tab

Texture See About Pencil Line Texture on page 139.
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Selecting a Pencil Preset
A pencil preset is a pencil with specific properties. You can work with regular pencil presets and thickness 
stencils.

How to select a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, use the Presets menu to select a pencil preset.

 3. In the Drawing view, draw your pencil line or shape.
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Creating Pencil Presets
You can create your own custom pencil presets.  

Regular pencil presets allow you to set the size and smoothing of the line or shape.  As you draw, the thickness of 
the line varies according the amount of pressure you apply with a pen and tablet.

NOTE: To learn more about the Pencil tool options, see the Reference guide .

How to create a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, adjust your pencil settingsthe Reference guide .

 3. In the Tool Properties view, click the New Brush  button.

The New Preset dialog box opens.

 4. Type in a name for your new pencil thickness stencil and click OK.

 5. Start drawing in the Drawing view. 
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Creating Pencil Thickness Presets
Thickness stencils that are indicated with this  icon  are also set with specific properties, but disregards the 
pressure of your pen and tablet. The line thickness varies. You can access thickness stencils from the list of 
presets on the Tool Properties view or create your own. 

How to create a pencil thickness stencil

 1. In the Tools toolbar, select the Select  tool.

 2. In the Camera view, select the pencil line or shape from which you want to take the style.

 3. In the Tool Properties view, click the New Thickness Stencil  button.

A new thickness stencil is added to the end of the list in the Presets menu.

 4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Drawing view to 
apply the thickness stencil you created.
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Renaming Pencil Presets
You can rename your pencil presets to keep your list organized.

How to rename a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Presets menu, select the thickness stencil or preset you want to rename.

 3. From the Brush menu , select Rename Brush.

The Rename Preset dialog box opens.

 4. In the Name field, type in the new name.

 5. Click OK.
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Deleting Pencil Presets
You can delete unnecessary presets from your list. 

How to delete a thickness stencil or pencil preset

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Presets menu, select the thickness stencil or preset to delete.

 3. Click the Delete Preset  button.
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Applying a Pencil Preset
You can apply a pencil preset on already drawn pencil lines using the Select tool.

How to apply a thickness stencil to a pencil line or shape

 1. In the Tools toolbar, select the Select  tool.

 2. In the Drawing view, select the pencil line or shape on which you want to apply a style.

 3. In the Tool Properties view, select the style you want to apply from the Presets list.

The style you selected is applied to your selection.
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Exporting Pencil Presets
You can export your pencil presets to either backup, share or install on a different computer.

How to export pencils, brushes and erasers

 1. From the Brush menu, select Export.

 2. In the Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as 
any pencils.

 3. Click Export.

 4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file 
and give it a name.

 5. Click Save.
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Importing Pencil Presets 
You can import Harmony pencil presets that you previously exported. 

How to import pencils, brushes and erasers

 1. From the Brush menu , select Import Brushes.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also 
import pencils at the same time.

 5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the 
imported tips to create other brush, eraser and pencil style presets.
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Changing the Pencil Preset Display
You can display your preset list as thumbnails or a list. 

How to change the Presets Library thumbnail display

 1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. 
Displays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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Changing Pencil Line Opacity Display
A central vector outline can obscure the true edges of a shape's fill. You can change the opacity of central vector 
lines and outlines, while working, to bypass this problem. This feature only works in the OpenGL view. This feature 
is meant to be used as a working tool, like the Light Table or Onion Skin, therefore this transparency effect will not 
appear when the scene is rendered. However, the opacity value that you set will remain as the set preference, even 
after you end a session and close the software.

If you want the transparency of a line or outline to show up in the render of your scene, use one of the many other 
options that Harmony offers, such as colouring the line with a semi-transparent swatch or using the Transparency or 
Colour-Override effects.

How to Use the Pencil Line Opacity feature

 1. In either the Drawing view or Camera view toolbar, click on the Top Light icon. The Pencil Lines Opacity fea-
ture can also be accessed through the Preferences panel.

The Onion Skin and Light Table Transparency dialog opens.

 2. In the Onion Skin and Light Table Transparency dialog box, use the Pencil Lines Opacity slider to globally 
increase or decrease the opacity of central vector lines. Sliding the slider all the way to the right equals 100% 
opacity. Sliding the slider all the way to the left equals 0% opacity.
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 3. Click OK.

NOTE: If your object has a vector contour outline (created by the Brush tool), this feature will not work. It 
must have a central vector outline (created by one of the shape tools or Pencil tool).
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About Pencil Line Texture
You can apply a texture to a pencil line. Pencil lines support texture. Before drawing, you can select or import a 
texture and apply it to your lines. You can also change it afterward using the Select  tool. Textures are independent 
from pencil templates.

When you import a texture in your pencil styles, it is saved in your scene. If you want to add that texture to a bank 
that you will reuse in different scenes, you can add that texture to your preferences.
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Selecting Pencil Textures
You can select various pencil textures from a preset list.

How to apply a preset texture to a pencil line

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters in the Tool Properties view. Click the arrow button.

 3. In the Pencil Properties editor, select the Texture tab.

 4. In the Texture library, select a texture for the pencil.

 5. In the Drawing view, draw a pencil line.
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Creating Pencil Textures
You can create your own pencil texture presets. 

NOTE: To learn more about the Pencil tool options, see the Reference guide .

How to create a pencil texture template with the Pencil tool

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Tool Properties view, click the arrow button beside the stroke preview area.

 3. In the Pencil Properties editor, click the New Texture  button or select New Texture from the Texture 
menu.

 l To delete a preset style, click the Delete Texture  button or select Delete Texture from the 
Texture menu.

 4. Browse for your bitmap texture file. 

NOTE: The following file formats are supported: .jpg, .png, .psd, .sgi, .tif. Your texture MUST 
HAVE an alpha channel.

 5. Click Open.

The imported texture is saved in your texture list.

 6. In the Pencil Properties editor, select your new texture.
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 7. Click the Texture menu and select Rename Texture.

The Rename Opacity Texture dialog box opens.

 8. In the Name field, type the template name and click OK.

 9. In the Drawing view, draw your pencil line with your new texture.
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Applying Pencil Textures
You can apply a pencil texture preset to an already drawn line. 

How to apply a preset texture to a pencil line

 1. In the Tools toolbar, select the Select  tool.

 2. In the Drawing view, select a pencil line.

 3. In the Tool Properties view,  select a texture from the Textures area to apply to the selected stroke. 
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Adding Pencil Textures to your Preferences
You can add a pencil texture to your preset preferences. 

How to add a texture to your preferences

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Tool Properties view, click the arrow button beside the stroke preview area.

 3. In the Pencil Properties editor, select a texture from the Textures area to add to your preferences. 

 4. Click the Copy to Preference   button.
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About Shape Tools
T-HFND-004-006

In Harmony, you can use the shape tools to draw circles, lines and rectangles. You can also easily reshape a square 
or circle into a much more complex drawing—see About the Contour Editor Tool on page 169  and About the Pencil 
Editor Tool on page 172. 

The available shape tools are: 

 l Line tool

 l Rectangle tool

 l Ellipse tool

 l Polyline tool 

The shape tools use the same pencil presets as the Pencil tool. To learn how to create, delete, rename, import and 
export presets, see About the Pencil Tool on page 121.  

To learn more about the shape tool parameters, see the Reference guide . 
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Drawing with the Polyline Tool 
You can use the Polyline tool to draw long and curvy lines. 

NOTE: To learn more about the Polyline tool options, see the Reference guide .

How to draw with the Polyline tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Polyline   tool or press Alt + _.

 3. In the Drawing view, click and drag to create a point and a Bezier handle to shape your line.

 4. Click a new area and drag to create a second point and Bezier handle.

 l Press Alt to pull only one handle, instead of two.

 l Press Shift to snap the handles to 45, 90, or 180 degrees.

 

 5. Repeat the previous step until your shape is completed.

 6. Press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click to release the Polyline tool from the current path or 
shape that it is creating. Continue to use the tool to make multiple, independent paths or shapes.

 7. If necessary, reshape the lines using the Contour Editor    tool—see Reshaping a Drawing with the Con-
tour Editor Tool on page 170.
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Drawing with the Rectangle, Ellipse, and Line Tools 
T-HFND-004-006A

You can use the Line, Rectangle, or Ellipse tool to draw shape without having to trace them. You can also draw 
perfect circles and squares. 

NOTE: To learn more about the shape tool parameters, see the Reference guide . 

How to draw with a shape tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Rectangle , Ellipse , or Line  tool.

 3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill  option.

 4. In the DrawingCamera view, click and drag to draw the shape.
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 l Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

 l Hold down Alt to draw the rectangle or ellipse from its centre.

 l Hold down Shift to snap the line every 15 degrees.

 l Hold down Alt to snap the start or end of the line to a nearby stroke.

 5. Use the Contour Editor  tool to deform the shape and create your drawing.
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About the Stroke Tool
T-HFND-004-013

There are two different ways to draw invisible lines, using the Pencil tool or Stroke tool.

Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful for 
drawing tones and highlights directly on the character.

The Stroke  tool draws invisible lines only. You cannot add thickness to the line. Unlike the Close Gap tool that 
creates a short, straight line between two points, the stroke line will stay exactly where you draw it. This tool can be 
useful for closing a zone in a particular way or creating some hard shadows or highlight areas.

Sometimes, it may be difficult to see strokes, especially if your colours are similar to the blue stroke colour. In 
Harmony, you can display the strokes in washed-out colours so the invisible lines stand out.

NOTE: To learn more about the Stroke tool parameters, see the Reference guide 
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Drawing with the Stroke Tool 
T-HFND-004-013A

You can draw invisible lines with the Stroke tool as well as with the Pencil tool.  

NOTE: To learn more about the Stroke tool parameters, see the Reference guide 

How to draw invisible lines with the Stroke tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar from the Paint drop-down menu, select the Stroke  tool or press Alt + V.

 3. From the top menu, select View > Show Strokes  or press K. 

 4. In the Tool Properties view, you can adjust the smoothness.

 5. In the  Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a 
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about 
the Show Strokes option.

 6. Click OK.

 7. You can modify the stroke shape with the Contour Editor  tool.

How to draw invisible lines with the Pencil tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. From the top menu, select View > Show Strokes  or press K. 

 4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.

 5. In the  Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a 
Message dialog box opens.
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Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about the 
Show Strokes option.

 6. Click OK.

 7. You can modify the stroke shape with the Contour Editor  tool.

How to show the strokes with washed-out colours

 1. From the top menu, select View > Show Stroke With Colour Wash.
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About the Eraser Tool
T-HFND-004-010

Using the Eraser tool, you can remove parts of your drawing. When erasing brush strokes and painted areas, the 
contours will keep the shape you traced. When erasing pencil stroke, the central vector will be erased and the line 
tips will reshape based on the line's parameters. 

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when drawing 
and designing. Toon Boom Harmony provides you with a variety of default eraser styles and allows you to create 
and save your own.

Eraser presets are created by saving the properties of the current eraser as a preset, in order to reuse it again and 
again. 

The Eraser tool uses its own preset list, separated from the Brush tool. 

NOTE: To learn more about each individual parameter, see the Reference guide .

152



Harmony 14 Paint - User Guide

Erasing 
T-HFND-004-010A

You can erase portion of your artwork using the Eraser tool.  

For information on erasing textured lines, see How to erase textured lines on page 100. 

NOTE: To learn more about each individual parameter, see the Reference guide .

How to erase with the Eraser tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Eraser  tool or press Alt + E.

 3. In the Drawing view, start erasing.
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Modifying the Eraser Settings 
T-HFND-004-010B

In the Tool Properties view, you can modify the Eraser tool parameters such as the size and smoothing. 

NOTE: To learn more about each individual parameter, see the Reference guide  .

How to modify the eraser settings

 1. In the Tools toolbar, select the Eraser  tool.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters in the Eraser Properties view. Click the arrow button.

The Eraser Properties window opens.
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The Size and Smoothness tab is where you set the minimum and maximum sizes of your drawing tool which 
will produce the thick and thin effect on your stroke.

The Soft Eraser tab needs to be enable for its parameters to become active. This feature only works on soft 
or textured brush strokes. Both tabs works with the pressure sensitivity of a pen tablet.

Hardness
Defines the softness of the stroke edge. The lower the value, the 
softer the stroke edge will be. The higher the value, the sharper the 
stroke edge will be.

Saturation

Lets you adjust the softness of edge feathering. Works in con-
junction with the Hardness, e.g. 100% Hardness will yield no res-
ults in saturation change. 0% Hardness will allow a fine tuning of 
the feathering of the soft stroke edge.

Maximum Opacity

The transparency of the brush when the pressure is heavy.  A smal-
ler value will leave semi-transparent colour and texture. A larger 
value will ensure that everything is properly erased. This option in 
unavailable if the Keep Vectors option is disabled.

Minimum Opacity

Sets the minimum transparency of the brush, in relation to the Max-
imum Opacity, when the pressure is very light. A smaller value will 
leave semi-transparent colour and texture. A larger value will 
ensure that everything is properly erased.  This option in unavailable 
if the Keep Vectors option is disabled.

Keep Vectors

Keeps the vector frames around your strokes intact, only the tex-
ture fill disappears. Disabling this option will cut the stroke's vector 
frame into different pieces when the Eraser tool passes over it. If 
you disable this option, the maximum and minimum opacity sliders 
are disabled as well.
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Exporting Eraser Presets
You can export your eraser presets for backup, sharing or installing on a different computer. 

How to export pencils, brushes and erasers

 1. From the Brush menu, select Export.

 2. In the Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as 
any pencils.

 3. Click Export.

 4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file 
and give it a name.

 5. Click Save.
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Importing Eraser Presets
You can import Harmony eraser presets you previously exported. 

How to import pencils, brushes and erasers

 1. From the Brush menu , select Import Brushes.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also 
import pencils at the same time.

 5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the 
imported tips to create other brush, eraser and pencil style presets.

157



Chapter 4: Drawing      Changing the Eraser Preset Display

Changing the Eraser Preset Display
You can display your preset list as thumbnails or a list. 

How to change the Presets Library thumbnail display

 1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. 
Displays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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About the Select Tool
T-HFND-004-005

Before you can edit objects, you must first select them using the Select tool. After that, you can scale, translate, 
rotate, and resize them, as well as reposition the pivot point.

NOTE: To learn more about the Select tool options, see the Reference guide .
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Selecting 
T-HFND-004-005A

Using the Select tool, you can select drawing strokes and groups. 

NOTE: To learn more about the Select tool options, see the Reference guide .

How to select objects

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Select  tool or press Alt + S.

 3. In the Camera or Drawing view, select the drawing objects.

 l You can select all the drawing objects in a drawing by using Edit > Select All or by pressing 
Ctrl + A (Windows/Linux) or ⌘  + A (Mac OS X).

 4. To deform or reposition a selection:

 l To reposition, click the selected drawing object and drag the selection to a new area.

 l To rotate, grab the selection box handle and rotate it.

 l To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift to lock 
the selection’s ratio.
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 l To skew, drag sideways or up and down the sides or top and bottom segments, between the 
control points.
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Inverting a Selection
You can invert your selection to select everything else in your drawing that was not previously selected. 

How to invert a selection

 1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I.
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Repositioning the Selection Pivot
You can temporarily reposition the selection's pivot position to rotate, scale, or skew from a different point.

How to temporarily reposition the pivot point

 1. In the Drawing view, select the drawing object you want to transform. 

The pivot point appears in the middle of your selection.

 2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain there until you 
make a new selection.
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About the Repositioning All Drawings Tool
The Reposition All Drawings  tool is used to reposition, scale, rotate or skew all drawing strokes on every drawing 
included in a layer. 

If your hand-drawn animation requires to be repositionned in the grid, as soon as your select the Reposition All 
Drawings tool, all the strokes in all the drawings exposed on the current layer are selected. You can use the 
controls the same was as the Select tool—see About the Select Tool on page 159. 

You can use the Drawing Desk feature to select specific drawings and avoid repositioning all the drawings—see 
Drawing Desk. 

NOTE: To learn more about the Reposition All Drawings tool options, see the Reference guide .
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Repositioning Drawings
Use the Reposition All Drawings tool to reposition all the drawing strokes on all drawings exposed in the current 
layer. 

NOTE: To learn more about the Reposition All Drawings tool options, see the Reference guide .

How to reposition all drawings

 1. From the Tools toolbar, select the Reposition All Drawings  tool. This also automatically selects every 
stroke in your drawing in the Drawing and Camera view.

 2. Do any of the following:

 l To reposition, click and drag your selection to a new area.

 l To rotate, rotate the selection box handle.
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 l To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift to 
maintain the selection’s ratio.

 l To skew, drag the sides or top and bottom segments, between the control points.

 3. When you release your cursor, every drawing in the drawing layer you repositioned, scaled, rotated or 
skewed will follow the same transformation.

 4. You can also adjust the position by modifying the settings and using the operation buttons in the Tool Prop-
erties view.
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About the Cutter Tool
T-HFND-004-007

The Cutter tool lets you cut a drawing to move, copy, or delete it.You can use it to scale or reposition the portion of a 
flattened or bitmap drawing. you can also use it to trim strokes using a single gesture.

NOTE: To learn more about the Cutter tool options, see the Reference guide .
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Cutting Artwork 
T-HFND-004-007A

Use the Cutter tool to trim and cut your artwork. 

NOTE: To learn more about the Cutter tool options, see the Reference guide .

How to cut drawings

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Drawing view, select an area to cut away.

 l To delete the selected area, press Delete.

 l To move the selection, drag it to a new area.

 l Use the bounding box controls to scale, skew, or rotate the cut piece.
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About the Contour Editor Tool
T-HFND-004-008

The Contour Editor lets you reshape drawings. By displaying vector points around a shape and the central vector 
points in a pencil line, you can pull or push on these points to adjust the brush’s line thickness. Points can be 
selected and deleted. Each point has two Bezier handles for correcting the curves between two points. You can 
modify shapes by pulling and pushing directly on the segment between the points. You can use it to perfect a central 
shape pencil line, a contour shape brush line, or even create an elaborate shape from a basic ellipse or square.

NOTE: To learn more about the Contour Editor tool options, see the Reference guide .
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Reshaping a Drawing with the Contour Editor Tool
T-HFND-004-008A

You can use the Contour Editor tool to reshape vector drawings by editing the points. 

NOTE: To learn more about the Contour Editor tool options, see the Reference guide .

How to reshape drawings with the Contour Editor Tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Line , Ellipse , or Rectangle  tool. The following example uses the 
Ellipse tool.

 3. In the Tool Properties view, click the Ellipse  button, click the Auto Fill  button and set the pencil 
size to 0.

 4. In the Drawing  view, draw a circle.

 5. In the Tools toolbar, select the Contour Editor  tool.

 6. In the Drawing  view, click the line to reshape it.

 7. Select one or several points by clicking on them or circling around.
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 8. Press Delete to delete a selected point.

Press Ctrl (Windows/Linux) or ⌘  (Mac OS X)and click on the contour to add a new point to adjust the 
contour.

 9. To modify the shape, you can:

 l Pull on the Bezier handle. Both point’s handles will move as one.

 l Hold down Alt and pull on one of the Bezier handles. The point’s handle will move inde-
pendently from the other one.

 l Move the selected points to a new area.

 l Pull directly on the line between two points. No selection is necessary. Holding down Shift will 
limit the contour modification to the curve between the two first points.

 l If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

 l To add control points, press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click the line.

 l To remove control points, select the control point and press Delete.
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About the Pencil Editor Tool
T-HFND-004-009

A pencil line is a central vector shape. Control    points are located along the central spine allowing you to adjust the    
stroke curve and position. Using the Pencil Editor tool, you can adjust the thick and thin areas of pencil lines. 
Using the Contour Editor tool, you can reposition the spine of the stroke.

NOTE: To learn more about the Pencil Editor tool options, see the Reference guide .
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Reshaping Pencil Lines 
T-HFND-004-009A

You can use the Pencil Editor tool to reshape the pencil line thickness. 

NOTE: To learn more about the Pencil Editor tool options, see the Reference guide .

How to reshape pencil lines

 1. In the Tools toolbar, select the Pencil Editor  tool.

 2. In the  Drawing view, select a pencil line and click to reshape it.

 3. Select one or several points by clicking them or circling around.

 4. Press Delete to delete a selected point.
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 5. Press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click the central spine to add a set of points to adjust 
the contour.

 6. To modify the shape, you can:

 l Move the selected points to a new area. If you select matching points on each side of the 
line, holding the Shift key will move them both.  This way you can thicken or thin a line from 
both sides at the same time.

 l Pull on the Bezier handle to move both points’ handles s one.

 l Hold down Alt and pull on one of the Bezier handles. It moves the handle independently from 
the other one.
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 l Pull directly on the line between two points. No selection is necessary. Holding down the Shift 
key will limit the contour modification to the curve between the two first points.

 l If an anchor point has no visible Bezier handle, hold down Alt to display them.
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About the Smooth Editor Tool 
When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw may 
look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of your 
lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the lines, 
the Smooth Editor  tool. 

NOTE: To learn more about the Smooth Editor tool options, see the Reference guide .
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Smoothing Lines
You can use the Smooth Editor to smooth out specific areas of your drawing strokes.

How to optimize lines with the Smooth Editor tool

 1. In the Tools toolbar, select the Smooth Editor  tool or select  Tools > Smooth Editor.

 2. In the Drawing view, place your pointer over the lines to smooth. You may need to pass over the same line 
several times to remove more points and make the line smoother. Note that by default, the Smooth Editor tool 
colour is yellow, it was changed to orange for screen grab clarity—see the Reference guide  to learn about the 
various settings available.
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About the Perspective Tool
The Perspective tool lets you deform a drawing selection and alter its perspective. You can use the corner and 
edge anchor points to warp the shape.

To have even more control points to fully warp a vector image, see About the Envelope Tool. 

NOTE: To learn more about the Perspective tool options, see the Reference guide .
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Deforming a Drawing with the Perspective Tool
Use the Perspective tool to distort a drawing's bounding box.  

NOTE: To learn more about the Perspective tool options, see the Reference guide .

How to deform a drawing with the Perspective tool

 1. In the Tools toolbar, select the Perspective  tool from the Contour Editor drop-down menu or press Alt + 0.

 2. In the Drawing view, select a drawing to deform.

 3. Click and drag the different anchor points to deform the shape.
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About the Envelope Tool
The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles. You can 
warp images to make them look like they are reflected in water or in a deformable mirror.

NOTE: To learn more about the Envelope tool options, see the Reference guide .
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Warping a Drawing with the Envelope Tool
You can warp your drawings using the Envelope tool.  

NOTE: To learn more about the Envelope tool options, see the Reference guide .

How to warp a drawing with the Envelope tool

 1. In the Tools toolbar, select the Envelope   tool from the Contour Editor drop-down menu.

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the  Drawing view, select the region you want to deform

 3. Click and drag the different anchor points and handles to deform the image.
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 4. To display more controls, in the Tool Properties view, click the Show Advanced Controls  button.

 5. Increase the height and width of the grid to get more control points to deform your image.
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About the Text Tool
With the Text tool, you can type text in your project using various fonts and texts attributes. Text objects are part of 
a drawing, so you can manipulate them in the same way. OTF fonts are also supported.

Once your text is writing, you can break the strings apart to convert the letters into drawing objects that can than be 
individually modified with tools such as Select, Perspective, Contour Editor, Smooth Editor. 

NOTE: To learn more about the Text tool options, see the Reference guide .
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Adding Text
You can use the Text tool to add text to your drawings.  

NOTE: To learn more about the Text tool options, see the Reference guide .

How to add text to drawings 

 1. Do one of the following: 

 l In the Tools toolbar, select the Text  tool. 

 l From the top menu, select Tools > Text.

 l Press Alt + 9.

 2. In the Timeline view, select the cell containing the drawing on which you want to add text.

 3. In the Drawing view, click on the location you want the text to begin.

 4. You can use the Tool Properties view to select the font, font size and format of the text you will type—see 
the Reference guide . 

 5. Type in the desired text.

 6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always return 
to edit the text by selecting the Text  tool and clicking in the text.

 7. You can resize the text box by selecting your text box with the Text   tool and moving the anchor point 
right or left. Using the Select tool will distort and scale your text itself rather than changing the width and 
height of your text box.
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Breaking Text Apart
Text contained in a text field is treated as a single drawing object. You can easily separate the text so each 
character becomes an individual drawing object that you can select and modify independently.

How to break a text object

 1. In the Tools toolbar, click the Select  tool or press Alt + S.

 2. In the Drawing  view, select the text object you want to break.

 3. From the top menu, select Drawing > Convert > Break ApartText Layers.

Each character is surrounded by a bounding box that you can modify; they remain text objects that you 
can edit.

 4. If you want to convert your independent letter to a complete vector object that you can deform, use the 
Select tool to select the letters to convert.

 5. From the top menu, select Selected > Convert > Break Apart Text Layers to break the selection into a 
regular drawing object, with no more text attributes.
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About the Rotate View Tool
The Rotate View  tool lets you rotate the Drawing view, the same way as you would do with a real animation disc  for 
increased flexibility. This tool can also be used in the Perspective view.

When using the Rotate View tool, you are only rotating your workspace. You can not changing the actual rotation 
angle of your drawings. Exporting your project will completely ignore the Rotate View angle.

The Rotate View tool has no options in the Tool Properties view.
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Rotating the Workspace
You can use the Rotate View tool to rotate your drawing workspace. 

How to use the Rotate View tool

 1. Do one of the following:

 l From the top menu, select Tools > Rotate View.

 l In the Tools toolbar, select the Rotate View  tool.

 l In the Drawing view, right-click and select Drawing Tools > Rotate View.

 l Hold down Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X).

The rotary table appears.

 2. In the Drawing view, click and drag to rotate the space. 

 3. Release the keyboard shortcut or switch to a new drawing tool.

 4. Reset the view rotation using View > Reset Rotation or press Shift + X to reset the rotation.
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About the Hand Tool
You can use the Hand tool to pan through the Drawing  view. When you are zoomed in your workspace, you may 
need to pan to a different area of your image. You can do so with the Hand tool or the Spacebar keyboard shortcut. 

The Hand tool has no options in the Tool Properties view.

How to use the Hand tool 

 1. Do one of the following:

 l In the Tools toolbar, select the Hand  tool, click in the Drawing  view and drag. 

 l You can also Hold down the Spacebar, click in the Drawing  view and move your mouse in the 
direction you want to pan the view.
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About the Zoom Tool
The Zoom   tool in the Tools toolbar lets you zoom in and zoom out of the Drawing view.

NOTE: To learn more about the Zoom tool options, see the Reference guide .

How to use the Zoom tool 

 1. In the Tools toolbar, select the Zoom  tool available in the Hand tool drop-down menu. 

 2. Click in the  Drawing view. 

 3. In the Tools Properties view, do the following:  

 l Enable the Zoom In  mode to zoom in mode when you click in the  Drawing view. When 
you're in Zoom In mode, hold  as you click to zoom out.

 l Enable the Zoom Out mode to zoom out when you click in the  Drawing view. 

 l Click on the Zoom In  button to immediately zoom in. You can also press 2.

 l Click on the Zoom Out   button to immediately zoom out. You can also press 1.
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About the Grid 
Harmony is equipped with a traditional animation grid. You can use it as a reference while drawing to fit a given 
layout field chart, align elements, or simply see the center of your drawing. You can draw beyond the grid boundaries 
as it is only a visual reference.  
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Displaying the Grid
You can display the grid and it will be visible in the Drawing view.

Use the Show Grid option to display a grid in the Drawing  view. 

How to display the grid 

 1. Do one of the following: 

 l In the Drawing View toolbar, press the Show Grid  button. 

 l In the Camera View toolbar, press the Show Grid  button.  

 l Select View > Grid > Show Grid. 

 l Press Ctrl + ' (Windows/Linux) or ⌘  + ' (Mac OS X).
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Modifying the Grid
You can modify the look of the grid to be either square, 12-field, 16-field, outline, and so on. 

How to modify the grid display  

 1. Select View > Grid > Show Grid to display the grid. 

 2. To modify the grid, select one of the following: 

 l View > Grid > Grid Outline Only—Displays the outline of the grid only.

 l View > Grid > Square—Displays a standard square grid. 

 l View > Grid > 12 Field Grid—Displays a 12-field size grid. 

 l View > Grid > 16 Field Grid—Displays a 16-field size grid.

 l View > Grid > Underlay—Displays the grid under the drawing elements. 

 l View > Grid > Overlay—Displays the grid over the drawing elements.
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Grouping Drawing Strokes
Use the grouping options to group and ungroup selected drawing objects and strokes. This can help in the 
selection, repositioning, re-scaling and other transformations to be applied to multiple objects of a drawing. 
Grouping does not flatten your objects. You can ungroup your selection at any time. You can also group groups. 

How to group strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be grouped.

 3. Do one of the following:

 l From the top menu, select Selected> Group > Group.

 l Press Ctrl + G (Windows/Linux) or ⌘  + G (Mac OS X). 

How to ungroup strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  groups to be ungrouped.

 3. Do one of the following:

 l From the top menu, select Selected > Group > Ungroup.

 l Press Ctrl + Shift + G (Windows/Linux) or ⌘  + Shift + G (Mac OS X). 
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Arranging Drawing Strokes
The different Arrange options let you reorder drawing objects and strokes inside a single layer in the Drawing view.  

How to arrange drawing strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be reordered.

 3. Do one of the following: 

 l From the top menu, select Selected > Arrange > Bring to Front—Moves the selected art to 
the front (on top). Press Ctrl + Shift + PgUp (Windows/Linux) or ⌘  + Shift + PgUp (Mac OS X).
 

 l From the top menu, select Selected > Arrange > Bring Forward—Moves the selected art one 
level forward (closer to the front). Press Ctrl + PgUp (Windows/Linux) or ⌘  + PgUp (Mac OS 
X).

 l From the top menu, select Selected > Arrange > Send Backward—Moves the selected art 
one level lower (behind). Press Ctrl + PgDown (Windows/Linux) or ⌘  + PgDown (Mac OS X).

 l From the top menu, select Selected > Arrange > Send to Back—Moves the selected art 
behind everything (bottom / back). Press Ctrl + Shift + PgDown (Windows/Linux) or ⌘  + Shift 
+ PgDown (Mac OS X).

 l Bring to Front  button

 l Bring Forward   button

 l Send Backward   button

 l Send to Back  button
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About Drawing Optimization 
As you work, you drawing can get complex and contain multiple strokes. You may want to optimize those 
drawings to reduce the number of brush strokes, pencil lines, and invisible strokes. You may also want to flatten 
your artwork or optimize your brush stroke textures.

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected 
drawing objects. Drawing objects will only be flattened and optimized if the selected objects do not change the 
appearance of the final image when they are merged. 

For example, if you have selected a number of partially transparent objects, which you layered to create an 
additive colour effect, the selected transparent drawing objects will not be merged. This is because merging the 
transparent drawing objects will cause them to lose the effect of the layered transparent colours. 

You could also want to add invisible contour strokes so that if you unpaint lines, the vector container remains to 
be repainted later.
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Flattening Drawings
The Flatten  operation is used to merge drawing objects and brush strokes into a single layer. If you draw new lines to 
fix a drawing or line with many brush strokes, it can be useful to flatten them all into a single shape. By default, lines 
are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it will be easier if they are 
flattened.  

How to flatten drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Drawing view, select the drawing strokes you want to flatten. 

 3. Select Drawing > Optimize > Flatten or press Alt + Shift + F. You can also press the Flatten  button in 
the Tool Properties view.
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Smoothing Drawings
The Smooth operation is used to reduce the number of contour points on a brush stroke and center points on a 
pencil line. It also smooths out the shape.  

The Smooth Fast option allows out to smooth out a drawing stroke at a faster rate than the regular smooth option.

How to smooth drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Drawing view, select the drawing strokes you want to smooth out. 

 3. Select Drawing > Optimize > Smooth or press Alt + Shift + S. You can also press the Smooth  button 
in the Tool Properties view.
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Creating Contour Strokes
The Create Contour Stroke  option is used to add a permanent invisible line around a shape that was drawn directly in 
Harmony. This allows you to unpaint your lines with the Paint  tool but maintain the shape of the lines, should you 
need to repaint later.

This command is useful when inking and painting and using the Apply to All Drawings in Layer  option.

How to create contour strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the  Drawing view, use the Select tool to select the drawing objects you want to create contour strokes for.

 3. From the top menu, select Selected > Create Contour Strokes.
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Removing Contour Strokes
The Remove Contour Stroke option is used to remove any permanently invisible lines that were created while 
scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove the 
intersection triangles created during vectorization.

How to remove contour strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the  Drawing view, use the Select tool to select the drawing objects you want to remove contour strokes 
for.

 3. From the top menu, select Selected > Remove Contour Strokes.
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Flattening and Removing Extra Strokes
The Flatten and Remove Extra Strokes option lets you flatten your drawing and remove the invisible lines in your 
selection.

How to remove extra strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the  Drawing view, use the Select tool to select the drawing objects from which you want to remove invis-
ible lines. 

 3. From the top menu, select Selected >Flatten and Remove Extra Strokes.
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Optimizing Drawings
You can use the Optimize feature to flatten your drawing strokes without changing the aspect of your drawings. 
This mainly means that transparencies will not be flattened. 

How to optimize a drawing

 1. In the Tools toolbar, select the Select tool.

 2. In the Drawing view, select the drawing strokes you want to optimize. 

 l From the top menu, select Selected > Optimize.
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Reducing the Drawing Texture Resolution

How to reduce the drawing texture resolution

 1. In the Tools toolbar, select the Select tool.

 2. In the  Drawing view, use the Select tool to select the drawing objects whose texture resolution you wan to 
reduce.

 3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.

 4. In the dialog box, drag the slider toward the left to reduce the texture resolution.

 5. Enable the Apply to All Drawings option if you want the modification to be applied to all the drawings in your 
layer.

 6. Click OK.
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About Strokes Conversion 
You may have drawing stroke using the Pencil tool when you wanted to use the Brush tool. You may also have 
drawing your image using the Polyline tool and now you want to convert your strokes to brush strokes. For many 
reasons, you may want to switch your stroke types to another type to use the various advantage set they offer.  

There are three types of strokes: 

 l Brush strokes (contour vector) 

 l Pencil strokes (central vector) 

 l Invisible strokes (central vector with a thickness value of 0)

Harmony lets you convert pencil lines to brush strokes, brush strokes to pencil lines, and invisible strokes 
(strokes) to pencil lines. 

You can also break text objects apart—see Breaking Text Apart on page 186.
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Converting Brush Strokes to Pencil Lines 
The Brushes Strokes to Pencil Lines  operation converts selected contour strokes into centreline pencil strokes. The 
brush stroke thickness will be lost.

How to convert brush strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l From the top menu, select Selected > Convert > Brush Strokes to Pencil Lines or press ̂ .

 l Right-click on the selection, select Convert >Brush Strokes to Pencil Lines or press ̂

205



Chapter 4: Drawing      About Strokes Conversion

Converting Pencil Lines to Brush Strokes
The Pencil Lines to Brush Strokes  operation converts the selected centreline pencil strokes into contour strokes 
brush lines.

How to convert pencil lines to brush strokes

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l From the top menu, select Selected > Convert > Pencil Lines to Brush Strokes or press 
&.

 l Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &. 

 l In the Tool Properties view, press the Pencil Lines to Brush Strokes  button.
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Converting Strokes to Pencil Lines
The Strokes to Pencil Lines  operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l Select Selected > Convert > Strokes to Pencil Lines or press Shift + F12 (Windows/Linux 
only).

 l Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12 
(Windows/Linux only)
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About OpenGL Antialiasing
Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. When you 
draw in the Drawing view, notice that your lines may appear jagged. This is caused by the fast real-time display 
called OpenGL.  If you prefer to see smooth lines as you draw, you can enable the antialiasing preference.

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias your 
drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on or off; by 
default, it is disabled. 

There is no need to modify your graphic card settings.

NOTE: Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be 
rendered to 100% of its resolution regardless of your preference settings or graphic card panel.
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Setting the Full Scene Antialiasing Preference
You can enable  the Full Scene Antialiasing preference to smooth out the OpenGL artwork.

NOTE: You must restart Harmony after you change the parameters.

How to customize the full scene antialiasing parameters

 1. Do one of the following:

 l Select Edit > Preferences (Windows/Linux) or Harmony Paint > Preferences (Mac OS X). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

 2. In the OpenGL tab, select the Enable option in the Full Scene Antialiasing section.

 3. Number or samples: Enter the number of samples you want to be used for the antialiasing process. The 
number of samples is basically equivalent to the amount of times a pixel will be enlarged to calculate the anti-
aliasing. This technique is called supersampling. The higher the number of samples, the better the anti-
aliasing quality will be, but the longer it will take to calculate.

 4. Restart Harmony.
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About the Tool Colour Swatches
While drawing and painting, you can let Harmony retain the last colour you selected for each one of the following 
tool types:

 l Brush

 l Paint 

 l Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint,   and Pencil   tools.

You can also link or unlink the colour swatch used between vector and bitmap layers.

210



Harmony 14 Paint - User Guide

Unlinking the Tool Colour Swatches 
You can unlink the tool colour swatches and use separated colours for the Brush, Paint, and pencil line tools. 

If you prefer to have Harmony use the same colour swatches regardless of the selected tool, you can link the three 
swatches together.

How to unlink the tool colour swatches

 1. In the Colour view, if the storage swatches are linked, click the Link   button to unlink them.

 2. Click on the Brush  storage swatch.

 3. In the Colour list, select the desired colour.

 4. Click the Pencil   storage swatch.

 5. In the Colour list, select a colour.

 6. Click the Paint   storage swatch.

 7. In the Colour list, select a colour.
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Linking the Tool Colour Swatches
You can link the tool colour swatches so all the tools use the same colour swatch.

How to link the storage swatches

 1. In the Tools toolbar, select one of the following tools:

 l  Brush

 l  Paint

 l  Pencil

 l  Polyline

 l  Line

 l  Ellipse

 l  Rectangle

 2. In the Colour view, if the storage swatches are unlinked, click the Link   button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.
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Using Independent Bitmap Colour Swatches
When working in the Colour view, by default the current colour is active for both vector and bitmap layers. You 
can however, use different reference colours for each layer. 

When using bitmap colours, there is no longer a link between the painted zones and selected colour. You can edit 
the colour  as much as you want, but your drawing will not be affected. You can still select colours from your 
vector colour palette to use the same tint, but you will not create links between your drawing and the swatches.

How to use independent colours

 l From the Colour view menu, select Colours > Independent Bitmap Colour.

Whichever colour you choose as the reference color is retained for that layer type.
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Chapter 5: Colours
Toon Boom Harmony has some very powerful painting features to add colour to your drawings. Whereas some other 
software only allow users to work with on colour swatch at a time, painting in Harmony is done by using palettes 
containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You can 
add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch 
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones. 
This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain using 
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene. Using 
palettes linked to your character in this way allows you to instantly change its colouring to suit the mood and 
atmosphere of the scene without tediously repainting each element.
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It is also possible to use colour swatches from palettes in bitmap drawings, although changing the colours in the 
palettes will not automatically update colours used in bitmap layers. Likewise, it is possible to create drawing 
layers with bitmap line art and vector colour art, all with the same palettes —see About Art Layers and Creating 
Colour Art from Line Art .
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About Colour Swatches
T-HFND-006-017

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap texture 
swatches.

A colour palette is an actual file on the hard drive. 

In Harmony Server, these palette files can be stored in a different location on the server. They can be stored in the 
Environment, Job, Scene, or Element folder and linked to any palette list. This means that if the original palette file is 
modified, it will update in every drawing element the palette is linked to. 

In Harmony Server, to avoid accidentally modifying the palette, the palette files can be locked. If a palette must be 
modified, you must get the rights to modify them before doing so.
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Locking and Unlocking the Colour List
In Harmony Server, you can lock and unlock the colour list to avoid modifying or modify the colour swatches.

How to lock and unlock the colour list 

 1. In the Colour view, click the Edit Palette Mode  button. 

A grey pencil icon appears in the top-right corner of the Palette list.
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Adding a Colour Swatch 
T-HFND-006-017A

You can add as many colour swatches as you want in your palette. 

How to add a solid colour swatch

 1. In the Colour view, click the Add Colour  button.

 2. From the Colour view menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens. 

 3. To set your colour, do one of the following:

 l In the colour wheel, select a colour.

 l Enter the HSV or RGB values in the corresponding fields.

 l Select the R,G,B,H,S or V options to change the look of the colour picking area.

 l Click the Dropper  button to select any colour on your screen. It can be from the Harmony 
interface, your operating system or any other open application. 
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You can also click Multi Wheel Mode to open the Multiwheel Colour window. This displays all the picking 
area styles together and also contains a picking undo list. To return to the regular Colour Picker window, 
click Single Wheel Mode.

 4. Click on the Shade Scale swatches to modify the shade of the selected colour. 

 5. Adjust the transparency with the Alpha slider or type the value directly in the Alpha field.
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 6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can quickly 
access it later.

 7. Rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking on its 
name.

How to add a new colour swatch using the default colour

 1. From the Colour view menu, select Colours > New. 

A new swatch is added to your palette using the default colour swatch colour. The new swatch created 
with the New  command will be named New 0.
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Deleting a Colour Swatch
T-ANIMPA-003-007

You can delete unnecessary colour swatches from your palette. If painted zones are using this colour, they will be 
displayed in red and the system will try to recover them the next time you load the scene. 

How to delete a colour swatch

 1. In the Colour view, select the colour swatches to delete.

 2. Do one of the following:

 l From the Colour View menu, select Colours > Delete.

 l Click the Delete Colour  button. 

 l Right-click and select Delete.

 l Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

 3. Click OK to delete the colours or click Cancel to abort the operation.

If you delete colour swatches already in use, the zones painted with them turn red so you can easily 
identify them.
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Adding a Gradient Colour Swatch 
T-HFND-006-017B

You can transform any colour swatch into a linear or radial gradient. 

How to create a gradient colour swatch

 1. In the Colour view, select a colour to modify .

 2. Do one of the following:

 l Click the new colour and from the Colour View  menu, select Colours > New. 

 l Double-click on the colour swatch.

The Colour Picker window opens.

 3. Select the Gradient option.

 4. Select the Linear or Radial option.

 5. Adjust the Gradient arrows to modify the colours.

 l Add extra colours by clicking between the arrows below the gradient bar. Then click on the 
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Colour Preview to select a colour.

 l Pull down the arrows to remove them.

 l Move the arrows left and right to modify the gradient distance.

NOTE: To learn how to reposition the gradient zones in your drawings, see About the Edit 
Gradient and Texture Tool on page 294.
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Adding a Texture Colour Swatch 
T-HFND-006-017C

You can add bitmap texture colour swatches to your palette. 

How to create a texture colour

 1. From the Colour  menu, select Colours > New Texture or click the New Texture  button.

The Browser window opens.

 2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.

NOTE: 
To learn how to reposition the textured zones in your drawings, see About the Edit Gradient and 
Texture Tool on page 294.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of 
plaid, just update the texture file in the swatch and the entire project updates. Any transformation previously 
applied to the texture’s position in your drawings will be kept.
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Modifying a Texture Colour Swatch
You can replace a texture colour swatch and all zones already painted with it will update.

How to replace a texture swatch

 1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

 2. From the Colour View  menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

 3. Browse for the new PSD or TGA bitmap file created in a third party software.

 4. Click Open to update the colour swatch.
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Mixing Colours
If you want to modify a series of colours to blend a tint in them or offset their RGBA values, you can use the Tint 
panel. You can also create palette styles, such as night and day styles.

How to mix colours

 1. In the Colour view, select the palette that contains the colours you want to offset or blend.

 2. Do one of the following:

 l From the Colour View menu, select Palettes > Tint Panel. 

 l Right-click and select Tint Panel.

The Tint Blend/Offset panel opens.

 3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A (Win-
dows/Linux) or ⌘  + A (Mac OS X).

 4. Select Preview option.

227



Chapter 5: Colours     About Colour Swatches

 5. Select the Offset, Blend, or Mixer option.

Parameter Description

Offset

Offsets the selected colours by the adjustments made using the 
HSB and RGB sliders. Use the Amount slider to adjust the 
degree of offset. Use the Alpha slider to adjust the opacity of the 
selected colour. 

Blend

Blends the selected colours with the colour swatch in the top-
right corner. Use the Amount slider to adjust the degree of blend. 
A blend of 100% turns the selected colours into the same colour 
as the swatch. Adjusting the HSB and RGB sliders affect the 
swatch colour, which in turn affects the selected colours on the 
left. Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use 
the slider just beneath to mix the Base and Tint colours by dif-
ferent amounts. This will affect the mixed swatch whether it is 
selected or not. Select either the Tint or Base swatch and use 
the HSB and RGB sliders to adjust its colour. This will affect the 
mixed swatch colour, which in turn affects the selected colours 
on the left.

 6. Click Apply.
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Protecting Colours
When you are finished inking one colour, you can lock it so if you ever paint over it accidentally, the work already 
done will not be affected. You can also use the Protect Colour feature to block the filling colours if you painted all of 
the animation in Line Art and you plan to repaint the lines.

When painting, the Respect Protected Colour option is enabled by default. In the Colour view, you can protect In the 
Colour view, you can protect a colour swatch to avoid repainting or unpainting the zones linked to that swatch. If you 
using the Paint tool and this option is deselected, you will repaint or unpaint the protected colours on your drawings 
until you enable the option again.

How to protect colours

 1. In the Colour view, select the colour to be protected.

 2. Do one of the following:

 l From the Colour view menu, select Colours > Protect Colour.

 l From the top menu, select Colours > Protect Colour.

A red bar appears beside the colour to indicate that it is locked.

How to enable the Respect Protected Colours option

 1. Do one of the following:

 l In the Paint tool properties, click the Respect Protected Colour button.

 l From the top menu, select Options > Colour Protection > Respect Colour Protection.

 l Press Shift + S.
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Copying and Pasting Colours 
When you're creating palettes, you may want to copy colour swatches or their values and paste them in other 
palettes to save time. You can also quickly copy a colour value from a palette in your scene to a selected colour 
swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, it is 
impossible to use the Paste as Clone command in the same palette as you copied the original colour swatch 
from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can copy the 
colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

How to copy and paste colours

 1. In the Colour view, select one or more colours to copy.

 l In the Colour view, click the Edit Palette Mode  button to edit the colour list. 

 2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS 
X).

 3. In the Palette list, select the palette in which you want to paste the colours.

 4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V (Windows/Linux) 
or ⌘  + V (Mac OS X).

 l To paste the colour values of the copied swatch over an existing colour swatch, select Col-
ours > Paste Colour Values.
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How to clone a colour swatch

 1. In the Colour view, select the colour swatch you want to clone.

 l In the Colour view, click the Edit Palette Mode  button to edit the colour list. 

 2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS 
X).

 3. In the Colour view, select the colour palette you want to paste the clone into or create a new palette.

 4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

 1. In the Colour view, select the colour swatch you want toget the ID from.

 l In the Colour view, click the Edit Palette Mode  button to edit the colour list. 

 2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X).

 3. Paste the copied value as plain text in the desired document.
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Changing the Colour Display Mode 
The Colour view has two display modes:

 l List

 l Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This 
option is not available when displaying the colours in Swatch mode.

How to switch between the display modes

 1. From the Colour View menu, and do one of the following: 

 l Select Colours > Swatch Mode to display the swatches.

 l Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

 l From the Colour View menu, select Palettes > Display Colour Values.   

The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The 
gradient colour swatches will be identified as (gradient). 
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About Palettes
T-ANIMPA-003-001

In animation, specific colours are used to paint each part of each character. In order to maintain absolute 
consistency, a colour palette is created for each character, prop and effect throughout the production. This is 
referred to as a master palette.

Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of red, 
green, blue and opacity, the latter which is referred to as alpha.

Using a master colour palette has many benefits, including:

 l Each character consistently retains their dedicated colours.

 l You cannot accidentally use a colour which is not in the master palette.

 l Standardization and colour consistency throughout the production

 l Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and 
consistency in the painting process. 

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette and 
add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue, shirt, 
pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a  *.plt file name 
extension. 

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch 
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones. 
This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain using 
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene. Using 
palettes linked to your character in this way allows you to instantly change its colouring to suit the mood and 
atmosphere of the scene without tediously repainting each element.
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In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is 
created from Harmony, it needs to be stored somewhere. By default, the palette file is stored in the scene 
directory in a palette-library folder unless you specify a different location.

There are four locations where you can find palette-library folders:

 l Element: The Palette Library folder is stored directly in the drawing Element folder.

 l Scene: The Palette Library folder is stored directly in the Scene folder.

 l Job: The Palette Library folder is stored in a Job folder contained in the Scene folder.

 l Environment: The Palette Library folder is stored in an Environment folder contained in the Scene folder.
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By default, the palette is stored at the scene level. For simple projects and standalone projects, it is recommended 
to keep it as is. If you work with a larger studio, it is recommended to verify with them on the file structure.

This existing structure is compatible with Harmony Server. Harmony’s database has a leveled structure starting 
from the Environment down to the Element. Its client-server configuration allows all data, such as palettes and 
scenes, to be shared between a series of client machines.

Element Level 
Working with Harmony Stand Alone, the Element level is very useful when there are a lot of different palettes. When 
a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette file with the 
colour model, the colourist can load them both from the same location. This also creates a more organized structure.

Scene Level 
Working with Harmony Stand Alone, a palette file can also be saved at the scene level, so that all of the palettes 
from the scene are stored together. The palette naming must be structured so the colourist or character builders can 
find the correct one. Saving the palettes at the scene level makes it very easy to back up the palettes and retrieve 
their location.

The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that includes all of 
the characters, props, effects, and location, the colour palette or model will often be directly imported to, or created 
in, the character building scene. Just as with a cut-out character building scene, each element uses the same 
palette so it would not be efficient to save the palette inside one element. Instead, it is saved at the scene level. This 
prevents a palette overload because all of the models are in different scenes. It also allows each scene to have its 
own set of palettes corresponding to its model.

When working on a cut-out animation production, it is highly recommended that you work with the Scene level.

Where to Save the Palette File
The palette storage location depends on the type of production and the backup plan being used. Some studios like to 
store their palettes at the Element level and others at the Environment level as this will not create a problem so long 
as the scene is in the Harmony structure. In fact, as long as the Harmony structure is maintained it can be stored at 
any level. However, difficulties may occur when the scene is backed up or transferred to another studio or database 
and removed from the structure.
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What happens when you export a palette file?
It is important to understand what is happening to a palette file when the scene is exported.

Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes in the 
database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing or 
Environment level. The palette files can be accessed from any scene of any project.

When you export scenes from Harmony to either archive or send them to other users or studios, the palettes 
stored in external scenes, jobs or environment will NOT be exported.

An exported scene will carry palettes stored in its own Element’s Palette Library, scene’s palette library, the Job 
and the Environment where it is stored. Any other palette from other Environments, Jobs, Elements or Scenes 
(even from the same job) will NOT follow. Instead a recovery palette will be created when the scene is reopened 
in another Harmony system. A recovery palette is a local palette created by the system when palettes and 
colours are missing. This palette is no longer shared with the rest of the project.

For example, in the following chart, if you export Scene 2 from Job 1, the package will carry the palettes from 
Scene 2, Job 1 and Environment. It WILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2. 
If Scene 2 was linked to any of these, the system will create a recovery palette the next time Scene 2 is opened in 
another Harmony system.

The best place to store your palette is:

• Environment level for a movie or series

• Job level for a publicity or small project
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• Scene level for a student exercise

To store your palette with their colour models, you can use the Element level, however, it will require more structure 
when exporting the scenes. The scene will have to be exported along with its colour model scene. The other studio 
you are working with must recreate an identical structure to yours, then import the received scenes into the same 
location as you have them in order to maintain the links.

Palette Backup
When sharing palettes between scenes, some users may accidentally modify the colours, even though the palettes 
are locked by default. That is why it is a good idea to copy and back up your palette libraries and master palette 
directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble replacing an 
altered file. Harmony automatically updates all of the files and drawings linked to it.
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About the Palette List
T-ANIMPA-003-006

The Colour view has two modes: basic and advanced.

 l Basic Mode

The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony, you only 
see the colours available in the Default palette which contains six basic colour swatches and is 
automatically named the same as your scene. For simple projects, you can manage with the default 
palette, but for movies, series, or shorts it is recommended that you create palettes for your characters. To 
create a palette, you have to switch to the Advanced mode of the Colour view and show the Palette list.

 l Advanced Mode

The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes for your 
characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a palette list. 
The scene also has a palette list.  For example, a drawing layer can use three different palettes stored in three 
different locations, while another drawing layer can use two of these palettes plus another one coming from 
another scene. The palette list keep track of the locations of the palettes.

There are two types of palette lists:

 l Scene Palette List 
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The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless and 
traditional animations. A cut-out character will often be divided into 20 to 30 different drawing elements that 
use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to 
this list will appear in every drawing element created in the scene. There is no need to manually load the 
palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only Scene 
Palette lists.

 l Element Palette List
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In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your palette 
at an element’s level. The Element Palette list is mainly used with traditional and paperless animation. 
Unlike cut-out animation, all columns (drawing elements) contain different characters, props, 
backgrounds, and effects. The Element Palette list is used when you do not necessarily want all of the 
palettes for all of your elements linked in every column. 

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This 
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a 
global palette list, link your palettes to the Scene Palette list.

When you are using several cloned palettes that are related to the same original palette, Toon Boom Harmony 
uses the palette located highest in the list to determine the colour of the painted zones—see Cloning a Colour 
Palette  on page 251.

How to reorder palettes in the Palette list

Do one of the following:

‣ From the Colour View menu, select Palettes > Move Up or Move Down. 

‣ In the Palette list, click the Up  and Down  buttons.
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Showing and Hiding the Palette List
You can show or hide the palette list in the Colour view. 

How to show or hide the Palette list

 l In the Colour view, click the Show/Hide Palette List View  button to expand or collapse the Palette List 
area.

The Palette List window opens and displays all your palettes.
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Locking and Unlocking the Palette List
To prevent users from accidentally removing a link to a palette, the palette lists are locked. To link or create a new 
palette, the palette list must first be unlocked. 

How to lock and unlock to the palette list

‣ From the top menu, select Edit > Edit Palette List Mode. 

A grey pencil appears on the top-right corner of the Palette list to indicate that it can be modified.
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Enabling the Advanced Palette Mode 
You can set up the Advanced Palette Lists option in the Preferences panel. This allows you to see the Element and 
Scene palette lists.

How to set the Advanced Palette Lists mode

 1. Do one of the following:

 l From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Paint > Prefer-
ences (Mac OS X).

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the General tab.

 3. In the Advanced OptionsColor Management section, select  the Advanced Palette Lists option.

 4. Click OK.
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Creating a Colour Palette
T-ANIMPA-003-002 

You can create a palette in either Basic or Advanced mode.

By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended to use the 
Basic mode.  This setting stores the palettes automatically for you and saves them at the Scene level. When you 
use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: 
Environment, Job, Scene, or Element.

If you are using Harmony Server, see About Palettes on page 233.

How to create a new palette (Basic Palette Lists mode)

 1. From the Colour view menu, select Palettes > New or click the New Palette button.

 l Make sure you have the rights to modify the palette list. If not, select  Edit > Edit Palette 
List Mode.

The Create Palette dialog box opens.

 2. Enter the palette name according to the model. 

 3. Click OK.

The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode

 1. In the Timeline or Xsheet view, select the drawing that requires a palette. 

 2. Make sure that you have the necessary rights to modify the palette list. If you do not, select  Edit > Edit 
Palette List Mode.

 3. In the Colour view, click the Show Palette List View  button to display the palette list. 
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 4. Do one of the following:

 l From the Colour view menu, select Palettes > New. Before you can create a palette in the 
Advanced Palette Lists mode, you must first set your preferences to Advanced Palette Lists 
mode in the Preferences dialog box—see Enabling the Advanced Palette Mode  on page 243.

 l Click the Create Palette  button. 

The Palette Browser: Create Palette dialog box opens. 

 5. Select the level to store the palette file. 
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 l Environment: The palette-library folder is stored in the scene's parent environment folder.

 l Job: The  palette-library folder is stored in the scene's parent job folder. 

 l Scene: The  palette-library folder is stored directly in the scene folder. 

 l Element: The  palette-library folder is stored directly in the drawing element folder. 

When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

 6. Name the palette. There is no need to add the suffix "palette" to the as it is always recognized as a palette 
file.

 

 7. Select a Palette List option.

 

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be 
divided in twenty to thirty different drawing elements that use the character's master palette. 

The palette list is stored at the scene level instead of the Element directory. This way, all palettes 
linked to this list will appear in every drawing element created in the scene. There is no need to 
manually load the palette in each element. 

The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out 
animation, all columns (drawing elements) contain different characters, props, backgrounds and 
effects. The Element Palette List is used because you do not necessarily want all of the palettes for 
all of your elements linked in every column. 
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The palette list is stored in the drawing element's directory instead of directly in the Scene level. This 
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a 
global palette list, link your palettes to the Scene Palette List.

 8. Click OK. 

The new palette appears in the palette list.
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Renaming a Colour Palette
T-ANIMPA-003-003

You can rename a colour palette to keep your list organized. 

How to rename a palette

 1. In the Colour view, select the palette to rename.

 2. Do one of the following:

 l Right-click and select Rename.

 l From the Colour View menu, select Palettes > Rename.

 3. In the Rename dialog box, give the palette a new name and click OK.
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Removing a Colour Palette
You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will not be 
deleted and you can reimport it in your Palette list later on.

How to remove a palette

 1. In the Colour view, select the palette to remove.

 2. Do one of the following:

 l From the Colour View menu, select Palettes > Remove. 

 l Right-click on the selected palette and select Remove.

 l Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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Duplicating a Colour Palette 
A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but has a 
different ID and is independent from the original palette. This ensures that both palettes are completely 
independent.
This option is used when there are similar models and you want to avoid recreating and naming all the colours. 
You can change the values and the names afterward without affecting the original palette. You can also keep 
some RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.

How to duplicate a palette 

 1. In the Colour view, select the palette to be duplicated.

 2. Do one of the following:

 l From the Colour menu, select Palettes > Duplicate. 

 l Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.

 3. If you are in Advanced Palette List mode, select the palette storage level—see About Palettes on page 233.

 4. In the New Palette Name field, name the palette.

 5. In the New Palette Name field, name the palette.

 6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette 
A character usually has only one master palette, although there are times when the characters are placed in different 
lighting conditions and require a different colour shading. The night palette is a popular choice when a scene or 
sequence changes from day to night. It can be difficult and time-consuming to repaint everything and creating two 
independent palettes can be quite complex. As an alternative, Toon Boom Harmony provides clone palettes.

The clone palette is a copy of the master palette. The colours in each palette have the same properties. The colours 
have the same identification number pointing to the same colour zones, but they can have different names and 
RGBA values. Depending on the palette (night or day) you're currently using, the painted drawing will update. So 
there's no need to repaint the animation. All you have to do is create or import a clone palette (palette style).

How to clone a palette

 1. In the Colour view, select a palette to clone.

 2. From the Colour  menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.
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 3. If you're in Advanced Palette List mode, select the palette storage level—see About Palettes on page 233.
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 4. In the New Palette Name field, name the palette. We recommend keeping the "-clone" in the name.

 5. Click OK.

The cloned palette appears in the palette list.

 6. In the Palette list, select the clone palette you created to offset or blend colours—see Mixing Colours on page 
227.

 7. From the Colour View  menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.

 8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A (Windows/Linux) or 
⌘  + A (Mac OS X).

 9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

253



Chapter 5: Colours     About Palettes

 10. Select the Preview option to see a preview of the colours while you adjust them.

NOTE: You can also modify the colours individually with the Colour Picker window.

 

254



Harmony 14 Paint - User Guide

About Linking and Importing Palettes
Before you start colouring work such as ink and paint or even creating new colour models, you may want to load 
existing colour palettes to your scene. You can do so by importing colour palettes to your palette list, or by linking 
them to your palette list.

Importing a colour palette creates a copy of the palette file in your scene's palette folder, then adds it to your scene's 
palette list. Linking to a palette adds the palette to your scene's palette list, but from its original location. With the 
latter method, you can source the colors for your characters and backgrounds from their original model, and make 
modifications on your models that will apply to all your scenes.

On Harmony Server, you can link to a palette file from any scene, job or environment in your database. As a result, 
you can link to a palette from the scene in which you created your character and its original palette, or you can store 
the palettes used by your production at the job or environment level so they can be shared between scenes from a 
common palette library.

If you are storing palettes in element palette lists, you can link a palette from one element's palette list to another 
element's palette list. This allows you to share palette files between  two or more elements without storing them in 
the scene's palette list.

If a palette file is missing, it will still appear in the palette list for that scene or element, with a strike through across 
its name. If you preformed the automatic colour recovery for that palette, when the scene was opened, the colours of 
that palette will be made available in your scene.

The palette list displays icons next to each palette to indicate how it is linked to in the palette list.

Icon Description

Indicates that the palette is safe.

There won’t be any problems once the scene is exported. For example, the palette file is stored 
in the scene folder and is linked to the Scene Palette List. 

Indicates that the palette file is stored in a directory external to the scene’s structure.

The palette file is probably stored in a Master Palette directory on a hard drive external to the 
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palette-libraries planned for the palette storage. The warning in this case is that if you move your 
Master Palette directory to another location, you may loose the palette in your scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is 
linked to a Palette list that is not on the same level. 

For example, a palette file is stored into the Environment folder and is linked to the Element 
Palette list. The palette is shared.

Indicates a potentially dangerous situation.

Problems may occur when trying to export or link to the palette file. For example, a palette file is 
stored into the element folder and is linked to the Scene Palette list. The issue in this case is 
that if you decide to delete the layer containing the palette, it will be lost from your scene.
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Importing a Colour Palette
T-ANIMPA-003-005

You can import an existing colour palette in your project. 

How to import a palette into your project

 1. Do one of the following:

 l From the Colour menu, select Palettes > Import. 

 l Right-click and select Import.

The Browser window opens.

 2. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in your pro-
ject's palette-library directory.

 3. Click Open.

The Palette Browser opens. 
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 4. If you're in Advanced Palette mode, select the level where the palette file is stored—see About Palettes on 
page 233.

 5. If you're in Advanced Palette mode, select the palette list linking level by enabling either Scene Palette 
List or Element Palette List—see About Palettes on page 233.

 6. In the New Palette Name, name the imported palette.

The palette appears in the Colour view and the file is copied in your project.
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Linking a Colour Palette
T-ANIMPA-003-004

You can link a palette from its original location as long as it is located in the Harmony structure. 

How to link a colour palette

 1. Do one of the following:

 l From the Colour View menu, select Palettes > Link. 

 l Right-click and select Link.

 l Click the Import  button.

The Palette Browser: Link Palette dialog box opens.
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 2. Select the level where the palette file is stored—see About Palettes on page 233.

 3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—see 
About the Palette List on page 238.

The palette appears in the Colour view.
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Palette Operations
When you start Toon Boom Harmony connected to the database, you can access the Palette Operations dialog box 
which lets you clone, rename, or delete palettes. 
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Opening the Palette Operations Dialog Box
You can open the Palette Operations dialog box in Harmony Server.

How to open the Palette Operations dialog box

 1. Start Paint and log in. 

 2. Close the Database Selector dialog box. 

 3. From the top menu, select Tools > Palette Operations. 

The Palette Operations dialog box opens. 
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Cloning a Palette in the Palette Operations Dialog Box
From the Palette Operations window, you can clone palettes in Harmony Server.  

How to clone a palette in the Palette Operations dialog box 

 1. Select the palette you want to clone at the location and level in which it was stored. 

 2. Click Clone. 

A Warning dialog box opens. 

 

 3. Select the Don't show this message again option if you do not want to see this message every time you per-
form this operation.

 4. Click Yes.

The Palette Browser dialog box opens. 

 5. Select the level to store the palette file.
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 6. Name the palette. There is no need to add the suffix "palette"  to the name as it is always recognized as a 
palette file.

 

 7. Select a Palette List option.

 

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be 
divided in twenty to thirty different drawing elements that use the character's master palette. 

The palette list is stored at the scene level instead of the Element directory. This way, all palettes 
linked to this list will appear in every drawing element created in the scene. There is no need to 
manually load the palette in each element. 

The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out 
animation, all columns (drawing elements) contain different characters, props, backgrounds and 
effects. The Element Palette List is used because you do not necessarily want all of the palettes for 
all of your elements linked in every column. 

The palette list is stored in the drawing element's directory instead of directly in the Scene level. 
This ensures that the links to the palettes appear only in the appropriate element. If you prefer to 
access a global palette list, link your palettes to the Scene Palette List.

 8. Click OK.
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Renaming a Palette in the Palette Operations Dialog Box
You can rename palettes in the Palette Operations dialog box in Harmony Server.

How to rename a palette in the Palette Operation dialog box

 1. Select the palette you want to rename at the location and level in which it was stored. 

 2. Click Rename.

A Warning dialog box opens. 

 3. Select the Don't show this message again option if you do not want to see this message every time you per-
form this operation.

 4. Click Yes.

The Rename Palette dialog box opens. 

 

 5. Type in a name for the palette. 

 6. Click OK. 
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Deleting a Palette in the Palette Operations Dialog Box
You can delete palette files from the Palette Operations dialog box in Harmony Server. 

How to delete a palette in the Palette Operation dialog box

 1. Select the palette you want to delete at the location and level in which it was stored. 

 2. Click Delete. 

A Warning dialog box opens. 
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 3. Select the Don't show this message again option if you do not want to see this message every time you per-
form this operation.

NOTE: It is not recommended to disable the warning message as deleting a palette cannot be 
undone. 

 4. Click Yes.
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About Painting
Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-based, the 
colour zones are completely filled and there are no scattered spots left blank. Also, there are some actions that 
can be applied on an entire animation sequence at once, like dirt removal, some colour filling, line repainting, and 
so on.

When traditional animation is traced, cleaned up, scanned in and properly exposed, it's time for the ink and paint 
process. This consists of cleaning all dirt and hair (for example, dust that was in the scanner, dots that do not 
belong in the drawing, extra floating artwork around the drawing that must be removed), painting the lines and 
filling the colours in the empty zones on an entire animation sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt to clean, 
only painting and inking. 

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by assigning a 
set of colours to each character, prop or effect. The colour styling artist will create a new palette and add a new 
colour for each zone of the character, such as the skin, hair, tongue, shirt, pants, and so on. Each colour is known 
as a colour swatch—see About Palettes on page 233. 
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About Colour Models
Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. That drawing 
can be used and loaded in any of your Harmony scenes—see Painting Drawings on page 279. 

 

Once a drawing is loaded in the Model view, you can use the Model view Dropper to select a colour from the model 
and use it to paint in your Drawing view without having to pick the colour from the colour palette.

You can do more than just copy colours from a colour model. Harmony gives you the ability to copy parts of the 
character directly from its colour model and paste these elements into the Drawing view.
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Loading Colour Models
T-ANIMPA-004-005

You can load any TVG drawings in your Model view. To avoid browsing for models every single time you work on 
your scene, you can store default models in your scene and load those. 

How to browse for a colour model drawing on your hard drive

 1. Do one of the following: 

 l Right-click in the Model View and select Import Model.

 2. In the Browser window, browse for any *.tvg drawing file on your hard drive or in the database for Harmony 
Server.

 3. Click Open. 

The model appears in the Model view.

How to load the default models

 1. In your scene’s folder, create a new folder and name it models.

 2. On your hard drive, copy the *.tvg drawing file you want to use as colour models in your scene.

 3. Paste the copied models in the models folder you created.

 4. Do one of the following:

 l Right-click in the Model View and select Load Default Models.
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Clearing Colour Models
You can remove colour models from the Model view. 

How to clear a colour model

 l Right-click in the Model view, select Clear Model or press Delete.
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Copying Colour Models
You can copy pieces or the entire colour model to paste in your scene, 

How to copy the entire model from the Model view

 1. Right-click and select the Select  tool.

 2. In the Model view, select your model.

 3.  Press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

 4. Select the Drawing view, then go to the top menu and select Edit > Paste Drawing Objector pressCtrl + 
V (Windows/Linux) or ⌘  + V (Mac OS X). 

The model appears in the selected view.

How to copy part of the model from the Model view

 1. Right-click in the Model view and select Cutter Selection or press Alt + T.

 2. In the Model view, use the Cutter tool to create a selection around the part of your model that you want to 
copy.
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 3. PressCtrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Do one of the following:

 l Select the Drawing view and select Edit > Paste Drawing Object. 

The model appears in the selected view.
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About Dirt Cleanup
When paper drawings are passed through a scanner, there can be some hair and dirt scattered across them. 
These lines and dots need to be cleaned. Harmony provides different tools to help get rid of them quickly.

If there are some marks that cannot be removed with the automated tools, you can erase them with the Eraser 
tool or select them with the Select tool and then delete them. It's always safer to select and delete them than to 
erase them, so you do not overlook anything.
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Removing Dirt
The Remove Dirt tool selects small dots and hairs on the drawing.

Raising the Remove Dirt level will select bigger dots. When selecting larger dots, be careful not to lose small details 
like pupils and nostrils. Once you have chosen the level, you can apply it to the current drawing or the entire 
animation sequence. This is a quick way to get rid of most dirt and dust.

During this process, the dirt that will be removed is highlighted in red.

How to use the Remove Dirt tool

 1. Do one of the following:

 l From the top menu, select Drawing > Remove Dirt.

 l Press Shift + D.

 2. Increase the Remove Dirt value by moving the slider to the right.

 3. Select the Apply to All Drawings option if you want to apply the operation to all drawings in the layer.
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Removing Dirt Outside the Selection
The Remove Art Outside Selection option lets you remove any art existing outside a selection. It is recommended 
that you clean your Colour Art level as well. If you have a stroke accumulation in your Colour Art, it can result in 
large output files, especially if you work in high-definition resolutions.

How to clean dirt with Remove Art Outside Selection

 1. In the Tools toolbar, select the  Select  tool.

 2. From the top menu, select Options > Permanent Selection.

 3. Draw a selection around the animation making sure to include the entire animation sequence.

 4. From the top menu, select Selected one of the following options:

 l Remove Art Outside Selection to delete artwork outside your selection on a single draw-
ing.

 l Remove Art Outside Selection on All Drawings to delete artwork outside your selection 
on all the drawings.

The art outside the selection is removed.
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Removing the Art Inside the Selection
You can delete any art inside a selection with the Remove Art Inside Selection option. We recommend that you 
clean your Colour Art level as well. If you have a stroke accumulation in your Colour Art, it can result in large output 
files, especially if you work in high definition resolutions.

You can simultaneously apply this operation to all your drawings in the layer by using the Remove Art Inside 
Selection on All Drawings command.

How to clean dirt with Remove Art Inside Selection

 1. In the Tools toolbar, click the Select tool or press Alt + S.

 2. To apply the action to your entire animation, select Options > Permanent Selection.

 3. In the Drawing view, draw a selection around the animation. Make sure the area is large enough to include all 
the zones to be cleaned up on all drawings.

 4. From the top menu, select Selected > Remove Art Inside Selection to delete artwork inside your selection 
on one single drawing. You can also press Delete.

 5. To apply the action on all your drawings in the layer, select Selected > Remove Art Inside Selection on All 
Drawings to delete artwork inside your selection on all the drawings.
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Removing Hair
The Remove Hair command lets you remove any small strokes created in the Colour Art layer from very thick 
lines or filled zones. Increasing the Remove Hair level value will select larger strokes for removal from the 
drawing.

How to use the Remove Hair tool

 1. Select the drawing containing the drawing to clean.

 2. From the top menu, select View > Show Strokes to display the invisible lines or press K.

 3. In the top menu, select Drawing > Remove Hair.

The Remove Hair dialog box opens.

 4. Move the slider to the right to increase the number and length of hairs to be selected. 

 5. Select the Apply to All Drawings option if you want to apply the operation to all the drawings in the layer.

 6. Click OK.
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Painting Drawings
T-HFND-004-011

The main tool you will use to paint your drawings with is the Paint  tool. The Paint tool can be used in several different 
modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the lines defining a 
zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic Close Gap option.

NOTE: To learn more about the Paint tool options, see the Reference guide .

How to paint drawings

 1. Select the drawing on which you want to paint.

 2. Do one of the following:

 l In the Tools toolbar, click the Paint  tool.

 l From the top menu, select Tools > Paint or press Alt + I..

 l Press Alt + I. 

In the Tool Properties view or Tools toolbar, you can select additional painting modes. 

 l The Paint   mode paints everything it touches, including empty and filled zones.

 

 l The Paint Unpainted  mode paints only empty zones. Any line or filled zone will remain 
unchanged.

279



Chapter 5: Colours     About Painting

 l The Repaint   mode paints everything it touches except empty zones. Any zone that is 
not painted will remain intact.

 l The Unpaint   mode unpaints everything it touches, including empty and filled zones.

 3. In the Colour view, select a colour.

 4. In the  Drawing  view, start painting. Click on a zone or pencil line to paint it, or trace a lasso or marquee 
selection to paint several zones or pencil lines at the same time.

NOTE: The last colour you select while using the Paint tool will be used the next time you 
select the Paint tool if you're using the unlocked painting tools in the Colour view.
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Repainting
You can use the Paint tool to click on the zones to repaint. If you click in an empty zone, it will fill the area.  

You can repaint lines, zones, and brush strokes using the Repaint tool. The repaint pencil lines more efficiently, 
see Inking Lines on page 291. The Repaint tool does not fill empty zones, even if they are closed.

If you imported and vectorized drawings, during the vectorization process on traditional scanned drawings, 
triangles are added on the lines' intersections to break the artwork in segments. This way, when you paint a line, it 
will not repaint the entire drawing, only the relevant segment—see Creating Break Triangles.

 

The Brush tool can be used to repaint specific segments. The Brush tool's Repaint Brush mode is used to paint a 
section by manually painting over the lines. This is useful when the vectorization triangles are not placed as you 
would like or you simply need to repaint a section of a segment. It is also useful for paperless animation, where 
there are no triangles. So, the Repaint Brush is used to paint a certain area. It acts like the Brush tool, but will only 
show on painted areas that are already painted. 

Unlike the Brush tool's regular mode, the Repaint Brush mode flattens automatically. The brush strokes are not 
added one on top of each other. 

NOTE: To avoid repainting specific colours, see Protecting Colours

How to access the Repaint Tool

 1. In the Tools toolbar, select the Repaint  tool. You can also find the option in the Tool Properties view 
when the Paint tool is selected. 

 2. In the Drawing view, click on the zones to repaint. You can also make a lasso or marquee selection around 
several zones.

How to enable the Repaint Brush mode

 1. In the Tools toolbar, select the Brush  tool.

 2. In the Tool Properties view, click the Repaint Brush  button. 

 3. In the Drawing view, draw on the zones to repaint.

282



Harmony 14 Paint - User Guide

Repainting a Selection
The Repaint Selection command is used to repaint any art inside a selection. You must first draw a selection using 
the Select  tool in order for this command to be available. You can also click on the colour swatch in the colour palette 
to automatically repaint your selection.

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the drawings 
contained within the same layer. You must enable the Permanent Selection  option in the Select tool Tool Properties 
view and then select an area of your drawing using the Select  tool in order for this command to be available. The 
Permanent Selection option lets you maintain the same selection throughout the drawings of a same layer.

NOTE: To avoid repainting specific colours, see Protecting Colours

How to repaint a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the zones to repaint. 
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 3. To repaint the selection on all drawings,  enable the Permanent Selection  option in the Select tool Tool 
Properties view. 

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Repaint 
Selection or Repaint Selection on All Drawings.

 l From the top menu, select Selected > Paint > Repaint Selection or Repaint Selection on 
All Drawings.
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Repainting Outside a Selection
The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection has been 
drawn using the Select   tool, the entire drawing will be repainted.

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection on all the 
drawings contained within the same layer. You must enable the Permanent Selection  option in the Select tool Tool 
Properties view and then select an area of your drawing using the Select  tool in order for this command to be 
available. The Permanent Selection option lets you maintain the same selection throughout the drawings of a same 
layer.

NOTE: To avoid repainting specific colours, see Protecting Colours

How to repaint outside a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the zones you do not want to repaint. 

 3. To repaint outside the selection on all drawings,  enable the Permanent Selection  option in the Select tool 
Tool Properties view. 

 4. Do one of the following: 
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 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Repaint Out-
side Selection or Repaint Outside Selection on All Drawings.

 l From the top menu, select Selected > Paint > Repaint Outside Selection or Repaint Out-
side Selection on All Drawings.
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Unpainting a Selection
The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first draw a 
selection using the Select  tool in order for this command to be available.

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection on all the 
drawings within the same layer. 

You must enable the Permanent Selection  option in the Select tool Tool Properties view and then select an area of 
your drawing using the Select  tool in order for this command to be available. The Permanent Selection option lets 
you maintain the same selection throughout the drawings of a same layer.

How to unpaint a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the zones to unpaint. 

 3. To unpaint the selection on all drawings,  enable the Permanent Selection  option in the Select tool Tool 
Properties view. 

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Unpaint Selec-
tion or Unpaint Selection on All Drawings.

 l From the top menu, select Selected > Paint > Unpaint Selection or Unpaint Selection on 
All Drawings.
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Unpainting Outside a Selection
The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no selection 
have been drawn using the Select  tool, the entire drawing will be unpainted.

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection on all the 
drawings within the same layer. You must enable the Permanent Selection  option in the Select tool Tool 
Properties view and then select an area of your drawing using the Select  tool in order for this command to be 
available. The Permanent Selection option lets you maintain the same selection throughout the drawings of a 
same layer.

How to unpaint outside a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the zones you don't want to unpaint. 

 3. To unpaint the selection on all drawings,  enable the Permanent Selection  option in the Select tool Tool 
Properties view. 

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Unpaint 
Selection or Unpaint Selection on All Drawings.

 l From the top menu, select Selected > Paint > Unpaint Selection or Unpaint Selection on 
All Drawings.
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Closing Gaps
T-HFND-004-014

When painting, you may notice that some drawing areas are not closed. To close the zone, you can draw the 
missing line with the Brush or Pencil tool, or close the gap with an invisible line using the Close Gap tool.

The Close Gap tool lets you close small gaps in a drawing by creating small, invisible strokes between the two 
closest points to close the colour zone. You do not need to trace directly over the gap. You can draw it a few 
millimeters away. The two closest points automatically close the gap.

How to close gaps

 1. Select View >Show Strokes or press K to see a preview of the result.

 2. In the Tools toolbar, select the Close Gaps  tool.

 3. In the Drawing view, trace a line near the gap to be closed. Your strokes will be invisible. 

 4. Enable the Auto-Flatten  option in the Tool Properties view if you want your strokes to be flattened with 
your artwork. They will cut overlapping drawing strokes in two pieces.

The gap automatically closes.
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Picking a Colour with the Dropper Tool
While working in the Drawing view, you can use the Dropper  tool to pick a colour from your drawing without going 
to the Colour view. 

NOTE: To learn more about the Dropper tool options, see the Reference guide .

How to use the Dropper tool

 1. Do one of the following:

 l In the Tools toolbar, select the Dropper  tool.

 l From the top menu, select Tools > Dropper.

 l Press Alt + D. 

 2. In the Drawing view, click on the desired colour.

 l If you're using another drawing tool such as the Paint tool, you can temporarily hold down 
the D key and click in your drawing before releasing the key to pick your colour. When you 
release the key,  you will return to your previous tool. You may also want to select the zones 
painted with the colour currently selected in the Colour view. This can be useful for removing 
rough lines from a clean drawing.
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Inking Lines
T-HFND-004-012

Although pencil lines can be painted in much the same way as closed zones, you can use the Paint, Repaint, 
Repaint Brush, and Ink tools to make painting segmented lines easier. Normally when you have a drawing, such as 
the one below, and you use the Paint tool to paint one of the lines, the entire line is painted.

However, if you select the Ink  tool instead and click on the same pencil line, only the segment that you clicked on 
between two intersections will be painted.

Painting and inking can be used in combination depending on what you need to paint. If you need to ink a character’s 
outline in black, it might be easier to use the Paint tool. If you need to paint the outline of a character’s neck with a 
tan colour and its shirt outline blue and both the neck and shirt belong to the same continuous outline, then the Ink 
tool might prove more useful.

NOTE: Unless you are repainting all the lines in an entire animation sequence, do not use the Apply Tool to All 
Drawings option. Since the line positions change a lot over time, you risk painting lines that should not be 
painted.

NOTE: To avoid repainting specific colours, see Protecting Colours

NOTE: To learn more about the Ink tool options, see the Reference guide .

How to use the Ink tool

 1. In the Tools toolbar, select the Ink  tool located in the Paint tool drop-down menu.  
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 2. In the Drawing view, click on the pencil lines to repaint.

 l The newly inked segment is always moved on top of all other pencil strokes, even if it was 
behind all other pencil strokes before it was inked. To reverse that behaviour, disable the 
Raise  option in the Tool Properties view.

 l Hold down Alt while clicking a segment to do the opposite option from the Raise mode cur-
rent state.  The inked segment will be sent to the back or forward, even if it was in front or 
behind all other segments to begin with.
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Verifying Painted Zones
When the ink and paint process is completed, it's always a good idea to verify that every zone was painted properly.

The backlight produces Produces a silhouette effect by changing the drawing’s coloured areas into a single dark, 
solid colour. Use this to verify the completeness of the ink and paint process. Any unpainted zones can be seen as 
the light shows through the unpainted areas of the silhouetted drawing.

How to use the backlight

NOTE: This feature is only available in the Drawing view.

 1. Do one of the following:

 l From  the top menu, select View > Backlight.

 l From the Tools toolbar, click the Backlight button.

 l Press Alt + Shift + B. 

 2. Verify the drawings in the Colour Art to make sure that all the areas are painted. In the Colour view, click the 
Colour Art  button.

 3. In the Colour view, click the Preview  button  to see the colour zones with lines to ensure that you did not 
forget any spots between the colour filling and lines.
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About the Edit Gradient and Texture Tool
T-HFND-006-019

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its 
position in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set 
the first texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you can 
select the next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if you want the Brush and Paint tool to use your gradient’s position, 
angle and scale settings instead of the default ones, you can store your own settings and reuse them afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with textured 
“brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both elements 
independently at the same time.

How to use Pencil Editor tool to edit the texture or gradient on a pencil line

 1. Do one of the following:

 l In the Tools toolbar, select the Pencil Editor  tool. 

 2. Click on the pencil line to be modified to bring up its contour envelope.

 3. Select one of the contour points around the envelope and move its position to change the size of the tiled 
texture or gradient. You can also pull directly on the lines of the contour envelope or play with the Bezier 
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handles of any given point in order to continue to modify the envelope form.

Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled texture to be 
stretched. Conversely, reducing the envelope’s width will cause the tiled texture to look squashed.

Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the number of tiles, 
while expanding it will increase the number of tiled images. 

This editing technique does not just work on texture fills, but can also be applied to pencil lines drawn with a 
textured “brush”.

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line

 1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, select Tools > Edit Gradient/Texture. 

‣ Press Shift + F3.

 2. Click on the pencil line to be modified to bring up the editor controls.
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 3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull on the top 
of the editor controls to stretch the tiled texture throughout the length of the stroke. 

As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is 
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or gradient.

 

 4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central vector 
line. This is another way to resize the texture tile. Instead of stretching or shrinking it vertically, this motion 
stretches or shrinks it vertically. As gradients are parallel to the pencil line’s central vector, stretching them 
vertically gives no visual result.

How to use Edit Gradient/Texture tool to edit the texture and gradient of a pencil line

 1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, select Tools > Edit Gradient/Texture. 

‣ Press Shift + F3.

 2. Click on the pencil line to be modified to bring up the editor controls.

296



Harmony 14 Paint - User Guide

 3. Use the top editor controls edit the gradient.

 4. Use the bottom controls edit the “brush” texture.
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Using the Edit Gradient and Texture Tool 
T-HFND-006-019A

You can use the Edit Gradient/Texture tool to reposition a texture or gradient within a painted zone. 

How to use Edit Gradient/Texture tool

 1. Do one of the following: 

 l In the Tools toolbar, click the Edit Texture  tool.

 l From the top menu, select Tools > Edit Gradient/Texture.

 l Press Shift + F3.

 2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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 3. Edit the gradient or texture by adjusting the control handles around the selection frame.
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Storing the Gradient and Texture Settings
You can store the position, scale, and angle of a given gradient or texture painted zone to reuse on other ones as 
you paint them. 

How to store gradient and texture settings

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Camera or Drawing view, select the gradient or texture zone to store.

 3. In the Tool Properties view, click the Store Colour Gradient  button.
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Using the Stored Gradient and Texture Settings
You can use the gradient and texture settings previously stored to paint zones using those exact parameters. 

How to use the stored gradient and texture settings

 1. In the Tools toolbar, select the Brush  or Paint  tool.

 2. In the Tool Properties view, click the Use Stored Colour Gradient  button.

 3. In the Camera or Drawing view, draw and paint.
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