Toon Boom
Harmony 16.0

Play User Guide

Toon Boom

Bring Your Stories To Life

TOON BOOM ANIMATION INC.

+1 514 278 8666
4200 Saint-Laurent, Suite 1020 contact@toonboom.com
Montreal, Quebec, Canada

toonboom.com
H2W 2R2




Harmony 16.0 Play User Guide

Legal Notices

Toon Boom Animation Inc.
4200 Saint-Laurent, Suite 1020
Montreal, Quebec, Canada
H2W 2R2

Tel: +1 514 278 8666
Fax:+1 514278 2666

toonboom.com

Disclaimer

The content of this document is the property of Toon Boom Animation Inc. and is copyrighted. Any
reproduction in whole or in part is strictly prohibited.

The content of this document is covered by a specific limited warranty and exclusions and limit of liability under
the applicable License Agreement as supplemented by the special terms and conditions for Adobe®Flash® File
Format (SWF). For details, refer to the License Agreement and to those special terms and conditions.

Trademarks

Toon Boom® is a registered trademark. Harmony™ and the Toon Boom logo are trademarks of Toon Boom
Animation Inc. All other trademarks of the property of their respective owners.

Publication Date

01-15-2020

Copyright © 2020 Toon Boom Animation Inc., a Corus Entertainment Inc. company. All rights reserved.


http://www.toonboom.com/

Table of Contents

Table of Contents

Table of Contents . 2
About the Play Application .. .. 4
Chapter 1: Launching the Play Application ... 6
Chapter 2: User Interface .. 8
O MENU L 9
Playback Toolbar il 13
Chapter 3: Loading Image SeqUeNCes . ... ... ... . 16
Loading Image Sequences from Folders ... . L 17
Loading Image Sequences from Databases .. ... ... L 19



Harmony 16.0 Play User Guide




About the Play Application

About the Play Application

The Play module is designed specifically for playing back and viewing animated projects once they have been

rendered out into image sequences.

This module opens directly from your program menu to load your final render. It's also used when playing back a
scene with effects in Harmony.
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Chapter 1: Launching the Play Application

Chapter 1: Launching the Play Application

To use Toon Boom Play, you must start the program. You can run the software on macOS or Windows/Linux
operating systems. You can start Toon Boom Play from within Harmony to play back your scene, and see the

effects and final images.

How to launch the Play Module

1. Doone of the following:

In Harmony, select Play > Render and Play or in the Playback toolbar, click the Render
and Play ® button.

Windows: Start > Programs > Harmony 16.0(Edition] > Play
macOS: Applications > Toon Boom Harmony 16.0[Edition] > Play

GNUY/Linux: /usr/local/ToonBoomAnimation/harmony_12/Inx86_64/bin/Play
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Chapter 2: User Interface

Chapter 2: User Interface

The Play Module interface is composed of two main components.

Top Menu
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Top Menu

In the top menu are all the necessary commands for loading and previewing image sequences.

File Menu

Command

Action

Access Methods

Load From Folder

Opens the Find Directory
window where you can select
one or more images to load in
the player.

File > Load from Folder

Load From Database

If you are connected to the
Database, this command
opens the Database Selector
window where you can select
an image sequence to load in
the player.

File > Load from Database

Reload Frames

Opens the Load Playback
dialog box and indicates
which frames are loaded. You
can select the frames you
want to reload. Use the
Reload command to load
frames that are currently open
in the player and that were
modified since they were
loaded.

File > Reload Frames

Unload Frames

Opens the Unload Playback
dialog box and indicates
which frames are loaded. You
can select the frames you
want to unload.

File > Unload Frames

Quit Play

Exits the application.

macOS: macOS Play > Quit Play.

Windows/Linux: File > Quit.
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View Menu

Command

Action

Access Methods

Zoom In

Zooms in on the loaded images
to view them closer. In the
lower-right corner of the
interface, you can see the
relative zoom level compared to
the image’s original resolution.

View > Zoom In

Press Ctrl + =.

Zoom Out

Zooms out of the loaded
images to view them smaller. In
the lower-right corner of the
interface, you can see the
relative zoom level compared to
the image’s original resolution.

View > Zoom Out

Press Ctrl + =.

Image

Displays the images in normal
mode with all their colours.

View > Image

Matte

Displays the image’s matte
(alpha channel). All transparent
zones are displayed in black
and all fully opaque zones are
displayed in white. Zones that
are semitransparent are
displayed in grey.

View > Matte

Loaded Files Properties

Opens the Loaded Files
Properties dialog box. Displays
the format, path and resolution
information of each loaded
image.

View > Loaded Files Properties

Play Menu

Command

Action

Access Methods

Play Scene Forward

Plays the animation from the
current frame to the last frame.

Play > Play Scene Forward

Play Forward ® button

10
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Command

Action

Access Methods

Play Scene Backward

Plays the animation from the
current frame to the first
frame.

Play > Play Scene Backward

Play Backward € button

Stop Frame dialog box.

Play > Stop
Stop Stops playback.
Stop @ button
Repeats the scene when it Play > Loop
Loop reaches the last frame during
playback. Loop© button
Controls the starting frame of Play > Start Frame
Start Frame the playback range. Opens the In the Playback toolbar, enter
Set Start Frame dialog box. values in the Start field.
Controls the end frame of the Play > Stop Frame
Stop Frame playback range. Opens the Set

In the Playback toolbar, enter
values in the Stop field.

Go to Frame

Sets your current frame to any
frame you input in the Go to
Frame dialog box.

Play > Go to Frame

Playback Speed

Changes the frame rate of the
playback. Opens the Set Speed
dialog box.

Play > Playback Speed

First Frame

Sets the current frame to the
first frame of the loaded image
sequence.

Play >First Frame

First €l button

Previous Frame

Sets the current frame to its

previous frame.

Play > Previous Frame

Next Frame

Sets the current frame to its
following frame.

Play > Next Frame

Last Frame

Sets the current frame to the

Play > Last Frame

11
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Command

Action

Access Methods

last frame of the image
sequence.

Last I button

Play Module Help Menu

Command

Action

Access Methods

Online Help

Opens Toon Boom Online

Help where you can find
useful indexed and searchable
information on the operation
of the Toon Boom Play
module.

Help > Online Help

Press F1.

About

Opens the About window
which displays information
related to the application
version.

Windows/Linux: Help > About

macOS: This command is
located in the macOS Play menu.

12
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Playback Toolbar

Using the Playback toolbar (located at the bottom of the player interface), you can play your animation, loop
playback, navigate through frames and change the playback speed.

[ 185 [+
41 = E] > Bl ) Start 1 3] Stop 198 (¥ FPS 24 [ Preroll |24 % Scale: 1:1
Interface Element Name Action
0 = . Scrolls forwards or through
155 = Frame slider

the playback frames.

Sets the current frame to the
«l First first frame of the loaded
image sequence.

Plays the animation from

L | Play Backward the current frame to the first
frame.
] Stop Stops playback.

Plays the animation from
> Play Forward the current frame to the last
frame.

Plays your sound frame-by-
frame. This command is

>l Last only available when the
application is launched from
Harmony.

Repeats the scene when it
O Loop reaches the last frame
during playback.

Includes the soundtrack
during playback. This

L D) Sound command is only available
when the application is
launched from Harmony.
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Interface Element

Name

Action

<

Sound Scrubbing

Plays your sound frame-by-
frame. This command is
only available when the
application is launched from
Harmony.

Start 1 +| Stop

198

Start Frame

Enter a new value to control
the starting frame of the
playback range.

Start 1 +| Stop

198

Stop Frame

Enter a new value to control
the end frame of the
playback range.

FPS 24 £

FPS

Enter a new value (in frames
per second) in this field to
change the playback speed.

V| Preroll 24 |3

Preroll

Select the Preroll option and
enter the number of blank
frames. These frames will be
added at the start of the
playback.

Scale: 1:3

Scale

Displays the ratio of the
playback size you are
currently viewing in Toon
Boom Play compared to the
image’s actual size.

14




Harmony 16.0 Play User Guide

15



Chapter 3: Loading Image Sequences

Chapter 3: Loading Image Sequences

To play a scene in Play, you must load the sequence of rendered frames for that scene in the Play application.
Loading Image Sequences from Folders .. 17

Loading Image Sequences from Databases ... .. 19
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Loading Image Sequences from Folders

You can import an image sequence from a folder stored locally.

How to load an image sequence from a folder

1. From the top menu, select File > Load from Folder.

The Find Directory dialog box opens.
2. Select the folder that contains the image sequence to load.
3. Click OK.

The Load Playback dialog box opens.
Load Playback ==

File Name Loaded Changed *
preview-072f3b2194800a8-1.tga
preview-072f3b2194800a8-2.tga
preview-072f3b2194800ea8-3.tga

preview-072f3b2194800ea8-4.tga i
1 ¢

[ Select Al ] [ Select Loaded ] Load at : Full Resolution +

[Select Changed] [Select Unloaded] [ Filter Current Selection hd ]

w iR

[ Load ][ Cancel ]

4. Click one of the following:

» Select All: To select all the files in the list.

» Select Loaded: To reload images that are already loaded in the player.

» Select Changed: To reload only the images that were modified since they were loaded.

» Select Unloaded: To load all the images in the list that are not currently loaded in the player.

» Select an option from the Filter Current Selection menu to select a series of frames from the ones
selected. For example, to load one of six frames instead of the entire sequence, select Keep 1
Frame Out of 6 from the drop-down menu.

L r |
[ Select Al ] [ Select Loaded ] Load at : Full Resolution +

[Select Changed] [Select Unloaded] [ Filter Current Selection hd ]

Keep 1 Frame Out of 2
Keep 1 Frame Out of 3

Keep 1 Frame Out of 4

Keep 1 Frame Out of 5

Keep1 Frame[\Out of 6
Keep 1 Frame But of 7
Keep 1 Frame Out of 8

Keep 1 Frame Out of 9
Keep 1 Frame Out of 10
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5. Inthe Load At menu, select the image resolution. To load images faster, or to fit them on your screen,
load the images at a lower resolution.

[ Select Al ] [ Select Loaded ] Load at :
Full Resolution
[Select Changed] [Select Unloaded] [ Filter Currei 1/2 Resolution
1/3 Resolution
1/5 Resolution k
Load 1/ Resolution
1/7 Resolution
1/8 Resolution

6. Click Load to load the selected images.

7. Oncetheimages are loaded, click the Play » button to play back your image sequence.

18
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Loading Image Sequences from Databases

You can import an image sequence stored on the Harmony database.

How to load an image sequence from the database

1. Fromthe top menu, select File > Load from Database. Note that Harmony Essentials cannot
connect to a database. This option is only for Harmony Advanced and Harmony Premium.

The Database selector dialog box opens.
2. Select the environment, job, scene and element in which your frames are located.
3. Select one or more frames to load.
4. Click Open.
The Load Playback dialog box opens.
5. Click one of the following:

» Select All: To select all the files in the list.

» Select Loaded: To reload images that are already loaded in the player.

» Select Changed: To reload only the images that were modified since they were loaded.

» Select Unloaded: To load all the images in the list that are not currently loaded in the player.

» Select an option from the Filter Current Selection menu to select a series of frames from the ones
selected. For example, to load one of six frames instead of the entire sequence, select Keep 1
Frame Out of 6 from the drop-down menu.

L ’ |
[ Select Al ] [ Select Loaded ] Load at : Full Resolution +

[Select Changed] [Select Unloaded] [ Filter Current Selection hd ]

Keep 1 Frame Out of 2
Keep 1 Frame Out of 3

Keep 1 Frame Out of 4

Keep 1 Frame Out of 5

Keep1 Frame[\Out of 6
Keep 1 Frame But of 7
Keep 1 Frame Out of 8

Keep 1 Frame Out of 9
Keep 1 Frame Out of 10

6. Inthe Load At menu, select the image resolution. To load images faster, or to fit them on your screen,
load the images at a lower resolution.

L ... s |

[ Select Al ] [ Select Loaded ] Load at : Full Resolution +
Full Resolution
[Selectchanged] [SelectUnIoaded] [ Filter Currei 1/2 Resolution
1/3 Resolution
‘4 Resolution
1/5 Resolution
Load 1/ Resolution
1/7 Resolution
1/8 Resolution
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7. Click Load to load the selected images.

8. Oncetheimages are loaded, click the Play » button to play back your image sequence.

20
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