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Introduction

The Harmony core functionality are explained in this User guide. All the steps required to create and complete 

a project are covered in the follow ing chapters w ith concept descriptions and detailed step-by-step 

procedures focused on the task at hand.  

Detailed parameter descriptions for all buttons, commands, and functions are covered in the Reference guide 

and Preference guide. Some of them are explained here where necessary to the understanding of a given 

concept or procedure.  
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Chapter 1: Project Creation

Chapter 1: Project Creation

Once Harmony is installed, you are ready to start the application and paint! In this chapter, you w ill learn about 

starting the application, as well as opening and saving scenes

13



About the Database Structure in Harmony Server

Harmony Server has a client-server configuration linked through a network. Although the user is working on a 

client machine, all of the data is saved on the server.

You can compare the Harmony Server structure to a fil ing cabinet. Every element is structured and follows a 

strictly organized hierarchy.

The follow ing production structure hierarchy is used:

 l Environment: Production, project, feature film, series—see Environment Structure on page 14

 l Job: Episode and sequence from each environment

 l Scene: Scene from each job

 l Element: Layers and columns from each scene

 l Drawing: Drawings from each element

If you imagine the environment as a fil ing cabinet containing all the folders and information, then the follow ing 

structure is used:

 l The job is a drawer in the fil ing cabinet containing all the folders related to the drawer’s topic.

 l The scenes are the folders contained in that drawer

 l The elements are the papers contained in the folder

 l The drawings are the information contained on the paper

A Harmony Server scene can only be saved inside the structure. This maintains structural organization so 

nothing is lost. By adhering to this structure, every user working in the database always knows where to find 

the scenes to work on.

Environment Structure

Before you create or save any elements in your production, you should decide upon a project name. This 

should reflect the content or title. Use the name to create the project’s environment, where you w ill store all of 
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Chapter 1: Project Creation

your production elements.

For example, the environment could be called adventure_movie. An environment can be used for movies, 

series, commercials, student work database, etc.

For a series, you can create an environment w ith the same name as the series, such as smith_family. Then 

you can create a job per episode: smep_001, smep_002, and so on. Here is what the letters and numbers 

represent:

 l sm: The first two letters of the name smith

 l ep: Episode

 l 001: The number of the episode

For commercials, which are rather short, you can create an environment, such as commercials. Then you can 

create one job per commercial: toothpaste, soap, car, and so on. As commercials are short and do not require 

splitting into episodes or sequences, you can group them all in the same environment.

For a database of student’s work, you can create an environment and name it w ith the class or group name, 

such as gr402a. Then you can create one job per student: smith_john, robertson_jane. And then store 

the different student exercises in separate scenes under their job name.
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About Scene Creation for Paint

W hen working in Paint, you cannot create scenes or drawings. You can only edit existing drawings in existing 

scenes. To create scenes, you must use the Control Center module. To create drawings, you must use 

Harmony and, optionally, Scan. 

For documentation on how to use Control Center, Harmony and Scan, refer to the User Guide for your edition 

of Harmony.
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Starting Paint

T-HFND-001-002

You can run Harmony [Edition] from your operating system's desktop. 

W ARNING 

On macOS, Harmony and its other applications w ill not run on the first time unless you right-click 

on the application, then select Open. You w ill be prompted to confirm a security exception, which 

w ill require administrative privileges. 

How to start Harmony Paint

 1. Depending on your operating system, do one of the follow ing:

 l W indows: Open the Start menu and, in the list of programs, select Harmony 22 [Edition] > 
 Paint.

 l macOS: Do the follow ing:

 a. In Finder, proceed to Applications > Toon Boom Harmony 22 [Edition] and 

double-click  Harmony [Edition].

The main Harmony application launches.

 b. In the top menu, select Harmony [Edition] > Tools > Paint.

 l GNU/Linux: In the GNOME top menu, select Applications > Harmony 22 [Edition] >  

Paint.

The Paint application launches and displays a splash screen. After the splash screen, the log-in 

dialog box appears—see Connecting to the Database on page 18.
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Connecting to the Database

Before you can work in HarmonyPaint via Harmony Server, you must be connected to the Harmony database. 

How to connect to the Harmony database

 1. Start   Paint—see Starting Paint.

 2. In the User Name field, type in your Harmony username. 

NOTE 

This username should be provided to you by your project lead or system administrator. 

 3. Click on OK. 

The main application w indow appears. You can now load drawings so you can work on them—see 

Loading Drawings and Elements in Paint
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Loading Drawings and Elements in Paint

Once you launch Paint, you need to load a scene’s drawings from the Database Selector, in order to start the 

ink and paint process. The drawings must have previously been created and scanned. 

There are two ways of loading drawings:

 l Open Drawings: You can select individual drawings to open.

 l Open Elements: You can open all the drawings in one or several elements. 

19



Opening Drawings in Paint

This option w ill let you load drawings from one element at a time, for quick ink and paint on a single layer 

animation.

How to open drawings in Paint

 1. Once Paint is launched and you are logged in, select File > Open Drawings. Press Ctrl + O 

(W indows/Linux) or ⌘  + O (macOS).

The Database Selector opens, displaying the Environments available from the Harmony database.

 2. Select the Environment, Job, Scene and Element where the drawings you need to paint are located.

 3. Choose the version you want to open from the Version drop-down menu.
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 l The Saved By and Saved Date fields display the user who was the last to save the 

selected scene and the date of the last save. 

 4. Click on the Open button.

The Drawings Selector dialog box opens.

 5. Select the desired drawings from the drawings list:

 l Click on a single drawing to select it.

 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (W indows/Linux) or ⌘  

(macOS) key.

 l Click on the All button to select all the drawings that are listed in the Drawings 

Selector.

 l Click on the Unpainted button to select all the drawings whose status appears as 

UNPAINTED.

21



 l Click on the Painted button to select all the drawings whose status appears as 

PAINTED.

 6. Click OK.

The selected drawings appear in the Drawing Thumbnails view

 7. Use the Control panel to navigate between the previous and next drawings. Press F and G.

You are now ready to ink and paint!
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Opening Elements in Paint

This option w ill let you load drawings from several elements at once. This can be useful when an animation is 

separated in many layers, to insure that they are well aligned and that the painted shapes and lines fit 

together. A good example of this would be a dialogue w ith the chin and mouth separated from the rest of the 

head.

How to open elements in Paint

 1. Once Paint is launched and you are logged in, select File > Open Elements. Press Ctrl + E 

(W indows/Linux) or ⌘  + E (macOS).

The Database Selector opens, displaying the Environments available from the Harmony database.

 2. Select the Environment, Job and Scene where the elements containing the drawings you need to 

paint are located. 

 3. Choose the version you want to open from the Version drop-down menu.
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 l The Saved By and Saved Date fields display the user who was the last to save the 

selected scene and the date of the last save. 

 4. Click on the Open button.

The Open Elements dialog box opens.

 5. Select the elements you need to paint from the Elements list:

 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (W indows/Linux) or ⌘  (macOS) key.

 6. Select the frames you w ish to load from the Frames list:

 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (W indows/Linux) or ⌘  (macOS) key.

 l Click on the All Frames button to load all the frames of the scene.
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 7. Click OK.

The Drawing Thumbnails view is hidden and your selected elements are loaded in Paint.

 8. Enable the Light Table  option from the Drawing view toolbar to display all the drawing layers.

The selected layer are displayed in original colours and the other layers are displayed as washed 

out colours.

 9. Use the Control Panel to navigate between previous and next layers. Press H and J.

 10. Use the Control panel to navigate between previous and next drawings. Press F and G.

You are now ready to ink and paint!
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Saving a Scene in Paint

It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in the title 

bar beside the scene name to indicate that the scene contains unsaved changes.

In Paint, you can only make changes to drawings in a scene, not to the scene's structure or set-up. W hen you 

save in Paint, all the changes you made to the loaded drawings are saved to the database.

How to save a scene

 1. Do one of the follow ing

 l In the top menu, select File > Save.

 l Press Ctrl + S (W indows/Linux) or ⌘  + S (macOS).
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Advanced Saving in Paint

Use the Advanced Save dialog box to save specific drawings, palettes and palette lists as a version of your 

scene. 

How to use the Advanced Save dialog box

 1. From the top menu, select File > Save.... 

The Advanced Save dialog appears.

For information on the parameters in the Advanced Save Dialog Box, refer to the Advanced Save 

Dialog Box topic of the Reference guide.
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Verifying a Scene's Integrity

The Check Files commandVerifies the integrity of the drawing and palette files in your project.  Use the Check 

Files dialog box to verify that the data is consistent, correct, and accessible.

How to open the Check Files dialog box

 1. From the top menu, select File > Check Files.

 2. Click Check Colours to open the Check Colours dialog box.

The Check Colours dialog box checks the palette integrity and displays the colour recovery 

data.
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Chapter 2: User Interface

T-HFND-003-001

Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize your 

workspace conveniently. There are a series of views and toolbars you can use as you perform different 

operations. Usually, each person has a specific way of working in the interface and prefer particular views and 

toolbars. In this chapter, you w ill learn about the main elements of the interface and how to manage them.

NOTE 

To learn more about each view 's properties, see the Reference guide.

29



Changing the Theme Colours

The Harmony interface is set to a dark theme by default. You have the option of sw itching to a light theme.

How to change the interface theme

 1. In the top menu, select Edit > Preferences (W indows/Linux) or Harmony [Edition] > Preferences 

(macOS) .

The Preferences dialog box opens.

 2. In the General tab, in the Options section, uncheck the Use Dark StyleSheet (Requires Relaunch) 

check box.

 3. Click OK.

 4. Close and relaunch Harmony.
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Changing the User Interface Language

Harmony is available in English, Spanish, Japanese, and Chinese. 

By default, Harmony w ill automatically launch in your operating system language if it is one of the supported 

languages. Otherwise, it w ill launch in English. 

There are two ways of controlling the language in which Harmony launches:

 l By changing the Language preference in the Preferences dialog.

 l By launching Harmony from a command line, w ith the -lang parameter followed by a two-letters 

language code.

How to change the user interface language for Harmony

 1. In the top menu, select Edit > Preferences (W indows/Linux) or Harmony [Edition] > Preferences 

(macOS) .

The Preferences dialog box opens.

 1. In the General tab, in the Language section, open the Language (Requires Relaunch) drop-down 

and select the desired user interface language.

 2. Click OK. 

 3. Close and relaunch Harmony.

How to start Harmony in a specific user interface language from the command line

 1. Open a Command Prompt or Terminal w indow.

 2. Type in the follow ing command, including the quotation marks, but don't press Enter/Return yet. 

 l W indows: "C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony 22 [Edition]\win64\bin\Harmony[Edition].exe"

 l macOS: "/Applications/Toon Boom Harmony 22 [Edition]/Harmony 
[Edition].app/Contents/MacOS/Harmony [Edition]"

 l GNU/Linux: /usr/local/ToonBoomAnimation/harmony[Edition]_22/lnx86_
64/bin/Harmony[Edition]

 3. Type a space, then type the follow ing parameter depending on which language you want to launch 

Harmony in:

 l English:  -lang en

 l Chinese: -lang zh
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 l Japanese: -lang ja

 l Spanish: -lang es

 4. Press Enter/Return.

Harmony w ill launch in the specified language.
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About Menus

T-HFND-003-002

Harmony contains three types of menus from which you can access many commands and options:

Top Menu 

The top menu contains most of the commands. Depending on the view you're working in and the element, 

some commands are available and others are not. The top menu is always located at the very top of the 

interface.

The top menu contains the follow ing categories:

 l File

 l Edit

 l View

 l Drawing

 l Selected

 l Tools

 l Options

 l Colours

 l Palettes

 l Frames

 l Columns

 l W indows

 l Help

On macOS, there is also a Harmony [Edition] category that contains the follow ing commands:

 l Preferences

 l About

 l Quit

View Menu 

A view menu contains commands specifically related to that view.
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To access a  view menu, click the Menu  button in the top-left corner of a view.

A view menu is available in the follow ing views:

 l Colour

Quick Access Menu

A quick access menu lets you open a list of the commands you w ill use most often.

To access this menu, right-click anywhere in a view.
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About Toolbars

T-HFND-003-003

The Harmony user interface contains various toolbars, such as the Tools toolbar and the Edit toolbar, to give 

you quick access to various menu commands. 

NOTE 

Throughout this section, there may be slight differences between your interface and the 

il lustrations in this guide. This is because the images are taken from Harmony Premium.

Toolbars are separated in two main categories:

 l W orkspace  toolbars are toolbars that have a general purpose. For example, the File, Edit, W orkspace, 

Advanced Animation and Deformation toolbars at the top, as well as the Tools toolbar on the left, are 

workspace toolbars. Those toolbars can be placed at the top, bottom, left or right edge of the 

application w indow. They can also be placed at the edge of specific views if preferred. 

 l View toolbars are toolbars that are useful for a specific view. For example, the Camera view has a 

Camera toolbar at its top. View toolbars can only be displayed inside their respective view. They can be 

placed at the top, bottom, left or right edge of their view. 

You can display or hide toolbars using the W indows > Toolbars menu. This menu contains all the workspace 

toolbars, as well as the view toolbar for all the views that are currently displayed in your workspace. 

For example, in the default workspace, you have the Camera and the Drawing views in the same area, and you 

can switch between either view by clicking on the Camera or Drawing tab. If the Camera view is the one being 

displayed, then the Camera toolbar w ill be in the list. If the Drawing view is displayed, then the Drawing 

toolbar w ill be in the list instead.

W orkspace toolbars can be added to either the general workspace or the inside of a view.  For example, you 

can add the Edit toolbar to the top of the area occupied by the Camera view instead of the top of the 

application w indow, where it is by default. In the default workspace, the Tool Presets and Art Layer toolbars 

are placed in the area where the Camera and Drawing views are, even though they’re actually workspace 

toolbars. 

W hen a workspace toolbar is added to a view, and several views are placed where this view is, then all those 

views w ill have this toolbar inside of them. For example, if you add the Edit toolbar to the Camera view, it w ill 

also be available in the Drawing view, as both these views share the same space. However, the Camera 

toolbar w ill not be available in the Drawing view as it is specific to the Camera view. 

Some toolbars have buttons that are hidden by default to avoid cluttering. You can customize which buttons 

are displayed in these toolbars, and in which order they’re displayed—see Customizing Toolbars.
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TIP 

Many toolbar buttons have a keyboard shortcut associated to them. You can check which keyboard 

shortcut is associated to a button by leaving your mouse cursor over the button for a second. If the 

button has a keyboard shortcut, it w ill be indicated in the tooltip that appears. 
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Adding and Removing Toolbars

T-HFND-003-004

You can add toolbars to certain areas of your workspace. The way it works is as follows:

 l A workspace toolbar can be added to any edge of the application w indow, or to the edge of a view in 

your workspace.

 l A view-specific toolbar can be added to the edge of its respective view only. 

NOTE 

W hen a workspace toolbar is added inside a view, and this view shares its area w ith other views—

like the Camera and Drawing views do by default—the toolbar w ill remain visible even if you 

switch to a different view in this area. For example, if you added the Alignment Guides toolbar to 

the Camera view, this toolbar would also be visible in the Drawing view. 

How to add or remove a workspace toolbar to the general workspace

 1. Do one of the follow ing:

 l In the top menu, select W indows > Toolbars and in the sub-menu, select the toolbar you 

want to add. 

 l Right-click on any toolbar that is at the top or side of the workspace, or in the empty space 

next to these toolbars, and select the toolbar you want to add in the contextual menu.

NOTE 

In the list of toolbars in the top menu and in the contextual menu of the workspace, the 

toolbars listed above the separator are workspace toolbars, and the ones below the 

separator are view toolbars.

How to add a view toolbar to a view

 1. Do one of the follow ing:

 l Click on the tab of the view for which you want to add a toolbar to set the focus on it. Then, 

in the top menu, select W indows > Toolbars and select the toolbar you want to add.

 l In the top area of the view to which you want to add a toolbar, to the left of its tab, right-click 

and  select the toolbar you want to add in the contextual menu.
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How to add or remove a workspace toolbar to a view

 1. In the top area of the view to which you want to add a toolbar, left of its tab, right-click and  select 

the toolbar you want to add in the contextual menu. You can also-right-click on a toolbar inside this 

view, if there is any.

NOTES 

 l If the workspace toolbar was present somewhere else in your workspace, it w ill be 

removed from its previous position and moved to the view where you just added it.

 l In the list of toolbars in the contextual menu of a view, the toolbars listed above the 

separator are workspace toolbars, and the ones below the separator are view 

toolbars.
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Moving Toolbars

T-HFND-003-005, T-HFND-003-006

You can move toolbars around using drag & drop. This can be used to:

 l Reorder toolbars w ithin the same toolbar area.

 l Move a toolbar from one edge of the application w indow or view in which it is located to another edge.

 l Hide part of a toolbar w ith another toolbar. 

The action you do depends on the gesture w ith which you drag the toolbar:

 l If you drag the toolbar horizontally you are “sliding” the toolbar. This allows you to move the toolbar 

over another toolbar in the same row. W hen two toolbars share the same space, the toolbar on the 

right appears over the toolbar on the left, and the left toolbar’s rightmost buttons are hidden in a pop-

up menu. 

Likewise, you can do this w ith a vertical toolbar by sliding it vertically, in which case the toolbar at the 

bottom appears over the toolbar at the top. 

 l If you drag the toolbar vertically, you “pop” it out of its row. W hen a toolbar is popped out, you can 

reorder toolbars and move the toolbar to another row or to a different edge of the user interface.

Likewise, you can do this w ith a vertical toolbar, such as the Tools toolbar at the left of the workspace, 

by moving it horizontally. 

NOTE 

You cannot move a toolbar from the edge of the application w indow to the inside of a view, or vice 

versa. If you want to do that, you must add the toolbar where you want it to be located, and it w ill 

automatically be removed from the area where it is currently located. For example, if you want to 

move the Edit toolbar from the top of the workspace to the Camera view, all you have to do is add 

it to the Camera view—see Adding and Removing Toolbars.
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How to move a toolbar around

 1. Click and hold the handle at the left of the toolbar you want to move.

 2. Do one of the follow ing:

 l If the toolbar is horizontal, move it up or down to make it pop out of its row.

 l If the toolbar is vertical, move it left or right to make it pop out of its column.

 3. Do one of the follow ing:

 l To reorder toolbars, drag the toolbar where you want it to be located and drop it.

The toolbar w ill move to its new position. Toolbars to the right (or to the bottom, if the 

toolbar is vertical) w ill be offset to make space for it.

 l To move the toolbar to a new row or to a new column, simply move the toolbar where the 

new row or column should be created. For example, to create a new row of toolbars at the 

top of the user interface, move it just below the existing toolbars at the top of the user 

interface. A new row or column will appear, highlighted in cyan.

W hen you drop the toolbar, the new row will be created and the toolbar w ill be placed at 

the left end of the row.
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Likewise, to create a new column at the left of the user interface, move the toolbar just right 

of the existing toolbars at the left of the user interface.

 l To move the toolbar to another edge of the user interface, drag it all the way to that edge of 

the user interface.

How to move a toolbar over another toolbar

 1. Make sure both toolbars are in the same row or column. If they are not, move both toolbars to the 

same row or column using the method previously described. 

 l If the toolbars are horizontal, click and hold the handle at the left of the rightmost toolbar. 

Then, w ithout going outside of the toolbar’s row, slide the toolbar towards the left.

 l If the toolbars are vertical, click and hold the handle at the top of the bottom toolbar. Then, 

w ithout going outside of the toolbar’s column, slide the toolbar up. 

As you slide the toolbar over the other toolbar, the other toolbar’s buttons become hidden and a 

pop-up menu button appear.

 2. To separate the toolbars again, simply slide the same toolbar in the opposite direction.

 3. To expand a toolbar that is overlapped by another toolbar, click on the expand button at the right 

of the overlapped toolbar.
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Customizing Toolbars

T-HFND-003-007

Some toolbars have buttons that are hidden by default to prevent clutter. You can customize which buttons 

are displayed in these toolbars, as well as the order in which the buttons are displayed. 

How to customize a toolbar

 1. Right-click on the toolbar that you want to customize.

 2. In the context menu, select Customize.

The Toolbar Manager dialog appears.

NOTES 

 l If the Customize option is greyed out, this toolbar cannot be customized.

 l The Customize option is only available if the toolbar is in the space above the 

Camera View.

 l The Tools toolbar can only be customized in Flat Tools Toolbar mode—see 

Enabling the Flat Toolbar.

 3. To add a new toolbar button, select the button you want to add from the Available Tools l ist, then 

click on the  Add the selected tool into the toolbar button. 

The button w ill be removed from the Available Tools l ist and added to the Toolbar list. 
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 4. To remove a button from the toolbar, select it in the Toolbar list, then click on the Remove the 

selected tool from the toolbar button. 

The button w ill be removed from the Toolbar list and added to the Available Tools list. 

 5. To reorder the buttons in the toolbar, select a button in the Toolbar list, then use the Move the tool 

up and Move the tool down buttons to change the button’s order. The order of the tools in the 

toolbar from left to right is the same as the order of the buttons in the Toolbar list from top to 

bottom.
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 6. Click OK when you are done customizing the toolbar.
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About Views

T-HFND-003-008

The Harmony interface is composed of different views, each one designed for a specific purpose. You can 

modify the location of the views by adding a new view as a tab or as a w indow. You can also swap the location 

of a view.

W hen a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are 

associated w ith the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing 

or other type of selection or the option does not apply to the active view.

W orkspace modifications are automatically saved when you exit the application, unless you disable the 

Automatically Save W orkspace option in the Preferences dialog box.
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Showing and Hiding Views

T-HFND-003-012

You can temporarily show and hide views using the collapsing buttons.

How to temporarily hide a view

 1. On the edge of the w indow you want to hide, click the Collapse/Expand button.

The view is compressed and only the Collapse/Expand button is visible.

 2. Click the Collapse/Expand button again to redisplay the view.
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Moving Views

T-HFND-003-011

You can move views by dragging their name tab to a new location.
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Resizing Views

T-HFND-003-013

You can resize a view by sliding its edges.

How to resize a view

 1. Place the pointer on the edge of the view to resize.

 2. W hen you see the Resizing  icon, drag the side of the view to the desired size.
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About Preferences

An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can customize the 

behaviour of various user interface elements, as well as drawing and animation tools, and enable or disable 

advanced features.

NOTE 

For a list of all the preferences as well as their functionality, refer to the Preferences guide.

How to open the Preferences dialog box

 1. Do one of the follow ing:

 l W indows or GNU/Linux:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony [Edition] > Preferences.

 l Press ⌘  + U.
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About Keyboard Shortcuts 

Harmony uses keyboard shortcuts to allow you to quickly use commands you are familiar w ith w ithout having 

to browse through menus and toolbars. Learning the keyboard shortcuts for the commands you use the most 

often can be a great way to increase your productivity w ith Harmony. 

Using the Keyboard Shortcuts dialog, you can: check which keyboard shortcuts are assigned to which 

commands, you can customize existing keyboard shortcuts, and you can assign keyboard shortcuts to 

commands that don't have any.

NOTE 

For more information on how to configure keyboard shortcuts as well as a list of commands and 

their default keyboard shortcuts, refer to the Keyboard Shortcuts guide.

How to open the Keyboard Shortcuts dialog box

 1. Do one of the follow ing:

 l W indows or GNU/Linux: In the top menu, select Edit > Keyboard Shortcuts.

 l macOS: In the top menu, select Harmony [Edition] > Keyboard Shortcuts.
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Loading W orkspaces

T-HFND-003-015

You can load an existing workspace from the drop-down menu.

How to load a workspace

 1. Do one of the follow ing:

 l Select W indows > W orkspace > W orkspace.

 l Select a workspace from the W orkspace toolbar.
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Creating W orkspaces

T-HFND-003-016

You can create new workspaces through the W orkspace Manager dialog box.

How to create a new workspace

 1. Do one of the follow ing:

 l In the W orkspace toolbar, click the         button.

 l From the top menu, select W indows > W orkspace > W orkspace Manager.

 2. In the Available W orkspaces list, select an existing workspace.

 3. At the bottom of the Available W orkspaces list, click the Add  button to add a workspace.

 4. Select the new workspace that was created. Click Rename and give it a new name.
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 5. Select the new workspace and click the Right Arrow  button to move it to the W orkspace 

toolbar.

 6. Click OK.
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Renaming W orkspaces

You can rename a workspace through the W orkspace Manager dialog box.

How to rename a workspace

 1. Do one of the follow ing:

 l In the W orkspace toolbar, click the         button.

 l From the top menu, select W indows > W orkspace > W orkspace Manager.

 2. Choose the workspace to be renamed from the list.

 3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit 

the name. 

 4. Type in the new name of the workspace.

 5. Press the Enter/Return key to validate the name.

 6. Click OK. 
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Saving W orkspaces

T-HFND-003-017

You can either save your workspaces automatically or manually.

How to save your workspace as a new version

 1. From the top menu, select W indows > W orkspace > Save W orkspace As.

The Save W orkspace As dialog box opens.

 2. Type in a workspace name and click OK. 

How to disable the Automatically Save W orkspace preference

 1. From the top menu, select Edit > Preferences (W indows/Linux) or Harmony [Edition] > 

Preferences (macOS) to open the Preferences dialog box.

 2. Select the General tab.

 3. In the Options section, deselect the Automatically Save W orkspace option.

 4. Click OK. 

The Save W orkspace   button appears in the W orkspace toolbar.

How to save a workspace manually

 1. Do one of the follow ing:

 l In the W orkspace toolbar, click the Save W orkspace   button. 

 l You can also select W indows > W orkspace > Save W orkspace.
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Deleting W orkspaces

You can delete a workspace through the W orkspace Manager dialog box.

How to delete a workspace

 1. Do one of the follow ing:

 l In the W orkspace toolbar, click the         button.

 l From the top menu, select W indows > W orkspace > W orkspace Manager.

 2. In the W orkspace Manager, select the workspace to be deleted and click the Left Arrow   button 

to move it to the Available W orkspaces list.

 3. Select the workspace from the Available W orkspaces list, then click the Delete  button to delete 

the workspace.

 4. Click OK.
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Showing and Hiding W orkspaces

You can show and hide workspaces from your drop-down list through the W orkspace Manager dialog box.

How to show a workspace

 1. Do one of the follow ing:

 l In the W orkspace toolbar, click the         button.

 l From the top menu, select W indows > W orkspace > W orkspace Manager.

 2. In the Available W orkspaces list, select the workspace to be displayed and click the Right Arrow  
 button to move it to the W orkspace toolbar.

 3. Click OK. 

How to hide a workspace

 1. Do one of the follow ing:

 l In the W orkspace toolbar, click the         button.

 l From the top menu, select W indows > W orkspace > W orkspace Manager.

 2. In the W orkspace Manager, select the workspace to be hidden and click the Left Arrow   button 

to move it to the Available W orkspaces list.

 3. Click OK. 
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Reordering W orkspaces

You can reorder workspaces in your drop-down list through the W orkspace Manager dialog box.

How to reorder workspaces

 1. Do one of the follow ing:

 l In the W orkspace toolbar, click the         button.

 l From the top menu, select W indows > W orkspace > W orkspace Manager.

 2. In the W orkspace toolbar, select the workspace to be reordered and on the Up  or Down  

buttons to move it up or down.

 3. Click OK. 
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Restoring the Default W orkspace

T-HFND-003-018

You can restore modified workspaces to their original layout.

How to restore the default workspaces

 l Select W indows > Restore Default W orkspace.

59



About Interface Navigation

W ith the help of menu commands and keyboard shortcuts, some views let you navigate their content by 

zooming in, zooming out, panning and rotating them. You can also reset the zoom level, pan and rotation angle 

of these views as needed.

TIP 

Keyboard shortcuts can be customized. You can view, search for and change keyboard shortcuts 

for Harmony in the Keyboard Shortcuts dialog. To access the Keyboard shortcuts dialog:

 l W indows or GNU/Linux: In the top menu, select Edit > Keyboard Shortcuts.

 l macOS: In the top menu, select Harmony [Edition] > Keyboard Shortcuts.

Command Action Access Methods

Zoom In
Zooms in the 

view. 

View > Zoom In

Press 2

Roll the mouse wheel up (except in the Timeline and Xsheet views)

Zoom Out
Zooms out the 

view.

View > Zoom Out

Press 1 

Roll the mouse wheel down (except in the Timeline and Xsheet 

views)

Zoom In or Out
Zooms in or out 

of the view.

Roll the middle mouse button up or down.

Hold down the Spacebar and the middle mouse button while 

dragging the mouse up or down.

Pan

Moves the view 

horizontally or 

vertically.

Hold down the Spacebar and drag in the direction you want to pan 

the view.

Reset Pan

Resets the view’s 

pan to its default 

position.

View > Reset Pan

Press Shift + N

Reset View

Resets the view 

to its default 

position.

View > Reset View

Press Shift + M

The  Reset View button at the bottom of the Camera view.

60

Harmony 22 Paint User Guide                          



Chapter 2: User Interface

Command Action Access Methods

Reset Rotation

Resets the view’s 

rotation to its 

default position.

View > Reset Rotation

Press Shift + X

Reset Zoom

Resets the view’s 

zoom to its 

default position.

View > Reset Zoom

Rotate View
Rotates the view 

left or right.

W hile holding Ctrl + Alt (W indows/Linux) or Ctrl + ⌘  (macOS), click 

and drag the rotating disc to rotate it clockwise or counterclockwise.

3D Rotate View

Rotates the view 

in any direction. 

This is only 

available in the 

Perspective view. 

W hile holding Ctrl + Shift (W indows/Linux) or ⌘  + Shift (macOS), 

click and drag the stage to rotate it in any direction.

Rotate 30 CW

Rotates the 

Camera view 30 

degrees 

clockwise, like an 

animation table.

View > Rotate View CW

Rotate 30 CCW

Rotates the 

Camera view 30 

degrees counter-

clockwise, like an 

animation table.

View > Rotate View CCW

Mirror View

Temporarily fl ips 

the Camera or 

Drawing view 

horizontally, 

allow ing you to 

view and edit 

your artwork as if 

it was being 

mirrored.

View > Mirror View

In the Camera or Drawing toolbar, click on the  Mirror View 

button.

Toggle Quick 

Close-up

Instantly 

multiplies the Shift + Z

61



Command Action Access Methods

view 's Zoom 

Factor by 4. For 

example, if the 

Camera View 's 

Zoom Factor is at 

100%, this w ill 

make it toggle 

between 400% 

and 100%. 
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Accessing the Documentation

T-HFND-001-004

The Harmony documentation can be accessed from the Help menu.

How to access the Harmony documentation

 1. From the top menu, select Help > Online Help.
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Chapter 3: Drawing

Harmony has many powerful tools, views, and features for sketching, drawing and animating w ith ease. This 

chapter describes the main assets needed when drawing , as well as tips on how to start and use these tools 

efficiently. 
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About Drawing Tools

Harmony has a w ide array of drawing tools and drawing features to allow flexible design, work methods and 

styles.

Here are the drawing tools available in Harmony, followed by the types of layer on which they are supported.  

If you are editing a vector layer, then all of the tools are available to you. If you are drawing on a bitmap layer, 

some tools are not available. W hen tools are not available, they are grayed out in the Tools toolbar. 

Icon Tool Name Vector Layer
Bitmap 

Layer

Select ✓ ✓

Cutter ✓ ✓

Reposition All Drawings ✓  

Contour Editor ✓  

Centerline Editor ✓  

Pencil Editor ✓  

Smooth Editor ✓  

Perspective ✓  

Envelope    

Edit Gradient/Texture ✓  

Brush ✓ ✓
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Icon Tool Name Vector Layer
Bitmap 

Layer

Pencil ✓  

Eraser ✓ ✓

Text ✓ ✓

Line ✓ ✓

Rectangle ✓ ✓

Ellipse ✓ ✓

Polyline ✓  

Paint ✓ ✓

Ink ✓  

Paint Unpainted ✓ ✓

Repaint ✓  

Unpaint ✓ ✓

Stroke ✓  
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Icon Tool Name Vector Layer
Bitmap 

Layer

Close Gap ✓  

Colour Eyedropper ✓ ✓

Pencil Texture Eyedropper ✓  

Each drawing tool has a series of options to customize its behaviour and drawing style. W hen you select a 

tool, the Tool Properties view displays the properties of the currently selected tool, where you can configure 

your drawing tool's behavior and style, if applicable. 
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About the Brush Tool

T-HFND-004-003

The Brush tool is pressure sensitive and lets you create a contour shape w ith a thick and thin line effect, as if it 

was created w ith a paint brush.

W ith the Brush tool, you can draw solid vector strokes or textured bitmap strokes, depending on your brush 

properties.  Solid vector brush strokes are made of a vector shape fil led w ith a solid colour, making them 

limited in terms of art style, but lightweight and easy to manage. Textured brush strokes can have a bitmap 

brush tip, a bitmap paper texture, and various settings such as hardness, randomness, antialiasing and 

transparency. Hence, they can be used to draw in various art styles, add natural- looking details to your 

drawing and reproduce the feel of a real brush stroke. 

W hen drawing on vector layers, you can use the Select Tool, Contour Editor, Smooth Editor, Perspective and 

Envelope tool to scale your brush strokes or to tweak their shape. If your strokes contain a bitmap texture, 

Harmony w ill scale or deform the texture to fit the new shape of your brush. If your brush is scaled up or 

deformed in a way that takes more volume, Harmony w ill automatically generate new pixels for the textures, 

which might cause them to lose quality.

On vector layers, textured vector brush strokes are composed of a greyscale bitmap mask applied to their 

colour. Hence, their colour can be repainted or updated as easily as w ith solid vector brush strokes. Changing 

the colour used to paint a textured vector brush stroke  from the colour palette w ill update the colour in  

textured vector brush stroke, as it would w ith solid vector brush strokes, all the while preserving its texture.

You can also create dynamic brushes, which allow you to use artwork created in Harmony as if it was a brush 

tip or a stamp. 

NOTE 

To learn more about the options of the Brush tool, see the Reference Guide.
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Drawing with the Brush Tool

T-HFND-004-003A 

In the Drawing view, you can draw on any drawing layer type w ith the Brush tool. 

How to draw with the Brush tool                                       on a vector layer                 

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Tool Properties view, set the Maximum Size to the desired brush size. 

NOTE 

If you are drawing w ith a mouse, your strokes w ill always be at their maximum size. If you are 

using a pressure-sensitive tablet, your strokes w ill vary in size depending on the pressure of 

your pen, ranging between 25% to 100% of the maximum size. 

 4. In the Colour view, click a colour swatch to select a colour.

 5. In the Drawing or Camera view, start drawing.
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TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 

key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 

this w ith the eraser tip of your pen w ill adjust the size of the Eraser tool, regardless of 

which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you w ill draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 

w ill lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 

its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you w ill draw a 

straight horizontal or vertical l ine.

 l If you press and hold the Ctrl (W indows/Linux) or ⌘  (macOS) key while drawing, your 

drawing stroke w ill turn into a closed shape.

 l If you press and hold Alt before drawing a stroke, and start drawing near existing artwork, 

the start of your drawing stroke w ill connect to that artwork.

 l If you press and hold Alt while drawing a stroke, and end your drawing stroke near 

existing artwork, the end of that drawing stroke w ill connect to that artwork.

How to draw with the Brush tool on a bitmap layer

 1. In the Drawing Thumbnails panel, select a bitmap drawing.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Tool Properties view, set the Maximum Size to the desired brush size. If you are drawing w ith 

a mouse, your strokes w ill always be at their maximum size. If you are using a pressure-sensitive 

tablet, your strokes w ill vary in size depending on the pressure of your pen, ranging between 25% 

to 100% of the maximum size by default.

 4. In the Colour view, select a colour.
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 5. If you would prefer using Red/Green/Blue sliders, you can switch between HSV and RGB sliders by 

doing one of the follow ing:

 l Select Colour > Bitmap Colour Sliders > HSV Sliders or RGB Sliders. 

 l Right-click on the colour sliders and select RGB Sliders or HSV Sliders.

NOTE 

Although you can use colours from your colour palette to paint on a bitmap layer, 

colours used in a bitmap drawing layer are not linked to their colour swatch in the 

palette. This means that, contrary to vector drawing, updating the colours in your 

colour palette w ill not update your bitmap drawings w ith the new colours. 

 6. In the Camera or Drawing view, start drawing.

72

Harmony 22 Paint User Guide                          



Chapter 3: Drawing

TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 

key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 

this w ith the eraser tip of your pen w ill adjust the size of the Eraser tool, regardless of 

which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you w ill draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 

w ill lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 

its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you w ill draw a 

straight horizontal or vertical l ine.

 l If you press and hold the Ctrl (W indows/Linux) or ⌘  (macOS) key while drawing, your 

drawing stroke w ill turn into a closed shape.
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Creating a Solid  Brush

T-ANIMPA-002-001A

W hen drawing w ith the Brush tool on a vector layer, you can use either solid vector brushes or textured vector 

brushes. By default, your brush w ill be a solid vector brush. A solid vector brush creates a vector shape and 

simply fil ls it w ith the selected colour, making lightweight, simple crisp strokes. 

A solid vector brush's tip can be shaped like a circle, a diamond or a square, and can be configured to have a 

specific size, aspect ratio and angle. Also, solid vector brushes can be automatically smoothed by Harmony as 

you draw.

If you are drawing on a bitmap layer, you can only use textured brushes. You can create a textured brush that 

makes solid looking strokes, but they can not be automatically smoothed by Harmony, nor can they tweaked 

w ith vector tools such as the Contour Editor. 

 

You can now control the Size properties w ith input options such as Pressure, Tilt and Speed. You can use a 

combination of multiple inputs to control a single property. Also, you can control the Angle Function by 

selecting any one option from the drop down list.

How to create a                                       solid vector                                  brush

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

The Brush Properties dialog opens.

74

Harmony 22 Paint User Guide                          



Chapter 3: Drawing

 1. In the Brush Type dropdown list, select Solid Vector.

 2. In the brush tip list, select either Circle, Diamond or Square. 

 3. Use the Maximum Size slider to set the maximum size of your brush tip.

 4. 
NOTE 

W hen drawing w ith a mouse, your brush is always at its maximum size. W hen drawing 

w ith a pressure-sensitive pen tablet, your brush's size w ill range between its minimum 

and maximum size, depending on the amount of pressure you put on the pen when 

drawing. 

 5. You can control the size properties by clicking on the arrow button on right and the Size Properties 

dialog box w ill appear.
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 6. 
NOTE 

Please see Brush Properties Dialog and to learn more about Brush Tool options, see 

Brush Tool Properties. 

 7. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 

brush when using your pen w ith very little pressure. The minimum size is set to a percentage of 

your brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen 

to affect the brush size, set this parameter to 100%.

 8. If you want your brush to keep the same size relative to the camera frame when the camera zooms 

in on or zooms out of the scene, check the Proportional to Camera option.

 9. 
NOTE 

The "Size Proportional to Camera" option has been moved to the new Size Properties 

w indow. 

 10. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 

tip vertically all the while preserving its horizontal size.

 11. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.

 12. If you want your brush tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to 

set how much the tip should stretch. The tip w ill stretch by the percentage you set, in the direction 

in which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.
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 13. If you want your brush tip to rotate w ith the angle of your pen tip use the Angle Function. You can 

select one of the follow ing options:

 l Constant: The static orientation of the brush tip expressed in degrees.

 l Heading: The orientation of the brush tip is determined by the direction in which the stroke 

is drawn. It changes dynamically as the stroke is drawn.

 l Azimuth: W hen the pen is tilted, it uses the direction in which the pen eraser is facing.

 l Twist (if supported by pen): It uses the tw ist angle of the stylus and is only available w ith 

W acom Art Pen.

 14. Click on the Smoothing tab.

 15. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 

your  stroke's direction, curves and corners. A higher setting w ill prevent your line from being shaky, 

but is liable to reduce your drawing precision and to round sharp corners into curves.

 16. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on 

your stroke's contour. A higher setting w ill round sharp corners and reduce the amount of control 

points for the resulting vector shape. 

 17. Either close or set aside the Brush Properties dialog.

 18. In the  Drawing view, start drawing to test your brush settings.
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Creating a Textured Brush

T-LAY-001-004

Using textured brushes, you can create an infinite range of fuzzy, textured and watercolour lines. You can use 

bitmap brush tips, adjust your line's hardness and opacity, combine two tips and apply a paper texture to your 

brush strokes so as to adapt the Brush tool to a variety of art styles and create natural- looking brush strokes.

W hen drawing on a vector layer, brushes are solid vector brushes by default. You can however create a 

textured vector brush which combines both Harmony's vector and bitmap drawing capabilities. You can tweak 

textured vector brush strokes using various vector editing tools such as the Contour Editor, the Smooth Editor, 

the Perspective tool and the Envelope tool, and Harmony w ill resample the textures inside your brush strokes 

w ith each modification.

If you are drawing on a bitmap layer, your brush is always textured. You can configure a textured brush to look 

crisp and solid if desired, but brush strokes on bitmap layers cannot be tweaked or smoothed.
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Configuring a Textured Brush Tip

T-ANIMPA-002-002

The Brush tool supports two types of brush tips: Solid and Textured. Solid brush tips are plain shapes that can 

be used to draw vector shapes fil led w ith a solid color, whereas textured brush tips are bitmap images w ith 

various shapes and opacity levels that can be used to create natural- looking brush strokes.

Solid brush tips are not customizable. The selection is limited to either a circle, diamond or square-shaped 

brush tip, the proportions and angle of which can be adjusted. W hile Harmony also comes bundled w ith 

preset textured brush tips, it is also possible to create and use your own textured brush tips. 

How to configure a textured brush tip

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 

brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.
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 4. In the Brush Tip l ist, select the desired brush tip. If you want to create your own brush tip, see 

Adding a Brush Tip on page 83.

 5. Use the Maximum Size slider to set the maximum size of your brush tip.

 6. 
NOTE 

W hen drawing w ith a mouse, your brush is always at its maximum size. W hen drawing 

w ith a pressure-sensitive pen tablet, your brush's size w ill range between its minimum 

and maximum size, depending on the amount of pressure you put on the pen when 

drawing. 

 7. You can control the size properties by clicking on the arrow button on right and the Size Properties 

dialog box w ill appear.
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 8. 
NOTE 

Please see Brush Properties Dialog and to learn more about Brush Tool options, see 

Brush Tool Properties. 

 9. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 

brush when using your pen w ith very little pressure. The minimum size is set to a percentage of 

your brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen 

to affect the brush size, set this parameter to 100%.

 10. If you want your brush to keep the same size relative to the camera frame when the camera zooms 

in on or zooms out of the scene, check the Proportional to Camera option.

 11. 
NOTE 

The "Size Proportional to Camera" option has been moved to the new Size Properties 

w indow. 

 12. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 

tip vertically all the while preserving its horizontal size.

 13. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.

 14. If you want your brush tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to 

set how much the tip should stretch. The tip w ill stretch by the percentage you set, in the direction 

in which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.

 15. If you want your brush tip to rotate w ith the angle of your pen tip use the Angle Function. You can 

select one of the follow ing options:
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 l Constant: The static orientation of the brush tip expressed in degrees.

 l Heading: The orientation of the brush tip is determined by the direction in which the stroke 

is drawn. It changes dynamically as the stroke is drawn.

 l Azimuth: W hen the pen is tilted, it uses the direction in which the pen eraser is facing.

 l Twist (if supported by pen): It uses the tw ist angle of the stylus and is only available w ith 

W acom Art Pen.

 16. Use the Hardness slider to set how much of the outer part of your brush tip should fade to 

transparency. If you set it to 100 %, the brush w ill be completely solid. If you set it to 0 %, the 

brush w ill only be opaque in its center, and w ill gradually become transparent towards its edges. 

 17. Use the Spacing slider to set how much distance you must drag your brush before Harmony prints 

the brush tip onto your canvas, relative to your brush's size. The default setting is 7%, which 

produces a relatively realistic brush stroke-like result. If this setting is too low, your brush strokes 

might feel too thick and opaque. If this setting is too high, your strokes w ill look like the brush tip 

has been stamped repeatedly over your canvas instead of dragged on it.

 18. If you want the size of your brush tip to vary each time it's printed on your canvas, set the Random 

Size setting to any value above 0 %.

 19. If you want the angle of your brush tip to be random each time the tip is printed on your canvas, set 

the Random Angle setting to any value above 0 °.

 20. If you want the spacing between each instance of the brush tip to be random, set the Random 

Spacing setting to any value above 0 %.

 21. If you want the spacing between each instance of the brush tip to be random, set the Random 

Spacing setting to any value above 0 %.

 22. In the  Drawing view, start drawing to test your brush settings.

NOTE 

It is also possible to use textures when drawing w ith the Pencil tool. Those textures follow the 

angle of your pencil l ines, which may create more interesting results depending on your desired 

drawing style. For more information, see About Pencil Line Textures on page 134.
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Adding a Brush Tip

In the Brush or Eraser Properties dialog, you w ill find a set of default brush tips which are bundled w ith 

Harmony, but you can also create your own brush tips, then export your collection or import an existing set. 

To make your own brush tip, you must first create an image file containing the brush tip, either in Harmony or 

in a third party software, like Adobe Photoshop, then import it into Harmony. A brush tip must be a greyscale 

image. Colors in brush tips are not acknowledged by Harmony, as brush tips only use the colour you are 

painting w ith in Harmony. Your brush tip should also not contain transparency, as Harmony determines the 

brush tip's transparency based on its black, white and grey levels. Its black parts w ill appear 100% opaque, its 

white parts w ill appear 100% transparent, and its grey parts w ill appear semitransparent. 

You can import brush tips in any image format supported by Harmony. It is recommended to create brush tips 

in a resolution ranging from 100 x 100 pixels to 400 x 400 pixels.

Brush tips are shared between the brush tool and the eraser tool. Like paper textures and brush presets, paper 

textures are saved in your preferences. You can also export your brush tips into an .xml file, and import them 

on a different workstation, allow ing you to share your brush tips between the different people collaborating 

on your project.

How to add a brush tip

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 

brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 

eraser tool. 

 4. Do one of the follow ing:

 l Click on the Paper Texture menu icon  and select Add.

 l Click the Add Paper Texture button.
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 5. In the file browser w indow, navigate to the location of your texture image file and select it.

 6. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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Renaming Brush Tips

You can rename your bitmap brush tips to keep your list organized. 

How to rename a brush tip

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 

brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 

eraser tool. 

 4. Select the brush tip you w ish to rename. 

 5. Click on the Paper Texture menu icon  and select Rename.

 6. In the Rename  dialog box that appears, type in the new name of the brush tip. 

 7. Click OK.
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Deleting Brush Tips 

You can delete unnecessary brush tips to keep your list organized. 

How to delete a brush tip

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 

brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 

eraser tool. 

 4. Select the brush tip you w ish to delete.

 5. Do one of the follow ing:

 l Click on the Paper Texture menu icon  and select Delete.

 l Click the Delete  button.

NOTE 

You can delete any brush tip in the Paper Texture library, including the default paper textures, 

except for the three solid brush tips: Circle, Diamond and Square. Also, brush tips w ill not get 

deleted if they are used in a brush preset. 
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Exporting Brush Tips

You can export brush tips to share, backup or install on a new computer. 

How to export brush tips

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 

brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 

eraser tool. 

 4. Click on the Paper Texture menu icon  and select Export.

The Export Tips and Textures dialog opens. This dialog allows you to export both your textured 

brush tips and your paper textures.

 5. By default, both your brush tips and your paper textures are selected for export. If you only w ish to 

export your brush tips, uncheck the Select Paper Textures option.

 6. Click Export.
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 7. In the Export Textures w indow that appears, browse to a location where you want save the .xml 

file and give it a name.

 8. Click Save.
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Importing Brush Tips

You can import Harmony brush tips you previously exported.

How to import brush tips

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 

brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 

eraser tool. 

 4. Click on the Paper Texture menu icon  and select Import.

 5. In the browser w indow that appears, navigate to and select the .xml file in which you exported 

your brush tips.

 6. Click Open.

In the Import Tips and Textures dialog box appears.
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 7. If the selected .xml file also contains paper textures, they w ill be selected for import along w ith 

the brush tips by default. If you w ish to only import the paper textures, uncheck the Select Paper 

Textures option.

 8. Click Import.

The imported brush  tips appear in the Brush Tips Library. 
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Changing the Brush Tip Display

You can display your preset list as thumbnails or a list.

How to change the Brush Tips thumbnail display

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 

brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 

eraser tool. 

 1. Click on the Brush Tips menu icon .

 2. Select one of the follow ing options:

 l Small Thumbnail: Displays brush tips in a grid of small thumbnails.

 l Large Thumbnail: Displays brush tips in a grid of large thumbnails w ith their name. 

The default view setting.

 l List View: Displays brush tips in a list, w ith their name on the left and their texture on 

the right of each row. 
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Configuring Smoothing for a Textured Brush

T-ANIMPA-002-003

If you are drawing on a vector layer, the Brush Properties dialog w ill have a Smoothing tab, which allows to 

configure how Harmony automatically smooths your brush strokes. If you are drawing on a bitmap layer, this 

topic is not applicable, as bitmap layers do not support automatic smoothing. 

How to configure a textured brush's smoothing

 1. In the Brush Properties dialog, open the Smoothing tab.

 2. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 

your  stroke's direction, curves and corners. A higher setting w ill prevent your line from being shaky, 

but is liable to reduce your drawing precision and to round sharp corners into curves.

 3. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on 

your stroke's contour. A higher setting w ill round sharp corners and reduce the amount of control 

points for the resulting vector shape. 

 4. In the  Drawing view, start drawing to test your brush settings.
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Configuring Antialiasing and Transparency for a Textured Brush

A textured brush can be either antialiased or not antialiased. W ithout antialiasing, your brush strokes w ill only 

create fully opaque artwork. W ith antialiasing enabled, you also have the option to set the flow and opacity of 

your brush, allow ing you to simulate the effect of inks and paints w ith various consistencies. 

You can now control the Flow/Opacity properties w ith input options such as Pressure, Tilt and Speed. You can 

use a combination of multiple inputs to control a single property.

NOTE 

If you are working on a vector layer, make sure the Brush Type option in the Tip tab is set to 

Textured Vector Brush to enable the textured brush options.

How to configure a brush's antialiasing and transparency settings

 1. In the Brush Properties dialog, open the Transparency tab.

 2. If you want your brush to have antialiasing or transparency, enable the Antialiasing option. 

NOTE 

If the Antialiasing option is disabled, all Transparency settings w ill be disabled, and 

your brush w ill only create fully opaque artwork.

 3. Use the Maximum Flow slider to set the consistency of your brush strokes. A lower flow will make 

your stroke more transparent towards the extremities and more opaque in its center, whereas a 

higher flow will make your stroke consistently opaque.
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 4. If you are using a pressure-sensitive pen tablet, use the Minimum Flow slider to set the percentage 

of the maximum flow that you want your brush to use when using your pen w ith very little 

pressure. If you don't want the pressure on your pen to affect the flow, set this parameter to 100%.

 5. Use the Maximum Opacity slider to set the maximum opacity of your brush strokes. 

 6. If you are using a pressure-sensitive pen tablet, use the Minimum Opacity slider to set the 

percentage of the maximum opacity that you want your brush to use when using your pen w ith 

very little pressure. If you don't want the pressure on your pen to affect the opacity, set this 

parameter to 100%.

NOTE 

You can control the Flow/Opacity properties by clicking on the arrow button on the 

right and Flow/Opacity Properties Dialog box w ill appear.

NOTE 

Please see Brush Properties Dialog and to learn more about Brush Tool option, see 

Brush Tool Properties.

 7. If you want the Flow of your brush to be randomized, set the Random Flow setting to any value 

over 0 %.

 8. If you want the Opacity of your brush to be randomized, set the Random Opacity setting to any 

value over 0 %.

 9. In the  Drawing view, start drawing to test your brush settings.
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Configuring a Textured Brush with a Dual Tip

Textured brushes can also have a dual tip. A dual tip is a secondary tip that can be blended into your primary 

tip in various blend modes, w ith its own full set of tip settings. 

NOTE 

If you are working on a vector layer, make sure the Brush Type option in the Tip tab is set to 

Textured Vector Brush to enable the textured brush options.

How to configure a brush with a dual tip

 1. In the Brush Properties dialog, click on the Dual Tip tab.

 2. Check the check box in the Dual Tip tab to enable the Dual Tip functionality.
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 3. In the Brush Tip l ist, select the desired brush tip. If you want to create your own brush tip, see 

Adding a Brush Tip on page 83.

 4. In the Blend Mode drop-down list, select the algorithm with which you want your secondary tip to 

blend into your primary tip:

 l Multiply w ill draw the least opaque pixel of either brush tip, making more spaced out, 

inconsistent strokes. 

 l Color Dodge w ill add the opacity of the pixels in both brush tips, making more 

opaque strokes. 

 l Combine w ill draw the most opaque pixel of either brush tip, combining the tip 

shapes w ithout increasing their opacity.

 5. Use the Maximum Size slider to set the maximum size of your brush tip.

 6. 
NOTE 

W hen drawing w ith a mouse, your brush is always at its maximum size. W hen drawing 

w ith a pressure-sensitive pen tablet, your brush's size w ill range between its minimum 

and maximum size, depending on the amount of pressure you put on the pen when 

drawing. 

 7. You can control the size properties by clicking on the arrow button on right and the Size Properties 

dialog box w ill appear.

 8. 
NOTE 

Please see Brush Properties Dialog and to learn more about Brush Tool options, see 

Brush Tool Properties. 

 9. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 

brush when using your pen w ith very little pressure. The minimum size is set to a percentage of 

your brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen 

to affect the brush size, set this parameter to 100%.

 10. If you want your brush to keep the same size relative to the camera frame when the camera zooms 

in on or zooms out of the scene, check the Proportional to Camera option.
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 11. 
NOTE 

The "Size Proportional to Camera" option has been moved to the new Size Properties 

w indow. 

 12. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 

tip vertically all the while preserving its horizontal size.

 13. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.

 14. If you want your brush tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to 

set how much the tip should stretch. The tip w ill stretch by the percentage you set, in the direction 

in which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.

 15. If you want your brush tip to rotate w ith the angle of your pen tip use the Angle Function. You can 

select one of the follow ing options:

 l Constant: The static orientation of the brush tip expressed in degrees.

 l Heading: The orientation of the brush tip is determined by the direction in which the stroke 

is drawn. It changes dynamically as the stroke is drawn.

 l Azimuth: W hen the pen is tilted, it uses the direction in which the pen eraser is facing.

 l Twist (if supported by pen): It uses the tw ist angle of the stylus and is only available w ith 

W acom Art Pen.

 16. Use the Hardness slider to set how much of the outer part of your brush tip should fade to 

transparency. If you set it to 100 %, the brush w ill be completely solid. If you set it to 0 %, the 

brush w ill only be opaque in its center, and w ill gradually become transparent towards its edges. 
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 17. Use the Spacing slider to set how much distance you must drag your brush before Harmony prints 

the brush tip onto your canvas, relative to your brush's size. The default setting is 7%, which 

produces a relatively realistic brush stroke-like result. If this setting is too low, your brush strokes 

might feel too thick and opaque. If this setting is too high, your strokes w ill look like the brush tip 

has been stamped repeatedly over your canvas instead of dragged on it.

 18. If you want the size of your brush tip to vary each time it's printed on your canvas, set the Random 

Size setting to any value above 0 %.

 19. If you want the angle of your brush tip to be random each time the tip is printed on your canvas, set 

the Random Angle setting to any value above 0 °.

 20. If you want the spacing between each instance of the brush tip to be random, set the Random 

Spacing setting to any value above 0 %.

 21. If you want the spacing between each instance of the brush tip to be random, set the Random 

Spacing setting to any value above 0 %.

 22. In the  Drawing view, start drawing to test your brush settings.
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Configuring a Brush with a Paper Texture

T-ANIMPA-002-004

Paper textures are bitmap textures that you can apply to your brush strokes as you draw. They act as 

transparency filters that are tiled over your brush strokes to make them look grainy, as if you were drawing on 

a rough paper surface. W hile Harmony comes bundled w ith preset paper textures, it is also possible to create 

and use your own paper textures. 

How to configure a brush with a paper texture

 1. In the Brush Properties dialog, click on the Paper Texture tab.

 2. Check the check box in the Paper Texture tab to enable paper textures.
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 3. In the paper texture list, select the desired paper texture. If you w ish to create your own paper 

texture, see Adding a Paper Texture on page 102.

 4. Using the Texture Scale slider, select the scaling factor at which to scale the paper texture when 

applying it to your brush strokes.

 5. If you want your brush strokes to get more opaque as you drag your brush or when you draw over 

them, enable the Additive option.

 6. If you want the paper texture to always be aligned to the same grid regardless of where you draw 

your strokes, enable the Aligned option. Otherwise, your paper textures w ill be positioned relative 

to where you start your drawing stroke, and if you draw two strokes one over the other, their paper 

textures w ill clash w ith each other.

 7. In the  Drawing view, start drawing to test your brush settings.
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NOTE 

It is also possible to use textures when drawing w ith the Pencil tool. However, those textures 

follow the shape of the line instead of til ing over your strokes. For more information, see About 

Pencil Line Textures on page 134.
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Adding a Paper Texture

In the Brush Properties dialog, you w ill find a set of default paper textures which are bundled w ith Harmony, 

but you can also create your own paper textures, then export your collection or import an existing set. 

To make your own paper texture, you must first create an image file containing the texture, either in Harmony 

or in a third party software, like Adobe Photoshop, then import it into Harmony. A paper texture must be a 

greyscale image. Colors in paper textures are not acknowledged by Harmony, as paper textures are applied 

onto the colour you are painting w ith in Harmony. Your texture should also not contain transparency, as 

Harmony determines the texture's transparency based on its black, white and grey levels. W hen drawing w ith 

a paper texture, its black parts w ill appear 100% opaque, its white parts w ill appear 100% transparents, and 

its grey parts w ill appear semitransparent. 

You can import brush tips in any image format supported by Harmony. It is recommended to create paper 

textures in a resolution ranging from 100 x 100 pixels to 400 x 400 pixels.

Like brush tips and brush presets, paper textures are saved in your preferences. You can also export your 

paper textures into an .xml file, and import them on a different workstation, allow ing you to share your 

textures between the different people collaborating on your project.

How to add a paper texture

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 

brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.
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 1. In the Brush Properties dialog, do one of the follow ing:

 l From the Paper Texture menu, select Add.

 l Click the Add Paper Texture button.

 2. In the browser w indow that appears, navigate to where you saved your texture file.

 3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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Renaming a Paper Texture

You can rename your paper textures to keep your list organized. 

How to rename a paper texture

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 

brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 6. Select the texture you want to rename.

 7. Click on the Paper Texture menu icon  and select Rename.
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 8. In the Rename Texture dialog box that appears, type in the new name for the texture. 

 9. Click OK.
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Deleting Paper Textures

You can delete unnecessary paper textures from your preset list. 

How to delete a paper texture

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 

brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 1. Select the texture you want to delete.

 2. Do one of the follow ing:

 l Click on the Paper Texture menu icon  and select Delete.

 l Click the Delete  button.
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NOTE 

You can delete any paper texture in the Paper Texture library, including the 

default paper textures, as long as no brush preset is using that paper texture. 
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Exporting Paper Textures

You can export paper textures into an .xml file which w ill contain their name and bitmap texture. This can be 

useful if you w ish to back up or share your paper textures. 

How to export paper textures

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 

brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 6. Click on the Paper Texture menu icon  and select Export.

The Export Tips and Textures dialog opens. This dialog allows you to export both your textured 

brush tips and your paper textures.
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 7. By default, both your brush tips and your paper textures are selected for export. If you only w ish to 

export your paper textures, uncheck the Select Brush Tips option.

 8. Click on the Export button.

 9. In the Export Textures dialog that appears, browse to a location where you would like to save the 

.xml file, then type in the desired file name.

 10. Click Save.
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Importing Paper Textures

You can import paper texture presets you previously exported from Harmony. 

How to import paper textures

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 

brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 6. Click on the Paper Texture menu icon  and select Import.

 7. In the browser w indow that appears, navigate to and select  the .xml file in which you exported 

your paper textures. 

 8. Click Open.

In the Import Tips and Textures dialog box appears.
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 9. If the selected .xml file also contains brush tips, they w ill be selected for import along w ith the 

paper textures by default. If you only w ish to import the paper textures, uncheck the Select Brush 

Tips option.

 10. Click Import.

The imported paper textures w ill appear in the Paper Texture Library. 
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Changing the Paper Texture Display

You can change the way the paper textures are displayed in the paper textures list of the Brush Properties 

dialog.

How to change the Paper Texture thumbnail display

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 

brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 1. Click on the Paper Texture menu icon .

 2. Select one of the follow ing options:

 l Small Thumbnail: Displays paper textures in a grid of small thumbnails.

 l Large Thumbnail: Displays paper textures in a grid of large thumbnails w ith their 

names. The default view setting. 

 l List View: Displays paper textures in a list, w ith their name on the left and their 

texture on the right of each row. 
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Setting the Textured Brush Resolution

An important thing to take in consideration when drawing w ith textured brushes is that, contrary to solid 

vector brushes, textured brushes store their texture in bitmap data, which is stored in individual pixels. This 

implies that, where solid vector artwork can be scaled and zoomed in w ithout issue, textured brush strokes are 

resolution dependent, and are liable to lose quality and appear pixelated if they are enlarged or zoomed in. 

By default, textured brush strokes have a pixel density of 100%. At this density, when your scene is not 

zoomed in and your artwork is not scaled up, each pixel in the textured brush strokes corresponds to one pixel 

in the rendered image. Scaling it up or zooming in w ill require Harmony to render several pixels using the 

same pixel from the brush stroke's texture, making the artwork lose quality.

Hence, before you start drawing using textured brushes, it is important to consider if you w ill need to zoom 

onto or scale up your artwork, and set the pixel density accordingly. For example, if you intend to scale your 

bitmap artwork up to 300%, or if you intend to zoom in from 12 fields to 4 fields, you should make sure the 

pixel density for your textured brush strokes is of at least 300% before you start drawing. 

You can specify the pixel density for textured brushes at the scene level or at the drawing level:

 l Setting the pixel density at the scene level w ill make newly created drawings have the specified pixel 

density, but it w ill not change the pixel density of existing textured artwork.

 l Setting the pixel density  at the drawing level w ill allow you to change the pixel density of existing 

drawings, but w ill not affect the pixel density of drawings created afterward.

NOTE 

In Paint, you cannot set the  pixel density of textured brush strokes for the whole scene, since Paint 

is only able to modify individual drawings. You can only change the pixel density of textured brush 

strokes in existing drawings. If you need to make this change for the whole scene, open the scene 

in Harmony and refer to the Harmony documentation. 

NOTE 

If you are drawing on a bitmap layer, you must set the pixel density and canvas size for bitmap 

artwork instead—see Setting the Bitmap Resolution on page 305.

How to change the pixel density for textured brushes strokes in existing drawings

 1. In the Drawing Thumbnails panel, select the drawing for which you want to change the textured 

brush stroke resolution. 

 2. From the top menu, select Drawing > Change Vector Drawing Brush Resolution.

The Change Vector Drawing Brush Textures Resolution dialog opens.
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 3. In the Pixel Density field, enter the desired percentage of pixel density. If you intend to scale or 

zoom in on your artwork, make sure your pixel density is set to be at least the factor by which your 

artwork w ill scaled or zoomed on. For example, if you intend to scale your artwork by 300%, you 

need to set the pixel density to at least 300%. If you intend to zoom in on your artwork from 12 

fields to 6 fields, you need to set the pixel density to at least 200%. If you intend to do both, you 

need to set the pixel density to at least 600%, as the camera zoom and scaling factor w ill have a 

multiplying effect on the apparent scaling of your artwork.

 4. If you want the specified pixel density to be applied on the existing textured brush strokes in the 

drawing, check the Apply to Existing Strokes option.

 5. If you want the specified pixel density to be applied to all the drawing's art layers (ie: Line Art, 

Colour Art and, if enabled, Overlay Art and Underlay Art), check the Apply to All Art Layers 

option. Otherwise, only the currently active art layer w ill be affected.

 6. If you want the specified pixel density to be applied to all drawings in the active layer, check the 

Apply to All Drawings option. Otherwise, only the current drawing w ill be affected. 

 7. Click OK.

From now on, new brush strokes w ill be in the selected drawing w ill be in the specified pixel 

density.

NOTE 

This does not change the default pixel density for the scene. New drawings w ill stil l be 

created w ith the scene's default  pixel density.
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About Brush Presets

Setting up your brush to perfectly reproduce the desired art style can require a lot of tweaking as well as trial 

and error. Once you have found the correct settings for your brush, you w ill want to reuse it throughout your 

project for consistency. You can do that by creating and using brush presets.

Harmony comes preloaded w ith many brush presets which you can select from the Tool Properties view. It is 

also possible to create your own brush presets by configuring your brush, then saving it as a preset. 

Like brush tips and paper textures, brush presets are saved in your preferences. You can also export your 

brush presets into an .xml file, and import them on a different workstation, allow ing you to share your brush 

presets between the different people collaborating on your project.

NOTES 

 l Brush presets are not to be confused w ith brush tips and paper textures. A brush tip is one of 

the properties of a brush. A brush preset contains all of the properties for a given brush. 

However, both can be exported, imported and managed similarly. 

 l Brush presets for vector layers and for bitmap layers are separate. A brush preset created 

while working on a vector layer cannot be used when working on a bitmap layer, and vice 

versa. 
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Creating a Brush Preset

You can create your own custom brush presets by configuring your brush, then adding it as a preset.

How to create a brush preset

 1. Make sure the current drawing layer is vector if you w ish to create a vector brush preset, or bitmap 

if you w ish to create a bitmap brush preset—see About Vector and Bitmap Layers.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. Click on the Arrow button to open the Brush Properties dialog.

 4. Configure your brush to be exactly how you w ish to use it in the future—see Creating a Solid  Brush 

or Creating a Textured Brush.

 5. Do one of the follow ing:

 l From the Brush Properties dialog, click on the New Brush Preset  button in the top-

right corner. 

 l In the Tool Properties view, click the New Brush Preset  button.

 l In the Tool Properties view, open the Brush Presets  menu  and select New Brush 

Preset.

 6. In the New Preset w indow, type a name for your new brush preset.

Your new brush preset is added to the end of the list of brush presets.
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Creating a Stamp

You can create a stamp by drawing the artwork for your stamp, then selecting it and creating a stamp preset. 

How to create a stamp 

 1. In the Drawing view, draw the artwork w ith which you want to create a stamp.

 2. Do one of the follow ing:

 l If you want to create a stamp with all the artwork in the drawing, select this drawing in the 

Thumbnails list. 

 l If you want to create a stamp with part of the artwork in the drawing, select the Select  

tool in the Tools toolbar, then select the artwork that you want to use to create a stamp—

see—Selecting, Repositioning and Transforming Artwork on page 227.

 3. In the Tools toolbar, select the  Stamp  tool.

 4. In the Tool Properties view, click on the New Preset  button.

 5. In the New Preset dialog, type the desired name for your new stamp.

 6. Click OK.

A stamp containing the selected artwork is added to the Presets list for the Stamp tool. You can 
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now draw with the Stamp tool using this stamp.

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 

project. The artwork in your stamps w ill be saved in your preferences.
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Selecting a Brush Preset

Harmony provides you w ith default brush presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset from the Presets list.
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Updating a Brush Preset

If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in 

the Tool Properties view, then updating your preset w ith your brush current's parameters.

How to update a brush preset

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 1. In the Tool Properties view, select the Brush Preset you w ish to update.

 2. Click on the Arrow button to open the Brush Properties view.

 3. Configure your brush to be exactly how you w ish to use it in the future—see Creating a Solid  Brush 

or Creating a Textured Brush.

 4. Click on the Update Brush Preset  button  in the upper-right corner of the Brush Properties 

dialog. 
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Renaming a Brush Preset

To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset to rename. 

 3. Open the Brush Preset menu  and select Rename Brush. 

 4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset

You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select the brush preset you want to delete.

 3. Do one of the follow ing:

 l Click the Delete Brush  button.

 l Open the Brush Preset menu  and select Delete Brush.
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Exporting Brush Presets

You can export brush presets into an .xml file which w ill contain all of your brush's settings. This can be 

useful if you w ish to back up or share your brush presets.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 

Pencil and Eraser tools. 

 3. By default, the presets for all your tools w ill be selected for export. If you only w ish to export 

presets for specific tools, uncheck Select/Deselect All and select the tools for which you want to 

export the presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 

file and enter its file name.

 6. Click Save.
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Importing Brush Presets

You can import brush presets that you previously exported from Harmony. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser w indow that appears, navigate to and select the .xml file in which you exported 

your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file w ill be selected for import. If you only w ish 

to import presets for specific tools, uncheck Select/Deselect All and select the tools for which you 

want to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles w ill appear in the Presets list.
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Changing the Brush Preset Display

You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the follow ing options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails w ith a preview of 

their tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, w ith their name and a 

preview of their tip.

 l Stroke View: Displays presets in a list, w ith their name and a preview of a stroke 

done w ith each preset. 
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Adjusting Texture Opacity

An advantage of using textured vector brushes on vector layers is that you can adjust their opacity afterward. 

Using the Adjust Line Texture Opacity dialog, you can adjust the opacity levels between the most opaque and 

the most transparent pixels in your textures. 

How to adjust the line texture opacity

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the  Drawing view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line Texture Opacity dialog box opens. 

 3. Do one of the follow ing:

 l Drag the upper slider towards the right to increase the transparency of the more 

transparent pixels.

 l Drag the lower slider towards the left to increase the opacity of the more opaque 

pixels. 

 4. If you want to apply the changes to all drawings exposed on the layer, enable the Apply to All 

Drawings option.

 5. Click OK.
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About the Pencil Tool

T-HFND-004-004

The Pencil  tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation. 

The pencil creates a central vector shape. Pencil l ines support pressure sensitivity and texture.

The Brush  and Pencil  tools are used for drawing and sketching. Both  tools support pressure sensitivity, 

allow ing you to create lines w ith variable thickness. The Brush tool produces contour vector lines. The Pencil 

and shape tools produce central vector lines. This means that a pencil l ine’s control points (used to deform its 

shape) are located along the length of the central spine, while the Brush line’s control points are located along 

the contour.

 l If you draw with the Brush tool and want to modify the thickness variation, use the Contour Editor  tool. 

 l If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor  tool. 

 l You can also convert a brush zone into a pencil l ine w ith the Brush Stroke to Pencil Line   option.

If you sketch a drawing using a semitransparent colour to get a paper- like feel, you should use the Brush tool, 

as it produces a more realistic and natural feel. Transparent pencil l ines may not display the way you want 

when they overlap:
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The pencil l ine is more appropriate for the final l ine of your clean drawings. Also, if you're drawing for digital 

animation and intend to use the Auto-Patch effect to connect the parts of your character model, you should 

use pencil l ines for the Auto-Patch effect to work as expected.

NOTE 

To learn more about the Pencil tool options, see the Reference Guide.
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Drawing with the Pencil Tool

T-HFND-004-004A

Using the Pencil tool, you can draw vector pencil l ines which can be easily tweaked and reshaped as needed.

How to draw with the Pencil tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Colour view, click a colour swatch to select a colour.

 4. In the Drawing view, start drawing.
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TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 

key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 

this w ith the eraser tip of your pen w ill adjust the size of the Eraser tool, regardless of 

which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you w ill draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 

w ill lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 

its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you w ill draw a 

straight horizontal or vertical l ine.

 l If you press and hold the Ctrl (W indows/Linux) or ⌘  (macOS) key while drawing, your 

drawing stroke w ill turn into a closed shape.

 l If you press and hold Alt before drawing a stroke, and start drawing near existing artwork, 

the start of your drawing stroke w ill connect to that artwork.

 l If you press and hold Alt while drawing a stroke, and end your drawing stroke near 

existing artwork, the end of that drawing stroke w ill connect to that artwork.
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Creating a Pencil

T-LAY-001-001

You can configure a pencil 's size, how much Harmony should automatically smooth your pencil l ines when 

drawing, the shape of the tips and corners of your pencil l ine as well as its texture.

How to modify the pencil settings

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 

Pencil Properties dialog.

The Pencil Properties dialog opens.

 3. Use the Maximum Size slider to set the maximum size of your pencil l ine.

 4. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 

pencil when using your pen w ith very little pressure. The minimum size is set to a percentage of 

your pencil 's maximum size, which is 20% by default. If you don't want the pressure on your pen to 

affect the pencil size, set this parameter to 100%.

 5. If you want your pencil to keep the same size relative to the camera frame when the camera zooms 

in on or zooms out of the scene, check the Proportional to Camera option.

 6. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 

your  pencil stroke's centreline. A higher setting w ill prevent your line from being shaky, but is liable 

to reduce your drawing precision and to round sharp corners into curves.
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 7. If you are using a pressure-sensitive tablet, use the Contour Smoothing slider to set the amount of 

smoothing Harmony should perform on your pencil stroke's contour. A higher setting w ill 

smoothen the variations in your pencil l ine's thickness and reduce its amount of control points, but 

may affect the precision of the variations in line thickness.

NOTE 

This parameter is only useful if you are drawing w ith a pressure-sensitive tablet, as it 

only affects the control points for the thickness of your pencil l ine. W hen drawing w ith 

a mouse, the pencil l ine has a uniform thickness, and hence its contour only has control 

points at its extremiities. 

 8. Click on the Shape pop-up buttons to select whether you want the Start and End of your pencil 

l ines to be Round or Flat, and whether you want the points and corners where pencil l ines Join to 

be Round, Mitre-shaped or Beveled.

 9. Click on the Texture tab.

 10. If you want your pencil l ine to have a texture, select the desired pencil l ine texture from the pencil 

l ine texture library. Otherwise, select None. For more information on pencil l ine textures, see About 

Pencil Line Textures on page 134.
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 11. Either close or set aside the Pencil Properties dialog.

 12. In the  Drawing view, start drawing to test your pencil settings.
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About Pencil Line Textures

Just like the Brush tool, the Pencil tool also supports textures. However, there are important differences 

between the way brush textures and pencil textures work.

For one thing, a pencil l ine texture is applied w ith regard to the w idth and direction of the pencil l ines. For 

example, if you draw a spiral w ith a dash texture, the dashes w ill follow the curves of the spiral, and if you 

draw a thicker line w ith the same texture, the dashes w ill be both longer and thicker.

Like colours, pencil textures are stored in special palettes in your scene. W hile brush textures are stored in 

your artwork as bitmap data, pencil textures are stored in your artwork by linking the pencil l ine w ith its pencil 

texture in the palette. This means that if you scale or tweak your pencil l ine, the pencil texture w ill be updated 

based on the new line's shape and the original texture. This also means that you are able to change the pencil 

texture of an existing pencil l ine or to apply a texture to a pencil l ine that does not already have one.

Pencil l ine textures can also be used w ith the Line, Rectangle, Ellipse and Polyline tools, as those tools also 

draw pencil l ines. 
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Drawing with Pencil Textures

You can draw a textured pencil l ine by selecting the pencil texture, then drawing. 

There are two ways to select a pencil texture. In the Colour view, you can select a pencil texture palette, then 

one of its pencil texture swatches, as you would do to select a colour, or you can select a pencil texture from 

the current pencil texture palette in the Pencil Properties dialog.

Your pencil texture w ill be combined w ith the selected colour to make a textured colour line.

NOTE 

You can also draw with textured pencil l ines w ith the Line, Rectangle and Ellipse tools. 

How to draw with a textured pencil line using the Colour view

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Colour view, select the colour w ith which you w ish to draw. 

 3. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 

texture palettes.

 4. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 5. In the swatch list, select the pencil texture you want to use. 

 6. In the Drawing view, draw a pencil l ine.
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How to draw with a textured pencil line using the Pencil Properties dialog

 1. In the Colour view, select the colour w ith which you w ish to draw. 

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 

Pencil Properties dialog.

 4. In the Pencil Properties dialog, click on the Texture tab.

NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 

currently selected pencil texture palette in the Colour view.

 5. In the Texture library, select a texture for the pencil.

 6. In the Drawing view, draw a pencil l ine.
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Applying Texture to a Pencil Line

You can apply a pencil texture to an existing pencil l ine. You can also change a textured pencil l ine's texture by 

follow ing the same steps.

NOTE 

You can also apply pencil l ine textures on artwork created w ith the Line, Rectangle, Ellipse and 

Polyline tools. 

How to apply a pencil line texture to an existing pencil line using the Colour view

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Drawing view, select a pencil l ine.

 3. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 

texture palettes.

 4. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 5. In the swatch list, select the pencil texture you want to apply to your pencil l ine.
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 6. The selected pencil l ine now uses the selected pencil l ine texture.

How to apply a pencil line texture to an existing pencil line using the Tool Properties 
view

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Drawing view, select a pencil l ine.

 3. In the Tool Properties view, scroll down to the pencil texture library panel.

NOTE 

The texture library in the Tool Properties view lists the same pencil textures as the 

ones in the currently selected pencil texture palette in the Colour view.

 4. Select the pencil texture you w ish to apply.
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 5. The selected pencil l ine now uses the selected pencil l ine texture.
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Editing a Pencil Line's Texture

There are two kinds of modification you can make to a pencil l ine's texture. Using the Edit Gradient/Texture 

tool, you can scale the texture by its length and thickness, as well as offset its starting position. Using the 

Pencil Editor tool, you can change the texture's symmetry relative to the line's center.

How to scale the length or thickness of a pencil line texture.

 1. In the Tools toolbar, select the Edit Gradient/Texture  tool or press Shift + F3.

 2. Click on the pencil l ine you want to edit. 

 3. Drag one of the square-shaped handles to scale the texture's length, thickness, or both 

simultaneously.

How to offset a pencil line's texture.

 1. In the Tools toolbar, select the Edit Gradient/Texture tool or press Shift + F3.

 2. Click on the pencil l ine you want to edit. 

 3. Drag the triangle-shaped handle to offset the texture. 
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How to change a pencil line's symmetry

 1. In the Tools toolbar, select the Pencil Editor  tool or press 8.

 2. Click on the pencil l ine you want to edit. 

 3. Drag one of the line's control points closer or further away from the center line to change the size of 

its half of the texture.
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Picking a Pencil Texture from Artwork

Just like you can pick a colour from your artwork using the  Colour Eyedropper tool, you can pick a pencil 

texture from your artwork and make it the current pencil texture using the  Pencil Texture Eyedropper tool. 

How to pick a pencil texture from your artwork

 1. In the Tools toolbar, double-click or long-click on the  Colour Eyedropper button. Then, in the 

pop-up menu, select  Pencil Texture Eyedropper.

 2. In the Drawing view, click on a pencil l ine that uses the pencil texture you want to select.

The pencil texture used by that line w ill become the active pencil texture, and pencil l ines you draw 

from that point w ill use that texture.
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Disabling Pencil Line Textures

After you selected a pencil l ine texture, if you w ish to resume drawing solid pencil l ines again, you can do so 

using either the Colour view or the Pencil Properties dialog. 

How to resume drawing with a solid pencil line using the Colour view

 1. Click on the Show Pencil Texture Palettes  button to display your pencil texture palettes.

 2. Over the swatch list, click on the No Texture button.

From now on, the pencil l ines you draw will not have a texture.

How to resume drawing with a solid pencil line Pencil Properties dialog

 1. In the Colour view, select the colour w ith which you w ish to draw. 

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 

Pencil Properties dialog.

 4. In the Pencil Properties dialog, click on the Texture tab.

 5. In the pencil textures library, select None.
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From now on, the pencil l ines you draw will not have a texture.
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Pencil Texture Palettes

Just like colours used by your drawings, pencil textures are stored in pencil texture swatches, which are stored 

in pencil texture palettes. Because pencil l ines drawn with pencil textures are linked to the pencil texture in 

their pencil texture palette, pencil textures can be shared and updated just as easily as colours in your 

Harmony project.

For example, you can create the texture palette for your character in your character model's scene, then make 

scenes that include this character link to that character's pencil texture palette, as you can w ith their colour 

palette, to make sure both their colour and line textures are the same throughout your project. For more 

information, see About Advanced Palette Management on page 331.

Just as w ith colour palettes, you can update a swatch in a pencil texture palette w ith a different texture, and 

the pencil l ines that are drawn with this texture w ill update w ith the new texture. This means your pencil 

textures can always be subjected to revisions. 

W hen you create a new scene, your palette list w ill be preloaded w ith a default colour palette and a default 

texture palette, the latter which is contains some sample pencil textures. If you w ish, you can use these 

textures for your project, you can build on this palette and add new textures as needed, or you can create your 

own texture palette, loaded w ith only your custom textures, to use across your project. You can configure 

Harmony to create new scenes w ith your own custom pencil texture palette.

NOTE 

The follow ing topics w ill introduce you to the basics of creating and using pencil texture palettes. 

For more information on creating and managing swatches and palettes, see About Colour 

Swatches on page 311 and About Palettes on page 329.
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Creating a Pencil Texture Palette

Creating a pencil texture palette allows you to manage your own pencil textures as you w ish. You can create 

separate pencil texture palettes for different characters, props and backgrounds as needed, and share them 

among the people collaborating on your project like you would w ith colour palettes.

Creating a pencil texture palette is as simple as creating a colour palette. W hen creating a palette, you have 

the option to create it as a colour or a pencil texture palette. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 

one of the follow ing:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 

checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

      How to create a pencil texture palette (Basic palette list mode)

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 

texture palettes.

 2. Do one of the follow ing:

 l In the Colour View, click the New Palette  button over the palette list.

 l From the Colour view menu, select Palettes  > New

The Create Palette dialog box opens.

 3. In the Create Palette dialog, enter the new palette's name. Make sure your palette name contains 

information to be easy to identify, such as the name of the character and information about the type 

of setting for this palette, if any.

 4. In the Palette Type drop-down, select Pencil Texture.

 5. Click OK.

The palette appears in the drawing element’s palette list.
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How to create a pencil texture palette (Advanced palette list mode)

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 

texture palettes.

 2. If you want to add the palette to an element's palette list, select a drawing from the element for 

which you want to create a palette in the Timeline, Xsheet or Camera view. 

 3. Do one of the follow ing:

 l In the Colour View, click the New Palette  button over the palette list.

 l From the Colour view menu, select Palettes  > New

The Palette Browser dialog box opens. 

 4. In the Palette Location panel, select the location where you want to store the palette file. If you are 

using Harmony Server, you can store the palette in any environment, job, scene or element on your 

database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 

or inside its provisional job or environment. For more information, see About Palette Storage 

Locations on page 334.

 5. In the New Palette Name field, enter the name for the new palette. The palette list above this field 

lists the palettes that already exist in the selected location. Make sure you enter a name that is not 

already used by another palette. 

 6. In the Palette Type drop-down, select Pencil Texture.
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 7. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 

List, or to the Element Palette List of the currently selected element. Note that in the latter case, 

the palette w ill only be usable by the element. For more information, see About Scene and Element 

Palette Lists on page 333.

 8. Click OK. 

The new palette appears in the palette list.
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Adding a Pencil Line Texture

You can create your own pencil textures by first creating an image file containing the texture, either in 

Harmony or in a third party software, then importing it to your pencil texture palette. 

A pencil texture must be created w ith transparency, as Harmony w ill only use the image's transparency 

channel to determine how to apply the texture to your pencil l ines. Hence, pencil textures can be in image 

format that are supported by Harmony and which supports transparency: .png, .tga, .tif, .psd, .psb and

 .sgi.

A pencil texture can be of any size, but the bigger the image resolution, the thicker the lines you can draw with 

it w ithout seeing pixels. The pencil texture w ill follow your pencil l ines on their horizontal axis, l ike so:

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to add a pencil line texture using the Colour view

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 

texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 
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 3. Do one of the follow ing:

 l Click on the Add Texture  button.

 l Right-click on the swatch list and select New Texture.

 l Open the Colour view menu  and select Colours > New Texture.

 4. In the file browser dialog, navigate to the location of your texture image file and select it.

 5. Click Open.

The texture is added to your pencil texture palette.

You can start drawing w ith your new pencil texture.

How to add a pencil line texture using the Pencil Properties dialog

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 

Pencil Properties dialog.

 3. In the Pencil Properties dialog, click on the Texture tab.
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NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 

currently selected pencil texture palette in the Colour view.

 4. Do one of the follow ing:

 l Click on the New Texture  button over the pencil textures list.

 l Open the Brush menu  and select New Texture.

 5. In the file browser dialog, navigate to the location of your texture image file and select it.

 6. Click Open.

The texture is added to your pencil texture palette.

 7. In the pencil texture library, select the new pencil texture.
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You can start drawing w ith your new pencil texture.
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Renaming Pencil Line Textures

You can rename pencil textures from the Colour view or from the Pencil Properties dialog box. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to rename a pencil line texture using the Colour view

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 

texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 3. In the swatch list, double-click on the name of the texture you w ish to rename.

 4. Enter the texture's name, then click outside of the text input field to confirm the new name.

153



How to rename a pencil line texture using the Pencil Properties dialog

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 

Pencil Properties dialog.

 3. In the Pencil Properties dialog, click on the Texture tab.

NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 

currently selected pencil texture palette in the Colour view.

 4. In the pencil texture library, select the texture you w ish to rename.

 5. Open the Brush menu  and select Rename Texture.

The Rename Texture dialog box opens.
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 6. In the Name field, type in the desired name for your texture

 7. Click OK.

You can start drawing w ith your new pencil texture.
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Deleting Pencil Line Textures

You can delete pencil texture palettes that you do not need. 

NOTE 

You should not delete any pencil texture that is used in your project, as pencil l ines using a deleted 

pencil texture w ill become solid pencil l ines.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to rename a pencil line texture using the Colour view

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 

texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 3. In the swatch list, select the pencil texture you w ish to delete.
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 4. Do one of the follow ing:

 l Click on the Remove Colour button.

 l Right-click on the pencil texture and select Delete.

 l Open the Colour view menu and select Colours > Delete.

 l Press Del (W indows/Linux) or Backspace (macOS).

The selected pencil texture is removed from the pencil texture palette.

How to rename a pencil line texture using the Pencil Properties dialog

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 

Pencil Properties dialog.

 3. In the Pencil Properties dialog, click on the Texture tab.

NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 

currently selected pencil texture palette in the Colour view.

 4. In the pencil texture library, select the texture you w ish to delete.
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 5. Do one of the follow ing:

 l Click on the Delete Texture  button.

 l Open the Brush menu  and select Delete Texture.

The selected pencil texture is removed from the pencil texture palette.
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Replacing a Pencil Texture

Just like you can edit a colour swatch and simultaneously update all the drawings using the colour swatch 

w ith this new colour, you can replace an existing pencil texture w ith a different texture, and update all pencil 

l ines that use this texture w ith the new texture.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to replace an existing pencil line texture

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 

texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 3. In the swatch list, select the pencil texture that you want to replace.

 4. Do one of the follow ing:
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 l Right-click on the pencil texture and select Edit Texture.

 l Open the Colour view menu and select Colours > Edit Texture.

 5. In the file browser dialog, navigate to the location of your new texture image file and select it.

 6. Click Open.

The selected texture is replaced w ith the new texture file. It is also renamed based on the new 

texture's file name. 

Any pencil l ine that was drawn with the older pencil texture w ill now be drawn with the new 

pencil texture.
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Setting the Default Pencil Texture Palette

You can make a pencil texture palette into the default texture palette which is added to every new scene you 

create. This w ill be saved in your user preferences. 

How to add a texture to your preferences

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 

texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 3. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 4. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 

Pencil Properties dialog.

 5. In the Pencil Properties dialog, click on the Texture tab.
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NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 

currently selected pencil texture palette in the Colour view.

 6. Do one of the follow ing:

 l Click on the Use as Default Texture Palette  button.

 l Open the Brush menu  and select Use as Default Texture Palette.

From now on, new scenes created in Harmony w ill have the selected pencil texture palette as their 

default pencil texture palette.
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Recovering the Default Pencil Texture Palette

If you have made modifications on the default pencil texture palette in your scene that you w ish to undo, you 

can easily re-import the default pencil texture palette back into your scene as a new pencil texture palette.

How to recover the default pencil texture palette into your scene

 1. Click on the Show Pencil Texture Palettes  button to display your pencil texture palettes.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 

Pencil Properties dialog.

 4. In the Pencil Properties dialog, click on the Texture tab.

NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 

currently selected pencil texture palette in the Colour view.

 5. Click on the Reload Default Texture Palette  button.

A copy of the default pencil texture palette is added to the scene's pencil texture palette list.
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Converting a Colour Palette to a Pencil Texture Palette

As of Harmony 15, each palette is set to either be a colour palette, or a texture palette, and both palette types 

are kept in separate lists. However, in Harmony 14 and prior versions, pencil texture palettes were just regular 

palettes, which you had to temporarily set at your pencil texture palette in order to use it for pencil l ine 

textures. 

Because of this, if you open a scene created in Harmony 14 or prior, and which contains pencil texture palettes, 

Harmony 15 w ill not be able to tell which palettes are colour palettes and which ones are pencil texture 

palettes. Hence, you must manually move your pencil texture palettes to the pencil texture palette list before 

you can use them for pencil l ine textures. 

The only exception to this is if a scene created in a prior version of Harmony has a pencil texture palette named 

penstyle_opacity. Because this was the default name for pencil texture palettes in older versions of 

Harmony, Harmony 15 w ill automatically convert those palettes to pencil texture palettes.

NOTE 

Converting a colour palette to a pencil texture palette is permanent. You cannot convert a pencil 

texture palette to a colour palette. However, you w ill be prompted to confirm before making the 

conversion, and the conversion can be undone w ith the Undo command. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to convert a colour palette to a pencil texture palette

 1. In the palette list of the Colour view, select the palette you want to convert to a pencil texture 

palette.

 2. Do one of the follow ing:

 l Right-click on the palette and select Change to Pencil Texture.

 l Open the Colour view menu  and select Palettes > Change to Pencil Texture.
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The palette w ill be moved from the colour palette list to the pencil texture palette list. To 

see it, click on the Show Pencil Texture Palettes  button or the Show All Palettes  

button.
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About Pencil Presets

Setting up your pencil to perfectly reproduce the desired art style can require a lot of tweaking as well as trial 

and error. Once you have found the correct settings for your pencil, you w ill want to reuse it throughout your 

project for consistency. You can do that by creating and using pencil presets.

Harmony comes preloaded w ith a few pencil presets which you can select from the Tool Properties view. It is 

also possible to create your own pencil presets by configuring your pencil, then saving it as a preset. 

Pencil presets are saved in your preferences. You can also export your brush presets into an .xml file, and 

import them on a different workstation, allow ing you to share your brush presets between the different people 

collaborating on your project.
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Creating Pencil Presets

T-LAY-002-002

You can create your own custom pencil presets.  

Regular pencil presets allow you to set the size and smoothing of the line or shape.  As you draw, the thickness 

of the line varies according the amount of pressure you apply w ith a pen and tablet.

NOTE 

To learn more about the Pencil tool options, see the Reference guide .

How to create a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 

Pencil Properties dialog.

 3. Configure your brush to be exactly how you w ish to use it in the future—see Creating a Pencil on 

page 131.

 4. In the Tool Properties view, click the New Brush  button.

The New Preset dialog box opens.

 5. Type in a name for your new pencil thickness stencil and click OK.

 6. Start drawing in the Drawing view. 
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Creating Pencil Thickness Presets

T-LAY-002-003

Thickness stencils that are indicated w ith this  icon  are also set w ith specific properties, but disregards the 

pressure of your pen and tablet. The line thickness varies. You can access thickness stencils from the list of 

presets on the Tool Properties view or create your own. 

How to create a pencil thickness stencil

 1. In the Tools toolbar, select the Select  tool.

 2. In the Camera view, select the pencil l ine or shape from which you want to take the style.

 3. In the Tool Properties view, click the New Thickness Stencil  button.

A new thickness stencil is added to the end of the list in the Presets menu.

 4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Drawing view 

to apply the thickness stencil you created.

168

Harmony 22 Paint User Guide                          



Chapter 3: Drawing

Selecting a Pencil Preset

T-ANIMPA-010-001

A pencil preset is a pencil w ith specific properties. You can work w ith regular pencil presets and thickness 

stencils.

How to select a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, use the Presets menu to select a pencil preset.

 3. In the Drawing view, draw your pencil l ine or shape.
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Applying a Pencil Preset

T-ANIMPA-010-004

You can apply a pencil preset on already drawn pencil l ines using the Select tool.

How to apply a thickness stencil to a pencil line or shape

 1. In the Tools toolbar, select the Select  tool.

 2. In the Drawing view, select the pencil l ine or shape on which you want to apply a style.

 3. In the Tool Properties view, select the style you want to apply from the Presets list.

The style you selected is applied to your selection.

170

Harmony 22 Paint User Guide                          



Chapter 3: Drawing

Renaming Pencil Presets

You can rename your pencil presets to keep your list organized.

How to rename a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Presets menu, select the thickness stencil or preset you want to rename.

 3. From the Brush menu , select Rename Brush.

The Rename Preset dialog box opens.

 4. In the Name field, type in the new name.

 5. Click OK.
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Deleting Pencil Presets

You can delete unnecessary presets from your list. 

How to delete a thickness stencil or pencil preset

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Presets menu, select the thickness stencil or preset to delete.

 3. Click the Delete Preset  button.
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Exporting Pencil Presets

T-ANIMPA-010-005

You can export your pencil presets to either backup, share or install on a different computer.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 

Pencil and Eraser tools. 

 3. By default, the presets for all your tools w ill be selected for export. If you only w ish to export 

presets for specific tools, uncheck Select/Deselect All and select the tools for which you want to 

export the presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 

file and enter its file name.

 6. Click Save.
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Importing Pencil Presets 

T-ANIMPA-010-006

You can import Harmony pencil presets that you previously exported. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser w indow that appears, navigate to and select the .xml file in which you exported 

your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file w ill be selected for import. If you only w ish 

to import presets for specific tools, uncheck Select/Deselect All and select the tools for which you 

want to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles w ill appear in the Presets list.
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Changing the Pencil Preset Display

You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the follow ing options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails w ith a preview of 

their tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, w ith their name and a 

preview of their tip.

 l Stroke View: Displays presets in a list, w ith their name and a preview of a stroke 

done w ith each preset. 
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About Shape Tools

T-HFND-004-006

In Harmony, you can use the shape tools to draw circles, lines and rectangles. You can also easily reshape a 

square or circle into a much more complex drawing—see About the Contour Editor Tool on page 247  and 

About the Pencil Editor Tool on page 258. 

The available shape tools are: 

 l Line tool

 l Rectangle tool

 l Ellipse tool

 l Polyline tool 

NOTES 

 l The shape tools use the same pencil presets as the Pencil tool. To learn how to create, delete, 

rename, import and export presets, see About the Pencil Tool on page 127.  

 l To learn more about the shape tool parameters, see the Reference guide . 
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Creating Lines, Rectangles and Ellipses  with the Shape Drawing Tools

T-HFND-004-006A

You can use the Line, Rectangle, or Ellipse tool to draw shape w ithout having to trace them. You can also use 

these tools to draw perfect circles and squares. 

How to draw with the Line tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Line  tool.

 3. In the DrawingCamera view, click and hold where you want the line to start, then move the mouse 

cursor where you want the line to end. 

 l If you want to snap the angle of your line to the nearest 15° angle, hold the Shift key.

 l If you want to snap the end of your line to the nearest shape, hold the Alt key.

 l If you want to draw a curved line, hold Ctrl (W indows/Linux) or ⌘  (macOS). The line w ill 

end where your mouse cursor currently is, and moving the mouse cursor w ill pull the line's 

curve towards it. 

TIP 

You can use the Contour Editor  tool to tweak the shape of your line—see About the 

Contour Editor Tool on page 247.                 

How to draw with the Rectangle or Ellipse tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Rectangle  or Ellipse  tool.

 3. To automatically fil l the shape, in the Tool Properties view, enable the Auto Fill  option.
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 4. In the DrawingCamera view, click and hold where you want one of the corners of your shape to be, 

then move the mouse cursor where you want the opposing corner of the shape to be.

TIPS 

 l To draw a perfect square or circle (w ith equal w idth and height), hold the Shift key. 

You can also enable the  Draw Square or  Draw Circle option in the Tool 

Properties view.

 l To draw the rectangle or ellipse from its centre instead of its corner, hold the Alt 

key.
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Drawing Curved Lines with the Line Tool

The Line tool allows you to draw curved lines very quickly by drawing a straight line, then defining its curve 

right after.

There are three ways to do this:

 l In Straight Line Mode, the default mode of the Line tool, you can press and hold the Ctrl 

(W indows/Linux) or ⌘  (macOS) key while drawing a line to define a simple curve for it.

 l In Curved Line Mode, after drawing a line, you are prompted to move the mouse cursor or tablet pen 

and click once to define the line’s curve.

 l In S Curve Line Mode, after drawing a line, you are prompted to click once to position the line’s first 

Bezier handle, and then once more to position its second Bezier handle.

NOTE 

You can also define the curve of an existing line using the Contour Editor tool—see About the 

Contour Editor Tool on page 247.

How to draw a curved line in Straight Line Mode

 1. In the Tools toolbar, select the  Line tool.

 2. In the Tool Properties view, click  Straight Line Mode.

 3. In the Drawing view, click and drag to draw a line, but don’t release the mouse button or tablet pen.

 4. W hile holding the mouse button or tablet pen down, press and hold the Ctrl (W indows/Linux) or 

⌘  (macOS) key.

 5. Move the mouse or pen in the general direction of the desired curve.

 6. W hen the curve looks as intended, release the mouse button or pen to preserve it.
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How to draw a curved line in Curve Line Mode

 1. In the Tools toolbar, select the  Line tool.

 2. In the Tool Properties view, click  Curve Line Mode.

 3. In the Drawing view, click and drag to draw a line, then release the mouse button or tablet pen.

 4. Move the mouse or pen in the general direction of the desired curve.

 5. W hen the curve looks as intended, click to preserve it.

How to draw a curved line in S Curve Line Mode

 1. In the Tools toolbar, select the  Line tool.

 2. In the Tool Properties view, click  Curve Line Mode.

 3. In the Drawing view, click and drag to draw a line, then release the mouse button or tablet pen.
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 4. Move the mouse cursor or pen where you want the curve’s first Bezier handle (from the start of the 

line) to be positioned, then click.

 5. Move the mouse cursor or pen where you want the curve’s second Bezier handle (from the end of 

the line) to be positioned, then click.
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Creating Vector Shapes with the Polyline Tool

You can use the Polyline tool to draw complex segmented lines or curved lines by creating each point 

constituting the line. 

How to draw with the Polyline tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Polyline   tool or press Alt + _.

 3. In the Drawing view, do one of the follow ing:

 l Click to create a point w ith no Bezier handles.

 l Click and drag to create a point and its Bezier handles in the same stroke.

TIP 

W hile dragging to create a Bezier handle, you can:

 l Hold the Alt key to only change the angle of the outer handle, and leave the inner 

handle at its current angle.

 l Hold the Shift key to lock the angle of the handle at every 15 degrees. 

 4. Click or click and drag somewhere else to create the second point in your line. A line w ill be drawn 

between the first point and the second point. 

 5. Repeat the previous step until your line is complete. 

 6. W hile holding Ctrl (W indows/Linux) or ⌘  (macOS), click anywhere in the drawing space to release 

the Polyline tool from the line you've been building. You can then start building a new line. 

 7. If you want to make adjustments to the line you created, you can use the Contour Editor  tool—

see Reshaping a Shape, Pencil Line or Stroke w ith the Contour Editor Tool on page 248.
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About the Stamp Tool

The Stamp tool allows you to create stamps out of drawings in your projects, then stamp those drawings over 

your artwork. You can click on your artwork to apply your stamp once, or draw a stroke w ith the Stamp tool, as 

you would w ith the Brush or Pencil tool, to apply the stamp repeatedly along the stroke.

A stamp can contain one or several drawings. W hen a stamp is made of multiple drawings, it w ill cycle 

through each one of its drawings each time it is stamped onto your artwork. Hence, when you draw a stroke 

w ith a multi-drawing stamp, you w ill see the stamp tool cycle through the sequence of drawings as you draw 

the stroke. The way the drawings in a multi-drawing stamp are cycled through can even be customized. 

Among other settings, you can make it cycle backward, stamp random drawings or even stamp only a specific 

drawing in the sequence. 

Other than being able to easily re-use drawings, The Stamp tool can be used to streamline drawing if you 

need to draw something that requires a lot of repetitive detail, such as starry skies, grass, weather conditions 

or particle-type effects. For example, a stamp made of a few different drawings of a blade of grass can be 

used to draw a grass line by drawing a few strokes of that stamp over the same horizontal l ine. The ability to 

randomize the size, angle and distance of the stamping can give the result of using this procedure a more 

natural look. 
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NOTES 

 l To learn more about the Stamp tool properties, see the Reference Guide

 l The Stamp tool replaces the Dynamic Brush option of the Brush tool in Harmony 15.0 and 

earlier.
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Creating a Stamp

You can create a stamp by drawing the artwork for your stamp, then selecting it and creating a stamp preset. 

How to create a stamp 

 1. In the Drawing view, draw the artwork w ith which you want to create a stamp.

 2. Do one of the follow ing:

 l If you want to create a stamp with all the artwork in the drawing, select this drawing in the 

Thumbnails list. 

 l If you want to create a stamp with part of the artwork in the drawing, select the Select  

tool in the Tools toolbar, then select the artwork that you want to use to create a stamp—

see—Selecting, Repositioning and Transforming Artwork on page 227.

 3. In the Tools toolbar, select the  Stamp  tool.

 4. In the Tool Properties view, click on the New Preset  button.

 5. In the New Preset dialog, type the desired name for your new stamp.

 6. Click OK.

A stamp containing the selected artwork is added to the Presets list for the Stamp tool. You can 
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now draw with the Stamp tool using this stamp.

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 

project. The artwork in your stamps w ill be saved in your preferences.
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Creating a Multi-Drawing Stamp

You can create a stamp containing a series of drawings. All you need to do is create each drawing you want to 

add to your stamp in a separate drawing cell, then create a stamp with those drawings selected. The resulting 

stamp will cycle through each one of those drawings as you use it. 

In order to create a stamp using multiple drawings, your drawings must either be in a single contiguous 

horizontal or vertical sequence.

NOTE 

You cannot create a multi-drawing stamp in Paint. To follow these steps, you must open your 

scene in Harmony.

How to create a multi-drawing stamp 

 1. In the Timeline view, select an empty cell. 

 2. In the Camera or Drawing view, create the first drawing you want to have in the drawing sequence 

of your stamp.
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 3. In the Timeline view, select the cell right after the current cell.

 4. In the Camera or Drawing view, create the second drawing you want to have in the drawing 

sequence of your stamp.

 5. Repeat these previous steps until you have all the drawings you want to have in your stamp, in one 

continuous sequence of drawings, in the same layer.

NOTE 

You can also create a stamp using drawings in a sequence of layers, provided that 

those drawings are all in the same frame and that those layers are adjacent to each 

other. The drawings in the stamp will be ordered from top to bottom.

 6. In the Timeline view, select all the cells containing the drawings you want to add to your stamp. 
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TIPS 

 l You can click and drag over a sequence of drawing cells to select them.

 l You can also select multiple cells by clicking on the first cell you want to select, 

holding shift, then clicking on the last cell you want to select. 

 7. In the Tools toolbar, select the   Stamp  tool.

 8. In the Tool Properties view, click on  New Preset.

The New Preset dialog appears.

 9. In the New Preset dialog, type the desired name for your new stamp.

 10. Click OK.

A multi-drawing stamp containing the artwork in all the selected layers is added to the Presets list. 

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 

project. The artwork in your stamps w ill be saved in your preferences.
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Configuring a Stamp

W hen drawing a stroke w ith the stamp tool, the way the stamp is applied in terms of size, angle, spacing can 

be customized.

How to configure the size, pressure sensitivity, roundness, angle and spacing of a 
stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 

Properties   button.

The Stamp Properties dialog opens.

 3. If you want to adjust the size of the stamp, change the Maximum Scale setting until you obtain the 

desired size.
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NOTE 

The Scale of a stamp is relative to the original size of the drawing used to create the 

stamp. At 100% scale, the stamp added to your artwork w ill be the same size as its 

original drawing. 

 4. If you're using a pressure-sensitive pen tablet and want the size of the stamp to depend on the 

amount of pressure you put on your pen, reduce the Minimum Scale setting. 

 5. If you would like to fl ip the stamp horizontally, click on the two-ended horizontal arrow  over the 

stamp thumbnail. If you would like to fl ip the stamp vertically, click on the two-ended vertical 

arrow left of the stamp thumbnails. 

 6. If your stamp is round or square, and you would like it to appear flat or squished, reduce the 

Roundness parameter. This w ill scale down the stamp vertically.

 7. If you want your stamp to be added to your artwork at an angle, change the Angle parameter. This 

setting rotates the stamp counterclockwise, on a 360 degrees scale.

 8. If you want to change the amount of space between each stamp when you draw a stroke w ith the 

Stamp tool, adjust the Spacing parameter. 

 9. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.
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NOTE 

You can use the Stamp tool w ith the currently selected settings w ithout updating your 

preset. 

You can randomize the size, angle and spacing of the stamp. This w ill make the Stamp tool apply a randomly 

picked value to these parameters every time it applies a stamp to your artwork.

How to randomize the size, angle and spacing of a stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 

Properties   button.

The Stamp Properties dialog opens.

 3. If you want the size of the stamp to be randomized every time the stamp is added to your artwork, 

decrease the Minimum Scale setting, then increase the Random Size setting.
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NOTE 

The Random Size setting makes the size of each stamp vary randomly between its 

Minimum Scale and Maximum Scale. The higher the Random Size is, the closer to its 

Minimum Scale the random size can be.

 4. If you want the angle of your stamp to be randomized every time the stamp is added to your 

artwork, increase the Random Angle setting.

 5. If you want the spacing of your stamp to be randomized every time the stamp is added to your 

artwork, increase the Random Spacing setting.

 6. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.

NOTE 

You can use the Stamp tool w ith the currently selected settings w ithout updating your 

preset. 

You can make a multi-drawing stamp cycle through its sequence of drawings in several different ways. You 

can also randomize the cycle, or disable it so that it only stamps the drawing of your choice. 

How to change the way a multi-drawing stamp cycles through its drawings

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 

Properties   button.

193



The Stamp Properties dialog opens.

 1. In the Cycle drop-down, select the desired cycling method:

 l Forward: Starts by applying the first drawing in the sequence, then the next one, and so on 

until it reaches the last drawing in the sequence, then cycles back to the first one.

 l Reverse: Starts by applying the last drawing in the sequence, then the previous one, and so 

on until it reaches the first drawing in the sequence, then cycles back to the last one.

 l Forward->Reverse: Starts by cycling forward through the sequence until it reaches the last 

drawing, then cycles backward to the first drawing, and so on.

 l Reverse->Forward: Starts by cycling backward through the sequence until it reaches the 

first drawing, then cycles back to the last drawing, and so on.
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 l Random: Applies a random drawing in the sequence each time the stamp is applied. 

 l Hold: Applies a single one of the drawings in the sequence over and over again. 

 2. If you selected the Hold option, select which one of the stamps in the sequence you w ish to stamp 

onto your artwork by changing the Stamp setting in the Tool Properties view. For example, if you 

only want to stamp the second drawing in the sequence, set the Stamp setting to 2.

 3. If you want the cycle to restart at the beginning of each one of your drawing strokes, enable the 

Reset Cycle for Each Stroke option.

 4. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.

NOTE 

You can use the Stamp tool w ith the currently selected settings w ithout updating your 

preset. 
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Updating a Stamp

A stamp in your Presets list does not only contain its drawings, but also its properties. If you have made any 

changes to the properties of your stamp, and w ish for those properties to be set automatically whenever you 

use that stamp, you can update the stamp. This w ill save the current properties of the stamp into its preset. 

Once that is done, the current properties of the stamp will be loaded the next time you select it from the 

Presets list, even after you close and reopen the project. 

NOTE 

You cannot update the drawings in a stamp. You can only update its parameters. If you need to use 

different drawings for your stamp, you must create a new stamp—see Creating a Stamp on page 

185 and Creating a Multi-Drawing Stamp on page 187.

How to update a stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 

Properties   button.
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The Stamp Properties dialog opens.

 3. In the Stamp Properties dialog, adjust the settings of your stamp as desired—see Configuring a 

Stamp on page 190.

 4. In the top-right corner of the Stamp Properties dialog, click on the Update Preset  button.

The selected stamp properties w ill be loaded whenever you select this stamp, even after you close 

and reopen your project. 
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Drawing with the Stamp Tool

Once you have created a stamp, you can start drawing w ith it. You can either stamp it into your artwork once at 

a time, or draw strokes w ith the tool, making it apply the stamp repeatedly onto your artwork along your 

strokes.

How to draw with the Stamp tool

 1. In the Layer panel of the Stage or Camera view or the Layers view, select the layer on which you 

want to apply the stamp.                     

 2. In the Tools toolbar, select the  Stamp  tool.

 3. In the Tool Properties view, select a stamp from the Presets list—see Creating a Stamp on page 

185 and Creating a Multi-Drawing Stamp on page 187.

 4. Move the mouse cursor over the Stage or Camera view. You w ill see the stamp under your mouse 

cursor as it w ill be applied into your artwork. If you want to adjust the size in which it w ill be 

applied, adjust the Maximum Scale setting in the Tool Properties view.

 5. By default, your stamp will be applied at an even size, angle and distance. Also, if your stamp is a 

multi-drawing stamp, it w ill cycle through its drawings in their original order. If you want your 

stamp to be applied w ith different parameters, see Configuring a Stamp.

 6. In the Drawing view, do one of the follow ing:

 l To apply the stamp once, simply click where you want to apply it.

 l To draw a stroke along which the stamp is applied multiple times, simply draw a stroke w ith 

the tool as you would w ith the Brush or Pencil tool. 
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TIPS 

 l If your stamp has multiple drawings in it, you can select which drawings to stamp by using 

the Stamp slider in the Tool Properties view. You can also cycle through the stamp's 

drawings by pressing the Left Arrow and Right Arrow keys. 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 

key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 

this w ith the eraser tip of your pen w ill adjust the size of the Eraser tool, regardless of 

which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you w ill draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 

w ill lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 

its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you w ill draw a 

straight horizontal or vertical l ine.

 l If you press and hold the Ctrl (W indows/Linux) or ⌘  (macOS) key while drawing, your 

drawing stroke w ill turn into a closed shape.
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Renaming Stamps

You can rename stamps you have created to make them easier to identify in the Presets list. 

How to rename a stamp.

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Presets list of the Tool Properties view, select the stamp you want to rename.

 3. Open the Brush Presets  menu, then select Rename Brush.

 4. In the Rename Brush dialog, enter the new name for your stamp.

 5. Click OK.

The stamp's new name updates in the Presets list. 
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Deleting Stamps

You can delete stamps you no longer need from the Presets list. 

How to delete a stamp.

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Presets list of the Tool Properties view, select the stamp you want to delete.

 3. Click on the Delete Brush  button just above the Presets list.

The stamp is removed from the Presets list. 
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Exporting Stamps

You can export stamps you have created to keep a backup of them, or to import them for use in another 

project.

How to export stamps

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Tool Properties view, open the Brush Preset   menu and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 

Pencil, Eraser and Stamp tools. 

 3. By default, the presets for all your tools w ill be selected for export. If you only w ish to export your 

stamps, uncheck Select/Deselect All, then check Stamp.

 4. Click on Export.

A save dialog appears.

 5. Browse to the location where you want to save the .xml file that w ill contain your presets.

 6. Enter the desired file name for your presets file. 

 7. Click on Save.
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Importing Stamps

You can import stamps you have exported from another project into your current project, allow ing you to reuse 

them between projects or to restore backups of your stamps. 

How to import stamps

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

An Open File dialog appears.

 3. In the browser w indow that appears, navigate to and select the .xml file in which you exported 

your stamps

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file w ill be selected for import. If you only w ish 

to import the stamps from this file, uncheck Select/Deselect All and check Stamps.

 6. Click on Import.

The imported stamps w ill be added to the Presets list in the Tool Properties view. 
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Changing The W ay Stamps Are Displayed

By default, your stamps are listed in the Tool Properties dialog as strokes. You can also preview them as big 

thumbnails if you want to be able to pick them without scrolling, or as small thumbnails if you have a lot. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the follow ing options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails w ith a preview of 

their tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, w ith their name and a 

preview of their tip.

 l Stroke View: Displays presets in a list, w ith their name and a preview of a stroke 

done w ith each preset. 
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Stamp Tool Modes

W hen you select the Stamp tool, its properties are displayed in the Tool Properties view.

 Draw Behind Mode

W hen enabled, your drawing strokes w ill be added underneath the existing artwork instead of over it.

NOTE 

Your stroke w ill  appear over your artwork as you draw it, until you release the mouse cursor or 

tablet pen. 
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About the Stroke Tool

T-HFND-004-013

There are two different ways to draw invisible lines, using the Pencil tool or Stroke tool.

Using the Pencil tool, you can draw as strokes only, meaning that the line w ill be invisible. This can be useful 

for drawing tones and highlights directly on the character.

The Stroke  tool draws invisible lines only. You cannot add thickness to the line. Unlike the Close Gap tool that 

creates a short, straight line between two points, the stroke line w ill stay exactly where you draw it. This tool 

can be useful for closing a zone in a particular way or creating some hard shadows or highlight areas.

Sometimes, it may be difficult to see strokes, especially if your colours are similar to the blue stroke colour. In 

Harmony, you can display the strokes in washed-out colours so the invisible lines stand out.

NOTE 

To learn more about the Stroke tool parameters, see the Reference guide .
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Creating Invisible Lines with the Stroke Tool 

T-HFND-004-013A

You can draw invisible lines w ith the Stroke tool. These lines can be used to delimit or close off colour areas 

when you colour drawing w ith the Paint tool.

How to draw invisible lines with the Stroke tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. Make sure strokes are visible in your drawing space by doing one of the follow ing:

 l In the top menu, select View > Show Strokes

 l Press K. 

 3. Select the Stroke tool by doing one of the follow ing:

 l In the Tools toolbar, double-click on Paint. In its drop-down menu, select the  Stroke tool

 l Press Alt + V.

 4. In the  Drawing view, start drawing.

TIPS 

 l If you press and hold the Shift key before or while you are drawing, your stroke w ill 

be a straight line until you stop drawing or release the Shift key.

 l If you press and hold the Shift and the Alt keys before drawing, your stroke w ill be a 

straight line in an angle that is a multiple of 15 degrees. 

 l If you press and hold the Ctrl (W indows/Linux) or ⌘  (macOS) key while drawing, 

your stroke w ill be a closed shape.

 l If you press and hold Alt before drawing a stroke, and you start your stroke near 

another stroke, the start of your stroke w ill connect to the other stroke. Likewise, if 

you press and hold the Alt key and end your stroke near another stroke, the end of 

the stroke w ill connect to that stroke.
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NOTE 

If the Show Strokes option is not enabled, the follow ing message w ill appear after you 

draw a stroke. To remedy this, refer to step 2. 

Authors

Marie-Eve Chartrand

        Christopher Diaz

chrisdiazart.com
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About the Eraser Tool

T-HFND-004-010

Using the Eraser tool, you can erase portions of your drawing by drawing strokes over it. 

Just like the Brush tool, the Eraser tool is pressure-sensitive, allow ing you to erase w ith more precision if you 

are using a pen tablet.

It is a good idea to create and save erasers w ith precise sizes and parameters in order to save time when 

drawing and designing. Harmony provides you w ith a variety of default eraser styles and allows you to create 

and save your own eraser presets. 

Just like the Brush tool, you can use the Eraser tool on both vector and bitmap layers, and you can configure an 

eraser to have a solid or textured tip, to have automatic smoothing, a dual tip and a paper texture.

NOTE 

To learn more about each individual parameter of the Eraser tool, see the Reference Guide.

209



Erasing 

T-HFND-004-010A

Using the Eraser tool, you can erase portions of your drawing by drawing strokes over it.

How to erase with the Eraser tool

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Eraser  tool or press Alt + E.

 3. In the Presets list of the Tool Properties view, select a brush preset to use. 

NOTE 

To learn how to create an Eraser preset, see Creating a Solid  Eraser on page 211 and 

Creating a Textured Eraser on page 215.

 4. Set the Maximum Size to the desired Eraser size. 

NOTE 

If you are drawing w ith a mouse, your strokes w ill always be at their maximum size. If 

you are using a pressure-sensitive tablet, your strokes w ill vary in size depending on 

the pressure of your pen, ranging between 25% to 100% of the maximum size. 

 5. In the  Drawinga view, start erasing.

TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 

key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 

this w ith the eraser tip of your pen w ill adjust the size of the Eraser tool, regardless of 

which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you w ill draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 

w ill lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 

its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you w ill draw a 

straight horizontal or vertical l ine.
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Creating a Solid  Eraser

W hen using the Eraser tool on a vector layer, you can use either solid vector erasers or textured vector erasers. 

By default, your eraser w ill be a solid vector eraser. A solid vector eraser cuts out the shape of its stroke from 

your vector artwork.

A solid vector eraser's tip can be shaped like a circle, a diamond or a square, and can be configured to have a 

specific size, aspect ratio and angle. Also, solid vector erasers can be automatically smoothed by Harmony as 

you draw.

If you are erasing on a bitmap layer, you can only use textured erasers, although you can configured a textured 

eraser to appear solid.

How to create                                      a solid vector eraser                 

 1. In the Tools toolbar, select the Eraser tool or press  Alt + B. 

 2. In the Tool Properties view,  click the arrow button to open the Eraser Properties view.

The Eraser Properties dialog opens.
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 3. In the Eraser Type dropdown list, select Solid Vector.

 4. In the brush tip list, select either Circle, Diamond or Square. 

 5. Use the Maximum Size slider to set the maximum size of your eraser tip, in pixels. 

NOTE 

W hen drawing w ith a mouse, your eraser is always at its maximum size. W hen 

drawing w ith a pressure-sensitive pen tablet, your eraser's size w ill range between its 

minimum and maximum size, depending on the amount of pressure you put on the pen 

when drawing. 

 6. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the percentage 

of your eraser tip's maximum size your eraser should be when you use your pen w ith very little 

pressure. If you don't want the pressure on your pen to affect the eraser size, set this parameter to 

100%.
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 7. If you want your eraser tip to have uneven dimensions, use the Roundness slider to shrink the 

eraser tip vertically all the while preserving its horizontal size.

 8. If you want your eraser tip to be at an angle, use the Angle slider to rotate your brush tip.

 9. If you want your eraser tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to 

set how much the tip should stretch. The tip w ill stretch by the percentage you set, in the direction 

in which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.

 10. If you want your eraser ip to rotate when you rotate your pen, check the Use Pen Rotation check 

box. 

NOTE 

This option only works if your tablet and your pen support pen rotation. 

 11. Click on the Smoothing tab.

 12. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 

your  stroke's direction, curves and corners. A higher setting w ill prevent your line from being shaky, 

but is liable to reduce your drawing precision and to round sharp corners into curves.
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 13. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on 

your stroke's contour. A higher setting w ill round sharp corners and reduce the amount of control 

points for the resulting vector shape. 

 14. Either close or set aside the Eraser Properties dialog.

 15. In the  Drawing view, start erasing to test your eraser settings.
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Creating a Textured Eraser

A textured eraser can have the same settings as a textured brush: It can have a bitmap tip of any shape, can be 

hard or soft, semi-transparent, combine two tips and be applied w ith a paper texture effect.

W hen working on a bitmap layer, the eraser tool is always textured, whereas when working on vector layers, 

erasers are solid vector by default. A solid vector eraser merely cuts out the shape of the eraser stroke from 

the vector artwork, whereas a textured vector eraser makes the artwork's bitmap texture more opaque or fully 

invisible, depending on its intensity, then cuts out some of the vector artwork that the eraser made fully 

invisible. 

A textured eraser works like a reverse textured brush: It makes the pixels in a brush stroke's texture more—or 

completely—transparent, depending on the eraser's intensity. This effect can only be obtained by using a 

textured eraser on a textured brush stroke. If you use a textured eraser on solid vector shapes or on pencil 

l ines, the eraser w ill act like a solid vector eraser, that is, it w ill merely cut out the shape of the stroke from the 

artwork. This is because solid vector shapes and pencil l ines don't have a bitmap texture, and therefore the 

textured eraser cannot work on the opacity of their individual pixels. Hence, when working on vector layers, it 

is better to use a textured eraser only if all your artwork is composed of textured brush strokes, or it might 

w ield strange-looking results. 

This outlines one of the advantages of working w ith bitmap layers. On bitmap layers, your brushes and 

erasers always work as textured brushes and erasers. 

Another issue you might encounter when erasing textured vector artwork is that textured vector brush strokes 

are not flattened together, whereas on bitmap layers, your artwork is always flattened. This implies that if you 

use a semi-transparent eraser on textured vector artwork, and the artwork has overlapping strokes, all the 

strokes you erase w ill become semi-transparent, the resulting image w ill be a composite of the overlapping 

strokes. On a bitmap layer, this would simply result in a single layer of semi-transparent artwork.
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There are two different types of textured vector erasers: Textured and Textured, Preserve Vector. A simple 

textured eraser w ill do two things: First, it w ill make textured brush strokes more or completely transparent 

where you erased, and second, it w ill cut out from the brush stroke's vector shape where it made its texture 

completely transparent. In contrast, a Textured, Preserve Vector-type eraser w ill only make the texture brush 

strokes more or fully transparent, but w ill leave its vector shape intact. 

Creating a textured eraser works exactly like creating a textured brush. Therefore, you can follow the steps in 

the Creating a Textured Brush section to learn how to create a textured eraser.
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About Eraser Presets

Once you have found the correct settings for your eraser, you might want to reuse it throughout your project 

for consistency. You can do that by creating and using eraser presets.

Harmony comes preloaded w ith a few eraser presets which you can select from the Tool Properties view. It is 

also possible to create your own eraser presets by configuring your eraser then saving it as a preset. 

Like eraser tips and paper textures, eraser presets are saved in your preferences. You can also export your 

eraser presets into an .xml file, and import them on a different workstation, allow ing you to share your eraser 

presets between the different people collaborating on your project.

NOTES 

 l Eraser presets are not to be confused w ith eraser tips and paper textures. Eraser tips and paper 

textures are one of the many properties of an eraser, whereas an eraser preset contains all the 

properties of a brush.

 l Eraser presets for vector layers and for bitmap layers are separate. An eraser preset created 

while working on a vector layer cannot be used when working on a bitmap layer, and vice 

versa. 
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Creating an Eraser Preset

You can create your own custom eraser preset by configuring your eraser, then adding it as a preset.

How to create an eraser preset

 1. Make sure the current drawing layer is vector if you w ish to create a vector eraser preset, or bitmap 

if you w ish to create a bitmap eraser preset—see About Vector and Bitmap Layers .

 2. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 3. Click on the Arrow button to open the Eraser Properties dialog.

 4. In the Eraser Properties dialog, configure your eraser—see Creating a Solid  Eraser  and Creating a 

Textured Eraser.

 5. Do one of the follow ing:

 l From the Eraser Properties dialog, click on the New Brush Preset  button in the top-

right corner. 

 l In the Tool Properties view, click the New Brush Preset  button.

 l In the Tool Properties view, open the Brush Presets  menu  and select New Brush 

Preset.

 6. In the New Preset w indow, type a name for your new eraser preset.

Your new eraser preset is added to the end of the list of eraser presets.
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Selecting an Eraser Preset

Harmony provides you w ith default eraser presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select an eraser preset from the Presets list.
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Updating a Brush Preset

If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in 

the Tool Properties view, then updating your preset w ith your brush current's parameters.

How to update a brush preset

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 1. In the Tool Properties view, select the Brush Preset you w ish to update.

 2. Click on the Arrow button to open the Brush Properties view.

 3. Configure your brush to be exactly how you w ish to use it in the future—see Creating a Solid  Brush 

or Creating a Textured Brush.

 4. Click on the Update Brush Preset  button  in the upper-right corner of the Brush Properties 

dialog. 
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Renaming an Eraser Preset

To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select an eraser preset to rename. 

 3. Open the Brush Preset menu  and select Rename Brush. 

 4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset

You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select the eraser preset you want to delete.

 3. Do one of the follow ing:

 l Click the Delete Brush  button.

 l Open the Brush Preset menu  and select Delete Brush.
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Exporting Eraser Presets

You can export eraser presets into an .xml file which w ill contain all of your eraser's settings. This can be 

useful if you w ish to back up or share your eraser presets.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 

Pencil and Eraser tools. 

 3. By default, the presets for all your tools w ill be selected for export. If you only w ish to export 

presets for specific tools, uncheck Select/Deselect All and select the tools for which you want to 

export the presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 

file and enter its file name.

 6. Click Save.
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Importing Eraser Presets

You can import eraser presets that you previously exported from Harmony. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser w indow that appears, navigate to and select the .xml file in which you exported 

your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file w ill be selected for import. If you only w ish 

to import presets for specific tools, uncheck Select/Deselect All and select the tools for which you 

want to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles w ill appear in the Presets list.
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Changing the Brush Preset Display

You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the follow ing options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails w ith a preview of 

their tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, w ith their name and a 

preview of their tip.

 l Stroke View: Displays presets in a list, w ith their name and a preview of a stroke 

done w ith each preset. 
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About the Select Tool

T-HFND-004-005

The Select tool allows you to select drawing strokes and drawing objects. W hen selected, you  can use the 

Select tool to scale, translate, rotate, resize, fl ip and delete them.

NOTES 

 l The Select tool can only be used to select, reposition and transform whole drawing strokes. If 

you need to cut out part of your artwork to reposition or transform it, you must use the Cutter 

tool—see About the Cutter Tool.

 l To learn more about the Select tool options, see the Reference Guide .
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Selecting, Repositioning and Transforming Artwork

T-HFND-004-005A

Using the Select tool, you can select drawing strokes and groups, then reposition, rotate, scale and skew them.

 

NOTE 

The select tool can only select whole drawing strokes. If you need to cut out part of your artwork, 

use the Cutter tool instead—see About the Cutter Tool on page 240.

How to select artwork

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the Tools toolbar, select the Select  tool or press Alt + S.

 3. In the Camera or Drawing view, select the artwork you want to edit by doing one of the follow ing:

 l Click on a drawing stroke to select it.

 l Draw a lasso around drawing strokes  to select them simultaneously.

TIPS 

 l To add more drawing strokes to the selection, press and hold the Shift key and 

either click or draw a lasso around the strokes you want to select.

 l Press SHIFT+ALT to unselect all the strokes you have selected previously. You can 

also unselect strokes on multiple layers in the Timeline by pressing SHIFT+ALT 

+CTRL.

 l By default, you can only select artwork in the currently selected layer. You can 

select artwork from any visible layer by holding the Ctrl (W indows/Linux) or ⌘  

(macOS) key. 

 l If you prefer drawing a rectangle rather than a lasso to select artwork, click on the 
 Lasso button in the Tool Properties view and select  Marquee. 

 l You can select all the drawing strokes in the drawing by select Edit > Select All 

from the top menu or by press ing Ctrl + A (W indows/Linux) or ⌘  + A (macOS).
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 4. Do one of the follow ing to edit your selection:

 l To reposition the selected artwork, click on it and drag where you want to position it.

NOTE 

You can also nudge your selection using the arrow keys, and fast-nudge your 

selection by holding Shift and pressing the arrow keys.

 l To rotate the selected artwork, click and grab just outside one of the handles at the corners 

of the control box and rotate it.

 l To scale the selected artwork, click and drag on one of the control points at the corners or 

the middle of the edges of the control box. 
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TIP 

W hile scaling artwork, you can preserve its proportions by pressing and holding 

the Shift key.

 l To skew, drag sideways or up and down the sides or top and bottom segments, between the 

control points.

 l To delete, press Del (W indows/Linux) or Backspace (macOS).
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Selecting Artwork in Several Drawings

You can use the Select tool to select and manipulate artwork in several drawings in the same layer at the same 

time. There are two approaches to doing this, both of which are options available in the Tool Properties view:

 l  Apply to All Frames: W hen you draw a lasso or marquee in the Drawing views, it w ill select 

strokes in that area in all of the exposed drawings in the current layer. 

 l  Apply to Onion Skin Range: W hen you draw a lasso or marquee in the Drawing views, it w ill select 

strokes in that area in all of the drawings currently displayed in the Onion Skin. This method allows you 

to select and manipulate artwork in a specific range of drawings, and allows you to see the artwork you 

selected in the Drawing view. 

How to select artwork in a specific range of drawings

 1. In the thumbnails list, select a drawing somewhere in the middle of the range that you want to edit. 

 2. In the Tools toolbar, click on the  Onion Skin button to enable Onion Skin.

 3. Using the Options in the View > Onion Skin menu, adjust the amount of previous and next 

drawings displayed in the Onion Skin until all the drawings you want to pain simultaneously are 

displayed. 

The drawings included in the Onion Skin range w ill appear in red and green in the Drawing view. 

 4. In the Tools toolbar, select the  Select tool. 

 5. In the Tool Properties view, click and hold on the  Apply to All Frames button and, in the pop-up 

menu, select  Apply to Onion Skin Range. 

NOTE 

If this button is already set to  Apply to Onion Skin Range, simply click on it to toggle 

it on.

 6. In the Drawing view, draw a lasso or marquee around the artwork you want to select. 

Strokes in the current drawing and in the drawings displayed in the Onion Skin that fit inside the 

lasso or marquee you drew will be selected.

How to select artwork in all exposed drawings in a layer

 1. In the thumbnails list, select any drawing. 

 2. In the Tools toolbar, select the  Select tool. 
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 3. In the Tool Properties view, click on the  Apply to All Frames button to enable the Apply to All 

Frames mode. 

NOTE 

If this button is currently set to  Apply to Onion Skin Range mode, click and hold on 

the button to open its pop-up menu and select  Apply to All Frames.

 4. In the Drawing view, draw a lasso or marquee around the artwork you want to select.

Strokes in the current drawing as well as in all other drawings exposed in the current layer that fit 

inside the lasso or marquee you drew will be selected.
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Inverting a Selection

You can invert your selection to select everything else in your drawing that was not previously selected. 

How to invert a selection

 1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I (W indows/Linux) or Shift 

+ ⌘  + I (macOS).
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Repositioning the Selection Pivot

You can temporarily reposition the selection's pivot position to rotate, scale, or skew from a different point.

How to temporarily reposition the pivot point

 1. In the Drawing view, select the drawing object you want to transform. 

The pivot point appears in the middle of your selection.

 2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and w ill remain 

there until you make a new selection.
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Arranging and Reordering Drawing Strokes

The different Arrange options let you reorder drawing objects and strokes inside a single layer in the Drawing 

view.  

How to arrange drawing strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be reordered.

 3. Do one of the follow ing: 

 l From the top menu, select Selected > Arrange > Bring to Front—Moves the selected 

art to the front (on top). Press Ctrl + Shift + PgUp (W indows/Linux) or ⌘  + Shift + 

PgUp (macOS). 

 l From the top menu, select Selected > Arrange > Bring Forward—Moves the 

selected art one level forward (closer to the front). Press Ctrl + PgUp 

(W indows/Linux) or ⌘  + PgUp (macOS).

 l From the top menu, select Selected > Arrange > Send Backward—Moves the 

selected art one level lower (behind). Press Ctrl + PgDown (W indows/Linux) or ⌘  + 

PgDown (macOS).

 l From the top menu, select Selected > Arrange > Send to Back—Moves the selected 

art behind everything (bottom / back). Press Ctrl + Shift + PgDown (W indows/Linux) 

or ⌘  + Shift + PgDown (macOS).

 l Bring to Front  button

 l Bring Forward   button

 l Send Backward   button

 l Send to Back  button
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Grouping Drawing Strokes

Use the grouping options to group and ungroup selected drawing objects and strokes. This can help in the 

selection, repositioning, re-scaling and other transformations to be applied to multiple objects of a drawing. 

Grouping does not flatten your objects. You can ungroup your selection at any time. You can also group 

groups. 

How to group strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be grouped.

 3. Do one of the follow ing:

 l From the top menu, select Selected> Group > Group.

 l Press Ctrl + G (W indows/Linux) or ⌘  + G (macOS). 

How to ungroup strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  groups to be ungrouped.

 3. Do one of the follow ing:

 l From the top menu, select Selected > Group > Ungroup.

 l Press Ctrl + Shift + G (W indows/Linux) or ⌘  + Shift + G (macOS). 
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Selecting Artwork by Colour or Texture

You can select all the shapes in your artwork that are painted w ith a specific colour or texture. You can also 

select all the pencil l ines that use a specific pencil texture.

How to select all the artwork painted with the same colour as your selection

 1. In the Tools toolbar, select the  Select tool.

 2. In the Tools toolbar or Tool Properties view, toggle on  Select by Colour.

 3. In the Drawing view click on a shape fil led w ith the colour you want to select. 

All the shapes in the drawing that are painted w ith the same colour as the shape you clicked on 

w ill be selected.

How to select all the artwork filled with a specific colour or texture

 1. In the Colour view, click  Show Colour Palettes.

 2. In the upper list, select the palette containing the colour or texture you want to select

 3. In the lower list, select the colour or texture you want to select. 

 4. In the top menu, select Edit > Select Strokes with Current Colour. 

How to select all the pencil lines using a specific pencil texture

 1. In the Colour view, select  Show Pencil Texture Palettes.

 2. In the upper list, select the palette containing the pencil texture you want to select.

 3. In the lower list, select the pencil texture you want to select.

 4. In the top menu, select Edit > Select Strokes with Current Pencil Texture.
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About the Repositioning All Drawings Tool

T-ANIMPA-010-008

The Reposition All Drawings  tool is used to reposition, scale, rotate or skew all drawing strokes on every 

drawing included in a layer. 

If your hand-drawn animation requires to be repositioned in the grid, as soon as your select the Reposition All 

Drawings tool, all the strokes in all the drawings exposed on the current layer are selected. You can use the 

controls the same was as the Select tool—see About the Select Tool on page 226. 

NOTE 

To learn more about the Reposition All Drawings tool options, see the Reference guide .
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Repositioning All Drawings in a Layer

T-ANIMPA-010-009

Use the Reposition All Drawings tool to reposition all the drawing strokes on all drawings exposed in the 

current layer. 

How to reposition all drawings

 1. From the Tools toolbar, select the Reposition All Drawings  tool. This also automatically selects 

every stroke in your drawing in the Drawing and Camera view.

 2. Do any of the follow ing:

 l To reposition, click and drag your selection to a new area.

 l To rotate, rotate the selection box handle.

 l To scale, pull or push on the top, side, bottom or corner control points. Hold down 

Shift to maintain the selection’s ratio.
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 l To skew, drag the sides or top and bottom segments, between the control points.

 3. W hen you release your cursor, every drawing in the drawing layer you repositioned, scaled, rotated 

or skewed will follow the same transformation.

 4. You can also adjust the position by modifying the settings and using the operation buttons in the 

Tool Properties view.
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About the Cutter Tool

T-HFND-004-007

The Cutter tool lets you cut out part of a drawing so that you can transform it, copy it or delete it.  You can use it 

to scale or reposition the portion of a flattened or bitmap drawing. You can also use it to trim strokes using a 

single gesture.

NOTE 

To learn more about the Cutter tool options, see the Reference guide .
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Cutting Artwork 

T-HFND-004-007A

Use the Cutter tool to trim and cut your artwork. 

You can also use the Cutter tool to trim the ends of overshot lines. Line ends can be trimmed up to the point 

where they intersect w ith another line. This technique can be used to clean sketches much faster. Enable the 

Single Line Cutting Gesture mode for precision or the Multiple Line Cutting Gesture mode for speed.

How to cut drawings

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Drawing view, draw a lasso around the artwork you want to cut away.

The artwork inside the lasso you drew will be cut from the rest of the artwork and w ill be selected. 

TIPS 

 l You can add another part of your artwork to the selection by holding Shift and 

drawing another lasso. 

 l By default, the Cutter tool w ill only work on the current layer. You can cut artwork 

from all visible layers by holding the Ctrl (W indows/Linux) or ⌘  (macOS) key.

 3. Once you've cut out artwork, you can manipulate it l ike w ith the Select tool. For example:

 l To move the selected artwork, click and drag it.

 l To delete the selected area, press Del.

 l To scale, rotate or skew the selection, use the controls around the selection's bounding box.
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How to trim a single line

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Tool Properties view, under the Cutter Tool Options, select the Lasso .

The Line Cutter Gesture modes are enabled.

 3. Select the Single Line Cutting Gesture Mode .

 4. In the Stage or Camera view, sweep the Cutter tool across the end of a line you w ish to trim.

The line end disappears.

Before

After
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NOTE 

Even if your mouse gesture touches other lines, only the first l ine that the Cutter tool makes 

contact w ith disappears.

How to trim multiple lines

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Tool Properties view, under the Cutter Tool Options, select the Lasso .

The Line Cutter Gesture modes are enabled.

 3. In the Tool Properties view, select the Multiple Lines Cutting Gesture Mode .

 4. In the Stage or Camera view, sweep the Cutter tool across the end of a lines you w ish to trim.

The line ends disappear.

Before
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After
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Cutting Artwork in Several Drawings

You can use the Cutter tool to cut out and manipulate artwork in several drawings in the same layer at the 

same time. There are two approaches to doing this, both of which are options available in the Tool Properties 

view:

 l  Apply to All Frames: W hen you draw a lasso or marquee in the Drawing views, it w ill cut out 

artwork in that area in all of the exposed drawings in the current layer. 

 l  Apply to Onion Skin Range: W hen you draw a lasso or marquee in the Drawing views, it w ill cut 

out artwork in that area in all of the drawings currently displayed in the Onion Skin. This method allows 

you to cut out and manipulate artwork in a specific range of drawings, and allows you to see the 

artwork you cut out in the Camera or Drawing view. 

How to select artwork in a specific range of drawings

 1. In the thumbnails list, select a drawing somewhere in the middle of the range that you want to edit. 

 2. In the Tools toolbar, click on the  Onion Skin button to enable Onion Skin.

 3. Using the Options in the View > Onion Skin menu, adjust the amount of previous and next 

drawings displayed in the Onion Skin until all the drawings you want to pain simultaneously are 

displayed. 

The drawings included in the Onion Skin range w ill appear in red and green in the Drawing view. 

 4. In the Tools toolbar, select the  Cutter tool. 

 5. In the Tool Properties view, click and hold on the  Apply to All Frames button and, in the pop-up 

menu, select  Apply to Onion Skin Range. 

NOTE 

If this button is already set to  Apply to Onion Skin Range, simply click on it to toggle 

it on.

 6. In the Drawing view, draw a lasso or marquee around the artwork you want to select. 

The artwork in the current drawing and in the drawings displayed in the Onion Skin w ill be cut out 

by the lasso or marquee you drew and w ill become selected. 

How to select artwork in all exposed drawings in a layer

 1. In the thumbnails list, select any drawing. 

 2. In the Tools toolbar, select the  Cutter tool. 
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 3. In the Tool Properties view, click on the  Apply to All Frames button to enable the Apply to All 

Frames mode. 

NOTE 

If this button is currently set to  Apply to Onion Skin Range mode, click and hold on 

the button to open its pop-up menu and select  Apply to All Frames.

 4. In the Drawing view, draw a lasso or marquee around the artwork you want to select.

The artwork in all the drawings in the current layer w ill be cut out by the lasso or marquee you 

drew and w ill become selected.
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About the Contour Editor Tool

T-HFND-004-008

The Contour Editor lets you reshape vector shapes, brush strokes and lines in your drawings. 

Artwork in Harmony is made of vector shapes. Vector shapes are defined by points, the lines joining the points 

together (contours) and the curve vectors, represented by Bezier handles, which make the curve of said lines.

The Contour Editor tool allows you to select a contour or point, and change the position of points, add and 

remove points from the shape, rotate, lengthen and shorten curve handles to influence the curve of contours 

between those points, or drag contours between points to change their curve directly. 

Since pencil l ines are defined by a single line w ith a line w idth, you can use the Contour Editor to easily modify 

the shape of pencil l ines. In contrast, brush strokes are full vector shapes, so the Contour Editor can be used to 

modify their shape. 

The Contour Editor can be used to tweak vector artwork in all sorts of ways. It can be used to perfect a pencil 

l ine, correct shapes, or create complex shapes out of a basic ellipse or rectangle.

NOTE 

To learn more about the Contour Editor tool options, see the Reference Guide.
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Reshaping a Shape, Pencil Line or Stroke with the Contour Editor Tool

T-HFND-004-008A

You can use the Contour Editor tool to tweak the contours of vector shapes and brush strokes in your 

drawings, as well as reshape pencil l ines and strokes. 

How to reshape drawings

 1. In the Tools toolbar, select the Contour Editor  tool or press Alt + Q.

 2. In the Drawing  view, click the shape, contour or pencil l ine you want to edit near the area you w ish 

to change.

The shape or line's control points appear.

 3. Click on one of the points to select it. 

The point's Bezier handles appears, as well as Bezier handles for the surrounding points. 

TIP 

You can select several points by drawing a lasso around the points, or by holding Shift 

while clicking on points to add them to your selection. You can use the Contour Editor 

to scale and rotate a selection of multiple points by enabling the  Show Contour 

Editor Control  option in the Tool Properties view.
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 4. Do one of the follow ing:

 l To move a point or a selection of multiple points, click and drag it. 

 l To change the curve on both sides of a point, drag one of its Bezier handles.

 l To change the curve on only one side of a point, press and hold the Alt key, then drag one of 

its Bezier handles.

 l To deform the contour, drag a part of the contour between two points.
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 l To deform the curve between two points, hold the Shift key and drag the contour between 

two points.

 l To remove a point's Bezier handles and make the lines it is connected to straight, press and 

hold the Alt key and click on the point.

 l Straight lines have no Bezier handles at their points by default. To create Bezier handles for 

these points and make their l ines curved, pres and hold the Alt key, then click and hold the 

point and drag the mouse cursor away from it. A new Bezier handle w ill follow your mouse 

cursor until you release the mouse button. 

 l To add a control point, press Ctrl (W indows/Linux) or ⌘  (macOS) and click on the contour 

where you want the new point to be created.
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 l To remove a control point, select the control point and press Del (W indows/Linux) or 

Backspace (macOS).
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About the Centerline Editor

T-HFND-004-009B

The Centerline Editor allows you to tweak and reshape a brush stroke by manipulating its centre line rather 

than its contour (you can manipulate its contour using the Contour Editor tool). This gives a flexibility similar to 

manipulating a pencil l ine  w ith the Contour Editor tool.

Keep in mind that brush strokes are vector shapes w ith a fil l. As such, the Centerline Editor must do guess 

work to figure out the centreline of your brush strokes, and apply deformations on its shape as you tweak its 

control points. The Centerline Editor w ill not be able to make a accurate centreline out of brush strokes that 

merge together, that look scrambled or that otherwise do not have a clear direction.    
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NOTE 

If you use the Centerline Editor on a textured brush stroke, it w ill deform the texture to make it fit 

the new shape of the stroke.

NOTE 

If you use the Centerline Editor to deform a closed brush stroke w ith a fil l inside it, the fil l w ill not 

be reshaped to fit the new shape of the brush stroke.

NOTE 

To learn more about the Centerline Editor tool options, see the Reference Guide.
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Reshaping Brush Strokes Using the Centerline Editor

T-HFND-004-009C

You can use the Centerline Editor tool to reshape brush strokes from their centreline rather than their contour, 

l ike you would reshape pencil l ines using the Contour Editor.

How to reshape brush strokes

 1. In the Tools toolbar, double-click on the Contour Editor  button and select the Centerline Editor 
 tool, or press Alt + W .

 2. In the  Drawing  view, click the contour or pencil l ine you want to edit near the area you w ish to 

change.

The Centerline Editor creates a centreline manipulator based on the outline's shape, w ith control 

points. 

 3. In the Tool Properties view, use the Centerline Smoothness slider to adjust the amount of control 

points on the centreline as needed:

 l If you find that the generated centreline has too many control points to be easily 

manipulated, reduce the Centerline Smoothness parameter.

 l If you need more control points to make precise manipulations, increase the Centerline 

Smoothness parameter.

 4. Click on one of the points to select it. 

The point's Bezier handles appears, as well as Bezier handles for the surrounding points. 
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TIP 

You can select several points by drawing a lasso around the points, or by holding Shift 

while clicking on points to add them to your selection. You can use the Contour Editor 

to scale and rotate a selection of multiple points by enabling the Show Centerline 

Editor Control  option in the Tool Properties view.

 5. Do one of the follow ing:

 l To move a point or a selection of multiple points, click and drag it. 

 l To change the curve on both sides of a point, drag one of its Bezier handles.

 l To change the curve on only one side of a point, press and hold the Alt key, then drag one of 

its Bezier handles.
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 l To deform the contour, drag a part of the contour between two points.

 l To deform the curve between two points, hold the Shift key and drag the contour between 

two points.

 l To remove a point's Bezier handles and make the lines it is connected to straight, press and 

hold the Alt key and click on the point.
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 l Straight lines have no Bezier handles at their points by default. To create Bezier handles for 

these points and make their l ines curved, pres and hold the Alt key, then click and hold the 

point and drag the mouse cursor away from it. A new Bezier handle w ill follow your mouse 

cursor until you release the mouse button. 

 l To add a control point, press Ctrl (W indows/Linux) or ⌘  (macOS) and click on the contour 

where you want the new point to be created.

 l To delete the control point, select it and press Del. 
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About the Pencil Editor Tool

T-HFND-004-009

A pencil l ine is a central vector shape. Control    points are located along the central spine allowing you to adjust 

the    stroke curve and position. Using the Pencil Editor tool, you can adjust the thick and thin areas of pencil 

l ines. Using the Contour Editor tool, you can reposition the spine of the stroke.

NOTE 

To learn more about the Pencil Editor tool options, see the Reference guide .
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Tweaking the Thickness of Pencil Lines with the Pencil Editor Tool 

T-HFND-004-009A

You can use the Pencil Editor tool to reshape the pencil l ine thickness.

How to reshape pencil lines

 1. In the Tools toolbar, select the Pencil Editor  tool.

 2. In the  Drawing view, select a pencil l ine and click to reshape it.

 3. Select one or several points by clicking them or circling around.

 4. Press Del to delete a selected point.

 5. Press Ctrl (W indows/Linux) or ⌘  (macOS) and click the central spine to add a set of points to 

adjust the contour.

 6. To modify the shape, you can:

 l Move the selected points to a new area. If you select matching points on each side of 

the line, holding the Shift key w ill move them both.  This way you can thicken or thin a 
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l ine from both sides at the same time.

 l Pull on the Bezier handle to move both points’ handles as one.

 l Hold down Alt and pull on one of the Bezier handles. It moves the handle 

independently from the other one.

 l Pull directly on the line between two points. No selection is necessary. Holding down 

the Shift key w ill l imit the contour modification to the curve between the two first 

points.
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 l If an anchor point has no visible Bezier handle, hold down Alt to display them.
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Editing a Pencil Line Texture with the Pencil Editor Tool

W hen working w ith textured pencil l ines, the Pencil Editor w ill deform the textures starting from the centre 

lines. 

How to use Pencil Editor tool to edit the texture or gradient on a pencil line

 1. Do one of the follow ing:

 l In the Tools toolbar, select the Pencil Editor  tool. 

 2. Click on the pencil l ine to be modified to bring up its contour envelope.

 3. Select one of the contour points around the envelope and move its position to change the size of 

the tiled texture or gradient. You can also pull directly on the lines of the contour envelope or play 

w ith the Bezier handles of any given point in order to continue to modify the envelope form.

Expanding the w idth of the envelope parallel to the pencil l ine’s central vector w ill cause the tiled 

texture to be stretched. Conversely, reducing the envelope’s w idth w ill cause the tiled texture to 

look squashed.

Reducing the contour’s w idth perpendicular to the pencil l ine’s central vector w ill reduce the 

number of tiles, while expanding it w ill increase the number of tiled images. 
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About the Smooth Editor Tool 

T-ANIMPA-010-010

W hen drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw 

may look as if they were drawn with an unsteady hand. W hen this occurs, you may need to correct the look of 

your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the 

lines, the Smooth Editor  tool. 

NOTE 

To learn more about the Smooth Editor tool options, see the Reference guide .
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Smoothing Artwork Using the Smooth Editor

T-ANIMPA-010-011

You can use the Smooth Editor to smooth out specific areas of your drawing strokes.

How to optimize lines with the Smooth Editor tool

 1. In the Tools toolbar, select the Smooth Editor  tool or select  Tools > Smooth Editor.

 2. In the Drawing view, place your pointer over the lines to smooth. You may need to pass over the 

same line several times to remove more points and make the line smoother. Note that by default, 

the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—see the 

Reference guide  to learn about the various settings available.

TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 

key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 

this w ith the eraser tip of your pen w ill adjust the size of the Eraser tool, regardless of 

which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you w ill draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 

w ill lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 

its thickness. 

265



About the Perspective Tool

The Perspective tool lets you deform a drawing selection and alter its perspective. You can use the corner and 

edge anchor points to warp the shape.

NOTE 

If you use the Perspective tool on a textured brush stroke, it is w ill deform its texture to fit the new 

shape of the brush stroke. Keep in mind that this w ill resample the texture, which is liable to make 

it lose quality. 

NOTES 

To learn more about the Perspective tool options, see the Reference guide .
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Deforming a Drawing with the Perspective Tool

Use the Perspective tool to distort a drawing's bounding box and simulate a perspective effect. 

How to deform a drawing with the Perspective tool

 1. In the Tools toolbar, select the Perspective  tool from the Contour Editor drop-down menu or 

press Alt + 0.

 2. In the Drawing view, select the artwork you want to deform by doing one of the follow ing:

 l Click on a drawing stroke to select it.

 l Draw a lasso around drawing strokes  to select them simultaneously.

TIPS 

 l To add more drawing strokes to the selection, press and hold the Shift key and 

either click or draw a lasso around the strokes you want to select.

 l Press SHIFT+ALT to unselect all the strokes you have selected previously. You can 

also unselect strokes on multiple layers in the Timeline by pressing SHIFT+ALT 

+CTRL.

 l By default, you can only select artwork in the currently selected layer. You can 

select artwork from any visible layer by holding the Ctrl (W indows/Linux) or ⌘  

(macOS) key. 

 l If you prefer drawing a rectangle rather than a lasso to select artwork, click on the 
 Lasso button in the Tool Properties view and select  Marquee. 

 l You can select all the drawing strokes in the drawing by select Edit > Select All 

from the top menu or by press ing Ctrl + A (W indows/Linux) or ⌘  + A (macOS).

 3. Click and drag the different anchor points to deform the shape.
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About the Envelope Tool

The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles. You 

can warp images to make them look like they are reflected in water or in a deformable mirror.

NOTE 

If you use the Envelope tool on a textured brush stroke, it is w ill deform its texture to fit the new 

shape of the brush stroke. Keep in mind that this w ill resample the texture, which is liable to make 

it lose quality. 

NOTE 

To learn more about the Envelope tool options, see the Reference guide .
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W arping a Drawing with the Envelope Tool

You can warp your drawings using the Envelope tool. 

How to warp a drawing with the Envelope tool

 1. In the Tools toolbar, select the Envelope   tool from the Contour Editor drop-down menu.

 1. Select a drawing from the Drawing Thumbnails panel.

 2. In the  Drawing view, select the artwork you want to deform by doing one of the follow ing:

 l Click on a drawing stroke to select it.

 l Draw a lasso around drawing strokes  to select them simultaneously.

TIPS 

 l To add more drawing strokes to the selection, press and hold the Shift key and 

either click or draw a lasso around the strokes you want to select.

 l Press SHIFT+ALT to unselect all the strokes you have selected previously. You can 

also unselect strokes on multiple layers in the Timeline by pressing SHIFT+ALT 

+CTRL.

 l By default, you can only select artwork in the currently selected layer. You can 

select artwork from any visible layer by holding the Ctrl (W indows/Linux) or ⌘  

(macOS) key. 

 l If you prefer drawing a rectangle rather than a lasso to select artwork, click on the 
 Lasso button in the Tool Properties view and select  Marquee. 

 l You can select all the drawing strokes in the drawing by select Edit > Select All 

from the top menu or by press ing Ctrl + A (W indows/Linux) or ⌘  + A (macOS).

A rectangle appears around the selected artwork. Bezier handles stem from each corner of the 

rectangle, which can be manipulated to make the sides of the rectangle into curves.
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 3. Click and drag the different anchor points and handles to deform the image.
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TIPS 

 l In the Tool Properties view, you can enable the  Show Advanced Controls  option to 

control the warp points inside the control box.

 l You can also divide the control box into several sections by increasing the value in the 

W idth and Height fields of the Tool Properties view. 
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About the Text Tool

W ith the Text tool, you can add text in your project using various fonts and texts attributes. 

Text objects are drawing objects in the same was as brush strokes and drawing groups are, so they can be 

manipulated w ith the select tool. After you have written and formatted your text, you can break the string 

apart to convert the letters into drawing objects that can than be individually modified w ith tools such as 

Select, Perspective, Contour Editor, Smooth Editor. 

NOTE 

To learn more about the Text tool options, see the Reference guide .
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Adding Text to Drawings

You can use the Text tool to add text to your drawings. 

How to add text to drawings 

 1. Do one of the follow ing: 

 l In the Tools toolbar, select the Text  tool. 

 l From the top menu, select Tools > Text.

 l Press Alt + 9.

 2. In the Timeline view, select the cell containing the drawing on which you want to add text.

 3. In the Drawing view, click on the location you want the text to begin.

 4. You can use the Tool Properties view to select the font, font size and format of the text you w ill 

type—see the Reference guide . 

 5. Type in the desired text.

 6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always 

return to edit the text by selecting the Text  tool and clicking in the text.

 7. You can resize the text box by selecting your text box w ith the Text   tool and moving the anchor 

point right or left. Using the Select tool w ill distort and scale your text itself rather than changing 

the w idth and height of your text box.
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Breaking Text Into Letters or Vector Shapes

Text contained in a text field is treated as a single drawing object. You can easily separate the text so each 

character becomes an individual drawing object that you can select and modify independently.

How to break a text object

 1. In the Tools toolbar, click the Select  tool or press Alt + S.

 2. In the Drawing  view, select the text object you want to break.

 3. From the top menu, select Drawing > Convert > Break ApartText Layers.

Each character is surrounded by a bounding box that you can modify; they remain text objects that 

you can edit.

 4. If you want to convert your independent letter to a complete vector object that you can deform, use 

the Select tool to select the letters to convert.

 5. From the top menu, select Selected > Convert > Break Apart Text Layers to break the selection 

into a regular drawing object, w ith no more text attributes.
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About the Tool Colour Swatches

T-ANIMPA-010-018

W hile drawing and painting, you can let Harmony retain the last colour you selected for each one of the 

follow ing tool types:

 l Brush

 l Paint 

 l Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint,   and Pencil   tools.

You can also link or unlink the colour swatch used between vector and bitmap layers.
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Unlinking the Tool Colour Swatches 

T-ANIMPA-010-019

You can unlink the tool colour swatches and use separated colours for the Brush, Paint, and pencil l ine tools. 

If you prefer to have Harmony use the same colour swatches regardless of the selected tool, you can link the 

three swatches together.

How to unlink the tool colour swatches

 1. In the Colour view, if the storage swatches are linked, click the Link   button to unlink them.

 2. Click on the Brush  storage swatch.

 3. In the Colour list, select the desired colour.

 4. Click the Pencil   storage swatch.

 5. In the Colour list, select a colour.

 6. Click the Paint   storage swatch.

 7. In the Colour list, select a colour.
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Linking the Tool Colour Swatches

You can link the tool colour swatches so all the tools use the same colour swatch.

How to link the storage swatches

 1. In the Tools toolbar, select one of the follow ing tools:

 l  Brush

 l  Paint

 l  Pencil

 l  Polyline

 l  Line

 l  Ellipse

 l  Rectangle

 2. In the Colour view, if the storage swatches are unlinked, click the Link   button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.
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Using Independent Bitmap Colour Swatches

W hen working in the Colour view, by default the current colour is active for both vector and bitmap layers. You 

can however, use different reference colours for each layer. 

Although you can use colours from your colour palette to paint on a bitmap layer, colours used in a bitmap 

drawing layer are not linked to their colour swatch in the palette. This means that, contrary to vector drawing, 

updating the colours in your colour palette w ill not update your bitmap drawings w ith the new colours. 

How to use independent colours

 l From the Colour view menu, select Colours > Independent Bitmap Colour.

W hichever colour you choose as the reference color is retained for that layer type.
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About Drawing Space Management

W hen you are drawing in the Camera or Drawing view, you can zoom, pan and rotate the view to make it 

easier to determine where to place objects, determine the scale of objects, and when zooming out, get an 

overall view of the panel and its contents. You can also use the grid to help you determine the size and 

placement of objects as you draw. 

If you like drawing in the Camera view, but don't want overlays to cover the drawing you're working on, you 

can enable the Current Drawing on Top option.
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About the Zoom Tool

The Zoom   tool in the Tools toolbar lets you zoom in and zoom out of the Drawing view.

NOTE 

To learn more about the Zoom tool options, see the Reference guide .

How to use the Zoom tool 

 1. In the Tools toolbar, select the Zoom  tool available in the Hand tool drop-down menu. 

 2. Click in the  Drawing view. 

 3. In the Tools Properties view, do the follow ing:  

 l Enable the Zoom In  mode to zoom in mode when you click in the  Drawing view. 

W hen you're in Zoom In mode, hold  as you click to zoom out.

 l Enable the Zoom Out mode to zoom out when you click in the  Drawing view. 

 l Click on the Zoom In  button to immediately zoom in. You can also press 2.

 l Click on the Zoom Out   button to immediately zoom out. You can also press 1.

282

Harmony 22 Paint User Guide                          



Chapter 3: Drawing

About the Hand Tool

You can use the Hand tool to pan through the Drawing  view. W hen you are zoomed in your workspace, you 

may need to pan to a different area of your image. You can do so w ith the Hand tool or the Spacebar keyboard 

shortcut. 

The Hand tool has no options in the Tool Properties view.

How to use the Hand tool 

 1. Do one of the follow ing:

 l In the Tools toolbar, select the Hand  tool, click in the Drawing  view and drag. 

 l You can also Hold down the Spacebar, click in the Drawing  view and move your 

mouse in the direction you want to pan the view.
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About the Rotate View Tool

T-LAY-001-005

The Rotate View  tool lets you rotate the Drawing view, the same way as you would do w ith a real animation 

disc  for increased flexibility. This tool can also be used in the Perspective view.

The Rotate View tool has no options in the Tool Properties view.

How to use the Rotate View tool

 1. Do one of the follow ing:

 l From the top menu, select Tools > Rotate View.

 l In the Tools toolbar, select the Rotate View  tool in the Hand tool menu.

 l In the Drawing view, right-click and select Drawing Tools > Rotate View.

 l Hold down Ctrl + Alt (W indows/Linux) or ⌘  + Alt (macOS).

The rotation disc appears.

 2. In the Drawing view, click and drag to rotate the space. 
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 3. Release the keyboard shortcut or sw itch to a new drawing tool.

 4. Reset the view rotation using View > Reset Rotation or press Shift + X to reset the rotation.
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About the Grid 

Harmony is equipped w ith a traditional animation grid. You can use it as a reference while drawing to fit a 

given layout field chart, align elements, or simply see the center of your drawing. You can draw beyond the 

grid boundaries as it is only a visual reference.  
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Displaying the Grid

You can display the grid and it w ill be visible in the Drawing view.

Use the Show Grid option to display a grid in the Drawing  view. 

How to display the grid 

 1. Do one of the follow ing: 

 l In the Drawing View toolbar, press the Show Grid  button. 

 l In the Camera View toolbar, press the Show Grid  button.  

 l Select View > Grid > Show Grid. 

 l Press Ctrl + ' (W indows/Linux) or ⌘  + ' (macOS).
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Modifying the Grid

You can modify the look of the grid to be either square, 12-field, 16-field, outline, and so on. 

How to modify the grid display  

 1. Select View > Grid > Show Grid to display the grid. 

 2. To modify the grid, select one of the follow ing: 

 l View > Grid > Grid Outline Only—Displays the outline of the grid only.

 l View > Grid > Square—Displays a standard square grid.

 l View > Grid > 12 Field Grid—Displays a 12-field size grid.

 l View > Grid > 16 Field Grid—Displays a 16-field size grid.

 l View > Grid > Underlay—Displays the grid under the drawing elements.

 l View > Grid > Overlay—Displays the grid over the drawing elements.
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About OpenGL Antialiasing

T-ANIMPA-010-016

Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. W hen you 

draw in the Drawing view, notice that your lines may appear jagged. This is caused by the fast real-time 

display called OpenGL.  If you prefer to see smooth lines as you draw, you can enable the antialiasing 

preference.

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing w ill not only antialias 

your drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on 

or off; by default, it is disabled. 

There is no need to modify your graphic card settings.

NOTE 

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene w ill be 

rendered to 100% of its resolution regardless of your preference settings or graphic card panel.
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Setting the Full Scene Antialiasing Preference

T-ANIMPA-010-017

You can enable  the Full Scene Antialiasing preference to smooth out the OpenGL artwork.

NOTE 

You must restart Harmony after you change the parameters.

How to customize the full scene antialiasing parameters

 1. Do one of the follow ing:

 l Select Edit > Preferences (W indows/Linux) or Harmony [Edition] > Preferences 

(macOS). 

 l Press Ctrl + U (W indows/Linux) or ⌘  + U (macOS).

The Preferences dialog box opens.

 2. In the OpenGL tab, select the Enable option in the Full Scene Antialiasing section.

 3. Number or samples: Enter the number of samples you want to be used for the antialiasing process. 

The number of samples is basically equivalent to the amount of times a pixel w ill be enlarged to 

calculate the antialiasing. This technique is called supersampling. The higher the number of 

samples, the better the antialiasing quality w ill be, but the heavier it w ill be on performance.

 4. Restart Harmony.
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About Drawing Optimization 

As you work, you drawing can get complex and contain multiple strokes. You may want to optimize those 

drawings to reduce the number of brush strokes, pencil l ines, and invisible strokes. You may also want to 

flatten your artwork or optimize your brush stroke textures.

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected 

drawing objects. Drawing objects w ill only be flattened and optimized if the selected objects do not change 

the appearance of the final image when they are merged. 

For example, if you have selected a number of partially transparent objects, which you layered to create an 

additive colour effect, the selected transparent drawing objects w ill not be merged. This is because merging 

the transparent drawing objects w ill cause them to lose the effect of the layered transparent colours. 

You could also want to add invisible contour strokes so that if you unpaint lines, the vector container remains 

to be repainted later.
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Flattening Drawings

T-ANIMPA-002-006

The Flatten  operation is used to merge drawing objects and brush strokes into a single layer. If you draw new 

lines to fix a drawing or line w ith many brush strokes, it can be useful to flatten them all into a single shape. By 

default, l ines are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it w ill 

be easier if they are flattened.  

How to flatten drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Drawing view, select the drawing strokes you want to flatten. 

 3. Select Drawing > Optimize > Flatten or press Alt + Shift + F. You can also press the Flatten  

button in the Tool Properties view.

292

Harmony 22 Paint User Guide                          



Chapter 3: Drawing

Smoothing Drawings

The Smooth operation is used to reduce the number of contour points on a brush stroke and center points on a 

pencil l ine. It also smooths out the shape.  

The Smooth Fast option allows out to smooth out a drawing stroke at a faster rate than the regular smooth 

option.

How to smooth drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Drawing view, select the drawing strokes you want to smooth out. 

 3. Select Drawing > Optimize > Smooth or press Alt + Shift + S. You can also press the Smooth  

button in the Tool Properties view.
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Creating Contour Strokes

The Create Contour Stroke  option is used to add a permanent invisible line around a shape that was drawn 

directly in Harmony. This allows you to unpaint your lines w ith the Paint  tool but maintain the shape of the 

lines, should you need to repaint later.

This command is useful when inking and painting and using the Apply to All Drawings in Layer  option.

How to create contour strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the  Drawing view, use the Select tool to select the drawing objects you want to create contour 

strokes for.

 3. From the top menu, select Selected > Create Contour Strokes.
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Removing Contour Strokes

The Remove Contour Stroke option is used to remove any permanently invisible lines that were created while 

scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove 

the intersection triangles created during vectorization.

How to remove contour strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the  Drawing view, use the Select tool to select the drawing objects you want to remove contour 

strokes for.

 3. From the top menu, select Selected > Remove Contour Strokes.
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Flattening and Removing Extra Strokes

The Flatten and Remove Extra Strokes command allows you to flatten the selected artwork together and 

instantly remove invisible lines that are adjacent to it.

NOTE 

This w ill only remove invisible lines that are adjacent to visible artwork. Invisible lines that are not 

connected to any visible shape or line w ill not be removed. 

How to                                    flatten artwork and                              remove extra strokes

 1. In the Tools toolbar, select the Select  tool.

 2. In the  Drawing view, use the Select tool to select the artwork that you want to flatten and clean up. 

 3. In the top menu, select Selected > Flatten and Remove Extra Strokes.
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Optimizing Drawings

You can use the Optimize feature to flatten your drawing strokes w ithout changing the aspect of your 

drawings. This mainly means that transparencies w ill not be flattened. 

How to optimize a drawing

 1. In the Tools toolbar, select the Select tool.

 2. In the Drawing view, select the drawing strokes you want to optimize. 

 l From the top menu, select Selected > Optimize.
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Reducing the Drawing Texture Resolution

How to reduce the drawing texture resolution

 1. In the Tools toolbar, select the Select tool.

 2. In the  Drawing view, use the Select tool to select the drawing objects whose texture resolution you 

wan to reduce.

 3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.

 4. In the dialog box, drag the slider toward the left to reduce the texture resolution.

 5. Enable the Apply to All Drawings option if you want the modification to be applied to all the 

drawings in your layer.

 6. Click OK.
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About Strokes Conversion 

You may have drawing stroke using the Pencil tool when you wanted to use the Brush tool. You may also have 

drawing your image using the Polyline tool and now you want to convert your strokes to brush strokes. For 

many reasons, you may want to switch your stroke types to another type to use the various advantage set they 

offer.  

There are three types of strokes: 

 l Brush strokes (contour vector) 

 l Pencil strokes (central vector) 

 l Invisible strokes (central vector w ith a thickness value of 0)

Harmony lets you convert pencil l ines to brush strokes, brush strokes to pencil l ines, and invisible strokes 

(strokes) to pencil l ines. 

You can also break text objects apart—see Breaking Text Into Letters or Vector Shapes on page 275.
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Converting Brush Strokes to Pencil Lines 

The Brushes Strokes to Pencil Lines  operation converts selected contour strokes into centreline pencil strokes. 

The brush stroke thickness w ill be lost.

How to convert brush strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the strokes you want to convert. 

 3. Do one of the follow ing: 

 l From the top menu, select Selected > Convert > Brush Strokes to Pencil Lines or 

press ̂ .

 l Right-click on the selection, select Convert >Brush Strokes to Pencil Lines or press ̂
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Converting Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes  operation converts the selected centreline pencil strokes into contour 

strokes brush lines. This feature works for both solid and textured pencil l ines.

How to convert pencil lines to brush strokes

 1. In the Tools toolbar, select the Select  tool. 

 2. In the Drawing view, select the strokes you want to convert.

 3. Do one of the follow ing: 

 l From the top menu, select Selected > Convert > Pencil Lines to Brush Strokes .

 l Right-click on the selection, select Convert > Pencil Lines to Brush Strokes.

 l In the Tool Properties view, press the Pencil Lines to Brush Strokes  button.
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Converting Strokes to Pencil Lines

The Strokes to Pencil Lines  operation converts the selected invisible line to a pencil l ine.

How to convert strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the strokes you want to convert. 

 3. Do one of the follow ing: 

 l Select Selected > Convert > Strokes to Pencil Lines or press Shift + F12 

(W indows/Linux only).

 l Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + 

F12 (W indows/Linux only)
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About Vector and Bitmap Layers

T-LAY-001-002

W ith Harmony, you have the choice to use vector or bitmap drawing tools. Vector drawing tools allow you to 

make drawings that can be scaled w ithout losing quality, to easily tweak and fine tune your drawings and to 

use the whole suite of drawing tools available in Harmony, whereas bitmap drawing tools allow you to lay on 

brush strokes to make more traditional- looking artwork, and to tweak your drawing by the pixel rather than by 

their strokes and contours. 

W hen drawing, whether you can use vector or bitmap drawing tools is determined by whether the art layer 

you are drawing on is a vector or a bitmap layer. By default, each drawing layer has two art layers: Line Art 

and Colour Art, and each of these art layers can be a vector or a bitmap layer. This can be useful if, for 

example, you w ish your line art to be done using bitmap drawing tools, and then to paint your drawings using 

vector drawing tools, or vice versa.

Using bitmap layers may be preferable if you find that vector drawings are too limiting for the desired art style, 

or if your vector drawings are so complex that they affect software performance. However, bitmap layers have 

the follow ing limitations which you should carefully consider before using them:

 l In vector drawings, each stroke  is a separate drawing object by default, and each of these drawing 

objects, as well as each of their points, curves and outlines, can be manipulated independently. It is not 

possible to do that w ith bitmap layers, as they are always a single drawing object. They can be drawn, 

fil led or erased over, and manipulated as a whole, but its individual elements cannot be manipulated 

independently. 

 l By default, bitmap layers are created at the same pixel density as your scene's camera when it is in its 

default position. This means that your artwork w ill lose picture quality if you zoom in on it or scale it up. 

If you need bitmap drawings to be scaled up or zoomed on, you must set your bitmap artwork's pixel 

density higher before you start drawing. 

 l Bitmap drawings may require more storage space than vector drawings. Note that this depends a lot on 

the amount of space in your drawing that is covered by artwork. Harmony does not store bitmap data 

for empty areas of your drawings.
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W hen drawing on a bitmap layer, the follow ing tools are unavailable, as they exploit the vector drawing 

capabilities of Harmony:

 l Pencil

 l Contour Editor

 l Pencil Editor

 l Smooth Editor 

 l Perspective

 l Envelope

 l Ink

 l Stroke

 l Close Gap 

 l Polyline
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Setting the Bitmap Resolution

W hen drawing in bitmap, it is important to understand that, contrary to vector artwork, bitmap artwork is 

stored in pixels. This implies that, where vector artwork can be scaled and zoomed in w ithout issue, bitmap 

artwork is resolution dependent, and is liable to drop in picture quality and appear pixelated if it is enlarged or 

zoomed in. 

By default, bitmap layers created in Harmony have a pixel density of 100%. At this density, when your scene is 

not zoomed in and your artwork is not scaled up, each pixel in your artwork corresponds to one pixel in the 

rendered image. Scaling it up or zooming in w ill require Harmony to render several pixels using the same 

bitmap pixel, making the artwork lose quality.

Hence, before you start drawing on your bitmap layer, it is important to consider if you w ill need to zoom onto 

or scale up your artwork, and set the pixel density accordingly. For example, if you intend to scale your bitmap 

artwork up to 300%, or if you intend to zoom in from 12 fields to 4 fields, you should make sure your bitmap 

artwork's pixel density is of at least 300% before you start drawing. 

The pixel density of a bitmap layer affects the amount of pixels it contains, but not its apparent size in the 

scene. For example, if your scene resolution is set to 1920 x 1080 and your bitmap artwork's pixel density is 

300%, its resolution w ill be 5760 x 3240. However, it w ill be scaled down to 1920 x 1080, and the extra 

pixels w ill be used to preserve the image quality if the artwork is zoomed on or scaled up.

Bitmap layers are also limited by a canvas. By default, this canvas is set to be 200% of the scene's w idth and 

height. This means that your artwork can bleed outside any edge of the camera frame by 50% of its size. If you 

need your bitmap artwork to have a larger canvas, it is possible to change its canvas size. This can be useful 

for example if you want to create a panning background in a bitmap layer. If you want a background to pan 

horizontally over three times the w idth of the camera frame, you would need to set its canvas w idth to at least 

300%, but it is recommended to make your canvas bigger than what you plan to use so as to avoid 

accidentally including the edges of your artwork in the picture. 
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You can specify the pixel density and canvas size at the scene level or at the drawing level:

 l Setting the pixel density and canvas size at the scene level w ill make it newly created bitmap drawings 

have the specified settings, but it w ill not change the pixel density and canvas size of existing bitmap 

drawings.

 l Setting the pixel density and canvas size at the drawing level w ill allow you to change the pixel density 

and canvas size of existing drawings in a bitmap layer, but w ill not affect the pixel density and canvas 

size of drawings created afterward.

NOTE 

In Paint, you cannot set the canvas size and pixel density for the whole scene, since Paint is only 

able to modify individual drawings. You can only change the canvas size and pixel density of 

existing drawings. If you need to make this change for the whole scene, open the scene in 

Harmony and refer to the Harmony documentation. 

NOTE 

If you are using textured brushes on a vector drawing layer, you must set the pixel density for 

vector drawing brush textures instead—see Setting the Textured Brush Resolution on page 113.
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How to change the canvas size and pixel density of existing bitmap drawings

 1. In the Drawing Thumbnails panel, select the bitmap drawing for which you want to change the 

canvas size or pixel density.

 2. From the top menu, select Drawing > Change Bitmap Drawing Resolution.

The Change Bitmap Drawing Resolution dialog opens.

 3. In the W idth and Height fields, enter the percentage of your scene's resolution that you want the 

canvas of your bitmap layer to occupy. By default, both values w ill be set to 200%, which means 

the w idth and height of your bitmap canvas w ill be tw ice the w idth and height of your scene's 

resolution. W hen the camera is in its default position, this leaves  extra space around the camera 

frame to draw on your bitmap layer. 

 4. In the Pixel Density field, enter the desired percentage of pixel density. If you intend to scale or 

zoom in on your artwork, make sure your pixel density is set to be at least the factor by which your 

artwork w ill scaled or zoomed on. For example, if you intend to scale your artwork by 300%, you 

need to set the pixel density to at least 300%. If you intend to zoom in on your artwork from 12 

fields to 6 fields, you need to set the pixel density to at least 200%. If you intend to do both, you 

need to set the pixel density to at least 600%, as the camera zoom and scaling factor w ill have a 

multiplying effect on the apparent scaling of your artwork.

 5. Enable the  Resample Bitmap option if you want your drawings to preserve their apparent size in 

the scene. 

 6. If you want the specified settings to be applied to all of the drawing's art layers, i.e., Line Art, 

Colour Art and, if enabled, Overlay Art and Underlay Art, check the Apply to All Art Layers option. 

Otherwise, only the currently active art layer w ill be affected.

 7. If you want the specified settings to be applied to all drawings in the active layer, check the Apply 

to All Drawings option. Otherwise, only the current drawing w ill be affected. 

 8. Click OK.

The selected drawing's canvas size and pixel density is set to the specified settings.
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NOTE 

This does not change the default canvas size and pixel density for the scene. New drawings 

w ill stil l be created w ith the scene's default canvas size and pixel density.
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Chapter 4: Painting and Colours

T-ANIMFX-003-001

Toon Boom Harmony has some very powerful painting features to add colour to your drawings. W hereas 

some other software only allow users to work w ith one colour swatch at a time, painting in Harmony is done 

by using palettes containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You 

can add as many swatches as you want. You can also rename them and modify existing ones.

W hen you modify the colour of an existing swatch, it automatically updates all the zones painted w ith this 

swatch throughout the entire scene. The colour swatch has a unique ID number that associates it w ith the 

painted zones. This way, you can change the look of your character at any time w ithout having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 

instance, in addition to the regular palette for a character, you could have one for that character in the rain 
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using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night 

scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit 

the mood and atmosphere of the scene w ithout having to repaint each element.

It is also possible to use colour swatches from palettes in bitmap drawings, although changing the colours in 

the palettes w ill not automatically update colours used in bitmap layers.
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About Colour Swatches

T-HFND-006-017

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap 

texture swatches.

A colour palette is an actual file on the hard drive. 

In Harmony Server, these palette files can be stored in a different location on the server. They can be stored in 

the Environment, Job, Scene, or Element folder and linked to any palette list. This means that if the original 

palette file is modified, it w ill update in every drawing element the palette is linked to. 

In Harmony Server, to avoid accidentally modifying the palette, the palette files can be locked. If a palette 

must be modified, you must get the rights to modify them before doing so.
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Locking and Unlocking the Colour List

In Harmony Server, you can lock and unlock the colour list to avoid modifying or modify the colour swatches.

How to lock and unlock the colour list 

 1. In the Colour view, click the Edit Palette Mode  button. 

A grey pencil icon appears in the top-right corner of the Palette list.
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Adding a Colour Swatch 

T-HFND-006-017A

You can add as many colour swatches as you want in your palette. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to add a solid colour swatch

 1. In the Colour view, click the Add Colour  button.

 2. Do one of the follow ing to edit the colour swatch:

 l From the Colour view menu, select Colours  > Edit.

 l Double-click on the colour swatch.

The Colour Picker w indow opens. 

 3. To set your colour, do one of the follow ing:

 l Select either Red, Green, Blue, Hue, Saturarion of Value to change the colour wheel's 

spectrum, then click on the desired colour in the colour wheel.
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 l Enter the hue, saturation, value, red, green and blue values manually into their 

corresponding fields. All values range from 0 to 255. 

 l Click the Dropper  button to select any colour on your screen. It can be from the 

Harmony interface, your operating system or any other open application. 

You can also click Multi W heel Mode to open the Multiwheel Colour w indow. This displays all the 

picking area styles together and also contains a picking undo list. To return to the regular Colour 

Picker w indow, click Single W heel Mode.
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 4. Click on the Shade Scale swatches to modify the shade of the selected colour. 

 5. Adjust the transparency w ith the Alpha slider or type the value directly in the Alpha field.

 6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can 

quickly access it later.

 7. Rename the colour swatch in the Colour Picker w indow or directly in the colour list by double-

clicking on its name.

By default, when you create a new colour swatch, its colour w ill be the same as the currently selected colour 

swatch, or black if no colour swatch is selected. You can make Harmony create new colour swatches w ith a 

specific default colour instead. 
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Adding a Gradient Colour Swatch 

T-HFND-006-017B

You can transform any colour swatch into a linear or radial gradient. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to create a gradient colour swatch

 1. In the Colour view, select a colour to modify .

 2. Do one of the follow ing:

 l Click the new colour and from the Colour View  menu, select Colours > New. 

 l Double-click on the colour swatch.

The Colour Picker w indow opens.
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 3. Select the Gradient option.

 4. Select the Linear or Radial option.

 5. In the Gradient slider, create your gradient:

 l To change one of the colours of your gradient, select a key colour from the gradient slider, 

then pick its colour in the colour picker.

 l To add a key colours to your gradient, click anywhere on the colour slider, between the 

existing key colour.

 l To delete a key colour, use the mouse to pull down on it.

 l To move a key colour's position in the gradient, use the mouse to drag it left or right.

NOTE 

To learn how to reposition the gradient zones in your drawings, see About the Edit Gradient 

and Texture Tool on page 403.
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Adding a Texture Colour Swatch 

T-HFND-006-017C

You can add bitmap texture colour swatches to your palette. This allows you to fil l zones in your artwork w ith 

custom patterns and textures. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to create a texture colour

 1. From the Colour  menu, select Colours > New Texture or click the New Texture  button.

The Browser w indow opens.

 2. Browse for a PSD or TGA bitmap file created w ith a third party software and click Open.

The texture is added to the colour list.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool 

instead of plaid, just update the texture file in the swatch and the entire project updates. Any 

transformation previously applied to the texture’s position in your drawings w ill be kept.
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NOTE 

To learn how to reposition the textured zones in your drawings, see About the Edit Gradient 

and Texture Tool on page 403.
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Copying and Pasting Colours 

There are three ways to copy and paste colour swatches:

 l Paste as New Colours: This create a new colour swatch w ith the same colour value, but w ith a different 

colour ID as the original swatch.

 l Paste as Clones: This creates a new colour swatch w ith the same colour value and the same colour ID 

as the original swatch.

 l Paste Colour Values: This replaces the colour values in the selected colour swatch w ith the colour 

values from the copied swatch.

Pasting a colour as a clone is useful if you’ve created a clone of a palette, then added a new swatch in the 

original palette, and need to add a swatch w ith the same colour ID in the clone palette.

NOTE 

A palette cannot have two swatches w ith the same colour ID. Hence, you can only paste colours 

as clones in a different palette than the ones the colours were copied from.

If, for any reason, you need to obtain the colour ID of your colour swatches, whether to make a reference table 

of them, or to compare the colour IDs of two swatches, you can copy the colour ID of a colour swatch to the 

clipboard. You cannot paste a colour ID anywhere on a colour swatch, but you can paste it in a text editor or a 

spreadsheet application for your own purposes. 

A colour ID is a string of 16 hexadecimal digits, i.e.: 075cf5b552401130.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to copy and paste colours

 1. In the Colour view, select one or more colours to copy.
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 2. In the Colour View menu, select Colours > Copy or press Ctrl + C (W indows/Linux) or ⌘  + C 

(macOS).

 3. In the Palette list, select the palette in which you want to paste the colours.

 4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V 

(W indows/Linux) or ⌘  + V (macOS).

 l To paste the colour values of the copied swatch over an existing colour swatch, select 

Colours > Paste Colour Values.

How to clone a colour swatch

 1. In the Colour view, select the colour swatch you want to clone.

 2. From the Colour View menu, select Colours > Copy or press Ctrl + C (W indows/Linux) or ⌘  + C 

(macOS).

 3. In the Colour view, select the colour palette you want to paste the clone into or create a new 

palette.

 4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

 1. In the Colour view, select the colour swatch from which you want to copy the ID.

 2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (W indows/Linux) 

or ⌘  + C (macOS).

 3. Paste the copied colour ID in a document.
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Deleting a Colour Swatch

T-ANIMPA-003-007

You can delete unnecessary colour swatches from your palette. If painted zones are using this colour, they w ill 

be displayed in red and the system will try to recover them the next time you load the scene. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to delete a colour swatch

 1. In the Colour view, select the colour swatches to delete.

 2. Do one of the follow ing:

 l From the Colour View menu, select Colours > Delete.

 l Click the Delete Colour  button. 

 l Right-click and select Delete.

 l Press Del.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

 3. Click OK to delete the colours or click Cancel to abort the operation.
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If you delete colour swatches already in use, the zones painted w ith them turn red so you can easily 

identify them.

323



Modifying a Texture Colour Swatch

You can replace a texture colour swatch and all zones already painted w ith it w ill update.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to replace a texture swatch

 1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

 2. From the Colour View  menu, select Colours > Edit Texture or double-click on the swatch.

The Browser w indow opens.

 3. Browse for the new PSD or TGA bitmap file created in a third party software.

 4. Click Open to update the colour swatch.
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Replacing Colours and Textures in Drawings

T-H15NEW -004-001

Although it is always possible to change colours and textures in existing drawings by updating the swatch in 

the palette, there may be situations where you want to replace a colour or texture in your drawings w ith a 

different colour or texture swatch, w ithout updating the existing swatch. For example, you may want to only 

replace a colour w ith a different colour in specific drawings, but not in all the drawings that use the original 

colour, or you may want to replace a colour w ith a colour from a different palette w ithout changing your 

palettes. 

Using the Recolour Drawing dialog, you can replace all instances of a colour or texture used in your drawings 

w ith a different colour or texture swatch. This w ill actually change the colours or textures from within the 

drawings, w ithout making any changes to your palette. You can perform this operation on the currently 

selected drawing, on all drawings in the current layer or in all drawings in your scene.

How to recolour drawings

 1. First, make sure one of the palettes in your scene already has a swatch containing the colour or 

texture you want to replace the original colour w ith—see About Colour Swatches on page 311, 

About the Edit Gradient and Texture Tool,  Adding a Texture Colour Swatch  on page 318 and 

Adding a Pencil Line Texture on page 149.

 2. In the Timeline or Xsheet view, select the drawing or drawing layers you w ish to recolour. 

NOTE 

You can select multiple layers if needed. 

NOTE 

You can skip this step if you intend to recolour all the drawings in your scene.

 3. In the Colour view, click on Show Colour Palettes  if you want to replace a colour, gradient or 

texture, or on Show Pencil Texture Palettes  if you want to replace a pencil texture. You can also 

click on Show All Palettes . 

 4. In the Colour view, select the colour or texture swatch you want to replace by doing one of the 

follow ing:

 l Select the palette in which the colour or texture swatch is located, then select the swatch 

you w ish to replace. 

 l If the drawing in the Camera or Drawing view contains the colour or texture you want to 

replace, select the Colour Eyedropper  tool in the Tools toolbar, then click on that colour 
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or texture in the drawing. The Colour view will automatically select that colour or texture's 

palette as well as that colour or texture's swatch.

 5. Do one of the follow ing:

 l Right-click on the swatches list, then select Recolour Drawings.

 l Open the Colour view menu , then select Colours > Recolour Drawings.

The Recolour Drawings dialog appears.

 6. In the Replace Colour In panel, select whether you want to replace the selected colour in the 

Current Drawing, in All drawings in the selected layers or in All drawings in the scene.

 7. In the palette list in the Replacement Colour panel, select the palette that contains the colour or 

texture swatch you want to replace the original colour or texture w ith.

 8. In the swatches list, select the colour or texture swatch you want to replace the original colour or 

texture w ith.

 9. Click OK.

A dialog displays showing the progress of the recolour operation. W hen finished, the original 

colour or texture is replaced w ith the replacement colour or texture in your drawing.
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Protecting Colours
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W hen you are finished inking one colour, you can lock it so if you ever paint over it accidentally, the work 

already done w ill not be affected. You can also use the Protect Colour feature to block the fil l ing colours if you 

painted all of the animation in Line Art and you plan to repaint the lines.

W hen painting, the Respect Protected Colour option is enabled by default. In the Colour view, you can protect 

In the Colour view, you can protect a colour swatch to avoid repainting or unpainting the zones linked to that 

swatch. If you using the Paint tool and this option is deselected, you w ill repaint or unpaint the protected 

colours on your drawings until you enable the option again.

How to protect colours

 1. In the Colour view, select the colour to be protected.

 2. Do one of the follow ing:

 l From the Colour view menu, select Colours > Protect Colour.

 l From the top menu, select Colours > Protect Colour.

A red bar appears beside the colour to indicate that it is locked.

How to enable the Respect Protected Colours option

 1. Do one of the follow ing:

 l In the Paint tool properties, click the Respect Protected Colour button.

 l From the top menu, select Options > Colour Protection > Respect Colour 

Protection.

 l Press Shift + S.
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Changing the Colour Display Mode 

The Colour view has two display modes:

 l List

 l Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This 

option is not available when displaying the colours in Swatch mode.

How to switch between the display modes

 1. From the Colour View menu, and do one of the follow ing: 

 l Select Colours > Swatch Mode to display the swatches.

 l Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

 l From the Colour View menu, select Palettes > Display Colour Values.   

The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The 

gradient colour swatches w ill be identified as (gradient). 
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About Palettes
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In animation, specific colours are used to paint each part of each character. In order to maintain absolute 

consistency, a base colour palette should be created for each character, prop and effect in the production. This 

is referred to as a master palette.

Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels 

of red, green, blue and opacity (the latter which is referred to as alpha).

Using a master colour palette has many benefits, including:

 l Each character consistently retains their dedicated colours.

 l You cannot accidentally use a colour which is not in the master palette.

 l Standardization and colour consistency throughout the production.

 l Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allow ing complete control and 

consistency in the painting process. 

A palette is created by assigning a set of colours to each character, prop or effect. You w ill create a new 

palette and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, 

tongue, shirt, pants, and so on.

W hen you modify the colour of an existing swatch, it automatically updates all the zones painted w ith this 

swatch throughout the entire scene. The colour swatch has a unique ID number that associates it w ith the 

painted zones. This way, you can change the look of your character at any time w ithout having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 

instance, in addition to the regular palette for a character, you could have one for that character in the rain 

using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night 

scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit 

the mood and atmosphere of the scene w ithout having to repaint each element.
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About Advanced Palette Management

In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. W hen a palette is 

created in Harmony,it is stored in your scene's palette-library subfolder by default, and linked to your 

scene's palette list. However, Harmony has advanced palette management features that allow you to store 

and manage your palettes in manners that may better serve your production's needs. This is called Advanced 

Palette Lists mode. To enable these features, you must enable the Advanced Palette Lists preference.

The Advanced Palette Lists mode unlocks two features that can be very useful, especially for a big production:

 l Palette location: W hile palette files are stored in a scene's palette library directory by default, you can 

choose to store palettes in different locations, allow ing you to easily share palettes between different 

scenes in a Harmony Server database. 

 l Palette list type: W hereas palettes are usually added to a scene's palette list, making them available 

to all the elements in your scene, you can also choose to add palettes to the palette list of individual 

elements (layers) in your scene. 

W hen the Advanced Palette Lists mode is enabled, Harmony open a dialog called the Palette Browser 

whenever you want to create, import, clone, duplicate or link to a palette, which allows you to decide your 

palette's location and palette list type. 

To use advanced palette lists, it is important to understand the difference between a palette's location and a 

palette list's level. For example, it is possible to add a palette file stored in a scene's palette library folder to an 

element's palette list. This can be useful if you w ish to have the same palette file used by several specific 

elements in your scene, w ithout copying it in the palette library folder of each element that uses it. The reverse 

is possible: You can add a palette file stored in an element's palette library folder to a scene's palette list, 

making the palette usable for all the elements in the scene, even if it is stored inside a single element's folder. 
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Enabling the Advanced Palette Lists Mode 

Advanced Palette Lists mode is disabled by default to avoid cluttering a basic workflow with too many 

options, but it enables palette management capabilities that are very useful for big productions. Mainly, this 

preference allows you to:

 l Create palettes inside a scene's environment, job or element palette- library directory, instead of the 

scene's palette- library directory. Storing a palette at the environment or job level can be especially 

useful if you want to use the same palette in several scenes w ithout creating dependencies between 

animation scenes and colour model scenes. 

 l Create palettes for specific elements instead of the entire scene. You can do this by adding, importing or 

linking to a palette in an element's palette list. A palette in an element's palette list can only be used by 

that element. 

You can set up the Advanced Palette Lists option in the Preferences panel.

How to set the Advanced Palette Lists mode

 1. Do one of the follow ing:

 l From the top menu, select Edit > Preferences (W indows/Linux) or Harmony [Edition] 

> Preferences (macOS).

 l Press Ctrl + U (W indows/Linux) or ⌘  + U (macOS).

 2. Select the General tab.

 3. In the Advanced OptionsColor Management section, select  the Advanced Palette Lists option.

 4. Click OK.
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About Scene and Element Palette Lists

By default, you can only add palettes to a scene's palette list. W ith the Advanced Palette Lists preference 

enabled, you can choose to store add palettes to the palette list of individual elements if you choose. Here is 

an explanation of the two different levels of palette lists:

 l Scene palette list: This palette list and its palettes are available for and can be used in all of the scene's 

elements. Hence, it is the most simple and least restrictive approach, and is the type of palette used by 

Harmony when Advanced Palette Lists mode is disabled. It is most recommended to add your palettes 

to your scene's palette list if you are doing digital animation, where character models can be made of 

many different elements that must use the same palette. 

 l Element palette list: A palette list associated w ith a single element in your scene. An element is the 

container for the drawings used by a drawing layer. Hence, when an element has a palette list w ith its 

own palettes, only the drawings in that element can use the colours in these palettes, and the palettes 

in this element's palette list w ill only be shown in the Colour view when a drawing from this element is 

selected. 

Using element palette lists as certain advantages, depending on your type of production:

 l In paperless and traditional animation projects, characters are usually drawn on single elements. 

Hence, you can use this to associate characters in a scene to their colour palette.

 l If a scene requires a lot of palettes, linking those palettes only to elements that need them rather than 

to the whole scene can help declutter your palette list. 

 l W hen a palette and its clone are in the scene's palette list, Harmony w ill only use whichever palette is 

highest in the list. If you want one element to use the original palette and another element to use the 

cloned palette, you can do so by adding the right palette to each element's palette list.
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About Palette Storage Locations

Palettes can also be stored in four different locations. The best location to store palettes depends on the type 

of production, the purpose of the palette, your pipeline and your backup plan. Here is an introduction to each 

type of palette location and their purpose:

 l Element: The palette- library folder inside an element's folder in the scene. This is the recommended 

location if you are adding palettes to the palette lists of individual elements. 

 l Scene: The palette- library folder inside the scene's folder. This is the default location when creating a 

palette in the scene's palette list, and is the location chosen by Harmony when creating a palette w ith 

the Advanced palette Lists preference disabled. This is a suitable location to store the palettes of 

characters, props and backgrounds used in a single scene, a small project, or any production that uses 

Harmony Stand Alone. 

 l Job:  For Harmony Server, this is the palette- library folder inside the job's folder on the database server. 

This is the recommended location if you want to share the same palette between several scenes in the 

same job, like for characters, props and backgrounds that are used in across entire episodes or smaller-

scale projects. 

 l Environment: For Harmony Server, this is the palette- library folder inside the environment's folder on 

the database server. This is the recommended location if you want to share the same palette between 

several scenes in the same environment, l ike for characters, props and backgrounds that are used 

across an entire series or movie. 

It is actually possible, but not recommended, to use palettes that are from a different job or environment. For 

example, if you w ish to store a colour model's palette in the colour model's scene, you can make animation 

scenes that user this character link to the palette in the colour model's scene. However, this means your scene 

w ill depend on the colour model's scene and its palette being available at this location to render its colours. If 

the colour model's scene is moved or deleted, or if you export the animation scene and import it in another 

database, it w ill not be able to retrieve the palette. Hence, you would have to export the colour model along 

w ith the animated scene, and import it into the other database. If you were to store the colour model's palette 

in its element folder, this would have the same restriction, w ith the added risk of breaking links to the original 

palette if the character model's element is renamed. However, if you are sure that the structure of your 

Harmony database w ill remain static and available at all time and at all steps of your production, then you can 

store your palettes in whichever job or environment you see fit.

Another reason why it is better to store shared palettes in a scene's job or environment is because, when you 

export a Harmony scene, you can choose to export the palettes in the scene's job or environment palette 

libraries along w ith it. These palettes are then stored w ith the exported scene and, when importing the scene 

back into the database, you can choose to import the job and environment palettes that were exported w ith it 

back into the scene's job and environment. 

Even in Harmony Stand Alone, you can store palettes at the job or environment level, even though Harmony 

Stand Alone scenes do not have a job or an environment. W hen you do this, palettes are stored inside a 

provisional jobs or environments directory inside the scene directory. If you import your scene to a Harmony 

Server database, you can choose to import the files located in that scene's provisional job and environment 
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into the scene's job and environment. Hence, when using Harmony Stand Alone, you should only store 

palettes at the job or environment level if you intend to import your scene in a database later.

NOTE 

In Harmony Server, even if you store palettes in a job or environment, they w ill not become 

immediately accessible to the scenes inside that job or environment. You must stil l add them to the 

scene's palette list, or to the palette list of one of its elements, before you can use the palette. 
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About Exporting Palettes

It is important to understand what is happening to a palette file when the scene is exported.

Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes in 

the database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing or 

Environment level. The palette files can be accessed from any scene of any project.

W hen you export scenes from Harmony to either archive or send them to other users or studios, you can 

choose to export it w ith palettes stored in the scene's own job or environment, but if your scene uses palettes 

stored in other jobs, environments, or in any other location, those palettes will not be exported. Hence, if you 

w ish to use the same palette for several scenes, it is recommended to store that palette at the environment or 

job level to avoid ever facing a situation where a scene no longer has access to its palette. 

For example, in the follow ing chart, if you export Scene 2 from Job 1, the package w ill carry the palettes from 

Scene 2, Job 1 and Environment. It W ILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2. 

If Scene 2 was linked to any of these, the system will create a recovery palette the next time Scene 2 is opened 

in another Harmony system.
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About Backing Up and Recovering Palettes

Although Harmony Server opens palettes in read-only mode by default, there is always the possibility of 

palettes that are shared between scenes getting modified or their swatches getting deleted by accident. That 

is why it is a good idea to copy and back up your palette libraries, your master palette directories and your 

colour models. 

If you open a scene and a palette file happens to be missing, it w ill stil l appear in the palette list for that scene 

or element, w ith a strike through across its name. 

W hen Harmony attempts to load a drawing that uses colours from a missing palette, or colours that were 

removed from their palette, it w ill display the zones painted w ith the missing colours in red. Then, it w ill 

prompt you to recover the missing colours into a recovery palette. A recovery palette is based on the colour 

information which Harmony stores in each drawing as a backup mechanism. This palette is stored at the scene 

level, and is not shared or sourced externally. 

W hether you choose to perform colour recovery or not, your artwork w ill preserve the colour IDs which 

Harmony uses to associate brush strokes, pencil l ines and fil led zones w ith the colour swatches in your 

palettes. Hence, if you recover your original palette, you can just import or link it back to your scene—and 

remove the recovery palette, if you have one—and Harmony w ill automatically associate your artwork w ith 

the original palette again. You w ill not have to repaint your drawings. 

You can backup your palettes by copying them manually using your operating system's shell, or by cloning 

them using the Palette Operations dialog. In both cases, the palette preserves the colour IDs, making it easy to 

replace a missing palette w ith its backup. For more information on the Palette Operations, see Palette 

Operations on page 367.

337



About the Palette List
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A palette list is a file containing all of the links to the palette files. Each scene created has its own palette list. 

However, it is also possible to assign palette lists to individual layers in a scene. To be able to do that, you 

must first enable Advanced Palette Lists mode—see Enabling the Advanced Palette Lists Mode  on page 332.

 l Scene Palette List 

The scene palette list is simple to understand and convenient. Every element in your scene can use 

colours from a palette in your scene's palette list. This is especially useful for digital animation, as a cut-

out character model w ill often be divided into dozens of different layers which w ill all use the same 

palette.

The scene palette list is stored inside the scene's directory in a file named PALETTE_LIST, and its 

palettes are usually located in the scene's palette-library subfolder.

 l Element Palette List
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An element palette list is a list of palettes that is associated to an individual layer (element) in your 

scene. Only the drawings inside that element are able to use the colours in the palettes of its element 

palette list. The palettes in an element palette list w ill only be visible in the colour view when a 

drawing from that element is selected. This can be useful if you are doing traditional animation in which 

characters are usually drawn on a single layer, so you can assign each character to their individual 

palette.

An element's palette list is stored in a file named PALETTE_LIST, inside the element's directory in the 

scene's elements subdirectory. An element's palettes can be stored in palette-library 

subdirectory of the element's directory.

If you have the Advanced Palette List preference enabled, then you can build a palette list by creating palettes 

in different locations, or linking to palettes from different locations. You might notice that the icon left of each 

palette in the list looks different depending on where the palette is sourced from. The follow ing is a table 

explaining the meaning of each icon in the list. 

Icon Description

Indicates that the palette is stored at the same level as its palette list. For example, a palette that is 

stored in the scene's palette library and which is listed in the scene's palette list, or a palette that is 

stored in an element's palette library and which is listed in that same element's palette list. 

Indicates that the palette file is stored in an external location, such as a different scene, an element in 

a different scene, a job other than the scene's job, or an environment other than the scene's 

environment. This means the palette is liable to be missing if it is moved from its original location, or if 

the scene is exported from the database into an offline scene or to a different database.

This indicates that the palette is stored at a higher level than its palette list, making it a shared 

palette. For example, a palette in your scene's palette list that is stored in the palette library of the 

scene's job or environment, or a palette in an element's palette list that is stored in the palette library 

of the scene.
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Indicates a potentially dangerous situation. For example, a palette file that is stored in one of the 

scene's element folders, but which is added to your scene's palette list. The whole scene can use the 

palette, but since it's stored inside an element, deleting that element w ill make your whole scene lose 

access to that palette. 
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Showing and Hiding the Palette List

By default, the palette list is enabled. If you want to only use one palette for all of your scenes, you can disable 

the palette list simply by collapsing it, which w ill give more vertical space to your colour swatch list:

How to show or hide the palette list

 1. In the Colour view, right over the palettes list, click on the expand/collapse arrow to expand or 

collapse the palettes list. 
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Locking and Unlocking the Palette List

In Harmony Server, palette lists are open in read only mode when loading a scene. This is to prevent users 

from accidently removing palettes. To create, link to, reorder or remove palettes, you must first unlock your 

scene's palette list. 

How to lock and unlock to the palette list

 1. Do one of the follow ing:

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option 

is checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

A grey pencil appears on the top-right corner of the Palette list to indicate that it can be modified.
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Displaying Colour and Pencil Texture Palettes

Besides regular colour palettes, Harmony also supports pencil texture palettes. A pencil texture can be 

combined w ith a colour to create pencil l ines of various styles, ranging from styles reproducing traditional 

drawing tools such as chalk or felt to simple patterns like dots and circles. For more information, see About 

Pencil Line Textures on page 134.

By default, the Colour view only lists colour palettes in its palette list. You can make the Colour view list only 

pencil texture palettes, or all types of palettes.

How to change the palette list's filter to show colour palettes, pencil texture palettes, 
or both

 1. In the Colour view, do one of the follow ing:

 l If you only want to only see colour palettes, press the Show Colour Palettes  

button.

 l If you only want to see texture palettes, press the Show Texture Palettes  button.

 l If you want to see both types of palettes, press the Show All Palettes  button.

NOTE 

If you open the Link Palette dialog, it w ill only list either colour palettes or pencil texture palettes, 

depending on which filter is currently applied to the palette list. If the palette list is set to display 

all palettes, the dialog w ill l ist the type of palettes of the last palette list filter that was used.
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Creating a Palette
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You can create a palette in either Basic or Advanced mode.

By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended to use 

the Basic mode.  This setting stores the palettes automatically for you and saves them at the Scene level. 

W hen you use the Advanced Palette Lists mode, you can decide at which level you want to store your 

palettes: Environment, Job, Scene, or Element.To enable Advanced Palette Lists, see Enabling the Advanced 

Palette Lists Mode  on page 332.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 

one of the follow ing:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 

checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

      How to create a new palette (Basic palette list mode)

 1. Do one of the follow ing:

 l In the Colour View, click the New Palette  button over the palette list.

 l From the Colour view menu, select Palettes  > New

The Create Palette dialog box opens.

 2. In the Create Palette dialog, enter the new palette's name. Make sure your palette name contains 

information to be easy to identify, such as the name of the character and information about the type 

of setting for this palette, if any.

 3. Set the Palette Type to Colour if you want to create a colour palette, or to Pencil Texture if you 

want to create a pencil texture palette—see About Pencil Line Textures.

 4. Click OK.

The palette appears in the drawing element’s palette list.
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How to create a palette (Advanced palette list mode)

 1. If you want to add the palette to an element's palette list, select a drawing from the element for 

which you want to create a palette in the Timeline, Xsheet or Camera view. 

 2. Do one of the follow ing:

 l In the Colour View, click the New Palette  button over the palette list.

 l From the Colour view menu, select Palettes  > New

The Palette Browser dialog box opens. 

 3. In the Palette Location panel, select the location where you want to store the palette file. If you are 

using Harmony Server, you can store the palette in any environment, job, scene or element on your 

database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 

or inside its provisional job or environment. For more information, see About Palette Storage 

Locations on page 334.
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 4. In the New Palette Name field, enter the name for the new palette. The palette list above this field 

lists the palettes that already exist in the selected location. Make sure you enter a name that is not 

already used by another palette. 

 5. Set the Palette Type to Colour if you want to create a colour palette, or to Pencil Texture if you 

want to create a pencil texture palette—see About Pencil Line Textures.

 6. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 

List, or to the Element Palette List of the currently selected element. Note that in the latter case, 

the palette w ill only be usable by the element. For more information, see About Scene and Element 

Palette Lists on page 333.

 7. Click OK. 

The new palette appears in the palette list.
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Linking a Colour Palette
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Linking a palette means adding a palette to your scene's palette list, or to an element's palette list, w ithout 

making a local copy of that palette in your scene's palette library. This means your scene w ill depend in this 

palette remaining in its location in order to render its colours, but it allows you to reuse the same palette files 

for several scenes, making sure that recurring characters and objects keep their original colours across a 

production and that any late change done to their colour scheme can be quickly reflected across all your 

scenes. 

In Harmony Server, environments, jobs, scenes and elements can all have their own palette library, and you 

can link to a palette from the palette library of any environment, job, scene or element in your database. 

However, to make it easier to ensure scenes do not lose access to their palettes, it is recommended to only link 

to palettes from within the scene's own environment, job, scene or elements. The most important reason for 

this is that if you export a scene that uses palettes from other jobs, environments, scenes or elements, these 

palettes w ill not be exported. Hence, they w ill be missing if you import them in a different database. However, 

you can export a scene w ith all of its assets along w ith the assets contained in its own job and environment. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 

one of the follow ing:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 

checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to link a colour palette

 1. If you want to add the palette to an element's palette list, select a drawing from the element for 

which you want to create a palette in the Timeline, Xsheet or Camera view. 

 2. Do one of the follow ing:

 l From the Colour View menu, select Palettes > Link. 

 l Right-click and select Link.

 l Click the Link Palette  button.

The Palette Browser: Link Palette dialog box opens.
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 3. In the Palette Location panel, browse to the location of the palette you want to link to.

 4. In the Palette l ist, select the palette you want to link to.

 5. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 

List, or to the Element Palette List of the currently selected element. Note that in the latter case, 

the palette w ill only be usable by the element. For more information, see About Scene and Element 

Palette Lists on page 333.

The palette appears in the Colour view.
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Importing a Colour Palette
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You can import an existing palette from your file system or network into your scene. This w ill create a copy of 

the palette file and add it to your palette list. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 

one of the follow ing:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 

checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to import a palette into your project                                      (Basic palette list mode)                

 1. Do one of the follow ing:

 l From the Colour menu , select Palettes > Import. 

 l Right-click on the palette list and select Import.

The Browser w indow opens.

 2. Browse for a palette file located (*.plt) on your hard drive. You can usually find a scene's palettes 

by browsing to the palette-library sub-folder of the scene's folder.

 3. Click Open.

The Import Palette dialog box appears.

 4. In the New Palette Name field, enter the name for the imported palette.

The palette is copied to your project and added to your scene's palette list.

How to import a palette into your project (Advanced palette list mode)

 1. If you want to add the palette to an element's palette list, select a drawing from the element for 

which you want to create a palette in the Timeline, Xsheet or Camera view. 
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 2. Do one of the follow ing:

 l From the Colour menu , select Palettes > Import. 

 l Right-click on the palette list and select Import.

The Browser w indow opens.

 3. Browse for a palette file located (*.plt) on your hard drive. You can usually find a scene's palettes 

by browsing to the palette-library sub-folder of the scene's folder.

 4. Click Open.

The Palette Browser dialog box appears.

 5. In the Palette Location panel, select the location where you want to store the palette file. If you are 

using Harmony Server, you can store the palette in any environment, job, scene or element on your 

database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 

or inside its provisional job or environment. For more information, see About Palette Storage 

Locations on page 334.

 6. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 

List, or to the Element Palette List of the currently selected element. Note that in the latter case, 

the palette w ill only be usable by the element. For more information, see About Scene and Element 

Palette Lists on page 333.

 7. In the New Palette Name field, name the imported palette.

The palette is copied to your project and added to your scene's palette list.
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Consolidating Used Colours Into a Single Palette

Using the Create Palette from Selection dialog, you can instantly generate a single palette that contains all the 

colours used in your artwork, and no other colours. This can be useful if you have used colours from several 

different palettes to design the colours for a character, background or prop, and want this asset to have its 

own dedicated palette. 

NOTE 

The Create Palette from Selection dialog uses the colours in all the drawings in the selected 

layers, even drawings that are not exposed. 

How to create a single palette with the colours used by one or several drawings

 1. In the Timeline, Camera, Xsheet or Node view, select all the layers for which you want to create a 

single colour palette.
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TIPS 

 l To select multiple layers, press and hold the Ctrl (W indows/Linux) or ⌘  (macOS) 

key, then click on each layer you want to select.

 l In the Timeline or Xsheet view, you can select a contiguous series of layers by 

clicking on the first layer you want to select, then, while holding Shift, clicking on 

the last layer you want to select. Every layer in-between w ill also be selected. 

 l If your scene has a complex layer hierarchy, you can expand all the layers in the 

Timeline view by pressing 9 before selecting all the layers in your scene.

 l To select all layers in your scene, select Edit > Select All in the top menu or press 

Ctrl + A (W indows/Linux) or ⌘  + A (macOS).

 l To select all but a few specific layers, select the layers you want to exclude, then 

select Edit > Invert Selection in the top menu or press Ctrl + Shift + I 

(W indows/Linux) or Shift + ⌘  + I (macOS).

 2. In the top-left corner of the Colour view, open the  View Menu and select Palettes > New 

Palette from Selected Drawings.The Create Palette from Selection dialog appears.

NOTE 

If the Advanced Palette Lists preference is enabled, the dialog w ill also have a palette 

browser to allow you to select where to store the palette and whether to associate the 

palette to the scene or to an element. For information on how to create a palette in 

Advanced Palette Lists mode, see Creating a Palette.

 3. In the Name field, type in the name for the palette to create.

 4. In the Palette Type drop-down, select Colour if you want to create a palette containing all the 

colours, gradients and bitmap textures in the selected layers, or select Pencil Texture if you want 

to create a palette containing all the pencil textures in the selected layers.

 5. If you want the swatches in the new colour palette to have different colour IDs than the ones 

currently used by the selected drawings, check the Generate New Colour IDs and Recolour 

Selected Drawings option. 
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NOTES 

 l This option creates a palette w ith new colour IDs, and replaces the old colour IDs in 

your artwork w ith the new ones. This w ill typically not cause any visible change, 

and it w ill prevent your new palette from using the same colour IDs as the palettes 

that are currently in your scene. This is important because, when two colour 

swatches in two different palettes have the same colour ID, the zones fil led w ith 

that colour ID w ill appear in the colour in the top-most palette. If you want to 

prevent this, it is recommended to check this option.

 l If there are any Colour-Override in the selection, they w ill not be updated to use the 

new colour IDs, which w ill cause them to no longer work w ith your artwork unless 

you reconfigure them manually. Using this option is not recommended in this case.

 6. Click on OK. 

A new palette is generated containing all the colours used in all the drawings in the selected layers 

and is added to the palette list.
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Renaming a Palette

T-ANIMPA-003-003

You can rename a colour palette to keep your list organized. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 

one of the follow ing:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 

checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to rename a palette

 1. In the Colour view, select the palette to rename.

 2. Do one of the follow ing:

 l Right-click and select Rename.

 l From the Colour View menu, select Palettes > Rename.

 3. In the Rename dialog box, give the palette a new name and click OK.
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Removing a Palette

You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file w ill 

not be deleted, so you can add it back to your palette list later if you need it. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 

one of the follow ing:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 

checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to remove a palette

 1. In the Colour view, select the palette to remove.

 2. Do one of the follow ing:

 l From the Colour View menu, select Palettes > Remove. 

 l Right-click on the selected palette and select Remove.

 l Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted w ith its colours turn red.
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NOTE 

If you w ish to delete the palette file, you can select the Remove and Delete From Disk option 

from the same menu. You w ill be prompt to confirm the deletion. Note that the palette w ill be 

deleted from your file system, and there w ill be no way to recover it. 
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Duplicating a Palette 

A duplicated palette is a simple copy of the original palette. W hen you duplicate a palette, the duplicated 

palette w ill have the same colour names and values, but w ill have different colour IDs so that Harmony does 

not mix it up w ith its original palette. This is useful when you want to create different palettes for similar 

models, but want to avoid having to create the palette and its colours all over again. You can just start w ith 

your duplicate palette, tweak the colours and  add and remove colours as needed.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 

one of the follow ing:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 

checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to duplicate a palette                                      (Basic palette list mode)                 

 1. In the Colour view, select a palette to duplicate.

 2. Do one of the follow ing: From the Colour  menu, select Palettes > Duplicateor right-click and select 

Duplicate.

 l Right-click on the palette and select Duplicate.

 l Open the Colour menu , then select  select Palettes > Duplicate.

The Duplicate palette dialog box opens

 3. In the New Palette Name field, enter the name for the new palette. By default, the palette's name 

is based on the original palette name followed by "-copy". The palette list above this field lists the 

palettes that already exist in the selected location. Make sure you enter a name that is not already 

used by another palette. 
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 4. Click OK.

The duplicated palette appears in the palette list.

How to duplicate a palette (Advanced palette list mode)

 1. In the Colour view, select a palette to duplicate.

 2. Do one of the follow ing: From the Colour  menu, select Palettes > Duplicate or right-click and 

select Duplicate.

 l Right-click on the palette and select Duplicate.

 l Open the Colour menu , then select  select Palettes > Duplicate.

The Palette Browser dialog box opens. 
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 3. In the Palette Location panel, select the location where you want to store the palette file. If you are 

using Harmony Server, you can store the palette in any environment, job, scene or element on your 

database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 

or inside its provisional job or environment. For more information, see About Palette Storage 

Locations on page 334.

 4. In the New Palette Name field, enter the name for the new palette. By default, the palette's name 

is based on the original palette name followed by "-copy". The palette list above this field lists the 

palettes that already exist in the selected location. Make sure you enter a name that is not already 

used by another palette. 

 5. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 

List, or to the Element Palette List of the currently selected element. Note that in the latter case, 

the palette w ill only be usable by the element. For more information, see About Scene and Element 

Palette Lists on page 333.

 6. Click OK.

The duplicated palette appears in the palette list.
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Cloning a Palette 

Cloning a palette creates an exact copy of the palette, where each colour swatch has the same colour ID as in 

the original palette, but which you can modify independently afterward. Since painted zones in drawings are 

associated to their colour by their colour ID, this means that any drawing colored w ith the original palette can 

have its colours replaced w ith the cloned palette's colours just by switching the palette in the scene w ith the 

cloned palette. 

A good example of how this can be useful is when you want to make variants of a character's palette. A 

character usually has only one master palette, although there are times when the characters are placed in 

different lighting conditions and require a different colour shading. The night palette is a popular choice when 

a scene or sequence changes from day to night. Instead of creating a different palette for the character and 

repainting all of its zones w ith the night palette, you can just clone the character's master palette, tweak its 

colours, and the character w ill have its original colours or its night colours depending on which one of the 

palettes is in the palette list, w ithout having to repaint your drawings. 

W hen a palette and its clone are present in the same scene, Harmony uses the palette that is highest in the 

list. If one palette clone is present in the scene's palette list and another clone is present in the element's 

palette list, the element w ill use the palette in its own palette list. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 

one of the follow ing:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 

checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to clone a palette                                       (Basic palette list mode)                 

 1. In the Colour view, select a palette to clone.
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 2. Do one of the follow ing: From the Colour  menu, select Palettes > Clone or right-click and select 

Clone.

 l Right-click on the palette and select Clone.

 l Open the Colour menu , then select  select Palettes > Clone.

The Clone palette dialog box opens

 3. In the New Palette Name field, enter the name for the new palette. By default, the palette's name 

is based on the original palette name followed by "-clone". The palette list above this field lists the 

palettes that already exist in the selected location. Make sure you enter a name that is not already 

used by another palette. 

 4. Click OK.

The cloned palette appears in the palette list.

How to clone a palette (Advanced palette list mode)

 1. In the Colour view, select a palette to clone.

 2. Do one of the follow ing: From the Colour  menu, select Palettes > Clone or right-click and select 

Clone.
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 l Right-click on the palette and select Clone.

 l Open the Colour menu , then select  select Palettes > Clone.

The Palette Browser dialog box opens. 

 3. In the Palette Location panel, select the location where you want to store the palette file. If you are 

using Harmony Server, you can store the palette in any environment, job, scene or element on your 

database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 

or inside its provisional job or environment. For more information, see About Palette Storage 

Locations on page 334.

 4. In the New Palette Name field, enter the name for the new palette. By default, the palette's name 

is based on the original palette name followed by "-clone". The palette list above this field lists the 

palettes that already exist in the selected location. Make sure you enter a name that is not already 

used by another palette. 

 5. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 

List, or to the Element Palette List of the currently selected element. Note that in the latter case, 

the palette w ill only be usable by the element. For more information, see About Scene and Element 

Palette Lists on page 333.

 6. Click OK.

The cloned palette appears in the palette list.
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NOTE 

You can modify your cloned palette by changing its colour swatches individually, or you can use 

the Tint Panel to change all of the palette's colour swatches simultaneously—see Tinting a 

Palette's Colour Swatches on page 364.
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Tinting a Palette's Colour Swatches

You can use the Tint Panel dialog to offset, blend or mix all the different colour swatches in a palette 

simultaneously. This can be useful if you want to give a cloned palette a different tint, for example to make a 

night-themed version of a character's master palette. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 

doing one of the follow ing:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 

Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 

to Modify All Palettes.

How to tint a palette

 1. In the Palette list, select the palette you want to tint.

 2. From the Colour View  menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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 3. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A 

(W indows/Linux) or ⌘  + A (macOS).

 4. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

 5. Select the Preview option to see a preview of the colours while you adjust them.
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Reordering Palettes in the Palette List

You may want your palettes to be listed in a specific order. In a lot of cases, this is strictly a matter of 

convenience. However, if your palette list contains palettes that have been cloned off each other, Harmony 

w ill use the palette that is located the highest in the list to determine the colours to use in the drawings. 

Hence, if you are using cloned palettes, you must mind the order of your palettes in the palette list. For more 

information, see Cloning a Palette  on page 360.

NOTE 

If a palette in the scene's palette list has been cloned into an element's palette list, Harmony w ill 

use the palette in the element's palette list for this element. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 

one of the follow ing:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 

checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to reorder palettes in the palette list

 1. Select the palette you w ish to reorder.

 2. Do one of the follow ing:

 l In the Palette list toolbar, click the Up  or Down  buttos.

 l From the Colour View menu, select Palettes > Move Up or Move Down. 
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Palette Operations

W hen you start Toon Boom Harmony connected to the database, you can access the Palette Operations 

dialog box which lets you clone, rename, or delete palettes in your database, w ithout having to open a scene 

or browse the database's file system in your operating system's shell. 

NOTE 

The Palette Operations dialog box never makes any change to any palette list in your database. All 

it allows you to do is manipulate palettes files. You should be careful not to rename or delete 

palettes that are required by some of your existing scenes, or Harmony w ill be unable to locate 

those palettes when you open one of those scenes.

367



Opening the Palette Operations Dialog Box

You can open the Palette Operations dialog box in Harmony Server.

How to open the Palette Operations dialog box

 1. Start Paint and log in. 

 2. Close the Database Selector dialog box. 

 3. From the top menu, select Tools > Palette Operations. 

The Palette Operations dialog box opens. 

368

Harmony 22 Paint User Guide                          



Chapter 4: Painting and Colours

Cloning a Palette in the Palette Operations Dialog Box

From the Palette Operations w indow, you can clone palettes in Harmony Server.  

How to clone a palette in the Palette Operations dialog box 

 1. Select the palette you want to clone at the location and level in which it was stored. 

 2. Click Clone. 

A W arning dialog box opens. 

 3. Select the Don't show this message again option if you do not want to see this message every 

time you perform this operation.

 4. Click Yes.

The Palette Browser dialog box opens. 

 5. Select the level to store the palette file.
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 6. In the New Palette Name field, enter the name of your palette. 

 7. Click OK.
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Renaming a Palette in the Palette Operations Dialog Box

You can rename palettes in the Palette Operations dialog box in Harmony Server.

How to rename a palette in the Palette Operation dialog box

 1. Select the palette you want to rename at the location and level in which it was stored. 

 2. Click Rename.

A W arning dialog box opens. 

 3. Select the Don't show this message again option if you do not want to see this message every 

time you perform this operation.

 4. Click Yes.

The Rename Palette dialog box opens. 

 5. Type in a name for the palette. 
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 6. Click OK. 
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Deleting a Palette in the Palette Operations Dialog Box

You can delete palette files from the Palette Operations dialog box in Harmony Server. 

How to delete a palette in the Palette Operation dialog box

 1. Select the palette you want to delete at the location and level in which it was stored. 

 2. Click Delete. 

A W arning dialog box opens. 

 3. Select the Don't show this message again option if you do not want to see this message every 

time you perform this operation.

NOTE 

It is not recommended to disable the warning message as deleting a palette 

cannot be undone. 

 4. Click Yes.
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About Painting

Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-based, the 

colour zones are completely fil led and there are no scattered spots left blank. Also, there are some actions 

that can be applied on an entire animation sequence at once, like dirt removal, some colour fil l ing, line 

repainting, and so on.

W hen traditional animation is traced, cleaned up, scanned in and properly exposed, it 's time for the ink and 

paint process. This consists of cleaning all dirt and hair (for example, dust that was in the scanner, dots that do 

not belong in the drawing, extra floating artwork around the drawing that must be removed), painting the 

lines and fil l ing the colours in the empty zones on an entire animation sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt to 

clean, only painting and inking. 

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by 

assigning a set of colours to each character, prop or effect. The colour styling artist w ill create a new palette 

and add a new colour for each zone of the character, such as the skin, hair, tongue, shirt, pants, and so on. Each 

colour is known as a colour swatch—see About Palettes on page 329. 

374

Harmony 22 Paint User Guide                          



Chapter 4: Painting and Colours

About Colour Models

Once you have a fully painted drawing, you can use it as a colour model and load it in the Reference view. That 

drawing can be used and loaded in any of your Harmony scenes—see Painting Drawings on page 386. 

Once a drawing is loaded in the Reference view, you can use the Reference view’s  Colour Eyedropper tool 

to select a colour from the model and use it to paint in your Drawing  view without having to pick the colour 

from the colour palette.

You can do more than just copy colours from a colour model. Harmony gives you the ability to copy parts of the 

character directly from its colour model and paste these elements into the Drawing  view.
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Loading Colour Models

T-ANIMPA-004-005

You can load any TVG drawings in your Model view. To avoid browsing for models every single time you work 

on your scene, you can store default models in your scene and load those. 

How to browse for a colour model drawing on your hard drive

 1. Do one of the follow ing:

 l Right-click in the Reference View and select Import References.

 2. In the Browser w indow, browse for any *.tvg drawing file on your hard drive or in the database for 

Harmony Server.

 3. Click Open. 

The model appears in the Reference view.

How to load the default models

 1. In your scene ’s folder, create a new folder and name it models.

 2. On your hard drive, copy the *.tvg drawing files you want to use as colour models in your scene.

 3. Paste the copied models in the models folder you created.

 4. Do one of the follow ing:

 l Right-click in the Reference View and select Load Default References.
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Clearing Colour Models

You can remove colour models from the Reference view. 

How to clear a colour model

 l Right-click in the Reference view, select Clear Model or press Del.
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Flipping Between Models

T-LAY-002-001

Once your models are loaded in the Reference view, you can flip through them using a keyboard shortcut or 

toolbar buttons.

How to flip between models

 1. Do one of the follow ing:

 l Right-click in the Reference view and select Next or Previous.

The previous or next model appears in the Reference view.
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Copying Colour Models

You can copy pieces or the entire colour model to paste in your scene, 

How to copy the entire model from the Model view

 1. Right-click and select the Select  tool.

 2. In the Reference view, select your model.

 3.  Press Ctrl + C (W indows/Linux) or ⌘  + C (macOS).

 4. Select the Drawing view, then go to the top menu and select Edit > Paste Drawing Object or press 

Ctrl + V (W indows/Linux) or ⌘  + V (macOS). 

The model appears in the selected view.

How to copy part of the model from the Reference view

 1. Right-click in the Reference view and select Cutter Selection or press Alt + T.

 2. In the Reference view, use the Cutter tool to create a selection around the part of your model that 

you want to copy.
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 3. PressCtrl + C (W indows/Linux) or ⌘  + C (macOS).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Do one of the follow ing:

 l Select the Drawing view and select Edit > Paste Drawing Object. 

The model appears in the selected view.

380

Harmony 22 Paint User Guide                          



Chapter 4: Painting and Colours

About Dirt Cleanup

T-INK-002-001

W hen paper drawings are passed through a scanner, there can be some hair and dirt scattered across them. 

These lines and dots need to be cleaned. Harmony provides different tools to help get rid of them quickly.

If there are some marks that cannot be removed w ith the automated tools, you can erase them with the Eraser 

tool or select them with the Select tool and then delete them. It's always safer to select and delete them than 

to erase them, so you do not overlook anything.
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Removing Dirt

T-INK-002-002

The Remove Dirt tool selects small dots and hairs on the drawing.

Raising the Remove Dirt level w ill select bigger dots. W hen selecting larger dots, be careful not to lose small 

details like pupils and nostrils. Once you have chosen the level, you can apply it to the current drawing or the 

entire animation sequence. This is a quick way to get rid of most dirt and dust.

During this process, the dirt that w ill be removed is highlighted in red.

How to use the Remove Dirt tool

 1. Do one of the follow ing:

 l From the top menu, select Drawing > Remove Dirt.

 l Press Shift + D.

 2. Increase the Remove Dirt value by moving the slider to the right.

 3. Select the Apply to All Drawings option if you want to apply the operation to all drawings in the 

layer.
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Removing Dirt Outside the Selection

T-INK-002-003

The Remove Art Outside Selection option lets you remove any art existing outside a selection. It is 

recommended that you clean your Colour Art level as well. If you have a stroke accumulation in your Colour 

Art, it can result in large output files, especially if you work in high-definition resolutions.

How to clean dirt with Remove Art Outside Selection

 1. In the Tools toolbar, select the  Select  tool.

 2. From the top menu, select Options > Permanent Selection.

 3. Draw a selection around the animation making sure to include the entire animation sequence.

 4. From the top menu, select Selected one of the follow ing options:

 l Remove Art Outside Selection to delete artwork outside your selection on a single 

drawing.

 l Remove Art Outside Selection on All Drawings to delete artwork outside your 

selection on all the drawings.

The art outside the selection is removed.
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Removing the Art Inside the Selection

T-INK-002-004

You can delete any art inside a selection w ith the Remove Art Inside Selection option. W e recommend that you 

clean your Colour Art level as well. If you have a stroke accumulation in your Colour Art, it can result in large 

output files, especially if you work in high definition resolutions.

You can simultaneously apply this operation to all your drawings in the layer by using the Remove Art Inside 

Selection on All Drawings command.

How to clean dirt with Remove Art Inside Selection

 1. In the Tools toolbar, click the Select tool or press Alt + S.

 2. To apply the action to your entire animation, select Options > Permanent Selection.

 3. In the Drawing view, draw a selection around the animation. Make sure the area is large enough to 

include all the zones to be cleaned up on all drawings.

 4. From the top menu, select Selected > Remove Art Inside Selection to delete artwork inside your 

selection on one single drawing. You can also press Delete.

 5. To apply the action on all your drawings in the layer, select Selected > Remove Art Inside 

Selection on All Drawings to delete artwork inside your selection on all the drawings.
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Removing Hair

T-INK-002-005

The Remove Hair command lets you remove any small strokes created in the Colour Art layer from very thick 

lines or fil led zones. Increasing the Remove Hair level value w ill select larger strokes for removal from the 

drawing.

How to use the Remove Hair tool

 1. Select the drawing containing the drawing to clean.

 2. From the top menu, select View > Show Strokes to display the invisible lines or press K.

 3. In the top menu, select Drawing > Remove Hair.

The Remove Hair dialog box opens.

 4. Move the slider to the right to increase the number and length of hairs to be selected. 

 5. Select the Apply to All Drawings option if you want to apply the operation to all the drawings in 

the layer.

 6. Click OK.
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Painting Drawings

T-HFND-004-011

The main tool you w ill use to paint your drawings w ith is the Paint  tool. The Paint tool can be used in several 

different modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil l ines. If there are gaps in the lines 

defining a zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic Close Gap 

option.

NOTE 

To learn more about the Paint tool options, see the Reference guide .

How to paint drawings

 1. Select the drawing on which you want to paint.

 2. Do one of the follow ing:

 l In the Tools toolbar, click the Paint  tool.

 l From the top menu, select Tools > Paint or press Alt + I..

 l Press Alt + I. 

In the Tool Properties view or Tools toolbar, you can select additional painting modes. 

 l The Paint   mode paints everything it touches, including empty and fil led zones.

 

 l The Paint Unpainted  mode paints only empty zones. Any line or fil led zone w ill 

remain unchanged.
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 l The Repaint   mode paints everything it touches except empty zones. Any zone that 

is not painted w ill remain intact.

 l The Unpaint   mode unpaints everything it touches, including empty and fil led 

zones.

 3. In the Colour view, select a colour.

 4. In the  Drawing  view, start painting. Click on a zone or pencil l ine to paint it, or trace a lasso or 

marquee selection to paint several zones or pencil l ines at the same time.
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NOTE 

The last colour you select while using the Paint tool w ill be used the next time 

you select the Paint tool if you're using the unlocked painting tools in the Colour 

view.

Authors

Marie-Eve Chartrand

        Christopher Diaz

chrisdiazart.com
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Painting Several Drawings Simultaneously

You can use the Paint tool on several drawings in the same layer at the same time. W hen you set up the Paint 

tool to work on several drawings, if you click on a colour zone in the current  drawing to fil l it, it w ill fil l any 

colour zone located where you clicked in other drawings as well. This can be useful if you have several 

drawings w ith colour zones that mostly overlap each other, such as in a typical walk cycle, or in any animation 

where the character mostly stays in place:

There are two approaches to painting several drawings at the same time. Both are options available in the 

Tool Properties view:

 l  Apply to All Frames: W hen you click on a colour zone in the Drawing view, it w ill fil l the area you 

clicked on in every exposed drawing in the current layer.

 l  Apply to Onion Skin Range: W hen you click on a colour zone in the Drawing view, it w ill fil l the 

area you clicked on in every drawing that is displayed in the Onion Skin. This method allows you to only 

fil l a specific range of drawings, and allows you to see those drawings in the Drawing view as you fil l 

them.

How to paint a specific range of drawings simultaneously

 1. In the thumbnails list, select a drawing somewhere in the middle of the range that you want to 

paint. 

 2. In the Tools toolbar, click on the  Onion Skin button to enable Onion Skin.

 3. Using the Options in the View > Onion Skin menu, adjust the amount of previous and next 

drawings displayed in the Onion Skin until all the drawings you want to pain simultaneously are 

displayed. 

The drawings included in the Onion Skin range w ill appear in red and green in the Drawing view. 

 4. In the Tools toolbar, select the  Paint tool. 
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 5. In the Tool Properties view, click and hold on the  Apply to All Frames button and, in the pop-up 

menu, select  Apply to Onion Skin Range. 

NOTE 

If this button is already set to  Apply to Onion Skin Range, simply click on it to toggle 

it on.

 6. In the Drawing view, click in an area where the colour zones for all the drawings in the Onion Skin 

overlap each other to fil l them all simultaneously. 

How to paint all exposed drawings in a layer simultaneously

 1. In the thumbnails list, select any drawing. 

 2. In the Tools toolbar, select the  Paint tool. 

 3. In the Tool Properties view, click on the  Apply to All Frames button to enable the Apply to All 

Frames mode. 

NOTE 

If this button is currently set to  Apply to Onion Skin Range mode, click and hold on 

the button to open its pop-up menu and select  Apply to All Frames.

 4. In the Drawing view, click in an area where the colour zones for most or all of your drawings 

overlap each other to fil l them all simultaneously. 
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Repainting

T-ANIMPA-011-004

You can use the Paint tool to click on the zones to repaint. If you click in an empty zone, it w ill fil l the area.  

You can repaint lines, zones, and brush strokes using the Repaint tool. The repaint pencil l ines more efficiently, 

see Inking Lines on page 400. The Repaint tool does not fil l empty zones, even if they are closed.

The Brush tool can be used to repaint specific segments. The Brush tool's Repaint Brush mode is used to paint 

a section by manually painting over the lines. This is useful when the vectorization triangles are not placed as 

you would like or you simply need to repaint a section of a segment. It is also useful for paperless animation, 

where there are no triangles. So, the Repaint Brush is used to paint a certain area. It acts like the Brush tool, 

but w ill only show on painted areas that are already painted. 

Unlike the Brush tool's regular mode, the Repaint Brush mode flattens automatically. The brush strokes are 

not added one on top of each other. 

NOTE 

To avoid repainting specific colours, see Protecting Colours

How to access the Repaint Tool

 1. In the Tools toolbar, select the Repaint  tool. You can also find the option in the Tool Properties 

view when the Paint tool is selected. 

 2. In the Drawing view, click on the zones to repaint. You can also make a lasso or marquee selection 

around several zones.

How to enable the Repaint Brush mode

 1. In the Tools toolbar, select the Brush  tool.

 2. In the Tool Properties view, click the Repaint Brush  button. 

 3. In the Drawing view, draw on the zones to repaint.
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Repainting a Selection

 The Repaint Selection command is used to repaint any art inside a selection. You must first draw a selection 

using the Select  tool in order for this command to be available. You can also click on the colour swatch in the 

colour palette to automatically repaint your selection.

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the 

drawings contained w ithin the same layer. You must enable the Permanent Selection  option in the Select tool 

Tool Properties view and then select an area of your drawing using the Select  tool in order for this command 

to be available. The Permanent Selection option lets you maintain the same selection throughout the drawings 

of a same layer.

NOTE 

To avoid repainting specific colours, see Protecting Colours
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How to repaint a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the zones to repaint. 

 3. To repaint the selection on all drawings,  enable the Permanent Selection  option in the Select 

tool Tool Properties view.

 4. Do one of the follow ing: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > 

Repaint Selection or Repaint Selection on All Drawings.

 l From the top menu, select Selected > Paint > Repaint Selection or Repaint 

Selection on All Drawings.
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Repainting Outside a Selection

The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection has been 

drawn using the Select   tool, the entire drawing w ill be repainted.

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection on all 

the drawings contained w ithin the same layer. You must enable the Permanent Selection  option in the Select 

tool Tool Properties view and then select an area of your drawing using the Select  tool in order for this 

command to be available. The Permanent Selection option lets you maintain the same selection throughout 

the drawings of a same layer.

NOTE 

To avoid repainting specific colours, see Protecting Colours

How to repaint outside a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the zones you do not want to repaint. 
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 3. To repaint outside the selection on all drawings,  enable the Permanent Selection  option in the 

Select tool Tool Properties view. 

 4. Do one of the follow ing: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > 

Repaint Outside Selection or Repaint Outside Selection on All Drawings.

 l From the top menu, select Selected > Paint > Repaint Outside Selection or Repaint 

Outside Selection on All Drawings.
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Unpainting a Selection

The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first draw a 

selection using the Select  tool in order for this command to be available.

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection on all 

the drawings w ithin the same layer. 

You must enable the Permanent Selection  option in the Select tool Tool Properties view and then select an 

area of your drawing using the Select  tool in order for this command to be available. The Permanent Selection 

option lets you maintain the same selection throughout the drawings of a same layer.

How to unpaint a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the zones to unpaint. 

 3. To unpaint the selection on all drawings,  enable the Permanent Selection  option in the Select 

tool Tool Properties view. 

 4. Do one of the follow ing: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > 

Unpaint Selection or Unpaint Selection on All Drawings.

 l From the top menu, select Selected > Paint > Unpaint Selection or Unpaint 

Selection on All Drawings.
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Unpainting Outside a Selection

The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no selection 

have been drawn using the Select  tool, the entire drawing w ill be unpainted.

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection on all 

the drawings w ithin the same layer. You must enable the Permanent Selection  option in the Select tool Tool 

Properties view and then select an area of your drawing using the Select  tool in order for this command to be 

available. The Permanent Selection option lets you maintain the same selection throughout the drawings of a 

same layer.

How to unpaint outside a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Drawing view, select the zones you don't want to unpaint. 

 3. To unpaint the selection on all drawings,  enable the Permanent Selection  option in the Select 

tool Tool Properties view. 

 4. Do one of the follow ing: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > 

Unpaint Selection or Unpaint Selection on All Drawings.

 l From the top menu, select Selected > Paint > Unpaint Selection or Unpaint 

Selection on All Drawings.
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Closing Gaps

T-HFND-004-014

W hen painting, you may notice that some drawing areas are not closed. To close the zone, you can draw the 

missing line w ith the Brush or Pencil tool, or close the gap w ith an invisible line using the Close Gap tool.

The Close Gap tool allows you to close small gaps in a drawing by creating small, invisible strokes between 

the two closest points to close the colour zone. You do not need to trace directly over the gap. You can draw it 

a few millimeters away. The two closest points automatically close the gap.

How to close gaps

 1. Select View >Show Strokes or press K to see a preview of the result.

 2. In the Tools toolbar, select the Close Gaps  tool.

 3. In the Drawing view, trace a line near the gap to be closed. Your strokes w ill be invisible. 

 4. Enable the Auto-Flatten  option in the Tool Properties view if you want your strokes to be 

flattened w ith your artwork. They w ill cut overlapping drawing strokes in two pieces.

The gap automatically closes.
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Picking a Colour with the Colour Eyedropper Tool

T-ANIMPA-011-002

W hile working in the Drawing view, you can use the Colour Eyedropper  tool to pick a colour from your 

drawing w ithout going to the Colour view. 

NOTE 

To learn more about the Colour Eyedropper tool options, see the Reference guide .

How to use the Colour Eyedropper tool

 1. Do one of the follow ing:

 l In the Tools toolbar, select the  Colour Eyedropper  tool.

 l From the top menu, select Tools > Colour Eyedropper.

 l Press Alt + D. 

 2. In the Drawing view, click on the desired colour.

TIP 

If you're using another drawing tool such as the Paint tool, you can temporarily hold down the 

D key and click in your drawing before releasing the key to pick a colour. W hen you release 

the key,  you w ill return to your previous tool. 
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Inking Lines

T-HFND-004-012

The Ink tool allows you to paint separate segments of pencil l ines.

Although pencil l ines can be painted in much the same way as closed zones, you can use the Paint, Repaint, 

Repaint Brush, and Ink tools to make painting segmented lines easier. Normally when you have a drawing, 

such as the one below, and you use the Paint tool to paint one of the lines, the entire line is painted.

However, if you select the Ink  tool instead and click on the same pencil l ine, only the segment that you clicked 

on between two intersections w ill be painted.

Painting and inking can be used in combination depending on what you need to paint. If you need to ink a 

character’s outline in black, it might be easier to use the Paint tool. If you need to paint the outline of a 

character’s neck w ith a tan colour and its shirt outline blue and both the neck and shirt belong to the same 

continuous outline, then the Ink tool might prove more useful.

NOTES 

 l To avoid repainting specific colours, see Protecting Colours

 l To learn more about the Ink tool options, refer to the Reference Guide.

How to use the Ink tool

 1. In the Tools toolbar, select the Ink  tool located in the Paint tool drop-down menu.  

 2. In the Drawing view, click on the pencil l ines to repaint.
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 l The newly inked segment is always moved on top of all other pencil strokes, even if it 

was behind all other pencil strokes before it was inked. To reverse that behaviour, 

disable the Raise  option in the Tool Properties view.

 l Hold down Alt while clicking a segment to do the opposite option from the Raise 

mode current state.  The inked segment w ill be sent to the back or forward, even if it 

was in front or behind all other segments to begin w ith.
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Verifying Painted Zones

T-ANIMPA-011-008

W hen the ink and paint process is completed, it 's always a good idea to verify that every zone was painted 

properly.

The backlight produces Produces a silhouette effect by changing the drawing’s coloured areas into a single 

dark, solid colour. Use this to verify the completeness of the ink and paint process. Any unpainted zones can be 

seen as the light shows through the unpainted areas of the silhouetted drawing.

How to use the backlight

NOTE 

This feature is only available in the Drawing view.

 1. Do one of the follow ing:

 l From  the top menu, select View > Backlight.

 l From the Tools toolbar, click the Backlight button.

 l Press Alt + Shift + B. 

 2. Verify the drawings in the Colour Art to make sure that all the areas are painted. In the Colour view, 

click the Colour Art  button.

 3. In the Colour view, click the Preview  button  to see the colour zones w ith lines to ensure that 

you did not forget any spots between the colour fil l ing and lines.
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About the Edit Gradient and Texture Tool

T-HFND-006-019

If you paint a zone w ith a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its 

position in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, 

set the first texture position and copy the Edit Gradient/Texture position. W hen moving to the next drawing, 

you can select the next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if you want the Brush and Paint tool to use your gradient’s 

position, angle and scale settings instead of the default ones, you can store your own settings and reuse them 

afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works w ith pencil l ines drawn with 

textured “brushes”. If you then paint your textured pencil l ine w ith a gradient, you can do so and then edit both 

elements independently at the same time.

NOTE 

For information on the Edit Gradient/Texture tool properties, see the Reference Guide
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Using the Edit Gradient and Texture Tool 

T-HFND-006-019A

You can use the Edit Gradient/Texture tool to reposition a texture or gradient w ithin a painted zone. 

How to use Edit Gradient/Texture tool

 1. Do one of the follow ing: 

 l In the Tools toolbar, click the Edit Texture  tool.

 l From the top menu, select Tools > Edit Gradient/Texture.

 l Press Shift + F3.

 2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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 3. Edit the gradient or texture by adjusting the control handles around the selection frame.
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Storing the Gradient and Texture Settings

You can store the position, scale, and angle of a selected gradient or texture to reuse it in other painting zones.

How to store gradient and texture settings

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Camera or Drawing view, select the gradient or texture zone to store.

 3. In the Tool Properties view, click the Store Colour Gradient  button.
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Pasting a Stored Gradient or Texture

You can apply the gradient and texture settings previously stored to paint zones w ith the same gradient or 

texture, in the same position, scale and angle.

How to use the stored gradient and texture settings

 1. In the Tools toolbar, select the Brush  or Paint  tool.

 2. In the Tool Properties view, click the Use Stored Colour Gradient  button.

 3. In the Camera or Drawing view, draw and paint.
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Editing Pencil Line Textures with the Edit Gradient/Texture Tool

You can use the Edit Gradient/Texture tool to tweak the way a texture or gradient is applied onto a pencil l ine. 

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line

 1. Do one of the follow ing:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, select Tools > Edit Gradient/Texture. 

‣ Press Shift + F3.

 2. Click on the pencil l ine to be modified to bring up the editor controls.

 3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull 

on the top of the editor controls to stretch the tiled texture throughout the length of the stroke. 

As gradients are parallel to the stroke’s central vector, this w ill stretch the way that the gradient is 

distributed in the pencil l ine’s envelope. The envelope stil l acts as a boundary for the texture or 

gradient.
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 4. Drag the editor control perpendicular to the stroke. You w ill feel it glide along the strokes central 

vector line. This is another way to resize the texture tile. Instead of stretching or shrinking it 

vertically, this motion stretches or shrinks it vertically. As gradients are parallel to the pencil l ine’s 

central vector, stretching them vertically gives no visual result.

How to use Edit Gradient/Texture tool to edit a pencil line with both a texture and a 
gradient

 1. Do one of the follow ing:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, select Tools > Edit Gradient/Texture. 

‣ Press Shift + F3.

 2. Click on the pencil l ine to be modified to bring up the editor controls.

 3. Use the top editor controls edit the gradient.
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 4. Use the bottom controls edit the “brush” texture.
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About Colour Space Management

411



About Colour Spaces

Colour spaces are profiles defining the rules used by a display device, such as a monitor or a projector, to 

convert numerical colour values into colours. 

In computing, as a general rule, colours are defined by three numerical values: one for red, one for green and 

one for blue, which are the primaries used for additive colour mixing. Each of these values vary between 0 and 

255. Those primary values result in actual red, green and blue light, at an intensity proportional to said value.   

By mixing different primary colours, different hues such as cyan, yellow and magenta can be obtained, and 

mixing all three primaries results in white. 

W here colour spaces come into play is how each primary value is used to determine the intensity of their 

respective colour signal. For example, let’s say you have a blue value of 127, which is halfway between 0 and 

255. The resulting blue light w ill not be exactly halfway between black and the lightest possible blue light the 

display can generate, because monitors don’t convert colour values to colour signals on a linear scale, but 

rather, on a curvilinear scale that is a lot l ike an exponential function. This is because the human eye can 

perceive differences between lower light intensities better than between higher light intensities. Hence, to get 

the most nuances out of the 255 possible values of a primary, the differences between lower values must be 

smaller than the differences between higher values. The point is that, to the human eye, incrementing a colour 

value by 1 results in the same perceived intensity difference regardless of the colour value. 

The curvilinear function used to convert colour values to colour intensities is referred to as the gamma 

conversion curve, and each colour space has its own gamma conversion curve. The most commonly used 

colour space in computing, sRGB, has a gamma conversion curve that is designed to reproduce that of CRT 

displays. However, the most commonly used colour space in HD television, Rec. 709, has a gamma conversion 

curve that is considered better than that of sRGB.

Another aspect of colour spaces is the range of colours they can display. Commonly used colour spaces such 

as sRGB, Rec. 709 and Display P3 can display the same limited subset of the colours that can be perceived by 

the human eye. This subset is especially limited in the range of greens it can display. In contrast, the colour 

space Rec. 2020 is known for supporting a much w ider range of colours, especially in terms of greens, than 

those colour spaces. Rec. 2020 is hence preferred for high end productions, but displays that support Rec. 

2020 are currently very expensive, and hence producing in Rec. 2020 comes at a cost in hardware 

compatibility.

Because of this, productions typically use a specific colour space that is different than that of the standard 

sRGB. This also incurs common production problems such as:

 l Materials such as character models and backgrounds may have been created in a specific colour space 

that is different than the one intended for production. 

 l Project collaborators may be using displays that do not use the colour space intended for the project’s 

delivery. 

 l Compositing artists may also prefer using a specific colour space for compositing, as special effects may 

w ield different results w ith a colour space that uses linear values than w ith a colour space that uses a 

curvilinear gamma curve.
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Colour Spaces in Harmony

To ensure the integrity of colours across your production, Harmony uses sRGB colour space for Toon Boom 

drawings—see Setting the W orking Colour Space for a Scene on page 418. It allows you to specify the colour 

space of your inputs (bitmap images), of your outputs (rendered frames, movies) as well as the colour space 

used internally for compositing your scene. More specifically, you can specify different colour spaces for:

 l Each imported bitmap image

 l The scene

 l The preview image in the Camera view

 l The rendered images and movies

The way it works, when rendering a frame in your scene, is as follows:

 1. Harmony converts the colours of each drawing layer from sRGB colour space to the scene’s working 

colour space.

 2. Harmony converts the colours in each bitmap image from their respective colour space to the scene’s 

working colour space.

 3. All visual elements and effects in your scene are composited together into a single image, all in your 

scene’s working colour space.

 4. The image is converted to the colour space selected for the Camera view or for rendering, depending on 

whether the frame is a preview image or a final frame.

The follow ing graph il lustrates this process:
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NOTE 

If “Read Toon Boom Drawings Using sRGB Colour Space” option is disabled—see Setting the 

W orking Colour Space for a Scene on page 418, in the Camera view the colour spaces of drawing 

layers are used in the Render View mode when converting their respective colour space to the 

scene’s working colour space. In OpenGL View mode, the colour spaces of drawing layers are 

ignored, and the colours of bitmap images are converted directly from their respective colour 

space to the preview colour space, skipping the scene’s colour space.

Hence, in order to properly manage the colours in your production, you must make sure that:

 l The colour space of each bitmap image layer is set to the colour space, used in the imported images—

see Setting the Colour Space of an Element Layer on page 416. 

 l The colour space for your scene is the optimal colour space chosen for composition—see Setting the 

W orking Colour Space for a Scene on page 418.

 l The colour space for your Camera view is set to the colour space supported by your monitor and, 

preferably, the one intended for delivery—see Setting the Display Colour Space on page 420.

 l The colour space used when rendering frames or when exporting a movie is the one intended for 

delivery or for post-production—see Setting the Colour Space for Rendered Movies and Frames on 

page 422.

By default, Harmony supports the follow ing colour spaces:

 l Linear: The same primaries and white point as sRGB and Rec. 709, but w ith no gamma transfer curve 

applied to the colour values. This colour space is useful for compositing intermediary images that are 

meant to be rendered in sRGB or Rec. 709.

 l Display P3: A colour space commonly used for digital projection. It has the same primaries as DCI-P3, 

the same white point as sRGB and the same gamma transfer curve as sRGB.

 l Display P3 Linear: The same as Display P3, except w ith no gamma transfer curve. This colour space is 

useful for compositing intermediary images that are meant to be rendered in Display P3.

 l Rec. 709: The colour space used for HDTV. It has the same primaries and white point as sRGB, but has 

a different gamma transfer curve.

 l Rec. 709 2.4: The same colour space as Rec. 709 or sRGB, except w ith a gamma transfer curve of 2.4 

(per ITU-R BT.1886). This colour space exists because some editing systems use a gamma transfer 

curve of 2.4 instead of the standard gamma curve for Rec. 709.

 l Rec. 2020: A colour space used for Ultra High Definition TV (UHDTV). It has a complex gamma transfer 

curve and primaries that cover more of the human-perceivable colour space than other colour spaces, 

especially in the area of human-perceivable greens. 
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 l Rec. 2020 2.4: The same colour space as Rec. 2020, except w ith a simple gamma transfer curve of 2.4 

(per ITU-R BT.1886). This colour space exists because some editing systems use a gamma transfer 

curve of 2.4 instead of the standard gamma curve for Rec. 2020.

 l Rec. 2020 Linear: The same colour space as Rec. 2020, except w ith no gamma transfer curve. This 

colour space is useful for compositing intermediary images that are meant to be rendered in Rec. 2020.

 l sRGB: A colour space typically used for standard computer monitors. It has the same primaries and 

white point as Rec. 709, but has a different gamma transfer curve.

Those colour spaces are defined using the OpenColourIO specification, which is a text based-technology for 

defining colour spaces and how to convert between them. Hence, it is possible to configure Harmony to 

support different colour spaces as needed. Furthermore, if other software in your pipeline use a specific 

OpenColourIO configuration file to define its colour spaces, Harmony is able to use that file as well for its 

colour space definitions. For more information, see Customizing Available Colour Spaces on page 424.

NOTE 

Any scene created in Harmony 17 or earlier has colour space management disabled by default. To 

enable colour space management on a scene created in older versions of Harmony, see Setting the 

W orking Colour Space for a Scene on page 418.

NOTE 

Any scene created in Harmony 20 has “Read Toon Boom Drawings Using sRGB Colour Space” 

option disabled, see Setting the W orking Colour Space for a Scene on page 418.
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Setting the Colour Space of an Element Layer

You can set the colour space of each bitmap image layer in your scene individually. For Toon Boom vector and 

bitmap drawings by default, Harmony uses sRGB colour space.

W hen rendering your scene, the colours of each bitmap image layer w ill be converted from their respective 

colour space to the scene’s colour space before they are composited together w ith your scene’s effects. The 

colours of the bitmap drawing layers and vector drawing layers w ill be converted from sRGB colour space to 

the scene’s colour space, ignoring the colour space selection of the drawing layers.

NOTE 

In OpenGL View mode, bitmap images are converted from their colour space to the colour space 

selected in the Display Colour Space preference in the Camera tab of the Preferences dialog, and 

the colour space of drawing layers is ignored. 

NOTE 

If “Read Toon Boom Drawings Using sRGB Colour Space” option is disabled—see Setting the 

W orking Colour Space for a Scene on page 418.

 l In Render View mode the colours of the original bitmap images, bitmap drawing layers and 

vector drawing layers are converted from their respective colour space to the scene’s colour 

space before they are composited together.

 l In OpenGL View mode bitmap images are converted from their colour space to the colour space 

selected in the Display Colour Space preference in the Camera tab of the Preferences dialog, 

and the colour space of drawing layers is ignored.

W hen adding a new element layer, by default sRGB is used as the layer’s colour space.

How to set the colour space of an element layer

 1. Open the Layer Properties for the element layer for which you want to select a colour space by 

doing one of the follow ing:

 l In the Timeline view, double-click on the element layer but outside of its name (such as on 

the  icon).

 l In the Timeline view, right-click on the element layer and select Layer Properties.

 l In the Node View, locate the element node and click on its  Layer Properties icon.

 l In the Node View, right-click on the element layer and select Layer Properties.
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 l Add the Layer Properties view to your workspace, then select the element layer in the 

Timeline or Node view.

 2. In the element’s layer properties, select the Drawing tab.

 3. At the bottom, in the Colour Space drop-down, select the colour space for the element layer.
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Setting the W orking Colour Space for a Scene

You can select the working colour space for your scene in the scene settings dialog.

The working colour space is the colour space to which each layer in your scene is converted before all 

elements in your scene are composited together along w ith your scene’s effects. Then, the image is converted 

from your scene’s working colour space to the intended colour space for rendering. Hence, the scene’s working 

colour space is the intermediary colour space in which the compositing is done internally.

TIP 

For optimal compositing, it is recommended to set your scene’s working colour space to the linear 

version of the colour space used by your production. That way, the calculations done for the visual 

effects in your scene are not affected by the gamma curve of your production’s colour space. 

How to set the working colour space for a scene

 1. In the top menu, select Scene > Scene Settings.

The Scene Settings dialog appears.

 2. Select the Colour Space tab.

 3. In the W orking Colour Space l ist, select the desired working colour space for your scene.

 4. Click OK.
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NOTE 

Any scene created in Harmony 20 has “Read Toon Boom Drawings Using sRGB Colour Space” 

option disabled. In this case the colour space information of each drawing layer w ill be used when 

converting to the scene’s working colour space in the Camera view > Render View mode, but 

ignored in OpenGL View mode—see Setting the Colour Space of an Element Layer on page 416. 

Moreover, display colour space in OpenGL View mode is  l imited—see Setting the Display Colour 

Space on page 420
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Setting the Display Colour Space

You can set the colour space in which to display the preview image in the Camera view.

The generation of the preview image works exactly the same as when you’re rendering your scene. You can 

select the colour space in which to display the preview image using the drop-down menu at the bottom of the 

Camera view. Furthermore, if you have several monitors and want to preview your scene in the respective 

colour space of each monitor, you can do so by adding several Camera views to your workspace, moving each 

Camera view to its own monitor and setting the colour space of each Camera view to its monitor’s colour 

space. The different Camera views w ill display in their own colour space. 

If “Read Toon Boom Drawings Using sRGB Colour Space” option is disabled—see Setting the W orking Colour 

Space for a Scene on page 418.

In OpenGL View mode, colour management is much more limited, in the follow ing ways:

 l The colour space used for the preview image cannot be selected individually for each Camera view. 

Hence, instead of using the drop-down at the bottom of the Camera view, it is selected in the Display 

Colour Space preference in the Camera tab of the Preferences dialog.

 l The colours in the bitmap images in your scene are converted directly from their own colour space to 

the preview colour space, w ithout getting converted to your scene’s working colour space first, and the 

colours in the drawing layers in your scene are not processed at all. Hence, in OpenGL View mode, the 

colours in the preview image are not faithful to those of the final rendered image.

How to set the display colour space for the Render View mode of the Camera view

 1. At the bottom of the Camera view, select  Render View.

 2. In the drop-down right of the  Render View button, select the colour space in which you want 

the render preview to be.

How to have an extra camera view displaying on a different monitor and a different 
colour space

 1. In the top menu, select W indows > Camera.

A floating Camera view appears over the Harmony user interface.

 2. Drag the floating Camera view to the monitor where you want it to display.

 3. At the bottom of the Camera view, select  Render View.

 4. In the drop-down right of the  Render View button, select the colour space in which you want 

the render preview to be.
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How to set the display colour space for the OpenGL View mode of the Camera view 
when “Read Toon Boom Drawings Using sRGB Colour Space” option is disabled 

 1. Do one of the follow ing to open the Preferences dialog:

 l W indows or GNU/Linux:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony [Edition] > Preferences.

 l Press ⌘  + U.

 2. Select the Camera tab.

 3. In the Colour Space section, open the Display Colour Space drop-down and select the colour 

space in which you want the OpenGL preview to be.

 4. Click OK.
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Setting the Colour Space for Rendered Movies and Frames

You can select the colour space in which to render your scene in the Export Images and Export Movie dialog. 

W hen rendering a scene, the individual layers are converted from their respective colour space to the scene’s 

working colour space, then they are composited together along w ith your scene’s visual effects, and the 

resulting image is converted to the rendering colour space.

About Tagging Exported Files

Some but not all files exported from Harmony can be tagged w ith their colour space. Tagging is when the 

information for an image or movie file’s colour space is embedded in the file itself, which allows some 

software to automatically load its colour space information instead of requiring you to provide it manually. 

Tagging images and movies w ith their colour space is not necessary, especially if you intend to load the files in 

a video editing or compositing software that allows you to specify their colour space manually, but it can be 

convenient if your post-production software supports reading the colour space information of your source 

files. 

Movies exported from Harmony are only tagged w ith their colour space information when exported in formats 

below:

 l QuickTime ProRes Movie (*.mov): W hen rendering a movie in QuickTime Prores Movie (*mov) format, 

the movie colour space ‘nclc’ tag w ill be only set as:

 l HD (1-1-1) if using “Rec. 709” colour space

 l BT.2020 (9-1-9) if using “Rec. 2020” colour space

 l P3 D65 (12-1-1) if using “Display P3” colour space

 l QuickTime Movie (*.mov) on macOS. The movie in this format w ill not be tagged w ith their colour space 

information if exported on W indows or GNU/Linux. W hen rendering a movie in QuickTime Movie 

(*.mov) format on macOS in a specific colour space, the movie buffer data w ill be tagged w ith the 

corresponding ICC colour profile.

As for exported images, colour space tagging is supported in the follow ing formats:

 l Portable Network Graphic (.png)

 l Photoshop Document (.psd)

 l OpenEXR (.exr)

NOTE 

OpenEXR files are only tagged w ith the coordinates for their white point and primaries.
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How to set the colour space when exporting your scene as images

 1. In the top menu, select File > Export > Images.

The Export Images dialog box appears.

 2. In the Colour Space field, select the colour space in which you want your exported images to be 

rendered.

How to set the colour space when exporting your scene as a movie

 1. In the top menu, select File > Export > Movie.

 2. In the Colour Space field, select the colour space in which you want your movie to be rendered.
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Customizing Available Colour Spaces

By default, Harmony supports a handful of commonly used colour spaces. If your production uses a colour 

space that is not supported by Harmony out of the box, it is possible to customize the colour spaces supported 

by Harmony to suit your production’s needs. 

The colour spaces supported by Harmony are stored in files in the follow ing location:

 l W indows: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 22 

[Edition]\etc\colourmanagement

 l macOS: /Applications/Toon Boom Harmony 22 [Edition]/Harmony 

[Edition].app/Contents/tba/etc/colourmanagement

 l GNU/Linux: /usr/local/ToonBoomAnimation/harmony[Edition]_22/etc/colourmanagement

In this directory, you w ill find the follow ing contents:

Name Type Purpose

config.ocio
OpenColorIO 

configuration file

The configuration file that contains the colour profile definitions 

used by Harmony. 

luts Directory
A directory containing some dependency files used by the colour 

profiles defined in config.ocio.

icc Directory
A directory containing ICC profiles matching the colour spaces 

defined in config.ocio.

Just like many other software that support colour space management, Harmony uses the OpenColorIO colour 

management technology to define its supported colour spaces. If the other software used by your production 

also uses OpenColorIO, this means you can easily use the OpenColourIO configuration you use w ith your other 

software w ith Harmony so as to use the same colour space definitions across your production.

You can customize the colour space definitions used by Harmony by setting the OCIO environment variable for 

your operating system to the full path of your own, custom config.ocio file. This allows you to use the 

same .ocio file for multiple software if needed.

NOTE 

Harmony uses sRGB colour space for Toon Boom drawings—see Setting the W orking Colour 

Space for a Scene on page 418). If a customized config.ocio file does not contain colour space 

definition named sRGB, a colour space of default view displayed in config.ocio file is used.

You might notice that, along w ith the OpenColorIO configuration files, there is a directory containing ICC 

colour profiles. The ICC colour profiles are only used to tag exported images when supported and movies 

424

Harmony 22 Paint User Guide                          



Chapter 4: Painting and Colours

when using QuickTime Movie (*.mov) format on macOS, and are not required for any other part of the colour 

management in Harmony. 

Hence, if you decide to customize the colour space definitions used by Harmony, you can include the ICC 

colour profiles for your colour space definitions if you want. If you don’t, Harmony w ill stil l render your images 

and movies in the appropriate colour spaces w ith the appropriate colour values, but w ill not be able to tag 

your exported images and movies w ith their colour space information.

For Harmony to be able to use an ICC colour profile to tag exported images and movies, the follow ing 

conditions must be met:

 l The ICC colour profiles must be located in an icc sub-directory, in the same directory as 

config.ocio. 

 l The file name of the ICC colour profile must match the name of the colour space as defined in 

config.ocio.

For example, if your config.ocio file contains a colour space definition named sRGBf, for Harmony to be 

able to tag exported movies (on macOS) and images w ith this colour space, then the directory containing your 

config.ocio file should also contain a directory named icc, which would in turn contain a corresponding 

colour profile for sRGBf named sRGBf.icc. 

NOTES 

 l W hen rendering a movie in a specific colour space in QuickTime Movie (*.mov) format on 

macOS, the movie buffer data w ill be tagged w ith the corresponding ICC colour profile.

 l W hen rendering a movie in a specific colour space in QuickTime Prores Movie (*mov) format, 

the movie colour space ‘nclc’ tag w ill be only set as:

 l HD (1-1-1) if using “Rec. 709” colour space

 l BT.2020 (9-1-9) if using “Rec. 2020” colour space

 l P3 D65 (12-1-1) if using “Display P3” colour space

 l W hen rendering frames in a specific colour space,  the follow ing file formats w ill be tagged 

w ith their colour space information:

 l Portable Network Graphic (.png)

 l Photoshop Document (.psd)

 l OpenEXR (.exr)

OpenEXR files are only tagged w ith the coordinates for their white point and primaries.
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About Displays

The Display node is an important node; it is used by the export and views to display your scene, primarily the 

Camera and Timeline views. By default, a scene's node system always has a Display node which can be used 

to show your entire scene, a single node or a group of nodes through a Composite or Group node. You might 

use it to see one single character as you animate it, debug your node system as you create complex effects or 

export your complete scene or a portion of it. 

W hen your scene does not have a Display node, it is automatically set to Display All which uses the Timeline 

view ordering and shows floating nodes from the Node view. You can also set your scene to use Display All 

using the Display toolbar.

NOTE 

If you try to add a peg or other transformation layer in the Timeline view without having a layer 

selected, an error message w ill display. Make sure to change to Display All. The peg layer w ill be 

floating in the Node view and w ill not be visible in the Timeline view.  The Timeline view shows 

only layers that are connected to the Composite node.

If you switch to Display All, you run the risk of not realizing when you have floating nodes that are 

not connected to your composite.  For this reason, it is not recommended to work in Display All 

mode.
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