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Chapter 1: Storyboard Pro

Chapter 1: Storyboard Pro

Storyboard Pro is a complete storyboarding software for animated features and TV series, 2D/3D, live action
production, video games, or events with advanced features for all your project’s needs.

Whether you are planning an animation, a live action production or an event, Storyboard Pro takes care of your
entire storyboard and animatic project. From importing your script and images, drawing, editing captions, all the
way to layer and camera movements and sound editing.

Set up your project planning in a true 3D space. With 3D model import, positioning of 2D assets within the 3D
space and impressive 3D camera movements.

Storyboard Pro features an extensive set of drawing tools and export options that range from PDF, images, movie
files and even third party editing software to fit all of your sharing and production needs.

14
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Starting Toon Boom Storyboard Pro
T-SBFND-002-001

You can run Toon Boom Storyboard Pro on the Windows and Mac OS X operating systems. You will also need
Apple QuickTime Player to play back movies and Adobe Reader to display PDFs.

@ Storyboard Pro

Project Creation
Starting Storyboard Pro

_ Toon Boom
- Qriginal

How to start Storyboard Pro
1. Double-click the Storyboard Pro @ icon or do one of the following:

« Windows: Select Start > Programs > Toon Boom Animation > Toon Boom Storyboard
Pro > Storyboard Pro.

« Mac OS X: Select Applications > Toon Boom Storyboard Pro > Storyboard Pro.

Storyboard Pro opens. If this is the very first time you are starting Storyboard Pro, then the following screen is
displayed. If you want to explore, go ahead and click one of the button. Otherwise, click Close.

15
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Learning Tools What's New Join the Community

A second Welcome screen displays.

Open Project...

How to install Apple QuickTime Player

« Gotothis link and follow the instructions:

Windows: apple.com/quicktime/download/pc

Mac OS X: apple.com/quicktime/download/mac

16
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How to install Adobe Reader

o Gotothis link and follow the instructions:

Windows: adobe.com/support/downloads/pc

Mac OS X: adobe.com/support/downloads/mac

17
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Chapter 2: Projects

All projects created with Storyboard Pro are independent and local to the computer. There are a few different ways to
create and open projects. You can create a project from the Welcome screen, File menu, Final Draft script, or Toon
Boom Harmony scenes.

@ Storyboard Pro

Project Creation

About Projects and File Structure
——

- '_ . Toon Boom

Original

A Storyboard Pro project is composed of several files. The drawings and colour palettes are not embedded in the
project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the files
contained in the folder structure.

NOTE: You can save your project as an open directory or as a single file. To switch to a single file, see Saving
Projects as a Single File on page 36

Here is an example of the file structure contained in a scene. As you work and use more features, different folders
may appear in your structure.

(LI

- -
-~ -~

elements environments frames jobs logs

palette-library myProject.aux myProject.sbeard | myProject.sboard PALETTE_LIST
thumbnails

scene.clementTa  scenewversionTabl
ble e
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The Storyboard Pro project folder contains the following folders: frames, audio, elements, etc.

Folder/File Contents
audio Contains all imported audio files.
elements Contains all the drawing files.

environments

Contains the exported palette files that were originally stored at the
environment level in the Harmony Server database structure or the palettes in
a Harmony Stand Alone scene that will be imported later at the environment
level in Harmony Server. This is for compatibility with export to Toon Boom.

Contains the final frames after a render if you are using the default settings of

frames the Write node in the Node view.
Contains the exported palette files that were originally stored at the
. environment level in the Harmony Server database structure or the palettes in
jobs . . .
a Harmony Stand Alone scene that will be imported later at the environment
level in Harmony Server. This is for compatibility with export to Toon Boom.
logs Contains traces of operations and processes while working with Storyboard

Pro. This can be useful for debugging.

palette-library

Contains palettes files.

*.sboard

This is the main Storyboard Profile. This is the file you must click on to launch
the software and load the project. This file links to all the other files in the
directory.

PALETTE_LIST

This is the list of all the different palettes in the project.

20
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Creating Projects

When creating projects, you have the choice of using the Welcome screen or the File menu in Storyboard Pro. You
can also create a project from a Final Draft script or from Harmony scenes.

21
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Creating Projects from the Welcome Screen

T-SBFND-002-003

You can create a project from the Welcome screen.

@ Storyboard Pro

Project Creation =

Creating Projects from the YWelcome Screen
3

: Toon Boom
- Qriginal

How to create a project from the Welcome screen

—

In the Project Name field, type the name of the project. This name will appear as the file name.
2. Inthe Project Directory field, specify the location of your new project.

3. Inthe Project Title field, type the name of the project title. It is a good idea to use the Project Name for the
Project Title. You can also type in the name of the Project Subtitle, but it is not mandatory. These titles will
appear on the appropriate pages of PDF exports.

4. Inthe Camera Size menu, choose the project’s resolution—see Creating Custom Resolutions.

5. Click Create Project.

22
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Creating Projects from the File Menu
T-SBFND-002-004

You can also use the File menu. If a project is already open and you want to create a new one, use the File menu.
Note that the content of the project directory will appear when you save the project for the first time.

@ Storyboard Pro

Project Creation
Creating Projects from the File Menu

- Toon Boom
- Qriginal

How to create a project from the File menu

1. Do one of the following:

« Select File > New.
« Inthe File toolbar, click the New [ button.

o Press Ctrl+N (Windows) or 3 +N (Mac OS X).

The New Project dialog box opens.

Rocket-Rodeo
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2. Inthe Project Name field, type the name of the project. This name will appear as the file name.

3. Inthe Project Directory field, specify the location of your new project.

In the Project Title field, type the name of the project title. It is a good idea to use the Project Name for the
Project Title. You can also type in the name of the Project Subtitle, but it is not mandatory. These titles will
appear on the appropriate pages of PDF exports.

5. Inthe Camera Size menu, choose the project’s resolution—see Creating Custom Resolutions.

6. Click Create Project.

24
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Creating Projects from Final Draft
T-SBADV-001-001

Storyboarding and script writing go hand-in-hand. Storyboard Pro lets you use your Final Draft script to create a new
Storyboard Pro project. This feature is a time saver as it handles the creation of scenes and panels, as well as
inserting all the text in the proper captions automatically.

If you are working with version 7 of Final Draft, you must use Final Draft Tagger to generate the *.xml file needed to
use this feature. After you have produced your export, follow the steps to create a project from a Final Draft script.

NOTE: Final Draft 8 uses a new file format, *.fdx, which can be imported directly into Storyboard Pro, as opposed to
the older *.fdr, which needs to be exported from Final Draft Tagger to generate an *.xml file.

How to create project from a Final Draft script

1. Select File > New From Final Draft Script.

The Import from Final Draft window opens.

2. Usethe Browse  button to search for an *.fdx or *.xml file exported from Final Draft. After making a file
selection, the other options in the window become active.

25
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Add caption field

Import

Add caption field

Import

The selected tag, Action, is assigned to New Scene. A new scene will be
created every time this tag is encountered in the *fdx or * xml script.

4. Forthe selected tag, decide if you want to set the following options:

« Combine Successive Elements: Combines the selected tag with an identical tag if it
occurs successively in the script. For example, you might choose to create a New Panel for
every Dialogue tag that appears in the Final Draft script. However, if there are three Dia-
logue tags in a row without a break due to an Action tag, then selecting this option places
these three lines of dialogue together in the same Panel.

« Include Element Number When Available: In a Final Draft script, there are numbers along
the right and left margins of the document that indicate a change in scene. Select this option
to import these into your Storyboard Pro project.
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1 EXT. DAY - FOREST PATH 1

The second little pig met a man with a bundle of furze
[sticks].

PIz
Please, man, give me that furze
to build a house.

Which the msn did.

2 EXT. DAY - FOREST 2

The pig build hisz house.

3 EXT. DAY - FOREST 3

5. From the Destination caption field menu, select the location in the Panel window in which you want place the
text associated with the selected tag.

Panel (%

Import

In the example above, Storyboard Pro will take all the text associated with the Action tag in the Final Draft file
and put it in the Action Notes section in the Panel window for each new scene that it creates in this project.

From the Import from Final Draft dialog box, below is a list of some sample settings for the most common
tags:

Action Combine suc- Destination caption field
cessive elements
Action New Panel Action Notes
Character None Dialogue
Dialogue None Enabled Dialogue
Scene Heading New Shot Enabled Slugging

27
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Transition New Transition Notes

Parenthetical None None

Try different settings with your style of script and see what works best for you. Remember to select
the Save as default rules option once you have your settings just right, so these settings are used
as the default the next time you create your Storyboard Pro project from a Final Draft script.

6. When you have finished setting up your import parameters, click Import.

7. Now, you will be asked to create your new project. You will be prompted to save changes to your current
scene, before it is closed and your new project, generated from your script, is opened.

For more information on creating a new Storyboard Pro project, see Creating Projects on page 21.

How to export a script as an XML

1. Start Final Draft Tagger.

2. Select File > Import Script or press Ctri+l.

The Import dialog box opens.

3. Inthe browser, select your script file and click Open.

Your script appears in Final Draft Tagger.

"5 31p.far
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Fie  Print
:l Reveal 4 Elements ~
L) Int... Sec Day/Hight Len Category
1 EXT. DAY FOREST PATH 1 a0 + Cast Members -~
2 EXT. DAY FOREST 1 0... Extras
3 EXT. DAY FOREST 1 0... Stunts
4 INT. DAY PIG'S HOUSE 1 0... Vehicles
5 EXT. DAY FOREST 10 Pre
o 10 .

oatmes P

Add Category I Clear Category
EXI. DAY - FOREST EATH Element
jui

The second little pig met a man with a bundle of furze
[=ticks].

s
Pleaze, man, give me that furze to
build a house.

Which the man did.

AddElenent |

4. Select File > Export to XML.

5. Close Final Draft Tagger and proceed to import the *.xml file as in the previous section.
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Creating Projects from Harmony Scenes

You can create a project from Harmony scenes. Before you do this, in Harmony, you must mark the frames you
want to use as panels in your project. Frames must be marked in an annotation column called "EM". For each
marked frame, a panel is created in Storyboard Pro. If you don't mark your frames, the first frame of each Harmony
scene will be used.

You must group all your different Harmony scenes in one folder. Storyboard Pro will create one scene per Harmony
scene. If your Harmony scene contains several EM markers in the annotation column, Storyboard Pro will create
multiple panels within the scene.

How to create a project from Harmony scenes

1. From the top menu, select File > New from Harmony Scenes.

The New Project dialog box opens.

2. Inthe Project Directory field, specify the location of your new project.

Rocket-Rodeo

Create Cancel

3. Inthe Project Name field, type the name of the project. This name will be used as the file name.

4. Inthe Project Title field, type the name of the project title. It can be a good idea to use the Project Name for
the Project Title.

You can also type in the name of the Project Subtitle, but it is not mandatory. These titles will appear on the
appropriate pages of PDF renders.

5. Inthe Resolution section, choose the project’s resolution—see Creating Custom Resolutions.

6. Click Create.

The Select Harmony Scenes Directory window opens.

7. Select the folder you created that contains your multiple Harmony scenes; do not select the Harmony scene
folder directly. Click Select Folder.

The name of the folder of each scene file is used to name the scene that is created. Panels are created in the
Thumbnails and Timeline views.
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Creating Custom Resolutions

You can create a custom resolution from the Welcome screen or New Project window. Your new resolution will
appear in the Camera Size menu of both the New Project window and Welcome screen.

If you no longer need a custom resolution, you can easily remove it. However, you cannot delete the factory
resolutions that come with Storyboard Pro.

@ Storyboard Pro

Project Creation

Custom Resolution

: Toon Boom
- Qriginal

How to create a custom resolution

1. Inthe Welcome screen or New Project window, click the Add + button to add a new resolution to the list.

The New Resolution box opens.

« Resolution Name: Type a name for your new resolution.

« Width/Height: Enter the resolution width or height in pixels. These two parameters are
linked; changing one changes the other.

« Field of View: Set the field of view to use the horizontal or vertical resolution, or enter a cus-
tom field of view.
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« Frame Rate: Type the scene’s frame rate per second.

How to delete a custom resolution

1. Inthe Welcome screen or New Project window, select a custom resolution from the Camera Size menu.

2. Click the Remove — button.

The selected custom resolution is deleted from the list.
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Opening Projects

T-SBFND-002-006

Existing projects can be opened from the Welcome screen when you start Storyboard Pro. If you already have
Storyboard Pro open, you can open projects from the File menu.

@ Storyboard Pro

Project Creation
Opening a Project

- Toon Boom
- Qriginal

How to open a project from the Welcome screen

1. Start Storyboard Pro.

2. Inthe Recent Projects section, do one of the following:

« Select a project from the list.

» Click Open Project and select a project (*. sboard file) from the browser that appears.
How to open a project from the File menu

1. Do one of the following:

» Select File > Open.
« Inthe File toolbar, click the Browse ¢ button.

o Press Ctrl+O (Windows) or 3£ +O (Mac OS X).

The Open Project window opens.
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2. Locate and select an *.sboard file.

3. Click Open.
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About Saving

It is important to regularly save your project. For more information about the structure of a saved project, see
Projects on page 19.

To save the current state of a project as a new one, you can use the Save As command. The Save As window
prompts you to give a new name and choose a different location to this project before saving it. This will create a
complete project directory for the new project.

You can also automatically save your work. Refer to the Preferences Guide to learn more about this function.

A Storyboard Pro project is composed of many small files. Each drawing in a project is a file, which may result in
projects containing over 10,000 files. This can quickly fill your storage solution with a high number of files,
straining the file system and backup process.

You can reduce the number of files and protect the integrity of projects by saving (packing) the project in a single
file. A packed project file is appended with the .sbpz extension.

NOTE: See Project Managementon page 499 to learn more about splitting and merging projects.
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Saving Projects

You can save your projects as is or save them as a new copy.
How to save a project

» Select File > Save.
o Press Ctrl + S (Windows/Linux) or 3£ + S (Mac OS X).

How to save a project as a copy (Save As)

1. Select File > Save As.

2. Inthe Save As dialog box, browse to the location of the new archive and give the copy of the project a new
name.

3. Click Save.
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Saving Projects as a Single File

A Storyboard Pro project is composed of many small files. Each drawing in a project is a file, which may result in
projects containing over 10,000 files. This can quickly fill your storage solution with a high number of files,
straining the file system and backup process.

You can reduce the number of files and protect the integrity of projects by saving (packing) the project in a single
file. A packed project file is appended with the .sbpz extension.

The location of your packed file (*.sbpz) does not have to be in the same place as your current project file. For
example, you can save the packed file on your company’s server and save the current version on your local
computer.

You can open a packed file in the usual way by using the File > Open command or by double clicking the file in the
Explorer (Windows) or Finder (Mac OS X). The packed file extracts to a temporary folder on your computer.

»  Windows: \Users\[username]\Documents\Toon Boom Animation\StoryboardPro Project Cache
* Mac OS X: /Users/[username]/Documents/Toon Boom Animation/StoryboardPro Project Cache

When opening a project in Storyboard Pro, you can select an .sbpz file (the packed project); this file will be
updated when you perform a Save and Pack. If you opened an .sboard project, you can perform a Save As toa
packed format, after which that file (the packed/zipped one) will be updated by the Save and Pack.

NOTE:

- Unpacked projects do not appear in the list of recent projects, so you don't accidentally open the projectin the
cache.

- Multiple users cannot open the same packed project at the same time.

- When working with a packed project and you have Storyboard Pro set to automatically save your project,
Autosave, itis saved to the project cache.

How to set your project to save as a single file

1. Do one of the following:

« Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
o Press Ctrl+U (Windows) or & + , (Mac OS X).

2. Select the Project Settings tab.

3. Select the Save new projects in single file format (packed file) option and click OK.
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How to convert a standard Storyboard Pro project to a packed project

1. Select File > Save As.

The Save As window opens.

Organize « MNew folder 4= - .j@.
& Google Drive = MName Date modified Type
- Favorites - Shortcut ] .
, audio File folder
R | elements File folder
= Libraries X .
= E | environments File folder
j Documents )
| frames File folder
J’- Music X .
. | jobs File folder
= Pictures )
. , logs File folder
=l Subversion ] ]
] | palette-library File folder
B2 videos )
& RR-Export.shoard SBOARD File
M Computer
& os (@
5 Marketing (Viserver) (M:)
S pub (\server) (P:) - 4 m 3
File name: -
Save as type: | Storyboard Project (*.sboard) v]
+ Hide Folders Save ] [ Cancel ]

In the File Name field, give your packed file a name.

3. From the Save as Type list, select Storyboard Packed File (*.sbpz).

File name:

Save as type: lStor)rboard Project (*.sboard)

rd Packed File (*.sbpz)

4. Click Save.

The project is saved and zipped to the location you specified.

How to save an unpacked project

1. Do one of the following:

» Select File > Save to save the project to your local cache.
» Select File > Save and Pack to pack the project to the location you specified for your packed project.

The unpacked project is saved and packed to the original zipped project file.

NOTE: If the project already has a file, save the project locally using the Save command , then save to the zip file
using the Save and Pack command.
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About Project Optimization
T-SBFND-002-007

If you are concerned with file size and speed, there are a few things you can do to optimize your project.

@ Storyboard Pro

Project Creation
About Project Optimization

: Toon Boom
- Qriginal

NOTE: Toon Boom Storyboard Pro has an optimized file structure that reduces the number of folders. For this
reason, once a project is saved in this version, it can no longer be opened in Storyboard Pro 2. However, Toon
Boom Storyboard Pro is fully backwards compatible and will open files created by older versions of Storyboard
Pro.

38



Toon Boom Storyboard Pro 5.1 User Guide

Optimizing Projects
T-SBFND-002-008

You can optimize projects by flattening all drawings in your project, removing unused files, and reducing the texture
size.

@ Storyboard Pro

Project Creation
About Project Optimization

- -_ Toon Boom

Qriginal

How to optimize your project

1. Select File > Optimize Project.

The Optimize project dialog box opens.

2. Select one or more of the following options:

« Remove unused elements from the project: As you create a storyboard you will delete pan-
els or layers, update drawings, unlink sounds, and so on. Some of these files are kept for
backup purposes, but they take up space and increase the size of your project on your hard
drive. This option removes these unwanted elements.

- Flatten drawings in the project: Flattens all the brush or pencil line strokes of all the vector
drawings in your project. This means that all overlapping strokes will no longer be editable as
single strokes, but only as whole, drawn objects.

39



Chapter 2: Projects About Project Optimization

NOTE: Strokes drawn with different colours will not be flattened together.

« Reduce texture resolution of all drawings in the project: Reduces the texture resolution
and consequently makes the project file size smaller. The resolution is set so it cannot go
below 72 dpi.

NOTE: This cannot be reversed once you have reduced the resolution. These operations cannot
be undone and will empty the undo list.
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Optimizing Drawings
T-SBFND-002-009

When using any of the playback options in Storyboard Pro, the software must calculate the positioning of all the
*.tvg (Toon Boom vector graphics) files. This is the file format created from all your drawing strokes. This calculation
tends to slow down the rate of playback. There is, however, a way to circumvent this problem.

There is a second file format, *.tvgo (Toon Boom vector graphic optimized), that has all the pixel position information
pre-calculated. Using these drawings should significantly speed up playback.

@ Storyboard Pro

Project Creation

Optimizing Drawings

- '_ . Toon Boom

Original

How to optimize playback and create optimized drawngs

1. Select Edit > Preferences.

The Preferences dialog box opens.
2. From the Advanced tab, under the Optimized Playback section, select the Use Optimized Drawings option.

3. Select the Asynchronous Drawing Loading option to optimize playback. There are cases in which, during
playback, the software may encounter a particularly texture-heavy or complex panel. When this happens,
and this option is deselected, there will be a pause in playback while the frame loads. If you select this option,
then playback will continue and the drawings will load as soon as they are available. You may notice a short
blink while the drawing loads.

4. Select the Preload Drawings option to enhance playback further by loading drawings in memory before you
reach them during playback. Storyboard Pro will determine which, between the two options, has more draw-
ings to preload and use the appropriate option during playback.

o Number of Frames to Preload: Storyboard Pro looks ahead for the number of frames, and

checks to see how many drawings are used. Each layer on each panel is a drawing. If you have
many short panels, then you will have more drawings than if you had one long panel.
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o Number of Panels to Preload: Storyboard Pro looks ahead for the specified number of pan-
els to determine the number of drawings in those panels. Keep in mind that each layer on
each panel is a drawing. If you have long panels, then it will want to look ahead several pan-
els, instead of the specified number of frames.

5. Click OK.

6. Select File > Create Optimized Drawings.
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Optimization Best Practices
T-SBFND-002-010

When working in Storyboard Pro, there are some best practices you should follow to keep the file size low and
playback speed fast.

@ Storyboard Pro

Project Creation

Optimization Best Practices

: Toon Boom
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Plain Vector Versus Texture Brush
T-SBFND-002-011

When you draw on a layer, all the strokes that you create with the Brush tool are vector elements. There are two
kinds of brushes:

« Plain Brushes: By default, the Brush tool creates vector strokes filled with either a colour or a gradient.
Vector strokes use a very small amount of memory and can be used rapidly because they do not contain
any pixel information, only mathematical functions.

» Texture Brushes: This type of brush also produces a vector contour for its strokes, but is filled with a bit-
map texture. These textures allows you to produce drawings that have natural looking brush strokes that
resemble lines drawn using a crayon or airbrush.

Because you are using a bitmap image mapped inside vector strokes, texture brushes use much more memory
and processing time than brush strokes filled with colour. Therefore if you want to make your file size lighter and
drawing speed faster, use only regular brushes to draw scenes. If you choose to use texture brushes, is it
important to use a reasonable size bitmap for the texture brush.

NOTE: When you use a bitmap layer instead of a vector layer, individual vector strokes are not created. Instead,
individual pixels are laid down, recording information about the RGBA of each pixel. Because of this, when
working with lots of shading and lots of different textures or colours, the bitmap layer is actually more efficient than
the texture brush on the vector layer—see Drawing on page 183.
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Bitmap Import Optimization
T-SBFND-002-012

Storyboard Pro allows you to create storyboards by importing scanned images or bitmaps drawn in another
software. During the import process, images are vectorized and placed in a new scene in a vector bounding box as a
bitmap fill. The bitmap image’s resolution can affect your project’s file size and the speed at which Storyboard Pro
functions while handling your project. When importing bitmaps into a storyboard, there is rarely a need to use a high
resolution as it will not increase the quality of your PDF or animatic. You should import bitmaps with a resolution
close to the project resolution. For example, in an NTSC project, using a bitmap with a 720 x 480 resolution or a 72
dpi quality will be fine.
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Flattening Drawings
T-SBFND-002-013

In Storyboard Pro, strokes inside a vector layer are independent. You can select a specific stroke and edit its
position, scale, rotation, skew, colour and so on, whenever you want. However, this flexibility increases the
amount of memory and resources used, especially when you have a lot of strokes in your drawing (which
frequently happens when sketching).

You can flatten all drawings in at the same time. However, you can retain partial flexibility and still minimize file
size and resources needed by consciously flattening certain drawings as you draw, or even by selecting them
after you have drawn them. You can take all strokes of the same colour with overlapping areas on the same layer
and flatten them to create a single drawing with a vector contour.

When you use the Flatten option in the Tools menu, Storyboard Pro automatically crops all textures, reducing the
drawing size by removing the texture area which is not visible.

How to flatten strokes as you draw

1. From the Tools toolbar, select the Brush - tool.
2. Inthe Tool Properties view, click the Auto-Flatten = button.
3. Inthe Stage view, sketch your first drawing.

The strokes are automatically flattened.

How to flatten an existing drawing

1. From the Tools toolbar, select the Select w tool.

2. Inthe Stage view, select a group of strokes.

« If you do not select a group of strokes, the entire layer will be flattened.

« You can select multiple layers, so they are flattened individually.

3. Select Tools > Flatten or press Alt+Shift+F.
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About Project Properties

T-SBFND-002-014

When you created your new project, you chose the name and resolution. However, if you want to change these
initial settings later on, you can. All global project properties such as the resolution, project name, copyright, field
chart size, and frame rate are available in the Project Properties dialog box—see Project Properties Dialog Box.

How to access the project properties

« Select Storyboard > Properties.

The Project Properties dialog box opens.
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About Project Backup

T-SBADV-001-003

As you work on your storyboard project, it is always a good idea to save continuously. At the end of each
workday, it is even better to back up your work. The difference between backing up and saving is that a backup is
a compressed version of your project. Backing up your work provides a safety net against corrupted files and

allows you to have several versions of your project at different stages, in case you need to go back and work from
an earlier point in the production.
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Backing Up Projects
T-SBADV-001-004

The place where you save your backup file (*.sbbkp) does not necessarily have to be the same place where you
have your current project file saved. For example, you can save the backup on your company’s server, even though
the current version is saved somewhere on your computer.

How to back up the current version of your Storyboard Pro project

1. Select File > Backup Storyboard.

The Create Storyboard Backup window opens.

2. Browse for a location on your computer to save this backup file. You can also rename it with a date or version
number.

3. Click Save.

An *.sbbkp file is created and saved in the assigned location.
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Restoring Backups
T-SBADV-001-005

At times, you may need to restore a backup of a project you are working on.

How to restore and open a backup file

1. Do one the following:

» Select File > Restore and Open Backup. In the Open Storyboard Backup window that appears,
locate and select the *.sbbkp file.

»  Onyour computer, go to the location where you saved the *.sbbkp file and double-click its icon. In the
browser window, select a place to save the restored file.

2. The project opens in Storyboard Pro.
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Chapter 3: Interface
T-SBFND-003-001

Understanding how to manage the Storyboard Pro interface helps you to work efficiently and organize your
workspace conveniently. There are a many views and toolbars you can use for performing different operations. You
will probably have your own preferred way of working in the Storyboard Pro interface as well.

When you start Storyboard Pro for the first time, the default workspace is displayed. It contains all of the main
elements you need for storyboarding.

Top menu Storyboard toolbar Playback toolbar

PR ™S

- R R

Thumbnails view Stage view

Top Menu

Located at the top of the Storyboard Pro interface, the top menu contains most of the commands. Depending on the
view you are working in and the selected element, some commands are available and others not.

Tools Toolbar

The Tools toolbar contains all the main tools you need to work in Storyboard Pro. In the default workspace, this
toolbar located on the left-most side of the interface. A small triangle at the lower-right comner of a tool indicates
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additional tools under the main tool. To access these tools, hold down the left mouse button until the additional
tools appear, then select one.

Storyboard Toolbar

The Storyboard toolbar contains all of the basic commands related to adding and deleting panels, scenes, and
transitions, as well as switching between the 2D and 3D workspaces. In the default workspace, this toolbar is
located at the top of the interface.

Playback Toolbar

The Playback toolbar lets you play back your storyboard. When you create an animatic with transitions and
sound, you can play it back in real time in the Stage view to check the timing. In the default workspace, this
toolbar is located at the top of the interface.

Thumbnails View

The Thumbnails View displays all the panels of your project in chronological order. You can use this view to
navigate through your storyboard, rearrange panels and scenes, and select the panel to display in the Stage view.

By default, it is not possible to draw in the Thumbnails view and there are no browsing buttons. But you can
change these settings in the Preferences dialog box.

Stage View

The Stage and Camera views are the centre of operations in Storyboard Pro. In these views, you can build, draw,
paint, animate the camera, create layers, and see your results.

Panel View

The Panel view displays the different captions related to the current panel, the in, out and duration, and lets you
play any voice annotations related to the panel.

NOTE: By default, when you modify the workspace, it is automatically saved. You can restore the default
workspaces by selecting Windows > Restore Default Workspace. You can prevent this behaviour by deselecting
the Save Workspace option in the Preferences dialog box—see General Preferences in the Preferences Guide.
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About Menus

In Storyboard Pro, you can access the commands from the following three types of menus:

Top Menu: Located at the top of the Storyboard Pro interface, the top menu contains most of the commands.
Depending on the view you are working in and the selected element, some commands are available and others not.

View Menus: Some views have their own menu containing commands specifically related to that view. To access a
view menu, click the View Menu =/ button in the top-right corner of a view.

Menu in
Staoryboard
view

Contextual Menus: Each view has a contextual menu containing commands for recurring actions. To access a
contextual meu, right-click (Windows) or Ctrl+click (Mac OS X) anywhere in a view.
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About Views
T-SBFND-003-002

The Storyboard Pro user interface is comprised of different views, each one designed for a specific purpose. You
can modify the location and accessibility of the views by adding a new view as a tab or as a window. You can
also swap the view locations around, as well as do the following:

o Addaview

. Tabaview

o Dock aview

« Undock a view
« Rename aview
o Closeaview

« Move aview

o Resize aview

o Collapse aview

« Expandaview

For details about the views in Storyboard Pro, see Reference Guide.

Here is a complete list of the views available in Storyboard Pro.

« 3D Schematic
o Camera

« Colour

« Function Editor
o Layers

« Library

o Message Log
« Panel

« Panel PDF Options
« PDF Export

« Pitch Mode

« Script Editor

« Side

. Stage

« Storyboard

o Thumbnails

o Timeline
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« Tool Properties

o Top
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Adding Views

T-SBFND-003-002

Views contain specific groupings of features and can be positioned anywhere on your screen. You can tab, dock,
and undock a view.

@ Storyboard Pro

Interface
Adding Views

: -_ - Toon Boom

Qriginal

The Colour view is a bit different than other views in Storyboard Pro. By default, the Colour view is part of the Tool
Properties view, not a separate view on its own. If you have chosen to separate the two views and want to
reintegrate them into one view, select Windows > Restore Default Workspace.

Tool Properties : Colour 4= (% Colour @

[ATTW]

Colour view in a window

Default, docked Colour view
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How to add a view

1. Do one of the following:

« Select Windows and then select a view from the list.

« InPanel view, click the View Menu button and select a view from the list.

How to dock a view

« Drag the window’s tab onto the Panel view and drop it in the tab area.

The view is added to the Panel view.

Colour

How to undock a view

1. Inthe Panel view, select a view by clicking its tab.

2. Drag the selected view to a new location, moving away from the Panel view.

The view turns into a window.
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I Sh_&;)_‘board
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Renaming a View
T-SBFND-003-003

You can rename a view for convenience. When you do, the new name remains in effect as long as the view stays
open. Once you close and reopen the view, its name, as displayed on the tab, will revert to the default name.

How to rename a view

1. Inthe view to rename, click the View Menu button.

2. Select Rename Tab from the list.

The Rename View Tab dialog box opens.

Cancel

3. Type a new name for the tab you want to rename and click OK.
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Closing Views
T-SBFND-003-003

If there are views in your workspace that you do not use, you can close them to streamline your space.

How to close a view

1. Inthe view to close, click the Close View button.

2. If there are several tabs, press Shift and click the Close View button.

panel  Lbrary (%)

All the tabs are closed at the same time.

NOTE: Don't forget, you can restore the default workspace at any time by selecting Windows > Restore Default
Layout.
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Moving Views
T-SBFND-003-004

You can move and group views, create floating windows, or dock them in their own individual areas.

NOTE: The Colour view is like other views, thatis, you can dock and undock it. When you first open the Colour view,
itis docked. You can undock it so it becomes its own window which you can move around freely.

How to move a view

1. Select the tab of a view and drag it onto a view separator, top area, or onto another view’s tab.

2. When a rectangle outline appears showing an available location for the view (see 1, 2 and 3 below), release
the mouse button to drop the view into position.

The view becomes a tabbed window, a floating window, or a new docked window.

Selected tab of a view

a
F
z
L]
T 0

+ix

f— W—— IS I IS IS T s
1 n o 2 Ay - -

R Ay . g n n
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Resizing Views

T-SBFND-003-005

By resizing a view, you can customize your workspace. You can change the width and height of the views in the
workspace.

How to resize a view

1. Position your cursor at the edge of the view you want to resize.

2. When you see the Resizing cursor, drag the side of the window to the desired width or height.
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Expanding or Collapsing Views
T-SBFND-003-006

By temporarily expanding or collapsing a view, you can manipulate the workspace to suit your workflow. The
expanded or collapsed state of a view will be saved as part of the workspace modifications.

How to expand or collapse a view

1. Onthe edge of the view you want to hide, click the Expand/Collapse button.

The view is collapsed and only the Expand/Collapse button is visible.

2. Click the Expand/Collapse button to display the view again.
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About Toolbars
T-SBFND-003-007
The Storyboard Pro interface contains toolbars which lets you access many useful tools.
You can add, move and close toolbars, as well as customize them.
For details on each toolbar, refer to the Reference Guide.

These toolbars are available in Storyboard Pro.

« Camera

« Coordinate
. Edit

« File

o Layer

« Navigation
« Onion Skin
« Playback
« Scripting

« Sound

« Storyboard
o View

« Workspace
o Tool Presets

e Tools
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Adding and Closing Toolbars
T-SBFND-003-007

You can easily add a toolbar to your workspace or close one you don't use very often.

@ Storyboard Pro

Interface

Adding and Closing Toolbars
e —

- Toon Boom
- Qriginal

How to add a toolbar

» Select Windows > Toolbars > the toolbar to add.

How to close a toolbar

» Select Windows > Toolbars > the toolbar to close.
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Moving Toolbars
T-SBFND-003-008

You can move toolbars and place them at the top of the interface or beside a view.

How to move a toolbar

1. Select the toolbar to move by clicking its anchor point * and dragging it to a toolbar area at the top or side of
the interface.

oard Layer Camera Sound Caption Too

As you drag the toolbar, a rectangle outline appears to indicate the available locations for the toolbar.

2. Release the toolbar to drop it into position.

&
I
T
L
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Customizing Toolbars
T-SBFND-003-009

Some of the toolbars can be customized with your favourite tools and options. You can also organize the toolbars to
suit your working preferences.

These are the toolbars that can be customized:

« Layer
« Storyboard
« Navigation
« Sound

e Tools

The Tools toolbar can only be customized if the Flat Tools Toolbar preference is enabled. This preference allows you
to display all the tools instead of having some of them grouped as drop-downs.

How to customize a toolbar

1. Right-click (Windows) or Ctrl+click (Mac OS X) on any button in a toolbar and select Customize.

The Toolbar Manager dialog box opens.

Default K Cancel

2. Do any of the following:
o Add a new icon to a toolbar: Select a tool/command from the Available Tools list and click
the Right Arrow button.

« Remove an icon from a toolbar: Select a tool/command in the Toolbar list and click the Left
Arrow button to remove it from the toolbar.

« Reordericons in a toolbar: Select a tool/command in the Toolbar list and click the Up or
Down Arrow buttons to reposition it.

67



Chapter 3: Interface  About Toolbars

3. Click Apply to apply the changes without closing the Toolbar Manager dialog box or click OK to apply the
changes and close the window.

How to enable the Flat Tools Toolbar preference

1. Open the Preferences dialog box by do:

« Select File > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
o Press Ctrl+U (Windows) or 3£ + , (Mac OS X).

2. Select the Global Ul tab.
3. Inthe Toolbars section, select the Flat Tool Toolbar option.

4. Restart Storyboard Pro. Once the software is restarted, you can customize the Tools toolbar.
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About Workspaces
T-SBFND-003-010

The Storyboard Pro workspace is comprised of several views. You can customize your workspace to suit your work
style, save it as a new workspace, and load it from the Workspace toolbar.

The first time you open Storyboard Pro, the default Drawing workspace is loaded. There are a total of eight ready-
made workspaces.

@ Storyboard Pro

Interface
About Workspaces

_ '_ . Toon Boom

Sriginal

Workspace | Icon | Description

Drawing — This workspace is designed to enable you to draw your storyboard efficiently. The main
space is the large Stage view and the Thumbnails view is at the bottom. This workspace
also gives you quick and easy access to all your tools, as well as the Panel and Story-
board views.

This workspace is designed with the process of animatic creation in mind. The main space
is the large Stage view and the Timeline view is at the bottom, where you can easily edit
the timing of panels, transitions and sounds. This workspace also gives you quick and
easy access to all your tools, as well as the Panel and Storyboard views.

Timeline

Overview This workspace is designed to provide an organized overview of your project. The main
space is the Thumbnails view where you can efficiently reorganize the order of your
panels.

Horizontal This workspace displays your project as a classic horizontal paper storyboard layout. The
main space displays three panels at a time, with the panel information shown below each
one.

Vertical This workspace displays your project as a classic vertical paper storyboard layout. The
main space displays two panels at a time, with the panel information shown at the side of

each.

Pitch Mode This workspace displays your project with a different set of views than the other
workspaces. Access is only given to a certain number of features. This maximizes the
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Workspace | Icon | Description
viewing space to focus solely on the story being pitched.
The Pitch Mode workspace occupies the entire display screen. There are no toolbars or
top menu available.

PDF View This workspace displays your project with the views required to quickly set up your PDF
export.

3D View Gl This workspace displays your project with the views appropriate for working with 3D
objects, including the Camera, Top, Timeline, and Layers views—see 3D Objects on page
357.

When you create or change any of the customer workspaces, the file are stored in a folder called Toon Boom
Storyboard Pro. You can copy this folder if you want to use the same workspaces on a different computer.

« Windows:

o C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom Storyboard

Pro \1200-layouts-xml

« Mac OS X: On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down
the Alt key when displaying Finder's Go menu.

« /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom Storyboard

o Linux:

Pro/1200-layouts-xml

« /home/[user_name]/Toon Boom Animation/Toon Boom Storyboard Pro /1200-layouts-xml/
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Loading Workspaces

There are several ways to load a workspace in Storyboard Pro.

How to load a workspace

« From the View toolbar, click a workspace button.

1 2 3 4 5 6 7 8 9 10

1. Drawing \Workspace 6. Pitch Mode Workspace
2. Timeline Workspace 7. PDF ViewWorkspace
3. Overview Workspace A 3D ViewWorkspace
4. Horizontal Workspacs 9. Zoom Out

& Vertical Workspace 10. Zoom In

T-SBFND-003-011

« Select Windows > Workspace > Workspace and then select a workspace.

« Use the keyboard shortcuts 3 to 8 to open the corresponding workspaces. There is no keyboard shortcut for

the PDF View. You must use the button on the View toolbar.
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Creating a Workspace

Using the Workspace Manager, you can modify, create, delete, rename, and reorder workspaces. You can create
a new workspace from an existing one and modify it to suit your needs.

How to create a new workspace

1. Do one of the following:

» Select Windows > Workspace > Workspace Manager.

« Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the Workspace
Manager = button.

2. Inthe Available Workspaces list, select an existing workspace.

Rename

Cancel

3. At the bottom of the Available Workspaces list, click the Add button to add a workspace.

4. Select the new workspace you created, then click Rename and give it a new name.

5. Select the new workspace and click the Right Arrow button to send it to the Workspace toolbar.

6. Click OK
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Renaming a Workspace

You can rename an existing workspace in the Workspace Manager.

How to rename a workspace

1. Do one of the following:
« Select Windows > Workspace > Workspace Manager.

« Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the Workspace Man-
ager = button.

2. From the Available Workspaces column, select a workspace to rename.
3. Click the Rename button.

4. Type in a new name for the workspace.
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Saving a Workspace

Storyboard Pro automatically saves the changes made to a workspace. This means that when you resize, move
around, add or delete views, your workspace will be automatically saved in its current state.

You can save a workspace manually, or as a new version to avoid overwriting the current one.
How to save a workspace manually
« Select Windows > Workspace > Save Workspace.
How to save your workspace as a new version

1. Select Windows > Workspace > Save Workspace As.

The Save Workspace As dialog box opens.

2. Typein a name for the workspace.
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Deleting a Workspace

You can delete a workspace from your list using the Workspace Manager. Note that you cannot delete the default
worksapces.

How to delete a workspace

1. Do one of the following:
« Select Windows > Workspace > Workspace Manager.

« Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the Workspace Man-
ager = button.

2. From the Toolbar list on the right, select the workspace to delete and click the Left Arrow button to send it
to the Available Workspaces list. This removes it from the Workspace toobar.

Rename

Cancel

3. From the Available Workspaces list on the left, select a workspace and click the Delete button.

4. Click OK.
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Showing and Hiding Workspaces

You can show and hide selected workspaces from the Workspace toolbar's drop-down menu.

How to show a workspace

1. Do one of the following:
o Select Windows > Workspace > Workspace Manager.
« Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the Workspace
Manager = button.

2. Inthe Available Workspaces list, select the workspace to be displayed. Click the Right Arrow button
to send it to the Workspace toolbar.

How to hide a workspace

1. Do one of the following:
o Select Windows > Workspace > Workspace Manager.

« Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the Workspace
Manager = button.

2. Inthe Workspace Manager, select the workspace to be hidden. Click the Left Arrow button to send it
to the Available Workspaces list.
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Reordering the Workspace List

You can edit the order that the available workspaces are listed in the Workspace toolbar’'s drop-down menu.

How to reorder the workspace list

1. Do one of the following:
« Select Windows > Workspace > Workspace Manager.
« Select Windows > Toolbars > Workspace and in the Workspace toolbar, click the Workspace Man-
ager = button.

2. From the Toolbar list, select the workspace to be reordered and click the Up or Down Arrow buttons to move
it up or down.
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Restoring the Default Workspace
T-SBFND-003-012

You can restore the modified workspaces to their original default layout. This is particularly useful if you have
closed several views or moved toolbars.

How to restore the default workspace

o Select Windows > Restore Default Workspace.

Interface Navigation

Toon Boom Storyboard Pro lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the

interface.
Command Action Access Methods
View >Zoom In
Zoom In Zooms in the view. Press 2 or roll the mouse
wheel up.
View > Zoom Out
Zoom Out

Zooms out the view.

Press 1 or roll the mouse
wheel down.

Zoom In or Out

Zooms in or out of the view.

Roll the middle mouse button
up or down.

Hold down the Spacebar and
the middle mouse button
while dragging the mouse up
or down.

Hold down the Spacebar and

Pan Moves parallel to the view. drag in the direction you want
to pan the view.
Resets the view’s pan to its default View > Reset Pan
Reset Pan o
position. Press Shift + N
View > Reset View
Reset View Resets the view to its default position. | Press Shift + M

Reset View to Default Drawing Area

Resets the Stage view to show the
default drawing area, which is the
space inside the default camera frame
(before the camera is modified).

View > Reset Stage View
To > Default Drawing Area

Reset View to Current Panel

Resets the Stage view to show the cur-
rent panel in its entirety.

View > Reset Stage View
To > Current Panel Over-
view
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Reset View to Camera Overview

Resets the Stage view to show an
overview of the camera frames. If a
camera movement was created in the
selected panel, it will show the entire
space within the camera movement.

NOTE: This option is only available
when the Point of View Mode is set
to the Scene or Panel Level.

View > Reset Stage View
To > Camera Overview

Reset View to Start Camera

Resets the Stage view to focus on the
starting camera position of the camera
movement on the current panel.

NOTE: This option is only available
when the Point of View Mode is set
to the Scene or Panel Level.

View > Reset Stage View
To > Start Camera Frame

Reset View to End Camera

Resets the Stage view to focus on the
ending camera position of the camera
movement on the current panel.

NOTE: This option is only available
when the Point of View Mode is set
to the Scene or Panel Level.

View > Reset Stage View
To > End Camera Frame

Reset Rotation

Resets the view’s rotation to its default
position.

View > Reset Rotation

Press Shift + X

Resets the view’s zoom to its default

View > Reset Zoom

counter-clockwise, like an animation
table.

Reset Zoom o
position. Press Shift+Z

Rotate 30 CW Rotate§ the.Camera view 30 degrees View > Rotate View CW
clockwise, like an animation table.
Rotates the Camera view 30 degrees

Rotate 30 CCW

View > Rotate View CCW

Toggle Full Screen

Lets you switch back and forth
between maximizing Storyboard Pro
on your screen and returning to the
default size.

View > Toggle Full Screen

Ctri+Alt+Shift+F (Windows)
or £ +Alt+Shift+F (Mac OS
X)

Navigation Toolbar

Storyboards can easily become very extensive projects. The Navigation toolbar lets you quickly display the first and

last frame of a panel. These buttons grey out when the playhead is at the start or end of a panel.
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First Frame

Last Frame

To learn more about animatics and timing, see Motion on page 381.

How to access the Navigation toolbar

>

Select Windows > Toolbars > Navigation.

Icon Tool Name Description
.l First Frame Displays the first frame of the layer animation.
- Last Frame Displays the last frame of the layer animation.
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Chapter 4: Storyboard Structure

T-SBFND-005-001

To build and organize your storyboard project, you will use panels, scenes, sequences, and acts. You have many
options to customize these project elements in order to keep things clear and organized.

@ Storyboard Pro

Panels
About the Storyboard Structure

- -_ Toon Boom

Qriginal

Below are examples of panels, scenes, sequences and acts in the Thumbnails and Timeline views.

1. A panel represents an action. You can use multiple panels whenever you need more than one drawing to
clearly express the acting within a scene. It is the white rectangle representing the camera view. By default
the current panel will be highlighted in red in the Thumbnails view.

2. Asceneis composed of one or several panels. In animation, whenever the camera angle changes, you
should create a new scene. In live action, this is called a shot.In other words, if your action goes from a mid
shot to a close shot, each of these shot should be a different scene. By default, a grey rectangle connects the
different panels of a scene together.

3. Asequence is a series of scenes that should be grouped together. Usually, scenes are grouped together by
location. For example, all the scenes that are taking place in one location, should be in the same sequence
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and as soon as there is a change of location, it should be a new sequence. by default, a blue line connects
the different scenes of a sequence together.

4. Anactis composed of one or several scenes and sequences. An act usually represents a story arc. It can
be a certain time lapse in the story. For example, all the scenes in the first half of a TV series are one act,
and the second act is after the commercial break. As for movies, live action, or even video games, there
could have several different story arcs. In Storyboard Pro, a purple flag shows the beginning of a new act.
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About Scenes
T-SBFND-005-002

In live-action productions, scene changes occur when the location of the action changes, such as from the bedroom
to the living room, from the living room to outside, from outside to across town. In traditional animation, every time a
painted background has to be changed or the camera cuts, a scene change is required, even if the characters are in
the same location. For example, two characters could be talking face-to-face in a forest, however the trees behind
each character would be different as the shot cuts from one character to the other. Each shot would require a new
scene. A sequence of these scenes taking place in the same location could be referred to as an act.

In Storyboard Pro, panels in the same scene are grouped together by a dark grey bounding box.

You can:

« Create new scenes

o Delete scenes

« Rename scenes

« Lock and unlock scene and panel names
o Split scenes

« Select all panels ina scene

83



Chapter 4: Storyboard Structure About Scenes

Creating Scenes

T-SBFND-005-003

When you create a new scene, it is usually added after a selected scene, but you can make the new scene

appear before it. You can also create a new scene from a series of selected panels within a scene and then
separate them as a new one.

How to create a hew scene

1. Do one of the following:
« Inthe Storyboard toolbar, click the Add Scene #; button.
» Select Storyboard > Create Scene.

A new panel is created in the Timeline immediately after the current shot. The new panel is contained in a
separate grey box.

Thumbnails
view e ’
New scene New scene New scene
Timeline
view . T Pl

How to create a scene before the current scene

« Select Storyboard > New > New Scene Before.

A new scene containing a blank panel is added before the current scene.
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How to create a scene from a selection of panels

1. Inthe Thumbnails or Timeline view, select one or more consecutive panels.

The selected panels are joined together within the scene.
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Import Images as Scenes

T-SBADV-008-001

You can import one or more images and have Storyboard Pro automatically create a new scene for each. This

useful when you have a series of bitmap images that you need to include, such as backgrounds or scanned
storyboards.

The supported image formats include: *.bmp, *.jpg, *.omf, *.opt, *.pal, *.png, *.psd, *.scan, *.sgi, *.tga, *.tif, *.tvg,

and *.yuv.

How to import images as scenes

1. Select File > Import > Images as Scenes.

The Choose Image Files browser opens.

2. Browse to the desired images, select one or more images, and click Open.

The images are imported and a new scene is created for one.

NOTE: By default, when importing images in Storyboard Pro, the images are vectorized in colour and imported in
vector layers. You can access more vectorization options by enabling the Display Vectorize Options Dialog
preferences—see Importing Images as Layers on page 179.

Automatic Insertion

When using the Import Images as Scenes function, you can save a little time by using the following naming
convention for your bitmap images when you scan. Having your bitmap images named in the following manner,
will allow acts, scenes, panels and layers to be created upon import into Storyboard Pro.

How to use Automatic Insertion

1. When scanning images, name them according to the following example:

<name>-A#-S#-E#-P#-L<layer name>.<extension>

« Name: This is the name of the project. This string will not be inserted into the Storyboard
Pro project, but it is mandatory.

« A: Indicates the act the image will be placed in. Replace the # with the number of the act.

« S:Indicates the first (or only) scene the image will be placed in. Replace the # with the num-
ber of the first scene this image will be used in.

» E: (Optional attribute) Use this attribute along with the S attribute if you want the image to be
included in multiple scenes. Replace the # with the number of the last scene this image will
be usedin.

« P: (Optional attribute) This attribute is to indicate which panel the image will be placed in.
Replace the # with the number of the panel in the scene.
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o L: (Optional string) This string is to indicate the name of the layer where the image will be
placed. Replace the # with the number of the layer in the scene.

2. Select File > Import > Images as Scenes, and browse to the location on your computer where your images
are saved.
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The following are two examples of how the Automatic Insertion could be used:

How to use the Automatic Insertion

1. The drawings are scanned and named as such:

» RocketRodeo-A1-S103-P1-LBackground.jpeg
» RocketRodeo-A1-S103-P2-LBackground.jpeg
» RocketRodeo-A1-S103-P3-LBackground.jpeg
» RocketRodeo-A1-S104-P1-LCity.jpeg

2. Then, imported using the File > Import > Images as Scenes command, they are imported in the following
order in the Storyboard Pro project:

Act 1, Scene 103, Act1. Scene 103, Act 1, Scene 103, Act 1, Scene 104,
Panel 10f 3, Panel 2of 3, Panel 3of 3, Panel 1of 4,
Layer - Background Layer - Background Layer - Background Layer - City

How to use the Automatic Insertion using the E parameter

1. Adrawing is scanned and named like this: RocketRodeo-A1-S100-E102-P1-LBG.jpeg.

2. Then, imported using the File > Import > Images as Scenes command, the image is placed in act 1, in
scenes 5 through 7, on panel 1 on a layer called Background:

Act 1. Scene 100, Act 1. Scene 101, Act 1, Scene 102,
Panel 10f 1, Panel 10of 1, Panel 10f 1,
Layer-BG Layer-BG Layer-BG
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Deleting Scenes

T-SBFND-005-004

If you have one or more scenes that are no longer needed, you can easily remove them. When you delete a scene or
insert a new scene between two existing scenes, the numbering of the scenes will be out of order. By default, there
is no automatic renaming of scenes. You can change this in the Preferences dialog box—see Renaming Scenes on
page 90.

NOTE: The last scene in your project cannot be deleted. There must always be atleast one scene in the project.

How to delete a scene

1.

In the Thumbnails view, select a scene to delete. If it is composed of more than one panel, select them all.
You can also click the minus sign (-) in the upper-left corner of the scene to collapse it into one panel. This will
let you select all the panels with one click.

% o
Y (S
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2. Select Edit > Delete Selected Panels/Transitions or press Delete.

The selected scene is deleted from your storyboard.
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Renaming Scenes
T-SBFND-005-005

When you start moving scenes and panels around, the Rename Scene dialog box automatically opens and
prompts you to rename them every time. You can also rename selected scenes as needed, using the Rename
Scene command or the Panel view.

How to rename scenes with the Rename Scene command

1. Inthe Thumbnails view, select a scene to rename.

2. Select Storyboard > Rename Scene.

The Rename Scene dialog box opens.

Cancel

3. Inthe New name field, type the new name for the selected scene. You can type either a number or a name.

4. Usethe Renaming Rule for Subsequent Scene menu and determine if the next scenes should be
renamed. The Renumbered Scene Names section displays the current and new names for all the scenes
that will be affected by the renaming process.

« Current Scene Only:Renames only the selected scene.

« Renumber Scenes:Renumbers the current scene, as well as all the scenes that follow.
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« Renumber Selected Scenes: Renumbers the first selected scene of a multiselection, as well
as all the following scenes that are part of the selection.

- Renumber Prefix Only: Renumbers the scenes' numerical prefixes beginning at the selected
scene. The new name must be a numerical value.

5. Select the Reset Panel Name option to reset all panel names according to the current panel time automatic
increment rule.

6. Select the Do not show this dialog automatically option to prevent it from automatically opening every time
you move scenes around.

How to rename a scene using the Panel view

1. Inthe Thumbnails view, select a scene to rename.

2. Inthe Panel view, type the new name or number for your scene in the Scene field.

Panel (%

3. Press Enter to validate the scene name or number.

If the name is invalid or already used by another scene, a warning message will appear. If this happens, use
the Rename command to rename all subsequent scenes.
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Locking and Unlocking Names
T-SBADV-004-012

Itis possible to lock sequence, scene and panel names to prevent any unwanted modification.

NOTE: To type custom panel names, you must enable the Allow Custom Panel Names preferences—see Locking
and Unlocking Names on page 92Locking and Unlocking Names on page 92

How to lock scene and panel names

« Select Storyboard > Lock Sequence, Scene and Panel Names.

The Scene and Panel fields become deactivated.

The Thumbnail view displays a locked icon in the header.

How to unlock scene and panel names

« Select Storyboard > Unlock Sequence, Scene and Panel Names.

The names are unlocked and can be edited if necessary.
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Splitting Scenes
Using Storyboard Pro, you can split the current scene in two or break it into three parts.

When you split a scene, it is divided before the current panel by default.

NOTE: You can change this in your preferences so that when you split a scene, itis broken into three parts and the
selected panel is isolated.

How to split the current scene

1. Inthe Thumbnails view, select a scene to split. The current scene must contain two or more panels. The spilit
will occur before the current panel.

2. Select Storyboard > Split Current Scene.

The scene is split into two scenes.

How to break the current scene

1. Inthe Preferences dialox box, select the General tab, and then select the Break Scene when performing
the “Split Current Scene” command option.

2. Inthe Thumbnails view, select a scene to break. The current scene must contain two or more panels.
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3. Select Storyboard > Split Current Scene.

The scene is divided in three.

r 4 }

Example: The same scene after diviting into two scenes,
one has a single panel, the other scene has two panels.
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Selecting All Panels
T-SBADV-004-013

You can select all the panels in a scene, using the Select All Panels in Scene command.

NOTE: You can also double-click on a panel's header to select all panels in the scene.

How to select all the panels of a scene

1. Inthe Thumbnails or Timeline view, select one panel inside the scene you want to select all panels from.

2. Select Edit > Select All Panels in Scene.
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Expanding and Collapsing Scenes
T-SBADV-004-008

As you work on a storyboard, you may accumulate a large number of scenes composed of a tremendous number
of panels. You can collapse lengthy scenes into one panel to have more space in the Thumbnails view.

Expand/Collapse a Scene

Thumbnails  ==|%
fj=— Expand All Scenes

B~ Collapse All Scenes

How to expand or collapse a scene

» Inthe Thumbnails view, click the Expand/Collapse Scene button at the top-left of a scene composed
of many panels.

One of the following happens:

The scene collapses, leaving only the first panel visible. The Expand/Collapse icon changes to a plus (+)
sign.

The scene expands to show all its panels. The Expand/Collapse icon change to a minus (-) sign.

How to collapse or expand all scenes

» Inthe Thumbnails view, click the Expand/Collapse All Scenes button at the top-right.
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Working with a Collapsed Scene

When your scene is collapsed, you can still work in the Timeline view. However when you select a panel, the entire
scene is selected, not just one panel. This means that you cannot work only on a single panel in the Timeline view;
you must first expand the collapsed scene.

IMPORTANT: If you try to delete a panel in a collapsed scene, the entire scene will be deleted. You cannot delete a
single panel.
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About Panels

T-SBFND-005-006

Your scenes (shots) should comprise as many panels as needed to show the actions taking place. With
Storyboard Pro, you can easily create many panels.

By default, you can find this information on the top of each panel:

al rmier of panels in scene
arsel (i frames)

You can:

o Create a panel

« Delete a panel

« Rename panels

« Duplicate a panel
« Move panels

o Customize the panel colour
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Creating Panels
T-SBFND-005-007

When you create a new panel, it is added after the current panel.However, you can create a new panel before the
current panel. You can also create a new panel that contains elements (layers) from another panel.

How to create a new panel

1. Inthe Thumbnails view, select the panel to which you want to add a panel.

2. Do one of the following:

« Inthe Storyboard toolbar, click the New Panel #; button.

« Select Storyboard > New > New Panel.

o PressP.

A new panel is added to the storyboard and is part of the same scene as the current panel.

How to create a new panel before a selected panel

1. Inthe Thumbnails view, select a panel.

2. Select Storyboard > New > New Panel Before.
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A new panel is added before the selected panel and is inside the same scene.

How to use create a new panel that contain elements from another panel

1. Inthe Thumbnails view, select the panel that contains the elements you want duplicate into the new panel.

2. Do one of the following:

« Select Storyboard > Smart Add Panel.
« Inthe Storyboard toolbar, click the Smart Add Panel % button.

The Smart Add Panel dialog box opens.

Ak gl e il s

3. Select the layers that contain elements you want to copy into the new panel.

4. Select the Add default layer if missing option to create the default layers in the new panel if they are not
part of the Smart Add Panel selection list.

A new panel is created next to the selected panel. All layers are copied into the new panel, but only the
layers you chose contain artwork.
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Renaming Panels
T-SBFND-005-009

You can rename panels one at a time using the Panel view or rename multiple panels using the Rename Panel
command. But before you can rename panels, you must use the Preferences dialog box to enable the renaming of
panel names.

@ Storyboard Pro

Panels

Renaming Panels

_ '_ . Toon Boom

Qriginal

How to enable the renaming of panels

1. Do one of the following:

« Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).

o Press Ctrl + U (Windows/Linux) or &£ + U (Mac OS X).

2. Inthe Preferences dialog box, select the Naming tab.

3. Inthe Panel section, select the Allow Custom Panel Names option.

How to rename a single panel

1. Inthe Thumbnails view, select a panel to rename.

2. Inthe Panel view, type a new name in the Panel field and press Enter.
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How to rename multiple panels

1. Inthe Thumbnails view, select a panel to rename.

2. Select Storyboard > Rename Panel.

The Rename Panel dialog box opens.
3. Type a new name in the New name field.

4. You can use the Renaming Rule for Subsequent Panel menu to determine if the next scenes should be
renamed:

« Current Panel Only: Renames only the selected panel.
« Renumber Panels: Renumbers the current panel, as well as all panels that follow.

« Renumber Selected Panels: Renumbers the first selected panel of a multiselection, as
well as all following panels that are part of the multiselection.

« Renumber Prefix Only: Renumbers the panels’ numerical prefixes beginning at the selec-
ted scene. The new name must be a numerical value.

The Renumbered Panel Names section displays a list of the panels that will be renamed, their old names
and the new names.
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Deleting Panels

T-SBFND-005-008

If there are panels you no longer need, you can simply delete them. Note that it is impossible to have an empty
project as there is a minimum of one panel.

@ Storyboard Pro

Panels

Deleting Panels

: Toon Boom
- Qriginal

How to delete panels

1. Inthe Thumbnails view, select one or more panels to delete.

2. Do one of the following:

« Inthe Storyboard toolbar, click the Delete Selected Panels ¢ button.
« Select Edit > Delete Panel.

o Press Delete.

The selected panels are deleted from your storyboard.
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Duplicating Panels

T-SBFND-005-010

You can duplicate panels when you need an exact copy of an existing one.

@ Storyboard Pro

Panels

Duplicating Panels

: -_ Toon Boom

Qriginal

How to duplicate panels

1. Inthe Thumbnails view, select the panel or range of panels to duplicate.

2. Do one of the following:

« Inthe Storyboard toolbar, click the Duplicate Selected Panels £ button.

« Select Storyboard > Duplicate Selected Panels.

A copy of the previous panel is created.
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The duplicated panels are added at the end of the current scene. If the selection included panels from
different scenes, new scenes are created for them.
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Moving Panels

T-SBFND-005-011

You can easily move panels in the Thumbnails and Timeline views to reorder, separate, or join them. Joining
panels will make them part of the same scene.

@ Storyboard Pro

Panels

Moving Panels

_ Toon Boom
. Qriginal

You can reorder selected panels by dragging and dropping them where you see a straight blue line. You can drop
the panels between two scenes or in the middle of a scene. Dropping a panel in the middle of a scene will include
it in the scene; it will not split it.

If you select more than one panel to move, you can drag them by clicking the current panel in the selection.
Clicking any other panel in the selection will deselect the other panels.

You can remove selected panels from a scene. Just drag and drop the panels between two scenes when you see
a straight red line appear.
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You can join selected panels with another scene. Just drag the panel onto the edge of the scene you want it to attach
to, and drop it when you see a right-facing or left-facing bracket appear.

You can drag and drop a selection to remove it from a scene. Just drag the selection out and drop it between two
scenes when you see a rounded green rectangle shape appear.

How to drag and drop panels

1. Inthe Thumbnails or Timeline view, select one or more panels to move.

2. Click the header of the current panel and drag it to the new location.
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« When you move your cursor, a thumbnail with a number is displayed. The number rep-
resents the number of selected panels being moved.

« Inthe Thumbnails view, a straight red line or a red bracket represents what the movement
will do.

« Inthe Timeline view, a green bracket or a green shape represents what the movement will
do.
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Customizing the Panel Colour
T-SBADV-004-009

You can mark panels with a custom colour to quickly identify and manage them. You can also do this for audio
clips—see Sound on page 443.

How to customize a panel with colour

1. Inthe Timeline view, select the panel you want to mark with colour. You can also make a multiple selection.

2. Right-click on your selection and select one of the following option: Set Colour > Red, Orange, Yellow,
Green, Blue, Purple or Custom. Choosing custom, will open a Colour Picker dialog box, in which you can

select the colour of your choice.

The selected panel will change to the colour you have chosen.

How to reset the panel colour

1. Inthe Timeline view, select the panel you want to reset the colour to default. You can also make a multiple
selection.

2. Right-click on your selection and select Set Colour > Default Colour.

The selected panel colour will reset to the default colour.

NOTE: The default colour of panels is grey. However, you can change this value in the Preferences dialog box—see
Preferences on page 1.
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About Sequences

T-SBADV-004-014

A sequence is a particular section of the story composed by one or several scenes that has a unity in either time
or its location. Scenes that are contained in different sequences can have the same name. Like scenes, panels,
and acts, you can manipulate the sequences of your story while you are building your storyboard.

In the Timeline view, sequences are displayed as blue bars above the timeline.

When you hover the cursor on the blue sequence bar, the sequence’'s name is
displayed in a tooltip.

You can:

« Create asequence

« Remove all sequences
« Rename a sequence

« Split and join sequences

» Select all panels in a sequence
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Creating Sequences
T-SBADV-004-015

By default, when you start building a storyboard, the scenes you create are not part of a sequence. If you want to
start adding sequences to your project, you must use the New Sequence button for every new scene beginning a
new sequence. This will add a new scene to your project and show the sequence markers in the Thumbnails and
Timeline views.

You can also start adding sequences to your project at anytime, using the New Sequence from Selection command,
and manipulate them using the different commands in the following topics.

By default, new storyboard projects are created without sequences. You can change this, so that new projects are
automatically created with a sequence.

NOTE: When you add a new scene using the New Sequence button or command for the first time in your project, all
scenes before it will be combined as a sequence. For this reason, you should use the New Sequence button when
starting the first scene of your second sequence.

How to create a new sequence

1. Do one of the following:

» Inthe Storyboard toolbar, click the New Sequence £ button.

» Select Storyboard > New > New Sequence.

A new scene is added to your project and is now the starting point of a new sequence. If this is the first
sequence you add to a project, all scenes prior to it will be combined as a sequence as well. The sequence
markers will also become visible in both the Thumbnails and Timeline views.

How to create a new sequence from a selection

1. Inthe Thumbnails or Timeline view, select one or many scenes to combine as a sequence.
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2. Select Storyboard > New > New Sequence from Selection.

Your selection becomes a new sequence. If this is the first sequence added to your project, all scenes before or
next to it will be combined as sequences as well, and the sequence markers will be displayed in the Thumbnails
or Timeline views. If your selection was part of an existing sequence, it will be split accordingly.

NOTE: A single scene cannot be splitinto two or more different sequences, unless you split the scene first.

How to enable the Automatically Create New Sequence preference

1. Do one of the following:

» Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
» Press Ctrl+U (Windows) or 38 + , (Mac OS X).

2. Inthe Preferences dialog box, click the General tab.

3. Inthe General section, select the Automatically Create New Sequence option.
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Renaming Sequences
T-SBADV-004-016

Once you start adding sequences to your project, the Sequence field will become visible in the Panel view, allowing
you to view the selected sequence's name and edit it if needed.

You can rename a selected sequence using the Panel view or Rename Sequence command.

How to rename a sequence using the Panel view

1. Inthe Thumbnails view, select a sequence to rename.

2. Inthe Panel view, type the new name or number for the selected sequence in the Sequence field and press
Enter/Return.

Panel (%

How to rename sequences with the Rename Sequence command

1. Inthe Thumbnails view, select a sequence to rename.

2. Select Storyboard > Rename Sequence.

The Rename Sequence dialog box opens.

Cancel

3. Inthe New name field, type the new name for the selected sequence. You can type either a number or a
name. If you type a name or a number that is already used by another sequence, a waring message will
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4.

appear.

You can use the Renaming Rule for Subsequent Sequence menu to determine how the next
sequences should be renamed. The Renumbered Sequence Names section displays the current and new
names for all the sequences that will be affected by the renaming process.

» Current Sequence Only: Renames only the selected sequence.

» Renumber Sequences: Renumbers the current sequence, and the ones that follow.

» Renumber Selected Sequences: Renumbers the first selected sequence of a multiselection, as well
as all the following sequences that are part of the multiselection.

» Renumber Prefix Only: Renumbers renumbers the sequence numerical prefixes beginning at the
selected sequence. Note that the new name must be a numerical value.
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Removing Sequences

The sequences in your project can all be removed at the same time.

How to remove all sequences from a project

« Select Storyboard > Remove All Sequences from Project.

All sequences are removed from your project.
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Joining and Splitting Sequences
T-SBADV-004-018

Two sequences can be joined using the Join Selected Sequences command. A sequence can also be split in two.

How to join sequences

1. Inthe Thumbnails or Timeline view, select two consecutive sequences.

2. Select Storyboard > Join Selected Sequences.

The selected sequences are joined as one.

How to split a sequence

1. Inthe Thumbnails or Timeline view, select the scene before the sequence to be split.

2. Select Storyboard > Split Current Sequence.

The sequence is split in two and the Rename Sequence dialog box opens, prompting you to rename the
second portion of the split sequence—see Joining and Splitting Sequences on page 118

| A
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Selecting All Panels in a Sequence
T-SBADV-004-019

You can select all the panels of a sequence simultaneously.

How to select all the panels in a sequence

1. Inthe Thumbnails or Timeline view, select a panel in the sequence you want to select all panels from.

2. Select Edit > Select All Panels in Sequence.

119



Chapter 4: Storyboard Structure About Acts

About Acts

T-SBADV-004-020
An act is a particular section of the story delimited by a particular event or mood.

For example, a story could be constructed in three acts:

« Act 1: The initial situation, character introduction.
o Act 2: The journey.

o Act 3: The resolution.

Like scenes, panels and sequences, you can manipulate acts when building your storyboard. To add acts to your
storyboard, you must first enable the option.

You can:

« Enable acts
o Create an act

« Joinacts
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Enabling Acts
T-SBADV-004-021

By default, the acts are disabled. You must enable them in the Preferences dialog box.

How to enable acts

1. Open the Preferences dialog box:

« Select Edit > Preferences (Windows) or Storyboard Pro> Preferences (Mac OS X).
o Press Ctrl+U (Windows) or &£ + , (Mac OS X).
2. Inthe Preferences dialog box, select the General tab.

3. Inthe General section, select the Enable Acts option.

A purple flag appears at the beginning of your project, indicating the act.

1(1/1) 08:01
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Starting New Acts

T-SBADV-004-022

Once you have enabled acts in your storyboard project, it indicates that your storyboard is composed of a single
long act. You must break it in several smaller acts. Before splitting a project into acts, you must to define the
starting panel for each act in your story.

How to start new acts

1. Inthe Thumbnails view, click the panel where you want to create a new act.

2. Do one of the following:

» Select Storyboard > New > Start New Act.
» Right-click the selected panel and select Start New Act.
The Rename Scene dialog box is displayed.

3. Enter a name for the new act and click OK.

The act is divided in two at the point you selected.
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Joining Acts
T-SBADV-004-023

Once an act has been split, it is possible to join acts at any time.

How to join acts

1. Inthe Thumbnails view, select the last panel and first panel of the acts you want to join.

You can also join more than two sections by selecting the last panel of the first section until the first panel of
the last section you want to join.

2. Do one of the following:

« Select Storyboard > Join Selected Acts
« Right-click the selected panel and select Join Selected Acts.
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Selecting All Panels in an Act
T-SBADV-004-024

You can select all the panels of an act simultaneously.

How to select all panels in an act

1. Inthe Thumbnails or Timeline view, select a panel contained in the act in which you want to select all the
panels.

2. Select Edit > Select All Panels in Act.
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Regenerating Thumbnails

T-SBADV-004-011

You can get the most up-to-date thumbnails in the Thumbnails view. As you draw, a series of small images
(thumbnails) is generated. These thumbnails are automatically refreshed based on the refresh duration you set in the
Preferences dialog box (Advanced tab, Delay Before Updating Thumbnails parameter).

You can choose update thumbnails immediately. This deletes all cached thumbnails in the Thumbnails and Timeline
views, and forces new thumbnails to be regenerated.

How to regenerate all thumbnails

1. Select File > Regenerate All Thumbnails.

2. Inthe dialog box that opens, click Yes.

IMPORTANT: This cannot be undone. All existing thumbnail images in the Library will be deleted.

All thumbnails are deleted and replaced with the regenerated ones.
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Chapter 5: Captions

T-SBFND-006-002

Captions are text fields you can edit to include special indications and notes specific to a panel in your storyboard.
These text indications can be dialogue, action notes, sound effects, and more. You can customize the captions to
include any information realted to your project.

@ Storyboard Pro

Script and Captions

About Captions

- Toon Boom
- Qriginail

When you start your storyboard from a script, the caption fields are where you will break down the script to build the
various scenes, panels, sequences, and acts of your project.

To add information to a particular panel, you will use the Panel view. This view displays the different captions related
to a panel, as well as other useful information.

The Panel view always shows the information and captions of the selected panel—see Panel View in the Reference
Guide.
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Importing Scripts
T-SBFND-006-001

A complete storyboard is not only made of drawings, but also dialogue, actions, and valuable indications. In
Storyboard Pro, you can easily import a script into your storyboard project to help edit captions.

@ Storyboard Pro

Script and Captions

Importing Scripts

- Toon Boom
: Qriginal

If your script is in .txt or .rif file format, you can import it into the Script caption field.

If a script was created with Final Draft, importing it into Storyboard Pro should be your next step. While importing
your Final Draft script, you will retain the rich text formatting.

NOTE: If you are working with Final Draft 8, Storyboard Pro can directly import the *.fdx project file. If you are working
with Final Draft 7 and earlier, you must export your project from Final Draft as an *.xml first, so you can importitin
Storyboard Pro—see How to export a script as an XML on page 28.

How to import a script using the Import Caption command

1. Inthe Storyboard view, click the Caption Menu = button and select Import Caption.
The Import Caption browser opens.

2. Select your .txt or .rif file and click Open.

The script appears in the Script caption field.
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card =%
Q_

How to import a Final Draft script

1. Inthe Storyboard view, click the Caption Menu |=| button and select Import Final Draft Script.
The Select Final Draft browser opens.

2. Select your Final Draft *.fdx or *.xml file and click Open.

The script appears in the Script caption field with all notes and formatting intact.
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How to export a Final Draft version 7 script as an *.xmil file

1. Start the Final Draft Tagger software.
2. Select File > Import Script, the keyboard shortcut is Ctr+l (Windows) or 3£ +1 (Mac OS X).
The Import dialog box opens.

3. Inthe browser, select your script file and click Open.

Your script appears in Final Draft Tagger.

# 3p.fdr (=

File  Print
l:l Reveal &ll Elements ™
# Int... Set Day/Night Len Category
1 EXT. DAY FOREST PATH 1.0 + Cast Members i
Z EXT. DAY FOREST 1 0 Extras
3 EXT. DAY FOREST 1 0 Stunts
4 INT. DAY PIG’ 5 HOUSE 1 0 Vahdrlen
5 EXT. DAY FOREST 10 Props
o 1 0
Costumes |
Add Category Clear Category
EXT. DAY - FOREST PATH Element
PIG
The second little pig met a man with a bundle of furze
[sticks].
PIG
Please, man, give me that furze to
build a house.
Which the man did.
Add Element

==

4. Select File > Export to XML.

5. Close the Final Draft Tagger application.
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Adding Captions

In each panel, there are four caption fields: Dialogue, Action Notes, Slugging and Notes. If you need to enter more
information, you can add a new caption for your panels. The new caption will be available for every panel in your
storyboard.

In the Storyboard view, by default, there is only one caption field which is called Script. If you need to, you can
add more captions to this view such as production notes. These captions are only for reference and will not be
exported.

Just like in a traditional storyboard, you can add drawn indications to a panel’s caption. For this, you need to add a
Sketch caption to your panel.

NOTE: You cannot add a sketch caption to the Storyboard view.

How to add captions to a panel

1. Inthe Thumbnails view, select a panel.

2. Do one of the following:
» Inthe Panel view, click a Caption Menu button and select Add Caption.

» Select Caption > Add Caption to Panels.
The Choose Field Name dialog box opens.

3. Type a name for your new Caption field. In the following example, the caption is named: SFX.

The new caption appears below the existing ones.

How to add captions in the Storyboard view

1. Inthe Storyboard view, do one of the following:

» Click a Script Caption Menu button and select Add Caption.

» Select Caption > Add Caption to Storyboard.
The Choose Field Name dialog box opens.

2. Type a name for your new Caption field.
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The new caption appears below the Script caption. In the following example, the caption is named: Director
Notes.

How to add a sketch to a panel

1. Inthe Thumbnails view, select the panel to which you want to add a sketch.

2. Do one of the following:
» Inthe Panel view, click a Caption Menu button and select Add Sketch.
» Select Caption > Add Sketch to Current Panel.
The Choose Field Name dialog box opens.

3. Type a name for the Sketch field.

The Sketch field appears below the existing captions for this panel only.
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4. Once you added a Sketch caption field, you can use any drawing tool to sketch in it—see Drawing on page
183 and Colouron page 283.
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Renaming Captions
T-SBFND-006-005

If it is more convenient for you, you can rename the captions.

How to rename a caption

1. Inthe Panel or Storyboard view, do one of the following:

« Select Caption > Rename Caption and then select the caption to rename from the list.

« Inthe caption to rename, click the Caption Menu button and select Rename Caption.

2. Type a new name for your caption field.

NOTE: After you have changed the names of the captions and you are certain you want to keep these names
throughout the project, you can set the new names as the default by selecting Caption > Save Captions Layout as
Default.
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Deleting Captions

How to delete captions

1. Display the Panel or Storyboard view, depending on whether it is a panel caption or storyboard caption you
want to delete.

2. Inthe Panel or Storyboard view, select a caption to delete. Click the Caption Menu button and select
Delete Caption. You can also select Caption > Delete Caption > select a caption to delete from the list.

A warning message opens.

oject will delete the text entered in this field in all

nt to remove this field from the pr

» If you are sure you want to delete the caption, click Yes.
» If you want to cancel the process, click No.
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About Default Panel Captions
T-SBFND-006-003

@ Storyboard Pro

Script and Captions
About Default Panel Captions
——

_ '_ Toon Boom

Sriginal

There are several fields which are collectively known as panel captions. Captions are a method by which you can
organize information in your project, and tie that information to a panel. They are fully customizable. These are the
default names:

- Dialogue: Type or copy/paste dialogue from your script that occurs during this shot in the current panel.
« Action Notes: Type or copy/paste notes related to the action occurring in the panel.

« Slugging: Add notes referring to the timing of the storyboard. Slugging is the timing of the individual recorded
lines of dialogue against the board.

« Notes: Add anything relevant about the current panel or the shot it represents. For example, the crew working
on the shot, required props, ambient sounds, continuity notes or required equipment to complete the shot.
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Saving the Caption Layout as Default

T-SBADV-004-003

When you are satisfied with your current caption combination and layout, you can save it as the default caption

layout for any future Storyboard Pro projects. The next project you create will automatically have this layout by
default.

How to save the caption layout as default

» Select Caption > Save Captions Layout as Default.
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Expanding and Collapsing Captions
T-SBADV-004-001

When you have more than one caption field in a panel, you can expand or collapse them. Note that there must be
more than one caption field in a panel in order to do this.

How to expand and collapse captions

1. Display the Panel or Storyboard view.

2. Click theExpand and Collapse button of the desired caption.

3. Onthefirst click, the selected caption expands and the other ones collapse.

4. Onthe second click, the selected caption collapses and the other ones expand.

5. Onthe third click, all the captions return to their original state
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Hiding Captions
T-SBADV-004-002

When there are captions you do not use regularly, you can hide them to streamline your workspace.

How to hide a caption in the Panel view

1. Select Caption > Show/Hide Captions.

The Show/Hide Captions dialog box opens.

Cancel

2. Deselect the captions you want to hide. If you have added your own custom captions, they also appear in
the list. Any captions that you renamed appears as you renamed them.
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Adding Text to Captions

T-SBFND-006-004

There are several ways to add text to a Caption field, and editing it is very easy. The quickest and easiest way to
add text to the caption fields is to drag and drop it. For example, if you imported a script into the Script caption field of
the Storyboard view, you can select the text you need and drop it in the desired panel’s caption field.

If you did not import a script or if you want to add more text, you can simply type in the needed instructions and
information into the caption field.

@ Storyboard Pro

Script and Captions
Adding Text to Captions

_ Toon Boom
c Original

How to add text to a caption
« Inthe Panel view, click in a caption field and type the information, dialogue, or notes.
How to drag and drop text from an imported script

1. (Optional) Switch to the Vertical workspace by clicking the Vertical Workspace
Windows > Workspace > Workspace > Vertical.

button or selecting

2. Inthe Thumbnails view, select the panel to which you want to add text to a caption.

3. Inthe Storyboard view, click the Storyboard tab to switch to this view.

If the Storyboard view is not displayed in your workspace, select Windows > Storyboard.

4. Inthe Script caption field, select the text you want to move. Note that the text will be copied when dragged.

NOTE: You can drag and drop text from any caption field to another; it does not necessarily have to be

141



Chapter 5: Captions Adding Text to Captions

from the Script caption.

5. Inthe Script caption, drag the selected text and drop it in the destination caption of your panel.

You golng to sleep for the next two years.

6. Repeat this until you have copied all the necessary text into your project’s caption fields.

7. If youwere using the Vertical workspace, select Windows > Restore Default Workspace.
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Formatting Caption Text

Once you have imported, dragged and dropped, or typed some text into your storyboard captions, you can use the
Text Formatting toolbar to enhance it.

How to apply Rich Text formatting to caption text

1. Inthe Panel or Storyboard view, click the Text Formatting button of a caption.

2. Inacaption, select the text to format.

3. Use the Text Formatting toolbar buttons and options to edit the text.

» Font Type: Choose the font type of your choice from this menu.
» Font Size: Change the size of the text using menu.
» Bold: Click the Bold button to change the text to bold.

» Iltalic: Click the Italic button to change your text to italic.

» Underline: Click the Underline button to underline your text.

» Align Left: Click the Align Left button to align your text to the left.

» Centre: Click the Centre button to centre your text.

» Align Right: Click the Align Right button to align your text to the right.
» Justify: Click the Justify button to justify your text.

» Colour: Click the Colour Swatch B button to open the Select Colour dialog box and choose a new colour
for your text.
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Searching Text in Captions
T-SBADV-004-004

You can search captions to find a specific part of your text. This can become very handy when you have a large
number of captions and text in your project.

How to search for text in captions

1. Inthe Panel or Storyboard view, select any caption field.

2. Do one of the following:

» Click the Caption Menu button and select Find Text in Captions.

» Select Caption > Find Text in Captions.
» Press Ctrl+Shift+F (Windows) or 3£ +Shift+F (Mac OS X).

The Find Text in Captions dialog box opens.

3. Edit the search options:

» Inthe Find field, type in the word you are looking for.
» Select the Case sensitive option to have the search consider the case of the word.
» Select Forward or Backward for the search direction.

4. Click Find.

The caption containing the first word fitting your search options is displayed in either the Storyboard or
Panel view, and the word is highlighted in blue. The Find Text in Captions dialog box displays information
about the caption in which the word was found.
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Terrance

5. Click Find to display the next resullt.
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Updating Captions from CSV

T-SBADV-004-005

In Storyboard Pro, you can efficiently update the caption text in your project. If you generate a * . csv sheet
(comma separated values) from your project, you can update the file, then import it into Storyboard Pro. Doing so
will update all caption fields automatically. You must first generate the CSV from your current project.

How to generate a CSV from your current project

1. Make sure your caption fields are up to date, and save your project.

2. Select File > Export > CSV.
The Export to CSV dialog opens.

Make sure these options are
selected before you export:
- Include Column Names

- Include Scene Names

- Include Panel Names

- Include Captions

Once you have generated the CSV, you can update your spreadsheet if there are major changes, such as
the dialogue. Working this way allows you to import the updated CSV into Storyboard Pro to update all

caption fields.

How to use the Update Captions from CSV option

1. When you open the * . esv file in your spreadsheet application, select the field separator you used (i.e.: a
comma).
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The heading of each column contains the name of the caption field. Use this to determine where to add your
caption updates.

Find the captions you need to modify within the * . esv file. When you are finished, save and close your file.
Open the Storyboard Pro project you want to update.

Select File > Update Captions from CSV.

The Import CSV window opens.
Browse to the folder that contains your * . esv file, select it, and click Import.

In the Report section, notice which caption fields were updated.

Import

Any captions you modify in the * . esv file are also updated in the caption fields of your Storyboard Pro
project.CSV files exported from Storyboard Pro are UTF-8. CSV files can be modified in Microsoft Excel if all
the characters are part of the Latin character set. If non-Latin characters are used, the CSV files can be
edited using Open Office.CSV files exported from Storyboard Pro can be edited in either Microsoft Excel or
Open Office. Excel does not display non-English characters properly and will not recognize them when
importing to Storyboard Pro.
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Chapter 6: Layers

T-SBFND-007-001

Storyboard Pro allows you to work with layers within the individual storyboard panels. Working with layers helps to
keep your artwork organized and permits advanced editing of individual components.

@ Storyboard Pro

Layers
About Layers

_ Toon Boom
: Qriginail

Working on multiple layers increases the reusability of your drawings as you move from shot- to-shot or scene-to-
scene. Each layer or part of a layer can be dragged from the selected shot into any other shot, reducing drawing
time.

The scene’s layers are superposed to form the final image.

When you import an image or draw in a panel, you are actually adding artwork to one of its layers. By default, each
panel has two layers, a background (BG) and a foreground layer (A). As you add layers, they are automatically
assigned subsequent letters in alphabetical order, but you can rename them. They are also placed on top of the
selected layer or at the very top of other layers if there is no layer selected in the panel.
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When you open a project, the Stage view is displayed by default; its tabs are always displayed, allowing you to
navigate between layers. If the Thumbnails view is large enough, layer tabs are displayed for each panel there as
well. By default, an empty layer will have the closed eyes icon to indicate that it is empty. When you start drawing
or paste anything on an empty layer, the eyes icon will open.

— Layers list

i 1(1/1) 0100

Foreground layer (&)
Layers displayed in the
Thumbnails view

98 =15

Background layer (BG)

i)

How to draw on a layer

1. Select alayer by clicking it.

The active layer is highlighted in blue.

2. From the Tools toolbar, choose a drawing tool and begin drawing in the Stage view.
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About Layer Types
T-SBFND-007-002

There are several types of layers available depending on the type of graphics and artwork you are aiming to achieve:
bitmap or vector.

Bitmap Layers: Allow you to use bitmap graphics which are made of pixels on a grid that resemble tiny dots, which
altogether make up the drawing you are creating or artwork you are importing. Bitmap graphics impart a more natural
and soft look to your work. The colour is defined on a pixel-by-pixel basis—see Changing the Resolution of Bitmap
Layers on page 177 and Layers on page 149.

Vector Layers: Allow you to create 2D graphics that are made of many individual, scalable objects. Each object is
created by a mathematical equation rather than pixels, so they always display at the highest quality. Because they
are scalable, vector objects are resolution independent. You can increase and decrease the size of vector objects
and your lines remain crisp and sharp, which is ideal for cartoons! On vector layers, the colour is defined for the
whole stroke.

Vector objects consist of lines, curves, and shapes you can edit and transform using their control handles. Vector
graphics are not restricted to rectangular shapes like bitmap graphics. You can place vector objects over other
objects, and the object below will show through.

3D Layers: Allow you to manipulate imported 3D objects (.fbx). Afterimporting 3D object into the Library, you can
add it the Layers list to automatically create a 3D layer.

Group Layers: Allow to group multiple layers that can consist of vector, bitmap and 3D layers—see Grouping
Layers on page 162.

Bitmap layer (blue)
3D layer (red)

Vector layer (grey)

Group layer (black)

Different types of layers
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Expanding and Collapsing Layers

There are several ways to display layers in Storyboard Pro: in the Stage view or Layers panel. In both, thumbnails
are displayed on each layer, so you can easily identify its contents.

How to view layers in the Stage view

» Inthe Stage view, click the arrow button to expand the Layers list.

+x

Stage View

Expanded view
of layers

How to view layers in the Layers panel

1. Do one of the following:
» Inthe upper-right comner of a view, click the Add View 3 button and select Layers.

» Select Windows > Layers.
The Layers panel displays all the layers in the selected panel.
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Adding Layers
T-SBFND-007-003

You can add an unlimited number of layers to a panel.

How to add a layer to a panel
1. Inthe Thumbnails view, select the panel to which you want to add a new layer.
2. Do one of the following:

« Select Layer > New > Vector Layer or New Bitmap Layer.

« Click the Add Vector Layer g, or Add Bitmap Layer @ button in one of these areas: Layers
toolbar, Layers list in the Stage view, or Layers panel.
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Selecting Layers
T-SBFND-007-004

You can select any layer from the Stage view, Layers panel, or Thumbnails view. Selected layers turn blue.

How to select a layer

1. Do one of the following:

- Stage view and Layers panel: Click the layer you want to select.

« Thumbnails view: Click the layer tab of the layer you want to select. Arrows above and
below the layer tabs indicate additional layers.

« To select multiple layers, press Ctrl (Windows) or 38 (Mac OS X) and click each layer you
want to select. Also, press Shift and click one layer and then another to select a sequence of
layers.

Arrow button

Layer tabs

Thumbnails view

How to select the next and previous layers

1. Select alayer.

2. From the top menu, select one of the following:

« Layer > Select Next Layer to select the next layer up the layer stack, stopping at the top of
the stack.

. Layer > Select Previous Layer to select the next layer down the layer stack, stopping at
the bottom of the stack.
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Renaming Layers
T-SBFND-007-006

When layers are named appropriately, you can work faster and keep track of all the layers.

@ Storyboard Pro

Layers

Renaming Layers

: Toon Boom
~ Original

How to rename a layer

1. Select the panel with the layer you want to rename.

2. Do one of the following:

« Select Layer > Rename Layers.
« Right-click the layer’s tab and select Rename Layer.

« Double-click the layer tab.

3. Inthe Change Layer Name dialog box, type in a new name for the layer.
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Deleting Layers

T-SBFND-007-005

You can delete layers you no longer need. This keeps your project clean and tidy.
How to delete a layer from a panel

1. Inthe Thumbnails view, select a layer.
2. Do one of the following:
» Select Layer > Delete Layers.

» Right-click the layer and select Delete Layers.

« Inthe Stage view, Layers view or Layers toolbar, click the Delete Selected Layers f7 but-

1]
ton.
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Copying Layers

You can reuse drawings from other panels throughout your storyboard. You can also modify drawing objects and
transformations after they have been copied to a new layer, instead of redrawing similar objects.

When you copy a layer, it is placed on the Clipboard, so you can paste it in many different locations if needed.
How to copy a layer to another panel by dragging

Click the tab of the layer you want to copy. Hold down Ctrl (Windows/Linux) or &£ (Mac OS X) and select
additional layers if needed.

Drag the selected layer to the layer section of the destination panel. Drop the layers at a specific position to
place it in the desired layer order.

Layertab Destination panel

(Right) Selected layer, containing the astronaut, is placed afterthe
background.

When you copy a layer, it retains its original layer name in the new panel. If a layer with the same name
already exists, then you will be prompted to give it a new name or overwrite the existing layer.

For example, if layer A is copied to a panel, where a layer A already exists, the copied layer will be named A_
1 by default. If it is copied into the panel a second time, the new layer will be named A_2.

How to copy a layer to another panel by using copy and paste

1. Select the layer you want to copy. Hold down Ctrl (Windows/Linux) or 3£ (Mac OS X) and select additional

layers if needed.
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2. Do one of the following:

>

Select Layer > Copy Layers. Select the destination panel, and from the top menu, select Layer >
Paste Layers.

Right-click the layer tab and select Copy Selected Layers. Select the destination panel, right-click
the layer tab and select Paste Layer.
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Duplicating Layers

Duplicating layers is a quick way to perform a quick copy and paste in one operation. Unlike copying a layer, you
cannot paste multiple copies of a layer on other panels. Duplicating layers is only available within one panel.
Duplicated layers retain their names and are appended with a number.

How to duplicate a layer

1. Select alayer and do one of the following:

» Right-click the layer and select Duplicate Selected Layers.
» Inthe Stage view, Layers panel or Layers toolbar, click the Duplicate Selected Layer p| button.

» Select Layer > Duplicate Layers.
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Reordering Layers

Layers can be rearranged to bring them closer to the front or back in relation to the other layers in a panel. For
example, if you want to have a character move to the front of a shot, you can move the character layer above the
others. In Storyboard Pro, the layers at the top of the list are displayed above the other layers in the Stage view.
The layer order will be reflected in the final export.

There are several different ways to change the order of layers in a panel. You can reorder layers by selecting a
layer and dragging it to a new location, or reorder layers through the Layers menu.

How to arrange a layer by dragging

1. Select alayerto move.

2. Drag the layer above or below other layers to change their display priority in the Stage view.

How to arrange a layer using the Layers menu

1. Select a layer to modify.

2. Select one of the following:

» Layer > Arrange > Bring Layer to Front to move the selected layer in front of all other layers in the
current panel.

» Layer > Arrange > Bring Layer to Forward to move the selected layer up one spot in the current
panel.

» Layer > Arrange > Send Layer to Back to move the selected behind all other layers in the current
panel.
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» Layer > Arrange > Bring Layer Backward to move the selected layer down one spot in the current
panel.

NOTE: If you changed the Z-depth, it supecedes the layer order.
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Grouping Layers
T-SBFND-007-007

Grouping layers helps organize your work and keeps your list of layers uncluttered. You can group selected layers
or create an empty group layer and add layers toit.

@ Storyboard Pro

Layers
Grouping Layers

: Toon Boom
- Qriginal

When you group selected layers, they become the sub-layers of the group layer. The first newly-created group
layeris named Group. Subsequent group layers are appended with a number. For example, Group_1. The number
increments with each new group layer you create. The selected group layer is highlighted in blue and its sub-
layers are displayed below.

Within a group layer, you can create sub-groups to further streamline your work, and rename them to suit your
project—see Renaming Layers on page 155. Grouped layers can also be animated.

Main group =

A main group with b Sub-groups

How to group layers

1. Select two or more layers to group.

2. Do one of the following:
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o Click the Group Selected Layers | button in one of these areas: Layers toolbar, Layers list in
the Stage view, or Layers view.

« Right-click and select Group Selected Layers.

« Select Layer > Group Selected Layers.

How to ungroup a group layer

1. Select a group layer.

2. Do one of the following:

« Right-click and select Ungroup Selected Layer.

« Select Layer > Ungroup Selected Layer.

The selected group layer is ungrouped. The group layer disappears and its child layers are no longer grouped.

How to expand or collapse a group layer

1. Click the Expand/Collapse button on a group layer.

How to create an empty group layer

1. Select Layer > New > Group Layer.

A new, empty group layer is created in the list of layers and is highlighted in blue. The new layer is positioned
above the layer that was selected before you created the group layer.

How to add layers to an empty group layer

1. Select a layer.

2. Dragand drop it on a group layer.
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Showing and Hiding Layers

Working with many layers, it may be useful to hide certain layers.

Visible layer

Hidden layer

You can also show or hide group layers. When you do so, all of its sub-layers are shown or hidden, and the state
of the Show/Hide icon on each sub-layer is respected. For example, if you hide a group layer that contains one
hidden layer and two visible layers, all of the layers in the group are hidden. When you show the group layer, it will
once again show one hidden and two visible layers because the visibility state of each layer is retained.

Group layer is visible. Two of its sub-layers are Group layer and all of its sub-layers are hidden.
visible and one is hidden. The visibility state (shown or hidden) of each sub-
layer is retained.

NOTE: When merging layers, hidden layers will be excluded and left unmerged.

How to view layers in the Stage view

» Inthe Stage view, click the arrow button to expand the Layers list.

+I%

Stage View

Expanded view
of layers

How to show or hide a layer

1. Do one of the following:

» Inthe Stage or Layers view, select a layer.
» Inthe Thumbnails view, click the tab of a layer.
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2. Do one of the following:

» Click the Show/Hide Layer (, icon.

» Select Layer > Show/Hide Layers.
» Right-click and select Show/Hide Layers.
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Locking and Unlocking Layers

You can lock a selected layer to protect any objects on it from being changed. Once locked, you can unlock the
layer to make changes to any objects on it.

How to lock or unlock a layer

1. Select a layer.

2. Do one of the following:

» Click the Lock icon of a layer.

Unlocked layer

Locked layer

» Select Layer > Lock/Unlock Layers.

» Inthe Layer toolbar, click the Lock/Unlock Layers button.
»  Press Alt+L.
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Toggling Background Layers

Sometimes it is helpful not to have onion skinning applied to certain layers while working. You can set certain layers
as background elements, so they will not interfere with onion skinning—see About the Onion Skin on page 268.

How to set a layer as a background element

1. Inthe Onion Skinning toolbar, click the Onion Skinning & button.

The Toggle Background Layer button appears on each layer.

Toggle
Background
Layer

2. Toset a particular layer as a background element, do one of the following:

» Click the Toggle Background Layer button.
» Select Layer > Toggle Background Layers.
The layer will not have onion skinning applied to it.
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Changing Layer Opacity

T-SBFND-007-009
If necessary, you can modify the opacity of layers.

@ Storyboard Pro

Layers
Changing Layer Opacity

: Toon Boom
. Qriginal

NOTE: Layer transparency is not supported when exporting to the Toon Boom and/or FBX formats.

How to change the layer opacity
1. Select the layer whose opacity you want to modify.
2. Inthe Stage or Layers view, do one of the following in the Opacity field:

« Typeinanew opacity between 0 and 100.

« Click inthe Opacity field and use the up/down arrows on your keyboard to set the opacity.

The changes you make are reflected in the Stage view.
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How to modify the layer opacity in other ways

« Right-click alayer and select Change Layer Opacity.
« Select Layer > Change Layer Opacity.

In the Change Layer Opacity window that opens, enter a new opacity.
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Merging Layers
T-SBFND-007-008

There are two ways to merge layers. You can merge layers quickly and simply using the Merge Layer command.
If all the layers are vector layers, the new layer is vector. If all the selected layers are bitmap, the resulting layer is
bitmap. If there is a mix of vector and bitmap, you can decide if the resulting layer is vector or bitmap. The newly
merged layer is editable.

@ Storyboard Pro

Layers
Merging Layers

- Toon Boom
- Original

Using the Merge Layers dialog box gives you more control when merging layers. You can name the new layer,
specify whether it is a vector or bitmap layer, select source layers, and more.

After you have merged a layer, it is still possible to edit it. However, any previously defined motion in the source
layers will be lost. If you choose not to allow the layer to be edited, transform motion will be retained. For
example, if you are using a .swf file and want to edit its layer, the layer you select will be retained. The rest of the
layers will not be part of this layer.

How to quickly merge layers

1. Select the layers to merge.

2. Do one of the following:

« Right-click and select Merge Selected Layers.

« Select Layer > Merge Selected Layers.

How to merge layers using the Merge Layers dialog box

1. Select the layers to merge.

2. Do one of the following:
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« Right-click and select Merge Layers.

« Select Layer > Merge Layers.

The Merge Layers dialog box opens.

Inthe New Layer section, enter a name for the merged layer.

Select one of the following:

« Vector Layer: Makes the merged layer a vector layer. If there were bitmap layers in your selec-
tion, they will be converted to vector. Proceed to step 5.

« Bitmap Layer: Makes the merged layer a bitmap layer. If there were vector layers in your selec-
tion, they will be converted to bitmap.

If your merged layer is bitmap, set the Bitmap Canvas Size parameters. Adjust the Width, Height, or Res-
olution Factor. These three parameters are linked; changing one, changes the others. However, you can
click the Lock button to adjust each parameter separately.

(Optional) Select the Delete Source Layers option to remove the original layers that make up the merged
layer. Select the source layers to delete.

Do one of the following:

« If you deleted the source layers, you can also select the Remove Invisible Layers option to
remove hidden layers and click OK
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« If you did not delete the source layer, click OK.

NOTE: To merge a hidden layer, you must first unhide any hidden layers.

NOTE: Layers containing 3D objects cannot be merged and will not appear in the Merge Layers dialog box.

How to edit a merged layer

1. Select a merged layer and do one of the folowing:

« Right-click and select Convert to Drawing.

« Select Layer > Convert to Drawing.
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Converting Layers

If you started with one type of layer, such as vector, you can always switch it to use a bitmap layer and vice versa.

NOTE: When you convert from vector to bitmap, the vector data is lost, so if you convert back to vector, what you get
is a vector region with a bitmap inside of it

How to convert a layer

1. Select one or more layers to convert.

2. Do one of the following:
» Right-click the selected layer and select Convert Vector Layer, Convert to Bitmap Layer or Convert
to Drawing Layer.
» Select Layer > Convert Vector Layer, Convert to Bitmap Layer or Convert to Drawing Layer.

The Choose Bitmap Layer Resolution dialog box opens.

3. Select a canvas size and pixel density for the new bitmap layer and click OK.

The following message appears.

4. Click OK.

The layer is converted as indicated by the layer colour and icon.
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Bitmap layer (blue)
3D layer (red)

Vector layer (grey)

Group layer (black)

Different types of layers
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Blurring Layers

If the layer you want to blur is on a vector layer, you must first convert it to a bitmap layer—see Converting Layers on
page 173.

How to blur a bitmap layer

1. Select the layer(s) to blur.

2. Do one of the following:

» Right-click and select Blur Bitmap Layer.
» Select Layer > Blur Bitmap Layer.
The Blur Bitmap Layer dialog box opens.
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3. Forthe Blur Radius, enter a value from 0 to 100 to blur the contents of the layer.
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Changing the Resolution of Bitmap Layers

You can change the resolution of bitmap layers to better suit the needs of your project.

How to change the resolution of a bitmap layer

1. From the Layers view, select a bitmap layer whose resolution you want to change.

2. Do one of the following:

» Right-click the layer and select Change Bitmap Layer.
» Select Layer > Change Bitmap Layer Resolution.
The Change Bitmap Layer Resolution dialog box opens. The current project resolution is displayed.

Cancel

3. Adjust the Width, Height, or Resolution Factor. These three parameters are linked; changing one, changes
the others.

4. Select the Resample Bitmap option to change the resolution of the bitmap layer without changing the area it
covers.

NOTE: Resampling an image will degrade it to some extent. Resampling to a lower resolution makes the image
blocky and jagged. Resampling to a higher resolution may blur the image.
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Setting a Layer Layout as Default

Once you set up a layer layout in a panel, you can select that panel and save this layout as the default layout to
use whenever a new panel is added.

How to set a layer layout as the default

>

Select the layer to use as the template and select Layer > Set Layer Layout as Default.
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Importing Images as Layers

T-SBADV-008-003

As you build your scene, you may want to use bitmap images for backgrounds and overlays. You may also want to
import an image as a reference for a vector drawing you want to create. With Storyboard Pro, you can import a
variety of bitmap formats (TVG, OPT, PAL, SCAN, SGlI, TGA, YUV, OMF, PSD, PNG, JPG, JPE or JPEG) which
you can combine with your vector-animated content to create rich and unique graphic styles. You can import a single
image (or multiple images located in the same folder) into a new layer.

You can vectorize images upon import. To display the Vectorization Parameter dialog box, see Setting Vectorization
Options on page 180.

IMPORTANT: Storyboard Pro does not supportimport of 8-bit CMYK or 16-bit RGB or CMYK format PSD files. You
can currently import only 8-bit RGBA format PSD files.

How to import images into the current panel

1. Select the panel to which you want to import the image(s).

2. Select File > Import > Images as Layers.

The Choose Image Files dialog box opens.

3. Select the image to import and click Open.

NOTE: To select multiple images, hold down Ctrl (Windows) or 3£ (Mac OS X) as you click.

A layer is created in your panel, containing the imported image. If you selected more than one image, each
image will be imported in alphanumerical order on its own layer.

If you selected a * . psd image with multiple layers, a message will appear giving you the option to import
each layer separately.

« Click Yes toimport each layer on its own layer in the panel.

« Click No to create a layer behind the existing layers, containing the selected * . psd image.
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Setting Vectorization Options
T-SBADV-008-004

By default, when you import an image into your project using either the Import Image as Layers or Import Images
as Scenes commands, the imported images will be vectorized in colour and fit the camera frame. The image
resulting from a colour vectorization will appear exactly as the original picture.

With the Storyboard Pro, more options are available which give you better control over the vectorization of
imported images. To access these options, you must first select the Display Vectorize Options Dialog option in
the Preferences dialog box.

How to set the vectorization options

1. Do one of the following:

« Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
o Press Ctrl+U (Windows) or 38 + , (Mac OS X).

2. Inthe User Preferences dialog box, select the Import/Export tab.

3. Select the Display Vectorize Options Dialog option.

Tools | Import/Export | pitch Mode

4. Select File > Import > Images as Layers.

5. Inthe browser that opens, select an image to import.

The Import Images dialog box opens.
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The preview area displays the original image on the left and the resulting image on the right. The preview of
the resulting image automatically updates each time you modify a parameter.

6. Inthe Import Options section, set the following parameters:

- As Bitmap Layer: Preserves the exact look of the imported images and imports it in a bitmap
layer.

« Colour to Vector Layer: Preserves the exact look of the imported images and imports itina
vector layer.

« Gray Scale to Vector Layer: Imports the selected images as a gray scale in a vector layer.

181



Chapter 6: Layers Setting Vectorization Options

« Black and White to Vector Layer: Imports the images as black line art. When you enable
this option, more options become available:

« Threshold (%): Filters out noise in yourimages. Noise can be dirt or faint smudges on your
scanned images. For example, if your value is set to 70%, all colour values below 70% are
converted to white and ignored in the final image. If your value is set to 100%, only com-
pletely black lines will be kept.

« Expand: Enter a value between 1 and 100 to thicken lines or the outer edges of the bitmap.
Use this option if your line art is too fine or pale so that their visibility is increased in the soft-
ware.

« Smooth: Enter a value between 1 and 5 to set the smoothness level. Greater smoothness
equals less jaggedness and imperfections, but at a greater loss to detail.

7. Inthe Resampling Options section, set the following parameters:

» Maximum Size: Enter a specific maximum size for your imported image to be scaled down
to. The original ratio of the image will be preserved during the operation. You can see the
final values resulting from the scaling process in the Scale Size fields. Note that you can not
use these fields to scale up an image.

« Scaled Size: Displays the final size the image will be scaled after it is imported in your pro-
ject.

8. Once you have set the vectorization options:

« Saves as default: Saves the current settings. Every time you open this dialog box, the new
default parameters will automatically be set. The import images commands will still use this
new default even if you deselect the Display Vectorize Options Dialog preferences.

« Do not show this dialog again: Deselects the Display Vectorize Options dialog option in
the Preferences dialog box directly from here.
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Chapter 7: Drawing

In Storyboard Pro, many powerful tools, views, and features are available for sketching and drawing with ease. This
chapter describes the main assets needed when drawing and animating, as well as tips on how to start and use
these tools efficiently.
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About Drawing Tools
T-SBFND-008-001

The Tool Properties view displays the properties of the currently selected tool on the current layer you are
working. If you are editing a vector layer, then all of the tools are available to you. If you are drawing on a bitmap
layer, some tools are not available. When tools are not available, they are grayed out in the Tools toolbar.

Vector Drawing

@ Storyboard Pro

Drawing and Colour

About Vector Drawings Tools
——

: Toon Boom
: Original

Bitmap Drawing

@ Storyboard Pro

Drawing and Colour

About Bitmap Drawing Tools
—d:

- Toon Boom
- Original
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Drawing Tools

Depending on the type of layer you select, here are the drawing tools available:

Tool Name Icon Vector Layer Bitmap Layer

Select 13 . .
Cutter i . .
Select by Colour | 3 .

Contour Editor .

Perspective A .
Edit Gradient/Texture O] .

Brush - . .

Pencil & .

Text T . .

Eraser & . .

Paint ® . .
Paint Unpainted © . .
Unpaint © . .
Close Gap .

Line / . .
Rectangle [ . .
Ellipse (@) . .

Dropper 4 . .

NOTE: By default, the Tools toolbar is displayed vertically on the left side of the interface. For convenience, you can
display the Tools toolbar horizontally—see Tools Toolbaron page 1.
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About the Brush Tool

The Brush tool is used to draw and sketch on vector and bitmap layers.

The Brush tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if the
drawing was made with a brush.

If you want sketch a drawing using a semi-transparent colour to get a paper-like feel, then use the Brush tool as it
produces a more realistic and natural feel.

Vector Brushes and Pencils

Brush
Pencil

Vector strokes produce files that are very light, and are ideal for long projects because you do not have to
compromise on efficiency during playback. Also, you can modify the shape of the lines after you draw them using
the Contour Editor or Perspective tool. The strokes are stored as separate lines until the drawing is flattened.

+ Advantage: File sizes are light.
+ Disadvantage: Cannot get natural media-style textured drawings.

Recommended Use: For clean drawings, sketchy vector drawings, drawings you want to reuse from
different distances (close, mid, far).
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Textured Brushes

Textured brushes allow you to create lines that feel more like natural media, like working with a pencil on paper for
example. With this kind of stroke, you can still move the strokes around after you draw them. You cannot, use the
Contour Editor or Perspective tool on this kind of line.

» Advantage: You can get a natural media feel, and still have the ability to modify the position of lines after you
draw them.

» Disadvantage: File sizes can get heavy. Although some strokes can be flattened, they cannot be flattened
when you use different colours. Also, you can only have one colour/shade applied for the entire length of the
line.

+ Recommended Use: For textured drawings in which you can adjust the position of the lines later.

Brushes on Bitmap Layers

_,k'n_::

Bitmap layers allow you to create 2D graphics. The bitmap lines you create are composed of pixels on a grid that
resemble tiny dots, which altogether make up the drawing you are creating or artwork you are importing. Bitmap
graphics impart a more natural and soft look to your work. The colour is defined on a pixel-by-pixel basis.

Drawing on a bitmap layer is similar to drawing with a bitmap tool in Photoshop or Painter. You can select and move
bitmap strokes. However, layering strokes on top of each other will merge (flatten) them. Instead of drawing lines,
you are laying down the individual pixels. This gives you finer control over the brush itself, as well as the shading and
colour of the drawing. However, the strokes cannot be edited with the Contour Editor or Perspective tool. It is more
efficient for storing texture information than a textured brush on a vector layer, so if you are creating drawings with a
lot of texture, this may be a better option.

» Advantage: File sizes are not as heavy as when you use textured brushes on a vector layer, since each
stroke does not have to be remembered individually. Also, you have full artistic control over the style of the
drawing.
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+ Disadvantage: You cannot modify the lines after you draw them. Simply draw and erase, like you would
on paper. Also, it can be difficult to reuse the drawing at multiple distances.

*» Recommended Use: When creating drawings with a lot of texture, for a natural media feel. Particularly
when you want a wide variety in colour and shading, this is where you will see the real advantage.

Vector-to-bitmap conversion includes flattening individual drawings into a single image. Flattening means that it
will not be possible to select non-overlapping or overlapping elements as individual objects with the Select tool.
Instead, the selection of one drawing will initiate the selection of all elements, with a single vector frame
surrounding them.

Resampling is also triggered on bitmap layers with the use of a bitmap drawing tool. For example, if you draw the
outline of a circle, scale it down and then zoom into it, you will see tiny square pixels along the edge of the line. If
you then draw a line right next to it, you will notice two things: first that the square pixels of the new line are
gigantic by comparison and that the pixels in the line of your circle suddenly become the same size. This is
because the circle was resampled. It was not resampled when you scaled it down. It was resampled when you
used a bitmap drawing tool. It is resampled so that all the drawn objects are scaled to the same bitmap grid, in
other words that their basic unit, the pixel, is the same size. The grid is defined by the bitmap layer's resolution.

Before resampling After resampling

Before you start drawing in bitmap, it is important to understand that your artwork will now be resolution
dependent. If you zoom in your scene, you artwork will be enlarged. It is important to plan ahead and decide how
high of a resolution you need your artwork to be. If you plan to zoom in your scene, the smallest section of the
image that the camera will frame must be 100% the size of your scene resolution. For example, if your scene
resolution is set to 1920 x 1080 and you zoom- in 300% with your camera, then the resolution of the bitmap layer
also has to be set to 300%, otherwise its elements will look pixelated in the final render. It is important to change
the bitmap layer resolution before you start drawing.
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5760/ 1920 x 100 = 300%

1080 x 3 = 3240

1920 x 1080

1920 x 3 = 5760
The bitmap resolution can be set at the scene level or drawing level. The setting at the scene level affects newly
created bitmap art layers.

Note that even if your drawing resolution is set to be very large, it doesn't mean that your file will be very heavy. It
depends on the amount of artwork you draw in it.

The yellow tiles are the spaces containing artwork. The white tiles are empty spaces.
—, Making the bitmap image much lighter.

The bitmap resolution (width and height) is the resalution of the tiles in relation to the
praject resolution.

There is a function to Lets you change the resolution of bitmap art for individual drawings. You can reduce the
resolution of your bitmap file as well as increase it. Be careful because enlarging the bitmap resolution on an existing
drawing will result in a loss of quality.Storyboard Pro will perform a pixel smoothing pass (resampling) and create
additional pixels to avoid losing too much quality, but only to a certain extent. This feature is very useful when you
need to have a full resolution of a bitmap image (such as imported bitmaps as .psd or .tga for the background) for
tracing to create a matte directly in Storyboard Pro.By default, Storyboard Pro creates small thumbnail images when
imported as bitmap in order to increase performance by using a small thumbnail image instead of using the original
large size bitmap for animation work in Storyboard Pro. This will make difficult to view details or trace due to the low
resolution (blurry). This option temporary increases the resolution of bitmaps up to their original bitmap resolution to
make tracing easier.

For example, what if you used the default scene’s resolution for some bitmap art, but then discover you are zooming-
in quite close? If you do not want to see the pixels appear too much when you are zoomed in, you can set the bitmap
resolution to 200% and the bitmap art will have a higher resolution with smaller pixels, but will NOT retain 100% of its
quality. You can use this function on multiple drawings using the Apply to All Drawings option. Changing this option
will affect existing and selected bitmap art layers.

You should avoid scaling up your bitmap strokes using the Select tool. If you do, keep in mind that when you
continue drawing, your image will be resampled and your new strokes will be scaled to the scene resolution.
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Scaled-up bitmap drawing before Scaled-up bitmap drawing resampled.
reesampling The new brush stroke triggers the
resampling.
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About Brush Modes

The Brush tool creates contour lines as you draw on vector layers, adding each brush line on top of the previous
ones. On bitmap layers, the Brush tool creates 2D graphics, laying down individual pixels.

When you select the Brush tool, the Tool Properties view displays the different Brush modes that control how the
brush line is drawn: Draw Behind and Auto Flatten. Click on the Brush Mode buttons to enable or disable the
different states.

Auto Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flatten mode automatically
merges lines created with the existing ones into one single object as you draw.

Middle mouse
button drag

When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened. You can no
longer access the individual stroke after you draw it.

NOTE:
Using the Select tool, you can use select and remove a segment of flattened pencil lines. Overlapping pencil lines

drawn with the Auto-Flatten mode are essentially cut into segments by the overlap and can be treated as individual
lines.

Draw Behind Mode

Orange stroke appears
behind existing black stroke

When drawing on vector layers, the Draw Behind mode lets you paint behind existing art. By default, strokes appear
over your work until you release the tool. If you want a live preview of your stroke, activate the Realistic Preview
option by selecting View > Realistic Preview.
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Drawing with the Brush Tool

T-SBFND-008-002

Once you start Storyboard Pro, you can start to draw in the currently selected panel and layer. But first, you must
decide on the style of drawing you are trying to achieve, and therefore, the type of layer you will be using: vector
or bitmap. Whichever you decide upon, the associated tools become available for that type of layer—see Layers
on page 149.

These are the general steps to start drawing in Storyboard Pro.

How to draw

1. Inthe Timeline or Thumbnails view, click a panel.

1(1/1) 01:00

Selected panel in Selected panel in
Thumbnails view Timeline view

2. Select a vector or bitmap layer on which to draw—see Layers on page 149.

3. Inthe Tools toolbar, select the Brush -~ tool or press Alt+B—see About the Brush Tool on page 186.

4. Inthe Stage view, start drawing.

5. You can change the current colour by adjusting the sliders in the Colour view, or click a colour swatch to
use that colour. To add colour swatches, see Adding Colour Swatches on page 288.

Current colour

- Colour swatches
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Using Vector Brush Presets

A variety of brush styles are provided allowing you to create and save your own.This way you can create brushes
with precise sizes and parameters and save them so you can draw and design—see Drawing with Textured Brushes
on page 201.

There are several ways to display the available brushes: small or large thumbnails, or strokes.
You can delete the brushes you no longer use.

The Preview area lets you see a preview of the selected or customized stroke. You can click on the Show Extended
Properties arrow to display advanced customization parameters.

You can set the minimum and maximum sizes of your tool, which will produce the thick and thin effect on your line.
This works with the pressure sensitivity of a pen tablet.

Also, you can optimize the smoothness of the contour of lines. You can modify the central line smoothness of your
line using this option. This parameter smooths the initial movement of your line. Increasing the value will result in a
smoother line with fewer less control points.

How to select a brush style

« Inthe Tool Properties, select a brush style from the Presets section.

The Brush properties are displayed. What you see depends on whether you are drawing on a vector or bitmap
layer.

| Current brush
properties

Brushd4  |Brush Fixed... Brush Ficed...| Soft Brush

* ’ — Brush presets

Ink Brush | Wax Crayon | Colored Pe...| Ballpoint

10 20 10 1 15
Marker Chalk Texture 1 Texture 2 Texture 3 Texture 4

20 10 10 10
Marker 1 Marker2 | Airbrush M... Soft Shading | Hard Sha...

95 200 200

15

1 2

Draw Behind 1. Draw Behind
2. Auto Flatten
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How to change the Presets display

« Inthe Tool Properties view, click the Brush =] menu, and select Small Thumbnail, Large Thumbnail,

or Stroke View.

Pencil 3

Pencil 1 Pencil 2

5 10 20
Fixed Thick...

10

Large Thumbnail view

Small Thumbnail view

How to rename a brush preset

1. Inthe Tool Properties view, select a brush to rename.

2. From the Brush |z menu, select Rename Brush.

3. Typeinanew name for the brush and click OK.

How to delete a brush presets

1. Inthe Tool Properties view, select a brush to delete.

2. Do one of the following:

Click the Delete Brush -4 button.
menu, select Delete Brush.

>

» Fromthe Brush =
How to adjust the size, smoothness and contour of lines

1. Inthe Tool Properties view, click the arrow button.

The Properties window of the current tool opens.
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5
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Pencil 3 ,,.-—-\-_/
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Fixed Thickness 2 __d-——-..\__/
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Do the following:

» Maximum Size: Defines the maximum width of the line.
» Minimum Size: Defines the minimum width of the line as a percentage of the maximum size.
» Smoothing: Defines the number of control points added to the centre line.

» Contour Smoothing: Defines the number of control points added to the contour boundaries (around the
line).

Lower values mean that the line will appear as you draw it (with more control points along the centre line).
Higher values mean that the line will be smoothed out (removing control points from the centre line).
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Using Bitmap Brush Presets

Creating bitmap brush presets is similar to vector brush presets—see Using Vector Brush Presets on page 193.

With bitmap brushes in Storyboard Pro, you can create an infinite range of fuzzy, textured and watercolour lines.
You can combine two different brush tips, with separate sets of parameters, with the Dual Tip feature. You can
also select a paper texture that will mimic the texture of the surface that is being painted on. Uses these features
separately or in combination to create distinct, natural-looking strokes.

How to create a bitmap brush preset

1. Inthe Tools toolbar, select the Brush - tool or press Alt + B.

2. Inthe Tool Properties view, select a brush and click the Arrow button to open the Bitmap Brush Properties
view.

3. Inthe Tiptab, select a brush tip.
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Tip | Transparency W oo Tip ] Paper Tex

Default | brushil brush(3

o7 y

brush04 | brush05 | brush0& | brushO7

m

brush(s brushl0 | brushll

Click on the different tabs to access the options available for adjustment. You can use the brush stroke pre-
view at the top to view all your adjustments in real time.

« Tip tab: Make adjustments to size, brush tip angle, hardness and spacing.
« Transparency tab: Make adjustments to flow and opacity.

« Dual Tip tab: Select this option to enable the Dual Tip feature. Select a dual brush tip and
make adjustments to its size, brush tip angle, hardness and spacing.

« Paper Texture tab: Select this option to enable the Paper Texture feature. Select a paper tex-
ture and make adjustments to its scale, alignment and additivity. To learn more about using
paper textures, see:
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o Adding a Paper Texture

« Renaming a Paper Texture

« Deleting Paper Textures

« Exporting Paper Textures

« Importing Paper Textures

« Changing the Paper Texture Display

5. When you are satisfied with the look of your bitmap brush, click the Add New Brush Preset <4 button at
the top-right corner of the Bitmap Brush Properties window.

6. Inthe New Preset dialog box that appears, enter the name for your brush preset.

7. Click OK.

If you continue to make adjustments to your new brush preset and want to save these changes, click the
Update Preset N/’ button. Otherwise, your modifications will only be saved until another brush preset or
drawing tool is selected.
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Using the Dynamic Brush

When creating drawings for a panel, there may be a specific object that is repeated many times to create a bigger
picture, such as a landscape. The object can be a blade of grass, tree, or rock. Instead of creating this drawing and
then copy/pasting it over and over again, you can create a pattern and assign it as its own brush.

You can create your pattern, select it, and add it to your brush styles using the Dynamic brush.

How to use the Dynamic brush

1. Use the Brush drawing tool to create a small drawing.

NOTE: If you are drawing on a vector layer, you may want to select Auto Flatten mode to help create a single object.

/

2. Use the Select tool to choose the parts of the drawing you want to use as the pattern.

3. Inthe Tool Properties view, click the New Dynamic Brush t¢ button to use the current layer as a new brush
pattemn.

If you do not want to use the entire layer as the brush pattern, select the parts of the drawing you want to use
as the pattern. If you do this, you must reselect the Brush tool before you click the New Dynamic Brush g

button.

When you add the Dynamic Brush to your brush styles list, it is given a default name and a preview appears
in the Tool Properties view. You can use the Rename Brush button to give the Dynamic Brush a more
meaningful name.

4. Use the new Dynamic Brush to quickly repeat a pattern.

/ i\ ’(M NI
\M/\{ NI WW
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How to create a Dynamic Brush with multiple drawings

1. Create drawings on the same layer of multiple panels or multiple layers of the same panel.

2. Inthe Thumbnails, Timeline, or Stage view, Shift+click to multiselect all the layers you want to use to cre-
ate the Dynamic brush. If you are creating your brush with panels, Ctrl+Shift+click (Windows) or
3 +Shift+click (Mac OS X)) the panels to use to create the Dynamic brush.

3. Select the Brush tool and click the Add Dynamic Brush 14 button.

4. Inthe Tool Properties view, adjust the slider to see the properties of the Dynamic brush.

Your new Dynamic brush will contain all the selected drawings. When you use this brush, you will cycle
through the drawings.
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Drawing with Textured Brushes

In Storyboard Pro, you can draw with a textured line. When drawing on vector layers, textured lines are a mixed
bitmap image contained in a vector frame. This allows you to sketch as if you are drawing on paper. When drawing
on bitmap layers, there is no vector frame. There is only one big rectangular canvas that you are drawing on.

To create your own texture brush, you must prepare your tiled texture file in a third-party software, such as Adobe
Photoshop. If your image has transparency in it, it will be supported. The texture file must be either a .PSD or . TGA
file.

NOTE: Iltis recommended that you maintain your texture resolution between 100 x 100 pixels and 400 x 400 pixels.

How to draw with a textured brush

1. Inthe Tools toolbar, select the Brush  tool or press Alt+B.

2. Inthe Tool Properties view, select a brush and click the Arrow button to open the Brush Properties view.

3. Inthe Texture section, do one of the following:

» Onabitmap layer, select the Tip tab and then select a texture.
» Onavector layer, select the Paper Texture option.
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Texture properties on bitmap layer Texture properties on vector layer

Tip 01 | Tip.02

PN

Tip 04 | Tip05 | Tip06

m

Tip 08 | Tip.09 | Tip_10

?r Marker | Texture 1 | Texture 2

4. Set the following parameters:

» Hardness: The hardness value corresponds to the smoothness of the line edge. The lower the value,
the more blurry and smooth the line edge will be. The higher the value, the sharper the line edge will be.

>

» (Vector layers) Maximum Opacity: This value corresponds to the transparency of the brush when the
pressure is heavy. Values closer to 1 produce a more opaque line.

» (Vector layers) Minimum Opacity: This value corresponds to the transparency of the brush when the
pressure is very light. Values closer to 0 produce a more transparent line.
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» Select Texture: Lets you use and select a texture for your brush. The thumbnail displays the texture
currently in use. You can also browse for a texture file to import. Browsing for a texture file in a brush
already using texture will replace the file currently in use, although it will not replace the texture in the lines
already drawn.

» Texture Scale: Changes the size of the texture in the lines you draw. If you are using a plaid texture, the
squares will be larger if you increase the value and smaller if you decrease it.

5. Select the panel and layer on which you want to draw.

6. Inthe Stage view, start drawing.

How to create a texture brush

1. Inthe Tools toolbar, select the Brush s tool or press Alt+B.

2. Inthe Texture section, do one of the following:

» Onabitmap layer, select the Tip tab and then select a texture.

» On avector layer, select the Paper Texture option.

3. Inthe Texture section, select the Select Texture option.
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4. Click the Add button and browse for a bitmap texture file.

5. Inthe Tool Properties view, click the New Brush 4 button to add a new brush to your list.

The colour of your texture will not be used. Instead, the dark and light areas will be used to determine the
alpha in your texture. The current colour swatch will be used in conjunction with the pattern and alpha in

your texture.

6. Inthe Stage view, draw some lines and adjust the parameters to fit the style you are looking for.
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Drawing with Bitmap Brushes
T-SBFND-008-004

Drawing on a bitmap layer is similar to drawing with a bitmap tool in Photoshop or Painter. You can select and move
bitmap strokes. However, layering strokes on top of each other will merge (flatten) them. Instead of drawing lines,
you are laying down the individual pixels. This gives you finer control over the brush itself, as well as the shading and
colour of the drawing.

How to draw with bitmap brushes

1. Inthe Stage view, add a bitmap layer—see Adding Layers on page 153.
2. Inthe Tools toolbar, select the Brush - tool or press Alt + B.

The Tool Properties view, if it is open, displays the properties relevant to the bitmap Brush tool.
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Tool Proper

Parameters available

Ink Brush | Wax Crayon | Colored Pe...| Ballpoint Marker 1 — :\riﬂp the bitmap Brush
00
20 10 10 10 15
Marker2 | Airbrush M...| Soft Shading | Hard Sha... | Textured ... | Water Pastel
- @ . @ »
25 95 200 200 250 a0
Pastel Conte Soft Pastel | Dusty Pastel | Dappled | Rough Paper
[ATM]
== Colour view

3. Inthe Colour view at the bottom of the Tool Properties view, select a colour.

4. To switch the colour picker from HSV to RGB, in the Colour view menu, select RGB Sliders or HSV
Sliders.

206



Toon Boom Storyboard Pro 5.1 User Guide

5. Inthe Stage view, start drawing.
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About the Pencil Tool

The Pencil tool is used to draw and sketch on vector layers.

Brush
Pencil

Vector strokes produce files that are very light, and are ideal for long projects because you do not have to
compromise on efficiency during playback. Also, you can modify the shape of the lines after you draw them using
the Contour Editor or Perspective tool. The strokes are stored as separate lines until the drawing is flattened.

+ Advantage: File sizes are light.
+ Disadvantage: Cannot get natural media-style textured drawings.

» Recommended Use: For clean drawings, sketchy vector drawings, drawings you want to reuse from
different distances (close, mid, far).

The Pencil tools support pressure sensitivity, allowing you to create lines with variable thickness, producing
central vector lines of constant or variable width, making a clean line. This means that a pencil line’s control
points (used to deform its shape) are located along the length of the central spine. The Pencil tool is very useful
for tracing, clean or final drawings.

You can customize pencils, controlling the line’s colour, size, smoothness, and the minimum and maximum
width.
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About Pencil Modes

The Pencil tool creates central lines as you draw on vector layers, adding each stroke on top of the previous ones.

When you select the Pencil tool, the Tool Properties view displays the different Pencil modes that control how the
pencil line is drawn.

Pencil 1 Pencil 2 Pencil 3 Fixed Thick...

20
Fixed Thick...

Draw Behind
. Auto Fill
. Auto Close Gap

k=

Draw Behind Mode

Orange stroke appears
behind existing black stroke

When drawing on vector layers, the Draw Behind mode lets you paint behind existing art. By default, strokes appear
over your work until you release the tool. If you want a live preview of your stroke, activate the Realistic Preview
option by selecting View > Realistic Preview.

Auto Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flatten mode automatically
merges lines created with the existing ones into one single object as you draw.

Middle mouse
button drag
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When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened. You can no
longer access the individual stroke after you draw it.

NOTE:

Using the Select tool, you can use select and remove a segment of flattened pencil lines. Overlapping pencil lines
drawn with the Auto-Flatten mode are essentially cut into segments by the overlap and can be treated as
individual lines.

Auto Close Gap Mode

When using the pencil tool, you can automatically close strokes with an invisible stroke.

Auto Close Gap off Auto Close Gap on

It is recommended to keep this option enabled when drawing with the Pencil tool.
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Drawing with the Pencil Tool
T-SBFND-008-003

You can draw with the Pencil tool to create central vector lines.

How to draw with the Pencil tool

1. Inthe Thumbnails or Timeline view, select the panel on which you want to draw.

2. Inthe Camera, Stage, or Thumbnails view, select a vector layer to draw on.

3. Inthe Tools toolbar, select the Pencil & tool or press Alt+9.

4. You can change the current colour by adjusting the sliders in the Colour view, or click a swatch to use that col-
our. To add colour swatches—see Adding Colour Swatches on page 288.
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Current colour

Colour swatches

5. Inthe Stage view, start drawing.

» Hold Alt to draw a straight line.

« Hold Ctrl (Windows) or 3 (Mac OS XMac OS X) to force a line to join the end and start and
end of the stroke your shape while drawing.
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Using Pencil Presets

When you select the Pencil tool, its properties and options appear in the Tool Properties view. You can use these
properties to change the size of the pencil line, define how the line size responds to pressure on the stylus, how the
line acts in relation to other lines in the scene, and how to modify the line’s direction and size after it has been drawn.

The Preview area lets you see a preview of the selected or customized stroke. You can click on the Show Extended
Properties arrow to display advanced customization parameters.

You can set the minimum and maximum sizes of your tool, which will produce the thick and thin effect on your line.
This works with the pressure sensitivity of a pen tablet.

Also, you can optimize the smoothness of the contour of lines. You can modify the central line smoothness of your
line using this option. This parameter smooths the initial movement of your line. Increasing the value will result in a
smoother line with fewer less control points.

There are several line shapes to choose from. You can select how the start, end, and joints in the pencil line are
drawn.

Using the Pencil tool, you can draw invisible lines. This can be useful to draw tones and highlights directly on the
character.

How to change the Presets display

« Inthe Tool Properties view, click the Brush [=| menu, and select Small Thumbnail, Large Thumbnail, or
Stroke View.

Pencil 1 Pencil 2 Pencil 3 Fixed Thick... Pencil 1

'-__H\"‘-u..._‘_ -
5 ~
. . [ ]
Pencil 2 __%_
5 10 20 2 10 ]
Fixed Thick...
Pencil 3 ,,.-—-\-_/
20
10 Fixed Thickness 1 e
2
Fixed Thickness 2 __d-——-..\__/
Small Thumbnail view Large Thumbnail view 10

Stroke view
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How to select a pencil style

« Inthe Tool Properties, select a pencil style from the Presets section.

Pencil tools available on vector layer

Tool Properties (%

Pencil

[ presets

Fixed Thickness 1
2

Fixed Thickness 2
10

How to add a pencil preset

1. Click the Add Brush <4 button. The new pencil style appears in the list of presets.

How to rename a pencil preset

1. Inthe Tool Properties view, select a pencil to rename.
2. From the Brush menu, select Rename Brush.

3. Typeinanew name for the pencil.

How to delete a pencil preset

1. Inthe Tool Properties view, select a pen to delete.

2. Do one of the following:

» Click the Delete Brush -4 button.

» From the Brush menu, select Delete Brush.
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How to adjust the size, smoothness and contour of lines

1. Inthe Tool Properties view, click the arrow button.

The Properties window of the current tool opens.

2. Dothe following:

» Maximum Size: Defines the maximum width of the line.
» Minimum Size: Defines the minimum width of the line as a percentage of the maximum size.
» Smoothing: Defines the number of control points added to the centre line.

» Contour Smoothing: Defines the number of control points added to the contour boundaries (around the
line).

Lower values mean that the line will appear as you draw it (with more control points along the centre line).
Higher values mean that the line will be smoothed out (removing control points from the centre line).

How to change the line shape

1. Inthe Pencil Properties window, click a line shape in the Shape section.

» Start: Make the beginning of the line round or flat.
» End: Make the end of the line round or flat.
» Join: Make joints round, mitred, or bevelled.

How to draw invisible lines

1. Select the panel and layer on which you want to draw.

2. Inthe Tools toolbar, select the Pencil & tool or press Alt+9.

3. Select View > Extras > Show Strokes or press K to see your strokes.
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4. Inthe Tool Properties view, set the size to 0. You can also adjust the smoothness.
5. Inthe Stage view, start drawing.

6. You can modify the stroke shape with the Contour Editor tool-see About the Contour Editor Tool on
page 242.
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About the Rectangle, Ellipse and Line Tools

The Shape tools are used to draw rectangles, ellipses and lines. You can use them on both vector and bitmap layers.
You can also easily reshape a square or circle into a much more complex drawing like these butterfly wings.
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About the Rectangle, Ellipse and Line Modes

When you select the Rectangle, Ellipse, Polyline or Line tool, the Tool Properties view displays the different
modes that control how the shape is drawn. Different modes are available depending on the selected tool and
whether the layer is vector or bitmap.

Rectangle tools available on vector layer Rectangle tools available on bitmap layer

Softlead | InkBrush | Wax Crayon Colored Pe...| Ballpoint

Pencil 1 Pencil 2 Fixed Thick... |Fixed Thick... -

20 10 10 10
Marker 1 Marker2 | Airbrush M... Soft Shading | Hard Sha...

: . .

15 25 95 200 200
Textured ... | Water Pastel Pastel Conte Soft Pastel

» : / &
250 a0 120.2 95 838
Dusty Pastel | Dappled |Rough Paper Pipe Cleaner Brush on C...

83.8

1 2
1. Draw Behind 1. Draw Behind
2. Snap to Contour 2. Auto Fill
3. Snap and Align
4. Auto Fill
5.

Auto Flatten

Draw Behind Mode

Orange stroke appears
behind existing black stroke

When drawing on vector layers, the Draw Behind mode lets you paint behind existing art. By default, strokes
appear over your work until you release the tool. If you want a live preview of your stroke, activate the Realistic
Preview option by selecting View > Realistic Preview.

Snap Modes

When drawing a shape, you can snap it to any line at which you begin drawing. This helps you set objects in your
drawing with greater precision. You can also create objects that snap to an anchor point of an existing object in
your drawing.
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NOTE: When snapping and aligning objects, it is helpful to display the grid—see About Drawing Space Efficiency on
page 265.

How to snap to contours

1. Inthe Tool Properties view, click the Snap to Contour —. button.

2. Position the pointer near the object to which you want to snap your new shape and begin drawing.
How to snap and align objects

1. Inthe Tool Properties view, click the Snap and Align —; button.

2. Position the pointer near the anchor point of the object to which you want to snap your new shape and begin
drawing.

Auto Fill Mode

You can automatically fill a shape with a selected colour as you draw. By default the Shape tool creates the contour
of an empty shape that you can later fill using the Paint tool.

How to automatically fill objects

» Inthe Tool Properties view, click the Auto Fill @ button and begin drawing.

Auto Flatten Mode

When drawing on vector layers, lines do not usually become one object. The Auto-Flatten mode automatically
merges lines created with the existing ones into one single object as you draw.

Middle mouse
button drag

When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened. You can no
longer access the individual stroke after you draw it.
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NOTE:

Using the Select tool, you can use select and remove a segment of flattened pencil lines. Overlapping pencil lines
drawn with the Auto-Flatten mode are essentially cut into segments by the overlap and can be treated as
individual lines.

Auto Close Gap Mode

When using the pencil tool, you can automatically close strokes with an invisible stroke.

Auto Close Gap off Auto Close Gap on

It is recommended to keep this option enabled when drawing with the Pencil tool.
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Drawing with the Rectangle, Ellipse and Line Tools

]

To create shape presets or modify your tool style, see Using Pencil Presets on page 213.

How to draw with a shape tool

1. Inthe Timeline or Thumbnails view, select the panel and layer on which you want to draw.

2. Inthe Tools toolbar, select the Rectangle — , Ellipse & ,orLine , tool.
3. Toautomatically fill the shape, in the Tool Properties view, select the Auto Fill g option.

4. Inthe Stage view, click and drag to draw the shape.

« Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.
« Hold down Alt to draw the rectangle or ellipse from its centre.
« Hold down Shift to snap the line every 15 degrees.

« Hold down Alt to snap the start or end of the line to a nearby stroke.

5. Use the Contour Editor tool to deform the shape and create your drawing.
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About the Eraser Tool

The Eraser tool is pressure sensitive, like the Brush tool, giving you more precision when erasing parts of a
drawing. You can also use the Select tool to select drawing objects and delete them instead of erasing.

It is a good idea to create and save erasers with precise sizes and parameters to save time when drawing and
designing. There are two icons located at the top-right corner of the Eraser properties window: New Brush
Preset is for creating a new preset and Update Preset is for updating the currently selected preset. Use them
after you have set all the parameters for the new eraser preset.

Mew Brush Preset  Update Preset
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Erasing

With the Eraser tool, you can erase parts of drawings.

How to erase with the Eraser tool

1. Inthe Thumbnails or Timeline view, select the panel where you want to erase.
2. Inthe Thumbnails or Stage view, select a layer.

3. Inthe Tools toolbar, select the Eraser ¢ tool or press Alt+E.

>

In the Stage view, start erasing.
NOTE: When working in vector, you can also use the Select tool to select drawing objects and delete them instead of

erasing.

NOTE: You can also use Cutter tool to select part of a drawing and then press Delete to erase.
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Using Eraser Presets

When you select the Eraser tool, its properties and style options appear in the Tool Properties view. The
properties available are different depending on whether you are drawing on a vector or bitmap layer.

The Preview area lets you see a preview of the selected or customized stroke. You can click on the Show
Extended Properties arrow to display advanced customization parameters.

The Eraser tool uses the same Brush presets as the Brush tool. Storyboard Pro provides a variety of eraser
presets, which you can create and save.lt is a good idea to create and save eraser brushes with precise sizes

and parameters for drawing and design—see .

NOTE: If you are working on a vector layer, you can only have a solid eraser. When working on a bitmap layer,

you also have texture erasers available.

How to select an eraser style

1. Inthe Eraser Tool Properties, select an eraser preset from the Presets section.

Tool Properties = | 4

Brush
preview
.| Soft Eraser |Very Soft Er..
L] L]
Brush
presets

Eraser tool properties available on vector layer
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Show
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Hard Eraser | Soft Eraser 'Hard Eraser..

100 150 40
Scraper  Scraper rou..

Eraser tool properties available on bitmap layer
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About the Select Tool

The Select tool lets you select strokes in the Stage view, and apply basic transformations such as repositioning,
rotating, scaling or skewing, using the different handles of the bounding box.

When you use the Select tool and select an object such as a stroke or text, it properties are displays in the Tool

Properties view in the Panel view. For example, if you have pencil selected, the pencil section displays, orif you
have text selected, the text section displays.

NOTE: The Select tool, when used to scale, offset or rotate objects, retains your selection when switching layers or
panels.

Pivotpoint

Skew
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About Select Modes

When you use the Select tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee Modes

When selecting a section of a drawing, you can use the Lasso to make a freehand selection or the Marquee to
make a rectangular selection.

In the tool properties, select Lasso (, orMarquee ', mode to change the selection style of the tool. Hold down
the Alt key to temporarily switch from the selected mode to the other.

Snap Modes

When drawing a shape, you can snap it to any line at which you begin drawing. This helps you set objects in your
drawing with greater precision. You can also create objects that snap to an anchor point of an existing object in
your drawing.

NOTE: When snapping and aligning objects, it is helpful to display the grid—see About Drawing Space Efficiency
on page 265.

How to snap to contours

1. Inthe Tool Properties view, click the Snap to Contour —. button.

2. Position the pointer near the object to which you want to snap your new shape and begin drawing.
How to snap and align objects

1. Inthe Tool Properties view, click the Snap and Align —; button.

2. Position the pointer near the anchor point of the object to which you want to snap your new shape and
begin drawing.

Select by Colour Mode

You can rapidly select all drawing parts painted or drawn with the colour you click on in the Stage view.
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Select All Drawings in Scene

You can select all the drawings in a scene on all layers.

227



Chapter 7: Drawing About Drawing Tools

Selecting

Before you can perform transformations such as a rotation, scale, skew or flip, you must select the objects using
the Select tool. Once selected, you can transform all the objects within the bounding box simultaneously. There
are various controls around the bounding box for you to manipulate a selection.

Some transformations are relative to the position of the pivot point, which you can temporarily reposition.

How to select objects

1. Inthe Timeline or Thumbnails view, select the panel and layer on which you want to select objects.

2. Inthe Tools toolbar, click the Select tool or press Alt+S.

3. Inthe Stage view, select an object. To select all objects, press Ctrl+A (Windows) or 3£ +A (Mac OS X).
How to move objects

1. Inthe Stage view, select some objects. Position the cursor over a stroke and when you see the move
cursor appear, drag to move the selection to a new location.

NOTE: To make it easier to move selected objects without having to position the cursor over a
stroke, you can set the Select Tool Bounding Box is Movable option in the Preferences dialog box
(Tools tab). This lets you place the cursor anywhere inside the bounding box and move its contents.
This option applies to these tools: Select, Select by Colour, and Cutter.

2. Tonudge selected objects, use Arrow keys on your keyboard. To move objects in larger increments, press
Shift + Arrow keys.
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How to rotate, scale and skew objects

1. Torotate selected objects, position the cursor at any corner of the bounding box. When you see the rotate
cursor, drag to rotate. Press Shift as you drag to rotate in 15 degree increments.

©

2. Toscale selected objects, position the cursor at any corner of the bounding box. When you see the scale
cursor appear, drag to resize. Press Shift as you drag to maintain the aspect ratio.
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How to temporarily reposition the pivot point

1. Inthe Stage view, select one or more objects.

The pivot point appears in the middle of the bounding box.
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2. Drag the pivot point to a new position.

This becomes the new position of the pivot point for the current transformation and will remain there until you
make a new selection.
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Rotating a Selection 90 Degrees

Once you have selected drawing strokes from a drawing, you can rotate them by 90 degrees clockwise or
counterclockwise.

How to rotate an area
1. Inthe Tools toolbar, select the Select w tool.
2. Inthe Stage view, select the strokes to rotate.

3. Inthe Tool Properties view, select the Rotate 90° CW or Rotate 90° CCW

button. You can keep
rotating areas at 90 degree increments by clicking the button again.
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Flipping a Selection

Once you have selected strokes from a drawing, you can flip them horizontally or vertically. If no strokes are
selected, the layer will be flipped. If you select more than one layer, they will all be flipped individually.

How to flip a selection

1. Inthe Tools toolbar, select the Select w tool.
2. Inthe Stage view, select the strokes to flip.
3. Do one of the following:
« Inthe tool properties, click the Flip Horizontal ¢ or Flip Vertical = button.

o Press Alt + H to flip horizontally. Press Alt + V to flip vertically.

« Select Tools > Transform > Flip Horizontal or Flip Vertical.
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Flattening a Selection

The Flatten operation is used to merge drawing objects and brush strokes into a single layer. If you draw new
lines to fix a drawing or a line with many brush strokes, it can be useful to flatten them all into a single shape. By
default, lines are drawn one on top of each other, if you intend repainting the lines or modifying their shape, it will
be easier if they are flattened—see About Project Optimization on page 38.

If you have selected strokes while using the flatten command, only these strokes will be flattened. If no strokes
are selected, the entire current layer will be flattened. If you have selected multiple layers, they will all be flattened
individually.

How to flatten a selection
1. Inthe Tools toolbar, select the Select w tool.

2. Inthe Stage view, select the strokes to flatten.

3. Do one of the following:

» Inthetool properties, click the Flatten = button.
» Press Alt+Shift+F.
» Select Tools > Flatten.
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Grouping Objects

By grouping objects together, you can reposition, scale and apply other transformations to multiple objects of a
drawing. You can also ungroup a group of objects to fine-tune individual objects.

NOTE: You can only group objects on one vector layer, you cannot group objects from several layers. Also, you
cannot group objects on bitmap layers.

How to group or ungroup objects

» Select object(s) in the Stage view, then select Edit > Group Drawing Selection or Ungroup Drawings.

235



Chapter 7: Drawing About Drawing Tools

Converting Strokes

When drawing on vector layers, you may want to change brush strokes to pencil lines to convert contour strokes
into centre line pencil strokes.

NOTE: Any line thickness information is lost upon conversion from brush to pencil

At times, you may want to change pencil lines to brush strokes. This converts a centre line stroke to a contour
line stroke. Or you can convert strokes to pencil lines.

How to convert pencil lines to brush

1. Select the strokes you want to convert.

2. Right-click and Convert > Pencil Lines to Brush Strokes.
How to convert brush to pencil lines

1. Select the strokes you want to convert.

2. Right-click and select Convert > Brush Strokes to Pencil Lines.
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Using the Select by Colour Tool

T-SBADV-005-017

The Select by Colour tool lets you quickly select all artwork painted or drawn with the selected colour. This makes it
easy to select artwork from a single layer that contains different colours and shades.

How to select by colour

1. Inthe Tools toolbar, click the Select by Colour w button.

In the Stage view, select a layer.
3. Click onacolour.

All artwork painted or drawn with the selected colour is selected.
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About the Cutter Tool

You can cut a drawing area on a bitmap or vector layer to move, copy, cut or delete it.

NOTE: When you use the Cutter tool on a bitmap layer, the drawing will be flattened automatically on the next
drawing operation after the cut.

To learn more about the Contour Editor properties, see Cutter Tool Properties on page 1.
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About Cutter Modes

When you use the Cutter tool, its properties and options appear in the Tool Properties view. The four Cutter modes
include: Lasso or Marquee, tip style, mouse gesture, and antialiasing.

Lasso and Marquee Modes

When selecting a section of a drawing, you can use the Lasso to make a freehand selection or the Marquee to make
a rectangular selection.

In the tool properties, select Lasso ) orMarquee [,) mode to change the selection style of the tool. Hold down the
Alt key to temporarily switch from the selected mode to the other.

Tip Style Mode

You can customize the tip of the line you cut pencil lines on a vector layer.
How to set the tip style

« Inthe Cutter tool properties, click the Tip Style -button and select a style: Round, Flat or Bevel.

Use Mouse Gesture Mode

When using the Lasso selection type, the Use Mouse Gesture =« option lets you automatically delete any
extra sections of line in your artwork by simply dragging your mouse over it.

NOTE: For this operation to work, lines CANNOT be flattened.

Antialiasing Mode

When working with the Cutter tool on bitmap layers, you can turn antialiasing on or off. With antialiasing on, the
jagged appearance of diagonal lines in bitmap images are smoothed.

NOTE: This option is not available on vector layers.
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How to turn on antialiasing

1. Select a bitmap layer.

2. In Cutter tool properties, click the Antialiasing ge button and select Antialiasing On.
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Cutting

The Cutter tool lets you cut a drawing to move, copy, or delete it.

How to cut drawings

1. Inthe Tools toolbar, select the Cutter ~ tool or press Alt + T.

2. Inthe Stage view, select an area to cut away.

o Todelete the selected area, press Delete.

« Tomove the selection, drag it to a new area.

« Use the bounding box controls to scale, skew, or rotate the cut piece.

Resize

T-SBFND-008-007

To flip and rotate your selection, see Flipping a Selection on page 233 and Rotating a Selection 90 Degrees on page

232.
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About the Contour Editor Tool

The Contour Editor lets you reshape drawings. By displaying vector points around a shape and the central vector
points in a pencil line, you can pull or push on these points to adjust the brush’s line thickness. Points can be
selected and deleted. Each point has two Bezier handles for correcting the curves between two points. You can
modify shapes by pulling and pushing directly on the segment between the points. You can use it to perfect a

central shape pencil line, a contour shape brush line, or even create an elaborate shape from a basic ellipse or
square.

To learn more about the Contour Editor properties, see Contour Editor Tool Properties on page 1.
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About Contour Editor Modes

When you select the Contour Editor tool, its properties and options appear in the Tool Properties view.

Tool Properties == | %

Lasso and Marquee Modes

When selecting a section of a drawing, you can use the Lasso to make a freehand selection or the Marquee to make
a rectangular selection.

In the tool properties, select Lasso (- or Marquee 1, mode to change the selection style of the tool. Hold down the
Alt key to temporarily switch from the selected mode to the other.

Snap to Contour Mode

The Snap to Contour option will snap the selected anchor point to any line you position it on.

The Snap to Contour option will snap the selected anchor point to any line you position it on.

How to shap two shapes together

1. Inthe Tools toolbar, select the Contour Editor tool.
2. Inthe Contour Editor Tool Properties view, click the Snap to Contour —. button.

3. Inthe Stage view, click an anchor point you want to snap to the other shape, drag it on top of the contour line
area and release it.
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Reshaping with the Contour Editor Tool
T-SBFND-008-006

The Contour Editor lets you reshape drawings. By displaying vector points around a shape and the central vector
points in a pencil line, you can pull or push on these points to adjust the brush’s line thickness. Points can be
selected and deleted. Each point has two Bezier handles for correcting the curves between two points. You can
modify shapes by pulling and pushing directly on the segment between the points. You can use it to perfect a
central shape pencil line, a contour shape brush line, or even create an elaborate shape from a basic ellipse or
square.

@ Storyboard Pro

Drawing and Colour
Reshaping with the Contour Editor Tool
i

_ Toon Boom
- Criginal

How to reshape with the Contour Editor tool

1. Inthe Timeline or Thumbnails view, select the cell and layer into which you want to draw.
2. Inthe Tools toolbar, select ashapetool: , & .

3. Inthe Tool Properties view, click the Ellipse & button, click the Auto Fill g button and set the pencil
sizeto 0.

4. Inthe Stage view, draw a circle.
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5. Inthe Tools toolbar, select the Contour Editor tool.

6. Inthe Stage view, click the line to reshape it.

7. Select one or several points by clicking on them or circling around.

.

8. Press Delete to delete a selected point.

Press Ctrl (Windows/Linux) or 3£ (Mac OS X)and click on the contour to add a new point to adjust the
contour.

9. To modify the shape, you can:

« Pull on the Bezier handle. Both point’s handles will move as one.

« Hold down Alt and pull on one of the Bezier handles. The point’s handle will move independently from the
other one.
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« Move the selected points to a new area.

« Pull directly on the line between two points. No selection is necessary. Holding down Shift will limit the
contour modification to the curve between the two first points.

« If an anchor point has no visible Bezier handles, hold down the Alt key to display them.
« To add control points, press Ctrl (Windows/Linux) or 38 (Mac OS X) and click the line.

« Toremove control points, select the control point and press Delete.
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Smoothing a Selection

—

The Smooth Selection operation is used to smooth out selected drawing strokes and remove extra points.
Smoothing is applied to the entire stroke.

Depending on how you draw your pencil line (changing the Smoothness or Contour Optimization), there may be few
or many control points on the centre line. Just as you can modify a brush line, you can modify the direction of a
pencil line using the Contour Editor to move its control points.

To learn how to create a pencil line with more or fewer control points, see Reshaping with the Contour Editor Tool on
page 244.

How to modify a pencil line using control points

1. Usingthe & Pencil tool, create a line that has control points along its centre line (adjust the Smoothness or
Contour Optimization to set the right number of control points).

2. From the Tools toolbar, select the Contour Editor tool and select the pencil line.

The selected pencil line will display its centre line along and control points.

To add control points, press Ctrl and click to create control points.

3. Drag any of the control points along the centre line to change the shape.
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About the Perspective Tool

When drawing on vector layers, the Perspective tool is used to deform a drawing selection and alter its
perspective.

NOTE: This tool cannot be used on textured brush strokes or bitmap layers.
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About the Perspective Modes

When drawing on vector layers, selecting the Perspective tool displays its properties and options in the Tool
Properties view.

Lasso and Marquee Modes

When selecting a section of a drawing, you can use the Lasso to make a freehand selection or the Marquee to make
a rectangular selection.

In the tool properties, select Lasso or Marquee [, mode to change the selection style of the tool. Hold down the
Alt key to temporarily switch from the selected mode to the other.

Snap Modes

When drawing a shape, you can shap it to any line at which you begin drawing. This helps you set objects in your
drawing with greater precision. You can also create objects that snap to an anchor point of an existing object in your
drawing.

NOTE: When snapping and aligning objects, itis helpful to display the grid—see About Drawing Space Efficiency on
page 265.

How to snap to contours

1. Inthe Tool Properties view, click the Snap to Contour = button.

2. Position the pointer near the object to which you want to snap your new shape and begin drawing.

How to snap and align objects

1. Inthe Tool Properties view, click the Snap and Align = button.

2. Position the pointer near the anchor point of the object to which you want to snap your new shape and begin
drawing.

How to snap to the grid

1. Inthe Tool Properties view, click the Snap to Grid = button.

2. Position the pointer near the anchor point of the object to which you want to snap to the grid and move the
point.
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Using the Perspective Tool

To flip and rotate your selection, see Flipping a Selection on page 233 and Rotating a Selection 90 Degrees on
page 232.

How to deform a drawing

1. Inthe Tools toolbar, select the Perspective » tool.

[
g

‘ ® Contour Editor

N

r-
&

2. Inthe Stage view, select the drawing you want to deform.

3. Click and drag the different anchor points to deform the shape.
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About the Text Tool
T-SBADV-005-012

With the Text tool, you can type text in your project, using various fonts and text attributes. Text objects are part of a
drawing, so you can manipulate them the same way. You can use the Text tools on both vector and bitmap layers.

My Project

Il
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Adding Text
T-SBADV-005-013

Whenever needed, you can add text to panels.

How to add text to drawings

1. Inthe Tools toolbar, select the Text T tool, press Ctrl+Shift+T (Windows) or 3£ +Shift+T (Mac OS X) or
select Tools > Text.

2. Inthe Timeline or Thumbnails view, select the panel and layer that contains the drawing on which you
want to add text.

3. Inthe Stage view, click the location at which you want to add text.

4. You can use the Text properties in the Tool Properties view to select the font, font size and format of the
text you will type—see Adding Text on page 252.

5. Typeinthe desired text.

My Project

Il

6. Click outside the text box to exit the typing mode.

» If you want to create another text object, click outside the currently active text box. You can always
return to edit the text by selecting the Text T tool and clicking in the text.
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Formatting Text
T-SBADV-005-014

Use the Text Tool Properties view to select the font type and other formatting options you want to apply to the text.

. Fonttype

. Font style

. Alignment

. Fontsize
Keming

. Indentation

. Line Spacing

1
2
3
4
5.
6
7

NOTE:
If the text is already written, use the Text tool to select the text you want to format.

W rojec

1

Font Type

Use this drop-down menu to select the desired font, from the list of fonts available in your system.

Vivaldi font Copperplate Gothic Light

\ ~
Qf»{:'p E’!:d/'ﬁ(:{\ MY PROJECT

Font Style

Use the Bold and Italic buttons to set the style for your text.

My Project My Project
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Alignment

Use these buttons to align the paragraph.

Left

LOREM IPSUM DOLOR SIT AMET,

CONSECTETUR ADIPISCING
ELIT. AENEAN VESTIBULUM,
METUS AC FERMENTUM
PORTTITOR, ODIO TURPIS
PORTTITOR NIBH, ID
CONSEQUAT MAGNA LIGULA ET
ELIT. CURABITUR SOLLICITUDIN
ELIT AC LOREM MOLLIS ACC
UMSAN.

Centred

LOREM IPSUM DOLOR SIT AMET,
CONSECTETUR ADIPISCING
ELIT. AENEAN VESTIBULUM,

METUS AC FERMENTUM
PORTTITOR, ODIO TURPIS
PORTTITOR NIBH, ID

CONSEQUAT MAGNA LIGULA ET

ELIT. CURABITUR SOLLICITUDIN
ELIT AC LOREM MOLLIS ACC

UMSAN.

Right

LOREM IPSUM DOLOR SIT AMET,
CONSECTETUR ADIPISCING
ELIT. AENEAN VESTIBULUM,
METUS AC FERMENTUM
PORTTITOR, ODIO TURPIS
PORTTITOR NIBH, ID

CONSEQUAT MAGNA LIGULA ET

ELIT. CURABITUR SOLLICITUDIN

ELIT AC LOREM MOLLIS ACC
UMSAN.

Justified

LOREM IPSUM DOLOR SIT AMET,
CONSECTETUR ADIPISCING
ELIT. AENEAN VESTIBULUM,
METUS AC FERMENTUM
PORTTITOR, ODIO TURPIS
PORTTITOR NIBH, ID
CONSEQUAT MAGNA LIGULA ET
ELIT. CURABITUR SOLLICITUDIN
ELIT AC LOREM MOLLIS ACC
UMSAN.

Font Size

Type the desired size for the text in this field. You can also use the up and down arrow buttons to set the desired
value.

Kerning

Use the kerning field to modify the spacing between letters and characters. You can select the Auto Kern option
to set the kerning automatically, based on the font’s predefined standard. A negative value decreases spacing
between each character creating a letter overlap and a positive value increases it.
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Lorem ipsum dolor
sit amet, consectetur
adipiscing elit.
Aenean vestibulum,
metus ac fermentum
porttitor, odio turpis
porttitor nibh, id
consequat magna
ligula et elit.
Curabitur
sollicitudin elit ac
lorem mollis acc
umsan.

Indent

Lorem ipsum dolor sit amet,
consectetur adipiscing elit.
Aenean vestibulum, metus ac
fermentum porttitor, odio turpis
porttitor nibh, id consequat
magna ligula et elit. Curabitur
sollicitudin elit ac lorem mollis
acc umsan.

Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A positive value
sets the first line of your paragraph farther to the right and a negative value sets it farther to the left.

Lorem ipsum dolor sit amet,
vestibulum, metus ac fermentum
consequat magna ligula et elit.

Curabitur sollicitudin elit ac lorem
mollis acc umsan.

consectetur adipiscing elit. Aenean

porttitor, odio turpis porttitor nibh, id

orem ipsum dolor sit amet,
consectetur adipiscing elit. Aenean
vestibulum, metus ac fermentum
porttitor, odio turpis porttitor nibh, id
consequat magna ligula et elit.
Curabitur sollicitudin elit ac lorem
mollis acc umsan.

Line Spacing

Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

orem ipsum dolor sit amet,
consectetur adipiscing elit. Aenean
vestibulum, metus ac fermentum
porttitor, odio turpis porttitor nibh, id
consequat magna ligula et elit.
Curabitur sollicitudin elit ac lorem
mollis acc umsan.

orem ipsum dolor sit amet,
consectetur adipiscing elit. Aenean
vestibulum, metus ac fermentum
porttitor, odio turpis porttitor nibh, id
consequat magna ligula et elit.
Curabitur sollicitudin elit ac lorem
mollis acc umsan.
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Resizing the Text Box
T-SBADV-005-015

You can resize the text box by selecting your text box with the Text T tool and moving the anchor point right or
left.

orem ipsum dolor sit 7 >

amet, consectetur
adipiscing elit. Aenean
vestibulum, metus ac
fermentum porttitor, odio
turpis porttitor nibh, id
consequat magna ligula et
elit. Curabitur sollicitudin
elit ac lorem mollis acc
umsan.

Using the Select tool will distort and scale your text itself rather than changing the width and height of your text
box.
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Breaking Text
T-SBADV-005-016

Text contained in a text field is treated as a single drawing object. You can easily separate the text so that each
character becomes an individual drawing object that you can select and modify independently.

How to break a text object

1. Inthe Tools toolbar, click the Select tool or press Alt+S.

2. Inthe Stage View, select the text object you want to break.

L orem Iipsum

3. Right-click the text and select Convert > Break ApartText Layers.
Lorem; ipsum

Each character is now surrounded by its own bounding box that you can modify, they remain text objects that
you can edit.

4. If youwant to convert your independent letter to a complete vector object that you can deform, using the
Select tool, select the letters to convert.

5. Right-click the text and select Convert > Break ApartText Layers to break the selection into a regular draw-
ing object, with no more text attributes.

“orem ipsum

NOTE: After your text has been broken apart twice, into a regular drawing object, you can use all the drawing tools
such as the Eraser tool, on the drawing. Be aware that if you want to use the Perspective tool on the text, you should
create the text on a vector layer before breaking it apart twice; then you can use the Perspective tool on it.
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About Tool Presets

T-SBADV-005-006

Tool presets let you save a variety of settings and are very efficient for accessing the tools you use most often.
That way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable
Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush,
Pencil, Eraser, Rectangle, Ellipse, and Line.

The difference between a tool preset and a brush preset is that when you save a tool preset, you have the option
of saving the colour and assigning a shortcut, which you cannot do with brush presets.

You can assign a keyboard shortcut to tool presets to quickly access them—see Shortcut Preferences in the
Preferences Guide.
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Creating Tool Presets
T-SBADV-005-007

To create a tool preset, you will need to select a tool, adjust the properties, and then create a tool preset for it. Once
you have created a tool preset, you can make adjustments to fine-tune it, as well as create a keyboard shortcut for it.
All tool presets are displayed in the Tool Presets toolbar.

How to create a tool preset

1. Inthe Tools toolbar, select a tool, for example the Brush tool.
2. Inthe Panel view, use the Tool Properties view and/or the Brush Properties window to customize the tool.

To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the tool.

NOTE: When using a tool preset in a scene that is not using the assigned colour swatch, a colour
recovery dialog box appears prompting you to add the colour to the scene.

4. Inthe Tool Presets toolbar, click the New Tool Preset +¢ button.

5. Inthe New Preset dialog box, in the Name field, type a name for your new preset.

Cancel

6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the File = but-
ton.
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. Bru
! default_brush0l
default_brush02
Default default_brush03
fool .
p|ESEt default_brush04
ons default_brush05

default_brush06

7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset. By default, the
shortcuts are unassigned. To assign a keyboard shortcut, select Edit > Preferences > Shortcuts > Tool
Presets (Windows) or Storyboard Pro > Preferences > Shortcuts > Tool Presets (Mac OS X).

8. When you select an option, it will take effect when you use the tool preset. If an option is deselected, then
using a tool preset will not override your current settings.

« Colour: Saves the current colour into the tool preset.

« Layer: Lets you select a drawing layer to be used on the current panel when the tool preset
is clicked. When selecting the preset, if the assigned layer exists, it will be selected, if not, it
will be created. When changing panels, depending on your global navigation setting, it will
look for the layer. If it does not exist, the first layer will be selected. Select the Layer option,
assign a layer to the tool preset, and decide whether the layer is vector or bitmap.

« Draw Behind: When this option is selected, saves the specified Draw Behind option to the
tool preset. When deselected, the current Draw Behind status is unchanged when the tool
preset is clicked—see About Brush Modes on page 191.

« Auto Flatten: When this option is selected, saves the specified Auto-Flatten state to the
tool preset. When deselected, the current Auto-Flatten state is unchanged when the tool pre-
set is clicked—see About Brush Modes on page 191.

9. Click OK.
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Updating Tool Presets
T-SBADV-005-008

As you work with a tool preset, you may need to fine-tune and update its parameters until it is exactly what you
want.

How to update a tool preset

1. Inthe Tool Properties view, update the tool settings.

2. Inthe Tool Presets toolbar, click the Manage Tool Presets ¢ button.

3. Inthe Manage Tool Presets dialog box, select the tool preset from the list.

4. Update the additional parameters such as the icon, Colour, Layer and Draw Behind options.

Click Update.
6. Click OK.
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Deleting Tool Presets
T-SBADV-005-009

If you no longer need a tool preset, you can delete it.

How to delete a tool preset

1. Inthe Tool Presets toolbar, click the Manage Tool Presets & button.

Tool Preview

Import... Export... Update

Cancel

2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.
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Importing and Exporting Tool Presets
T-SBADV-005-010

If there are tool presets created by other Storyboard Pro artists you want to use, you can import them to use in your
projects. You can also export your tool presets for other artists to use.

How to import a tool preset

1. Inthe Tool Presets toolbar, click the Manage Tool Presets button.

The Manage Tool Presets dialog box opens.

2. Click Import.
3. Inthe Import Brush Presets window that opens, locate and select the preset(s) to import and click Open.

How to export a tool preset

1. Inthe Tool Presets toolbar, click the Manage Tool Presets button.
The Manage Tool Presets dialog box opens.

2. Click Export.
In the Export Brush Presets window that opens, select the preset(s) to export and click Export.

Give the exported preset(s) a name and click Save.
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Locking the Tool Preset Layer Selection
T-SBADV-005-011

It is possible to assign a tool preset to a specific layer. When the preset is selected, it will verify if the layer exists.
If so, the layer will be selected and if not, it will be created.

When switching panels, by default Storyboard Prolooks for a layer with the same name as the one currently
selected. If it does not exist, the first layer will be selected. To prevent Storyboard Pro from selecting a random
layer, you can activate the Enable Brush Preset Layer Selection Lock option. This way, Storyboard Pro prevents
you from drawing in the next panel unless you create the missing layer. Click on the preset again to create the
missing layer.

How to enable the Enable Brush Preset Layer Selection Lock option

1. Open the Preferences dialog box:

« Windows: Select Edit > Preferences or press Ctri+U.

« Mac OS X: Select Storyboard Pro > Preferences or press3$ + ,.

2. Select the General tab.

3. Inthe Layers section, select the Enable Brush Preset Layer Selection Lock option.
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About Drawing Space Efficiency
T-SBADV-005-001

Drawing can be time consuming and complicated if you don't take advantage of some of the time-saving features in
Storyboard Pro. It starts with turning on the grid to help you determine the size and placement of objects as you
draw. For your drawing tool, you can choose from a lasso or marquee type cursor.

With onion skinning, you can see the previous and next drawings, which is handy for referring to for the size, angle
and position of the drawing in the current panel.

The light table lets you preview the previous and subsequent active layers in light colours. This is really useful for
seeing other layers when designing or cleaning up your storyboard.

You can also quickly swap between two drawing tools by using keyboard shortcuts.

Everything you draw in Storyboard Pro is vector-based. When you draw in the Drawing or Camera view, notice that
your lines may appear jagged. This is caused by the fast real-time display called OpenGL. If you prefer to see
smooth lines as you draw, you can enable the antialiasing preference.
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Displaying the Grid

T-SBADV-005-002

Using a grid is useful when positioning or drawing objects and characters in a scene. You can use the Show Grid
option to display several different kinds of grids in the Stage or Camera views.

How to display the grid

1. Do one of the following:

« Click the Grid button at the bottom of the Stage or Camera view.

« Select View > Grid > Show Grid.
o Press Ctrl+G (Windows) or & +G (Mac OS X).

2. Tochoose a grid option, select View > Grid and one of the following options:

Parameter Description

Grid Outline Only Displays only the contour of the grid.

Underlay Displays the grid behind the drawing elements.

Overlay Displays the grid over the drawing elements.

Square Displays a standard square grid.

12 Field Grid Displays a 12 field size grid.

16 Field Grid Displays a 16 field size grid.

World Grid Displays a reference grid that remains the same size when you scale objects.
This is useful when creating elements in your drawing and you need a ref-
erence point.
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Using the Light Table
T-SBFND-008-005

The light table is used to preview the previous and subsequent active layers. It is useful to see the other layers when
designing or cleaning up your storyboard.

@ Storyboard Pro

Drawing and Colour
Using the Light Table
—

: Toon Boom
” Qriginal

When the light table is activated, all layers apart from the currently selected one are shown in washed-out colours in
the Stage and Camera views and when using the layer tools.

How to turn on the light table

1. Select View > Light Table.

The drawings for the other layers are displayed as washed-out colours in the Stage view.
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About the Onion Skin

T-SBFND-008-013

With onion skinning, you can display the previous and next drawings and refer to them to determine the size,
angle or position of the drawing in the current panel.

You can display the drawings from previous panels in the current panel, so you can see where to place the
drawings for the next panel.

You can also display drawings from the next panels in the current panel, so you can see where to place the
drawings for the previous panel.

@ Storyboard Pro

Drawing and Colour
About the Onion Skin
—

: Toon Boom
- Qriginal

By default, previous drawings appear in a shade of red and next drawings are displayed in green. You can change
the display colours of onion skinned drawings in the Preferences dialog box (Colours tab).
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Setting the Onion Skin
T-SBFND-008-014

After enabling the Onion Skin, you can set the number of previous and next panels to view. You can set the onion
skin to display up to three panels.

Next drawing Current drawing Previous drawing

How to enable the Onion Skin

1. Do one of the following:

« Inthe Onion Skin toolbar, click the Onion Skin = button.

=

o Press Alt+0 (Windows) or £ +Alt+0O (Mac OS X).

« Select View > Onion Skin > Show Onion Skin.

How to set the number of previous panels

1. Inthe Onion Skin toolbar, click the Show Previous button and select one of the following:

. No Previous Panels

e < Previous Panel

e <« Previous Two Panels
. Previous Three Panels

=

The previous panel(s) appear in the Stage view.

NOTE: You can also select View > Onion Skin to access these options.

How to set the number of next panels

1. Inthe Onion Skin toolbar, click the Show Next button and select one of the following:
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. No Next Panels

o = Next Drawing

0

Next Two Panels

(

e = Next Three Panels

The next panel(s)appear in the Stage view.

NOTE: You can also select View > Onion Skin to access these options.
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Flipping through Onion-skinned Drawings
T-SBFND-008-015

With the flipbook, you can move quickly between onion-skinned drawings. This is an extremely useful and time
saving feature.

How to flip through onion-skinned drawings

1. Inthe Onion Skin toolbar, do one of the following:

==

Flipbock  Play
slider

« Drag the flipbook slider to flip between the drawings you selected with the Onion Skin tool.

« Click the Play button to automatically play the onion-skinned drawings as a flipbook.
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Expanding the Onion Skin Preview

You can expand the Onion Skin to show more than the default three previous and three next drawings. You can
see some or all of the 15 previous or next drawings. Once you set the number of drawings you want to see, it is
used as the default when expanding the onion skin.You can set the default number of available Onion Skin levels
in the Preferences dialog box (Camera tab, Onion Skin and Light Table section).

How to view additional drawings

1. Inthe Onion Skin toolbar, click the Expand Onion Skin & button.
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About Quick Swap Shortcut

T-SBADV-005-003

Overriding one tool with another lets you increase productivity by rapidly switching between tools used for short
tasks and your previous tool. Most drawing tool shortcuts are accessed using the Alt key followed by another key,
such as the Eraser tool which is accessed by pressing Alt + E.

For example, if you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold
down the E key while you are erasing. When you are done, release the E key to return to the previous tool; in this
case, the Brush tool. You can do the same for most drawing tools that have a shortcut composed of Alt followed by
another key.

Selected tool

N H & 0

N H & 0

COwverride tool

For a list of keyboard shortcuts, refer to one of the following:
* Right-click on the Stage or Camera view to access the contextual menu.
» From the top menu, select Tools.
+ Preferences dialog box, Shortcuts tab: Ctrl+U (Windows) or 3£ + , (Mac OS X)

» Drawing Tools Shortcuts
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Antialiasing OpenGL Lines

T-SBADV-005-004

Everything you draw in Storyboard Pro is vector-based. When you draw in the Drawing or Camera view, notice
that your lines may appear jagged. This is caused by the fast real-time display called OpenGL. If you prefer to see
smooth lines as you draw, you can enable the antialiasing preference.

Full scene antialiasing is generated by your computer's graphics card. This antialiasing will not only antialias your
drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on or off; by
default, it is disabled.

There is no need to modify your graphic card settings.

NOTE: Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be
rendered to 100% of its resolution regardless of your preference settings or graphic card panel.

How to customize the full scene antialiasing parameters

NOTE: You must restart Storyboard Pro after you change the parameters.

1. Do one of the following:

« Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
« Press Ctrl + U (Windows/Linux) or 3£ + U (Mac OS X).

The Preferences dialog box opens.

2. Inthe Advanced tab, select the Enable option in the Full Scene Antialiasing section.
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3. Number or samples: Enter the number of samples you want to be used for the antialiasing process. The
number of samples is basically equivalent to the amount of times a pixel will be enlarged to calculate the anti-
aliasing. This technique is called supersampling. The higher the number of samples, the better the anti-
aliasing quality will be, but the longer it will take to calculate.

4. Restart Storyboard Pro.
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Changing the Drawing Tool Cursor
T-SBADV-005-005

By default, the Brush tool cursor is displayed as a crosshair. You can change it to display the shape of the current
brush size.

- o

Default cursor Brush size cursor

How to change the Brush tool cursor

1. Open the Preferences dialog box:

» Select Edit > Preferences (Windows) or Storyboard Pro> Preferences (Mac OS X).
» Press Ctrl+U (Windows) or &£+, (Mac OS X).

2. Select the Tools tab.

3. Inthe Drawing section, select the Brush Size Cursor option.

4. Click OK.

The cursor displays the current brush size.

276



Toon Boom Storyboard Pro 5.1 User Guide

About Drawing Space Navigation

When you are drawing in the Stage view, you can zoom, pan and rotate the view to make it easier to determine

where to place objects, determine the scale of objects, and when zooming out, get an overall view of the panel and
its contents.
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Zooming the Stage View

Zooming in and out of the Stage view lets you see elements close up and far away.

How to zoom the Stage view

o From the Tools toolbar, select the Zoom tool. Click the Stage view to zoom in. Press [Alt] to zoom

out.
Zoom In: Select View > Zoom In or press 2. When the Zoom In mode is selected, hold [Alt] as you click
to zoom out.

o Zoom Out: Select View > Zoom Out or press 1.

How to reset zoom

« Select View > Reset Zoom or press Shift+Z.
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Panning the Stage View

Using the Hand tool, you can pan the Stage view.

How to pan the Stage view

1. Do one of the following:

» Inthe Tools toolbar, click the Hand &\ tool.

» Hold down the Spacebar.
» Select Tools > Hand.

2. Inthe Stage view, drag the cursor.

How to reset pan

« Select View > Reset Pan or press Shift+N.
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Rotating the Stage View

You can rotate the Stage view in the same way as you would with an actual animation disc. You can also use the
menu options to rotate the Stage view in 30 degree increments.

How to rotate the drawing space

1. Do one of the following:

« From the Tools toolbar, select the Rotate View tool.
« Hold down Ctrl+Alt (Windows) or &£ +Alt (Mac OS X).

2. Drag the cursor in the Stage view to rotate the view.

How to rotate the drawing view in 30 degree increments

« Select View > Rotate View CW (clockwise) or press V.

« Select View > Rotate View CCW (counterclockwise) or press C.

How to reset rotation

« Select View > Reset Rotation or press Shift+X.
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Sharing Drawings

When there is a drawing that occurs across multiple panels, you can share (link) the drawing. This way, any
changes you make to one of the drawing affects all other instances, making it faster and more efficient when
managing and producing your storyboard.

Duplicating a panel that contains a shared drawing preserves the link.

When sharing is not needed, you can easily unlink an instance of a shared drawing from the other instances.

How to share a drawing

1. Inthe Drawing list, right-click the layer that contains the drawing to share.

2. Right-click and select Share Drawing.

The drawing is now available in the Shared Drawings folder of the Library view. In the Layers list, a star
appears beside the name of the drawing to indicate that it is a shared drawing.

3. Touse the shared drawing in another panel, drag it from the Share Drawings folder to the Layer list or Stage
view.

How to unlink a shared drawing

1. Right-click the layer to unlink and select Unlink from Shared Drawing.

The layer is unlinked from the shared drawing and its instances.
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Chapter 8: Colour

With Storyboard Pro, you can add colour to your projects.
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About Colour Swatches

T-SBFND-008-008

You can use two different types of colour swatches. You can paint drawings with vector swatches, which are the
solid and gradient colours.

@ Storyboard Pro

Drawing and Colour

About Colour Swatches
—

: Toon Boom
- Qriginal

You can paint your vector drawings with bitmap texture swatches. You can import textures and add them to your
palette. Textures must be * . psd or * . tga files. Transparency is supported. Once you have painted with
textures, you can edit the gradient's position—see Using the Edit Gradient - Texture Tool on page 301.
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Changing the Current Colour
T-SBFND-008-009

There are several ways to modify the current colour. It can be modified directly in the Colour view using the sliders
(HSV or RGB), or using the Colour Picker window.

How to change the current colour in the Colour view

1. Inthe Colour view, make sure the Colour area is expanded by clicking the Collapse/Expand arrow.

2. Inthe Colour view, drag the H,S,V sliders left or right to adjust the colour.
In the Opacity field, adjust the colour's alpha.
4. Inthe HSV/RGB menu, you can switch between HSV and RGB sliders.

Expanded Colour area — Colour HSV or RGB mode

Current colour .
Opacity

How to change the current colour in the Colour Picker window

1. Inthe Colour view, make sure the Colour area is expanded by clicking the Collapse/Expand arrow.

2. Double-click on the current colour swatch.

The Colour Picker window opens.
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Multi Wheel Mode

3. Inthe Colour Picker window, do one of the following to modify the current colour:

« Inthe colour picking area, click to select a colour.

» Typeinthe HSV or RGB values in the corresponding fields. Select the R,G,B orH,S,V
options to change the look of the colour picking area.

» Drag the Dropper 6;? to select any colour in the Storyboard Pro interface.

NOTE: When using the Dropper tool, the selected colour becomes the current colour, but is not
added to the colour swatches.

You can also click the Multi Wheel Mode button to open the Multiwheel Colour dialog box. This displays all
the picking area styles and a picking undo list. Click the Single Wheel Mode button return to the regular
Colour Picker window.
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Picking areas

Display options

Picking Undo list

Click the Shade Scale swatches to modify the shade of the selected colour.

Adjust the level of transparency with the Alpha slider, or type the value directly in the Alpha field.

Click the Add button to add the current selected colour to the Colour Storage Library, so you can quickly
access it later.

You can rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking
its name.

Multi Wheel Mode
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Adding Colour Swatches
T-SBFND-008-010

You can create your own vector colour swatches and import bitmap textures to use as swatches in your palette.

NOTE: Once added, a colour swatch can no longer be modified. You must delete the swatch and add a new one.

How to add a vector colour swatch

1. Inthe Colour view, make sure the Colour area is expanded by clicking the Collapse/Expand arrow.
2. Using the Colour view sliders or the Colour Picker window, adjust the colour for the new swatch.

3. Click the Add Colour button or select New Colour Swatch from the Colour Swatch menu.

Add Colour Colour Swatch menu

How to create a bitmap texture swatch

1. Inthe Colour Swatch menu, select New Texture.

Colour Swatch menu

+ -8
[ - |
!-:-:-f-- -

A browser window opens.

2. Browse fora PSD or TGA bitmap file created in a third party software and click Open.

A textured colour swatch is added to the swatch palette.
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Renaming Colour Swatches

If you plan on adding a lot of colour swatches to your palette, it is a good idea to organize them by naming and
reordering them.

How to name a colour swatch

1. Inthe Colour Swatch menu, deselect the Swatch Mode option.

2. Inthe Colour list, double-click on a swatch name to rename it.

3. Once you are done renaming the swatch, press Enter/Return to validate the entry.

How to order swatches

» Inthe Colour list, in Swatch mode or List mode, drag and drop the swatches to change the order.
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Deleting Colour Swatches

At any time, you can delete colour swatches that you are not using or not part of the colour palette you have in
mind for a character or scene.

How to delete a colour swatch

1. Inthe Colour view, select a colour swatch to delete by clicking a swatch. To select multiple swatches,
press Ctrl (Windows) or 3£ (Mac OS X), and click the swatches to delete. To select multiple swatches ina
range, press Shift, click the first swatch to delete and then click the last swatch.

2. Do one of the following:

» Press Delete.
» From the Colour Swatch menu, select Delete Swatch.

» Click the Remove Colour button.

Delete Colour Colour View menu
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Creating Gradients

Vector drawings can be painted using linear and radial gradients. Once painted, you can modify the position of the
gradient—see Using the Edit Gradient - Texture Tool on page 301.

How to create a gradient colour

1. Inthe Colour view, double-click the current colour swatch.

The Colour Picker window opens.

2. Select the Gradient option.

3. Select the Linear or Radial option.

4. Inthe color picking area, use the gradient arrows to modify the colours.
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Sharing Colour Palettes

Once you have established the colours to be used throughout your storyboard, you can save it as your default

colour palette for the project. You can also import and export colour palettes so that everyone on your team is
using the same colours.

NOTE: Toon Boom colour palettes are appended with a .plt extension.

How to save a default colour palette

» Inthe Colour view, click the Colour Swatch menu and select Save as Default Palette.

Colour Swatch menu

How to export a colour palette

1. From the Colour Swatch menu, select Export Colours.

2. Inthe Export Colours window, give your palette a name and click Save.
How to import a colour palette

1. From the Colour Swatch menu, choose Import Colours.

2. Inthe Import Colours window, select a colour palette and click Open.
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About Colour Tools

The colour tools are available in the Tools toolbar. The Tool Properties view displays the properties of the currently
selected tool on the current layer you are working. If you are editing a vector layer, then all of the tools are available
to you. If you are drawing on a bitmap layer, some tools are not available.

NOTE: You can display the Tools toolbar horizontally (flat toolbar) if you find it more efficient for your workflow—see
Tools Toolbarin the Reference Guide.

Depending on the type of layer you select, here are the colour tools available:

Tool Vector Layer Bitmap Layer
[ Edit Gradient/Texture . .
® Paint . .
® Paint Unpainted . .
® Unpaint . .
/ Close Gap .
* Dropper . .
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About the Paint Tool

The main tool you will use to paint your drawings is the Paint tool. The Paint tool can be used in several different
modes, and can be customized in the Tool Properties view.

The Paint tool only paints closed zones. If you have gaps in your lines, you must close them using either the
Brush, Pencil, or Close Gap tools.

To learn more about the Contour Editor properties, see Paint, Paint Unpainted and Unpaint Tool Properties on
page 1.
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About Painting Modes
The Paint tool has three different modes: Paint, Paint Unpainted, and Unpaint.

You can also find these tools in the Tools toobar and in the Tools menu.

‘ll w Paint

§ Paint Unpainted
& Unpaint

You can also enable the Auto Close Gap mode to automatically close open areas while painting.

Icon Tool Name Description

Paint Tool Options

Lasso A mode for making a rectangular selection.
x Marquee A mode for making a freehand selection.
" Paint A mode for painting everything the tool touches,

including empty and filled zones.

LG Paint Unpainted A mode for painting only empty zones. Any line or filled
zone will remain unchanged.

© Unpaint A mode for unpainting everything the tool touches,
including empty and filled zones.

Apply to Visible Drawings | Applies paint to several drawings on separate layers on
the current frame.

Auto Close Gap The Automatic Close Gap option is used while painting
drawings with small gaps. Instead of having to close
them manually either with the Brush tool or Close Gap
tool, Storyboard Pro will analyse the drawing and close
the gaps while you paint according to the selected
mode.

There are four modes available: No Close Gap, Close
Small Gap, Close Medium Gap, and Close Large Gap
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Bitmap Options
- Alpha
- Colour Tolerance
- Maximum Overlap
r Antialiasing Smooths lines as you cut drawings on bitmap layers.
When this option is deselected, the cut lines are jagged.
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Painting
T-SBFND-008-011

@ Storyboard Pro

Drawing and Colour
Painting
—

- Toon Boom
- Qriginal

How to paint a drawing

1. Do one of the following:

« Inthe Tools toolbar, select the Paint ® tool.

« Select Tools > Paint.

o Press Alt+].

2. Inthe Tool Properties & Colour view, select a colour by clicking a colour swatch.

Colour swatches

3. Inthe Stage view, start painting on your drawing by clicking the area to be painted. Note that the area to be
painted must be closed. You can either click to paint a zone or trace a lasso or marquee selection to paint sev-
eral zones at the same time.
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Using the Dropper Tool

While working in the Stage view, you can use the Dropper tool to pick a colour from your drawing without going to the
Colour view. When picking a colour with the dropper, the colour is not added to the swatch list. It becomes the
current colour.

How to select a single colour in a drawing

1. Do one of the following:In the Tools toolbar, select the Dropper  tool.Select Tools > Dropper.Press
Alt+D.

2. Inthe Stage view, click the desired colour.

How to select a compaosite colour

1. Do one of the following:In the Tools toolbar, select the Dropper # tool.Select Tools > Dropper.Press
Alt+D.

When enabled, the dropper picks the RGBA values of all the layers combined. When disabled, the dropper
picks the RGBA value from just one layer at a time.

2. Inthe Tool Properties view, click the Sample All Layers /% button.

3. Inthe Stage view, position the dropper tip over overlapping strokes and click to select the colour.

The new colour is displayed in the Colour view and becomes the current colour.
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1

Composite colour

How to select colours with or without transparency

1. Do one of the following:In the Tools toolbar, select the Dropper # tool.Select Tools > Dropper.Press
Alt+D.

2. Inthe Tool Properties view, do one of the following:

» Click the Do Not Pick Transparency ® button to select colours at 100% opacity, ignoring the alpha
value.

» Do not click the Do Not Pick Transparency ® button to select colours and retain the alpha value of
the stroke.

3. Inthe Stage view, position the dropper tip over a stroke and click to select the colour.

The new colour is displayed in the Colour view and becomes the current colour.
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Using the Edit Gradient - Texture Tool

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its position
in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set the first
texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you can select the
next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if you want the Brush and Paint tool to use your gradient’s position,
angle and scale settings instead of the default ones, you can store your own settings and reuse them afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with textured
“brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both elements
independently at the same time.

How to use Edit Gradient/Texture tool

1. Inthe Tools toolbar, select the Edit Gradient/Texture [ tool or select Tools > Edit Gradient/Texture.

1. Click the Gradient or Texture zone to be modified. To modify several areas at once, hold down the Shift key and
click in the zones to be modified.

U

l | 1]

Linear gradient Radial gradient
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2. Move the edit texture’s anchor points to the desired result.

» If the same maodification needs to be applied to another gradient in another drawing or texture zone, you
can select the modified zone and select Edit > Copy. Select the zone to be modified in the other
drawing and select Edit > Paste.
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Using the Close Gap Tool

<
O <
— U

When painting, you will notice that some of your drawing areas are not closed. To close the zone you can either draw
the missing line with the Brush or Pencil tool, but you can also close the gap with an invisible line. To do so, you will
use the Close Gap tool.

The Close Gap tool is used to close small gaps in a drawing. The Paint tool only paints closed areas. The Close Gap
tool will create a small, invisible stroke between the two closest points to close the colour zone. You do not need to
trace directly over the gap. You can draw it a few millimetres away and the Close Gap will automatically choose the
two closest points and close the gap.

How to use the Close Gap tool

1. Inthe Tools toolbar, select the Close Gap ¢ tool or select Tools > Close Gap.

» Click the Auto Flatten = button in the Tool Properties view if you want the stroke you will draw to be
flattened in your drawing instead of being on top.

» You candisplay the invisible lines with the Show Strokes option underView > Extras > Show Strokes or
press K.

» If you do not display the strokes, a warning message dialog box will appear. Enabling the Don’t Show
This Message Again option prevents this Message from appearing.

2. Inthe Stage view, trace an invisible line near to the gap to be closed.

The gap automatically closes.
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Chapter 9: Libraries
T-SBADV-009-001

You can share and reuse any elements you create in Storyboard Pro using templates. Storyboard Pro has a library
where you can store several different elements such as characters, sets, props, layers and camera moves.

The Library view lets you reuse artwork and panels in other scenes and projects.

A library is a folder where you store your templates. You can access these folders from different projects. Using the
library is easy, just drag the content into the library to store your artwork and then drag it into your Camera, Timeline,
or Thumbnails view where you want to reuse it. Organize your library using subfolders. You can keep several
different library folders on your hard drive or network.

A template is a copy (instance) of the artwork stored in the library which you can reuse in different scenes. Once a
template is stored in the library, you can access it from any project, as many times as needed.

When you import the template, a copy of the artwork is created in the project, but is not linked to the template in the
library. This mean you can modify the artwork inside the project without affecting the template it came from.
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About the Library Structure
T-SBADV-009-002

As you will probably create a large number of templates, they will need to be organized. You can create different
libraries and subfolders so you easily access your assets. For example, create a different library for each project
and divide it into several categories, such as:

« Characters
o Props

« Backgrounds
« Panels

« Soundclips

« 3D objects

You have the possibility to share your drawings across several panels throughout your storyboard. The drawings
that you share are automatically added to the Shared folder. From that folder, you have the possibility to drag your
drawings back to your panels to reuse it. Shared drawings are linked. If you modify it in one place, it is modified
everywhere.

NOTE: When you import a 3D object, it is added automatically to the Library.
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Creating Libraries
T-SBADV-009-003

There are two ways to create Library folders.

« Using Storyboard Pro’s interface

« Directly through your operating system

To create a library using your operating system, create a new folder with a relevant name in the location where you
want the library to be stored. This can be opened in Storyboard Pro when you require it—see Creating Libraries on
page 307.

Template libraries need to be organized. You can create different subfolders on your hard drive or directly in the
Library view so that you can gain easy access to your assets.

How to create a library from Storyboard Pro

1. Inthe Library view, right-click in the Library List section and select Open Library.

The Browser window opens.
2. Browse for the location where you want to store your new library in your computer.
3. Click New Folder.

4. Name the new library with a relevant name and click Select Folder.

The new library appears in the Library List section.

How to create a folder

1. Inthe Library view’s left side, select the library folder in which you want to create subfolders.

2. Right-click on the selected library and select New Folder.

The new subfolder is added to the Library (although not immediately visible as it is collapsed in its parent
folder). Click the root library folder containing the new folder and then click the plus (+) sign to expand it. The
new subfolder appears.
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Opening Libraries
T-SBADV-009-004

You can open any folder on your hard drive or network as a library. Opening a library means linking the folder to
your Library view. You only need to open the library once. The library folder is available every time you open the
application until you decide to close the library and unlink it.

NOTE: Opening a folder that contains image files will allow you to quickly import those images into Storyboard Pro
by dragging and dropping them into the Stage view.

How to open a library

1. Inthe Library view, right-click in the Library List section and select Open Library.

The Browser window opens.
2. Browse to the location of the library folder.

3. Select the folder and click OK.

The new library appears in the Library List section.
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Renaming Folders
T-SBADV-009-005

Once you add a folder, you can rename it. This also renames the folder on your hard drive.

How to rename a folder

1. Inthe Library view’s left side, select the folder to rename.

2. Right-click on the selected library and select Rename Folder.
3. Rename the selected folder.

4. Press Enter/Return to validate the operation.
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Closing Libraries and Deleting Folders

T-SBADV-009-006

You may not always require all of the library folders in the Library List. You can close the ones you do not need.
Closing it does not delete the folder, it only unlinks it from the Library view. If you want to reopen it later, you only

need to locate it on your hard drive or network and open it in the Library view.

You can delete a folder from the library if its contents are no longer needed.

IMPORTANT: ALL THE TEMPLATES CONTAINED IN THE FOLDER WILL BE DELETED FROM YOUR HARD

DRIVE. ONCE DELETED, THE DATA CAN NOT BE RETRIEVED. Itis NOT the case when simply closing
libraries.

How to close a library

1. Ontheright side of the Library view, select a library folder to close.

2. Inthe Library View menu, select Folders > Close Library.
How to delete a folder

1. Inthe Library view’s left side, select the folder to delete.
2. Right-click the selected library and select Delete Folder or press Delete.
A warning dialog box opens.

« Click Yes to delete the folder. ALL THE TEMPLATES CONTAINED IN THE FOLDER

WILL BE DELETED FROM YOUR HARD DRIVE. ONCE DELETED, THE DATA CAN
NOT BE RETRIEVED

« Click No to cancel.
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Refreshing Libraries
T-SBADV-009-007

If you update the content of your libraries through your operating system, you must refresh the library folders in the
Library view.

How to refresh a library

« Inthe Library view’s left side, right-click and select Refresh or press [F5].
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About Templates

T-SBADV-009-009

If you want to reuse artwork, layer, or camera motions from your project in the same or other projects, you need to
create a template out of it. A template can be seen as a portable scene or package that you can drag inside your
project.

A template is a copy (instance) of the artwork stored in the library which you can reuse in different scenes. Once a
template is stored in the library, you can access it from any project, as many times as needed.

When you import the template, a copy of the artwork is created in the project, but is not linked to the template in
the library. This mean you can modify the artwork inside the project without affecting the template it came from.
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Creating Templates
T-SBADV-009-010

You can create a template out of many assets in your project. You can create templates from the Camera,
Thumbnails or the Timeline view.

From the Stage view, you can create a template from a panel’s layer or a selection of layers. Note that if a motion
was created on the selected layer, it will be included in the template.

From the Thumbnails view, you can create a template from an entire panel. Note that if there is a layer or camera
motion in the selected panel, it will be included in the template.

From the Timeline view, you can create a template out of an entire panel or a sound clip. Note that if there is a layer
or camera motion in the selected panel, it will be included in the template.

How to create a template from the Stage view

1. Inthe Library view, select a folder to store your template.

2. Inthe Stage view, select one or more layer tabs and drag them to the right side of the Library view.

3. Inthe Rename dialog box, rename the new template. If you want to rename a template after it is created,
right-click it and select Rename.

How to create a template from the Thumbnails view

1. Inthe Library view, select a folder to store your template.

2. Inthe Thumbnails view, select a panel and drag it to the right side of the Library view.
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3. Inthe Rename dialog box, rename the new template. If you want to rename a template after it is created,
right-click it and select Rename.

How to create a template from the Timeline view

1. Inthe Library view, select a folder to store your template.

2. Inthe Timeline view, select a panel or sound clip and drag it to the right side of the Library view.

3. Inthe Rename dialog box, rename the new template.

If you want to rename a template after it is created, right-click it and select Rename.
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Deleting Templates
T-SBADV-009-011

To delete templates from your library, use the Library view. You can always undo the delete action if necessary.

IMPORTANT: DO NOT DELETE TEMPLATES USING THE OPERATING SYSTEM BECAUSE YOU WILL NOT BE
ABLE TO UNDO IT.

How to delete a template

1. Inthe Library view, select the template to delete.

2. Right-click and select Delete or press Delete.
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Importing Templates

T-SBADV-009-012

There are several ways you can insert templates in your project. You can insert layer and panel template in the
Stage, Thumbnails and Timeline views.

How to import a template in the Stage view

1. Inthe Thumbnails view, select the panel in which you want to insert the template.
2. Inthe Library view, select the template you want to insert.

3. Drag the selected template to the Stage view.

If you drag a template of an entire panel into a selected panel, it will add all the contents of the template
into the existing selected panel.

How to importing a template in the Thumbnails view

1. Inthe Thumbnails view, select the panel in which you want to insert the template.
2. Inthe Library view, select the template you want to insert.

3. Drag the selected template to the selected panel in the Thumbnails view.

316



Toon Boom Storyboard Pro 5.1 User Guide

T

w;:;?

How to import a template in the Timeline view

1. Inthe Timeline view, select the panel in which you want to insert the template.
2. Inthe Library view, select a template to insert.

3. Drag the selected template to the selected panel in the Timeline view.

TATNI

If you are inserting a sound clip template, drag the template into a sound layer in the Timeline view.
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Generating Thumbnails

T-SBADV-009-013

When you display thumbnails in the Library view, Storyboard Pro generates a series of small images (thumbnails)
for you. However, it is possible to generate template thumbnails manually.

By default the automatic option is enabled, which means the thumbnails in the Library view will be automatically
generated. You can disable this option to prevent the thumbnails from being automatically generated.

You can delete the thumbnails files from the Library view.

How to generate thumbnails

1. Inthe Library view’s right side, select a template.

Library

LR_Ship_Holo_Red

[R¥AIF.N|

LR_Ship_no_texture

. Ship_LRtxd_dmgd

Template with missing thumbnail

2. Right-click and select Generate Thumbnails.
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Library

<
>

How to disable the automatically Generate Thumbnails preference

1. Do one of the following:

« Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
o Press Ctrl+U (Windows) or 3£ + , (Mac OS X).

2. Select the General tab.

3. Inthe General section, select the Automatically Generate Thumbnails in Library option.

NOTE: When you deselect the Automatically Generate Thumbnails in Library option, you can manually generate
them.

How to delete thumbnails

« Inthe Library view, right-click in the left section and select Delete Thumbnails.
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Searching Libraries

You can use the Quick Search field to rapidly locate a particular template using a keyword contained in the
template’s name.

How to search for a template

1. Inthe Quick Search ¢ field, type a word or part of a word contained in the template’s name. You can
select a folder in the Library’s List to limit the search to this specific library.

2. Press Enter/Return to validate.

The first template found is selected and displayed along with the other templates contained in the same
folder.

Library  ==[%
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3. Click the Right Arrow button to find the next template containing the keyword, or on the Left Arrow
button to see the previous result.
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About Importing Files

Using the Library view, you can import several types of files and store them in a library folder as a template. Once
you have these new templates, you can use them throughout your storyboard projects just like the regular ones.

You can import all sorts of files using the Library view. You can import bitmaps as well as vector-based images,
audio files, Adobe Flash movie file (.swf), and templates (.tpl) files made in Harmony 9.2 or highe. This can be
useful for importing backgrounds created in Harmony directly into your storyboard.

You can alsoimport four types of 3D files. When you import a 3D model, it is automatically added to the Library in
the 3D Models folder according to its format.
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Importing Images
T-SBFND-008-012

You can import all sorts of image files and reuse them throughout your project as templates. You can import bitmap
as well as vector-based images, which can be really handy. The supported image formats include: .ai, .pdf, .tvg,
.pal, .scan, .sgi, . tga, .yuv, .omf, .psd, .png, .jpg, .jpeg, .bmp and .tif.

@ Storyboard Pro

Drawing and Colour

Importing Images

- '_ Toon Boom

Qriginal

How to import an image file

1. Inthe Library view, right-click a library folder and select Import Files.

Library  ==[%

The browser window opens.

2. Find and select an image file and click Open.

The selected file appears in the Library view as a .tpl file inside the selected library folder.

Fropz.tpl
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Importing Audio Files

You can import three types of audio files, which you can drag in the Timeline view when creating your animatic
project. The supported audio file formats are: .wav, .aif and .mp3.

How to import an audio file

1. Inthe Library view, right-click a library folder and select Import Files.

The browser window opens.

2. Find and select your audio file and click Open.

The selected audio appears in the Library view as a .tpl file inside the selected library folder.
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Importing Flash Movies (SWF)

You can import an Adobe Flash movie file (.swf) into the Library view. The movie file will become a single layer
template that contains the animation. Only the first 20 first frames of the animation will be imported in the template.

How to import an Adobe Flash movie file

1. Inthe Library view, right-click a library folder and select Import Files.

The browser window opens.

2. Find and select your Adobe Flash Move file (.swf) and click Open.

The selected .swf files appears in the Library view as a .tpl file inside the selected library folder.

NOTE: You can preview the animation contained in the new template by using the preview section of the Library
view—see Library View in the Reference Guide.
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Importing Harmony Templates

You can import template (.tpl) files made in Harmony 9.2 or higher into the Library. This can be useful for importing
backgrounds created in Harmony directly into your storyboard.

NOTE: Because Harmony is an animation software and Storyboard Pro is not, animated templates and templates
of rigged puppets created in Harmony may not import properly. Templates with multiple layers will retain their layer
structure, but cut-out puppets may be rendered as flat objects with stationary parts.

How to import a template created in Harmony

1. Inthe Library view, right-click on the left side of the Library view, under all the existing folders and select
Open Library.

A browser window opens.

2. Search for the folder with the .tpl file to import. That folder is considered the “Library” that you choose to
open. Note that the . tpl file itself is also a folder. Select the Library folder and not the Template folder. For
example, the library may be the Toon Boom Stage Library (found in the My Documents folder on Windows)
and the name of the template inside Enchanted Forest. tpl.

An orange book icon appears on the left side of the Library view with the name of the folder that you
selected.

3. Click the folder to display the templates on the right side of the Library view. The template thumbnails may
take a moment to generate.

If there were any subfolders in the root library folder, they will appear as grey books within the root library.
You may need to expand the root library to see them. Click on one of these grey book subfolders to display
its templates on the right side of the Library view.
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Importing 3D Objects

You can import four types of 3D files, which you can drag in the Timeline view when creating your animatic project.
The supported 3D file formats include: .osb, .3ds, .obj and .fbx. When you import a 3D model, it is automatically
added to the Library in the 3D Models folder according to its format. You can then reuse that 3D model easily within
your project file.

In addition to importing 3D objects into the 3D Models folder in the Library view, you can also open a folder
containing 3D models as a library in the Library view. The models can then be dragged and dropped into the scene
directly from the Library and will be copied into the project’s local 3D Models folder so that the model can be
referenced in that project file.

How to import a 3D object

1. Inthe Library view, right-click on the 3D Models library folder, and select Import Files.

The browser window opens.

2. Locate the 3D file and click Open.

3. To consolidate the textures and convert your 3D model to FBX format select the Convert to FBX Format
option.

An FBX version of your 3D model is generated which stores the texture within the new FBX file. This will
prevent the link between the 3D model and its textures from breaking.

The 3D object is imported into the 3D Models folder of the Library view and labeled according to its format.

4. Dragthe 3D object into the Stage view.

The 3D object appears in its original size and is located at the zero NS/EW/FB position. The 3D object
appears in all three view windows.

NOTE: When deleting a 3D model from the 3D Models folder of the Library, every instance of the model used in the
project will be deleted at once. A warning message will prompt you to confirm or cancel the action.

How to open a folder containing 3D models as a Library

1. Inthe Library view, right-click somewhere in the left side of the Library view, under all the existing folders, and
select Open Library.

A browser window opens.

2. From the browser window, search for the folder that contains the .osb, .3ds, .obj or .fbx files that you wish to
import. That folder is considered the “library” that you chose to open.
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3. An orange book icon will appear in the left side of the Library view with the name of the folder that you
selected. Click on it to see the templates contained inside on the right side of the Library view. The tem-
plate thumbnails may take a moment to generate.

If there were any other readable files in the same folder, such as .tga files used for the 3D objects texture,
they may appear in the new library as well.

4. From the right side of the Library view, select the 3D model’s thumbnail and drag and drop it into your pro-
ject, either in the Camera or Timeline view.

A copy of the model will be copied into the appropriate models folder in the root 3D Models folder of the
Library view. Although you can store 3D models in the Library view for easy accessibility, the project can
only reference models found in the 3D Model folder of the Library view.

NOTE: If your 3D template is animated, you can preview the animation by using the Preview section of the Library
view—see Library View in the Reference Guide.
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Chapter 10: Timing

The Timeline view is where you assemble the timing of a scene’s visuals and sounds. You can add sound track
layers, as well as edit audio files imported into the sound tracks. You can also add transitions and control the
playback of a selected panel or the entire storyboard from this view.

By default, timecode format is used to display the timing in the most accurate manner. The starting timecode of your
project is set to 00:00:00.00. However, sometimes it may be best to use the number of frames as a timing value and
a later timecode value as the start of your project. You can modify the format and default starting time code value via
the Preference dialog box.
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About the Panel Duration

T-SBFND-009-001

When panels are initially created, their default length is 1 second, displayed in timecode format. When it comes to
your animatic, you will want to be more accurate. Modifying the duration of a particular panel is key when working
out timing. There are a few different ways to accomplish this.

@ Storyboard Pro

Animatic
About the Panel Duration

: Toon Boom
- Qriginal

In the Timeline view, it is easy to change the duration of a panel just by dragging to resize it. This way, you can
easily see the length of panels in relation to one another.
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Changing the Panel Duration
T-SBFND-009-002

There are two ways to resize a panel, depending on how you want the change to affect subsequent panels. You can
resize a panel in the Timeline view and shift all other panels down. This is handy when you are not concerned about
modifying the position of all subsequent panels. Or you can resize a panel while only affecting the next panel. This is
useful if you need to keep subsequent panels exactly where they are.

An accurate way of setting the duration of a panel is to use the Panel view, which will display, among other things,
the exact timecode information for the selected panel.

Panel (%

Displays the Selection
Information section

Duration of
selected panel

How to set the panel duration in the Panel view

1. Inthe Timeline or Thumbnails view, select a panel.

2. Inthe Duration field of the Panel view, lengthen or shorten the selected panel by using the up and down
arrows or type in a value.

Panel (%

How to resize a panel in the Timeline view and shift all other panels down

1. Place the cursor over the end (right side) of a panel.

The resize icon displays.
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2. Drag the edge of the panel left or right to set the desired length. Using this method, all subsequent panels
will be shifted along with the selected one.

While you drag, the new duration of the panel as well as the difference between the former duration are
displayed in a black box for accuracy. This value can be displayed in either frames or timecode.

How to resize a panel while only affecting the next panel

1. Place the cursor over the end (right side) of a panel.

The resize icon displays.

2. Hold the Alt key, then drag the edge of the panel left or right to set the desired length. Only the panel dir-
ectly after the selected panel will be changed.
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Setting the Panel's In and Out Point

You can adjust the duration and position of a panel by moving its in and out points to a specific frame determined by
the current position of the playhead.

NOTE: Note that the frame you specify must be contained within the current position of the panel you want to change
the in or out point of.

How to set a panel's in point to the current frame

1. Inthe Timeline view, position the red playhead where you want the panel to start.

2. Do one of the following:

» Select Storyboard > Move Panel In to Current Frame.

>

Right-click on the selected panel and select Move Panel In to Current Frame.

The selected panel's in point is pushed to the new position, resulting in the previous panel being extended
to this point.

How to set the panel's out point to the current frame

1. Inthe Timeline view, position the red playhead to where you want the panel to end.

2. Do one of the following:

» Select Storyboard > Move Panel Out to Current Frame.
» Right-click on the selected panel and select Move Panel Out to Current Frame.
The selected panel's out point is pushed to the new position, shortening its duration.
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Splitting a Panel at the Current Frame

You can split your current panel into two pieces. Following this operation, you will have two identical panels
generated from the original. All elements, including layers, will be in both panels. Each panel’s length will be
determined by where you have the red playhead when you perform the operation.

How to split panel at current frame

1. Inthe Timeline view, position the red playhead to where you want the panel to be spilit.

2. Do one of the following to split the panel:

» Select Storyboard > Split Panel At Current Frame.
» Inthe Timeline view, right-click in your selected panel and select Split Panel At Current Frame.

Your panel is split into two pieces, precisely where the red playhead is positioned.

NOTE: You may have to adjust any layer transformations you created before splitting the panels.
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Locking the Scene Duration

You can lock the duration of all scenes in your project with the Lock Scene Duration command. This ensures that
the length of every scene is preserved when adding, duplicating, or deleting panels.

How to lock the scene duration

1. Select Storyboard > Lock Scene Duration.

NOTE: You can add a custom keyboard shortcut to this option through the Preferences dialog box or use the Lock
Scene Duration g button in the Storyboard toolbar. You may need to add the button to the toolbar. Right-click
the toolbar area and select Customize.

2. Once your scene duration is locked:

>

Adding a panel using the New Panel or Smart Add Panel command reduces the size of the selected

panel to make room for the new one. If the selected panel's length is one frame, the panel length cannot
be reduced and therefore the new panel cannot be inserted in the scene.

>

Deleting or cutting one or more panels causes the preceding panel's length to extend to fill the gap and

preserve the scene's duration. Cutting or deleting a scene or all the panels on a scene will not let you
preserve the scene's duration.
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» Duplicating a single panel using the Duplicate Panel command reduce the length of the selected panel to
make room for the duplicated one. Duplicating multiple panels will not keep the scene's duration.

» Copying and pasting panels, adding a scene or a sequence, or deleting an entire scene will not preserve
scene duration.

» Manually changing the duration of a panel is still permitted and will modify the scene duration.
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Selecting All Panels Forward

By using a series of keyboard shortcuts, it is possible to select a panel and all the panels following. You can also
do this on the audio tracks—see Sound on page 443.

How to select all panels forward

1. Inthe Timeline view, select a panel.

2. Hold Ctri+Alt+Shift (Windows) or 35 +Alt (Mac OS X) and click the panel again.

The selected panel and all the panels following it, up until the end of the storyboard project, are selected.

» If you drag the selection forward, the panel preceding the selection will be extended.

» If you drag the selection backward, the panel preceding the selection will be reduced until it reaches the
minimum length allowed (one frame). Then the second panel preceding it will be reduced.

How to select all panels and all sound clips forward
1. Inthe Timeline view, press Ctrl+Alt+Shift (Windows) or 35 +Alt (Mac OS X) and click the panel from which
you want the selection to start.

The panel and all the panels following it, up until the end of the storyboard project, as well as all the sound
clips in all audio tracks starting from the position of the play head are selected and can be moved together.

RR_Line01_Celina_

RR._Line02_Terrance_01.wav

» If you drag the selection forwards, the panel preceding the selection will be extended.

» If you drag the selection backwards, the panel preceding the selection will be reduced until it reaches
the minimum length allowed (one frame), then the second panel preceding it will be reduced.
Overlapping sound clips will be overwritten by the ones that are selected.
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Playing Back the Animatic

You can preview your project as an animatic in Storyboard Pro at any time during its development process. Using
the Playback toolbar, you can preview the visual content, including transformations and transitions, and have it
synchronized with sounds.

How to preview an animatic

1. Inthe Playback toolbar, click the Sound «, button.

If you want to see how the shots will look with dynamic camera movement, click the Camera Preview &

button. You will need this option on to preview Camera moves and transitions. When you drag the red
playhead while Camera Preview is enabled, it will adjust the Stage view to match the point of view of the
camera.

2. Inthe Timeline or Thumbnails view, select the panel where you want the playback to begin.

3. Inthe Playback toolbar, click the Play Selection = orPlay » buttons or press Shift+Enter.
4. Toplay your project in a continuous loop, click the Loop & button.

5. You may also scroll through the Timeline view by dragging the red playhead.

6. Select Play > Previous Frame or Next Frame to skip and play back one frame at a time. Or press comma ()
and period (.).
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Chapter 11: Staging

Staging is all about placing elements in your scene.
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Adjusting the Pivot Point Layers

T-SBFND-009-009

If you plan to animate a layer, it is wise to first set its pivot point. If you do not intend to animate a layer, there is no
need to set the pivot.

@ Storyboard Pro

Animatic
Adjusting the Pivot Point of Layers
———

: Toon Boom
- Qriginal

How to set the pivot point of a layer

1. Inthe Timeline view, select the panel on which you want to animate a layer.

2. Do one of the following:

« From the Tools toolbar, click the Layer Transform i-; tool.

« Select Tools > Layer Transform.

3. Inthe Stage view, select a layer to animate.

The selected layer’s transformation controls and pivot point become visible. The pivot point is represented
by a blue circle at the centre of the camera frame.
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Pivot point

4. Inthe Stage view, drag the pivot point to new location.

The new location of the pivot point will now be used as the reference when transforming layers.

How to set the pivot point at the centre of a selection
1. Inthe Timeline view, select the panel containing the layer on which you want to set the pivot.
2. From the Tools toolbar or the Tools menu, select the First Frame Transform o tool.

In the Stage view, select the layer with the pivot you want to set at the centre.

4. Do one of the following:

« Inthe First Frame Transform Tool Properties view, click the Center Pivot on Selection 77 but-
ton.

« Select Layer > Pivot > Center Pivot on Selection.

The pivot position is reset to the centre of the selection.
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How to reset the pivot position
1. Inthe Timeline view, select the panel containing the layer on which you want to reset the pivot.
2. From the Tools toolbar or the Tools menu, select the First Frame Transform . tool.

3. Inthe Stage view, select the layer with the pivot to reset.

4. Do one of the following:

« Inthe First Frame Transform Tool Properties view, click the Reset Pivot ‘@ button.

» Select Layer > Pivot > Reset Pivot.

The pivot position is reset to the centre of the camera frame.
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Resetting Transformations

When you no longer need a layer's transformation, you can easily reset layers to their original position.

How to reset layer animation back to its default state

1. Inthe Timeline view, select a layer.

2. Do one of the following:

» Select Layer > Reset Transform.
» Press Ctrl+R (Windows) or 3£ +R (Mac OS X).
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About Staging in 3D Space

Storyboard Pro adds a new dimension to the layout process by allowing you to plan your 2D scenes in a 3D
space. The 3D space is described in terms of three planes:

» EW: Maps the horizontal plane in terms of East and West, this is the X coordinate.
* NS: Maps the vertical plane in terms of North and South, this is the Y coordinate.
* FB: Maps the depth of the plane in terms of Front and Back, this is the Z coordinate.

When you add elements to a scene, they appear in layers in the initial position of zero fields NS, zero fields EW,
and zero fields FB within the 3D scene space. Before the 3D space feature, you could only change the layer
position—see .

But in 3D space, you can use the EW (X), NS (Y), and FB (Z) coordinates to place your elements at different
distances in depth from the camera and from each other, adding a three-dimensional effect to your two-
dimensional animation.

EW(X)

A

NS
(Y)

Once you place the elements in your scene, you can move, rotate, or scale your elements in 3D space.
Storyboard Pro automatically applies the changes to all of the contents in the element.

Where previously 2D objects could only be moved, rotated and animated on a 2D plane, now they too can be
manipulated in 3D space. This means that flat, 2D objects can move forward or backward along the Z-axis,
growing realistically bigger or smaller as they move towards or away from the camera. Features, such as Always
Face Camera, mask the paper thin edges of 2D objects for camera rotations around these objects.
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Converting Scenes to 3D

By default, newly created scenes are set to the 2D mode, so your project is not encumbered with unnecessary
features if you plan to work in 2D for more than a few scenes. You can convert a scene to 3D, so you can move and
rotate 2D and 3D layers in 3D space. This means that even if you do not have any 3D objects in your scene, you can
still move 2D objects along the Z-axis to create a multiplane effect. A 3D scene will also allow a camera to be moved
in 3D space using the Camera tool.

NOTE: Converting a scene to 3D applies only to the selected scene, not the entire project.

How to enable the 3D option

1. Inthe Thumbnails view, select the scene you want to convert to 3D.

2. Do one of the following:

» Inthe Storyboard toolbar, click the Enable 3D X button.

» Select Storyboard > Enable 3D for Current Scene.

NOTE: Selecting these options in the Preferences dialog box requires you to restart Storyboard Pro.

347



Chapter 11: Staging About Staging in 3D Space

Resetting Scenes to 2D

Storyboard Pro lets you reset your scene to 2D. When you do so, the following happens:
* Imported 3D models are removed.
+ 3D camera moves are removed.

» 2D layers that have been moved and rotated in 3D are be set back to 2D, removing those transformations.

How to reset a scene to 2D

1. Do one of the following:

» Inthe Storyboard toolbar, click the Reset Scene to 2D 3 button.

» Select Storyboard > Reset Scene to 2D.
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Viewing Objects from the Top and Side

The Top and Side views are representations of your scene’s space viewed from the top and side. The views also
display the viewing area that the camera can see.

When you move an element along the Z-axis, notice that it seems the object becomes smaller or larger. This is
because of the perspective effect. That is, the elements closer to the camera appear larger and elements that are
farther away, appear smaller. Because of this, you may need to resize elements once they are positioned.
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Each alement in his scene i3 located in a different position in 30 space, which you can clearly see in the Top and Side views

The Stage view displays the north/south (NS), east/west (EW) and front/back (FB) offset positions, but you can use
the Side and Top views to reposition elements:

« Top View: Displays the EW and FB positions.
« Side View: Displays the NS and FB positions.

Changing an element’s position affects all of its contents.

Because these are 2D layers in your scene, they appear as lines in the Top and Side views (since you are viewing
them from their sides). When you import 3D objects, you will see the full 3D object in the Top and Side views.
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Positioning 2D Objects in 3D Space

You can manipulate a single 2D object in 3D space. You can also stagger multiple 2D objects along the Z-axis to
make a multiplane or rotate planes to build open-faced rooms.

How to position 2D objects in 3D space

1. Inthe Stage or Camera view, select a layer with a 2D object.

2. From the Tools toolbar, click the Layer Transform ;-3 button.
Manipulators appear over the object layer’s pivot point.

3. Use the manipulators to manipulate your image in the following ways:

» To squash and stretch your image vertically: Pull the green, square points located at the top and
bottom of the manipulator circle.
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» To squash and stretch the image horizontally: Pull the red, square points located on the right and left
sides of the manipulator circle.

» Toscale the image proportionally: Hover anywhere over the box outside the manipulator circle until the
cursor turns into a white, double-headed arrow. Pull in any direction to scale the image up or down.

» To move the image vertically: Click the green, vertical arrow and pull it up or down.
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>

» To move the image backwards or forwards along the Z-axis: Go to either the Top or Side views
and use the blue arrow to pull the layer closer or farther from the static camera cone.
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» To rotate the image on the X-axis: Hover over the vertical line (actually a ring) bisecting the manipulator

circle. The rotate X-axis cursor bk appears. Pull up or down to rotate your object along this axis.

» To rotate the image on the Y-axis: Hover over the horizontal line (actually a ring) bisecting the

manipulator circle. The rotate Y-axis cursor ¢ ¥ appears. Pull towards the left or right to rotate your object
along this axis.

» To rotate the image on the Z-axis: hover anywhere over the manipulator ring. The rotate Z-axis cursor
appears. Pull clockwise or counter clockwise to rotate the object.
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You can perform any of these manipulations in combination. For example, after have rotated your 2D
object 45 degrees around the Y-axis, you can reposition it along the Z-axis.
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Modifying 2D Objects in 3D Space

Flat 2D objects integrated into your 3D scene may sometimes need to be edited, even after the camera has been
repositioned or rotated in 3D space. An edit usually requires redrawing and recolouring part of the object. However,
after making several rotations or a movement in 3D space, the Stage view and the drawing layer of the 2D object
might no longer be parallel to one another. If this happens, you cannot draw on that layer. To make your edits, you
must use the Look At Selected feature.

How to use the Look at Selected feature

1. Select a layer by doing one of the following:

» Stage View: In the Layers section select a layer.
» Stage View: Use the Layer Transform -3 tool to select a layer.

» Thumbnails View: Click the scene's layer tab.

2. Inthe Stage view status bar, click the Look At Selected =) button.

The Drawing object layer is perpendicular to the Stage view, ready for drawing edits.

NOTE: You can use rotate the light table by pressing: Ctrl+Alt (Windows) or 3£ +Alt (Mac OS X).
You can rotate the Stage view by pressing V or C (Windows) or Shift+38 (Mac OS X).
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Chapter 12: 3D Objects

T-SBADV-010-001

Storyboard Pro brings your animation into the third dimension by letting you import 3D objects into your project. You
can place, manipulate, and modify 3D objects and add new depth to your storytelling.

When creating your storyboard, you can import four types of 3D files. The supported 3D file formats are: *.osb,
*.3ds, *.obj and *.fbx. When you import a 3D model, it is automatically added to the Library in the 3D Models folder
according to its format. You can then reuse that 3D model easily within your project file.

NOTE: ltis recommended to use the .fbx format as it allows the textures to be packaged with the model.

When you import a 3D model into your library, each time you drag it into your scene, it continues to refer to the
original model (it does not make a copy of the 3D model). The 3D Models library is also local to your project file, so
you must import your 3D models in each project file.
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Determining the Scale Factor

T-SBADV-010-002

Before importing a 3D object, you must consider the scale factor to use. This will depend on the base units of the
modelling program used to create the 3D object.

How to determine the scale factor

Create a unit cube in the source modeling program (a 1x1x1 cube).
Place the model in the scene.

Import the cube in Storyboard Pro, setting the scale factor to 1.0.

A w o=

Verify the scaling to see if it is correct. If not, display the grid (Ctrl+G (Windows) or 3£ +G (Mac OS X))and
change the scale factor so the cube fits correctly in the scene. The resulting scale factor will be the one to
use when importing models created with that particular 3D modelling application.
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About Pre-scaling 3D Objects
T-SBADV-010-003

When importing a 3D object created in a 3D modeling application, such as Maya, Cinema4D, Blender or others, the
3D object can appear much larger than the scene. To use the object, you would have to scale it manually, which is
cumbersome and prone to errors. This is because 3D modeling applications use different base units than Storyboard
Pro. For example, Maya works in centimeters and Blender works in meters. When a 3D model is saved, the base
unit is not necessarily included.

When importing the file, Storyboard Pro does not know which base unit was used. 3D objects will appear huge or
tiny when placed in a scene.

The 3D model is much larger than the scene. It would require many steps to scale it down manually.

By pre-scaling the 3D object before placing it in a scene, it should come in at the right size.

After pre-scaling and placing a 3D object in a scene:

« ltis still possible to change the scale factor of a object in the library even when an instance is already in the
scene. Its scaling will be changed for each instance in the scene.

« When exporting the project. the scale factor of the 3D object is retained.

« The value you set will become the default Scale Factor used when you import subsequent 3D objects. If you
are importing a large number of 3D objects that were created with the same 3D software, it may be more effi-
cient to set the Scale Factor in the Preferences dialog box. This way, the Scale Factor is set on a project-
wide basis—see Project Setting Preferences in the Preferences Guide.

« 3D objects will scale according to the scale factor you set. However, its value will not appear in the trans-
formation values. You can reset the transformation of the 3D object without affecting the scaling done by the
pre-scaling.

« After you have imported a 3D object and placed it into a scene, the scale factor you set will not appear in the
transformation values. You can reset the transformation of the 3D object without affect the scaling done by
the pre-scaling.
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Importing 3D Objects
T-SBADV-010-004

You can import four types of 3D files, which you can drag in the Timeline view when creating your animatic
project. The supported 3D file formats include: .osb, .3ds, .obj and .fbx. When you import a 3D model, it is
automatically added to the Library in the 3D Models folder according to its format. You can then reuse that 3D
model easily within your project file.

In addition to importing 3D objects into the 3D Models folder in the Library view, you can also open a folder
containing 3D models as a library in the Library view. The models can then be dragged and dropped into the scene
directly from the Library and will be copied into the project’s local 3D Models folder so that the model can be
referenced in that project file.

How to import a 3D object

1. Inthe Library view, right-click on the 3D Models library folder, and select Import Files.

The browser window opens.

2. Locate the 3D file and click Open.

3. To consolidate the textures and convert your 3D model to FBX format select the Convert to FBX Format
option.

An FBX version of your 3D model is generated which stores the texture within the new FBX file. This will
prevent the link between the 3D model and its textures from breaking.

The 3D object is imported into the 3D Models folder of the Library view and labeled according to its format.

4. Drag the 3D object into the Stage view.

The 3D object appears in its original size and is located at the zero NS/EW/FB position. The 3D object
appears in all three view windows.

NOTE: When deleting a 3D model from the 3D Models folder of the Library, every instance of the model used in
the project will be deleted at once. A warning message will prompt you to confirm or cancel the action.
How to open a folder containing 3D models as a Library

1. Inthe Library view, right-click somewhere in the left side of the Library view, under all the existing folders,
and select Open Library.

A browser window opens.
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2. From the browser window, search for the folder that contains the .osb, .3ds, .obj or .fbx files that you wish to
import. That folder is considered the “library” that you chose to open.

3. Anorange book icon will appear in the left side of the Library view with the name of the folder that you selec-
ted. Click on it to see the templates contained inside on the right side of the Library view. The template thumb-
nails may take a moment to generate.

If there were any other readable files in the same folder, such as .tga files used for the 3D objects texture,
they may appear in the new library as well.

4. From the right side of the Library view, select the 3D model’s thumbnail and drag and drop it into your project,
either in the Camera or Timeline view.

A copy of the model will be copied into the appropriate models folder in the root 3D Models folder of the
Library view. Although you can store 3D models in the Library view for easy accessibility, the project can only
reference models found in the 3D Model folder of the Library view.

NOTE: If your 3D template is animated, you can preview the animation by using the Preview section of the Library
view—see Library View in the Reference Guide.
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Replacing 3D Objects

T-SBADV-010-005

Once you have imported a 3D model in the Library, you can easily replace it with a new one using the Replace 3D
Model command. This will update all instances of the model used in the project.

How to replace a 3D model

1. Inthe Library view, click the 3D Models folder to display its contents.
2. From the 3D Models folder, select the model you want to replace.

3. Right-click on the selected model and select Replace 3D Model.

A browser window opens.

4. Inthe browser, locate the 3D model file you want to replace and click Open.

The Rename Node dialog box opens.

» Click Yes to rename the model you are replacing.
« Click No to keep the existing model name.

» Select the Don't show this message again option to prevent this dialog box from opening
again, and use the same behavior as you choose now for future use of the Replace 3D
Model command.

The 3D model is updated in the Library view and in your project.
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Adding 3D Objects
T-SBADV-010-006

Once you have a 3D object in your library, you can insert into a panel just like any other element: you drag it from the
Library view to a panel and position it in the scene.

Once you placed your 3D object in a panel, you can do any of the following:

« Move, rotate, or transform your object.

« Animate the 3D Object—see Animating 3D Objects on page 389.

« Display the various layers of the 3D object.

How to insert a 3D object into a panel

1. Inthe Library view, open the 3D Models folder and then open the format folder that contains your 3D object.

2. Drag the 3D object into your panel, the Stage view, or Camera view window.

The object appears at its default size in the middle of the panel.

3. To place or modify the 3D object, use the Layer Transform ;-3 tool.
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Displaying 3D Objects
T-SBADV-010-010
Each 3D object consists of multiple layers, which you can display in Storyboard Pro. It contains the following
layers:
» Washed: A lighter version of the 3D object.
» Shaded: Graphics that add texture to the flat areas.
« Flat: Flat areas to which textures will be applied.

» Wireframe: Boundaries that define the edges of the object.

How to change the display of a 3D object

1. Inthe Thumbnails view, select the panel that contains a 3D object.
2. Inthe Stage or Layers view, select the layer that contains a 3D object.

3. Right-click and select one of the following:

» Shaded: The 3D object displays the textures that cover its wireframe.

» Washed: The 3D object is displayed with a washed-out appearance.

« Flat: The 3D object displays the surfaces that cover its wireframe.

« Wireframe: The 3D object displays the lines that define the area covered by the object.
» Wireframe on Shaded: The 3D objects displays the textures with its wireframe on top.

» Wireframe on Flat: The 3D objects displays the surface with its wireframe on top.
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Navigating 3D Space

When working in the Stage view, you can quickly navigate through a scene using the mouse buttons or
3D navigation tools.

365



Chapter 12: 3D Objects Displaying 3D Objects

Navigating with the 3D Navigation Tools

By using your left, middle, and right mouse buttons, you can rotate around in the Stage view, dolly on the Z axis,
and pan the X and Y axes. If you only have access to the left mouse button, such as when using a pen and tablet,
you can still navigate easily in 3D space.

To increase efficiency while working with the tools in Storyboard Pro, you can temporarily swap one tool for
another—see About Quick Swap Shortcut on page 273.

How to navigate 3D space using only the left mouse button

1. Inthe Stage view, do any of the following:

» Press Shift+Ctrl and left-click to rotate.
» Press Spacebar and left-click to pan.
» Press Spacebar+Alt and left-click to zoom out.

» Press Spacebar+Ctrl and left-click to zoom in.

How to navigate 3D space using the three mouse buttons

1. Inthe Stage view, hold down Shift+Ctrl and do any of the following:

» Left Mouse Button: Hold down the left mouse button and drag to rotate the view.
» Middle Mouse Button: Hold down the middle mouse button and drag to pan along the X and Y axes.
» Right Mouse Button: Hold down the right mouse button and drag to dolly on the Z-axis.

« Scroll Wheel: Roll the scroll wheel to dolly on the Z-axis.

How to navigate 3D space with the 3D Navigation tool

1. From the Tools toolbar, click the 3D Navigation tool.

2. Do any of the following:

« Hold down the left mouse and drag to rotate the scene.
« Hold down the middle mouse and drag to pan the scene.
« Hold down the middle mouse button while pressing Spacebar and drag to dolly in the Z axis.

« Roll the scroll wheel to dolly on the Z-axis.
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Navigating with the 3D Flying Navigation Tool

You can get afirst person perspective while navigating with the 3D Flying Navigation tool. By using your mouse
buttons, mouse wheel, and arrow keys, you can move through 3D space interactively.

When the 3D Flying Navigation tool is active, the cursor (hand) is not visible. You can now navigate through a
scene. When you move the mouse, the view rotates around the current view point (instead of around a fixed pivot).

You can move around in the scene by using the following:
* The mouse wheel controls the Z axis.
+ The Up/Down keys control the Z axis.
+ The Left/Right keys control the X axis.
+ ThePgUp/PgDnkeys the Y axis.

You can deactivate the tool by clicking anywhere on the interface.

NOTE: When using the 3D Flying Navigation tool with a tablet, the cursor remains visible.

How to navigate with the 3D Flying Navigation tool

1. From the Tools toolbar, click the 3D Flying Navigation tool or press Alt+W.

NOTE: You can also use the W key to temporarily override the selected tool.

2. Toactivate the tool, click on the Stage view.

The hand cursor disappears.

« Move mouse to rotate the scene.

« Roll the mouse wheel to move forwards or backwards. The more you roll the mouse wheel, the faster you nav-
igate through the scene.

« Press the arrow keys and PgUp/PgDn keys to move in all six directions. Press repeatedly to increase or
decrease speed.

4. To stop all motion, click anywhere on the interface.

The hand cursor reappears.
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Creating 2D Layers on Surface of 3D Objects

T-SBADV-010-009

Working in the Camera view, you can create a new vector or bitmap layer on the surface of a 3D object. The new
layer will be positioned at the point in Z depth on which you clicked. It is positioned perpendicular to the camera so
you can start drawing.

How to create a 2D layer on the surface of a 3D object

1. Inthe Tools toolbar, click the Create Layer on Surface ﬁ button.

A red crosshair appears in the Stage view.

2. Inthe Tool Properties, select a layer type: Vector or Bitmap.

3. Inthe Stage view, move the crosshair around (without clicking the mouse button) to see where it is pos-
sible to create a 2D layer. You can also click and drag the crosshair to display the drawing grid. The size of
the grid is constant. When it is farther from the camera, it appears smaller.

T LN 1 3 5 4Va g 7

Drawing grid

4. When you are satisfied with the position, release the mouse button.

A 2D layer is created and is positioned perpendicular to the camera.
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About 2D and 3D Obiject Interaction
T-SBADV-010-008

Now that you have a true three-dimensional space to work in, complete with matching three-dimensional objects,
you can create sophisticated storyboards that feature realistic interaction between 2D elements and 3D elements.

For example, if you had a character that wanted to hop into a 3D car, then you can use the First and Last Frame
features to easily animate the following scene:

« The character walking towards the car
« Animating the car door node opening
« The character disappearing into the 3D car object

« Animating the car door node closing

« The 3D carturning sideways and moving out of the frame

In the first frame, the 2D characteris
walking towards the pickup truck with its
door closed.

Inthe last frame, the 20 characteris
closertothe pickup truck and by
rotation, the door node on the pickup
truck. ltwas angled outto make it

appearopen.

When you play this animation, the 2D
characterwillappearto move towands
the truck as the doorslowly cpens.

By harnessing the three-dimensional nature of the car, you do not need to create extra drawings to handle the
animation of doors opening and closing, or of the car rotating to drive down the street.

You can also use the three-dimensional nature of the objects and the scene space to allow characters to walk in
front, walk behind, or even through objects without having to resize objects to create the illusion of distance. By
laying these elements out in the three-dimensional space, they can physically walk around and through these
objects, allowing you to create a more realistic storyboard that is closer to the final product.
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About 3D Object Positioning

T-SBADV-010-011

When you import a 3D object into a panel, you can place it in the 3D space much just as you would a 2D element
by clicking directly on it and dragging it into place along the X, Y, and Z planes in the 3D space—see .

When you select a 3D object in a panel, a 3D transformation bounding box appears around the object. This
bounding box allows you to transform the object in any of the following ways:

« Rotating the object on a pivot point.
« Changing the dimensions of the 3D object.
« Modifying the individual nodes in the 3D object.

Once you place your 3D object in your panel, you can create some basic animation with it using the First and Last
Frame feature. Being able to animate your 3D object allows you to create interaction between 2D and 3D
elements.

The pivot point defines the size of the arc upon which you will apply the rotation to the 3D object. When the pivot
point is in the centre of the object, the object rotates upon itself. But when you place the pivot point on the outside
of the object, the object will rotate a larger axis with the pivot point at the centre.

Rotation along the X-axis Rotation along the Y-axis
(X-axis guideline is red) (Y-axis guideline is green)

Resizing the 3D object

Rotation along the Z-axis (Resize guideline is purple)
(Z-axis guideline is blue)

In the above examples, the pivot point was moved to the side of the object for illustrative purposes. By default,
the pivot is positioned below the 3D object at its centre. Depending on the pivot point’s position, the object’s
rotation arc will change.
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When you import a 3D object, it appears in its initial size and dimensions. Using the control points on the bounding
box, you can change these dimensions of the object:

« Width (X-axis)

« Height (Y-axis)

« Length (Z-axis)

o Overall size (X, Y, Z axis in proportion)

Resizing along the Y-axis

. . (Y-axis control point is green)
Resizing along the X-axis

(X-axis control point is red)

Resizing along the Z-axis Resizing the whole 3D object
(Z-axis control point is blue) (Resize bounding box is purple)

3D objects often consist of multiple nodes or meshes that are combined to form the entire object. If you look at the
pickup truck examples in this chapter, you can see that it consists of:
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« Abody
o Fourwheels

o Two wipers

Just as you can transform the object as a whole, you can also apply transformations to the individual nodes of the
3D object.
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Rotating 3D Objects

T-SBADV-010-012

How to rotate a 3D element along a pivot point

1. Click the Layer Transform ;-3 button and select an element from your scene in the Stage view.

A bounding box appears around the element and the layer appears highlighted in purple in the Top and Side
views.

2. Drag the pivot point to the location at which you want to base the rotation.

In this example, the pivot point
(™, . isatthe centre of the pickup
\‘ 1 fruck, so you can rofate it on

\ ; the itself along the X axis.

In this example, the pivot point
is off-centre, so the truck can
be rotated on a larger arc along
the Y axis.

Pivot point

3. Usingthe X-axis, Y-axis, and Z-axis guiding lines, change the Yaw, Pitch, and Roll of the object.

As you place the cursor on the guide lines, it will change to display with axis is being changed. Use the view
windows to see how the object looks from the Camera, Top, and Side views.
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Scaling 3D Objects

T-SBADV-010-013

How to rotate a 3D element along a pivot point

1.

Click the Layer Transform :-3 button and select an element from the Stage view.

A bounding box appears around the element and the layer is highlighted in purple in the Top and Side
views.

Drag one of the X-axis, Y-axis, and Z-axis control points to change any of the following dimensions:

o Width (X-axis)
« Height (Y-axis)
« Length (Z-axis)

o Size (X, Y, Z axes in proportion)

Use the views to see how the object looks from the Camera, Top, and Side views.
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Maintaining the Size of Elements
T-SBADV-010-014

When positioning elements, you can retain the visual scale of elements as you move them in the Z-axis in the Side
or Top views. As you move drawing layers on the Z-axis, they are scaled to preserve their size in the camera.

How to position an element in the Top and Side views

1. From the Tool toolbar, select the Maintain Size £ tool.

2. Inthe Side or Top view, select a layer.

The selected layer is highlighted in pink.

—

Selected layer

3. Drag the layer to the correct depth position in the camera cone.

Your element aspect remains the same in the Camera view.

4. Toscale the element up or down in relation to its distance to the camera, select the Layer Transform ;-3 tool
from the Tools toolbar.

5. Inthe Tool Properties view, make sure the Peg Selection Mode ,; option is deselected.

The selected layer is highlighted in the camera cone.

6. Inthe Top view, drag the element sideways to position it horizontally. Hold Shift while dragging to make sure
it only moves along the X-axis.

7. Inthe Side view, drag the selected element up or down to position it vertically. Hold Shift while dragging to
make sure it only moves along the Y-axis.

375



Chapter 12: 3D Objects About 3D Object Positioning

Positioning 3D Nodes

T-SBADV-010-015
How to select individual nodes in the 3D object

1. Click the Layer Transform ;-3 button and select an element from the Stage view.

A bounding box appears around the element and the layer is highlighted in purple in the Top and Side
views.

1. Toselect a node in the 3D object, select Windows > 3D Schematic.
The 3D Schematic view displays. You can change how the hierarchy appears in this view using the
following commands:

o Zoom In/Out: Increases (zoom in) or decreases (zoom out) the magnification. You can also
press 1to Zoom Out or press 2 to Zoom In.

» Reset Zoom: Restores the magnification to its default setting.
» Reset Pan: Resets the 3D node tree to its default position.
» Reset view: Restores the 3D node tree to its default position and magnification.

You can reposition the 3D node tree in the view by pressing Spacebar and dragging the cursor inside the
3D Schematic view.

2. Select one of the nodes of the 3D object.

The selected node appears highlighted in green and a bounding box appears.

3. You can also select the nodes using Ctrl+click (Windows) or 38 +click (Mac OS X). To select all the
nodes, right-click the 3D Schematic view and select Select All.

By default, the basic node structure appears in the 3D Schematic view.
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NOTE: To show or hide a detailed hierarchy that composes the 3D element, right-click in the 3D Schematic view and
select or deselect Extended Display Mode.

4. Using the bounding box, you can make the following changes to the node:
o Its position in the 3D space

« lIts Yaw, Pitch, Roll rotation (use the pivot point to change the arc size)

« Its dimensions along the X, Y, and Z-axis
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Resetting a 3D Object's Position

T-SBADV-010-016

If you make changes to the 3D object, such as its dimensions, position, or rotation, and you want to revert back to
the object’s original settings, you do not need to delete the object and start over. You have couple of options:

« You can use the Undo command to undo any of the changes you made to the object or in the panel since
the project was last saved.

« You can use the Reset Transform command to revert to the object’s original settings (position and dimen-
sions).

The Reset Transform command will only affect the selected element, reverting it back to its default dimensions,
position, and rotation for all the frames in the panel (First Frame and Last Frame).

When you import a 3D element that contains 3D nodes, all these nodes are in their default position and
size/proportion. You can make changes to these nodes, but if you want to reset a node to its default position
(undoing all the changes you made), you can restore each node to its default settings.

How to revert the 3D object to its original state

1. Select the 3D object in your panel.

2. Select Layer > Reset Transform.

How to reset a 3D node

1. Select the node to restore by [Ctr]+clicking the node in a view or by selecting it from the hierarchical pos-
ition in the 3D Schematic view.

If you use the 3D Schematic view, you can select multiple nodes by [Ctrl]+clicking each one.

2. Select Layer > Reset Selected 3D Sub-Obijects.

The selected nodes return to their default settings.
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Snapping to Surface or Ground
T-SBADV-010-017

When working in Storyboard Pro, you can snap a 2D layer or 3D object to the 3D surface directly below it. Contact
between the layer or 3D object is maintained with the surface no matter what changes you make to your selection.
This makes it much faster to block out shots and also works with 2D artwork.

When the layer or 3D object comes into contact with the surface, its pivot connects to the 3D surface directly below
it if you are moving the mouse. If your selection is a 2D layer, you can move it on the X and Z axes; the Y axis is
controlled by Storyboard Pro allowing for quick placement around the ground plane. Also, the layer automatically
rotates to be parallel to the surface, which is useful with 2D layers. In the Tool Properties view, you can disable the
rotation parameter if you do not want to the rotation to occur.

For both 2D layers and 3D objects, the angle is retained. If needed, you can change the rotation using the rotation
controls. When snapping a layer, its lowest point snaps to the 3D surface.

Using the Snap to Surface tool, the photo behind th tercan be repositicned shere in the scena.

How to snap to a surface

1. Select the layer that contains the object with which you will snap to a surface.

2. Inthe Tools toolbar, Layer Transform -1 button.

3. Inthe Tool Properties view, click the Snap to Surface@ button.

The 3D navigation controls appear in the Camera and Stage views.
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4. Inthe Tool Properties view, how you want to use the transform options in Layer Transform controls.

« Translate: Activate this option to move the 3D object. Deactivate to keep the object in
place.

« Rotate: Activate this option if you want the 3D object to change its angle to match that of
the 3D surface beneath it. Deactivate to keep the angle of the object.

« Scale: Activate this option if you want to change the size of the 3D object. Deactivate to
keep the size of the object.

5. Position the cursor close to the centre pivot and when you see the Move Cursor "}E appear, click and drag

the 3D object to a new location. As you move, the object will rotate and scale (if you selected these
options in the Tool Properties), and adhere to the 3D surface undemeath it.

Move cursor

The photo was repositioned above
the character's head, snapping to
the 3D surface.

6. Continue moving the object around until you are satisfied with its placement.

7. Deactivate the tool by clicking the Snap to Surface I@ button again.
How to snap to the ground

1. Select the layer that contains the object with which you will snap to the ground.
2. Inthe Tools toolbar, Layer Transform :-3 button.

3. Inthe Tool Properties view, click the Snap to Surfacei button.

The 3D object snaps to the 3D surface directly beneath it.
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Chapter 13: Motion

The camera and layers in your panels can be animated. This is helpful to test the potential animation of scene
elements. In Storyboard Pro, you can add keyframes to move a camera or layer to a specific position and keep
adding keyframes and moving the camera or layer until you are satisfied with the movement. When you play back
the panels, the layer moves from one position to the next.

By default, layers are not animated. To animate a layer, you will use the Layer Transform tool. Using the Layer
Transform tool on a layer that contains no animation will affect the panel's entire duration.

NOTE: When a layer is selected and the Layer Transform tool is active, the 3D path for the layer is displayed in the
Stage, Camera, Top and Side views.

As you animate the position of a drawing layer, a motion path is created which are trajectories. Using keyframes,
you can then record key positions along the trajectory. You can produce simple and advanced motions and
trajectories.

About the Animate Mode

The Animate mode records the position, rotation, scale, skew, etc. of objects as keyframes in the Timeline view.
Turn off the Animate mode to reposition objects for the entire scene. When the Animate mode is disabled,
keyframes are not created when an object's parameters change.

To animate a layer using multiple keyframes, you must first activate the Animate mode. You can modify the object in
the panel and Storyboard Pro will transform the object from one keyframe to the next at a speed defined by the
duration of the panel.

Frame 1

Frame 100

(Left) The truck starts at frame 1 and ends at frame 200 (right). Storyboard Pro interpolates the various
positions and rotations of the truck as it moves from its initial state to its final state.

Deactivating the Animate mode clears all the keyframes and leaves the layer at the position of the current frame.
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Animating Layers
T-SBFND-009-008

By default, layers are not animated. To animate a layer, begin by setting a keyframe on the desired position. You
can then use the Transform tool to move the layer and set as many keyframes as needed for your animation. You
can then edit the keyframes and timing using the layer track controls in the Timeline view.

If you decide to delete the keyframes from a layer, you can clear all of them by clicking the Animate button. Once
cleared the keyframes are cleared, the layer remains at the position of the current frame.

How to animate a layer

1. Inthe Timeline or Thumbnails view, select a panel.

2. Inthe Stage or Camera view, select a layer.

In the Stage view, the layer is highlighted in blue.

In the Timeline view, position the playhead on the starting position of your movement.

In the Tools toolbar, click the Layer Transform ;-3 button and position your drawing in the Stage or Cam-
era view.

5. Do one of the following:

« Inthe Stage or Camera view, click the layer's Animate 3 button.
« Inthe Timeline view, click the button on the layer track.

« Inthe Tool Properties view, click the Add Keyframe button # .

The Animate button turns yellow and changes shape to indicate the presence of keyframes: A
keyframe is created on the current position of the playhead.

6. Inthe Timeline view, move the playhead to the next position where you want to add a keyframe.

In the Camera, Stage, Top or Side view, set the new position of the layer.

NOTE: You can also use the Coordinate toolbar to enter values for the translation, scale and rotation values of a
selected layer—see Coordinate Toolbarin the Reference Guide.

A keyframe is automatically created and the animation between both keyframes is set.

Once the Animate button is on, any transformation applied to your layer with the Transform tool will
create a keyframe at the current frame on the Timeline.
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Keep setting keyframes in time and space until your animation is complete.

Click the Play » button to see the animation of the layer.

The speed of the animation depends on the length of the panel, which is displayed in the Timeline view—see
About the Panel Duration on page 330.

How to clear all keyframes

1. Select a layer that contains animation. This is indicated by the yellow Animate icon.

2. Do one of the following:
« Click the Animate icon of the layer.
All keyframes are cleared and the layer remains at the position of the current frame.
o Press Ctrl+R (Windows) or 3£ +R (Mac OS X) to clear all keyframes on the current layer.

All keyframes are cleared and the layer resets back to its original position.
The Animate icon on the layer turns grey to indicate that it no longer contains information.
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Animating Layers on the Layer Track

By default, layers are not animated. To animate a layer, begin by setting a keyframe on the desired position. You
can use the Transform tool to move the layer and set as many keyframes as needed for your animation then edit
the keyframes and timing with the Layer track in the Timeline view.

Arnimate
Moda

Add Keyframe
Fesal Keylrame
Delele Keyrame
Previous
Keylama

Curmant
panal

How to add a keyframe at the current frame

1. Inthe Timeline view, drag the red playhead to the frame on which you want add a keyframe.
2. Inthe Camera or Stage view, select the layer on which you want the keyframe applied.

3. Do one of the following:

» Inthe Timeline view, click the plus button on the Layer track.

» With the Layer Transform tool :-; active, click the Add Keyframe # button from the tool properties
view.

> Inthe Stage or Camera view, click the Animate button. #

A keyframe is added in the Layer track at the exact position of the red playhead. The Animate button

turns yellow to indicate the presence of keyframes on your layer. Note that if you select a different layer or
change panels, you will no longer see the keyframes until the layer is selected again.

How to navigate between keyframes

1. Select the layer you want to see.
2. Do one of the following to navigate between keyframes within the same panel:
» Inthe track controls of the layer track, click the Previous Keyframe or Next Keyframe . button.

» With the Layer Transform tool :-3 active, click the Previous Keyframe * or Next Keyframe >
button from the tool properties view.
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How to move a keyframe

1. Inthe layer track of the Timeline view, select a layer keyframe.

The keyframe turns blue.

2. Drag the keyframe left or right within the same panel.

How to copy and paste keyframes

1. Inthe layer track of the Timeline view, select a layer keyframe.

The keyframe turns blue.

2. Do one of the following:
» Select Edit > Copy Layer Keyframe.
» Press Ctrl+C (Windows) or &£ +C (Mac OS X).

3. Move the playhead to the position within the same panel where you want to paste the keyframe.

4. Do one of the following:

» Select Edit > Paste Layer Keyframe
» Press Ctrl+V (Windows) or 3£ +V (Mac OS X).
A keyframe is pasted at the location of the playhead.

How to delete a keyframe

1. Inthe layer track of the Timeline view, select a layer keyframe.

The keyframe turns blue.

2. Do one of the following:

» Press Delete.

» Select Edit > Delete.

» With the Layer Transform tool :-; active, click the Delete Keyframe £ button from the tool properties
view.

» Inthe track controls of the layer track, click the button.

» Press Ctrl+R (Windows) or 3 +R (Mac OS X) to remove all keyframes on the selected layer.

The keyframe is removed from the Timeline view.

How to reset a keyframe

1. Inthe layer track of the Timeline view, select a layer keyframe.

The keyframe turns blue.
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2. With the Layer Transform tool ;-3 active, place the playhead over the keyframe and click the Reset Key-
frame button from the tool properties view. You can affect several keyframes simultaneously if you
selected multiple keyframes prior to the operation.

NOTE: If you selected the Focus on Mouse Enter option in the Preferences dialog box, this may
change the options in the Edit menu to the ones of the selected view.
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Animating the Camera

Storyboard Pro contains a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis

offers the possibility to create truck in and truck outs, as well as multiplane camera moves. The default camera
position is centred and backed up to 12 fields.

It is important to understand the coordinate values in Storyboard Pro, which is based on the origins of animation. In
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and measures

0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field chart. Storyboard
Pro uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the north-
south (up-down) direction and the Z axis is the forward-backward direction.

The camera is treated the same way as any other element. You can use the same tools and selection modes to
offset or animate it, but the camera is a static object.

While making camera moves, you can use the Top, Side, and Camera views.
How to animate the camera

1. Inthe Timeline or Thumbnails view, select the panel with the layer you want to animate.

2. Inthe Timeline view, move the playhead to the frame on which you want the camera move to start.
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3. Inthe Stage or Camera view, select a layer to animate and click its Animate = button.

4. Inthe Tools toolbar, click the Camera #. button.
5. Inthe Camera, Side or Top view, select the camera (the large V-shaped cone) and move it to the desired

position. In the Camera view, the camera is represented by a thin black, rectangular frame. You need to
click directly on one of the edges.

Camera in Camera view Camera in Side view

Camerain Top view

6. Inthe Tool Properties view, click the Add Keyframe # button.

7. Inthe Timeline view, move the playhead to the next frame and move the camera to its next position and
set a keyframe.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.

Repeat step 7 until your animation is complete.

9. Play back p youranimation.

388



Toon Boom Storyboard Pro 5.1 User Guide

Animating 3D Objects

Once you have imported 3D objects, you can animate them in Storyboard Pro.

How to animate a 3D element

1. From the Tools toolbar, click the Layer Transform ;-3 button, select an element in the scene, and place it in
its initial state. You can also make a multiple selection to move multiple 3D layers at once.

2. Make any of the following changes to the object:
» Position in 3D space
» Yaw, pitch, roll rotation (use the pivot point to change the arc size)

» Dimensions along the X, Y, and Z-axis
You can also make changes to the individual nodes that make up the object.

3. Inthe Layer Transform tool properties, click the Add Keyframe button # to set a keyframe.

4. Select the same element and place it in its next state. Keep setting keyframes until your animation is com-
plete.

5. Clickthe Play » button to see the animation of the element.

The speed of the animation depends on the length of the panel, which is displayed in the Timeline view—see
About the Panel Duration on page 330.
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Animating 3D Nodes

After adding 3D objects to a scene, you may want to animate a part of the object, called a sub-object. For
example, the doors of a spaceship can be animated to open.

You can only select sub-objects on one layer.

3D Schematic ==[%

I llA

How to animate a sub-object

1. Inthe Stage or Camera view, select one or more sub-objects by doing the following:

» Inthe Stage view: Use the Layer Transform i3 tool to select a sub-object. Press Ctrl to select
multiple sub-objects.
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» Inthe 3D Schematic view: Select one or more nodes.

I llA

2. Right-click and select Separate Sub-Object.
The layer containing the 3D objects is duplicated. In this new layer, the selected sub-objects are displayed
and all others are hidden. In the original layer, the selected node(s) are hidden.
The new layer is grouped with the original layer.
Any transformation in the original layer is transferred to the parent group.

<
>

If you selected multiple nodes to separate, all the sub-nodes are visible on the newly-created layer.

3. Toanimate the sub-objects, use the Layer Transform :: tool and place them in their initial state.
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4. Inthe Layer Transform tool properties, click the Add Keyframe button # to set a keyframe.

5. Select the same element and place it in its next state. Keep setting keyframes until your animation is com-
plete.

6. Click the Play » button to see the animation of the element.

Refer to Animating 3D Objects on page 389.
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Easing
For effect, you can adjust your camera or layer movements so they ease in or ease out of the keyframes.

With the Camera or Layer Transform tool selected, the Ease In/ Ease Out parameters become available in the Tool
Properties view.

Tool Properties == |3 Tool Properties == | 3

Camera tool properties

Layer Transform tool properties

How to set ease in or ease out for a keyframe

1. Inthe Timeline view, select a keyframe.

2. From the Tools toolbar, select the Camera ®. tool or Layer Transform - tool.

3. Do one of the following:

» Ease In: Inthe Ease In section of the Tool Properties view, enter the duration of the ease in after the first
frame in which the gradual change in camera or layer movement begins. For example, if you want to
slowly accelerate to the normal camera or layer speed from frame 1-10, enter a value of 10.

» Ease Out: Inthe Ease Out section of the Tool Properties view, enter the duration of the ease out after the
first frame in which the gradual change in camera or layer movement begins. Enter the number of frames
before the last frame in which the change in camera or layer movement is gradual.
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Copying and Pasting Keyframes

You can copy the position of the first frame and paste it on the last frame and vice versa-copy the position of the
last frame and paste it on the first frame.

How to copy the end position from the start position

1. Inthe Timeline view, select the panel that contains the start position to copy.

2. Select Layer > Copy Start Layer Position to End.

How to copy the start position from the end position
1. Inthe Timeline view, select the panel that contains the end position to copy.

2. Select Layer > Copy End Layer Position to Start.
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Spreading the Layer Motion

Within the same shot, you can spread the current layer motion across all panels or a specified number of panels after
the current panel.

A new layer will be added and the drawing will be duplicated for panels that do not have the same name in the
defined range.

How to spread the motion from one panel to more than one panel

1. Inthe Timeline view, select the layer with the motion you want to spread.

2. Do one of the following:

» Select Layer > Spread Layer Motion.

» Inthe Layertoolbar, click the Spread Layer Motion 2. button. You may have to add this button to the

Layer toolbar by customizing it.
The Spread Layer Motion dialog box opens.

3. Do one of the following:

« Tospread layer motion over all panels in the same shot, select the All panels in the same
shot option.

« Tospread layer motion a specified number of panels after the current panel in the same shot,
select Next panel(s) and enter or select the number of adjacent panels.

395



Chapter 13: Motion Animation Functions

Animation Functions

Using the Layer Transform tool, the Timeline view as well as the parameters in the Tool Properties view, you can
control the position of each point in a layer, the position of each keyframe in time as well as the ease-in and the
ease-out of each movement. Layer animations are however composed of functions that can be customized in
various other ways. If you need to tweak the animation of a layer in specific ways, you may have to use the
Function Editor view.

The Function Editor view displays all the functions which, internally, compose the movement of the selected
layer or of the scene's camera. A function is simply a geometric (ie: position, size, angle) component of an
animation. When you add a keyframe to a layer or to the camera, a keyframe is created for each animation
function for that layer or camera, and that keyframe stores the value for that function at the current frame. Then,
the value of the function for each frame between any two keyframes is calculated by Storyboard Pro.

Animation Functions

A layer or camera animation is composed of the following functions:

« Path X, Y and Z: The position of the object on the x, y and z axes, relative to the centre of the stage. The
default value for these functions is 0.

NOTE: In 2D scenes, the Path Z function should always be 0, as it represents the distance of the layer
relative to the camera. Changing the value of this function while in a 2D scene will convert the scene to a
3D scene.

« Path Velo: This function is used to adjust the curve of the Path X, Y and Z functions between their key-
frames.

The Path Velo is automatically generated by Storyboard Pro and has one keyframe for each keyframe on
the Path X, Y and Z functions. You cannot adjust the value of these keyframes, only the curve between
the keyframes. When you do so, the curve between the keyframes of the Path Velo function is applied to
the Path X, Y and Z functions. Basically, this allows you to adjust the ease of the object's movement on all
three axes simultaneously, using a single function.

In summary, you can edit the Path X, Y and Z function to adjust the position of the object on different
keyframes, and the Path Velo function to adjust the pace at which the object moves between keyframes.

NOTE: The value of this function always progresses from 0 to 1.

« Scale X, Y and Z: The size of the object on the x, y and z axes relative to its original size. The default
value for these functions is 1.

NOTE: The Scale Z function only has a visible effect on 3D objects.

« Angle Z: The rotation angle of the object around the z-axis.
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« Quaternion X, Y and Z: If you have rotated the object on any angle but the z-axis, a Quaternion (3D rotation)
function is used to track and adjust its angle on each of the x, y and z axes.

Quaternion Velo: Like the path function, the Quaternion function uses a Velo function to determine the ease
of the rotation between keyframes. The values of the keyframes in the Quaternion Velo function cannot be
adjusted, only the curve between its keyframes. This curve is applied to the Quaternion X, Y and Z functions,
allowing you to adjust the ease of the object's rotation on all three axes simultaneously, using a single func-

tion.

Function types

The functions are of the following types:

. Ease: An ease function determines how the interpolation between each keyframe is timed based on the
length of the ease, in frames, before and after a keyframe. A function subjected to an ease-in will speed up for
the length of the ease-in, then continue at constant pace until it reaches the next keyframe. A function sub-
jected to an ease-out will start out progressing at a constant pace, then start slowing down when the ease-out

begins.

Path Velo and Quaternion Velo functions are ease functions.

Span of left ease-out Span of right ease-in
Angle of left ease-out Angle of right ease-in
Keyframe

« Beazier: A bezier function determines how the interpolation between each keyframe is timed based on Bez-
iers that extend left and right of each keyframe, creating Bezier curves between keyframes.

Scale functions as well as Angle Z functions are Bezier functions.

Left Bezier Keyframe Right Bezier
handle handle
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« Coordinate: The X, Y or Z component of a 3D Path or 3D Quaterion functions. These functions do not
have Beziers nor ease. Their curve is determined by the Velo function to which they are associated
(ie: Path Velo or Quaternion Velo).

For Path functions specifically, each keyframe can have a tension, continuity and bias setting which will
influence on how the trajectory of the animation path is curved between each keyframe.

® © " ._.:a . @
X i / " /
: "y
; b y * : ’ :
of % ’ , 7 | ’ |
of ~, ¥ X
® ® @ ‘@ ® ® @ ®
Default motion path Motion path with Motion path with Motion path with
curve between three added tension added continuity added bias
keyframes

Path X, Y and Z functions as well as Quaternion X, Y and Z functions are coordinate functions. However,
only Path functions have tension, continuity and bias parameters.

The Path X function associated with the ease function displayed
above. Its timing is the same as the ease function. but you
cannot control the function's ease directly.

Bezier Curves and Ease curves

Bezier curves and Ease curves are very similar at first glance. Their differences are mostly conceptual,

The most noticeable difference between a Bezier and an ease function is that an ease function will cause a curve
to occur only for the duration of an ease. So, with an ease function, the values between two keyframes can ease-
in, then progress at a constant pace, then ease out. In contrast, in a Bezier function, the values between two
keyframes will either curve all throughout or, if the Bezier handles are in their neutral position, progress at a
constant pace all throughout.

A Bezier and an Ease function with the same values and parameters, side to side.
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Tweaking an Animation Path

Using the Function Editor view, you can fine-tune the animation of a layer or camera movement in very specific
ways.

How to view a layer or the camera's function curves
1. Inthe Stage or Camera view, select a layer that contains animation. This is indicated by the yellow Animate
icon.

2. From the Tools toolbar, click one of the following:

« LayerTransform -3 button for layer animation.

o Camera B button for camera animation.

NOTE: To switch between layer and camera functions, click the Show Camera Functions 'l.r button at the
bottom of the Function Editor view. When the button is selected, camera functions are displéyed in the graph,
When deselected, layer functions are displayed.

3. Inthe Tool Properties view, click the Function Editor view _ button.

The Function Editor view is blank until you select the layer containing the functions you want to display.

4. Inthe list of functions, check the functions that you wish to edit, and uncheck the ones you want to leave
unchanged so that they do not clutter the graph view to the right.

You can change the colour of the function's representation in the graphic by double-clicking on the coloured square to the
right of the function's name. This can help you identify the functions visually.

How to edit an Ease (Velocity) function

1. Inthe function editor view, identify which functions are the Velocity (Velo) functions. If necessary, uncheck
all other functions in the functions list so that only the velocity function you want to edit to appear.

2. If your functions appear too big, too small or cropped out of the view, adjust the graph view by doing one of
the following:
« Click onthe Reset View button to adjust the graph view to the size of the functions that are cur-

rently visible.
« Click onthe Reset View Vertically button if you only want the functions to fit within the view ver-
tically.
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« While holding Spacebar, click and drag on the graph to pan it.

» Press 1tozoom in on the graph or 1 to zoom out of the graph.
3. Select one of the keyframes of one of the velocity function.

4. Inthe top of the function view, right of the Frame and Value fields, expand the extra parameters section. If
the arrow is pointing towards the right , click on it so that it points to the bottom.

The Left Angle , Left Ease Out °—, Right Angle and Right Ease In fields display at the right of
the Frame and Value fields.

NOTE: Since extra parameters depend on the type of keyframe selected, if keyframes from several
different types of functions are selected at the same time, no extra parameters will be visible. To remedy
this, discard the selection by clicking anywhere inside the function graph, then click on the keyframe you
wish to select.

5. Inthe Left Ease Out °— field, type in the amount of frames the ease-out before this keyframe should last.

6. IntheRight Easeln - field, type in the amount of frames the ease-in after this keyframe should last.

7. By default, the angles of each ease is horizontal. You can adjust the Left Angle and the Right Angle if you
want the ease to be less abrupt or if you want to reverse the curve of the ease. To do this, do one of the fol-
lowing:

« Click on one of the points left and right of the selected keyframe and drag it along the circle to adjust
the angle of the ease on that side of the keyframe.

« Typeinthe desired angles in the Left Angle and Right Angle fields.

How to edit a Coordinate function

1. Inthe function editor view, identify which functions are the coordinate (Path X, Path Y and Path Z) func-
tions. If necessary, uncheck all other functions in the functions list so that only they are visible.

2. If your functions appear too big, too small or cropped out of the view, adjust the graph view by doing one of
the following:
« Click onthe Reset View button to adjust the graph view to the size of the functions that are cur-

rently visible.
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« Click onthe Reset View Vertically button if you only want the functions to fit within the view ver-
tically.

« While holding Spacebar, click and drag on the graph to panit.

o Press 1tozoom in on the graph or 1 to zoom out of the graph.

3. Select one of the keyframes of one of the coordinate functions.

4. To adjust the value of the coordinate, click on the keyframe and drag it up or down, or type in a new value in
the Value field at the top.

5. To adjust the position of the keyframe in time, press and hold Alt, then click on the keyframe and drag it left or
right. This will adjust the position of the keyframe in time for all corresponding coordinate functions (X, Y, Z
and Velo).

6. Inthe top of the function view, right of the Frame and Value fields, expand the extra parameters section. If
the arrow is pointing towards the right , click on it so that it points to the bottom.

The Tension , Continuity /¢ and Bias fields display at the right of the Frame and Value fields.

NOTE: Since extra parameters depend on the type of keyframe selected, if keyframes from several different
types of functions are selected at the same time, no extra parameters will be visible. To remedy this, discard
the selection by clicking anywhere inside the function graph, then click on the keyframe you wish to select.

7. Inthe Tension field, enter a value between -1 and 1. A positive tension will reduce the curve of the path
between keyframes. A negative tension will increase it.
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8. Inthe Continuity field, enter a value between -1 and 1. A positive continuity will cause the path to curve
beyond the trajectory between each keyframes. A negative continuity will have a reverse effect.

@ L) o

& ® @ ® @ ®

Neutral continuity Pesitive continuity Negative continuity

9. Inthe Bias field, enter a value between -1 and 1. A high bias will make the curve more straight before the
keyframe and more curved out after it. A negative bias will make the curve more curved out before the key-

frame and more straight after it.

@ o @
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Meutral bias Pesitive bias MNegative bias

NOTE: Tension, Continuity and Bias settings are applied for all the functions in the same path (Path X,
Path Y and Path Z) simultaneously.

How to edit a Bezier function

1. Inthe function editor view, identify which functions are the coordinate (Path X, Path Y and Path Z) func-
tions. If necessary, uncheck all other functions in the functions list so that only they are visible.

2. If your functions appear too big, too small or cropped out of the view, adjust the graph view by doing one of

the following:
« Click onthe Reset View button to adjust the graph view to the size of the functions that are cur-

rently visible.

« Click onthe Reset View Vertically button if you only want the functions to fit within the view
vertically.

« While holding Spacebar, click and drag on the graph to pan it.

o Press 1tozoom in on the graph or 1to zoom out of the graph.
3. Select one of the keyframes of one of the coordinate functions.

4. To adjust the value of the coordinate, click on the keyframe and drag it up or down, or type in a new value
in the Value field at the top.
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5. To adjust the position of the keyframe in time, press and hold Alt, then click on the keyframe and drag it left or
right. This will adjust the position of the keyframe in time for all corresponding coordinate functions (X, Y, Z
and Velo).

6. Do one of the following to adjust the point's Bezier handles:

« Locate the yellow arrows pointing towards the left and towards the right of the keyframe. By default,
those arrows will be at the same position as the keyframe. You can click and drag on the left Bezier
handle to adjust the curve at the left of the function, or on the right Bezier handle to adjust the curve at
the right of the function.

Bezier handles in their neutral position

« Inthe top of the function view, right of the Frame and Value fields, expand the extra parameters sec-
tion. If the arrow is pointing towards the right , click on it so that it points to the bottom. The Left Length
.., Left Angle , Right Length _~ , and Right Angle fields will appear at the right of the Frame
and Value fields. You can use these fields to adjust the angle and length of their respective Bezier
handles relative to the keyframes.
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NOTE: Since extra parameters depend on the type of keyframe selected, if keyframes from several
different types of functions are selected at the same time, no extra parameters will be visible. To
remedy this, discard the selection by clicking anywhere inside the function graph, then click on the
keyframe you wish to select.
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Chapter 14: Camera

T-SBFND-009-003

In the Stage view, the camera is displayed as a frame that matches the aspect ratio of your chosen resolution.

V=_1T4

Snapshot of the same scene exported to a bitmap
image with Static Camera preservad.

As seen in the Stage view

You can enhance your animatics by adding camera movements to the scenes. You can restrict camera movements to one

panel or spread it out across an entire scene/shot. An example of a camera movement would be if you wanted the camera
to go from a wide shot and then zoom in to a close up.

Camera movements are created in much the same way as setting the Static Camera frame, but you will work with

keyframes in the Timeline view to set the different camera positions over time. Once again you will use the Camera tool to
animate the camera.

In this example, the camera starts further out
(green frame) and zooms in on the character
on the left (red frame).

405



Chapter 14: Camera Positioning the Camera

Positioning the Camera

You can move the camera’s position using the Camera tool.

You can also set up the Static Camera position using the Camera tool properties—see Camera Tool Properties in
the Reference Guide.

How to position the Static Camera using the Camera tool

1. Inthe Timeline view, select a panel within the scene in which you want to adjust the camera.

2. Inthe Tools toolbar, select the Camera #. tool.

The camera frame is displayed. It is represented by a black box. The default camera frame is set to 12
fields.

3. Do one of the following to modify the Static Camera:

» Toposition the selected panel along the Z-axis to create a truck in or truck out movement, drag the top-
left corner of the camera frame up or down when you see the Truck {} icon. To change the zoom

level, change the Focal Length field in the Tool Properties view.

» Torotate the Static Camera on the X and Y axes, drag when you see the Rotation (:) icon. Hold the
Shift key while rotating to restrict movement to the X or Y axis, depending on the aX|s on which you
started dragging.

» Torotate the Static Camera on the Z axis, position the cursor outside one of the corners of the camera
frame. When you see the Rotation (:)Z icon, drag to rotate.

» Tomove the centre pivot point, position your the cursor over the centre point and when you see the
drag « icon, drag to move in the X or Y axis. Hold down the Alt key when dragging the center point to

move it on the Z axis. The farther you drag the mouse, the faster the camera moves.
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Resetting the Camera

If necessary, you can remove all the keyframes in your scene, and revert back to the original Static Camera.

How to reset camera animation

1. Inthe Timeline view, select the scene on which you want to reset the camera animation.

2. Do one of the following:
» Select the Camera &. tool, and in the Tool Properties view, click the Reset Camera g button.

» Select Camera > Reset Camera.
All camera keyframes for the selected scene are deleted and the scene’s Static Camera is reset.
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Copying and Pasting the Camera

If you need to reuse a camera position, you can copy and paste it from one scene to another. It is not necessary
to have the Camera tool selected to do this.

@ Storyboard Pro

Animatic
Copy and Pasting the Camera
——

: -_ Toon Boom

Qriginal

How to copy and paste the camera position

1. Inthe Timeline view, select the scene that contains the Static Camera to copy.

2. Select Camera > Copy Camera from Selected Panels.

The Static Camera in this scene is
| displayed in green because the
Camera tool is not active

3. Inthe Timeline view, select the scene to which you want to paste the copied camera information.
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In this scene, the Static Camera is
still set to its default 12 fields,
displayed here as a black frame

Now this scene has the same
Static Camera as the original
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About the Stage and Camera Views

You can use the Stage view or the Camera view to place your camera.

In the Stage view, the perspective is from a fixed point in space, as if were standing on the stage looking at the
various elements. As you add your keyframes and change the focus and rotation of the camera, you can see how
the camera changes over time.

If you switch to the Camera view to preview the scene, the perspective is from the camera lens, so you can see
exactly what the camera captures as it moves from one keyframe to another.

HEmEoE

The Camera view displays the current frame from the point of view of the camera. Because the camera at the first keyframe is facing the
spaceship, you see the side face of the ship.

Because the perspective in the Stage view is locked at the default position, it displays the objects from that perspective. The ship in this
example is in the same position as above, but from the Stage view perspective; its angle is different.
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Therefore, if you make changes to the camera position, especially if you change the camera’s focus, use the
Camera view to preview the camera move accurately.
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About Camera Moves
T-SBFND-009-004

Camera keyframes enable you to modify the position of your camera and have it change over time. The camera
keyframes are coordinates indicating the position of your camera on a particular frame. In order to create any camera
movements, you must set at least two camera keyframes.

With Camera keyframes, you set the camera to go from one position in the frame to another, over a defined number
of frames. You can also to control the velocity at which the camera attains its final position.

@ Storyboard Pro

Animatic
About Camera Mowves

_ Toon Boom
c Original

Keyframes appear as grey diamonds or half diamonds in the Timeline view. The space between keyframes in the
Timeline view represents the number of frames it takes for the camera to move from one keyframe to the next, which
determines the speed.

When a keyframe is selected in the Timeline view, it is displayed in blue. Camera keyframes are displayed in the
Timeline view only, in a strip above the panel thumbnails. The first and last keyframes in a scene appear as half
diamonds, while any in between are displayed as full diamonds.

 Barabove panel thumbnails
displays keyframes

Selected keyframe

In the Timeline view, when the first keyframe of the panel is selected, the rectangle that defines the camera frame,
along with a large X that quarters the camera frame, is highlighted in green. When the last keyframe is selected,
these elements appear in red. If you have any keyframe between the first and last selected, then these elements will
appear in blue.

413



Chapter 14: Camera About Camera Moves

Camera frame is green when the first keyframe is ) Camera frame is red when the last keyframe is
selected selected

Camera frame blue when any keyframe between
the first and last is selected

These are the default camera keyframe colours. You can use the Preferences dialog box to choose your own
camera keyframe colours. When you do, the new colours will used in the Camera and Stage views, as well as in
the different export formats of your storyboard.

If you want to create a truck in or truck out (a move along the Z-axis), you can use the manipulators in the Top or
Side views, (you can also click on the upper-left corner of the frame in the Camera view). If you select the arrow
pointing along the Z-axis and drag the manipulators from that arrow instead of from the centre point of the
manipulator circle, your movements will be locked to that axis. This is useful if you do not want to accidentally
displace the up and down or left and right position of your camera frame.

Remember that the light-blue arrows in the Camera view do not necessarily indicate backward and forward
movements. If your second camera frame appears larger or smaller than the initial camera frame position, then
you can be sure that a camera truck in or truck out was made.

Truck-in
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Adding Keyframes

In order to create any animated camera for a scene, you need at least two keyframes. Create these keyframes
before you change the position of the camera if you plan to move it.

How to add a keyframe at the current frame

1. Inthe Timeline view, drag the red playhead to the frame on which you want add a keyframe.

2. From the Tools toolbar, select the Camera . tool.

3. Do one of the following:

« Select Camera > Add Camera Keyframe at Current Frame.

« Inthe Tool Properties view, click the Add Keyframe # button.

Keyframe

A keyframe is added in the Timeline view at the exact position of the red playhead.

How to add a keyframe at the beginning of the current panel

1. Inthe Timeline view, select the panel on which you want to add a keyframe.

2. Do one of the following:
» Inthe Tools toolbar, click the Camera &. tool.
» Select Tools > Camera.

3. Do one of the following:

» Select Camera > Add Camera Keyframe at Beginning of panel.
» Inthe Tool Properties view, click the Add Keyframe at Beginning of Current Panel # button.

In the Timeline view, a keyframe is added at the beginning of the selected panel.
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How to add a keyframe at the end of the current panel

1. Inthe Timeline view, select the panel on which you want to add a keyframe.

2. Do one of the following:

» Inthe Tools toolbar, click the Camera &. tool.

» Select Tools > Camera.

1. Do one of the following:

» Select Camera > Add Camera Keyframe at End of panel.
» Inthe Tool Properties view, click the Add Keyframe at the End of Current Panel #: button.

A keyframe is added in the Timeline view, at the end of the current panel.

How to use the Copy and Paste commands to add keyframes

1. Inthe Timeline view, click to select a camera keyframe.

The keyframe turns blue.

Sef40:0
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2. Inthe Stage view, click the camera keyframe.

3. Do one of the following:
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» Select Edit > Copy Camera Keyframes.
» Press Ctrl+C (Windows) or &£ +C (Mac OS X).

» Select the Camera . tool. In the Tool Properties view click the Copy Camera from Selected Panels g,
button.
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4. Move the playhead to the position within the same scene where you want to paste the keyframe.

40:23

If-\,{ e

5. Do one of the following:

» Select Edit > Paste Camera Keyframes.
» Press Ctrl+V (Windows) or 3£ +V (Mac OS X).

40:23

» Selectthe Camera ®. tool, and in the Tool Properties view, click the Paste and Fit Camera on
Selected Panels g, button.

NOTE: You can copy/paste several keyframes simultaneously if you selected multiple keyframes before
performing the operation.
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Deleting Keyframes

When you no longer need keyframes, you can delete them from the Timeline view.

How to delete keyframes from the Timeline view

1. Select the keyframe(s) to delete.

2. Do one of the following:

» Select Edit > Delete Selected Camera Keyframes.

» Select the Camera . tool, and in the Tool Properties view, click the Delete Selected Keyframe
button.

» Press Delete.

How to delete a keyframe at the current frame

1. Inthe Timeline view, place the red playhead on the frame that contains the keyframe to delete.

2. Select Camera > Remove Camera Keyframe at Current Frame.
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Animating Keyframes

T-SBFND-009-005

The position of the camera keyframes is set in much the same way as the Static Camera, using the Camera tool

in the Stage view. You must do this for every keyframe you created, so the camera moves from one keyframe to
the next when played back.

NOTE: This section shows you how to setup a 2D Camera movement. When using the Camera in 3D space, new

manipulators become available—see 3D Objects on page 357 to learn more about 3D camera moves and framing
your 3D scene.

NOTE: Enabling the Camera Label in the Stage view can be very helpful when manipulating
keyframes. You can do this via the Stage view status bar.

How to position camera keyframes in a 2D project

1. Do one of the following:

« From the Tools toolbar, select the Camera =

'a

tool.

« Select Tools > Camera.

2. Inthe Stage view, select the camera keyframe to modify.

3. Use one of the following methods to modify the camera keyframe:
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o TruckIn, Truck Out: To position the selected keyframe along the Z axis, creating a truck in or
truck out movement, drag the top-left corner of the frame when you see the Truck @ icon.

N\

When you release the mouse, the keyframe is set, and blue arrows appear to indicate the

direction of the camera movement. In this case, it would be zooming out from position A to
position B.

« Rotate: To rotate the selected keyframe, drag the top-left corner of the frame when you see the
Rotate () icon.

N\
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« Move: To move the selected keyframe, drag the frame from the centre pivot point or the
outer edge of the camera frame when you see the Drag 41-. icon.
C

0
LAl

Keyframe B was dragged to the right of keyframe A. When the Camera pans, it will pan
from left to right.

« Nudge: You can also nudge the selected keyframe by pressing the arrow keys on your key-
board.

At this point, if you wanted to, you can select the B position keyframe and move it to a new location. When
you play back the scene, the camera will move from position A to B.
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Timing Keyframes

If you need to change the frame or timing of a keyframe in the Timeline view, there are a few different ways to do
this. Note that camera keyframes can only be moved to a new location within the same scene.

The following two methods are useful when you want to move a keyframe to a new location, or cut and paste a
keyframe.

To synchronize or snap the keyframes as you move them, see About Keyframe Sync Mode on page 426 and
Snapping Keyframes and Sound Tracks on page 425.

How to drag camera keyframes to a new location in the Timeline view

1. Inthe Timeline view, select one or more keyframes.

The keyframe turns blue.

2. Drag the selected keyframe left or right to choose a new position in time. You can only drag it to a new loc-
ation within the current scene.

While you drag the keyframe, its position relative to the scene is displayed in a black box. The number of
frames is also displayed from the original position the new keyframe will be located.

Number of frames you
13:13 (-00:13) are moving this
keyframe.

The current time,
relative to the scene.

How to using the Cut and Paste commands to move keyframes

1. Inthe Timeline view, select one or more keyframes.

The keyframe turns blue.

SEa0:01
[NRRERENNRNNRNRRNEN] WENENRNNENRENNERNNENI
4

3 5 4

2. Select Edit > Cut Camera Keyframes or press Ctrl+X (Windows) or 3£ +X (Mac OS X).

The keyframe is removed and copied to the Clipboard.
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3. Within the same scene, move the red playhead to the position on which you want to paste the keyframe.

4. Select Edit > Paste Camera Keyframes or press Ctrl+V (Windows) or £ +V (Mac OS X)).
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Snapping Keyframes and Sound Tracks

If you turn on snapping, camera keyframes and sound tracks snap to the beginning and end of each panel, each
sound track, or the red playhead when dragging.

How to turn snapping on or off

1. Do one of the following:

» At the bottom-left of the Timeline view, click the Snapping -+« button.

» Right-click the Timeline view and select Snapping.

NOTE: Snapping settings can be overridden by holding the Shift key.
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About Keyframe Sync Mode

When you change the duration of panels, add, delete or drag-and-drop scenes and panels, it affects the
placement of keyframes.

Setting the keyframe syncing to the None option will keep your keyframes exactly where they are when you
change the panel duration. You will lose keyframes not within the scene range.

Setting the keyframe syncing to the Relative to Panels option will reposition all the keyframes within the selected

panel, relative to where they were placed in the panel. When a panel is deleted, all keyframes within the deleted
panel will also be deleted.

Setting the keyframe syncing to the Relative to Scene option will reposition all the keyframes within the selected
scene, relative to where they were placed in the panel.
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Syncing Keyframes

There are three keyframe syncing options that affect keyframes when changing the duration of panels. Depending
on the option you set, the keyframes will be repositioned accordingly.

How to change keyframe syncing settings
Do one of the following:

« Select Camera > Keyframe Sync Mode > None, Relative to Panel or Relative to Scene.

« Inthe Timeline view, right-click the area with the camera keyframes and select Keyframes Sync Mode >
None, Relative to Panel or Relative to Scene.
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Spreading Camera Motions Across Panels

T-SBFND-009-007

A camera movement is not restricted to a panel. Keyframes for a particular camera movement can span multiple
panels within the same scene.

How to spread a camera movement across multiple panels of a scene

1. Inthe Timeline view, select the panel that contains the camera movement you want to span over multiple
panels.

2. Select the keyframe you want to move to a new panel.

3. Drag the selected keyframe to another panel within the scene.
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About 3D Camera Moves

With your scene enabled for 3D, you can rotate your camera on all three axes in the Camera view, as well as in the
Top and Side views. As you pass your cursor over the camera manipulators, the cursor changes to indicate this axis
on which you will be performing the rotation. Think of the X, Y and Z axes as poles that you can clamp your camera
to in order to rotate on that pole or axis. For example, the Y-axis would be a pole that extends from north to south. If

you clamp your camera to that pole, your camera would actually move from side to side, or be rotating around that
vertical axis.

In the Camera view, hover the cursor over:

+ The N and S points on the manipulator circle will bring up the X-axis cursor (:)x. This means that if you pull up

or down on these points, you will be rotating your camera on the X-axis, the axis that runs horizontally, or
from east to west, in the Camera view.

Rotation on the X-axis

Camera view Side view Top view

» The E and W points on the manipulator circle will bring up the Y-axis cursor (:)y. This means that if you pull

towards the left or right on these points, you will be rotating your camera on the Y-axis, the axis that runs
vertically, or from north to south, in the Camera view.

Rotation on the Y-axis

1

Camera view Side view Top view

* Anywhere but the points on the manipulator circle will bring up the generic rotation cursor (:) . Inthe Camera
view, this cursor represents a rotation on the Z-axis.
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Rotation on the Z-axis

Camera view Side view Top view

These cursors will obviously differ depending on which view you are in. For example, in the Top view, hovering
your cursor over the manipulator circle will bring up the Y-axis cursor instead of the generic rotation cursor. In the
Top and Side views, there are no points on the manipulator circle, but rather three rings that each control rotation
on one of the three axes. Two of these axes are seen as lines instead of rings from the perspective.
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Animating the 3D Camera

Not only can you move 2D and 3D objects in 3D space, but you can also move and animate your camera in this 3D
space as well. This makes for impressive animatics and is also a great way to show off imported 3D objects. If the
first frame does not do justice to your 3D camera movement in a printed or PDF version of your storyboard, you can
add snapshots to better illustrate those wide sweeping, 3D camera movements.

How to animate the 3D camera

1. Besure you are in the Camera view. You can also use the Top and Side views for further clarity if needed.

2. Inthe Tool Properties view, click the Add Keyframe :# button. Even if the playhead is not at the start of the
currently selected panel, a keyframe will be added to the first frame of that panel.

NOTE: If the Timeline view is not displayed, select Windows > Timeline.

3. Inthe Camera view, use the Camera &. tool and adjust the camera manipulators to change the camera’s
position and rotation—see About 3D Camera Moves on page 429.
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4. Do one of the following:

» Inthe Timeline view, move the playhead to the frame on which where you want to place your final
camera position. In the Tool Properties panel, click the Add Keyframe # button to current frame.

» Click the Add Keyframe #: button at the end of current panel.

A keyframe is added to the selected location.

5. Inthe Camera view, with the Camera ®. tool selected, use the camera manipulators to move the camera

into its final position. If you do not see any manipulators in the Camera view, your second keyframe might
not be selected in the Timeline view.

Manipulators

T———

First keyframe camera position

NOTE: If the playhead is not at the correct keyframe, in the Tool Properties panel, click the Go to Selected
Keyframe button to move your playhead there.

6. Continue to adjust your camera move until you are satisfied. In the Timeline view, use the red playhead to
scrub back and forth between keyframes to view the smooth, interpolated movement. Adjust the camera
position on the first or last frame or add more keyframes between the first and last keyframes.

From the Camera view Status Bar, use the Camera Mask to get a better sense of what the exact
scene framing will look like.
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For information about the options available in the Camera tool’s Tool Properties, see About Camera Moves on page
413.
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Aligning 2D Layers with the Camera

While working with layers, you may want to align specific layers with the camera, so any time you adjust the
camera, the layer is always in full view. You can set a different alignment for each layer. The default behaviour is
that the camera is not aligned with layers.

How to align a layer with the camera

1. Inthe Layers view, select a layer to align with the camera.

Layer alignment options

Selected layers

2. From the Layer Alignment section, select one of the following:

. ‘ No Alignment: The layer is independent of the camera.

If the layer is set to No Alignment and you switch to Face Camera, the offset and scale is retained but
the rotation is removed.If the layer is set to No Alignment and you switch to Pin to Camera, all layer
transformation is reset and animation is removed.

If the layer is set to No Alignment and you switch to Pin to Camera, all layer transformation is reset and
animation is removed.

- B Face Camera: The layer is oriented to face the camera, so it rotates around its pivot point to always
face the camera, but does not move with the camera.

If the layer is set to Face Camera and you switch to Pin to Camera, all layer transformation is reset and
animation is removed.

If the layer is set to Face Camera and you switch to No Alignment, the offset and scaling are retained.
You should change the rotation keyframes so the layer faced the camera at the current frame.

. n Pin to Camera: The layer is oriented to the camera's perspective. Essentially the layer always
moves with the camera.

If alayeris set to Pin to Camera and you switch to No Alignment or Face Camera, the layer stays at its
position at the current frame.
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If alayeris set to Pin to Camera and set it back to No Alignment or Face Camera, the layer
transformation is combined with the camera. The layer is left in place at the current frame.
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About the Camera Path

You can adjust the Tension, Bias, and Continuity parameters on keyframes and control points by selecting the
point in the Timeline view and using the Keyframes and Control Points toolbar.

Continuity controls the smoothness of a transition between the segments joined by a point.

e )

A Continuity of -1 sharpens the transition on either side

A Continuity of +1 rounds out the transition, creating
of the keyframe

two gentle curves on either side of the keyframe
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» Tension controls how sharply the path bends as it passes through a control point or keyframe.

A Tension of -1 increases the curve on either side of A Tension of +1 sharpens the curve on either side of
the keyframe the keyframe

+ Bias controls the slope of the path so that it flows towards one side of the motion point or the other.

A Bias of -1 favours the left side of the keyframe A Bias of +1 favours the right side of the keyframe

437



Chapter 14: Camera About the Camera Path

Adding Control Points

You can change the camera path from one keyframe to the next by adding control points to the trajectory.

How to add control points to a trajectory

1. Inthe Timeline view, select the scene on which you want to modify the camera trajectory.

2. From the Tools toolbar or the Tools menu, select the Camera ®. tool.

3. Inthe Stage view, place the cursor over the trajectory between two keyframes.

4. When you see this icon [y, click and drag the trajectory to reshape it.

5. A control point is added when you let go of the mouse button.

. o

Now, instead of the camera going from A to B in a linear fashion, there is a slight curve to the trajectory.
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6. Click the control point to move it and to reshape the trajectory if desired. You can also select the control point
in the Stage view, Top view or Side view and click Delete. You do not have to go to the Timeline.
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Deleting Control Points

Control points are visible in the Timeline, but you can only move them in the Stage view. To delete a control point,
you must go to the Timeline. A control pointed is represented by a small dot between keyframes.

How to delete a control point
1. Inthe Timeline view, select the control point which represented by a small dot between keyframes.

The control point turns blue.

LUl [IHI:Id?i[IH:I'IIIIIIml;lﬁ_;_;lIIIIIIIIIIIIIIIIIIIIIIIIII
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2. Press Delete to remove the selected point.

The trajectory reverts to its original shape.
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Adjusting the Curve of a Camera Movement

When you animate a camera movement with more than two keyframes, the path of the camera follows a curve that
touches every keyframe in its animation. Using the Keyframes and Control Point toolbar, you can adjust how the
path curves before and after each keyframe in the camera's trajectory.

When a camera keyframe is selected, the Keyframes and Control Point toolbar gives you access to three settings
that can be applied to that keyframe. Each setting can have a value ranging from -1 to 1. When all fields are set to
their default value, 0, the curve is constant and even. Here is an example opf how each setting can affect the
camera path:

« T (Tension): A positive tension will reduce the curve of the path between keyframes. A negative tension will

increase it.
L+ o @
@& ® @ ® @ @®
Meutral tension Positive tension Megative tension

« C (Continuity): A positive continuity will cause the path to curve beyond the trajectory between each key-
frames. A negative continuity will have a reverse effect.

@ L) o

& ® @ ® ® @

Neutral continuity Positive continuity Negative continuity

« B (Bias): A high bias will make the curve more straight before the keyframe and more curved out after it. A
negative bias will make the curve more curved out before the keyframe and more straight after it.

@ ] @

® ® ® ® ® ®

Meutral bias Positive bias Megative bias

How to adjust the Continuity, Tension and Bias parameters of a keyframe or control point

1. Add the Keyframes and Control Points toolbar to your workspace by doing one of the following:
« Inthe top menu, select Windows > Toolbars > Keyframes and Control Points.

« Right-click on a toolbar or on the empty space around a toolbar and select Keyframes and Control
Points.

The Keyframes and Control Points toolbar appears
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2. Inthe Tools toolbar, select the Camera % tool.

3. Inthe Timeline view, select the keyframe or control point you want to adjust.

4. Inthe Keyframes and Control Points toolbar, enter values between -1 and 1 in the Continuity, Tension,
and Bias fields until the path before and after the selected keyframe is the way you want it to be.

How to set defaults for the Continuity, Tension and Bias parameters for keyframes and control points

1. Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).

The Preferences dialog box opens.

2. Select the Camera tab.

3. Inthe Keyframes and Controls Points section, enter the defaults for Tension, Continuity and Bias, based
on your preferred settings.
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Chapter 15: Sound

T-SBFND-009-010

When you decide that you want to add sound to your storyboard, you must first prepare the sound outside of
Storyboard Pro.

To work with sounds in Storyboard Pro, add one or more audio tracks into which you import the sound sequences.
You can then organize the sounds by placing them in audio tracks, mixing sound levels, and editing the part of the
sound sequence you will use.

You can preview your panels with sound at any time by playing back an animatic of the current panel or the entire
storyboard using the controls in the Play toolbar.

To import sounds and view audio tracks, display the Timeline workspace.
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About Audio Tracks

You can create an audio track in which you can import one or more sounds. You can add an unlimited number of
tracks to your project to help you organize your work. For instance, you can have a track for all dialogue or a

separate track for each character’s dialogue. You can create a track for ambient sound, music, or significant sound
effects.
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Adding Audio Tracks

You can add new audio tracks to your project. To do so, you must work in the Timeline view—see Importing Sound
Clips on page 453.

How to add an audio track

1. Do one of the following:

« Select Sound > New AudioTrack.

« Inthe Timeline view, right-click the area below the thumbnails and select New AudioTrack.
« Inthe Sound toolbar, click the New Audio Track «» button.

Once you add a new audio track, you are ready to import a sound.

How to add an audio track

1. Do one of the following:

« Select Sound > New AudioTrack.

« Inthe Timeline view, right-click the area below the thumbnails and select New AudioTrack.
« Inthe Sound toolbar, click the New Audio Track <« button.
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Deleting AudioTracks

You can delete an audio track at any time. When you do so, all the sounds in the audio track are also deleted. You
must work in the Timeline view.

How to delete an audio track

1. Inthe Timeline view, select the audio track you want to delete.

2. Do one of the following:

» Select Sound > Delete Current Audio Track.
» Right-click the audio track and selectDelete Current Audio Track.
> Inthe Sound toolbar, click the Delete Current Audio Track < button.

The selected audio track is deleted from the Timeline view.
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Muting Audio Tracks

You can mute all or some of the audio tracks in your project. When all audio tracks are enabled, you can quickly
isolate one audio track by muting all the others at once.

How to turn the sound on or off for all audio tracks

>

In the Playback toolbar, click the Sound ) button to enable audio playback.

How to turn on the sound of selected audio tracks

1. Inthe selected audio track, click the Sound On/Off button to turn that track’s sound on or off.

A

RR_LineD1_Celina_
Audio track off a1

Audio track on

How to mute all other audio tracks

» When all audio tracks are enabled. Click the Sound button on the one audio track you want to leave on

while holding down the Alt key. All other audio tracks will be muted. Click again while holding the Alt key to
turn them all back on.
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Locking Audio Tracks

T-SBFND-009-013

By default, an audio track follows the timing changes made to your project. This means that if you extend the
duration of a panel, the audio track following this panel will move in consequently. However, you can lock an audio
track to prevent it from following the timing change. Locking a track will also prevent you from making unwanted
changes to the audio timing. Once it is locked, it is impossible to drag and modify the sound clips or import more
sound into this track.

@ Storyboard Pro

Animatic
Locking Audio Tracks

_ Toon Boom
- Qriginal

When your project's audio tracks are all unlocked, you can lock them all at the same time. When all audio tracks are
unlocked, you can quickly decide to lock all but one.

How to lock an audio track

1. Inthe Timeline view, click the open lock icon of the audio track you want to lock.
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How to unlock a locked audio track

1. Inthe Timeline view, click the locked icon of the audio track you want to unlock.

How to lock all audio tracks

1. Inthe Timeline view, make sure that all audio tracks are unlocked, or else, the Lock All Audio Tracks com-
mand will be unavailable.

2. Select Sound > Lock All Audio Tracks.

NOTE: If an audio track is already locked, the Lock All Audio Tracks command will toggle to Unlock All Audio

Tracks.

How to unlock all audio tracks at once

1. Inthe Timeline view, make sure there is at least one locked audio track. Otherwise, the Unlock All Audio
Tracks command will be unavailable.

2. Select Sound > Unlock All Audio Tracks.

How to lock all other audio tracks

1. Inthe Timeline view, hold Alt and click the open lock icon of the audio track you want to remain unlocked.

All other audio tracks are locked.
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2. Click once more on the audio track's open lock icon while holding the Alt key to unlock all audio tracks.
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About Sound Clips

Once you have created audio tracks, you can now import sound clips. Sound clips are edited bits of sound which
are already edited and in digital format, ready for import.
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Importing Sound Clips
T-SBFND-009-011

You can import sound clips (.wav, .aif, .aiff, or .mp3) into an audio track at the first frame or at the current frame. If
the sound clip does not already exist in your project, Storyboard Pro copies the file from its present location to the
audio folder in your storyboard project folder. You must work in the Timeline view.MP3 files are not recommended for
long sequences because it is a compressed file format. For optimal results, use .wav or .aif sound files when
working on a long sequence.

How to import a sound clip
1. Inthe Timeline view, select an audio track.
2. Do one of the following:

« Select File > Import Sounds.
« Right-click the audio track and select Import Sound Clips.
« Inthe Sound toolbar, click Import Sound Files -+ button.

The Import Sound Clips dialog box opens.

Cancel

3. Select a sound clip to import by typing in the file path or using the Browse button to search for the file.

4. Inthe Target Sound Track section, specify whether you want to create an audio track and import the clip into
it orimport the clip into the selected audio track.
5. Inthe Target Frame section, indicate the frame at which the sound will begin.

6. If you selected the Current Sound Track option, specify the Import Rule:

« Overwrite Existing Sound Clips: By default, when you import a sound, it will replace sounds
that exist in the target frames.

« Fill Next Available Frames: Imports the sound clip into the first available empty frames after
any existing sound selection.
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7. Select the Set as default and don’t show dialogue again option if you want to use the current settings
the next time you import sound and open a browse box to select a sound automatically.
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Deleting Sound Clips

How to delete a sound clip

1. Inthe Timeline view, select the clip you want to delete. You can create a multiselection to delete more than
one at the same time.

2. Do one of the following:

» Right-click the sound clip and select Delete Selected Clips.
> Inthe Sound toolbar, click Delete Sound Clip -~ button.

» Press Delete.
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Selecting All Sound Clips

By using a series of keyboard shortcuts, it is possible to select a sound clip and all the sound clips following it at
once. These options are also available on panels—see About the Panel Duration on page 330.

How to select all sound clips on a single sound track forward

1. Inthe Timeline view, hold Ctrl+Alt and click the sound clip from which you want the selection to start.

The sound clip and all the ones following it on the same audio track, up until the end of the storyboard
project, are selected.

How to select all sound clips on all audio tracks forward

1. Inthe Timeline view, hold Ctrl+Shift+Alt and click the sound clip from which you want the selection to
start.

The sound clip and all the sound clips following it on all audio tracks, up until the end of the storyboard
project, are selected.

RR_Line01_Celina_

RR._Line02_Terrance_01.wav

How to select all panels and all sound clips forward

1. Inthe Timeline view, press Ctrl+Alt+Shift (Windows) or 35 +Alt (Mac OS X) and click the panel from which
you want the selection to start.

The panel and all the panels following it, up until the end of the storyboard project, as well as all the sound
clips in all audio tracks starting from the position of the play head are selected and can be moved together.

RR_Line01_Celina_

RR._Line02_Terrance_01.wav

» If you drag the selection forwards, the panel preceding the selection will be extended.
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» If you drag the selection backwards, the panel preceding the selection will be reduced until it reaches the
minimum length allowed (one frame), then the second panel preceding it will be reduced. Overlapping
sound clips will be overwritten by the ones that are selected.
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Moving Sound Clips

You can move sound clips from the same audio track or different audio tracks at the same time.

How to move sound clips

1. Inthe Timeline view, draw a selection across the clips you want to select. You can also Shift+click to cre-
ate a contiguous multiple selection or Ctrl+click (Windows) or §¢+click (Mac OS X) to create a non-con-

tiguous selection.

RR._Line04_Terrance_02 wav

RR._Line02_Terrance_01.wav

2. Dragthe clips to the new position and release.
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Marking Sound Clips with Colours

Marking sound clips with a custom colour allows you manage them and quickly identify them. This option is also
available for marking panels—see Storyboard Structure on page 81.

How to mark a sound clip with colour

1. Inthe Timeline view, select one or more sound clips. They can be on different audio tracks.

RR._Line04_Terrance_02.wav

2. Right-click on the selection and select one of the following: Set Colour > Red, Orange, Yellow, Green,
Blue, Purple or Custom. If you choose custom, the Colour Picker dialog box opens from which you can

select a colour.

The selected sound clips change to the colour you chose.

RR._Line04_Terrance_02.wav

How to reset the sound clip colour

1. Inthe Timeline view, select the sound clip you want to reset the colour to default. You can also make a mul-
tiple selection.

2. Right-click on the selection and select Set Colour > Default Colour.

The selected clip colour resets to the default colour.

NOTE: The default colour of sound clips is blue-green. However, you can change this in the Preferences dialog box.
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Splitting a Sound Clip

You can cut one clip into many pieces if you want to move parts of a sound to another location.

How to split a sound clip

1. Move the red playhead to the frame at which you want to begin the second sound clip that results from the
split.

RR_Line1l_Celina_06.wav

2. From the top menu, select Sound > Split Clip at Current Frame or right-click in the audio track area of
the Timeline view and select Split Clip at Current Frame.

RR_Line11_Celina_06.wav

The sound clip is split. You can move both parts independently.
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Adjusting the Sound Length and Timing
T-SBFND-009-012

Most of the editing must be done to your sound before it is imported into Storyboard Pro. There are however, a few
tools to help make minor adjustments.

@ Storyboard Pro

Animatic
Adjusting the Sound Length and Timing

- Toon Boom
- Qriginal

You can snip the beginning and/or end of the sound clip.

You can play back the sound to hear the edited version of the clip. The original sound clip is not modified. You can
drag the edges of the edited clip to expand it to its original length.

NOTE: Verify that sound is enabled and that the audio track you want to work with is not muted. You may find it easier
to edit sound when the waveform is visible.

How to adjust the length and timing of a sound clip
Do one of the following:

« Position your cursor at the starting edge of a clip. Drag to the right to shorten it at the desired timing. As you
drag, the timing is displayed.

The beginning of the original sound file is cut from playback.

Cursor placed at beginning of sound clip Shortened sound clip
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« Position your cursor at the ending edge of a clip. Drag to the left to shorten it at the desired timing. As you
drag, the timing is displayed.

The end of the original sound file is cut from playback.

RR_Line11_Celina_06.wav

Cursor placed at end of sound clip Shortened sound clip
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Scrubbing Sound Clips

When scrubbing, the sound will play forward or backwards as you scrub through the Timeline view.
How to enable sound scrubbing

Do one of the following:

« At the bottom-right of the Timeline view, click the Sound Scrubbing 1 button.

« Select Sound > Sound Scrubbing.
« Inthe Timeline view, right-click and select Sound Scrubbing.

« Inthe Sound toolbar, click the Sound Scrubbing = button.
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About Sound Display

These are the different features that will help make things clear while working with sound.

464



Toon Boom Storyboard Pro 5.1 User Guide

Setting the Audio Track Height

By default the size of the soundtracks is set to small, but you can modify the size of the different soundtracks of
your project individually to increase or decrease their heights.

How to set the audio track size

» Inthe Timeline view, right-click a soundtrack and select Track Size > Mini, Small, Medium or Large.
The soundtrack is resized.

RR_Line01_Celina_ " RR_Line03_Celin I  RR_Line01_Celina_ 'RR_Line03 Celin

RR._Line02_Terrance_01.wav

Small track size

RR._Line02_Terrance_01.wav

Large track size
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Displaying Waveforms

How to display the sound clip's waveform

1. Do one of the following:

» At the bottom of the Timeline view, click the Menu =/ button and select Show Waveform.

» From the top menu, select Sound > Show Waveform or right-click in the audio track area of the
Timeline view and select Show Waveform.
» Inthe Sound toolbar, click the Show Waveform button. By default, this toolbar only contains the

essential options. You can add the Show Waveform option by right-clicking on the toolbar and
selecting Customize.

" RR_Line03_Celin

R_Line02_Terrance_01.wav RR._Line04_Terrance_02 wav
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Adjusting Volume Envelopes

Once the waveform is displayed, you can also display the playback sound level for each sound clip.

How to display and adjust the volume levels of a sound clip

1. From the top menu, select Sound > Show Waveform.

2. Toenable the Show Volume Envelope option, do one of the following:

» At the bottom of the Timeline view, click the menu = button and select Show Volume.

» Select Sound > Show Volume Envelope
» Inthe Timeline view, right-click in the audio track area and select Show Volume.

» Inthe Sound toolbar, click the Show Volume Envelope = button. You may need to add this button to the
toolbar. Right-click the toolbar and select Customize.

A blue line, indicating the sound level, is displayed for each sound sequence.

RR_Line 1

3. Hold down the Alt key and click the line to add a new marker. A plus sign (+) on the cursor indicates that a
keyframe will be added. You can add an unlimited number of volume keyframes.

RR_Line11_Celina_06.wav RR_Line11_Celina_06.wav

T

Volume keyframe

4. Drag an existing marker to adjust the volume at a specific frame. When you drag a volume keyframe, the cur-
rent dB level is displayed.

RR_Line11_Celina_06.wav

v T B |
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5. Hold the Alt key and click an existing volume keyframe to delete it. A minus sign (-) on the cursor indicates
that the marker will be deleted.

RR_Line11_Celina_06.wav

The slope of the line indicates how quickly the sound changes from one level to another. If the slope is
steep, the change is abrupt. If the slope is less inclined, the volume changes at a more gradual rate.
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Showing or Hiding the Sound Clip Name

By default, the clip's file names are displayed on the audio blocks. However, you can hide the names if needed.

R_Line02_Terrance_01.wav RR_Line04_Terrance_|

Clip names are displayed

How to hide the name of each sound in the audio tracks

1. Do one of the following:

At the bottom of the Timeline view, click the menu =/ button and deselect Show Sound Clip Names.

>

In the Timeline view, right-click and deselect Show Sound Clip Names.

>

2. Toshow the clips names again, re-enable the Show Sound Clip Names option.
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Recording Sound Guides

You can record sound directly from Storyboard Pro and insert it in the timeline.

How to record sound in Storyboard Pro

1. Inthe Timeline view, add a new audio track if needed.

2. Position the play head at the frame you want your recording to begin and select the audio track you want to
record your sound guide in.

3. Select File > Import > Record Sound.

The Record Sound dialog box opens.

Cancel

4. Inthe Target Sound Track section:

« Select the New Sound Tracks option to create a new audio track for the recording.

« Select the Current Sound Track option to record in the selected audio track.

5. Inthe Target Frame section:

« Select the First Frame option to start the recording on the first frame of the project.

« Select the Current Frame option to start the recording on the current frame.

6. Inthe Import Rule section:

« Select the Overwrite Existing Sound Clips option so that the resulting audio clip will be
position in its entire length, overwriting any existing clip positioned in its way.

« Select the Fill Next Available Frames option so that the recording do not overwrite the pos-
ition of existing audio clips that are on the same audio track.

7. Inthe Record Sound Clip section:

« Name the audio clip.
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o Click the Record @ button to start the recording.
o Click the Stop g button to stop the recording.

« Click the Play » button to preview the recording.

8. Click OK.

The recording is imported in the selected audio track of your project.
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Chapter 16: Transitions

By default, transitions between scenes are defined as cuts; the action in the panel at the end of a shot finishes and
immediately displays the next scene. In Storyboard Pro, you can add one of two custom transitions between
scenes: Wipe or Dissolve.

Dissolve

The Dissolve transition is the typical cross-dissolve transition effect. The images gradually fade in and out to a

smooth scene transition.
|) / ”\"

?ll‘:‘ I
“\

Edge Wipe

By default, the Edge Wipe will pass from one scene to the other with a wiping motion from left to right. It is possible
to customize the effect to change the direction of the wiping motion.

Clock Wipe

By default, the Clock wipe will pass from one scene to the other with a circular clockwise wiping motion. It is
possible to customize the direction of the wipe as well as the starting angle.

By default, the Slide transition will pass from one scene to the other by translating the next scene panel from the
right side of the camera frame. It is possible to customize the angle and direction.
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Adding Transitions

A transition is inserted between scenes (shots).

How to add a transition

1. Inthe Timeline view, select the scene in which you want to add a transition.

2. Do one of the following:

» From the Storyboard toolbar, click the New Transition &y button.

» Select Storyboard > Add Transition.
» Right-click the scene thumbnails and select Add Transition.
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Deleting Transitions

How to delete a transition

1. Select atransition to remove.

2. Do one of the following:

» Inthe Storyboard toolbar, click the Delete Transition <y button.

» Right-click the transition and select Delete Transition.
» Select Storyboard > Delete Transition.
» Press Delete.
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Changing the Transition Type

By default, the transition is a dissolve, but you can easily change it to an edge or clock wipe by selecting the
transition, and either double-clicking it or changing it in the Panel view.

How to change the transition type

1. Inthe Timeline or Thumbnails view, select the transition.

2. Do one of the following:

« Inthe Panel view, select Edge Wipe, Clock Wipe or Dissolve from the Type menu.

Panel (%

« Inthe Timeline view, double-click the selected transition in the Timeline view to change the transition type
between Dissolve, Edge Wipe, and Clock Wipe.

1_A_1 0(4/4)01 1_A_1(1/1) 04:00

How to change the starting angle of a Clock Wipe transition

1. Inthe Timeline or Thumbnails view, select the Clock Wipe transition.

2. Inthe Panel view, set the starting angle by doing one of the following:

o Click the Direction knob.

« Typeinavalue in the text field.

Panel =

3. Inthe Direction menu, select the wipe direction: Clockwise or Counterclockwise.

477



Chapter 16: Transitions Changing the Transition Duration

Changing the Transition Duration

You can also use the Panel view to change the duration of the transition.

How to change the transition duration

1. Inthe Timeline view, select a transition.

2. Do one of the following:

« Position the cursor on the left or right side of the transition and drag to lengthen or shorten.

Panel (%

» Select Storyboard > Change Transition Duration and enter a new duration in frames.
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Chapter 17: Pitching the Storyboard

Storyboard Pro has a Pitch Mode workspace that was is created specifically for pitching a storyboard or concept to a
group of people.

You can use the Pitch Mode workspace to add comments based on the given feedback. A special Comments layer
can automatically be added to your drawing for making notes and corrections.

NOTE: The Camera view displays your drawings, camera moves and transitions. You do not have access to your
layer listin this mode. All layers that are enabled are shown.
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Accessing and Exiting the Pitch Mode Workspace

The Pitch Mode workspace can be accessed in the same way as other default workspaces, but you must exit the
mode in a different way.

You can easily exit by using the Exit Pitch Mode button at the bottom of the screen. This is useful when in full
screen mode and you can no longer access the menus at the top of the interface.

How to access the Pitch Mode workspace

Do one of the following:

« From the View toolbar, click the Pitch Mode O button.

« From the Workspace toolbar, select Pitch Mode.

« Select Windows > Workspace > Workspace > Pitch Mode.
o Press 8.

How to exit the Pitch Mode workspace

« Inthe Control Panel view, click the Exit Pitch Mode r button.

NOTE: To exit the workspace, you can also switch to another workspace using the top menu.
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Displaying Captions

As you play back your storyboard, your audience may want to see the dialogue or action notes as subtitles. For that
reason, the Pitch Mode workspace lets you select one of the caption fields available in your storyboard and display it
at the bottom of the Camera view. By default, the Dialogue caption is selected.

In the Control Panel view, you will find a drop-down menu that will allow you to select the captions in your
storyboard. Note that you cannot select a sketch caption. Only text captions can be selected.

Caption tools

If you want to make the selected caption field larger, you can hide the Caption tools area.

How to select a caption

» From the Caption menu, select a caption to display below the Camera view.

How to hide the Caption Tools area

» Inthe Caption Tools area, click the Arrow button to hide the settings.

How to show the Caption Tools area

» Hoverthe cursor at the edge of the caption, when you see a splitter cursor, drag left to reveal the Caption
Tools area.
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Customizing Captions

By default, the selected caption field has a black background and a gray font. You can change the colours and the
font.

How to customize the look of captions

In the Caption Tools area, do any of the following:

Fontcolour  Background colour

» Font: Click Font. In the Select Font dialog box, set the font parameters.

WOLF
"Then I'll huff, and I'll puff, and I'll blow your house in."

» Font Colour: Double-click the font colour swatch. In the Colour Picker window, select a new colour.

» Background Colour: Double-click the background colour swatch. In the Colour Picker window, select
a new colour.
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Navigating the Storyboard

Navigating through your storyboard lets you see how your project is progressing. You can scrub through a scene,
view a specific point in the scene, see it in slow motion, or check a particular section.

The slider lets you scrub through all the panels in a scene. You will see the camera motions and the transitions at the
speed you want by sliding left or right. Sliding left brings you to the beginning of the scene and sliding right brings you
to the end. Transitions, camera moves, and all panels will be displayed.

As you select or scrub through panels and scenes, the name and number of the current scene and panel are
displayed.

Current scene name Current panel name

Auto-play camera moves

As you navigate through the panels of your storyboard by either using shortcuts, clicking on panels or using the
navigation buttons, you can automatically play the camera moves.

NOTE: When you select a panel that contains a camera move, it will automatically play. If you do not want to see the
transitions or camera motions, deselect the Camera Mode # button in the Control Panel view.

How to navigate through your storyboard
Do one of the following:

e PressAandF
o Select panels in the Thumbnails view

« Usethe Previous Panel «4q and Next Panel ps buttons

How to automatically play camera moves

» Inthe Control Panel, select the Auto-play Camera Moves option.

_— T
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Drawing Revisions

When presenting a storyboard, you will most likely receive comments and feedback. The Pitch Mode workspace
allows you to easily draw comments and corrections over your panels.

In Pitch Mode, you do not have access to the drawing layers in your panels, so when you draw corrections on
your panel, a new Comments layer is automatically added for you on top of the panel. You can use this new
Comments layer the same way as any other drawing layer in your scene.

Adding comments and corrections in Pitch Mode is easy. As soon as you start drawing with the Brush tool, the
Comments layer is added.

If you no longer require a Comments layer, you can delete it while you are still in the Pitch Mode workspace.

Eraser tool Colour swatches

Brush tool Erase Layer

Brush or Eraser size

NOTE:

In the Pitch Mode workspace, you can use the Onion Skin feature to see your previous and next panels—see About
the Onion Skin on page 268. To see the onion skinning, deselect the Camera Mode # button in the Control
Panel view.

How to add comments and corrections

1. Inthe Comments section of the Control Panel view, select the Brush ~ tool or press Alt+B.

2. Click a colour swatch to select a colour for your brush.

3. To change the colour, double-click the colour swatch to open the Select Colour dialog box. Select a new
colour—see Colouron page 283.

EEEEEENEN
EEEEEEEN
lours

Add to Cus
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4. Set the brush size and click OK.
5. Inthe Stage view, add your comments and corrections.

6. Inthe Camera view, draw your correction.

A Comments layer is added on top of your layers.

7. Toaccess the Comments layer, click the Exit Pitch Mode | button.

The Pitch Mode workspace is closed.

How to erase a correction

» Inthe Comments section of the Control Panel, click Eraser & tool or press Alt+E.

How to delete a comment

» Inthe Comments section of the Control Panel, click the Erase Layer i button.

The Comments layer is deleted. You cannot delete any other layers.
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Recording Voice Annotations

Since the Pitch Mode workspace is all about reviewing and approving your storyboard, you can also record voice
annotations—see About Voice Annotations on page 495.

The Voice Annotation tools are not displayed by default. You must enable the sound tools in the Preferences
dialog box.

How to enable the sound tools

Do one of the following:

» Select Edit > Preferences (Windows) or Storyboard Pro > Preferences (Mac OS X).
» Press Ctrl+U (Windows) or &£+, (Mac OS X).

In the Preferences dialog box, select the Pitch Mode tab.

In the Control Panel section, select the Display Sound Tools option.

|

Vaoice annctation togls

The voice annotation tools appear in the Control Panel.

How to record voice annotations

—_

. Verify that you have a working voice recording device and that it is correctly connected to your computer.

In the Thumbnails view, select the panel on which you want to record a voice annotation.

Display the Panel view.

« Ifthe Panel view is not part of your current workspace, select Windows > Panel.

In the Voice Annotations section, click the Record Voice Annotation g button.

The Record a Voice Annotation dialog box opens.

o Click the Record @ button to begin recording.
o Click the Stop g button to stop the recording.

o Clickthe Play p button to preview your recording.
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NOTE: If you try to record your voice and the voice recording device is improperly connected or malfunctioning, a
warning message will appear. If this happens, check the voice recording device.
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Navigating the Storyboard

Navigating through your storyboard lets you see how your project is progressing. You can scrub through a scene,
view a specific point in the scene, see it in slow motion, or check a particular section.

The slider lets you scrub through all the panels in a scene. You will see the camera motions and the transitions at
the speed you want by sliding left or right. Sliding left brings you to the beginning of the scene and sliding right
brings you to the end. Transitions, camera moves, and all panels will be displayed.

As you select or scrub through panels and scenes, the name and number of the current scene and panel are
displayed.

Current scene name Current panel name

Auto-play camera moves

As you navigate through the panels of your storyboard by either using shortcuts, clicking on panels or using the
navigation buttons, you can automatically play the camera moves.

NOTE: When you select a panel that contains a camera move, it will automatically play. If you do not want to see
the transitions or camera motions, deselect the Camera Mode # button in the Control Panel view.

How to navigate through your storyboard
Do one of the following:

o« PressAandF
o Select panels in the Thumbnails view

« Usethe Previous Panel =4 and Next Panel ps buttons

How to automatically play camera moves

» Inthe Control Panel, select the Auto-play Camera Moves option.

_— T
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Chapter 18: Storyboard Supervision

Storyboard Pro goes beyond the storyboard and animatic creation tasks by providing powerful tools for the
supervision of a storyboarding project.

Project managers, storyboard supervisors and artistic directors now have an efficient supervision tool to help them
track the changes and communicate their feedback, corrections and such to the storyboard artists.
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About Track Changes

T-SBADV-007-001

In Storyboard Pro, you can track changes in the storyboard’s panels. This allows the storyboard artist to integrate
any comments the supervisor has made, and the supervisor can easily track any changes and validate or
comment on them.

Modified panels are outlined in yellow. You also have the possibility to write revision notes about the changes.
This visual indicator allows the supervisor to rapidly locate any panels which have changed. A new temporary
caption field is added to the tracked panel's Panel view.

3 (1/1) 05:00
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Tracking Changes

T-SBADV-007-002

Storyboard Pro lets you automatically detect any changes in your project, and adds a visual indication in the
Thumbnails and Timeline views.

You can also track changes by date. If a storyboard becomes very large, it may be easier to track changes made on
a specific date.

You can add notes to the Revision Notes caption. The caption only appears once the panel is marked as changed.
Note that the text you type here will also be displayed in the Track Changes dialog box during the validation
process—see Tracking Changes on page 491.

How to enable auto tracking

1. Select Storyboard > Track Changes > Auto Tracking Mode.

Once the Auto Tracking Mode is enabled and you edit a panel, a yellow rectangle appears around the panel in
the Thumbnails and Timeline views.

2. Edit your panels either by drawing or modifying caption text. If applicable, add comments in the
Revision Notes caption.

How to track changes by date

1. Select Storyboard > Track Changes > Track Changes by Date.
The Search by Date dialog box opens.

2. Use the From and To fields to define a particular time range in which to track changes. If you want to track
changes done on one specific day, place that day’s date in both the From and To fields. Click the From button
and select the first date. Only the dates at which a change occurred will be available. The other dates will
appear dimmed.
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3. Select the first date and click OK.

4. Repeat these steps to select the To date.

The first line displays the number of panels found in the storyboard that have been modified during the
defined time range, and the panel that is currently selected.The second line displays information about the
currently selected panel, such as which scene it is part of, the name of the panel, and the date it was last
modified.

6. Usethe Next and Previous buttons to jump from one modified panel to the next.

7. Use the menu in the bottom-left corner to modify the status of the selected panel.

« Mark as Changed: Marks the currently selected panel as being edited on the current date;
this is the default option. Click the button to activate it.

» Mark Scene as Changed: Marks the scene of the currently selected panel as being edited
on the current date.

» Mark All as Changed: Marks all the storyboard panels as being edited on the current date.
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Validating Changes
T-SBADV-007-003

When you use the Auto Tracking Mode feature, you can use the Validate Changes option to follow up on these
changes.

How to validate changes

1. Select Storyboard > Track Changes > Validate Changes.

The Track Changes dialog box opens.

» Useful information is displayed on the top part of the dialog box:

» Thefirst line displays the number of panels found in the storyboard that were modified while the Auto
Tracking Mode was enabled, as well as which of the panels that fits the description is currently selected.

» The second line displays information about the currently selected panel, such as which scene it is part of,
the name of the panel, and the date it was modified.

2. Use the Notes field to enter text about the selected panel. This information will be available in the tracked
panel Panel view in the Revision caption. If notes were added in the Revision Notes caption field, they will be
displayed in the Revision Notes field of the Track Changes dialog box.

NOTE: This caption is temporary; it will be removed when the change is validated.
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3. Use the Validate menu to select a validation option:

» Validate: Validates the currently selected panel. This is the default option, simply click on the button to
activate it, there is no need to use the drop-down menu.

» Validate All: Validates all of the panels in the storyboard. Click on the arrow button to display the drop-
down menu and activate the command.

» Validate Scene: Validates the scene that the currently selected panel is part of. Click on the arrow
button to display the drop-down menu and activate the command.

4. Use the Next and Previous buttons to navigate from one tracked panel to the other.
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About Voice Annotations

T-SBADV-007-004
In Storyboard Pro, you can provide the storyboard artists with voice annotations as well as written notes.

After the voice annotation has been recorded, the Voice Annotations section indicates the total number of
annotations, displaying the order of the current voice annotation in the sequence and the total number of voice
annotations associated with the panel. As you record voice annotations, they accumulate in sequence without being
overwritten. You can select and play back any of the annotations.
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Recording Voice Annotations

T-SBADV-007-005

Recording a voice annotation is quite simple. All you need is a microphone correctly connected to your computer
and Storyboard Pro.

How to record voice annotations

—

Verify that you have a working voice recording device and that it is correctly connected to your computer.
2. Inthe Thumbnails view, select the panel on which you want to record a voice annotation.

3. Display the Panel view.

« If the Panel view is not part of your current workspace, select Windows > Panel.

4. Inthe Voice Annotations section, click the Record Voice Annotation g button.

The Record a Voice Annotation dialog box opens.

» Click the Record ¢ button to begin recording.
o Click the Stop g button to stop the recording.

o Click the Play » button to preview your recording.

NOTE: If you try to record your voice and the voice recording device is improperly connected or malfunctioning, a
warning message will appear. If this happens, check the voice recording device.
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Playing Voice Annotations
T-SBADV-007-006

Once a voice annotation has been added to a panel, you can play it back using the playback controls.

How to listen to voice annotations

1. Inthe Thumbnails view, select the panel with the voice annotation which you want to listen to.

2. Inthe Panel view, do any of the following in the Voice Annotations section:

« Click the Next Voice Annotation »» and Previous Voice Annotation «¢ buttons to select the

annotation you want to listen to. Use the order display in the Voice Annotation section to see
which annotation is selected.

« Click the Play Voice Annotation » button to play back the selected voice annotation.

« Click the Stop Voice Annotation g button to stop playback.
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Deleting Voice Annotations
T-SBADV-007-007

When a voice annotation is no longer required, you can delete it.

How to delete a voice annotation

1. Inthe Thumbnails view, select the panel with the voice annotation you want to delete.

2. Inthe Panel view, do any of the following in the Voice Annotations section:

« Click the Next Voice Annotation »» and Previous Voice Annotation <¢ buttons to select

the annotation to delete. Use the order display in the Voice Annotation section to see which
annotation is selected.

« Click the Delete Voice Annotation «, button.
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Project Management
T-SBADV-002-001

To distribute work to different storyboard artists, it is necessary to split up a large storyboard into different files.
Once the work on all of the parts is completed, you must reassemble them into the same project to complete the
storyboard.

Once the various parts of your project are complete and you are ready to bring it all back into your master project,
you can easily merge and replace the changed scenes.
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Splitting Storyboards

T-SBADV-002-002

Using the Split option, you can divide your storyboard into two parts. Each part can be saved as a different file.
You can choose to save either the first half of the project, the last half of the project, or both. You can also choose
to preserve the original project intact, or to remove the panels from the original project. The selected panel
determines the point of division.

How to split a storyboard project

1.

In the Timeline, drag the red playhead to the panel where you want the split to take place.

2. Select File > Project Management > Split.

Cancel

The Split Storyboard window opens.

Select one or both options:

» Export before selected panel: Exports all panels before the selected panel into a new file.
» Export after selected panel: Exports all panels after the selected panel into a new file.
For one or both options:

» Use the browse button to choose a location and create a file name.

» Select the Include selected panel option to include the selected panel in the export.

Select the Remove exported panelsfrom current project option to remove the panels you selected to
export from the current project. If you do not select this option, you will be left with an intact copy of your
storyboard, along with one or both divisions as a new project file(s).

NOTE: If you chose to export both the panels before and after the selected panel along with this option, then only
a blank panel will be left in your current project.
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Extracting Storyboards
T-SBADV-002-003

You can divide a storyboard into several parts. Each export portion of the storyboard will be saved as a different file.
You can choose to save an intact copy of the entire storyboard or divide the project into separate files.

How to extract different scenes from your storyboard

1. Select File > Project Management > Extract.

Cancel

The Extract Storyboard window opens.

2. From the Scenes section, select a scene or press Shift+click to include more than one scene.

NOTE: The number of panels in a scene is indicated under the Panels heading. These panels cannot be divided,
and you cannot split a scene.

3. Click Extract Selected Scenes.

A browser window opens.

4. Choose a name and location for this new project file and click Save.

The project name and location appears under the Path heading in the Projects section.
5. Todelete an extracted project, select it from the Projects section, and click Remove Selected Projects.

6. Select the Remove extracted scenes from current project option. This option determines if you will have
an intact copy of the entire storyboard.
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Merging Storyboard Projects

T-SBADV-002-004

After dividing your storyboard project by splitting or extracting it, you may need to reassemble all the files into a
single project file. By merging several projects into one, you can have one final Storyboard Pro project.

How to merge different storyboard files into a single project

1.

Select File > Project Management > Merge.

The Merge Storyboard window opens.

1e numbers will be updated in e of number c

Import Project

Dialogue

Action Notes

Crossed-out fields will not be imported.

Cancel

Click Import Project.

In the browser window that opens, search for a Storyboard Pro project file that you want to merge with your
current file and click Open.

The file name appears in the top section of the Merge Storyboard window.
Continue adding files until you have all the files you need.

Use the Move Up and Move Down buttons to reorganize the files into the order in which you want them to
be imported in relation to your current file.

Select any unwanted project file names and click Remove Project to delete them from the list.

In the Captions section, select a caption from under one of the project name headings and click Remove
Caption to keep them from being imported into the merged file.

Removal will be indicated by highlighting that caption in grey. If you change your mind about removing a
caption, select that caption and click Add Caption to reinstate it.
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8. If you created new caption fields in your current project, the captions associated with certain panels in the pro-
ject files that you intend to import and merge will not correspond. You may also have new dialogue or notes
that you would like to insert into the proper fields, but would like to keep the old information just to be safe.

Use the Move Up and Move Down buttons to move the caption text around. If you move a caption from a
certain project to a blank row, a new field will be created for this text in the project’s panel window.

9. By default, scene numbers will be updated to avoid number conflicts, however, you can force the scene's
numbering by selecting the Force scenes humbering option. If you do this, you must enter a number in the
Start scene number field. This number will be assigned to the first scene in import project list section above.

10. Select the Use project name as scene's prefix option if you want the imported project’s name to remain on
all its scenes in the new merged file. The scene’s new name will be its number in the merged file, prefixed by
the file it originated from.

11. Select the Create hew soundtracks option if you want to have the sound element from each imported pro-
ject appear in a separate soundtrack (row) in the Timeline. Otherwise, all the sound elements will appear in
the same soundtrack in the new merged project.

NOTE: This option is only available if you do not select the Force scenes numbering option.
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Inserting Scenes
T-SBADV-002-005

After splitting your storyboard project, you may need to reintegrate the scenes from a separate project file. You
can do this by using the Insert option.

How to insert the scenes from a different project file into your current project

1. Inyour current project, in the Timeline view, move the red playhead to the point at which you want to insert
the new scenes, or simply click a scene to select the insertion point.

2. From the top menu, select File > Project Management > Insert.

The Open Storyboard Project window appears.

3. Search for the *.sboard file you are looking for and click Open.

All scenes from the selected project file appear after the red playhead in the Timeline.
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Merging and Replacing Scenes
T-SBADV-002-006
In order to merge and replace scenes, you must keep a copy of the master project intact.

What is the difference between merging and merging/replacing? When merging a project, two projects are combined
into one; each project appears sequentially in the Thumbnails and Timeline views. A merge and replace integrates
scene changes back into the master project. Any scenes that were changed are replaced with the new one. As an
option, you can keep a copy of the original files for verification purposes.

NOTE: When merging projects, the sounds in the master project will now move in order to sync with the panels.The
sounds will follow panels based on their name, therefore, itis important to lock scenes and panels names prior to
distributing the different scene's extracts, in order to preserve them.

How to merge and replace scenes

1. Open your master project.

2. Select File > Project Management > Merge and Replace.

The Advanced Merge Storyboard dialog box opens.

Import Project...

Remove Project

Cancel

3. Click Import Project and locate the .sboard file you want to bring in.

4. Inthe top pane, select the project you want to merge/replace.
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5. Use the Move Up and Move Down buttons to organize the projects.
6. Inthe Select Scenes to Merge section, select the individual scenes to merge/replace.

7. Select the Keep and move original scenes to the end option to retain a copy of the original scenes,
which are placed at the end of the master project. The name of the copy is prefixed sequentially by "1_orig'
followed by the original scene name.

8. Select the Respect locked audio tracks option to ensure that the locked audio tracks will not be synced
during the merge and replace. When deselected, audio tracks will be synched regardless if they were
locked or not.

9. Select the Import audio changes from source project to allow the modifications done in the audio to be
applied to the scenes that are replaced.
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Chapter 19: Exporting

Now that you have finished your storyboard or animatic, it is time to export it as images, PDF, or a movie file.
Depending on whether or not you plan to edit your movie in a third party software or export snapshots, Storyboard
Pro supports several export formats.
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About File Naming Patterns

T-SBADV-011-007

It is possible to define sequential file name patterns when exporting to a image sequence, bitmap, EDL and AAF
(movie files).

Forexample:%$4s.%2p.%3f.%4F.tga
%4s =>shot name on 4 chars (all export formats)
%2p => panel name on 2 chars (all export formats)

%$3f =>frame on 3 chars (Image Sequence and Bitmap)
%$4F => global frame on 4 chars (Image Sequence Only)

Where:

% means it will be replaced by:

s (shot name)

p (panel number)

£ (local frame number in panel)

F (global frame number in timeline)

The number in-between represents the minimum length to display it. If the text value is shorter than this length, it
will be left-padded by 0 (zero).
For example:
If the frame number is 48, and the user specifies the following in file name:
%$1£ =you will see "48"in file name.
%$2f =you will see "48"in file name.
%$3£ =you will see "048" in file name.

%4 £ =you will see "0048" in file name.
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About Layer Export Settings

T-SBADV-011-001

When exporting your storyboard, you can set the export behaviour for each layer. This can be handy if you have
reference layers that you do not necessarily want to see in your final export. You can set individual layer export
settings in the Layers panel.

How to change individual layer export behaviour

1. From the Thumbnails view, select the panel with the layers to export.
2. Inthe Layers view, select a layer.

3. Depending on your needs, select the options for the formats to be included with the layer. For example, if you
do not want a certain layer to appear when you export a movie, deselect the Movie option for that layer.
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About Exporting to PDF

T-SBADV-011-002

You can export your storyboard project as a PDF file which you can print or share electronically. This is where
you can set up your visuals to represent a classic storyboard on paper, or any other format you desire.

You can create your own custom PDF profiles. The information is stored in an XML file, pdfoptions.xml, that can
be found here:

o Windows:

« C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom Storyboard
Pro \full-1400-pref\pdfoptions.xml

o Mac OS X: On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down
the Alt key when displaying Finder's Go menu.

» /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom Storyboard Pro
Premium/full-1400-pref/pdfoptions.xml

« Linux:

« /home/[user_name]/Toon Boom Animation/Toon Boom Storyboard Pro /full-1400-pre-
f/pdfoptions.xml
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Setting Up the PDF Export

T-SBFND-010-002

You can set up the PDF export settings for a selected panel. This panel will be exported with all the others, but will
follow its own rules.

@ Storyboard Pro

Project Export

Setting Up the PDF Export

: Toon Boom
- Qriginal

How to specify independent PDF options for selected panels

1. Display the Panel PDF Options view by doing one of the following:

« Inthe Workspace toolbar, click the PDF View [z button to switch to the PDF View work-
space.
« Select Windows > Panel PDF Options to display the view in your current workspace.

2. Inthe Thumbnails view, select one or more panels.

3. Inthe Panel PDF Options, set the export options to apply to the selected panels:
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Restore All From Profile

Parameter Description
Options
Export to PDF Exports the selected panel. This option is enabled by default. Deselect

this option if you do not want to export this particular panel.

Force New Page

Starts panel on a new page.

Full Page

Prints panel on a full page.

Image

Maximum Height for Full
Page

Lets you set the maximum image height for a full page panel. Applies to
landscape orientation only. 0 = No Limit.

Expand

Displays camera motion (such as pan, tilt, or zoom) in the image across
several panels.

Zoom Level (%)

Size, in percentage, that the panel will appear within its frame.

Caption & Sketch

Export All Captions

This option is enabled by default. All captions from this panel will be
exported to PDF. If you want to select specific captions to export,
deselect this option and use the Caption List option

to make your selections.

Caption List This option is unavailable when the Export All Captions option is enabled.
When available, click the Browse button to open the List Picker for
selecting specific captions to export.

Spread Captions Adapts the box to the text and spreads it across the next panel if

necessary.

When this option is deselected, caption text is cut if it is too long or big for
the space available in the box.

Caption Font Scale
(%)

Select the scale, in percentage, the text will appear in the captions of this
panel.
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Shrink Text to Fit Shrinks captions if they do not fit in the panel.
Export Sketch Exports the sketch caption field of this panel.
Preview Creates a quick PDF of the page containing the selected panel(s), using

the current default PDF export profile for the other panels.

Restore All from Profile Returns the options to the current default PDF export profile.

4. Click Preview to create a quick pdf preview of the page containing the selected panel(s), using the current
default pdf export profile for the other panels.

5. Click Restore All from Profile to reset the options to the current default pdf export profile.
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Exporting to PDF

T-SBFND-010-001

Using the PDF Export view, you can set up your PDF export and run an analysis on the result before printing it to
a PDF file. This can be useful in preventing overset text resulting from the selected profile and PDF layout
options.

@ Storyboard Pro

Project Export
Exporting to PDF

: -_ Toon Boomn

Original

How to export a PDF

1. Select File > Export > PDF.

The Export to PDF window opens.
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2. Inthe Destination Path field, specify the location and name of the file.

3. Inthe PDF Export Parameters section, select a layout for the PDF file.

« 3 Panels Horizontal: This is a classic layout of a printed storyboard. It consists of three pan-
els per page, including captions, in an horizontal arrangement.

« 3 Panels Vertical: This is a classic layout of a printed storyboard. It consists of three panels
per page, including captions, in a vertical arrangement.

« Full Page: This layout consists of one large panel per page, including captions.

« Overview 2x4 Panels: This layout consists of a total of eight panels per page, organized on
two rows of four, with captions in the middle.

« Overview 4x3: This layout consists of a total of 12 panels per page, organized in three rows of
four. No caption is included.

« Typical Japanese Format: This layout consists of a total of five panels by page, aligned on
the left side of the page. Captions and duration are aligned in two consecutive rows on the right
side. Note that your PDF reader and system may require an additional font package in order to
display the PDF file properly.

« Alternate Vertical Layout: This layout consists of a total of 5 panels per page, aligned on the
left side of the page. Captions are organized on the right size of each panel. This export also
includes a cut and a duration column, and displays the duration of each scene at the beginning
of every new one.

« Overview 8x10: This layout consists of a total of 80 panels per page, organized in ten rows of
four. No caption is included.

« Alternate Japanese Layout: This layout consists of a total of 5 panels per page, aligned on
the left side of the page. This export includes vertical columns for the dialog, action, sluggin,
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notes, and time (duration) column which is displayed near the end of each scene (optionally).
The scene name appears near the top of the first panel of a scene. The caption titles appear
at the top and do not repeat at each panel. The total duration appears at the bottom of the
page.

4. Toenable the security, see Adding Security to a PDF on page 519.

5. Inthe Export Range section, select whether to generate a file including the entire storyboard, specific
shots, or the currently selected panel(s).

« All: Exports the entire storyboard.

» Selected Scenes: Select this option and click Select to open the Scenes Picker dialog box
in which you can select specific scenes to export. You can also select your scenes per
sequences if your project contains sequences.

« Current Scene: Exports only the currently selected scene.
« Current Panel: Exports only the currently selected panel.

» Tracked Panels: Exports panels are marked as tracked. The number of tracked panels will
appear beside the option—see About Track Changes on page 490.

6. Toview the file when it is ready, select the Open document after export option.

How to analyse and export with the PDF Export view

1. Done of the following:

« Inthe Workspace toolbar, click the PDF View =2 button.
o Select Windows > PDF Export.

2. Inthe PDF Export view or window, do the following:
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PDF Export (%

Fiters ~ Select all

« Inthe Profile section, use the drop-down menu to select a profile for your export. Click Edit to
modify the current options of the layout if needed—see Creating Custom PDF Profiles on page
520.

3. Click the Expand button to display the Export Range section:

« By default, the export range is set to All, which means your entire storyboard project will be
exported.

« Selected Scenes: Select this option and click Select to open the Scenes Picker dialog box in
which you can select specific scenes to export.

« Current Scene: Exports only the currently selected scene to PDF.
« Current Panel: Exports only the selected panels to PDF.

« Tracked Panels: Exports panels that are marked as tracked. The number of tracked panels
will appear beside the option—see About Track Changes on page 490.

4. Inthe Analysis section:

« Click Filters and select the issue types you want the analysis to display. Options include: Text
Overflow, Text Overlap, and Camera Pan issues.

« Click Analyse to start the analysis of your PDF options.

If no issue is encountered, the list will remain empty and the word Done ! will appear beside the
Analyse button.

517



Chapter 19: Exporting About Exporting to PDF

If issues are encountered, they will appear in the list area. The scene, panel, and page
numbers will be indicated, as well as a description of the problem found.

You can select an issue and click Ignore to remove it from the list as you verify the critical
level these elements have on your PDF export.

In the Filters menu, you can show ignored issues by selecting the Show Ignored option.
Instead of being removed from the list, a red X will appear beside the issue.

You can reset an ignored issue by clicking Restore Ignored to remove the red X.
5. Click Preview to generate a PDF preview of the selected issue.

6. Click Export to export your PDF file.
The Export to PDF dialog box opens.

«» Inthe Destination Path field, specify the location and name of the file that will contain the
PDF. Either type in the path directly or click the Browse button to display a window to select
afile. Refer to the Exporting to PDF on page 514 section to learn how to set up password pro-
tected security rules.

« Select the Open document after export option to automatically open your PDF file when it
is ready.
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Adding Security to a PDF
T-SBADV-011-003

By giving your PDF file a password and restricting certain features, such as printing and editing, you can provide
document security to your digital storyboard. When files have restricted features, any tools and menu items related
to those features are not available.

How to protect a PDF
1. Select File > Export > PDF.
The Export to PDF window opens.
2. Set your PDF export options.

3. Inthe Document Security section, set up the protection:

« Select the Need Password Protection option to add password protection to your PDF file.

« Inthe Master Password field, type an administrator password. The owners of this password
will not be bound by the protection.

« Enterthe Master Password in the top Confirm field. Note that the password must be at least
6 characters long.

« Inthe User Password field, type a user password. The owners of this password will be bound
to the protection options you have defined. Enter the user password in the bottom Confirm
field. Note that the password must be at least 6 characters long.

« Define the permissions you want to give users:
« Printable: Gives the user permission to print the storyboard.

« Edit All: Gives users the following PDF permissions: Changing the Document, Document
Assembly, Filling of Form Fields, Signing and Creation of Template Pages.

« Copy: Gives users the following PDF permissions: Content Copying and Content Copying for
Accessibility.

« Edit: Gives users the following PDF permissions: Commenting, Filing of Form Fields and Sign-
ing.
« Select the Remember Protection Settings option to keep these settings as default.
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Creating Custom PDF Profiles

T-SBADV-011-004

When exporting your storyboard project to a PDF file, various page layouts are available depending on your
document standards. You can also define some preferences and create a personalized layout.

You can create your own custom PDF profiles. The information is stored in an XML file, pdfoptions.xml, that can
be found here:

o Windows:

« C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom Storyboard
Pro \full-1400-pref\pdfoptions.xml

o Mac OS X: On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down
the Alt key when displaying Finder's Go menu.

» /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom Storyboard Pro
Premium/full-1400-pref/pdfoptions.xml

« Linux:

« /home/[user_name]/Toon Boom Animation/Toon Boom Storyboard Pro /full-1400-pre-
f/pdfoptions.xml

How to create a custom PDF Profile

1. Select File > Export > PDF.
The Export to PDF dialog box opens.

2. Inthe PDF Export Parameters section, click one of the following buttons:

« New Profile: Creates a completely new layout.
« Duplicate Profile: Makes a copy of the selected layout from the list.
« Edit Profile: Lets you edit the selected layout from the list.

« Delete Profile: Deletes the selected layout from the list.

3. Inthe PDF Profile dialog box, adjust the parameters—see PDF Profile Dialog Box in the Reference Guide.
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Adding Snapshot Markers

T-SBFND-010-003

By default, only the first frame of each panel is visible in the PDF file you export. Sometimes, you may need to
display a specific frame or several frames from a panel. For example, on a panel that has a layer or camera
movement. If you want to specify which frames in a panel will be visible in a PDF file, you must add snapshot
markers to the panels.

The adding of snapshots is especially useful when you make changes to the camera position in 3D space. If the
camera is not taking a shot that is representative of your scene at the beginning of the panel, you can select the
keyframe of the panel that has the camera in the right position before you take the snapshot. For more information on
viewing what the camera is capturing, see About Camera Moves on page 413.

@ Storyboard Pro

Project Export
Add Snapshot Markers

- -_ Toon Boom

Qriginal

How to add a snapshot marker to a panel

1. Inthe Timeline view, select the panel to which you want to add a snapshot marker.

2. Position the play head to the exact position where you want to add the snapshot.

3. Do one of the following:

« Select Storyboard > Add Snapshot.
« Right-click the panel and select Add Snapshot.

The Snapshot marker, a blue arrow, appears in the Timeline view.
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Deleting Snapshot Markers

You can remove snapshot markers from the currently selected panel.

How to delete a snapshot marker

1. Inthe Timeline view, position your cursor over the snapshot marker to delete.

A hand cursor appears over the snapshot marker.

The snapshot marker is removed.
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About Exporting a Movie

Once you have created your storyboard and animatic, you can export it as a movie file to share and play back
easily for an efficient timing reference. You can export your movie file in different formats (QuickTime, SWF
movie (Flash), jpeg, targa) and as image sequences.

When QuickTime is your chosen export format, some of the QuickTime movie settings will be overridden by the
Storyboard Pro project or export settings.

The default codec when exporting to Quick Time is H.264 which is natively supported by Mac OS X.
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Exporting a QuickTime Movie
T-SBFND-010-004

Once you have created your storyboard and animatic, you can export it as a movie file to share and play back easily
for an efficient timing reference. You can export your movie file in different formats (QuickTime, SWF movie (Flash),
jpeg, targa) and as image sequences.

How to export a QuickTime movie

1. Select File > Export > Movie.

The Export to Movie dialog box opens.

Export Range

2. Inthe Destination Path, select a folder in which to save your movie. You can type in the exact path or use the
Browse ¢ button to browse to a specific folder on your system.

3. From the Export Movie Format panel:

« From the Movie Format menu, select QuickTime Movie (*.mov).

« From the Resolution menu, select the resolution: A quarter size, half size, or full size of the cur-
rent storyboard resolution—see About Project Properties on page 47.

« From the One Clip menu, select the Per Scene option if you want to create a single movie file
for each scene. Once this option is activated, the Include Transitions option becomes avail-
able. Select this option if you want transitions to be included in your movie files. If you prefer to
have one single clip for the entire project, select the Per Project option in the drop-down menu.
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4.

5.

When you add sequences to your projects, you can also select Per Sequence to create
one clip per sequence.

Click Movie Options to modify some of the QuickTime movie settings.

NOTE: Refer to the QuickTime documentation to learn more about these movie settings.

In the Export Range tab:

Export Range

Decide whether you want to export the entire project (All), a selected frame range, a selected scene, a
selected panel, or tracked panels. If you decide on the latter, be sure to enter the frame range in the fields
provided. In the Scene Picker dialog box, you can select scenes by sequence if your project contains
sequences—see About Track Changes on page 490.

In the Burn-in tab:

» Print Time Code: Prints the project timecode on the video as an overlay on your video.

» Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an overlay
on your video.

» Print Additional Duration: Prints an additional duration on your video, defined by the Units and
Repeat menu.

» Units: Displays additional duration information using Time Code or Frames units.
» Repeat: Displays additional duration information per panel, scene or sequence.

In the Camera Grids tab, do the following:
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Camera Grids

» Project Safety: Prints the safe area on your video.
» 4.3 Safety: Prints the 4:3 safe area on each panel of your storyboard that has a camera movement.
» 4:3 Reference: Prints the 4:3 area on each panel of your storyboard that has a camera movement.

8. Select the Open document/folder after export option to view the file when it is ready.
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Exporting a SWF Movie

Once you have completed your storyboard and animatic, you can export as a SWF (Flash) movie file which you
can share and play back to test its timing.

How to export a SWF Movie

1. Select File > Export > Movie.

The Export to Movie window opens.

2. Inthe Destination Path section, click the Browse  button and choose a folder in which to save your
movie.

3. From the Export Movie Format panel:

» From the Movie Format menu, select Flash (*.swf).

» Select the Resolution from the drop-down menu. This will be a quarter size, half size, or full size of the
current storyboard resolution.

4. Click Options.

The Flash Export Settings dialog box opens.
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» To protect your movie from being imported in another application, select the Protect from Import option.

» Toget alighter format, select the Compress Movie option. The movie may lose some quality, but in turn
create a lighter file.

» Select the quality of the video image with the JPEG Quiality slider.

Click OK.

In the Export Range tab:

Decide whether you want to export the entire project (All), a selected frame range, a selected scene, a
selected panel, or tracked panels. If you decide on the latter, be sure to enter the frame range in the fields
provided. In the Scene Picker dialog box, you can select scenes by sequence if your project contains
sequences—see About Track Changes on page 490.

In the Burn-in tab:

Burn-In

» Print Time Code: Prints the project timecode on the video as an overlay on your video.

» Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an overlay on
your video.

» Print Additional Duration: Prints an additional duration on your video, defined by the Units and Repeat
menu.

» Units: Displays additional duration information using Time Code or Frames units.
» Repeat: Displays additional duration information per panel, scene or sequence.

In the Camera Grids tab, do the following:
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» Project Safety: Prints the safe area on your video.
» 4:3 Safety: Prints the 4:3 safe area on each panel of your storyboard that has a camera movement.
» 4:3 Reference: Prints the 4:3 area on each panel of your storyboard that has a camera movement.

9. Select the Open document/folder after export option to view the file when it is ready.
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Exporting an Image Sequence

How to export an image sequence

1. Select File > Export > Movie.

The Export To Movie dialog box opens.

Export Range

2. Inthe Destination Path section, click the Browse ¢ button and choose a folder in which to save your image
sequence.

3. Inthe Export Movie Format section:

Export Movie Format

Movie Format: Targa [".tga) Iz‘
QuickTime Movie [*.mav)
Flash [*.zwf]

Resolution:
Targa [*.tga)

» From the Movie Format menu, select Jpeg (*.jpg) or Targa (*.tga).

» From the Resolution menu, select a resolution.

4. Inthe Export Range tab:
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Decide whether you want to export the entire project (All), a selected frame range, a selected scene, a
selected panel, or tracked panels. If you decide on the latter, be sure to enter the frame range in the fields
provided. In the Scene Picker dialog box, you can select scenes by sequence if your project contains
sequences—see About Track Changes on page 490.

5. Inthe Burn-in tab:

» Print Time Code: Prints the project timecode on the video as an overlay on your video.

» Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an overlay
on your video.

» Print Additional Duration: Prints an additional duration on your video, defined by the Units and
Repeat menu.

» Units: Displays additional duration information using Time Code or Frames units.

» Repeat: Displays additional duration information per panel, scene or sequence.
6. Inthe Camera Grids tab, do the following:

Camera Grids

» Project Safety: Prints the safe area on your video.
» 4:3 Safety: Prints the 4:3 safe area on each panel of your storyboard that has a camera movement.

» 4:3 Reference: Prints the 4:3 area on each panel of your storyboard that has a camera movement.
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7. Select the Open document/folder after export option to view the file when it is ready.
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Exporting an EDL, AAF or XML File

Once a storyboard is complete, you can send it to a Non-linear Editing (NLE) system to complete the animatic in
a real editing suite with a direct return on TV or use it as a pre-editing map to replace the storyboard scenes with
the final materials (shot in live action or rendered from a 2D or 3D software).

It is possible to export your storyboard project and preserve the timing, motions, and sounds edited with
Storyboard Pro, directly to Apple Final Cut Pro using the EDL or XML formats or to Adobe Premiere, Avid Xpress,
or Sony Vegas using the AAF format.

How to export a storyboard to EDL or AAF or XML

1. Select File > Export > EDL/AAF/XML.
The Export to EDL/AAF/XML window opens.

ExportRange | Burn-In

2. Inthe Destination Path, select a folder in which to save your storyboard project. You can type in the exact
path or use the Browse ¢ button to browse to a specific folder on your system. You should create a
folder for your exported project since Storyboard Pro will generate several files during the export.

3. Inthe File Pattern field, you can set your own pattern which will be used to name the files created from the
export. Leave this field blank to use the default pattern. The following variables can be used to define the
file name pattern:

» %t =Project title
»  %a= Act name (when acts are enabled)

»  %q = Sequence name (when project contains sequences)
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» %s = Scene name
» %p = Panel name
» %l = Layer name (when exporting one image per layer)

You can add a number between the % sign and the letter of the variable to define a minimum number of
characters to use.

4. In Export Type, select the format in which to store the timing information (timecode for panels and audio
tracks). The format will be chosen depending on the destination application:

+ Apple Final Cut Pro (FCP) EDL: In EDL, if you are using audio elements more than once in
the timeline, FCP will not be able to reconnect the media. AAF is supported in FCP with a plug-
in from Automatic Duck. Final Cut Pro also supports XML.

* Adobe Premiere Pro AAF (Windows)

+ EDL (Mac OS X): With EDL, media must be linked manually one by one. Premiere Pro on
Windows cannot open AAF files coming from Windows (and AAF is not supported on the Mac
OS X version of Premiere Pro).

» Avid Xpress AAF

NOTE: If your editing system is not in the list, check its specifications to verify which format can be imported.

5. Inthe Options section:

» Video Config.: The storyboard scenes are exported in QuickTime format. Click Video Config. to
configure the video settings (codecs, quality)—see About Exporting a Movie on page 524 to learn more
about the option available via the Video Config. button.Use the resolution menu to define the output
resolution since you might not always need to export the storyboard at full resolution (you can select Full,
Half or Quarter of a project’s resolution).

» One Movie Clip Per Panel: Exports more than one QuickTime movie clip per scene (which might
contain more than one panel) e.g. to obtain better granularity during editing since the storyboard will have
smaller movie clips.

» Generate Video Files: If you only need the EDL, AAF or XML files to be generated, deselect this option
so no video files are rendered.

» Copy Audio Files: By default, during the export to EDL/AAF, the original sound elements used are copied
to the same location as the QuickTime movie clip’s and the EDL or AAF file. If sound elements in the
timeline are used more than once, the elements are not duplicated. The EDL/AAF refers to the same
sound elements. You can deselect this option if needed.

1. Inthe Export Range tab:

ExportRange | Burn-In ¢
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3.

4.

Decide whether you want to export the entire project (All), a selected frame range, a selected scene, a
selected panel, or tracked panels. If you decide on the latter, be sure to enter the frame range in the fields
provided. In the Scene Picker dialog box, you can select scenes by sequence if your project contains
sequences—see About Track Changes on page 490.

In the Burn-in tab:

» Print Time Code: Prints the project timecode on the video as an overlay on your video.

» Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an overlay
on your video.

» Print Additional Duration: Prints an additional duration on your video, defined by the Units and
Repeat menu.

» Units: Displays additional duration information using Time Code or Frames units.
» Repeat: Displays additional duration information per panel, scene or sequence.

In the Camera Grids tab, do the following:

Camera Grids

» Project Safety: Prints the safe area on your video.
» 4:3 Safety: Prints the 4:3 safe area on each panel of your storyboard that has a camera movement.

» 4:3 Reference: Prints the 4:3 area on each panel of your storyboard that has a camera movement.

Select the Open document/folder after export option to view the file whenit is ready.

NOTE: Refer to the third party software’s user guide to learn how to import and use the EDL/AAF/XML file.
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About Conformation

In Storyboard Pro, you can export your storyboard project to Final Cut Pro, an Apple third party editing software, edit
it, and then import the changes back into your Storyboard Pro project using the conformation feature. The
conformation export will produce an XML file containing the entire animatic project structure, as well as images of
your panels. You can then import it into Final Cut Pro and it will recreate the animatic.

You can also track the changes in your panels and export tracked panels only.

537



Chapter 19: Exporting About Conformation

Exporting for Conformation

When you are ready to export, decide if you will export the entire project, only the tracked panels or specific
panels. If you are exporting to Flix, you can automate the process by using scripts.

How to export an entire storyboard project

1. Select File > Conformation > Export Project.

The Export Project window opens.

2. Inthe Destination Path section, enter the name for the exported files and specify a folder.

3. Inthe Options section:

» Exportone image per layer: Keeps layers on separate images instead of flattening each panel’s
layers into one flat image file.

» Always Nest Layers: Nests the scene's layers inside one single clip. When this option is deselected,
layers will not be nested into clips and will export as individual video tracks. This is true as long as a
panel has either layer motion or a camera move, as it is not possible to export both without nesting. If a
panel contains both motion on layers and a camera move, the panel will be nested into the V1 track.
option to nest your scene's layers inside one single clip. When this option is deselected, layers will not
be nested into clips and will export as individual video tracks. This is true as long as a panel has either
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layer motion or a camera move, as it is not possible to export both without nesting. If a panel contains
both motion on layers and a camera move, the panel will be nested into the V1 track.

» Export Camera Frame: Includes the camera frame’s black border.

» Maintain image size throughout scene: Prevents image files from being different sizes depending on
the camera frames and movements on each panel. To avoid the image from being pixelated when the
camera is zoomed in, the image must be rendered larger. The area where the camera is the most zoomed
in must be the same size as the project resolution. This means that the rest of the image has to be
exported in proportion to the smallest area. Consider the following example:

Project Resolution:
720 x540 pixels

Smaller Camera Frame
Resolution:
720 x 540 pixels

Biggest Camera Frame
- Resolution:
1354 x 1016 pixels

» Bitmap Format: Lets you select a bitmap image format: Targa (*.tga)Photoshop (*.psd)Portable Network
Graphics (*.png)Jpeg (*.jpg)

+ Export markers at scene beginning: Places a chapter marker at the beginning of each
scene. These markers are used to find the in point of each scene when conforming from Final
Cut Pro to Harmony. The marker are named "Scene: NAME_OF_SCENE" and have a unique
scene ID and chapter marker as their comment.

+ Export Scenes Reference Track: Generates .png images with the scene named burned in.
When exporting to Final Cut Pro, this option must be enabled. The track will be used by
Harmony when conforming the XML from Final Cut Pro to find the scene in the XML.
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4. Select the additional information you want to overlay on the exported images. This information will be
added to each image and will be specific to the panel. Here are the choices:

» Burn-In: Adds information specific about the panels and their position in the Timeline.
» Print Time Code: Prints the project timecode on the images as an overlay

on your video.

» Print Scene Names and Panel Numbers: Prints the scene names and
panel numbers as an overlay on your images.

+ Print Additional Duration: Prints an additional duration on your video,
defined by the Units and Repeat drop-down menu.

* Units: Choose either you want the additional duration information to be
displayed using Time Code or Frames units.

* Repeat: Choose either you want the additional duration information to be
the duration per Panel, per Scene or per Sequence.

» Camera Grids: Adds boundaries to the images that indicate what the Camera includes
or excludes.

* Project Safety: Prints the safe area on your video.

+ 4:3 Safety: Prints the 4:3 safe area on each panel of your storyboard that
has a camera movement.

+ 4:3 References: Prints the 4:3 area on each panel of your storyboard that
has a camera movement.

5. Select the Notify Flix option to so it will automatically update its asset database. Note that Flix must be
installed on your computer.

6. Select the Open folder after export option to open the folder where the files are stored when the export is
complete.

How to export selected panels

1. Inthe Thumbnails view, select the panels you want to export to a third party software.

2. Select File > Conformation > Export Selected Panels.

The Export Selected Projects dialog box opens.
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3. Set your export options in the Export Project dialog box.

How to export tracked panels

1. Once you have tracked panels in your storyboard project, select File > Conformation > Export Tracked
Panels.

The Export Tracked Panels dialog box opens.
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2. Set your export options in the Export Tracked Panels dialog box.
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Exporting to Flix
There are three scripts for exporting to Flix with the touch of a button in the Scripting toolbar:
+ TB_ExportAllPanelsToFlix: Exports all panels in your storyboard project to Flix.
+ TB_ExportSelectedPanelsToFlix: Exports selected panels in your storyboard project to Flix.
+ TB_ExportTrackedPanelsToFlix: Exports tracked panels in your storyboard project to Flix.
You can also use the TB_SetFilePathForExport ToXML script to reset the path of the export.

To add scripts to the Scripting toolbar, see Linking Scripts to Toolbar Buttons on page 565.

For more information on scripting, see Scripting on page 559.
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Importing Animatics

Once you have imported your project’s conformation XML into Final Cut Pro and completed editing, you will need
to export it once again as an XML file to bring it back into your Storyboard Pro project.

NOTE: Refer to your third party software’s documentation to learn how to export the animatic projectin an XML file
format.

IMPORTANT: You can only reimport a modified conformation XML file into the original project from which it was
first exported.

How to import an animatic

1. Inyour original storyboard project, select File > Conformation > Import Animatic Project.

The Import Project window opens.

2. Click the Browse ¢ button and locate your XML file.

3. Inthe Options section, the Process Audio and Process Captions options are enabled by default, which
means that the audio tracks and captions will be conformed as well. Deselect these options if you do not
want to conform the audio or captions.

4. Click OK to return to the Import Project dialog box.

The Report section displays information relative to the conformation process. If an error happened during
the conformation process, this is also where the details relative to this error would appear.
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Feport

Femoving Al Tranzitions
Femoving Deleted Panel:
Felrdering Panel:
Festoring Al tranzitions
Updating Sound Tracks
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Exporting the Current Image

You can export the current visible frame to a .tga, .jpeg or PSD image. Note that a PSD file will keep each layer
separated and named as in the panel.

NOTE: No caption or camera frame will be exported in the image file.

How to export the current frame to .tga, .jpeg or .psd image

1. Inthe Thumbnails view, select the panel containing the image to export as a bitmap image file.

2. Select File > Export > Export Current Image.

The Export Current Image window opens.
3. Select the destination folder for the image.
4. Type a name for the image.
5. Select the desired type from the Save as type menu.

6. Click Save to begin the export.

The image inside the frame is exported as a bitmap image file.
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Exporting to Bitmap

T-SBADV-011-008

The Export Bitmap window lets you export a storyboard project to bitmap files in .psd, .tga or .jpg format. The
exported data includes a separate bitmap file for each panel in the storyboard.

NOTE: For .psd files, the transform and transition animations are not exported. However, camera moves are
rendered into an independent layer.
How to export a storyboard to a bitmap file

1. Select File > Export > Bitmap.

The Export to Bitmap dialog box opens.

2. Inthe Destination Path panel:

« Specify the name and location of the folder that will contain the storyboard’s assets.

« Inthe File Pattern field, enter a prefix for the file names. If you leave this field blank, by default,
the resulting bitmap files will be named: storyboardname-shot-
namepanelnumber.psd/tga/jpg.

Three Little Pigs-BrickHouse-1.psd/jpg/tga
Three Little Pigs-BrickHouse-2.psd/jpg/tga
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Three Little Pigs-BrickHouse-3.psd/jpg/tga

3. Inthe Setup Bitmap Export Parameters panel:

« Inthe Bitmap Format menu, set the bitmap files to be in .psd, .jpg or .tga format.

» Resolution: Sets the resolution to be a quarter size, half size, or full size of the current story-
board resolution.

- Image Zoom Level: Sets the magnification of the image. Enter a value between 0 and 400.
The default value is 85%.

« Transparent Background: This option is only available when the Adobe Photoshop (.psd)
file format is selected. By default this option is enabled and will export your .psd file.

« Export Camera Frame: Exports the camera frame black border in the image file.

« Rectify Static Camera: When this option is enabled, if there is a rotation in the camera, the
camera frame will appear as straight and the image will be rotated instead. When disabled,
the camera frame appears as rotated and the image is straight.

« Include Camera Path: Ensures that the camera paths and control points appear inside the
image. When this option is disabled, they might appear cropped if they exceed the camera
frames area.

» Allow Camera Scaling: This option is enabled by default. This ensures that when a very
wide zoom camera movement is included in a panel, the image resulting from the export will
be bigger in relation to the camera scaling used. If you disable this option, the exported
image will not follow the camera scaling and export it to fit a normal camera frame.

« Maintain Size Through Scene: Ensures that all images exported are the same size. If this
option is disabled, it is possible that some images export to a bigger size, for example if
there is a traveling camera movement.

« Export Camera Keyframes: Prints each camera keyframe on your images.

4. Inthe Export Range panel, decide if you want to export the entire storyboard, specific shots, or the last
panel you selected. You can enter a space between shot names or click Select to open the Scene Picker
dialog box. You can select scenes by sequence (if your project contains sequences). See About Track
Changes on page 490.

5. Toview the location and contents of the exported folder when it is ready, select the
Open folder after export option.
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Exporting Layouts

T-SBADV-011-009
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Exporting to Toon Boom

Using Storyboard Pro, you can export your animatic as Harmony scene files. You can export the entire
storyboard project or a selection of scenes. When the export is ready, you can open it in the destination software.
When you first save this new scene, the exported file will be converted in the proper format depending on the
software you used.The following elements of your storyboard will be exported: layers, layer motion and camera
moves.

NOTE: Transitions and holds in the layer motions are not supported by the Exportto Toon Boom option.

To learn more about the Layers view, see Layers on page 149.

How to export to Toon Boom

1. Select File > Export > Export to Toon Boom.

The Export to Toon Boom dialog box opens.

Export Range

2. Inthe Destination Path, select a folder in which to save your storyboard project. You can type in the exact
path or use the Browse ¢ button to browse to a specific folder on your system. You should create a

folder for your exported project since Storyboard Pro will generate several files during the export.

550



Toon Boom Storyboard Pro 5.1 User Guide

3. Inthe Scene Name Pattemn field, you can set your own pattern which will be used to name the Harmony
scenes created from the export. Leave this field blank to use the default pattern. The following variables can
be used to define the scene name pattern:

» %t = Project title

»  %a = Act name (when acts are enabled)

» %q = Sequence name (when project contains sequences)
» %s = Scene name

You can add a number between the % sign and the letter of the variable to define a minimum number of
characters to use. For example, if the scene is named 16 and the Scene Name Pattern value is MyProject_
sc%4s, the resulting export will be named: MyProject_sc0016.

4. Inthe Export Type section, select the Toon Boom animation software in which you want to export.

NOTE: To determine if your export will be created for Harmony Server or Harmony Stand Alone, in the Format menu,
select the Offline option for a stand alone export or To Database for a server format. Depending on the Harmony
version you have, select either 7.8 or 9.2 or higher.

5. Select one of the following options:

» Rendered Animatic: Exports a storyboard to be rendered in bitmap images and exports to
Animate/Animate Pro/Harmony scene. For each scene in your storyboard, an Animate/Animate
Pro/Harmony scene will be created. Use this option if you have 3D content and want to export to
Animate, Animate Pro, or Harmony 9.2 and earlier. And also to export to Harmony if you have bitmap
drawing layers.

* AllFrames: Renders the full storyboard project.

+ One Frame Each: Renders only one frame for every chosen number of frames you
specify. For example, if you choose to render every 5 frames, then a new image will appear
every fifth frame, with each image being held for 5 frames to maintain the timing.

+ Resolution: Lets you select the render size of the project: Full size, half size or quarter
size.

+ Generate One Scene: Generates a scene by scene or by selected sequences and
panels.
» Per Scene: Generates the scene by shots.
» Per Selection: Generates the scene by selected panels.

» Per Sequence: Generates the scene by sequences. Note that this option
only appears when sequences are added in the project.

» Per Act: Generates the scene by act. Note that this option only appears
when the Enable Act option is selected.

« Animatic on Top: If you generate scenes based on sequences or acts, this option
becomes available. When enabled, the animatic is rendered and placed as the top layer and
column in Harmony or Animate.
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» Select Original Scene to export your storyboard in a project where the vector drawings, layers and
camera settings are kept as is. For each shot or scene in your storyboard, a Harmony/Animate scene
is created.

* Nest Panels in Symbols: Upon export to Harmony or Animate, the panel's content will
be nested inside symbols. Instead of having several layers in your root timeline, you will
have a single one. You will need to enter the symbol to edit its content.

+ Add a Camera Reference Layer: Adds a layer containing the different camera frames
on top of the other layers to use as a reference in Harmony and Animate.

+ Apply Transformation on Drawings: Applies transformation on the first and last
position of each panel. The in-between animation will be lost.

6. If you selected Rendered Animatic as the Export Style, you can now select the additional information you
want to overlay on the exported images. This information is add to each image and is specific to the panel.
You have the following choices:

» Export Range: Decide if you want to export the entire project (All), Selected Scenes, Current Scene,
or the Current Act.
» Sounds: Using the drop-down menu, choose how the soundtrack will be exported:

+ Keep Original Files: Keeps and uses all original sound files.
* Process Soundtrack Individually: Creates one audio file per soundtrack.
+ Merge All Soundtracks: Creates a single audio file, gathering sounds from every
soundtrack of your storyboard.
» Burn-In:

+ Print Time Code: Prints the global timecode on each rendered image.

* Print Scene Names and Panel Numbers: Prints the scene names and panel numbers
for the current frame.

» Print Additional Duration: Prints an additional duration on your video, defined by the
Units and Repeat menu.

» Camera Grids: Adds boundaries to the images that indicate what the camera includes or excludes.
+ Project Safety: Prints the safe area on your video.

+ 4:3 Safety: Prints the 4:3 safe area on each panel of your storyboard that has a camera
movement.

+ 4:3 References: Prints the 4:3 area on each panel of your storyboard that has a camera
movement.

7. Select the Open document/folder after export option to view the file when it is ready.

552



Toon Boom Storyboard Pro 5.1 User Guide

Exporting Soundtracks

In Storyboard Pro, you can export your project’s soundtrack to an audio .wav file. You can export the different
soundtracks as one audio file or export all soundtracks separately.

How to export a soundtrack

1. Select File > Export > Soundtrack.

The Export Soundtracks window opens.

2. From the Destination Path section, click the Browse  button. Select and name the folder in which to save
the exported soundtrack.

3. Inthe File Pattern field, you can set your own pattern name. The default File Pattern is %t-A%n.wav.

» %t = Project title
»  %n = Soundtrack number

For example, if you export separate soundtracks for a project named Rocket Rodeo, the resulting audio files
will be named: Rocket Rodeo-Al.wav, Rocket Rodeo-A2.wav, Rocket Rodeo-A3.wavandsoon.

4. Inthe Options section, select the way you want the software to process your soundtracks:

» Process Soundtracks Individually: Exports the different sound layers to be exported as individual
soundtracks.

» Merge All Soundtracks: Merges all the sound layers onto one single soundtrack.
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Don't Break Sound: Exports the sound layers as one complete soundtrack. Depending on whether
you selected to export the sound layers individually or merged, one single soundtrack will be exported
or one soundtrack per layer will be exported.

Break Sound Per Scene: Divides the soundtracks in sound files per scene. Depending on whether
you selected to export the sound layers individually or merged, one single soundtrack will be exported
per scene or one soundtrack per layer will be exported per scene.

Break Sound Per Sequence: Divides the soundtracks in sound files per sequence. Depending on
whether you selected to export your sound layers individually or merged, one single soundtrack will be
exported per sequence or one soundtrack per layer will be exported per sequence.

Break Sound Per Act: Divides the soundtracks into sound files per act. Depending on whether you
selected to export your sound layers individually or merged, one single soundtrack will be exported per
act or one soundtrack per layer will be exported per act.

5. Inthe Sound Settings section:

>

Sample Rate: Lets you select the Khz sample rate value. A higher value results in a better quality
sound but heavier file.

Bit Depth: Sets the audio file bit depth to 8 or 16 bit. A higher bit value will result in a better quality
sound but heavier file.

Channels: Lets you select the exported audio files channels to be either Mono or Stereo.

6. Inthe Export Range section:

>

>

All: Exports the entire storyboard’s soundtrack.

Selected Scenes: Opens the Scenes Picker dialog box so you can select specific scenes in which to
export the soundtrack. In the Scene Picker dialog box, you can select your scenes by sequences if
your project contains sequences.

Current Scene: Exports only the currently selected scene’s soundtrack.

7. Select the Open folder after export option to have the system automatically open the folder containing
your exported audio files.
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Exporting CSV Files
T-SBADV-011-006
You can export the data in a storyboard project in comma separated value (*.csv) file format.

You can view this data in any application that supports comma separated value files, such as Microsoft Excel. If you
do not have Microsoft Excel installed, you can save the .csv file to your computer, and then open the file in another
application.

How to export a storyboard to a CSV file

1. Select File > Export > CSV.
The Export to CSV dialog box opens.

2. Inthe Destination Path field, specify the location and name of the folder for the storyboard project data.

3. Inthe CSV Export Options section, do the following:

« Encoding: Select the type of encoder to use for export.

« Field Separator: Select the fields separator to use. Options include: Comma, Semicolon, Tab
or Vertical bar (Pipe).

« Select the types of data to export.
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NOTE: Refer to About Track Changes on page 490 to learn about Tracking Information.

4. Inthe Export Range panel, decide if you want to export the entire storyboard, specific shots, or the last
panel you selected. You can enter a space between shot names or click Select to open the Scene Picker

dialog box. You can select scenes by sequence (if your project contains sequences).

5. Toview the CSV file directly in Microsoft Excel or other application that recognizes the CSV format, select
the Open document/folder after export option.
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Exporting FBX Files

Exporting a storyboard project in FBX format allows you to store any motion data (from element motion or Camera
angles/zooms), as well as the 2D and 3D elements in your scene. Once exported to FBX, you can open the
storyboard elements in a third-party 3D application and continue to work on them. You would only export these
elements to FBX once you are finished with them in Storyboard Pro. Normally, you would not bring these elements
back into Storyboard Pro.

How to export an FBX file

1. Select File > Export > FBX.
The Export to FBX dialog box opens.

Cancel

2. Inthe Destination Path section, click the Browse  button and choose a folder in which to save yourimage
sequence.

3. Inthe File Pattern field, type a name for the exported files.
4. Toinclude the camera frame’s black border in the scene, select the Export Camera Frame option.

5. From the One Clip list, select one of the following:

» Per Scene: Exports one clip per scene.
» Per Project: Exports one clip for the entire project.

» Per Sequence: Exports one clip per sequence. This option is available only if your project contains
sequences.

6. Inthe Export Range section, select how many scenes to include in the exported files:

» All: Includes all the scenes in your project.

» Current Scene: Includes only the scene you selected when you opened this dialog box.

7. Click OK.

Your objects are saved as an FBX file in the folder you specified.
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Chapter 20: Scripting

Qt Script provides access to many of the functions supported in the Storyboard Pro interface. With Qt Script, you
can automate a number of Storyboard Pro functions to speed the completion of various repetitive tasks.

Qt Script is an object-oriented scripting language based on the ECMAScript standard, like JavaScript and JScript.
However, there are some differences that distinguish it from these scripting languages which are familiar to web
programmers.

559



Chapter 20: Scripting Importing Scripts

Importing Scripts

If there are scripts that are ready for you to use, you must first transfer the * . j s files from the computer where
the scripts were created to the one you intend to use. Then you can use the Script Editor to import the * . js files
into Storyboard Pro.

When working with Storyboard Pro, scripts that you created while working on a scene orimported are available
for all other projects created on the same computer; there's no need for any kind of transfer orimport. You can find
your custom, default, and imported scripts here:

*  Windows: C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom Storyboard
Pro\1200-scripts

* Mac OS X: /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom Storyboard
Pro/1200-scripts

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, hold down the Alt key.

How to import scripts

1. Copy the *. js files you want to transfer onto a USB key, or use the transfer method of your choice.

2. Transfer and save the * . js files onto the computer you intend to use. Be sure to save them in a logical loc-
ation. You can save them directly in the default locations indicated above, in which case they will auto-
matically appear in the Script Editor. If you prefer not to mix them with the default scripts, save them to a
different location.

3. In Storyboard Pro, start a new scene or open an existing one.

4. Addthe Script Editor view to your workspace.

From the Script Editor menu, select File > Import Script.

Script Editor == |3

MNew Script

Delete Script

6. Selectthe *. js file and click Open.

The script is imported and appears in the Files list of the Script Editor.
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Creating Scripts
Using the Script Editor, you can create Qi scripts for Storyboard Pro.
Your custom scripts and default scripts are stored here:

*  Windows: C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom Storyboard
Pro\1200-scripts

+ Mac OS X: /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom Storyboard
Pro/1200-scripts

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, hold down the Alt key.

For details about the scripting nodes, click the link below.

» Storyboard Pro Script Interface Documentation

You can also find the help files in the Script Editor view. From the Script Editor menu, select Help > Scripting
Interface Documentation.

How to create a script

1. Select Windows > Script Editor.
The Script Editor view opens. A list of all the available JavaScript files is displayed.

Script Editor menu

Script Editor == |3

-

Script
content

Search
toolbar

Script list Syntax Save

verification madification

2. From the Script Editor menu, select File > New Script
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The New Script dialog box appears.

Enter name of n

3. Enteraname and click OK.

The name of your script appears in the File column of the Script Editor view.

4. Click in the right side of the Script Editor and start writing your script. Try typing in the following script:
function projectQuery ()
{
var storyboard = new StoryboardManager () ;

print ("This project has " + storyboard.numberOfScenesInProject() + "
scenes in the project");

}

NOTE:
For a tutorial on coding in JavaScript, refer to docs.oracle.com/javase/tutorial/java

For a detailed Storyboard Pro script interface documentation, refer to Storyboard Pro Script Interface
Documentation

There are also help files in the Script Editor view. In the Script Editor menu, select Help > Scripting Interface
Documentation.

5. To check your syntax, click Verify.

A window opens with syntax information.

® Syntax is not valid: 4 : Unclosed string at end of line

COK

6. Totest yourscript, select the script to run from the File column.

7. From the Script Editor menu, select Play/Debug > Run.
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A window opens to ask you for the target function to run. In the window, select the function you want to
execute.

NOTE:
To avoid selecting the function every time you want to run your script, you can set a target function. In the Script Editor
menu, select Play/Debug > Set Target. In the Function column, select a function and click OK.

Cancel

» To stop the execution of your script, select Play/Debug > Stop from the Script Editor menu.

» You may receive the following message: Only functions that have been saved or are explicitly called will
be executed.

This usually occurs if you did not select the function you wanted to run from the File column before
running the script. When this happens, click Save and run your script again.

» You may also see the following message (in red) on the right side of the Script Editor:

This is because the Storyboard Pro jumped to the <<Sandbox>> item in the Function column. The
<<Sandbox>> is provided to test scripts without saving them. Simply click on your newly created script
and run it again.
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Using an External Script Editor

If you are more comfortable editing your scripts using another editor, Storyboard Pro allows you to set an external
script editor and use that one instead.

NOTE:
If you do not set an external editor, on Windows and Mac OS X, when selecting the External Editor option, it will
launch the registered editor for JavaScript program (e.g. Visual Studio, XCode or Brackets).

Multiple files can be opened in the same editor instead of starting a different copy of the editor each time a *.js
scriptis selected.
How to set an external editor

1. From the Script Editor menu, select Editor > Set External Editor.

The Set External Editor window opens.

2. Inthe external editor, type or paste the complete path to the application, including its name and extension.

For example, if you want to set Adobe Dreamweaver as your external editor, a Windows path would look
like this:
C:\Program Files (x86)\Adobe\Adobe Dreamweaver CS5\Dreamweaver.exe

On Mac OS X, simply specify the application name. If the application supports the Applescript Open
Document protocol, it will open.

3. Click OK.

How to edit a script in an external editor

1. Inthe File list, select the script to edit.
2. From the Script Editor menu, select Editor > External Editor.
3. Inthe external editor that opens, edit the script and save the file.

4. In Storyboard Pro, refresh the Script Editor view by selecting another script and then selecting your edited
script again to see the modifications.
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Linking Scripts to Toolbar Buttons

You can add buttons to the Scripting toolbar so you can access them easily.

How to link a script to a toolbar button

1. Inthe Scripting toolbar, click the Manage Scripts button.

The Scripts Manager dialog box opens and displays the available scripts.

Functions In Toolbar

Cancel

You can select a script from this dialog box and run it immediately by clicking Execute.

2. Inthe Files list, select the JavaScript file containing the function you want to add to the toolbar.

3. Inthe Functions list, select the function to add to the toolbar.

4. Click the Right Arrow button to add the function to the In Toolbar list.

5. Toload a custom icon, click Customize Icon and browser fora * . png, *. jpg or * . xpm file.

6. To customize the tooltip appearing in the Scripting toolbar, click Customize Tooltip and type in the new tool-

tip in the Function Tooltip window.

(Game Animation to 5
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7. Click OK.

How to execute a script

1. Once the script is added to the Scripting toolbar, you can press on the corresponding script button to
execute the action.

2. Youcan press the Esc key to interrupt the execution of a script.
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